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1 Introduction

Gsharp® is an application for data presentation, which allows the users to design graphs interactively and display their
data in 2D and 3D graphs. Gsharp is a modular application with powerful interactive graphing and easy layout.

e This cookbook aims to explain to the users how Gsharp works and how the presentations through this application,
are structured.

e There are examples of how a graph is drawn in Chapter 2. The examples used will show the user how to produce a
data presentation with Gsharp.

e Chapters 3, 4, 5, and 6 contain four example datasets; and describe step-by-step how to visualize them respectively.

This cookbook is written for users:

e Who are new to using Gsharp.
e Who want to visualize data using Gsharp.

It is not intended to be a tutorial on Gsharp.

1.1 Conventions Used

e Underlined text denotes the title of a dialogue window.

o Italic text is used to signify the name of a file or a command or a button, which can be selected.

e The figures in Chapter 2 are preceded by the Roman numerals 11, figures in Chapter 3 are preceded by Ill and so
on.

e All files used or created are stored in the current working directory.

8 http://www.avs.com/
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2 Drawing a Graph

2.1 Creating a 2D Graph

2.1.1 Specifying a Viewport

e  Select Viewport... from the Create drop-down menu (Figure 11.1).

$ Gsharp 3.2 for Windows -0l x|

File | Create Edit Delete ‘Yiew Options Tools Examples Help

B [HEETTA DY

araph...
Logo...
Make. ..

Page...

O EE e ¢ |

age 1
-
) 1
|Reau:|~;.-' v

Figure 11-1: Creating a Viewport for 2D Graphs
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e Use the left mouse button to draw a rectangle on the Canvas® area (Figure 11-2).

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1.viewport 1

-
Dirag out a rectanagle with rouse buttan 1 ;I
o
[ 2
|Read~;.-' i

Figure 11-2: Defining a Viewport for 2D Graphs

Refer to Appendix A, Figure A-1, for descriptions of what the canvas is.
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2.1.2 Selecting a Graph Type

e Select Graph... from the Create drop-down menu (Figure 11-3).

_iBix]
File | Create Edit Delete Wiew Opkions Tools Examples Help
APTOwW, ., o —_ o
By de A E R T A RS E
“oah. |
~ Llogo.., T R -
Mate, .. '
Page... E
Title. .. E
Wigwport,. ., I
H "
. B 8
ABC R
L Sl ¢ D
age 1.viewport 1
Drag out a rectangle with mouse button 1 ;I
I 2
|Reau:|':.f v

Figure 11-3: Selecting Graph Type
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e The Graph Editor appears (Figure 11-4).

Graph Editor

Figure 11-4: Graph Editor
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Graph Editor

Region
b air | M ame

I B arrier
I [rata I Chart

I bl arkers I Labelz I Labels+

Contralz

— Main
¥ Graph Type

[ Fricrity

[ Legend Entry

6? I Line

Bar

Line Bar
Scatter
Area
Staircase

Stair Area

Pie

Faolar Line
Polar Scatter
Palar Area

30 Line

30 Scatter

30 Bar

30 Irregular Bar
20 Contaur

~

Under Main of the Graph Editor, select Line from the Graph Type drop-down menu (Figure 11-5).

X
|

o ]

Cancel

Help

Figure 11-5:

Selecting Graph Type for 2D Graphs
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2.1.3 Setting the Data Values

e Select Data to set a value for Y Data. The ! % in the example is next to the Y so a value is to be set. (Figure 11-6).

Graph Editor

[ |

|

I~ v Base
I=| Colar
] S

™ = Date
™ Time:

Figure 11-6: Graph Editor for 2D Graphs

° The ! next to some data resources signifies that a value is to be set.
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o Nexttothe & inthe box, there is the word “Unset” (Figure 11-6). In the example, the value® log(-10:10) is entered.
The X values are set automatically’ (Figure 11-7).

x
Region | B arrier | Controls
Main | Mame  Data | Chat | Makes | Labels | Labek+
~Data
% ILlnset J
W v & [logl10:10] ]
I~ v Base [Unset ]
= Color [Urset J
I~ Size [Unset [
~Date-Time
I~/ % Date [Unset ]
I Time [Urset ]
[ ok | Cancel Help

Figure 11-7: Setting a Y Value for 2D Graphs

e Select OK and a line is drawn according to the entered values (Figure 11-8).

6 (-10:10) is shorthand for -10, -9, -8, ..., 10
! In the example, X takes a value when Y values are true. Since log(-10) to log(0) are undefined, no values are set for X. So for log(1), X
will take the value of 12 because the previous values are undefined.

Manchester Visualization Centre Page 8 of 165 22 October 2002



Visualization Cookbook Using Gsharp

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

2.0 4

2.5+

2.0

1.5

1.0

0.5+

oo T T T T T 1 T T T T

OO R B4 ¢ | DY

age 1

Dirag out a rectanagle with rouse buttan 1 ;I

= H

|Read~;.-' i

Figure 11-8: An Example of a 2D Line Graph
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2.1.4 Labelling the Axes

Double click with the left mouse button on the x-axis (Figure 11-9) so that Axis Editor appears (Figure 11-10).

$ Gsharp 3.2 for Windows - 10| x|
File Create Edit Delete View Options Tools

= E &

Examples Help

25

b “E|E§_A§1|§§ & N

20—
25 -
2.0
15 -
1.0
0.5 -
B0 o e e e
2 4 s 2 Mo

OB e 4 ¢ |

age 1.viewport 1.domain 2.xaxis1

Drag out a rectangle with mouse button 1

1=
I 2
|Reau:|':.f v

Figure 11-9: X-Axis
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Az ITickmarksI Ticklinesl Text I IIniit I Lal:uelsl Fl:urmatl I:l:untn:ulsl

— &ule

[or

I Lirear - I
—

|n.23?2522948ﬁ [rom =]

— Crozs Position

[~ Cross Yalue
[T DatedTime
[T Date
[T Time

—

=10l i

— Labelz Data
™| Wser ILlnset J
[T Humeric W J

[T Caordinate ILlnset J

— Tickmarks Data

[T Mo Im J
[T Wit IUnSEt J
— Component

[ Clearance IEI.?E ﬁ I‘*/;_ j

[ |

Cancel | Spply |

Figure 11-10:

Axis Editor
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Select Text and enter in the box next to Text, X-AXIS, and set the Height to 5 (Figure 11-11).

aaseditor =10l x|
Bz I Tickmarksl Ticklings Test |L|nit I Lal:uelsl Fl:urmatl I:l:untn:ulsl
— T et Shyle — Placement

[¥ Teut IWJ [~ Path Im
v Height |5 j If"é j [~ Harizantal Im
I Fort IWJ [ “ertical Im
 Color _J [T ¥ Position IW
[ Rotation |0 i = I~ Date/Time [Unset ™ =
[ Skewing |0 aes =] r XDf‘E et |
[T Baoldness 0 4% L i ILlnset J
 Expansion [ = [T % Position IHHE.'.EIEIEI

I Spacing m [T | B Pasition W

I~ T Position |999.999 [deg ]

[ |

Cancel | Apply | Help

Figure 11-11:

Select OK and the result will be (Figure 11-12).

Writing Text for an X-Axis
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% Gsharp 3.2 for Windows

File Create Edit Delete Wiew Options Tools Examples Help

=10 x|

= &

2.0 4

2.5+

2.0

1.5

1.0

0.5+

0.0 —Smmopm s s e T T

OO R B4 ¢ | DY

age 1.viewport 1.domain 2.xaxis1

Dirag out a rectanagle with rouse buttan 1

[ 2
|Read~;.-' i
Figure 11-12: An Example of Labelling an X-Axis
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e Double click with the left mouse button on the y-axis (Figure 11-13) so that the Axis Editor appears (Figure 11-14).

% Gsharp 3.2 for Windows

File Create Edit Delete Wiew Options

Tools

Examples

Help

=10 x|

= &

o |2

J|I:|"‘i|§l:%>“§|STDF'

e
th

ST=I=[=T=t=t L=t=r=t ==t =Tl = e e = =l LI == =T=l =Tl = =l ===l =T =T=l=T=T= 1]

oo T T T T T 1 T

O o DB e < ¢ [T

age 1.viewport 1.domain 2.yvaxisl

Dirag out a rectanagle with rouse buttan 1

I 2
|Read~;.-' o
Figure 11-13: Y-Axis
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Az ITickmarksI Ticklinesl Text I IIniit I Lal:uelsl Fl:urmatl I:l:untn:ulsl

— &ule

[T Enahbled
I~ Tupe
[T Calar

[~ width

[on
—

|n.23?2522948ﬁ [rom =]

— Crozs Position

[~ Cross Yalue
[T DatedTime
[T Date
[T Time

=10l i

— Labelz Data
[ Wser ILlnset J
[T Humeric W J

[T Caordinate ILlnset J

— Tickmarks Data

[T Mo IUnSEt J
[T Wit IUnSEt J
— Component
.il =% -
[T Clearance IEI.?E — I/.; J

[ |

Cancel | Spply |

Figure 11-14:

Axis Editor
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Select Text and next to the box of Text enter Y-AXIS. Also set Height to 5 (Figure 11-15).

aaseditor =10l x|
Bz I Tickmarksl Ticklings Test |L|nit I Lal:uelsl Fl:urmatl I:l:untn:ulsl
— T et Shyle — Placement

W Test IWJ [~ Path Im
v Height |5 j If"é j [ Horizontal Im
I Font IWJ [T Wertical Im
 Color _J [T ¥ Position IW
[ Rotation |0 i = I~ Date/Time [Unset ™ =
[ Skewing |0 aes =] r XDf‘E et |
[T Baoldness 0 4% L i ILlnset J
 Eoparsion | = [ % Position IHHE.'.EIEIEI

I Spacing m [T | B Pasiticn W

I~ T Position |999.999 [deg ]

[ |

Cancel | Apply | Help

Figure 11-15:

Select OK and the result will be (Figure 11-16).

Setting Text for Y-Axis
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

ST=I=[=T=t=t L=t=r=t ==t =Tl = e e = =l LI == =T=l =Tl = =l ===l =T =T=l=T=T= 1]

oo T T T T T 1 T T T T

OO R B4 ¢ | DY

age 1.viewport 1.domain 2.yvaxisl

Dirag out a rectanagle with rouse buttan 1 ;I

= H

|Read~;.-' i

Figure 11-16: An Example of Labelling a Y-Axis
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2.1.5 Writing a Title

e Select the viewport by clicking with the left mouse button in the graph (Figure 11-17, Section 2.1.1).

$ Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete View Options Tools Examples Help

= E &

25
It
13

e
th

e
o

-
fom]

=
th

TV-AXIS

R IR ERbih R (i e e Bl el el
2 4 5 & 40 42 14 48 12 20
A-ARIS

OB e 4 ¢ |

age 1.viewport 1

Drag out a rectangle with mouse button 1 ;I

I 2
|Reau:|':.f v

Figure 11-17: Selecting Viewport to Write a Title for 2D Graphs
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e  Select Title... from the Create drop-down menu (Figure 11-18).

$ Gsharp 3.2 for Windows -0l x|

File | Create Edit Delete ‘Yiew Options Tools Examples Help

W g |=EE BT T AL BN
T araph...
Logo...
Make. ..
Page...
Viewpatk, .,
20
0
§ 158
=
1.0
D.ﬁ—é
0.0 &B---pnopnnogn e (i e e I Riehinkel Al tele
z 4 ] g 10 12 14 16 18 20
F-ARS
18 D8 e ls ¢ |
age 1.viewport 1

Dirag out a rectangle with mouge button 1 ;l

il 4

|Reau:|~;.-' v

Figure 11-18: Creating a Title for 2D Graphs
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e The Title Editor appears and next to Text a name is written for the title. For this example log(-10:10) is written.
Next set Height to 10 (Figure 11-19).

Title Editor x|

b ain ISt_I,IIe I F'n:nsitin:nnl Eu:nntrn:nlsl

— Title

¥ Tex & [leat-10:10) =
™ Fort SMP -]

¥ Height |1u j |z |

[ Calar -

k. I Cancel Help

Figure 11-19:  Writing a Title for 2D Graphs

e Select OK and the title is written above the graph? (Figure 11-20)

8 If necessary, drag the title with the left mouse button to position it.
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% Gsharp 3.2 for Windows O] =|
File Create Edit Delete Wiew Options Tools Examples Help
25 — Bl — o .
%’]%‘]%?EBWE|E """ Ail|§g>@gsmP
2.0 ----I--1=0-1-0 ---------------- =
of ) |
2.0 —E E
I i
Sisa H
> 5
1.0 —E E
0.5 i
0.0 & T T T T T T T —a
2 4 & g 10 12z 14 16 18 Z0
F-ARIS
ABC  ~
B30 B e 4 & | DY
age 1.viewport 1
Dirag out a rectanagle with rouse buttan 1 ;I
[ 2
|Read~;.-' i
Figure 11-20: An Example of a Title for 2D Graphs
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2.2 Creating a 3D Graph

2.2.1 Specifying a Viewport

e  Select Viewport... from the Create drop-down menu (Figure 11-21).

% Gsharp 3.2 for Windows O] x|

File | Create Edit Delete View Options Tools Examples Help

B HEETCA B

Graph...

Laga...
Moke. ..

O 8 E B S e 2 ¢ | TY

age 1
[—
7 ﬁ
|Ready o

Figure 11-21: Creating a Viewport for 3D Graphs
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e Use the left mouse button to draw a rectangle on the Canvas® area (Figure 11-22).

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1.viewport 1

-
Dirag out a rectanagle with rouse buttan 1 ;I
o
[ 2
|Read~;.-' i

Figure 11-22: Defining a Viewport for 3D Graphs

Refer to Appendix A, Figure A-1, for descriptions of what the canvas is.
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2.2.2 Selecting a Graph Type

e  Select Graph... from the Create drop-down menu (Figure 11-23) so that the Graph Editor appears (Figure 11-24).

_iBix]
File | Create Edit Delete Wiew Opkions Tools Examples Help
APTOwW, ., o —_ o
By de A E R T A RS E
“oah. |
~ Llogo.., T R -
Mate, .. '
Page... E
Title. .. E
Wigwport,. ., I
H "
. B 8
ABC R
L Sl ¢ D
age 1.viewport 1
Drag out a rectangle with mouse button 1 ;I
I 2
|Reau:|':.f v

Figure 11-23: Selecting Graph Type

Manchester Visualization Centre Page 24 of 165 22 October 2002



Visualization Cookbook Using Gsharp

Graph Editor

Figure I1-24: Graph Editor
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e Under Main of the Graph Editor, select 3D Line from the Graph Type drop-down menu. (Figure 11-25).

Graph Editor

Region
b air | M ame

I [rata I Chart I bl arkers I Labelz I Labels+

I B arrier

Contralz

— Main
¥ Graph Type

[ Fricrity

[ Legend Entry

&

Line

Bar

Line Bar
Scatter
Area
Staircase

Line j

Stair Area
Pie

Faolar Line
Polar Scatter
Palar Area

A0 Line

30 Scatter

30 Bar

30 Irregular Bar

20 Contaur &7

X
|

o ]

Cancel

Help

Figure 11-25:

Selecting 3D Line Graph
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2.2.3 Setting Data Values

e Select Data to set a value for X, Y and Z values. The 6?10 in the example is next to the X, Y and Z values so values
are to be entered (Figure 11-26).

Graph Editor x|

t ain I Mame Data |Ehart I Markersl En:nntrn:nlsl

- Data
i & [Dnset ]
s & [Unset ]
rz & [Unset ]
- Date-Time
I %Date [Uinset [
I~ % Time [Uinset J
I~ v Date [Unset J
I~ Time [Uinset J

k. I Cancel Help

Figure 11-26: Graph Editor for 3D Graphs

e Nextto the 6? in the boxes, there is the word “Unset” (Figure 11-26). Here a value is entered for the 3D line graph.
In this example the values™ (1:10) for X, 1/(1:10) for Y, and (-10:10) for Z are entered (Figure 11-27).

10 The '5? next to some data resources signifies that a value is to be set for those resources.

u (2:10) is shorthand for 1,2,3, ...,10; 1/(1:10) is shorthand to 1/1,1/2,1/3, ...,1/10; and (-10,10) is shorthand to -10,-9,-8, ...,10.
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Graph Editor

|
A T —
A C—

Figure II-27:  Setting Values for 3D Graphs

e Select OK and a 3D line graph is drawn according to the entered values (Figure 11-28).
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% Gsharp 3.2 for Windows

File Create Edit Delete Wiew Options Tools Examples Help

=10 x|

= &

OO R B4 ¢ | DY

age 1.viewport 1.domain 1.graph 1

Dirag out a rectanagle with rouse buttan 1

ki

|Ready

Figure 11-28: An Example of a 3D Line Graph

Manchester Visualization Centre

Page 29 of 165

22 October 2002



Visualization Cookbook Using Gsharp

3 Displaying Temperature Inside a Room

This chapter describes how the temperature flows inside a room.

The values given are x, y, z and t from a data file called block.dat™. t is the value for the temperature at locations given
by coordinates X, y and z. The task is to visualize the distribution of temperature in the room. For example, if in the
centre of the room the colour of the temperature is blue then this part of the room is cold. The data is irregular (the
location of each point is given explicitly) and the coordinates are located on a regular grid (the points are arranged in
planes perpendicular to the coordinate axes).

3.1 Choosing the Best Graph

Notice that there is no functionality within GSharp menus/data manager to automatically create a 3D block or a variable
such as unique x. This means there is no tag or a button that sets automatically variables or creating a 3D block.

12 Courtesy of John Stringer, AVS UK. Refer to Appendix B, Figures B-1 and B-2 for descriptions of the file.
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e  Select Open... from the File drop-down menu. Import block.dat file into Gsharp (Figure 111-1).

% Gsharp 3.2 for Windows O] =|

File ©Create Edit Delete Wiew Options Tools Examples Help
e B
v Z | BT A By &0

Ckpuk Irmage. ..

Prink Sekup...
Prink

Reset Canvas
Reset Al

Exit. ..

OO R B4 ¢ | DY

age 1
=
I 2
|Read~;.-' i

Figure I1-1: Opening a File

e The result will be (Figure 111-2).
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1
-
Irmpart Bepart: 1000 values read inko w, p, 2, ¢ ;I
o
[ 2
|Read~;.-' i

Figure 111-2: Result of Opening block.dat
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3.1.1 2D Contour for z=1

The task is to visualize all values of Z (10 values) within the block.dat file. To do that a 3D block is to be created using
2D contours of each slice (Z values) of the block.

Type BlockX = unique(x); in command line™® (Figure 111-3)™.

% Gsharp 3.2 for Windows
File Create Edit Delete Wiew Options Tools

= E &

=10l x|

Examples Help

OO DB e 2 ¢ |

age 1
BlockX=unique[x];

Import Report: 1000 values read inko w0, v, 2, t

- -

H 4
|Ready

Figure 111-3: Writing Commands in Command Line

e  Press enter so that the command is processed.

B Refer to Appendix A, Figure A-1, for descriptions of what the command line is.

u This command is entered in order to get the unique values (not the repeated) of x.

Manchester Visualization Centre Page 33 of 165 22 October 2002



Visualization Cookbook Using Gsharp

e Type BlockY=unique(y); in command line (Figure 111-3) and press enter™.

e Type BlockZ=unique(z); in command line (Figure 111-3) and press enter™®.

e Type Block=reshape(t,size(BlockX),size(BlockY),size(Blockz)); in command line (Figure 111-3) and press enter"’.
e Type Classes=range(t, 10) and press enter (Figure 111-3)*,

e Select Viewport... from the Create drop-down menu (Section 2.1.1).

e Select Graph... from the Create drop-down menu (Section 2.1.2).

e Select 2D Contour for Graph Type (Section 2.1.2)*.

1 This command is entered in order to get the unique values (not the repeated) of y.

This command is entered in order to get the unique values (not the repeated) of z.

7 This command is entered in order to get a new block of 10 (BlockX) by 10 (BlockY) by 10 (BlockZ) with range t.

18 This command is entered in order to get 10 different classes of colour for the t value.

Refer to Appendix B, Figure B-3 to see how the dataset is managed and if the dataset is set correctly in the Data Editor.

16

19
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e InData, set X to be BlockX, Y to be BlockY and Color Grid to be Block[,,1] (Figure 111-4)%.

Graph Editor

C—
CE—
= 2 Grid (.
o R

Figure 111-4: Setting Values for 2D Contour

e Select OK and the result will be (Figure I11-5).

x That means the plane is set to z=1.
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1.viewport 1.domain 2.graph ?

Irmpart Bepart: 1000 values read inko w, p, 2, ¢ ;I
Drag out a rectangle with mouse button 1

= H

|Read~;.-' i

Figure 111-5: Result of 2D Contour for z=1
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e  Select Domain... from the Edit drop-down menu (Figure 111-6).

4 Gsharp 3.2 for Windows

File Create | Edit Delete View Options Tools Examples Help

=10l x|

H
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Jﬂ"‘i|£&|5%P

AFraw, ..

.................. s, .,

Graph. ..
Legend...
Loga,..
Make. ..
Page...
Title. ..
Viewpork, ..

Limes...
Text. ..
shades. ..

O 8B B ESe 4 ¢ |TY

age 1.viewport 1.domain_Z2.graph 2

[rmpart Bepart: 1000 values read into w v, 2.t
Drag out a rectangle with mouse button 1
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ﬂ

|Reau:|~;.-'

A

Figure 111-6: Editing the Domain
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e In the Domain Editor select Classes and set Num Values to 10 (Figure 111-7)%,

=

b ain I # Limits I ' Lirnitz | Switches | Frojections I Style
Reference Clazzes Contrals

— Shading Scale

[ Shading Scale | I N -

[ Coorforumper [ | -]

— Clazzes
w 1 o
V¥ Mum Yalue 10 =
ClazzEditar ... |
[~ Classes Dataset IUHSEE J

] I Cancel Apply Help

Figure 11I-7: Changing the Classes Value

o Select ClassEditor..., (Figure 111-7) and the Class Editor appears (Figure I11-8).

2 This gives 10 different colours to the graph.
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e Set Mode to Min/Max?, the Type to Limits?*, Minimum to 3% and Maximum to 11.1% (Figure 111-8).

Class Editor

—Clazzes — Clazzes

10.29 - | = Mode [MintMax =]
9,57 -10.29
885957 [+ Type |Limits vI
B c13-885
| EEESRERE

B Ge3-7a ¥ Mirimum |3

— Lirmitz

I 5497-5669
v Maxi 1.1
I 5255497 L il
453-5.25 ™ Step 0.72
I 381-453
. 3.8 — Percentiles

™| ki |1EI
j ™| b awimnum IE":I
Legend i Default i~ EE Update | [T Step IE_EEEEEEEEEEEE

] I Cancel |

Figure 111-8: Class Editor

e  Select OK and return to Domain Editor (Figure 111-9).

2 To set minimum and maximum values to the colours.

= There are two options here, percentiles and limits. Limits are to be set because the temperature is between 3 and 11.1 values. Other values
are not needed.

2 3 is the minimum value of t in the file.

% 11.1 is the maximum value of t in the file.
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e Inthe Domain Editor set Classes Dataset to Classes (Figure 111-9).

Domain Editor

Figure 111-9: Changing Classes Dataset

e Select OK and the result will be (Figure 111-10).
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% Gsharp 3.2 for Windows O] =|
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Figure 11I-10:  Result After Changing Colour Classes
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Select Legend... from the Edit drop-down menu (Figure I11-11).
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Figure 1lI-11:  Editing the Legend
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e Inthe Legend Editor select Text and set Entry Height to be 7 (Figure 111-12)%.

i

b airn ITitIe Text |Sty|e Il:l:untrl:ulsl

— Tent
[+ Entre Height I? j IZ j

[~ Fort I SIMP

e -
[T Boldness I':' _Ij %

— Uzer-defined Text
[ Undefined Text ILlndef J
[T Class Text Data ILlnset J
[T Below Test IEE|DW J
[T Abowve Test I-'“-"-bDVE J

k. I Cancel Apply | Help

Figure 1lI-12:  Editing Entry Height

e  Select Controls (Figure 111-13).

% The legend is more readable when setting Entry Height to 7 than other values.
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e Set Enabled to On (Figure I11-13).

Legend Editor

Figure IlI-13:  Enable the Legend

e Select OK and the result will be (Figure 111-14).
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

%’]%‘]gs*ﬁ”ﬁ-| """ Ail|§g>“@gsw

1.1
10.2
9.3
8.4
7.4
BB
57
4.5
39
3.0

O o DB e < ¢ [T

age 1

Dirag out a rectanagle with rouse buttan 1 ;I
Drag out a rectangle with mouse button 1

= H

|Read~;.-' i

Figure 1lI-14:  Result With a Legend

This result (Figure 111-14) is the plane of z=1. The Legend®’ shows the value of the corresponding colour in the graph in
each x, y dimension.

2" The Legend will require positioning to provide a result similar to Figure 111-14.
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3.1.2 2D Contour for z=2

e  Select Graph... from the Edit drop-down menu (Figure 111-15).

4 Gsharp 3.2 for Windows - 10| x|

File Create | Edit Delete  Wiew Options Tools Examples  Help
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93 Texk...
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4.8

3.0
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-
Drag out a rectangle with mouse button 1 ;I
Dirag out a rectangle with mouse button 1
-
I  /
|Ready

Figure 1I-15:  Editing Graph

e In Data of Graph Editor set Color Grid to be Block[,,2] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-16).

Manchester Visualization Centre Page 46 of 165 22 October 2002



Visualization Cookbook Using Gsharp

% Gsharp 3.2 for Windows O] =|
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Figure I1I-16:  Result of 2D Contour for z=2

This result (Figure 111-16) is the plane of z=2.
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3.1.3 2D Contour for z=3

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure I11-15).

e In Data of Graph Editor set Color Grid to be Block[,,3] (Section 3.1.1, Figure 111-4).
e Select OK and the result will be (Figure I11-17).
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Figure 111-17:  Result of 2D Contour for z=3

This graph (Figure 111-17) is the plane of z=3.
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3.1.4 2D Contour for z=4

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).
e In Data of Graph Editor set Color Grid to be Block[,,4] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-18).
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Figure 111-18:  Result of 2D Contour for z=4

This graph (Figure 111-18) is the plane of z=4.
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3.1.5 2D Contour for z=5

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).
o In Data of Graph Editor set Color Grid to be Block[,,5] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-19).
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Figure 111-19:  Result of 2D Contour for z=5

This graph (Figure 111-19) is the plane of z=5.
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3.1.6 2D Contour for z=6

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).
o In Data of Graph Editor set Color Grid to be Block[,,6] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-20).
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Figure 111-20:  Result of 2D Contour for z=6

This graph (Figure 111-20) is the plane of z=6.
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3.1.7 2D Contour for z=7

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).
e In Data of Graph Editor set Color Grid to be Block[,,7] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure I11-21).
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Figure 111-21:  Result of 2D Contour for z=7

This graph (Figure 111-21) is the plane of z=7.
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3.1.8 2D Contour for z=8

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).

e In Data of Graph Editor set Color Grid to be Block[,,8] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-22).
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Figure 111-22:  Result of 2D Contour for z=8

This graph (Figure 111-22) is the plane of z=8.
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3.1.9 2D Contour for z=9

e  Select Graph... from the Edit drop-down menu (Section 3.1.2, Figure 111-15).

o In Data of Graph Editor set Color Grid to be Block[,,9] (Section 3.1.1, Figure 111-4).
e  Select OK and the result will be (Figure 111-23).
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Figure 111-23:  Result of 2D Contour for z=9

This graph (Figure 111-23) is the plane of z=9.
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3.1.10 2D Contour for z=10

e  Select Graph... from the Edit drop-down menu Section (3.1.2, Figure 111-15).
o In Data of Graph Editor set Color Grid to be Block[,,10] (Section 3.1.1, Figure 111-4).
e Select OK and the result will be (Figure I11-24).
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Figure 11I-24:  Result of 2D Contour for z=10

This graph (Figure 111-24) is the plane of z=10.
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The conclusion from those 10 graphs is that they give a very good visualization as each plane shows the different
temperatures in the room. The blue colour represents the coldest temperature in the room and the yellow colour the
hottest temperature in the room.
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3.1.11 2D Contour in 3D Style
A graph will be drawn to show the previous 2D graphs in a 3D style, i.e. the 10 planes combined into a 3D graph.

Select Open... from the File drop-down menu. Import block.dat (Section 3.1, Figure 111-1).

Type BlockX=unique(x); in command line?® (Figure 111-3)*° and press enter so that the command will be processed.
Type BlockY=unique(y); in command line (Figure 111-3)* and press enter.

Type BlockZ=unique(z); in command line (Figure 111-3)* and press enter.

Type Block=reshape(t,size(BlockX),size(BlockY),size(BlockZ)); in command line (Figure 111-3) and press enter®,
Type Classes=range(t,10) and press enter (Figure 111-3)*.

Select Viewport... from the Create drop-down menu (Section 2.1.1).

No aksdwbde

» Refer to Appendix A, Figure A-1, for descriptions of what the command line is.

» This command is entered in order to get the unique values (not the repeated) of x.

This command is entered in order to get the unique values (not the repeated) of y.

8 This command is entered in order to get the unique values (not the repeated) of z.

2 The reshape command is entered in order to get a new block of 10 (BlockX) by 10 (BlockY) by 10 (BlockZ) with range t.
8 The range command arranges the colours according to the t value.

30
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8. Select Domain... from the Create drop-down menu (Figure 111-25).
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Figure 111-25:  Creating Domain

9. Select OK and the result will be (Figure 111-26).
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Figure 111-26:  Result of Creating Domain
10. Select Domain... from the Edit drop-down menu (Section 3.1.1, Figure 111-6).
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11. In the Domain Editor select X Limits and set X Minimum to 1 and X Maximum to 10 (Figure 111-27)*.
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Figure 11I-27:  Editing X Limits

12. Select Y Limits (Figure 111-28).

3 To give the correct limits to the x-axis.
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13. Set Y Minimum to 1 and Y Maximum to 10 (Figure 111-28).

Domain Editor
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Figure 111-28:  Editing Y Limits

14. Select Projections (Figure 111-29).
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15. Set 3D Plane to On®, Location to Inside and Level to 0 (Figure 111-29)%°.
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Figure 111-29:  Editing Projections
16. Select Style (Figure 111-30).
% This will draw the domain in a 3D way.
% This will set the location of the domain inside the viewport.
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17. Set X Data Type to Continuous®” (Figure 111-30).
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Figure 111-30:  Editing Style

18. Select Classes and set Num Values to 10 (Section 3.1.1, Figure I11-7).

19. Select ClassEditor... and the Class Editor appear. Here set Mode to Min/Max,® the Type to Limits,* Minimum to 3
and Maximum to 11.1 (Section 3.1.1, Figure 111-8).

20. Select OK and then set Classes Dataset to Classes (Section 3.1.1, Figure 111-9).

8 This will make sure that the values will be correctly set to the axis.

To set minimum and maximum values to the colours.
There are two options here, percentiles and limits. Limits are to be set because the temperature is between 3 and 11.1 values. Other values
are not needed.

38

39
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21. Select OK and the result will be (Figure I11-31).
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Figure I11-31:  Result of 1* Domain
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22. Select Viewport... from the Edit drop-down menu (Figure 111-32).
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Figure 111-32:  Editing Viewport
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23. In Viewport Editor select 3D Workbox. Set Angle in XY Plane to 245, Elevation Plane to 10.292 and Distance

Factor to 10 (Figure 111-33)*.
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Figure 111-33:  Editing Values in 3D Workbox

24. Select OK.

40 All these values are selected to give a better view to the graph.
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25. Select Graph... from the Create drop-down menu (Section 2.1.2).
26. Select 2D Contour for Graph Type (Section 2.1.2).

27. In Data set BlockX for X, BlockY for Y and Block(,,1] for Color Grid (Section 3.1.1, Figure I11-4)
28. Select OK and the result will be (Figure 111-34).
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Figure I11-34:  Result of 1* Block
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To produce the remaining graphs in a 3D style, repeat steps 8*! — 21 followed by steps 25 - 28 for each graph, i.e.

the second graph for the 2™ Block, the third graph for the 3" Block, ..., the tenth graph for the 10" Block. Use the
following settings while creating those graphs:

o In Projections of Domain Editor, set Level for the 2" Block to 0.1111111, for the 3" Block to 0.2222222, for
the 4™ Block to 0.3333333 and so on.

In Data of Graph Editor, set Color Grid for the 2" Block to Block[,,2], for the 3" Block to Block][,,3], for the
4" Block to Block(,,4] and so on.

e The final result will be Figure 111-35.
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Figure 111-35:

Result When Visualizing the Dataset in 3D way

4 The viewport must be selected before repeating step 8.
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e Select Legend... from the Edit drop-down menu (Figure 111-11).

¢ Inthe Legend Editor select Text and set Entry Height to be 7 (Figure 111-12).
e  Select Controls and set Enabled to On (Figure 111-13).

e  Select OK and the result will be (Figure 111-36).
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Figure 111-36:  Result of 3D Block With Legend
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Figure 111-36 shows the temperature of the room. Each plane represents the room height (z). The Figure illustrates a
method for visualizing 2D graphs in a 3D style. The Legend shows the temperature for each graph, where the blue
colour represents the coldest temperature and the light yellow the hottest temperature.
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4  Visualizing Behaviour of a Superconductor

This chapter describes the visualization of the behaviour of a superconductor. The visualization shows the critical
current, the angle and the temperature.

The task is to visualize the behaviour of the superconductor in each point of critical current (Jc), against each angle (phi,
theta).

The values given are T(Kelvin), B(Tesla), Theta, Phi, Jc(A/m2), dv/di criterion, Smoothed Jc, Actual Theta and actual
phi (the values needed for the task are Theta, Phi, and Jc(A/m2)) from 10 files* which are:

o (02-07-33,Sep-07.txt contains the following variables:

T1 represents T(Kelvin) that is the temperature values.

T2 represents B(Tesla) that is magnetic field values.

Theta that is angle values.

phi that is angle values.

T3 represents Jc(A/m2) that is the maximum current values.
T4 represents dv/di criterion.

T5 represents Smoothed Jc.

T6 represents Actual Theta.

T7 represents actual phi.

e 01-23-29,Sep-07.txt

© XN O wwDNRE

02-07-33,Sep-07.txt is imported first. The variables, in the files that follow, will not have the same name of the file in
Gsharp. The same will happen with the names of this file against the next file and so on.

T8 represents T(Kelvin).

T9 represents B(Tesla) that is magnetic field values.

T10 represents Theta that is angle values.

T11 represents phi that is angle values

T12 represents Jc(A/m2) that is the maximum current values.
T13 represents dv/di criterion.

T14 represents Smoothed Jc.

T15 represents Actual Theta.

T16 represents actual phi.

© o N gD R

2 Courtesy of John Durrell, University of Cambridge. Refer to Appendix C, Figures C-1 and C-2 for description of the file.
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e 00-39-33,Sep-07.txt
e 20-00-22,Sep-06.txt
e 20-45-45,Sep-06.txt
e 21-33-38,Sep-06.txt
e 22-19-18,Sep-06.txt
e  23-06-59,Sep-06.txt
o 23-54-13,Sep-06.txt
e phi-90.txt

Manchester Visualization Centre Page 72 of 165 22 October 2002



Visualization Cookbook Using Gsharp

4.1 Choosing the Best Graph

The data will be visualized in 2D. A scatter graph will best show the pattern of the visualization.

Each of the 10 data files will be imported individually.

e Define a viewport (Section 2.1.1).
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4.1.1 Scatter Graph for 02-07-33,Sep-07.txt

e  Select Open... from the File drop-down menu to import a file (Figure 1V-1).
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Figure IV-1: Importing Files

Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).
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e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).
e In Data set X to be Theta, Y to be T3 (Figure IV-2).

Graph Editor

Figure IV-2: Setting Data Values for Scatter
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e  Select Markers and set Symbol to and Color to Blue (Figure 1V-3).

Graph Editor

¥ | farkers

NI ELL Rdes

Figure IV-3: Setting Markers

e Select OK and the result will be (Figure 1V-4).
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% Gsharp 3.2 for Windows

File Create Edit Delete Wiew Options Tools Examples Help

=10 x|

= &
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5710
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i 1]

o
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-4l 1] an 100 150

200
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[ 2
|Read~;.-' i
Figure 1V-4: Result of 02-07-33,Sep-07.txt File
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Double click with the left mouse button on the x-axis (Section 2.1.4, Figure 11-9) so that Axis Editor appears
(Section 2.14, Figure 11-10).

Select Text and enter in the box next to Text, Theta, and set the Height to 5 (Section 2.1.4, Figure 11-11).
e Select OK and the result will be (Figure 1V-5).

% Gsharp 3.2 for Windows
File Create Edit Delete Wiew Options Tools

= E &

=10l x|

Examples Help

™10

(1]

410

o

10

& o Qo
oo T T T T T 1
-100 -50 1] 50 100 150 200
Theta

ABC

OE R SNl ¢ D
age 1.viewport 1.domain 1.xaxis1

Import Report; 133 values read into T1, T2, Theta, Phi, ... T7 ;I
[l 2%
|Ready

Figure IV-5; Labelling the X-Axis
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Double click with the left mouse button on the y-axis (Section 2.1.4, Figure 11-13) so that Axis Editor appears
(Section 2.14, Figure 11-14).

e Select Text and enter in the box next to Text, Jc (A/m2), and set the Height to 5 (Section 2.1.4, Figure 11-15).
e Select OK and the result will be (Figure 1V-6).

% Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete Wiew Options Tools Examples Help

= E &

™10

(1]

210
110+
& o oo
o1 T T T T T 1
-100 -50 1] 50 100 150 200
Theta

OO0 DB e 2 ¢ |

age 1

Tickmark step value [30.0000] iz less than the minimurm [6.00000e+008) - value is rejected ;I
Tickmark step value [50.0000] iz lesz than the minimum [6.00000e+008] - value iz rejected

&

= AV
|Ready i
Figure 1V-6: Labelling the Y-Axis
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4.1.2 Scatter Graph for 01-23-29,Sep-07.txt

e  Select Open... from the File drop-down menu to import the 01-23-29,Sep-07.txt file (Section 4.1.1, Figure 1V-1).
e Select the previous graph®.

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T10, Y to be T12 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to (%~ and Color to Green (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure IV-7).

4 Gsharp 3.2 for Windows =10 x|

File Create Edit Delete View Options Tools Examples Help

= & &

R0

50

10 -
=10
€ o B a
010 T T T T T 1
-100 -60 1] A0 100 160 200

Theta

OO DB e 2 ¢ |

age 1

Import Report: 133 values read into T2, T3, T10, T11, ..., T1E ;I
Tickmark step value [30.0000] iz lezs than the minimurm [6.00000e+008] - value iz rejected

K| v

|Ready o

Figure IV-7: Result of 01-23-29,Sep-07.txt File

3 This graph is must be selected in order to visualize the next graph. This must be done for all of the graphs.
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4.1.3 Scatter Graph for 00-39-33,Sep-07.txt

e  Select Open... from the File drop-down menu to import the 00-39-33,Sep-07.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InDataset X to be T19, Y to be T21 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to + '~ and Color to Red (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-8).

4 Gsharp 3.2 for Windows =10 x|

File Create Edit Delete View Options Tools Examples Help

25
Ca R AR=A:
13
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5710
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Theta
ABEC "
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age 1
Import Report: 133 values read into T17, T18, T19, T20, ..., T25 ;I
Tickmark step value [30.0000] iz lezs than the minimurm [7.00000e+008] - value iz rejected
[ 1/
|Ready o

Figure 1V-8: Result of 00-39-33,Sep-07.txt File
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4.1.4 Scatter Graph for 20-00-22,Sep-06.txt

e Select Open... from the File drop-down menu to import the 20-00-22,Sep-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T28, Y to be T30 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to * =l and Color to Turquoise (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-9).

$ Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete View Options Tools Examples Help
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Figure 1V-9: Result of 20-00-22,Sep-06.txt File
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4.1.5 Scatter Graph for 20-45-45,Sep-06.txt

e  Select Open... from the File drop-down menu to import the 20-45-45,Sep-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T37, Y to be T39 (Section 4.1.1, Figure 1V-2).

e Select Markers and set Symbol to Tﬂ and Color to Orange (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-10).

4 Gsharp 3.2 for Windows =10 x|

File Create Edit Delete View Options Tools Examples Help
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1.2710

1.07510 o &
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vh b
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Import Report: 133 values read into T53, TH4, THE, TEE, ..., TE1 ;I
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[ 1/
|Ready o

Figure IV-10:  Result of 20-45-45,Sep-06.txt File
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4.1.6 Scatter Graph for 21-33-38,Sep-06.txt

e Select Open... from the File drop-down menu to import the 21-33-38,Sept-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T46, Y to be T48 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol tol o = and Color to Yellow (Section 4.1.1, Figure IV-3).

e Select OK and the result will be (Figure 1V-11).

$ Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete View Options Tools Examples Help

= E &

1.7710
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Figure IV-11: Result of 21-33-38,Sep-06.txt File
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4.1.7 Scatter Graph for 22-19-18,Sep-06.txt

e  Select Open... from the File drop-down menu to import the 22-19-18,Sep-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T55, Y to be T57 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol tol = =land Color to Purple (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-12).

$ Gsharp 3.2 for Windows - 10| x|
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Figure IV-12:  Result of 22-19-18,Sep-06.txt File
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4.1.8 Scatter Graph for 23-06-59,Sep-06.txt

e  Select Open... from the File drop-down menu to import the 23-06-59,Sep-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InData set X to be T64, Y to be T66 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to | = = and Color to Brown (Section 4.1.1, Figure 1V-3).
e Select OK and the result will be (Figure 1V-13).

4 Gsharp 3.2 for Windows =10 x|

File Create Edit Delete View Options Tools Examples Help
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Figure IV-13:  Result of 23-06-59,Sep-06.txt File
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4.1.9 Scatter Graph for 23-54-13,Sep-06.txt

e  Select Open... from the File drop-down menu to import the 23-54-13,Sep-06.txt file (Section 4.1.1, Figure 1V-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InDataset Xtobe T73, Y to be T75 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to * =l and Color to Dark Green (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-14).

$ Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete View Options Tools Examples Help
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Figure IV-14:  Result of 23-54-13,Sep-06.txt File
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4.1.10 Scatter Graph for phi-90.txt

e Select Open... from the File drop-down menu to import the phi-90.txt file (Section 4.1.1, Figure 1VV-1).
e  Select the previous graph

e In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).

e InDataset X to be T82, Y to be T84 (Section 4.1.1, Figure 1V-2).

e  Select Markers and set Symbol to [%" =land Color to Dark Blue (Section 4.1.1, Figure 1V-3).

e Select OK and the result will be (Figure 1V-15).

$ Gsharp 3.2 for Windows - 10| x|
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Figure IV-15:  Result of phi-90.txt File
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e Select Legend... from the Edit drop-down menu (Figure 1V-16).

$ Gsharp 3.2 for Windows - 10| =|
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Figure IV-16: Editing a Legend
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e In Legend Editor set Entry Height to be 6 (Figure 1VV-17).

Legend Editor

|
|
I~ | Below Text
™| Bbove Tiest

Figure IV-17:  Setting Entry Height
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e Select Controls and set Enabled to On (Figure 1V-18).

Legend Editor

Figure IV-18:  Enable the Legend

e Select OK and the result will be (Figure 1V-19).
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% Gsharp 3.2 for Windows O] =|
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Figure IV-19:  Result of a Legend
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4.1.11 3D Scatter Graph

A 3D scatter graph will be drawn so that the previous 10 scatter graphs will be visualized in 3D style.

Select Open... from the File drop-down menu to import the 02-07-33,Sep-07.txt (Section 4.1.1, Figure 1V-1).
In Graph Editor select 3D Scatter for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to be Theta, Y to be T3 and Z to be Phi (Section 2.2.3 Figure 11-28).

Select Markers, set Color to Blue (Section 4.1.1 Figure 1V-3).

Select OK and the result will be (Figure 1V-20).

o s D
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% Gsharp 3.2 for Windows
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Figure IV-20:  Result of 3D Scatter for 02-07-33,Sep-07.txt File
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Repeat steps 1-5 in Section 4.1.11 using the data files and colour settings listed in Sections 4.1.1 to 4.1.10

inclusive. The values for X, Y and Z for each graph should correspond to the Theta, Jc(A/m2) and phi values in the
data files* (Section 4). The final result will be (Figure 1V-21).

$ Gsharp 3.2 for Windows - 10| x|
File Create Edit Delete View Oplions

Taols Examples Help
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Mﬁf >
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Import Report; 133 values read into T, 772, 773, T4, .. T79 ;I
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|Reau:|':.f v

Figure IV-21:  Final Graph of 3D Scatter

* For example in 01-23-29,Sep-07.txt file the values to be entered are T10 (Theta) for X, T12 (Je(A/m2)) for Y, and T11 (phi) for Z. The colour of the
graph will be green.
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5 Showing Percentiles of a Value Over 10 Days

In this chapter percentiles over a period of 10 days are visualized. The file percs.dat* contains 10 values (p3, p5, p10,

p25, p50, p75, p90, p95, p97, x). Each value of p contains percentile data for each day x (24 May 2002 to 02 June
2002).

The task is to visualize how the percentiles vary through the 10 days.

5.1 Choosing the Best Graph

First the data will be visualized in 2D. A scatter graph will best show the pattern of the visualization.

* Courtesy of John Stringer, AVS UK. Refer to Appendix D, Figures D-1 and D-2, for descriptions of the file.
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5.1.1 2D Scatter Graph

1. Import percs.dat file by selecting Open... from the File drop-down menu (Figure V-1).

$ Gsharp 3.2 for Windows - 10| x|

File Create Edit Delete View Options Tools Examples Help

B = R

Outpuk Image. ..
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Prink
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Figure V-1: Importing File

2. Define a viewport (Section 2.1.1).
3. Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).
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4. In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).
5. Select Data and set X to x and Y to p3 (Figure V-2).

Graph Editor x|

ke ain I Mame Data |Markers| Labelsl Lal:uels+| Heginnl Elarrierl Eu:untru:ulsl

~Data
ox | |
WV & |p3 J
I~ v Base [Unset [
I~ Color [Unset ]
I~ Giee [Unset ]
~ Date-Tie
I~| % Date [Unset J
= % Time [Urset [

2k, I Cancel Help

Figure V-2: Setting Data Values

6. Select OK and the result will be (Figure V-3)*.

46 To remove June, double click on the x-axis, the Axis Editor will appear. Select Labels, select Level 2 and the Level 2 Labels window will
appear, set Enabled to Off. Select OK on the Level 2 Labels window and select OK on the Axis Editor. June will now be removed from the x-axis. To
remove 2002 from the x-axis repeat the steps above but select Level 3 instead.
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Figure V-3: Result for Variable p3
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7. Repeat steps 3 to 6*' but change Y*® to p5 for the second graph, Y to p10 for the third graph until Y to p97 for ninth
graph. The result will be (Figure V-4).
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Figure V-4; Final Result of Scatter Graph

a7 The previous graph must be selected before repeating steps 3-6.

The value of Y is determined by the column headings in the percs.dat file. For example, the value of Y for the second graph corresponds to
the value of the second column heading in the percs.dat file (Appendix D, Figures D-1 and D-2).

48
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8. Select Legend... from the Edit drop-down menu (Figure V-5).
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Figure V-5: Editing Legend
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9. Inthe Legend Editor select Text and set Entry Height to 6 (Figure V-6).

Legend Editor

Figure V-6: Setting Entry Height
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10. Select Controls and set Enabled to On (Figure V-7).

Legend Editor

Figure V-7: Enable Legend

11. Select OK and the result will be (Figure V-8).

Manchester Visualization Centre Page 103 of 165 22 October 2002



Visualization Cookbook Using Gsharp
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Figure V-8: Graph With Legend

12. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears

(Section 2.1.4, Figure 11-14).

13. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure 11-15).

14. Select OK and the result will be (Figure V-9).
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Figure V-9: Labelling the Y-Axis

The graph above shows percentiles over a period of ten days. The symbols show the values of the percentiles (p3, p5,
p10, p25, p50, p75, p90, p95, p97) on each day, from 24 May 2002 to 2 June 2002.

Manchester Visualization Centre Page 105 of 165 22 October 2002



Visualization Cookbook Using Gsharp

5.1.2 2D Bar Graph

The dataset will be visualized using a bar graph so a clearer image of the percentiles over the time period can be
obtained.

Import percs.dat file by selecting Open... from the File drop-down menu (Figure V-1).
Define a viewport (Section 2.1.1).

In Graph Editor select Bar for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to x and Y to p97 (Section 5.1.1, Figure V-2).

Select OK and the graph will be (Figure V-10).

o s e
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% Gsharp 3.2 for Windows
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Figure V-10:  Result for Variable p97
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6. Repeat steps 3 to 5* but change Y*° to p95 for the second graph, Y to p90 for the third graph until Y to p3 for ninth
graph. The result will be (Figure V-11).
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Figure V-11:  Final Result of Bar Graph

49 The previous graph must be selected before repeating steps 3-5.

%0 The value of Y is determined by the column headings in the percs.dat file (Appendix D, Figures D-1 and D-2).
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7. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears
(Section 2.1.4, Figure 11-14).

8. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure 11-15).

9. Select OK and the result will be (Figure V-12).
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Figure V-12:  Labelling the Y-Axis
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10. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears
(Section 2.1.4, Figure 11-14).

11. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure 11-15).

12. Select OK and the result will be (Figure V-13).
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Figure V-13:  Labelling the X-Axis

13. Select Legend... from the Edit drop-down menu (Section 5.1.1, Figure V-5).

14. In the Legend Editor select Text and set Entry Height to 6 (Section 5.1.1, Figure V-6).
15. Select Controls and set Enabled to On (Section 5.1.1, Figure V-7).

16. Select OK and the graph will be (Figure V-14).

Manchester Visualization Centre Page 110 of 165 22 October 2002



Visualization Cookbook Using Gsharp

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

14
I
Gy
I ras | o '
[ peo0 |
s (S
CJps0 | . il
[ ras
[ ]wn 4
s il
L ]
1] T T T T T T T T T T
4 25 26 it et a0 k3 1 2

Percentiles

7
June
2002
Date
AEC =
OE LB Sl ¢ D
age 1

Impart Bepart: 10 values read into p3, ph, p10, p25, ... = ;I
Drag out a rectangle with mouse button 1

[ 2
|Read~;.-' i

Figure V-14:  Graph with Legend

This graph shows the percentiles for each day in a bar chart. Each percentile is represented by a different colour so the
percentile change can be compared between dates.
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5.1.3 2D Area Graph

The dataset will be visualized displaying the percentiles using a 2D Area graph.

Import percs.dat file by selecting Open... from the File drop-down menu (Figure V-1).
Define a viewport (Section 2.1.1).

In Graph Editor select Area for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to x and Y to p97 (Section 5.1.1, Figure V-2).
Select OK and the graph will be (Figure V-15).
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Figure V-15:  Result for variable p97
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6. Repeat steps 3 to 5°* but change Y** to p95 for the second graph, Y to p90 for the third graph until Y to p3 for ninth
graph. The result will be (Figure V-16).
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Figure V-16:  Result Area

5t The previous graph must be selected before repeating steps 3-5.
52

The value of Y is determined by the column headings in the percs.dat file (Appendix D, Figures D-1 and D-2).
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(Section 2.1.4, Figure 11-14).

9. Select OK and the result will be (Figure V-17).
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Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure 11-15).
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Figure V-17:  Labelling the Y-Axis
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10. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears
(Section 2.1.4, Figure 11-14).

11. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure 11-15).
12. Select OK and the result will be (Figure V-18).
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Figure V-18:  Labelling the X-Axis

13. Select Legend... from the Edit drop-down menu (Section 5.1.1, Figure V-5).

14. In the Legend Editor select Text and set Entry Height to 6 (Section 5.1.1, Figure V-6).
15. Select Controls and set Enabled to On (Section 5.1.1, Figure V-7).

16. Select OK and the graph will be (Figure V-19).
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Figure V-19:

Graph with Legend
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5.1.4 Box Plot
The dataset will be visualized showing the percentiles as a box plot.
Define a viewport (Section 2.1.1).

In Graph Editor select Line Bar for Graph Type (Section 2.1.2, Figure 11-5).
Select Data and set X to x, Y to p97 and Y Base to p3 (Figure V-20).
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Import percs.dat file by selecting Open... from the File drop-down menu (Figure V-1).

k. I Cancel

Help

Figure V-20:  Graph Editor

5. Select Chart from the Graph Editor (Figure V-21).
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Figure V-21:  Chart

6. Set Bar Ends to be 4 (Figure V-22).
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Figure V-22:  Bar Ends

7. Select OK and the result will be (Figure V-23).
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Figure V-23:  Maximum and Minimum Values

8. In Graph Editor select Bar for Graph Type (Section 2.1.2, Figure 11-5).
9. Select Data and set X to x, Y to p75 and Y Base to p25 (Figure V-20).
10. Select Chart and set Color to White (Figure V-24).
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Figure V-24:  Color
11. Select OK and the graph will be (Figure V-25).
22 October 2002
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% Gsharp 3.2 for Windows O] =|
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Figure V-25:  Lower and Upper Quartiles

12. In Graph Editor select Line Bar for Graph Type (Section 2.1.2, Figure 11-5).
13. Select Data and set X to x, Y to p50 and Y Base to p50 (Figure VV-20).

14. Select Chart from the Graph Editor, set Bar Ends to be 4 (Figure V-21).
15. Set Color to Black (Figure VV-24).

16. Select OK and the graph will be (Figure V-26).
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

o =
! !
| I S|

(v ]
|
I

OO R B4 ¢ | DY

age 1

Impart Bepart: 10 values read into p3, ph, p10, p25, ... = ;I
Drag out a rectangle with mouse button 1

= H

|Read~;.-' i

Figure V-26:  Mean Values

17. Double click with the left mouse button on the y-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears
(Section 2.1.4, Figure 11-14).

18. Select Text and next to the box of Text enter Percentiles. Also set Height to 5 (Section 2.1.4, Figure 11-15).

19. Select OK and the result will be (Figure V-27).
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Figure V-27:  Labelling the Y-Axis

20. Double click with the left mouse button on the x-axis (Section 2.1.4, Figure 11-13) so that the Axis Editor appears
(Section 2.1.4, Figure 11-14).

21. Select Text and next to the box of Text enter Date. Also set Height to 5 (Section 2.1.4, Figure 11-15).

22. Select OK and the result will be (Figure V-28).

Manchester Visualization Centre Page 124 of 165 22 October 2002



Visualization Cookbook Using Gsharp
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Figure V-28:  Labelling the X-Axis
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6 Viewing Percentage of Longitude and Latitude Points

In this chapter the task is to visualize the various percentages in each point of longitude and latitude over the UK.

The file scores.dat®® contains four variables, which are x, y, t1 and t2. x represents the latitude over UK, y represents the

longitude over UK and t1, t2 are the percentage values for each point.

5 Courtesy of John Stringer, AVS UK. Refer to Appendix E, Figures E-1 and E-2, for descriptions of the file.
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6.1 Choosing the Best Graph

1. Select Open... from the File drop-down menu to import a file (Figure VI-1).
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Figure VI-1: Importing File

2. Define a viewport (Section 2.1.1).
3. Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).
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6.1.1 2D Scatter Graph for t1

In this section, 2 scatter graphs will be visualized - one for each percentage values (one graph for t1 and one for t2).
This will show the pattern of the final graph.

4. In Graph Editor select Scatter for Graph Type (Section 2.1.2, Figure 11-5).
5. Select Data and set X to X, Y to y and Color to t1 (Figure VI-2).
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Figure VI-2: Setting Data Values

6. Select OK and the result will be (Figure VI1-3).
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Figure VI-3: Final Graph for Variable t1
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7. Select Legend... from the Edit drop-down menu (Figure VI-4).
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Figure VI-4: Editing the Legend
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8. Inthe Legend Editor select Text and set Entry Height to 6 (Figure VI-5).

Legend Editor

Figure VI-5: Setting Entry Height
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9. Select Controls and set Enabled to On (Figure VI-6).

Legend Editor

Figure VI-6: Enable the Legend

10. Select OK and the result will be (Figure VI-7).
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Figure VI-7: Result With Legend
11. Double click on the y-axis and the Axis Editor will appear (Figure VI-8).
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Figure VI-8: Axis Editor

12. In the Axis Editor select Text and set Text to Latitude and Height to 5 (Figure V1-9).
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Figure VI-9: Setting Text for the Y-Axis

13. Select OK and the result will be (Figure VI1-10).
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Figure VI-10:  Result of the Y-Axis

14. Repeat steps 11-13 for the x-axis. The only thing to be changed is to set Text to Longitude. Select OK and the result
will be (Figure VI-11).
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Figure VI-11:  Result of the X-Axis
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6.1.2 2D Scatter Graph for t2

This section contains the second 2D scatter graph which is going to show the visualization of the t2 percentage value.

1. Change page by selecting this icon g in the icon toolbar®.

2. Repeat steps 1-14 from Sections 6.1 and 6.1.1 but when setting data values set Colour to t2. The result will be
(Figure VI1-12).
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Figure VI-12:  Result of Percentage Value t2

5 Refer to Appendix A, Figure A-1 for where the icon toolbar is and Figure A-2 for a description of the icon.
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6.1.3 3D Scatter Graph for t1 and t2

This section shows how to produce a 3D graph displaying both the t1 and t2 datasets.

Select Open... from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1).
Define a viewport (Section 2.1.1).

Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).

In Graph Editor select 3D Scatter for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to x, Y to y and Color to t1 (Section 6.1.1, Figure VI-2).

Select Markers and set Symbol to [« = and Color to Red (Section 4.1.1, Figure 1V-3).
Select OK and the result will be (Figure VI-13).

No gk~ owbdE

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1

Irmpart Bepart: 83 values read into w, w1, 12 ;I
Drag out a rectangle with mouse button 1

I 1%
|Ready

Figure VI-13: 3D Scatter Graph for t1

Manchester Visualization Centre Page 139 of 165 22 October 2002



Visualization Cookbook Using Gsharp

8. Repeat steps 3-7°°, but when setting data values set Colour to t2 and select Markers and set Color to Blue. The
result will be (Figure VI1-14).

$ Gsharp 3.2 for Windows
File Create Edit

= E &

=10l x|

Delete  Wiew Options Tools Examples  Help

OB e 4 ¢ |

age 1
-
Import Report; 83 values read into w, w11, 12 ;I
Dirag out a rectangle with mouse button 1
o
[} 2
|Reau:|':.f v
Figure VI-14:

3D Scatter Graph for t1 and t2

% The previous graph must be selected before repeating steps 3-7.
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6.1.4 3D Irregular Bar Graph for t1 and t2

Continuing from Section 6.1.3, this section shows how to produce a 3D Irregular Bar graph displaying both the t1 and
t2 datasets on the same set of axes as the 3D Scatter Graph.

Select Graph...*® from the Create drop-down menu (Section 2.1.2, Figure 11-3).

In Graph Editor select 3D Irregular Bar for Graph Type (Section 2.1.2, Figure 11-5).
Select Data and set X to x, Y to y and Color to t1 (Section 6.1.1, Figure VI-2).
Select Chart from the Graph Editor and set Bar Frame Color to Red (Figure VI-15).

> w e

Graph Editor X|

b airn I M arne I Data  Chart |I:|:|ntr|:||s|

— Color Bars

 Color | J ™ width |4n 5‘ %
™ Megative Colar I J [T Offzet |0 = %

— 30 Barz

™ 3w Shadaw fol
Faocor [
[ 3D width |15 _,;‘ %

— Bar Frame
oo L
™ width |n.3 j [om =]

k. Cancel Help

Figure VI-15:  Bar Frame Color

5. Select OK and the result will be (Figure VI-16).

% The previous graph must be selected
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% Gsharp 3.2 for Windows
File Create Edit

= &

=10 x|

Delete  Wiew Options Tools Examples  Help

OO R B4 ¢ | DY

age 1
-
Irmpart Bepart: 83 values read into w, w1, 12 ;I
Drag out a rectangle with mouse button 1
o
[ 2
|Read~;.-' i
Figure VI-16:

3D Irregular Bar for t1
6.

Repeat steps 1-5°, but when setting data values set Colour to t2 and set Bar Frame Color to Blue. The result will
be (Figure VI-17).

5 The previous graph must be selected before repeating steps 1-5.
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% Gsharp 3.2 for Windows O] =|
File Create Edit Delete Wiew Options Tools Examples Help
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OO R B4 ¢ | DY

age 1
Irmpart Bepart: 83 values read into w, w1, 12 ;I
Drag out a rectangle with mouse button 1
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Figure VI-17: 3D Irregular Bar for t1 and t2
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6.1.5 3D Irregular Grid for t1 and t2
This section shows how to produce a 3D Irregular Grid for both the t1 and t2 datasets.

Select Open... from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1).
Define a viewport (Section 2.1.1).

Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).

In Graph Editor select 3D Irregular Grid for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to x, Y to y and Z to t1 (Section 6.1.1, Figure VI-2).

Select OK and the result will be (Figure VI1-18).

o gk wbh e

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

= &

OO R B4 ¢ | DY

age 1

Wigwpart ¥ limitz [12.3879,12.3879] are equal - limitz ignared ;I
Wigwpaort ¥ limitz [12.23873,12.3879)] are equal - limitz ignared

I 1%
|Ready

Figure VI-18: 3D Irregular Grid for t1
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7.

Repeat steps 1-6, but when setting data values set Y to t2. The result will be (Figure VI1-19).

% Gsharp 3.2 for Windows

File Create Edit Delete Wiew Options Tools  Examples

=10 x|

Help

= &

OO R B4 ¢ | DY

age 1

Wigwpart ¥ limitz [12.3879,12.3879] are equal - limitz ignared

Wigwpaort ¥ limitz [12.23873,12.3879)] are equal - limitz ignared
[ 2
|Read~;.-' i
Figure VI-19: 3D Irregular Grid for t2
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6.1.6 Visualizing scores.dat on the same axes as uk.dat

This section shows how to visualize scores.dat using 3D Irregular Grid to show the percentage of longitude and latitude
points with an Area graph of the UK on the same axes.

Select Open... from the File drop-down menu to import the uk.dat file (Section 6.1, Figure VI-1).
Define a viewport (Section 2.1.1).

Select Graph... from the Create drop-down menu (Section 2.1.2, Figure 11-3).

In Graph Editor select Area for Graph Type (Section 2.1.2, Figure 11-5).

Select Data and set X to Long and Y to Lat (Section 6.1.1, Figure VI-2).

Select OK and the result will be (Figure VI-20).

S A

% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help

W RS-t BT T A OB I

an o

25 _-*

20 ."-
.
-

-

i

TE o

70—+

55 —

G0 T T T T T T
-2710 -G710 -0 -2710 010 2710

OO R B4 ¢ | DY
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Figure VI-20: UK Area Graph
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7. Select Open... from the File drop-down menu to import the scores.dat file (Section 6.1, Figure VI-1).

8. Select Graph...*® from the Create drop-down menu (Section 2.1.2, Figure 11-3).

9. In Graph Editor select 3D Irregular Grid for Graph Type (Section 2.1.2, Figure 11-5).

10. Select Data and set X to x, Y to y and Z to t1 (Section 6.1.1, Figure VI-2).

11. Select Grid Cells from Graph Editor and set Num X Cells to 30, Num Y Cells to 30 and Width to 0 (Figure VI-21).

i

ke ain I Data  Grid Cells I Heginnl Earrierl I:::untrculsl

— [Gnd Cell:
v Mum i Cells a0 =
v Mum'' Cells a0 _:I
™ Mode I.-’-'-.verage 7 I
— Cell Frame
o |
Iv wiidtk 1] _I mm

k. I Cancel Lpply Help

Figure VI-21:  Grid Cells

12. Select OK and the result will be (Figure VI1-22).

s The viewport must be selected.
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help
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Figure VI-22:  Area Graph for uk.dat and 3D Irregular Grid for scores.dat

13. Select the Viewport (Figure VI1-23).
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% Gsharp 3.2 for Windows O] =|

File Create Edit Delete Wiew Options Tools Examples Help
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Figure VI-23:  Selecting Viewport

]
14. Select the df') button from the icon toolbar® and use the left mouse button to drag the graph to produce a better
view of the graph. The result will be (Figure V1-24).

% Refer to Appendix A, Figure A-1, for where the icon toolbar is; and Figure A-2 for a description of the icon.
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% Gsharp 3.2 for Windows O] =|
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Figure VI-24:  Result of Rotating the Graph
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Appendix A: Gsharp Window

Figure A-1 shows the Gsharp window.

I Command
File Create Edit Delete Miew Options Tools Examples Help P Toolbar
Icon Toolbar —*E) ) & fE - B = = Ay LB 2
Canvas >
D@ﬁ%*@\i( ||E < Icon Toolbar
Status Line age 1 >
Command
] Line
Message Area > _ILI
g 4 M 4
|Ready A
Figure A-1: Gsharp Window
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Figure A-2 shows the icons of Gsharp and description of each icon.

Icon

&)
)

U

&

Description

Open

Save

Print

Data Manager

Hierarchy Browser

Script Builder

Object Editor

Shade Editor

Line Editor

Text Editor

Rotate

Copy Clipboard

Repaint

Stop
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Icon

[J

® o O

B

s

Description

Page

Viewport

Domain

Graph

Title

Note

Arrow

Logo

Select

Figure A-2: Icons Descriptions
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Appendix B: File Block.dat

Figure B-1 shows the description of the first 41 lines of the block.dat file. The first line contains the title.

© 0o ~NOO UL WDNPEFE X

=

0]

© 00 ~NO Ul WNP

=

0]

© 00 ~NO Ul WNP

=

0

ADDDNDANDDDANDNWWWWWWWWWWNNNNNNNNNNRRPRREPRRRRERLRERKXK
PR RRPRRPRRRRPRRPRRRPRRPRRRPRPRRRPRPRRPRPREPRPRRRPRPEPRRRPRERRREPRERLERLEREN

© 00 ~NO Ul WNP

Figure B-1:

r+

.5
.33333333333333
.25

.2
.16666666666667
.14285714285714
.125
10.1111111111111

© 00 ~NO O WW

[EEN
[N
[EEN

.5

.5
.83333333333333
.25

.7
.16666666666667
.64285714285714
.125
.61111111111111
.1
.33333333333333
.16666666666667
.33333333333333
.58333333333333
.86666666666667
.16666666666667
.47619047619048
.79166666666667
.111111122111111
.43333333333333
.25

.08333333333333
.25

.45
.66666666666667
.89285714285714
.125
.36111111111111

OO0 0101 orT oo oo o000~ bSDDMLAMENOOOOOGGOMDBDWWO®W

First 40 Lines of the File
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Figure B-2 shows the description of the last lines of the block.dat file

1 7 10
2 7 10
3 7 10
4 7 10
5 7 10
6 7 10
7 7 10
8 7 10
9 7 10
10 7 10
1 8 10
2 8 10
3 8 10
4 8 10
5 8 10
6 8 10
7 8 10
8 8 10
9 8 10
10 8 10
1 9 10
2 9 10
3 9 10
4 9 10
5 9 10
6 9 10
7 9 10
8 9 10
9 9 10
10 9 10
1 10 10
2 10 10
3 10 10
4 10 10
5 10 10
6 10 10
7 10 10
8 10 10
9 10 10
10 10 10
Figure B-2:

10.8428571428571
-98571428571429
-46190476190476
.77142857142857
-41428571428571
.22380952380952
-12857142857143
.09285714285714
-0968253968254
-12857142857143
10.925

.05
-50833333333333
-8

.425
.21666666666667
-10357142857143
.05
-03611111111111
.05
11.0111111111111
.12222222222222
-56666666666667
.84444444444444
-45555555555556
.23333333333333
-10634920634921
-03888888888889
-01111111111111
-01111111111111
11.1

.2
.63333333333333
-9

-5
.26666666666667
-12857142857143
.05
-01111111111111

W wWwwwwwwar~o W wWwwwwwwar~o W wWwwwwwwahraoum

W wWwwwwwwar~o

Last 40 Lines of the File
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Figure B-3 shows Data Editor

DataEditor

Block

1]

2| 3 4|

35

5.25
E.2

9125

11.1

35 3333333333 5.25
3.5 SEERGEEEET 5

3333333333 3333333333 3333333333 3333333333 3333333

425 3333333333 5.25 f
4.7 SEEEEEREEY 5.45

3F14285714 3714285714 3047619042 3714285714 5714285

E.125 SEEEEEREEY E.125 E.

1

2

3

4

5

G| 3BEEEEREEY SEERERREERY JEREEEEERY SEREERERES SEREREE
¥

g

1111111 1111101111 11111111171 1111111111 111111
]

¥ 3333333333 E.E

Flane I‘I _I:

(] 4 Cancel Help

Figure B-3:

Data Editor Containing Values of Block.dat

To see the dataset of other planes, for example plane z=2, click on the upper arrow (Figure B-3). The horizontal grey
cells (1,2...10) are the y values and the vertical grey cells are the x values (1,2...10).

To use the Data Editor follow steps 1 —3 overleaf.
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1. Select Data Manager from the Tools drop-down menu (Figure B-4).

% Gsharp 3.2 for Windows

=100 x|
File Create Edit Delete Wiew Options | Tools Examples Help

?fﬁ DDE | Hierarchy Browser. ..

Data Manager...

= &

S

Scripk Builder. ..

e

OO R B4 ¢ | DY

age 1
[ 2
|Read~;.-' i
Figure B-4: Selecting Data Manager
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2. Select Block in the Data Manager by clicking once with the left mouse button on it (Figure B-5).

=
File Edit Interpolate Help

Folder [WORK =l

I ame | Type | Size | Fange

angy Test [1] C:hunirazh v 2hbinhgsharp exe

) Real [1000] 1-+10

1 Real [1000] 1-+10

z Real [1000] 1-+10

t Real [1000] 3111

Blocks Real [10] 1-+10

Blocky Real [0 1-+10

Blocks Real [0 1-+10

[Elock. | Real 0,170,100 3111

4 | ]
5L Corrnand:

Figure B-5: Selecting Block
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3. Select Editor... from the Edit drop-down menu (Figure B-6).

=

File | Edit Interpolate Help
o I
E

Create Folder. .,

Foli  Celete j
—  Delete Folder

M | Size | Range
an Paste From Excel 1] C:\unirazs7v2hbingsharp. exe
" e [1000] 1-x10
[t Real [1000] 110
z Feal [1000] 110
Feal [1000] 3111
Real [10] 110
Real [10] 110
Real [10] 110

Real  [10,10,10] 3> 11.1

5L Carmmatd:

Figure B-6: Selecting Editor for Block
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Appendix C: Superconductor Files

These are the first 25 lines and 3", 4™ and 5™ column of 00-39-33,Sep-07.txt file. The first line contains header

information.

Theta

1.10000000E+2

O O© © © © O OV O O O OV OV O O O O OO OoOkFFPPFPPFPP

-07000000E+2
-04000000E+2
-01000000E+2
-00500000E+2
-00000000E+2
-95000000E+1
-90000000E+1
-85000000E+1
-80000000E+1
- 75000000E+1
- 70000000E+1
-65000000E+1
-60000000E+1
-55000000E+1
-50000000E+1
-45000000E+1
-40000000E+1
-35000000E+1
-30000000E+1
-25000000E+1
-20000000E+1
-15000000E+1
-10000000E+1
-05000000E+1

Figure C-1:

Phi

[l RN e RN BN RN BN e BN BN o) R R BYe) BN e) BN e) B e >N e) N o) BN o) BN o) o) I e) BN e )R o))

Jc (A/m2)
.00000000E+1 3.22356347E+10
.00000000E+1 2.72672295E+9
.00000000E+1 3.99047557E+10
.00000000E+1 4.49788889E+10
.00000000E+1 5.47276568E+10
.00000000E+1 5.40836973E+10
.00000000E+1 5.89814061E+10
.00000000E+1 6.01080968E+10
.00000000E+1 6.00190000E+10
.00000000E+1 6.13340059E+10
.00000000E+1 6.14041306E+10
.00000000E+1 5.84813843E+10
.00000000E+1 5.60704645E+10
.00000000E+1 5.76031000E+10
.00000000E+1 5.77612824E+10
.00000000E+1 5.55248723E+10
.00000000E+1 5.59663788E+10
.00000000E+1 5.52096211E+10
.00000000E+1 5.28042857E+10
.00000000E+1 5.30446316E+10
.00000000E+1 5.13812061E+10
.00000000E+1 5.05760806E+10
.00000000E+1 4.96483687E+10
.00000000E+1 4.92829048E+10
.00000000E+1 4.45706370E+10

First 25 Lines and 3", 4™ and 5™ Column
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These are the last 25 lines and 3", 4™ and 5" column of 00-39-33,Sep-07.txt file.

Figure C-2:

-65000000E+1
. 70000000E+1
- 75000000E+1
-80000000E+1
-85000000E+1
-90000000E+1
-95000000E+1
-00000000E+1
-05000000E+1
-10000000E+1
-15000000E+1
-20000000E+1
-25000000E+1
-30000000E+1
-35000000E+1
-40000000E+1
-45000000E+1
-50000000E+1
-55000000E+1
-60000000E+1
-65000000E+1
. 70000000E+1
- 75000000E+1
-80000000E+1
-85000000E+1

6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1
6.00000000E+1

Last 25 Lines and 3", 4™ and 5

4 _95293759E+10
4_.72481049E+10
4_.70969448E+10
4 _.51317600E+10
4 _.43541698E+10
3.14603254E+10
4_.25624647E+10
4_27740195E+10
4_.20171477E+10
4.02391475E+10
4.00687173E+10
3.81946048E+10
3.66846151E+10
3.68072364E+10
3.53120000E+10
4 _22324515E+9
3.59350042E+10
3.48161520E+10
3.43704468E+10
3.37127385E+10
3.36291080E+10
3.26614471E+10
2.81305867E+9
3.20563254E+10
3.10477712E+10

" Column
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Appendix D: File percs.dat

This figure shows the first four columns of the file perc.dat.

p3

N

P NRRPNRNRPR

.43675231933594
.84078788757324
.59338760375977
.01849555969238
.45458221435547
.1877498626709

.61725997924805
.58316993713379
-5045166015625

.57023429870605

p5

w

W Hh WOWNAEADNMNWWW

.77732753753662
.50401306152344
.26341724395752
.69032096862793
.97425365447998
.14098739624023
.7100076675415

.23186683654785
.22495174407959
.10932159423828

Figure D-1:

pl10

&)

O OTWOSA O A D

.70948028564453
-90051651000977
.47679138183594
.4636344909668
.92519378662109
.86970901489258
. 77587890625

.22469711303711
.05863189697266
.17752456665039

ONO PMANOON OO NT

N
a1

.10166454315186
.66944313049316
.91360950469971
.16080856323242
.528639793396
.02697563171387
.81455326080322
.23193359375
.71629619598389
.12541389465332

First Four Columns of percs.dat File
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P90

11.9674530029297
12.1997451782227
10.2283935546875
12.7075729370117
11.7831573486328
11.5595169067383
9.43350219726563
10.7643661499023
12.2233734130859
10.5418472290039

Figure D-2:

This figure shows the last four columns of the file perc.dat.

P95

13.8349866867065
14.1032314300537
12.1270723342896
14 .6593627929688
13.3862447738647
13.3478031158447
10.7913370132446
12.1877174377441
14.0631742477417
11.9082317352295

p97
15.0559692382813
15.705602645874
13.1783790588379
15.6653079986572
14.7151870727539
15.0407543182373
12.0494499206543
13.9972248077393
15.2575836181641
13.1667995452881

Last Four Columns of percs.dat File

X

24-MAY-2002
25-MAY-2002
26-MAY-2002
27-MAY-2002
28-MAY-2002
29-MAY-2002
30-MAY-2002
31-MAY-2002
01-JUN-2002
02-JUN-2002
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Appendix E: File scores.dat

This is the first 25 lines of scores.dat file. The first line contains the title.

X y tl t2
-5.90733313200349 55.5266956331216 51.7027875726873 33.5983972549438
-1.46225439109685 60.1075656571411 59.7741234519265 54.222677230835
1.06086531013739 50.5573746640111 1.54237955266779 68.2734390894572
-6.52290783287663  53.7736891078093 81.0779072154652 26.507391611735
1.39636514483277 58.1416396545574 59.4995085976341 49.2445370356242
-3.90857078830641  53.399280273421  37.1455126675693 70.76717821757
-0.425759868677005 56.7069040250462 34.8837006308816 50.8982877731323
0.612751125563591  59.0741435867967 71.115478515625  64.1433537801107
-7.54941335136959 53.3659391575675 80.8876491893421 26.6496082941691
-7.45483522166569  54.3848920580858 90.9967269897461 28.9188365936279
1.76506208042906 58.0115493110898 38.6923290599476 72.2880900700887
-6.29041610035802  58.1423005793913 81.1032229336825 32.5832506815592
-4.09463699135927 54.0793719275425 40.0948371887207 51.3035198847453
-5.89688668770987  52.8292986966335 69.7386328957298 64.4605299631755
-0.501863008875034 56.6057926935282 73.2044154080478 61.3572340011597
0.614618229101325 50.9885721937462 3.13098421963778 76.3990224202474
-5.62816381104153  60.333998505248  79.3884731639515 12.7326389948527
-7.8670169986558 59.6548016416709 93.7991423173384 0.0240942637125627
-1.44299521810512  53.7911476914996 58.7413375160911 47.9315659205119
1.30055472679396 54_.7825247743313 29.7147424871271 53.0532341003418
-4.60749299110398 51.3576631252399 70.4393667741255 73.2497911453247
-5.01972144568254  56.2966120562123 66.9868490045721 22.1736570994059
1.51318981318877 52.7016588590886 14.3460641340776 89.8317238489787
-1.16398460094388 53.2083848452312 28.7966142134233 84.9824091593425

Figure E-1: First 25 Lines of File scores.dat
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0.785943649723777
-5.53630231698503
-1.44253777773838

1.77126086417434

0.0881323735311526
0.801879378418334

1.07256271380129

-4.27527925863501
-5.78678359208971
-4.67377516669353
-4.70108155593289
-3.43235669548972
0.148551844012218
-5.54948406796143
-5.21755973654081
-6.28241556169883
-5.65108250696721
-2.08335571844168
-1.76741379330406
0.299833908157098
-6.50423679749929

1.03086095628601
1.75861123770619

-3.13933346627778

-1.7895389702262

These are the last 25 lines of the scores.dat file.

54 .543493682082

50.6206404227305
54.9021623373483
57.1827292331836
58.2463403163274
54 5162737469982
54 5973234677876
52.7014961698987
53.0409776688321
50.5214813614912
59.4874758098667
52.2048467454551
53.7646598577703
59.5125401131845
56.6720173618887
55.1617634440445
57.7622993041005
57.5520133580903
54 .4077498892657
60.20826009761

58.2139651675388
53.1882418899077
52.7883823653756
57.1508828242622
57.4623817825341

Figure E-2:

43.055605801669

70.9149901650169
56.403318231756
32.9838079972701
70.6714130748402
33.0352197126909
32.6649773337624
60.776478507302
78.4202769886364
52.0707324634899
74.7530524513938
51.2239563681863
21.6022685657848
86.3400653492321
65.169319152832
53.1987557844682
99.1254133744673
84.9288007562811
67.5235075517134
66.5677091425115
83.0511460737748
44 5077483437278
19.7151204889471
53.5556033741344
57.230674050071

Last 25 Lines of scores.dat File

65.9791768391927
40.7115360895793
40.3092047373454
42 .9769099553426
38.0455792744954
88.7063086827596
51.9302031199137
42.6509122848511
35.9273096720378
75.6735544204712
16.2260672251383
53.0950765609741
74.6390164693197
35.0198488235474
16.8963413238525
34.4737908045451
38.3359731038411
54.1882257461548
74.489528020223
47.8629013697306
24.0640780131022
76.7415107091268
73.486421585083
57.3330462773641
60.5098546346029
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