VirusScan Enterprise 簡介

VirusScan Enterprise 提供的防護易於升級、效能快速、設計靈巧，可防止您的環境受到病毒、蠕蟲病毒及特洛伊木馬程式的危害。還可保護系統免於存取點違規、緩衝區溢位遭到利用，以及潛在無用之程式碼與程式的危害。它可偵測威脅，然後執行您設定的動作來保護環境。請參閱《VirusScan Enterprise 8.7i版本說明》，以取得此版本新功能的詳細資訊。

本指南說明設定及使用 VirusScan Enterprise 的方法。

您可以將 VirusScan Enterprise 設定為獨立式產品，或使用 ePolicy Orchestrator 3.6.1 及 4.0 版來集中管理及執行 VirusScan Enterprise 原則，然後使用查詢與儀表版來追蹤活動及偵測。

註: 此文件是以 ePolicy Orchestrator 4.0 來做說明。如需使用 ePolicy Orchestrator 任一版本的相關資訊，請參閱其產品說明文件。

內容

  • 使用 VirusScan Enterprise
  • 快速入門
  • 首要事項
  • 產品資訊的位置


使用 VirusScan Enterprise

使用 VirusScan Enterprise software 可保護您的環境免於潛在的威脅。

安裝後，VirusScan Enterprise 便已設定為使用隨產品封裝的偵測定義 (DAT) 檔案，並且為您的環境提供一般安全性。我們建議您針對環境定義原則與需求，並依據這些定義來設定產品，然後在開始使用產品或將其部署到用戶端電腦前，先更新產品的偵測定義。

每個 VirusScan Enterprise 元件或功能均扮演保護環境的角色。

防禦

先定義您的安全性需求，以確保所有資料來源均受到保護，然後再制訂有效的策略，以避免您的環境遭到入侵。設定這些功能以防止入侵：
  • 使用者介面安全性 — 設定顯示及密碼保護，以控制使用者介面的存取。
  • 存取保護 — 使用存取保護規則來保護電腦，以避免受到與檔案、登錄及連接埠相關之不良行為的危害。若您已安裝 AntiSpyware Enterprise Module，則有其他規則可保護您免於遭到潛在無用之間諜軟體相關的威脅。
  • 緩衝區溢位保護 — 防止遭到利用的緩衝區溢位在您的電腦中執行任意程式碼。
  • 無用程式保護 — 從您的電腦中徹底移除潛在無用程式 (例如間諜軟體及廣告軟體)。

偵測

制訂有效的策略以偵測發生的入侵。設定下列功能來偵測威脅：
  • 更新工作 — 從 McAfee下載網站取得偵測定義與掃描引擎的自動更新。
  • 常駐掃描 — 當從磁碟讀取檔案或將檔案寫入磁碟時，偵測來自任何可能來源的潛在威脅。如果您已安裝 AntiSpyware Enterprise Module，也可以掃描 Cookie 資料夾中潛在無用的 Cookie。
  • 按指定掃描工作 — 使用即時與排程掃描工作來偵測潛在威脅。如果您已安裝 AntiSpyware Enterprise Module，也可以掃描之前未清除的潛在無用 Cookie 以及與間諜軟體相關的登錄項目。
  • 傳送及按指定電子郵件掃描 — 使用郵件、附件或公用資料夾的傳送掃描，偵測 Microsoft Outlook 電子郵件用戶端上的潛在威脅。存取郵件時，偵測 Lotus Notes 電子郵件用戶端上的潛在威脅。
  • Quarantine Manager 原則 — 指定隔離位置及隔離項目的保留時間長度。請視需要還原隔離的項目。

通知

警告與通知 — 設定警告，以在偵測到威脅時通知您。

回應

使用產品記錄檔、自動作業及其他通知功能來決定處理偵測的最佳方式。

  • 記錄檔 — 監視產品記錄檔以檢視偵測項目的歷程記錄。

  • 查詢及儀表板 — 使用 ePolicy Orchestrator 查詢及儀表板來監視掃描活動及偵測。
  • 動作 — 設定功能以針對偵測執行動作。

補充資訊

請參閱以下主題以取得其他資訊：

  • 存取使用者介面選項 — 以多種方式存取產品的獨立式版本。

  • 新增及排除掃描項目 — 微調每個掃描程式中的掃描檔案類型清單。

  • 排程工作 — 排程按指定掃描、更新及鏡像工作，以在特定的日期、時間或間隔執行。

  • 設定命令列選項 — 從命令列設定按指定掃描及更新工作。

  • 連線至遠端系統 — 使用安裝的 VirusScan Enterprise 連線至遠端系統，以執行如修改及排程掃描、更新工作或啟用及停用常駐掃描程式等動作。

  • 提交威脅樣本以進行分析 — 透過 WebImmune 提交未偵測到的潛在威脅樣本給 Avert Labs。

  • 存取 Avert Labs 威脅程式庫 — 存取「Avert Labs 威脅程式庫」中的資訊。

  • 疑難排解 — 取得修復產品安裝與常見問題集的相關資訊。


快速入門

我們假定您具有執行本指南中所述步驟的必要權限。

  1. 從 McAfee 下載網站取得 VirusScan Enterprise 8.7i 產品檔案。這些檔案可能包含產品安裝檔案、產品套件檔案、報告及說明延伸模組檔案，及 ePolicy Orchestrator 遷移工具。請參閱《VirusScan Enterprise 8.7i 版本說明》，以取得安裝及已知問題。
  2. 若為 ePolicy Orchestrator，請使用「簽入精靈」，將產品、報告延伸模組檔案以及產品套件檔案新增至存放庫。如果您是從先前版本的 VirusScan Enterprise 升級並想要保留設定，請執行 ePolicy Orchestrator 遷移工具。請參閱 ePolicy Orchestrator 產品說明文件，以取得詳細資訊。
  3. 若為 VirusScan Enterprise 獨立式安裝，請參閱《安裝指南》以取得安裝產品的詳細資訊。如果您要從先前版本的 VirusScan Enterprise 升級，《安裝指南》中詳述保留設定的方法。


首要事項

安裝後，VirusScan Enterprise 便已設定為使用隨產品封裝的偵測定義，並且為您的環境提供一般安全性。將產品部署到用戶端系統之前，建議您取得最新的偵測定義，並自訂其組態以符合您的需求。

工作

產品安裝完成後，請立即執行這些動作。

  1. 設定使用者介面安全性。設定顯示及密碼選項，以防止使用者存取特定元件或整個 VirusScan Enterprise 使用者介面。請參閱「控制使用者介面的存取」，以取得更多資訊。
  2. 更新偵測定義。執行「立即更新」工作，以確保您有最新的偵測定義。請參閱「更新偵測定義」，以取得更多資訊。
  3. 防止入侵。設定下列功能，以防止潛在威脅存取您的系統：
    • 存取保護。設定存取保護規則以防止電腦的意外變更，並啟用選項以防止 McAfee 處理程序被終止。請參閱「保護系統的存取點」，以取得更多資訊。
    • 緩衝區溢位保護。啟用緩衝區溢位偵測及指定排除。請參閱「封鎖緩衝區溢位弱點」，以取得更多資訊。
    • 無用程式原則。設定常駐、按指定及電子郵件掃描程式用來偵測潛在無用程式的原則。在預先定義的清單中，從要偵測的無用程式類別中選取類別，然後定義要偵測或排除的其他程式。請參閱「限制潛在無用程式」，以取得更多資訊。
  4. 偵測入侵。設定下列功能以偵測系統上的潛在威脅，然後在發生偵測時通知您並執行動作：
    • 自動更新。設定更新工作以取得最新的偵測定義、掃描引擎及產品升級。請參閱「更新偵測定義」，以取得更多資訊。
    • 常駐掃描程式。設定掃描程式以進行偵測，以及在系統存取環境中的潛在威脅時採取動作。啟用無用程式掃描。如果您已安裝 AntiSpyware Enterprise Module，也可以掃描 Cookie 資料夾中的 Cookie。請參閱「在存取時掃描項目」，以取得更多資訊。
    • 按指定掃描程式。設定掃描工作以進行偵測，以及對環境中的潛在威脅執行動作。啟用無用程式掃描。如果您已安裝 AntiSpyware Enterprise Module，也可以掃描 Cookie 資料夾中的 Cookie，以及之前未清除的潛在無用間諜軟體相關之登錄項目。請參閱「根據需求掃描項目」，以取得更多資訊。
    • 電子郵件掃描程式。設定 Microsoft Outlook 及 Lotus Notes 電子郵件用戶端的傳送及按指定掃描。啟用無用程式掃描。請參閱「在傳送時掃描電子郵件以及根據需求掃描電子郵件」，以取得更多資訊。
  5. 傳送警告及隔離威脅。設定下列功能以在偵測發生時發出警告，並管理隔離項目：
    • 警告與通知。設定接收偵測通知及警告的方式與時間。請參閱「設定警告與通知」，以取得更多資訊。
    • Quarantine Manager 原則。設定隔離資料夾的位置，以及在自動刪除隔離項目之前要保留的天數。請參閱「定義隔離原則」，以取得更多資訊。


產品資訊的位置

產品說明文件旨在針對產品實作中的每個階段提供您需要的資訊，涵蓋的範圍從評估新產品到維護現有產品為止。您可能還可以使用其他文件，須視產品而定。產品發行後，有關此產品的其他資訊會輸入於 McAfee ServicePortal 的線上知識庫。

安裝階段

設定階段

維護階段

安裝之前、安裝期間及安裝之後。

版本說明

  • 目前版本中的已知問題。
  • 前一版本至今解決的問題。
  • 產品或其說明文件的最新變更。

安裝指南

  • 在生產環境中準備、安裝及部署軟體。

啟動並執行產品。

產品指南與線上說明

  • 針對您的環境設定及自訂軟體。

線上說明

  • 透過 ePolicy Orchestrator 管理及部署產品。
  • 產品之選項的詳細資訊。

維護軟體。

線上說明

  • 維護軟體。
  • 參考資訊。
  • 產品指南中的所有資訊。

「知識庫」(knowledge.mcaf)

  • 版本說明與說明文件。
  • 附加產品資訊。

  • 已知問題的因應措施。

尋找適用於 McAfee 企業產品的版本說明與說明文件

  1. 移至 knowledge.mcafee.com 並選取「Useful links (可用連結)」下的「Product Documentation (產品說明文件)」。
  2. 選取 <產品名稱>│<產品版本>，並從文件清單選取需要的文件。

在產品中存取說明主題

若要存取說明主題：

  • 從 ePolicy Orchestrator 主控台按一下?，然後選取 VirusScan Enterprise 8.7i。

    如需選項說明，請按一下原則或工作索引標籤上的 ?。

  • 從「VirusScan 主控台」，選取「說明」功能表中的「說明主題」。
    註: 安裝產品後第一次存取「說明」時，系統會詢問您是否要下載說明檔案。按一下「是」來下載說明檔案，並將其安裝到您的安裝目錄。

    如需選項說明，請按一下功能內容索引標籤上的「說明」。


控制使用者介面的存取

為用戶端電腦上的介面設定安全性，是保護環境的重要環節。身為系統管理員，您可以控制使用者對 VirusScan Enterprise 介面所擁有的存取權。指定密碼，以防止使用者存取或變更選取的功能。必要時，您也可以鎖定使用者介面及解除鎖定。

內容

  • 設定密碼對使用者的影響
  • 配置使用者介面安全性設定


設定密碼對使用者的影響

設定使用者介面密碼來遏止意圖不軌的使用者。當您在用戶端電腦上使用密碼來保護使用者介面時，會對使用者產生下列影響：

  • 非系統管理員 — 不具系統管理員權限的使用者。非系統管理員能在唯讀模式下執行所有的 VirusScan Enterprise 應用程式。他們可以檢視部份組態參數、執行已儲存的掃描，並且執行即時掃描與更新。但其無法變更任何組態參數，也無法建立、刪除、修改已儲存的掃描或更新工作。
  • 系統管理員 — 具系統管理員權限的使用者。系統管理員必須鍵入密碼，才能以讀取/寫入模式來存取受保護的索引標籤及控制項。若未提供受保護項目的密碼，系統管理員只能以唯讀模式進行檢視。


配置使用者介面安全性設定

若要存取「使用者介面」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「使用者介面原則」。

  • 從「VirusScan 主控台」選取「工具」|「使用者介面選項」。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 | 說明
顯示選項
  • 指定使用者可檢視的系統匣圖示選項。
  • 允許連線至遠端電腦。
  • 設定主控台語言。
密碼選項 | 為整個系統或選取的項目指定密碼安全性。


保護系統的存取點

存取保護可藉由限制存取指定的連接埠、檔案、共用、登錄機碼及登錄值，來防止電腦的意外變更。它也可以避免使用者停止 McAfee 處理程序。這種保護在病毒爆發之前及病毒爆發期間都很重要。

此功能使用預先定義的規則、類別及使用者定義的規則，來指定可存取與不可存取的項目。每個規則可設定為在存取點違規發生時，封鎖及/或報告存取點違規。預先設定之規則與類別是以透過 McAfee 更新網站所更新的內容為依據。

註: 存取保護功能使用常駐掃描程式來偵測存取點違規。常駐掃描程式必須啟用後，存取保護功能才能偵測到存取連接埠、檔案、共用及登錄機碼與值的嘗試。

內容

  • 存取保護規則的定義方式
  • 存取點違規及 VirusScan Enterprise 回應的方式
  • 使用者定義的規則類型
  • 設定存取保護設定


存取保護規則的定義方式

規則可分為下列類型，並提供下列層級的保護。

規則類型說明

規則類型 說明
防毒

這些預先設定的規則可保護您的電腦，使其免於惡意軟體的常見威脅行為。您可以啟用、停用和變更此設定，但無法刪除這些規則。

以下是兩個規則的範例：

  • 防止停用或變更重要處理程序、遠端建立或修改可執行檔、劫持可執行檔、假造 Windows 處理程序，以及防止大宗郵件發送蠕蟲病毒傳送郵件。
  • 保護電話簿檔案，防止密碼及電子郵件遭竊。

下列保護層級會套用至防毒規則：

  • 標準保護
  • 最大保護
  • 病毒爆發控制
一般

這些預先設定的規則會防止常用檔案及設定的修改。您可以啟用、停用和變更此設定，但無法刪除這些規則。

以下是三個規則的範例：

  • 避免 McAfee 檔案與設定遭到修改。
  • 保護 Mozilla 和 Firefox 檔案與設定、Internet Explorer 設定及網路設定。
  • 防止安裝 Browser Helper Object 及自動執行 Temp 資料夾的程式。

下列保護層級會套用至一般規則。

  • 標準保護
  • 最大保護
虛擬機器保護

這些預先設定的規則可防止 VMWare 處理程式終止及 VMWare 檔案遭到修改。您可以啟用、停用及變更設定，但無法刪除這些規則。

以下為規則範例：
  • 防止 VMWare 處理程序終止。
  • 防止 VMWare 工作站、伺服器或虛擬機器檔案被修改。
使用者定義

這些自訂規則可用來補充「防毒」規則及「一般」規則所提供的保護。
反間諜軟體

若您已安裝 AntiSpyware Enterprise Module，則您有其他規則可保護免於遭到與間諜軟體相關的威脅。

以下為規則範例：
  • 保護 Internet Explorer 我的最愛及設定。
  • 防止程式執行及防止從 Temp 資料夾執行指令碼。

保護層級說明

保護層級 | 說明
標準 | 可防止某些重要設定與檔案遭到修改的防毒與一般規則，但通常可允許合法軟體的安裝與執行。
最大 | 防毒及一般規則可防止最重要的設定與檔案遭到修改。此層級提供比「標準」層級更多的保護，但可能會讓您無法安裝合法軟體。如果無法安裝軟體，建議您在安裝軟體前先停用「存取保護」功能，然後在安裝後啟用該功能。
病毒爆發控制 | 防毒規則可以封鎖破壞性程式碼，不讓它存取電腦，直到發佈 DAT 檔案為止。這些規則是預先設定為在病毒爆發期間封鎖共用存取權。


存取點違規及 VirusScan Enterprise 回應的方式

存取點違規發生時：

  • 如果您在偵測到違規的規則中選取了「報告」選項，則記錄檔就會記錄違規資訊。
  • 如果您設定「警告內容」來執行此作業，則事件將記錄到本機事件記錄與 SNMP 中。
  • 如果您已針對產品進行此設定，則系統會向 Alert Manager 及/或 ePolicy Orchestrator 報告違規事件。
  • 系統會根據偵測違規之規則所設定的動作，來執行「封鎖」及/或「報告」動作。

  • 在用戶端系統上，系統匣圖示周圍將出現紅色外框，除非重新設定，否則紅色外框會顯示 30 分鐘。

    註: 若要重新設定圖示，請開啟系統匣圖示的「存取保護記錄檔」。使用任何其他方法開啟記錄檔，都無法將圖示重新設定為正常狀態。


使用者定義的規則類型

從三種類型的規則中選擇。

規則說明

規則 | 說明
連接埠封鎖規則 | 封鎖特定連接埠或連接埠範圍中的傳入或傳出網路流量。 註: 當您封鎖連接埠時，會一併封鎖「傳輸控制通訊協定 (TCP)」與「使用者資料包通訊協定 (UDP)」的存取。
檔案/資料夾封鎖規則 | 封鎖檔案與資料夾的讀取或寫入存取。 註: 在限制對檔案或資料夾的存取後，除非系統管理員將其移除，否則限制會永久生效。這有助於防止入侵，並在病毒爆發期間防止入侵的病毒傳播。
登錄封鎖規則 | 藉由封鎖下列動作來來保護登錄機碼或值：讀取、寫入、建立或刪除。


設定存取保護設定

若要存取「存取保護」內容

  • 從「ePolicy Orchestrator 主控台」移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「存取保護原則」。

  • 從「VirusScan 主控台」中，開啟「存取保護」內容。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 說明
存取保護
  • 啟用存取保護。
  • 設定規則。
  • 避免 McAfee 處理程序遭到停止。
報告
  • 啟用活動記錄。
  • 指定記錄檔名稱及位置。
  • 指定記錄檔大小限制。
  • 選取記錄檔格式。


設定防毒及一般規則

使用預先定義的「防毒」及/或「一般」規則，可避免對電腦進行不需要的變更。您可以啟用及編輯這些規則，但是無法刪除。

工作

  1. 選取左窗格中的「防毒」或「一般」類別，然後選取右窗格中的特定規則。
  2. 設定「封鎖」及/或「報告」選項。
  3. 按一下「編輯」以設定「規則詳細資料」。


設定使用者定義的規則

建立及編輯使用者定義的規則可補足「防毒」及「一般」規則提供的保護。

工作

  1. 選取左窗格中的「使用者定義的規則」類別，然後按一下「新增」。
  2. 選取規則類型。
  3. 視需要變更「封鎖」及「報告」動作。
  4. 按一下「編輯」以變更組態。


設定連接埠封鎖規則

封鎖使用者存取指定的入埠及/或出埠連接埠。

選項定義

選項 | 定義
規則名稱 | 輸入此規則的名稱。
要包含的處理程序 | 限制對指定處理程序的存取。
要排除的處理程序 | 允許存取指定的處理程序。
起始連接埠 | 指定第一個連接埠號碼。這可以是單一連接埠或連接埠範圍的起始號碼。 註: 如果您封鎖 McAfee Agent、Entercept Agent 或 Host Intrusion Prevention 代理程式使用之連接埠的存取，則代理程式處理程序會受到信任，並允許與已封鎖連接埠通訊。所有與這些代理程式處理程序無關的其他網路流量均會被封鎖。
結束連接埠 | 指定連接埠範圍內的最後一個連接埠號碼。
入埠 | 防止網路上的系統存取指定的連接埠。
出埠 | 防止本機處理程序存取網路上指定的連接埠。


設定檔案/資料夾封鎖規則

防止使用者對指定的檔案或資料夾執行動作。

選項定義

選項 | 定義
規則名稱 | 輸入此規則的名稱。
要包含的處理程序 | 限制對指定處理程序的存取。
要排除的處理程序 | 允許存取指定的處理程序。
要封鎖的檔案或資料夾名稱 | 封鎖對指定檔案或資料夾的存取。
瀏覽檔案 | 切換至要瀏覽的檔案。
瀏覽資料夾 | 切換至要瀏覽的資料夾。
讀取存取檔案 | 封鎖對指定檔案的讀取存取。
寫入存取檔案 | 封鎖對指定檔案的寫入存取。
已被執行的檔案 | 封鎖檔案以避免在指定資料夾中被執行。
已建立的新檔案 | 封鎖新檔案以避免在指定資料夾中被建立。
已被刪除的檔案 | 封鎖檔案以避免在指定資料夾中被刪除。


設定登錄封鎖規則

封鎖使用者以避免對指定的登錄機碼或值執行動作。

選項定義

選項 | 定義
規則名稱 | 指定此規則的名稱。
要包含的處理程序 | 限制對指定處理程序的存取。
要排除的處理程序 | 允許存取指定的處理程序。
要保護的登錄機碼或登錄值 保護此登錄機碼或值：
  • 從下拉式清單中選取根目錄機碼或值。
  • 在文字方塊中鍵入機碼或值。
您也可以從下拉式清單中，選取根目錄機碼或值。使用以下任一方法指定機碼或值：
  • 從下拉式清單中選取根目錄機碼或值，然後在文字方塊中鍵入機碼或值的剩餘路徑。
  • 在文字方塊中鍵入機碼或值的完整路徑。
規則類型 選取規則的類型：
  • 機碼 — 此規則可保護指定的機碼。
  • 值 — 此規則可保護指定的值。
寫入機碼或值 | 封鎖寫入至指定的機碼或值。
建立機碼或值 | 封鎖建立指定的機碼或值。
刪除機碼或值 | 封鎖刪除指定的機碼或值。


包含或排除特定處理程序

選項定義

編輯規則詳細資料，以指定偵測中要包含或排除的特定處理程序。

選項 | 說明
規則名稱 | 此規則的名稱。例如，防止登錄編輯程式及工作管理員被停用。
要包含的處理程序 | 限制存取這些處理程序。先使用實際的處理程序名稱或萬用字元指定廣泛的處理程序 (如 *.EXE)，再為合法的特定處理程序加上排除項目 (如 SETUP.EXE)。例如，指定 * 來包括所有處理程序。
要排除的處理程序 | 允許存取這些處理程序。使用實際的處理程序名稱。例如，指定下列排除項目：avtask.exe、cfgwiz,exe、fssm32.exe、giantantispywar*、kavsvc.exe、mmc.exe、navw32.exe、nmain.exe、rtvscan.exe。


移除使用者定義的規則

移除您建立之後就未使用的規則。

工作

  1. 選取左窗格中的「使用者定義的規則」類別，然後在右窗格中選取要移除的規則。
  2. 按一下「刪除」。
    註: 若要停用規則而不刪除，請取消選取「封鎖」及「報告」動作。必要時，您可以重新啟用規則。


封鎖緩衝區溢位弱點

緩衝區溢位保護可防止緩衝區溢位弱點在您的電腦中執行任意程式碼。它會監視使用者模式 API 呼叫，並辨識由於緩衝區溢位而被呼叫的時間。

偵測發生時，系統會將資訊記錄在活動記錄中，也會顯示在「常駐掃描訊息」對話方塊中 (如果您已設定那些選項的動作)。

VirusScan Enterprise 會使用「緩衝區溢位」及「存取保護 DAT」檔案來保護大約 20 個應用程式，包括 Internet Explorer、Microsoft Outlook、Outlook Express、Microsoft Word 及 MSN Messenger。

內容

  • 緩衝區溢位弱點的定義方式
  • 設定緩衝區溢位保護


緩衝區溢位弱點的定義方式

緩衝區溢位弱點是指利用應用程式或處理程序中的軟體設計瑕疵，強制其在電腦上執行程式碼的攻擊技術。應用程式用來儲存資料的緩衝區具有固定容量。若攻擊者傳送太多資料或程式碼到其中一個緩衝區，該緩衝區會產生溢位。然後，電腦會將溢位的程式碼當成程式來執行。由於程式碼的執行發生在通常具有高度權限或為管理員層級的應用程式安全內容中，所以入侵者得以執行平常無法使用的命令。攻擊者可以利用此弱點在電腦中執行自訂的駭客程式碼，並對電腦的安全性與資料完整性造成威脅。


設定緩衝區溢位保護

若要在執行 Linux 的系統上存取「緩衝區溢位保護」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「緩衝區溢位保護原則」。

  • 從「VirusScan 主控台」開啟「緩衝區溢位保護」內容。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 說明
緩衝區溢位保護
  • 啟用緩衝區溢位保護。
  • 設定偵測模式以警告及/或保護您免於緩衝區溢位攻擊。
  • 偵測發生時，顯示「常駐掃描訊息」對話方塊。
報告
  • 啟用活動記錄。
  • 指定記錄檔名稱及位置。
  • 指定記錄檔大小限制。
  • 選取記錄檔格式。


限制潛在無用程式

VirusScan Enterprise 能避免潛在無用程式對您的電腦構成干擾或是引起安全性風險。系統中已有一個設定好的一般無用程式原則，但您可以針對每個 VirusScan Enterprise 掃描程式個別啟用或停用該原則，並指定動作。

內容

  • 潛在無用程式的定義方式
  • 設定無用程式原則


潛在無用程式的定義方式

潛在無用程式的定義為：由合法公司撰寫的軟體程式，其可以改變安裝之電腦的安全性狀態或隱私權原則。本軟體可包含間諜軟體、廣告軟體及撥號程式 (但未必如此) 。這些程式可隨使用者想要的程式一起下載。重視安全性的使用者能夠辨識這類程式，並會在某些情況下移除它們。


設定無用程式原則

索引標籤說明

設定包含兩個步驟：

  1. 定義該偵測及排除的潛在無用程式：
    • 從目前 DAT 檔案的預先定義清單中，選取整個程式類別或某類別中的特定程式。
    • 指定排除項目。
    • 建立要偵測的使用者定義程式清單。

  2. 設定「無用程式原則」之後，啟用常駐、按指定及電子郵件掃描程式中的無用程式偵測，接著設定偵測到無用程式時要採取的動作。

若要存取「無用程式」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「無用程式原則」。

  • 從「VirusScan 主控台」中，開啟「無用程式原則」內容。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤 | 說明
掃描項目
  • 選取要偵測的無用程式類別。例如，間諜軟體、廣告軟體等。這些類別是由目前的 DAT 檔案所定義。
  • 指定排除項目。
使用者定義的項目 | 定義要偵測的其他無用程式。


更新偵測定義

VirusScan Enterprise 軟體會根據掃描引擎及偵側定義 (DTA) 檔案中的資訊，來識別威脅並執行動作。新的威脅會定期出現。為應對此挑戰，McAfee 每天都發佈包含最新研究結果的新 DAT 檔案，並納入正在進行的研究結果。更新工作會擷取最新的 DAT 檔案、EXTRA.DAT 檔案、掃描引擎、Service Pack 及修復程式。

內容

  • 決定更新策略的方式
  • 更新工作與其運作方式
  • 鏡像工作與其運作方式
  • 自動更新的運作方式
  • 復原 DAT 檔案的運作方式


決定更新策略的方式

您有多種方法可以完成更新。例如使用更新工作、手動更新、登入指定碼，或者也可以使用管理工具排程更新。本章節說明使用更新工作的方法。任何其他方法都不在本指南討論的範圍內。

一個有效的更新策略通常都要求，組織中至少須有一個用戶端或一部伺服器從 McAfee 下載網站擷取更新。從該下載網站，檔案可以複製到整個組織中，為所有其他電腦提供了存取權。建議您透過自動複製更新檔案至共用網站處理程序，來最小化您網路中傳輸的資料流量。

用戶端數目與站台數目是有效更新要考慮的主要因素。當然也需要考慮每個遠端網站上的系統數目、遠端網站存取網際網路的方式等因素。不過，使用集中式存放庫擷取更新與排程更新工作將環境保持在最新狀態的基本概念，適用於任何規模的組織。

使用更新工作可讓您：

  • 在方便的時間排程網路範圍的 DAT 檔案推展作業，且不太需要系統管理員或網路使用者操作。例如，您可能會錯開您的更新工作，或設定排程來劃分階段或輪流將 DAT 檔案更新到網路的不同部分。
  • 將推展的管理職責分割給不同的伺服器或網域控制站、廣域範圍網路的不同區域，或是跨其他網路的區塊。讓更新資料主要在內部進行傳輸，也可以減少網路安全性缺口的潛在威脅。
  • 降低下載新 DAT 或升級的引擎檔案所需要等待的時間。在固定的 DAT 檔案發佈日期及每當新產品版本問世時，McAfee 電腦上的流量會急劇增加。避開網路頻寬的競用時段，讓您在部署新的軟體時比較不會出現中斷。


更新工作與其運作方式

使用更新工作來取得最新的 DAT 檔案、掃描引擎、Service Pack 以及修補程式。

VirusScan Enterprise 包含預設的更新工作。預設工作排定在每天下午 5:00 執行更新，並有一小時的隨機選擇時間。您也可以建立其他更新工作，以滿足您的更新需求。

下圖顯示了一般更新工作的運作方式：

更新工作活動

執行更新工作時會發生以下活動：

  • 與存放庫清單中的第一個「已啟用」存放庫 (更新網站) 建立連線。如果此存放庫若無法使用，則會連絡下一個網站，依此類推直到建立連線或者到達清單結尾為止。
  • 從存放庫下載 CATALOG.Z 加密檔案。檔案中包含更新所需的基礎資料。此資料是用來判斷可用的檔案及/或更新。
  • 檔案中的軟體版本會與電腦中的版本比對。如果有可用的新軟體更新，則會進行下載。
  • 一旦將更新簽入存放庫後，系統會驗證更新以確認它適用於 VirusScan Enterprise，且版本高於目前版本。驗證過後，VirusScan Enterprise 會在下一個更新工作執行時下載更新。

更新工作中斷

如果更新工作在更新時被中斷 (不論原因為何)：

  • 從 HTTP、UNC 或本機站台更新的工作會在下一次更新工作啟動時從中斷的位置繼續更新。
  • 如果是在下載單一檔案時中斷，則自 FTP 站台更新的工作將不會繼續。但是，如果工作在下載多個檔案時發生中斷，則會從中斷時正在下載的檔案開頭繼續。

使用 EXTRA.DAT 更新

EXTRA.DAT 檔案可在緊急情況時作為暫時的處置方式。EXTRA.DAT 會在每次更新時從存放庫下載。這可以確保當您修改 EXTRA.DAT 並將其重新簽入作為套件時，所有 VirusScan Enterprise 用戶端都會下載並使用同一個更新的 EXTRA.DAT 套件。例如，您可以將 EXTRA.DAT 作為改進的偵測程式，偵測同一潛在無用程式，或者對其他新的潛在無用程式進行其他偵測。VirusScan Enterprise 僅支援使用一個 EXTRA.DAT 檔案。

提示: EXTRA.DAT 檔案使用完畢之後，您必須將該檔案從主要存放庫中移除，並執行複寫工作以確保該檔案已從所有分散式存放庫網站中移除。這可以防止 VirusScan Enterprise 用戶端在更新期間嘗試下載 EXTRA.DAT 檔案。依預設，一旦將新的偵測定義新增到每日的 DAT 檔案後，EXTRA.DAT 中的新潛在無用程式偵測將會被忽略。


設定自動更新工作

若要存取「自動更新」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「系統樹狀目錄」|「用戶端工作」。選取現有的更新工作或建立新的工作，按一下「新工作」，接著在「類型」清單中選取「更新 (McAfee Agent)」，然後按「下一步」。

  • 從「VirusScan 主控台」選取現有的更新工作或建立新的工作，選取「工作」|「新的更新工作」。

設定索引標籤上的選項。如需選項說明，請按一下索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 說明
更新
  • 指定記錄檔位置及格式。
  • 設定是否要取得較新的偵測定義、較新的引擎與 DAT 以及其他可用的更新，例如 Service Pack 與產品更新。
  • 指定在更新工作完成後要執行的執行檔，以及是否只要在成功更新後執行。


鏡像工作與其運作方式

鏡像工作會將存放庫清單中定義的第一個可存取之存放庫中的更新檔案，複寫至網路上的鏡像網站。這項工作最常見的用途是將 McAfee 下載網站的內容製作成鏡像，並儲存在本機伺服器。

VirusScan Enterprise 軟體會依靠一種目錄結構來進行自我更新。當您製作網站的鏡像時，請務必複寫整個目錄結構。
註: 此目錄結構也支援舊版的 VirusScan 與 NetShield，只要將整個目錄結構複寫到 VirusScan 4.5.1 用於更新的相同位置即可。

在複寫包含更新檔案的 McAfee 網站之後，您網路上的電腦就可以從鏡像網站下載檔案。此方法非常實用，因為無論是否可以存取網際網路，它都可讓您更新網路上的系統；且由於系統的通訊對象是比 McAfee 網際網路站台更近的伺服器，此方法可以有效率地節省存取與下載的時間。


設定鏡像工作

若要存取「鏡像」工作內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「系統樹狀目錄」|「用戶端工作」。選取現有的鏡像工作或建立新的工作，按一下「新工作」，接著在「類型」清單中選取「鏡像工作 (McAfee Agent)」，然後按「下一步」。

  • 從「VirusScan 主控台」選取現有的鏡像工作或建立新的工作，選取「工作」|「新的鏡像工作」。

設定索引標籤上的選項。如需選項說明，請按一下索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 說明
鏡像
  • 指定記錄檔位置及格式。
  • 指定在鏡像工作完成後要執行的執行檔，以及是否只要在成功製作鏡像後執行。


自動更新的運作方式

「自動更新」存放庫清單 (SITELIST.XML) 會指定執行「自動更新」工作所需的設定資訊。例如：
  • 存放庫資訊與位置。
  • 存放庫順序偏好設定。
  • Proxy 設定 (如有需要)。
  • 存取每個存放庫所需的加密認證。

執行「自動更新」工作時，會與存放庫清單中第一個「已啟用」的存放庫 (更新網站) 建立連線。如果無法使用此存放庫，則會連絡下一個存放庫，依此類推直到建立連線，或者直到清單結束為止。

Proxy 伺服器是網際網路安全性的一部份，其可對網際網路隱藏網際網路使用者的電腦，再透過快取公用存取網站提高存取速度。如果您的網路使用 Proxy 伺服器，則您可以指定使用的 Proxy 設定、Proxy 伺服器的位址以及是否要使用驗證。Proxy 資訊存放在「自動更新」存放庫清單中。此處設定的 Proxy 設定可套用至存放庫清單中的所有存放庫。

「自動更新」存放庫清單的位置取決於作業系統。例如，在 Windows XP 中：

C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework


設定存放庫清單

存放庫清單包含您擷取更新的來源存放庫。您可視需要建立及設定不限數目的存放庫。有些站台可能無時無刻都在使用，有些站台只會偶爾使用。

若要存取「自動更新存放庫清單」內容：

  • 從「VirusScan 主控台」選取「工具」|「使用者介面選項」。

註: 從「ePolicy Orchestrator 主控台」無法使用此功能。

設定索引標籤上的選項。如需選項說明，請按一下索引標籤上的「說明」。

索引標籤說明

索引標籤 | 說明
存放庫
  • 指定要取得更新的來源存放庫。
  • 設定存放庫的存取順序。
Proxy 設定 | 指定更新時使用的 Proxy 設定。


復原 DAT 檔案的運作方式

如果您發現目前的 DAT 檔案已損壞或不相容，您可以將 DAT 檔案復原為上次備份的版本。

當您更新 DAT 檔案時，舊版的檔案儲存在以下位置：<磁碟機>:\Program Files\Common Files\McAfee\Engine\OldDats。當復原 DAT 檔案時，目前的 DAT 檔案會被 OldDats 資料夾中的版本取代，並會在以下位置的登錄中設定標幟：HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS.復原後，您便無法再次返回先前的版本。下次執行更新時，系統會比對登錄中的 DAT 版本與更新存放庫中的 DAT 檔案。如果新的 DAT 檔案與登錄中的檔案相同，則不會執行更新。


復原 DAT 檔案

若要將 DAT 檔案復原為先前的版本。

工作

  1. 從「VirusScan 主控台」中選取「工具」|「復原 DAT」。
  2. 按一下「是」以繼續進行 DAT 復原。
    註:

    從「ePolicy Orchestrator 主控台」無法使用此功能。

    設定索引標籤上的選項。如需選項說明，請按一下索引標籤上的「說明」。


在存取時掃描項目

常駐掃描程式會在電腦上的檔案被存取時檢查這些檔案，以對威脅進行持續即時偵測。「存取保護」與「緩衝區溢位保護」功能還使用常駐掃描程式，分別偵測存取點違規與緩衝區溢位弱點。

內容

  • 常駐掃描與其運作方式
  • 指令碼掃描與其運作方式
  • 決定掃描原則的數量
  • 決定要指派給處理程序的風險
  • 設定一般設定與處理程序設定的方式
  • 設定一般設定
  • 設定處理程序設定


常駐掃描與其運作方式

常駐掃描程式會植入系統的最低層級 (檔案系統篩選器驅動程式)、成為系統的一部份 (系統服務)，並在偵測發生時透過介面傳送通知。

此範例說明當嘗試開啟、關閉或重新命名檔案時會出現什麼情況。掃描程式會攔截作業，並採取下列動作。

  1. 掃描程式會根據下列準則決定是否需要掃描檔案：
    • 檔案的副檔名符合設定。
    • 檔案未被快取。
    • 檔案未被排除。
    • 檔案先前未經掃描。
  2. 若檔案符合掃描準則，則會對其進行掃描：
    • 若檔案已清除，則會快取結果，並授權進行讀取、寫入或重新命名作業。
    • 若檔案包含威脅，則會拒絕作業，並執行設定的動作。
    • 若設定掃描程式執行記錄，則系統會將結果記錄在活動記錄中。
  3. 若檔案不符合掃描需求，則不進行掃描。會快取檔案並授權進行作業。


掃描比較：寫入磁碟與從磁碟讀取

常駐掃描程式的掃描方式會根據使用者執行的作業 (寫入磁碟或從磁碟讀取) 而有所不同：

將檔案寫入磁碟時，會掃描下列項目：

  • 寫入本機硬碟的傳入檔案。
  • 在本機硬碟上或對應的網路磁碟機上建立的檔案 (包括新檔案、已修改的檔案，或由一台磁碟機複製或移至他台磁碟機的檔案)。

從磁碟讀取檔案時，會掃描下列項目：

  • 從本機硬碟讀取的傳出檔案。選取「掃描項目」索引標籤上的「在網路磁碟機上」，以併入遠端網路檔案。
  • 任何在本機硬碟上執行的檔案。
  • 任何在本機硬碟上開啟的檔案。
  • 任何在本機硬碟上重新命名的檔案 (若檔案內容已變更)。


掃描比較：掃描所有檔案與掃描預設 + 其他檔案類型

常駐掃描程式會根據掃描程式設定為掃描所有檔案，或掃描預設加上其他檔案類型，而進行不同的掃描。

當掃描「所有檔案」時，掃描程式會掃描每一種檔案類型以找出所有可能的威脅。

當掃描「預設 + 其他檔案類型」時，掃描程式會根據選取的檔案類型檢查特定檔案清單。
  • 預設檔案類型：掃描程式只會針對攻擊該檔案類型的威脅檢查特定的檔案類型。例如，當掃描 XLS 檔時，掃描程式會掃描攻擊 XLS 檔案的威脅，例如巨集。掃描程式並不會掃描 XLS 檔案是否受到 PE (可攜式執行檔) 感染原，或甚至是 EICAR 的威脅。如果將 XLS 檔案重新命名為不同的檔案類型，則掃描程式會掃描重新命名後的檔案，以找出影響重新命名之檔案類型的威脅。

  • 其他檔案類型：掃描程式會此掃描檔案類型以找出所有可能的威脅，如同掃描「所有檔案」。


指令碼掃描與其運作方式

此指令碼掃描程式會以實際 Windows Scripting Host 元件的 Proxy 元件來作業。它會攔截指令碼，並在執行之前先行掃描。

  • 若為清潔的指令碼，則程式會將它傳遞到實際的 Scripting Host 元件中。
  • 如果指令碼包含潛在威脅，則不會執行該指令碼。

指令碼掃描程式會載入執行指令碼的處理程序，因此，若該處理程序毀損，則它的記憶體空間中會出現 ScriptProxy.dll 及 Mytilus.dll。該掃描程式還載入 DAT 檔案及掃描引擎，這會明顯增加該處理程序的記憶體使用量。


決定掃描原則的數量

遵循此處理程序來決定是否需要設定多個常駐掃描原則：


決定要指派給處理程序的風險

一旦您決定需要多個掃描原則之後，請識別各處理程序並決定要指定給每一個處理程序的風險。

工作

  1. 決定使用的處理程序。使用「Windows 工作管理員」或「Windows 效能監視器」，協助您瞭解哪些處理程序使用最多的 CPU 時間及記憶體。
  2. 決定負責每個處理程序的程式。請記住，只有已定義之父處理程序的子處理程序遵守掃描原則。例如，如果您將 Microsoft Word 可執行檔 WINWORD.EXE 定義為高風險處理程序，則系統會依據高風險掃描原則來掃描所有存取的 Microsoft Word 文件。然而，一旦父處理程序 Microsoft Word 啟動，系統就會依據啟動它的處理程序原則來掃描 WINWORD.EXE 檔案。
  3. 使用下列指導方針來決定每一個處理程序適用的風險：
    • 低風險 — 較不可能傳播或引進潛在威脅的處理程序。這些可能是存取許多檔案的處理程序，不過其存取檔案的方式可能引起傳播潛在威脅的風險較低。例如：

      備份軟體

      編譯處理程序

    • 高風險 — 較可能傳播或引進潛在威脅的處理程序。例如：

      啟動其他處理程序的處理程序，例如 Microsoft Windows 檔案總管或指令提示。

      執行指令碼或巨集的處理程序，例如 WINWORD 或 CSCRIPT。

      用於從網際網路下載的處理程序，例如瀏覽器、即時訊息通訊或電子郵件用戶端。

      註: 一開始將高風險掃描原則設為與預設處理程序相同，以確保能對高風險處理程序進行深入掃描，並提供最大保護。建議您不要降低預設的掃描層級。
    • 預設值 — 未將任何處理程序定義為低風險或高風險。


設定一般設定與處理程序設定的方式

常駐掃描程式的一般及處理程序原則是分別設定的。

  • 一般設定 — 一般原則包含可套用至所有處理程序的選項。
  • 處理程序設定 — 此處理程序的設定能讓您針對所有處理程序設定一個掃描原則，或針對您定義為預設、低風險及高風險的處理程序設定不同的原則。


設定一般設定

索引標籤說明

一般設定適用於掃描所有處理程序，並可包含掃描時間上限、掃描指令碼、封鎖來自遠端電腦的無用威脅、偵測到威脅時傳送訊息，以及報告偵測等參數。

若要存取「常駐掃描一般」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「常駐掃描一般原則」。

  • 從「VirusScan 主控台」開啟「常駐掃描程式」內容，然後在左窗格中選取「一般設定」。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤 | 說明
一般
  • 在關機期間掃描開機磁區及/或軟碟機。
  • 啟動系統時啟用常駐掃描。
  • 保存檔及所有檔案的最長掃描時間。
  • 掃描所有正在執行中的處理程序。
  • 如果已安裝 AntiSpyware Enterprise Module，則掃描 Cookie 檔案。
ScriptScan | 啟用指令碼掃描及指定排除。
封鎖
  • 當遠端電腦將威脅寫入此系統時傳送訊息，並指定訊息。
  • 當遠端電腦將威脅寫入此系統時封鎖連線。
  • 經過指定的時間後解除封鎖連線。
  • 當在共用資料夾中偵測到含潛在無用程式的檔案時封鎖連線。
訊息
  • 偵測發生時向本機使用者顯示訊息對話方塊，並指定訊息的內容。
  • 如果已安裝 AntiSpyware Enterprise Module ，則會在偵測到 Cookie 時傳送警告。
  • 設定不具系統管理員權限的使用者可對訊息執行的動作。
報告
  • 啟用活動記錄。
  • 指定記錄檔名稱及位置。
  • 指定記錄檔大小限制。
  • 選取記錄檔格式。
  • 指定掃描活動之外要記錄的事項。


設定處理程序設定

根據您指派給每個處理程序的風險，來設定常駐掃描處理程序。您可以針對所有處理程序設定一個預設掃描原則，或根據指派給每個處理程序的風險來設定不同的原則。參數包括指定處理程序的風險、定義掃描的項目、執行啟發式掃描、掃描壓縮檔、對偵測執行動作，以及掃描潛在無用程式。

若要存取「預設處理程序」、「低風險處理程序」或「高風險處理程序」的內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「常駐掃描預設處理程序原則」、「常駐掃描低風險處理程序原則」或「常駐掃描高風險處理程序原則」。

  • 從 「ePolicy Orchestrator 主控台」開啟「常駐掃描程式」內容，然後在左窗格中選取「預設處理程序」、「低風險處理程序」或「高風險處理程序」。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 | 說明
處理程序
  • 常駐掃描預設處理程序 — 選擇該選項以針對所有處理程序設定一個掃描原則，或針對預設處理程序、低風險處理程序及/或高風險處理程序設定不同的掃描原則。
    註: 如果您選擇設定一個掃描原則，則此原則會套用至所有處理程序。如果您選擇針對低風險及/或高風險原則設定不同的掃描原則，則此原則只會套用至沒有定義為低風險或高風險的處理程序。
  • 常駐掃描低風險處理程序 — 指定您定義為低風險的處理程序。
  • 常駐掃描高風險處理程序 — 指定您定義為高風險的處理程序。
註: 您必須在「常駐掃描預設處理程序」索引標籤上，選取「針對高風險、低風險及預設處理程序設定不同的掃描原則」，才能針對低風險及/或高風險處理程序設定個別的原則。
掃描項目
  • 設定是否要掃描讀取中、寫入中或網路磁碟上及/或為備份而開啟的檔案。
  • 設定要掃描的檔案及檔案類型。
  • 掃描類似無用程式、特洛伊病毒程式及巨集病毒的潛在威脅。
  • 對保存檔內部進行掃描，與對 MIME 編碼檔案進行解碼。
  • 針對無用程式啟用常駐掃描。
排除 | 設定要從掃描中排除的磁碟、檔案及資料夾。
動作
若為威脅偵測：
  • 偵測到威脅時所執行的主要動作。
  • 第一個動作失敗時威脅偵測所執行的次要動作。
若為無用程式偵測：
  • 偵測到無用程式時所執行的主要動作。
  • 第一個動作失敗時無用程式偵測所執行的次要動作。


根據需求掃描項目

按指定掃描程式提供了隨時或定期掃描整部電腦的方法，以找出是否有潛在威脅存在。使用按指定掃描來輔助常駐掃描程式所提供的不間斷保護，或在掃描不干擾您工作的情況下排程定期掃描。

內容

  • 按指定掃描方法與其定義方式
  • 遠端存放掃描的運作方式
  • 延後掃描的運作方式
  • 可疑檔案之啟發式網路檢查的運作方式
  • 系統使用率的運作方式
  • 設定按指定掃描工作


按指定掃描方法與其定義方式

按指定掃描程式使用以下兩種掃描方法：

記憶體中處理程序掃描

此方法在執行按指定掃描工作之前，會先檢查所有作用中的處理程序。偵測到的潛在無用處理程序會反白顯示，並停止該處理程序。這表示只需執行一次按指定掃描程式，就能移除潛在無用程式的所有執行個體。

可累加或恢復的掃描

此方法可讓掃描程式從上一次中斷的位置開始。對於您已排定開始時間、停止時間或時間限制的掃描，掃描會在到達時間限制時停止。在下一個排程掃描中，按指定掃描會從檔案與資料夾結構中，上一個掃描停止的地方繼續。


遠端存放掃描的運作方式

遠端存放的資料存放是階層式的，具有兩個已定義的層級：
  • 上層為本機存放，包含於 Windows 2000 Server 上執行「遠端存放」之電腦的 NTFS 磁碟區。
  • 下層為遠端存放，位於機械磁帶庫或與伺服器電腦連接的獨立磁帶機上。

「遠端存放」會自動將您本機磁碟區上的相關檔案複製到磁帶庫中，然後監視本機磁碟區的可用空間。檔案資料可從本機快取，這樣就可以視需要對其進行快速存取。必要時，「遠端存放」會將資料從本機儲存體移至遠端儲存體。當您需要從受「遠端存放」管理的磁碟區中存取檔案時，可像往常一樣開啟檔案。當您無法再從本機磁碟區中快取該檔案資料時，「遠端存放」便會從磁帶庫中回收這些資料。


延後掃描的運作方式

當電池電源不足或進行簡報中時，您可延後按指定掃描工作以增進效能。您也可允許使用者以小時為單位 (從 1 到 24 小時) 來延後排定的掃描，或者永久延後排定的掃描。每一個使用者延後掃描的持續時間都是以 1 小時為單位。例如，若「最大延後時數」選項設定為「2」，則使用者可以延後掃描兩次或兩小時。當指定的最大時數結束後，掃描會繼續執行。如果系統管理員將選項設定為 0 以藉此允許不限時延後，則使用者可以永久延後掃描。


可疑檔案之啟發式網路檢查的運作方式

此功能提供最新的即時偵測給使用 Window 型 McAfee 防毒產品的客戶，以抵抗某些惡意軟體。它會使用系統管理員設定的敏感度層級，在受 VirusScan Enterprise 保護的用戶端系統上尋找可疑的程式檔案與 DLL。當即時惡意軟體防禦偵測到可疑的程式時，它會傳送一個包含可疑檔案指紋的 DNS 要求到由 McAfee Avert Labs 管理的中央資料庫伺服器。即時防禦的功能不提供各種惡意軟體的保護，它只適用於可疑的樣本。針對特定威脅進行防護的優點為當 McAfee Avert Labs 判定樣本是有害的同時，隨即以 McAfee 安全性產品來保護使用者。在此版本中，本功能預設為停用。您必須選取敏感度層級才能啟用此功能。


系統使用率的運作方式

按指定掃描開始時會判定系統使用率。系統會在前 30 秒對 CPU 與 IO 執行取樣，然後依據您指定的使用率層級執行掃描。

您指定的系統使用率不適用於加密的檔案。解密是由 LSASS.EXE 完成，而不是由 Scan32 處理程序完成。掃描已加密檔案會耗用大量 CPU，因此即使掃描執行緒的系統限制較低，檔案的掃描速度仍會很快，以致 LSASS.EXE 須不停地提供已解密資料。


設定按指定掃描工作

VirusScan Enterprise 包含預設的按指定掃描工作。您可以使用預設工作及/或建立新的工作。

若要存取按指定掃描工作：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「系統樹狀目錄」|「用戶端工作」。選取現有的按指定掃描工作或存取預設的工作後，按一下「新工作」，接著在「類型」清單中選取「按指定掃描 (VirusScan Enterprise 8.7.0)」，然後按「下一步」。

  • 從「VirusScan 主控台」選取現有的按指定掃描工作，或者是若要存取預設的工作，請開啟「完整掃描」內容。如果您安裝 AntiSpyware Enterprise Module，請開啟「目標掃描」內容。若要建立新工作，請選取「工作」|「新的指定掃描工作」。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 | 說明
掃描位置
  • 指定要掃描的位置與項目。
  • 掃描時包含子資料夾。
  • 掃描時包含開機磁區。
掃描項目
  • 設定要掃描的檔案及檔案類型。
  • 啟用偵測無用程式的按指定掃描。
  • 對保存檔內部進行掃描，與對 MIME 編碼檔案進行解碼。
  • 掃描已備份至存放區的檔案。
  • 掃描類似無用程式、特洛伊病毒程式及巨集病毒的潛在威脅。
排除 | 設定要從掃描中排除的磁碟、檔案及資料夾。
效能
  • 設定何時要延後掃描及延後的時間長度。
  • 指定系統使用率百分比。
  • 設定可疑檔案之啟發式網路檢查的敏感度層級。
動作
若為威脅偵測：
  • 偵測到威脅時所執行的主要動作。
  • 第一個動作失敗時威脅偵測所執行的次要動作。
若為無用程式偵測：
  • 偵測到無用程式時所執行的主要動作。
  • 第一個動作失敗時無用程式偵測所執行的次要動作。

在提示對話方塊中允許的動作下，選取動作。
報告
  • 啟用活動記錄。
  • 指定記錄檔名稱及位置。
  • 指定記錄檔大小限制。
  • 選取記錄檔格式。
  • 指定掃描活動之外要記錄的事項。
  • 如果已安裝 AntiSpyware Enterprise Module，則會在偵測到 Cookie 時會發出警告。
工作 指定按指定掃描工作的執行位置。
註: 此索引標籤僅能透過 ePolicy Orchestrator 使用。


在傳送時掃描電子郵件以及根據需求掃描電子郵件

電子郵件掃描程式會自動檢查電子郵件訊息及附件：

  • 對於 Microsoft Outlook 來說，會在傳送時掃描電子郵件，或者您也可以直接從 Microsoft Outlook 呼叫按指定電子郵件掃描。
  • 對於 Lotus Notes 來說，會在存取時掃描電子郵件。

內容

  • 可疑檔案之啟發式網路檢查的運作方式
  • 設定電子郵件掃描內容


設定電子郵件掃描內容

索引標籤說明

若要存取「傳送電子郵件掃描」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「傳送電子郵件掃描程式原則」。

  • 從「VirusScan 主控台」開啟「傳送電子郵件掃描程式」內容。

若要存取「按指定電子郵件掃描」內容：

  • 從 Microsoft Outlook 中選取「工具」|「電子郵件掃描內容」。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤 說明
掃描項目
  • 指定要掃描的訊息和附件。
  • 掃描類似惡意軟體的潛在威脅。
  • 掃描不明巨集病毒。
  • 尋找具有多個副檔名的附件。
  • 對保存檔內部進行掃描，與對 MIME 編碼檔案進行解碼。
  • 啟用電子郵件掃描程式來掃描無用程式。
  • 掃描電子郵件本文。
  • 設定可疑檔案之啟發式網路檢查的敏感度層級。
    註: 此選項只適用於「傳送電子郵件掃描」。
動作
若為威脅偵測：
  • 偵測到威脅時所執行的主要動作。
  • 第一個動作失敗時所執行的次要動作。
若為無用程式偵測：
  • 偵測到無用程式時所執行的主要動作。
  • 第一個動作失敗時所執行的次要動作。

在提示對話方塊中允許的動作中選取動作。
警告
  • 在偵測到具威脅性的電子郵件時，通知其他使用者。
  • 指定當出現動作提示時，顯示給使用者的訊息。
報告
  • 啟用活動記錄。
  • 指定記錄檔名稱及位置。
  • 指定記錄檔大小限制。
  • 選取記錄檔格式。
  • 指定掃描活動之外要記錄的事項。
Notes 掃描程式設定
註: 此索引標籤只適用於「傳送電子郵件掃描」。

設定 Lotus Notes 的特定設定。

  • 掃描所有伺服器資料庫。
  • 掃描指定的信箱根資料夾中的伺服器信箱。
  • 要忽略的 Notes 應用程式。


定義隔離原則

偵測到的檔案、登錄機碼及登錄值係根據您設定的隔離原則加以隔離。您可以視需要還原隔離項目。

內容

  • 設定隔離原則及還原項目


設定隔離原則及還原項目

若要存取「隔離」原則及「還原」內容，請參閱以下所述的各種方法。

設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

ePolicy Orchestrator — 隔離原則

從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「Quarantine Manager 原則」。

索引標籤說明

索引標籤 說明
原則
  • 指定隔離位置
  • 可設定保留隔離項目的時間長短。

ePolicy Orchestrator — 從隔離區還原工作

從 ePolicy Orchestrator 主控台移至「系統」|「系統樹狀目錄」|「用戶端工作」並選取「新增工作」，然後在「類型」下選取「從隔離區還原 (VirusScan Enterprise 8.7.0)」。

索引標籤說明

索引標籤 | 說明
還原 | 指定要還原的項目。 註: 您可以在記錄檔中利用偵測名稱找到要還原之項目的名稱。
工作 | 指定可以存取隔離位置的使用者帳戶。

VirusScan 主控台 — Quarantine Manager 原則

從「VirusScan 主控台」中，開啟「Quarantine Manager 原則」內容。

索引標籤說明

索引標籤 說明
隔離
  • 指定隔離位置。
  • 可設定保留隔離項目的時間長短。
管理員
  • 還原、重新掃描、刪除及檢視隔離項目。
    註:

    您可以在記錄檔中利用偵測名稱找到要還原之項目的名稱。

  • 檢查隔離項目是否為誤報。


設定警告與通知

在偵測到潛在威脅時收到通知，是保護環境的重要環節。您可以使用 Alert Manager 或 VirusScan Enterprise 本機警告，以在偵測發生時通知您。

  • Alert Manager 是與 VirusScan Enterprise 搭配使用的個別元件，可即時處理警告及事件。在一般的設定中，Alert Manager 會駐留在中央伺服器上，並監聽由 VirusScan Enterprise 傳送給它的警告。使用它來設定警告的傳送位置、傳送方式，以及警告訊息的定義。
  • VirusScan Enterprise 提供一個介面，以設定 Alert Manager 及其他不需要 Alert Manager 的警告選項。按嚴重性篩選警告，以限制傳送到 Alert Manager 的警告流量，並設定不需要 Alert Manager 的本機警告選項。

內容

  • 設定警告


設定警告

若要存取「警告」內容：

  • 從 ePolicy Orchestrator 主控台移至「系統」|「原則目錄」，並在「產品」清單與「類別」清單中分別選取 VirusScan Enterprise 8.7.0 與「警告原則」。

  • 從「VirusScan 主控台」中，選取「工具」|「警告」。

    設定每個索引標籤上的選項。如需選項說明，請按一下每個索引標籤上的 ? 或「說明」。

索引標籤說明

索引標籤 說明
Alert Manager 警告
  • 指定產生警告的元件。
  • 設定 Alert Manager。
其他的警告選項
  • 按嚴重性篩選警告。
  • 設定本機警告。


存取查詢及儀表板

使用查詢及儀表板，以監視活動並協助您決定對偵測作業採取的動作。您可以使用預先定義的查詢及儀表板，並建立額外的儀表板及查詢來滿足您的需求。如需有關查詢及儀表板的資訊，請參閱 ePolicy Orchestrator 產品說明文件。

查詢

若要存取 ePolicy Orchestrator 主控台中的查詢，請移至「報告」，然後在「查詢」下，向下捲動至以 VSE 開頭的查詢。

下列為可用的預先定義查詢：

  • VSE：過去 30 天的符合性
  • VSE：每週偵測到威脅的電腦
  • VSE：目前 DAT 的採用情況
  • VSE：過去 24 小時 DAT 的採用情況
  • VSE：DAT 部署
  • VSE：偵測回應摘要
  • VSE：依標記顯示偵測次數
  • VSE：過去 24 小時所偵測到的間諜軟體
  • VSE：過去 7 天所偵測到的間諜軟體
  • VSE：過去 24 小時所偵測到的威脅摘要
  • VSE：過去 7 天所偵測到的威脅摘要
  • VSE：依嚴重性顯示的威脅計數
  • VSE：每週偵測到的威脅名稱
  • VSE：過去 24 小時所偵測到的威脅
  • VSE：過去 7 天所偵測到的威脅
  • VSE：過去兩季所偵測到的威脅
  • VSE：每週偵測到的威脅
  • VSE：前 10 個違反的存取保護規則
  • VSE：偵測次數排列前 10 位的緩衝區溢位
  • VSE：偵測次數最多的前 10 台電腦
  • VSE：前 10 個最常偵測到的威脅
  • VSE：前 10 個威脅來源
  • VSE：各威脅類別的前 10 個威脅
  • VSE：偵測次數最多的前 10 個使用者
  • VSE：過去 24 小時所偵測到的無用程式
  • VSE：過去 7 天所偵測到的無用程式
  • VSE：8.5 版符合性
  • VSE：8.7 版符合性

儀表板

若要存取 ePolicy Orchestrator 主控台中的儀表板，請移至「儀表板」。

下列為可用的預先定義儀表板：
  • VSE：趨勢資料
  • VSE：目前偵測數量


回應偵測

您有多種對偵測執行動作的方法，需視何種功能偵測到威脅而定。

內容

  • 對偵測執行動作的方式
  • 系統存取點違規
  • 緩衝區溢位偵測
  • 無用程式偵測
  • 常駐掃描偵測
  • 按指定掃描偵測
  • 電子郵件掃描偵測
  • 隔離項目


對偵測執行動作的方式

當偵測發生時，系統會視 DAT 檔案中偵測定義的定義方式來執行動作。例如，如果掃描程式無法清除檔案或檔案已損毀而無法修復，則掃描程式可以刪除檔案，或根據次要動作在 DAT 檔案中的定義方式來執行它。

當掃描程式拒絕存取具有潛在威脅的檔案時，也會在儲存檔案時在檔名後附加 .mcm 副檔名。


系統存取點違規

當發生系統存取點違規時，會視設定規則的方式來決定採取的動作：

  • 如果將規則設定為報告，則會將資訊報告至記錄檔中。

  • 如果將規則設定為封鎖，則會封鎖存取。

檢視記錄檔來判斷哪些系統存取點發生違規，以及哪些規則偵測到違規，然後設定存取保護規則來允許使用者存取合法項目，並防止使用者存取受保護的項目。

使用下列案例來決定要採取的回應動作。

偵測類型 案例
無用處理程序
  • 如果規則在記錄檔中記錄了違規報告但未封鎖違規，請選取該規則的「封鎖」選項。
  • 如果規則封鎖了違規但未在記錄檔中記錄違規報告，請選取該規則的「報告」選項。
  • 如果規則封鎖了違規且在記錄檔中記錄違規報告，則不須執行動作。
  • 若您發現某個未偵測到的無用處理程序，您可以編輯規則以將其納入。
合法處理程序
  • 如果規則在記錄檔中記錄了違規報告但未封鎖違規，請取消選取該規則的「報告」選項。
  • 如果規則封鎖了違規且在記錄檔中記錄違規報告，請編輯規則以排除合法處理程序。


緩衝區溢位偵測

緩衝區溢位偵測發生時：

  • 掃描程式會封鎖偵測。
  • 訊息會記錄在「常駐掃描訊息」對話方塊中。檢視對話方塊，然後決定是否執行任何下列其他動作：
    • 移除訊息 — 選取清單中的項目，然後按一下「移除」。
    • 建立排除 — 如果偵測到的處理程序是合法使用的處理程序或者是誤報，則使用「常駐掃描訊息」對話方塊中的資訊建立排除。檢視「名稱」欄位中的資訊，以判斷擁有執行呼叫之可寫入記憶體的處理程序名稱。使用處理程序名稱建立排除。
    • 提交樣本給 AVERT Labs 分析 — 掃描程式若偵測到您認為不應偵測的內容、或未偵測到您認為應該偵測的內容，請將樣本傳送給 AVERT Labs。


無用程式偵測

常駐、按指定及電子郵件掃描程式會依據您設定的「無用程式原則」來偵測無用程式。當偵測發生時，偵測到潛在無用程式的掃描程式，會套用該掃描程式之「動作」索引標籤上設定的動作。

檢視記錄檔中的資訊，然後判斷是否執行任何下列其他動作：

  • 微調掃描項目以使掃描更有效率。
  • 若偵測到合法程式，則可從偵測中排除。
  • 若未偵測到某個無用程式，您也可以將其新增至使用者定義的偵測清單。
  • 提交樣本給 AVERT Labs 分析 — 掃描程式若偵測到您認為不應偵測的內容、或未偵測到您認為應該偵測的內容，請將樣本傳送給 AVERT Labs。


常駐掃描偵測

當偵測發生時：

  • 掃描程式會根據您設定之「常駐掃描內容」的「動作」索引標籤來執行動作。
  • 訊息會記錄在「常駐掃描訊息」對話方塊中。

檢視活動記錄與/或「常駐掃描訊息」對話方塊中的資訊，然後決定是否執行下列任何其他動作。

  • 微調掃描項目以使掃描更有效率。
  • 常駐掃描訊息對話方塊 — 在清單中的項目上按一下滑鼠右鍵，然後選取下列其中一項動作：
    • 清除檔案 — 嘗試清除所選訊息參考的檔案。
    • 刪除檔案 — 刪除選取之訊息參考的檔案。此檔名會記錄在記錄中，因此您可以從 Quarantine Manager 還原檔案。
    • 全選 (ctrl+a) — 選取清單中的所有訊息。
    • 從清單移除訊息 (ctrl+d) — 從清單移除所選訊息。已從清單移除的訊息在記錄檔中仍可看見。
    • 移除所有訊息 — 從清單移除所有訊息。已從清單移除的訊息在記錄檔中仍可看見。
    • 開啟常駐掃描程式記錄檔 — 開啟常駐掃描程式活動記錄檔。僅在「檔案」功能表中提供此選項。
    • 開啟存取保護記錄檔 — 開啟存取保護活動記錄檔。僅在「檔案」功能表中提供此選項。
    • 如果目前訊息沒有可用的動作，則會停用對應的圖示、按鈕與功能表項目。例如，如果檔案已刪除，則無法使用「清除」，或如果系統管理員隱藏了該動作，則無法使用「刪除」。
    • 清除檔案 — 如果 DAT 檔案沒有清除程式或已損毀到無法修復的程度，則無法清除該檔案。如果無法清除該檔案，則掃描程式會將 .mcm 副檔名附加到檔名，並拒絕存取它。項目會記錄在記錄檔中。在此情況下，建議您刪除該檔案，並從乾淨的備份副本還原檔案。
  • 提交樣本給 AVERT Labs 分析 — 掃描程式若偵測到您認為不應偵測的內容、或未偵測到您認為應該偵測的內容，請將樣本傳送給 AVERT Labs。


按指定掃描偵測

當偵測發生時，掃描程式會根據您設定之「按指定掃描內容」的「動作」索引標籤來執行動作。

檢視記錄檔中的資訊，然後判斷是否執行任何下列其他動作：

  • 微調掃描項目以使掃描更有效率。
  • 如果您將掃描程式設定為「提示動作」，則請從「按指定掃描進度」對話方塊中選取動作。
  • 提交樣本給 AVERT Labs 分析 — 掃描程式若偵測到您認為不應偵測的內容、或未偵測到您認為應該偵測的內容，請將樣本傳送給 AVERT Labs。


電子郵件掃描偵測

當偵測發生時，掃描程式會根據您設定之「傳送電子郵件掃描內容」或「按指定電子郵件掃描內容」的「動作」索引標籤來執行動作。

檢視記錄檔中的資訊，然後判斷是否執行任何下列其他動作：

  • 微調掃描項目以使掃描更有效率。
  • 提交樣本給 AVERT Labs 分析 — 掃描程式若偵測到您認為不應偵測的內容、或未偵測到您認為應該偵測的內容，請將樣本傳送給 AVERT Labs。


隔離項目

檢視隔離目錄中的項目，然後判斷是否執行任何下列其他動作：

  • 還原。

  • 重新掃描。

  • 刪除。

  • 檢查誤報。

  • 檢視偵測內容。

從 ePolicy Orchestrator 主控台，使用「從隔離區還原」用戶端工作來對隔離項目執行動作。

從「VirusScan Enterprise主控台」，使用「管理員」索引標籤上的「Quarantine Manager 原則」選項來對隔離項目執行動作。


補充資訊

請參閱以下主題以取得有關使用 VirusScan Enterprise 的補充資訊。

內容

  • 存取使用者介面選項
  • 新增及排除掃描項目
  • 排定工作
  • 設定命令列選項
  • 連接至遠端系統
  • 提交威脅樣本以供分析
  • 存取 Avert Labs 威脅程式庫
  • 疑難排解


存取使用者介面選項

您有多種存取 VirusScan Enterprise 獨立式版本使用者介面的方式。當您使用 ePolicy Orchestrator 來管理產品時，此資訊並不適用。


VirusScan 主控台與其運作方式

「VirusScan 主控台」是獨立式版本之程式活動的介面。使用下列任一方法開啟「VirusScan 主控台」：
  • 從「開始」功能表選取「程式集」|「McAfee」|「VirusScan 主控台」。
  • 在系統匣的 VirusScan Enterprise 盾形圖示上按一下滑鼠右鍵，然後選擇「VirusScan 主控台」。
「VirusScan 主控台」可分為以下部分：
  • 功能表列 — 使用功能表項目建立工作、設定內容以及存取其他資訊。
    • 工作 — 建立與設定工作，例如掃描威脅或更新 DAT 檔案。
    • 編輯 — 複製、貼上、刪除或重新命名選取的工作。
    • 檢視 — 顯示工具列與/或狀態列，並重新整理顯示內容。
    • 工具 — 設定使用者的介面選項、鎖定使用者介面安全性或解除鎖定、設定警告、存取事件檢視器、開啟遠端主控台 (如果您具有系統管理員權限)、匯入或編輯存放庫清單，以及復原 DAT 檔案。
    • 說明 — 存取線上「說明」主題、AVERT Labs 網站上的「威脅程式庫」、「提交樣本」網站以及「技術支援」網站。您也可以修復產品安裝，並檢視「關於」對話方塊以取得著作權資訊，以及檢視已安裝之產品、授權、定義檔案、掃描引擎、額外驅動程式以及修復程式等的版本。
    註: 功能表上的每個項目都有相關聯的快速鍵。每個項目的快速鍵都會以底線標示。某些作業系統上可能無法使用這些快速鍵，除非您使用鍵盤 (F10 或 ALT) 來存取功能表。
  • 工具列 — 使用圖示來存取以下的常用指令：
    • 顯示選取之工作的內容。
    • 啟動選取的工作。
    • 停止選取的工作。
    • 複製選取的工作。
    • 貼上選取的工作。
    • 刪除選取的工作。
    • 設定警告內容。
    • 啟動事件檢視器。
    • 存取 AVERT Labs 網站上的資訊庫。
    • 如果您具有系統管理員權限，則可連接至遠端電腦。
    • 建立新的按指定掃描。
  • 工作清單 — 顯示預設的工作與任何由您建立的新工作，以及每個工作的狀態與最新結果。
  • 狀態列 — 顯示目前活動的狀態。


使用按滑鼠右鍵的功能

使用按滑鼠右鍵的功能快速存取常用動作，如建立新工作、檢視工作統計資料與記錄、開啟工作內容頁面、掃描特定檔案或資料夾，或執行即時更新工作。

功能說明

位置 說明 範例
主控台 在「VirusScan 主控台」上按一下滑鼠右鍵，以顯示按滑鼠右鍵的功能。這些功能會視您是否選取工作清單中的工作，以及選取的工作而有所不同。
  • 在主控台中的工作上按一下滑鼠右鍵以存取其內容。您也可以啟動、停止、啟用或停用工作，並檢視統計資料及活動記錄，端視選取的工作而定。在某些情況下，您也可以重新命名或刪除工作。
  • 在主控台的空白區域上按一下滑鼠右鍵以建立新的掃描或更新工作。
Windows 檔案總管 在選取的檔案或資料夾上按一下滑鼠右鍵以對該項目執行立即的「完整掃描」。您可為掃描選取一個動作：
  • 清除 - 報告及清除偵測到的項目。
  • 繼續 - 報告偵測並繼續掃描。

對您懷疑受到威脅的檔案或資料夾執行立即掃描。

當您啟動掃描後，系統會直接呼叫已啟用所有掃描設定的按指定掃描程式。選取動作選項。您無法自訂任何其他掃描設定。
系統匣 在 VirusScan Enterprise 盾形圖示上按一下滑鼠右鍵以顯示功能表項目。
  • 開啟「VirusScan 主控台」。
  • 停用或啟用常駐掃描程式。
  • 開啟常駐掃描程式內容。
  • 檢視常駐掃描統計資料或訊息。
  • 建立一次可設定的按指定掃描。
  • 執行立即更新工作。
  • 開啟「關於」對話方塊。


系統匣圖示的運作方式

VirusScan Enterprise 一旦安裝後，Windows 系統匣中即會出現盾形圖示 (若您在安裝過程中設定此功能)。

請注意下列事項：
  • 常駐掃描程式偵測到存取保護違規時會變更圖示。除非重新設定，否則環繞圖示的紅色外框會顯示 30 分鐘。如需更多資訊，請參閱「保護系統的存取點」章節裡的「存取違規及 VirusScan Enterprise 回應方式」。
  • 在圖示上連按兩下以顯示這些功能表選項：
    • VirusScan 主控台 — 開啟「VirusScan 主控台」。
    • 停用常駐掃描 — 可切換停用與啟用。
      註: 存取保護、緩衝區溢位保護及指令碼掃描功能均使用常駐掃描程式。如果停用常駐掃描程式，則無法防止存取違規、緩衝區溢位及執行無用的指令碼。
    • 常駐掃描內容 — 開啟常駐掃描程式內容頁面。
    • 常駐掃描統計資料 — 顯示常駐掃描程式統計資料，您可在此開啟或停用常駐掃描程式，以及開啟常駐掃描程式內容頁面。
    • 常駐掃描訊息 — 顯示常駐掃描程式訊息，您可以對此清單中的項目執行動作。
    • 按指定掃描 — 開啟按指定掃描程式內容頁面以新增未儲存的工作，您可以在此建立一次的按指定掃描工作。
    • 立即更新 — 立刻執行「自動更新」工作。
    • 關於 VirusScan Enterprise — 顯示產品與授權的相關資訊，以及安裝的掃描引擎、偵測定義檔案、額外驅動程式 (extra.dat) 及修復程式的版本相關資訊。


開始功能表以及此功能表與 VirusScan Enterprise 一起運作的方式

從 Windows 的「開始」功能表選取「程式集」|「McAfee」以存取下列功能表項目：
  • VirusScan 主控台 — 開啟「VirusScan 主控台」。
  • 常駐掃描 — 開啟常駐掃描內容頁面。
  • 按指定掃描 — 開啟按指定掃描內容頁面，您可以在此設定及執行一次未儲存的「完整掃描」。


命令列與使用命令列設定 VirusScan Enterprise

使用命令列以從「命令提示字元」執行動作。請參閱「命令列選項」以瞭解更多資訊。


新增及排除掃描項目

設定偵測設定時，每個 VirusScan Enterprise 掃描程式允許您微調掃描的檔案類型清單。


指定掃描項目

將掃描項目新增至預設清單或建立要掃描的特定副檔名清單，以微調您的掃描功能。

選項定義

選項 定義
要掃描的檔案類型
  • 預設 + 其他的檔案類型 — 指定其他檔案副檔名，以及是否要同時掃描所有檔案中的巨集。掃描程式最多可容納 1,000 個其他檔案類型副檔名。
  • 僅指定的檔案類型 — 建立要掃描的特定副檔名清單。掃描程式最多可容納 1,000 個其他檔案類型副檔名。


指定排除項目

指定不進行掃描作業的檔案、資料夾及磁碟機。您也可以移除先前指定的任何排除項目。

選項定義

選項 定義
不掃描的對象 選取排除的類型。
  • 依模式排除 — 指定模式及是否要包含子資料夾。
  • 依檔案類型排除 — 指定檔案類型。
  • 依檔案時間長度排除 — 指定存取類型及時間長度下限 (天數)。
  • 受 Windows 檔案保護的保護 — 排除具有「Windows 保護檔案」狀態的檔案。


使用萬用字元指定掃描項目

當使用萬用字元來指定或排除掃描項目時，有以下限制：

  • 問號 (?) 是用來排除單一字元的有效萬用字元；星號 (*) 是用來排除多個字元的有效萬用字元。
  • 萬用字元位在路徑中的反斜線 (\) 前。例如：C:\ABC\*\XYZ 會查找到 C:\ABC\DEF\XYZ。

  • 如果字元數與檔案或資料夾名稱的長度相符，則會套用包含問號 (?) 字元的排除項目。例如：排除 W?? 將排除 WWW，但不會排除 WW 或 WWWW。

  • 此語法可延伸為包含雙星號 (**)，意即「零或多個包含反斜線的任何字元」。這可進行多重層次排除。例如：C:\ABC\**\XYZ 會查找到 C:\ABC\DEF\XYZ 及 C:\ABC\DEF\DEF\XYZ 等。


排定工作

您可以排程按指定、「自動更新」及鏡像工作，以在特定的日期、時間或間隔執行。


設定工作排程

將工作設定在指定時間或間隔執行。

註: 您必須具有系統管理員權限，才能排程工作。系統管理員權限可提供使用者排程工作登錄機碼的寫入存取權限。

若要排程工作，請在工作的內容對話方塊中按一下「排程」按鈕。

索引標籤說明

索引標籤 說明
工作
  • 啟用排程的工作以在指定時間執行。
  • 如果工作執行了指定的小時及分鐘，則停止執行。
  • 指定使用者帳戶設定；使用者名稱、網域和密碼。
排程

指定排程頻率與相關設定。


設定命令列選項

您可從命令列安裝、設定及執行 VirusScan Enterprise。《VirusScan Enterprise 安裝指南》中有安裝選項的說明。本章節說明執行按指定掃描與更新工作的選項。


設定按指定掃描命令列選項

按指定掃描程式會使用 SCAN32.EXE 來偵測威脅。

除了內容與內容值不得分開之外，SCAN32 語法的元素不須有任何特定順序。此語法包含：
  • 檔名 — 執行檔的名稱：SCAN32.EXE。
  • 選項 — 每個前面是正斜線 (/) 字元的選項都不區分大小寫。
例如，SCAN32 PROPERTY=VALUE [,VALUE] [/選項]。

按指定掃描選項定義

命令列選項 | 定義
ALL | 掃描目標資料夾中的所有檔案。
ALLOLE | 掃描預設檔案與所有 Microsoft Office 文件。
ALWAYSEXIT | 強制結束按指定掃描 (就算掃描已完成但發生錯誤/失敗)。
APPLYNVP | 掃描「無用程式原則」中定義的潛在無用程式。
ARCHIVE | 掃描保存檔，例如 .ZIP、.CAP、.LZH 及 .UUE 檔案。
AUTOEXIT | 完成非互動掃描後，結束按指定掃描程式。
CLEAN | 找到潛在無用程式後，清除偵測到的目標檔案。
CLEANA | 找到無用程式後，清除偵測到的檔案。
CONTINUE | 偵測到潛在無用程式後，繼續掃描。
CONTINUE2 | 偵測到潛在無用程式且主要動作失敗後，繼續掃描。
CONTINUEA | 偵測到無用程式後，繼續掃描。
CONTINUEA2 | 偵測到無用程式且主要動作失敗後，繼續掃描。
DEFEXT | 將指定為參數的檔案副檔名新增至掃描包含的選定檔案類型清單中。
DELETE | 找到潛在無用程式後，刪除偵測到的檔案。
DELETE2 | 找到潛在無用程式且主要動作失敗後，刪除偵測到的檔案。
DELETEA | 偵測到無用程式後，刪除檔案。
DELETEA2 | 偵測到潛在無用程式且主要動作失敗後，刪除檔案。
EDIT | 顯示「掃描內容」對話方塊。
EXT | 使用新增的檔案副檔名 (做為此引數後面的參數)，取代掃描包含之選定檔案類型清單的副檔名。
LOG | 將偵測報告記錄至先前指定的記錄檔。
LOGFORMAT <值> | 使用記錄檔的指定格式。有效的值為 ANSI、UTF8 或 UTF16。
LOGSETTINGS | 記錄掃描的組態設定。
LOGSUMMARY | 記錄掃描結果摘要。
LOGUSER | 記錄執行掃描的使用者識別資訊。
MHEUR | 啟用巨集威脅啟發式偵測。
MIME | 偵測以 MIME (多用途網際網路郵件延伸標準) 編碼之檔案的潛在無用程式。
NOESTIMATE | 在啟動檔案掃描前，不計算掃描大小。不顯示進度列。
PHEUR | 啟用非巨集威脅啟發式偵測。
PRIORITY | 設定與其他 CPU 處理程序相關的掃描優先順序。須有其他的數值參數。數值 1 會指派優先順序給所有其他的 CPU 處理程序。數值 5 會指派最高優先順序給掃描。
PROMPT | 偵測到潛在無用程式後，提示使用者執行動作。
PROMPT2 | 偵測到潛在無用程式且主要動作失敗後，提示使用者執行動作。
PROMPTA | 偵測到無用程式後，提示使用者執行動作。
PROMPTA | 偵測到無用程式後，提示使用者執行動作。
PROMPTA | 偵測到無用程式後，提示使用者執行動作。
PROMPTA | 偵測到無用程式後，提示使用者執行動作。
PROMPTA2 | 偵測到無用程式且主要動作失敗後，提示使用者執行動作。
RPTSIZE | 設定警告記錄的大小 (以 MB 為單位)。
START | 執行掃描。不顯示內容對話方塊。
TASK | 啟動在 VirusScan 主控台中指定的指定掃描程式工作。須有其他參數以指定特定的工作識別碼，如以下登錄的記錄項目：hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.
UINONE | 啟動掃描程式時，不顯示使用者介面對話方塊。


設定更新工作命令列選項

VirusScan Enterprise 使用 MCUPDATE.EXE 執行更新工作。

除了內容與內容值不得分開以外，MCUPDATE 語法的元素不須有任何特定順序。此語法包含：
  • 檔名 — 執行檔的名稱：MCUPDATE.EXE。
  • 選項 — 每個前面是正斜線 (/) 字元的選項都不區分大小寫。
例如，MCUPDATE [/<類型> [/TASK <guid>]] [/選項]。

/TASK 是選擇性的子句。然而若您使用了它，您也必須指定一個更新工作識別碼 (guid)。您選取的工作識別碼必須用於更新或復原 DAT 工作。請勿選取掃描識別碼。如果您沒有指定工作識別碼，則系統會使用預設的更新工作。工作識別碼位於：hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

/OPTION 是選擇性的子句。若要執行無訊息更新工作，請使用 /QUIET。
註: 使用復原 DAT 工作時，不支援 /QUIET 選項。此範例將執行一項無訊息更新工作：MCUPDATE [/UPDATE] [/QUIET]。

更新工作選項定義

命令列選項 | 定義
ROLLBACKDATS | 將目前的 DAT 檔案復原為上一個備份的版本。
UPDATE | 執行 DAT 檔案、掃描引擎、產品或 extra.dat 的更新。
/TASK | 啟動在「VirusScan 主控台」中指定的「自動更新」或「復原 DAT」工作。須有其他參數才能將工作識別碼指定成下方登錄中的記錄項目： hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | 無訊息執行工作。


連接至遠端系統

您可以連接至已安裝 VirusScan Enterprise 的遠端系統，以在遠端系統上執行作業，例如修改、排定掃描、更新工作或啟用及停用常駐掃描程式。
註: 若您不具有連接至遠端系統的系統管理員權限，則會收到「使用者權限不足，存取被拒」的錯誤訊息。

當您啟動「VirusScan 遠端主控台」時，連接的系統名稱會出現在主控台的標題列中。如果您尚未與網路中的其他系統連線，則標題列不會顯示本機系統的名稱。從遠端主控台開啟任意工作的內容對話方塊時，系統名稱會顯示在內容對話方塊的標題列中。

您可以開啟多個遠端主控台。當您關閉「連線至遠端電腦」對話方塊時，與遠端系統的連線也會關閉。


安裝 VirusScan Enterprise 之後存取遠端系統

若要在安裝 VirusScan Enterprise 之後連接至遠端系統。

工作

從「VirusScan 主控台」的「工具」功能表中選取「開啟遠端主控台」。

  1. 在「連線至電腦」下，輸入要管理的系統名稱，再從清單中選取系統，或按一下「瀏覽」以在網路上尋找該系統。
    註: 當設定用於遠端工作的檔案或資料夾之路徑名稱時，若要使用環境變數，請確定這些環境變數存在遠端系統上。「VirusScan 主控台」無法驗證遠端系統上的環境變數。
  2. 按一下「確定」以嘗試連線至目標系統。 當您連接至遠端系統時：
    • 標題列會改變以顯示系統的名稱。
    • 主控台會讀取遠端系統的登錄及顯示遠端系統的工作。您可以新增、刪除或重新設定遠端系統的工作。


提交威脅樣本以供分析

如果發現目前 DAT 檔案未偵測到的潛在威脅，您可以將樣本透過 WebImmune 提交給 McAfee AVERT Labs。AVERT Labs 會分析此樣本並考慮將其新增至 DAT 檔案中。

如果掃描程式偵測到您認為不應偵測的某些項目，則您也可以透過 WebImmune 將樣本提交給 AVERT Labs。Avert 會分析此樣本並考慮將其自 DAT 檔案中排除。

您可以直接存取網站、使用電子郵件或一般標準郵件，透過 WebImmune 將樣本提交給 Avert Labs。

WebImmune

從「VirusScan 主控台」選取「說明」|「提交樣本」以存取網站。

網站的位址為：https://www.webimmune.net/default.asp.

  1. 登入或建立免費帳戶。
  2. 直接將檔案上傳至 AVERT Labs 的自動系統，以供檢視。如果需要其他研究，系統會將項目轉交給 AVERT Labs 分析人員。

電子郵件

直接傳送電子郵件至 AVERT Labs 的自動系統，以供檢視。如果需要其他研究，系統會將項目轉交給 AVERT Labs 分析人員。

全球性的電子郵件地址為 virus_research@avertlabs.com。
註: 從 WebImmune 網站取得其他地區的地址。

標準郵件

從 WebImmune 網站取得地址。
註: 這是最不建議的方式，且檢視樣本花費的時間週期也最長。


存取 Avert Labs 威脅程式庫

若要從「VirusScan 主控台」存取「McAfee Avert Labs 威脅程式庫」，請從「說明」功能表中選取「McAfee Avert Labs 威脅程式庫」。


疑難排解

本章節包含 VirusScan Enterprise 產品的疑難排解資訊。


修復產品安裝

使用 VirusScan Enterprise 修復安裝公用程式來還原程式的預設安裝設定，及/或重新安裝所有程式檔案。

若要取用「修復安裝」公用程式，請在「VirusScan 主控台」中選取「說明」|「修復安裝」。
註: 從「ePolicy Orchestrator 主控台」無法使用此功能。

選項定義

選項 | 定義
將所有設定還原為安裝預設值 | 還原 VirusScan Enterprise 預設安裝設定。 注意: 自訂的設定值可能會遺失。
重新安裝所有程式檔 | 重新安裝 VirusScan Enterprise 程式檔。 注意: Hotfix、修復程式及/或 Service Pack 可能會被覆寫。


常見問題集

本章節以常見問題集形式提供疑難排解資訊。

安裝

  • 問題：我使用「無訊息安裝」方法來安裝軟體，但是 Windows 系統匣未顯示 VirusScan Enterprise 圖示。

    解答：重新啟動系統後，盾形圖示就會顯示於系統匣。但是，即使沒有圖示，VirusScan Enterprise 仍會執行並會保護您的系統。檢查下列登錄機碼即可確認：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • 問題：為什麼網路上的某些使用者可以擁有自己的設定值，而其他使用者卻不行？

    解答：使用者介面可能經系統管理員設定過，因而有密碼保護工作。如果是這樣的話，使用者便不能更改設定。此外，不同的 Microsoft Windows 作業系統具有不同的使用者權限。請參考 Microsoft Windows 文件，以取得更多有關使用者權限的資訊。

潛在無用程式

  • 問題：我懷疑有潛在無用程式，但是 VirusScan Enterprise 並未偵測到。

    解答：您可以在測試版 DAT 檔案正式發佈之前，從下列網站下載仍在測試中的最新檔案：http://vil.nai.com/vil/virus-4d.asp。

遭封鎖的程式

  • 問題：安裝 VirusScan Enterprise 之後，有一個程式無法運作。

    解答：該程式可能遭到存取保護規則封鎖。
    1. 檢視存取保護記錄檔，以判斷該程式是否遭到規則封鎖。
    2. 如果您在記錄中發現該程式，可將其輸入為規則的排除項目，或停用規則。請參閱「保護系統的存取點」以瞭解更多資訊。

Cookie 偵測

  • 問題：在按指定掃描活動記錄中檢視 Cookie 偵測時，我發現每個偵測的檔名偵測始終為 00000000.ie。當其他程式都指派個別或累加檔名給各個 Cookie 偵測時，VirusScan Enterprise 為何會指派相同的檔名給每個按指定掃描 Cookie 偵測？

    解答： VirusScan Enterprise 會指派相同的檔名給每個 Cookie 偵測，是由於按指定掃描程式偵測 Cookie 及對 Cookie 執行的動作所致。此行為僅適用於按指定掃描偵測到的 Cookie。一個 Cookie 檔案可能包含多個 Cookie。掃描引擎會將 Cookie 檔案視為保存檔，並從檔案的起點指派一個位移值 (以 0 起頭) 。由於掃描程式會先使用掃描引擎來偵測每個受偵測的 Cookie，並在對其執行動作後才進行掃描，因此每個偵測的值都以 0 起始。最後，每個偵測都會被指派 00000000.ie 的檔名。其他產品會偵測所有 Cookie、指派個別或累加檔名，然後對每個偵測執行動作。

一般

  • 問題：系統匣中的 VirusScan Enterprise 圖示顯示為已停用。

    解答：如果有紅圈與紅線覆蓋 VirusScan Enterprise 圖示，表示「常駐掃描」已停用。以下為最常見的原因與解決方案。如果這些方案都無法解決您的問題，請連絡「技術支援」。
    1. 確認「常駐掃描」已啟用。在系統匣的 VirusScan Enterprise 圖示上按一下滑鼠右鍵。如果常駐掃描程式已停用，請按一下「啟用常駐掃描」。
    2. 確定 McShield 服務正在執行。
      • 以手動方式從「服務」控制台啟動服務。
      • 選取「開始」|「執行」，然後輸入「Net Start McShield 」。
      • 從「服務」控制台將服務設定為自動啟動。

  • 問題：錯誤訊息顯示我無法下載 CATALOG.Z。

    解答：造成此錯誤的原因有很多。以下建議可協助您判斷問題的來源：
    • 如果您使用 McAfee 預設的下載網站來進行更新，則可以透過網頁瀏覽器來判斷能否下載 CATALOG.Z 檔案。請嘗試從以下網站下載檔案：http://update.nai.com/Products/CommonUpdater/catalog.z.
    • 如果您無法下載檔案，但是可以看見檔案 (換言之，瀏覽器不允許您下載該檔案)，則您的 Proxy 有問題，請連絡網路管理員。
    • 如果您可以下載檔案，則 VirusScan Enterprise 應該也可以下載檔案。若您有 VirusScan Enterprise 安裝上的問題，請連絡「技術支援」。

  • 問題：HTTP 下載網站的位址為何？

    解答：
    • McAfee 下載網站的位址為：http://www.mcafeesecurity.com/us/downloads/updates/default.asp.
    • 含最新更新的 CATALOG.Z 檔案可由此網站下載：http://update.nai.com/Products/CommonUpdater/catalog.z。

  • 問題：FTP 下載網站的位址為何？

    解答：
    • FTP 下載網站的位址為：ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x.
    • 含最新更新的 CATALOG.Z 檔案可由此站台下載：ftp://ftp.mcafee.com/CommonUpdater/catalog.z.

  • 問題：如果我偵測到潛在無用程式，並已選擇「提示使用者執行動作」，接下來我應選擇何種動作 (「清除」或「刪除」)？

    解答：如果您不確定如何處理偵測到的檔案，通常我們建議您選擇「清除」。常駐掃描程式及按指定掃描程式會在清除或刪除項目前，自動將項目備份到隔離目錄。


存取保護索引標籤

選項定義

設定存取保護規則，並避免停止 McAfee 處理程序。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
存取保護設定
  • 啟用存取保護 — 啟用存取保護功能。
  • 防止 McAfee 服務被停止 — 防止沒有偵錯權限的使用者終止 McAfee 處理程序。

    即使您選取了此選項，具有偵錯程式權限的使用者仍可停止 McAfee 處理程序。

    依預設，Windows XP 與 Windows 2003 作業系統的系統管理員具有偵錯程式權限。從使用者權限中移除偵錯程式權限，讓使用者無法停止 McAfee 處理程序。
存取保護規則

類別 — 選擇類別以顯示該類別的規則。規則可分組為以下類別：

  • 防毒標準保護
  • 防毒最大保護
  • 防病毒發作控制
  • 一般標準保護
  • 一般最大保護
  • 虛擬機器保護
  • 使用者定義的規則

如果您已安裝 AntiSpyware Enterprise Module 8.7，您還會有下列類別：

  • 反間諜軟體標準保護
  • 反間諜軟體最大保護

請參閱「存取保護規則的定義方式」，以取得更多資訊。

封鎖/報告/規則 — 設定規則：

  • 封鎖 — 封鎖「規則詳細資料」中指定的處理程序。選取「封鎖」以啟用規則，或取消選取此選項以停用規則。

    註:

    若要封鎖存取嘗試且不記錄，請選取「封鎖」，但不要選取「報告」。

  • 報告 — 可針對違反存取保護的嘗試提出報告。偵測發生時，資訊會記錄在活動記錄中。
    註:

    若要接受警告，但不要封鎖存取嘗試，請選取「報告」，但不要選取「封鎖」。在不清楚規則會有哪些影響時，這個方法很有用。監視記錄及/或報告一小段時間，以判斷是否要封鎖存取。

  • 規則 — 使用規則以保護您的電腦免於不需要的變更。規則係依類別分組。首先選取類別，然後選取規則。請參閱「設定防毒及一般規則」及「設定使用者定義的規則」，以取得更多資訊。

    新增 — 建立新的使用者定義規則。請參閱「設定使用者定義的規則」，以取得更多資訊。

    編輯 — 變更現有的規則。

    刪除 — 移除現有的使用者定義規則。
    註:

    您只能刪除使用者定義的規則。其他規則可加以編輯或停用，但無法刪除。若要停用規則，請取消選擇「封鎖」及「報告」兩個選項。


其他的警告選項索引標籤

選項定義

設定篩選程式與本機警告選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
嚴重性篩選程式 可供選擇的篩選程式選項包括：
  • 請勿篩選警告 — 傳送全部警告。
  • 隱藏資訊性的警告 — 不會傳送嚴重性小於 1 的資訊性警告。
  • 隱藏資訊性及警告性的警告 — 不會傳送嚴重性小於 2 的資訊性及警告性的警告。
  • 隱藏資訊性、警告性及低嚴重性的警告 — 不會傳送嚴重性小於 3 的資訊性、警告性及低嚴重性警告。
  • 隱藏嚴重警告之外的所有警告— 除了嚴重性大於 4 的警告之外，不會傳送任何警告。
  • 隱藏所有警告 — 不傳送任何警告。
本機警告
  • 記錄到本機應用程式事件記錄 — 將資訊記錄到本機應用程式事件記錄。
  • 使用 SNMP 服務傳送 SNMP 陷阱 — 如果您使用 SNMP，則可以傳送 SNMP 陷阱警告。
註:

本機警告選項不需有 Alert Manager。


警告索引標籤

選項定義

選取要產生警告的元件，並設定已安裝的 Alert Manager。

請參閱《Alert Manager 4.7.1 產品指南》，以取得更多資訊。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
產生警告的元件
  • 常駐掃描 — 當常駐掃描程式偵測到威脅時產生警告。
  • 按指定掃描及排程掃描 — 當按指定掃描工作偵測到威脅時產生警告。
  • 電子郵件掃描 — 當電子郵件掃描程式偵測到威脅時產生警告。
  • AutoUpdate — 當更新工作偵測到威脅時產生警告。
  • 存取保護 — 當存取保護偵測到威脅時產生警告。
Alert Manager 選項
  • 停用警告 — 偵測發生時不要產生警告。
  • 啟用集中式警告 — 偵測發生時使用集中式警告來通知您。
  • 啟用 Alert Manager 警告 — 偵測發生時使用 Alert Manager 警告來通知您。選取此選項並鍵入接收警告的 Alert Manager 伺服器位置路徑。
    • 停用 Active Directory 查閱服務 — 不使用 Active Directory 查閱服務。


報告索引標籤

選項定義

啟用記載以追蹤網路上的活動，並記錄您使用何種設定來偵測及回應掃描程式發現的所有潛在威脅。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
記錄至檔案 | 啟用活動記錄。
記錄檔位置 接受記錄檔的預設位置，或指定新位置。

預設記錄名稱為 AccessProtectionLog.txt。

預設位置為：<磁碟機>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

預設位置可能會視使用的作業系統而有所不同。
記錄檔大小 | 限制記錄檔的大小。接受預設大小 (1 MB) 或設定 1 MB 到 999 MB 的大小。如果記錄檔中的資料超出了設定的檔案大小，則會刪除最舊的 20% 項目，再將新資料附加至該檔案中。
記錄檔格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用此格式。


自動更新工作

設定「自動更新」工作

選項定義

選項 | 定義
記錄檔 | 啟用活動記錄。
格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。
取得較新的偵測定義檔 (如果有的話)

若有可用的較新版本，則下載最新版本的 DAT 檔案。
取得較新的偵測引擎 (如果有的話)

若有較新的引擎及/或 DAT 檔案版本，則下載最新版本。
取得其他可用更新 (Service Pack、升級等)

取得其他更新的最新版本，例如 Service Pack 與產品升級。
輸入要在完成更新後執行的執行檔

指定要在「自動更新」工作執行完畢後啟動的執行檔。指定您要執行的執行檔路徑，或者按一下「瀏覽」尋找該檔案。

例如，您可以啟動網路訊息公用程式，通知系統管理員「自動更新」工作已成功完成。

註: 您指定的程式檔必須由目前登錄的使用者執行。如果目前登錄的使用者沒有存取含程式檔之資料夾的權限，或者目前沒有登錄的使用者，則不會執行該程式。
僅在順利更新後執行

僅在成功更新後啟動執行檔程式。如果更新失敗，則不會執行您指定的程式。
排程

定義此更新工作的排程。

註:

請參閱「排程工作」以取得更多資訊。

我們不建議您將「自動更新」工作與鏡像工作排程在同時間執行。因為這兩個工作皆使用 McAfee Common Framework 服務，同時執行兩者可能會導致衝突。
立即更新

立即執行「自動更新」工作。+


封鎖索引標籤

選項定義

封鎖在共用資料夾中含有潛在威脅或無用程式之檔案的遠端電腦連線。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
傳送訊息 | 偵測到威脅時，傳送指定訊息給網路使用者 — 偵測到威脅時，通知遠端電腦上的網路使用者。
訊息文字

在文字方塊中輸入自訂訊息。遠端電腦必須執行 Windows Messenger 服務才能接收此訊息。
封鎖連線
  • 在共用資料夾中偵測到具有威脅的檔案時封鎖連線 — 當遠端電腦上的任何網路使用者，嘗試在共用資料夾中讀取或寫入有威脅性的檔案時，即封鎖與該使用者的連線。
  • 之後解除封鎖連線 — 在指定的分鐘數過後，便解除對連線的封鎖。請輸入介於 1 和 9999 之間的數字。預設值 = 10 分鐘。
  • 在共用資料夾中偵測到含有潛在無用程式之檔案時封鎖連線 — 當遠端電腦上的任何使用者嘗試將潛在無用程式寫入電腦時，封鎖與該使用者的連線。「常駐掃描統計資料」對話方塊會顯示已封鎖電腦的清單。


報告索引標籤

選項定義

針對所有因特定處理程序堆積或堆疊溢位而執行之程式碼，啟用記錄以在本機上追蹤偵測。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
記錄至檔案 | 啟用活動記錄。
記錄檔位置 接受記錄檔的預設位置，或指定新位置。

預設記錄檔名稱為 BufferOverflowProtectionLog.txt。

預設位置為：<磁碟機>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

預設位置可能會視使用的作業系統而有所不同。
記錄檔大小 | 限制記錄檔的大小。接受預設大小 (1 MB) 或設定 1 MB 到 999 MB 的大小。如果記錄檔中的資料超出了設定的檔案大小，則會刪除最舊的 20% 項目，再將新資料附加至該檔案中。
記錄檔格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。


緩衝區溢位保護索引標籤

選項定義

防止緩衝區溢位弱點在您的電腦上執行任意程式碼。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
緩衝區溢位設定 啟用緩衝區溢位保護 — 啟用緩衝區溢位保護功能，然後選取保護層級。

  • 警告模式 — 偵測到緩衝區溢位時傳送警告。不執行其他動作。

    在不清楚緩衝區溢位的所有影響時，您可以使用此模式。在「警告模式」中使用該功能一小段時間之後，檢視這段時間的記錄檔，以協助判斷是否要變更為「保護模式」。

  • 保護模式 — 在偵測到緩衝區溢位時進行封鎖並終止偵測到的執行緒。

    這也可能會導致應用程式終止。
用戶端系統警告 | 在偵測到緩衝區溢位時顯示訊息對話方塊 — 偵測發生時，顯示「常駐掃描訊息」對話方塊。
緩衝區溢位排除 指定排除資訊：
註:

排除名稱區分大小寫。

  • 處理程序 — 指定擁有執行呼叫之可寫入記憶體的處理程序名稱。

    只輸入處理程序名稱或包含其路徑。

    若只鍵入處理程序名稱，例如 OUTLOOK.EXE，則不管該處理程序的位置在哪，每次執行該處理程序時，它都會被排除。若鍵入包含路徑的處理程序名稱（例如 C:\Program files\OUTLOOK.EXE），則只有從指定路徑執行該處理程序時，它才會被排除。不允許使用萬用字元。

  • 模組 (選用) — 可能的話，鍵入擁有可寫入記憶體的模組名稱。不要求此資訊。
  • API — 指定呼叫的 API。
    註:

    若指定模組，則 API 為必要。


處理程序索引標籤

選項定義

選擇是否為所有處理程序設定一個掃描原則，還是為預設、低風險及高風險處理程序設定不同的掃描原則。

請參閱「決定掃描原則數目」及「決定指派給處理程序的風險」，以取得更多資訊。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
處理程序設定 指定是否要設定一或多個掃描原則：
  • 配置一個將用於所有處理程序的掃描原則— 如果選取此選項，您配置的原則會套用至所有處理程序。
  • 針對高風險、低風險和預設處理程序配置不同的掃描原則 — 您必須先選取此選項，才能針對低風險或高風險處理程序配置原則。++


顯示選項索引標籤

選項定義

設定使用者可以存取的系統匣選項及慣用語言。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
系統匣圖示
  • 顯示系統匣圖示以及所有功能表選項 — 允許使用者查看系統匣功能表上的所有選項。
  • 顯示系統匣圖示以及最少的功能表選項 — 除了「關於 VirusScan Enterprise」及「常駐掃描統計資料」之外，隱藏系統匣功能表上所有選項。
  • 不要顯示系統匣圖示 — 隱藏所有使用者的系統匣圖示。
主控台選項
註: 此選項僅能透過 ePolicy Orchestrator 使用。

  • 允許此系統建立到其他系統的遠端主控台連線 — 連線至遠端電腦。

    您必須有系統管理員權限並執行「遠端登錄服務」。

  • 在用戶端主控台中顯示受管理的工作 — 在用戶端電腦的「主控台」上顯示 ePolicy Orchestrator 工作。
  • 停用預設的 [自動更新] 工作排程 — 停用預設更新工作的排程。

    當執行原則時會停用排程。「工作管理員」服務必須為執行中，才能停用工作的排程。

  • 啟用開頭顯示畫面 — 在啟動「主控台」或 SHSTAT.EXE 時，會顯示 VirusScan Enterprise 8.7i 開頭顯示畫面。
    註:

    此選項僅能透過 ePolicy Orchestrator 使用。

主控台語言設定 指定主控台文字的語言：
  • 系統會自動選取語言，您亦可選取特定的語言。
    註:

    當您「從 VirusScan 主控台」變更慣用語言時，畫面會提示您重新啟動系統。如果您按一下「是」，則會套用語言變更。

    當您從「ePolicy Orchestrator 主控台」變更慣用語言時，系統會在第一次執行原則時將語言變更套用至使用者主控台。

    對於受 ePolicy Orchestrator 管理的系統來說，使用者在用戶端系統所做的變更會影響主控台介面，但記錄檔則會以在 ePolicy Orchestrator 設定中指定的語言來記錄動作。主控台語言變更會在主控台重新啟動後套用。


動作索引標籤

選項定義

設定當偵測到威脅或潛在無用程式時要執行的動作。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
找到威脅時 先執行此動作 — 選取當偵測到威脅時想要掃描程式執行的第一個動作。預設值 = 清除附件。
  • 清除附件 — 掃描程式會嘗試從附件中移除威脅。
  • 動作提示 — 偵測到威脅時，提示使用者執行動作。選取這個選項，然後在「提示對話方塊中允許執行的動作」下指定使用者可以執行的動作。
此選項沒有允許執行的次要動作。
  • 繼續掃描 — 偵測到具有威脅的附件時繼續掃描。
此選項沒有允許執行的次要動作。
  • 將附件移到資料夾 — 掃描程式會將具有潛在威脅的附件移至指定的資料夾。
  • 刪除附件 — 掃描程式會在偵測到具有潛在威脅的附件時，立即刪除該附件。對於 Microsoft Outlook 來說，會刪除電子郵件。對於 Lotus Notes 來說，會刪除附件。
  • 刪除郵件 (僅適用於 Outlook Scan) — 掃描程式會刪除具有潛在威脅的郵件。如果選取這個選項以作為主要動作，便不允許執行次要動作。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 將附件移到資料夾。
  • 動作提示 — 偵測到威脅時，提示使用者執行動作。選取這個選項，然後在「提示對話方塊中允許執行的動作」下指定使用者可以執行的動作。
  • 繼續掃描 — 偵測到具有威脅的附件時繼續掃描。
  • 將附件移到資料夾 — 掃描程式會將具有潛在威脅的附件移至指定的資料夾。
  • 刪除附件 — 掃描程式會在偵測到具有潛在威脅的附件時，立即刪除該附件。對於 Microsoft Outlook 來說，會刪除電子郵件。對於 Lotus Notes 來說，會刪除附件。
  • 刪除郵件 (僅適用於 Outlook Scan) — 掃描程式會刪除具有潛在威脅的郵件。
找到無用程式時 先執行此動作 — 選取當偵測到潛在無用程式時，您想要讓掃描程式執行的第一個動作。預設值 = 清除附件。
  • 清除附件 — 掃描程式會嘗試從附件中移除威脅。
  • 動作提示 — 偵測到威脅時，提示使用者執行動作。選取這個選項，然後在「提示對話方塊中允許執行的動作」下指定使用者可以執行的動作。
此選項沒有允許執行的次要動作。
  • 繼續掃描 — 偵測到具有威脅的附件時繼續掃描。
此選項沒有允許執行的次要動作。
  • 將附件移到資料夾 — 掃描程式會將具有潛在威脅的附件移至指定的資料夾。
  • 刪除附件 — 掃描程式會在偵測到具有潛在威脅的附件時，立即刪除該附件。對於 Microsoft Outlook 來說，會刪除電子郵件。對於 Lotus Notes 來說，會刪除附件。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 將附件移到資料夾。
  • 動作提示 — 偵測到威脅時，提示使用者執行動作。選取這個選項，然後在「提示對話方塊中允許執行的動作」下指定使用者可以執行的動作。
此選項沒有允許執行的次要動作。
  • 繼續掃描 — 偵測到具有威脅的附件時繼續掃描。
此選項沒有允許執行的次要動作。
  • 將附件移到資料夾 — 掃描程式會將具有潛在威脅的附件移至指定的資料夾。
  • 刪除附件 — 掃描程式會在偵測到具有潛在威脅的附件時，立即刪除該附件。對於 Microsoft Outlook 來說，會刪除電子郵件。對於 Lotus Notes 來說，會刪除附件。
移動到資料夾 指定隔離資料夾的位置。隔離資料夾必須位於硬碟上，且此位置應為本機磁碟機。因為隔離資料夾會依據使用 Microsoft Outlook 或 Lotus Notes 而有差異，所以它不得位於軟碟機或 CD 光碟機的預設位置。
  • 對於 Microsoft Outlook 來說，隔離資料夾位於 Microsoft Outlook 信箱中。
  • 對於 Lotus Notes 來說，隔離資料夾位於檔案系統中。
提示對話方塊中允許執行的動作 當使用者收到動作提示時，選取可執行的動作。
註:

在執行這些動作前，會先採取預設的「拒絕存取」動作。

  • 清除附件
  • 刪除附件
  • 移動附件
  • 刪除郵件 (僅適用於 Microsoft Outlook)
提示使用者執行動作時，會接收到您在「警告」索引標籤上指定的訊息。


警告索引標籤

選項定義

設定傳送電子郵件掃描程式的警告設定。

選項 | 定義
設定適用於 | 從下拉式清單選取「工作站」或「伺服器」。 註: 此選項僅能透過 ePolicy Orchestrator 使用。
以電子郵件傳送給使用者的警告 | 傳送警告郵件給使用者 — 當偵測到具有威脅性的電子郵件時，通知其他使用者。
動作提示訊息 | 指定當出現動作提示時，顯示給使用者的訊息。必須在「動作」索引標籤上選取「動作提示」選項。接受預設訊息，或輸入新訊息。預設訊息 = McAfee VirusScan Enterprise 電子郵件掃描程式：警告！


掃描項目索引標籤

選項定義

設定按指定電子郵件掃描程式的偵測選項。

選項 | 定義
要掃描的訊息
  • 所有反白的項目 — 掃描選取的電子郵件訊息及資料夾。
  • 「收件匣」資料夾中的所有郵件 — 掃描目前在「收件匣」資料夾中所有郵件與子資料夾。
    • 僅掃描未讀取郵件 — 掃描目前「收件匣」資料夾中所有未讀取的郵件與子資料夾。
要掃描的附件
  • 所有檔案類型 — 掃描所有檔案類型而不考慮副檔名。
  • 預設 + 其他的檔案類型 — 掃描預設副檔名清單及您所指定的新增內容清單。預設清單由目前的 DAT 檔案所定義。選取「預設 + 其他的檔案類型」，然後在文字方塊中輸入由空格分隔的副檔名。

    亦掃描所有附件中的巨集 — 如果您已選取「預設 + 其他的檔案類型」，也可以搜尋所有檔案中的已知巨集威脅。

  • 指定的檔案類型 — 針對使用者指定要掃描的副檔名來建立清單。您也可以移除先前新增的任何副檔名。

    選取「指定的檔案類型」，然後在文字方塊中輸入由空格分隔的副檔名。
啟發式
  • 尋找未知的程式威脅和特洛伊木馬程式 — 使用啟發式掃描來偵測具有類似惡意軟體之程式碼的執行檔。
  • 尋找未知的巨集威脅 — 使用啟發式掃描來偵測未知的巨集病毒。
  • 尋找具有多個副檔名的附件 — 將具有多個副檔名的附件視為威脅。

    選取此選項時，會顯示「電子郵件掃描警告」對話方塊。按一下「確定」以確認您的選項。
壓縮檔
  • 對保存檔內部進行掃描 — 檢查封存 (壓縮) 檔與其內容。

    掃描壓縮檔雖然可以提供更好的保護，但卻會增加執行掃描所需的時間。

  • 對 MIME 已編碼檔案進行解碼 — 偵測、解碼及掃描「多用途網際網路郵件延伸標準 (MIME)」編碼檔案。
無用程式偵測 偵測無用程式 — 啟用傳送電子郵件掃描程式來偵測潛在無用程式。電子郵件掃描程式會使用您在「無用程式原則」中設定的資訊，來偵測潛在無用程式。

請參閱「限制潛在無用程式」以取得更多資訊。
電子郵件本文 (僅適用於 Microsoft Outlook) | 掃描電子郵件本文 — 掃描 Microsoft Outlook 電子郵件的本文。


報告索引標籤

選項定義

啟用記錄以追蹤網路上的活動，並記錄您使用何種設定來偵測及回應掃描程式發現的所有潛在威脅。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
記錄至檔案 | 啟用活動記錄。
記錄檔位置 接受記錄檔的預設位置，或指定新位置。

傳送電子郵件記錄的預設記錄名稱為 EmailOnDeliveryLog.txt。

按指定電子郵件記錄的預設記錄名稱為 EmailOnDemandLog.txt。

預設位置為：<磁碟機>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

預設位置可能會視使用的作業系統而有所不同。
記錄檔大小 | 限制記錄檔的大小。接受預設大小 (1 MB) 或設定 1 MB 到 999 MB 的大小。如果記錄檔中的資料超出了設定的檔案大小，則會刪除最舊的 20% 項目，再將新資料附加至該檔案中。
記錄檔格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。
掃描活動之外的其他記錄事項
  • 工作階段設定 — 將每一個掃描工作階段的內容記錄到記錄檔中。
  • 工作階段摘要 — 將每一個掃描工作階段期間之掃描程式的動作摘要，記錄到記錄檔中。摘要資訊包含已掃描的檔案數目、偵測的數目及類型、已清除或已刪除的檔案數目及其他資訊。
  • 無法掃描已加密檔案 — 記錄掃描程式無法掃描的已加密檔案名稱。
  • 使用者名稱 — 記錄在將記錄項目記錄到記錄檔時登入電腦的使用者名稱。


掃描項目索引標籤

選項定義

設定電子郵件掃描程式的偵測選項。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
電子郵件掃描 啟用傳送電子郵件掃描。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
要掃描的附件
  • 所有檔案類型 — 掃描所有檔案類型而不考慮副檔名。
  • 預設 + 其他的檔案類型 — 掃描預設副檔名清單及您所指定的新增內容清單。預設清單由目前的 DAT 檔案所定義。選取「預設 + 其他的檔案類型」，然後在文字方塊中輸入由空格分隔的副檔名。

    亦掃描所有附件中的巨集 — 如果您已選取「預設 + 其他的檔案類型」，也可以搜尋所有檔案中的已知巨集威脅。

  • 指定的檔案類型 — 針對使用者指定要掃描的副檔名來建立清單。您也可以移除先前新增的任何副檔名。

    選取「指定的檔案類型」，然後在文字方塊中輸入由空格分隔的副檔名。
啟發式
  • 尋找未知的程式威脅和特洛伊木馬程式 — 使用啟發式掃描來偵測具有類似惡意軟體之程式碼的執行檔。
  • 尋找未知的巨集威脅 — 使用啟發式掃描來偵測未知的巨集病毒。
  • 尋找具有多個副檔名的附件 — 將具有多個副檔名的附件視為威脅。

    選取此選項時，會顯示「電子郵件掃描警告」對話方塊。按一下「確定」以確認您的選項。
壓縮檔
  • 對保存檔內部進行掃描 — 檢查封存 (壓縮) 檔與其內容。

    掃描壓縮檔雖然可以提供更好的保護，但卻會增加執行掃描所需的時間。

  • 對 MIME 已編碼檔案進行解碼 — 偵測、解碼及掃描「多用途網際網路郵件延伸標準 (MIME)」編碼檔案。
無用程式偵測 偵測無用程式 — 啟用傳送電子郵件掃描程式來偵測潛在無用程式。電子郵件掃描程式會使用您在「無用程式原則」中設定的資訊，來偵測潛在無用程式。

請參閱「限制潛在無用程式」以取得更多資訊。
電子郵件本文 (僅適用於 Microsoft Outlook) | 掃描電子郵件本文 — 掃描 Microsoft Outlook 電子郵件的本文。
適用於可疑檔案的啟發式網路檢查
設定在判定偵測樣本是否為惡意軟體時要使用的敏感度層級。除了「已停用」之外的所有層級，樣本指紋或「雜湊」都會提交給 Avert Labs 以判定這些樣本是否為惡意軟體。好處是一旦 AVERT Labs一發佈更新，您不需要等待下一個 DAT 版本即可使用偵測。您選擇的敏感度層級越高，偵測到的惡意軟體數目也越多。不過，越多偵測發生，也代表發生誤報的機會越大。選取以下的敏感度層級：

  • 已停用 — 不會將指紋或任何資料提交給 Avert Labs 判定是否為惡意軟體。

  • 非常低 — 偵測數及誤報的機會與一般 DAT 相同。當 Avert Labs 發佈偵測時就可在 VirusScan Enterprise 使用偵測，不需要等到下次 DAT 更新。

  • 低 — 此層級的定義介於「非常低」與「中」之間。

  • 中 — 當受惡意軟體侵擾的一般風險大於誤報的風險時，使用此層級。Avert Labs 的專利啟發式檢查會偵測出可能的惡意軟體。不過，當偵測較罕見的檔案時，可能會有誤報的風險。經 Avert Labs 檢驗，使用此設定的偵測不會對常見的應用程式及作業系統檔案產生誤報。

  • 高 — 此層級的定義介於「中」與「非常高」之間。

  • 非常高 — 建議您只針對電子郵件，或掃描不支援執行程式或作業系統的磁碟區與目錄時，使用此層級。使用此層級找到的偵測皆被推測為惡意軟體，但尚未經過完整測試來確認是否為誤報。


一般索引標籤

選項定義

設定一般常駐掃描選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
掃描 指定一般掃描項目：
  • 啟動磁區 — 掃描啟動磁區。
  • 在關機期間掃描軟碟機 — 在電腦關機期間掃描軟碟機。

  • 啟用的處理程序 — McAfee 常駐 McShield 服務會掃描所有執行中的處理程序。
啟用常駐掃描 指定啟用掃描的時間：
  • 啟動系統時啟用常駐掃描 — 每次啟動電腦時都啟用常駐掃描程式。
  • 執行原則時啟用常駐掃描 — 每次執行原則時都啟用常駐掃描程式。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
掃描時間上限 最大封存掃描時間 — 指定封存掃描時間上限，以秒為單位。預設值 = 15 秒。您選取的封存掃描時間必須少於為掃描所有檔案而選取的時間。
  • 套用掃描時間上限至所有檔案 — 定義掃描時間上限，然後套用至所有檔案。
  • 掃描時間上限 — 指定所有檔案的掃描時間上限 (以秒為單位)。預設值 = 45 秒。
註: 如果掃描超過時間限制，掃描將會完全停止並記錄訊息。如果掃描無法完全停止，則會終止並在下一次掃描時重新啟動。
Cookie
註: 此選項只會在安裝 AntiSpyware Enterprise Module 8.7 後才可以使用。

掃描 Cookie 檔案 — 啟用 Cookie 檔案的掃描。


處理程序索引標籤

步驟 1 的選項定義

指定定義為高風險的處理程序。這分為兩個步驟。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
處理程序設定

開啟「常駐預設處理程序原則」並選取：

  • 針對高風險、低風險及預設處理程序設定不同的掃描原則
註:

您必須選取此選項，才能針對低風險或高風險處理程序設定原則。

步驟 2 的選項定義

選項 | 定義
設定適用於 | 從下拉式清單選取「工作站」或「伺服器」。 註: 此選項僅能透過 ePolicy Orchestrator 使用。
高風險處理程序 | 開啟「常駐高風險處理程序原則」，來指定您識別為高風險的處理程序。視需要新增及移除處理程序。

請參閱「決定掃描原則數目」及「決定指派給處理程序的風險」，以取得更多資訊。


處理程序索引標籤

步驟 1 的選項定義

指定定義為低風險的處理程序。這分為兩個步驟。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
處理程序設定

開啟「常駐預設處理程序原則」並選取：

  • 針對高風險、低風險及預設處理程序設定不同的掃描原則
註:

您必須選取此選項，才能針對低風險或高風險處理程序設定原則。

步驟 2 的選項定義

選項 | 定義
設定適用於 | 從下拉式清單選取「工作站」或「伺服器」。 註: 此選項僅能透過 ePolicy Orchestrator 使用。
低風險處理程序 | 開啟「常駐低風險處理程序原則」，來指定您識別為低風險的處理程序。視需要新增及移除處理程序。

請參閱「決定掃描原則數目」及「決定指派給處理程序的風險」，以取得更多資訊。


訊息索引標籤

選項定義

針對本機使用者及不具有系統管理權限的使用者設定訊息選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
使用者訊息 指定本機使用者接收的訊息。
  • 偵測到威脅時顯示訊息對話方塊，並在訊息中顯示指定文字 — 偵測發生時，向本機使用者顯示「常駐掃描訊息」對話方塊。

  • 在偵測到 Cookie 時顯示警告 — 偵測到 Cookie 時傳送警告。這包含產生 ePolicy Orchestrator 警告、將訊息傳送至「常駐掃描訊息」對話方塊、如果您在「報告」索引標籤中啟用活動記錄，則會在活動記錄中記錄偵測內容並在掃描統計資料中計算偵測數。如果您取消選取此選項，則 ePolicy Orchestrator 就不會產生警告，但如果您在「報告」索引標籤中啟用了活動記錄，則仍然會在活動記錄中記錄偵測，並在掃描統計資料中計算偵測數。

    註:

    此選項只會在安裝 AntiSpyware Enterprise Module 8.7 後才可以使用。
訊息文字

接受預設訊息，或輸入自訂訊息。預設值 = VirusScan 警告！
使用者可用的動作
  • 從清單中移除訊息 — 允許沒有管理員權限的使用者從清單中刪除訊息。
  • 清除檔案 — 允許沒有管理員權限的使用者清除清單中訊息參考的檔案。
  • 刪除檔案 — 允許沒有管理員權限的使用者刪除清單中訊息參考的檔案。


鏡像工作

設定鏡像工作

VirusScan 主控台 — 選項定義

選項 | 定義
記錄檔 | 啟用活動記錄。
格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。
取得較新的偵測定義檔 (如果有的話)

此選項不適用於鏡像工作。
取得較新的偵測引擎 (如果有的話)

此選項不適用於鏡像工作。
取得其他可用更新 (Service Pack、升級等)

此選項不適用於鏡像工作。
輸入要在完成鏡像後執行的執行檔

指定要在鏡像工作執行完畢後啟動的執行檔。指定您要執行的執行檔路徑，或者按一下「瀏覽」尋找該檔案。

例如，您可以啟動網路訊息公用程式，其可通知系統管理員鏡像工作已成功完成。

註: 您所指定的程式檔必須可以由目前登入的使用者執行。如果目前登入的使用者無權存取包含程式檔的資料夾，或者目前沒有已登入的使用者，就不會執行該程式。
僅在順利鏡像後執行

僅在順利鏡像後才啟動執行檔程式。如果鏡像失敗，則不會執行您指定的程式。
鏡像位置

指定用於鏡像網站的本機系統目的地之路徑。

註: 支援系統變數。
排程

定義此更新工作的排程。

註:

請參閱「排程工作」以取得更多資訊。

我們不建議您將「自動更新」工作與鏡像工作排程在同時間執行。因為這兩個工作皆使用 McAfee Common Framework 服務，同時執行兩者可能會導致衝突。
立即鏡像

立即執行鏡像工作。


Notes 掃描程式設定索引標籤

選項定義

設定傳送電子郵件掃描程式的 Lotus Notes 設定。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
伺服器掃描設定
  • 掃描所有伺服器資料庫 — 掃描所有伺服器資料庫，查找潛在威脅。
  • 掃描伺服器信箱 — 掃描所有伺服器信箱，查找潛在威脅。
  • 信箱根資料夾 — 指定根資料夾的位置。接受信箱根資料夾的預設位置，或指定新位置。此選項只適用於傳送電子郵件掃描。預設值 = !!mail\。
進階選項 | 要排除的 Notes 應用程式 — 指定要從掃描中排除的 Lotus Notes 應用程式。預設值 = MNOTES。


動作索引標籤

選項定義

設定當偵測到威脅或潛在無用程式時要執行的動作。若您為預設、低風險及高風險處理程序設定不同的掃描原則，則必須在此索引標籤上為每個處理程序類型設定選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
找到威脅時 先執行此動作 — 選取當偵測到威脅時想要掃描程式執行的第一個動作。預設值 = 自動清除檔案。
  • 自動清除檔案 — 掃描程式會嘗試從偵測到的檔案中移除威脅。
  • 拒絕存取檔案 — 拒絕所有使用者存取任何掃描程式發現之具有潛在威脅的檔案。
  • 自動刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 自動刪除檔案。
  • 拒絕存取檔案 — 拒絕所有使用者存取任何掃描程式發現之具有潛在威脅的檔案。
  • 自動刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。
找到無用程式時 先執行此動作 — 選取當偵測到潛在無用程式時，您想要讓掃描程式執行的第一個動作。預設值 = 自動清除檔案。
  • 允許存取檔案 — 允許使用者存取偵測到的檔案及/或程式。
    註:

    使用此動作可以監視受偵測的項目，然後再您決定執行的動作。檢視活動記錄來查看受偵測的程式。此選項沒有允許執行的次要動作。

  • 自動清除檔案 — 自動從偵測到的檔案及/或程式中移除威脅。
  • 拒絕存取檔案 — 防止使用者存取偵測到的檔案及/或程式。
  • 自動刪除檔案— 自動移除偵測到的檔案及/或程式。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 自動刪除檔案。
  • 允許存取檔案 — 允許使用者存取偵測到的檔案及/或程式。
  • 拒絕存取檔案 — 防止使用者存取偵測到的檔案及/或程式。
  • 自動刪除檔案— 自動移除偵測到的檔案及/或程式。


排除索引標籤

選項定義

指定要從掃描中排除的項目。若您為預設、低風險及高風險處理程序設定不同的掃描原則，則必須在此索引標籤上為每個處理程序類型設定選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
不掃描的對象 從下拉式清單中選取排除的類型，然後指定排除的詳細資料：
  • 依模式排除 — 在文字方塊中鍵入模式。需要時，選取「包含子資料夾」。
  • 依檔案類型排除 — 在文字方塊中鍵入檔案類型。
  • 依檔案時間長度排除 — 選取存取類型，然後指定時間長度下限 (天數)。
  • 受「Windows 檔案保護」的保護

請參閱「新增及排除掃描項目」，以取得更多資訊。
如何處理用戶端排除 覆寫用戶端排除 — 僅排除此原則中指定的項目。如果未選取此選項，則用戶端電腦會使用在本機指定的排除，以及此原則中指定的排除。
註: 此選項僅能透過 ePolicy Orchestrator 使用。


報告索引標籤

選項定義

啟用記錄以追蹤網路上的活動，並記錄您使用何種設定來偵測及回應掃描程式發現的所有潛在威脅。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
記錄至檔案 | 啟用活動記錄。
記錄檔位置 接受記錄檔的預設位置，或指定新位置。

預設記錄名稱為 OnAccessScanLog.txt。

預設位置為：<磁碟機>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

預設位置可能會視使用的作業系統而有所不同。
記錄檔大小 | 限制記錄檔的大小。接受預設大小 (1 MB) 或設定 1 MB 到 999 MB 的大小。如果記錄檔中的資料超出了設定的檔案大小，則會刪除最舊的 20% 項目，再將新資料附加至該檔案中。
記錄檔格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。
除了掃描活動之外要記錄的事項
  • 工作階段設定 — 將每一個掃描工作階段的內容記錄到記錄檔中。
  • 工作階段摘要 — 將每一個掃描工作階段期間之掃描程式的動作摘要，記錄到記錄檔中。摘要資訊包含已掃描的檔案數目、偵測的數目及類型、已清除或已刪除的檔案數目及其他資訊。
  • 無法掃描已加密檔案 — 記錄掃描程式無法掃描的已加密檔案名稱。


掃描項目索引標籤

選項定義

設定偵測選項。若您為預設、低風險及高風險處理程序設定不同的掃描原則，則必須在此索引標籤上為每個處理程序類型設定選項。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
掃描檔案
  • 寫入至磁碟時 — 當在電腦或其他資料儲存裝置上寫入或修改任何檔案時，加以掃描。

    若要在電腦之間複製或移動檔案，請務必對所有電腦進行相同的設定，以免從電腦複製具有潛在威脅的檔案或將其寫入電腦。

  • 從磁碟讀取時 — 當從電腦或其他資料儲存裝置上讀取任何檔案時，加以掃描。
  • 在網路磁碟機上 — 掃描對應網路磁碟機的資源。

    掃描網路資源可能會影響效能。

  • 開啟檔案以進行備份 — 檢查為進行備份作業而開啟的檔案。
要掃描的檔案類型
  • 所有檔案 — 掃描所有檔案而不考慮副檔名。
  • 預設 + 其他檔案類型 — 掃描預設副檔名清單及您所指定的新增內容清單。預設清單由目前的 DAT 檔案所定義。

    亦掃描所有檔案中的巨集 — 如果您已選取此選項，也可以搜尋所有檔案中的已知巨集威脅。

  • 僅限指定的檔案類型 — 針對使用者指定要掃描的副檔名來建立清單。您也可以移除先前新增的任何副檔名。

    選取此選項，然後在文字方塊中輸入由空格分隔的副檔名。
啟發式
  • 尋找未知的程式威脅和特洛伊木馬程式 — 使用啟發式掃描來偵測具有類似惡意軟體之程式碼的執行檔。
  • 尋找未知的巨集威脅 — 使用啟發式掃描來偵測未知的巨集病毒。
壓縮檔
  • 對保存檔內部進行掃描 — 檢查封存 (壓縮) 檔與其內容。
  • 對 MIME 已編碼檔案進行解碼 — 偵測、解碼及掃描「多用途網際網路郵件延伸標準 (MIME)」編碼檔案。
註: 掃描壓縮檔雖然可以提供更好的保護，但卻會增加執行掃描所需的時間。
無用程式偵測
  • 偵測無用程式 — 啟用常駐掃描程式來偵測潛在無用程式。

    掃描程式會使用您在「無用程式原則」中設定的資訊，來偵測潛在無用程式。

    請參閱「限制潛在無用程式」以取得更多資訊。


動作索引標籤

選項定義

設定當偵測到威脅或潛在無用程式時要執行的動作。

選項 定義
找到威脅時 先執行此動作 — 選取當偵測到威脅時想要掃描程式執行的第一個動作。預設值 = 清除檔案。
  • 清除檔案 — 掃描程式會嘗試從偵測到的檔案中移除威脅。
  • 繼續掃描 — 在偵測到具有威脅的檔案時繼續掃描。
  • 自動刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 刪除檔案。
  • 繼續掃描 — 在偵測到具有威脅的檔案時繼續掃描。
  • 刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。
找到無用程式時 先執行此動作 — 選取當偵測到威脅時想要掃描程式執行的第一個動作。預設值 = 清除檔案。
  • 清除檔案 — 掃描程式會嘗試從偵測到的檔案中移除威脅。
  • 繼續掃描 — 在偵測到具有威脅的檔案時繼續掃描。
  • 刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。
如果第一個動作失敗，再執行此動作 — 選取若第一個動作失敗，您想要讓掃描程式執行的下一個動作。預設值 = 刪除檔案。
  • 繼續掃描 — 在偵測到具有威脅的檔案時繼續掃描。
  • 刪除檔案 — 掃描程式會在偵測到具有潛在威脅的檔案時立即刪除該檔案。


排除索引標籤

選項定義

指定要從掃描中排除的項目。

選項 定義
不掃描的對象 從下拉式清單中選取排除的類型，然後指定排除的詳細資料：
  • 依模式排除 — 在文字方塊中鍵入模式。需要時，選取「包含子資料夾」。
  • 依檔案類型排除 — 在文字方塊中鍵入檔案類型。
  • 依檔案時間長度排除 — 選取存取類型，然後指定時間長度下限 (天數)。
  • 受「Windows 檔案保護」的保護

請參閱「新增及排除掃描項目」，以取得更多資訊。
如何處理用戶端排除 覆寫用戶端排除 — 僅排除此原則中指定的項目。如果未選取此選項，則用戶端電腦會使用在本機指定的排除，以及此原則中指定的排除。
註:

唯有透過 ePolicy Orchestrator 才能設定此選項。


效能索引標籤

選項定義

指定延後掃描及系統使用率選項以增進效能。

選項 | 定義
延後掃描選項 選取延後掃描選項：
  • 當使用電池電源時延後掃描— 當系統使用電池電源時延後掃描。
  • 在簡報進行期間延後掃描— 當系統為簡報模式時延後掃描。
  • 使用者可以延後排定的掃描 — 允許使用者延後排定的掃描。

  • 最大延後時數 — 指定延後掃描的時間長度。選取範圍為 1 至 24 小時之間，或是選取 0 以永遠延後掃描。

請參閱「延後掃描的運作方式」，以取得更多資訊。
系統使用率 | 使用滑桿來設定掃描的使用率排程。每項工作都可獨立執行而不受限於其他工作。此工作在 ePolicy Orchestrator 中的預設值 = 30%。此工作在 VirusScan Enterprise 8.7i 中的預設值 = 100%。
適用於可疑檔案的啟發式網路檢查
設定在判定偵測樣本是否為惡意軟體時要使用的敏感度層級。除了「已停用」之外的所有層級，樣本指紋或「雜湊」都會提交給 Avert Labs 以判定這些樣本是否為惡意軟體。好處是一旦 AVERT Labs一發佈更新，您不需要等待下一個 DAT 版本即可使用偵測。您選擇的敏感度層級越高，偵測到的惡意軟體數目也越多。不過，越多偵測發生，也代表發生誤報的機會越大。選取以下的敏感度層級：

  • 已停用 — 不會將指紋或任何資料提交給 Avert Labs 判定是否為惡意軟體。

  • 非常低 — 偵測數及誤報的機會與一般 DAT 相同。當 Avert Labs 發佈偵測時就可在 VirusScan Enterprise 使用偵測，不需要等到下次 DAT 更新。

  • 低 — 此層級的定義介於「非常低」與「中」之間。

  • 中 — 當受惡意軟體侵擾的一般風險大於誤報的風險時，使用此層級。Avert Labs 的專利啟發式檢查會偵測出可能的惡意軟體。不過，當偵測較罕見的檔案時，可能會有誤報的風險。經 Avert Labs 檢驗，使用此設定的偵測不會對常見的應用程式及作業系統檔案產生誤報。

  • 高 — 此層級的定義介於「中」與「非常高」之間。

  • 非常高 — 建議您只針對電子郵件，或掃描不支援執行程式或作業系統的磁碟區與目錄時，使用此層級。使用此層級找到的偵測皆被推測為惡意軟體，但尚未經過完整測試來確認是否為誤報。


報告索引標籤

選項定義

啟用記錄以追蹤網路上的活動，並記錄您使用何種設定來偵測及回應掃描程式發現的所有潛在威脅。

選項 | 定義
記錄至檔案 | 啟用活動記錄。
記錄檔位置 接受記錄檔的預設位置，或指定新位置。

預設記錄名稱為 OnDemandScanLog.txt。

預設位置為：<磁碟機>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

預設位置可能會視使用的作業系統而有所不同。
記錄檔大小 | 限制記錄檔的大小。接受預設大小 (1 MB) 或設定 1 MB 到 999 MB 的大小。如果記錄檔中的資料超過設定的檔案大小，則會刪除最舊的 20% 項目，再將新資料附加至該檔案中。
記錄檔格式 選取記錄檔格式。預設值 = Unicode (UTF8)。
  • Unicode (UTF8) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • Unicode (UTF16) — 若要儲存東方文字 (每個字元皆是一或兩個位元組)，或要在跨國組織中共用資訊，建議您使用此格式。
  • ANSI — 若要儲存西方文字 (每個字元皆是一個位元組)，建議您使用 ANSI 格式。
除了掃描活動之外要記錄的事項
  • 工作階段設定 — 將每一個掃描工作階段的內容記錄到記錄檔中。
  • 工作階段摘要 — 將每一個掃描工作階段期間之掃描程式的動作摘要，記錄到記錄檔中。摘要資訊包含已掃描的檔案數目、偵測的數目及類型、已清除或已刪除的檔案數目及其他資訊。
  • 無法掃描已加密檔案 — 記錄掃描程式無法掃描的已加密檔案名稱。
在偵測到 Cookie 時顯示警告
註:

此選項只會在安裝 AntiSpyware Enterprise Module 8.7 後才可以使用。

在偵測到 Cookie 時顯示警告 — 偵測到 Cookie 時傳送警告。這包含產生 ePolicy Orchestrator 警告、偵測通知、如果您在「報告」索引標籤中啟用活動記錄，則在活動記錄中記錄偵測內容並在掃描統計資料中計算偵測數。如果您取消選取此選項，則 ePolicy Orchestrator 就不會產生警告，但如果您在「報告」索引標籤中啟用了活動記錄，則仍然會在活動記錄中記錄偵測，並在掃描統計資料中計算偵測數。


掃描項目索引標籤

選項定義

設定偵測選項。

選項 定義
要掃描的檔案類型
  • 所有檔案 — 掃描所有檔案而不考慮副檔名。
  • 預設 + 其他的檔案類型 — 掃描預設副檔名清單及您指定的新增內容清單。預設清單由目前的 DAT 檔案所定義。

    選取此選項，然後在文字方塊中輸入由空格分隔的副檔名。

    亦掃描所有檔案中的巨集 — 如果已選取「預設 + 其他的檔案類型」，也可以在搜尋所有檔案中的已知巨集威脅。

  • 指定的檔案類型 — 針對使用者指定要掃描的副檔名來建立清單。您也可以移除先前新增的任何副檔名。

    選取此選項，然後在文字方塊中輸入由空格分隔的副檔名。
選項
  • 偵測無用程式 — 啟用常駐掃描程式來偵測潛在無用程式。

    掃描程式會使用您在「無用程式原則」中設定的資訊，來偵測潛在無用程式。

    請參閱「限制潛在無用程式」，以取得更多資訊。

  • 對 MIME 已編碼檔案進行解碼 — 偵測、解碼及掃描「多用途網際網路郵件延伸標準 (MIME)」編碼檔案。
  • 對保存檔內部進行掃描 — 檢查封存 (壓縮) 檔與其內容。
掃描壓縮檔雖然可以提供更好的保護，但卻會增加執行掃描所需的時間。

  • 掃描已遷移到存放區的檔案 — 掃描「遠端存放」上儲存的快取檔案。

    請參閱「掃描遠端存放的運作方式」，以取得更多資訊。
啟發式
  • 尋找未知程式威脅 — 使用啟發式掃描來偵測具有類似惡意軟體之程式碼的執行檔。
  • 尋找未知的巨集威脅 — 使用啟發式掃描來偵測未知的巨集病毒。


工作索引標籤

選項定義

指定執行此按指定工作的平台。

選項 定義
執行此工作的平台
  • 在伺服器上執行此工作 — 在伺服器上執行此按指定掃描工作。
  • 在工作站上執行此工作 — 在工作站上執行此按指定掃描工作。
執行工作時所使用的使用者帳戶
  • 使用者名稱 — 指定使用者的帳戶名稱。如果未輸入帳戶資訊，則此工作會以系統帳戶執行。
  • 密碼 — 鍵入密碼。
  • 網域 — 鍵入網域。
註:

您必須具有管理權限，才能排程此工作。管理權限可提供使用者排程工作登錄機碼的寫入存取權。如需排定用戶端工作的相關資訊，請參閱 ePolicy Orchestrator 說明文件。


密碼選項索引標籤

選項定義

針對整個系統或選取的項目設定密碼安全性。請參閱「設定密碼對使用者的影響」，以取得更多資訊。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
使用者介面密碼 指定使用者介面安全性：
  • 沒有密碼 — 存取組態設定時不需要密碼。
  • 用密碼保護所有列出的項目 — 對清單中的所有項目指定一個密碼。
  • 用密碼保護所選的項目 — 針對清單中選取的項目指定一個密碼。
  • 一般條件規範的密碼保護 — 對於必須使用經「國際資訊擔保組織 (National Information Assurance Partnership, NIAP) 共通準則」驗證之安全性產品的政府機構而言，確保介面安全為必要工作。

    這可防止沒有管理認證的使用者存取所有設定選項，但是工作站使用者可以針對自己的工作站執行即時按指定掃描。在即時按指定掃描中包含或排除檔案。在即時按指定掃描中包含或排除保存檔，例如 .ZIP 檔案。檢視按指定掃描與常駐掃描活動記錄。

密碼 — 鍵入密碼。

確認密碼 — 重新鍵入密碼以進行確認。
受密碼保護的使用者介面項目 選取要以密碼保護的項目。
  • 全選 — 選取區段中的所有項目。
  • 取消全選 — 取消選取區段中的所有項目。

系統管理員可以透過「主控台」鎖定或解除鎖定介面。


原則索引標籤

選項定義

設定隔離位置及隔離項目的保留時間長度。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
隔離目錄 | 接受隔離目錄的預設位置，或指定新位置。預設值 = <系統磁碟機>\Quarantine。
隔離資料保留
  • 自動刪除隔離的資料 — 在指定的天數之後刪除隔離的資料。
  • 將備份資料保留在隔離目錄中的天數 — 指定在自動刪除隔離項目之前要保留的天數。選擇範圍為 1 到 999 天。


Proxy 設定索引標籤

Proxy 伺服器是網際網路安全性的一部份，其可對網際網路隱藏網際網路使用者的電腦，再透過快取公用存取網站提高存取速度。

如果您的網路使用的是 Proxy 伺服器，則您可以指定使用哪種 Proxy 設定、Proxy 伺服器的位址以及是否要使用驗證。Proxy 資訊存放在「自動更新」存放庫清單 (sitelist.xml) 中。此處設定的 Proxy 設定可套用至此存放庫清單中的所有存放庫。

註:

從「ePolicy Orchestrator 主控台」無法使用此功能。請從「VirusScan 主控台」存取此功能。

選項定義

選項 定義
不使用 Proxy

不指定 Proxy 伺服器。

使用 Internet Explorer Proxy 設定

使用目前安裝之 Internet Explorer 版本的 Proxy 設定。

預設值 = 使用 Internet Explorer Proxy 設定。
手動設定 Proxy 設定

設定 Proxy 設定以符合您的特定需要。
例外情況

只有選取「手動設定 Proxy 設定」時才能使用。

指定 Proxy 例外情況。按一下「例外情況」以開啟「Proxy 例外情況」對話方塊：
  • 指定例外情況 — 選取此選項以輸入 Proxy 例外情況。
  • 使用分號 (;) 來分隔項目 — 例如：internal1;internal2
HTTP

鍵入 HTTP Proxy 伺服器的位址。
FTP

鍵入 FTP Proxy 伺服器的位址。
連接埠

鍵入 HTTP 或 FTP Proxy 伺服器的連接埠號碼。
使用 HTTP 驗證

使用指定的認證來存取 HTTP Proxy。
HTTP 使用者名稱

鍵入 HTTP 使用者名稱。
HTTP 密碼

鍵入 HTTP 密碼。


掃描項目索引標籤

選項定義

選取要偵測的潛在無用程式類別，並針對不偵測的程式建立排除項目。

選項 | 定義
設定適用於 | 從下拉式清單選取「工作站」或「伺服器」。 註: 此選項僅能透過 ePolicy Orchestrator 使用。
選取要偵測之潛在無用程式的類別 | 指定要偵測之潛在無用程式的類別。
無用程式排除 | 依偵測名稱指定排除。視需要新增及移除項目。


隔離原則索引標籤

選項定義

設定隔離位置及隔離項目的保留時間長度。

選項 | 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
隔離目錄 | 接受隔離目錄的預設位置，或指定新位置。預設值 = <系統磁碟機>\Quarantine。
隔離資料保留
  • 自動刪除隔離的資料 — 在指定的天數之後刪除隔離的資料。
  • 將備份資料保留在隔離目錄中的天數 — 指定在自動刪除隔離項目之前要保留的天數。選擇範圍為 1 到 999 天。


新增及編輯存放庫

新增存放庫或編輯現有的存放庫。

選項定義

選項 定義
存放庫說明

指定存放庫的名稱。
檔案擷取來源
選取擷取檔案的位置。預設值 = HTTP 存放庫。
  • HTTP 存放庫 — 從您指定的 HTTP 存放庫位置擷取檔案。
    註: HTTP 站台與 FTP 一樣，可提供不受網路安全性限制的更新方式，不過它可支援的同時連線層級高於 FTP。
  • FTP 存放庫 — 從您指定的 FTP 存放庫位置擷取檔案。
    註: FTP 站台可提供彈性的更新方式，不必受到網路安全性權限的限制。與 HTTP 相比，FTP 較不易受無用程式碼的攻擊，因此具有更佳的容錯能力。
  • UNC 路徑 — 從您指定的 UNC 路徑位置擷取檔案。
    註: UNC 站台是設定最省時且最容易的站台。跨網域的 UNC 更新必須具備各網域的安全性權限，因此更新設定需考量較多因素。
  • 本機路徑 — 從您指定的本機路徑位置擷取檔案。
URL
只當您選取「HTTP 存放庫」或「FTP 存放庫」時才能使用。
  • HTTP — 輸入更新檔案所在的 HTTP 伺服器及資料夾位置。
  • FTP — 輸入更新檔案所在的 FTP 伺服器及資料夾位置。
路徑
只當您選取「UNC 路徑」或「本機路徑」時才能使用。
  • UNC 路徑 — 使用 UNC 標記法 (\\伺服器名稱\路徑\)，輸入更新檔案所在的存放庫路徑。
  • 本機路徑 — 輸入您存放更新檔案的本機資料夾路徑，或按「瀏覽」切換至要瀏覽的資料夾。這路徑可以是本機磁碟機或網路磁碟機上的資料夾路徑。
連接埠

只當您選取「HTTP 存放庫」或「FTP 存放庫」時才能使用。輸入指定的 HTTP 或 FTP 伺服器的連接埠號碼。

使用驗證

使用匿名登入

使用登入的帳戶
使用指定的認證來存取存放庫。
註:

此選項的標題會因您在「檔案擷取來源」區段中選取的選項而有所不同。

「自動更新」會使用您指定的認證來存取存放庫，以下載必要的更新檔案。設定存放庫上的帳戶認證時，請確保該帳戶具有包含更新檔案之資料夾的讀取權限。
  • FTP 與 UNC 存放庫需要下載認證，但對於 HTTP 存放庫則是選擇性的。
  • FTP 更新支援匿名存放庫連線。
  • 使用 UNC 更新您也可使用已登入的帳戶，利用已登入的使用者權限存取存放庫。
使用者名稱

鍵入使用者名稱。
密碼

鍵入密碼。
確認

重新鍵入密碼並確認。


存放庫索引標籤

設定取得更新的來源存放庫。
註:

從「ePolicy Orchestrator 主控台」無法使用此功能。請從「VirusScan 主控台」存取此功能。

選項定義

選項 定義
存放庫說明

指定存放庫的名稱。

此清單已預先設定一個 HTTP 與 FTP 存放庫。
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

HTTP 存放庫為預設下載網站。
狀態

已啟用 — 可在「自動更新」處理程序期間使用的已定義存放庫。

已停用 — 此為您不想在「自動更新」處理程序期間存取的已定義存放庫。這可能是偶爾才使用、不是經常使用的存放庫。

註: 請視需要建立存放庫站台，先啟用後再停用。
新增

將新的存放庫新增到清單中。
編輯

編輯選取的存放庫。
刪除

刪除選取的存放庫。
上移

將清單中選取的存放庫往上移。
下移

將清單中選取的存放庫往下移。


管理員索引標籤

選取清單中的項目，然後按一下滑鼠右鍵來存取進階選項。您可以重新掃描、檢查誤報、還原、刪除或檢視內容。


工作索引標籤

選項定義

指定可存取還原位置之使用者的帳戶資訊。如果未在此處輸入帳戶，則還原工作會在系統帳戶下執行。

選項 | 定義
使用者 | 鍵入可存取此還原位置的使用者名稱。
密碼 | 鍵入指定使用者的密碼。
網域 | 鍵入指定使用者的網域。


掃描位置索引標籤

選項定義

設定要掃描的項目類型及位置。

選項 定義
要掃描的位置 選取要掃描的位置。預設值 = 記憶體中的 Rootkit、正在執行的處理程序及所有本機磁碟機。 按一下「新增」、「編輯」及「移除」來變更「項目名稱」。
  • 記憶體中的 Rootkit。掃描系統記憶體以找出安裝的 Rootkit、隱藏的處理程序，以及其他暗示惡意程式碼正在嘗試自我隱藏的行為等資訊。此掃描作業會在所有其他掃描之前執行。
  • 正在執行的處理程序。掃描所有執行中之處理程序的記憶體。除「清除」之外的動作均被視為「繼續掃描」。
  • 已登錄檔案。掃描所有已登錄的檔案。掃描程式會先在登錄中搜尋檔名，然後再掃描檔案。掃描程式會從登錄中移除潛在無用檔案的參考。
  • 我的電腦。掃描實體上連接到您電腦，或邏輯上對應到電腦上磁碟機代號的所有磁碟機。
  • 所有本機磁碟機。掃描您電腦上的所有磁碟機及其子資料夾。
  • 所有硬碟。掃描所有實體連接到您電腦的磁碟機。
  • 所有卸除式磁碟機。掃描所有卸除式磁碟機或其他與您電腦連接的儲存裝置。
  • 所有對應的磁碟機。掃描邏輯上對應到您電腦上網路磁碟機的網路磁碟機。
  • 主資料夾。掃描啟動掃描之使用者的主資料夾。
  • 使用者設定檔資料夾。掃描啟動掃描之使用者的設定檔，包含使用者的「我的文件」資料夾。
  • Windows 資料夾。掃描 Windows 資料夾的內容。
  • Program Files 資料夾。掃描 Program Files 資料夾的內容。
  • Temp 資料夾。掃描 Temp 資料夾的內容。
  • 資源回收筒。掃描資源回收筒的內容。
  • 磁碟機或資料夾。掃描指定的磁碟機或資料夾。
  • 檔案。掃描指定的檔案。
  • 登錄。掃描登錄項目。安裝 AntiSpyware Enterprise Module 8.7 後才會出現此位置。
  • Cookie。掃描 Cookie 資料夾中的 Cookie。安裝 AntiSpyware Enterprise Module 8.7 後才會出現此位置。
註: 使用預設的掃描項目清單可能會啟動非常耗時的完整掃描。請考慮是否要縮小此掃描的範圍以供定期使用。
掃描選項 選取之項目的掃描類型。
  • 包含子資料夾 — 掃描程式會檢查指定磁碟區的所有子資料夾。取消選取此選項，以只針對磁碟區的根層級進行掃描。
  • 掃描開機磁區 — 掃描程式會檢查磁碟開機磁區。
若磁碟中有無法執行掃描的特別或異常開機磁區，則最好停用開機磁區掃描。


進階排程選項

設定排程參數。

選項定義

選項 | 定義
開始日期 | 指定開始此工作的日期。
結束日期 | 指定結束此工作的日期。
重複工作 | 以指定的頻率來重複工作。 如果您選取此選項，亦請指定此工作的重複頻率。
每隔 | 指定重複此工作的頻率。 也選取頻率為小時或分鐘。
時間 (本地) | 在指定的本地時間重複此工作。 如果您選取此選項，亦請選取特定的時間。
持續時間 | 在指定的小時及分鐘內重複此工作。 如果您選取此選項，亦請選取小時及分鐘。
小時 | 小時數。選擇 0 到 99 間的數字。
分鐘 | 分鐘數。選擇 0 到 59 間的數字。


排程索引標籤

指定工作的排程頻率與其他設定。

選項定義

選項 定義
執行階段

執行工作 從下列選項選取此工作的頻率：

每日 — 在指定日期每日執行工作。

每日工作可在固定天數間隔後執行，或每天執行 (星期一至星期日)。如果您只想在每週的特定日期中每天執行 (而非星期一至星期日每日執行)，建議您使用每週工作頻率。

每週 — 在指定的週與日期每日執行工作。

每月 — 在指定的日期與月份每日執行工作。

一次 — 在指定日期執行一次工作。

啟動時 — 在系統啟動時執行此工作，並指定是否每天執行此工作一次，以及延遲工作的分鐘數。

登入時 — 在登入時執行此工作，並指定是否每天執行此工作一次，以及延遲工作的分鐘數。

閒置時 — 在電腦閒置時執行工作，並指定啟動工作前電腦閒置的分鐘數。

如果工作已啟動，且使用者在工作完成前恢復使用電腦，則工作會繼續執行直到完成。

立即 — 立即執行工作。

撥號時 — 在撥號時執行工作。
開始時間

選取排程工作的開始時間。
UTC 時間

國際標準時間 (UTC)。選取此選項以在所有時區同步執行工作。
本地時間

在每個本機時區獨立執行工作。

註: 預設值= 本地時間
啟用隨機選擇

在您設定的時間間隔內隨機執行工作。

若您選取此選項，亦請指定作為最大時間間隔的小時與/或分鐘數。

註:

指定時間間隔區間 (從最小值 1 分鐘到最大值 23 小時)。例如，若將工作排程設定為 1:00，然後將隨機選擇設定為 3 小時，則工作會在介於 1:00 到 4:00 之間的任一時間執行。

若將工作排程於「啟動時」、「登入時」或「閒置時」執行，則無法使用此選項。
小時

小時數。選擇範圍介於 0 到 23 小時
分鐘

分鐘數。

註:
可選取的分鐘數視您選取的選項而定。例如：
  • 啟用隨機選擇 — 選擇範圍介於 0 到 59 分鐘。
  • 延遲已錯過的工作 — 選擇範圍介於 0 到 99 分鐘。
如果錯過就執行

可確保電腦在重新啟動後會執行錯過的工作。如果電腦在排程工作執行前離線，可能會錯過此工作。

註: 如果遠端使用者與網路剛好在排程工作執行前離線，此功能可確保他們受到完整的保護。
延遲已錯過的工作

選取要延遲錯過之工作的分鐘數。選擇範圍介於 0 到 99 分鐘。
每幾天

在指定的天數間隔後執行此工作。選擇範圍介於 0 到 9999 天。

註: 只有將工作排程為「每日」，才能使用此選項。
每幾週

在指定的週數間隔後執行此工作。選擇範圍介於 0 到 99 週。

如果您選取此選項，亦請指定週數及每週特定日期。

註:

若為每月固定日期，選擇範圍為星期日、星期一、星期二、星期三、星期四，星期五及星期六。

只有將工作排程為「每週」，才能使用此選項。

每月固定日期

在每月的固定日期執行此工作。選擇範圍介於 1 到 31 天。

如果您選取此選項，亦請指定每月固定日期。

註: 只有將工作排程為「每月」，才能使用此選項。
每月的每週固定日期

在每月的指定日期執行此工作。

如果您選取此選項，亦請選取發生次數及每月固定日期。

註:

若為發生次數，選擇範圍為「第一次」、「第二次」、「第三次」、「第四次」及「最後一次」。

若為每月固定日期，選擇範圍為星期日、星期一、星期二、星期三、星期四，星期五及星期六。

只有將工作排程為「每月」，才能使用此選項。
選取月份

指定執行此工作的月份。

註: 只有將工作排程為「每月」，才能使用此選項。
執行時間

指定要執行此工作的日期。

註: 只有將工作排程為「一次」，才能使用此選項。
一天僅執行此工作一次

一天執行此工作一次。

註:

若您未選取此選項，則每次啟動或登入時都會執行此工作。

只有將工作排程於「啟動時」、「登入時」或「撥號時執行」，才能使用此選項。
延遲工作的時間

指定延遲此工作的分鐘數。選擇範圍介於 0 到 99。

註:

這給予使用者進行登入及執行登入指令碼的時間。

只有將工作排程於「啟動時」或「登入時」，才能使用此選項。
當電腦閒置達到

指定啟動工作前，電腦閒置的分鐘數。選擇範圍介於 0 到 999 分鐘。

註:

如果工作已啟動，且使用者在工作完成前恢復使用電腦，則工作會繼續執行直到完成。

只有將工作排程為「閒置時」，才能使用此選項。
進階

設定進階選項。

註: 請參閱「進階排程選項」，以取得更多資訊。


工作索引標籤

啟用此工作的排程及指定使用者帳戶設定。

選項定義

選項 | 定義
啟用 (已排程的工作會在指定時間執行) | 排程工作以在指定時間執行。 註: 必須選取此選項，才能排程工作。
如果超過下列時間就停止執行工作 | 在指定的時數及/或分鐘數後停止工作。 註: 如果工作完成前被中斷，下次會從中斷處重新開始掃描。
小時 | 工作停止前所經過的時數。
分鐘 | 工作停止前所經過的分鐘數。
使用者 | 輸入執行此工作所需的使用者識別碼。 註: 認證的使用為選擇性。如果您未在此處輸入認證，則已排程的工作會在本機系統帳戶下執行。 請參閱「登入權限」，以取得更多資訊。
網域 | 輸入您指定之使用者識別碼的網域。
密碼 | 輸入您指定之使用者識別碼及網域的密碼。


指令碼掃描索引標籤

選項定義

避免執行無用的指令碼。

請參閱「指令碼掃描及其運作方式」，以取得更多資訊。

選項 | 定義
設定適用於 | 從下拉式清單選取「工作站」或「伺服器」。 註: 此選項僅能透過 ePolicy Orchestrator 使用。
指令碼掃描 | 啟用指令碼掃描 — 在執行 JavaScript 及 VBScript 指令碼之前進行掃描。
指令碼掃描排除 | 處理程序 — 依處理程序名稱指定「指令碼掃描」排除。不允許使用萬用字元來指定處理程序名稱。


使用者定義的偵測索引標籤

選項定義

指定要視為無用程式的個別檔案或程式。

選項 定義
設定適用於 從下拉式清單選取「工作站」或「伺服器」。
註: 此選項僅能透過 ePolicy Orchestrator 使用。
使用者定義的項目
  • 檔名 — 指定您要偵測的檔案或程式名稱。

  • 說明 — 指定當偵測到指定的檔案時，要在通知中顯示的說明。

註: 掃描程式不會偵測大小為零位元組的使用者定義無用程式。