Préface

Pour utiliser ce document efficacement, vous devez comprendre à qui il est destiné, les conventions qui y sont utilisées, ce qu'il contient et comment trouver de la documentation de référence supplémentaire.

Sommaire

  • Public visé
  • Conventions
  • Organisation de ce guide
  • Recherche de la documentation du produit


Public visé

La documentation McAfee a fait l'objet de recherches attentives et a été rédigée en fonction du public visé.

Les informations présentées dans ce guide sont destinées principalement aux :
  • Administrateurs : personnes qui mettent en œuvre et appliquent le programme de sécurité de l'entreprise.
  • Utilisateurs : personnes chargées de la configuration des options du produit sur leur système ou de la mise à jour de ce dernier.


Conventions

Les conventions typographiques suivantes sont utilisées dans ce guide :
Titre de manuel ou Accentuation | Titre d'un manuel, chapitre ou rubrique ; introduction d'un nouveau terme ; accentuation.
Gras | Texte fortement accentué.
Saisie utilisateur ou Chemin | Commandes et autre texte saisi par l'utilisateur ; chemin d'accès à un dossier ou un programme.
Code | Exemple de code.
Interface utilisateur | Termes de l'interface utilisateur, y compris les options, menus, boutons et boîtes de dialogue.
Lien hypertexte bleu | Lien actif vers une rubrique ou un site web.
Remarque | Informations supplémentaires, telles qu'une méthode alternative d'accès à une option.
Conseil | Suggestions et recommandations.
Important/Attention | Conseil important visant à protéger un système informatique, l'installation d'un logiciel, un réseau ou des données.
Avertissement | Conseil crucial visant à empêcher les dommages corporels lors de l'utilisation du matériel informatique.


Organisation de ce guide

Ce document sert de référence à utiliser avec les interfaces utilisateur de la Console VirusScan et ePolicy Orchestrator. Il décrit également, dans un ordre logique, l'approche à adopter pour protéger votre système contre les logiciels malveillants (malwares) avec VirusScan Enterprise. La description de cette procédure est divisée en quatre parties principales accompagnées d'annexes :
  • Partie I -- Prévention : éviter les menaces : le meilleur moyen de protéger votre système consiste à empêcher les logiciels malveillants (malwares) d'y accéder. Cette partie du document décrit les éléments suivants :
    • la protection des points d'accès de votre système et de la mémoire en cas d'erreurs provoquées par des Buffer Overflows et des programmes indésirables ;
    • les définitions de détection et leur utilisation pour protéger votre système ainsi que l'importance de la mise à jour régulière de ces définitions ;
    • l'exclusion des fichiers, dossiers et disques de l'analyse ;
    • l'utilisation de tâches planifiées pour analyser régulièrement votre système et mettre à jour les fichiers utilisés par VirusScan Enterprise.
  • Partie II -- Détection : trouver les menaces : les fichiers ouverts ou copiés à partir d'autres systèmes de fichiers ou d'Internet peuvent représenter une porte ouverte sur votre système. Les appels d'API (Application Programming Interface, interface de programmation d'applications) et les scripts peuvent également représenter une menace pour votre système. Ces menaces sont découvertes lors des processus d'analyse VirusScan Enterprise suivants :
    • Analyse à l'accès : analyse un fichier à la recherche de logiciels malveillants (malwares) lorsque ce dernier est lu ou écrit sur le disque, protège les secteurs d'amorçage, analyse la mémoire des processus en cours d'exécution, détecte les cookies et protège le système des programmes indésirables.
    • Analyse à la demande : analyse la totalité du système à la recherche de menaces, régulièrement ou à la demande lorsqu'elle est exécutée à partir de la Console VirusScan.
    • Analyse d'e-mails à la réception et à la demande : protège contre les logiciels malveillants (malwares) contenus dans les messageries Microsoft Outlook et Lotus Notes.
    • Protection en cas de Buffer Overflow : analyse les appels d'API effectués par certains processus, pour confirmer qu'ils ne tentent pas d'écraser des données adjacentes de la mémoire tampon.
    • ScriptScan : recherche les menaces provenant de navigateurs ou autres applications utilisant le composant Windows Scripting Host.
  • Partie III -- Réponse : gérer les menaces : VirusScan Enterprise peut être configuré pour exécuter toutes les étapes suivantes en cas de détection de menace :
    • Refuser l'accès à la menace ou n'entreprendre aucune autre action.
    • Supprimer ou nettoyer la menace. Lorsque l'une ou l'autre de ces actions est entreprise, une copie du fichier d'origine est stockée dans le dossier de quarantaine.
    Remarque : pour toutes les détections, vous pouvez configurer VirusScan Enterprise pour qu'il envoie ou non une notification à l'utilisateur.
  • Partie IV -- Surveillance, analyse et paramétrage de votre protection : dès que votre protection est opérationnelle, vous devez surveiller votre système à l'aide de requêtes et de rapports ePolicy Orchestrator. Vous pouvez ensuite décider d'apporter des modifications à vos paramètres de sécurité afin de renforcer ou d'affaiblir la protection de votre système. Vous pouvez également utiliser les journaux de la Console VirusScan et les interruptions SNMP (Simple Network Management Protocol) pour ce faire.
  • Annexes : décrivent quelques fonctions supplémentaires à connaître pour l'utilisation de VirusScan Enterprise. Par exemple, les options de ligne de commande VirusScan Enterprise, la connexion à des systèmes distants via VirusScan Enterprise, etc.


Recherche de la documentation du produit

McAfee fournit les informations nécessaires à chaque phase de la mise en œuvre du produit, de l'installation à l'utilisation et au dépannage. Après publication d'un produit, des informations le concernant sont entrées dans la Base de connaissances (KnowledgeBase) en ligne McAfee.
  1. Accédez au support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com.
  2. Sous Self Service (Libre service), accédez au type d'informations dont vous avez besoin :
    Pour accéder à... Procédez comme suit...
    Documentation de l'utilisateur

    1. Cliquez sur Product Documentation (Documentation produit).

    2. Sélectionnez un Produit, puis sélectionnez une Version.

    3. Sélectionnez un document produit.

    Base de connaissances
    • Cliquez sur Search the KnowledgeBase (Rechercher dans la Base de connaissances) pour répondre aux questions que vous vous posez sur le logiciel.
    • Cliquez sur Browse the KnowledgeBase (Parcourir la Base de connaissances) pour obtenir une liste des articles par produit et version.


Mise en route

Connaître les composants du logiciel McAfee® VirusScan® Enterprise 8.8 et la séquence à suivre pour configurer le logiciel vous permet de protéger votre système contre les menaces.

Sommaire

  • Présentation de VirusScan Enterprise
  • Composants et leurs interactions
  • Importance de la création d'une stratégie de sécurité
  • Console VirusScan : présentation et accès
  • Procédure préalable


Présentation de VirusScan Enterprise

Dès que le logiciel VirusScan Enterprise est installé, la protection de votre système contre les menaces est assurée. Vous pouvez améliorer cette protection si vous connaissez le fonctionnement du logiciel, les nouveautés de cette version et ses composants principaux.

Présentation et fonctionnement

VirusScan Enterprise fournit une protection évolutive et se caractérise par sa rapidité d'exécution et sa mobilité pour protéger votre environnement des éléments suivants :

  • virus, vers et chevaux de Troie ;
  • violations de point d'accès et Buffer Overflows exploités ;
  • code et programmes potentiellement indésirables.

Il détecte les menaces, puis effectue les actions que vous avez configurées pour protéger votre environnement.

Vous pouvez configurer le logiciel en tant que produit autonome ou vous pouvez utiliser McAfee® ePolicy Orchestrator® version 4.0 et versions ultérieures pour gérer et appliquer les stratégies VirusScan Enterprise, puis surveiller l'activité et les détections au moyen des requêtes et des tableaux de bord.

Remarque : ce document traite de l'utilisation d'ePolicy Orchestrator 4.0 4.5 et 4.6. Pour plus d'informations sur l'utilisation de ces versions d'ePolicy Orchestrator, consultez la documentation produit correspondante.

Nouveautés

Cette version contient les nouvelles fonctionnalités suivantes :
  • Niveau de performances amélioré.
  • Permet à ePolicy Orchestrator 4.5 et 4.6 de gérer vos systèmes VirusScan Enterprise.
  • Une nouvelle fonctionnalité d'exclusion d'URL ScriptScan vous permet de configurer des exclusions plutôt que de modifier manuellement le Registre.
  • AntiSpyware Enterprise Module est entièrement intégré au logiciel VirusScan Enterprise 8.8.
  • Prise en charge de l'analyse de la messagerie Outlook 2010.
  • Prise en charge de l'analyse de la messagerie Lotus Notes 8.0x à 8.5.1.


Composants et leurs interactions

En tant qu'administrateur et utilisateur de VirusScan Enterprise, vous devez connaître ses composants et connexions. La figure suivante montre ces composants dans un environnement de base.

Figure 1. Composants de VirusScan Enterprise

Système client

Il s'agit du système sur lequel VirusScan Enterprise et McAfee Agent (facultatif) sont installés et configurés.
  • Fichiers DAT : les fichiers de signatures de détection, ou signatures contre les logiciels malveillants (malwares), fonctionnent avec le moteur d'analyse pour identifier les menaces et entreprendre des actions à leur encontre.
  • Moteur d'analyse : utilisé pour analyser les fichiers, les dossiers et les disques sur l'ordinateur client et pour les comparer aux informations des fichiers DAT sur les virus connus.
    Remarque : les fichiers DAT et le moteur d'analyse sont mis à jour si nécessaire via la connexion Internet au siège social de McAfee, ou via les connexions facultatives du réseau Intranet de l'entreprise à un serveur désigné.
  • Artemis (Recherche réseau heuristique de fichiers suspects) : permet de rechercher les programmes et fichiers DLL suspects s'exécutant sur les systèmes clients protégés par VirusScan Enterprise. Lorsque l'outil de défense en temps réel contre les logiciels malveillants (malwares) détecte un programme suspect, il envoie une requête DNS contenant une empreinte de ce fichier à un serveur de base de données central hébergé par McAfee Labs.
  • McAfee Agent (facultatif) : permet une communication sécurisée entre les produits McAfee managés et le serveur McAfee ePolicy Orchestrator. L'agent fournit également des services locaux tels que la mise à jour, la journalisation, les rapports d'événements et propriétés, la planification des tâches, la communication et le stockage des stratégies.

Siège social de McAfee

Le siège social de McAfee, hébergeant McAfee Labs et le support technique de McAfee, fournit les services VirusScan Enterprise suivants :
  • Mises à jour des fichiers DAT : stockés sur un serveur de base de données central McAfee, et grâce à la fonction AutoUpdate, ces fichiers de mise à jour des fichiers DAT sont copiés sur les clients VirusScan Enterprise ou dans les référentiels de fichiers DAT facultatifs afin de fournir les informations nécessaires à la lutte contre les menaces connues ainsi que de nouvelles listes de virus connus découverts en temps réel.
  • Mises à jour du moteur d'analyse : stockées sur un serveur de base de données central, les mises à jour du moteur d'analyse sont téléchargées si nécessaire pour maintenir le moteur d'analyse de VirusScan Enterprise à jour.
  • McAfee Labs : cette bibliothèque de menaces contient des informations détaillées sur les menaces de type virus, cheval de Troie et programmes potentiellement indésirables (PUP) : leur provenance, leur incidence sur votre système et comment les gérer. La fonction Artemis envoie l'empreinte du fichier suspect à McAfee Labs, où ce dernier est analysé et où l'on détermine l'action à entreprendre à son encontre.

Serveur

Le serveur facultatif utilise les composants suivants pour gérer et mettre à jour de nombreux systèmes clients à distance :
  • ePolicy Orchestrator : gère et met en œuvre de manière centralisée les stratégies VirusScan Enterprise, puis surveille l'activité et les détections au moyen des requêtes et des tableaux de bord.
    Remarque : ce document traite de l'utilisation d'ePolicy Orchestrator 4.0 4.5 et 4.6. Pour en savoir plus sur ePolicy Orchestrator, consultez la documentation produit correspondant à votre version.
  • Référentiel de fichiers DAT : permet de récupérer les mises à jour des fichiers DAT à partir du site de téléchargement McAfee. A partir de là, il est possible de répliquer ces fichiers dans toute votre organisation, en permettant l'accès à tous les autres ordinateurs. Cela réduit la quantité de données transférées sur votre réseau en automatisant le processus de copie des fichiers mis à jour vers vos sites partagés.


Importance de la création d'une stratégie de sécurité

La protection de vos systèmes clients contre les virus, vers et fichiers type cheval de Troie à l'aide de VirusScan Enterprise requiert une stratégie bien planifiée : définition de la prévention et de la détection des menaces, réponse aux menaces et analyse et réglages continus.

Prévention : éviter les menaces

Définissez vos besoins en matière de sécurité afin d'assurer la protection de toutes vos sources de données, puis développez une stratégie efficace pour arrêter les intrusions avant que votre environnement ne soit atteint. Configurez ces fonctionnalités pour empêcher les intrusions :
  • Sécurité de l'interface utilisateur : définissez l'affichage et la protection par mot de passe pour contrôler l'accès à l'interface utilisateur de VirusScan Enterprise.
  • Protection d'accès : utilisez des règles de protection d'accès pour protéger votre ordinateur de comportements indésirables concernant les fichiers, le Registre et les ports.
  • Protection en cas de Buffer Overflow : empêchez des menaces ou programmes anormaux de dépasser la limite de la mémoire tampon et d'écraser la mémoire adjacente lors de l'écriture des données dans une mémoire tampon. Ces Buffer Overflows exploités peuvent exécuter un code arbitraire sur votre ordinateur.
  • Protection contre les programmes indésirables : empêchez des programmes potentiellement indésirables, comme les logiciels espions (spywares) ou publicitaires (adwares), d'accéder à votre ordinateur.

Détection : trouver les menaces

Développez une stratégie efficace pour détecter les intrusions lorsqu'elles se produisent. Configurez ces fonctionnalités pour détecter les menaces :
  • Tâche de mise à jour : obtenez des mises à jour automatiques des fichiers DAT et du moteur d'analyse sur le site web de téléchargement de McAfee.
  • Analyseur à l'accès : détectez les menaces potentielles de toutes origines au moment où les fichiers sont lus ou écrits sur le disque. Vous pouvez également analyser les cookies potentiellement indésirables dans le dossier de ces derniers.
  • Tâches d'analyse à la demande : détectez les menaces potentielles à l'aide de tâches d'analyse immédiates et planifiées. Vous pouvez également rechercher des cookies potentiellement indésirables et des entrées de Registre associées à des logiciels espions (spywares) qui n'ont pas déjà été nettoyées.
  • Analyseur d'e-mails à la réception et à la demande : détectez les menaces potentielles sur les clients de messagerie Microsoft Outlook en utilisant l'analyse à la réception des messages électroniques, des pièces jointes et des dossiers publics. Détectez les menaces potentielles sur les clients de messagerie Lotus Notes lors de l'accès aux messages.
  • Stratégie du Quarantine Manager : configurez la durée de conservation des éléments mis en quarantaine ainsi que leur emplacement de stockage. Vous pouvez restaurer des éléments mis en quarantaine si nécessaire.

Réponse : gérer les menaces

Utilisez les fichiers journaux du produit, les actions automatiques et d'autres fonctions de notification pour décider de la meilleure technique de gestion des détections.
  • Actions : configurez les actions à effectuer en cas de détection.

  • Fichiers journaux : surveillez les fichiers journaux du produit pour afficher un historique des éléments détectés.

  • Requêtes et tableaux de bord : utilisez les requêtes et les tableaux de bord ePolicy Orchestrator pour surveiller les activités d'analyse et les détections.

Réglage : surveillance, analyse et paramétrage de votre protection

Après la configuration initiale de VirusScan Enterprise, il est toujours bon de surveiller et d'analyser votre configuration. Cela peut permettre d'améliorer les performances système et réseau, et optimiser le niveau de votre protection antivirus, si nécessaire. Par exemple, les outils et fonctionnalités VirusScan Enterprise suivants peuvent être modifiés dans le cadre de vos processus de surveillance, d'analyse et de paramétrage :
  • Fichiers journaux (Console VirusScan) : affichez un historique des éléments détectés. L'analyse de ces informations peut vous permettre de déterminer si l'amélioration de votre protection ou la modification de la configuration est nécessaire pour optimiser les performances système.
  • Requêtes et tableaux de bord (Console ePolicy Orchestrator) : surveillez l'activité d'analyse et les détections. L'analyse de ces informations peut vous permettre de déterminer si l'amélioration de votre protection ou la modification de la configuration est nécessaire pour optimiser les performances système.
  • Tâches planifiées : modifiez les tâches (telles qu'AutoUpdate) et les heures d'analyse pour améliorer les performances en les exécutant pendant les périodes de faible activité.
  • Référentiels de fichiers DAT : réduisez le trafic sur les réseaux Internet ou Intranet de l'entreprise en déplaçant ces fichiers sources à proximité des clients nécessitant les mises à jour.
  • Modification des stratégies d'analyse : optimisez les performances ou la protection antivirus en fonction de votre analyse des fichiers journaux ou des requêtes. Par exemple, la configuration des exclusions, des conditions d'analyse à haut ou faible risque et des conditions de désactivation de l'analyse lors de l'écriture sont autant d'éléments permettant d'améliorer les performances du système.
    ATTENTION :
    si l'analyse Lors de la lecture à partir d'un disque n'est pas activée, votre système n'est pas protégé contre les nombreuses attaques de logiciels malveillants (malwares).


Console VirusScan : présentation et accès

La Console VirusScan est l'interface de la version autonome des activités du programme. Elle sert à configurer, surveiller et mettre le produit à jour.
Remarque : ces informations s'appliquent uniquement à la version autonome du produit, et non à la version managée d'ePolicy Orchestrator.


Console VirusScan et son fonctionnement

Une fois que vous connaissez le fonctionnement de VirusScan Enterprise et de ses composants, vous devez comprendre comment accéder à ses fonctionnalités. Utilisez l'une de ces méthodes pour ouvrir la Console VirusScan Enterprise 8.8 :
  • Dans le menu Démarrer, choisissez Programmes | McAfee | Console VirusScan.
  • Cliquez avec le bouton droit de la souris sur l'icône en forme de bouclier VirusScan Enterprise dans la barre d'état système, puis sélectionnez Console VirusScan.

Barre de menus

Utilisez les options du menu pour créer des tâches, configurer des propriétés et accéder à des informations supplémentaires.
  • Tâche : permet de créer et de configurer des tâches telles que la recherche de menaces ou la mise à jour des fichiers DAT.
  • Edition : permet de copier, coller, supprimer ou renommer la tâche sélectionnée.
  • Affichage : permet d'afficher la barre d'outils et/ou la barre d'état et d'actualiser l'affichage.
  • Outils : permet de configurer des options d'interface utilisateur, de verrouiller ou déverrouiller la sécurité de l'interface, de configurer des alertes, d'accéder à la visionneuse d'événements, d'ouvrir une console distante si vous disposez des droits d'administrateur, d'importer ou de modifier la liste des référentiels et de restaurer les fichiers DAT.
  • Aide : permet d'accéder aux rubriques de l'Aide en ligne, à la bibliothèque de menaces du site web McAfee Labs, à la page web Envoi d'un échantillon et au site web de support technique. Vous pouvez également réparer l'installation du produit et afficher la boîte de dialogue A propos de pour visualiser les informations de copyright et savoir quelles versions du produit, de la licence, des fichiers de définition, du moteur d'analyse, du pilote supplémentaire et du patch sont installées.
Remarque : chaque élément du menu est associé à une touche de raccourci. Sur certains systèmes d'exploitation, ces raccourcis peuvent ne pas être disponibles à moins d'utiliser la touche F10 ou ALT pour accéder aux menus.

Barre d'outils

Utilisez les icônes pour accéder à ces commandes fréquemment utilisées :
  • Afficher les propriétés de la tâche sélectionnée.
  • Démarrer la tâche sélectionnée.
  • Arrêter la tâche sélectionnée.
  • Copier la tâche sélectionnée.
  • Coller la tâche sélectionnée.
  • Supprimer la tâche sélectionnée.
  • Configurer les propriétés d'alerte.
  • Lancer la visionneuse d'événement.
  • Accéder à la Bibliothèque d'informations sur le site web McAfee Labs.
  • Se connecter à un ordinateur distant si vous disposez des droits d'administrateur.
  • Créer une nouvelle analyse à la demande.

Liste des tâches

Affiche les tâches par défaut et toutes celles que vous créez, ainsi que le statut et le dernier résultat obtenu pour chaque tâche.

Barre de statut

Affiche le statut de l'activité en cours.


Utilisation des fonctions du bouton droit de la souris

Utilisez les fonctions associées au bouton droit de la souris pour accéder rapidement aux actions couramment utilisées telles que la création de tâches, l'affichage des statistiques et des journaux relatifs aux tâches, l'ouverture des pages de propriétés de tâche, l'analyse d'un fichier ou d'un dossier spécifique ou l'exécution immédiate d'une tâche de mise à jour.

Description des fonctions

Emplacement | Description | Exemples
Console Cliquez avec le bouton droit de la souris sur la Console VirusScan pour afficher les fonctions correspondantes. Celles-ci varient selon que vous avez sélectionné ou non une tâche dans la liste des tâches et selon la tâche sélectionnée.
  • Dans la console, cliquez sur une tâche avec le bouton droit de la souris pour accéder à ses propriétés. Selon la tâche sélectionnée, il est possible que vous puissiez également la lancer, l'arrêter, l'activer ou la désactiver et afficher ses statistiques et son journal d'activité. Dans certains cas, vous pouvez également renommer ou supprimer une tâche.
  • Cliquez avec le bouton droit de la souris dans une zone vide de la console pour créer une nouvelle tâche d'analyse ou de mise à jour.
Explorateur Windows Cliquez avec le bouton droit de la souris sur un fichier ou un dossier sélectionné pour Rechercher les menaces immédiatement. Vous pouvez sélectionner une action pour cette analyse :
  • Nettoyer : rapporte et nettoie l'élément détecté.
  • Continuer : signale la détection et poursuit l'analyse.

Lancez l'analyse immédiate d'un fichier ou dossier que vous pensez menacé.

Lorsque l'analyse commence, l'analyseur à la demande est appelé directement, avec chaque paramètre d'analyse activé. Sélectionnez l'option d'action. Vous ne pouvez personnaliser aucun autre paramètre d'analyse.

Barre d'état système | Reportez-vous à la section Icônes de la barre d'état système et leur fonctionnement pour obtenir les descriptions des options de menu contextuel de l'icône VirusScan Enterprise.


Icônes de la barre d'état système et leur fonctionnement

Une fois VirusScan Enterprise installé, l'une des icônes suivantes s'affiche dans la barre d'état système de Windows si vous avez choisi cette option au cours du processus d'installation.

« M » dans une icône en forme de bouclier

S'affiche sur les systèmes ePolicy Orchestrator managés utilisant McAfee Agent 4.5 ou version ultérieure. Elle indique :
  • Statut : l'aspect de cette icône ne change pas pour indiquer les alertes déclenchées pour la protection de l'accès ni pour indiquer si l'analyse à l'accès est désactivée sur les clients ePolicy Orchestrator managés utilisant McTray version 2.x ou ultérieure (avec McAfee Agent 4.5 ou version ultérieure). Les modifications de statut s'affichent sous forme d'infobulles.
  • Infobulles : les infobulles de l'icône incluent :
    • Statut McAfee : OK : normal. Les options indiquent :
      • Voir le statut de sécurité : affiche une coche.
      • Paramètres rapides | Analyse virale à l'accès - activée : affiche une coche.
    • Statut McAfee : Problème détecté : analyse lors de l'accès désactivée Les options indiquent :
      • Voir le statut de sécurité : affiche un point d'exclamation.
        Remarque : cliquez sur Voir le statut de sécurité pour afficher la boîte de dialogue du statut de sécurité de McAfee contenant Problème : « Analyse lors de l'accès désactivée » dans la colonne Statut.
      • Paramètres rapides | Analyse virale à l'accès - désactivée : aucune coche ne s'affiche.
    • Statut McAfee : Problème détecté : événement de protection de l'accès déclenché. Les options indiquent :
      • Voir le statut de sécurité : affiche un point d'exclamation.
        Remarque : cliquez sur Voir le statut de sécurité pour afficher la boîte de dialogue du statut de sécurité de McAfee contenant Problème : « Consultez le journal de protection d'accès » dans la colonne Statut.
      • Paramètres rapides | Analyse virale à l'accès - activée : affiche une coche.
  • Options de menu : les options du menu contextuel incluent :
    • Mise à jour de sécurité : permet de mettre à jour les fichiers DAT et toutes les autres modifications.
    • Paramètres rapides : ils contiennent :
      • Propriétés d'analyse lors de l'accès : ouvre les pages de propriétés de l'analyseur à l'accès.
      • Analyse à l'accès activée ou désactivée : active ou désactive l'analyseur à l'accès.
      • Propriétés d'analyse lors de l'accès : ouvre les pages de propriétés de l'analyseur à l'accès.
      • Messages d'analyse lors de l'accès : ouvre les statistiques ou les messages de l'analyse à l'accès.
      • Ouvrir le fichier journal de protection à l'accès : ouvre le fichier journal.

    • Gérer les fonctions | VirusScan Enterprise : ouvre la Console VirusScan.
    • Analyser l'ordinateur | Menaces : permet de démarrer une analyse immédiate.
    • Voir le statut de sécurité : permet d'afficher la boîte de dialogue du statut de sécurité de McAfee.
    • McAfee Agent Status Monitor : permet d'afficher la boîte de dialogue du moniteur de statut de sécurité de McAfee.
    • A propos de : ouvre la boîte de dialogue A propos de.

« M » dans une boîte

S'affiche sur les systèmes autonomes utilisant McTray 1.0 et sur les systèmes ePolicy Orchestrator managés utilisant McAfee Agent 4.0 avec McTray 1.0. Elle indique :
  • Statut : les affichages incluent :
    • « M » dans une boîte : statut normal.
    • « M » dans une boîte avec point d'exclamation : un événement de violation de la protection d'accès est déclenché ou l'analyse à l'accès est désactivée. Les options du menu contextuel indiquent :
      • « V » dans une icône en forme de bouclier avec cercle barré : indique que l'analyse à l'accès est désactivée.
      • « V » dans une icône en forme de bouclier entouré de rouge : indique que l'analyse à l'accès est activée, mais qu'il faut consulter le journal de protection d'accès.

  • Infobulle : affiche « McAfee ».
  • Options de menu : les options du menu contextuel incluent :
    • Console VirusScan : ouvre la Console VirusScan.
    • Désactiver ou Activer l’analyse à l'accès : active ou désactive l'analyseur à l’accès.
    • Propriétés d'analyse lors de l'accès : ouvre les pages de propriétés de l'analyseur à l'accès.
    • Statistiques d'analyse lors de l'accès : ouvre les statistiques d'analyse à l'accès.
    • Messages d'analyse lors de l'accès : ouvre les statistiques ou les messages de l'analyse à l'accès.
    • Analyse à la demande : permet de créer une analyse à la demande unique configurable.
    • Mettre à jour maintenant : exécute une tâche de mise à jour immédiate.
    • A propos de VirusScan Enterprise : ouvre la boîte de dialogue A propos de.

« V » dans une icône en forme de bouclier

S'affiche sur les systèmes autonomes n'utilisant pas McTray 1.0. Elle indique :
  • Statut : les affichages incluent :
    • « V » dans une icône en forme de bouclier : normal.
    • « V » dans une icône en forme de bouclier avec cercle barré : indique que l'analyse à l'accès est désactivée.
    • « V » dans une icône en forme de bouclier entouré de rouge : indique que l'analyse à l'accès est activée, mais qu'il faut consulter le journal de protection d'accès.
  • Infobulles : les infobulles de l'icône incluent :
    • « V » dans une icône en forme de bouclier : analyse à l'accès McAfee : activée, normale.
    • « V » dans une icône en forme de bouclier avec cercle barré : analyse à l'accès McAfee : désactivée.
    • « V » dans une icône entourée de rouge : analyse à l'accès McAfee : activée, consultez le journal de protection d'accès.

  • Options de menu : les options du menu contextuel incluent :
    • Mise à jour de sécurité : permet de mettre à jour les fichiers DAT et toutes les autres modifications.
    • Paramètres rapides : ils contiennent :
      • Propriétés d'analyse lors de l'accès : ouvre les pages de propriétés de l'analyseur à l'accès.
      • Analyse à l'accès activée ou désactivée : active ou désactive l'analyseur à l'accès.
      • Messages d'analyse lors de l'accès : ouvre les statistiques ou les messages de l'analyse à l'accès.
      • Ouvrir le fichier journal de protection à l'accès : ouvre le fichier journal.

    • Gérer les fonctions | VirusScan Enterprise : ouvre la Console VirusScan.
    • Analyser l'ordinateur | Menaces : permet de démarrer une analyse immédiate.
    • Voir le statut de sécurité : permet d'afficher la boîte de dialogue du statut de sécurité de McAfee.
    • McAfee Agent Status Monitor : permet d'afficher la boîte de dialogue du moniteur de statut de sécurité de McAfee.
    • A propos de : ouvre la boîte de dialogue A propos de.


Procédure préalable

Une fois le logiciel installé, il utilise les fichiers DAT inclus avec le produit, qui assurent la sécurité générale de votre environnement. McAfee vous recommande d'acquérir les fichiers DAT les plus récents et de personnaliser votre configuration afin qu'elle réponde à vos besoins avant le déploiement du produit sur les systèmes clients.

Dès que le produit est installé, effectuez immédiatement les actions suivantes :

  1. Définissez la sécurité de l'interface utilisateur. Configurez les options d'affichage et de mot de passe pour empêcher les utilisateurs d'accéder à des composants spécifiques ou à l'ensemble de l'interface utilisateur de VirusScan Enterprise. Consultez la section Contrôle de l'accès à l'interface utilisateur pour plus d'informations.
  2. Mettez à jour les fichiers DAT. Effectuez une tâche Mettre à jour maintenant afin de vous assurer que vous disposez des fichiers DAT les plus récents. Consultez la section Mise à jour des définitions pour la détection pour plus d'informations.
  3. Empêchez les intrusions. Configurez ces fonctions pour empêcher l'accès de menaces potentielles à vos systèmes :
    • Protection d'accès. Configurez les règles de protection d'accès pour empêcher les modifications indésirables sur votre ordinateur et activez l'option qui empêche l'arrêt des processus McAfee. Consultez la section Protection des points d'accès à votre système pour plus d'informations.
    • Protection en cas de Buffer Overflow. Activez la détection des Buffer Overflows et indiquez les exclusions. Consultez la section Blocage des exploits par Buffer Overflow pour plus d'informations.
    • Stratégie contre les programmes indésirables. Configurez la stratégie utilisée par les analyseurs à l'accès, à la demande et d'e-mails pour détecter les programmes potentiellement indésirables. Sélectionnez les catégories de programmes potentiellement indésirables à détecter dans une liste prédéfinie, puis définissez les autres programmes à détecter ou à exclure. Consultez la section Restriction de programmes potentiellement indésirables pour plus d'informations.
  4. Détectez les intrusions. Configurez ces fonctions afin qu'elles détectent les menaces potentielles sur vos systèmes, vous envoient une notification et entreprennent des actions en cas de détection :
    • AutoUpdate. Configurez les tâches de mise à jour pour obtenir les fichiers DAT, le moteur d'analyse et les mises à niveau du produit les plus récents. Consultez la section Mise à jour des définitions pour la détection pour plus d'informations.
    • Analyseur à l'accès. Configurez l'analyseur pour détecter et entreprendre des actions sur les menaces potentielles dès leur accès à votre environnement. Activez l'analyse des programmes indésirables et analysez les cookies du dossier des cookies. Consultez la section Analyse d'éléments à l'accès pour plus d'informations.
    • Analyseur à la demande. Configurez les tâches d'analyse pour détecter et entreprendre des actions sur les menaces potentielles dans votre environnement. Activez l'analyse des programmes indésirables et analysez les cookies du dossier des cookies et les entrées de Registre associées à des logiciels espions (spywares) potentiellement indésirables qui n'ont pas déjà été nettoyées. Consultez la section Analyse d'éléments à la demande pour plus d'informations.
    • Analyseur d'e-mails. Configurez l'analyse à la réception et à la demande des clients de messagerie Microsoft Outlook et Lotus Notes. Activer l'analyse des programmes indésirables. Consultez la section Analyse d'e-mails à la demande et à la réception pour plus d'informations.
  5. Envoyez des alertes et mettez les menaces en quarantaine. Configurez ces fonctions pour être alerté en cas de détections et pour gérer les éléments mis en quarantaine :
    • Alertes et notifications. Configurez les conditions de réception des notifications et alertes de détection. Consultez la section Configuration des alertes et des notifications pour plus d'informations.
    • Stratégie du Quarantine Manager. Configurez l'emplacement du dossier de quarantaine et le nombre de jours pendant lequel les éléments mis en quarantaine doivent être conservés avant suppression automatique. Consultez la section Eléments mis en quarantaine pour plus d'informations.
Concepts associés
Eléments mis en quarantaine
Tâches associées
Analyse d'e-mails à la demande et à la réception
Informations associées
Contrôle de l'accès à l'interface utilisateur
Mise à jour des définitions pour la détection
Protection des points d'accès à votre système
Blocage des exploits par Buffer Overflow
Restriction de programmes potentiellement indésirables
Analyse d'éléments à l'accès
Analyse d'éléments à la demande
Configuration des alertes et notifications


Partie I -- Prévention : éviter les menaces

La prévention constitue la première étape d'une stratégie de protection. Il s'agit d'empêcher les menaces d'accéder à votre système.

Sommaire

  • Protection d'accès
  • Protection des points d'accès à votre système
  • Blocage des exploits par Buffer Overflow
  • Restriction de programmes potentiellement indésirables
  • Mise à jour des définitions pour la détection
  • Exclusion d'éléments à analyser
  • Utilisation des tâches planifiées


Protection d'accès

La prévention de l'accès des menaces à votre système client constitue votre première ligne de défense contre les logiciels malveillants (malwares). La fonction de protection de l'accès de VirusScan Enterprise compare l'action demandée à une liste de règles configurées. Chaque règle peut être configurée pour bloquer ou notifier ou bloquer et notifier les violations d'accès lorsque celles-ci se produisent.

La protection d'accès empêche des modifications indésirables sur votre ordinateur en restreignant l'accès aux ports, aux fichiers, aux éléments partagés et aux clés et valeurs de Registre spécifiés. Elle protège également les processus McAfee en empêchant que les utilisateurs ne les arrêtent. Cette protection est essentielle avant et au cours des attaques.

Cette fonction utilise des règles prédéfinies et définies par l'utilisateur pour spécifier à quels éléments il est possible d'accéder. Chaque règle peut être configurée pour bloquer ou notifier ou bloquer et notifier les violations d'accès lorsque celles-ci se produisent. Les règles et catégories prédéfinies peuvent être mises à jour à partir des sites de mise à jour McAfee.

Remarque : l'analyseur à l'accès, qui détecte les violations d'accès, doit être activé pour détecter les tentatives d'accès aux ports, aux fichiers, aux éléments partagés et aux clés et valeurs de Registre.

Comment les menaces parviennent à accéder au système

Voici comment les menaces parviennent le plus couramment à accéder à votre système :
  • Macros : dans les applications de traitement de texte et de feuilles de calcul.
  • Fichiers exécutables : outre le programme attendu, certains logiciels apparemment inoffensifs peuvent contenir des virus. Voici par exemple quelques extensions de fichier courantes : EXE, .COM, .VBS, .BAT, .HLP et .DLL.
  • E-mail : blagues, jeux et images des e-mails avec pièces jointes.
  • Scripts : associés à des pages web et à des e-mails, les scripts ActiveX et JavaScript par exemple, lorsque vous autorisez leur exécution, peuvent contenir des virus.
  • Messages IRC (Internet Relay Chat) : les fichiers accompagnant ces messages peuvent facilement contenir des logiciels malveillants (malwares). Les processus de démarrage automatique par exemple peuvent contenir des menaces de type ver et cheval de Troie.
  • Fichiers d'aide de navigateur et d'application : le téléchargement de ces fichiers d'aide expose le système à des virus et fichiers exécutables imbriqués.
  • Combinaison de tous ces éléments : les créateurs de logiciels malveillants (malwares) sophistiqués combinent tous ces modes de distribution et imbriquent même des portions de logiciel malveillant (malware) dans d'autres pour tenter d'accéder à votre ordinateur.

Sommaire

Concepts associés
Blocage des menaces relatives à l'accès
Informations associées
Contrôle de l'accès à l'interface utilisateur


Blocage des menaces relatives à l'accès

En activant la fonction de protection de l'accès ou en modifiant la configuration de cette dernière, vous pouvez configurer la protection anti-espion (antispyware), la protection antivirus, la protection commune, la protection de la machine virtuelle et définir vos propres règles de protection. Ce qui suit représente le processus de base qu'utilise VirusScan Enterprise pour assurer la protection de l'accès.

Etapes suivies en cas de menace

  1. Un utilisateur ou un processus tente d'effectuer une action.
  2. Cette dernière est examinée par la fonction de protection de l'accès selon les règles définies.
  3. Lorsqu'une règle n'est pas respectée, l'action demandée par l'utilisateur ou le processus est traitée selon les informations des règles configurées. Par exemple, l'action ne déclenche aucun événement, elle est bloquée, ou bien elle est bloquée et l'envoi d'un rapport a lieu.
  4. Le fichier journal de protection d'accès est mis à jour et un événement est généré pour l'administrateur global ePolicy Orchestrator.

Exemple de menace d'accès

  1. Un utilisateur télécharge un programme, MonProgramme.exe, à partir d'Internet.
    Remarque : dans cet exemple, MonProgramme.exe n'est pas un logiciel malveillant (malware).
  2. L'utilisateur exécute le programme qui semble se lancer comme prévu.
  3. MonProgramme.exe exécute ensuite un processus enfant appelé ContrariezMoi.exe qui tente de modifier le système d'exploitation afin de s'assurer que le programme se charge toujours au démarrage.
  4. La fonction de protection de l'accès traite la requête et la compare à une règle existante configurée pour bloquer les menaces et les signaler.
  5. L'accès est refusé à ContrariezMoi.exe lorsqu'il tente de modifier le système d'exploitation et la fonction de protection de l'accès journalise les détails de la tentative et génère une alerte destinée à l'administrateur global ePolicy Orchestrator.

Rapport de journal et alertes générés

Voici un exemple d'entrée de journal de la protection d'accès.

10/02/2010 11:00:00 Bloqué par la règle Protection à l'accès TestDomain\TestUser C:\Users\TestUser\Desktop\ContrarieMoi.exe \REGISTRY\MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion\Run\ Empêcher l'enregistrement de programmes à des fins d'exécution automatique

Ce tableau décrit les données de l'entrée de journal de la protection d'accès ci-dessus :
Entrée de journal | Description
10/02/2010 | Date
11:00:00 | Heure
Bloqué par la règle Protection à l'accès | Action entreprise
TestDomain\TestUser | Informations d'identification
C:\Users\TestUser\Desktop\ContrariezMoi.exe | Nom du processus ayant enfreint la règle
\REGISTRY\MACHINE\SOFTWARE\Microsoft... | Emplacement auquel le processus a tenté d'accéder
Empêcher l'enregistrement de programmes à des fins d'exécution automatique | Règle Protection à l'accès déclenchée

Des informations similaires sont disponibles via les requêtes ePolicy Orchestrator. Pour en savoir plus, reportez-vous à la section Accès aux requêtes et aux tableaux de bord.

Informations associées
Accès aux requêtes et aux tableaux de bord


Contrôle de l'accès à l'interface utilisateur

Le paramétrage de la sécurité de l'interface sur les ordinateurs clients est une part importante de la protection de votre environnement.

En tant qu'administrateur, vous pouvez :
  • contrôler l'accès des utilisateurs à l'interface VirusScan Enterprise ;
  • définir un mot de passe pour empêcher que des utilisateurs n'accèdent aux fonctions sélectionnées ou ne les modifient ;
  • verrouiller et déverrouiller l'interface utilisateur selon vos besoins.

Sommaire

Concepts associés
Incidence de la définition d'un mot de passe sur les utilisateurs
Tâches associées
Configuration des paramètres de sécurité de l'interface utilisateur


Incidence de la définition d'un mot de passe sur les utilisateurs

Définissez un mot de passe pour l'interface utilisateur afin de dissuader les utilisateurs animés d'intentions malveillantes.

Lorsque vous protégez l'interface utilisateur sur des ordinateurs clients au moyen d'un mot de passe, cela se répercute différemment sur les utilisateurs :

  • Non-administrateurs : utilisateurs sans droits d'administrateur. Les non-administrateurs exécutent toutes les applications de VirusScan Enterprise en mode lecture seule. Ils peuvent visualiser certains paramètres de configuration, exécuter des analyses enregistrées, ainsi que des analyses et des mises à jour immédiates. Cependant, ils ne peuvent pas modifier les paramètres de configuration, ni créer, supprimer ou modifier des analyses enregistrées ou des tâches de mise à jour.
  • Administrateurs : utilisateurs disposant de droits d'administrateur. Les administrateurs doivent saisir le mot de passe afin d'accéder aux commandes et onglets protégés en mode lecture/écriture. En l'absence de mot de passe pour un élément protégé, ils le visualiseront en mode lecture seule.


Configuration des paramètres de sécurité de l'interface utilisateur

Utilisez les propriétés de l'interface utilisateur des stratégies relatives aux options générales pour configurer les options d'affichage et de mot de passe auxquelles les utilisateurs peuvent accéder.
ATTENTION :
examinez attentivement les conséquences que les modifications de propriétés sont susceptibles d'avoir sur la sécurité avant de les appliquer. Ces options vous permettent de limiter ou d'autoriser les utilisateurs à apporter des modifications à leur configuration de sécurité et peuvent laisser les systèmes sans protection contre nombre d'attaques de logiciels malveillants (malwares).

Configurez les propriétés de l'interface utilisateur des stratégies relatives aux options générales à l'aide des consoles correspondantes.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les propriétés de l'interface utilisateur des stratégies relatives aux options générales.

Tâche

Pour une définition des options, cliquez sur ? dans chaque onglet.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans l'onglet Options d'affichage, configurez les icônes VirusScan Enterprise de la barre d'état système à afficher pour les utilisateurs ainsi que les paramètres de langue de ces derniers.
  5. Dans l'onglet Options de mot de passe, configurez les tâches VirusScan Enterprise et options de l'interface utilisateur que les utilisateurs peuvent modifier via le mot de passe approprié.


ePolicy Orchestrator 4.0

Configurez les propriétés de l'interface utilisateur des stratégies relatives aux options générales.

Tâche

Pour une définition des options, cliquez sur ? dans chaque onglet.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans l'onglet Options d'affichage, configurez les icônes VirusScan Enterprise de la barre d'état système à afficher pour les utilisateurs ainsi que les paramètres de langue de ces derniers.
  5. Dans l'onglet Options de mot de passe, configurez les tâches VirusScan Enterprise et options de l'interface utilisateur que les utilisateurs peuvent modifier via le mot de passe approprié.


Console VirusScan

Configurez les propriétés de l'interface utilisateur des options générales.

Tâche

Pour une définition des options, cliquez sur Aide dans chaque onglet.

  1. Cliquez sur Outils | Options générales pour ouvrir la boîte de dialogue de configuration des options générales.
  2. Dans l'onglet Options d'affichage, configurez les icônes VirusScan Enterprise de la barre d'état système à afficher pour les utilisateurs ainsi que les paramètres de langue de ces derniers.
  3. Dans l'onglet Options de mot de passe, configurez les tâches VirusScan Enterprise et options de l'interface utilisateur que les utilisateurs peuvent modifier via le mot de passe approprié.


Protection des points d'accès à votre système

La protection d'accès empêche des modifications indésirables sur votre ordinateur en restreignant l'accès aux ports, aux fichiers, aux éléments partagés et aux clés et valeurs de Registre spécifiés. Elle protège également les processus McAfee en empêchant que les utilisateurs ne les arrêtent. Cette protection est essentielle avant et au cours des attaques.

Cette fonction utilise des règles et catégories prédéfinies et des règles définies par l'utilisateur pour spécifier à quels éléments il est possible ou non d'accéder. Chaque règle peut être configurée pour bloquer et rapporter les violations de point d'accès lorsque celles-ci se produisent. Les règles et catégories prédéfinies peuvent faire l'objet de mises à jour de contenu par l'intermédiaire des sites de mises à jour McAfee.

Sommaire

Concepts associés
Violations de point d'accès et réponse de VirusScan Enterprise
Tâches associées
Configuration des paramètres de protection d'accès
Référence associée
Définition des règles de protection d'accès
Types des règles définies par l'utilisateur


Définition des règles de protection d'accès

Les règles sont séparées en trois catégories et fournissent trois niveaux de protection.

Description des types de règle

Type de règle Description
Antivirus

Ces règles préconfigurées protègent votre ordinateur contre les comportements courants de logiciels malveillants (malwares). Vous pouvez les activer, les désactiver et modifier leur configuration, mais vous ne pouvez pas les supprimer.

Voici deux exemples de règles :

  • Empêcher la désactivation ou la modification de processus critiques, la création ou la modification à distance de fichiers exécutables, le détournement de fichiers exécutables, l'usurpation du processus Windows et l'envoi d'e-mails par les vers de diffusion massive.
  • Protéger les fichiers de répertoire des voleurs de mots de passe et d'adresses de messagerie.

Les niveaux de protection ci-dessous s'appliquent aux règles antivirus :

  • Protection standard
  • Protection maximale
  • Contrôle des attaques
Communes

Ces règles préconfigurées empêchent la modification des fichiers et des paramètres fréquemment utilisés. Vous pouvez les activer, les désactiver et modifier leur configuration, mais vous ne pouvez pas les supprimer.

Voici trois exemples de règles :

  • Empêcher la modification des fichiers et paramètres McAfee.
  • Protéger les fichiers et les paramètres de Mozilla et Firefox, les paramètres d'Internet Explorer et les paramètres réseau.
  • Empêcher l'installation d'objets d'aide à la navigation et l'exécution automatique de programmes à partir du dossier Temp.

Les niveaux de protection ci-dessous s'appliquent aux règles communes :

  • Protection standard
  • Protection maximale
Protection de la machine virtuelle

Ces règles préconfigurées empêchent l'arrêt des processus VMWare et la modification des fichiers VMWare. Vous pouvez les activer, les désactiver et modifier leur configuration, mais vous ne pouvez pas les supprimer.

Voici quelques exemples :
  • Empêcher l'arrêt des processus VMWare.
  • Empêcher la modification des fichiers du poste de travail, du serveur ou de la machine virtuelle VMWare.
Définies par l'utilisateur

Ces règles personnalisées complètent la protection fournie par les règles Antivirus et Communes.

Antispyware

Voici quelques exemples :
  • Protéger les favoris et les paramètres d'Internet Explorer.
  • Empêcher l'exécution de programmes et de scripts à partir du dossier Temp.

Description des niveaux de protection

Niveau de protection | Description
Standard | Règles antivirus et règles communes qui protègent certains paramètres et fichiers critiques contre la modification, mais qui vous permettent généralement d'installer et d'exécuter les logiciels légitimes.
Maximale | Règles antivirus et règles communes qui empêchent la modification de la plupart des paramètres et des fichiers critiques. Ce niveau offre une protection supérieure à la protection standard, mais il peut empêcher l'installation d'un logiciel légitime. Si vous ne pouvez pas installer un logiciel, il est recommandé de désactiver au préalable la fonction Protection d'accès, puis de l'activer à nouveau après l'installation.
Contrôle des attaques | Règles antivirus qui empêchent un code destructeur d'accéder à l'ordinateur jusqu'à la diffusion d'un fichier DAT. Ces règles sont préconfigurées pour bloquer l'accès aux éléments partagés au cours d'une attaque.


Violations de point d'accès et réponse de VirusScan Enterprise

Une violation d'accès se produit lorsqu'un processus ou un utilisateur disposant d'un accès restreint tente de démarrer, d'arrêter ou d'accéder à des composants de votre ordinateur.

Lorsqu'une violation de point d'accès a lieu :

  • Les informations sont enregistrées dans le fichier journal si vous avez sélectionné l'option Rapport dans la règle qui a détecté la violation.
  • L'événement est enregistré dans le journal d'événements local et via SNMP, si vous avez choisi cette option dans les Propriétés d'alerte.
  • L'événement est signalé à Alert Manager et à ePolicy Orchestrator, si ces produits sont configurés en conséquence.
  • Les actions Bloquer et Rapport d'une règle déterminent l'action à entreprendre si cette dernière détecte une violation.
  • Sur un système client autonome, un cadre rouge s'affiche autour de l'icône de la barre d'état système et reste visible durant 30 minutes, sauf si vous en demandez la réinitialisation.
    Remarque : pour ce faire, ouvrez le Fichier journal de la protection d'accès à partir de l'icône de la barre d'état système. L'ouverture du fichier journal à l'aide de toute autre méthode ne restaure pas l'icône à son état d'origine.


Types des règles définies par l'utilisateur

Lors de la configuration d'une nouvelle règle de protection d'accès définie par l'utilisateur, vous pouvez créer des règles de blocage de ports, blocage de fichiers et de dossiers et blocage du Registre.

Le tableau suivant décrit ces règles.

Description des règles

Règle | Description
Règle de blocage de ports Bloque le trafic réseau entrant ou sortant au niveau de ports ou de séries de ports spécifiques.
Remarque : lorsque vous bloquez un port, les accès TCP (Transmission Control Protocol) et UDP (User Datagram Protocol) sont bloqués.
Remarque : lorsque vous bloquez un port ou une série de ports, tout protocole utilisant ce port ou cette série est bloqué. Par exemple, les accès TCP (Transmission Control Protocol) et UDP (User Datagram Protocol) sont bloqués.
Règle de blocage de fichier/dossier Bloque l'accès en écriture à ces fichiers et dossiers ainsi que l'exécution, la création et la suppression de fichiers.
Remarque : une fois que vous avez limité l'accès à un fichier ou à un dossier, seul l'administrateur peut revenir sur cette restriction. Cela permet de bloquer les intrusions et les empêche de se propager au cours d'une attaque.
Règle de blocage du Registre | Protège les clés ou valeurs de Registre en bloquant les actions suivantes : écriture, création ou suppression.


Configuration des paramètres de protection d'accès

Utilisez les Stratégies de protection lors de l'accès pour protéger les points d'accès de votre système et empêcher l'arrêt des processus McAfee.
ATTENTION :
si vous n'activez pas la protection d'accès afin d'empêcher l'arrêt des services McAfee, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Vous pouvez configurer deux types de règles de protection d'accès.
  • Règles prédéfinies : elles vous permettent :
    • d'ouvrir la catégorie de règles de protection d'accès dans l'une des consoles d'interface utilisateur ;
    • de sélectionner le bloc et signaler l'action à entreprendre si la règle est enfreinte.
  • Règles définies par l'utilisateur : elles vous permettent :
    • de créer la catégorie de règles définies par l'utilisateur à l'aide de l'une des consoles d'interface utilisateur ;
    • de choisir le type de blocage appliqué par la règle : blocage de ports, blocage de fichiers et de dossiers ou blocage du Registre ;
    • de configurer les détails de la règle ;
    • d'enregistrer la règle et de la modifier ultérieurement, si nécessaire.

Tâches

Tâches associées
Configuration des règles prédéfinies
Configuration des règles définies par l'utilisateur
Suppression des règles définies par l'utilisateur
Référence associée
Options des règles de blocage de ports
Options des règles de blocage de fichiers et de dossiers
Options des règles de blocage du Registre
Options d'inclusion ou d'exclusion de processus spécifiques


Configuration des règles prédéfinies

Utilisez les règles prédéfinies pour protéger votre ordinateur contre les modifications indésirables. Ces règles peuvent être activées et modifiées mais ne peuvent pas être supprimées.

Les règles de protection d'accès prédéfinies incluent :
  • Protection standard contre les logiciels espions
  • Protection maximale contre les logiciels espions
  • Protection standard antivirus
  • Protection maximale antivirus
  • Contrôle des attaques d'antivirus
  • Protection standard commune
  • Protection maximale commune
  • Protection de la machine virtuelle

Consultez la section Définition des règles de protection d'accès pour en savoir plus sur ces règles de protection d'accès prédéfinies.

Configurez les règles de protection d'accès prédéfinies à l'aide de l'une de ces consoles d'interface utilisateur.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les règles de protection d'accès prédéfinies à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégie de protection d'accès, cliquez sur l'onglet Protection d'accès pour afficher les règles de protection d'accès.
  5. Sélectionnez l'une des catégories de règles prédéfinies du volet de gauche, puis la règle spécifique dans celui de droite.
  6. Configurez les options Bloquer ou Rapport, ou Bloquer et Rapport à la fois.
  7. Cliquez sur Modifier pour configurer les Détails des règles.


ePolicy Orchestrator 4.0

Configurez les règles de protection d'accès prédéfinies à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégie de protection d'accès, cliquez sur l'onglet Protection d'accès pour afficher les règles de protection d'accès.
  5. Sélectionnez l'une des catégories de règles prédéfinies du volet de gauche, puis la règle spécifique dans celui de droite.
  6. Configurez les options Bloquer ou Rapport, ou Bloquer et Rapport à la fois.
  7. Cliquez sur Modifier pour configurer les Détails des règles.


Console VirusScan

Configurez les règles de protection d'accès prédéfinies à partir des propriétés de protection d'accès.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Protection d'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Dans la boîte de dialogue Stratégie de protection d'accès, cliquez sur l'onglet Protection d'accès pour afficher les règles de protection d'accès.
  3. Sélectionnez l'une des catégories de règles prédéfinies du volet de gauche, puis la règle spécifique dans celui de droite.
  4. Configurez les options Bloquer ou Rapport, ou Bloquer et Rapport à la fois.
  5. Cliquez sur Modifier pour configurer les Détails des règles.


Configuration des règles définies par l'utilisateur

Créez et modifiez des règles définies par l'utilisateur afin de compléter la protection fournie par les règles prédéfinies.

Consultez la section Définition des règles de protection d'accès pour en savoir plus sur les règles de protection d'accès prédéfinies.

Créez et modifiez des règles de protection d'accès définies par l'utilisateur à l'aide de l'une de ces consoles d'interface utilisateur.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les règles de protection d'accès définies par l'utilisateur à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Sélectionnez la catégorie Règles définies par l'utilisateur du volet de gauche, puis cliquez sur Nouvelle pour ouvrir la boîte de dialogue Sélectionner le nouveau type de règle.
  5. Sélectionnez le type de règle et cliquez sur OK. Consultez la section Types des règles définies par l'utilisateur pour en savoir plus. La boîte de dialogue qui s'affiche dépend du type de règle sélectionné.
  6. Configurez les détails de cette règle d'accès.
    • Règle de protection d'accès de port réseau : reportez-vous au tableau d'options de la section Options des règles de blocage de ports.
    • Règle de protection d'accès de fichier/ dossier : reportez-vous au tableau d'options de la section Options des règles de blocage de fichiers et de dossiers.
    • Règle de protection d'accès du Registre : reportez-vous au tableau d'options de la section Options des règles de blocage du Registre.
    Remarque : pour configurer les processus à inclure et à exclure, reportez-vous à la section Options d'inclusion ou d'exclusion de processus spécifiques.
  7. Cliquez sur OK. La nouvelle règle définie par l'utilisateur s'affiche dans le volet de droite sous Bloquer/Rapport/Règles. Pour modifier la nouvelle règle, sélectionnez-la et cliquez sur Modifier.


ePolicy Orchestrator 4.0

Configurez les règles de protection d'accès définies par l'utilisateur à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Sélectionnez la catégorie Règles définies par l'utilisateur du volet de gauche, puis cliquez sur Nouvelle pour ouvrir la boîte de dialogue Sélectionner le nouveau type de règle.
  5. Sélectionnez le type de règle et cliquez sur OK. Consultez la section Types des règles définies par l'utilisateur pour en savoir plus. La boîte de dialogue qui s'affiche dépend du type de règle sélectionné.
  6. Configurez les détails de cette règle d'accès.
    • Règle de protection d'accès de port réseau : reportez-vous au tableau d'options de la section Options des règles de blocage de ports.
    • Règle de protection d'accès de fichier/ dossier : reportez-vous au tableau d'options de la section Options des règles de blocage de fichiers et de dossiers.
    • Règle de protection d'accès du Registre : reportez-vous au tableau d'options de la section Options des règles de blocage du Registre.
    Remarque : pour configurer les processus à inclure et à exclure, reportez-vous à la section Options d'inclusion ou d'exclusion de processus spécifiques.
  7. Cliquez sur OK. La nouvelle règle définie par l'utilisateur s'affiche dans le volet de droite sous Bloquer/Rapport/Règles. Pour modifier la nouvelle règle, sélectionnez-la et cliquez sur Modifier.


Console VirusScan

Configurez les règles de protection d'accès définies par l'utilisateur à partir des propriétés de protection d'accès.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Dans la liste Tâche, cliquez sur Protection d'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Sélectionnez la catégorie Règles définies par l'utilisateur du volet de gauche, puis cliquez sur Nouvelle pour ouvrir la boîte de dialogue Sélectionner le nouveau type de règle.
  3. Sélectionnez le type de règle et cliquez sur OK. Consultez la section Types des règles définies par l'utilisateur pour en savoir plus. La boîte de dialogue qui s'affiche dépend du type de règle sélectionné.
  4. Configurez les détails de cette règle d'accès.
    • Règle de protection d'accès de port réseau : reportez-vous au tableau d'options de la section Options des règles de blocage de ports.
    • Règle de protection d'accès de fichier/ dossier : reportez-vous au tableau d'options de la section Options des règles de blocage de fichiers et de dossiers.
    • Règle de protection d'accès du Registre : reportez-vous au tableau d'options de la section Options des règles de blocage du Registre.
    Remarque : pour configurer les processus à inclure et à exclure, reportez-vous à la section Options d'inclusion ou d'exclusion de processus spécifiques.
  5. Cliquez sur OK. La nouvelle règle définie par l'utilisateur s'affiche dans la colonne Règles du volet de droite. Pour modifier la nouvelle règle, sélectionnez-la et cliquez sur Modifier.


Options des règles de blocage de ports

Les règles de blocage de ports empêchent les utilisateurs d'accéder à des ports entrants et sortants spécifiques et les autres ordinateurs d'accéder à celui qui est utilisé.

Définition des options

Option | Définition
Nom de la règle | Entrer le nom de cette règle.
Processus à inclure | Limiter l'accès aux processus spécifiés.
Processus à exclure | Autoriser l'accès aux processus spécifiés.
Port de début | Indiquer le numéro du premier port. Il peut s'agir d'un seul port ou du premier numéro d'une série de ports. Remarque : si vous bloquez l'accès à un port utilisé par McAfee Agent ou l'agent Host Intrusion Prevention, les processus de l'agent sont approuvés et donc autorisés à communiquer avec le port bloqué. Tout le trafic non lié aux processus de ces agents est bloqué.
Port de fin | Indiquer le numéro du dernier port dans une série de ports.
Entrant | Empêcher les systèmes du réseau d'accéder aux ports spécifiés.
Sortant | Empêcher les processus locaux d'accéder aux ports spécifiés sur le réseau.


Options des règles de blocage de fichiers et de dossiers

Les règles de blocage de fichiers et de dossiers empêchent les utilisateurs non autorisés de modifier, ouvrir ou supprimer des fichiers et dossiers spécifiques.

Définition des options

Option | Définition
Nom de la règle | Entrer le nom de cette règle.
Processus à inclure | Limiter l'accès aux processus spécifiés.
Processus à exclure | Autoriser l'accès aux processus spécifiés.
Nom de fichier ou de dossier à bloquer | Bloquer l'accès au fichier ou dossier spécifié.
Rechercher le fichier | Accéder au fichier.
Rechercher le dossier | Accéder au dossier.
Accès en lecture aux fichiers | Bloquer l'accès en lecture aux fichiers spécifiés.
Accès en écriture aux fichiers | Bloquer l'accès en écriture aux fichiers spécifiés.
Fichiers en cours d'exécution | Bloquer l'exécution des fichiers dans le dossier spécifié.
Nouveaux fichiers en cours de création | Bloquer la création de nouveaux fichiers dans le dossier spécifié.
Fichiers en cours de suppression | Bloquer la suppression des fichiers du dossier spécifié.


Options des règles de blocage du Registre

Les règles de blocage du Registre empêchent les utilisateurs et programmes non autorisés de modifier, ouvrir ou supprimer des clés et valeurs de Registre spécifiques.

Remarque : lors de la création d'une règle de blocage du Registre, utilisez l'abréviation de sous-arborescence de ruche de Registre correspondant le mieux. Par exemple, pour bloquer HKLM\System\CurrentControlSet\Services\MyService, choisissez la ruche HKCCS plutôt que la ruche HKLM.

Définition des options

Option | Définition
Nom de la règle | Spécifier le nom de cette règle.
Processus à inclure | Limiter l'accès aux processus spécifiés.
Processus à exclure | Autoriser l'accès aux processus spécifiés.
Clé ou valeur de Registre à protéger Protéger cette clé ou valeur de Registre :
  • Sélectionnez une clé ou une valeur racine dans la liste déroulante.
  • Entrez une clé ou une valeur dans la zone de texte.
La sélection d'une clé ou d'une valeur racine dans la liste déroulante est facultative. Utilisez l'une des méthodes suivantes pour indiquer la clé ou la valeur :
  • Sélectionnez la clé ou la valeur racine dans la liste déroulante, puis entrez le reste du chemin de la clé ou de la valeur dans la zone de texte.
  • Entrez le chemin complet de la clé ou de la valeur dans la zone de texte.
Type de règle Sélectionner le type de règle :
  • Clé : cette règle protège la clé spécifiée.
  • Valeur : cette règle protège la valeur spécifiée.
Ecrire une clé ou une valeur | Bloquer l'écriture de la clé ou de la valeur spécifiée.
Créer une clé ou une valeur | Bloquer la création de la clé ou de la valeur spécifiée.
Supprimer la clé ou la valeur | Bloquer la suppression de la clé ou de la valeur spécifiée.


Options d'inclusion ou d'exclusion de processus spécifiques

Définition des options

Pour modifier les détails de la règle, tels que son nom et les processus à inclure ou exclure, utilisez l'option Protection d'accès et cliquez sur Modifier.

Option | Description
Nom de la règle | Nom de cette règle. Par exemple, Empêcher la désactivation de l'éditeur du Registre et du Gestionnaire des tâches.
Processus à inclure | Restreindre l'accès à ces processus. Indiquez le nom de processus exact ou utilisez un caractère générique pour désigner une collection de processus, comme *.EXE, puis ajoutez des exclusions pour des processus spécifiques et légitimes, comme SETUP.EXE. Par exemple, spécifiez * pour inclure tous les processus.
Processus à exclure | Autoriser l'accès à ces processus. Utilisez le nom de processus exact. Par exemple, définissez ces exclusions : avtask.exe, cfgwiz,exe, fssm32.exe, giantantispywar*, kavsvc.exe, mmc.exe, navw32.exe, nmain.exe, rtvscan.exe.


Suppression des règles définies par l'utilisateur

Supprimez les règles que vous avez créées mais que vous n'utilisez plus.

Supprimez les règles définies par l'utilisateur à l'aide de l'une de ces consoles d'interface utilisateur.


ePolicy Orchestrator 4.5 ou 4.6

Supprimez les règles que vous avez créées mais que vous n'utilisez plus à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? ou Aide dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Sélectionnez la catégorie Règles définies par l'utilisateur dans le volet de gauche, puis sélectionnez la règle que vous souhaitez supprimer dans le volet de droite.
  5. Cliquez sur Supprimer.
    Remarque : pour désactiver une règle sans la supprimer, désélectionnez les actions Bloquer et Rapport. Vous pouvez activer à nouveau cette règle si nécessaire.


ePolicy Orchestrator 4.0

Supprimez les règles que vous avez créées mais que vous n'utilisez plus à partir des Stratégies de protection lors de l'accès.

Tâche

Pour une définition des options, cliquez sur ? ou Aide dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Sélectionnez la catégorie Règles définies par l'utilisateur dans le volet de gauche, puis sélectionnez la règle que vous souhaitez supprimer dans le volet de droite.
  5. Cliquez sur Supprimer.
    Remarque : pour désactiver une règle sans la supprimer, désélectionnez les actions Bloquer et Rapport. Vous pouvez activer à nouveau cette règle si nécessaire.


Console VirusScan

Supprimez les règles que vous avez créées mais que vous n'utilisez plus à partir des propriétés de protection d'accès.

Supprimez les règles définies par l'utilisateur à l'aide de l'une de ces consoles d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? ou Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Protection d'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Sélectionnez la catégorie Règles définies par l'utilisateur dans le volet de gauche, puis sélectionnez la règle que vous souhaitez supprimer dans le volet de droite.
  3. Cliquez sur Supprimer.
    Remarque : pour désactiver une règle sans la supprimer, désélectionnez les actions Bloquer et Rapport. Vous pouvez activer à nouveau cette règle si nécessaire.


Blocage des exploits par Buffer Overflow

La protection en cas de Buffer Overflow permet d'éviter que les exploits par Buffer Overflow n'exécutent un code arbitraire sur votre ordinateur. Elle contrôle les appels API du mode utilisateur et identifie les appels dus à un Buffer Overflow.

Lorsqu'une détection se produit, les informations sont enregistrées dans le journal d'activité et s'affichent dans la boîte de dialogue Messages d'analyse lors de l'accès si vous avez configuré ainsi ces options.

VirusScan Enterprise utilise un fichier DAT de protection d'accès et contre le Buffer Overflow pour protéger environ 30 applications, par exemple Internet Explorer, Microsoft Outlook, Outlook Express, Microsoft Word et MSN Messenger.

Sommaire

Concepts associés
Fonctionnement des exploits par Buffer Overflow
Tâches associées
Configuration de la protection en cas de Buffer Overflow


Fonctionnement des exploits par Buffer Overflow

Les agresseurs se servent des exploits par Buffer Overflow pour lancer un code exécutable en faisant déborder la mémoire tampon fixe réservée à un processus d'entrée. Ce code leur permet ensuite de prendre le contrôle de l'ordinateur cible ou d'en compromettre les données.

Il existe deux types d'exploit par Buffer Overflow :
  • Attaques basées sur les tas : elles inondent l'espace mémoire réservé à un programme, mais elles sont difficiles à réaliser et rares.
  • Attaques basées sur les piles : elles utilisent les objets de la mémoire de la pile pour stocker les entrées de l'utilisateur ; ce sont les plus communes.
Le processus suivant décrit des attaques par Buffer Overflow basées sur des piles :
  1. Processus normal de mémoire de pile : l'objet de la mémoire de pile de taille fixe est généralement vide et en attente d'une entrée de l'utilisateur. Lorsqu'un programme reçoit des entrées de l'utilisateur, telles que son nom, ces données sont stockées sur le dessus de la pile et une adresse mémoire de retour leur est attribuée. Lors du traitement de la pile, les entrées de l'utilisateur sont envoyées à l'adresse de retour définie par le programme.
  2. Dépassement de la pile : lors de l'écriture d'un programme, une quantité spécifique de mémoire est réservée aux données. La pile déborde si les données écrites sont plus volumineuses que l'espace qui leur est réservé dans la mémoire. Ce phénomène constitue un problème uniquement lorsqu'il est combiné à des entrées malveillantes.
  3. Exploitation du dépassement : si le programme attend que l'utilisateur entre son nom, mais que l'agresseur entre une commande exécutable dépassant la taille de la pile, cette commande est enregistrée en dehors de l'espace réservé.
  4. Exécution du code malveillant : la commande n'est pas exécutée automatiquement simplement parce qu'elle déborde de la mémoire tampon d'une pile. Mais cela peut se produire si une adresse de retour pointant vers la commande malveillante est fournie par l'agresseur. Le programme commence d'abord à planter à cause du Buffer Overflow, puis il tente de corriger le problème en utilisant l'adresse de retour fournie par l'agresseur. S'il s'agit d'une adresse valide, la commande malveillante est exécutée.
  5. Exploitation des autorisations : les programmes s'exécutent généralement en mode noyau ou avec des autorisations héritées d'un compte de service. Le code malveillant s'exécute donc à présent avec les mêmes autorisations que l'application compromise. Par conséquent, l'agresseur peut obtenir le contrôle total du système d'exploitation.


Configuration de la protection en cas de Buffer Overflow

Pour empêcher les applications d'exécuter un code arbitraire sur votre ordinateur, vous devez configurer les stratégies de protection en cas de Buffer Overflow.

Configurez les stratégies de protection en cas de Buffer Overflow via les consoles d'interface utilisateur suivantes.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies de protection en cas de Buffer Overflow via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies de protection en cas de Buffer Overflow, cliquez sur l'onglet Protection en cas de Buffer Overflow, puis configurez les éléments suivants :
    1. Activez les Paramètres de la protection en cas de Buffer Overflow ainsi que le mode de protection utilisé. Configurez ce mode pour qu'il bloque les exploits ou qu'il envoie simplement un message et qu'il journalise l'événement.
    2. Activez les Avertissements du système client envoyés lorsqu'un exploit par Buffer Overflow se produit.
    3. Configurez les Exclusions en cas de Buffer Overflow pour des valeurs d'API (Application Programming Interface, interface de programmation d'applications) spécifiques, ainsi que des processus et noms de modules facultatifs à exclure.
  5. Cliquez sur l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


ePolicy Orchestrator 4.0

Configurez les stratégies de protection en cas de Buffer Overflow via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies de protection en cas de Buffer Overflow, cliquez sur l'onglet Protection en cas de Buffer Overflow, puis configurez les éléments suivants :
    1. Activez les Paramètres de la protection en cas de Buffer Overflow ainsi que le mode de protection utilisé. Configurez ce mode pour qu'il bloque les exploits ou qu'il envoie simplement un message et qu'il journalise l'événement.
    2. Activez les Avertissements du système client envoyés lorsqu'un exploit par Buffer Overflow se produit.
    3. Configurez les Exclusions en cas de Buffer Overflow pour des valeurs d'API (Application Programming Interface, interface de programmation d'applications) spécifiques, ainsi que des processus et noms de modules facultatifs à exclure.
  5. Cliquez sur l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


Console VirusScan

Configurez les stratégies de protection en cas de Buffer Overflow via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Dans la liste Tâche, cliquez sur Protection en cas de Buffer Overflow avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Dans la page Propriétés de protection en cas de Buffer Overflow, cliquez sur l'onglet Protection en cas de Buffer Overflow, puis configurez les éléments suivants :
    1. Activez les Paramètres de la protection en cas de Buffer Overflow ainsi que le mode de protection utilisé. Configurez ce mode pour qu'il bloque les exploits ou qu'il envoie simplement un message et qu'il journalise l'événement.
    2. Activez les Avertissements du système client envoyés lorsqu'un exploit par Buffer Overflow se produit.
    3. Configurez les Exclusions en cas de Buffer Overflow pour des valeurs d'API (Application Programming Interface, interface de programmation d'applications) spécifiques, ainsi que des processus et noms de modules facultatifs à exclure.
  3. Cliquez sur l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


Restriction de programmes potentiellement indésirables

VirusScan Enterprise protège votre ordinateur des programmes potentiellement indésirables nuisibles ou pouvant représenter un risque pour la sécurité. Une stratégie commune contre les programmes indésirables est configurée, mais vous pouvez activer ou désactiver la stratégie séparément et spécifier des actions pour chaque analyseur VirusScan Enterprise.

Les programmes potentiellement indésirables (PUP) sont des logiciels écrits par des entreprises légitimes qui peuvent modifier l'état de la sécurité ou la politique de confidentialité de l'ordinateur sur lequel ils sont installés. Ces logiciels peuvent inclure (mais ce n'est pas toujours le cas) des logiciels espions (spywares), des logiciels publicitaires (adwares) et des numéroteurs. Ces programmes imbriqués peuvent être téléchargés en même temps qu'un programme que vous souhaitez acquérir. Les utilisateurs soucieux de la sécurité reconnaissent ces programmes et, dans certains cas, les suppriment.


Configuration relative aux programmes indésirables

Pour protéger votre ordinateur contre les programmes potentiellement indésirables, vous devez configurer les catégories de programmes indésirables à détecter dans votre environnement.

La configuration est un processus en deux étapes :

  1. Configurez la Stratégie contre les programmes indésirables pour définir les programmes potentiellement indésirables à détecter et à exclure :
    • Sélectionnez des catégories entières de programmes ou des programmes spécifiques au sein d'une catégorie à partir d'une liste prédéfinie, stockée dans le fichier DAT actuel.
    • Indiquez les exclusions.
    • Créez une liste de programmes définis par l'utilisateur à détecter.

  2. Activez la détection des programmes indésirables dans les analyseurs à l'accès, à la demande et les analyseurs d'e-mails, puis configurez les actions à entreprendre en cas de détection d'un programme indésirable.

Remarque : la détection des programmes indésirables est activée différemment pour l'analyseur à la demande car l'analyse à la demande est une tâche et non une stratégie. Consultez la section Configuration des tâches d'analyse à la demande pour en savoir plus.

Tâches

Tâches associées
Accès aux stratégies contre les programmes indésirables
Activation de la détection des programmes indésirables dans les analyseurs à l'accès et les analyseurs d'e-mails


Accès aux stratégies contre les programmes indésirables

Configurez les stratégies contre les programmes indésirables en sélectionnant les catégories de programmes indésirables à détecter, par exemple les logiciels espions (spywares) et publicitaires (adwares). Vous pouvez également spécifier des exclusions concernant les programmes à détecter.

Accédez aux stratégies contre les programmes indésirables via l'une des consoles d'interface utilisateur suivantes.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies contre les programmes indésirables à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégie contre les programmes indésirables, cliquez sur l'onglet Eléments à analyser pour configurer :
    1. Catégories de programmes indésirables à détecter : par exemple, les logiciels espions (spywares) et publicitaires (adwares). Ces catégories sont définies par le fichier DAT actuel.
    2. Exclusions : vous devez spécifier le nom exact de la détection à exclure, pas le nom de fichier.
  5. Cliquez sur l'onglet Détections définies par l'utilisateur et spécifiez les programmes ou fichiers individuels à traiter comme des programmes indésirables. Spécifiez chaque élément par nom de fichier et fournissez une définition pour chacun d'entre eux.


ePolicy Orchestrator 4.0

Configurez les stratégies contre les programmes indésirables à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégie contre les programmes indésirables, cliquez sur l'onglet Eléments à analyser pour configurer :
    1. Catégories de programmes indésirables à détecter : par exemple, les logiciels espions (spywares) et publicitaires (adwares). Ces catégories sont définies par le fichier DAT actuel.
    2. Exclusions : vous devez spécifier le nom exact de la détection à exclure, pas le nom de fichier.
  5. Cliquez sur l'onglet Détections définies par l'utilisateur et spécifiez les programmes ou fichiers individuels à traiter comme des programmes indésirables. Spécifiez chaque élément par nom de fichier et fournissez une définition pour chacun d'entre eux.


Console VirusScan

Configurez les propriétés relatives aux programmes indésirables à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Stratégie contre les programmes indésirables avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue Stratégie contre les programmes indésirables.
  2. Dans la page Stratégie contre les programmes indésirables, cliquez sur l'onglet Eléments à analyser pour configurer :
    1. Catégories de programmes indésirables à détecter : par exemple, les logiciels espions (spywares) et publicitaires (adwares). Ces catégories sont définies par le fichier DAT actuel.
    2. Exclusions : vous devez spécifier le nom exact de la détection à exclure, pas le nom de fichier.
  3. Cliquez sur l'onglet Détections définies par l'utilisateur et spécifiez les programmes ou fichiers individuels à traiter comme des programmes indésirables. Spécifiez chaque élément par nom de fichier et fournissez une définition pour chacun d'entre eux.


Activation de la détection des programmes indésirables dans les analyseurs à l'accès et les analyseurs d'e-mails

Pour que les analyseurs à l'accès et les analyseurs d'e-mails détectent les programmes indésirables, vous devez activer la fonctionnalité correspondante à partir de l'onglet Eléments à analyser.

Pour ce faire, utilisez les consoles d'interface utilisateur suivantes.
Remarque : pour activer la fonction de détection des programmes indésirables par l'analyseur à la demande, reportez-vous à la section Configuration des tâches d'analyse à la demande.


ePolicy Orchestrator 4.5 ou 4.6

Activez la fonction de détection des programmes indésirables par les analyseurs à l'accès et les analyseurs d'e-mails via la console ePolicy Orchestrator 4.5 ou 4.6.

Le processus utilisé pour activer la détection des programmes indésirables dans les analyseurs à l'accès et les analyseurs d'e-mails est globalement identique. La seule différence repose dans la stratégie que vous sélectionnez dans le catalogue de stratégies à l'étape 2. Pour activer la détection des programmes indésirables pour :
  • Analyse à l'accès : sélectionnez Stratégies d'analyse à l'accès.
  • Analyse d'e-mails : sélectionnez Stratégies de l'analyseur d'e-mails à la réception.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies d'analyse à l'accès ou Stratégies de l'analyseur d'e-mails à la réception, cliquez sur l'onglet Eléments à analyser et sélectionnez Détecter les programmes indésirables.


ePolicy Orchestrator 4.0

Activez la fonction de détection des programmes indésirables par les analyseurs à l'accès et les analyseurs d'e-mails via la console ePolicy Orchestrator 4.0.

Le processus utilisé pour activer la détection des programmes indésirables dans les analyseurs à l'accès et les analyseurs d'e-mails est globalement identique. La seule différence repose dans la stratégie que vous sélectionnez dans le catalogue de stratégies à l'étape 2. Pour activer la détection des programmes indésirables pour :
  • Analyse à l'accès : sélectionnez Stratégies d'analyse à l'accès.
  • Analyse d'e-mails : sélectionnez Stratégies de l'analyseur d'e-mails à la réception.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies d'analyse à l'accès ou Stratégies de l'analyseur d'e-mails à la réception, cliquez sur l'onglet Eléments à analyser et sélectionnez Détecter les programmes indésirables.


Console VirusScan

Activez la fonction de détection des programmes indésirables par les analyseurs à l'accès et les analyseurs d'e-mails via la Console VirusScan.

Le processus utilisé pour activer la détection des programmes indésirables dans les analyseurs à l'accès et les analyseurs d'e-mails est globalement identique. La seule différence repose dans la stratégie que vous sélectionnez dans la Console VirusScan à l'étape 2. Pour activer la détection des programmes indésirables pour :
  • Analyse à l'accès : sélectionnez Stratégies d'analyse à l'accès.
  • Analyse d'e-mails : sélectionnez Analyseur d'e-mails à la réception.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur l'un des éléments avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue :
    • Stratégies d'analyse à l'accès : pour une analyse à l'accès.
    • Analyseur d'e-mails à la réception : pour une analyse d'e-mails.
  2. Dans la page Stratégies d'analyse à l'accès ou Stratégies de l'analyseur d'e-mails à la réception, cliquez sur l'onglet Eléments à analyser et sélectionnez Détecter les programmes indésirables.


Mise à jour des définitions pour la détection

Le logiciel VirusScan Enterprise dépend du moteur d'analyse et des informations contenues dans les fichiers de signatures de détections (DAT) pour l'identification et la lutte contre les menaces. De nouvelles menaces apparaissent régulièrement. Pour faire face à cette situation, McAfee publie tous les jours de nouveaux fichiers DAT qui contiennent les résultats de ses recherches en cours sur les menaces. La tâche de mise à jour récupère les dernières versions des fichiers DAT à partir du site de mise à jour McAfee externe, puis les installe.
Remarque : un environnement ePolicy Orchestrator managé peut également récupérer les dernières versions des fichiers DAT, du fichier EXTRA.DAT, du moteur d'analyse, des Service Packs et des patchs.

Sommaire

Concepts associés
Fichiers DAT et leur fonctionnement
Importance d'une stratégie de mise à jour
Tâches de mise à jour et fonctionnement
Tâches de mise en miroir et leur fonctionnement
Fonctionnement du référentiel AutoUpdate
Restauration de fichiers DAT


Fichiers DAT et leur fonctionnement

Lorsque le moteur d'analyse examine des fichiers à la recherche de menaces, il compare le contenu des fichiers analysés aux informations sur les menaces connues stockées dans les fichiers de signatures de détections (DAT). Ces informations, appelées signatures, proviennent des découvertes réalisées et ajoutées par McAfee Labs aux fichiers DAT.

Outre les signatures, les fichiers DAT comprennent des informations permettant de nettoyer et de contrer les dommages causés par le virus détecté. C'est pourquoi il est important de télécharger la version la plus récente du fichier DAT utilisé par VirusScan Enterprise.
ATTENTION :
si la signature d'un certain virus ne figure dans aucun des fichiers DAT installés, ce virus n'est pas détecté par le moteur d'analyse. De même, la version du moteur d'analyse installé doit être la plus récente possible afin d'utiliser pleinement les derniers fichiers DAT.

VirusScan Enterprise utilise également une analyse heuristique, ou Artemis, pour contrôler les fichiers suspects avec les fichiers DAT. Reportez-vous à la section Fonctionnement d'Artemis pour en savoir plus.

Les divers fichiers DAT sont stockés à cet endroit :

\Program Files\Common Files\McAfee\Engine


Importance d'une stratégie de mise à jour

Il ne faut pas sous-estimer l'importance d'une stratégie de mise à jour. Sans les fichiers DAT et le moteur d'analyse les plus récents installés sur votre système, ce dernier n'est pas entièrement protégé contre les derniers virus. L'augmentation de nouveaux logiciels malveillants (malwares) est sans précédent : en termes de quantité, taux de propagation et prévalence. En outre, la quantité grandissante de logiciels publicitaires (adwares) et espions (spywares) requiert des fonctions de détection et de suppression plus cohérentes et disponibles.

McAfee Labs publie des mises à jour de fichiers DAT à environ 18 heures (GMT) tous les jours, ou presque. Les fichiers DAT d'urgence continueront bien entendu d'être publiés ponctuellement en cas d'attaques. Lorsqu'un fichier DAT est publié en avance, pour devancer une attaque potentielle, aucun autre fichier DAT n'est publié ce jour-là à l'heure planifiée habituelle, à moins qu'une autre situation d'urgence ne se présente.


Détermination d'une stratégie de mise à jour

Vous pouvez utiliser plusieurs méthodes de mise à jour des fichiers DAT et du moteur d'analyse utilisés par VirusScan Enterprise. Vous pouvez utiliser des tâches AutoUpdate, des mises à jour manuelles, des scripts de connexion ou planifier des mises à jour avec des outils de gestion.

L'utilisation d'une tâche de mise à jour permet de :

  • Planifier des déploiements de fichiers DAT : vous pouvez échelonner vos tâches de mise à jour ou définir une planification d'introduction progressive des mises à jour de fichiers DAT sur différentes parties du réseau, au moment opportun, avec un minimum d'intervention de la part des administrateurs ou des utilisateurs du réseau.
  • Répartir les fonctions d'administration du déploiement : pour améliorer l'efficacité de la bande passante, utilisez différents serveurs ou contrôleurs de domaine, différentes régions des réseaux étendus ou d'autres divisions du réseau afin de garder un trafic principalement interne pour les mises à jour. Cela permet également de réduire la probabilité de failles de sécurité réseau.
  • Réduire le temps d'attente requis pour télécharger de nouveaux fichiers DAT ou les dernières versions des fichiers du moteur : le trafic sur les ordinateurs McAfee augmente considérablement aux dates de publication régulières des fichiers DAT et lorsque de nouvelles versions produit sont disponibles. Eviter la concurrence sur la bande passante du réseau vous permet de déployer votre nouveau logiciel sans interruption ou presque.


Exigences d'une stratégie de mise à jour efficace

Une stratégie de mise à jour efficace implique généralement qu'au moins un client ou serveur de votre organisation récupère les mises à jour sur le site de téléchargement de McAfee. A partir de là, il est possible de répliquer ces fichiers dans toute votre organisation, en permettant l'accès à tous les autres ordinateurs. Dans l'idéal, vous pouvez réduire le plus possible la quantité de données transférées sur votre réseau en automatisant le processus de copie des fichiers mis à jour vers vos sites partagés.

Les principaux facteurs à prendre en compte pour une mise à jour efficace sont le nombre de clients et le nombre de sites. Vous pouvez également tenir compte du nombre de systèmes sur chaque site distant ou du mode d'accès à Internet des sites distants. Les concepts de base pour utiliser un référentiel central afin de récupérer les mises à jour et pour planifier les tâches de mise à jour afin de garder votre environnement à jour s'appliquent aux organisations de toutes tailles. Pour obtenir des informations sur le déploiement de logiciels et la mise à jour, consultez le Guide Produit d'ePolicy Orchestrator approprié.


Tâches de mise à jour et fonctionnement

Utilisez la tâche de mise à jour pour obtenir la dernière version des fichiers DAT, du moteur d'analyse, des Services Packs et des patchs.

VirusScan Enterprise inclut une tâche de mise à jour par défaut qui s'exécute tous les jours à 17 heures avec intervalle aléatoire d'une heure. Vous pouvez créer d'autres tâches de mise à jour si nécessaire.

Activités de tâche de mise à jour

Les activités suivantes se produisent lorsque vous exécutez une tâche de mise à jour :

  • Une connexion s’établit avec le premier référentiel activé (site de mise à jour) dans la liste de référentiels. Si ce référentiel n'est pas disponible, le site suivant est contacté, et ainsi de suite jusqu'à ce qu'une connexion soit établie ou que la fin de la liste soit atteinte.
  • Un fichier CATALOG.Z chiffré se télécharge à partir du référentiel. Le fichier contient les données fondamentales nécessaires à la mise à jour. Ces données sont utilisées pour déterminer quels fichiers et quelles mises à jour sont disponibles.
  • Les versions du logiciel contenues dans le fichier sont comparées aux versions installées sur l'ordinateur. Si de nouvelles mises à jour logicielles sont disponibles, elles sont téléchargées.

Interruption d'une tâche de mise à jour

Si la tâche de mise à jour est interrompue pour quelque raison que ce soit au cours de la mise à jour :

  • Une tâche de mise à jour à partir d'un site HTTP, UNC ou local reprend lors du prochain lancement de la tâche de mise à jour à l'endroit où elle s'est arrêtée.
  • Une tâche de mise à jour à partir d'un site FTP ne reprend pas si elle est interrompue pendant le téléchargement d'un seul fichier. Toutefois, si une tâche qui télécharge plusieurs fichiers est interrompue, elle reprend avant le fichier qui était en cours de téléchargement au moment de l'interruption.

Mise à jour à l'aide d'un fichier EXTRA.DAT

Un fichier EXTRA.DAT peut être utilisé comme mesure temporaire en cas d'urgence. Le fichier EXTRA.DAT est téléchargé depuis le référentiel à chaque mise à jour. Cela garantit que, si vous modifiez et réarchivez le fichier EXTRA.DAT sous forme de package, tous les clients VirusScan Enterprise téléchargent et utilisent le même package EXTRA.DAT mis à jour. Par exemple, vous pouvez utiliser le fichier EXTRA.DAT comme un détecteur amélioré pour le même programme potentiellement indésirable ou comme une détection supplémentaire pour d'autres programmes potentiellement indésirables. VirusScan Enterprise ne prend en charge qu'un seul fichier EXTRA.DAT.

Conseil : lorsque vous avez terminé d'utiliser le fichier EXTRA.DAT, vous devez le supprimer du référentiel maître et exécuter une tâche de réplication pour vous assurer qu'il a été supprimé de tous les sites de référentiels distribués. Cela évite aux clients VirusScan Enterprise d'essayer de télécharger le fichier EXTRA.DAT pendant une mise à jour. Par défaut, la détection d'un nouveau programme potentiellement indésirable dans le fichier EXTRA.DAT est ignorée une fois la nouvelle définition de détection ajoutée aux fichiers DAT quotidiens.


Configuration de la tâche AutoUpdate

Pour mettre à jour les fichiers DAT et les moteurs d'analyse de tous les produits McAfee automatiquement, vous devez configurer les propriétés et la planification de la tâche AutoUpdate.

Tâche

Pour la définition des options, cliquez sur ? ou Aide dans l'onglet.

  1. Pour accéder aux propriétés d'AutoUpdate :

    • ePolicy Orchestrator 4.5 ou 4.6 : cliquez sur Menu | Systèmes | Arborescence des systèmes, puis sélectionnez Tâches client.
      Remarque : reportez-vous au Guide Produit de McAfee ePolicy Orchestrator 4.5 pour obtenir des instructions détaillées sur la création d'une nouvelle tâche client planifiée.
    • ePolicy Orchestrator 4.0 : cliquez sur Systèmes | Arborescence des systèmes | Tâches client, puis sélectionnez une tâche de mise à jour existante ou cliquez sur Nouvelle tâche pour en créer une.
      Remarque : reportez-vous au Guide Produit de McAfee ePolicy Orchestrator 4.0 pour obtenir des instructions détaillées sur la création d'une nouvelle tâche client planifiée.
    • Console VirusScan : sélectionnez une tâche de mise à jour existante (clic droit, puis Propriétés), ou créez une nouvelle tâche (cliquez sur Tâche | Nouvelle tâche de mise à jour, puis sélectionnez la nouvelle tâche dans la liste).
      Conseil : lors de la création d'une nouvelle tâche client, il est recommandé de lui donner un nom descriptif.
  2. Spécifiez l'emplacement et le format du fichier journal.
  3. Indiquez s'il convient de récupérer les versions plus récentes des fichiers DAT, du moteur, ainsi que les autres mises à jour disponibles telles que les Service Packs et les mises à niveau du produit.
  4. Spécifiez l'exécutable à lancer à l'issue de la tâche de mise à jour et précisez s'il doit être exécuté uniquement après une mise à jour réussie.
  5. Cliquez sur Planifier pour configurer le moment et le mode d'exécution de la tâche. Reportez-vous à la section Utilisation des tâches planifiées pour en savoir plus.
  6. Cliquez sur Mettre à jour maintenant et la tâche s'exécute immédiatement.


Tâches de mise en miroir et leur fonctionnement

Les tâches de mise en miroir répliquent les fichiers de mise à jour à partir du premier référentiel accessible (défini dans la liste de référentiels) vers un site miroir du réseau. L'utilisation la plus courante de cette tâche consiste à mettre en miroir le contenu du site de téléchargement de McAfee sur un serveur local.

Une fois répliqué le site McAfee contenant les fichiers de mise à jour, les ordinateurs de votre réseau peuvent télécharger les fichiers depuis le site miroir. Cette technique est pratique, car elle permet de mettre à jour n'importe quel ordinateur du réseau, qu'il dispose d'un accès à Internet ou non. Elle est également économique, car vos systèmes communiquent avec un serveur qui est certainement plus proche qu'un site Internet McAfee : les temps d'accès et de téléchargement sont ainsi réduits.

Pour sa mise à jour, le logiciel VirusScan Enterprise utilise une structure de répertoire. Lors de la mise en miroir d'un site, il est important de répliquer l'intégralité de la structure de répertoire.
Remarque : cette structure de répertoire prend également en charge les versions précédentes de VirusScan Enterprise et NetShield, à condition que l'intégralité de la structure de répertoire soit répliquée au même emplacement que celui utilisé par VirusScan Enterprise 8.8 pour la mise à jour.


Configuration de la tâche de mise en miroir

Pour stocker les fichiers DAT et moteurs d'analyse dans un emplacement désigné pour utilisation par d'autres ordinateurs, configurez l'emplacement et planifiez la tâche via les propriétés de la tâche de mise en miroir.

Tâche

Pour la définition des options, cliquez sur ? ou Aide dans l'onglet.

  1. Pour accéder aux propriétés de la tâche de mise en miroir :

    • ePolicy Orchestrator 4.5 ou 4.6 : cliquez sur Menu | Systèmes | Arborescence des systèmes, puis sélectionnez Tâches client.
      Remarque : reportez-vous au Guide Produit de McAfee ePolicy Orchestrator 4.5 pour obtenir des instructions détaillées sur la création d'une nouvelle tâche client planifiée.
    • ePolicy Orchestrator 4.0 : cliquez sur Systèmes | Arborescence des systèmes | Tâches client, puis sélectionnez une tâche de mise à jour existante ou cliquez sur Nouvelle tâche pour en créer une.
      Remarque : reportez-vous au Guide Produit de McAfee ePolicy Orchestrator 4.0 pour obtenir des instructions détaillées sur la création d'une nouvelle tâche client planifiée.
    • Avec la Console VirusScan, effectuez l'une des actions suivantes :
      • Sélectionnez une tâche de mise en miroir existante, cliquez dessus avec le bouton droit de la souris, puis sélectionnez Propriétés. La boîte de dialogue de tâche de mise en miroir s'affiche.
      • Pour créer une nouvelle tâche de mise en miroir, sélectionnez Tâche | Nouvelle tâche de mise en miroir : une nouvelle tâche de mise à jour s'affiche dans la liste des tâches. Cliquez sur la nouvelle tâche pour ouvrir la boîte de dialogue de tâche de mise en miroir.
        Remarque : choisissez un nom plus descriptif pour la tâche en cliquant sur cette dernière avec le bouton droit de la souris et en sélectionnant Renommer.
  2. Console VirusScan : sélectionnez une tâche de mise à jour existante (clic droit, puis Propriétés), ou créez une nouvelle tâche (cliquez sur Tâche | Nouvelle tâche de mise en miroir, puis sélectionnez la nouvelle tâche dans la liste).
    Conseil : lors de la création d'une nouvelle tâche client, il est recommandé de lui donner un nom descriptif.
  3. Spécifiez l'emplacement et le format du fichier journal.
  4. Indiquez s'il convient de récupérer les versions plus récentes des définitions pour la détection, du moteur et des fichiers DAT, ainsi que les autres mises à jour disponibles telles que les Service Packs et les mises à niveau du produit.
  5. Spécifiez l'exécutable à lancer à l'issue de la tâche de mise à jour et précisez s'il doit être exécuté uniquement après une mise à jour réussie.
  6. Cliquez sur Emplacement de mise en miroir pour configurer la destination du serveur miroir.
  7. Cliquez sur Planifier pour configurer le moment et le mode d'exécution de la tâche. Reportez-vous à la section Utilisation des tâches planifiées pour en savoir plus.
  8. Cliquez sur Mettre en miroir pour exécuter la tâche immédiatement.
  9. Configurez les options de l'onglet. Pour la définition des options, cliquez sur ? ou Aide dans l'onglet.

Définitions des onglets

Onglet Définitions
Mise en miroir
  • Spécifiez l'emplacement et le format du fichier journal.
  • Spécifiez l'exécutable à lancer à l'issue de la tâche de mise en miroir et précisez s'il doit être exécuté uniquement après une mise en miroir réussie.


Fonctionnement du référentiel AutoUpdate

La liste de référentiels AutoUpdate (SITELIST.XML) contient les informations de configuration nécessaires à l'exécution d'une tâche AutoUpdate.

La liste de référentiels AutoUpdate comprend :
  • les informations et emplacement des référentiels ;
  • la préférence dans l'ordre des référentiels ;
  • les paramètres de proxy, si nécessaire ;
  • les informations d'identification chiffrées nécessaires pour accéder à chaque référentiel.

Lorsqu'une tâche AutoUpdate est exécutée, une connexion s'établit avec le premier référentiel activé (site de mise à jour) de la liste de référentiels. Si ce référentiel n'est pas disponible, le référentiel suivant est contacté, et ainsi de suite jusqu'à ce qu'une connexion soit établie ou que la fin de la liste soit atteinte.

Si votre réseau utilise un serveur proxy, vous pouvez spécifier les paramètres de proxy à utiliser, l'adresse du serveur proxy et l'utilisation ou non de l'authentification. Les informations relatives au proxy sont stockées dans la liste de référentiels AutoUpdate (sitelist.xml). Les paramètres de proxy que vous configurez s'appliquent à tous les référentiels de la liste.

L'emplacement de la liste de référentiels AutoUpdate dépend de votre système d'exploitation.
  • Pour Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server et Microsoft 2008 Server : C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework
  • Pour Microsoft Windows 7 : C:\ProgramData\McAfee\Common Framework


Configuration de la liste de référentiels

La liste de référentiels inclut les référentiels à partir desquels vous pouvez récupérer des mises à jour. Créez et configurez autant de référentiels que nécessaire. Certains sites peuvent être utilisés très souvent, alors que d'autres ne sont utilisés qu'occasionnellement.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la Console VirusScan, sélectionnez Outils | Modifier la liste de référentiels AutoUpdate pour accéder aux propriétés de la Liste de référentiels.
    Remarque : pour configurer la fonctionnalité de référentiel via la console ePolicy Orchestrator, accédez à l'affichage Catalogue de stratégies | McAfee Agent et cliquez sur l'onglet Référentiels.
  2. Configurez les options des onglets.

Définitions des onglets

Onglet | Définitions
Référentiels
  • Spécifier les référentiels dans lesquels vous obtenez des mises à jour.
  • Configurer l'ordre d'accès aux référentiels.
Paramètres proxy | Indiquer les paramètres de proxy à utiliser lors de la mise à jour.


Restauration de fichiers DAT

Si vous vous apercevez que vos fichiers DAT actuels sont endommagés ou incompatibles, vous pouvez les annuler en en restaurant la dernière version sauvegardée.

Lorsque vous mettez à jour les fichiers DAT, l'ancienne version est stockée à l'emplacement suivant : <lecteur>:\Program Files\Common Files\McAfee\Engine\OldDats.

Lorsque vous restaurez les fichiers DAT, les fichiers actuels sont remplacés par la version qui se trouve dans le dossier OldDats et un indicateur est défini dans le Registre, à l'emplacement suivant : HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS.

Après la restauration, vous ne pouvez pas revenir une nouvelle fois à la version précédente. Lors de la mise à jour suivante, la version DAT du Registre est comparée aux fichiers DAT du référentiel de mise à jour. Si les nouveaux fichiers DAT sont les mêmes que ceux du Registre, aucune mise à jour n'est effectuée.


Restauration des fichiers DAT

Pour récupérer la version précédente des fichiers DAT, utilisez l'outil Restaurer les fichiers DAT.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la Console VirusScan, choisissez Outils | Restaurer les fichiers DAT.
  2. Cliquez sur Oui pour poursuivre la restauration.
    Remarque : cette fonction n'est pas disponible à partie de la console ePolicy Orchestrator.
  3. Configurez les options de l'onglet.


Exclusion d'éléments à analyser

Chacun des analyseurs VirusScan Enterprise vous permet de paramétrer la liste des types de fichier analysés. Par exemple, vous pouvez exclure des éléments de fichiers individuels, dossiers et disques de l'analyse. Ces exclusions peuvent être nécessaires, car les analyseurs peuvent analyser et verrouiller un fichier lorsque ce dernier est utilisé par une base de données ou un serveur. Cela peut entraîner une défaillance ou des erreurs au niveau de la base de données ou du serveur.

Sommaire

Référence associée
Définition d'exclusions
Utilisation de caractères génériques pour spécifier des éléments à analyser


Définition d'exclusions

Spécifiez les fichiers, les dossiers et les lecteurs à exclure des opérations d'analyse. Vous pouvez également supprimer toute exclusion spécifiée précédemment.

Définition des options

Option Définition
Eléments à exclure Sélectionner le type d'exclusion.
  • Exclure par nom/emplacement de fichier : spécifier le nom de fichier, son emplacement et indiquer s'il faut exclure les sous-dossiers.
    Remarque : vous devez ajouter une barre oblique inverse (\) à la fin de la chaîne pour que cela s'applique à un dossier. Sinon, cela est considéré comme une exclusion de fichier et la case à cocher Exclure également les sous-dossiers est désactivée par défaut.
  • Exclure par type de fichier : spécifier un ou plusieurs types de fichier.
  • Exclure par âge de fichier : sélectionner le type d'accès, puis indiquer l'âge minimum en jours.
Conditions d'exclusion Choisir les conditions dans lesquelles exclure l'élément sélectionné :
  • Lors de la lecture
  • Lors de l'écriture
Gestion des exclusions client Remplacer les exclusions client : exclure uniquement les éléments spécifiés dans cette stratégie. Si cette option n'est pas sélectionnée, l'ordinateur client utilise les exclusions définies localement et les exclusions définies dans cette stratégie.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.


Utilisation de caractères génériques pour spécifier des éléments à analyser

Vous pouvez utiliser des caractères génériques pour exclure des types de fichier en fonction de leur extension.

Lorsque vous utilisez des caractères génériques, les limitations suivantes s'appliquent.

  • Les caractères génériques admis sont le point d'interrogation (?) pour exclure des caractères simples et l'astérisque (*) pour exclure des caractères multiples.
  • Les caractères génériques peuvent être suivis d'une barre oblique inverse (\) dans un chemin d'accès. Exemple : C:\ABC\*\XYZ reconnaît C:\ABC\DEF\XYZ.
  • Une exclusion comportant des points d'interrogation (?) est applicable si le nombre de caractères correspond à la longueur du nom de fichier ou de dossier. Exemple : L'exclusion W?? exclut WWW, mais pas WW ni WWWW.
  • La syntaxe peut également comporter un double astérisque (**) pour représenter aucun ou plusieurs caractères, y compris une barre oblique inverse. Cela permet des exclusions complexes. Exemple : C:\ABC\**\XYZ reconnaît C:\ABC\DEF\XYZ et C:\ABC\DEF\DEF\XYZ, etc.


Utilisation des tâches planifiées

Dans le cadre de la configuration de l'analyse à la demande, de la tâche AutoUpdate ou des tâches de mise en miroir, vous devez indiquer le moment, la fréquence et la durée d'exécution de ces dernières. Vous devez également configurer les autorisations utilisateur lors de ce processus.

Sommaire

Référence associée
Configuration de la planification de tâche
Informations associées
Planification de tâches


Planification de tâches

Vous avez la possibilité de planifier des tâches d'analyse à la demande, des tâches AutoUpdate et des tâches de mise en miroir selon des dates et des durées ou des intervalles spécifiques. Le mode de planification des tâches dépend de la console d'interface utilisateur utilisée.

Pour planifier ces tâches :
  • Console ePolicy Orchestrator : utilisez l'onglet Planifier pour afficher la page de planification.
  • Console VirusScan : utilisez le bouton Planifier pour afficher la boîte de dialogue de planification.
Tâches associées
Configuration des tâches d'analyse à la demande
Référence associée
Configuration de la tâche AutoUpdate
Configuration de la tâche de mise en miroir
Informations associées
Configuration des tâches serveur ePolicy Orchestrator


Configuration de la planification de tâche

Pour configurer une tâche à exécuter à un moment ou intervalle spécifique, utilisez la boîte de dialogue Paramètres de planification.

Avant de commencer

Vous devez disposer de droits d'administration pour planifier la tâche. Les droits d'administration offrent à l'utilisateur un accès en écriture à la clé de Registre de la tâche planifiée.

Pour planifier une tâche, cliquez sur Planifier dans la boîte de dialogue des propriétés de la tâche.

ATTENTION :
McAfee vous recommande de planifier les analyses à la demande à des intervalles minimaux.
Intervalles minimaux recommandés par McAfee :
  • Tous les jours : uniquement en cas d'attaque majeure de logiciels malveillants (malwares).
  • Toutes les semaines : recommandé.
  • Tous les mois : acceptable.
  • Tous les trimestres : le minimum.

Définitions des onglets

Onglet Définitions
Tâche
  • Activer la tâche planifiée pour qu'elle s'exécute à des heures spécifiées.
  • Arrêter la tâche si elle s'exécute aux heures et minutes spécifiées.
  • Spécifier les paramètres du compte d'utilisateur : nom d'utilisateur, domaine et mot de passe.
Planifier

Spécifier la fréquence planifiée et les paramètres associés.


Partie II -- Détection : trouver les menaces

La seconde étape d'une stratégie de protection consiste à trouver les menaces et détecter les logiciels malveillants (malwares) tentant d'accéder à votre système.

Sommaire

  • Analyse d'éléments à l'accès
  • Analyse d'éléments à la demande
  • Analyse d'e-mails à la demande et à la réception


Analyse d'éléments à l'accès

L'analyseur à l'accès examine les fichiers de votre ordinateur lorsque vous y accédez afin de fournir une détection continue et en temps réel des menaces. Les fonctions Protection d'accès et Protection en cas de Buffer Overflow utilisent également l'analyseur à l'accès pour détecter respectivement les violations d'accès et les exploits par Buffer Overflow.

Sommaire

Concepts associés
Analyse à l'accès et fonctionnement
Comparaison des analyses : écriture sur un disque et lecture à partir d'un disque
Comparaison des analyses : tous les fichiers et fichiers par défaut + types supplémentaires
Analyse de script et fonctionnement
Détermination du nombre de stratégies d'analyse
Fonctionnement d'Artemis
Informations associées
Configuration des paramètres généraux et de processus


Analyse à l'accès et fonctionnement

L'analyseur à l'accès intervient aux niveaux les plus bas du système (pilote de filtre du système de fichiers), il analyse les fichiers dès leur accès au système. Il agit comme un élément du système (service système) et envoie des notifications via l'interface en cas de détections.

En cas de tentative d'ouverture, de fermeture ou de modification du nom d'un fichier, l'analyseur intercepte l'opération et effectue les actions suivantes.

  1. L'analyseur détermine si le fichier doit être analysé, selon ces critères :
    • L'extension du fichier correspond à la configuration.
    • Le fichier n'a pas été mis en cache.
    • Le fichier n'a pas été exclu.
    • Le fichier n'a pas encore été analysé.
  2. Si le fichier remplit les critères d'analyse, il est analysé via la comparaison de ses informations avec les signatures de logiciels malveillants (malwares) connues contenues dans les fichiers DAT actuellement chargés.
    • Si le fichier ne contient pas de virus, le résultat est mis en cache et l'opération de lecture, d'écriture ou de modification de nom est autorisée.
    • Si le fichier contient une menace, l'opération est refusée et l'action configurée est effectuée. Exemple :
      • Si le fichier doit être nettoyé, ce processus est déterminé par les fichiers DAT actuellement chargés.
      • Les résultats sont enregistrés dans le journal d'activité si l'analyseur a été configuré ainsi.
      • L'alerte Messages d'analyse lors de l'accès s'affiche et contient le nom de fichier et l'action entreprise, si l'analyseur a été configuré ainsi.
  3. Si le fichier ne répond pas aux conditions d'analyse, il n'est pas analysé : il est mis en cache et l'opération est autorisée.
    Remarque : le cache de fichiers à analyser est vidé et tous les fichiers sont de nouveau analysés dès qu'une modification est apportée à la configuration de l'analyse à l'accès par exemple, qu'un fichier EXTRA.DAT est ajouté ou que le cache est plein.


Comparaison des analyses : écriture sur un disque et lecture à partir d'un disque

L'analyseur à l'accès effectue les analyses de différentes manières selon que l'utilisateur écrit sur le disque ou lit à partir du disque.

Lors de l'écriture de fichiers sur le disque, il analyse les éléments suivants :

  • les fichiers entrants écrits sur le disque dur local ;
  • les fichiers créés sur le disque dur local ou un lecteur réseau connecté (y compris les nouveaux fichiers, les fichiers modifiés ou ceux ayant été copiés ou déplacés d'un lecteur vers un autre).
    Remarque : pour analyser les lecteurs réseau connectés, vous devez activer l'option Sur les lecteurs réseau. Reportez-vous à la section Activation de l'option Sur les lecteurs réseau.

    Ces analyses sont uniquement accessibles à partir du client sur lequel VirusScan Enterprise est installé. L'analyseur ne détecte pas l'accès à un lecteur réseau mappé par d'autres systèmes.

Lors de la lecture de fichiers à partir du disque, l'analyseur à l'accès contrôle les éléments suivants :

  • les fichiers lus à partir d'un disque dur local ou de lecteurs réseau connectés ;
    Remarque : pour analyser des lecteurs réseau connectés, sélectionnez l'option Sur les lecteurs réseau, décrite précédemment, pour inclure les fichiers réseau distants.
  • tous les fichiers tentant d'exécuter un processus sur le disque dur local ;
  • tous les fichiers ouverts sur le disque dur local ;
  • tous les fichiers renommés sur le disque dur local, si leurs propriétés ont changé.


Comparaison des analyses : tous les fichiers et fichiers par défaut + types supplémentaires

L'analyseur à l'accès effectue les analyses différemment selon qu'il est configuré pour analyser tous les fichiers ou les fichiers par défaut et des types de fichier supplémentaires.

Avec l'option Tous les fichiers, l'analyseur examine tous les types de fichier correspondant à toutes les menaces possibles.

Avec l'option Fichiers par défaut + types supplémentaires, l'analyseur examine une liste de fichiers spécifiques correspondant aux types de fichier que vous avez sélectionnés.
  • Types de fichier par défaut : l'analyseur à l'accès examine les fichiers du type indiqué en se limitant aux attaques spécifiques de ce type de fichiers.

  • Types de fichier supplémentaires : l'analyseur à l'accès examine les fichiers dont les extensions correspondent à toutes les menaces possibles.

  • Types de fichier spécifiés : l'analyseur à l'accès examine la liste d'extensions de fichiers définie par l'utilisateur à la recherche de menaces potentielles.


Analyse de script et fonctionnement

L'analyseur de script fonctionne comme un proxy du composant Windows Scripting Host. Il intercepte les scripts, puis les analyse avant leur exécution.

Par exemple, l'analyseur de scripts permet de confirmer :

  • que le script n'est pas infecté, auquel cas il est transmis à l'hôte de script ;
  • que le script contient une menace potentielle, auquel cas il n'est pas exécuté.
Les processus approuvés ainsi que les sites web utilisant des scripts peuvent être exclus de l'inspection.
Remarque : sur les systèmes Windows Server 2008, les exclusions d'URL ScriptScan ne fonctionnent pas avec Windows Internet Explorer à moins que la case Activer les extensions tierce partie du navigateur soit sélectionnée pour activer le paramètre et que Windows Server 2008 soit redémarré. Pour en savoir plus, consultez l'article https://kc.mcafee.com/corporate/index?page=content&id=KB69526.


Fonctionnement d'Artemis

La fonction Artemis utilise l'analyse heuristique pour contrôler les fichiers suspects. Elle offre aux utilisateurs possédant des produits antivirus McAfee sous Windows la détection en temps réel la plus à jour de certains logiciels malveillants (malwares).

Artemis n'offre pas de protection contre des classes entières de logiciels malveillants, mais contre des échantillons spécifiques. L'avantage de cette approche réside dans la capacité d'offrir aux utilisateurs la protection McAfee, quasiment au moment où McAfee Labs établit qu'un échantillon est malveillant.

Vous pouvez configurer les niveaux de sensibilité utilisés par Artemis pour rechercher les programmes et DLL suspects s'exécutant sur les systèmes clients protégés par VirusScan Enterprise. Lorsqu'Artemis détecte un programme suspect, il envoie une requête DNS contenant une empreinte de ce fichier à un serveur de base de données central hébergé par McAfee Labs.

Remarque : dans cette version, la fonction Artemis est activée par défaut et son niveau de sensibilité est défini sur Très faible.


Détermination du nombre de stratégies d'analyse

Cette procédure permet de déterminer s'il est nécessaire de configurer plusieurs stratégies d'analyse à l'accès.


Configuration des paramètres généraux et de processus

Les stratégies de l'analyseur à l'accès, générales et de processus, sont configurées séparément.
  • Paramètres généraux : incluent les options s'appliquant à tous les processus.
  • Paramètres des processus : permettent de configurer une seule stratégie d'analyse pour tous les processus ou configurer des stratégies différentes (par défaut, faible risque et haut risque) pour les processus correspondants.


Configuration des paramètres généraux

Les paramètres généraux s'appliquent à l'analyse de tous les processus et incluent des paramètres comme la durée maximale d'analyse, l'analyse des scripts, le blocage des menaces indésirables provenant d'un ordinateur distant, l'envoi de messages lorsque des menaces sont détectées et le signalement des détections.

Configurez les paramètres généraux de l'analyse à l'accès à l'aide des consoles d'interface utilisateur suivantes.

Informations associées
Analyse d'éléments à l'accès


ePolicy Orchestrator 4.5 ou 4.6

Configurez les paramètres généraux s'appliquant à l'analyse de tous les processus à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies générales de l'analyse à l'accès, cliquez sur l'onglet Général pour configurer la stratégie générale s'appliquant à toutes les analyses à l'accès. Vous pouvez par exemple indiquer les éléments à analyser à l'accès, quand les analyser, la durée d'analyse maximale et si les cookies doivent être analysés ou non.

    Vous pouvez configurer l'analyse de tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée. Cela améliore la sécurité de votre système mais peut avoir une incidence sur ses performances au démarrage.

    Pour configurer la fonction d'analyse des processus activés, cliquez sur Processus activés dans le groupe d'analyse pour analyser tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée.
    Remarque : l'activation de cette fonction peut avoir une incidence sur la durée de démarrage de votre système.
  5. Dans l'onglet ScriptScan, activez l'option ScriptScan et configurez tous les processus ou URL à exclure de l'analyse.
  6. Dans l'onglet Blocage, configurez le blocage des connexions émanant d'ordinateurs distants écrivant des fichiers associés à des menaces potentielles ou des programmes indésirables.
    Remarque : par défaut, lorsqu'un système distant écrit un logiciel malveillant (malware) sur un système exécutant VirusScan Enterprise, VirusScan Enterprise bloque la connexion à ce système distant.

    Vous pouvez également configurer un message qui est envoyé au système ayant écrit le logiciel malveillant (malware).

    Remarque : l'envoi de ce message nécessite l'utilisation du service Windows Messenger.
  7. Dans l'onglet Messages, configurez des messages de notification destinés aux utilisateurs locaux pour les informer des détections et spécifiez-y les actions que l'utilisateur peut effectuer contre la menace.
  8. Dans l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format et toute autre information de journalisation d'analyse permettant de diagnostiquer cette menace.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


ePolicy Orchestrator 4.0

Configurez les paramètres généraux s'appliquant à l'analyse de tous les processus à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies générales de l'analyse à l'accès, cliquez sur l'onglet Général pour configurer la stratégie générale s'appliquant à toutes les analyses à l'accès. Vous pouvez par exemple indiquer les éléments à analyser à l'accès, quand les analyser, la durée d'analyse maximale et si les cookies doivent être analysés ou non.

    Vous pouvez configurer l'analyse de tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée. Cela améliore la sécurité de votre système mais peut avoir une incidence sur ses performances au démarrage.

    Pour configurer la fonction d'analyse des processus activés, cliquez sur Processus activés dans le groupe d'analyse pour analyser tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée.
    Remarque : l'activation de cette fonction peut avoir une incidence sur la durée de démarrage de votre système.
  5. Dans l'onglet ScriptScan, activez l'option ScriptScan et configurez tous les processus ou URL à exclure de l'analyse.
  6. Dans l'onglet Blocage, configurez le blocage des connexions émanant d'ordinateurs distants écrivant des fichiers associés à des menaces potentielles ou des programmes indésirables.
    Remarque : par défaut, lorsqu'un système distant écrit un logiciel malveillant (malware) sur un système exécutant VirusScan Enterprise, VirusScan Enterprise bloque la connexion à ce système distant.

    Vous pouvez également configurer un message qui est envoyé au système ayant écrit le logiciel malveillant (malware).

    Remarque : l'envoi de ce message nécessite l'utilisation du service Windows Messenger.
  7. Dans l'onglet Messages, configurez des messages de notification destinés aux utilisateurs locaux pour les informer des détections et spécifiez-y les actions que l'utilisateur peut effectuer contre la menace.
  8. Dans l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format et toute autre information de journalisation d'analyse permettant de diagnostiquer cette menace.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


Console VirusScan

Configurez les paramètres généraux s'appliquant à l'analyse de tous les processus à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Analyseur à l'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Dans la page Stratégies générales de l'analyse à l'accès, cliquez sur l'onglet Général pour configurer la stratégie générale s'appliquant à toutes les analyses à l'accès. Vous pouvez par exemple indiquer les éléments à analyser à l'accès, quand les analyser, la durée d'analyse maximale et si les cookies doivent être analysés ou non.

    Vous pouvez configurer l'analyse de tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée. Cela améliore la sécurité de votre système mais peut avoir une incidence sur ses performances au démarrage.

    Pour configurer la fonction d'analyse des processus activés, cliquez sur Processus activés dans le groupe d'analyse pour analyser tous les processus en cours d'exécution sur votre système dès que l'analyse à l'accès est activée.
    Remarque : l'activation de cette fonction peut avoir une incidence sur la durée de démarrage de votre système.
  3. Dans l'onglet ScriptScan, activez l'option ScriptScan et configurez tous les scripts à exclure de l'analyse.
  4. Dans l'onglet Blocage, configurez le blocage des connexions émanant d'ordinateurs distants écrivant des fichiers associés à des menaces potentielles ou des programmes indésirables.
    Remarque : par défaut, lorsqu'un système distant écrit un logiciel malveillant (malware) sur un système exécutant VirusScan Enterprise, VirusScan Enterprise bloque la connexion à ce système distant.

    Vous pouvez également configurer un message qui est envoyé au système ayant écrit le logiciel malveillant (malware).

    Remarque : l'envoi de ce message nécessite l'utilisation du service Windows Messenger.
  5. Dans l'onglet Messages, configurez des messages de notification destinés aux utilisateurs locaux pour les informer des détections et spécifiez-y les actions que l'utilisateur peut effectuer contre la menace.
  6. Dans l'onglet Rapports, activez la génération de journaux d'activité d'analyse, spécifiez leur emplacement, leur taille et leur format et toute autre information de journalisation d'analyse permettant de diagnostiquer cette menace.
    Remarque : ces fichiers journaux s'avèrent très utiles lors du diagnostic des menaces de sécurité et permettent de déterminer les actions à entreprendre contre ces dernières.


Configuration des paramètres de processus

Les processus d'analyse à l'accès sont configurés selon le risque que vous affectez à chaque processus. Vous pouvez configurer une stratégie d'analyse par défaut pour tous les processus ou configurer des stratégies différentes basées sur le risque affecté à chaque processus. Les paramètres comprennent l'affectation de risque aux processus, la définition des éléments à analyser, l'exécution de l'analyse Artemis, l'analyse de fichiers compressés, l'exécution d'actions en cas de détection et l'analyse de programmes potentiellement indésirables.

Configurez les paramètres généraux de l'analyse à l'accès à l'aide des consoles d'interface utilisateur suivantes.


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies des processus d'analyse à l'accès par défaut à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans l'onglet Processus, cliquez sur Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque pour afficher les processus d'analyse à l'accès par défaut, à faible risque ou à haut risque.
  5. Configurez les options des onglets de la page Stratégies des processus d'analyse à l'accès par défaut, à faible risque ou à haut risque. Reportez-vous à la section Options de l'onglet Paramètres des processus.


ePolicy Orchestrator 4.0

Configurez les stratégies des processus d'analyse à l'accès par défaut à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans l'onglet Processus, cliquez sur Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque pour afficher les processus d'analyse à l'accès par défaut, à faible risque ou à haut risque.
  5. Configurez les options des onglets de la page Stratégies des processus d'analyse à l'accès par défaut, à faible risque ou à haut risque. Reportez-vous à la section Options de l'onglet Paramètres des processus.


Console VirusScan

Configurez les propriétés des processus d'analyse à l'accès à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Analyseur à l'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Cliquez sur Tous les processus dans le volet de gauche.
  3. Dans l'onglet Processus, cliquez sur Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque pour afficher les processus d'analyse à l'accès par défaut, à faible risque ou à haut risque.
  4. Configurez les options des onglets de la page Stratégies des processus d'analyse à l'accès par défaut, à faible risque ou à haut risque. Reportez-vous à la section Options de l'onglet Paramètres des processus.


Options de l'onglet Paramètres des processus

Le tableau suivant décrit les options des onglets de l'analyseur à l'accès.

Onglet | Définitions
Processus
  • Processus d'analyse à l'accès par défaut : configurez une seule stratégie d'analyse pour tous les processus ou configurez différentes stratégies d'analyse pour les processus par défaut, les processus à faible risque et les processus à haut risque.
    Remarque : si vous choisissez de configurer une seule stratégie d'analyse, cette stratégie par défaut s'applique à tous les processus. Si vous configurez différentes stratégies d'analyse pour les processus à faible risque et à haut risque, cette stratégie par défaut s'applique uniquement aux processus qui ne sont pas définis comme à faible risque ou à haut risque.
  • Processus d'analyse à l'accès à faible risque : indiquez les processus que vous considérez à faible risque.
  • Processus d'analyse à l'accès à haut risque : indiquez les processus que vous considérez à haut risque.
Remarque : vous devez sélectionner l'option Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque dans l'onglet Processus d'analyse à l'accès par défaut avant de pouvoir configurer des stratégies séparées pour les processus à faible risque et à haut risque.
Eléments à analyser
  • Configurer l'analyse des fichiers lors de la lecture, de l'écriture, sur des lecteurs réseau et ouverts pour sauvegarde.
    ATTENTION :
    si vous n'activez pas les options Lors de l'écriture sur un disque et Lors de la lecture à partir d'un disque, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Configurer les fichiers et types de fichier à analyser.
    ATTENTION :
    si vous n'activez pas Tous les fichiers, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Analyser pour rechercher des menaces potentielles similaires à des programmes indésirables, des chevaux de Troie et des virus de macro.
  • Analyser à l'intérieur des archives et décoder les fichiers MIME.
  • Activer l'analyse à l'accès pour les programmes indésirables.
Exclusions | Configurer les disques, fichiers et dossiers à exclure de l'analyse.
Actions
Pour les détections de menaces :
  • Action principale à effectuer lorsqu'une menace est détectée.
  • Action secondaire à effectuer en cas de détection d'une menace, si la première action échoue.
Pour les détections de programmes indésirables :
  • Action principale à effectuer en cas de détection d'un programme indésirable.
  • Action secondaire à effectuer en cas de détection d'un programme indésirable, si la première action échoue.


Activation de l'option Sur les lecteurs réseau

Pour analyser les lecteurs réseau connectés, vous devez activer l'option Sur les lecteurs réseau.

Configurez l'analyse à l'accès des lecteurs sur le réseau à partir des stratégies des processus d'analyse à l'accès par défaut à l'aide de l'une des consoles d'interface utilisateur suivantes.


ePolicy Orchestrator 4.5 ou 4.6

Activez l'option Sur les lecteurs réseau à partir des stratégies des processus d'analyse à l'accès par défaut, à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies des processus d'analyse à l'accès par défaut, cliquez sur l'onglet Eléments à analyser puis sélectionnez Sur les lecteurs réseau en regard des fichiers à analyser.
  5. Cliquez sur Enregistrer.


ePolicy Orchestrator 4.0

Activez l'option Sur les lecteurs réseau à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Stratégies des processus d'analyse à l'accès par défaut, cliquez sur l'onglet Eléments à analyser puis sélectionnez Sur les lecteurs réseau en regard des fichiers à analyser.
  5. Cliquez sur Enregistrer.


Console VirusScan

Activez l'option Sur les lecteurs réseau à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Analyseur à l'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue Propriétés de l'analyse à l'accès.
  2. Cliquez sur l'onglet Eléments à analyser puis sélectionnez Sur les lecteurs réseau en regard des fichiers à analyser.
  3. Cliquez sur Enregistrer.


Analyse d'éléments à la demande

L'analyseur à la demande examine l'ensemble de votre ordinateur à la recherche de menaces potentielles, à un moment précis ou à intervalles réguliers. Utilisez les analyses à la demande pour compléter la protection continue offerte par l'analyseur à l'accès ou pour planifier des analyses régulières afin qu'elles n'interfèrent pas avec votre travail.

Sommaire

Concepts associés
Analyse à la demande et fonctionnement
Méthodes d'analyse à la demande et définitions
Fonctionnement de l'analyse du stockage étendu
Fonctionnement de l'option de différé d'analyse
Fonctionnement de l'utilisation du système
Tâches associées
Configuration des tâches d'analyse à la demande
Configuration du cache système global


Analyse à la demande et fonctionnement

L'analyseur à la demande examine les fichiers, les dossiers, la mémoire, le Registre et d'autres éléments de votre système à la recherche de logiciels malveillants (malwares) pouvant avoir infecté ce dernier. Vous décidez des conditions d'exécution de l'analyse à la demande. Vous pouvez analyser votre système manuellement, à une heure planifiée, ou par exemple, lors du démarrage du système.

En cas de tentative d'ouverture, de fermeture ou de modification du nom d'un fichier, l'analyseur intercepte l'opération et effectue les actions suivantes.

  1. L'analyseur détermine si le fichier, dossier ou disque doit être analysé, selon ces critères :
    • L'extension du fichier correspond à la configuration.
    • Le fichier n'a pas été mis en cache.
    • Le fichier n'a pas été exclu.
    • Le fichier n'a pas encore été analysé.
      Remarque : l'analyseur à la demande utilise l'analyse heuristique pour contrôler les fichiers suspects, si vous avez configuré la fonction Artemis. Pour en savoir plus, consultez la section Fonctionnement d'Artemis.
  2. Si le fichier, dossier ou disque remplit les critères d'analyse, il est analysé via la comparaison de ses informations avec les signatures de virus connues contenues dans les fichiers DAT actuellement chargés.
    • S'il ne contient pas de virus, le résultat est mis en cache et l'élément suivant est analysé.
    • S'il contient une menace, l'action configurée est entreprise. Exemple :
      • S'il doit être nettoyé, ce processus est déterminé par les fichiers DAT actuellement chargés.
      • Les résultats sont enregistrés dans le journal d'activité si l'analyseur a été configuré ainsi.
      • Les informations décrivant la mémoire, le nom de fichier, dossier ou disque et l'action entreprise s'affichent dans la boîte de dialogue Progression de l'analyse à la demande.
  3. Si la mémoire, le fichier, le dossier ou le disque ne remplit pas les critères d'analyse, l'élément n'est pas analysé et l'analyseur continue jusqu'à l'analyse complète de toutes les données.
Concepts associés
Fonctionnement d'Artemis


Méthodes d'analyse à la demande et définitions

L'analyseur à la demande utilise une analyse des processus en mémoire ainsi qu'une analyse incrémentielle et avec reprise.

Analyse des processus en mémoire

Cette méthode examine tous les processus actifs avant de lancer la tâche d'analyse à la demande. Tout processus potentiellement indésirable détecté est sélectionné et arrêté. Cela signifie qu'un seul passage de l'analyseur à la demande est nécessaire pour supprimer toutes les instances d'un programme potentiellement indésirable.

Analyse incrémentielle ou avec reprise

Cette méthode vous permet de restreindre les occurrences d'analyses à la demande tout en analysant l'intégralité du système sur plusieurs sessions. L'analyse incrémentielle peut être définie en ajoutant une limite temporelle à l'analyse planifiée. L'analyse s'arrête lorsque la limite est atteinte. A la prochaine analyse, cette dernière reprend à l'endroit de la structure de fichiers et de dossiers où l'analyse précédente s'est arrêtée.


Fonctionnement de l'analyse du stockage étendu

Les données du stockage étendu sont hiérarchiques, et stockées sur deux niveaux définis.

Ces deux niveaux de stockage sont les suivants :
  • Niveau supérieur, stockage local : comprend les volumes de disque NTFS de l'ordinateur exécutant le stockage étendu sur Windows 2000 Server.
  • Niveau inférieur, stockage étendu : se trouve sur le lecteur de bibliothèque sur bande automatisé ou sur le lecteur de bande autonome connecté à l'ordinateur serveur.

Le stockage étendu copie automatiquement les fichiers définis sur les volumes locaux vers un lecteur de bibliothèque sur bande, puis contrôle l'espace disponible sur les volumes locaux. Les données de fichiers sont mises en cache localement, afin que vous puissiez y accéder rapidement en cas de besoin. Si nécessaire, le stockage étendu déplace les données vers le stockage local. Lorsque vous devez accéder à un fichier sur un volume managé par stockage étendu, ouvrez le fichier de la manière habituelle. Si les données de ce fichier ne sont plus en cache sur le volume local, le stockage étendu rappelle les données depuis un lecteur de bibliothèque sur bande.

Tâches associées
Configuration des tâches d'analyse à la demande


Fonctionnement de l'option de différé d'analyse

Pour améliorer les performances, vous pouvez différer les tâches d'analyse à la demande lorsque la charge des batteries est basse ou pendant des présentations en plein écran. Vous pouvez également autoriser l'utilisateur à différer les analyses planifiées par incréments d'une heure. Ces incréments peuvent représenter une heure, 24 heures ou l'analyse peut être différée indéfiniment.

Chaque différé utilisateur peut durer une heure. Par exemple, si l'option Différer au plus est définie sur 2, l'utilisateur peut différer la tâche d'analyse deux fois, soit de deux heures. Lorsque ce délai maximal est écoulé, l'analyse continue. Si l'administrateur autorise un nombre illimité de différés en mettant l'option à zéro, l'utilisateur peut continuer de repousser l'analyse indéfiniment.


Fonctionnement de l'utilisation du système

L'analyseur à la demande utilise le paramètre de définition de priorité Windows pour les processus d'analyse et la priorité des threads. Le système d'exploitation définit le temps processeur que l'analyseur à la demande reçoit lors du processus d'analyse. Le paramètre d'utilisation du système des Propriétés d'analyse à la demande est mappé avec le contrôle de définition de priorité Windows.

La définition de l'utilisation du système pour l'analyse sur une valeur faible améliore les performances des autres applications en cours d'exécution. Cela s'avère utile pour les systèmes sur lesquels une activité utilisateur final est en cours. A l'inverse, une utilisation du système définie sur une valeur normale accélère l'analyse. Cela s'avère utile pour les systèmes contenant de grands volumes et sur lesquels peu d'activité utilisateur final est observée.

Le tableau suivant contient les paramètres des processus par défaut de VirusScan Enterprise et ePolicy Orchestrator.

Paramètre de processus VirusScan Enterprise | Paramètre de définition de priorité Windows
Faible | Faible
Sous la normale : la valeur par défaut d'ePolicy Orchestrator | Sous la normale
Normal : la valeur par défaut de VirusScan Enterprise 8.8 | Normal
Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Configuration des tâches d'analyse à la demande

La configuration des tâches d'analyse à la demande dépend de la console d'interface utilisateur utilisée. Les tâches qui suivent décrivent cette procédure, pour chacune d'entre elles.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan
Référence associée
Configuration des onglets des tâches d'analyse à la demande


ePolicy Orchestrator 4.5 ou 4.6

Configurez les tâches d'analyse à la demande à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Systèmes | Arborescence des systèmes et sélectionnez Tâches client.
  2. Dans la page Tâches client qui s'affiche :
    • Cliquez sur Modifier les paramètres dans la colonne Actions de la tâche pour ouvrir la page de description et modifier une tâche d'analyse à la demande existante.
    • Cliquez sur Actions | Nouvelle tâche pour ouvrir la page de description et créer une nouvelle tâche d'analyse à la demande.
  3. A partir de la page de descriptions :
    • Lorsque vous modifiez une tâche d'analyse à la demande existante, vérifiez les descriptions et cliquez sur Suivant.
    • Lorsque vous créez une tâche d'analyse à la demande, configurez les éléments ci-dessous et cliquez sur Suivant :
      • le Nom et les Remarques ;
      • le Type, en sélectionnant Analyse à la demande (VirusScan Enterprise 8.8) dans la liste ;
      • les Balises, qui déterminent quels ordinateurs reçoivent la tâche d'analyse à la demande.
  4. A partir de la page de configuration du Générateur de tâches client qui s'affiche, configurez chaque onglet. Pour en savoir plus, reportez-vous à la section Configuration des onglets des tâches d'analyse à la demande.


ePolicy Orchestrator 4.0

Configurez les tâches d'analyse à la demande à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Arborescence des systèmes | Tâches client.
  2. Dans la page Tâches client qui s'affiche :
    • Cliquez sur Modifier dans la colonne Actions de la tâche pour ouvrir la page de description et modifier une tâche d'analyse à la demande existante.
    • Cliquez sur Actions | Nouvelle tâche pour ouvrir la page de description et créer une nouvelle tâche d'analyse à la demande.
  3. Effectuez l'une des actions suivantes :
    • Lorsque vous modifiez une tâche d'analyse à la demande existante, vérifiez les descriptions et cliquez sur Suivant.
    • Lorsque vous créez une tâche d'analyse à la demande, configurez les éléments ci-dessous et cliquez sur Suivant :
      • le Nom et les Remarques ;
      • le Type, en sélectionnant Analyse à la demande (VirusScan Enterprise 8.8) dans la liste ;
      • les Balises, qui déterminent quels ordinateurs reçoivent la tâche d'analyse à la demande.
  4. A partir de la page de configuration du Générateur de tâches client qui s'affiche, configurez chaque onglet. Pour en savoir plus, reportez-vous à la section Configuration des onglets des tâches d'analyse à la demande.


Console VirusScan

Configurez les tâches d'analyse à la demande à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Ouvrez la page Propriétés d'analyse à la demande d'une tâche existante ou d'une nouvelle tâche :
    • Sélectionnez une tâche d'analyse à la demande, cliquez dessus avec le bouton droit de la souris et sélectionnez Propriétés.
    • Créez une nouvelle tâche, sélectionnez Tâche | Nouvelle tâche d'analyse à la demande, cliquez sur cette tâche avec le bouton droit de la souris, puis sélectionnez Propriétés.
  2. Configurez chaque onglet de la boîte de dialogue Propriétés d'analyse à la demande. Pour en savoir plus, reportez-vous à la section Configuration des onglets des tâches d'analyse à la demande.
Référence associée
Configuration des onglets des tâches d'analyse à la demande


Configuration des onglets des tâches d'analyse à la demande

VirusScan Enterprise comprend une tâche d'analyse à la demande par défaut. Vous pouvez utiliser cette tâche par défaut et en créer de nouvelles.

Configurez les options de chaque onglet. Pour une définition des options, cliquez sur ? ou Aide dans chaque onglet.

Définitions des onglets

Onglet | Définitions
Emplacements à analyser
  • Spécifier les emplacements et éléments à analyser.
  • Inclure les processus en cours d'exécution.
  • Inclure les sous-dossiers dans l'analyse.
  • Inclure les secteurs d'amorçage dans l'analyse.
  • Inclure les clés et valeurs de Registre dans l'analyse.
  • Inclure les fichiers de cookies dans l'analyse.
ATTENTION :
si vous n'analysez pas la Mémoire des rootkits et les Processus en cours, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Remarque : lorsque la boîte de dialogue Progression de l'analyse à la demande s'affiche, les emplacements à analyser se présentent sous forme de chaîne dont les éléments sont séparés par des virgules, à la suite de Rechercher dans. Une fois les processus d'analyse terminés, ils sont supprimés de la chaîne.
Eléments à analyser
  • Configurer les fichiers et types de fichier à analyser.
  • Activer l'analyse à la demande pour les programmes indésirables.
  • Analyser à l'intérieur des archives et décoder les fichiers MIME.
  • Analyser les fichiers migrés vers une zone de stockage.
  • Analyser les éléments à la recherche de menaces potentielles similaires à des programmes indésirables, des chevaux de Troie et des virus de macro.
Exclusions | Configurer les disques, fichiers et dossiers à exclure de l'analyse par nom ou emplacement, par type de fichier ou par âge de fichier.
Performances
  • Configurer le différé des analyses et le délai correspondant.
  • Spécifier le pourcentage d'utilisation du système.
  • Configurer le niveau de sensibilité d'Artemis.
Actions
Pour les détections de menaces :
  • Action principale à effectuer lorsqu'une menace est détectée.
  • Action secondaire à effectuer en cas de détection d'une menace, si la première action échoue.
Pour les détections de programmes indésirables :
  • Action principale à effectuer en cas de détection d'un programme indésirable.
  • Action secondaire à effectuer en cas de détection d'un programme indésirable, si la première action échoue.

Sélectionner l'action correspondante dans les actions autorisées de la boîte de dialogue d'interrogation.

Rapports
  • Activer la journalisation des activités.
  • Spécifier le nom et l'emplacement du fichier journal.
  • Indiquer la taille maximale du fichier journal.
  • Sélectionner le format du fichier journal.
  • Spécifier les éléments à journaliser en plus de l'activité d'analyse.
  • Spécifier les éléments à journaliser en plus de l'activité d'analyse parmi les suivants :
    • Activer les paramètres de session
    • Activer le récapitulatif de session
    • Activer l'échec d'analyse des fichiers chiffrés
  • Activer les alertes en cas de détection de cookies.
Tâche Indiquer l'emplacement d'exécution de la tâche d'analyse à la demande.
Remarque : cet onglet est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.


Configuration du cache système global

Le cache de l'analyse VirusScan Enterprise enregistre une liste de fichiers mis en cache ne contenant pas de virus. Vous pouvez améliorer les performances de votre système en enregistrant les informations du cache d'analyse du fichier sain lors d'un redémarrage du système. L'analyseur à la demande peut utiliser ces informations pour réduire les analyses redondantes.

Configurez les fonctions de cache d'analyse via les Stratégies relatives aux options générales et l'onglet Paramètres généraux de l'analyse à l'aide des consoles d'interface utilisateur.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan


ePolicy Orchestrator 4.5 ou 4.6

Configurez la fonction de cache de l'analyse à partir des Stratégies relatives aux options générales via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? ou Aide dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. A partir des Stratégies relatives aux options générales, cliquez sur l'onglet Paramètres généraux de l'analyse pour configurer les paramètres de l'option de cache de l'analyse VirusScan Enterprise.
  5. Configurez les paramètres généraux suivants pour le cache de l'analyse :
    • Cliquez sur Activer l'enregistrement des données d'analyse après les redémarrages : permet d'enregistrer les résultats d'analyse des éléments sains au redémarrage du système.
    • Cliquez sur Autoriser l'utilisation du cache de l'analyse par les analyses à la demande : permet à l'analyseur à la demande d'utiliser les résultats d'analyse des éléments sains pour réduire les analyses redondantes.
  6. Cliquez sur Enregistrer.


ePolicy Orchestrator 4.0

Configurez la fonction de cache de l'analyse à partir des Stratégies relatives aux options générales via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? ou Aide dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. A partir des Stratégies relatives aux options générales, cliquez sur l'onglet Paramètres généraux de l'analyse pour configurer les paramètres de l'option de cache de l'analyse VirusScan Enterprise.
  5. Configurez les paramètres généraux suivants pour le cache de l'analyse :
    • Cliquez sur Activer l'enregistrement des données d'analyse après les redémarrages : permet d'enregistrer les résultats d'analyse des éléments sains au redémarrage du système.
    • Cliquez sur Autoriser l'utilisation du cache de l'analyse par les analyses à la demande : permet à l'analyseur à la demande d'utiliser les résultats d'analyse des éléments sains pour réduire les analyses redondantes.
  6. Cliquez sur Enregistrer.


Console VirusScan

Configurez la fonction de cache de l'analyse via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Cliquez sur Outils | Options générales et sélectionnez l'onglet Paramètres généraux de l'analyse pour afficher la boîte de dialogue Paramètres généraux de l'analyse.
  2. Configurez les paramètres généraux suivants pour le cache de l'analyse :
    • Cliquez sur Activer l'enregistrement des données d'analyse après les redémarrages : permet d'enregistrer les résultats d'analyse des éléments sains au redémarrage du système.
    • Cliquez sur Autoriser l'utilisation du cache de l'analyse par les analyses à la demande : permet à l'analyseur à la demande d'utiliser les résultats d'analyse des éléments sains pour réduire les analyses redondantes.
  3. Cliquez sur OK.


Analyse d'e-mails à la demande et à la réception

L'analyseur d'e-mails examine automatiquement tous les messages et toutes les pièces jointes.

L'e-mail est analysé via :
  • Microsoft Outlook : l'e-mail est analysé à la réception ; vous pouvez également déclencher une analyse à la demande à partir de Microsoft Outlook.
    Remarque : si vous avez configuré les fonctionnalités d'analyse heuristique et Artemis, les analyseurs d'e-mails à la réception et à la demande utilisent l'analyse heuristique pour contrôler les fichiers suspects. Pour en savoir plus, consultez la section Fonctionnement d'Artemis.
  • Lotus Notes : vous permet de configurer les éléments suivants :
    • Les e-mails sont analysés à l'accès.
    • Lorsqu'il est invoqué, l'analyseur d'e-mail à la demande analyse directement les messages à partir de Lotus Notes.
    • Vous pouvez choisir les Bases de données Notes à exclure.

Configurez les stratégies d'analyse d'e-mails à la réception via les consoles d'interface utilisateur suivantes.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan
Référence associée
Définitions de l'onglet Stratégies d'analyse d'e-mails à la réception


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies d'analyse d'e-mails à la réception via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Configurez les options de chaque onglet dans la page de configuration des stratégies d'analyse d'e-mails à la réception. Reportez-vous à la section Définitions de l'onglet Stratégies d'analyse d'e-mails à la réception.


ePolicy Orchestrator 4.0

Configurez les stratégies d'analyse d'e-mails à la réception via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Configurez les options de chaque onglet dans la page de configuration des stratégies d'analyse d'e-mails à la réception. Reportez-vous à la section Définitions de l'onglet Stratégies d'analyse d'e-mails à la réception.


Console VirusScan

Configurez les stratégies d'analyse d'e-mails à la réception via cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Dans la liste Tâche, cliquez sur Propriétés d'analyse d'e-mails à la réception avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Configurez les options de chaque onglet dans la boîte de dialogue Propriétés d'analyse d'e-mails à la réception. Reportez-vous à la section Définitions de l'onglet Stratégies d'analyse d'e-mails à la réception.


Définitions de l'onglet Stratégies d'analyse d'e-mails à la réception

Onglet Définitions
Eléments à analyser
  • Spécifier les pièces jointes et messages à analyser.
  • Rechercher les menaces potentielles similaires à des logiciels malveillants (malwares), virus de macro inconnus et pièces jointes à plusieurs extensions à l'aide d'une analyse heuristique.
  • Analyser les fichiers compressés à l'intérieur des archives et décoder les fichiers MIME.
  • Activer l'analyseur d'e-mails pour rechercher les programmes indésirables.
  • Analyser le corps des e-mails.
  • Configurer le niveau de sensibilité d'Artemis.
    Remarque : cette option est disponible uniquement pour l'Analyse d'e-mails à la réception.
Actions
Pour les détections de menaces :
  • Action principale à effectuer lorsqu'une menace est détectée.
  • Action secondaire à effectuer si la première action échoue.
Pour les détections de programmes indésirables :
  • Action principale à effectuer en cas de détection d'un programme indésirable.
  • Action secondaire à effectuer si la première action échoue.

Sélectionner l'action correspondante dans les actions autorisées de la boîte de dialogue d'interrogation.

Alertes
  • Notifier un autre utilisateur lorsqu'un e-mail contenant une menace potentielle est détecté.
  • Indiquer le message qui s'affiche pour inviter l'utilisateur à agir.
Rapports
  • Activer la journalisation des activités.
  • Spécifier le nom et l'emplacement du fichier journal.
  • Indiquer la taille maximale du fichier journal.
  • Sélectionner le format du fichier journal.
  • Spécifier les éléments à consigner en plus de l'activité d'analyse.
Paramètres d'analyse de Notes
Remarque : cet onglet est disponible uniquement pour l'Analyse d'e-mails à la réception.

Configurer les paramètres spécifiques à Lotus Notes.

  • Analyser toutes les bases de données du serveur.
  • Analyser les boîtes aux lettres du serveur dans le dossier racine de boîte aux lettres spécifié.
  • Applications Notes à ignorer.


Partie III -- Réponse : gérer les menaces

La troisième étape d'une stratégie de protection consiste à réagir aux menaces et détecter les logiciels malveillants (malwares) tentant d'accéder à votre système pour les éliminer.

Sommaire

  • Détections et réponses
  • Configuration des alertes et notifications
  • Accès aux requêtes et aux tableaux de bord
  • Configuration des fichiers DAT d'urgence


Détections et réponses

Lorsqu'une menace survient et qu'elle est détectée, l'action entreprise est déterminée par la configuration de VirusScan Enterprise relativement à la réponse à donner et par la fonction qui détecte la menace. La connaissance de ces différences vous permet de développer et de mettre en œuvre une stratégie efficace.

Sommaire

Concepts associés
Que se passe-t-il en cas de détection ?
Eléments mis en quarantaine
Référence associée
Violations des points d'accès système
Détections de Buffer Overflow
Détections de programmes indésirables
Détections d'analyse à l'accès
Détections d'analyse à la demande
Détections lors de d'analyse d'e-mails


Que se passe-t-il en cas de détection ?

Lorsqu'une détection a lieu et que cette dernière est détectée, la réponse apportée dépend de la configuration de VirusScan Enterprise.

Si VirusScan Enterprise est configuré pour nettoyer les éléments détectés automatiquement (paramètre proposé par défaut), l'action entreprise dépend de l'instruction de nettoyage contenue dans le fichier DAT. Par exemple, si l'analyseur ne peut pas nettoyer un fichier ou si le fichier est trop endommagé pour être réparé, l'analyseur peut le supprimer ou effectuer l'action secondaire, selon la définition du fichier DAT.

Si l'analyseur refuse l'accès aux fichiers potentiellement infectés, il ajoute également une extension .mcm au nom du fichier lors de l'enregistrement de ce dernier.


Violations des points d'accès système

En cas de violation d'un point d'accès système, l'action entreprise dépend de la configuration de la règle.

Si la règle est configurée pour entreprendre l'action suivante :

  • Rapport : les informations sont enregistrées dans le fichier journal.

  • Bloquer : l'accès est refusé.

Consultez le fichier journal pour savoir si des points d'accès système ont fait l'objet d'une intrusion et quelles règles ont détecté la violation, puis configurez les règles de protection d'accès pour permettre aux utilisateurs d'accéder aux éléments légitimes et les empêcher d'accéder aux éléments protégés.

Utilisez les scénarios ci-après pour décider de l'action à entreprendre en réponse.

Type de détection Scénario
Processus indésirables
  • Si la règle a consigné la violation dans le fichier journal sans la bloquer, sélectionnez l'option Bloquer pour cette règle.
  • Si la règle a bloqué la tentative de violation sans la consigner dans le fichier journal, sélectionnez l'option Rapport pour cette règle.
  • Si la règle a bloqué la tentative de violation et consigné cette dernière dans le fichier journal, aucune action n'est nécessaire.
  • Si vous repérez un processus indésirable non détecté, modifiez-la afin d'inclure celui-ci en tant que processus à bloquer.
Processus légitimes
  • Si la règle a consigné la violation dans le fichier journal sans la bloquer, désélectionnez l'option Rapport pour cette règle.
  • Si la règle a bloqué la tentative de violation et consigné cette dernière dans le fichier journal, modifiez-la afin d'exclure le processus légitime des processus à bloquer.


Détections de Buffer Overflow

Lorsqu'un Buffer Overflow est détecté, l'analyseur bloque la détection et un message est enregistré dans la boîte de dialogue Messages d'analyse lors de l'accès. Vous pouvez afficher cette dernière, puis décider d'entreprendre ou non des actions supplémentaires.

Les actions qu'il est possible de choisir comprennent :
  • Suppression du message : sélectionnez l'élément dans la liste, puis cliquez sur Supprimer.
  • Création d'une exclusion : si le processus détecté fait partie de ceux que vous utilisez en toute légitimité ou correspond à un faux positif, créez une exclusion à l'aide des informations de la boîte de dialogue Messages d'analyse lors de l'accès. Consultez les informations de la colonne Nom pour déterminer le nom du processus propriétaire de la mémoire avec accès en écriture qui est à l'origine de l'appel. Utilisez le nom du processus pour créer une exclusion.
  • Envoi d'un échantillon à l'équipe de McAfee Labs pour analyse : si l'analyseur détecte des données qu'il ne devrait pas détecter ou ne détecte pas des données qu'il devrait détecter, vous pouvez envoyer un échantillon à McAfee Labs.


Détections de programmes indésirables

Les analyseurs à l'accès et à la demande, de même que l'analyseur d'e-mails, recherchent les programmes indésirables sur la base de la Stratégie contre les programmes indésirables configurée. En cas de détection, l'analyseur qui a détecté le programme potentiellement indésirable applique l'action configurée dans l'onglet Actions de cet analyseur.

Consultez les informations du fichier journal, puis décidez éventuellement d'effectuer l'une des actions supplémentaires suivantes :

  • Paramétrage des éléments d'analyse : permet de rendre vos analyses plus efficaces.
  • Exclusion de la détection : en cas de détection d'un programme légitime, vous pouvez le configurer comme exclusion.
  • Ajout à la liste de détections définies par l'utilisateur : si un programme indésirable n'a pas été détecté, vous pouvez l'ajouter à la liste de détections définies par l'utilisateur.
  • Envoi d'un échantillon à l'équipe de McAfee Labs pour analyse : si l'analyseur détecte des données qu'il ne devrait pas détecter ou ne détecte pas des données qu'il devrait détecter, vous pouvez envoyer un échantillon à McAfee Labs.


Détections d'analyse à l'accès

Lorsqu'un analyseur à l'accès détecte un logiciel malveillant (malware), il entreprend une action en fonction de votre configuration des propriétés d'analyse lors de l'accès, dans l'onglet Actions. Un message est également enregistré dans la boîte de dialogue Messages d'analyse lors de l'accès.

Consultez les informations du journal d'activité et de la boîte de dialogue Messages d'analyse lors de l'accès, puis décidez éventuellement d'entreprendre l'une des actions supplémentaires suivantes :

  • Paramétrage des éléments d'analyse : pour rendre les analyses plus efficaces, excluez les fichiers légitimes que VirusScan Enterprise peut considérer comme des menaces, et supprimez les menaces éventuellement enregistrées dans le dossier de quarantaine.
  • Clic droit sur un élément de la boîte de dialogue Messages d'analyse lors de l'accès : pour effectuer ces actions :
    • Nettoyer le fichier : tente de nettoyer le fichier référencé par le message sélectionné.
    • Supprimer le fichier : supprime le fichier référencé par le message sélectionné. Le nom du fichier est enregistré dans le journal d'activité afin de permettre sa restauration à partir de Quarantine Manager.
    • Tout sélectionner (ctrl+a) : sélectionne tous les messages de la liste.
    • Supprimer le message de la liste (ctrl+d) : supprime le message sélectionné de la liste. Les messages supprimés de la liste restent visibles dans le fichier journal.
    • Supprimer tous les messages : supprime tous les messages de la liste. Les messages supprimés de la liste restent visibles dans le fichier journal.
    • Ouvrir le fichier journal de l'analyseur lors de l'accès : ouvre le fichier du journal d'activité de l'analyseur à l'accès. Cette option est uniquement disponible à partir du menu Fichier.
    • Ouvrir le fichier journal de la protection d'accès : ouvre le fichier du journal d'activité de la protection d'accès. Cette option est uniquement disponible à partir du menu Fichier.
    • Si aucune action n'est disponible pour le message actuel, l'icône, le bouton et les éléments du menu correspondants sont désactivés. Par exemple, l'option Nettoyer n'est pas disponible si le fichier a déjà été supprimé ou l'option Supprimer n'est pas disponible si l'administrateur a supprimé l'action.
    • Nettoyer le fichier : un fichier ne peut pas être nettoyé si le fichier DAT n'a pas de nettoyeur ou s'il est trop endommagé pour être réparé. Si tel est le cas, l'analyseur ajoute une extension .mcm au nom du fichier et en refuse l'accès. Une entrée est enregistrée dans le fichier journal. Dans ce cas, il est recommandé de supprimer le fichier et de le restaurer à partir d'une sauvegarde non infectée.
  • Envoi d'un échantillon à l'équipe de McAfee Labs pour analyse : si l'analyseur détecte des données qu'il ne devrait pas détecter ou ne détecte pas des données qu'il devrait détecter, vous pouvez envoyer un échantillon à McAfee Labs.


Détections d'analyse à la demande

En cas de détection à la demande, l'analyseur entreprend des actions en fonction de la configuration des Propriétés d'analyse à la demande, dans l'onglet Actions.

Consultez les informations du fichier journal, puis décidez éventuellement d'effectuer l'une des actions supplémentaires suivantes :

  • Paramétrer les éléments d'analyse : permet de rendre vos analyses plus efficaces.
  • Interroger l'utilisateur : configurez le scanner pour Interroger l'utilisateur en sélectionnant l'action dans la boîte de dialogue Progression de l'analyse à la demande.
  • Envoyer un échantillon à l'équipe de McAfee Labs pour analyse : si l'analyseur détecte des données qu'il ne devrait pas détecter ou ne détecte pas des données qu'il devrait détecter, vous pouvez envoyer un échantillon à McAfee Labs.


Détections lors de d'analyse d'e-mails

En cas de détection lors de l'analyse d'e-mails, l'analyseur entreprend des actions en fonction de la configuration des Propriétés d'analyse d'e-mails à la réception ou des Propriétés d'analyse d'e-mails à la demande, dans l'onglet Actions.

Consultez les informations du fichier journal, puis décidez éventuellement d'effectuer l'une des actions supplémentaires suivantes :

  • Paramétrage des éléments d'analyse : permet de rendre vos analyses plus efficaces.
  • Envoi d'un échantillon à l'équipe de McAfee Labs pour analyse : si l'analyseur détecte des données qu'il ne devrait pas détecter ou ne détecte pas des données qu'il devrait détecter, vous pouvez envoyer un échantillon à McAfee Labs.


Eléments mis en quarantaine

Les éléments détectés représentant une menace sont nettoyés ou supprimés. En outre, une copie de l'élément est convertie dans un format non exécutable et enregistrée dans le dossier de quarantaine. Cela vous permet d'appliquer des processus aux éléments mis en quarantaine, après le téléchargement d'une version plus récente du fichier DAT pouvant contenir les informations qui permettraient de nettoyer la menace.

Ces processus supplémentaires comprennent :

  • Restaurer

  • Analyser à nouveau

  • Supprimer

  • Rechercher les faux positifs

  • Afficher les propriétés de détection

Remarque : les éléments mis en quarantaine peuvent contenir plusieurs types d'objets analysés. Ces objets peuvent être des fichiers, des cookies, des Registres ou tout élément que VirusScan Enterprise analyse à la recherche de logiciels malveillants (malwares).


Configuration de la stratégie de quarantaine

Accédez aux stratégies de Quarantine Manager et configurez la stratégie de quarantaine, si nécessaire, ou acceptez les paramètres par défaut.

Configurez les stratégies de Quarantine Manager à l'aide des consoles d'interface utilisateur suivantes.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies de Quarantine Manager à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Quarantaine, acceptez le répertoire de quarantaine par défaut ou sélectionnez un autre répertoire.
  5. Pour configurer le nombre de jours durant lesquels les éléments doivent être enregistrés, cliquez sur Supprimer automatiquement les données mises en quarantaine après le nombre de jours spécifié et entrez le Nombre de jours de conservation des données sauvegardées dans le répertoire de quarantaine.


ePolicy Orchestrator 4.0

Configurez les stratégies de Quarantine Manager à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Dans la page Quarantaine, acceptez le répertoire de quarantaine par défaut ou sélectionnez un autre répertoire.
  5. Pour configurer le nombre de jours durant lesquels les éléments doivent être enregistrés, cliquez sur Supprimer automatiquement les données mises en quarantaine après le nombre de jours spécifié et entrez le Nombre de jours de conservation des données sauvegardées dans le répertoire de quarantaine.


Console VirusScan

Configurez la stratégie de Quarantine Manager à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Dans la liste Tâche, cliquez sur Stratégie du Quarantine Manager avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Acceptez le répertoire de quarantaine par défaut ou sélectionnez-en un autre.
  3. Pour configurer le nombre de jours durant lesquels les éléments doivent être enregistrés, cliquez sur Supprimer automatiquement les données mises en quarantaine après le nombre de jours spécifié et entrez le Nombre de jours de conservation des données sauvegardées dans le répertoire de quarantaine.


Gestion des éléments mis en quarantaine

Traitez les éléments mis en quarantaine pour effectuer d'autres vérifications dessus et les supprimer ou les restaurer manuellement à l'aide de la Console VirusScan.
Remarque : dans la console ePolicy Orchestrator, utilisez la tâche client Restaurer à partir de la quarantaine pour restaurer les éléments en quarantaine.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Dans la liste des tâches de la Console VirusScan, cliquez sur Stratégie du Quarantine Manager pour ouvrir la boîte de dialogue correspondante.
  2. Sélectionnez l'onglet Gestionnaire et cliquez sur un élément avec le bouton droit de la souris pour accéder aux options avancées suivantes :

    • Restaurer

    • Analyser à nouveau

    • Supprimer

    • Rechercher les faux positifs

    • Afficher les propriétés de détection

  3. Une boîte de dialogue décrivant l'incidence de votre tentative s'affiche.


Configuration des alertes et notifications

La réception de notifications lors de la détection d'une menace potentielle est un aspect important de la protection de votre environnement. Vous pouvez utiliser la console ePolicy Orchestrator ou la Console VirusScan pour configurer le mode de notification en cas de détections. Les deux consoles permettent de configurer les options d'alertes, de les filtrer selon leur gravité afin de limiter le volume du trafic d'alertes et de configurer les options d'alertes locales.

Tâches associées
Configuration des alertes
Référence associée
Détections d'analyse à l'accès


Configuration des alertes

Configurez les propriétés des alertes et notifications s'affichant lorsque les divers analyseurs détectent une menace.

Utilisez le même procédé pour configurer les alertes de ces stratégies :
  • Stratégies des alertes
  • Stratégies de protection en cas de Buffer Overflow
  • Stratégies d'analyse d'e-mails à la réception

Configurez les stratégies de notification d'alerte pour ces trois stratégies via les consoles d'interface utilisateur suivantes.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan
Référence associée
Configuration des onglets de stratégies des alertes


ePolicy Orchestrator 4.5 ou 4.6

Configurez les stratégies des alertes à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Menu | Stratégie | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Actions | Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Dans la liste Catégorie, sélectionnez une stratégie existante.
    3. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    4. Entrez un nouveau nom de stratégie.
    5. Entrez des commentaires si besoin.
    6. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
    7. Dans la colonne Actions de la nouvelle stratégie, cliquez sur Modifier les paramètres pour ouvrir la page de configuration de la stratégie.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Configurez les onglets des stratégies des alertes. Reportez-vous à la section Configuration des onglets de stratégies des alertes.


ePolicy Orchestrator 4.0

Configurez les stratégies des alertes à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Cliquez sur Systèmes | Catalogue de stratégies, puis sélectionnez VirusScan Enterprise 8.8.0 dans la liste de produits. La liste des catégories contient les catégories de stratégies de VirusScan Enterprise 8.8.0.
  2. Modifiez une stratégie existante ou créez-en une nouvelle : Modifier une stratégie existante
    1. Dans la liste Catégorie, sélectionnez la catégorie de stratégies souhaitée.
    2. Dans la colonne Actions, cliquez sur Modifier pour ouvrir la page de configuration de la stratégie.
    Créer une nouvelle stratégie
    1. Cliquez sur Nouvelle stratégie pour ouvrir la boîte de dialogue Nouvelle stratégie.
    2. Sélectionnez l'un des paramètres de la liste Créer une stratégie basée sur cette stratégie existante.
    3. Entrez un nouveau nom de stratégie.
    4. Cliquez sur OK. La nouvelle stratégie s'affiche dans la liste des stratégies existantes.
  3. Dans la liste Paramètres pour, sélectionnez Poste de travail ou Serveur.
  4. Configurez les onglets des stratégies des alertes. Reportez-vous à la section Configuration des onglets de stratégies des alertes.


Console VirusScan

Configurez les propriétés des alertes à l'aide de cette console d'interface utilisateur.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Ouvrez l'une des propriétés suivantes pour configurer les alertes :
    • Alertes : cliquez sur Outils | Alertes pour ouvrir la boîte de dialogues Propriétés d'alerte.
    • Protection en cas de Buffer Overflow : sélectionnez la tâche Protection en cas de Buffer Overflow et cliquez sur Propriétés avec le bouton droit de la souris pour ouvrir la boîte de dialogue Propriétés de protection en cas de Buffer Overflow.
    • Analyseur d'e-mails à la réception : sélectionnez la tâche Analyseur d'e-mails à la réception et cliquez sur Propriétés avec le bouton droit de la souris pour ouvrir la boîte de dialogue des propriétés de l'analyseur d'e-mails à la réception. Cliquez sur l'onglet Alertes.
  2. Configurez les onglets des stratégies des alertes. Reportez-vous à la section Configuration des onglets de stratégies des alertes.


Configuration des onglets de stratégies des alertes

Tâche Configuration
Stratégies des alertes

  1. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page Stratégies des alertes.

  2. Configurez les Composants générateurs d'alertes et les Options d'Alert Manager.

Stratégies de protection en cas de Buffer Overflow

  1. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page Protection en cas de Buffer Overflow.

  2. En regard de l'option Avertissement du système client, cliquez sur Afficher la boîte de dialogue de messages si un Buffer Overflow est détecté.

Stratégies d'analyse d'e-mails à la réception

  1. Dans la colonne Actions, cliquez sur Modifier les paramètres pour ouvrir la page des stratégies d'analyse d'e-mails à la réception.

  2. Cliquez sur Alertes et configurez l'Alerte par e-mail à l'utilisateur et le Message d'interrogation de l'utilisateur.


Accès aux requêtes et aux tableaux de bord

Utilisez les requêtes et les tableaux de bord pour surveiller l'activité et déterminer les actions à effectuer en cas de détection. Vous pouvez utiliser les requêtes et les tableaux de bord prédéfinis et en créer de nouveaux en fonction de vos besoins. Pour plus d'informations sur les requêtes et les tableaux de bord, consultez la documentation du produit ePolicy Orchestrator.

Requêtes

En fonction de votre version d'ePolicy Orchestrator, accédez aux requêtes comme suit :

ePolicy Orchestrator 4.5 et 4.6
  1. Cliquez sur Menu | Rapports | Requêtes pour afficher la page Requêtes.
  2. Dans le volet Requêtes, entrez VSE : dans Recherche rapide et cliquez sur Appliquer. Seules les requêtes VirusScan Enterprise s'affichent dans la liste.
ePolicy Orchestrator 4.0
  1. Cliquez sur Rapports | Requêtes pour afficher la page Requêtes.
  2. Parcourez la liste Requêtes, dans le volet de droite, pour trouver les requêtes commençant par « VSE : ».

Les requêtes prédéfinies suivantes sont disponibles :

VSE : conformité au cours des 30 derniers jours

VSE : ordinateurs avec menaces détectées par semaine

VSE : adoption du fichier DAT actuel

VSE : adoption de fichiers DAT au cours des dernières 24 heures

VSE : déploiement des fichiers DAT

VSE : synthèse des réponses en cas de détection

VSE : nombre de détections par balise

VSE : logiciels espions détectés au cours des dernières 24 heures

VSE : logiciels espions détectés au cours des 7 derniers jours

VSE : synthèse des menaces détectées au cours des dernières 24 heures

VSE : synthèse des menaces détectées au cours des 7 derniers jours

VSE : nombre de menaces par gravité

VSE : noms des menaces détectées par semaine

VSE : menaces détectées au cours des dernières 24 heures

VSE : menaces détectées au cours des 7 derniers jours

VSE : menaces détectées au cours des deux trimestres précédents

VSE : menaces détectées par semaine

VSE : 10 principales règles de protection de l'accès non respectées

VSE : 10 principales attaques par Buffer Overflow détectées

VSE : 10 ordinateurs présentant le plus grand nombre de détections

VSE : 10 principales menaces détectées

VSE : 10 principales sources de menaces

VSE : 10 principales menaces par catégorie de menace

VSE : 10 utilisateurs présentant le plus grand nombre de détections

VSE : programmes indésirables détectés au cours des dernières 24 heures

VSE : programmes indésirables détectés au cours des 7 derniers jours

VSE : conformité de McAfee VSE 8.5

VSE : conformité de McAfee VSE 8.7

VSE : conformité de McAfee VSE 8.8

Tableaux de bord

Pour accéder aux tableaux de bord dans la console ePolicy Orchestrator, choisissez Tableaux de bord.

Les tableaux de bord prédéfinis suivants sont disponibles :
  • VSE : conformité de McAfee VSE 8.8
  • VSE : données d'analyse des tendances
  • VSE : détections actuelles


Configuration des fichiers DAT d'urgence

Les fichiers DAT d'urgence peuvent être téléchargés manuellement pour protéger votre système contre un virus majeur jusqu'à la publication de la mise à jour officielle du fichier DAT VirusScan.
Remarque : ces fichiers EXTRA.DAT doivent être automatiquement téléchargés dans le cadre des mises à jour automatiques de votre système client, ou d'une extraction planifiée d'ePolicy Orchestrator. Reportez-vous à la section, Mise à jour des définitions pour la détection.
Configuration des fichiers DAT d'urgence en deux étapes.
  1. Téléchargez le fichier DAT d'urgence. Cette procédure est identique pour les systèmes clients et les référentiels ePolicy Orchestrator.
  2. Installez le fichier DAT d'urgence. Cette procédure est différente pour les systèmes clients et les serveurs ePolicy Orchestrator 4.0 4.5 et 4.6.

Chacune de ces procédures est décrite dans cette section.

Sommaire

Concepts associés
A propos des fichiers DAT d'urgence
Tâches associées
Téléchargement d'un fichier SuperDAT
Installation des fichiers SuperDAT sur un référentiel ePolicy Orchestrator
Installation du fichier EXTRA.DAT sur un système client
Informations associées
Mise à jour des définitions pour la détection


A propos des fichiers DAT d'urgence

Les fichiers DAT d'urgence, ou fichiers EXTRA.DAT, contiennent des informations que VirusScan Enterprise utilise pour détecter un nouveau virus. Lorsqu'un logiciel malveillant est découvert et requiert une détection supplémentaire, McAfee Labs met à disposition un fichier EXTRA.DAT, contenu dans un fichier exécutable SuperDAT (SDAT), jusqu'à la publication de la mise à jour normale du fichier DAT de VirusScan Enterprise.
Remarque : McAfee ne met plus de fichiers EXTRA.DAT à disposition sur le site de téléchargement des mises à jour de sécurité. Pour obtenir le fichier EXTRA.DAT relatif à une menace spécifique, rendez-vous sur la page de demande du fichier Extra.dat du site McAfee Avert Labs à l'adresse https://www.webimmune.net/extra/getextra.aspx.

Packages SuperDAT

Le fichier exécutable SuperDAT est un package auto-installable. Il peut également contenir un nouveau moteur d'analyse antivirus et d'autres composants de programme. Le fichier utilise le format de nom sdatXXXX.exe, où XXXX est le numéro de version à quatre chiffres du fichier DAT, par exemple sdat4321.exe.

Lorsqu'un fichier EXTRA.DAT est extrait de l'exécutable SuperDAT et ajouté au dossier du moteur de votre disque dur, il est utilisé par VirusScan Enterprise, en plus de ses fichiers DAT habituels, pour détecter le nouveau virus. Cela permet à VirusScan Enterprise de protéger votre ordinateur contre le nouveau code de logiciel malveillant (malware) jusqu'à ce que la mise à jour officielle du fichier DAT contenant les informations de détection et de suppression du logiciel malveillant soit publiée. Une fois la mise à jour officielle du fichier DAT publiée et installée, le fichier EXTRA.DAT n'est plus nécessaire.

Remarque : les fichiers EXTRA.DAT restent dans votre système de fichiers pendant 5 jours, puis ils sont automatiquement supprimés. Vous devez mettre à jour vos fichiers DAT VirusScan Enterprise en téléchargeant et en installant automatiquement les mises à jour quotidiennes officielles.


Téléchargement d'un fichier SuperDAT

Pour télécharger un fichier SuperDAT (SDAT), vous devez vous connecter à la page des mises à jour de sécurité de McAfee.

Avant de commencer

  • Vous devez disposer d'un Grant Number valide pour accéder à la page des mises à jour de sécurité de McAfee : http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  • Vous devez disposer de privilèges d'administrateur pour mettre à jour le logiciel McAfee.

Tâche

  1. Rendez-vous sur la page des mises à jour de sécurité de McAfee à l'URL suivante : http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  2. Cliquez sur l'onglet Fichiers SuperDAT et double-cliquez sur le fichier sdatXXXX.exe, où XXXX est le numéro de la mise à jour la plus récente du fichier DAT.
    Remarque : double-cliquez sur le fichier readme.txt pour plus d'informations.
  3. Enregistrez le fichier exécutable à un emplacement temporaire en utilisant son nom par défaut.


Installation des fichiers SuperDAT sur un référentiel ePolicy Orchestrator

Après avoir téléchargé le fichier SuperDAT, vous devez l'installer sur le serveur ePolicy Orchestrator.

Avant de commencer

Vous devez disposer de privilèges d'administrateur pour mettre à jour le logiciel McAfee.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Pour installer un fichier SuperDAT sur un serveur ePolicy Orchestrator, utilisez l'une des procédures suivantes :
    Serveur Etapes...
    ePolicy Orchestrator 4.5 et 4.6
    1. Cliquez sur Menu | Logiciels | Référentiel maître pour ouvrir la page Packages du référentiel maître dans la console ePolicy Orchestrator 4.5 et 4.6.
    2. Cliquez sur Actions | Archiver un package.
    ePolicy Orchestrator 4.0
    1. Cliquez sur Logiciels | Référentiel maître pour ouvrir la page Packages du référentiel maître.
    2. Cliquez sur Archiver un package pour ouvrir la page d'archivage des packages.
  2. Sélectionnez Fichier SuperDAT (EXE), accédez à l'emplacement auquel enregistrer le fichier, puis cliquez sur Suivant.
  3. Confirmez votre sélection, puis cliquez sur Enregistrer. La liste des noms de la page Packages du référentiel maître contient le nouveau package DAT.


Installation du fichier EXTRA.DAT sur un système client

Vous pouvez installer le fichier EXTRA.DAT sur un système client autonome après l'avoir téléchargé à partir du site McAfee Labs. Pour obtenir les informations relatives au téléchargement du fichier EXTRA.DAT, reportez-vous à la section A propos des fichiers DAT d'urgence.

Avant de commencer

Vous devez disposer de privilèges d'administrateur pour mettre à jour le logiciel de sécurité McAfee.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. A la fin du téléchargement, recherchez le fichier que vous venez d'enregistrer, exécutez le fichier exécutable et suivez les instructions de l'assistant. Le fichier exécutable EXTRA.DAT complète les étapes suivantes :
    • Il décharge les logiciels McAfee résidant dans la mémoire ou arrête les services utilisant vos fichiers DAT actuels.
    • Il copie les nouveaux fichiers DAT dans les répertoires de programmes appropriés.
    • Il redémarre les composants logiciels nécessaires à la poursuite des analyses avec vos nouveaux fichiers DAT.
  2. Lorsque le programme d'installation a terminé la mise à jour de vos fichiers DAT, vous pouvez supprimer le fichier téléchargé, ou conserver une copie accessible pour des mises à jour ultérieures.


Partie IV -- Surveillance, analyse et paramétrage de votre protection

Après la configuration initiale de votre stratégie de protection, il s'agit de surveiller, analyser et paramétrer votre protection. En examinant les journaux d'activité et les requêtes ePolicy Orchestrator, vous pouvez améliorer les performances et le niveau de protection des systèmes VirusScan Enterprise.

Sommaire

  • Surveillance de l'activité de votre environnement
  • Analyse de votre protection


Surveillance de l'activité de votre environnement

La surveillance des événements relatifs aux logiciels malveillants (malwares) se produisant sur vos systèmes représente une étape importante de l'élaboration d'une stratégie de protection. Cela suppose de connaître les outils à utiliser et leur fonctionnement.


Outils de surveillance de l'activité

VirusScan Enterprise permet de surveiller les événements de menace survenant sur vos systèmes protégés de diverses façons. Les outils dont vous disposez du produit que vous utilisez : la console ePolicy Orchestrator ou la Console VirusScan.


Utilisation des requêtes et tableaux de bord

Utilisez les requêtes et les tableaux de bord ePolicy Orchestrator pour surveiller l'activité de vos systèmes McAfee managés et déterminer les actions à effectuer en cas de détection.

Pour plus d'informations sur les requêtes et tableaux de bord, consultez les documents suivants :
  • Reportez-vous à la section Accès aux requêtes et tableaux de bord pour obtenir une liste complète des requêtes prédéfinies disponibles.
  • Reportez-vous à la documentation produit d'ePolicy Orchestrator pour obtenir des informations sur la modification et la création de requêtes et de tableaux de bord.
Informations associées
Accès aux requêtes et aux tableaux de bord


Utilisation des journaux d'activité

Les journaux d'activité de la Console VirusScan stockent un enregistrement des événements se produisant sur le système protégé par VirusScan Enterprise. Le tableau suivant décrit les fichiers journaux.

Tous les journaux d'activité sont stockés à l'un des emplacements suivants par défaut, en fonction de votre système d'exploitation :
  • Pour Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server et Microsoft 2008 Server : C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Pour Microsoft Windows 7 : C:\ProgramData\McAfee\DesktopProtection
Tableau 1. Fichiers journaux
Nom du fichier | Accès | Affiche
AccessProtectionLog.txt | Dans la colonne Tâche, cliquez sur l'onglet Protection d'accès | Rapports puis sélectionnez Afficher le journal. | Date, heure, événement, utilisateur et nom du fichier.
BufferOverflowProtectionLog.txt | Dans la colonne Tâche, cliquez sur l'onglet Protection en cas de Buffer Overflow | Rapports puis sélectionnez Afficher le journal. | Date, heure, exécutable responsable du Buffer Overflow et type de l'attaque : dépassement de la capacité du tas ou de la pile.
MirrorLog.txt
  • Pour Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server et Microsoft 2008 Server : C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Pour Microsoft Windows 7 : C:\ProgramData\McAfee\DesktopProtection
Date, heure, chemin d'accès aux fichiers miroir et autres informations.
OnAccessScanLog.txt | Dans la colonne Tâche, cliquez sur l'onglet Analyseur à l'accès | Paramètres généraux | Rapports, puis sélectionnez Afficher le journal. | Date, heure, logiciel malveillant (malware) détecté, action entreprise et informations trouvées.
OnDemandScanLog.txt | Cliquez sur Tâche | Afficher le journal dans le menu. | Date et heure de l'analyse, actions entreprises, sur quel fichier et informations trouvées.
UpdateLog.txt
  • Pour Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server et Microsoft 2008 Server : C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Pour Microsoft Windows 7 : C:\ProgramData\McAfee\DesktopProtection
Date, heure et initiateur de la mise à jour et autres informations connexes.


Exécution d'une requête exemple

Exécutez une requête simple pour déterminer la quantité de menaces détectées par semaine sur vos systèmes managés. Cette requête n'est qu'un exemple. Les requêtes que vous exécutez ou configurez dépendent des informations à récupérer dans la base de données ePolicy Orchestrator.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Utilisez l'une des procédures suivantes pour exécuter une requête ePolicy Orchestrator simple :
    • ePolicy Orchestrator 4.5 ou 4.6 : cliquez sur Menu | Rapports | Requêtes puis recherchez la requête VSE : Menaces détectées par semaine et cliquez sur Exécuter.
    • ePolicy Orchestrator 4.0 : cliquez sur Rapports | Requêtes puis recherchez la requête VSE : Menaces détectées par semaine et cliquez sur Exécuter.
  2. Si des menaces sont détectées, les résultats de la requête contiennent les éléments suivants :
    • un graphique à barres indiquant le nombre de menaces détectées et les semaines durant lesquelles elles se sont produites ;
    • un tableau contenant des informations similaires ainsi que le total des menaces.
    Remarque : vous pouvez cliquer sur les informations du graphique à barres ou du tableau pour ouvrir les données de la base de données ePolicy Orchestrator.
  3. Cliquez sur Fermer pour retourner à la liste des requêtes.
Vous pouvez exécuter beaucoup d'autres requêtes et créer les vôtres. Pour plus de détails, consultez la documentation ePolicy Orchestrator.


Analyse de votre protection

L'analyse de la protection de votre système VirusScan Enterprise protégé doit être un processus continu permettant d'améliorer cette protection et les performances de votre système.

Sommaire

Concepts associés
L'importance de l'analyse
Tâches associées
Exemples d'analyses de la protection


L'importance de l'analyse

L'analyse de votre protection vous permet de déterminer à quel type de menace vous êtes confronté, d'où elles proviennent, si elles sont rencontrées fréquemment et quels systèmes sont visés. Par exemple, si un système est sans cesse attaqué, peut-être que ce dernier devrait être déplacé vers une partie plus sécurisée de votre réseau et bénéficier d'une sécurité augmentée pour sa protection.

Cette analyse s'avère également utile lors :
  • de la création de rapports pour les responsables et services informatiques ;
  • de la récupération des informations utilisées pour créer des scripts et des requêtes ;
  • de la surveillance des heures d'accès au réseau et de l'utilisation du réseau de mise à jour VirusScan Enterprise.


Exemples d'analyses de la protection

Vous pouvez suivre les procédures décrites dans ces exemples d'analyses comme structure d'analyse de la plupart des scénarios de protection VirusScan Enterprise.

Ces exemples décrivent un pic d'attaques de logiciels malveillants (malwares) et déterminent :
  • où et quand les attaques ont eu lieu ;
  • quel logiciel malveillant (malware) a été utilisé lors de l'attaque ;
  • l'incidence de l'attaque sur le système.

Tâches

Tâches associées
ePolicy Orchestrator 4.5 ou 4.6
ePolicy Orchestrator 4.0
Console VirusScan


ePolicy Orchestrator 4.5 ou 4.6

Cet exemple d'analyse sert de structure à l'analyse de la plupart des scénarios de protection VirusScan Enterprise avec ePolicy Orchestrator 4.5 ou 4.6.

Avant de commencer

Vous devez disposer d'un accès direct ou distant à un système VirusScan Enterprise protégé pour réaliser cette analyse exemple.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Déterminez où et quand les attaques ont eu lieu :
    1. Cliquez sur Menu | Rapports | Requêtes pour ouvrir le volet Requêtes.
    2. Entrez Malware dans la Recherche rapide et cliquez sur Appliquer. La requête Historique des détections de programmes malveillants s'affiche dans la liste Requêtes.
    3. Sélectionnez la requête et cliquez sur Actions | Exécuter. Elle renvoie le nombre d'attaques récentes.
  2. Pour déterminer quel logiciel malveillant (malware) est responsable de l'attaque, cliquez sur Menu | Rapports | Journal des événements de menace pour afficher ce dernier.
  3. Double-cliquez sur le journal des événements pour afficher la page de détails dans le volet. A partir du journal des événements, il est possible de déterminer :
    • L'Adresse IP source de la menace et sa cible s'affichent pour vous aider à déterminer les actions à entreprendre.
    • Le Nom de la menace et Type de menace décrivent le logiciel malveillant (malware) responsable de l'attaque.
    • Les Descriptions des événements de menace indiquent l'incidence de l'attaque sur le système et les actions entreprises pour la contrer.


ePolicy Orchestrator 4.0

Cet exemple d'analyse sert de structure à l'analyse de la plupart des scénarios de protection VirusScan Enterprise avec ePolicy Orchestrator 4.0.

Avant de commencer

Vous devez disposer d'un accès direct ou distant à un système VirusScan Enterprise protégé pour réaliser cette analyse exemple.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Déterminez où et quand les attaques ont eu lieu :
    1. Cliquez sur Rapports | Requêtes pour ouvrir la liste Requêtes.
    2. Dans la liste Requêtes publiques, sélectionnez ePO : Historique des détections de programmes malveillants et cliquez sur Autres actions | Exécuter. La requête Historique des détections de programmes malveillants s'affiche dans la liste Requêtes.
  2. Pour afficher l'événement déclencheur de la détection du logiciel malveillant, cliquez sur Rapports | Journal des événements : la requête renvoie le nombre d'attaques récentes.
  3. Double-cliquez sur le journal des événements pour afficher la page de détails dans le volet. A partir du journal des événements, il est possible de déterminer les éléments suivants :
    • L'Adresse IP source de la menace et sa cible s'affichent pour vous aider à déterminer les actions à entreprendre.
    • Le Nom de la menace et Type de menace décrivent le logiciel malveillant (malware) responsable de l'attaque.
    • Les Descriptions des événements de menace indiquent l'incidence de l'attaque sur le système et les actions entreprises pour la contrer.


Console VirusScan

Cet exemple d'analyse sert de structure à l'analyse de la plupart des scénarios de protection VirusScan Enterprise avec la Console VirusScan.

Avant de commencer

Vous devez disposer d'un accès direct ou distant à un système VirusScan Enterprise protégé pour réaliser cette analyse exemple.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans la liste Tâche, cliquez sur Analyseur à l'accès avec le bouton droit de la souris et sélectionnez Statistiques dans la liste. La boîte de dialogue Statistiques d'analyse lors de l'accès s'affiche.
  2. Dans le groupe Statistiques d'analyse, notez le nombre de fichiers détectés qui s'affiche. S'il est différent de zéro, cliquez sur Propriétés pour ouvrir la boîte de dialogue Propriétés d'analyse lors de l'accès.
  3. Cliquez sur l'onglet Rapports puis sur Afficher le journal. Le fichier OnAccessScanLog.txt s'affiche dans une fenêtre du Bloc-notes.
  4. A partir de ce fichier de sortie, vous pouvez déterminer les éléments suivants :
    • quel logiciel malveillant (malware) a été utilisé lors de l'attaque, par exemple,
      Fichier de test EICAR	C:\...\eicar.com ;
    • l'incidence de l'attaque sur le système, par exemple,
      (Le nettoyage a échoué car la détection ne peut pas être nettoyée) ;
    • les actions entreprises sur la menace, par exemple,
      Supprimée.
  5. Utilisez les informations de l'étape précédente pour déterminer si les paramètres de protection antivirus des systèmes sources ou cibles doivent être modifiés, ou si vous souhaitez effectuer une autre action.


Annexes

D'autres fonctions de configuration et de dépannage vous permettent d'améliorer la protection offerte par VirusScan Enterprise. Ces fonctions exploitent des outils familiers, par exemple la console ePolicy Orchestrator, la ligne de commande et Internet.

Sommaire

  • Configuration des tâches serveur ePolicy Orchestrator
  • Utilisation de la ligne de commande avec VirusScan Enterprise
  • Connexion à des systèmes distants
  • Envoi des échantillons de menace pour analyse
  • Accès à McAfee Labs Threat Library
  • Dépannage


Configuration des tâches serveur ePolicy Orchestrator

Les tâches serveur, configurées dans ePolicy Orchestrator, vous permettent de planifier et d'exécuter des tâches automatiques pour gérer votre serveur ainsi que le logiciel VirusScan Enterprise.

Les tâches serveur VirusScan Enterprise peuvent être configurées pour générer automatiquement les événements suivants :
  • Exporter les stratégies : permet d'exécuter un rapport de stratégie et de stocker les informations relatives à cette dernière dans un fichier.
  • Exécuter une requête : permet d'exécuter une requête préconfigurée et d'en afficher la sortie sur le tableau de bord ePolicy Orchestrator si cette option a été configurée.
  • Exporter les requêtes : permet d'exécuter une requête préconfigurée et d'envoyer le rapport par e-mail à une adresse configurée ou d'exporter le rapport vers un emplacement défini.
    Remarque : la fonction Exporter les requêtes est disponible uniquement avec ePolicy Orchestrator 4.5 et 4.6.
Les tâches serveur VirusScan Enterprise suivantes sont déjà installées sur le serveur ePolicy Orchestrator :
  • VSE : conformité au cours des 30 derniers jours : permet d'exécuter une requête une fois par jour, qui stocke l'état de conformité du logiciel antivirus McAfee.
  • VSE : adoption de fichiers DAT au cours des dernières 24 heures : permet d'exécuter une requête toutes les heures, qui stocke l'état de la version des fichiers DAT du logiciel antivirus McAfee.
Remarque : pour configurer des tâches serveur personnalisées, reportez-vous au guide produit d'ePolicy Orchestrator approprié, qui contient des instructions détaillées.


Configuration d'une tâche serveur exemple

Pour activer et configurer la tâche serveur ePolicy Orchestrator existante, VSE : conformité au cours des 30 derniers jours.

Avant de commencer

Vous devez disposer de privilèges d'administrateur pour mettre à jour la configuration d'ePolicy Orchestrator.

Tâche

Pour une définition des options, cliquez sur ? dans l'interface.

  1. Ouvrez la page Tâches serveur existante à partir d'ePolicy Orchestrator.
    • ePolicy Orchestrator 4.5 ou 4.6 : cliquez sur Menu | Automatisation | Tâches serveur.
    • ePolicy Orchestrator 4.0 : cliquez sur Automatisation | Tâches serveur.
  2. Dans la colonne Nom, recherchez la tâche VSE : conformité au cours des 30 derniers jours et cliquez sur Modifier dans la colonne Actions. La page du Générateur de tâches serveur s'affiche.
  3. Sélectionnez Activé en regard de l'Etat de planification, puis cliquez sur Suivant. La page Actions s'affiche. En regard de 1. Actions, la tâche serveur Exécuter une requête est sélectionnée par défaut.
  4. En regard de Requête, la tâche serveur VSE : conformité de McAfee VSE 8.8 est sélectionnée par défaut. Modifiez le paramètre de langue si nécessaire. Dans le groupe Sous-actions, confirmez que les éléments suivants sont sélectionnés par défaut :
    • Générer un événement de conformité dans la liste des sous-actions ;
    • Nombre spécifique de systèmes cibles avec 1 dans la zone de texte.
  5. Ajoutez les actions de conformité de VirusScan Enterprise versions 8.7 et 8.5 à la tâche serveur :
    1. Dans la ligne 1. Actions, cliquez sur le signe plus (+) pour afficher une ligne d'actions supplémentaire.
    2. Configurez les éléments suivants dans la nouvelle ligne 2. Actions :
      • En regard de 2. Actions, sélectionnez Exécuter une requête dans la liste.
      • En regard de Requête, sélectionnez VSE : conformité de McAfee VSE 8.7 dans la liste.
      • Modifiez le paramètre de langue si nécessaire.
      • Dans le groupe Sous-actions, confirmez que Générer un événement de conformité et Nombre spécifique de systèmes cibles avec 1 dans la zone de texte sont sélectionnés.
    3. Dans la ligne 2. Actions, cliquez sur le signe plus (+) pour afficher une ligne d'actions supplémentaire.
    4. Configurez les éléments suivants dans la nouvelle ligne 3. Actions :
      • En regard de 3. Actions, sélectionnez Exécuter une requête dans la liste.
      • En regard de Requête, sélectionnez VSE : conformité de McAfee VSE 8.5 dans la liste.
      • Modifiez le paramètre de langue si nécessaire.
      • Dans le groupe Sous-actions, confirmez que Générer un événement de conformité et Nombre spécifique de systèmes cibles avec 1 dans la zone de texte sont sélectionnés.
  6. Cliquez sur Suivant pour ouvrir la page Planification.
  7. Sélectionnez la fréquence d'exécution de la tâche serveur dans la liste Type de planification.
    • Définissez la Date de début ou acceptez la date actuelle comme valeur par défaut.
    • Définissez la Date de fin ou acceptez Aucune date de fin comme valeur par défaut.
    • Définissez la Planification, acceptez la valeur par défaut ou définissez une autre heure de début pour l'exécution de la requête.
  8. Cliquez sur Suivant pour ouvrir la page de résumé. Confirmez que les informations configurées sont correctes.
  9. Cliquez sur Enregistrer : la page Tâches serveur s'affiche de nouveau.
  10. Confirmez que la tâche serveur VSE : conformité au cours des 30 derniers jours présente un Etat activé et que les paramètres de date et d'heure de la Prochaine exécution sont corrects.


Utilisation de la ligne de commande avec VirusScan Enterprise

Vous pouvez utiliser l'invite de commandes pour exécuter des processus VirusScan Enterprise de base. Vous pouvez installer, configurer et mettre à jour VirusScan Enterprise à partir de la ligne de commande. Les options d'installation de la ligne de commande sont décrites dans le Guide d'installation de VirusScan Enterprise.

Exemple d'analyse par ligne de commande

Pour analyser tous les fichiers, mettre à jour les journaux avec les résultats de l'analyse et fermer automatiquement la boîte de dialogue de l'analyse à la demande lorsque cette dernière est terminée, entrez la commande suivante :

scan32 /all /log /autoexit

Exemple de mise à jour par ligne de commande

Pour mettre à jour les fichiers DAT, le moteur d'analyse et le produit de manière silencieuse, ou ne pas afficher la boîte de dialogue de mise à jour McAfee pendant cette dernière, entrez la commande suivante :

mcupdate /update /quiet


Options de ligne de commande de l'analyse à la demande

VirusScan Enterprise utilise l'analyseur à la demande SCAN32.EXE pour détecter les menaces. Vous pouvez exécuter la même commande exécutable, SCAN32, à partir de la ligne de commande, ou dans un fichier de commandes, pour exécuter des analyses.

La syntaxe SCAN32 n'impose pas d'ordre spécifique pour ses éléments, mais vous ne pouvez pas séparer une propriété de sa valeur. La syntaxe comprend les éléments suivants :
  • Nom du fichier : nom du fichier exécutable : SCAN32.EXE.
  • Options : l'option est précédée d'une barre oblique (/) et la casse utilisée n'est pas prise en compte.
Le format de la commande est le suivant :

SCAN32 PROPERTY=VALUE [,VALUE] [/option].

Voici un exemple de commande scan32.exe :

scan32.exe PRIORITY /normal

Dans cet exemple :
  • « PRIORITY » est une valeur de commande ;
  • « /normal » est une option de valeur.

Valeurs et options d'analyse à la demande

Valeur de ligne de commande Définition avec options

ALL

Analyse tous les fichiers dans le dossier cible.

ALLOLE

Analyse les fichiers par défaut et tous les documents Microsoft Office.

ALWAYSEXIT

Impose de quitter l'analyse à la demande, même si l'analyse terminée indique une erreur ou un échec.

APPLYNVP

Recherche les programmes potentiellement indésirables définis dans la Stratégie contre les programmes indésirables.

ARCHIVE

Analyse les fichiers d'archive tels que les fichiers .ZIP, .CAP, .LZH et .UUE.

AUTOEXIT

Quitte l'analyseur à la demande après avoir achevé une analyse non interactive.

CLEAN

Nettoie le fichier cible détecté lorsqu'un programme potentiellement indésirable est découvert.

CLEANA

Nettoie le fichier détecté lorsqu'un programme indésirable est découvert.

CONTINUE

Poursuit l'analyse après la détection d'un programme potentiellement indésirable.

CONTINUE2

Poursuit l'analyse après la détection d'un programme potentiellement indésirable et l'échec de l'action principale.

CONTINUEA

Poursuit l'analyse après la détection d'un programme indésirable.

CONTINUEA2

Poursuit l'analyse après la détection d'un programme indésirable et l'échec de l'action principale.

DEFEXT

Ajoute des extensions de fichier spécifiées en tant que paramètres à la liste des types de fichier sélectionnés inclus dans l'analyse.

DELETE

Supprime le fichier détecté lorsqu'un programme potentiellement indésirable est découvert.

DELETE2

Supprime le fichier détecté après la découverte d'un programme potentiellement indésirable et l'échec de l'action principale.

DELETEA

Supprime le fichier lorsqu'un programme indésirable est détecté.

DELETEA2

Supprime le fichier après la détection d'un programme potentiellement indésirable et l'échec de l'action principale.

EDIT

Affiche la boîte de dialogue des propriétés de l'analyse.

EXT

Remplace les extensions dans la liste des types de fichier sélectionnés inclus dans l'analyse par les extensions de fichiers que vous avez ajoutées en tant que paramètres après cet argument.

LOG

Consigne les rapports de détection dans un fichier journal précédemment spécifié.

LOGFORMAT <valeur>

Utilise le format spécifié pour le fichier journal. Seules les valeurs ANSI, UTF8 ou UTF16 sont autorisées.

LOGSETTINGS

Journalise les paramètres de configuration d'une analyse.

LOGSUMMARY

Journalise un résumé des résultats de l'analyse.

LOGUSER

Journalise les informations d'identification relatives à l'utilisateur exécutant une analyse.

MHEUR

Active la détection Artemis des menaces de macro.

MIME

Détecte les programmes potentiellement indésirables dans les fichiers MIME (Multipurpose Internet Mail Extensions).

NOESTIMATE

Ne calcule pas la taille de l'analyse avant de commencer. La barre de progression ne s'affiche pas.

PHEUR

Active la détection Artemis des menaces de non-macro.

PRIORITY

Définit la priorité de l'analyse par rapport aux autres processus de l'UC. Requiert l'une des options suivantes :
  • LOW
  • BELOWNORMAL : la valeur par défaut d'ePolicy Orchestrator.
  • NORMAL : la valeur par défaut de la Console VirusScan.
Remarque : vous pouvez entrer un paramètre numérique compris entre 1 et 100, où 10 équivaut à LOW, 50 à BELOWNORMAL et 100 à NORMAL.

PROMPT

Invite l'utilisateur à agir lorsqu'un programme potentiellement indésirable est détecté.

PROMPT2

Invite l'utilisateur à agir après la détection d'un programme potentiellement indésirable et l'échec de l'action principale.

PROMPTA

Invite l'utilisateur à agir lorsqu'un programme indésirable est détecté.

PROMPTA2

Invite l'utilisateur à agir après la détection d'un programme indésirable et l'échec de l'action principale.

RPTSIZE

Définit la taille du journal des alertes (en Mo).

START

Exécute l'analyse. N'affiche pas la boîte de dialogue de propriétés.

TASK

Lance la tâche d'analyse à la demande spécifiée sur la Console VirusScan. Nécessite un paramètre supplémentaire précisant l'ID de la tâche spécifiée, tel qu'inscrit dans le Registre à l'emplacement : hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.

UINONE

Lance l'analyseur sans afficher la boîte de dialogue de l'interface utilisateur.


Options de ligne de commande des tâches de mise à jour

VirusScan Enterprise utilise MCUPDATE.EXE pour effectuer des tâches de mise à jour. Vous pouvez exécuter la même commande exécutable, MCUPDATE, à partir de la ligne de commande, ou dans un fichier de commandes, pour exécuter des tâches de mise à jour.

La syntaxe MCUPDATE n'impose pas d'ordre spécifique pour ses éléments, mais vous ne pouvez pas séparer une propriété de sa valeur. La syntaxe comprend les éléments suivants :
  • Nom du fichier : nom du fichier exécutable : MCUPDATE.EXE.
  • Options : l'option est précédée d'une barre oblique (/) et la casse utilisée n'est pas prise en compte.
Le format de la commande est le suivant :
MCUPDATE [/<type> [/TASK <guid>]] [/option].
Remarque : dans le format présenté, <type> peut être remplacé par ROLLBACKDATS ou UPDATE.

La clause /TASK est facultative. Toutefois, si vous l'utilisez, vous devez également spécifier un ID (guid) de tâche de mise à jour. L'ID de tâche sélectionné doit correspondre à une tâche de mise à jour ou de restauration de fichiers DAT. Ne sélectionnez pas un ID d'analyse. Si vous ne précisez pas l'ID de tâche, la tâche de mise à jour par défaut est utilisée. Les ID de tâche se trouvent à l'emplacement suivant : hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

La clause /option n'est pas obligatoire. Pour exécuter une tâche de mise à jour en mode silencieux, utilisez l'option /QUIET.
Remarque : l'option /QUIET n'est pas disponible dans le cas d'une tâche de restauration de fichiers DAT. L'exemple ci-après permet d'effectuer une tâche de mise à jour en mode silencieux. MCUPDATE /UPDATE /QUIET.

Options des tâches de mise à jour

Option de ligne de commande | Définition
ROLLBACKDATS | Annule le fichier DAT actuel et restaure la dernière version sauvegardée.
UPDATE | Effectue une mise à jour du fichier DAT, du moteur d'analyse, du produit ou du fichier extra.dat.
/TASK | Exécute la tâche AutoUpdate ou de restauration de fichiers DAT spécifiée dans la Console VirusScan. Nécessite un paramètre supplémentaire précisant l'ID de la tâche spécifiée, tel qu'inscrit dans le Registre à l'emplacement : hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.
/QUIET | Effectue la tâche en mode silencieux.


Connexion à des systèmes distants

Vous pouvez vous connecter à des systèmes distants sur lesquels VirusScan Enterprise est installé pour effectuer des opérations telles que la modification, la planification de tâches d'analyse ou de mise à jour, ou l'activation et la désactivation de l'analyseur à l'accès sur le système distant.
Remarque : si vous ne disposez pas des droits d'administrateur nécessaires pour vous connecter au système distant, le message d'erreur Droits d'accès utilisateur insuffisants, accès refusé s'affiche.

Lorsque vous démarrez la Console distante VirusScan, le nom du système auquel vous êtes connecté s'affiche dans la barre de titre de la console. Si vous n'êtes pas connecté à un système situé en un autre point du réseau, la barre de titre n'indique pas le nom de votre système local. Lorsque vous ouvrez la boîte de dialogue des propriétés de n'importe quelle tâche à partir d'une console distante, le nom du système s'affiche dans la barre de titre de cette boîte de dialogue.

Vous pouvez ouvrir plusieurs consoles distantes. Lorsque vous fermez la boîte de dialogue Se connecter à l'ordinateur distant, la connexion au système distant est arrêtée.


Accès à des systèmes distants équipés de VirusScan Enterprise

Pour vous connecter à des systèmes distants à administrer équipés de VirusScan Enterprise, utilisez la fonctionnalité Ouvrir la console distante de la Console VirusScan.

Tâche

Pour une définition des options, cliquez sur Aide dans l'interface.

  1. Dans le menu Outils de la Console VirusScan Enterprise 8.8, sélectionnez Ouvrir la console distante.
  2. Sous Se connecter à l'ordinateur, entrez le nom du système à administrer, puis sélectionnez un système dans la liste ou cliquez sur Parcourir pour rechercher le système sur le réseau.
    Remarque : si la procédure de configuration du chemin d'accès au fichier ou au dossier d'une tâche distante fait appel à des variables d'environnement, assurez-vous que celles-ci existent sur le système distant. En effet, la Console VirusScan Enterprise 8.8 ne peut pas valider des variables d'environnement sur le système distant.
  3. Cliquez sur OK pour tenter de vous connecter au système de destination. Une fois la connexion au système distant établie :
    • La barre de titre change pour indiquer le nom du système en question.
    • La console lit le Registre du système distant et affiche les tâches de ce dernier.
    • Vous pouvez ajouter, supprimer ou reconfigurer des tâches du système distant.


Envoi des échantillons de menace pour analyse

Si vous constatez la présence d'une menace potentielle non détectée, ou si l'analyseur détecte des données qu'il ne devrait pas considérer comme des menaces avec le fichier DAT actuel, vous pouvez envoyer un échantillon de la menace à McAfee Labs par le site WebImmune. L'équipe de McAfee Labs analyse l'échantillon et détermine s'il doit être inclus ou non dans le prochain fichier DAT.

Si vous souhaitez envoyer un échantillon à McAfee Labs, trois options s'offrent à vous : via le site WebImmune, par e-mail ou par courrier.

WebImmune

  1. Dans la Console VirusScan, choisissez Aide | Envoi d'un échantillon pour visiter le site web. L'adresse de ce site est la suivante : https://www.webimmune.net/default.asp.
  2. Connectez-vous à votre compte gratuit ou créez-en un.
  3. Téléchargez directement les fichiers sur les systèmes automatisés de l'équipe McAfee Labs pour analyse. Les éléments sont transmis aux analystes de McAfee Labs si des recherches supplémentaires sont nécessaires.

E-mail

Envoyez directement des e-mails aux systèmes automatisés de l'équipe McAfee Labs pour analyse. Les éléments sont transmis aux analystes de McAfee Labs si des recherches supplémentaires sont nécessaires.

L'adresse e-mail mondiale est virus_research@avertlabs.com.
Remarque : d'autres adresses régionales sont disponibles sur le site WebImmune.

Courrier standard

Vous trouverez l'adresse sur le site WebImmune.
Remarque : ce mode de transmission est le moins efficace, car il allonge le délai d'analyse de votre échantillon.


Accès à McAfee Labs Threat Library

Pour accéder à McAfee Labs Threat Library à partir de la Console VirusScan Enterprise 8.8, choisissez McAfee Labs Threat Library dans le menu Aide. Votre navigateur Internet s'ouvre et se connecte à http://vil.nai.com/vil/default.aspx.


Dépannage

Avant de contacter le support technique de McAfee, lisez cette section. Elle contient des informations sur les processus et outils à utiliser pour dépanner votre configuration de VirusScan Enterprise, ainsi qu'une foire aux questions.


Réparation de l'installation du produit

Il pourrait arriver que vous ayez besoin de réparer l'installation de VirusScan Enterprise pour restaurer les paramètres par défaut, réinstaller les fichiers programme ou les deux. Vous pouvez pour cela utiliser la Console VirusScan ou la ligne de commande.

Utilisation de la Console VirusScan

Pour accéder à l'utilitaire Réparer l'installation, dans la Console VirusScan Enterprise 8.8, choisissez Aide | Réparer l'installation.
Remarque : cette fonction n'est pas disponible à partie de la console ePolicy Orchestrator.
Option | Définition
Restaurer les paramètres d'installation par défaut | Restaure les paramètres d'installation par défaut de VirusScan Enterprise. ATTENTION : les paramètres personnalisés risquent d'être perdus.
Réinstaller tous les fichiers programme | Réinstalle les fichiers programme de VirusScan Enterprise. ATTENTION : il est possible que les HotFix, patchs et Service Packs soient écrasés.

Utilisation de SETUPVSE.exe dans la ligne de commande

Pour réparer ou réinstaller VirusScan Enterprise à partir de la ligne de commande à l'aide de la commande SETUPVSE.exe, utilisez les commandes suivantes.
Remarque : pour les options de paramètre de ligne de commande REINSTALLMODE, reportez-vous à la page REINSTALLMODE Property (en anglais), à l'adresse http://msdn.microsoft.com/en-us/library/aa371182(VS.85).aspx.
Description | Commande
Installer les fichiers programme uniquement | SETUPVSE.exe REINSTALLMODE=sec /q
Installer les fichiers de Registre uniquement | SETUPVSE.exe REINSTALLMODE=secum /q
Installer les fichiers programme et de Registre | SETUPVSE.exe REINSTALLMODE=amus /q

Utilisation de msiexec.exe dans la ligne de commande

Pour réparer ou réinstaller VirusScan Enterprise à partir de la ligne de commande à l'aide de la commande msiexec.exe, utilisez les commandes suivantes.
Remarque : pour les options de ligne de commande msiexec.exe, reportez-vous à la page Options de ligne de commande pour l'outil Msiexec.exe de Microsoft Windows Installer, à l'adresse http://support.microsoft.com/kb/314881.
Description | Commande
Installer les fichiers programme uniquement | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=sa /q REBOOT=R
Installer les fichiers de Registre uniquement | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=mu /q REBOOT=R
Installer les fichiers programme et de Registre | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=samu /q REBOOT=R


Affichage du journal d'activité à l'accès

Le journal d'activité à l'accès de la Console VirusScan contient l'historique des mises à jour, de l'activité des menaces et des réponses de VirusScan Enterprise. Ces informations peuvent s'avérer utiles dans le cadre du dépannage de l'activité de mise à jour automatique et des configurations de stratégies.

Utilisez l'une des procédures suivantes pour accéder aux journaux d'activité à l'accès :
Remarque : la fonction de génération de journal d'activité à l'accès doit être activée. Pour ce faire, reportez-vous à la section Configuration des paramètres généraux.

Tâche

Pour une définition des options, cliquez sur Aide dans chaque onglet.
  1. Dans la liste Tâche, cliquez sur Analyseur à l'accès avec le bouton droit de la souris, puis sélectionnez Propriétés pour ouvrir la boîte de dialogue.
  2. Dans la boîte de dialogue des propriétés de l'analyseur à l'accès, cliquez sur l'onglet Rapports puis sur Afficher le journal. Le fichier OnAccessScanLog.txt s'affiche dans une fenêtre du Bloc-notes. Voici un exemple de sortie de journal d'activité.

  3. Le tableau suivant décrit les données de l'exemple de fichier OnAccessScanLog.txt utilisé précédemment :
    Exemple d'entrée de journal | Description
    27/04/2010 | Date
    13:35:47 | Heure
    Nettoyé/Supprimé/Aucune action entreprise | Action entreprise
    Fichier mis à jour = version, ou (Le nettoyage a échoué car... | Description de l'action
    SRVR\utilisateur | Informations d'identification
    C:\WINDOWS\system32\NOTEPAD.EXE C:\temp\eicar.com | Chemin et nom du fichier représentant la menace
    Fichier de test EICAR (Test) | Description du fichier

Des informations similaires sont disponibles via les requêtes ePolicy Orchestrator. Pour en savoir plus, reportez-vous à la section Accès aux requêtes et aux tableaux de bord.

Tâches associées
Configuration des paramètres généraux
Informations associées
Accès aux requêtes et aux tableaux de bord


Utilisation de l'outil MERTool dans le cadre du dépannage

L'outil MERTool (Minimum Escalation Requirements tool) collecte les données de McAfee VirusScan Enterprise et d'autres produits McAfee sur votre ordinateur. L'utilisation de ces données permet au support technique de McAfee d'analyser et de résoudre votre problème.

L'outil WebMER peut être téléchargé via l'un des formats de fichier suivants :
  • EXE
  • ZIP
  • ZIP protégé
Les informations collectées par l'outil WebMER comprennent :
  • les détails du Registre ;
  • les détails de la version des fichiers ;
  • les fichiers ;
  • les journaux d'événements ;
  • les détails des processus.
Pour utiliser l'outil WebMER, vous devez :
  • Consulter le didacticiel Obtaining Minimum Escalation Requirements using McAfee WebMER (en anglais) se trouvant à l'adresse : https://kc.mcafee.com/corporate/index?page=content&id=TU30146.
  • Télécharger et installer le logiciel à partir de : http://mer.mcafee.com.
    Remarque : une version déployable d'ePolicy Orchestrator est également disponible. Cette version utilise la console ePolicy Orchestrator pour exécuter l'outil MERTool sur les ordinateurs clients pour la collecte des journaux et informations dans le cadre du diagnostic des problèmes du produit McAfee. Téléchargez McAfee MER pour ePolicy Orchestrator 4.x (v2.0) à l'adresse : http://mer.mcafee.com/enduser/downloadepomer.aspx.
  • Exécutez l'outil et renvoyez la sortie au support technique de McAfee.


Désactivation de VirusScan Enterprise dans le cadre du dépannage

Si un problème système pouvant être lié aux processus exécutés par VirusScan Enterprise survient, vous pouvez désactiver systématiquement les fonctions VirusScan Enterprise jusqu'à ce que le problème système soit éliminé. Vous pouvez également vous contenter d'éliminer VirusScan Enterprise comme cause possible du problème.
ATTENTION :
vous devez reconfigurer ou restaurer VirusScan Enterprise pour bénéficier de la protection complète contre les logiciels malveillants (malwares) après un dépannage.
La désactivation systématique de la fonctionnalité VirusScan Enterprise se compose de huit étapes :
  1. Désactivation de la protection en cas de Buffer Overflow
  2. Désactivation de la protection d'accès
  3. Désactivation du composant ScriptScan
  4. Désactivation de l'analyse à l'accès
  5. Désactivation de l'analyse à l'accès puis redémarrage
  6. Blocage du chargement et redémarrage effectués par MFEVTP
  7. Renommage du fichier mfehidk.sys puis redémarrage
  8. Suppression du produit puis redémarrage

Chacune de ces huit étapes est décrite dans les sections suivantes. Pour les définitions des options de la Console VirusScan, cliquez sur Aide dans l'interface.

Désactivation de la protection en cas de Buffer Overflow

Cette procédure permet de désactiver la protection en cas de Buffer Overflow.
  1. Dans la liste des tâches de la Console VirusScan, cliquez sur Protection en cas de Buffer Overflow avec le bouton droit de la souris et sélectionnez Propriétés.
  2. Dans la boîte de dialogue Propriétés, désélectionnez Activer la protection en cas de Buffer Overflow et cliquez sur OK.
  3. Le problème système d'origine est résolu en désactivant la protection en cas de Buffer Overflow :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à cette fonction.

Désactivation de la protection d'accès

Cette procédure permet de désactiver la protection de l'accès.
  1. Dans la liste des tâches de la Console VirusScan, double-cliquez sur Protection d'accès pour ouvrir la boîte de dialogue des propriétés de la protection de l'accès.
  2. Cliquez sur l'onglet Protection d'accès, désélectionnez Activer la protection d'accès et cliquez sur OK.
  3. Le problème système d'origine est résolu en désactivant la protection de l'accès :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à VirusScan Enterprise.

Désactivation du composant ScriptScan

Cette procédure permet de désactiver le composant ScriptScan.
  1. Dans la liste des tâches de la Console VirusScan, cliquez sur Analyseur à l'accès avec le bouton droit de la souris pour ouvrir la boîte de dialogue des propriétés de l'analyse à l'accès.
  2. Cliquez sur l'onglet ScriptScan, désélectionnez Activer l'analyse des scripts et cliquez sur OK.
  3. Le problème système d'origine est résolu en désactivant le composant ScriptScan :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à VirusScan Enterprise.

Désactivation de l'analyse à l'accès

Cette procédure permet de désactiver l'analyse à l'accès.
  1. Désactivez la protection d'accès. Dans la liste des tâches de la Console VirusScan, cliquez sur Protection d'accès avec le bouton droit de la souris et sélectionnez Désactiver.
  2. Modifiez le type de démarrage de l'applet des services McShield sur Désactivé via la procédure suivante :
    • Cliquez sur Démarrer | Panneau de configuration | Outils d'administration | Services pour ouvrir l'applet des services.
    • Dans Services (local), recherchez McAfee McShield et cliquez sur ce nom avec le bouton droit de la souris pour ouvrir la boîte de dialogue des propriétés de McAfee McShield.
    • Cliquez sur l'onglet Général, puis dans la liste Type de démarrage, cliquez sur Désactivé, puis sur OK.
  3. Dans la liste des tâches de la Console VirusScan, cliquez sur Analyseur à l'accès avec le bouton droit de la souris et sélectionnez Désactiver dans la liste qui s'affiche. L'icône de l'analyseur à l'accès doit se transformer et contenir un cercle barré pour indiquer que la fonction est désactivée.
  4. Le problème système d'origine est résolu en désactivant l'analyse à l'accès :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à cette fonction.

Désactivation de l'analyse à l'accès puis redémarrage

Cette procédure permet de désactiver l'analyse à l'accès et le redémarrage.
Remarque : la procédure suivante suppose que vous n'avez pas réactivé l'analyse à l'accès après sa désactivation lors des étapes décrites dans la section précédente.

  1. Effectuez un arrêt complet du système et redémarrez-le.
  2. Le problème système d'origine est résolu en désactivant l'analyse à l'accès et le redémarrage :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à cette fonction.

Blocage du chargement et redémarrage effectués par MFEVTP

Cette procédure permet d'empêcher le service McAfee Validation Trust Protection (MFEVTP) de charger et de redémarrer le système :
ATTENTION :
cette section contient des informations relatives à l'ouverture ou à la modification du Registre.
  • Les informations suivantes sont destinées aux administrateurs système. Les modifications apportées au Registre sont irréversibles et peuvent causer des défaillances système si elles ne sont pas effectuées correctement.
  • Avant de poursuivre, McAfee vous recommande fortement de sauvegarder votre Registre et de bien connaître le processus de restauration. Pour plus d'informations, voir : http://support.microsoft.com/kb/256986 .
  • N'exécutez pas de fichier .REG dont vous n'êtes pas certain qu'il s'agit d'un fichier d'importation de Registre authentique.

  1. A partir de la ligne de commande, entrez regedit afin d'afficher l'interface utilisateur de l'Editeur du Registre.
  2. Accédez au Registre suivant : [HKEY_LOCAL_MACHINE\System\ControlSet001\Services\mfevtp]
  3. Dans le volet de droite, cliquez sur Start avec le bouton droit de la souris puis sur Modifier pour afficher la boîte de dialogue Edition de la valeur DWORD.
  4. Entrez 4 dans le champ Données de la valeur puis cliquez sur OK.
  5. Le problème système d'origine est résolu en empêchant le chargement puis le redémarrage de MFEVTP :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à cette fonction.

Renommage du fichier mfehidk.sys puis redémarrage

Cette procédure permet de renommer le fichier mfehidk.sys et de redémarrer le système.
  1. Accédez au fichier mfehidk.sys du dossier suivant, en fonction de votre système d'exploitation :
    • Pour les systèmes d'exploitation 32 bits : %windir%\System32\drivers
    • Pour les systèmes d'exploitation 64 bits : %windir%\System64\drivers
  2. Remplacez le nom du fichier mfehidk.sys par mfehidk.sys.sauvegarde par exemple.
  3. Redémarrez le système afin d'arrêter et redémarrer VirusScan Enterprise sans charger le fichier mfehidk.sys.
  4. Le problème système d'origine est résolu en renommant le fichier mfehidk.sys puis en redémarrant :
    • Oui : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.
    • Non : le problème système d'origine n'était probablement pas lié à VirusScan Enterprise.

Suppression du produit puis redémarrage

Cette procédure permet de supprimer totalement VirusScan Enterprise et de redémarrer :
  1. Supprimez les fichiers programme de VirusScan Enterprise. Reportez-vous au Guide d'installation de McAfee VirusScan Enterprise 8.8 pour des instructions détaillées.
  2. Redémarrez le système pour arrêter et redémarrer le système d'exploitation sans que VirusScan Enterprise ne soit installé.
  3. Le problème système d'origine est résolu en supprimant totalement les fichiers programme de VirusScan Enterprise et en redémarrant :
    • Oui : le problème système d'origine était probablement lié à VirusScan Enterprise.
    • Non : rendez-vous sur le portail du support technique ServicePortal de McAfee à l'adresse http://mysupport.mcafee.com et recherchez une solution ou contactez le support technique de McAfee.


Outils de dépannage et de support suggérés

En tant qu'administrateur global VirusScan Enterprise, vous devez installer et configurer certains outils vous permettant de dépanner votre système et d'en évaluer la sécurité et les performances. Lorsque vous contactez le support technique de McAfee, ce dernier peut vous demander d'exécuter certains de ces outils dans le cadre du dépannage de votre configuration. Ces outils peuvent être téléchargés à partir des sites Internet répertoriés dans ces tableaux.

Outils McAfee

Les outils de dépannage et de support que vous pouvez télécharger auprès de McAfee sont répertoriés dans ce tableau.

Outil | Site de téléchargement
MERTool | WebMER
ProcessCounts | Fourni par le support de McAfee
SuperDAT Manager | Fourni par le support de McAfee
McAfee Profiler | Fourni par le support de McAfee

Outils non McAfee

Les outils de dépannage et de support, exécutables et sites de téléchargement sont répertoriés dans ce tableau.

Outil | Exécutable | Site de téléchargement
Vérificateur de pilotes | Verifier | Microsoft.com
Analyseur de performances | PerfMon | Microsoft.com
Analyseur de mémoire en pool | PoolMon | Microsoft.com
Process Monitor | ProcMon | Microsoft.com
Process Explorer | ProcExp | Microsoft.com
Vidage du processus | ProcDump | Microsoft.com
Explorateur d'objets Windows | WinObj | Microsoft.com
TCP Viewer | TCPView | Microsoft.com
Visionneuse de sortie de débogage | DebugView | Microsoft.com
Windows Debugger | WinDbg | Microsoft.com
Visionneuse des performances du noyau | KrView | Microsoft.com
Outils d'analyse des performances Windows | Xperf | Microsoft.com
VM Converter | Variable | Vmware.com
WireShark | wireshark | Wireshark.org


Foire aux questions

Cette section contient des informations sur le dépannage sous forme de foire aux questions.

Installation

  • Question : Je viens de procéder à l'installation silencieuse du logiciel, et l'icône VirusScan Enterprise ne s'affiche pas dans la barre d'état système de Windows.

    Réponse : L'icône ne s'affiche pas dans la barre d'état système tant que vous n'avez pas redémarré votre système. Toutefois, même si l'icône ne s'affiche pas, sachez que VirusScan Enterprise est en cours d'exécution et que votre système est protégé. Pour en être sûr, vérifiez la clé de Registre suivante : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • Question : Pourquoi certains utilisateurs du réseau peuvent-ils configurer leurs propres paramètres et d'autres non ?

    Réponse : L'administrateur peut avoir configuré l'interface utilisateur de manière à protéger les tâches par un mot de passe. Dans ce cas, les utilisateurs ne peuvent pas modifier les paramètres. En outre, les privilèges d'utilisateur varient selon les systèmes d'exploitation Microsoft Windows. Reportez-vous à votre documentation Microsoft Windows pour plus d'informations sur les privilèges d'utilisateur.

Programmes bloqués

  • Question : J'ai installé VirusScan Enterprise, et l'un de mes programmes ne fonctionne plus.

    Réponse : Le programme est peut-être bloqué par une règle de protection d'accès.
    1. Passez en revue le fichier journal de la protection d'accès pour déterminer si c'est le cas.
    2. Si le programme est effectivement répertorié dans le journal, vous pouvez soit l'entrer comme une exception à la règle, soit désactiver la règle. Consultez la section Protection des points d'accès à votre système pour plus d'informations.

Détections de cookies

  • Question : En passant en revue les détections de cookies dans le journal d'activité de l'analyse à la demande, j'ai remarqué que le nom du fichier de détection est 00000000.ie pour toutes les détections. Pourquoi VirusScan Enterprise attribue-t-il toujours le même nom de fichier aux détections de cookies lors de l'analyse à la demande, alors que d'autres programmes affectent des noms de fichier différents ou incrémentiels ?

    Réponse : Le fait que VirusScan Enterprise attribue le même nom de fichier à toutes les détections de cookies tient à la façon dont l'analyseur à la demande agit sur les cookies et les détecte. Ce comportement s'applique uniquement aux cookies détectés lors des analyses à la demande. Un fichier de cookies peut contenir plusieurs cookies. Le moteur d'analyse traite le fichier de cookies comme une archive et lui attribue une valeur en fonction du décalage existant par rapport au début du fichier (en partant de zéro). L'analyseur utilisant le moteur d'analyse pour détecter les cookies et agir sur chacun de ceux qu'il a détectés avant de procéder à l'analyse elle-même, il recommence à zéro pour chaque détection. C'est la raison pour laquelle le nom de fichier 00000000.ie est attribué à toutes les détections. Les autres produits commencent par détecter tous les cookies, puis ils leur attribuent à chacun un nom de fichier individuel ou incrémentiel et, pour finir, entreprennent des actions sur chaque détection.

Général

  • Question : Sur mon système VirusScan Enterprise autonome, l'icône de ma barre d'état système semble être désactivée.

    Réponse : Si l'icône VirusScan Enterprise est entourée d'un cercle rouge et barrée, cela signifie que l'analyseur à l'accès est désactivé. Vous trouverez ci-après les causes les plus courantes et leurs solutions. Si vous ne parvenez pas à résoudre votre problème, contactez le support technique :
    1. Vérifiez que l'analyseur à l'accès est activé. Cliquez avec le bouton droit de la souris sur l'icône VirusScan Enterprise de la barre d'état système. Si l'analyseur à l'accès est désactivé, cliquez sur Activer l'analyse lors de l'accès.
    2. Vérifiez que le service McShield est actif.
      • Démarrez le service manuellement dans le panneau de configuration des services.
      • Sélectionnez Démarrer | Exécuter, puis entrez Net Start McShield.
      • Dans le panneau de configuration des services, définissez le service de façon à ce qu'il démarre automatiquement.

  • Question : Je reçois un message d'erreur indiquant qu'il m'est impossible de télécharger le fichier CATALOG.Z.

    Réponse : Cette erreur peut avoir de nombreuses causes. Vous trouverez ci-après quelques suggestions pour vous aider à déterminer la source du problème.
    • Si vous utilisez le site de téléchargement par défaut de McAfee pour les mises à jour, voyez si vous parvenez à télécharger le fichier CATALOG.Z à partir d'un navigateur web. Essayez de télécharger le fichier à partir de ce site web : http://update.nai.com/Products/CommonUpdater/catalog.z.
    • Si vous ne parvenez pas à télécharger le fichier, alors que vous pouvez le visualiser (en d'autres termes, si votre navigateur ne vous autorise pas à le télécharger), vous avez un problème de proxy. Demandez conseil à votre administrateur réseau.
    • Si vous parvenez à télécharger le fichier, VirusScan Enterprise devrait pouvoir le faire également. Pour une assistance concernant le dépannage de votre installation de VirusScan Enterprise, contactez le support technique.

  • Question : Quel est l'emplacement du site de téléchargement HTTP ?

    Réponse :
    • L'emplacement du site de téléchargement de McAfee est le suivant : http://www.mcafee.com/us/downloads/.
    • Le fichier CATALOG.Z, qui contient les dernières mises à jour, peut être téléchargé à partir de ce site web : http://update.nai.com/Products/CommonUpdater/catalog.z.

  • Question : Quel est l'emplacement du site de téléchargement FTP ?

    Réponse :
    • L'emplacement du site de téléchargement FTP est le suivant : ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x.
    • Le fichier CATALOG.Z, qui contient les dernières mises à jour, peut être téléchargé à partir de ce site web : ftp://ftp.mcafee.com/CommonUpdater/catalog.z.

  • Question : Si je détecte un programme potentiellement indésirable alors que j'ai choisi l'option Interroger l'utilisateur, quelle action dois-je sélectionner (Nettoyer ou Supprimer) ?

    Réponse : De manière générale, il est conseillé de choisir Nettoyer si vous ne savez pas exactement quoi faire avec un fichier détecté. Les analyseurs à l'accès et à la demande sauvegardent automatiquement les éléments dans le répertoire de quarantaine avant nettoyage ou suppression.


Onglet Protection d'accès

Définition des options

Configurez les règles de protection de l'accès et empêchez l'arrêt des processus McAfee.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres de protection de l'accès
  • Activer la protection d'accès : activer la fonction de protection de l'accès.
  • Empêcher l'arrêt des services McAfee : empêcher les utilisateurs sans privilèges de débogage d'arrêter les processus McAfee.

    Les utilisateurs disposant des privilèges de débogage ont toujours la possibilité d'arrêter les processus McAfee, même si l'option est sélectionnée.

    Les administrateurs disposent par défaut des privilèges de débogage des programmes pour les systèmes d'exploitation Windows XP et Windows 2003. Supprimez ces privilèges des autorisations d'utilisateur pour que ces derniers ne puissent pas arrêter les processus McAfee.

ATTENTION :
si vous n'activez pas la protection d'accès et n'empêchez pas l'arrêt des services McAfee, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Règles de protection de l'accès

Catégories : sélectionnez une catégorie afin d'afficher les règles de cette catégorie. Les règles sont regroupées selon les catégories suivantes :

  • Protection standard antivirus
  • Protection maximale antivirus
  • Contrôle des attaques d'antivirus
  • Protection standard commune
    ATTENTION :
    si vous ne configurez pas la protection standard commune et que vous n'activez pas les options Bloquer et Rapport des règles suivantes, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares) :
    • Empêcher la modification des fichiers et paramètres McAfee.
    • Empêcher la modification des paramètres et fichiers McAfee Common Management Agent.
    • Empêcher la modification des paramètres et fichiers du moteur d'analyse McAfee.
    • Empêcher l'arrêt des processus McAfee.
  • Protection maximale commune
  • Protection de la machine virtuelle
  • Règles définies par l'utilisateur
  • Protection standard contre les logiciels espions
  • Protection maximale contre les logiciels espions

Consultez la section Définition des règles de protection de l'accès pour plus d'informations.

Bloquer/Rapport/Règles : configurez les règles :

  • Bloquer : bloque le processus spécifié dans les Détails des règles. Sélectionnez Bloquer pour activer la règle ou désélectionnez cette option pour la désactiver.

    Remarque :

    Pour bloquer les tentatives d'accès sans enregistrement dans le journal, sélectionnez Bloquer et non Rapport.

  • Rapport : active la consignation dans des rapports de tentatives de violation de la protection d'accès. Lorsqu'une détection a lieu, les informations sont enregistrées dans le journal d'activité.
    Remarque :

    Pour recevoir un avertissement sans bloquer les tentatives d'accès, sélectionnez Rapport et non Bloquer. Cela peut se révéler très pratique lorsque l'impact total d'une règle n'est pas connu. Contrôlez les journaux d'activité et les rapports sur une courte période afin d'opter ou non pour un blocage d'accès.

  • Règles : utilisez les règles pour protéger votre ordinateur contre les modifications indésirables. Les règles sont organisées par catégorie. Sélectionnez tout d'abord la catégorie, puis la règle. Consultez la section Configuration des règles prédéfinies et Configuration des règles définies par l'utilisateur pour plus d'informations.

    Nouveau : créer une nouvelle règle définie par l'utilisateur. Consultez la section Configuration des règles définies par l'utilisateur pour plus d'informations.

    Modifier : modifier une règle existante.

    Supprimer : supprimer une règle définie par l'utilisateur existante.
    Remarque :

    Vous pouvez supprimer uniquement les règles définies par l'utilisateur. Il est possible de modifier ou de désactiver les autres règles mais elles ne peuvent pas être supprimées. Pour désactiver une règle, désélectionnez les options Bloquer et Rapport.

Tâches associées
Configuration des paramètres de sécurité de l'interface utilisateur
Informations associées
Protection d'accès


Onglet Options d'alerte supplémentaires

Définition des options

Configurer le filtre et les options d'alerte locales.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Filtre de gravité Choisissez l'une des options de filtre suivantes :
  • Ne pas filtrer les alertes : envoyer toutes les alertes.
  • Supprimer les alertes de type Informations : ne pas envoyer les alertes de type Informations d'une gravité inférieure à 1.
  • Supprimer les alertes de type Informations et Avertissements : ne pas envoyer les alertes de type Informations et Avertissement d'une gravité inférieure à 2.
  • Supprimer les alertes de type Informations, Avertissements et les alertes peu importantes : ne pas envoyer les alertes de type Informations, Avertissement et Mineure d'une gravité inférieure à 3.
  • Supprimer toutes les alertes à l'exception des alertes de type Grave : n'envoyer aucune alerte sauf celles d'une gravité supérieure à 4.
  • Supprimer toutes les alertes : n'envoyer aucune alerte.
Alertes locales
  • Consigner dans le journal d'événements d'applications local : consigner les informations dans le journal d'événements d'applications local.
  • Envoyer une interruption SNMP à l'aide du service SNMP : si vous utilisez SNMP, vous pouvez envoyer des alertes d'interruptions SNMP.
Remarque :

Les options d'alertes locales ne nécessitent pas Alert Manager.
Tâches associées
Configuration des alertes
Informations associées
Configuration des alertes et notifications


Onglet Alertes

Définition des options

Sélectionnez les composants souhaités pour générer des alertes et configurez Alert Manager s'il est installé.

Consultez le Guide Produit d'Alert Manager 4.7.1 pour plus d'informations.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Composants générateurs d'alertes
  • Analyse à l'accès : générer des alertes lorsque l'analyseur à l'accès détecte des menaces.
  • Analyse à la demande et analyses planifiées : générer des alertes lorsque les tâches d'analyse à la demande détectent des menaces.
  • Analyse d'e-mails : générer des alertes lorsque l'analyseur d'e-mails détecte des menaces.
  • AutoUpdate : générer des alertes lorsque les tâches de mise à jour automatique détectent des menaces.
  • Protection d'accès : générer des alertes lorsque la protection d'accès détecte des menaces.
Options d'Alert Manager
  • Désactiver les alertes : ne pas générer d'alerte en cas de détection.
  • Activer les alertes centralisées : utiliser les alertes centralisées pour être averti en cas de détection.
  • Activer les alertes Alert Manager : utiliser les alertes Alert Manager pour être averti en cas de détection. Sélectionnez cette option et saisissez le chemin d'accès au serveur Alert Manager qui reçoit les alertes.
    • Désactiver la recherche Active Directory : ne pas utiliser la recherche Active Directory.
Tâches associées
Configuration des alertes
Informations associées
Configuration des alertes et notifications


Onglet Rapports

Définition des options

Activez la journalisation pour suivre les activités sur votre réseau et enregistrer les paramètres utilisés pour détecter et traiter une menace potentielle découverte par l'analyseur.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Consigner dans le fichier | Activer la journalisation des activités.
Emplacement du fichier journal Accepter l'emplacement par défaut du fichier journal ou indiquer un nouvel emplacement.

Le nom du journal par défaut est AccessProtectionLog.txt.

L'emplacement par défaut est le suivant : <lecteur>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

L'emplacement par défaut peut varier en fonction du système d'exploitation que vous utilisez.
Taille du fichier journal | Limiter la taille du fichier journal. Accepter la taille par défaut (1 Mo) ou définir une taille comprise entre 1 et 999 Mo. Si les données font grossir le fichier journal au-delà de la taille indiquée, les entrées les plus anciennes (20 %) sont supprimées et de nouvelles données sont ajoutées au fichier.
Format du fichier journal Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Concepts associés
Violations de point d'accès et réponse de VirusScan Enterprise
Tâches associées
Console VirusScan
Référence associée
Affichage du journal d'activité à l'accès


Tâche AutoUpdate

Configurez la tâche AutoUpdate.

Définition des options

Option | Définition
Fichier journal | Activer la journalisation des activités.
Format Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Obtenir les fichiers de définition les plus récents pour la détection

Obtenir la version la plus récente des fichiers DAT s'il en existe une.

Obtenir les moteurs les plus récents pour la détection

Obtenir la version la plus récente du moteur et des fichiers DAT si elles existent.

Obtenir les autres mises à jour disponibles (service packs, mises à niveau, etc.)

Obtenir la version la plus récente d'autres mises à jour, comme des Service Packs et des mises à niveau du produit.

Entrer le fichier exécutable à lancer après mise à jour

Spécifier un fichier exécutable à lancer après la fin de l'exécution de la tâche AutoUpdate. Indiquer le chemin d'accès de l'exécutable à lancer ou cliquer sur Parcourir pour le rechercher.

Vous pouvez ainsi démarrer un utilitaire de message réseau avertissant l'administrateur que la tâche AutoUpdate est terminée.

Remarque : le fichier programme spécifié doit être exécutable par l'utilisateur actuellement connecté. Si l'utilisateur actuellement connecté n'a pas accès au dossier contenant les fichiers programme ou si aucun utilisateur n'est actuellement connecté, le programme ne démarre pas.
Exécuter uniquement après une mise à jour réussie

Exécuter le programme exécutable après une mise à jour réussie. Si la mise à jour a échoué, le programme spécifié ne démarre pas.

Planifier

Définir la planification de cette tâche de mise à jour.

Remarque :

Voir la section Planification des tâches pour plus d'informations.

Il est préférable de ne pas planifier l'exécution d'une tâche AutoUpdate et d'une tâche de mise en miroir au même moment. Les deux tâches utilisant le service McAfee Common Framework, leur exécution simultanée risque de créer un conflit.

Mettre à jour maintenant

Exécuter la tâche AutoUpdate immédiatement.

Concepts associés
Tâches de mise à jour et fonctionnement
Référence associée
Configuration de la tâche AutoUpdate


Onglet Blocage

Définition des options

Bloquez les connexions émanant d'ordinateurs distants qui stockent des fichiers associés à des menaces potentielles ou des programmes indésirables dans un dossier partagé.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Envoyer un message | Envoyer le message spécifié à l'utilisateur réseau quand une menace est détectée : notifier l'utilisateur réseau sur l'ordinateur distant qu'une menace est détectée.
Texte du message

Saisir un message personnalisé dans la zone de texte. Le service Windows Messenger doit être en cours d'exécution sur l'ordinateur distant pour assurer la réception de ce message.
Bloquer la connexion
  • Bloquer la connexion quand un fichier contenant une menace potentielle est détecté dans un dossier partagé : bloquer la connexion de tout utilisateur réseau sur un ordinateur distant qui tente de lire ou d'écrire dans un fichier contenant une menace potentielle dans le dossier partagé.
  • Débloquer les connexions après : les connexions sont débloquées lorsque le nombre de minutes spécifié est écoulé. Entrer un nombre entre 1 et 9 999. Valeur par défaut = 10 minutes.
  • Bloquer la connexion quand un fichier contenant un programme potentiellement indésirable est détecté dans un dossier partagé : bloquer la connexion de tout utilisateur sur un ordinateur distant qui tente d'écrire un programme indésirable dans l'ordinateur. La boîte de dialogue Statistiques d'analyse lors de l'accès affiche la liste des ordinateurs bloqués.
Référence associée
Options des règles de blocage de ports
Options des règles de blocage de fichiers et de dossiers
Options des règles de blocage du Registre
Informations associées
Protection d'accès


Onglet Rapports

Définition des options

Activez la journalisation de façon à effectuer le suivi des détections sur le système local de l'exécution de code à partir d'un débordement de tas ou de pile pour certains traitements.

Option | Définition
Alerte sur les cookies | Avertir l'utilisateur lors de la détection d'un cookie. Par défaut = sélectionné.
Consigner dans le fichier | Activer la journalisation des activités et accepter l'emplacement par défaut du fichier journal ou spécifier un nouvel emplacement.
Emplacement du fichier journal Accepter l'emplacement par défaut du fichier journal ou indiquer un nouvel emplacement.

Le nom du journal par défaut est BufferOverflowProtectionLog.txt.

L'emplacement par défaut est le suivant : <lecteur>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

L'emplacement par défaut peut varier en fonction du système d'exploitation que vous utilisez.

Taille du fichier journal | Limiter la taille du fichier journal. Accepter la taille par défaut (1 Mo) ou définir une taille comprise entre 1 et 999 Mo. Si les données font grossir le fichier journal au-delà de la taille indiquée, les entrées les plus anciennes (20 %) sont supprimées et de nouvelles données sont ajoutées au fichier.
Format du fichier journal Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Informations associées
Configuration des alertes et notifications
Blocage des exploits par Buffer Overflow


Onglet Protection en cas de Buffer Overflow

Définition des options

Empêchez les exploits par Buffer Overflow d'exécuter un code arbitraire sur votre ordinateur.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres de la protection en cas de Buffer Overflow Activer la protection en cas de Buffer Overflow : activer la fonction de protection contre le Buffer Overflow, puis sélectionner le niveau de protection.

  • Mode Avertissement : envoie un avertissement en cas de détection d'un Buffer Overflow. Aucune autre action n'est entreprise.

    Ce mode peut s'avérer très pratique lorsque l'impact total d'un Buffer Overflow n'est pas connu. Utilisez la fonction en Mode Avertissement sur une courte durée et examinez le fichier journal de cette période pour déterminer s'il est nécessaire de passer en Mode Protection.

  • Mode Protection : bloque les Buffer Overflows dès leur détection et arrête le thread détecté.

    Cela peut également entraîner l'arrêt de l'application.

ATTENTION :
si vous n'activez pas la Protection en cas de Buffer Overflow et le Mode Protection, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Avertissement du système client | Afficher la boîte de dialogue de messages si un Buffer Overflow est détecté : affiche la boîte de dialogue Messages d'analyse lors de l'accès en cas de détection.
Exclusions en cas de Buffer Overflow Définissez les informations relatives aux exclusions :
Remarque :

La casse des noms d'exclusion est prise en compte.

  • Processus : indiquez le nom du processus propriétaire de la mémoire avec accès en écriture à l'origine de l'appel.

    Saisissez uniquement le nom du processus ou incluez son chemin d'accès.

    Si vous saisissez uniquement le nom du processus, par exemple OUTLOOK.EXE, ce processus est exclu chaque fois qu'il est exécuté, quel que soit son emplacement. Si vous tapez le nom du processus ainsi que son chemin d'accès, par exemple C:\Program files\OUTLOOK.EXE, ce processus n'est exclu que lorsqu'il est exécuté depuis le chemin spécifié. Les caractères génériques ne sont pas autorisés.

  • Module (facultatif) : le cas échéant, saisissez le nom du module propriétaire de la mémoire avec accès en écriture. Cette information n'est pas requise.
  • API : indiquez l'API appelée.
    Remarque :

    L'API n'est obligatoire que lorsque le module est spécifié.

Tâches associées
Configuration de la protection en cas de Buffer Overflow
Informations associées
Blocage des exploits par Buffer Overflow


Onglet Processus

Définition des options

Choisissez de configurer une seule stratégie d'analyse pour tous les processus ou différentes stratégies d'analyse pour les processus par défaut, à faible risque et à haut risque.

Consultez la section Détermination du nombre de stratégies d'analyse et Détermination du risque à affecter à un processus pour plus d'informations.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres de processus Indiquez si vous souhaitez configurer une ou plusieurs stratégies d'analyse :
  • Configurer une stratégie d'analyse pour tous les processus : si vous sélectionnez cette option, la stratégie que vous configurez s'applique à tous les processus.
  • Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque : vous devez sélectionner cette option avant de pouvoir configurer des stratégies pour les processus à faible risque ou à haut risque.
Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Options d'affichage

Définition des options

Configurez les options de la barre d'état système auxquelles les utilisateurs ont accès et la langue à utiliser de préférence.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Icône de la barre d'état système
  • Afficher l'icône de la barre d'état système avec toutes les options : les utilisateurs voient toutes les options de la barre d'état système.
  • Afficher l'icône de la barre d'état système avec les options minimales : toutes les options de la barre d'état système sont masquées, à l'exception des options A propos de VirusScan Enterprise et Statistiques d'analyse lors de l'accès.
  • Ne pas afficher l'icône de la barre d'état système : l'icône de la barre d'état système est masquée pour tous les utilisateurs.
Options de la console
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.

  • Autoriser le système à effectuer des connexions à la console distante vers d'autres systèmes : établir une connexion à des ordinateurs distants.

    Vous devez disposer des droits d'administrateur et le service d'accès à distance au Registre doit être en cours d'exécution.

  • Afficher les tâches gérées dans la console client : afficher les tâches ePolicy Orchestrator dans la console de l'ordinateur client.
  • Désactiver la planification de la tâche AutoUpdate (mise à jour automatique) par défaut : désactiver la planification de la tâche de mise à jour par défaut.

    La planification est désactivée lorsque la stratégie est appliquée. Le service de gestionnaire des tâches doit être en cours d'exécution pour pouvoir désactiver la planification de la tâche.

  • Activer l'écran de démarrage : afficher l'écran de démarrage de VirusScan Enterprise 8.8 lors de l'exécution de SHSTAT.EXE ou de la console.
    Remarque :

    cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.

Paramètres de langue de la console Indiquez la langue à utiliser pour le texte de la console :
  • La langue peut être sélectionnée automatiquement ou vous pouvez sélectionner une langue spécifique.
    Remarque :

    Lorsque vous changez la langue préférée à partir de la Console VirusScan Enterprise 8.8, un message vous invite à redémarrer le système. Si vous cliquez sur Oui, le changement de langue s'applique.

    Lorsque vous changez la langue préférée à partir de la console ePolicy Orchestrator, ce changement devient effectif dans la console utilisateur à la première application d'une stratégie.

    Pour les systèmes ePolicy Orchestrator managés, les changements apportés par l'utilisateur à partir du système client s'appliquent à l'interface de la console, mais le fichier journal enregistre l'activité dans la langue spécifiée dans la configuration d'ePolicy Orchestrator. Le changement de langue d'une console s'applique après redémarrage de celle-ci.

Tâches associées
Configuration des paramètres de sécurité de l'interface utilisateur
Informations associées
Protection d'accès


Onglet Actions

Définition des options

Configurer les actions à effectuer lorsqu'une menace ou un programme potentiellement indésirable est détecté.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Si une menace est détectée Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit effectuer lorsqu'il détecte une menace. Valeur par défaut = Nettoyer les pièces jointes.
  • Nettoyer les pièces jointes : l'analyseur tente de supprimer la menace de la pièce jointe.
  • Interroger l'utilisateur : l'utilisateur est interrogé sur l'action à entreprendre lorsqu'une menace est détectée. Sélectionner cette option, puis spécifier les actions autorisées pour les utilisateurs dans Actions autorisées dans la boîte de dialogue d'invite.
Aucune action secondaire n'est autorisée pour cette option.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'une pièce jointe avec une menace est détectée.
Aucune action secondaire n'est autorisée pour cette option.
  • Déplacer les pièces jointes vers un dossier : l'analyseur déplace les pièces jointes potentiellement infectées vers le dossier choisi.
  • Supprimer les pièces jointes : l'analyseur supprime les pièces jointes potentiellement infectées dès leur détection. Pour Microsoft Outlook, l'e-mail est supprimé. Pour Lotus Notes, la pièce jointe est supprimée.
  • Supprimer les messages électroniques (analyse Outlook uniquement) : l'analyseur supprime le message potentiellement infecté. Si vous sélectionnez cette option comme action principale, aucune action secondaire n'est autorisée.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Déplacer les pièces jointes vers un dossier.
  • Interroger l'utilisateur : l'utilisateur est interrogé sur l'action à entreprendre lorsqu'une menace est détectée. Sélectionner cette option, puis spécifier les actions autorisées pour les utilisateurs dans Actions autorisées dans la boîte de dialogue d'invite.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'une pièce jointe avec une menace est détectée.
  • Déplacer les pièces jointes vers un dossier : l'analyseur déplace les pièces jointes potentiellement infectées vers le dossier choisi.
  • Supprimer les pièces jointes : l'analyseur supprime les pièces jointes potentiellement infectées dès leur détection. Pour Microsoft Outlook, l'e-mail est supprimé. Pour Lotus Notes, la pièce jointe est supprimée.
  • Supprimer les messages électroniques (analyse Outlook uniquement) : l'analyseur supprime le message potentiellement infecté.
Si un programme indésirable est détecté Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit entreprendre lors de la détection d'un programme potentiellement indésirable. Valeur par défaut = Nettoyer les pièces jointes.
  • Nettoyer les pièces jointes : l'analyseur tente de supprimer la menace de la pièce jointe.
  • Interroger l'utilisateur : l'utilisateur est interrogé sur l'action à entreprendre lorsqu'une menace est détectée. Sélectionner cette option, puis spécifier les actions autorisées pour les utilisateurs dans Actions autorisées dans la boîte de dialogue d'invite.
Aucune action secondaire n'est autorisée pour cette option.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'une pièce jointe avec une menace est détectée.
Aucune action secondaire n'est autorisée pour cette option.
  • Déplacer les pièces jointes vers un dossier : l'analyseur déplace les pièces jointes potentiellement infectées vers le dossier choisi.
  • Supprimer les pièces jointes : l'analyseur supprime les pièces jointes potentiellement infectées dès leur détection. Pour Microsoft Outlook, l'e-mail est supprimé. Pour Lotus Notes, la pièce jointe est supprimée.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Déplacer les pièces jointes vers un dossier.
  • Interroger l'utilisateur : l'utilisateur est interrogé sur l'action à entreprendre lorsqu'une menace est détectée. Sélectionner cette option, puis spécifier les actions autorisées pour les utilisateurs dans Actions autorisées dans la boîte de dialogue d'invite.
Aucune action secondaire n'est autorisée pour cette option.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'une pièce jointe avec une menace est détectée.
Aucune action secondaire n'est autorisée pour cette option.
  • Déplacer les pièces jointes vers un dossier : l'analyseur déplace les pièces jointes potentiellement infectées vers le dossier choisi.
  • Supprimer les pièces jointes : l'analyseur supprime les pièces jointes potentiellement infectées dès leur détection. Pour Microsoft Outlook, l'e-mail est supprimé. Pour Lotus Notes, la pièce jointe est supprimée.
Déplacer vers le dossier Indiquer l'emplacement du dossier de quarantaine. Le dossier de quarantaine doit se trouver sur un disque dur et cet emplacement doit correspondre à un lecteur local. Il ne doit pas être placé sur une disquette ni à l'emplacement par défaut du lecteur de CD, car le dossier de quarantaine varie selon que vous utilisez Microsoft Outlook ou Lotus Notes.
  • Pour Microsoft Outlook, le dossier de quarantaine se trouve dans la boîte aux lettres Microsoft Outlook.
  • Pour Lotus Notes, le dossier de quarantaine figure dans le système de fichiers.
Actions autorisées dans la boîte de dialogue d'invite Sélectionner les actions autorisées lorsque l'utilisateur est invité à effectuer une action.
Remarque :

Une action Refuser l'accès par défaut s'exécute avant que l'une des actions ci-après ne soit effectuée.

  • Nettoyer la pièce jointe
  • Supprimer la pièce jointe
  • Déplacer la pièce jointe
  • Supprimer l'e-mail (pour Microsoft Outlook uniquement)
Lorsque l'utilisateur est invité à agir, il reçoit le message spécifié dans l'onglet Alertes.
Tâches associées
Configuration de la stratégie de quarantaine
Référence associée
Détections d'analyse à l'accès
Détections d'analyse à la demande
Détections lors de d'analyse d'e-mails
Informations associées
Détections et réponses


Onglet Alertes

Définition des options

Configurez les paramètres d'alerte pour l'analyse des e-mails à la réception.

Option | Définition
Paramètres pour | Sélectionner Poste de travail ou Serveur dans la liste déroulante. Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Alerte par e-mail à l'utilisateur | Envoyer un e-mail d'alerte à l'utilisateur : notifier un autre utilisateur lorsqu'un e-mail contenant une menace potentielle est détecté.
Message d'interrogation de l'utilisateur | Indiquer le message qui s'affiche pour inviter l'utilisateur à agir. L'option Interroger l'utilisateur doit être sélectionnée dans l'onglet Actions. Accepter le message par défaut ou saisir un nouveau message. Message par défaut = McAfee VirusScan Enterprise Analyseur d'e-mails : Alerte !
Tâches associées
Configuration des alertes


Onglet Eléments à analyser

Définition des options

Configurer les options de détection pour l'analyseur d'e-mails à la demande.

Option | Définition
Messages à analyser
  • Tous les éléments en surbrillance : analyser les dossiers et messages électroniques sélectionnés.
  • Tous les messages dans le dossier Boîte de réception : analyser tous les messages qui se trouvent dans le dossier Boîte de réception et dans ses sous-dossiers.
    • Analyser uniquement les messages non lus : analyser tous les messages non lus qui se trouvent dans le dossier Boîte de réception et dans ses sous-dossiers.
Pièces jointes à analyser
  • Tous les types de fichier : analyser tous les types de fichier, quelle que soit leur extension.
  • Fichiers par défaut + types supplémentaires : analyser la liste d'extensions par défaut et tous les ajouts indiqués. La liste par défaut est définie par le fichier DAT actuel. Sélectionner Fichiers par défaut + types supplémentaires, puis entrer les extensions de fichier dans la zone de texte, séparées par des espaces.

    Rechercher également les macros dans toutes les pièces jointes : si vous avez sélectionné Fichiers par défaut + types supplémentaires, vous pouvez également rechercher les menaces de macro connues dans tous les fichiers.

  • Types de fichier spécifiés : créer une liste spécifiée par l'utilisateur d'extensions de fichiers à analyser. Vous pouvez également supprimer toute extension ajoutée précédemment.

    Sélectionnez Types de fichier spécifiés, puis entrez les extensions de fichier dans la zone de texte, séparées par des espaces.

Artemis (recherche réseau heuristique de fichiers suspects)
  • Détecter les menaces de programmes inconnus et les chevaux de Troie : utiliser l'analyse Artemis pour détecter les fichiers exécutables ayant un code proche de celui de programmes malveillants (malwares).
  • Détecter les menaces de macro inconnues : utiliser l'analyse Artemis pour détecter les virus de macro inconnus.
  • Rechercher les pièces jointes portant plusieurs extensions : traiter les pièces jointes associées à plusieurs extensions comme une menace.

    Lorsque vous sélectionnez cette option, une boîte de dialogue Avertissement d'analyse d'e-mails s'affiche. Cliquez sur OK pour confirmer votre sélection.

ATTENTION :
si vous n'activez pas Artemis, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Fichiers compressés
  • Analyser à l'intérieur des archives : examiner les fichiers d'archive (compressés) et leur contenu.

    Bien qu'elle apporte une meilleure protection, l'analyse des fichiers compressés peut augmenter la durée d'une analyse.

  • Décoder les fichiers MIME : détecter, décoder et analyser les fichiers MIME (Multipurpose Internet Mail Extensions).
Détection de programmes indésirables Détecter les programmes indésirables : active l'analyse des e-mails à la réception pour détecter les programmes potentiellement indésirables. L'analyseur d'e-mails utilise les informations configurées dans la Stratégie contre les programmes indésirables pour détecter ces programmes.

Consultez la section Restriction de programmes potentiellement indésirables pour plus d'informations.

Corps des e-mails (pour Microsoft Outlook uniquement) | Analyser le corps des e-mails : analyser le corps des e-mails Microsoft Outlook.
Tâches associées
Configuration des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Rapports

Définition des options

Activez la journalisation pour suivre les activités sur votre réseau et enregistrer les paramètres utilisés pour détecter et traiter une menace potentielle découverte par l'analyseur.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Consigner dans le fichier | Activer la journalisation des activités.
Emplacement du fichier journal Accepter l'emplacement par défaut du fichier journal ou indiquer un nouvel emplacement.

Le nom par défaut du fichier journal des e-mails analysés à la demande est EmailOnDemandLog.txt.

L'emplacement par défaut est le suivant : <lecteur>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

L'emplacement par défaut peut varier en fonction du système d'exploitation que vous utilisez.

Taille du fichier journal | Limiter la taille du fichier journal. Accepter la taille par défaut (1 Mo) ou définir une taille comprise entre 1 et 999 Mo. Si les données font grossir le fichier journal au-delà de la taille indiquée, les entrées les plus anciennes (20 %) sont supprimées et de nouvelles données sont ajoutées au fichier.
Format du fichier journal Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Que journaliser, en plus des activités d'analyse ?
  • Paramètres de session : enregistrer les propriétés de chaque session d'analyse dans le fichier journal.
  • Récapitulatif de session : enregistrer un récapitulatif des actions de l'analyseur pendant chaque session d'analyse dans le fichier journal. Les informations du récapitulatif incluent le nombre de fichiers analysés, le nombre et le type de détections, le nombre de fichiers nettoyés ou supprimés, ainsi que d'autres données.
  • Impossible d'analyser les fichiers cryptés : enregistrer le nom des fichiers chiffrés dont l'analyse est impossible.
Tâches associées
Configuration des alertes


Onglet Eléments à analyser

Définition des options

Configurez les options de détection de l'analyseur d'e-mails.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Analyse des e-mails Activer l'analyse des e-mails à la réception.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Pièces jointes à analyser
  • Tous les types de fichier : analyser tous les types de fichier, quelle que soit leur extension.
  • Fichiers par défaut + types supplémentaires : analyser la liste d'extensions par défaut et tous les ajouts indiqués. La liste par défaut est définie par le fichier DAT actuel. Sélectionner Fichiers par défaut + types supplémentaires, puis entrer les extensions de fichier dans la zone de texte, séparées par des espaces.

    Rechercher également les macros dans toutes les pièces jointes : si vous avez sélectionné Fichiers par défaut + types supplémentaires, vous pouvez également rechercher les menaces de macro connues dans tous les fichiers.

  • Types de fichier spécifiés : créer une liste spécifiée par l'utilisateur d'extensions de fichiers à analyser. Vous pouvez également supprimer toute extension ajoutée précédemment.

    Sélectionnez Types de fichier spécifiés, puis entrez les extensions de fichier dans la zone de texte, séparées par des espaces.

Artemis (recherche réseau heuristique de fichiers suspects)
  • Détecter les menaces de programmes inconnus et les chevaux de Troie : utiliser l'analyse Artemis pour détecter les fichiers exécutables ayant un code proche de celui de programmes malveillants (malwares).
  • Détecter les menaces de macro inconnues : utiliser l'analyse Artemis pour détecter les virus de macro inconnus.
  • Rechercher les pièces jointes portant plusieurs extensions : traiter les pièces jointes associées à plusieurs extensions comme une menace.

    Lorsque vous sélectionnez cette option, une boîte de dialogue Avertissement d'analyse d'e-mails s'affiche. Cliquez sur OK pour confirmer votre sélection.

ATTENTION :
si vous n'activez pas Artemis, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Fichiers compressés
  • Analyser à l'intérieur des archives : examiner les fichiers d'archive (compressés) et leur contenu.

    Bien qu'elle apporte une meilleure protection, l'analyse des fichiers compressés peut augmenter la durée d'une analyse.

  • Décoder les fichiers MIME : détecter, décoder et analyser les fichiers MIME (Multipurpose Internet Mail Extensions).
Détection de programmes indésirables Détecter les programmes indésirables : active l'analyse des e-mails à la réception pour détecter les programmes potentiellement indésirables. L'analyseur d'e-mails utilise les informations configurées dans la Stratégie contre les programmes indésirables pour détecter ces programmes.

Consultez la section Restriction de programmes potentiellement indésirables pour plus d'informations.

Corps des e-mails (pour Microsoft Outlook uniquement) | Analyser le corps des e-mails : analyser le corps des e-mails Microsoft Outlook.
Recherche réseau heuristique de fichiers suspects
Configurer le niveau de sensibilité à utiliser pour déterminer si un échantillon détecté est un logiciel malveillant (malware). Pour tous les niveaux autres que Désactivé, des empreintes d'échantillons, obtenues par hachage, sont envoyées à McAfee Labs pour déterminer s'il s'agit de logiciels malveillants (malwares). L'avantage pour vous est que cette détection peut être mise à disposition dès que McAfee Labs publie la mise à jour, sans que vous ayez à attendre la version de fichier DAT suivante. Plus le niveau de sensibilité est élevé, plus le nombre de détections de logiciels malveillants (malwares) augmente. Toutefois, l'augmentation du nombre de détections peut engendrer une progression des détections de faux positifs. Choisissez l'un des niveaux de sensibilité suivants :

  • Désactivé : aucune empreinte ni aucune donnée n'est envoyée à McAfee Labs afin d'en déterminer la nature.

  • Très faible : les détections et le risque de faux positifs sont du même niveau qu'avec les fichiers DAT standard. Une détection est mise à la disposition de VirusScan Enterprise si elle est publiée par McAfee Labs sans attendre la prochaine mise à jour de fichier DAT.

  • Faible : ce niveau se situe entre les niveaux Très faible et Moyen.

  • Moyen : utilisez ce niveau lorsque le risque standard d'exposition à des logiciels malveillants (malwares) est supérieur au risque de faux positif. La recherche heuristique interne exclusive de McAfee Labs génère des détections qui sont susceptibles de correspondre à des logiciels malveillants (malwares). Il y a cependant un risque qu'une détection portant sur un fichier rarement rencontré engendre la détection d'un faux positif. McAfee Labs vérifie que les détections avec ce paramètre ne généreront pas de faux positifs avec des applications couramment utilisées et des fichiers de système d'exploitation.

  • Élevé : ce niveau se situe entre les niveaux Moyen et Très élevé.

  • Très élevé : nous recommandons d'utiliser ce niveau uniquement pour les e-mails et pour l'analyse de volumes et de répertoires qui ne sont associés ni à l'exécution de programmes ni à des systèmes d'exploitation. Les détections de ce niveau sont supposées correspondre à des logiciels malveillants, mais n'ont pas été entièrement testées pour vérifier qu'il ne s'agissait pas de faux positifs.

Tâches associées
Analyse d'e-mails à la demande et à la réception


Onglet Général

Définition des options

Configurez les options générales de l'analyse à l'accès.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Analyser Indiquer les éléments généraux à analyser :
  • Secteurs d'amorçage : analyser les secteurs d'amorçage. Valeur par défaut = Désactivé.
  • Disquette pendant l'arrêt du système : analyser les lecteurs de disquette pendant l'arrêt de l'ordinateur. Valeur par défaut = Activé.
  • Processus activés : le service McAfee McShield à l'accès analyse tous les processus qui sont déjà en cours d'exécution. Valeur par défaut = Désactivé.
    Remarque : l'activation de cette fonctionnalité optimise la sécurité mais a une incidence sur les performances du démarrage.
Activer l'analyse à l'accès Indiquer le moment auquel activer l'analyse :
  • Activer l'analyse à l'accès au démarrage du système : activer l'analyseur à l'accès à chaque démarrage de l'ordinateur.
  • Activer l'analyse à l'accès lors de l'application de la stratégie : activer l'analyseur à l'accès chaque fois que la stratégie est appliquée.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Durée maximale d'analyse Spécifier la durée maximale d'analyse :
  • Imposer une durée maximale d'analyse pour tous les fichiers : définir une durée maximale d'analyse et l'imposer pour tous les fichiers.
  • Durée maximale d'analyse : indiquer la durée maximale d'analyse de tous les fichiers, en secondes. Valeur par défaut = 45 secondes.
Remarque : si une analyse dépasse le délai, l'analyse s'arrête correctement et journalise un message. Si l'analyse ne peut pas s'arrêter correctement, elle se termine, puis redémarre à l'analyse suivante.
Cookies

Analyser les fichiers de cookies : activer l'analyse des fichiers de cookies.

Artemis (recherche réseau heuristique de fichiers suspects) | Spécifier l'un des six niveaux de sensibilité d'Artemis : de Désactivé à Très élevé. Valeur par défaut = Très faible.
Tâches associées
Configuration des paramètres généraux
Informations associées
Analyse d'éléments à l'accès


Onglet Paramètres généraux de l'analyse

Définition des options

Définissez les options du cache d'analyse pour enregistrer les données lors d'un redémarrage système et autorisez les analyses à la demande à utiliser les données du cache nettoyé pour optimiser les performances. Consultez la section Configuration des paramètres généraux pour en savoir plus.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Cache de l'analyse Configurer les options et les paramètres globaux
  • Activer l'enregistrement des données d'analyse après les redémarrages : cette option permet d'enregistrer les résultats d'analyse des éléments sains au redémarrage du système. (Par défaut = sélectionné.)
    Remarque : désactivez cette fonction si le système est utilisé là où des disques durs pourraient être endommagés de manière externe. Par exemple, si le disque dur est retiré, son contenu mis à jour, puis qu'il est remplacé (les machines virtuelles et systèmes avec configurations en double démarrage sont inclus dans cette exception).
  • Autoriser l'utilisation du cache de l'analyse par les analyses à la demande : cette option permet à l'analyseur à la demande d'utiliser les résultats d'analyse des éléments sains pour réduire les analyses redondantes. (Par défaut = sélectionné.)
Tâches associées
Configuration du cache système global


Onglet Processus

Définition des options de l'étape 1

Indiquez les processus définis comme étant à haut risque. Cette opération se déroule en deux étapes.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres de processus

Ouvrez les Stratégies des processus d'analyse à l'accès par défaut, puis sélectionnez :

  • Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque
Remarque :

vous devez sélectionner cette option avant de configurer des stratégies pour les processus à faible risque ou à haut risque.

Définition des options de l'étape 2

Option | Définition
Paramètres pour | Sélectionner Poste de travail ou Serveur dans la liste déroulante. Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Processus à haut risque | Ouvrez les Stratégies des processus d'analyse à l'accès à haut risque pour indiquer les processus que vous considérez à haut risque. Ajoutez et supprimez des processus si nécessaire.

Consultez la section Détermination du nombre de stratégies d'analyse et Détermination du risque à affecter à un processus pour plus d'informations.

Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Processus

Définition des options de l'étape 1

Indiquez les processus que vous définissez comme présentant un risque faible. Cette opération se déroule en deux étapes.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres de processus

Ouvrez les Stratégies des processus d'analyse à l'accès par défaut, puis sélectionnez :

  • Configurer différentes stratégies d'analyse pour les processus par défaut, à haut risque et à faible risque
Remarque :

vous devez sélectionner cette option avant de configurer des stratégies pour les processus à faible risque ou à haut risque.

Définition des options de l'étape 2

Option | Définition
Paramètres pour | Sélectionner Poste de travail ou Serveur dans la liste déroulante. Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Processus à faible risque | Ouvrez les Stratégies des processus d'analyse à l'accès à faible risque pour indiquer les processus que vous considérez à faible risque. Ajoutez et supprimez des processus si nécessaire.

Consultez la section Détermination du nombre de stratégies d'analyse et Détermination du risque à affecter à un processus pour plus d'informations.

Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Messages

Définition des options

Configurez les options de messages pour les utilisateurs locaux et les utilisateurs sans droits d'administrateur.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Messages de l'utilisateur Indiquer les messages devant être reçus par les utilisateurs locaux.
  • Afficher la boîte de dialogue de message lorsqu'une menace est détectée et y afficher le texte spécifié : présenter la boîte de dialogue Messages d'analyse lors de l'accès aux utilisateurs locaux en cas de détection.

  • Alerter lorsqu'un cookie est détecté : envoyer des alertes lorsque des cookies sont détectés. Cela inclut la génération d'alertes ePolicy Orchestrator, l'envoi de messages à la boîte de dialogue Messages d'analyse lors de l'accès, l'enregistrement des détections dans le journal d'activité si vous avez activé la journalisation des activités dans l'onglet Rapports et le décompte des détections dans les statistiques d'analyse. Si vous désélectionnez cette option, ePolicy Orchestrator ne génère pas d'alertes, mais les détections continuent d'être enregistrées dans le journal d'activité si vous avez activé la journalisation des activités dans l'onglet Rapports et d'être décomptées dans les statistiques d'analyse.

Texte du message

Accepter le message par défaut ou saisir un message personnalisé. Message par défaut = Alerte VirusScan Enterprise 8.8 !

Actions disponibles pour les utilisateurs
  • Supprimer des messages de la liste : les utilisateurs sans droits d'administrateur sont autorisés à supprimer des messages dans la liste.
  • Nettoyer les fichiers : les utilisateurs sans droits d'administrateur sont autorisés à nettoyer les fichiers référencés par les messages de la liste.
  • Supprimer les fichiers : les utilisateurs sans droits d'administrateur sont autorisés à supprimer les fichiers référencés par les messages de la liste.
Référence associée
Détections d'analyse à l'accès


Tâche de mise en miroir

Configurez la tâche de mise en miroir.

Console VirusScan Enterprise 8.8 — Définition des options

Option | Définition
Fichier journal | Activer la journalisation des activités.
Format Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Obtenir les fichiers de définition les plus récents pour la détection

Cette option ne s'applique pas aux tâches de mise en miroir.
Obtenir les moteurs les plus récents pour la détection

Cette option ne s'applique pas aux tâches de mise en miroir.
Obtenir les autres mises à jour disponibles (service packs, mises à niveau, etc.)

Cette option ne s'applique pas aux tâches de mise en miroir.
Entrer le fichier exécutable à lancer après mise en miroir

Spécifier un fichier exécutable à lancer après la fin de l'exécution de la tâche de mise en miroir. Indiquer le chemin d'accès de l'exécutable à lancer ou cliquer sur Parcourir pour le rechercher.

Vous pouvez par exemple démarrer un utilitaire de message réseau avertissant l'administrateur que la tâche de mise en miroir est terminée.

Remarque : le fichier programme spécifié doit être exécutable par l'utilisateur actuellement connecté. Si l'utilisateur actuellement connecté n'a pas accès au dossier contenant les fichiers programme ou si aucun utilisateur n'est actuellement connecté, le programme ne démarre pas.
Exécuter uniquement après une mise en miroir réussie

Exécuter le programme exécutable après une mise en miroir réussie. Si la mise en miroir a échoué, le programme spécifié ne démarre pas.
Emplacement de mise en miroir

Spécifiez le chemin d'accès au dossier de destination sur le système local que vous utilisez pour le site miroir.

Remarque : les variables système sont prises en charge.
Planifier

Définir la planification de cette tâche de mise à jour.

Remarque :

Voir la section Planification des tâches pour plus d'informations.

Il est préférable de ne pas planifier l'exécution d'une tâche AutoUpdate et d'une tâche de mise en miroir au même moment. Les deux tâches utilisant le service McAfee Common Framework, leur exécution simultanée risque de créer un conflit.
Mettre en miroir

Effectuer la tâche de mise en miroir immédiatement.

Concepts associés
Tâches de mise en miroir et leur fonctionnement
Référence associée
Configuration de la tâche de mise en miroir


Onglet Paramètres d'analyse de Notes

Définition des options

Configurez les paramètres Lotus Notes pour l'analyse des e-mails à la réception.

Configuration du mot de passe Lotus Notes

Lorsque vous accédez à une base de données locale sous Windows 2000 Server, Windows 2003 Server ou Windows XP, un message vous invite à entrer un mot de passe. Lorsque vous entrez le mot de passe, la boîte de dialogue de recherche de texte est activée et le mot de passe y est inséré au lieu de s'afficher dans la boîte de dialogue de mot de passe. La boîte de dialogue de mot de passe n'est pas entièrement modale. Vous pouvez entrer le mot de passe en sélectionnant de nouveau cette boîte de dialogue.

McAfee vous recommande de suivre la procédure suivante pour empêcher les invites de saisie de mot de passe multiples :
  1. Dans Lotus Notes, cliquez sur Fichier | Préférences | Sécurité | Sécurité utilisateur | Boîte de dialogue.
  2. Cliquez sur Utiliser le même mot de passe pour tous les programmes basés sur Notes (sécu. réduite).
    ATTENTION :
    ce choix de configuration réduit potentiellement la sécurité de votre système.
Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Paramètres d'analyse serveur
  • Analyser toutes les bases de données du serveur : rechercher des menaces potentielles dans toutes les bases de données du serveur.
  • Analyser les boîtes aux lettres du serveur : rechercher des menaces potentielles dans toutes les boîtes aux lettres du serveur.
  • Dossier racine de boîte aux lettres : indiquer l'emplacement du dossier racine. Accepter l'emplacement par défaut pour le dossier racine de boîte aux lettres ou indiquer un nouvel emplacement. Cette option est disponible uniquement pour l'analyse des e-mails à la réception. Valeur par défaut = !!mail\.
Options avancées | Applications Notes à exclure : indiquez les applications Lotus Notes à exclure de l'analyse. Valeur par défaut = MNOTES.
Tâches associées
Analyse d'e-mails à la demande et à la réception


Onglet Actions

Définition des options

Configurer les actions à effectuer lorsqu'une menace ou un programme potentiellement indésirable est détecté. Si vous configurez différentes stratégies d'analyse pour les processus par défaut, à faible risque et à haut risque, les options de cet onglet doivent être configurées pour chaque type de processus.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Si une menace est détectée Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit effectuer lorsqu'il détecte une menace. Valeur par défaut = Nettoyer automatiquement les fichiers.
  • Nettoyer automatiquement les fichiers : l'analyseur tente de supprimer la menace du fichier détecté.
  • Refuser l'accès aux fichiers : tout accès utilisateur aux fichiers potentiellement infectés détectés par l'analyseur est refusé.
  • Supprimer automatiquement les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Supprimer automatiquement les fichiers.
  • Refuser l'accès aux fichiers : tout accès utilisateur aux fichiers potentiellement infectés détectés par l'analyseur est refusé.
  • Supprimer automatiquement les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
Si un programme indésirable est détecté Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit entreprendre lors de la détection d'un programme potentiellement indésirable. Valeur par défaut = Nettoyer automatiquement les fichiers.
  • Autoriser l'accès aux fichiers : accorder aux utilisateurs l'accès aux fichiers et aux programmes détectés.
    Remarque :

    Utilisez cette action pour surveiller les éléments détectés avant de décider des actions à effectuer. Consultez le journal d'activité pour afficher les programmes détectés. Aucune action secondaire n'est autorisée pour cette option.

  • Nettoyer automatiquement les fichiers : supprimer automatiquement la menace des fichiers et des programmes détectés.
  • Refuser l'accès aux fichiers : empêcher les utilisateurs d'accéder aux fichiers et aux programmes détectés.
  • Supprimer automatiquement les fichiers : supprimer automatiquement les fichiers et les programmes détectés.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Supprimer automatiquement les fichiers.
  • Autoriser l'accès aux fichiers : accorder aux utilisateurs l'accès aux fichiers et aux programmes détectés.
  • Refuser l'accès aux fichiers : empêcher les utilisateurs d'accéder aux fichiers et aux programmes détectés.
  • Supprimer automatiquement les fichiers : supprimer automatiquement les fichiers et les programmes détectés.
Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Exclusions

Définition des options

Spécifier les éléments à exclure de l'analyse. Si vous configurez différentes stratégies d'analyse pour les processus par défaut, à faible risque et à haut risque, les options de cet onglet doivent être configurées pour chaque type de processus.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Eléments à exclure Sélectionner le type d'exclusion, puis indiquer les détails de cette dernière :
  • Exclure par nom/emplacement de fichier : entrer le nom et l'emplacement du fichier dans la zone de texte. Sélectionner Exclure également les sous-dossiers si nécessaire.
    Remarque : vous devez ajouter une barre oblique inverse (\) à la fin de la chaîne pour que cela s'applique à un dossier. Sinon, cela est considéré comme une exclusion de fichier et la case à cocher Exclure également les sous-dossiers est désactivée par défaut.
  • Exclure par type de fichier : entrer le type de fichier dans la zone de texte.
  • Exclure par âge de fichier : sélectionner le type d'accès, puis indiquer l'âge minimum en jours.

Consultez la section Ajout et exclusion d'éléments à analyser pour plus informations.

Conditions d'exclusion Choisir les conditions dans lesquelles exclure l'élément sélectionné :
  • Lors de la lecture
  • Lors de l'écriture
Gestion des exclusions client Remplacer les exclusions client : exclure uniquement les éléments spécifiés dans cette stratégie. Si cette option n'est pas sélectionnée, l'ordinateur client utilise les exclusions définies localement et les exclusions définies dans cette stratégie.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Rapports

Définition des options

Activez la journalisation pour suivre les activités sur votre réseau et enregistrer les paramètres utilisés pour détecter et traiter une menace potentielle découverte par l'analyseur.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Consigner dans le fichier | Activer la journalisation des activités.
Emplacement du fichier journal Accepter l'emplacement par défaut du fichier journal ou indiquer un nouvel emplacement.

Le nom du journal par défaut est OnAccessScanLog.txt.

L'emplacement par défaut est le suivant : <lecteur>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\.

L'emplacement par défaut peut varier en fonction du système d'exploitation que vous utilisez.
Taille du fichier journal | Limiter la taille du fichier journal. Accepter la taille par défaut (1 Mo) ou définir une taille comprise entre 1 et 999 Mo. Si les données font grossir le fichier journal au-delà de la taille indiquée, les entrées les plus anciennes (20 %) sont supprimées et de nouvelles données sont ajoutées au fichier.
Format du fichier journal Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Que journaliser, en plus des activités d'analyse ?
  • Paramètres de session : enregistrer les propriétés de chaque session d'analyse dans le fichier journal.
  • Récapitulatif de session : enregistrer un récapitulatif des actions de l'analyseur pendant chaque session d'analyse dans le fichier journal. Les informations du récapitulatif incluent le nombre de fichiers analysés, le nombre et le type de détections, le nombre de fichiers nettoyés ou supprimés, ainsi que d'autres données.
  • Impossible d'analyser les fichiers cryptés : enregistrer le nom des fichiers chiffrés dont l'analyse est impossible.
Tâches associées
Configuration des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Eléments à analyser

Définition des options

Configurez les options de détection. Si vous configurez différentes stratégies d'analyse pour les processus par défaut, à faible risque et à haut risque, les options de cet onglet doivent être configurées pour chaque type de processus.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Analyser les fichiers
  • Lors de l'écriture sur un disque : tous les fichiers sont analysés lorsqu'ils sont écrits ou modifiés sur l'ordinateur ou sur tout autre périphérique de stockage de données.
    ATTENTION :
    si vous n'activez pas l'option Lors de l'écriture sur un disque, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).

    Si vous copiez ou déplacez des fichiers d'un ordinateur vers un autre, il est important que tous les ordinateurs soient configurés de la même manière pour qu'un fichier avec une menace potentielle ne puisse pas être copié à partir d'un ordinateur ou écrit sur un ordinateur.

  • Lors de la lecture à partir d'un disque : tous les fichiers sont analysés lorsqu'ils sont lus à partir de l'ordinateur ou de tout autre périphérique de stockage de données.
    ATTENTION :
    si vous n'activez pas l'option Lors de la lecture à partir d'un disque, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Sur les lecteurs réseau : les ressources sur les lecteurs réseau mappés sont analysées.

    L'analyse des ressources réseau peut affecter les performances.

  • Ouvert pour sauvegarde : les fichiers ouverts pour des opérations de sauvegarde sont examinés.
Types de fichier à analyser
  • Tous les fichiers : analyser tous les fichiers, quelle que soit l'extension.
    ATTENTION :
    si vous n'activez pas Tous les fichiers, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Fichiers par défaut + types supplémentaires : analyser la liste d'extensions par défaut et tous les ajouts indiqués. La liste par défaut est définie par le fichier DAT actuel.

    Rechercher également les macros dans tous les fichiers : si vous avez sélectionné cette option, vous pouvez également rechercher les menaces de macro connues dans tous les fichiers.

  • Types de fichier spécifiés uniquement : créer une liste spécifiée par l'utilisateur d'extensions de fichiers à analyser. Vous pouvez également supprimer toute extension ajoutée précédemment.

    Sélectionnez cette option, puis entrez les extensions de fichier dans la zone de texte, séparées par des espaces.

Artemis (recherche réseau heuristique de fichiers suspects)
  • Détecter les menaces de programmes inconnus et les chevaux de Troie : utiliser l'analyse Artemis pour détecter les fichiers exécutables ayant un code proche de celui de programmes malveillants (malwares).
  • Détecter les menaces de macro inconnues : utiliser l'analyse Artemis pour détecter les virus de macro inconnus.
ATTENTION :
si vous n'activez pas Artemis, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
Fichiers compressés
  • Analyser à l'intérieur des archives : examiner les fichiers d'archive (compressés) et leur contenu.
  • Décoder les fichiers MIME : détecter, décoder et analyser les fichiers MIME (Multipurpose Internet Mail Extensions).
Remarque : bien qu'elle apporte une meilleure protection, l'analyse des fichiers compressés peut augmenter la durée d'une analyse.
Détection de programmes indésirables
  • Détecter les programmes indésirables : active l'analyse à l'accès pour détecter les programmes potentiellement indésirables.

    L'analyseur utilise les informations configurées dans la Stratégie contre les programmes indésirables pour procéder à cette détection.

    Consultez la section Restriction de programmes potentiellement indésirables pour plus d'informations.

Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Actions

Définition des options

Configurer les actions à effectuer lorsqu'une menace ou un programme potentiellement indésirable est détecté.

Option Définition
Si une menace est détectée Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit effectuer lorsqu'il détecte une menace. Valeur par défaut = Nettoyer les fichiers.
  • Nettoyer les fichiers : l'analyseur tente de supprimer la menace du fichier détecté.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'un fichier contenant une menace potentielle est détecté.
  • Supprimer automatiquement les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Supprimer les fichiers.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'un fichier contenant une menace potentielle est détecté.
  • Supprimer les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
Si un programme indésirable est détecté Effectuer d'abord cette action : sélectionner la première action que l'analyseur doit effectuer lorsqu'il détecte une menace. Valeur par défaut = Nettoyer les fichiers.
  • Nettoyer les fichiers : l'analyseur tente de supprimer la menace du fichier détecté.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'un fichier contenant une menace potentielle est détecté.
  • Supprimer les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
En cas d'échec de la première action, effectuer l'action suivante : sélectionner l'action à effectuer par l'analyseur en cas d'échec de la première action. Valeur par défaut = Supprimer les fichiers.
  • Poursuivre l'analyse : l'analyse se poursuit lorsqu'un fichier contenant une menace potentielle est détecté.
  • Supprimer les fichiers : l'analyseur supprime les fichiers contenant une menace potentielle dès leur détection.
Référence associée
Options de l'onglet Paramètres des processus
Informations associées
Analyse d'éléments à l'accès


Onglet Exclusions

Définition des options

Spécifier les éléments à exclure de l'analyse.

Option Définition
Eléments à exclure Sélectionner le type d'exclusion dans la liste déroulante, puis indiquer les détails de l'exclusion :
  • Exclure par nom/emplacement de fichier : entrer le nom et l'emplacement du fichier dans la zone de texte. Sélectionner Exclure également les sous-dossiers si nécessaire.
    Remarque : vous devez ajouter une barre oblique inverse (\) à la fin de la chaîne pour que cela s'applique à un dossier. Sinon, cela est considéré comme une exclusion de fichier et la case à cocher Exclure également les sous-dossiers est désactivée par défaut.
  • Exclure par type de fichier : entrer le type de fichier dans la zone de texte.
  • Exclure par âge de fichier : sélectionner le type d'accès, puis indiquer l'âge minimum en jours.

Consultez la section Ajout et exclusion d'éléments à analyser pour plus informations.

Conditions d'exclusion Choisir les conditions dans lesquelles exclure l'élément sélectionné :
  • Lors de la lecture
  • Lors de l'écriture
Gestion des exclusions client Remplacer les exclusions client : exclure uniquement les éléments spécifiés dans cette stratégie. Si cette option n'est pas sélectionnée, l'ordinateur client utilise les exclusions définies localement et les exclusions définies dans cette stratégie.
Remarque :

Cette option est configurée uniquement par l'intermédiaire d'ePolicy Orchestrator.

Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Performances

Définition des options

Définissez les options de différé d'analyse et d'utilisation du système pour améliorer les performances.

Option Définition
Options de différé de l'analyse Sélectionnez l'option de différé de l'analyse :
  • Différer l'analyse en cas d'alimentation par batterie : différer l'analyse lorsque le système est en cours d'utilisation et fonctionne sur batterie.
  • Différer les analyses pendant les présentations : différer l'analyse lorsque le système est en mode présentation.
  • L'utilisateur peut différer les analyses planifiées : autoriser l'utilisateur à différer des analyses planifiées.

  • Différer au plus : indiquer le délai de différé de l'analyse. Sélectionner une valeur comprise entre 1 et 24 heures ou une valeur nulle pour un différé indéfini de l'analyse.

Consultez la section Fonctionnement de l'option de différé d'analyse pour plus d'informations.

Utilisation du système Utiliser la liste d'ePolicy Orchestrator ou le curseur de la Console VirusScan pour définir la planification de l'utilisation pour l'analyse. Chaque tâche s'exécute de manière indépendante, sans connaître les limites des autres tâches. Les incréments sont les suivants :
  • Faible
  • Sous la normale : la valeur par défaut d'ePolicy Orchestrator.
  • Normal : la valeur par défaut de VirusScan Enterprise 8.8.
Artemis (recherche réseau heuristique de fichiers suspects)
Configurer le niveau de sensibilité à utiliser pour déterminer si un échantillon détecté est un logiciel malveillant (malware). Pour tous les niveaux autres que Désactivé, des empreintes d'échantillons, obtenues par hachage, sont envoyées à McAfee Labs pour déterminer s'il s'agit de logiciels malveillants (malwares). L'avantage pour vous est que cette détection peut être mise à disposition dès que McAfee Labs publie la mise à jour, sans que vous ayez à attendre la version de fichier DAT suivante. Plus le niveau de sensibilité est élevé, plus le nombre de détections de logiciels malveillants (malwares) augmente. Toutefois, l'augmentation du nombre de détections peut engendrer une progression des détections de faux positifs. Choisissez l'un des niveaux de sensibilité suivants :

  • Désactivé : aucune empreinte ni aucune donnée n'est envoyée à McAfee Labs afin d'en déterminer la nature.

  • Très faible : les détections et le risque de faux positifs sont du même niveau qu'avec les fichiers DAT standard. Une détection est mise à la disposition de VirusScan Enterprise si elle est publiée par McAfee Labs sans attendre la prochaine mise à jour de fichier DAT.

  • Faible : ce niveau se situe entre les niveaux Très faible et Moyen.

  • Moyen : utilisez ce niveau lorsque le risque standard d'exposition à des logiciels malveillants (malwares) est supérieur au risque de faux positif. La recherche heuristique interne exclusive de McAfee Labs génère des détections qui sont susceptibles de correspondre à des logiciels malveillants (malwares). Il y a cependant un risque qu'une détection portant sur un fichier rarement rencontré engendre la détection d'un faux positif. McAfee Labs vérifie que les détections avec ce paramètre ne généreront pas de faux positifs avec des applications couramment utilisées et des fichiers de système d'exploitation.

  • Élevé : ce niveau se situe entre les niveaux Moyen et Très élevé.

  • Très élevée : nous recommandons d'utiliser ce niveau uniquement pour les e-mails et pour l'analyse de volumes et de répertoires qui ne sont associés ni à l'exécution de programmes ni à des systèmes d'exploitation. Les détections de ce niveau sont supposées correspondre à des logiciels malveillants, mais n'ont pas été entièrement testées pour vérifier qu'il ne s'agissait pas de faux positifs.

Concepts associés
Fonctionnement de l'utilisation du système
Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Rapports

Définition des options

Activez la journalisation pour suivre les activités sur votre réseau et enregistrer les paramètres utilisés pour détecter et traiter une menace potentielle découverte par l'analyseur.

Option | Définition
Consigner dans le fichier | Activer la journalisation des activités.
Emplacement du fichier journal Accepter l'emplacement par défaut du fichier journal ou indiquer un nouvel emplacement.

Le nom du journal par défaut est OnDemandScanLog.txt.

L'emplacement par défaut est le suivant : <lecteur>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\.

L'emplacement par défaut peut varier en fonction du système d'exploitation que vous utilisez.
Taille du fichier journal | Limiter la taille du fichier journal. Accepter la taille par défaut (1 Mo) ou définir une taille comprise entre 1 et 999 Mo. Si les données font grossir le fichier journal au-delà de la taille indiquée, les entrées les plus anciennes (20 %) sont supprimées et de nouvelles données sont ajoutées au fichier.
Format du fichier journal Sélectionner le format du journal. Format par défaut = Unicode (UTF8).
  • Unicode (UTF8) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • Unicode (UTF16) : recommandé si vous stockez des caractères asiatiques (chaque caractère correspond à un ou deux octets) ou si vous partagez des informations au sein d'une organisation multinationale.
  • ANSI : recommandé si vous stockez des caractères occidentaux (chaque caractère correspond à un octet).
Que journaliser, en plus des activités d'analyse ?
  • Paramètres de session : enregistrer les propriétés de chaque session d'analyse dans le fichier journal.
  • Récapitulatif de session : enregistrer un récapitulatif des actions de l'analyseur pendant chaque session d'analyse dans le fichier journal. Les informations du récapitulatif incluent le nombre de fichiers analysés, le nombre et le type de détections, le nombre de fichiers nettoyés ou supprimés, ainsi que d'autres données.
  • Impossible d'analyser les fichiers cryptés : enregistrer le nom des fichiers chiffrés dont l'analyse est impossible.
Alerter lorsqu'un cookie est détecté

Alerter lorsqu'un cookie est détecté : envoyer des alertes lorsque des cookies sont détectés. Cela inclut la génération d'alertes ePolicy Orchestrator et de notifications de détections, l'enregistrement des détections dans le journal d'activité si vous avez activé la journalisation des activités dans l'onglet Rapports et le décompte des détections dans les statistiques d'analyse. Si vous désélectionnez cette option, ePolicy Orchestrator ne génère pas d'alertes, mais les détections sont toujours enregistrées dans le journal d'activité si vous avez activé la journalisation des activités dans l'onglet Rapports et sont décomptées dans les statistiques d'analyse.
Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Eléments à analyser

Définition des options

Configurez les options de détection.

Option Définition
Types de fichier à analyser
  • Tous les fichiers : analyser tous les fichiers, quelle que soit l'extension.
  • Fichiers par défaut + types supplémentaires : analyser la liste d'extensions par défaut et tous les ajouts indiqués. La liste par défaut est définie par le fichier DAT actuel.

    Sélectionnez cette option, puis entrez les extensions de fichier dans la zone de texte, séparées par des espaces.

    Rechercher également les macros dans tous les fichiers : si vous avez sélectionné Fichiers par défaut + types supplémentaires, vous pouvez également rechercher les menaces de macro connues dans tous les fichiers.

  • Types de fichier spécifiés : créer une liste spécifiée par l'utilisateur d'extensions de fichiers à analyser. Vous pouvez également supprimer toute extension ajoutée précédemment.

    Sélectionnez cette option, puis entrez les extensions de fichier dans la zone de texte, séparées par des espaces.

Options
  • Détecter les programmes indésirables : active l'analyse à l'accès pour détecter les programmes potentiellement indésirables.

    L'analyseur utilise les informations configurées dans la Stratégie contre les programmes indésirables pour procéder à cette détection.

    Consultez la section Restriction de programmes potentiellement indésirables pour plus d'informations.

  • Décoder les fichiers MIME : détecter, décoder et analyser les fichiers MIME (Multipurpose Internet Mail Extensions).
  • Analyser à l'intérieur des archives : examiner les fichiers d'archive (compressés) et leur contenu.
Bien qu'elle apporte une meilleure protection, l'analyse des fichiers compressés peut augmenter la durée d'une analyse.

  • Analyser les fichiers migrés vers une zone de stockage : analyser les fichiers en cache stockés dans le Stockage étendu.

    Consultez la section Fonctionnement de l'analyse du stockage étendu pour plus d'informations.

Artemis (recherche réseau heuristique de fichiers suspects)
  • Détecter les menaces de programme inconnues : utiliser l'analyse Artemis pour détecter les fichiers exécutables ayant un code proche de celui de programmes malveillants (malwares).
  • Détecter les menaces de macro inconnues : utiliser l'analyse Artemis pour détecter les virus de macro inconnus.
Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Tâche

Définition des options

Spécifiez les plates-formes sur lesquelles cette tâche à la demande doit être exécutée.

Option Définition
Plates-formes sur lesquelles cette tâche sera exécutée
  • Exécuter cette tâche sur les serveurs : effectuer cette tâche d'analyse à la demande sur les serveurs.
  • Exécuter cette tâche sur les postes de travail : effectuer cette tâche d'analyse à la demande sur les postes de travail.
Compte d'utilisateur à utiliser lors de l'exécution de la tâche
  • Nom d'utilisateur : spécifier le nom de compte de l'utilisateur. Si aucune information de compte n'est saisie, la tâche s'exécute sous le compte système.
  • Mot de passe : entrer le mot de passe.
  • Domaine : entrer le domaine.
Remarque :

Vous devez disposer de droits d'administration pour planifier la tâche. Les droits d'administration offrent à l'utilisateur un accès en écriture à la clé de Registre des tâches planifiées. Pour plus d'informations sur la planification des tâches client, consultez la documentation d'ePolicy Orchestrator.

Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à la demande


Onglet Options de mot de passe

Définition des options

Définissez la sécurité par mot de passe pour tout le système ou pour des éléments sélectionnés. Consultez la section Incidence de la définition d'un mot de passe sur les utilisateurs pour plus d'informations.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Mot de passe de l'interface utilisateur Spécifier la sécurité de l'interface utilisateur :
  • Aucun mot de passe :aucun mot de passe n'est requis pour accéder aux paramètres de configuration.
  • Protection par mot de passe de tous les éléments répertoriés : indiquer un seul mot de passe pour tous les éléments de la liste.
  • Protection par mot de passe des éléments sélectionnés : indiquer un seul mot de passe pour tous les éléments sélectionnés dans la liste.
  • Protection par mot de passe pour la conformité des critères communs : sécuriser l'interface des administrations devant utiliser uniquement des produits de sécurité validés, répondant aux critères communs NIAP (National Information Assurance Partnership).

    Toutes les options de configuration sont sécurisées vis-à-vis des utilisateurs dépourvus d'informations d'identification d'administration ; toutefois, les utilisateurs de postes de travail peuvent effectuer une analyse immédiate de leur poste de travail, à la demande. Inclure ou exclure des fichiers d'une analyse à la demande immédiate. Inclure ou exclure des archives, comme un fichier .ZIP, d'une analyse à la demande immédiate. Afficher les journaux d'activité des analyses à l'accès et à la demande.

Mot de passe : entrer le mot de passe.

Confirmer le mot de passe : entrer à nouveau le mot de passe pour le confirmer.
Eléments de l'interface utilisateur à protéger par un mot de passe Sélectionnez les éléments que vous souhaitez protéger par le mot de passe.
  • Tout sélectionner : sélectionner tous les éléments de la liste.
  • Tout désélectionner : désélectionner tous les éléments de la liste.

Les administrateurs peuvent verrouiller ou déverrouiller l'interface grâce à la Console.

Référence associée
Configuration de la planification de tâche
Informations associées
Contrôle de l'accès à l'interface utilisateur


Onglet Stratégie

Définition des options

Configurez l'emplacement de la quarantaine et la durée de conservation des éléments mis en quarantaine.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Répertoire de quarantaine | Accepter l'emplacement par défaut du répertoire de quarantaine ou indiquer un nouvel emplacement. Emplacement par défaut = <LECTEUR_SYSTÈME>\Quarantine.
Rétention des données mises en quarantaine
  • Supprimer automatiquement les données mises en quarantaine : supprimer les éléments mis en quarantaine une fois que le nombre de jours indiqué est écoulé.
  • Nombre de jours de conservation des données sauvegardées dans le répertoire de quarantaine : spécifier le nombre de jours de conservation des éléments mis en quarantaine avant leur suppression automatique. Choisissez une valeur comprise entre 1 et 999 jours.
Tâches associées
Configuration de la stratégie de quarantaine


Onglet Paramètres proxy

Les serveurs proxy sont utilisés comme éléments de la sécurité Internet pour masquer les ordinateurs des utilisateurs d'Internet sur la toile et pour améliorer la vitesse d'accès en mettant en mémoire cache les sites régulièrement visités.

Si votre réseau utilise un serveur proxy, vous pouvez spécifier les paramètres de proxy à utiliser, l'adresse du serveur proxy et l'utilisation ou non de l'authentification. Les informations du serveur proxy sont stockées dans la liste de référentiels AutoUpdate (sitelist.xml). Les paramètres de proxy configurés ici s'appliquent à tous les référentiels de la liste.

Remarque :

Cette fonction n'est pas disponible à partie de la console ePolicy Orchestrator. Pour y accéder, utilisez la Console VirusScan Enterprise 8.8.

Définition des options

Option Définition
Ne pas utiliser de proxy

Ne spécifier aucun serveur proxy.

Utiliser les paramètres proxy Internet Explorer

Utiliser les paramètres de proxy de la version actuellement installée d'Internet Explorer.

Valeur par défaut = Utiliser les paramètres proxy Internet Explorer.

Configurer manuellement les paramètres proxy

Configurer les paramètres de proxy en fonction de vos besoins.

Exceptions

Disponible uniquement si vous avez sélectionné l'option Configurer manuellement les paramètres proxy.

Indiquer les exceptions de proxy. Cliquer sur Exceptions pour ouvrir la boîte de dialogue Exceptions de proxy :
  • Spécifier des exceptions : sélectionner cette option pour entrer des exceptions de proxy.
  • Utiliser des points-virgules (;) pour séparer les entrées. Exemple : interne1;interne2
HTTP

Entrer l'adresse du serveur proxy HTTP.

FTP

Entrer l'adresse du serveur proxy FTP.

Port

Entrer le numéro de port du serveur proxy HTTP ou FTP.

Utiliser l'authentification pour HTTP

Utiliser les informations d'identification de sécurité permettant d'accéder au proxy HTTP.

Nom d'utilisateur HTTP

Entrer le nom d'utilisateur HTTP.

Mot de passe HTTP

Entrer le mot de passe HTTP.

Concepts associés
Fonctionnement du référentiel AutoUpdate
Référence associée
Configuration de la liste de référentiels


Onglet Eléments à analyser

Définition des options

Sélectionnez les catégories de programmes potentiellement indésirables à détecter et créez des exclusions pour les programmes que vous ne souhaitez pas détecter.

Option | Définition
Paramètres pour | Sélectionner Poste de travail ou Serveur dans la liste déroulante. Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Sélectionner les catégories de programmes indésirables à détecter | Spécifier les catégories de programmes potentiellement indésirables à détecter.
Exclusions des programmes indésirables | Spécifier les exclusions par nom de détection. Ajouter et supprimer des éléments si nécessaire.
Tâches associées
Configuration relative aux programmes indésirables
Informations associées
../../pgrestrictingunwantedprogram_chapter.ditamap


Onglet Stratégie de quarantaine

Définition des options

Configurez l'emplacement de la quarantaine et la durée de conservation des éléments mis en quarantaine.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Répertoire de quarantaine | Accepter l'emplacement par défaut du répertoire de quarantaine ou indiquer un nouvel emplacement. Emplacement par défaut = <LECTEUR_SYSTÈME>\Quarantine.
Rétention des données mises en quarantaine
  • Supprimer automatiquement les données mises en quarantaine : supprimer les éléments mis en quarantaine une fois que le nombre de jours indiqué est écoulé.
  • Nombre de jours de conservation des données sauvegardées dans le répertoire de quarantaine : spécifier le nombre de jours de conservation des éléments mis en quarantaine avant leur suppression automatique. Choisissez une valeur comprise entre 1 et 999 jours.
Tâches associées
Configuration de la stratégie de quarantaine


Ajout et modification de référentiels

Ajoutez des référentiels ou modifiez ceux qui existent.

Définition des options

Option Définition
Description du référentiel

Spécifier le nom du référentiel.
Récupérer les fichiers à partir de
Sélectionner l'emplacement à partir duquel les fichiers doivent être récupérés. Valeur par défaut = référentiel HTTP.
  • Référentiel HTTP : récupérer les fichiers à partir de l'emplacement de référentiel HTTP que vous indiquez.
    Remarque : un site HTTP, comme un site FTP, permet une mise à jour indépendante de la sécurité du réseau, mais il prend en charge des niveaux plus élevés de connexions simultanées qu'un site FTP.
  • Référentiel FTP : récupérer les fichiers à partir de l'emplacement de référentiel FTP que vous indiquez.
    Remarque : un site FTP donne de la flexibilité aux opérations de mise à jour qui n'ont pas à adhérer aux autorisations de sécurité du réseau. Le protocole FTP est moins sujet aux attaques de code indésirables que le protocole HTTP, il peut donc offrir une meilleure tolérance.
  • Chemin UNC : récupérer les fichiers à partir de l'emplacement correspondant au chemin UNC que vous indiquez.
    Remarque : le site UNC est le plus rapide et le plus simple à configurer. Les mises à jour UNC interdomaines nécessitent des autorisations de sécurité pour chaque domaine, ce qui implique une configuration plus importante de la mise à jour.
  • Chemin local : récupérer les fichiers à partir de l'emplacement correspondant au chemin local que vous indiquez.
URL
Disponible uniquement si vous avez sélectionné l'option Référentiel HTTP ou Référentiel FTP.
  • HTTP : entrez l'emplacement du serveur HTTP et du dossier où se trouvent les fichiers de mise à jour.
  • FTP : entrez l'emplacement du serveur FTP et du dossier où se trouvent les fichiers de mise à jour.
Chemin d'accès
Disponible uniquement si vous avez sélectionné l'option Chemin UNC ou Chemin local.
  • Chemin UNC : en utilisant la notation UNC (\\nom_serveur\chemin\), entrez le chemin d'accès au référentiel où sont situés les fichiers de mise à jour.
  • Chemin local : entrez le chemin d'accès au dossier local dans lequel vous avez placé les fichiers de mise à jour ou cliquez sur Parcourir pour rechercher le dossier. Le chemin d'accès peut être celui d'un dossier sur un lecteur local ou sur un lecteur réseau.
Port

Disponible uniquement si vous avez sélectionné l'option Référentiel HTTP ou Référentiel FTP. Entrez le numéro de port du serveur HTTP ou FTP que vous avez spécifié.

Utiliser l'authentification

Utiliser une connexion anonyme

Utiliser le compte connecté
Utiliser les informations d'identification spécifiées pour accéder au référentiel.
Remarque :

L'intitulé de cette option varie en fonction de celle sélectionnée dans la section Récupérer les fichiers à partir de.

Les informations d'identification spécifiées sont utilisées par AutoUpdate pour accéder au référentiel et télécharger les fichiers de mise à jour requis. Lorsque vous configurez les références du compte pour l'accès au référentiel, vous vous assurez que ce compte dispose des autorisations de lecture des dossiers contenant les fichiers de mise à jour.
  • Les informations d'identification de téléchargement sont nécessaires pour les référentiels FTP et UNC ; elles sont facultatives pour les référentiels HTTP.
  • Les mises à jour FTP acceptent les connexions anonymes au référentiel.
  • Avec les mises à jour UNC, vous pouvez également utiliser le compte connecté, en vous servant des autorisations de l'utilisateur connecté pour accéder au référentiel.
Nom d'utilisateur

Entrez le nom d'utilisateur.
Mot de passe

Entrez le mot de passe.
Confirmer

Entrez à nouveau le mot de passe pour le confirmer.
Concepts associés
Fonctionnement du référentiel AutoUpdate
Référence associée
Configuration de la liste de référentiels


Onglet Référentiels

Configurez les référentiels dans lesquels vous obtenez des mises à jour.
Remarque :

Cette fonction n'est pas disponible à partir de la console ePolicy Orchestrator. Pour y accéder, utilisez la Console VirusScan Enterprise 8.8.

Définition des options

Option Définition
Description du référentiel

Spécifier le nom du référentiel.

La liste est préconfigurée avec un référentiel HTTP et un référentiel FTP.
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

Le référentiel HTTP est le site de téléchargement par défaut.
Etat

Activé : référentiel défini, pouvant être utilisé pendant le processus AutoUpdate.

Désactivé : référentiel défini auquel vous ne souhaitez pas accéder pendant le processus AutoUpdate. Il peut s'agir d'un référentiel que vous utilisez uniquement occasionnellement.

Remarque : créez autant de sites de référentiels que nécessaire, puis activez-les et désactivez-les.
Ajouter

Ajouter un nouveau référentiel à la liste.
Modifier

Modifier le référentiel sélectionné.
Supprimer

Supprimer le référentiel sélectionné.
Déplacer vers le haut

Déplacer le référentiel sélectionné vers le haut de la liste.
Déplacer vers le bas

Déplacer le référentiel sélectionné vers le bas de la liste.
Concepts associés
Fonctionnement du référentiel AutoUpdate
Référence associée
Configuration de la liste de référentiels


Onglet Gestionnaire

Sélectionnez un élément dans la liste, puis cliquez avec le bouton droit de la souris pour afficher les options avancées. Vous pouvez alors effectuer une nouvelle analyse, rechercher les faux positifs, restaurer, supprimer et afficher les propriétés de chaque élément.

Tâches associées
Configuration de la stratégie de quarantaine


Onglet Tâche

Définition des options

Indiquez des informations de compte pour l'utilisateur ayant accès à l'emplacement de restauration. Si aucun compte n'est saisi ici, la tâche s'exécute sous le compte système.

Option | Définition
Utilisateur | Entrer le nom de l'utilisateur ayant accès à l'emplacement de restauration.
Mot de passe | Entrer un mot de passe pour l'utilisateur spécifié.
Domaine | Entrer un domaine pour l'utilisateur spécifié.
Tâches associées
Configuration de la stratégie de quarantaine


Onglet Emplacements à analyser

Définition des options

Configurez les types d'éléments et les emplacements à analyser.

Option Définition
Emplacements à analyser Sélectionner les emplacements à analyser. Valeur par défaut = Mémoire des rootkits, Processus en cours, Tous les lecteurs locaux, Registre et Cookies. Cliquez sur Ajouter, Modifier ou Supprimer pour modifier le Nom de l'élément.
  • Mémoire des rootkits. Analyse la mémoire système relativement aux rootkits (kits racine) installés, processus masqués et autres comportements suggérant qu'un code malveillant tente de se dissimuler. Cette analyse est exécutée avant toutes les autres.
    ATTENTION :
    si vous n'activez pas l'option Mémoire des rootkits, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Processus en cours. Analyse la mémoire de tous les processus actifs. Les actions autres que Nettoyer sont traitées avec l'option Poursuivre l'analyse.
    ATTENTION :
    si vous n'activez pas l'analyse des Processus en cours, votre système n'est pas protégé contre diverses attaques de logiciels malveillants (malwares).
  • Fichiers enregistrés. Analyse tous les fichiers enregistrés. L'analyseur recherche d'abord les noms de fichiers dans le Registre, puis analyse ces derniers. Il supprime du Registre les références aux fichiers potentiellement indésirables.
  • Poste de travail. Analyse tous les lecteurs physiquement connectés à votre ordinateur ou associés de manière logique à une lettre de lecteur sur votre poste.
  • Tous les lecteurs locaux. Analyse tous les lecteurs et leurs sous-dossiers sur l'ordinateur.
  • Tous les lecteurs fixes. Analyse tous les lecteurs physiquement connectés à l'ordinateur.
  • Tous les lecteurs amovibles. Analyse tous les lecteurs ou autres périphériques de stockage amovibles connectés à l'ordinateur.
  • Tous les lecteurs mappés. Analyse les lecteurs réseau mappés de manière logique à un lecteur réseau sur l'ordinateur.
  • Dossier personnel. Analyse le dossier personnel de l'utilisateur ayant lancé l'analyse.
  • Dossier de profil de l'utilisateur. Analyse le profil de l'utilisateur qui a lancé l'analyse, notamment son dossier Mes documents.
  • Dossier Windows. Analyse le contenu du dossier Windows.
  • Dossier Program Files. Analyse le contenu du dossier Program Files.
  • Dossier Temp. Analyse le contenu du dossier Temp.
  • Corbeille. Analyse le contenu de la corbeille.
  • Lecteur ou dossier. Analyse le lecteur ou dossier spécifié.
  • Fichier. Analyse le fichier spécifié.
  • Cookies. Analyse le dossier des cookies à la recherche de cookies.
  • Registre. Analyse les entrées du Registre.
Remarque : l'utilisation de la liste par défaut des éléments à analyser peut entraîner une analyse complète, qui demande beaucoup de temps. Prévoir de restreindre l'étendue de cette analyse pour une utilisation régulière.
Lorsque la boîte de dialogue Progression de l'analyse à la demande s'affiche, les emplacements à analyser se présentent sous forme de chaîne dont les éléments sont séparés par des virgules, à la suite de Rechercher dans. Une fois les processus d'analyse terminés, ils sont supprimés de la chaîne.
Options d'analyse Type d'analyse pour l'élément sélectionné.
  • Inclure les sous-dossiers : l'analyseur examine tous les sous-dossiers des volumes spécifiés. Désactiver cette case pour analyser uniquement le niveau racine des volumes.
  • Analyser les secteurs d'amorçage : l'analyseur examine le secteur d'amorçage du disque.
Il peut être utile de désactiver l'analyse du secteur d'amorçage lorsqu'un disque contient un secteur d'amorçage unique ou atypique ne pouvant pas être analysé.
Référence associée
Configuration des onglets des tâches d'analyse à la demande
Informations associées
Analyse d'éléments à l'accès


Options de planification avancées

Configurez les paramètres de planification.

Définition des options

Option | Définition
Date de début | Spécifier la date de lancement de cette tâche.
Date de fin | Spécifier la date de fin de cette tâche.
Répéter la tâche | La tâche est répétée selon la fréquence spécifiée. Si cette option est sélectionnée, spécifier également la fréquence de répétition de cette tâche.
Chaque | Spécifier la fréquence de répétition de cette tâche. Indiquer également si la fréquence est définie en heures ou en minutes.
Heure (local) | Répéter cette tâche à l'heure locale spécifiée. Si cette option est sélectionnée, indiquer également l'heure spécifique.
Durée | Répéter cette tâche aux heures et aux minutes spécifiées. Si cette option est sélectionnée, indiquer également les heures et les minutes.
Heures | Nombre d'heures. Choisir une valeur comprise entre 0 et 99.
Minutes | Nombre de minutes. Choisir une valeur comprise entre 0 et 59.
Concepts associés
Tâches de mise à jour et fonctionnement
Référence associée
Configuration de la tâche AutoUpdate


Onglet Planification

Spécifiez la fréquence planifiée et les autres paramètres de cette tâche.

Définition des options

Option Définition
Exécution

Sélectionner la fréquence d'exécution de cette tâche à partir de ces options :

Quotidiennement : la tâche est exécutée une fois par jour, les jours indiqués.

Les tâches quotidiennes peuvent être exécutées tous les x jours ou tous les jours du lundi au dimanche. Si vous souhaitez uniquement exécuter la tâche certains jours de la semaine, et non tous les jours du lundi au dimanche, il est recommandé d'utiliser une fréquence hebdomadaire.

Hebdomadairement : la tâche est exécutée une fois par jour, les jours et semaines indiqués.

Mensuellement : la tâche est exécutée une fois par jour, les jours et mois indiqués.

Une fois : la tâche est exécutée une fois à la date spécifiée.

Au démarrage : la tâche est exécutée au démarrage du système. Sa fréquence et son différé (en minutes) sont spécifiés.

A l'ouverture de la session : la tâche est exécutée lors de l'ouverture de session. Sa fréquence et son différé (en minutes) sont spécifiés.

En période d'inactivité : la tâche est exécutée lorsque l'ordinateur est inactif ; le temps d'inactivité de l'ordinateur avant l'exécution de la tâche est spécifié (en minutes).

Si la tâche est démarrée et si l'utilisateur se sert de l'ordinateur avant la fin de cette dernière, celle-ci continue à s'exécuter jusqu'à ce qu'elle soit achevée.

Immédiatement : la tâche est exécutée immédiatement.

A la numérotation : la tâche est exécutée à la numérotation.

Heure de début

Sélectionner l'heure de début de la tâche planifiée.

Heure UTC

Heure UTC (Coordinated Universal Time). Sélectionner cette option pour exécuter la tâche en même temps pour tous les fuseaux horaires.

Heure locale

La tâche est exécutée de façon indépendante pour chaque fuseau horaire local.

Remarque : valeur par défaut = Heure locale.
Activer l'exécution aléatoire

La tâche s'exécute à un moment aléatoire dans un intervalle de temps spécifique.

Si vous sélectionnez cette option, spécifiez également les heures et les minutes de l'intervalle de temps maximal.

Remarque :

spécifiez un intervalle de temps compris entre 1 minute (minimum) et 23 heures (maximum). Par exemple, si vous configurez une planification de tâche à 13 heures et un traitement aléatoire de trois heures, la tâche s'exécutera à un moment donné entre 13 heures et 16 heures.

Cette option n'est pas disponible lors de la planification de la tâche Au démarrage, A l'ouverture de la session ou En période d'inactivité.

Heures

Nombre d'heures. Choisissez une valeur comprise entre 0 et 23 heures.

Minutes

Nombre de minutes.

Remarque :
Le nombre de minutes dépend des options sélectionnées. Exemple :
  • Activer l'exécution aléatoire : choisissez entre 0 et 59 minutes.
  • Décaler la tâche manquée de : choisissez une valeur comprise entre 0 et 99 minutes.
Exécuter si la tâche est manquée

Cette option permet d'exécuter les tâches manquées au redémarrage de l'ordinateur. Si l'ordinateur était hors connexion lors de l'exécution planifiée de la tâche, celle-ci risque de ne pas avoir été exécutée.

Remarque : cette fonction garantit que les utilisateurs distants et le réseau sont entièrement protégés s'ils sont hors connexion lors de l'exécution planifiée d'une tâche.
Décaler la tâche manquée de

Sélectionner le différé (en minutes) à appliquer à la tâche manquée. Choisir une valeur comprise entre 0 et 99 minutes.

Tous les jours

Exécuter cette tâche selon la fréquence spécifiée (en jours). Choisir une valeur comprise entre 0 et 9 999 jours.

Remarque : cette option n'est disponible que lors de la planification de la tâche Quotidiennement.
Chaque semaine

Exécuter cette tâche selon la fréquence spécifiée (en semaines). Choisir une valeur comprise entre 0 et 99 semaines.

Si vous sélectionnez cette option, spécifiez également le nombre de semaines et le ou les jours de la semaine.

Remarque :

Pour le jour du mois, choisissez Dimanche, Lundi, Mardi, Mercredi, Jeudi, Vendredi et Samedi.

Cette option n'est disponible que lors de la planification de la tâche Hebdomadairement.

Jour du mois

Exécuter cette tâche un jour spécifique du mois. Choisir une valeur comprise entre 1 et 31 jours.

Si vous sélectionnez cette option, spécifiez également le numéro du jour du mois.

Remarque : cette option n'est disponible que lors de la planification de la tâche Mensuellement.
Jour de semaine du mois

Exécuter cette tâche le jour spécifique du mois.

Si vous sélectionnez cette option, sélectionnez également l'occurrence et le jour du mois.

Remarque :

Pour l'occurrence, sélectionnez l'option Premier, Deuxième, Troisième, Quatrième et Dernier.

Pour le jour du mois, choisissez Dimanche, Lundi, Mardi, Mercredi, Jeudi, Vendredi et Samedi.

Cette option n'est disponible que lors de la planification de la tâche Mensuellement.

Sélectionner les mois

Spécifier les mois d'exécution de cette tâche.

Remarque : cette option n'est disponible que lors de la planification de la tâche Mensuellement.
Exécuter à

Spécifier la date à laquelle cette tâche doit être exécutée.

Remarque : cette option n'est disponible que lors de la planification de la tâche Une fois.
N'exécuter la tâche qu'une fois par jour

Exécuter cette tâche une fois par jour.

Remarque :

Si vous ne sélectionnez pas cette option, la tâche s'exécute à chaque démarrage ou connexion.

Cette option n'est disponible que lors de la planification de la tâche Au démarrage, A l'ouverture de la session ou Exécuter à la numérotation.

Décaler la tâche de

Spécifier le différé de la tâche (en minutes). Choisir une valeur comprise entre 0 et 99.

Remarque :

Ce décalage permet aux utilisateurs d'ouvrir leur session et à la procédure de connexion de s'exécuter.

Cette option n'est disponible que lors de la planification de la tâche Au démarrage ou A l'ouverture de la session.

Si l'ordinateur reste inactif pendant

Spécifier le nombre de minutes pendant lequel l'ordinateur est inactif avant d'exécuter la tâche. Choisir une valeur comprise entre 0 et 999 minutes.

Remarque :

Si la tâche est démarrée et si l'utilisateur se sert de l'ordinateur avant la fin de cette dernière, celle-ci continue à s'exécuter jusqu'à ce qu'elle soit achevée.

Cette option n'est disponible que lors de la planification de la tâche En période d'inactivité.

Avancé

Configurer les options avancées.

Remarque : voir la section Options de planification avancées pour plus d'informations.
Concepts associés
Tâches de mise à jour et fonctionnement
Référence associée
Configuration de la tâche AutoUpdate


Onglet Tâche

Activez la planification de cette tâche et spécifiez les paramètres du compte utilisateur.

Définition des options

Option | Définition
Activer (la tâche planifiée est exécutée à une heure précise) | La tâche est planifiée pour s'exécuter à l'heure indiquée. Remarque : cette option doit être sélectionnée afin de planifier la tâche.
Arrêter la tâche si elle tourne pendant | Arrêter la tâche après le nombre d'heures et de minutes spécifié. Remarque : si la tâche est interrompue avant son achèvement, elle reprend l'analyse au point où elle s'est arrêtée à sa prochaine exécution.
Heures | Nombre d'heures après lequel la tâche s'arrête.
Minutes | Nombre de minutes après lequel la tâche s'arrête.
Utilisateur | Entrer l'ID d'utilisateur sous lequel la tâche s'exécute. Remarque : L'utilisation des informations d'identification est facultative. Si vous n'entrez aucune information d'identification, la tâche planifiée s'exécuter avec le compte système local. Consultez la section Privilèges de connexion pour plus d'informations.
Domaine | Entrer le domaine de l'ID d'utilisateur spécifié.
Mot de passe | Entrer le mot de passe pour l'ID d'utilisateur et le domaine spécifiés.
Concepts associés
Tâches de mise à jour et fonctionnement
Référence associée
Configuration de la tâche AutoUpdate


Onglet ScriptScan

Définition des options

Empêchez l'exécution des scripts indésirables.

Consultez la section Analyse de script et fonctionnement pour plus d'informations.

Option | Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
ScriptScan | Activer l'analyse des scripts : analyser les scripts JavaScript et VBScript avant leur exécution.
Exclusions des processus ScriptScan | Processus : indiquer les exclusions de ScriptScan par nom de processus. Les caractères génériques ne sont pas autorisés pour indiquer des noms de processus.
Exclusions d'URL ScriptScan URL : indiquer les exclusions d'URL ScriptScan par URL. Notez ce qui suit :
  • Les caractères génériques sont autorisés pour spécifier les URL. Mais si l'URL msn.com est exclue par exemple, toute URL contenant cette chaîne est exclue de l'analyse. Voici des exemples d'URL exclues :
    • http://weather.msn.com
    • http://music.msn.com
  • Sous Windows Server 2008, les exclusions d'URL ScriptScan ne fonctionnent pas avec Windows Internet Explorer à moins que la case Activer les extensions tierce partie du navigateur soit sélectionnée pour activer le paramètre et que Windows Server 2008 soit redémarré. Pour en savoir plus, consultez l'article https://kc.mcafee.com/corporate/index?page=content&id=KB69526.
Tâches associées
Configuration des paramètres généraux
Informations associées
Analyse d'éléments à l'accès


Onglet Détection définie par l'utilisateur

Définition des options

Spécifiez les fichiers ou programmes individuels à traiter comme des programmes indésirables.

Option Définition
Paramètres pour Sélectionner Poste de travail ou Serveur dans la liste déroulante.
Remarque : cette option est disponible uniquement par l'intermédiaire d'ePolicy Orchestrator.
Eléments définis par l'utilisateur
  • Nom de fichier : indiquer le nom du fichier ou du programme à détecter.

  • Description : indiquer la description à afficher dans la notification lors de la détection du fichier spécifié.

Remarque : l'analyseur ne détectera pas un programme indésirable défini par l'utilisateur si sa taille est de zéro octet.
Tâches associées
Configuration des paramètres généraux
Informations associées
Analyse d'éléments à l'accès