Prefazione

Per utilizzare questo documento in maniera efficace, è necessario comprendere quali sono i destinatari, le convenzioni utilizzate, i contenuti e come reperire altra documentazione di riferimento.

Sommario

  • Pubblico di riferimento
  • Convenzioni
  • Come è organizzata questa guida
  • Reperimento della documentazione del prodotto


Pubblico di riferimento

La documentazione McAfee viene studiata e redatta con cura per il pubblico di riferimento.

Le informazioni presenti nella guida sono rivolte principalmente ai seguenti destinatari:
  • Amministratori: persone che implementano e applicano il programma di sicurezza della società.
  • Utenti — Persone responsabili della configurazione delle opzioni del prodotto o dell'aggiornamento del prodotto sui rispettivi sistemi.


Convenzioni

Nella presente guida sono adoperate le seguenti convenzioni tipografiche.
Titolo del libro o Enfasi | Titolo di un libro, capitolo o argomento; introduzione di un nuovo termine; enfasi.
Grassetto | Testo fortemente enfatizzato.
Input utente o Percorso | Comandi e altro testo immesso dall'utente; percorso di una cartella o programma.
Codice | Esempio di codice.
Interfaccia utente | Termini nell'interfaccia utente, tra cui opzioni, menu, pulsanti e finestre di dialogo.
Collegamento ipertestuale di colore blu | Collegamento attivo a un argomento o a un sito Web.
Nota | Informazioni aggiuntive, ad esempio un metodo alternativo di accesso a un'opzione.
Suggerimento | Suggerimenti e raccomandazioni.
Importante/Attenzione | Avvertenza importante per proteggere un sistema, un'installazione software, una rete, un'azienda o dati.
Avviso | Avvertenza critica per prevenire lesioni personali durante l'utilizzo di un prodotto hardware.


Come è organizzata questa guida

Questo documento costituisce un riferimento da utilizzare insieme alle interfacce utente di Console di VirusScan e di ePolicy Orchestrator. Descrive inoltre, nell'ordine, come iniziare a proteggere il sistema dai malware utilizzando VirusScan Enterprise. Per descrivere questo processo, questo documento è suddiviso in quattro parti principali, più un appendice:
  • Parte I -- Prevenzione: Come evitare le minacce —Il modo migliore per proteggere il sistema è quello di impedire ai malware di accedere al sistema. Questa parte del documento descrive quanto segue:
    • Protezione dei punti di accesso del sistema, errori di overflow della memoria e programmi indesiderati.
    • Le definizioni dei rilevamenti e la relativa modalità di utilizzo per la protezione del sistema, nonché l'importanza dell'aggiornamento di tali definizioni in maniera regolare.
    • Esclusione dalla scansione di file, cartelle e dischi.
    • Utilizzo di attività pianificate per la scansione periodica del sistema e l'aggiornamento dei file utilizzati da VirusScan Enterprise.
  • Parte II — Rilevamento: Rilevamento delle minacce — I file aperti o copiati da altri file system o da Internet potrebbero favorire l'accesso al sistema. Inoltre, le chiamate e gli script API (Application Programming Interface) potrebbero introdurre una minaccia nel sistema. Tali minacce vengono rilevate durante i seguenti processi di scansione VirusScan Enterprise:
    • Scansione all'accesso — Esegue la scansione di un file per individuare un potenziale malware quando il file viene letto o scritto sul disco, protegge i settori di avvio, esegue la scansione della memoria di processi già in esecuzione, rileva i cookie e protegge dai programmi indesiderati.
    • Scansione su richiesta — Esegue la scansione dell'intero sistema per la ricerca di minacce, in base a una pianificazione oppure quando necessario quando ne viene eseguito l'avvio da Console di VirusScan.
    • Scansione e-mail alla consegna e su richiesta — Protegge dai malware che arrivano attraverso la posta elettronica in Microsoft Outlook e Lotus Notes.
    • Protezione dall'overflow del buffer — Analizza le chiamate API effettuate da alcuni processi, per verificare che non tentino di sovrascrivere i dati adiacenti nel buffer di memoria.
    • ScriptScan — Individua le minacce dai browser o da altre applicazioni a cui si accede e che utilizzano Windows Script Host.
  • Parte III -- Risposte: Gestione delle minacce —VirusScan Enterprise può essere configurato per l'esecuzione dei seguenti passi, quando viene rilevata una minaccia:
    • Negare l'accesso alla minaccia o non intraprendere ulteriori azioni.
    • Eliminare o pulire la minaccia. Quando si effettua una di queste azioni, viene memorizzata una copia del file originale nella cartella Quarantena.
    Nota: Per qualsiasi rilevamento, è possibile configurare VirusScan Enterprise per inviare o meno una notifica all'utente.
  • Parte IV — Monitoraggio, analisi e ottimizzazione della protezione — Una volta attivata la protezione, è necessario controllare il sistema utilizzando query e segnalazioni di ePolicy Orchestrator. Quindi è possibile decidere di apportare modifiche alle impostazioni di sicurezza al fine di aumentare o ridurre la protezione del sistema. In alternativa, è anche possibile utilizzare i registri di Console di VirusScan e i trap SNMP (Network Management Protocol) per monitorare i sistemi.
  • Appendice —Descrive ulteriori funzioni che occorre conoscere quando si utilizza VirusScan Enterprise. Ad esempio, le opzioni della riga di comando di VirusScan Enterprise, la connessione ai sistemi remoti mediante VirusScan Enterprise e altro.


Reperimento della documentazione del prodotto

McAfee fornisce le informazioni necessarie durante ciascuna fase dell'implementazione del prodotto, dall'installazione all'utilizzo e alla risoluzione dei problemi. Dopo il rilascio di un prodotto, le relative informazioni vengono immesse nella KnowledgeBase online di McAfee.
  1. Consultare il sito di assistenza tecnica McAfee Technical Support ServicePortal all'indirizzo http://mysupport.mcafee.com.
  2. Nella sezione Self Service, accedere al tipo di informazioni desiderate:
    Per accedere a... compiere le seguenti operazioni
    Documentazione utente

    1. Fare clic su Documentazione del prodotto.

    2. Selezionare un Prodotto, quindi scegliere una Versione.

    3. Selezionare un documento del prodotto.

    KnowledgeBase
    • Fare clic sul pulsante di ricerca nella KnowledgeBase per risposte ai quesiti relativi ai prodotti.
    • Fare clic sul pulsante di esplorazione della KnowledgeBase per consultare gli articoli elencati per prodotto e versione.


Guida introduttiva

Spiegazione dei componenti di McAfee® Il software VirusScan® Enterprise 8.8 e l'ordine che occorre utilizzare per configurare il software, aiuta a proteggere il sistema dalle minacce.

Sommario

  • Introduzione a VirusScan Enterprise
  • Componenti e relativa interazione
  • Importanza della creazione di una strategia di sicurezza
  • Console di VirusScan e modalità di accesso
  • Operazioni preliminari


Introduzione a VirusScan Enterprise

Non appena si installa il software VirusScan Enterprise, il sistema inizia immediatamente a essere protetto dalle minacce. È possibile aumentare la protezione se si comprende il modo in cui il software agisce, le nuove funzioni presenti in questa versione e i componenti principali.

Funzioni

VirusScan Enterprise offre una protezione facilmente scalabile, prestazioni veloci e un'architettura mobile per proteggere il sistema da:

  • Virus, worm e cavalli di Troia
  • Violazioni dei punti di accesso ed exploit da overflow del buffer
  • Codice e programmi potenzialmente indesiderati

Se vengono rilevate minacce, il prodotto esegue le azioni configurate per proteggere l'ambiente di lavoro.

È possibile configurare il software come prodotto standalone oppure è possibile utilizzare McAfee® Software ePolicy Orchestrator® versione 4.0 e successive per applicare e gestire centralmente i criteri di VirusScan Enterprise, quindi utilizzare le query e le dashboard per tenere traccia dei rapporti e dei rilevamenti.

Nota: Questo documento riguarda l'utilizzo di ePolicy Orchestrator 4.0, 4.5 e 4.6. Per informazioni sull'utilizzo di ePolicy Orchestrator, consultare la documentazione specifica della versione del prodotto.

Novità

Questa versione include le nuove funzioni seguenti:
  • Prestazioni migliorate.
  • Consente a ePolicy Orchestrator 4.5 e 4.6 di gestire i sistemiVirusScan Enterprise.
  • Una nuova funzione di esclusione degli URL per ScriptScan consente di configurare le esclusioni anziché gestire manualmente la modifica del registro.
  • AntiSpyware Enterprise Module è stato completamente integrato nel software VirusScan Enterprise 8.8.
  • Supporto per la scansione dell'e-mail di Outlook 2010.
  • Supporto per la scansione dell'e-mail di Lotus Notes 8.0x fino alle versioni 8.5.1


Componenti e relativa interazione

Amministratori e utenti di VirusScan Enterprise dovrebbero avere una certa dimestichezza con componenti e connessioni. La figura seguente illustra i componenti di un ambiente base.

Figura 1. Componenti di VirusScan Enterprise

Sistema client

Sistema in cui VirusScan Enterprise e McAfee Agent opzionale vengono installati e configurati.
  • File DAT: file di definizione dei rilevamenti, noti anche come "firme malware", che interagiscono con il motore di scansione per identificare le minacce e applicare le contromisure.
  • Motore di scansione: utilizzato per eseguire la scansione di file, cartelle e dischi sul computer client e confrontarli con le informazioni contenute nei file DAT relative ai virus conosciuti.
    Nota: I file DAT e il motore di scansione vengono aggiornati quando necessario mediante connessione Internet ai McAfee Headquarters oppure attraverso connessioni Intranet opzionali aziendali a un determinato server.
  • Artemis (verifica euristica in rete per il rilevamento di file sospetti): esegue la ricerca di programmi sospetti e di DLL in esecuzione sui sistemi client protetti da VirusScan Enterprise. Quando la protezione in tempo reale contro il malware rileva un programma sospetto, viene inviata una richiesta DNS contenente un'impronta del file sospetto a un server database centrale ubicato presso i McAfee Labs.
  • McAfee Agent (facoltativo): garantisce la sicurezza delle comunicazioni tra i prodotti gestiti da McAfee e il server McAfee ePolicy Orchestrator. L'agent fornisce anche servizi locali, come l'aggiornamento, la registrazione delle attività, la generazione di rapporti su eventi e proprietà, la pianificazione di attività, le comunicazioni e la memorizzazione di policy.

McAfee Headquarters

McAfee Headquarters, sede di McAfee Labs e dell'Assistenza tecnicaMcAfee, fornisce i seguenti servizi VirusScan Enterprise:
  • Aggiornamenti DAT: memorizzati su un server di database centrale McAfee, scaricabili grazie a AutoUpdate, i file di aggiornamento DAT vengono copiati sui client VirusScan Enterprise o negli archivi DAT facoltativi per fornire in tempo reale le informazioni contro le minacce e i nuovi elenchi di virus noti appena vengono scoperti.
  • Aggiornamenti del motore di scansione: memorizzati su un server di database centrale, vengono scaricati quando necessario per mantenere il motore di scansione di VirusScan Enterprise sempre aggiornato.
  • McAfee Labs: libreria delle minacce contenente informazioni dettagliate su virus, trojan, hoax e programmi potenzialmente indesiderati (PUP, Potentially Unwanted Program). Contiene informazioni sulla loro provenienza, sul modo in cui infettano il sistema e su come gestirli. La funzionalità Artemis invia l'impronta del file sospetto ai McAfee Labs, dove il file viene analizzato e vengono stabilite le contromisure da prendere.

Server

Il server opzionale utilizza i seguenti componenti per gestire e aggiornare molti sistemi client da remoto:
  • ePolicy Orchestrator: gestisce centralmente e forza i criteri di VirusScan Enterprise, quindi utilizza le query e le dashboard per tenere traccia delle attività e dei rilevamenti.
    Nota: Questo documento riguarda l'utilizzo di ePolicy Orchestrator 4.0, 4.5 e 4.6. Per informazioni su ePolicy Orchestrator, consultare la documentazione del prodotto per la versione in uso.
  • Archivio DAT: recupera gli aggiornamenti DAT dal sito di download McAfee. Da qui, i file DAT possono essere replicati in tutta l'organizzazione in modo da renderli accessibili a tutti gli altri computer. In tal modo viene ridotta al minimo la quantità di dati trasferiti in rete automatizzando il processo di copia dei file aggiornati nei siti condivisi.


Importanza della creazione di una strategia di sicurezza

La protezione dei sistemi client da file contenenti virus, worm e cavalli di Troia eseguita con VirusScan Enterprise, richiede una strategia correttamente pianificata, che prevede la definizione della prevenzione e del metodo di rilevamento delle minacce, la risposta da fornire, l'analisi continua e la messa a punto.

Prevenzione: come evitare le minacce

Si consiglia di definire le proprie esigenze di sicurezza al fine di garantire la protezione di tutte le proprie origini dati e, quindi, di sviluppare una strategia efficace per bloccare le intrusioni prima che riescano ad accedere al proprio ambiente. Per impedire le intrusioni, configurare le funzioni seguenti:
  • Protezione dell'interfaccia utente: consente di impostare le opzioni di protezione relative alla visualizzazione e alla password per controllare l'accesso all'interfaccia utente di VirusScan Enterprise
  • Protezione all'accesso: le regole di protezione all'accesso consentono di proteggere il computer da un funzionamento indesiderato per quanto riguarda file, registro di sistema e porte.
  • Protezione dall'overflow del buffer: impedisce ai programmi anomali o alle minacce di invadere i limiti del buffer e di sovrascrivere la memoria adiacente, registrando contemporaneamente i dati in un buffer. Gli exploit da overflow del buffer consentono l'esecuzione di codice arbitrario sul computer dell'utente.
  • Protezione da programmi indesiderati: consente di eliminare programmi potenzialmente indesiderati, quali spyware e adware, dal computer.

Rilevamento: individuazione delle minacce

Si consiglia di sviluppare una strategia efficace per rilevare le intrusioni nel momento in cui si verificano. Per rilevare le minacce, configurare le funzioni seguenti:
  • Attività di aggiornamento: consente di ottenere automaticamente dal sito di download di McAfee gli aggiornamenti relativi ai file DAT e al motore di scansione.
  • Scansione all'accesso: consente di rilevare le minacce potenziali da qualsiasi origine possibile durante la lettura o la scrittura dei file sul disco. È inoltre possibile eseguire la scansione per rilevare cookie potenzialmente indesiderati all'interno della cartella dei cookie.
  • Attività di scansione su richiesta: consente di rilevare le minacce potenziali utilizzando attività di scansione immediata e pianificata. È inoltre possibile eseguire la scansione per rilevare cookie e voci del Registro di sistema relative a spyware potenzialmente indesiderati che non sono stati puliti in precedenza.
  • Scansione della posta elettronica alla consegna e su richiesta: consente di rilevare minacce potenziali nei client di posta Microsoft Outlook mediante la scansione alla consegna di messaggi, allegati e cartelle pubbliche. Consente di rilevare minacce potenziali nei client di posta Lotus Notes quando si accede ai messaggi.
  • Criterio Quarantine Manager: consente di specificare il percorso di quarantena e il periodo di tempo in cui gli elementi resteranno in quarantena. È inoltre possibile ripristinare gli elementi in quarantena secondo le proprie esigenze.

Risposta: gestione delle minacce

Utilizzare i file di registro del prodotto, le azioni automatiche e altre funzioni di notifica per stabilire il miglior metodo di gestione dei rilevamenti.
  • Azioni: consente di configurare le funzioni in modo da intervenire in caso di rilevamento.

  • File di registro: consente di monitorare i file di registro per visualizzare una cronologia degli elementi rilevati.

  • Query e dashboard: le query e le dashboard di ePolicy Orchestrator consentono di monitorare l'attività di scansione e i rilevamenti.

Messa a punto: monitoraggio, analisi e ottimizzazione della protezione

Dopo la configurazione iniziale di VirusScan Enterprise, è sempre buona regola monitorare e analizzare la propria configurazione. Questo può migliorare le prestazioni del sistema e della rete, oltre che aumentare il livello di protezione antivirus qualora necessario. Ad esempio, i seguenti strumenti e funzioni di VirusScan Enterprise possono essere modificati come parte dei propri processi di monitoraggio, analisi e messa a punto:
  • File di registro (Console di VirusScan): visualizzare una cronologia degli elementi rilevati. L'analisi di queste informazioni potrebbe indicare se è necessario migliorare la protezione o modificare la configurazione per aumentare le prestazioni del sistema.
  • Query e dashboard: (console di ePolicy Orchestrator): consentono di monitorare l'attività di scansione e i rilevamenti. L'analisi di queste informazioni potrebbe indicare se è necessario migliorare la protezione o modificare la configurazione per aumentare le prestazioni del sistema.
  • Attività pianificate: consentono di modificare le attività (ad esempio l'aggiornamento automatico) e i tempi di scansione per migliorare le prestazioni mediante la relativa esecuzione negli orari non di punta.
  • Archivi DAT: consentono di ridurre il traffico di rete su Internet o la Intranet aziendale spostando i file di origine in una posizione più vicina ai client che necessitano di aggiornamenti.
  • Modifica dei criteri di scansione: consente di aumentare le prestazioni o la protezione antivirus a seconda dell'analisi dei file di registro o delle query. Ad esempio, le configurazioni delle esclusioni, del momento in cui utilizzare la scansione con profilo a basso e alto rischio e in cui disattivare la scansione alla scrittura, possono migliorare le prestazioni.
    ATTENZIONE:
    L'impossibilità di consentire la scansione durante la lettura dal disco lascia il sistema sprovvisto di protezione da numerosi attacchi malware.


Console di VirusScan e modalità di accesso

Console di VirusScan è l'interfaccia per la versione autonoma delle attività del programma. È possibile utilizzarla per configurare, monitorare e aggiornare il prodotto.
Nota: Queste informazioni si applicano solo alla versione autonoma del prodotto e non alla versione ePolicy Orchestrator gestita.


Console di VirusScan e relative funzionalità

Dopo aver appreso il funzionamento di VirusScan Enterprise, è necessario capire come accedere alle rispettive istruzioni. Per aprire la Console di VirusScan Enterprise 8.8, utilizzare uno dei seguenti metodi:
  • Dal menu Start, selezionare Programmi | McAfee | Console di VirusScan.
  • Fare clic con il pulsante destro del mouse sull'icona a forma di scudo di VirusScan Enterprise nella barra delle applicazioni, quindi selezionare Console di VirusScan.

Barra dei menu

Utilizzare le opzioni di menu per creare attività, configurare proprietà e accedere ad informazioni aggiuntive.
  • Attività: consente di creare e configurare attività come la scansione di minacce o l'aggiornamento dei file DAT.
  • Modifica: consente di copiare, incollare, eliminare o rinominare l'attività selezionata.
  • Visualizza: consente di visualizzare la barra degli strumenti e la barra di stato e di aggiornare la schermata.
  • Strumenti: consente di configurare le opzioni di interfaccia per gli utenti, bloccare o sbloccare la protezione dell'interfaccia utente, configurare gli avvisi, accedere al visualizzatore eventi, aprire una console remota se si dispone dei privilegi amministrativi, importare o modificare l'elenco degli archivi e ripristinare una versione precedente dei file DAT.
  • ?: consente di accedere agli argomenti della Guida in linea, al sito Web di McAfee per consultare la libreria delle minacce e inviare esempi di virus e al sito Web dell'assistenza tecnica. È inoltre possibile riparare l'installazione del prodotto e visualizzare la finestra di dialogo Informazioni su per verificare le informazioni sul copyright e le versioni del prodotto, della licenza, dei file di definizione, del motore di scansione, dei driver extra e delle patch installate.
Nota: A ogni voce del menu è associato un tasto di scelta rapida. Su alcuni sistemi operativi, questi tasti di scelta rapida potrebbero non essere disponibili, a meno che non si utilizzano F10 o ALT per accedere ai menu.

Barra degli strumenti

Scegliere le icone per un accesso rapido ai comandi che si utilizzano più di frequente.
  • Consente di visualizzare le proprietà dell'attività selezionata.
  • Consente di avviare l'attività selezionata.
  • Consente di arrestare l'attività selezionata.
  • Consente di copiare l'attività selezionata.
  • Consente di incollare l'attività selezionata.
  • Consente di eliminare l'attività selezionata.
  • Consente di configurare le proprietà degli avvisi.
  • Consente di avviare il visualizzatore eventi.
  • Consente di accedere alla libreria di informazioni online sul sito Web di McAfee Labs.
  • Consente di collegarsi a un computer remoto se si dispone di privilegi amministrativi.
  • Consente di creare una nuova attività di scansione su richiesta.

Elenco delle attività

Visualizza le attività predefinite e le nuove attività create, nonché lo stato e l'ultimo risultato per ciascuna attività.

Barra di stato

Visualizza lo stato dell'attività corrente.


Utilizzo delle funzioni del pulsante destro del mouse

Utilizzare le funzioni del pulsante destro del mouse per accedere rapidamente alle azioni che si eseguono di frequente, quali la creazione di nuove attività, la visualizzazione delle statistiche e dei registri delle attività, l'apertura delle pagine delle proprietà delle attività, la scansione di un file o di una cartella specifica o l'esecuzione immediata di un'attività di aggiornamento.

Descrizioni delle funzioni

Percorso | Descrizione | Esempi
La Console Fare clic con il pulsante destro del mouse su Console di VirusScan per visualizzare le funzioni del pulsante destro del mouse. Queste funzioni variano a seconda che si sia selezionata un'attività nell'elenco delle attività e in base all'attività selezionata.
  • Nella console, fare clic con il pulsante destro del mouse su un'attività per visualizzarne le proprietà. A seconda dell'attività selezionata, è inoltre possibile avviare, interrompere, attivare o disattivare un'attività, nonché visualizzarne le statistiche e il registro delle attività. In alcuni casi è anche possibile rinominare o eliminare un'attività.
  • Fare clic con il pulsante destro del mouse in un'area vuota della console per creare una nuova scansione o un'attività di aggiornamento.
Esplora risorse di Windows Selezionare un file o una cartella e fare clic con il pulsante destro del mouse per eseguire una Scansione minacce. È possibile selezionare un'azione per la scansione:
  • Pulisci: consente di segnalare ed eliminare l'elemento rilevato.
  • Continua: consente di segnalare il rilevamento e di continuare con la scansione.

Eseguire una scansione immediata di un file o una cartella se si sospetta la presenza di una minaccia.

Quando si avvia la scansione, lo scanner su richiesta viene richiamato direttamente con tutte le impostazioni di scansione attivate. Selezionare l'opzione. Non è possibile personalizzare altre impostazioni di scansione.

La barra delle applicazioni | Consultare Icone della barra delle applicazioni e relativo funzionamento per le descrizioni sulle icone selezionabili con il pulsante destro del mouse di VirusScan Enterprise.


Icone della barra delle applicazioni e relativo funzionamento

Una volta installato VirusScan Enterprise, nella barra delle applicazioni di Windows viene visualizzata l'icona a forma di scudo, se è stata scelta questa impostazione durante il processo di installazione.

"M" all'interno di un'icona a forma di scudo

Viene visualizzata nei sistemi ePolicy Orchestrator gestiti che utilizzano McAfee Agent versione 4.5 o successiva. Visualizza i seguenti elementi:
  • Stato: questa icona non cambia per indicare gli avvisi di attivazione della protezione all'accesso oppure se la scansione all'accesso è disattivata nei client ePolicy Orchestrator gestiti con McTray versione 2.x o successive (con McAfee Agent 4.5 o versione successiva). Le modifiche dello stato vengono visualizzate sotto forma di descrizione comandi.
  • Descrizioni comandi: le descrizioni comandi delle icone comprendono quanto indicato di seguito.
    • Stato di McAfee: OK - Normale. Le opzioni visualizzate includono:
      • Mostra stato sicurezza: presenta un segno di spunta.
      • Impostazioni rapide | Scansione all'accesso per il rilevamento virus - On: presenta un segno di spunta.
    • Stato di McAfee: Problema rilevato: scansione all'accesso disattivata. Le opzioni visualizzate includono:
      • Mostra stato sicurezza: presenta un punto esclamativo.
        Nota: Fare clic su Mostra stato sicurezza per visualizzare la finestra di dialogo relativa allo stato di sicurezza di McAfee all'interno della quale, nella colonna Stato, è visualizzato Problema — "scansione all'accesso disattivata".
      • Impostazioni rapide | Scansione all'accesso per il rilevamento virus - Off: non è presente alcun segno di spunta.
    • Stato di McAfee: Problema rilevato — Evento di protezione dell'accesso attivato. Le opzioni visualizzate includono:
      • Mostra stato sicurezza: presenta un punto esclamativo.
        Nota: Fare clic su Mostra stato sicurezza per visualizzare la finestra di dialogo relativa allo stato di sicurezza di McAfee all'interno della quale, nella colonna Stato, è visualizzato Problema — "Consultare il registro di protezione dell'accesso".
      • Impostazioni rapide | Scansione all'accesso per il rilevamento virus - On: presenta un segno di spunta.
  • Opzioni dei menu: le opzioni dei menu di scelta rapida includono le voci seguenti.
    • Aggiorna sicurezza: consente di aggiornare i file DAT e altre eventuali modifiche.
    • Impostazioni rapide: include le voci seguenti.
      • Proprietà della scansione all'accesso: consente di aprire le pagine delle proprietà della scansione all'accesso.
      • Scansione all'accesso attiva o disattiva: consente di attivare/disattivare la scansione all'accesso.
      • Proprietà della scansione all'accesso: consente di aprire le pagine delle proprietà della scansione all'accesso.
      • Messaggi della scansione all'accesso: consente di aprire le statistiche o i messaggi della scansione all'accesso.
      • Apri file di registro protezione all'accesso: consente di aprire il file di registro delle attività di protezione all'accesso.

    • Gestisci funzionalità | VirusScan Enterprise: consente di aprire Console di VirusScan.
    • Scansione del computer per il rilevamento di | Minacce: consente di avviare una scansione immediata.
    • Mostra stato sicurezza: consente di visualizzare la finestra di dialogo relativa allo stato di sicurezza diMcAfee.
    • Monitoraggio di stato di McAfee Agent: consente di visualizzare la finestra di dialogo relativa allo stato di sicurezza diMcAfee.
    • Informazioni: consente di visualizzare la finestra di dialogo Informazioni.

"M" all'interno di un'icona a forma di quadrato

Viene visualizzata nei sistemi standalone che utilizzano McTray 1.0 e nei sistemi ePolicy Orchestrator gestiti che utilizzanoMcAfee Agent versione 4.0 con McTray 1.0. Visualizza i seguenti elementi:
  • Stato: le opzioni visualizzate includono quanto segue.
    • "M" All'interno di un'icona a forma di quadrato - Stato normale.
    • "M" all'interno di un'icona a forma di quadrato con un punto esclamativo: è stato attivato un evento di violazione della protezione all'accesso oppure la scansione all'accesso è disattivata. Le opzioni del menu di scelta rapida indicano:
      • "V" all'interno di uno scudo con un cerchio e una linea: indica che la scansione all'accesso è disattivata.
      • "V" all'interno di uno scudo dal contorno rosso: indica che la scansione all'accesso è attivata, ma che è necessario consultare il file di registro della funzione Protezione all'accesso.

  • Descrizione comandi: visualizza "McAfee".
  • Opzioni dei menu: le opzioni dei menu di scelta rapida includono le voci seguenti.
    • Console di VirusScan: apre Console di VirusScan.
    • Disattiva scanner all'accesso o Attiva scanner all'accesso.: consente di attivare/disattivare lo scanner all'accesso.
    • Proprietà della scansione all'accesso: consente di aprire le pagine delle proprietà della scansione all'accesso.
    • Statistiche della scansione all'accesso: consente di aprire le statistiche della scansione all'accesso.
    • Messaggi della scansione all'accesso: consente di aprire le statistiche o i messaggi della scansione all'accesso.
    • Scansione su richiesta: consente di creare una scansione su richiesta configurabile eseguita una volta.
    • Aggiorna ora: consente di eseguire un'attività di aggiornamento automatico immediata.
    • Informazioni su VirusScan Enterprise: consente di visualizzare la finestra di dialogo Informazioni.

"V" all'interno di un'icona a forma di scudo

Viene visualizzata nei sistemi standalone in cui non è installato McTray 1.0. Visualizza i seguenti elementi:
  • Stato: le opzioni visualizzate includono quanto segue.
    • "V" all'interno di un'icona a forma di scudo - Normale.
    • "V" all'interno di uno scudo con un cerchio e una linea: indica che la scansione all'accesso è disattivata.
    • "V" all'interno di uno scudo dal contorno rosso: indica che la scansione all'accesso è attivata, ma che è necessario consultare il file di registro della funzione Protezione all'accesso.
  • Descrizioni comandi: le descrizioni comandi comprendono quanto indicato di seguito.
    • "V" all'interno di uno scudo — McAfee OAS: attivato, normale.
    • "V" all'interno di uno scudo con un cerchio e una linea — McAfee OAS: disattivato.
    • "V" all'interno di uno scudo con il contorno rosso — McAfee OAS: attivato, ma è necessario consultare il registro di Protezione all'accesso.

  • Opzioni dei menu: le opzioni dei menu di scelta rapida includono le voci seguenti.
    • Aggiorna sicurezza: consente di aggiornare i file DAT e altre eventuali modifiche.
    • Impostazioni rapide: include le voci seguenti.
      • Proprietà della scansione all'accesso: consente di aprire le pagine delle proprietà della scansione all'accesso.
      • Scansione all'accesso attiva o disattiva: consente di attivare/disattivare la scansione all'accesso.
      • Messaggi della scansione all'accesso: consente di aprire le statistiche o i messaggi della scansione all'accesso.
      • Apri file di registro protezione all'accesso: consente di aprire il file di registro delle attività di protezione all'accesso.

    • Gestisci funzionalità | VirusScan Enterprise: consente di aprire Console di VirusScan.
    • Scansione del computer per il rilevamento di | Minacce: consente di avviare una scansione immediata.
    • Mostra stato sicurezza: consente di visualizzare la finestra di dialogo relativa allo stato di sicurezza diMcAfee.
    • Monitoraggio di stato di McAfee Agent: consente di visualizzare la finestra di dialogo relativa allo stato di sicurezza diMcAfee.
    • Informazioni: consente di visualizzare la finestra di dialogo Informazioni.


Operazioni preliminari

Quando il software è installato, utilizza i file DAT forniti con il prodotto, che offrono protezione generale all'ambiente. McAfee consiglia di reperire i file DAT più aggiornati e di personalizzare la configurazione in modo da soddisfare le necessità dell'utente, prima di distribuire il prodotto ai sistemi client.

Immediatamente dopo l'installazione del prodotto, effettuare le seguenti operazioni.

  1. Impostazione della protezione dell'interfaccia utente Configurare le opzioni di visualizzazione e della password per impedire l'accesso a componenti specifici o a tutta l'interfaccia utente di VirusScan Enterprise. Per ulteriori informazioni, vedere Controllo dell'accesso all'interfaccia utente.
  2. Aggiornamento dei file DAT Eseguire l'operazione Aggiorna ora per assicurarsi di disporre dei file DAT più recenti. Per ulteriori informazioni, vedere Aggiornamento delle definizioni dei rilevamenti.
  3. Prevenzione delle intrusioni Configurare queste funzioni per impedire a minacce potenziali di accedere ai sistemi:
    • Protezione all'accesso. Consente di configurare le regole di protezione all'accesso per impedire che vengano apportate modifiche indesiderate al computer e attivare l'opzione che impedisce l'interruzione dei processi McAfee. Per ulteriori informazioni, vedere Protezione dei punti di accesso del sistema.
    • Protezione da sovraccarico del buffer. Consente di attivare il rilevamento del sovraccarico del buffer e di specificare le esclusioni. Per ulteriori informazioni, vedere Blocco degli utilizzi del sovraccarico del buffer.
    • Criterio per programmi indesiderati Consente di configurare il criterio utilizzato dagli scanner all'accesso, su richiesta e di posta elettronica per rilevare programmi potenzialmente indesiderati. Selezionare le categorie dei programmi indesiderati da rilevare da un elenco predefinito, quindi definire ulteriori programmi da rilevare o escludere. Per ulteriori informazioni, vedere Restrizione dei programmi potenzialmente indesiderati.
  4. Rilevamento delle intrusioni Configurare queste funzioni per rivelare minacce potenziali sui sistemi, ricevere un messaggio di avviso e intraprendere le azioni necessarie al verificarsi dei rilevamenti:
    • Aggiornamento automatico Consente di configurare le attività di aggiornamento per ottenere le versioni più recenti dei file DAT, del motore di scansione e del prodotto. Per ulteriori informazioni, vedere Aggiornamento delle definizioni dei rilevamenti.
    • Scansione all'accesso Consente di configurare lo scanner in modo tale da rilevare le minacce potenziali e intraprendere le azioni necessarie al momento dell'accesso all'ambiente. Attiva la scansione dei programmi indesiderati e ricerca i cookie nella relativa cartella. Per ulteriori informazioni, vedere Scansione di elementi all'accesso.
    • Scansione su richiesta Consente di configurare le attività di scansione per rilevare le minacce potenziali nell'ambiente e intraprendere le azioni necessarie. È inoltre possibile attivare la scansione dei programmi indesiderati e rilevare cookie all'interno della cartella dei cookie, e voci del Registro di sistema relative a spyware potenzialmente indesiderate che non sono state pulite in precedenza. Per ulteriori informazioni, vedere Scansione di elementi su richiesta.
    • Scanner della posta elettronica Consente di configurare la scansione alla consegna e su richiesta dei client di posta elettronica Microsoft Outlook e Lotus Notes. Attivare la scansione dei programmi indesiderati. Per ulteriori informazioni, vedere Scansione della posta elettronica alla consegna e su richiesta.
  5. Inviare avvisi e mettere in quarantena le minacce. Configurare queste funzioni per ricevere un avviso quando si verifica un rilevamento e per gestire gli elementi in quarantena:
    • Avvisi e notifiche Consente di configurare la modalità e la frequenza con cui si ricevono le notifiche e gli avvisi relativi ai rilevamenti. Per ulteriori informazioni, vedere Configurazione di avvisi e notifiche.
    • Criterio Quarantine Manager. Consente di specificare il percorso della cartella di quarantena e di definire il numero di giorni in cui i dati resteranno in quarantena prima di essere automaticamente eliminati. Per ulteriori informazioni, consultare Elementi in quarantena.
Concetti correlati
Elementi in quarantena
Attività correlate
Scansione e-mail alla consegna e su richiesta
Informazioni correlate
Controllo dell'accesso all'interfaccia utente
Aggiornamento delle definizioni dei rilevamenti
Protezione dei punti di accesso del sistema
Blocco degli exploit da overflow del buffer
Restrizione di programmi potenzialmente indesiderati
Scansione di elementi all'accesso
Scansione di elementi su richiesta
Configurazione di avvisi e notifiche


Parte I - Prevenzione: misure per impedire le minacce

La prevenzione è la fase principale di una strategia di protezione, per impedire alle minacce di accedere al sistema.

Sommario

  • Protezione all'accesso
  • Protezione dei punti di accesso del sistema
  • Blocco degli exploit da overflow del buffer
  • Restrizione di programmi potenzialmente indesiderati
  • Aggiornamento delle definizioni dei rilevamenti
  • Esclusione di elementi dalla scansione
  • Utilizzo di attività pianificate


Protezione all'accesso

Impedire alle minacce di accedere al sistema client è la prima linea di difesa contro il malware. La funzione Protezione all'accesso di VirusScan Enterprise confronta un'azione con un elenco di regole configurate. È possibile configurare le singole regole in modo che blocchino e segnalino le violazioni nel momento in cui si verificano.

La funzione Protezione all'accesso impedisce che il computer subisca modifiche indesiderate mediante la limitazione dell'accesso a porte, file, condivisioni nonché chiavi e valori di registro specificati. Protegge inoltre i processi di McAfee impedendo agli utenti di interromperli. La protezione può rivelarsi fondamentale sia prima sia durante la diffusione di virus.

Questa funzione utilizza regole predefinite e definite dall'utente per specificare a quali elementi è possibile o non è possibile accedere. È possibile configurare le singole regole in modo che blocchino e segnalino le violazioni nel momento in cui si verificano. Le regole e le categorie predefinite sono soggette ad aggiornamenti del contenuto tramite i siti di aggiornamento di McAfee.

Nota: Affinché la funzione di protezione all'accesso possa rilevare i tentativi di accesso alle porte, ai file, alle condivisioni, alle chiavi di registro e ai valori, deve essere attivata la scansione all'accesso.

Modalità di accesso delle minacce

I modi più comuni utilizzati dalle minacce per accedere al sistema includono:
  • Macro: vengono introdotte come parte dei documenti di elaboratori di testo e delle applicazioni di fogli elettronici.
  • File eseguibili: programmi apparentemente innocui che insieme al programma previsto possono contenere virus. Ad esempio, alcune estensioni di file comuni sono EXE, .COM, .VBS, .BAT, .HLP e .DLL.
  • E-mail: scherzi, giochi e immagini vengono inviati come parte di messaggi e-mail con allegati.
  • Script: associati alle pagine Web e messaggi e-mail, ad esempio script ActiveX e JavaScript, se eseguiti possono contenere virus.
  • Messaggi IRC (Internet Relay Chat): file inviati con questi messaggi possono facilmente contenere malware. Ad esempio, i processi ad avvio automatico possono contenere minacce quali worm e cavalli di Troia.
  • File della Guida del browser e delle applicazioni: il download di questi file della Guida espone il sistema a virus ed eseguibili incorporati.
  • Combinazione di tutti questi modi: autori di programmi malware sofisticati combinano tutti questi metodi di invio delle minacce e incorporano persino programmi malware uno dentro l'altro per tentare di accedere al computer.

Sommario

Concetti correlati
Come vengono bloccate le minacce all'accesso
Informazioni correlate
Controllo dell'accesso all'interfaccia utente


Come vengono bloccate le minacce all'accesso

L'abilitazione o la modifica della configurazione della funzione Protezione all'accesso consente di impostare la protezione antispyware e antivirus, nonché la protezione comune e della macchina virtuale, permettendo anche di definire regole personali. Di seguito è riportata la procedura di base che VirusScan Enterprise utilizza per fornire la protezione all'accesso.

Azioni che vengono intraprese in caso di minaccia

  1. Un utente o un processo tenta di intraprendere un'azione.
  2. Questa azione viene esaminata dalla Protezione all'accesso in base a regole definite.
  3. Quanto una regola viene infranta, l'azione richiesta dall'utente o dal processo viene gestita tramite le informazioni presenti nelle regole configurate. Ad esempio, un'azione può non determinare alcun evento, può essere bloccata oppure può essere bloccata e viene inviato un rapporto.
  4. Il file di registro di Protezione all'accesso viene aggiornato e viene generato un evento per l'amministratore globale di ePolicy Orchestrator.

Esempio di una minaccia all'accesso

  1. Un utente scarica un programma, ad esempio MyProgram.exe, da Internet.
    Nota: In questo esempio, MyProgram.exe non è malware.
  2. L'utente avvia il programma che sembra partire nel modo previsto.
  3. MyProgram.exe quindi avvia un processo figlio, denominato AnnoyMe.exe, e tenta di modificare il sistema operativo per assicurarsi che venga sempre caricato all'avvio.
  4. Protezione all'accesso elabora la richiesta e la confronta con una regola esistente che è configurata per bloccare le minacce e inviare un rapporto.
  5. Ad AnnoyMe.exe viene negato l'accesso quando tenta di modificare il sistema operativo, Protezione all'accesso registra i dettagli del tentativo e genera un avviso per l'amministratore globale di ePolicy Orchestrator.

Rapporti e avvisi generati

Il seguente è un esempio di una voce di registro generata da Protezione all'accesso.

2/10/2010 11:00AM Blocked by Access Protection rule TestDomain\TestUser C:\Users\TestUser\Desktop\AnnoyMe.exe \REGISTRY\MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion\Run\ Prevent programs registering to autorun

In questa tabella viene fornita una descrizione dei dati contenuti nella voce di registro di Protezione all'accesso mostrata in precedenza:
Voce di registro | Descrizione
2/10/2010 | Data
11:00:00 | Ora
Bloccato da una regola di protezione dell'accesso a file o cartelle | Azione intrapresa
TestDomain\TestUser | Credenziali
C:\Users\TestUser\Desktop\AnnoyMe.exe | Nome del processo che ha infranto la regola
\REGISTRY\MACHINE\SOFTWARE\Microsoft... | Posizione alla quale il processo ha tentato di accedere
Impedisci registrazione di programmi per l'esecuzione automatica | Regola di protezione all'accesso attivata

Informazioni simili vengono rese disponibili se si utilizzano le query di ePolicy Orchestrator. Per ulteriori informazioni, consultare Accesso a query e dashboard.

Informazioni correlate
Accesso a query e dashboard


Controllo dell'accesso all'interfaccia utente

L'impostazione della sicurezza dell'interfaccia nei computer client rappresenta un'operazione importante per la protezione dell'ambiente.

Se si ricopre il ruolo di amministratore, è possibile:
  • Controllare l'accesso all'interfaccia di VirusScan Enterprise di cui gli utenti dispongono.
  • Specificare una password per impedire agli utenti l'accesso o la modifica delle funzionalità selezionate.
  • Bloccare e sbloccare l'interfaccia utente in base alle proprie esigenze.

Sommario

Concetti correlati
Conseguenze sugli utenti a seguito dell'impostazione di una password
Attività correlate
Configurazione delle impostazioni di sicurezza dell'interfaccia utente


Conseguenze sugli utenti a seguito dell'impostazione di una password

Consente di impostare una password per l'interfaccia utente allo scopo di impedire l'accesso agli utenti pericolosi.

La protezione tramite password dell'interfaccia utente nei computer client comporta conseguenze per gli utenti elencati di seguito:

  • Non amministratori: utenti che non dispongono dei privilegi amministrativi. Gli utenti che non dispongono dei privilegi amministrativi eseguono tutte le applicazioni di VirusScan Enterprise in modalità di sola lettura. Possono visualizzare alcuni parametri di configurazione, eseguire scansioni salvate, scansioni immediate e aggiornamenti, ma non possono modificare alcun parametro di configurazione, creare, eliminare o modificare attività di scansione salvate o di aggiornamento.
  • Amministratori: utenti che dispongono dei privilegi amministrativi. Gli amministratori devono immettere la password per accedere a schede e comandi protetti in modalità di lettura e scrittura. Se non viene immessa una password per un elemento protetto, la visualizzazione sarà consentita in modalità di sola lettura.


Configurazione delle impostazioni di sicurezza dell'interfaccia utente

Utilizzare le proprietà dell'interfaccia utente dei criteri Opzioni generali per configurare le opzioni di visualizzazione e le password disponibili per gli utenti.
ATTENZIONE:
Prima di apportare modifiche a queste proprietà, considerare con attenzione le diramazioni della sicurezza. Queste opzioni consentono di limitare o consentire agli utenti di apportare modifiche alla configurazione della sicurezza, impedendo di lasciare i sistemi non protetti contro numerosi attacchi hardware.

È possibile configurare le proprietà dell'interfaccia utente dei criteri Opzioni generali con queste console dell'interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Configurare le proprietà dell'interfaccia utente dei criteri Opzioni generali.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? su ciascuna scheda.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella scheda Opzioni di visualizzazione, configurare le icone della barra delle applicazioni diVirusScan Enterprise che gli utenti possono vedere, se questi possono connettersi ai sistemi remoti e le impostazioni relative alle opzioni della lingua.
  5. Nella scheda Opzioni password configurare le attività e le opzioni dell'interfaccia utente di VirusScan Enterprise che gli utenti possono modificare utilizzando la password corretta.


ePolicy Orchestrator 4.0

Configurare le proprietà dell'interfaccia utente dei criteri Opzioni generali.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? su ciascuna scheda.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella scheda Opzioni di visualizzazione, configurare le icone della barra delle applicazioni diVirusScan Enterprise che gli utenti possono vedere, se questi possono connettersi ai sistemi remoti e le impostazioni relative alle opzioni della lingua.
  5. Nella scheda Opzioni password configurare le attività e le opzioni dell'interfaccia utente di VirusScan Enterprise che gli utenti possono modificare utilizzando la password corretta.


Console di VirusScan

Configurare le proprietà dell'interfaccia utente di Opzioni generali.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? su ciascuna scheda.

  1. Fare clic su Strumenti | Opzioni generali per visualizzare la finestra di dialogo di configurazione Opzioni generali.
  2. Nella scheda Opzioni di visualizzazione, configurare le icone della barra delle applicazioni diVirusScan Enterprise che gli utenti possono vedere, se questi possono connettersi ai sistemi remoti e le impostazioni relative alle opzioni della lingua.
  3. Nella scheda Opzioni password configurare le attività e le opzioni dell'interfaccia utente di VirusScan Enterprise che gli utenti possono modificare utilizzando la password corretta.


Protezione dei punti di accesso del sistema

La protezione all'accesso impedisce che il computer subisca modifiche indesiderate mediante la limitazione dell'accesso a porte, file, condivisioni nonché chiavi e valori di registro specificati. Protegge inoltre i processi McAfee impedendo agli utenti di interromperli. La protezione può rivelarsi fondamentale sia prima sia durante la diffusione di virus.

Questa funzione utilizza regole e categorie predefinite nonché regole definite dall'utente per specificare a quali elementi è possibile o non è possibile accedere. È possibile configurare le singole regole in modo che blocchino e segnalino le violazioni del punto di accesso nel momento in cui si verificano. Le regole e le categorie predefinite sono soggette ad aggiornamenti del contenuto tramite i siti di aggiornamento di McAfee.

Sommario

Concetti correlati
Violazioni del punto di accesso e relative reazioni di VirusScan Enterprise
Attività correlate
Configurazione delle impostazioni di protezione all'accesso
Riferimenti correlati
Modalità di definizione delle regole di protezione all'accesso
Tipi di regole definite dall'utente


Modalità di definizione delle regole di protezione all'accesso

Le regole si suddividono in vari tipi e forniscono i seguenti livelli di protezione.

Descrizioni del tipo di regola

Tipo regola Descrizione
Antivirus

Si tratta di regole preconfigurate che proteggono il computer dai comportamenti comuni delle minacce malware. È possibile attivarle, disattivarle e modificarne la configurazione, ma non è possibile eliminarle.

Di seguito sono riportati due esempi di tali regole.

  • Impedisci la disattivazione o la modifica di processi critici, la creazione remota o la modifica di file eseguibili, la presa di controllo di file eseguibili, lo spoofing dei processi Windows e l'invio di messaggi da parte di worm distribuiti tramite mass-mailing.
  • Proteggi i file della rubrica dal furto di password e di indirizzi di posta elettronica.

Alle regole antivirus si applicano i seguenti livelli di protezione:

  • Protezione standard
  • Protezione massima
  • Controllo diffusione
Comuni

Si tratta di regole preconfigurate per impedire la modifica delle impostazioni e dei file utilizzati più di frequente. È possibile attivarle, disattivarle e modificarne la configurazione, ma non è possibile eliminarle.

Di seguito sono riportati tre esempi di tali regole.

  • Impedisci la modifica dei file e delle impostazioni di McAfee.
  • Proteggi i file e le impostazioni di Mozilla e Firefox, le impostazioni di Internet Explorer e le impostazioni di rete.
  • Impedisci l'installazione di oggetti helper browser e l'esecuzione automatica di programmi dalla cartella Temp.

Alle regole comuni si applicano i seguenti livelli di protezione:

  • Protezione standard
  • Protezione massima
Protezione della macchina virtuale

Si tratta di regole preconfigurate per impedire l'interruzione dei processi VMWare e la modifica dei file VMWare. È possibile attivarle, disattivarle e modificarne la configurazione, ma non è possibile eliminarle.

Di seguito sono riportati alcuni esempi di tali regole.
  • Impedisci interruzione dei processi VMWare.
  • Impedisci modifica di file della workstation, del server o della macchina virtuale VMWare.
Definite dall'utente

Si tratta di regole personalizzate che integrano la protezione fornita dalle regole antivirus e comuni.

Anti-spyware

Di seguito sono riportati alcuni esempi di tali regole.
  • Proteggi impostazioni e preferiti di Internet Explorer.
  • Impedisci esecuzione di programmi e di script dalla cartella Temp.

Descrizioni dei livelli di protezione

Livello di protezione | Descrizione
Standard | Regole comuni e antivirus che proteggono alcuni file e impostazioni critici impedendone la modifica, ma che di solito consentono l'installazione e l'esecuzione di software legittimo.
Massima | Regole comuni e antivirus che consentono di proteggere la maggior parte dei file e delle impostazioni essenziali impedendone la modifica. Questo livello offre una maggiore protezione rispetto a quello Standard, ma può impedire l'installazione di software legittimo. Nel caso in cui non sia possibile installare il software, si consiglia di disattivare la funzione di Protezione all'accesso prima dell'installazione e di riattivarla al termine.
Controllo diffusione | Regole antivirus che impediscono al codice dannoso di accedere al computer fino al rilascio di un nuovo file DAT. Queste regole sono preconfigurate in modo da impedire l'accesso alle condivisioni durante la diffusione dei virus.


Violazioni del punto di accesso e relative reazioni di VirusScan Enterprise

Una violazione dell'accesso si verifica quando un utente o un processo con restrizioni tenta di avviare, interrompere o accedere a componenti del computer con restrizioni.

Quando si verifica una violazione del punto di accesso:

  • Se è stata selezionata l’opzione Segnala per la regola che ha rilevato la violazione, le informazioni vengono memorizzate nel file di registro.
  • L'evento viene inserito nel registro degli eventi locale e, se le impostazioni di Proprietà avvisi sono state configurate a tale scopo, nel servizio SNMP.
  • L'evento viene segnalato a Alert Manager e a ePolicy Orchestrator, se questi prodotti sono stati configurati a tale scopo.
  • Le azioni Blocco e Segnala per una regola determinano ciò che accade quando una regola rileva una violazione.
  • Nel sistema client autonomo, una cornice rossa circonda l'icona della barra delle applicazioni e rimane visibile per 30 minuti, a meno che non venga reimpostata.
    Nota: Per reimpostare l'icona, aprire il file di registro di Protezione all'accesso dall'icona della barra delle applicazioni. L'apertura del file di registro delle attività mediante un qualsiasi altro metodo non consente la reimpostazione dello stato dell'icona.


Tipi di regole definite dall'utente

Quando si configura una nuova regola definita dall'utente di protezione all'accesso, è possibile creare regole di blocco della porta, di blocco di file e cartelle e di blocco del registro.

Queste regole sono descritte nella seguente tabella.

Descrizioni delle regole

Regola | Descrizione
Regola di blocco porte Consente di bloccare il traffico di rete in entrata e in uscita su porte specifiche o intervalli di porte.
Nota: Quando si blocca una porta, l'accesso al protocollo di controllo della trasmissione (TCP) e l'accesso al protocollo per i datagrammi utente (UPD) sono bloccati.
Nota: Quando si blocca una porta, viene bloccato anche il protocollo che utilizza quella porta o quell'intervallo di porte. Ad esempio, l'accesso al protocollo di controllo della trasmissione (TCP) e l'accesso al protocollo per i datagrammi utente (UPD) sono bloccati.
Regola di blocco file o cartelle Blocca l'accesso in scrittura a file e cartelle, l'esecuzione dei file nonché la creazione di nuovi file e l'eliminazione di file.
Nota: Una volta limitato l'accesso a un file o una cartella, la limitazione rimane attiva finché l'amministratore non la rimuove. In questo modo si evitano le intrusioni e se ne impedisce la propagazione durante una diffusione dei virus.
Regola di blocco registro | È possibile proteggere le chiavi di registro bloccando le azioni seguenti: scrittura, creazione o eliminazione.


Configurazione delle impostazioni di protezione all'accesso

Utilizzare i Criteri di protezione all'accesso per proteggere i punti di accesso del sistema e impedire l'interruzione dei processi McAfee.
ATTENZIONE:
Se non si attiva la protezione all'accesso per impedire l'interruzione dei servizi McAfee, il sistema risulterà non protetto da numerosi attacchi malware.
È possibile configurare due tipi di regole di protezione all'accesso.
  • Regole predefinite — Consentono di:
    • Aprire la categoria della regola di protezione all'accesso in una delle console di interfaccia utente.
    • Selezionare l'azione di blocco e segnalazione da intraprendere se la regola viene violata.
  • Regole definite dall'utente — Consentono di:
    • Creare la categoria della regola definita dall'utente con una delle console di interfaccia utente.
    • Scegliere il tipo di blocco a cui applicare la regola: blocco della porta, blocco di file e cartelle o blocco del registro.
    • Configurare i dettagli della regola.
    • Salvare la regola e modificarla in futuro, se possibile.

Attività

Attività correlate
Configurazione delle regole predefinite
Configurazione delle regole definite dall'utente
Rimozione delle regole definite dall'utente
Riferimenti correlati
Opzioni della regola di blocco delle porte
Opzioni della regola di blocco di file e cartelle
Opzioni della regola di blocco registro
Opzioni di inclusione ed esclusione di processi specifici


Configurazione delle regole predefinite

Utilizzare le regole predefinite per proteggere il proprio computer da modifiche indesiderate. Queste regole possono essere attivate e modificate ma non eliminate.

Le regole di protezione all'accesso predefinite includono:
  • Protezione AntiSpyware standard
  • Protezione AntiSpyware massima
  • Protezione antivirus standard
  • Protezione antivirus massima
  • Controllo diffusione antivirus
  • Protezione comune standard
  • Protezione comune massima
  • Protezione della macchina virtuale

Per i dettagli sulle regole di protezione all'accesso predefinite, fare riferimento a Modalità di definizione delle regole di protezione all'accesso.

Configurare le regole di protezione all'accesso predefinite utilizzando una di queste console di interfaccia.


ePolicy Orchestrator 4.5 o 4.6

Da Criteri di protezione all'accesso, configurare le regole di protezione all'accesso predefinite.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri di protezione all'accesso, fare clic sulla scheda Protezione all'accesso per visualizzare le Regole di protezione all'accesso.
  5. Selezionare quella delle categorie delle regole predefinite nel riquadro di sinistra, quindi selezionare la regola specifica nel riquadro di destra.
  6. Configurare le opzioni Blocco o Segnala oppure entrambe le opzioni Blocco e Segnala.
  7. Fare clic su Modifica per configurare le opzioni di Dettagli regola.


ePolicy Orchestrator 4,0

Da Criteri di protezione all'accesso, configurare le regole di protezione all'accesso predefinite.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri di protezione all'accesso, fare clic sulla scheda Protezione all'accesso per visualizzare le Regole di protezione all'accesso.
  5. Selezionare quella delle categorie delle regole predefinite nel riquadro di sinistra, quindi selezionare la regola specifica nel riquadro di destra.
  6. Configurare le opzioni Blocco o Segnala oppure entrambe le opzioni Blocco e Segnala.
  7. Fare clic su Modifica per configurare le opzioni di Dettagli regola.


Console di VirusScan

Dalle proprietà di Protezione all'accesso, configurare le regole di protezione all'accesso predefinite.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Protezione all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Dalla finestra di dialogo Criteri di protezione all'accesso, fare clic sulla scheda Protezione all'accesso per visualizzare le Regole di protezione all'accesso.
  3. Selezionare quella delle categorie delle regole predefinite nel riquadro di sinistra, quindi selezionare la regola specifica nel riquadro di destra.
  4. Configurare le opzioni Blocco o Segnala oppure entrambe le opzioni Blocco e Segnala.
  5. Fare clic su Modifica per configurare le opzioni di Dettagli regola.


Configurazione delle regole definite dall'utente

È possibile creare e modificare regole definite dall'utente a integrazione della protezione fornita dalle regole predefinite.

Per i dettagli sulle regole di protezione all'accesso predefinite, fare riferimento a Modalità di definizione delle regole di protezione all'accesso.

Creare e modificare le regole di protezione all'accesso definite dall'utente utilizzando una di queste console di interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Da Criteri di protezione all'accesso, configurare le regole di protezione all'accesso definite dall'utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Selezionare la categoria Regole definite dall'utente nel riquadro a sinistra, quindi fare clic su Nuovo per aprire la finestra di dialogo Seleziona nuovo tipo di regola.
  5. Selezionare il tipo di regola e fare clic su OK. Per i dettagli, fare riferimento a Tipi di regole definite dall'utente. La finestra di dialogo della regola di accesso che viene visualizzata dipende dal tipo di regola selezionato.
  6. Configurare i seguenti dettagli della regola di accesso.
    • Regola di protezione dell'accesso a porte di rete — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco delle porte.
    • Regola di protezione dell'accesso a file o cartelle — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco di file e cartelle.
    • Regola di protezione dell'accesso al registro — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco registro.
    Nota: Per configurare i processi da includere e quelli da escludere, fare riferimento a Opzioni di inclusione ed esclusione di processi specifici.
  7. Fare clic su OK. La nuova regola definita dall'utente viene visualizzata nel riquadro a destra, al di sotto di Blocca/Segnala/Regole. Per modificare la nuova regola, selezionarla e fare clic su Modifica.


ePolicy Orchestrator 4,0

Da Criteri di protezione all'accesso, configurare le regole di protezione all'accesso definite dall'utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Selezionare la categoria Regole definite dall'utente nel riquadro a sinistra, quindi fare clic su Nuovo per aprire la finestra di dialogo Seleziona nuovo tipo di regola.
  5. Selezionare il tipo di regola e fare clic su OK. Per i dettagli, fare riferimento a Tipi di regole definite dall'utente. La finestra di dialogo della regola di accesso che viene visualizzata dipende dal tipo di regola selezionato.
  6. Configurare i seguenti dettagli della regola di accesso.
    • Regola di protezione dell'accesso a porte di rete — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco delle porte.
    • Regola di protezione dell'accesso a file o cartelle — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco di file e cartelle.
    • Regola di protezione dell'accesso al registro — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco registro.
    Nota: Per configurare i processi da includere e quelli da escludere, fare riferimento a Opzioni di inclusione ed esclusione di processi specifici.
  7. Fare clic su OK. La nuova regola definita dall'utente viene visualizzata nel riquadro a destra, al di sotto di Blocca/Segnala/Regole. Per modificare la nuova regola, selezionarla e fare clic su Modifica.


Console di VirusScan

Dalle proprietà di Protezione all'accesso, configurare le regole di protezione all'accesso definite dall'utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Protezione all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Selezionare la categoria Regole definite dall'utente nel riquadro a sinistra, quindi fare clic su Nuovo per aprire la finestra di dialogo Seleziona nuovo tipo di regola.
  3. Selezionare il tipo di regola e fare clic su OK. Per i dettagli, fare riferimento a Tipi di regole definite dall'utente. La finestra di dialogo della regola di accesso che viene visualizzata dipende dal tipo di regola selezionato.
  4. Configurare i seguenti dettagli della regola di accesso.
    • Regola di protezione dell'accesso a porte di rete — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco delle porte.
    • Regola di protezione dell'accesso a file o cartelle — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco di file e cartelle.
    • Regola di protezione dell'accesso al registro — Fare riferimento alla tabella delle opzioni Opzioni della regola di blocco registro.
    Nota: Per configurare i processi da includere e quelli da escludere, fare riferimento a Opzioni di inclusione ed esclusione di processi specifici.
  5. Fare clic su OK. La nuova regola definita dall'utente viene visualizzata nel riquadro a destra, nella colonna Regole. Per modificare la nuova regola, selezionarla e fare clic su Modifica.


Opzioni della regola di blocco delle porte

Le regole di blocco delle porte impediscono agli utenti di accedere a specifiche porte in ingresso e in uscita e impediscono l'accesso al computer da parte di altri computer.

Definizioni delle opzioni

Opzioni | Definizione
Nome regola | Digitare il nome della regola.
Processi da includere | Consente di limitare l'accesso ai processi specificati.
Processi da escludere | Consente l'accesso ai processi specificati.
Porta iniziale | Consente di specificare il numero della prima porta. Può essere una porta singola o il numero iniziale di un intervallo di porte. Nota: Se si blocca l'accesso a una porta utilizzata dall'agente McAfee o dall'agente Host Intrusion Prevention, i processi dell'agente sono considerati attendibili e possono comunicare con la porta bloccata. Tutto il traffico non correlato a questi processi degli agenti viene bloccato.
Porta finale | Consente di specificare il numero dell'ultima porta in un intervallo di porte.
In ingresso | Impedisce ai sistemi presenti sulla rete di accedere alle porte specificate.
In uscita | Impedisce ai processi locali di accedere alle porte specificate nella rete.


Opzioni della regola di blocco di file e cartelle

Le regole di blocco di file e cartelle impediscono agli utenti non autorizzati di modificare, aprire o eliminare specifici file o cartelle.

Definizioni delle opzioni

Opzioni | Definizione
Nome regola | Digitare il nome della regola.
Processi da includere | Consente di limitare l'accesso ai processi specificati.
Processi da escludere | Consente l'accesso ai processi specificati.
Nome del file o della cartella da bloccare | Consente di bloccare l'accesso al file o alla cartella specificata.
Individua file | Consente di individuare il file.
Individua cartella | Consente di individuare la cartella.
Accesso ai file in lettura | Consente di bloccare l'accesso in lettura ai file specificati.
Accesso ai file in scrittura | Consente di bloccare l'accesso in scrittura ai file specificati.
Esecuzione di file | Consente di bloccare l'esecuzione dei file nella cartella specificata.
Creazione di nuovi file | Consente di bloccare la creazione di nuovi file nella cartella specificata.
Eliminazione di file | Consente di bloccare l'eliminazione dei file dalla cartella specificata.


Opzioni della regola di blocco registro

Le regole di blocco registro impediscono agli utenti e ai programmi non autorizzati di modificare, aprire o eliminare chiavi di registro e valori specifici.

Nota: Se si intende creare una regola per il blocco del registro, utilizzare per l'hive l'abbreviazione più corrispondente alla sottostruttura del registro. Ad esempio, per bloccare HKLM\System\CurrentControlSet\Services\MyService, scegliere l'hive HKCCS piuttosto che HKLM.

Definizioni delle opzioni

Opzioni | Definizione
Nome regola | Consente di specificare il nome della regola.
Processi da includere | Consente di limitare l'accesso ai processi specificati.
Processi da escludere | Consente l'accesso ai processi specificati.
Chiave o valore del registro di sistema da proteggere Consente di proteggere la chiave o il valore del registro di sistema:
  • Selezionare un valore o una chiave principale dall'elenco a discesa.
  • Digitare una chiave o un valore nella casella di testo.
La scelta di un valore o di una chiave principale dall'elenco a discesa è facoltativa. Utilizzare uno dei seguenti metodi per specificare il valore o la chiave:
  • Selezionare il valore o la chiave principale dall'elenco a discesa, quindi digitare la parte restante del percorso del valore o della chiave nella casella di testo.
  • Digitare il percorso completo della chiave o del valore nella casella di testo.
Tipo regola Consente di selezionare il tipo di regola:
  • Chiave: questa regola protegge la chiave specificata.
  • Valore: questa regola protegge il valore specificato.
Scrittura di chiavi o valori | Consente di bloccare la scrittura nella chiave o nel valore specificato.
Creazione di chiavi o valori | Consente di bloccare la creazione della chiave o del valore specificato.
Eliminazione di chiavi o valori | Consente di bloccare l'eliminazione della chiave o del valore specificato.


Opzioni di inclusione ed esclusione di processi specifici

Definizioni delle opzioni

Per modificare i dettagli della regola, ad esempio il nome, e i processi da includere o escludere, utilizzare Protezione all'accesso e fare clic su Modifica.

Opzioni | Descrizione
Nome regola | Nome della regola. Ad esempio, Impedisci disattivazione dell'Editor del Registro di sistema e di Task Manager.
Processi da includere | Consente di limitare l'accesso a questi processi. Utilizzare il nome esatto del processo o un carattere jolly per specificare un'ampia gamma di processi, ad esempio *.EXE. Quindi, aggiungere le esclusioni per determinati processi legittimi, ad esempio SETUP.EXE. Ad esempio, specificare * per includere tutti i processi.
Processi da escludere | Consente l'accesso a questi processi. Utilizzare il nome esatto del processo. Ad esempio, specificare le seguenti esclusioni: avtask.exe, cfgwiz,exe, fssm32.exe, giantantispywar*, kavsvc.exe, mmc.exe, navw32.exe, nmain.exe, rtvscan.exe.


Rimozione delle regole definite dall'utente

È possibile rimuovere regole definite dall'utente che non vengono più utilizzate.

Rimuovere le regole predefinite dall'utente utilizzando una di queste console di interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Da Criteri di protezione all'accesso, rimuovere le regole create che non si utilizzano più.

Attività

Per le definizioni delle opzioni, fare clic su ? o su Guida in linea nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Selezionare la categoria Regole definite dall'utente nel riquadro di sinistra, quindi selezionare la regola che si desidera eliminare nel riquadro di destra.
  5. Fare clic su Elimina.
    Nota: Per disattivare una regola senza eliminarla, deselezionare le azioni Blocca e Segnala. Se necessario, è possibile attivare di nuovo la regola.


ePolicy Orchestrator 4.0

Da Criteri di protezione all'accesso, rimuovere le regole create che non si utilizzano più.

Attività

Per le definizioni delle opzioni, fare clic su ? o su Guida in linea nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Selezionare la categoria Regole definite dall'utente nel riquadro di sinistra, quindi selezionare la regola che si desidera eliminare nel riquadro di destra.
  5. Fare clic su Elimina.
    Nota: Per disattivare una regola senza eliminarla, deselezionare le azioni Blocca e Segnala. Se necessario, è possibile attivare di nuovo la regola.


Console di VirusScan

Dalle proprietà di Protezione all'accesso, rimuovere le regole create che non si utilizzano più.

Rimuovere le regole predefinite dall'utente utilizzando una di queste console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? o su Guida in linea nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Protezione all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Selezionare la categoria Regole definite dall'utente nel riquadro di sinistra, quindi selezionare la regola che si desidera eliminare nel riquadro di destra.
  3. Fare clic su Elimina.
    Nota: Per disattivare una regola senza eliminarla, deselezionare le azioni Blocca e Segnala. Se necessario, è possibile attivare di nuovo la regola.


Blocco degli exploit da overflow del buffer

La protezione da overflow del buffer impedisce l'utilizzo degli overflow del buffer per eseguire codice arbitrario sul computer dell'utente. La funzione controlla le chiamate all'API della modalità utente e riconosce se sono il risultato di un overflow del buffer.

Se le opzioni sono state configurate a tale scopo, a ogni rilevamento le informazioni vengono inserite nel registro delle attività e visualizzate nella finestra di dialogo Messaggi della scansione all'accesso.

VirusScan Enterprise utilizza un file DAT sovraccarico del buffer e protezione all'accesso per proteggere circa 30 applicazioni, tra cui Internet Explorer, Microsoft Outlook, Outlook Express, Microsoft Word e MSN Messenger.

Sommario

Concetti correlati
Come si verifica l'exploit da overflow del buffer
Attività correlate
Configurazione della protezione contro l'overflow del buffer


Come si verifica l'exploit da overflow del buffer

Gli hacker sfruttano l'overflow del buffer per avviare codice eseguibile tramite l'overflow dei buffer di memoria di dimensioni fisse per un processo di input. Tale codice consente all'hacker di assumere il controllo del computer bersaglio o di comprometterne i dati.

Esistono due tipologie di exploit da overflow del buffer:
  • Attacchi basati su heap - Occupano lo spazio di memoria riservato a un programma, ma sono rari e difficili da rimuovere.
  • Attacchi basati su stack - Utilizzano gli oggetti della memoria stack per memorizzare l'input dell'utente e sono i più comuni.
Di seguito viene fornita una descrizione degli attacchi tramite overfllow del buffer basati su stack:
  1. Processo della memoria stack in condizioni normali - L'oggetto della memoria stack di dimensioni fisse è in genere vuoto e in attesa dell'input dell'utente. Quando un programma riceve l'input dell'utente, ad esempio viene immesso il nome, i dati vengono memorizzati nella parte superiore dello stack e viene loro assegnato un indirizzo di memoria di restituzione. Quando lo stack viene elaborato, l'input dell'utente viene inviato all'indirizzo di restituzione specificato dal programma.
  2. Overflow dello stack - Quando il programma viene compilato, una quantità di spazio di memoria specifica viene riservato ai dati. Gli overflow dello stack si verificano se la quantità di dati scritti supera lo spazio a essi riservato nello stack della memoria. Questo rappresenta un problema solo quando è presente un input pericoloso.
  3. Exploit dell'overflow - Se il programma è in attesa dell'immissione del nome da parte di un utente, ma l'hacker digita un comando eseguibile che supera la dimensione dello stack, tale comando viene salvato al di fuori dello spazio riservato.
  4. Esecuzione di codice dannoso - Il comando non viene eseguito automaticamente solo perché supera la quantità di spazio disponibile nel buffer dello stack. Tuttavia, potrebbe esserlo se esiste un indirizzo di restituzione che punta al comando dannoso fornito dall'hacker. Prima il programma inizia ad arrestarsi in modo anomalo a causa dell'overflow del buffer tentando comunque di utilizzare l'indirizzo di restituzione fornito dall'hacker. Se l'indirizzo di restituzione è un indirizzo valido, il comando dannoso viene eseguito.
  5. Exploit delle autorizzazioni - Poiché i programmi vengono in genere eseguiti in modalità kernel o con autorizzazioni ereditate da un account di servizio, il codice dannoso viene eseguito con le stesse autorizzazioni associate all'applicazione compromessa. Questo significa che l'hacker può ottenere controllo completo sul sistema operativo.


Configurazione della protezione contro l'overflow del buffer

La configurazione dei criteri di protezione contro l'overflow del buffer impedisce alle applicazioni di eseguire codici arbitrari nel computer.

È possibile configurare i criteri di protezione contro l'overflow del buffer utilizzando le seguenti console dell'interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Configurare i criteri di protezione contro l'overflow del buffer utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella pagina Criteri di protezione da sovraccarico del buffer, fare clic sulla scheda Protezione dall'overflow del buffer, quindi configurare le seguenti voci:
    1. Attivare Impostazioni sovraccarico del buffer e la modalità di protezione da utilizzare. Configurare la modalità di protezione per bloccare l'exploit o semplicemente per inviare un messaggio e registrare l'evento.
    2. Attivare gli avvisi al sistema client che devono essere inviati quando si verificano gli exploit da overflow del buffer.
    3. Configurare Esclusioni per overflow del buffer per i valori specifici dell'API (Application Programming Interface) oltre ai processi opzionali e ai nomi di moduli da escludere.
  5. Fare clic sulla scheda Rapporti, attivare i file di registro dell'attività di scansione, quindi specificare la posizione in cui devono essere memorizzati, la dimensione e il formato.
    Nota: Questi file di registro sono molto utili quando vengono rilevate minacce alla sicurezza e consentono di determinare le azioni da intraprendere per combatterle.


ePolicy Orchestrator 4.0

Configurare i criteri di protezione contro l'overflow del buffer utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella pagina Criteri di protezione da sovraccarico del buffer, fare clic sulla scheda Protezione dall'overflow del buffer, quindi configurare le seguenti voci:
    1. Attivare Impostazioni sovraccarico del buffer e la modalità di protezione da utilizzare. Configurare la modalità di protezione per bloccare l'exploit o semplicemente per inviare un messaggio e registrare l'evento.
    2. Attivare gli avvisi al sistema client che devono essere inviati quando si verificano gli exploit da overflow del buffer.
    3. Configurare Esclusioni per overflow del buffer per i valori specifici dell'API (Application Programming Interface) oltre ai processi opzionali e ai nomi di moduli da escludere.
  5. Fare clic sulla scheda Rapporti, attivare i file di registro dell'attività di scansione, quindi specificare la posizione in cui devono essere memorizzati, la dimensione e il formato.
    Nota: Questi file di registro sono molto utili quando vengono rilevate minacce alla sicurezza e consentono di determinare le azioni da intraprendere per combatterle.


Console di VirusScan

Configurare i criteri di protezione contro l'overflow del buffer utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco delle attività, fare clic con il pulsante destro del mouse su Protezione dall'overflow del buffer, quindi su Proprietà per visualizzare la finestra di dialogo.
  2. Nella pagina Criteri di protezione da sovraccarico del buffer, fare clic sulla scheda Protezione dall'overflow del buffer, quindi configurare le seguenti voci:
    1. Attivare Impostazioni sovraccarico del buffer e la modalità di protezione da utilizzare. Configurare la modalità di protezione per bloccare l'exploit o semplicemente per inviare un messaggio e registrare l'evento.
    2. Attivare gli avvisi al sistema client che devono essere inviati quando si verificano gli exploit da overflow del buffer.
    3. Configurare Esclusioni per overflow del buffer per i valori specifici dell'API (Application Programming Interface) oltre ai processi opzionali e ai nomi di moduli da escludere.
  3. Fare clic sulla scheda Rapporti, attivare i file di registro dell'attività di scansione, quindi specificare la posizione in cui devono essere memorizzati, la dimensione e il formato.
    Nota: Questi file di registro sono molto utili quando vengono rilevate minacce alla sicurezza e consentono di determinare le azioni da intraprendere per combatterle.


Restrizione di programmi potenzialmente indesiderati

VirusScan Enterprise protegge il computer da programmi potenzialmente indesiderati che possono rivelarsi nocivi o costituire una minaccia alla protezione. Un unico criterio comune per i programmi indesiderati è già configurato, ma è possibile attivare o disattivare individualmente il criterio e specificare azioni per ognuno degli scanner di VirusScan Enterprise.

I programmi potenzialmente indesiderati (PUP) sono definiti come prodotti software che, benché scritti da società legittime, sono in grado di alterare lo stato di protezione o i criteri di riservatezza del computer in cui vengono installati. Questi programmi software potrebbero includere spyware, adware e dialer ed è possibile che l'utente li scarichi insieme a un programma desiderato. Gli utenti che prestano particolare attenzione alla protezione riconoscono questi programmi e in alcuni casi preferiscono rimuoverli.


Configurazione dei programmi indesiderati

Per proteggere il computer da programmi potenzialmente indesiderati, è necessario configurare le categorie di programmi indesiderati da rilevare nell'ambiente.

La configurazione prevede due passaggi:

  1. Configurare il Criterio per programmi indesiderati per definire i programmi potenzialmente indesiderati da rilevare e da escludere:
    • Selezionare intere categorie di programmi o programmi specifici all'interno di una categoria da un elenco predefinito contenuto nel file DAT in uso.
    • Consente di specificare le esclusioni.
    • Creare un elenco di programmi definiti dall'utente da rilevare.

  2. Attivare il rilevamento dei programmi indesiderati nelle scansioni all'accesso, su richiesta e della posta elettronica e quindi configurare le azioni da intraprendere quando viene rilevato un programma indesiderato.

Nota: Il rilevamento dei programmi indesiderati viene attivato per lo scanner su richiesta in maniera differente, dato che la scansione su richiesta è un'attività e non un criterio. Consultare Configurazione delle attività di scansione su richiesta per i dettagli.

Attività

Attività correlate
Accesso ai criteri di gestione dei programmi indesiderati
Attivazione del rilevamento dei programmi indesiderati negli scanner all'accesso e della posta elettronica


Accesso ai criteri di gestione dei programmi indesiderati

Configurare i criteri di gestione dei programmi indesiderati selezionando le categorie dei programmi indesiderati da rilevare. Ad esempio, spyware e adware. È anche possibile specificare esclusioni di programmi da non rilevare.

Accedere ai Criteri di gestione dei programmi indesiderati utilizzando le seguenti console dell'interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Configurare il Criterio per programmi indesiderati utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criterio per programmi indesiderati, fare clic sulla scheda Scansione elementi per configurare:
    1. Categorie dei programmi indesiderati da rilevare — Ad esempio, spyware e adware. Le categorie sono definite nel file DAT corrente.
    2. Esclusioni — È necessario specificare il nome esatto del rilevamento che si desidera escludere, non il nome file.
  5. Fare clic sulla scheda Rilevamenti definiti dall'utente e specificare i singoli file da considerare come programmi indesiderati. Specificare ciascun elemento in base al nome file e fornire una descrizione per ciascuno di essi.


ePolicy Orchestrator 4.0

Configurare il Criterio per programmi indesiderati utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criterio per programmi indesiderati, fare clic sulla scheda Scansione elementi per configurare:
    1. Categorie dei programmi indesiderati da rilevare — Ad esempio, spyware e adware. Le categorie sono definite nel file DAT corrente.
    2. Esclusioni — È necessario specificare il nome esatto del rilevamento che si desidera escludere, non il nome file.
  5. Fare clic sulla scheda Rilevamenti definiti dall'utente e specificare i singoli file da considerare come programmi indesiderati. Specificare ciascun elemento in base al nome file e fornire una descrizione per ciascuno di essi.


Console di VirusScan

Configurare le proprietà dei programmi indesiderati utilizzando questa console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Criterio per programmi indesiderati, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Dalla pagina Criterio per programmi indesiderati, fare clic sulla scheda Scansione elementi per configurare:
    1. Categorie dei programmi indesiderati da rilevare — Ad esempio, spyware e adware. Le categorie sono definite nel file DAT corrente.
    2. Esclusioni — È necessario specificare il nome esatto del rilevamento che si desidera escludere, non il nome file.
  3. Fare clic sulla scheda Rilevamenti definiti dall'utente e specificare i singoli file da considerare come programmi indesiderati. Specificare ciascun elemento in base al nome file e fornire una descrizione per ciascuno di essi.


Attivazione del rilevamento dei programmi indesiderati negli scanner all'accesso e della posta elettronica

Per consentire agli scanner all'accesso e della posta elettronica di rilevare i programmi indesiderati, è necessario attivare la funzione dalla scheda Scansione elementi.

Attivare gli scanner all'accesso e della posta elettronica per rilevare i programmi indesiderati utilizzando le seguenti console di interfaccia utente.
Nota: Per consentire allo scanner su richiesta di rilevare i programmi indesiderati, fare riferimento a Configurazione delle attività di scansione su richiesta.


ePolicy Orchestrator 4.5 o 4.6

Attivare gli scanner all'accesso e della posta elettronica per rilevare i programmi indesiderati utilizzando la console ePolicy Orchestrator 4.5 o 4.6.

Il processo utilizzato per attivare il rilevamento dei programmi indesiderati da parte degli scanner all'accesso e della posta elettronica è essenzialmente lo stesso. L'unica differenza è il criterio che si seleziona nel catalogo dei criteri al passo 2. Per attivare il rilevamento dei programmi indesiderati per:
  • Scansione all'accesso — Selezionare Criteri di scansione all'accesso.
  • Scansione della posta elettronica — Selezionare Criteri di scansione della posta elettronica alla consegna.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri di scansione all'accesso o Criteri di scansione della posta elettronica alla consegna, fare clic sulla scheda Scansione elementi e selezionare Rileva programmi indesiderati.


ePolicy Orchestrator 4.0

Attivare gli scanner all'accesso e della posta elettronica per rilevare i programmi indesiderati utilizzando la console ePolicy Orchestrator 4.0.

Il processo utilizzato per attivare il rilevamento dei programmi indesiderati da parte degli scanner all'accesso e della posta elettronica è essenzialmente lo stesso. L'unica differenza è il criterio che si seleziona nel catalogo dei criteri al passo 2. Per attivare il rilevamento dei programmi indesiderati per:
  • Scansione all'accesso — Selezionare Criteri di scansione all'accesso.
  • Scansione della posta elettronica — Selezionare Criteri di scansione della posta elettronica alla consegna.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri di scansione all'accesso o Criteri di scansione della posta elettronica alla consegna, fare clic sulla scheda Scansione elementi e selezionare Rileva programmi indesiderati.


Console di VirusScan

Attivare gli scanner all'accesso e della posta elettronica per rilevare i programmi indesiderati utilizzando la Console di VirusScan.

Il processo utilizzato per attivare il rilevamento dei programmi indesiderati da parte degli scanner all'accesso e della posta elettronica è essenzialmente lo stesso. L'unica differenza è l'attività che si seleziona nel Console di VirusScan al passo 2. Per attivare il rilevamento dei programmi indesiderati per:
  • Scansione all'accesso — Selezionare Criteri di scansione all'accesso.
  • Scansione della posta elettronica — Selezionare Scansione della posta elettronica alla consegna.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Proprietà, per aprire la finestra di dialogo.
    • Criteri di scansione all'accesso — Per la scansione all'accesso.
    • Scansione della posta elettronica alla consegna — Per la scansione della posta elettronica.
  2. Dalla pagina Criteri di scansione all'accesso o Criteri di scansione della posta elettronica alla consegna, fare clic sulla scheda Scansione elementi e selezionare Rileva programmi indesiderati.


Aggiornamento delle definizioni dei rilevamenti

Per identificare le minacce e intraprendere le azioni necessarie a rimuoverle, il software di VirusScan Enterprise dipende dal motore di scansione e dalle informazioni contenute nei file di definizione dei rilevamenti (DAT). Nuove minacce vengono scoperte continuamente. Per far fronte a questa sfida, McAfee rilascia nuovi file DAT ogni giorno, incorporando i risultati della propria ricerca continuativa. L'attività di aggiornamento recupera i file DAT più recenti dal sito di aggiornamento McAfee esterno e ne esegue l'installazione.
Nota: Un ambiente gestito di ePolicy Orchestrator è inoltre in grado di recuperare i file DAT più recenti, il file EXTRA.DAT, il motore di scansione, i service pack e le patch.

Sommario

Concetti correlati
I file DAT e il loro funzionamento
Importanza della strategia di aggiornamento
Attività di aggiornamento e relativo funzionamento
Attività di mirror e relativa modalità di funzionamento
Funzionamento dell'archivio di AutoUpdate
Modalità di funzionamento del ripristino di file DAT


I file DAT e il loro funzionamento

La ricerca delle minacce tra i file effettuata dal motore di scansione avviene sulla base del confronto del contenuto dei file sottoposti a scansione con le informazioni di minacce note memorizzate nei file DAT (file di definizione del rilevamento). Le informazioni sulle minacce note, definite firme, sono le informazioni che McAfee Labs ha trovato e aggiunto ai file DAT.

Oltre alle firme, i file DAT contengono informazioni su come pulire i danni creati dai virus rilevati e sulle contromisure da intraprendere. Ecco perché è così importante scaricare la versione più recente del file DAT utilizzato da VirusScan Enterprise.
ATTENZIONE:
Se la firma di un determinato virus non è contenuta in alcun file DAT installato sul sistema in uso, il virus non verrà rilevato dal motore di scansione. Inoltre, il motore di scansione deve essere sempre aggiornato all'ultima versione disponibile per poter utilizzare tutti i file DAT più recenti.

VirusScan Enterprise utilizza anche una tecnologia di rilevamento euristico, denominata Artemis, per rilevare file sospetti parallelamente ai file DAT. Per ulteriori informazioni, consultare Funzionamento di Artemis.

I vari file DAT vengono memorizzati al seguente percorso:

\Programmi\File comuni\McAfee\Engine


Importanza della strategia di aggiornamento

La strategia di aggiornamento è un aspetto di cui occorre sottolineare l'importanza. Il sistema non è completamente protetto dagli ultimi virus, senza il motore di scansione e i file DAT più aggiornati. Negli ultimi tempi, si è verificato un aumento senza precedenti del numero, della velocità di propagazione e della prevalenza di nuovi malware. Inoltre, la crescente quantità di adware e spyware richiede una maggiore consistenza e disponibilità delle attività di rilevamento e rimozione.

McAfee Labs rilascia gli aggiornamenti dei file DAT quasi ogni giorno alle 18:00 (GMT) circa. Naturalmente, le infezioni possono sempre verificarsi in qualsiasi momento, richiedendo rilasci di emergenza. Se un DAT giornaliero viene rilasciato in anticipo, per prevenire una potenziale infezione, nello stesso giorno non viene rilasciato un secondo DAT all'ora pianificata, a meno che non si verifichi una situazione di emergenza che ne richieda uno.


Determinazione di una strategia di aggiornamento

È possibile aggiornare i file DAT e il motore di scansione utilizzati da VirusScan Enterprise in diversi modi. È possibile utilizzare attività di aggiornamento automatico, aggiornamenti manuali, script di accesso oppure aggiornamenti pianificati con strumenti di gestione.

L'utilizzo di un'attività di aggiornamento consente di:

  • Pianificare la distribuzione dei file DAT in tutta la rete - È possibile distribuire nel tempo le attività di aggiornamento oppure impostare una pianificazione graduale e regolare degli aggiornamenti dei file DAT nelle diverse parti della rete con scadenze comode e un intervento minimo da parte di amministratori o utenti di rete.
  • Suddividere le mansioni amministrative di distribuzione - Per aumentare l'efficienza della larghezza di banda, utilizzare server o controller di dominio differenti, tra diverse zone della rete WAN (Wide Area Network) o in base ad altre suddivisioni della rete per mantenere il traffico di aggiornamento prevalentemente all'interno di quest'ultima. In questo modo è inoltre possibile ridurre le probabilità di violazione della protezione della rete.
  • Ridurre il tempo di attesa necessari per scaricare nuovi file DAT o file di aggiornamento del motore - Il traffico nei computer McAfee cresce significativamente nelle date preposte alla pubblicazione dei file DAT e in occasione dei rilasci di nuove versioni dei prodotti. La possibilità di evitare l'utilizzo concorrenziale della larghezza di banda della rete consente di distribuire il nuovo software con interruzioni minime dell'attività.


Requisiti per una strategia di aggiornamento efficace

Una strategia di aggiornamento efficiente richiede in genere che almeno un client o un server dell'organizzazione recuperi gli aggiornamenti dal sito di download di McAfee. Una volta eseguita questa operazione, i file possono essere replicati in tutta l'organizzazione in modo da renderli accessibili a tutti gli altri computer. È preferibile ridurre al minimo la quantità di dati trasferiti in rete automatizzando il processo di copia dei file aggiornati nei siti condivisi.

I fattori principali da considerare per l'esecuzione di aggiornamenti efficienti sono il numero di client e il numero di siti. È anche possibile prendere in considerazione il numero di sistemi presenti in ciascun sito remoto e le modalità di accesso a Internet dei siti remoti. I concetti fondamentali dell'utilizzo di un archivio centrale per il recupero di aggiornamenti e per la pianificazione di attività di aggiornamento allo scopo di mantenere aggiornato il proprio ambiente si applicano a organizzazioni di qualsiasi dimensione. Per informazioni sulla distribuzione del software e sull'aggiornamento, consultare la guida prodotto ePolicy Orchestrator appropriata.


Attività di aggiornamento e relativo funzionamento

L'attività di aggiornamento consente di ottenere i file DAT, il motore di scansione, i service pack e le patch più recenti.

VirusScan Enterprise prevede un aggiornamento predefinito che viene eseguito ogni giorno alle 17.00, con un'ora di intervallo per l'esecuzione casuale. È possibile creare attività di aggiornamento aggiuntive, come necessario.

Attività di aggiornamento

Durante un'attività di aggiornamento vengono eseguite le operazioni indicate di seguito:

  • Viene effettuata una connessione al primo archivio (sito di aggiornamento) abilitato presente nell'elenco degli archivi. Se l'archivio non è disponibile, viene contattato il sito successivo e così via fino a quando viene effettuata una connessione o fino alla fine dell'elenco.
  • Dall'archivio viene scaricato un file CATALOG.Z crittografato, contenente i dati fondamentali necessari per l'aggiornamento. Tali dati vengono utilizzati per determinare i file e gli aggiornamenti disponibili.
  • Le versioni del software contenute nel file vengono confrontate con quelle presenti nel computer e, se disponibili, vengono scaricati i nuovi aggiornamenti software.

Interruzione dell'attività di aggiornamento

Se l'attività di aggiornamento viene interrotta durante l'esecuzione, si verificherà quanto segue:

  • Se l'aggiornamento viene eseguito da un sito HTTP, UNC o locale, all'avvio successivo la scansione verrà ripresa dal punto in cui era stata sospesa.
  • Se l'aggiornamento viene eseguito da un sito FTP, l'attività non verrà ripresa se l'interruzione si è verificata durante lo scaricamento di un singolo file. Tuttavia, in caso di interruzione durante lo scaricamento di più file, l'attività riprende prima del file in fase di scaricamento al momento dell'interruzione.

Aggiornamento mediante EXTRA.DAT

È possibile utilizzare un file EXTRA.DAT come misura momentanea in una situazione di emergenza. Il file EXTRA.DAT viene scaricato dall'archivio a ogni aggiornamento. Ciò assicura che se si modifica e si archivia nuovamente il file EXTRA.DAT come parte di un pacchetto, tutti i client VirusScan Enterprise scaricheranno e utilizzeranno lo stesso pacchetto EXTRA.DAT aggiornato. Ad esempio, è possibile utilizzare il file EXTRA.DAT come rilevatore avanzato per lo stesso programma potenzialmente indesiderato o come rilevamento aggiuntivo per altri nuovi programmi potenzialmente indesiderati. VirusScan Enterprise supporta l'utilizzo di un solo file EXTRA.DAT.

Suggerimento: Al termine dell'utilizzo del file EXTRA.DAT, è opportuno eliminarlo dall'archivio principale ed eseguire un'attività di replica per assicurarsi che sia stato rimosso da tutti i siti di archivio distribuiti. In tal modo si evita che i client VirusScan Enterprise tentino di scaricare il file EXTRA.DAT durante un aggiornamento. Per impostazione predefinita, il rilevamento di un nuovo programma potenzialmente indesiderato nel file EXTRA.DAT viene ignorato una volta aggiunta la nuova definizione di rilevamento ai file DAT giornalieri.


Configurazione dell'attività di AutoUpdate

Per aggiornare automaticamente i file DAT e i motori di scansione per tutti i prodotti McAfee, è necessario configurare le proprietà e la pianificazione di AutoUpdate.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? o Guida in linea sulla scheda.

  1. Per accedere alle proprietà di AutoUpdate, utilizzare:

    • ePolicy Orchestrator 4.5 o 4.6 — Fare clic su Menu | Sistemi | Struttura del sistema e selezionare Attività client.
      Nota: Per istruzioni dettagliate sulla creazione di una nuova attività client pianificata, fare riferimento alla Guida di Prodotto McAfee ePolicy Orchestrator 4.5.
    • ePolicy Orchestrator 4.0 — Fare clic su Sistemi | Struttura del sistema | Attività client e selezionare un'attività di aggiornamento esistente oppure, per creare una nuova attività, fare clic su Nuova attività.
      Nota: Per istruzioni dettagliate sulla creazione di una nuova attività client pianificata, fare riferimento alla Guida di Prodotto McAfee ePolicy Orchestrator 4.0.
    • Console di VirusScan — Selezionare un'attività di aggiornamento esistente (fare clic con il pulsante destro del mouse e selezionare Proprietà) oppure creare una nuova attività (selezionare Attività | Nuova attività di aggiornamento, selezionare la nuova attività nell'elenco).
      Suggerimento: Quando si crea una nuova attività client, si consiglia di ridenominare l'attività con un nome descrittivo.
  2. Consente di indicare il percorso e il formato del file di registro.
  3. Consente di configurare la possibilità di ottenere nuovi DAT, le versioni più recenti del motore e altri aggiornamenti disponibili, quali i service pack e gli aggiornamenti del prodotto.
  4. Consente di indicare il file eseguibile da eseguire al termine dell'attività di aggiornamento e se eseguirlo solo dopo un’operazione di aggiornamento riuscita.
  5. Fare clic su Pianifica per configurare il momento e la modalità di avvio dell'attività. Per i dettagli, fare riferimento a Utilizzo delle attività pianificate.
  6. Fare clic su Aggiorna ora, l'attività viene eseguita immediatamente.


Attività di mirror e relativa modalità di funzionamento

L'attività di mirror consente di replicare su un sito di mirror della rete i file di aggiornamento contenuti nel primo archivio accessibile definito nell'elenco degli archivi. L'utilizzo più comune di questa attività è l'esecuzione del mirror dei contenuti del sito di download di McAfee in un server locale.

Dopo aver replicato il sito McAfee che contiene i file di aggiornamento, i computer della rete possono scaricare i file dal sito di mirror. Questo approccio risulta pratico poiché consente di aggiornare qualsiasi computer della rete, sia che disponga o meno dell'accesso a Internet, ed efficiente in quanto i sistemi comunicano con il server che è probabilmente più vicino rispetto al sito Internet di McAfee, consentendo una riduzione dei tempi di accesso e di download.

Il software VirusScan Enterprise utilizza una struttura di directory per il suo aggiornamento. Quando si esegue il mirror di un sito, è importante replicare l'intera struttura della directory.
Nota: Questa struttura di directory supporta inoltre versioni precedenti di VirusScan Enterprise e NetShield, a condizione che l'intera struttura di directory sia replicata negli stessi percorsi utilizzati da VirusScan Enterprise 8.8 per l'aggiornamento.


Configurazione dell'attività di mirror

Per memorizzare i file DAT e i motori di scansione in un percorso specificato per l'utilizzo da parte di altri computer, configurare il percorso e pianificare l'utilizzo delle proprietà dell'attività di mirror.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? o Guida in linea sulla scheda.

  1. Per accedere alle proprietà dell'attività di Mirror, utilizzare:

    • ePolicy Orchestrator 4.5 o 4.6 — Fare clic su Menu | Sistemi | Struttura del sistema e selezionare Attività client.
      Nota: Per istruzioni dettagliate sulla creazione di una nuova attività client pianificata, fare riferimento alla Guida di Prodotto McAfee ePolicy Orchestrator 4.5.
    • ePolicy Orchestrator 4.0 — Fare clic su Sistemi | Struttura del sistema | Attività client e selezionare un'attività di aggiornamento esistente oppure, per creare una nuova attività, fare clic su Nuova attività.
      Nota: Per istruzioni dettagliate sulla creazione di una nuova attività client pianificata, fare riferimento alla Guida di Prodotto McAfee ePolicy Orchestrator 4,0.
    • Console di VirusScan, eseguire una delle seguenti operazioni:
      • Selezionare un'attività di mirror esistente, fare clic sul pulsante destro del mouse e selezionare Proprietà. Viene visualizzata la finestra di dialogo Attività mirror.
      • Per creare una nuova attività di mirror, selezionare Attività | Nuova attività di mirror. Viene visualizzata una Nuova attività di aggiornamento nell'elenco Attività. Fare clic sulla nuova attività per aprire la finestra di dialogo Attività di mirror.
        Nota: Modificare il nome dell'attività utilizzandone uno più descrittivo, facendo clic con il pulsante destro del mouse sull'attività e selezionando Rinomina.
  2. Console di VirusScan — Selezionare un'attività di aggiornamento esistente (fare clic con il pulsante destro del mouse e selezionare Proprietà) oppure creare una nuova attività (selezionare Attività | Nuova attività di mirror, selezionare la nuova attività nell'elenco).
    Suggerimento: Quando si crea una nuova attività client, si consiglia di rinominare l'attività con un nome descrittivo.
  3. Consente di indicare il percorso e il formato del file di registro.
  4. Consente di configurare la possibilità di ottenere nuove definizioni di rilevamento, le versioni più recenti del motore e dei file DAT e altri aggiornamenti disponibili, quali i Service Pack e gli aggiornamenti del prodotto.
  5. Consente di indicare il file eseguibile da eseguire al termine dell'attività di aggiornamento e se eseguirlo solo dopo un’operazione di aggiornamento riuscita.
  6. Fare clic su Percorso mirror per configurare la destinazione del server di mirror.
  7. Fare clic su Pianifica per configurare il momento e la modalità di avvio dell'attività. Per i dettagli, fare riferimento a Utilizzo delle attività pianificate.
  8. Fare clic su Esegui mirror ora per avviare l'attività immediatamente.
  9. Configurare le opzioni nella scheda. Per ottenere le definizioni delle opzioni, fare clic su ? o Guida in linea sulla scheda.

Definizioni delle schede

Scheda Definizioni
Mirror
  • Consente di indicare il percorso e il formato del file di registro.
  • Consente di indicare il file eseguibile da eseguire al termine dell'attività di mirror e se eseguirlo solo dopo un’operazione di mirror riuscita.


Funzionamento dell'archivio di AutoUpdate

Nell'elenco degli archivi di AutoUpdate (SITELIST.xml) sono specificate le informazioni di configurazione necessarie per l'esecuzione di un'attività di AutoUpdate.

L'elenco degli archivi AutoUpdate include:
  • Informazioni sugli archivi e relativi percorsi
  • Preferenza dell'ordine degli archivi
  • Impostazioni del proxy, se richieste
  • Credenziali crittografate necessarie per accedere a ciascun archivio

Quando si esegue un'attività di AutoUpdate, viene effettuata una connessione al primo archivio abilitato (sito di aggiornamento) presente nell'elenco degli archivi. Se l'archivio non è disponibile, viene contattato l'archivio successivo e così via fino a quando viene effettuata una connessione o fino alla fine dell'elenco.

Se la rete utilizza un server proxy, è possibile specificare le impostazioni del proxy da utilizzare, l'indirizzo del server proxy e determinare se utilizzare o meno l'autenticazione. Le informazioni relative al proxy vengono memorizzate nell'elenco degli archivi di AutoUpdate. Le impostazioni del proxy configurate si applicano a tutti gli archivi presenti nell'elenco.

La posizione dell'elenco dell'archivio di AutoUpdate dipende dal sistema operativo.
  • Per Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server e Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework
  • Per Microsoft Windows 7 — C:\ProgramData\McAfee\Common Framework


Configurazione dell'elenco degli archivi

L'elenco degli archivi comprende gli archivi da cui recuperare gli aggiornamenti. Creare e configurare tutti gli archivi necessari. Alcuni siti possono essere utilizzati in qualsiasi momento, altri vengono utilizzati solo occasionalmente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dalla Console di VirusScan, selezionare Strumenti | Modifica elenco archivi AutoUpdate per accedere alle proprietà di Elenco archivi AutoUpdate.
    Nota: Per configurare la funzione di archiviazione utilizzando la console ePolicy Orchestrator, andare a Catalogo criteri | McAfee Agent e fare clic sulla scheda Archivi.
  2. Configurare le opzioni nelle schede.

Definizioni delle schede

Scheda | Definizioni
Archivi
  • Specificare gli archivi da cui ottenere gli aggiornamenti.
  • Configurare l'ordine di accesso agli archivi.
Impostazioni proxy | Consente di specificare le impostazioni proxy da utilizzare durante l'aggiornamento.


Modalità di funzionamento del ripristino di file DAT

Se i file DAT correnti sono danneggiati o incompatibili, è possibile ripristinare l'ultima versione di backup dei file DAT.

Quando si aggiornano i file DAT, la versione precedente dei file viene memorizzata in questo percorso: <unità>:\Programmi\File comuni\McAfee\Engine\OldDats.

Quando si ripristinano i file DAT, i file DAT correnti vengono sostituiti con la versione contenuta nella cartella OldDats e nel registro viene inserito un codice nel percorso: HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS.

Una volta eseguito il ripristino, non è possibile ritornare alla versione precedente. Al successivo aggiornamento, la versione del file DAT presente nel registro viene confrontata con i file DAT dell'archivio di aggiornamento. Se i nuovi file DAT sono uguali a quelli del registro, non ha luogo alcun aggiornamento.


Ripristino dei file DAT

Per riportare i file DAT alla versione precedente, utilizzare lo strumento Ripristino DAT.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dalla Console di VirusScan, selezionare Strumenti | Ripristino DAT.
  2. Fare clic su Sì per procedere con il ripristino dei file DAT.
    Nota: Questa funzione non è disponibile nella console di ePolicy Orchestrator.
  3. Configurare le opzioni nella scheda.


Esclusione di elementi dalla scansione

Ogni scanner di VirusScan Enterprise consente di configurare in modo dettagliato l'elenco dei tipi di file da sottoporre a scansione. Ad esempio, è possibile escludere dalla scansione singoli file, cartelle e dischi. Tali esclusioni potrebbero essere necessarie in quanto gli scanner potrebbero eseguire la scansione di un file e bloccarlo quando tale file è in uso da parte di un server di database. Ciò potrebbe causare errori del database o del server.

Sommario

Riferimenti correlati
Specificazione delle esclusioni
Utilizzo di caratteri jolly per specificare gli elementi da sottoporre a scansione


Specificazione delle esclusioni

È possibile specificare i file, le cartelle e le unità da escludere dalla scansione, nonché di rimuovere le esclusioni specificate in precedenza.

Definizioni delle opzioni

Opzioni Definizione
Elementi da escludere Selezionare il tipo di esclusione.
  • Escludi in base al nome/percorso file — Specificare il nome file, il percorso e se escludere le sottocartelle.
    Nota: È necessario aggiungere una barrae rovesciata (\) alla fine della stringa per applicare l'esclusione alla cartella. In caso contrario, viene considerata come un'esclusione del file e la casella di controllo Escludi anche le sottocartelle è disattivata per impostazione predefinita.
  • Escludi in base al tipo di file — Specificare uno o più tipi di file.
  • Escludi in base alla data del file — Specificare il tipo di accesso e il numero minimo di giorni dalla creazione del file.
Quando escludere Scegliere quando escludere l'elemento selezionato:
  • Lettura
  • Scrittura
Modalità di gestione delle esclusioni client Sovrascrivi esclusioni client — Consente di escludere soltanto gli elementi specificati in questo criterio. Se questa opzione non è selezionata, i computer client utilizzano le esclusioni specificate localmente insieme alle esclusioni specificate in questo criterio.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.


Utilizzo di caratteri jolly per specificare gli elementi da sottoporre a scansione

È possibile utilizzare i caratteri jolly per escludere tipi di file in base all'estensione.

Quando si utilizzano caratteri jolly, verranno applicate le seguenti limitazioni.

  • I caratteri jolly validi sono il punto interrogativo (?) per sostituire singoli caratteri e l'asterisco (*) per sostituire più caratteri.
  • Nei percorsi, i caratteri jolly possono essere utilizzati prima di una barra rovesciata (\). Ad esempio: se si specifica il percorso C:\ABC\*\XYZ è possibile includere o escludere il percorso C:\ABC\DEF\XYZ.
  • Un'esclusione contenente punti interrogativi (?) verrà applicata se il numero di caratteri corrisponde alla lunghezza del nome del file o della cartella. Ad esempio: l'esclusione W?? escluderà WWW ma non WW o WWWW.
  • La sintassi è estesa in modo da includere un doppio asterisco (**), che corrisponde a zero o più caratteri qualsiasi, inclusa la barra rovesciata. Ciò consente di utilizzare esclusioni a più livelli di profondità. Ad esempio: se si specifica C:\ABC\**\XYZ è possibile includere o escludere i percorsi C:\ABC\DEF\XYZ, C:\ABC\DEF\DEF\XYZ e così via.


Utilizzo di attività pianificate

Come parte della configurazione della scansione su richiesta, AutoUpdate, o attività di mirror, è necessario specificare il momento, la frequenza e la durata di esecuzione delle attività. È inoltre necessario configurare le autorizzazioni dell'utente durante il processo di configurazione.

Sommario

Riferimenti correlati
Configurazione del piano delle attività
Informazioni correlate
Pianificazione delle attività


Pianificazione delle attività

È possibile pianificare le attività su richiesta, di aggiornamento automatico e di mirror in modo tale che l'esecuzione avvenga in una determinata data e ora oppure a intervalli specifici. La modalità di pianificazione delle attività dipende dalla console di interfaccia utente utilizzata.

Per pianificare le attività:
  • Console ePolicy Orchestrator — Utilizzare la scheda Pianifica per visualizzare la pagina Pianifica.
  • Console di VirusScan — Utilizzare il pulsante Pianifica per visualizzare la finestra di dialogo Pianifica.
Attività correlate
Configurazione di attività di scansione su richiesta
Riferimenti correlati
Configurazione dell'attività di AutoUpdate
Configurazione dell'attività di mirror
Informazioni correlate
Configurazione delle attività del server di ePolicy Orchestrator


Configurazione del piano delle attività

Per configurare un'attività da eseguire a un'ora o intervallo specifico, utilizzare la finestra di dialogo Impostazioni di pianificazione.

Informazioni preliminari

Per pianificare l'attività è necessario disporre dei privilegi di amministratore. Tali privilegi consentono all'utente di accedere in scrittura alla chiave del registro delle attività pianificate.

Per pianificare un'attività, fare clic sul pulsante Pianificazione nella finestra di dialogo delle proprietà dell'attività.

ATTENZIONE:
McAfee consiglia di pianificare le scansioni su richiesta a intervalli minimi.
Intervalli minimi consigliati di McAfee:
  • Quotidiana — Solo se si è verificata un'infezione da malware significativa.
  • Ogni settimana — Consigliata.
  • Ogni mese — Accettabile.
  • Trimestrale — Il minimo.

Definizioni delle schede

Scheda Definizioni
Attività
  • Consente di attivare la pianificazione dell'esecuzione dell'attività in momenti specifici.
  • Consente di arrestare l'attività se viene eseguita oltre le ore e i minuti specificati.
  • Consente di specificare le impostazioni dell'account utente, il nome utente, il dominio e la password.
Pianificazione

Consente di specificare la frequenza per il piano e le impostazioni associate.


Parte II - Rilevamento: minacce potenziali

Il rilevamento delle minacce è la seconda fase in una strategia di protezione, per il rilevamento dei malware che tentano di ottenere l'accesso al sistema.

Sommario

  • Scansione di elementi all'accesso
  • Scansione di elementi su richiesta
  • Scansione e-mail alla consegna e su richiesta


Scansione di elementi all'accesso

La scansione all'accesso esamina i file nel computer nel momento in cui l'utente vi accede, in modo da consentire il rilevamento continuo e in tempo reale delle minacce. Le funzioni Protezione all'accesso e Protezione da sovraccarico del buffer utilizzano inoltre lo scanner all'accesso per rilevare, rispettivamente, le violazioni dell'accesso e gli utilizzi del sovraccarico del buffer.

Sommario

Concetti correlati
Scansione all'accesso e relativo funzionamento
Confronto relativo alle scansioni fra scrittura sul disco e lettura dal disco
Confronto relativo alle scansioni fra la scansione di tutti i file e la scansione dei tipi di file predefiniti e aggiuntivi
Scansione degli script e relativa modalità di funzionamento
Determinazione del numero di criteri di scansione
Funzionamento di Artemis
Informazioni correlate
Modalità di configurazione delle impostazioni generali e dei processi


Scansione all'accesso e relativo funzionamento

La scansione all'accesso si aggancia ai livelli più bassi del sistema (driver di filtro del file system) ed esegue la scansione dei file nel punto in cui entrano nel sistema. La scansione all'accesso agisce come parte del sistema (Servizio di sistema) e invia notifiche attraverso l'interfaccia in caso di rilevamenti.

Quando viene eseguito un tentativo di apertura, chiusura o ridenominazione di un file, lo scanner intercetta l'operazione e intraprende le azioni seguenti.

  1. Lo scanner determina se sottoporre il file a scansione in base ai criteri seguenti:
    • L'estensione del file corrisponde a quanto indicato nella configurazione.
    • Il file non è stato memorizzato nella cache.
    • Il file non è stato escluso.
    • Il file non è stato sottoposto precedentemente alla scansione.
  2. Se il file soddisfa il criterio di scansione, ne viene eseguita la scansione confrontando le informazioni contenute nel file con le firme di malware noti nei file DAT correntemente caricati.
    • Se il file è pulito, il risultato viene memorizzato nella cache e l'accesso viene consentito in lettura, scrittura o ridenominazione.
    • Se il file contiene una minaccia, l'accesso viene negato e viene intrapresa l'azione configurata. Ad esempio:
      • Se il file deve essere pulito, il processo di pulizia viene determinato dai file DAT correntemente caricati.
      • I risultati vengono memorizzati nel registro delle attività se lo scanner è stato configurato per eseguire questa operazione.
      • L'avviso Messaggi della scansione all'accesso visualizzato descrive il nome file e l'azione intrapresa, se lo scanner è stato configurato per eseguire questa operazione.
  3. Se il file non soddisfa i requisiti di scansione, non viene esaminato: viene memorizzato nella cache e l'accesso viene consentito.
    Nota: La cache del file di scansione viene scaricata e tutti i file vengono nuovamente sottoposti a scansione quando, ad esempio, la configurazione della scansione all'accesso viene modificata, viene aggiunto un file EXTRA.DAT o quando la cache è piena.


Confronto relativo alle scansioni fra scrittura sul disco e lettura dal disco

Lo scanner all'accesso gestisce le scansioni in modo diverso a seconda che l'utente effettui la scrittura sul disco o la lettura dal disco.

Quando i file vengono scritti sul disco, lo scanner all'accesso esegue la scansione di questi elementi:

  • File in ingresso che vengono scritti sul disco rigido locale.
  • File creati sul disco rigido locale o su un'unità di rete mappata (compresi i file nuovi, modificati o copiati/spostati da un'unità all'altra).
    Nota: Per eseguire la scansione delle unità di rete mappate, è necessario attivare l'opzione Sulle unità di rete. Fare riferimento ad Attivazione dell'opzione Sulle unità di rete.

    Tali scansioni sono accessibili solo dallo stesso client in cui VirusScan Enterprise è installato. Non rileva l'accesso all'unità di rete mappata da altri sistemi.

Quando i file vengono letti dal disco, lo scanner all'accesso esegue la scansione di questi elementi:

  • File in uscita che vengono letti dal disco rigido locale dalle unità di rete mappate.
    Nota: Per eseguire la scansione delle unità di rete mappate, selezionare l'opzione Sulle unità di rete, descritta nei punti precedenti, per includere i file di rete remoti.
  • Qualsiasi file che tenta di eseguire un processo sul disco rigido locale.
  • Qualsiasi file aperto dal disco rigido locale.
  • Qualsiasi file rinominato sul disco rigido locale, se le proprietà del file sono state modificate.


Confronto relativo alle scansioni fra la scansione di tutti i file e la scansione dei tipi di file predefiniti e aggiuntivi

Lo scanner all'accesso gestisce le scansioni in modo diverso a seconda che sia configurato per eseguire la scansione di tutti i file o dei tipi di file predefiniti e aggiuntivi.

Se configurato per eseguire la scansione di Tutti i file, lo scanner verifica la presenza di qualsiasi tipo di minaccia in ogni tipo di file.

Se configurato per eseguire la scansione dei Tipi di file predefiniti e aggiuntivi, lo scanner esamina un elenco specifico di file in base ai tipi di file selezionati.
  • Tipi di file predefiniti: lo scanner all'accesso verifica esclusivamente la presenza di minacce specifiche per il tipo di file esaminato.

  • Tipi di file aggiuntivi: Lo scanner all'accesso esamina la possibile presenza di minacce nei file con estensioni corrispondenti.

  • Tipi di file specificati: Lo scanner all'accesso esamina la possibile presenza di minacce nell'elenco dii file definito dall'utente.


Scansione degli script e relativa modalità di funzionamento

Lo scanner degli script funge da componente proxy per il componente Windows Scripting Host, intercettando gli script ed eseguendone la scansione prima della loro esecuzione.

Ad esempio, lo scanner degli script verifica quanto segue:

  • Se uno script è sicuro, viene trasmesso allo Scripting Host vero e proprio;
  • se invece contiene una minaccia potenziale, lo script non viene eseguito.
I processi affidabili e anche i siti Web che utilizzano gli script possono essere esclusi dal controllo.
Nota: Sui sistemi Windows Server 2008, le esclusioni degli URL Script Scan non funzionano con Windows Internet Explorer, a meno che non si seleziona la casella di controllo Attiva estensioni di browser di terze parti per attivare l'impostazione e riavviare Windows Server 2008. Per informazioni dettagliate, consultare https://kc.mcafee.com/corporate/index?page=content&id=KB69526.


Funzionamento di Artemis

La funzione Artemis effettua una verifica euristica per verificare la presenza di file sospetti. La funzione offre agli utenti di prodotti antivirus McAfee basati su Windows le più aggiornate funzionalità di rilevamento in tempo reale di determinati malware.

Artemis non fornisce protezione contro tutte le classi di malware, ma solo contro elementi sospetti. Il vantaggio comportato dalla protezione contro minacce specifiche è la possibilità di proteggere gli utenti mediante una tecnologia di protezione McAfee praticamente nello stesso momento in cui i laboratori McAfee determinano che un dato elemento è pericoloso.

È possibile configurare i livelli di sensibilità configurati dall'amministratore che Artemis utilizza per verificare la presenza di DLL e programmi sospetti in esecuzione sui sistemi client protetti da VirusScan Enterprise. Quando Artemis rileva un programma sospetto, viene inviata una richiesta DNS contenente un'impronta del file sospetto a un server database centrale ubicato presso i McAfee Labs.

Nota: In questa versione, la funzione Artemis è attivata per impostazione predefinita, con il livello di sensibilità molto basso.


Determinazione del numero di criteri di scansione

Seguire questa procedura per determinare se configurare più di un criterio di scansione all'accesso.


Modalità di configurazione delle impostazioni generali e dei processi

I criteri generali e dei processi dello scanner all'accesso sono configurati separatamente.
  • Impostazioni generali — Includono le opzioni da applicare a tutti i processi.
  • Impostazioni dei processi — Consentono di scegliere se configurare un solo criterio di scansione per tutti i processi oppure diversi criteri per i processi impostati come predefiniti, a basso rischio e ad alto rischio.


Configurazione delle impostazioni generali

Le impostazioni generali riguardano la scansione di tutti i processi e comprendono parametri quali il tempo massimo di scansione, la scansione degli script, il blocco delle minacce indesiderate da un computer remoto, l'invio di messaggi quando viene rilevata una minaccia e la segnalazione dei rilevamenti.

Configurare le impostazioni generali all'accesso utilizzando le seguenti console di interfaccia utente.

Informazioni correlate
Scansione di elementi all'accesso


ePolicy Orchestrator 4.5 o 4.6

Configurare le impostazioni generali da applicare alla scansione di tutti i processi utilizzando la seguente console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri generali all'accesso, fare clic sulla scheda Generale per configurare il criterio generale che si applica a tutte le scansioni all'accesso. Ad esempio, gli elementi all'accesso che devono essere sottoposti a scansione, quando eseguire la scansione, il tempo massimo di scansione e l'eventuale scansione dei cookie.

    È possibile configurare la scansione di tutti i processi correntemente in esecuzione sul sistema ogni volta che viene attivata la scansione all'accesso. Ciò migliora la sicurezza del sistema, ma può influenzare le prestazioni del tempo di avvio del sistema.

    Per configurare la funzione Processi in abilitazione, nel gruppo di scansione, fare clic su Processi in abilitazione per eseguire la scansione di tutti i processi correntemente in esecuzione sul sistema, ogni volta che la scansione all'accesso viene attivata.
    Nota: L'attivazione di questa funzione può influenzare il tempo impiegato dal sistema per l'avvio.
  5. Nella scheda ScriptScan, attivare ScriptScan e configurare i processi e gli URL da escludere dalla scansione.
  6. Nella scheda Blocco, configurare le connessioni di blocco dai computer remoti che scrivono i file con potenziali minacce o programmi indesiderati.
    Nota: Per impostazione predefinita, quando un sistema remoto scrive un malware su un sistema con VirusScan Enterprise, VirusScan Enterprise blocca la connessione al sistema remoto.

    È anche possibile configurare un messaggio che viene inviato al sistema che ha scritto il malware.

    Nota: L'invio di questo messaggio richiede il servizio Windows Messenger.
  7. Nella scheda Messaggi, configurare i messaggi per notificare agli utenti locali il verificarsi di rilevamenti mediante un messaggio configurato e specificare le azioni intraprese dall'utente contro la minaccia.
  8. Nella scheda Segnalazioni, attivare i file di registro dell'attività di scansione e definirne il percorso di memorizzazione, la dimensione, il formato ed eventuali altre registrazioni di scansione per consentire la diagnosi della minaccia.
    Nota: Questi file di registro sono molto utili nella diagnosi delle minacce alla sicurezza e consentono di determinare le azioni da intraprendere rispetto alle minacce.


ePolicy Orchestrator 4.0

Configurare le impostazioni generali da applicare alla scansione di tutti i processi utilizzando la seguente console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Criteri generali all'accesso, fare clic sulla scheda Generale per configurare il criterio generale che si applica a tutte le scansioni all'accesso. Ad esempio, gli elementi all'accesso che devono essere sottoposti a scansione, quando eseguire la scansione, il tempo massimo di scansione e l'eventuale scansione dei cookie.

    È possibile configurare la scansione di tutti i processi correntemente in esecuzione sul sistema ogni volta che viene attivata la scansione all'accesso. Ciò migliora la sicurezza del sistema, ma può influenzare le prestazioni del tempo di avvio del sistema.

    Per configurare la funzione Processi in abilitazione, nel gruppo di scansione, fare clic su Processi in abilitazione per eseguire la scansione di tutti i processi correntemente in esecuzione sul sistema, ogni volta che la scansione all'accesso viene attivata.
    Nota: L'attivazione di questa funzione può influenzare il tempo impiegato dal sistema per l'avvio.
  5. Nella scheda ScriptScan, attivare ScriptScan e configurare i processi e gli URL da escludere dalla scansione.
  6. Nella scheda Blocco, configurare le connessioni di blocco dai computer remoti che scrivono i file con potenziali minacce o programmi indesiderati.
    Nota: Per impostazione predefinita, quando un sistema remoto scrive un malware su un sistema con VirusScan Enterprise, VirusScan Enterprise blocca la connessione al sistema remoto.

    È anche possibile configurare un messaggio che viene inviato al sistema che ha scritto il malware.

    Nota: L'invio di questo messaggio richiede il servizio Windows Messenger.
  7. Nella scheda Messaggi, configurare i messaggi per notificare agli utenti locali il verificarsi di rilevamenti mediante un messaggio configurato e specificare le azioni intraprese dall'utente contro la minaccia.
  8. Nella scheda Segnalazioni, attivare i file di registro dell'attività di scansione e definirne il percorso di memorizzazione, la dimensione, il formato ed eventuali altre registrazioni di scansione per consentire la diagnosi della minaccia.
    Nota: Questi file di registro sono molto utili nella diagnosi delle minacce alla sicurezza e consentono di determinare le azioni da intraprendere rispetto alle minacce.


Console di VirusScan

Configurare le impostazioni generali da applicare alla scansione di tutti i processi utilizzando la seguente console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Scanner all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Dalla pagina Criteri generali all'accesso, fare clic sulla scheda Generale per configurare il criterio generale che si applica a tutte le scansioni all'accesso. Ad esempio, gli elementi all'accesso che devono essere sottoposti a scansione, quando eseguire la scansione, il tempo massimo di scansione e l'eventuale scansione dei cookie.

    È possibile configurare la scansione di tutti i processi correntemente in esecuzione sul sistema ogni volta che viene attivata la scansione all'accesso. Ciò migliora la sicurezza del sistema, ma può influenzare le prestazioni del tempo di avvio del sistema.

    Per configurare la funzione Processi in abilitazione, nel gruppo di scansione, fare clic su Processi in abilitazione per eseguire la scansione di tutti i processi correntemente in esecuzione sul sistema, ogni volta che la scansione all'accesso viene attivata.
    Nota: L'attivazione di questa funzione può influenzare il tempo impiegato dal sistema per l'avvio.
  3. Nella scheda ScriptScan, attivare ScriptScan e configurare gli script da escludere dalla scansione.
  4. Nella scheda Blocco, configurare le connessioni di blocco dai computer remoti che scrivono i file con potenziali minacce o programmi indesiderati.
    Nota: Per impostazione predefinita, quando un sistema remoto scrive un malware su un sistema con VirusScan Enterprise, VirusScan Enterprise blocca la connessione al sistema remoto.

    È anche possibile configurare un messaggio che viene inviato al sistema che ha scritto il malware.

    Nota: L'invio di questo messaggio richiede il servizio Windows Messenger.
  5. Nella scheda Messaggi, configurare i messaggi per notificare agli utenti locali il verificarsi di rilevamenti mediante un messaggio configurato e specificare le azioni intraprese dall'utente contro la minaccia.
  6. Nella scheda Segnalazioni, attivare i file di registro dell'attività di scansione e definirne il percorso di memorizzazione, la dimensione, il formato ed eventuali altre registrazioni di scansione per consentire la diagnosi della minaccia.
    Nota: Questi file di registro sono molto utili nella diagnosi delle minacce alla sicurezza e consentono di determinare le azioni da intraprendere rispetto alle minacce.


Configurazione delle impostazioni dei processi

I processi di scansione all'accesso vengono configurati in base al livello di rischio assegnato a ogni processo. È possibile configurare un unico criterio predefinito di scansione per tutti i processi o configurare più criteri in base al livello di rischio assegnato a ogni processo. I parametri includono l'assegnazione del livello di rischio ai processi, la definizione degli elementi da sottoporre a scansione, l'opportunità di eseguire la scansione Artemis, la scansione dei file compressi, le azioni da intraprendere quando viene rilevata una minaccia e la verifica dei programmi potenzialmente indesiderati.

Configurare le impostazioni del processo all'accesso utilizzando le seguenti console di interfaccia utente.


ePolicy Orchestrator 4.5 o 4.6

Configurare i Criteri dei processi predefiniti all'accesso utilizzando le seguenti console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla scheda Processi, fare clic su Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti per visualizzare i Processi predefiniti all'accesso, i Processi a basso rischio o i Processi ad alto rischio.
  5. Dalla pagina Criteri dei processi predefiniti all'accesso, Criteri dei processi a basso rischio o Criteri dei processi ad alto rischio, configurare le opzioni di ciascuna scheda. Fare riferimento a Opzioni della scheda Impostazioni dei processi.


ePolicy Orchestrator 4.0

Configurare i Criteri dei processi predefiniti all'accesso utilizzando le seguenti console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla scheda Processi, fare clic su Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti per visualizzare i Processi predefiniti all'accesso, i Processi a basso rischio o i Processi ad alto rischio.
  5. Dalla pagina Criteri dei processi predefiniti all'accesso, Criteri dei processi a basso rischio o Criteri dei processi ad alto rischio, configurare le opzioni di ciascuna scheda. Fare riferimento a Opzioni della scheda Impostazioni dei processi.


Console di VirusScan

Configurare le Proprietà della scansione all'accesso utilizzando le seguenti console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Scanner all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Dal riquadro a sinistra, fare clic su Tutti i processi.
  3. Dalla scheda Processi, fare clic su Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti per visualizzare i Processi predefiniti all'accesso, i Processi a basso rischio o i Processi ad alto rischio.
  4. Dalla pagina Criteri dei processi predefiniti all'accesso, Criteri dei processi a basso rischio o Criteri dei processi ad alto rischio, configurare le opzioni di ciascuna scheda. Fare riferimento a Opzioni della scheda Impostazioni dei processi.


Opzioni della scheda Impostazioni dei processi

Nella seguente tabella vengono riportate le opzioni della scheda di scansione all'accesso.

Scheda | Definizioni
Processi
  • Processi predefiniti all'accesso: scegliere se configurare un solo criterio di scansione per tutti i processi oppure criteri di scansione distinti per i processi predefiniti, a basso rischio e ad alto rischio.
    Nota: Se si sceglie di configurare un unico criterio di scansione, questo criterio viene applicato a tutti i processi. Se invece si sceglie di configurare criteri di scansione distinti per i criteri a basso rischio e ad alto rischio, questo criterio viene applicato esclusivamente ai processi non definiti come a basso o ad alto rischio.
  • Processi a basso rischio all'accesso: consente di specificare i processi definiti come a basso rischio.
  • Processi ad alto rischio all'accesso: consente di specificare i processi definiti come ad alto rischio.
Nota: Prima di poter configurare criteri specifici per i processi ad alto o basso rischio occorre selezionare l'opzione Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti nella scheda Processi predefiniti all'accesso.
Elementi da sottoporre a scansione
  • Consente di configurare se eseguire la scansione dei file in fase di lettura, in fase di scrittura, contenuti nelle unità di rete e aperti per il backup.
    ATTENZIONE:
    Se le opzioni Durante la scrittura sul disco e Durante la lettura dal disco non vengono attivate, il sistema rimane non protetto da numerosi attacchi malware.
  • Consente di configurare i file e i tipi di file da sottoporre a scansione.
    ATTENZIONE:
    Se l'opzione Tutti i file non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.
  • Consente di cercare potenziali minacce che somigliano a programmi indesiderati, trojan horse e virus macro.
  • Consente di eseguire scansioni all'interno di archivi e di decodificare file MIME codificati.
  • Consente di attivare la scansione all'accesso per esaminare i programmi indesiderati.
Esclusioni | Consente di configurare i dischi, i file e le cartelle da escludere dalla scansione.
Azioni
Per il rilevamento delle minacce:
  • Azione primaria da intraprendere in caso di rilevamento di una minaccia.
  • Azione secondaria da intraprendere in caso di rilevamento di minacce se la prima azione non riesce.
Per i rilevamenti di programmi indesiderati:
  • Azione primaria da intraprendere in caso di rilevamento di un programma indesiderato.
  • Azione secondaria da intraprendere in caso di rilevamento di programmi indesiderati se la prima azione non riesce.


Attivazione dell'opzione Sulle unità di rete

Per eseguire la scansione delle unità di rete mappate, è necessario attivare l'opzione Sulle unità di rete.

Configurare la scansione all'accesso della funzione Sulle unità di rete mediante i Criteri dei processi predefiniti all'accesso, utilizzando una delle seguenti console di interfaccia di rete.


ePolicy Orchestrator 4.5 o 4.6

Attivare la funzione Sulle unità di rete dai Criteri dei processi predefiniti all'accesso mediante la seguente console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella pagina Criteri dei processi predefiniti all'accesso, fare clic sulla scheda Scansione elementi e su Sulle unità di rete accanto ai file di scansione.
  5. Fare clic su Salva


ePolicy Orchestrator 4.0

Attivare l'opzione Sulle unità di rete mediante la seguente console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Nella pagina Criteri dei processi predefiniti all'accesso, fare clic sulla scheda Scansione elementi e su Sulle unità di rete accanto ai file di scansione.
  5. Fare clic su Salva


Console di VirusScan

Attivare l'opzione Sulle unità di rete mediante la seguente console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Scanner all'accesso, quindi fare clic su Proprietà per aprire la finestra di dialogo Proprietà di Scanner all'accesso.
  2. Fare clic sulla scheda Scansione elementi e su Sulle unità di rete accanto ai file di scansione.
  3. Fare clic su Salva


Scansione di elementi su richiesta

Lo scanner su richiesta consente di esaminare tutte le parti del computer per verificare la presenza di eventuali minacce potenziali, negli orari desiderati o ad intervalli regolari. Le scansioni su richiesta possono essere utilizzate per integrare la protezione continua offerta dalla scansione all'accesso oppure per pianificare scansioni regolari quando tali attività non interferiscono con il proprio lavoro.

Sommario

Concetti correlati
Scansione su richiesta e relativo funzionamento
Metodi di scansione su richiesta e relativa modalità di definizione
Modalità di funzionamento della scansione dell'archivio remoto
Modalità di funzionamento del rinvio scansione
Modalità di funzionamento dell'utilizzo del sistema
Attività correlate
Configurazione di attività di scansione su richiesta
Configurazione della cache di sistema globale


Scansione su richiesta e relativo funzionamento

Lo scanner su richiesta ricerca i file, le cartelle, la memoria e il registro del sistema e ricerca eventuali malware che avrebbero potuto infettare il sistema. Il momento e la modalità di esecuzione delle scansioni su richiesta vengono stabiliti dall'utente. È possibile eseguire la scansione del sistema manualmente, a un'ora pianificata o, ad esempio, all'avvio del sistema.

Quando viene eseguito un tentativo di apertura, chiusura o ridenominazione di un file, lo scanner intercetta l'operazione e intraprende le azioni seguenti.

  1. Lo scanner determina se sottoporre il file, la cartella o il disco a scansione in base ai criteri seguenti:
    • L'estensione del file corrisponde a quanto indicato nella configurazione.
    • Il file non è stato memorizzato nella cache.
    • Il file non è stato escluso.
    • Il file non è stato sottoposto precedentemente alla scansione.
      Nota: Lo scanner su richiesta utilizza l'euristica per verificare la presenza di file sospetti, se si configura Artemis. Per i dettagli, consultare Funzionamento di Artemis.
  2. Se il file soddisfa il criterio di scansione, ne viene eseguita la scansione confrontando le informazioni contenute nel file con le firme di virus noti nei file DAT correntemente caricati.
    • Se è pulito, il risultato viene inserito in cache e viene eseguita la verifica del successivo elemento.
    • Se contiene una minaccia, viene intrapresa l'azione configurata. Ad esempio:
      • Se il file deve essere pulito, il processo viene determinato dai file DAT correntemente caricati.
      • I risultati vengono memorizzati nel registro delle attività se lo scanner è stato configurato per eseguire questa operazione.
      • Nella finestra di dialogo Stato scansione su richiesta, vengono visualizzate le informazioni relative alla memoria, al file, alla cartella o al nome disco e l'azione intrapresa.
  3. Se la memoria, il file, la cartella o il disco non soddisfano i requisiti di scansione, la scansione non viene eseguita e lo scanner continua fino ad analizzare tutti i dati.
Concetti correlati
Funzionamento di Artemis


Metodi di scansione su richiesta e relativa modalità di definizione

Lo scanner su richiesta utilizza la scansione dei processi di memoria e la scansione incrementale o ripristinabile.

Scansione dei processi in memoria

Questo metodo esamina tutti i processi attivi prima di eseguire l'attività di scansione su richiesta. Quando la scansione rileva un programma potenzialmente indesiderato, questo viene evidenziato e il processo viene interrotto. Ciò significa che per rimuovere tutte le istanze di un programma potenzialmente indesiderato è necessario un unico passaggio dello scanner su richiesta.

Scansione incrementale o ripristinabile

Questo metodo consente di impostare un limite di tempo per il verificarsi dell'attività di scansione su richiesta e di eseguire la scansione dell'intero sistema in più sessioni. La scansione incrementale può essere impostata aggiungendo un limite di tempo alla scansione pianificata. la scansione si interrompe quando viene raggiunto il limite. Al successivo avvio, questa attività riprenderà dal punto nel file e nella struttura della cartella in cui la scansione precedente si era interrotta.


Modalità di funzionamento della scansione dell'archivio remoto

L'archivio dati di Archiviazione remota presenta una struttura gerarchica, con due livelli distinti:

I due livelli di archiviazione:
  • Livello superiore, archivio locale — Include i volumi del disco NTFS del computer che esegue Archiviazione remota in Windows 2000 Server.
  • Livello inferiore, archivio remoto — Ubicato nella libreria dei nastri robotica o nell'unità nastro autonoma connessa al server.

Archiviazione remota copia automaticamente in una libreria di nastri i file necessari contenuti nei volumi locali, quindi esegue il monitoraggio dello spazio disponibile nei volumi locali. I dati contenuti nei file vengono memorizzati nella cache, in modo da potervi accedere rapidamente secondo le necessità. Quando necessario, l'archivio remoto sposta i dati dall'archivio remoto a quello locale. Quando è necessario accedere a un file che si trova in un volume gestito da Archiviazione remota, è possibile aprire il file come di consueto. Se i dati relativi al file non sono più memorizzati nella cache del volume locale, Archiviazione remota richiama i dati da una libreria di nastri.

Attività correlate
Configurazione di attività di scansione su richiesta


Modalità di funzionamento del rinvio scansione

Per migliorare le prestazioni, è possibile rinviare le attività di scansione su richiesta quando la batteria è quasi esaurita o durante le presentazioni a schermo intero. È anche possibile consentire all'utente di rinviare le scansioni pianificate in incrementi di un'ora. Gli incrementi possono durare un'ora, 24 ore oppure è possibile rinviate per sempre la scansione su richiesta.

Ciascun rinvio dell'utente può durare un'ora. Ad esempio, se l'opzione Rinvio massimo è impostata su 2, l'utente può rinviare l'attività di scansione per due volte o per un intervallo di due ore. Quando il numero di ore massimo specificato scade, la scansione riprende. Se l'amministratore consente di configurare rinvii illimitati impostando l'opzione sul valore zero, l'utente potrà continuare a rinviare la scansione a tempo indeterminato.


Modalità di funzionamento dell'utilizzo del sistema

Lo scanner su richiesta utilizza l'impostazione di priorità di Windows per la priorità dei processi di scansione e dei thread. Ciò consente al sistema operativo di impostare la quantitò di tempo della CPU che lo scanner su richiesta riceve durante il processo di scansione. L'impostazione di utilizzo del sistema nelle Proprietà scansione su richiesta viene mappata sul controllo dell'impostazione di priorità di Windows.

Se si imposta l'utilizzo del sistema per la scansione su un valore basso, aumentano le prestazioni delle altre applicazioni in esecuzione. L'impostazione sul livello basso è utile per i sistemi con attività utente finale in corso. Di contro, impostando l'utilizzo del sistema su un valore normale, la scansione viene eseguita più rapidamente. L'impostazione normale è utile per i sistemi che dispongono di grandi volumi e una minima attività dell'utente.

La seguente tabella mostra le impostazioni di processo predefinite di VirusScan Enterprise e ePolicy Orchestrator.

VirusScan Enterprise impostazioni per i processi | Impostazione della priorità di Windows
Basso | Basso
Al di sotto del normale — L'impostazione predefinita di ePolicy Orchestrator | Al di sotto del normale
Normale — L'impostazione predefinita di VirusScan Enterprise 8.8 | Normale
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Configurazione di attività di scansione su richiesta

La configurazione delle attività su richiesta dipende dalla console di interfaccia utente che si sta utilizzando. Tali attività descrivono il processo per ciascuna console di interfaccia utente.

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4.0
Console di VirusScan
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta


ePolicy Orchestrator 4.5 o 4.6

Configurare le attività di scansione su richiesta utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Sistema | Struttura del sistema e selezionare Attività client.
  2. Dalla pagina Attività client visualizzata:
    • Per modificare un'attività di scansione su richiesta esistente, fare clic su Modifica impostazione dalla colonna Azioni dell'attività per aprire la pagina Descrizione.
    • Per creare una nuova attività di scansione su richiesta, fare clic su Azioni | Nuova attività per aprire la pagina Descrizione.
  3. Dalla pagina Descrizioni:
    • Quando si modifica un'attività di scansione su richiesta esistente, verificare le descrizioni e fare clic su Avanti.
    • Quando si crea una nuova attività di scansione su richiesta, configurare quanto segue e fare clic su Avanti.
      • Nome e Note.
      • Tipo selezionando Scansione su richiesta (VirusScan Enterprise 8.8) dall'elenco.
      • Tag che determinano i computer che ricevono l'attività di scansione su richiesta.
  4. Dalla pagina di configurazione di Client Task Builder che viene visualizzata, configurare ciascuna delle schede. Per i dettagli, fare riferimento a Configurazione delle schede di attività di scansione su richiesta.


ePolicy Orchestrator 4.0

Configurare le attività di scansione su richiesta utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Struttura del sistema | Attività client.
  2. Dalla pagina Attività client visualizzata:
    • Per modificare un'attività di scansione su richiesta esistente, fare clic su Modifica dalla colonna Azioni dell'attività per aprire la pagina Descrizione.
    • Per creare una nuova attività di scansione su richiesta, fare clic su Azioni | Nuova attività per aprire la pagina Descrizione.
  3. Eseguire una delle seguenti operazioni:
    • Quando si modifica un'attività di scansione su richiesta esistente, verificare le descrizioni e fare clic su Avanti.
    • Quando si crea una nuova attività di scansione su richiesta, configurare quanto segue e fare clic su Avanti.
      • Nome e Note.
      • Tipo selezionando Scansione su richiesta (VirusScan Enterprise 8.8) dall'elenco.
      • Tag che determinano i computer che ricevono l'attività di scansione su richiesta.
  4. Dalla pagina di configurazione di Client Task Builder che viene visualizzata, configurare ciascuna delle schede. Per i dettagli, fare riferimento a Configurazione delle schede di attività di scansione su richiesta.


Console di VirusScan

Configurare le attività di scansione su richiesta utilizzando questa console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Aprire la pagina Proprietà scansione su richiesta per un'attività nuova o esistente:
    • Selezionare l'attività di scansione su richiesta, fare clic con il pulsante destro del mouse e selezionare Proprietà.
    • Creare una nuova attività, selezionare Attività | Nuova attività di scansione su richiesta, fare clic con il pulsante destro del mouse sulla nuova attività, selezionare Proprietà.
  2. Configurare ciascuna delle schede nella finestra di dialogo Proprietà scansione su richiesta. Per i dettagli, fare riferimento a Configurazione delle schede di attività di scansione su richiesta.
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta


Configurazione delle schede di attività di scansione su richiesta

VirusScan Enterprise include un'attività di scansione su richiesta predefinita. È possibile utilizzare l'attività predefinita e creare nuove attività.

Configurare le opzioni in ciascuna scheda. Per ottenere le definizioni delle opzioni, fare clic su ? o Guida in linea su ciascuna scheda.

Definizioni delle schede

Scheda | Definizioni
Percorsi
  • Consente di specificare i percorsi e gli elementi da sottoporre a scansione.
  • Consente di includere i processi in esecuzione.
  • Consente di includere le sottocartelle durante la scansione.
  • Consente di includere i settori di avvio durante la scansione.
  • Consente di includere le chiavi di registro e i valori durante la scansione.
  • Consente di includere i file di cookie durante la scansione.
ATTENZIONE:
Se non viene effettuata la scansione di Memoria per i rootkit e Processi in esecuzione, il sistema non sarà protetto da numerosi attacchi malware.
Nota: Quando viene visualizzata la finestra di dialogo Stato della scansione su richiesta, i percorsi da sottoporre a scansione vengono visualizzati come stringa separata da virgole successivamente a Scansione in. Quando i processi di scansione vengono completati, vengono rimossi dalla stringa.
Elementi da sottoporre a scansione
  • Consente di configurare i file e i tipi di file da sottoporre a scansione.
  • Consente di attivare la scansione su richiesta per i programmi indesiderati.
  • Consente di eseguire scansioni all'interno di archivi e di decodificare file MIME codificati.
  • Esegui scansione sui file passati in archivio.
  • Consente di cercare potenziali minacce che somigliano a programmi indesiderati, trojan horse e virus macro.
Esclusioni | Consente di configurare i dischi, i file e le cartelle da escludere dalla scansione in base al nome o al percorso, in base al tipo di file o alla data del file.
Prestazioni
  • Consente di configurare quando eseguire il rinvio delle scansioni e per quanto tempo rinviarle.
  • Consente di specificare la percentuale di utilizzo del sistema.
  • Configurare il livello di sensibilità per Artemis.
Azioni
Per il rilevamento delle minacce:
  • Azione primaria da intraprendere in caso di rilevamento di una minaccia.
  • Azione secondaria da intraprendere in caso di rilevamento di minacce se la prima azione non riesce.
Per i rilevamenti di programmi indesiderati:
  • Azione primaria da intraprendere in caso di rilevamento di un programma indesiderato.
  • Azione secondaria da intraprendere in caso di rilevamento di programmi indesiderati se la prima azione non riesce.

In Azioni consentite nella finestra di dialogo di richiesta, selezionare l'azione desiderata.

Rapporti
  • Consente di attivare la registrazione delle attività.
  • Consente di indicare il nome e il percorso del file di registro.
  • Consente di indicare il limite della dimensione del file di registro.
  • Consente di selezionare il formato del file di registro.
  • Consente di specificare le azioni da registrare oltre all'attività di scansione.
  • Consente di specificare quali delle seguenti azioni registrare oltre all'attività di scansione:
    • Attivazione delle impostazioni di sessione
    • Attivazione del riepilogo sessione
    • Attivazione della scansione dei file crittografati non riuscita
  • Attivazione degli avvisi al rilevamento dei cookie.
Attività Consente di specificare il percorso di esecuzione dell'attività di scansione su richiesta.
Nota: Questa scheda è disponibile soltanto tramite ePolicy Orchestrator.


Configurazione della cache di sistema globale

La cache di scansione di VirusScan Enterprise salva un elenco di file sottoposti a scansione che risultano puliti. È possibile migliorare le prestazioni del sistema salvando nella cache di scansione le informazioni relative al file pulito durante il riavvio del sistema. In questo modo, lo scanner su richiesta potrà utilizzare queste informazioni sul file pulito presente nella cache per ridurre le scansioni duplicate dei file.

È possibile configurare le funzioni della cache di scansione utilizzando i criteri Opzioni generali e la scheda Impostazioni globali scansione mediante le seguenti console dell'interfaccia utente.

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4.0
Console di VirusScan


ePolicy Orchestrator 4.5 o 4.6

Configurare la funzione della cache di scansione dai criteri Opzioni generali mediante la console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? o su Guida in linea nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dai criteri Opzioni generali, fare clic sulla scheda Impostazioni globali scansione per configurare le impostazioni di opzione della cache di scansione diVirusScan Enterprise.
  5. Configurare le seguenti impostazioni globali per la cache di scansione:
    • Fare clic su Abilita il salvataggio dei dati di scansione tra i riavvii del sistema — Salva i risultati di scansione dei file puliti quando si riavvia il sistema.
    • Fare clic su Consenti alle scansioni su richiesta di utilizzare la cache di scansione — Consente allo scanner su richiesta di utilizzare i risultati di scansione dei file puliti per ridurre le scansioni duplicate.
  6. Fare clic su Salva


ePolicy Orchestrator 4.0

Configurare la funzione della cache di scansione dai criteri Opzioni generali mediante la console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? o su Guida in linea nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dai criteri Opzioni generali, fare clic sulla scheda Impostazioni globali scansione per configurare le impostazioni di opzione della cache di scansione diVirusScan Enterprise.
  5. Configurare le seguenti impostazioni globali per la cache di scansione:
    • Fare clic su Abilita il salvataggio dei dati di scansione tra i riavvii del sistema — Salva i risultati di scansione dei file puliti quando si riavvia il sistema.
    • Fare clic su Consenti alle scansioni su richiesta di utilizzare la cache di scansione — Consente allo scanner su richiesta di utilizzare i risultati di scansione dei file puliti per ridurre le scansioni duplicate.
  6. Fare clic su Salva


Console di VirusScan

Configurare funzione della cache di scansione utilizzando questa console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Strumenti | Opzioni generali e sulla scheda Impostazioni globali scansione per visualizzare la finestra di dialogo Impostazioni globali scansione.
  2. Configurare le seguenti impostazioni globali per la cache di scansione:
    • Fare clic su Abilita il salvataggio dei dati di scansione tra i riavvii del sistema — Salva i risultati di scansione dei file puliti quando si riavvia il sistema.
    • Fare clic su Consenti alle scansioni su richiesta di utilizzare la cache di scansione — Consente allo scanner su richiesta di utilizzare i risultati di scansione dei file puliti per ridurre le scansioni duplicate.
  3. Fare clic su OK.


Scansione e-mail alla consegna e su richiesta

Lo scanner della posta elettronica esamina automaticamente i messaggi e gli allegati di posta elettronica.

La posta elettronica viene sottoposta a scansione utilizzando:
  • Microsoft Outlook — Viene eseguita la scansione della posta elettronica alla consegna oppure è possibile richiamare le scansioni della posta elettronica su richiesta direttamente da Microsoft Outlook.
    Nota: Se si configurare le funzioni eurustica e Artemis, la posta elettronica su consegna e lo scannero su richiesta utilizzano l'euristica per controllare i file sospetti. Per i dettagli, consultare Funzionamento di Artemis.
  • Lotus Notes — Consente di configurare:
    • Quando si esegue l'accesso, la posta elettronica viene sottoposta a scansione.
    • Quando ne viene eseguita la chiamata, le scansioni di posta elettronica su richiesta vengono eseguite direttamente da Lotus Notes.
    • Quali Database Notes escludere.

Configurare i Criteri di scansione della posta elettronica alla consegna utilizzando le seguenti console dell'interfaccia utente.

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4.0
Console di VirusScan
Riferimenti correlati
Definizioni della tabella Criteri di scansione della posta elettronica alla consegna


ePolicy Orchestrator 4.5 o 4.6

Configurare i Criteri di scansione della posta elettronica alla consegna utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina di configurazione di Criteri scansione posta elettronica alla consegna, configurare le opzioni di ciascuna scheda. Consultare Definizioni della tabella Criteri di scansione della posta elettronica alla consegna.


ePolicy Orchestrator 4.0

Configurare i Criteri di scansione della posta elettronica alla consegna utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina di configurazione di Criteri scansione posta elettronica alla consegna, configurare le opzioni di ciascuna scheda. Consultare Definizioni della tabella Criteri di scansione della posta elettronica alla consegna.


Console di VirusScan

Configurare i Criteri di scansione della posta elettronica alla consegna utilizzando le seguenti console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Proprietà scansione posta elettronica alla consegna, quindi su Proprietà per visualizzare la finestra di dialogo.
  2. Dalla pagina di configurazione di Criteri scansione posta elettronica alla consegna, configurare le opzioni di ciascuna scheda. Consultare Definizioni della tabella Criteri di scansione della posta elettronica alla consegna.


Definizioni della tabella Criteri di scansione della posta elettronica alla consegna

Scheda Definizioni
Elementi da sottoporre a scansione
  • Consente di specificare i messaggi e gli allegati da sottoporre a scansione.
  • La scansione che utilizza l'euristica per le minacce potenziali che somigliano a malware, i virus di macro sconosciuti e gli allegati file con estensioni multiple.
  • Consente di eseguire scansioni di file compressi all'interno di archivi e di decodificare file MIME codificati.
  • Consente di attivare la scansione della posta elettronica per rilevare eventuali programmi indesiderati.
  • Consente di sottoporre a scansione il corpo dei messaggi di posta elettronica
  • Configurare il livello di sensibilità per Artemis.
    Nota: Questa opzione è disponibile solo per la Scansione della posta elettronica alla consegna.
Azioni
Per il rilevamento delle minacce:
  • Azione primaria da intraprendere in caso di rilevamento di una minaccia.
  • Azione secondaria da intraprendere se la prima azione non riesce.
Per i rilevamenti di programmi indesiderati:
  • Azione primaria da intraprendere in caso di rilevamento di un programma indesiderato.
  • Azione secondaria da intraprendere se la prima azione non riesce.

In Azioni consentite nella finestra di dialogo di richiesta, selezionare l'azione desiderata.

Avvisi
  • Consente di avvisare un altro utente quando viene rilevato un messaggio di posta elettronica potenzialmente dannoso.
  • Specificare il messaggio visualizzato quando è richiesta un'azione.
Rapporti
  • Consente di attivare la registrazione delle attività.
  • Consente di indicare il nome e il percorso del file di registro.
  • Consente di indicare il limite della dimensione del file di registro.
  • Consente di selezionare il formato del file di registro.
  • Consente di specificare le azioni da registrare oltre all'attività di scansione.
Impostazioni di Notes Scanner
Nota: Questa scheda è disponibile solo per la Scansione della posta elettronica alla consegna.

Consente di configurare le impostazioni specifiche di Lotus Notes.

  • Consente di sottoporre a scansione tutti i database del server.
  • Consente di sottoporre a scansione le cassette di posta del server nella cartella principale della cassetta di posta specificata.
  • Consente di specificare le applicazioni Notes da ignorare.


Parte III - Risposte: gestione delle minacce

La risposta alle minacce è la terza fase in una strategia di protezione, per il rilevamento e la pulizia dei malware che tentano di ottenere l'accesso al sistema.

Sommario

  • Rilevamenti e risposte
  • Configurazione di avvisi e notifiche
  • Accesso a query e dashboard
  • Configurazione di DAT di emergenza


Rilevamenti e risposte

Quando viene rilevata una minaccia, l'azione intrapresa dipende dalla modalità secondo la quale VirusScan Enterprise è stato configurato per la risposta e dalla funzione che ha rilevato la minaccia. Tenendo in considerazione queste differenze, è possibile sviluppare e implementare una strategia più efficace.

Sommario

Concetti correlati
Cosa succede quando si verifica un rilevamento
Elementi in quarantena
Riferimenti correlati
Violazioni dei punti di accesso del sistema
Rilevamenti di sovraccarichi del buffer
Rilevamenti di programmi indesiderati
Rilevamenti della scansione all'accesso
Rilevamenti della scansione su richiesta
Rilevamenti della scansione della posta elettronica


Cosa succede quando si verifica un rilevamento

Quando si verifica un rilevamento, la reazione dipende dal modo in cui è configurato VirusScan Enterprise.

Se VirusScan Enterprise è configurato per la pulizia automatica (impostazione predefinita consigliata), l'azione risultante dipende dalle istruzioni di pulizia contenute nel file DAT. Ad esempio, se non è stato possibile pulire un file o se il file è stato danneggiato irreparabilmente, lo scanner potrebbe eliminare il file o eseguire l'azione secondaria, in base alle istruzioni contenute nel file DAT.

Oltre a negare l'accesso ai file contenenti minacce potenziali, lo scanner aggiunge l'estensione MCM al nome del file al momento del salvataggio.


Violazioni dei punti di accesso del sistema

In caso di violazione di un punto di accesso del sistema, l'azione intrapresa dal sistema dipende da come la regola è stata configurata.

Se la regola è stata configurata per:

  • Segnala — Le informazioni vengono registrate nel file di registro.

  • Blocca — L'accesso viene negato.

Esaminare il file di registro per determinare i punti di accesso che sono stati violati e le regole che hanno rilevato tali violazioni e configurare successivamente le regole di protezione all'accesso in modo da consentire agli utenti di accedere agli elementi legittimi e impedire l'accesso agli elementi protetti.

È possibile utilizzare i seguenti scenari per decidere il tipo di azione da intraprendere in risposta.

Tipo di rilevamento Scenari
Processi indesiderati
  • Se la regola ha segnalato la violazione nel file di registro senza bloccarla, selezionare l'opzione Blocca per la regola.
  • Se la regola ha bloccato la violazione senza segnalarla nel file di registro, selezionare l'opzione Segnala per la regola.
  • Se la regola ha bloccato la violazione segnalandola nel file di registro, non è necessaria alcuna operazione.
  • Se si osserva il mancato rilevamento di un processo indesiderato, modificare la regola in modo da includerne il blocco.
Processi legittimi
  • Se la regola ha segnalato la violazione nel file di registro senza bloccarla, deselezionare l'opzione Segnala per la regola.
  • Se la regola ha bloccato la violazione segnalandola nel file di registro, modificare la regola in modo da escludere il blocco del processo legittimo.


Rilevamenti di sovraccarichi del buffer

Quando si verifica un rilevamento di overflow del buffer, lo scannere blocca il rilevamento e nella finestra di dialogo Messaggi della scansione all'accesso viene registrato un messaggio È possibile visualizzare la finestra di dialogo, quindi decidere se intraprendere ulteriori azioni.

Le azioni possibili sono:
  • Rimozione del messaggio — Selezionare questo elemento nell'elenco e fare clic su Rimuovi.
  • Creazione di un'esclusione — Se il processo rilevato è un elemento utilizzato in modo legittimo o un falso positivo, creare un'esclusione utilizzando le informazioni contenute nella finestra di dialogo Messaggi della scansione all'accesso. Esaminare le informazioni contenute nella colonna Nome per determinare il nome del processo che detiene la memoria scrivibile che sta effettuando la chiamata. Utilizzare il nome del processo per creare un'esclusione.
  • Invio di un esempio a McAfee Labs per l'analisi — se lo scanner effettua rilevamenti ritenuti inopportuni o non rileva elementi che avrebbero dovuto essere rilevati, è possibile inviare un esempio a McAfee Labs.


Rilevamenti di programmi indesiderati

La scansione all'accesso, su richiesta e della posta elettronica rileva i programmi indesiderati in base alla configurazione del Criterio per programmi indesiderati. Quando si verifica un rilevamento, lo scanner che rileva il programma potenzialmente indesiderato applica l'azione configurata nella scheda Azione dello scanner.

Esaminare le informazioni nel file di registro e quindi decidere se intraprendere una delle azioni aggiuntive seguenti:

  • Scansione personalizzata degli elementi — Consente di ottenere risultati più precisi.
  • Esclusione dal rilevamento — Se viene rilevato un programma legittimo, è possibile configurarlo come esclusione.
  • Aggiunta all'elenco di rilevamento definito dall'utente — Se un programma indesiderato non viene rilevato, è possibile aggiugerlo all'elenco di rilevamento definito dall'utente.
  • Invio di un esempio a McAfee Labs per l'analisi — se lo scanner effettua rilevamenti ritenuti inopportuni o non rileva elementi che avrebbero dovuto essere rilevati, è possibile inviare un esempio a McAfee Labs.


Rilevamenti della scansione all'accesso

Quando lo scanner all'accesso rileva un malware, l'azione viene intrapresa in base alla modalità di configurazione delle Proprietà della scansione all'accesso, nella scheda Azioni. Inoltre, nella finestra di dialogo Messaggi della scansione all'accesso viene registrato un messaggio.

Esaminare le informazioni contenute nel registro delle attività e nella finestra di dialogo Messaggi della scansione all'accesso, quindi decidere se intraprendere una delle azioni aggiuntive seguenti.

  • Scansione personalizzata degli elementi — Per risultati più precisi, escludere i file legittimi che VirusScan Enterprise potrebbe considerare come minacce ed eliminare le minacce note che potrebbero essere salvate in quarantena.
  • Fare clic con il pulsante destro del mouse sulla finestra di dialogo Messaggi della scansione all'accesso — Per eseguire queste azioni:
    • Pulisci file — Tenta di pulire il file indicato nel messaggio selezionato.
    • Elimina file — Consente di eliminare il file a cui fa riferimento il messaggio selezionato. Il nome del file viene memorizzato nel registro in modo che sia possibile ripristinarlo da Quarantine Manager.
    • Seleziona tutto (Ctrl+A) — Consente di selezionare tutti i messaggi presenti nell'elenco.
    • Rimuovi messaggio dall'elenco (Ctrl+D) — Consente di rimuovere il messaggio selezionato dall'elenco. I messaggi rimossi dall'elenco saranno comunque visibili nel file di registro.
    • Rimuovi tutti i messaggi — Consente di rimuovere tutti i messaggi dall'elenco. I messaggi rimossi dall'elenco saranno comunque visibili nel file di registro.
    • Apri file di registro scansione all'accesso— Consente di aprire il file di registro dell'attività di scansione all'accesso. Questa opzione è disponibile solo nel menu File.
    • Apri file di registro protezione all'accesso — Consente di aprire il file di registro delle attività di protezione all'accesso. Questa opzione è disponibile solo nel menu File.
    • Se per il messaggio corrente non è disponibile alcuna azione, l'icona, il pulsante e le voci di menu corrispondenti verranno disattivati. Ad esempio, l'opzione Pulisci non è disponibile se il file è già stato eliminato e l'opzione Elimina non è disponibile se l'amministratore ha eliminato l'azione.
    • Pulisci file — Non è possibile eseguire la pulizia di un file se il file DAT non dispone di uno strumento di pulitura o se il file è irreparabilmente danneggiato. Se non è possibile eseguire la pulizia del file, lo scanner aggiunge un'estensione MCM al nome e nega l'accesso al file. Nel file di registro viene memorizzata una voce. In questo caso, si consiglia di eliminare il file e di ripristinarlo da una copia di backup pulita.
  • Invio di un esempio a McAfee Labs per l'analisi — Se lo scanner effettua rilevamenti ritenuti inopportuni o non rileva elementi che avrebbero dovuto essere rilevati, è possibile inviare un esempio a McAfee Labs.


Rilevamenti della scansione su richiesta

In caso di rilevamento su richiesta, lo scanner adotta le misure necessarie in base alla configurazione specificata nelle Proprietà della scansione su richiesta della scheda Azioni.

Esaminare le informazioni nel file di registro e quindi decidere se intraprendere una delle azioni aggiuntive seguenti:

  • Scansione personalizzata degli elementi — Consente di ottenere risultati più precisi.
  • Richiedi azione — Configurare lo scanner per la funzione Richiedi azione selezionando l'azione dalla finestra di dialogo Stato scansione su richiesta.
  • Invio di un esempio a McAfee Labs per l'analisi — se lo scanner effettua rilevamenti ritenuti inopportuni o non rileva elementi che avrebbero dovuto essere rilevati, è possibile inviare un esempio a McAfee Labs.


Rilevamenti della scansione della posta elettronica

In caso di rilevamento della scansione della posta elettronica, lo scanner adotta le misure necessarie in base alla configurazione specificata nelle Proprietà della scansione della posta elettronica alla consegna o Proprietà della scansione su richiesta della scheda Azioni.

Esaminare le informazioni nel file di registro e quindi decidere se intraprendere una delle azioni aggiuntive seguenti:

  • Scansione personalizzata degli elementi — Consente di ottenere risultati più precisi.
  • Invio di un esempio a McAfee Labs per l'analisi — se lo scanner effettua rilevamenti ritenuti inopportuni o non rileva elementi che avrebbero dovuto essere rilevati, è possibile inviare un esempio a McAfee Labs.


Elementi in quarantena

Gli elementi che sono rilevati come minacce, vengono puliti o eliminati. Inoltre, una copia dell'elemento viene convertita in formato non eseguibile e salvata nella cartella Quarantena. Ciò consente di eseguire processi sugli elementi in quarantena dopo aver scaricato una versione successiva del file DAT, che probabilmente contiene informazioni in grado di eliminare la minaccia.

Questi processi aggiuntivi includono:

  • Ripristina

  • Ripeti scansione

  • Elimina

  • Verifica falsi positivi

  • Visualizzare le proprietà del rilevamento

Nota: Gli elementi in quarantena includono più tipi di oggetti sottoposti a scansione. Questi oggetti includono file, cookie, registri o qualsiasi altri elemento di cui VirusScan Enterprise esegue la scansione per la ricerca di malware.


Configurazione del criterio quarantena

Accedere ai Criteri di gestione della quarantena e configurare i criteri di quarantena, se necessario, oppure accettare le impostazioni predefinite.

Configurare i Criteri di gestione della quarantena utilizzando le seguenti console dell'interfaccia utente.

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4.0
Console di VirusScan


ePolicy Orchestrator 4.5 o 4.6

Configurare i Criteri di gestione della quarantena utilizzando la seguente console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Quarantena, accettare la directory di quarantena predefinita oppure selezionarne una diversa.
  5. Per configurare i giorni durante i quali vengono salvati gli elementi in quarantena, fare clic su Eliminare automaticamente i dati messi in quarantena dopo il numero di giorni specificato e immettere il Numero di giorni in cui i dati di backup resteranno in quarantena.


ePolicy Orchestrator 4.0

Configurare i Criteri di gestione della quarantena utilizzando la seguente console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Dalla pagina Quarantena, accettare la directory di quarantena predefinita oppure selezionarne una diversa.
  5. Per configurare i giorni durante i quali vengono salvati gli elementi in quarantena, fare clic su Eliminare automaticamente i dati messi in quarantena dopo il numero di giorni specificato e immettere il Numero di giorni in cui i dati di backup resteranno in quarantena.


Console di VirusScan

Configurare i Criteri di gestione della quarantena utilizzando la seguente console dell'interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco Attività, fare clic con il pulsante destro del mouse su Criteri di gestione della quarantena, quindi fare clic su Proprietà per aprire la finestra di dialogo.
  2. Accettare la directory di quarantena predefinita oppure selezionarne una diversa.
  3. Per configurare i giorni durante i quali vengono salvati gli elementi in quarantena, fare clic su Eliminare automaticamente i dati messi in quarantena dopo il numero di giorni specificato e immettere il Numero di giorni in cui i dati di backup resteranno in quarantena.


Gestione degli elementi in quarantena

Elaborare gli elementi di quarantena per sottoporli a ulteriore verifica ed eliminarli o ripristinarli utilizzando la Console di VirusScan.
Nota: Dalla console di ePolicy Orchestrator, selezionare l'attività client Ripristina da quarantena per ripristinare gli elementi in quarantena.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dall'elenco attività di Console di VirusScan, fare clic su Criteri di gestione della quarantena per aprire la finestra di dialogo Criteri di gestione della quarantena.
  2. Fare clic sulla scheda Manager e poi fare clic con il pulsante destro del mouse su un elemento per accedere alle seguenti opzioni avanzate:

    • Ripristina

    • Ripeti scansione

    • Elimina

    • Verifica falsi positivi

    • Visualizzare le proprietà del rilevamento

  3. Viene visualizzata una finestra di dialogo che descrive l'effetto del tentativo effettuato.


Configurazione di avvisi e notifiche

La possibilità di ricevere avvisi al rilevamento di una minaccia potenziale costituisce un aspetto fondamentale per la protezione dell'ambiente di lavoro. È possibile utilizzare la console ePolicy Orchestrator oppure Console di VirusScan, per configurare la modalità di notifica in seguito a un rilevamento. Entrambe le console consentono di configurare le opzioni di avviso, di filtrare gli avvisi in base alla gravità per limitarne il traffico e di configurare le opzioni di avvisi locali.

Attività correlate
Configurazione degli avvisi
Riferimenti correlati
Rilevamenti della scansione all'accesso


Configurazione degli avvisi

Configurare le proprietà degli avvisi e delle notifiche che vengono visualizzate quando una minaccia viene rilevata da diversi scanner.

Utilizzare lo stesso processo per configurare gli avvisi per i seguenti criteri di gestione:
  • Criteri di gestione avvisi
  • Criteri di gestione sovraccarico buffer
  • criteri di scansione della posta elettronica alla consegna

Configurare i criteri di gestione delle notifiche degli avvisi per tutti i e tre i criteri utilizzando le seguenti console di interfaccia utente.

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4,0
Console di VirusScan
Riferimenti correlati
Configurazione della scheda Criteri di gestione avvisi


ePolicy Orchestrator 4.5 o 4.6

Configurare i criteri digestione avvisi utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Menu | Criteri | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Azioni | Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Categoria, selezionare un criterio esistente.
    3. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    4. Immettere il nome di un nuovo criterio.
    5. Immettere eventuali note, se necessario.
    6. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
    7. Dalla colonna Azioni del nuovo criterio, selezionare Modifica impostazione per aprire la pagina di configurazione dei criteri.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Configurare le schede dei criteri di gestione avvisi. Fare riferimento a Configurazione della scheda Criteri di gestione avvisi.


ePolicy Orchestrator 4,0

Configurare i criteri digestione avvisi utilizzando questa console di interfaccia utente.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Fare clic su Sistemi | Catalogo criteri, quindi dall'elenco Prodotto selezionare VirusScan Enterprise 8.8.0. L'elenco Categorie visualizza le categorie di criteri per VirusScan Enterprise 8.8.0.
  2. Modificare un criterio esistente oppure crearne uno nuovo: Modifica di un criterio esistente
    1. Dall'elenco Categoria, selezionare la categoria di criteri.
    2. Dalla colonna Azioni, selezionare Modifica per aprire la pagina di configurazione dei criteri.
    Creazione di un nuovo criterio
    1. Fare clic su Nuovo criterio per aprire la relativa finestra di dialogo.
    2. Dall'elenco Crea un nuovo criterio in base al criterio esistente, selezionare una delle seguenti impostazioni.
    3. Immettere il nome di un nuovo criterio.
    4. Fare clic su OK. Il nuovo criterio appare nell'elenco di quelli esistenti.
  3. Dall'elenco Impostazioni per, selezionare Workstation o Server.
  4. Configurare le schede dei criteri di gestione avvisi. Fare riferimento a Configurazione della scheda Criteri di gestione avvisi.


Console di VirusScan

Configurare le proprietà degli avvisi utilizzando questa console di interfaccia utente.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Aprire una delle seguenti proprietà per configurare gli avvisi:
    • Avvisi — Fare clic su Strumenti | Avvisi per aprire la finestra di dialogo Proprietà avviso.
    • Protezione dall'overflow del buffer — Selezionare l'attività Protezione dall'overflow del buffer, fare clic con il pulsante destro del mouse su Proprietà per aprire la finestra di dialogo Protezione dall'overflow del buffer.
    • Scansione posta elettronica alla consegna — Selezionare l'attività Scansione posta elettronica alla consegna, fare clic con il pulsante destro del mouse su Proprietà per aprire la finestra di dialogo Scansione posta elettronica alla consegna. Fare clic sulla scheda Avvisi.
  2. Configurare le schede dei criteri di gestione avvisi. Fare riferimento a Configurazione della scheda Criteri di gestione avvisi.


Configurazione della scheda Criteri di gestione avvisi

Attività Configurazione
Criteri di gestione avvisi

  1. Dalla colonna Azioni, selezionare Modifica impostazioni per aprire la pagina Criteri di gestione avvisi.

  2. Configurare i Componenti che generano avvisi e le opzioni di Alert Manager.

Criteri di gestione sovraccarico buffer

  1. Dalla colonna Azioni, selezionare Modifica impostazioni per aprire la pagina Protezione dall'overflow del buffer.

  2. Accanto a Invio di avvisi al sistema client, fare clic su Mostra la finestra di dialogo dei messaggi quando viene rilevato un overflow del buffer.

criteri di scansione della posta elettronica alla consegna

  1. Dalla colonna Azioni, selezionare Modifica impostazioni per aprire la pagina Criteri di scansione della posta elettronica alla consegna nel buffer.

  2. Fare clic su Avvisi e configurare Avviso posta elettronica per l'utente e Messaggio di richiesta di azione.


Accesso a query e dashboard

Le query e le dashboard possono essere utilizzate per monitorare le attività e ottenere indicazioni sulle azioni da intraprendere in caso di rilevamenti. È possibile utilizzare le query e le dashboard predefinite nonché crearne di aggiuntive per soddisfare le proprie esigenze. Per informazioni su query e dashboard, vedere la documentazione del prodotto di ePolicy Orchestrator.

Query

A seconda della versione di ePolicy Orchestrator in uso, navigare fino alle query, utilizzando:

ePolicy Orchestrator 4.5 e 4.6
  1. Fare clic su Menu | Segnalazione | Query per visualizzare la pagina delle query.
  2. Nel riquadro delle query, digitare VSE: in Ricerca rapida, quindi fare clic su Applica. Nell'elenco vengono visualizzate solo la query VirusScan Enterprise.
ePolicy Orchestrator 4.0
  1. Fare clic su Menu | Segnalazione | Query per visualizzare la pagina delle query.
  2. Nel riquadro destro dell'elenco delle query, scorrrere fino alle query che iniziano con "VSE:".

Sono disponibili le seguenti query predefinite:

VSE: Conformità negli ultimi 30 giorni

VSE: Rilevamenti di computer con minacce per settimana

VSE: Adozione del file DAT corrente

VSE: Adozione del file DAT nelle ultime 24 ore

VSE: Distribuzione del file DAT

VSE: Riepilogo delle risposte ai rilevamenti

VSE: Numero di rilevamenti per tag

VSE: Spyware rilevato nelle ultime 24 ore

VSE: Spyware rilevato negli ultimi 7 giorni

VSE: Riepilogo delle minacce rilevate nelle ultime 24 ore

VSE: Riepilogo delle minacce rilevate negli ultimi 7 giorni

VSE: Numero di minacce in base al livello di gravità

VSE: Rilevamenti di nomi di minaccia per settimana

VSE: Minacce rilevate nelle ultime 24 ore

VSE: Minacce rilevate negli ultimi 7 giorni

VSE: Minacce rilevate negli ultimi due trimestri

VSE: Rilevamenti di minacce per settimana

VSE: Prime 10 regole di protezione all'accesso violate

VSE: Primi 10 overflow del buffer rilevati più di frequente

VSE: Primi 10 computer con il maggior numero di rilevamenti

VSE: Prime 10 minacce rilevate più di frequente

VSE: Prime 10 origini di minacce

VSE: Prime 10 minacce per categoria di minaccia

VSE: Primi 10 utenti con il maggior numero di rilevamenti

VSE: Programmi indesiderati rilevati nelle ultime 24 ore

VSE: Programmi indesiderati rilevati negli ultimi 7 giorni

VSE: Compatibilità con la versione 8.5

VSE: Compatibilità con la versione 8.7

VSE: Compatibilità con la versione 8.8

Dashboard

Per accedere alle dashboard nella console di ePolicy Orchestrator, passare a Dashboard.

Sono disponibili le dashboard predefinite seguenti:
  • VSE: Compatibilità con la versione 8.8
  • VSE: Dati di andamento
  • VSE: Rilevamenti correnti


Configurazione di DAT di emergenza

I DAT di emergenza possono essere scaricati manualmente per proteggere il sistema da un virus pericoloso, fino a quando viene rilasciato l'aggiornamento DAT VirusScan normale.
Nota: Tali file EXTRA.DAT devono essere scaricati automaticamente come parte degli AutoUpdate del sistema oppure nei processi di pull pianificati di ePolicy Orchestrator. Fare riferimento alla sezioneAggiornamento delle definizione dei rilevamenti.
La configurazione dei DAT di emergenza è un processo che prevede due fasi.
  1. Download del file DAT di emergenza. Questo processo è lo stesso per entrambi i sistemi client e gli archivi ePolicy Orchestrator.
  2. Installazione del file DAT di emergenza. Questo processo è diverso per i sistemi client e per i server ePolicy Orchestrator 4.0 4.5 e 4.6.

Ciascuno di questi processi è decritto in questa sezione.

Sommario

Concetti correlati
Informazioni sui DAT di emergenza
Attività correlate
Download di un file SuperDAT
Installazione dei file SuperDAT in un archivio ePolicy Orchestrator
Installazione del file EXTRA.DAT su un sistema client
Informazioni correlate
Aggiornamento delle definizioni dei rilevamenti


Informazioni sui DAT di emergenza

I DAT di emergenza, denominati file EXTRA.DAT, contengono informazioni utilizzate da VirusScan Enterprise per rilevare un nuovo virus. Quando viene scoperto un nuovo malware ed è necessario effettuare un ulteriore rilevamento, viene reso disponibile un file EXTRA.DAT, insieme al file eseguibile SuperDAT (SDAT), da McAfee Labs fino a quando viene rilasciato l'aggiornamento DAT di VirusScan Enterprise.
Nota: McAfee non rende più disponibili file EXTRA.DAT singoli sul sito di download di Security Updates. Per ottenere un file EXTRA.DAT per una minaccia specifica, andare alla pagina di richiesta di McAfee Avert Labs all'indirizzo https://www.webimmune.net/extra/getextra.aspx.

Pacchetti SuperDAT

L'eseguibile SuperDAT è un pacchetto autoinstallante. Potrebbe anche includere un nuovo motore di scansione virus e altri componenti del programma. Il file utilizza il formato nome sdatXXXX.exe, dove XXXX è il numero di versione DAT a quattro cifre, ad esempio sdat4321.exe.

Quando un file EXTRA.DAT viene estratto dall'eseguibile SuperDAT e aggiunto alla cartella Motore sul disco rigido, viene utilizzato da VirusScan Enterprise, oltre ai file DAT normali, per rilevare un nuovo virus. Ciò consente a VirusScan Enterprise di proteggere il computer dal codice del nuovo malware fino a quando l'aggiornamento DAT ufficiale, contenente le informazioni di rilevamento e rimozione del malware, viene rilasciato. Dopo il rilascio e l'installazione dell'aggiornamento ufficiale di DAT, il file EXTRA.DAT non è più necessario.

Nota: I file EXTRA.DAT rimangono nel file system per 5 giorni e poi vengono automaticamente eliminati. Mantenere i file DAT di VirusScan Enterprise aggiornati scaricando e installando automaticamente gli aggiornamenti quotidiani ufficiali.


Download di un file SuperDAT

Per scaricare un file SuperDAT (SDAT), connettersi alla pagina Security Updates di McAfee.

Informazioni preliminari

  • È necessario disporre di un codice di autorizzazione valido per accedere alla pagina Security Updates di McAfee: http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  • Per aggiornare il software McAfee, è necessario disporre dei privilegi di amministratore.

Attività

  1. Andare alla pagina Security Updates di McAfee al seguente URL: http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  2. Fare clic sulla scheda SuperDAT e poi fare doppio clic sul file sdatXXXX.exe, dove XXXX è il numero dell'aggiornamento DAT più recente.
    Nota: Fare doppio clic sul file readme.txt per ulteriori informazioni.
  3. Salvare il file eseguibile in un percorso temporaneo, utilizzando il relativo nome predefinito.


Installazione dei file SuperDAT in un archivio ePolicy Orchestrator

Dopo aver scaricato il file SuperDAT, è necessario installarlo sul server ePolicy Orchestrator.

Informazioni preliminari

Per aggiornare il software McAfee, è necessario disporre dei privilegi di amministratore.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Per installare il file SuperDAT su un server ePolicy Orchestrator, effettuare una delle seguenti operazioni:
    Server Passaggi...
    ePolicy Orchestrator 4.5 e 4.6
    1. Fare clic su Menu | Software | Archivio principale per aprire i pacchetti nella pagina Archivio principale nella console ePolicy Orchestrator 4.5 e 4.6.
    2. Selezionare Azioni | Archivia pacchetto.
    ePolicy Orchestrator 4.0
    1. Fare clic su Software | Archivio principale per aprire i pacchetti nella pagina Archivio principale.
    2. Fare clic su Archivia pacchetto per aprire la relativa pagina.
  2. Selezionare Super DAT (EXE), andare al percorso dove si desidera salvare il file e fare clic su Avanti.
  3. Confermare la selezione e fare clic su Salva. I pacchetti nella pagina Archivio principale visualizzano il nuovo pacchetto DAT nell'elenco Nome.


Installazione del file EXTRA.DAT su un sistema client

È possibile installare il file EXTRA.DAT su un sistema client autonomo dopo aver scaricato il file da McAfee Labs. Per le informazioni di download del file EXTRA.DAT, consultare Informazioni sui DAT di emergenza.

Informazioni preliminari

Per aggiornare il software di sicurezza McAfee, è necessario disporre dei privilegi di amministratore.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Una volta completato il download, individuare il file salvato, avviare l'eseguibile e seguire le istruzioni nella procedura guidata. Il file EXTRA.DAT eseguibile effettua i seguenti passi:
    • Scarica il software residente in memoria McAfee o interrompe i servizi che utilizzano i file DAT correnti.
    • Copia i nuovi file DAT nelle directory di programma appropriate.
    • Riavvia i componenti software necessari per continuare le scansioni con i nuovi file DAT.
  2. Quando il programma di installazione ha completato l'aggiornamento dei file DAT, è possibile eliminare il file scaricato o mantenere una copia per successivi aggiornamenti.


Parte IV - Monitoraggio, analisi e ottimizzazione della protezione

Dopo la configurazione iniziale della strategia di protezione, è necessario monitorare, analizzare e ottimizzare la protezione. Controllando i file di registro delle attività e le query ePolicy Orchestrator, è possibile migliorare le prestazioni e la protezione dei sistemi VirusScan Enterprise.

Sommario

  • Monitoraggio dell'attività nell'ambiente in uso
  • Analisi della protezione


Monitoraggio dell'attività nell'ambiente in uso

Una fase importante della strategia di protezione è il monitoraggio degli eventi di malware che si verificano nei sistemi. Per effettuare questa operazione, è necessario conoscere gli strumenti da utilizzare e la relativa modalità di utilizzo.


Strumenti per il monitoraggio delle attività

VirusScan Enterprise offre diversi modi per monitorare gli eventi di minaccia che si verificano sui sistemi protetti. Gli strumenti utilizzati variano a seconda che si utilizzi ePolicy Orchestrator o Console di VirusScan.


Utilizzo di query e dashboard

Le query e le dashboard di ePolicy Orchestrator possono essere utilizzate per monitorare le attività sui sistemi gestiti di McAfee e determinare l'azione da intraprendere in caso di rilevamento.

Per ulteriori informazioni su query e dashboard, consultare quanto segue:
  • Per un elenco completo di tutte le query predefinite disponibili, consultare Accesso a query e dashboard.
  • Per informazioni sulla modifica e sulla creazione di query e dashboard, fare riferimento alla documentazione del prodotto ePolicy Orchestrator.
Informazioni correlate
Accesso a query e dashboard


Utilizzo del registro delle attività

Nei registri delle attività di Console di VirusScan viene memorizzata una registrazione degli eventi che si verificano sul sistema protetto VirusScan Enterprise. La tabella seguente descrive i file di registro.

Per impostazione predefinita, tutti i file di registro delle attività vengono memorizzati in uno dei seguenti percorsi, a seconda del sistema operativo:
  • Per Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server e Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Per Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Tabella 1. File di registro
Nome file | Modalità di accesso | Informazioni visualizzate
AccessProtectionLog.txt | Nella colonna Attività, fare clic sulla scheda Protezione dell'accesso | Segnalazioni, quindi fare clic su Visualizza registro. | Data, ora, evento, utente e nome del file.
BufferOverflowProtectionLog.txt | Nella colonna Attività, fare clic sulla scheda Protezione dall'overflow del buffer | Segnalazioni, quindi fare clic su Visualizza registro. | Data, ora, eseguibile che ha causato l'overflow e tipo di overflow: dello stack o dello spazio heap.
MirrorLog.txt
  • Per Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server e Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Per Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Data, ora, percorso dei file di mirror ed eventuali altre informazioni.
OnAccessScanLog.txt | Nella colonna Attività, fare clic sulla scheda Scanner all'accesso | Impostazioni generali |Segnalazioni, quindi fare clic su Visualizza registro. | Data, ora, malware rilevato, azione intrapresa e cosa è stato trovato.
OnDemandScanLog.txt | Scegliere Attività | Visualizza registri dal menu File. | Data, ora in cui è stata effettuata la scansione, azioni intraprese e cosa è stato trovato.
UpdateLog.txt
  • Per Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server e Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Per Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Data, ora in cui è stato effettuato l'aggiornamento, utente che ha avviato l'aggiornamento ed eventuali informazioni sull'aggiornamento.


Esecuzione di una query di esempio

Eseguire una query di esempio per determinare la quantità di minacce che vengono rilevate ogni settimana sui sistemi gestiti. Questa query è solo un esempio. Le query eseguite o configurate dipendono dalle informazioni che si desidera recuperare dal database di ePolicy Orchestrator.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Utilizzare una delle seguenti opzioni per eseguire una semplice query ePolicy Orchestrator:
    • ePolicy Orchestrator 4.5 o 4.6 — Fare clic su Menu | Segnalazione | Query e scorrere verso il basso fino alla query VSE: Rilevamenti di minacce per settimana e fare clic su Esegui.
    • ePolicy Orchestrator 4.0 — Fare clic su Segnalazione | Query e scorrere verso il basso fino alla query VSE: Rilevamenti di minacce per settimana e fare clic su Esegui.
  2. Se viene rilevata una minaccia, l'output della query visualizza quanto segue:
    • Un grafico a barre con il numero di minacce e le settimane in cui si sono verificate.
    • Una tabella con informazioni simili e il totale delle minacce.
    Nota: È possibile fare clic sul grafico a barre o sulle informazioni della tabella per aprire i dati di database di ePolicy Orchestrator.
  3. Fare clic su Chiudi per tornare all'elenco di query.
È possibile eseguire molte altre query predefinite nonché crearne di nuove. Per informazioni dettagliate, consultare la documentazione di ePolicy Orchestrator.


Analisi della protezione

L'analisi della protezione del sistema protetto con VirusScan Enterprise deve essere un processo continuo. Consente di migliorare la protezione e le prestazioni del sistema.

Sommario

Concetti correlati
L'importanza dell'analisi
Attività correlate
Esempi di analisi della protezione


L'importanza dell'analisi

L'analisi della protezione consente di determinare il tipo di minacce che si stanno affrontando, la relativa provenienza, la frequenza con cui vengono rilevate e i sistemi che sono stati presi di mira. Se, ad esempio, un sistema viene attaccato di continuo, è possibile che debba essere spostato in una posizione più sicura della rete e che sia necessario aumentare il livello di sicurezza per proteggerlo.

L'analisi risulta inoltre utile quando:
  • Si creano rapporti per l'IT e i manager.
  • Si acquisiscono le informazioni utilizzate per creare script e query.
  • Si esegue il monitoraggio del tempo di accesso alla rete e l'utilizzo della rete per l'aggiornamento di VirusScan Enterprise.


Esempi di analisi della protezione

È possibile utilizzare i passaggi mostrati nei seguenti esempi di analisi come riferimento da seguire nell'analisi della maggior parte degli scenari di protezione di VirusScan Enterprise.

Questi esempi illustrano il rilevamento di un picco di un attacco malware e il modo in cui viene determinato quanto segue:
  • La posizione e l'ora in cui gli attacchi si sono verificati
  • Il tipo di malware utilizzato nell'attacco
  • Il modo in cui l'attacco ha interessato il sistema

Attività

Attività correlate
ePolicy Orchestrator 4.5 o 4.6
ePolicy Orchestrator 4.0
Console di VirusScan


ePolicy Orchestrator 4.5 o 4.6

Questo esempio di analisi deve essere utilizzato come riferimento per l'analisi della maggior parte degli scenari di protezione diVirusScan Enterprise con ePolicy Orchestrator 4.5 o 4.6

Informazioni preliminari

Per completare questo esempio di analisi, è necessario disporre dell'accesso diretto o remoto a un sistema protetto conVirusScan Enterprise.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Determinare la posizione e l'ora in cui gli attacchi si sono verificati:
    1. Fare clic su Menu | Segnalazione | Query per visualizzare l'elenco delle query.
    2. Digitare Malware nella ricerca Ricerca rapida e fare clic su Applica. La query Malware Detection History viene visualizzata nell'elenco delle query.
    3. Selezionare la query e fare clic su Azioni | Esegui. La query restituirà il numero di attacchi recenti.
  2. Per determinare il malware utilizzato nell'attacco, fare clci su Menu | Segnalazione | Threat Event Log per visualizzare il registro degli eventi di minaccia.
  3. Fare doppio clic sull'elenco del registro per visualizzare la pagina dei dettagli nel riquadro. L'evento del registro include:
    • L'indirizzo IP di orgine della minaccia e l'obiettivo dell'attacco che consentono di determinare le azioni da intraprendere.
    • Il nome della minaccia e il tipo di minaccia che descrivono il malware utilizzato nell'attacco.
    • Le descrizioni degli eventi delle minacce che descrivono il modo in cui l'attacco ha interessato il sistema e le azioni intraprese in relazione alla minaccia.


ePolicy Orchestrator 4.0

Questo esempio di analisi deve essere utilizzato come riferimento per l'analisi della maggior parte degli scenari di protezione diVirusScan Enterprise con ePolicy Orchestrator 4.0

Informazioni preliminari

Per completare questo esempio di analisi, è necessario disporre dell'accesso diretto o remoto a un sistema protetto conVirusScan Enterprise.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Determinare la posizione e l'ora in cui gli attacchi si sono verificati:
    1. Fare clic su Segnalazione | Query per visualizzare l'elenco delle query.
    2. Nell'elenco delle query pubbliche, selezionare ePO: Malware Detection History quindi fare clic su More Actions | Run. La query Malware Detection History viene visualizzata nell'elenco delle query.
  2. Per visualizzare l'evento che ha attivato il rilevamento del malware, fare clic su Segnalazione | Registro eventi, e la query restituirà il numero di attacchi recenti.
  3. Fare doppio clic sull'elenco del registro per visualizzare la pagina dei dettagli nel riquadro. L'evento del registro include:
    • L'indirizzo IP di orgine della minaccia e l'obiettivo dell'attacco che consentono di determinare le azioni da intraprendere.
    • Il nome della minaccia e il tipo di minaccia che descrivono il malware utilizzato nell'attacco.
    • Le descrizioni degli eventi delle minacce che descrivono il modo in cui l'attacco ha interessato il sistema e le azioni intraprese in relazione alla minaccia.


Console di VirusScan

Questo esempio di analisi deve essere utilizzato come riferimento per l'analisi della maggior parte degli scenari di protezione diVirusScan Enterprise con Console di VirusScan.

Informazioni preliminari

Per completare questo esempio di analisi, è necessario disporre dell'accesso diretto o remoto a un sistema protetto conVirusScan Enterprise.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Nell'elenco Attività, fare clic con il pulsante destro del mouse su Scanner all'accesso e selezionare Statistiche. Viene visualizzata la finestra di dialogo Statistiche della scansione all'accesso.
  2. Nel gruppo Statistiche scansione, osservare il numero di file rilevati indicato. Se questo numero è diverso da zero, fare clic su Proprietà per visualizzare la finestra di dialogo Proprietà della scansione all'accesso.
  3. Fare clic sulla scheda Rapporti, quindi su Visualizza registro. Nella finestra del blocco note viene visualizzato il file OnAccessScanLog.txt.
  4. In questo file è possibile determinare:
    • Il tipo di malware utilizzato nell'attacco. Ad esempio:
      C:\...\eicar.com	file di test EICAR
    • Il modo in cui l'attacco ha interessato il sistema. Ad esempio:
      (Pulizia non riuscita. Non è possibile eliminare il virus.)
    • Le azioni intraprese sulla minaccia. Ad esempio:
      Eliminato
  5. Utilizzare le informazioni visualizzate nel passaggio precedente per determinare se i sistemi di origine e di destinazione necessitano la modifica delle impostazioni di protezione antivirus oppure se si desidera intraprendere qualche altra azione.


Appendice

Sono disponibili ulteriori funzioni di configurazione e risoluzione dei problemi che è possibile utilizzare per migliorare la protezione fornita da VirusScan Enterprise. Queste funzioni utilizzano strumenti familiari agli utenti, ad esempio la console di ePolicy Orchestrator, la riga di comando e Internet.

Sommario

  • Configurazione delle attività del server di ePolicy Orchestrator
  • Utilizzo della riga di comando con VirusScan Enterprise
  • Connessione a sistemi remoti
  • Invio di esempi di minacce per l'analisi
  • Accesso alla libreria delle minacce di McAfee Labs
  • Risoluzione dei problemi


Configurazione delle attività del server di ePolicy Orchestrator

Le attività del server, configurate in ePolicy Orchestrator, consentono di pianificare ed eseguire attività automatiche per gestire il server e il software VirusScan Enterprise.

È possibile configurare le attività del server di VirusScan Enterprise per eseguire automaticamente le seguenti operazioni:
  • Esportazione di criteri: consente di eseguire un rapporto di criteri e di memorizzare le informazioni sui criteri in un file.
  • Esecuzione di query: consente di eseguire una query preconfigurata e, qualora impostata, di visualizzare l'output nel dashboard di ePolicy Orchestrator.
  • Esportazione di query : consente di eseguire una query preconfigurata, quindi di inviare il rapporto tramite e-mail oppure di esportarlo in una posizione configurata.
    Nota: La funzionalità di esportazione delle query è disponibile solo utilizzando ePolicy Orchestrator 4.5 e 4.6.
Nel server ePolicy Orchestrator VirusScan Enterprise sono già installate le seguenti attività:
  • VSE: Conformità negli ultimi 30 giorni: consente di eseguire una query una volta al giorno, che memorizza lo stato di conformità del software antivirus McAfee.
  • VSE: Adozione del file DAT nelle ultime 24 ore: consente di eseguire una query ogni ora, che memorizza lo stato della versione DAT del software antivirus McAfee.
Nota: Per configurare le attività del server personalizzate, consultare la guida al prodotto ePolicy Orchestrator appropriata, per ottenere istruzioni dettagliate.


Configurazione dell'attività del server esempi

Per attivare e configurare l'attività del server VSE ePolicy Orchestrator: Conformità negli ultimi 30 giorni esistente.

Informazioni preliminari

Per aggiornare la configurazione di ePolicy Orchestrator, è necessario disporre dei privilegi di amministratore.

Attività

Per le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Aprire la pagina Server Task da ePolicy Orchestrator.
    • ePolicy Orchestrator 4.5 o 4.6 - Fare clic su Menu | Automazione | Attività server.
    • ePolicy Orchestrator 4.0 — Fare clic su Automazione | Attività server.
  2. Nella colonna Nome, individuare VSE: Conformità negli ultimi 30 giorni e fare clic su Modifica nella colonna Azioni. Viene visualizzata la pagina Generatore attività server.
  3. Vicino a Schedule Status, fare clic su Attivato, quindi su Avanti. Viene visualizzata la pagina Azioni. Accanto a 1. Azioni, Esegui query è selezionata per impostazione predefinita.
  4. Accanto a Query, VSE: Compatibilità con la versione 8.8 è selezionata per impostazione predefinita. Modificare l'impostazione Lingua, se necessario. Nel gruppo Azioni secondarie, verificare che le seguenti voci siano selezionate per impostazione predefinita:
    • Genera evento conformità nell'elenco Azioni secondarie.
    • Specific number of target systems è selezionata con il valore 1 nella casella di testo.
  5. Aggiungere le versioni di conformità VirusScan Enterprise 8.7 e 8.5 per l'attività del server:
    1. Nella riga 1. Azioni, fare clic sul segno (+) per visualizzare righe aggiuntive.
    2. Nella nuova riga 2. Azioni, configurare quanto segue:
      • Accanto a 2. Azioni, selezionare Esegui query dall'elenco.
      • Accanto a Query, selezionare VSE: Version 8.7 Compliance dall'elenco.
      • Modificare l'impostazione Lingua, se necessario.
      • Nel gruppo Azioni secondarie, verificare che Genera evento conformità e Specific number of target systems siano selezionate con il valore 1 nella casella di testo.
    3. Nella riga 2. Azioni, fare clic sul segno (+) per visualizzare righe aggiuntive.
    4. Nella nuova riga 3. Azioni, configurare quanto segue:
      • Accanto a 3. Azioni, selezionare Esegui query dall'elenco.
      • Accanto a Query, selezionare VSE: Version 8.5 Compliance dall'elenco.
      • Modificare l'impostazione Lingua, se necessario.
      • Nel gruppo Azioni secondarie, verificare che Genera evento conformità e Specific number of target systems siano selezionate con il valore 1 nella casella di testo.
  6. Fare clic su Avanti per aprire la pagina Pianificazione.
  7. Selezionare dall'elenco Tipo pianificazione la frequenza con cui si desidera eseguire l'attività del server.
    • Impostare la Data di inizio o accettare la data corrente come data predefinita.
    • Impostare la Data di fine o accettare Nessuna data di fine come data predefinita.
    • Impostare la Pianificazione, accettare il valore predefinito o impostare un'altra data di inizio per l'esecuzione della query.
  8. Fare clic su Avanti per aprire la pagina Riepilogo. Verificare che le informazioni siano configurate correttamente.
  9. Fare clic su Salva: viene nuovamente visualizzata la pagina Server Task.
  10. Verificare che l'attività del server VSE: Conformità negli ultimi 30 giorni presenti lo Stato attivato e che le impostazioni di data e ora di Next Run siano corrette.


Utilizzo della riga di comando con VirusScan Enterprise

È possibile utilizzare il prompt dei comandi per eseguire alcuni processi di base di VirusScan Enterprise È possibile installare, configurare e aggiornare VirusScan Enterprise dalla riga di comando. Le opzioni di installazione con questa modalità sono descritte nella Guida all'installazione diVirusScan Enterprise.

Esempio di scansione dalla riga di comando

Per eseguire la scansione di tutti i file, aggiornare i file di registro con i risultati della scansione e chiudere automaticamente la finestra di dialogo Scansione su richiesta quando la scansione è stata completata, immettere il seguente comando:

scan32 /all /log /autoexit

Esempio di aggiornamento dalla riga di comando

Per eseguire l'aggiornamento in background dei file DAT, del motore di scansione e del prodotto, oppure per non visualizzare la finestra di dialogo di aggiornamento di McAfee durante l'aggiornamento, immettere il seguente comando:

mcupdate /update /quiet


Opzioni della riga di comando per la scansione su richiesta

VirusScan Enterprise utilizza lo scanner su richiesta SCAN32.EXE per rilevare le minacce. Per eseguire le scansioni, è possibile utilizzare lo stesso comando eseguibile, SCAN32, dalla riga di comando o come parte di un file batch.

La sintassi di SCAN32 non richiede un ordine specifico degli elementi, ma non è possibile separare una proprietà dal relativo valore. Questa sintassi è costituita da:
  • Nome file: il nome del file eseguibile: SCAN32.EXE.
  • Opzioni: le opzioni sono precedute da una barra (/). Le differenze fra maiuscole e minuscole non vengono rilevate.
Il formato del comando è:

SCAN32 PROPERTY=VALUE [,VALUE] [/option].

Di seguito è riportato un esempio di comando scan32.exe:

scan32.exe PRIORITY /normal

In questo esempio:
  • "PRIORITY" è un valore di comando.
  • "/normal" è un'opzione di valore.

Valori e opzioni di scansione su richiesta

Valore della riga di comando Definizione con opzioni

ALL

Esegue la scansione di tutti i file nella cartella di destinazione.

ALLOLE

Esegue la scansione dei file predefiniti, oltre a tutti i documenti di Microsoft Office.

ALWAYSEXIT

Forza l'uscita dalla scansione su richiesta, anche se la scansione è stata completata con errori o non è riuscita.

APPLYNVP

Esegue la scansione dei programmi potenzialmente indesiderati, definiti nel Criterio per programmi indesiderati.

ARCHIVE

Esegue la scansione di file di archivio quali ZIP, CAP, LZH e UUE.

AUTOEXIT

Esce dalla scansione su richiesta al completamento della scansione non interattiva.

CLEAN

Esegue la pulizia del file di destinazione quando viene rilevato un programma potenzialmente indesiderato.

CLEANA

Esegue la pulizia del file quando viene rilevato un programma indesiderato.

CONTINUE

Continua la scansione dopo il rilevamento di un programma potenzialmente indesiderato.

CONTINUE2

Continua la scansione dopo che è stato rilevato un programma potenzialmente indesiderato e l'azione primaria non è riuscita.

CONTINUEA

Continua la scansione dopo il rilevamento di un programma indesiderato.

CONTINUEA2

Continua la scansione dopo che è stato rilevato un programma indesiderato e l'azione primaria non è riuscita.

DEFEXT

Aggiunge le estensioni dei file specificate come parametri all'elenco dei tipi di file selezionati inclusi nella scansione.

DELETE

Elimina il file quando viene rilevato un programma potenzialmente indesiderato.

DELETE2

Elimina il file quando viene rilevato un programma potenzialmente indesiderato e l'azione primaria non è riuscita.

DELETEA

Elimina il file quando viene rilevato un programma indesiderato.

DELETEA2

Elimina il file quando viene rilevato un programma potenzialmente indesiderato e l'azione primaria non è riuscita.

EDIT

Visualizza la finestra di dialogo delle proprietà di scansione.

EXT

Sostituisce le estensioni dei file presenti nell'elenco dei tipi di file selezionati inclusi nella scansione con le estensioni aggiunte come parametri dopo questo argomento.

LOG

Registra i rapporti relativi ai rilevamenti in un file precedentemente specificato.

LOGFORMAT <valore>

Utilizza il formato specificato per il file di registro. I valori validi sono ANSI, UTF8 o UTF16.

LOGSETTINGS

Registra le impostazioni di configurazione di una scansione.

LOGSUMMARY

Registra un riepilogo dei risultati di scansione.

LOGUSER

Registra le informazioni di identificazione relative all'utente che esegue una scansione.

MHEUR

Attiva il rilevamento Artemis delle minacce rappresentate da macro.

MIME

Rileva i programmi potenzialmente indesiderati nei file con codifica MIME (Multipurpose Internet Mail Extensions).

NOESTIMATE

Non calcola le dimensioni dell'attività di scansione dei file prima dell'inizio della stessa. La barra di avanzamento non viene visualizzata.

PHEUR

Attiva il rilevamento Artemis delle minacce non rappresentate da macro.

PRIORITY

Imposta la priorità della scansione in relazione ad altri processi della CPU. Richiede una delle seguenti opzioni:
  • BASSO
  • BELOWNORMAL — L'impostazione predefinita di ePolicy Orchestrator.
  • NORMAL — L'impostazione predefinita di Console di VirusScan.
Nota: È possibile immettere un parametro numerico da 1 a 100, dove 10 è uguale a LOW, 50 è uguale a BELOWNORMAL e 100 è uguale a NORMAL.

PROMPT

Richiede l'azione dell'utente al rilevamento di un programma potenzialmente indesiderato.

PROMPT2

Richiede l'azione dell'utente quando viene rilevato un programma potenzialmente indesiderato e l'azione primaria non è riuscita.

PROMPTA

Richiede l'azione dell'utente al rilevamento di un programma indesiderato.

PROMPTA2

Richiede l'azione dell'utente quando viene rilevato un programma indesiderato e l'azione primaria non è riuscita.

RPTSIZE

Imposta le dimensioni del registro avvisi, in megabyte.

START

Esegue la scansione. Non visualizza la finestra di dialogo delle proprietà.

TASK

Avvia l'attività dello scanner su richiesta specificata nella Console di VirusScan. Richiede parametri aggiuntivi che definiscano l'ID dell’attività specificata memorizzato nel registro in: hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.

UINONE

Avvia la scansione senza visualizzare l'interfaccia utente.


Opzioni della riga di comando per l’attività di aggiornamento

VirusScan Enterprise utilizza MCUPDATE.EXE per eseguire le attività di aggiornamento. Per eseguire le attività di aggiornamento, è possibile utilizzare lo stesso comando eseguibile, MCUPDATE, dalla riga di comando o come parte di un file batch.

La sintassi di MCUPDATE non richiede un ordine specifico degli elementi, ma non è possibile separare una proprietà dal relativo valore. La sintassi è costituita da:
  • Nome file: il nome del file eseguibile: MCUPDATE.EXE.
  • Opzioni: le opzioni sono precedute da una barra (/). Le differenze fra maiuscole e minuscole non vengono rilevate.
Il formato del comando è:
MCUPDATE [/<tipo> [/TASK <guid>]] [/opzione].
Nota: Nel precedente formato, <tipo> può essere ROLLBACKDATS o UPDATE.

La clausola /TASK è facoltativa; tuttavia, se viene utilizzata, è necessario specificare anche un ID (guid) dell'attività di aggiornamento. L'ID dell'attività selezionato deve essere relativo a un'attività di aggiornamento o ripristino del file DAT. Non selezionare un ID di scansione. Se non si specifica un ID dell'attività, verrà utilizzata l'attività di aggiornamento predefinita. Gli ID delle attività si trovano in: hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

La clausola /opzione non è obbligatoria. Per eseguire un'attività di aggiornamento in modalità non interattiva, utilizzare l'opzione /QUIET.
Nota: L'opzione /QUIET non è supportata per l'utilizzo con l'attività di ripristino del file DAT. Nell'esempio seguente viene eseguita un'attività di aggiornamento in modalità non interattiva: MCUPDATE /UPDATE /QUIET.

Opzioni attività di aggiornamento

Opzione della riga di comando | Definizione
ROLLBACKDATS | Ripristina il file DAT corrente all'ultima versione di cui è stato eseguito il backup.
UPDATE | Esegue un aggiornamento del file DAT, del motore di scansione, del prodotto o del file extra.dat.
/TASK | Avvia l'attività di aggiornamento automatico o di ripristino DAT specificata nella Console di VirusScan. Richiede un parametro aggiuntivo che definisca l'ID dell’attività memorizzato nel registro in: hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | Esegue l'attività in modalità non interattiva.


Connessione a sistemi remoti

È possibile connettersi a sistemi remoti su cui è installato VirusScan Enterprise per eseguire operazioni quali la modifica o la pianificazione delle attività di scansione o di aggiornamento oppure l'attivazione e disattivazione della scansione all'accesso in un sistema remoto.
Nota: Se non si dispone dei diritti di amministratore per connettersi al sistema remoto, verrà visualizzato il messaggio Diritti utente insufficienti, accesso negato.

Quando si avvia la Console remota di VirusScan, il nome del sistema a cui si è connessi viene visualizzato nella barra del titolo della console. Se non si è connessi ad alcun sistema nella rete, sulla barra del titolo non è visualizzato il nome del sistema locale in uso. Quando si apre una finestra di dialogo delle proprietà di qualsiasi attività da una console remota, il nome del sistema in uso sarà visualizzato nella barra del titolo della finestra di dialogo delle proprietà.

È possibile aprire più console remote. Quando si chiude la finestra di dialogo Connetti al computer remoto, anche la connessione al sistema remoto viene chiusa.


Accesso ai sistemi remoti su cui è installato VirusScan Enterprise

Per eseguire la connessione ai sistemi remoti che si desidera amministrare, con VirusScan Enterprise installato, utilizzare la funzione Apri console remota sulla Console di VirusScan.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? nell'interfaccia.

  1. Dal menu Strumenti sulla Console VirusScan Enterprise 8.8, selezionare Apri console remota.
  2. In Connetti al computer, immettere il nome del sistema che si desidera amministrare e selezionare un sistema dall'elenco oppure fare clic su Sfoglia per individuare il sistema sulla rete.
    Nota: Se si utilizzano variabili di ambiente durante la configurazione del nome del percorso del file o della cartella per un'attività remota, accertarsi che tali variabili esistano nel sistema remoto. La Console di VirusScan Enterprise 8.8 non consente di convalidare le variabili di ambiente nel sistema remoto.
  3. Fare clic su OK per tentare una connessione al sistema di destinazione. Quando si esegue la connessione al sistema remoto:
    • La barra del titolo cambia e indica il nome del sistema.
    • La console legge il registro di sistema del sistema remoto e ne visualizza le attività.
    • È possibile aggiungere, eliminare o riconfigurare le attività per il sistema remoto.


Invio di esempi di minacce per l'analisi

Se si individua una minaccia potenziale non rilevata oppure se lo scanner rileva una minaccia che potrebbe non essere tale, utilizzando il file DAT corrente è possibile inviare un esempio della minaccia ai McAfee Labs mediante WebImmune. L'esempio verrà analizzato dai McAfee che ne valuteranno l'inclusione nel file DAT.

È possibile inviare un esempio ai McAfee Labs in tre modi: accedendo al sito Web WebImmune, mediante posta elettronica o per posta ordinaria.

WebImmune

  1. Per accedere al sito Web, dalla Console di VirusScan, selezionare ? | Invia un esempio. L’indirizzo del sito Web è il seguente: https://www.webimmune.net/default.asp.
  2. Accedere al proprio account gratuito, oppure crearne uno.
  3. Caricare i file da analizzare direttamente nei sistemi automatizzati di McAfee Labs. Qualora sia necessario eseguire ulteriori ricerche, il problema viene inoltrato agli analisti di McAfee Labs.

E-mail

È possibile inviare messaggi di posta elettronica direttamente ai sistemi automatizzati di McAfee per richiedere l'esame degli esempi. Qualora sia necessario eseguire ulteriori ricerche, il problema viene inoltrato agli analisti di McAfee Labs.

L'indirizzo di posta elettronica a cui inviare gli esempi è virus_research@avertlabs.com.
Nota: Ulteriori indirizzi di posta elettronica locali sono disponibili sul sito Web WebImmune.

Posta ordinaria

L'indirizzo è disponibile sul sito Web WebImmune.
Nota: Si tratta del metodo meno opportuno in quanto implica tempi di completamento delle analisi più lunghi.


Accesso alla libreria delle minacce di McAfee Labs

Per accedere alla libreria delle minacce di McAfee Labs dalla Console di VirusScan Enterprise 8.8, selezionare Libreria delle minacce di McAfee Labs dal menu ?. Il browser Internet si apre con la connessione a http://vil.nai.com/vil/default.aspx.


Risoluzione dei problemi

Prima di contattare il supporto tecnico di McAfee, leggere le informazioni in questa sezione. Sono contenuti i processi e gli strumenti che è possibile utilizzare per irolvere i problemi di configurazione di VirusScan Enterprise e le domande frequenti.


Riparazione dell'installazione del prodotto

Talvolta si rende necessario riparare l'installazione di VirusScan Enterprise per ripristinare l'impostazione predefinita, reinstallare i file di programma o eseguire entrambe le operazioni. È possibile effettuare queste operazioni dalla Console di VirusScan o dalla riga di comando.

Utilizzo di Console di VirusScan

Per accedere all'utilità Ripara installazione, aprire la Console di VirusScan Enterprise 8.8 e selezionare ? | Ripara installazione.
Nota: Questa funzione non è disponibile nella console di ePolicy Orchestrator.
Opzioni | Definizione
Ripristina tutte le impostazioni sui valori predefiniti di installazione | Consente di ripristinare le impostazioni di scansione predefinite di VirusScan Enterprise. ATTENZIONE: È possibile che le impostazioni personalizzate vengano perse.
Reinstalla tutti i file del programma | Consente di reinstallare tutti i file del programma VirusScan Enterprise. ATTENZIONE: È possibile che vengano sovrascritti gli aggiornamenti rapidi, le patch e i Service Pack.

Utilizzo di SETUPVSE.exe dalla riga di comando

Per riparare o reinstallare VirusScan Enterprise dalla riga di comando mediante il comando SETUPVSE.exe, utilizzare i seguenti comandi.
Nota: Per le opzioni dei parametri della riga di comando REINSTALLMODE, fare riferimento a Proprietà REINSTALLMODE all'indirizzo http://msdn.microsoft.com/en-us/library/aa371182(VS.85).aspx.
Descrizione | Comando
Installa solo i file di programma | SETUPVSE.exe REINSTALLMODE=sec /q
Installa solo i file di registro | SETUPVSE.exe REINSTALLMODE=secum /q
Installa sia i file di programma che di registro | SETUPVSE.exe REINSTALLMODE=amus /q

Utilizzo di msiexec.exe dalla riga di comando

Per riparare o reinstallare VirusScan Enterprise dalla riga di comando mediante il comando msiexec.exe, utilizzare i seguenti comandi.
Nota: Per le opzioni della riga di comando msiexec.exe, fare riferimento a Opzioni della riga di comando per lo strumento Microsoft Windows Installer Msiexec.exe all'indirizzo http://support.microsoft.com/kb/314881.
Descrizione | Comando
Installa solo i file di programma | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=sa /q REBOOT=R
Installa solo i file di registro | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=mu /q REBOOT=R
Installa sia i file di programma che di registro | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=samu /q REBOOT=R


Visualizzazione del file di registro dell'attività all'accesso

Il file di registro dell'attività all'accesso di Console di VirusScan visualizza la cronologia degli aggiornamenti, le attività di minaccia e il modo in cui VirusScan Enterprise ha risposto. Queste informazioni possono risultare utili durante la risoluzione dei problemi relativi alle configurazioni delle attività di aggiornamento automatico e dei criteri.

Per accedere ai file di registro dell'attività all'accesso, utilizzare uno dei seguenti processi:
Nota: Il processo di creazione del file di registro dell'attività all'accesso deve essere abilitato. Per abilitare il file di registro dell'attività all'accesso, fare riferimento a Configurazione delle impostazioni generali.

Attività

Per ottenere le definizioni delle opzioni, fare clic su ? su ciascuna scheda.
  1. Dall'elenco delle attività, fare clic con il pulsante destro del mouse su Scanner all'accesso, quindi su Proprietà per visualizzare la finestra di dialogo.
  2. Nella finestra di dialogo Proprietà della scansione all’accesso, fare clic sulla scheda Rapporti, quindi su Visualizza registro. Nella finestra del blocco note viene visualizzato il file OnAccessScanLog.txt. Di seguito viene fornito un esempio dell'output del file di registro.

  3. Nella seguente tabella viene fornita una descrizione dei dati contenuti nel precedente esempio su OnAccessScanLog.txt:
    Esempio di voce di registro | Descrizione
    4/27/2010 | Data
    13:35:47 | Ora
    Pulito/Eliminato/Nessuna azione intrapresa | Azione intrapresa
    File aggiornato = versione, o (Pulitura non eseguita a causa ... | Descrizione dell'azione
    SRVR\utente | Credenziali
    C:\WINDOWS\system32\NOTEPAD.EXE C:\temp\eicar.com | Nome e percorso del file minaccia
    file di test EICAR (Test) | Descrizione del file.

Informazioni simili vengono rese disponibili se si utilizzano le query di ePolicy Orchestrator. Per ulteriori informazioni, consultare Accesso a query e dashboard.

Attività correlate
Configurazione delle impostazioni generali
Informazioni correlate
Accesso a query e dashboard


Utilizzo dello strumento MER durante la risoluzione dei problemi

Lo strumento dei requisiti minimi di escalation (MER) raccoglie i McAfee dati di VirusScan Enterprise e di un altro prodottoMcAfee dal computer. L'utilizzo di tali dati consente al supporto tecnico di McAfee di analizzare e risolvere il problema.

È possibile scaricare lo strumento WebMER in uno dei seguenti formati:
  • EXE
  • ZIP
  • ProtectedZip
Le informazioni raccolte tramite lo strumento WebMER comprendono:
  • Dettagli relativi al Registro di sistema
  • Dettagli relativi alla versione dei file
  • File
  • Registri eventi
  • Dettagli relativi ai processi
Per utilizzare lo strumento WebMER, è necessario completare le seguenti operazioni:
  • Vedere il tutorial Obtaining Minimum Escalation Requirements using McAfee WebMER, disponibile all'indirizzo: https://kc.mcafee.com/corporate/index?page=content&id=TU30146.
  • Ottenere e installare lo strumento dal sito: http://mer.mcafee.com.
    Nota: È disponibile anche una versione distribuibile di ePolicy Orchestrator. Questa versione utilizza la console di ePolicy Orchestrator per eseguire lo strumento MER su computer client per la raccolta di registri e informazioni durante la diagnosi dei problemi del prodotto McAfee. Scaricare lo strumento MER di McAfee per le versioni ePolicy Orchestrator 4.x (v2.0) dal sito: http://mer.mcafee.com/enduser/downloadepomer.aspx.
  • Eseguire lo strumento e inviare il rapporto al supporto tecnico di McAfee.


Disattivazione di VirusScan Enterprise durante la risoluzione dei problemi

Nel caso si verifichi un problema al sistema riconducibile ai processi eseguiti da VirusScan Enterprise, è possibile disattivare sistematicamente le funzioni di VirusScan Enterprise fino all'eliminazione del problema. In alternativa, è possibile eliminare VirusScan Enterprise in quanto causa del problema.
ATTENZIONE:
Per ripristinare la protezione da malware completa, è necessario riconfigurare o ripristinare VirusScan Enterprise al termine della risoluzione dei problemi.
La disattivazione sistematica della funzionalità VirusScan Enterprise si suddivide nei seguenti otto passaggi:
  1. Disattivazione della protezione da overflow del buffer
  2. Disattivazione della protezione all'accesso
  3. Disattivazione di ScriptScan
  4. Disattivazione della scansione all'accesso
  5. Disattivazione della scansione all'accesso e riavvio del sistema
  6. Blocco del caricamento di MFEVTP e riavvio del sistema
  7. Ridenominazione di mfehidk.sys e riavvio del sistema
  8. Rimozione del prodotto e riavvio del sistema

Ciascuno di questi otto passaggi è descritto nelle sezioni seguenti. Per ottenere le definizioni delle opzioni in Console di VirusScan, fare clic su ? nell'interfaccia.

Disattivazione della protezione da overflow del buffer

Seguire questi passaggi per disattivare la protezione da overflow del buffer.
  1. Dall'elenco delle attività di Console di VirusScan, fare clic con il pulsante destro del mouse su Protezione da overflow del buffer e fare clic su Proprietà.
  2. Nella finestra di dialogo Proprietà deselezionare Attiva protezione dell'overflow del buffer e fare clic su OK.
  3. La disattivazione della protezione da overflow del buffer può risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a questa funzionalità.

Disattivazione della protezione all'accesso

Seguire questi passaggi per disattivare la protezione all'accesso.
  1. Dall'elenco delle attività di Console di VirusScan fare doppio clic su Protezione all'accesso per aprire la finestra di dialogo Proprietà della protezione all'accesso.
  2. Fare clic sulla scheda Protezione all'accesso, deselezionare Attiva protezione all'accesso e fare clic su OK.
  3. La disattivazione della protezione all'accesso può risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a VirusScan Enterprise

Disattivazione di ScriptScan

Seguire questi passaggi per disattivare ScriptScan.
  1. Dall'elenco delle attività di Console di VirusScan fare clic con il pulsante destro del mouse su Scanner all'accesso per aprire la finestra di dialogo Proprietà dello scanner all'accesso.
  2. Fare clic sulla scheda ScriptScan, deselezionare Attiva la scansione degli script e fare clic su OK.
  3. La disattivazione di ScriptScan può risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a VirusScan Enterprise

Disattivazione della scansione all'accesso

Seguire questi passaggi per disattivare la scansione all'accesso.
  1. Disattivare la protezione all'accesso. Dall'elenco delle attività di Console di VirusScan fare clic con il pulsante destro del mouse su Protezione all'accesso e selezionare Disattiva.
  2. Modificare il tipo di avvio dell'applet McShield Services su Disattivata nei seguenti modi:
    • Fare clic su Start | Pannello di controllo | Strumenti di amministrazione | Servizi per aprire l'applet Servizi.
    • In Servizi (computer locale), scorrere l'elenco dei servizi e fare clic con il pulsante destro del mouse su McAfee McShield per aprire la finestra di dialogo Proprietà di McAfee McShield.
    • Fare clic sula scheda Generale e nell'elenco Tipo di avvio fare clic su Disabilitato e quindi su OK.
  3. Nell'elenco delle attività di Console di VirusScan, fare clic con un pulsante destro del mouse su Scanner all'accesso e quindi su Disattiva dall'elenco che viene visualizzato. Intorno all'icona Scanner all'accesso compare un cerchio con una barra trasversale per indicare che la funzione è disattivata.
  4. La disattivazione della scansione all'accesso può risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a questa funzionalità.

Disattivazione della scansione all'accesso e riavvio del sistema

Seguire questi passaggi per disattivare la scansione all'accesso e riavviare il sistema.
Nota: Per poter eseguire il processo descritto di seguito occorre che la scansione in accesso disattivata come indicato nella sezione precedente non sia stata riattivata.

  1. Eseguire l'arresto e il riavvio completo del sistema.
  2. Il riavvio del sistema in seguito alla disattivazione della scansione all'accesso possono risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a questa funzionalità.

Blocco del caricamento di MFEVTP e riavvio del sistema

Seguire questi passaggi per impedire il caricamento di MFEVTP (Validation Trust Protection Service) di McAfee e riavviare il sistema:
ATTENZIONE:
questa sezione contiene informazioni sull'apertura o modifica del registro di sistema.
  • Le informazioni seguenti sono rivolte agli amministratori di sistema. Le modifiche dei registro di sistema sono irreversibili e possono causare errori di sistema se non effettuate in modo adeguato.
  • Prima di procedere, McAfee consiglia vivamente di eseguire un backup del registro di sistema e di apprendere le modalità di ripristino. Per ulteriori informazioni, vedere: http://support.microsoft.com/kb/256986 .
  • Non eseguire un file .REG non indicato esplicitamente come file di importazione del registro autentico.

  1. Nella riga di comando, digitare regedit per visualizzare l'interfaccia utente dell'Editor del Registro di sistema.
  2. Individuare la seguente voce di Registro: [HKEY_LOCAL_MACHINE\System\ControlSet001\Services\mfevtp]
  3. Nel riquadro a destra, fare clic con il pulsante destro del mouse su Avvia e fare clic su Modifica per visualizzare la finestra di dialogo Modifica valore DWORD.
  4. Nel campo Dati valore immettere 4 e fare clic su OK.
  5. Impedendo il caricamento di MFEVTP e riavviando il sistema, il problema può essere risolto?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a questa funzionalità.

Ridenominazione del file mfehidk.sys e riavvio del sistema

Seguire questi passaggi per rinominare il file mfehidk.sys file e riavviare il sistema.
  1. Individuare il file mfehidk.sys nella seguente cartella, a seconda del sistema operativo in uso:
    • Per i sistemi operativi a 32 bit: %windir%\System32\drivers
    • Per i sistemi operativi a 64 bit: %windir%\System64\drivers
  2. Rinominare il file da mfehidk.sys a mfehidk.sys.salvato, ad esempio.
  3. Riavviare il sistema per arrestare e riavviare VirusScan Enterprise senza caricare il file mfehidk.sys.
  4. La ridenominazione del file mfehidk.sys e il riavvio del sistema possono risolvere il problema?
    • Sì: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.
    • No: il problema di sistema probabilmente non è riconducibile a VirusScan Enterprise

Rimozione del prodotto e riavvio del sistema

Seguire questi passaggi per rimuovere completamente VirusScan Enterprise e riavviare il sistema:.
  1. Rimuovere i file di programma di VirusScan Enterprise. Fare riferimento a McAfee VirusScan Enterprise 8.8, Guida all'installazione per istruzioni dettagliate.
  2. Eseguire il riavvio per arrestare il sistema operativo e riavviarlo senza VirusScan Enterprise installato.
  3. La rimozione completa dei file di programma di VirusScan Enterprise e il riavvio possono risolvere il problema?
    • Sì: il problema del sistema era probabilmente riconducibile a VirusScan Enterprise
    • No: andare al ServicePortal dell'Assistenza tecnica McAfee all'indirizzo http://mysupport.mcafee.com e cercare una soluzione oppure contattare l'Assistenza tecnica McAfee.


Strumenti di supporto e di risoluzione dei problemi consigliati

In qualità di amministratore di VirusScan Enterprise è necessario installare e configurare alcuni strumenti per la risoluzione dei problemi e la valutazione del sistema di sicurezza e delle relative prestazioni. Nel momento in cui viene contattato il supporto tecnico di McAfee, può essere richiesta l'esecuzione di questi strumenti per la risoluzione dei problemi di configurazione. È possibile scaricare strumenti di risoluzione dei problemi dai siti Internet elencati nelle seguenti tabelle.

Strumenti McAfee

Gli strumenti di supporto e di risoluzione dei problemi che è possibile scaricare da McAfee, sono elencati nella seguente tabella.

Strumento | Sito di download
Strumento MER | WebMER
ProcessCounts | Fornito dal supporto McAfee
SuperDAT Manager | Fornito dal supporto McAfee
McAfee Profiler | Fornito dal supporto McAfee

Strumenti non McAfee

Nella seguente tabella sono elencati gli strumenti di supporto e di risoluzione dei problemi, insieme al file eseguibile e al sito di download.

Strumento | Eseguibile | Sito di download
Driver Verifier | Verifier | Microsoft.com
Performance Monitor | PerfMon | Microsoft.com
Pool Monitor | PoolMon | Microsoft.com
Process Monitor | ProcMon | Microsoft.com
Process Explorer | ProcExp | Microsoft.com
Process Dump | ProcDump | Microsoft.com
Windows Object Viewer | WinObj | Microsoft.com
TCP Viewer | TCPView | Mircosoft.com
Debug Output Viewer | DebugView | Microsoft.com
Windows Debugger | WinDbg | Microsoft.com
Kernel Rate Viewer | KrView | Microsoft.com
Strumenti di analisi delle prestazioni di Windows | Xperf | Microsoft.com
VM Converter | Varies | Vmware.com
WireShark | wireshark | Wireshark.org


Domande frequenti

Questa sezione contiene informazioni sulla risoluzione dei problemi sotto forma di domande frequenti.

Installazione

  • Domanda: Ho appena installato il software utilizzando la modalità non interattiva, ma nella barra delle applicazioni di Windows non è visualizzata l'icona di VirusScan Enterprise.

    Risposta: Per visualizzare l'icona a forma di scudo nella barra delle applicazioni, riavviare il sistema. In ogni caso, nonostante l'icona non sia visualizzata, VirusScan Enterprise è in esecuzione e il sistema è protetto. Per verificarlo, controllare la seguente chiave del registro di sistema: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • Domanda: Perché non tutti gli utenti in rete possono configurare impostazioni personalizzate?

    Risposta: L'amministratore potrebbe aver configurato l'interfaccia utente in modo tale da proteggere con password le attività. In questo caso le impostazioni non possono essere modificate. Inoltre, i diversi sistemi operativi di Microsoft Windows sono caratterizzati da una diversa assegnazione di privilegi utente. Per ulteriori informazioni sui privilegi degli utenti, consultare la documentazione di Microsoft Windows.

Programmi bloccati

  • Domanda: Dopo l’installazione di VirusScan Enterprise uno dei miei programmi non funziona.

    Risposta: È possibile che il programma sia bloccato da una regola di protezione all’'accesso.
    1. Esaminare il file di registro della protezione all'accesso per determinare se il programma è stato bloccato da una regola.
    2. Se il programma è elencato nel registro, è possibile inserirlo nell’elenco delle esclusioni dalla regola oppure disattivare la regola stessa. Per ulteriori informazioni, vedere Protezione dei punti di accesso del sistema.

Rilevamento di cookie

  • Domanda: Durante l’analisi dei rilevamenti di cookie nel registro delle attività di scansione su richiesta, ho notato che il rilevamento del nome del file è sempre 00000000.ie. Per quale motivo VirusScan Enterprise assegna lo stesso nome a tutti i rilevamenti di cookie durante la scansione su richiesta, mentre altri programmi assegnano a ciascun rilevamento di cookie il proprio nome oppure un nome incrementale?

    Risposta: VirusScan Enterprise assegna lo stesso nome a ciascun rilevamento di cookie a causa del modo in cui lo scanner su richiesta rileva e gestisce i cookie. Questo comportamento si applica solo ai cookie rilevati durante la scansione su richiesta. Un cookie potrebbe contenere a sua volta diversi cookie. Il motore di scansione considera i file dei cookie come archivi, assegnando loro un valore basato su un offset dall’inizio del file (iniziando da zero). Poiché lo scanner utilizza il motore di scansione per rilevare e gestire ciascun cookie prima di procedere con la scansione, il valore viene impostato su zero per ciascun rilevamento. Di conseguenza, a ciascun rilevamento viene assegnato il nome 00000000.ie. Altri prodotti rilevano tutti i cookie, assegnando a ciascuno il proprio nome oppure un nome incrementale, quindi eseguono le operazioni su ciascun rilevamento.

Generale

  • Domanda: Su sistema VirusScan Enterprise autonomo, l'icona di sistema nella barra delle applicazioni sembra essere disattivata.

    Risposta: Un cerchio rosso barrato sovrapposto all'icona di VirusScan Enterprise indica che la scansione all'accesso è disattivata. Di seguito sono elencate le cause più comuni e le relative soluzioni. Se nessuna delle soluzioni elencate consente di risolvere il problema riscontrato, contattare l'Assistenza tecnica.
    1. Verificare che la scansione all'accesso sia attivata. Fare clic con il pulsante destro del mouse sull’icona di VirusScan Enterprise nella barra delle applicazioni. Se la scansione all'accesso è disattivata, fare clic su Attiva scansione all'accesso.
    2. Verificare che il servizio McShield sia in esecuzione.
      • Avviare manualmente il servizio dal Pannello di controllo dei servizi.
      • Selezionare Start | Esegui e digitare Net Start McShield.
      • Impostare l'avvio automatico del servizio dal Pannello di controllo dei servizi.

  • Domanda: Si verifica un errore durante il download del file CATALOG.Z.

    Risposta: Questo errore può avere molte cause. Di seguito sono riportati alcuni suggerimenti per determinare l'origine del problema.
    • Se gli aggiornamenti vengono scaricati dal sito di download predefinito di McAfee, verificare se è possibile scaricare il file CATALOG.Z tramite un browser Web. Provare a eseguire il download dal seguente sito Web: http://update.nai.com/Products/CommonUpdater/catalog.z.
    • Se il file è visibile, ma non è possibile scaricarlo (in altre parole, il browser non consente di scaricarlo), si è verificato un problema con il proxy ed è necessario contattare l’amministratore di rete.
    • Se è possibile scaricare il file, anche VirusScan Enterprise deve essere in grado di eseguire il download. Per ricevere assistenza per la risoluzione dei problemi riscontrati nella propria installazione di VirusScan Enterprise, contattare il supporto tecnico.

  • Domanda: Qual è l'indirizzo del sito di download tramite HTTP?

    Risposta:
    • Il percorso del sito download di McAfee è: http://www.mcafee.com/us/downloads/.
    • Il file CATALOG.Z, contenente gli ultimi aggiornamenti, è scaricabile dal seguente sito Web: http://update.nai.com/Products/CommonUpdater/catalog.z.

  • Domanda: Qual è l'indirizzo del sito di download tramite FTP?

    Risposta:
    • Il percorso del sito di download FTP è: ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x.
    • Il file CATALOG.Z, contenente gli ultimi aggiornamenti, è scaricabile dal seguente sito: ftp://ftp.mcafee.com/CommonUpdater/catalog.z.

  • Domanda: Se viene rilevato un programma potenzialmente indesiderato ed è stata selezionata l'opzione Richiedi azione, quale azione è opportuno scegliere: Pulisci o Elimina?

    Risposta: In genere, se non si è sicuri di quale operazione eseguire su un file rilevato, si consiglia di scegliere Pulisci. Lo scanner all'accesso e su richiesta esegue automaticamente una copia di backup degli elementi nella directory di quarantena prima di pulirli o eliminarli.


Scheda Protezione all'accesso

Definizioni delle opzioni

Consente di configurare le regole di protezione all'accesso e impedire l'interruzione dei processi McAfee.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni della protezione all'accesso
  • Attiva protezione all'accesso: consente di attivare la funzionalità di protezione all'accesso.
  • Impedisci l'arresto dei servizi McAfee: consente di impedire agli utenti che non dispongono dei privilegi di debug di interrompere i processi McAfee.

    Gli utenti che dispongono del privilegio Debug di programmi potranno comunque terminare i processi McAfee anche se questa opzione è selezionata.

    Per impostazione predefinita, gli amministratori dispongono dei privilegi Debug di programmi per i sistemi operativi Windows XP e Windows 2003. Rimuovere tali privilegi dalle autorizzazioni concesse agli utenti in modo che non possano interrompere i processi McAfee.

ATTENZIONE:
Se non si attiva la protezione all'accesso per impedire l'interruzione dei servizi McAfee, il sistema risulterà non protetto da numerosi attacchi malware.
Regole di protezione all'accesso

Categorie: selezionare una categoria per visualizzare le regole ad essa associate. Le regole sono organizzate nelle seguenti categorie:

  • Protezione antivirus standard
  • Protezione antivirus massima
  • Controllo diffusione antivirus
  • Protezione comune standard
    ATTENZIONE:
    Se non si configura la Protezione comune standard e si attivano Blocca e Segnala per le seguenti regole, il sistema non sarà protetto contro numerosi attacchi malware:
    • Impedisci la modifica dei file e delle impostazioni di McAfee.
    • Impedisci modifica file e impostazioni di McAfee Common Management Agent di McAfee.
    • Impedisci modifica file e impostazioni del motore di scansione di McAfee.
    • Impedisci interruzione dei processi di McAfee.
  • Protezione comune massima
  • Protezione della macchina virtuale
  • Regole definite dall'utente
  • Protezione AntiSpyware standard
  • Protezione AntiSpyware massima

Per ulteriori informazioni, vedere Modalità di definizione delle regole di protezione all'accesso.

Blocca/Segnala/Regole — Configurare le regole come segue:

  • Blocca— Consente di bloccare i processi specificati nella finestra di dialogo Dettagli regola. Per attivare o disattivare la regola, selezionare o deselezionare Blocca.

    Nota:

    Per bloccare i tentativi di accesso senza registrarli, selezionare Blocca ma non selezionare Segnala.

  • Segnala — Consente di attivare la segnalazione dei tentativi di violazione della protezione all'accesso. Al verificarsi di un rilevamento, le informazioni vengono memorizzate nel registro delle attività.
    Nota:

    Per ricevere un avviso senza bloccare i tentativi di accesso, selezionare Segnala ma non selezionare Blocca. Si tratta di un'impostazione utile quando non sono note le effettive conseguenze di una regola. Controllare i registri e i rapporti per un breve periodo per determinare se è necessario bloccare l'accesso.

  • Regole — Utilizzare le regole per proteggere il proprio computer da modifiche indesiderate. Le regole sono organizzate per categoria. Selezionare prima la categoria e quindi la regola. Per ulteriori informazioni, vedere Configurazione delle regole predefinite e Configurazione delle regole definite dall'utente.

    Nuova — Consente di creare una nuova regola definita dall'utente. Per ulteriori informazioni, vedere Configurazione delle regole definite dall'utente.

    Modifica — Consente di modificare una regola esistente.

    Elimina — Consente di eliminare una regola esistente definita dall'utente.
    Nota:

    Solo le regole definite dall'utente possono essere eliminate. Le altre regole possono essere modificate o disattivate, ma non eliminate. Per disattivare una regola, deselezionare entrambe le opzioni Blocca e Segnala.

Attività correlate
Configurazione delle impostazioni di sicurezza dell'interfaccia utente
Informazioni correlate
Protezione all'accesso


Scheda Ulteriori opzioni di avviso

Definizioni delle opzioni

Consente di configurare le opzioni relative agli avvisi locali e ai filtri.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Filtro per gravità Selezionare una delle opzioni di filtro seguenti:
  • Non filtrare gli avvisi — Tutti gli avvisi vengono inviati.
  • Filtra avvisi informativi — Gli avvisi informativi con gravità inferiore a 1 non vengono inviati.
  • Filtra avvisi informativi e di attenzione — Gli avvisi informativi e di attenzione con gravità inferiore a 2 non vengono inviati.
  • Filtra avvisi informativi, di attenzione e con priorità bassa — Gli avvisi informativi, di attenzione e con priorità bassa con gravità inferiore a 3 non vengono inviati.
  • Filtra tutti gli avvisi tranne quelli gravi — Nessun avviso viene inviato ad eccezione di quelli con gravità superiore a 4.
  • Filtra tutti gli avvisi— Nessun avviso viene inviato.
Avvisi locali
  • Salva nel registro eventi applicazione locale — Le informazioni vengono salvate nel registro eventi applicazione locale.
  • Invia trap SNMP tramite servizio SNMP — Se si utilizza il protocollo SNMP, è possibile inviare avvisi tramite trap SNMP.
Nota:

Le opzioni degli avvisi locali non richiedono Alert Manager.
Attività correlate
Configurazione degli avvisi
Informazioni correlate
Configurazione di avvisi e notifiche


Scheda Avvisi

Definizioni delle opzioni

Selezionare i componenti che devono generare avvisi e, se installato, configurare Alert Manager.

Per ulteriori informazioni, vedere la Guida del prodotto di Alert Manager 4.7.1.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Componenti che generano avvisi
  • Scansione all'accesso— Consente di generare avvisi quando la scansione all'accesso rileva la presenza di minacce.
  • Scansione su richiesta e scansioni pianificate— Consente di generare avvisi quando le attività di scansione su richiesta rilevano la presenza di minacce.
  • Scansione posta elettronica— Consente di generare avvisi quando la scansione della posta elettronica rileva la presenza di minacce.
  • Aggiornamento automatico— Consente di generare avvisi quando le attività di aggiornamento rilevano la presenza di minacce.
  • Protezione all'accesso— Consente di generare avvisi quando la protezione all'accesso rileva la presenza di minacce.
Opzioni di Alert Manager
  • Disattiva avvisi — In caso di rilevamento non viene generato alcun avviso.
  • Abilita Sistema di avviso centralizzato — Utilizzare il Sistema di avviso centralizzato per ricevere una notifica non appena si verifica un rilevamento.
  • Attiva avvisi di Alert Manager — Utilizzare gli avvisi di Alert Manager per ricevere una notifica non appena si verifica un rilevamento. Scegliere questa opzione e digitare il percorso del server Alert Manager che riceve gli avvisi.
    • Disattiva ricerca in Active Directory — La ricerca in Active Directory non viene utilizzata.
Attività correlate
Configurazione degli avvisi
Informazioni correlate
Configurazione di avvisi e notifiche


Scheda Rapporti

Definizioni delle opzioni

La registrazione consente di monitorare le attività della rete e di tenere traccia delle impostazioni utilizzate per rilevare e rispondere alle minacce potenziali individuate dal programma antivirus.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Registra su file | Consente di attivare la registrazione delle attività.
Percorso file di registro Confermare il percorso predefinito del file di registro o specificare un nuovo percorso.

Il nome predefinito del registro è AccessProtectionLog.txt.

Il percorso predefinito è: <unità>:\Documents and Settings\All Users\Dati applicazioni\McAfee\DesktopProtection\

Il percorso predefinito può variare in base al sistema operativo in uso.
Dimensione file di registro | Consente di limitare la dimensione del file di registro. Accettare la dimensione predefinita (1 MB) oppure impostare un valore compreso tra 1 MB e 999 MB. Se il file di registro supera la dimensione impostata, il 20% delle voci meno recenti viene eliminato per consentire l'aggiunta di nuovi dati al file.
Formato file di registro Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Concetti correlati
Violazioni del punto di accesso e relative reazioni di VirusScan Enterprise
Attività correlate
Console di VirusScan
Riferimenti correlati
Visualizzazione del file di registro dell'attività all'accesso


Attività di AutoUpdate

Consente di configurare l'attività di AutoUpdate

Definizioni delle opzioni

Opzioni | Definizione
File di registro | Consente di attivare la registrazione delle attività.
Formato Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Ricevi file di definizione dei rilevamenti più recenti se disponibili

Consente di ricevere la versione più recente dei file DAT, se disponibile.

Ricevi motori di rilevamento più recenti se disponibili

Consente di ricevere la versione più recente del motore e dei file DAT, se disponibili.

Ricevi altri aggiornamenti disponibili (Service Pack, aggiornamenti, ecc.)

Consente di ricevere la versione più recente di altri aggiornamenti, quali Service Pack e aggiornamenti del prodotto.

Selezionare il programma da eseguire dopo che l'attività di Aggiornamento è stata completata

È possibile indicare un file eseguibile da avviare al termine dell'esecuzione dell'attività di AutoUpdate. Specificare il percorso dell'eseguibile da avviare oppure fare clic su Sfoglia per individuarlo.

Ad esempio, è possibile avviare un'utilità di messaggistica di rete che segnali all'amministratore l'avvenuto completamento dell'attività di AutoUpdate.

Nota: È necessario che l'utente attualmente connesso possa eseguire il programma specificato. Se l'utente attualmente connesso non ha accesso alla cartella contenente i programmi, o se al momento non è connesso alcun utente, il programma non verrà eseguito.
Esegui solo dopo aver completato l'aggiornamento

Consente di eseguire il programma solo ad aggiornamento completato. Se l'aggiornamento non ha esito positivo, il programma specificato non verrà eseguito.

Pianificazione

Consente di definire la pianificazione di questa attività di aggiornamento.

Nota:

Per ulteriori informazioni, vedere Attività di pianificazione.

Si consiglia di non pianificare l'esecuzione contemporanea di un'attività di AutoUpdate e di un'attività di mirror. Poiché entrambe le attività utilizzano il servizio McAfee Common Framework, la loro esecuzione contemporanea potrebbe causare un conflitto.

Aggiorna ora

Consente di eseguire immediatamente l'attività di AutoUpdate.

Concetti correlati
Attività di aggiornamento e relativo funzionamento
Riferimenti correlati
Configurazione dell'attività di AutoUpdate


Scheda Blocco

Definizioni delle opzioni

Consente di bloccare le connessioni da computer remoti che contengono file con minacce potenziali o programmi indesiderati in una cartella condivisa.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Invia un messaggio | Al rilevamento di una minaccia, inviare il messaggio specificato all'utente di rete — Consente di comunicare all'utente di rete di un computer remoto che è stata rilevata una minaccia.
Testo del messaggio

Digitare un messaggio personalizzato nella casella di testo. Per ricevere il messaggio, è necessario che il servizio Messenger di Windows sia in esecuzione.
Blocca la connessione
  • Blocca la connessione quando viene rilevata una minaccia in una cartella condivisa — Consente di bloccare la connessione per qualsiasi utente di rete di un computer remoto che tenti di leggere o scrivere un file contenente una minaccia nella cartella condivisa.
  • Sblocca connessioni dopo — Consente di sbloccare la connessione dopo il numero di minuti specificato. Immettere un numero compreso tra 1 e 9999. Impostazione predefinita = 10 minuti.
  • Blocca la connessione quando in una cartella condivisa viene rilevato un file con un programma potenzialmente indesiderato — Consente di bloccare la connessione per qualsiasi utente di un computer remoto che tenti di scrivere un programma indesiderato nel computer. Nella finestra di dialogo Statistiche della scansione all'accesso viene visualizzato un elenco dei computer bloccati.
Riferimenti correlati
Opzioni della regola di blocco delle porte
Opzioni della regola di blocco di file e cartelle
Opzioni della regola di blocco registro
Informazioni correlate
Protezione all'accesso


Scheda Rapporti

Definizioni delle opzioni

Consente di attivare la registrazione per tenere traccia dei rilevamenti nel sistema locale di qualsiasi esecuzione del codice causati da sovraccarichi di heap o stack per determinati processi.

Opzioni | Definizione
Avvisa in caso di cookie | Avvisa l'utente quando si verifica il rilevamento di un cookie. Impostazione predefinita = selezionato.
Registra su file | Attivare la registrazione delle attività e confermare il percorso predefinito del file di registro o specificare un nuovo percorso.
Percorso file di registro Confermare il percorso predefinito del file di registro o specificare un nuovo percorso.

Il nome predefinito del registro è BufferOverflowProtectionLog.txt.

Il percorso predefinito è: <unità>:\Documents and Settings\All Users\Dati applicazioni\McAfee\DesktopProtection\

Il percorso predefinito può variare in base al sistema operativo in uso.

Dimensione file di registro | Consente di limitare la dimensione del file di registro. Accettare la dimensione predefinita (1 MB) oppure impostare un valore compreso tra 1 MB e 999 MB. Se il file di registro supera la dimensione impostata, il 20% delle voci meno recenti viene eliminato per consentire l'aggiunta di nuovi dati al file.
Formato file di registro Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Informazioni correlate
Configurazione di avvisi e notifiche
Blocco degli exploit da overflow del buffer


Scheda Protezione dall'overflow del buffer

Definizioni delle opzioni

In caso di attacco mediante l'utilizzo di overflow del buffer, è possibile impedire l'esecuzione di codice arbitrario sul computer dell'utente.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni dell'overflow del buffer Attiva Protezione dell'overflow del buffer — Dopo aver attivato la funzione di protezione da sovraccarico del buffer, selezionare il livello di protezione.

  • Modalità di avviso — Consente di inviare un avviso quando viene rilevato un sovraccarico del buffer. Non viene eseguita nessun'altra azione.

    Questa modalità è utile quando non sono note le esatte conseguenze di un overflow del buffer. Utilizzare la funzione nella Modalità di avviso per un breve periodo di tempo e consultare contemporaneamente il file di registro per determinare se passare alla Modalità di protezione.

  • Modalità di protezione — Consente di bloccare l'overflow del buffer nel momento in cui viene rilevato e di terminare il thread rilevato.

    Questa operazione può anche provocare la chiusura dell'applicazione interessata.

ATTENZIONE:
Se non viene effettuata l'attivazione di Protezione dall'overflow del buffer e di Modalità protezione, il sistema non sarà protetto da numerosi attacchi malware.
Invio di avvisi al sistema client | Mostra la finestra di dialogo dei messaggi quando viene rilevato un sovraccarico del buffer — Consente di visualizzare la finestra di dialogo Messaggi della scansione all'accesso quando si verifica un rilevamento.
Esclusioni dell'overflow del buffer Specificare le informazioni di esclusione:
Nota:

Per i nomi delle esclusioni è prevista la distinzione tra maiuscole e minuscole.

  • Processo — Specificare il nome del processo che effettua la chiamata e a cui appartiene la memoria scrivibile.

    Digitare solo il nome del processo oppure includerne anche il percorso.

    Se si immette solo il nome del processo, ad esempio OUTLOOK.EXE, il processo viene escluso ogni volta che viene eseguito, indipendentemente dal percorso in cui si trova. Se si immette il nome del processo comprensivo del percorso, ad esempio C:\Programmi\OUTLOOK.EXE, il processo viene escluso solo se viene eseguito dal percorso specificato. Non sono consentiti i caratteri jolly.

  • Modulo (facoltativo) — Se applicabile, digitare il nome del modulo a cui appartiene la memoria scrivibile. Questa informazione non è obbligatoria.
  • API — Specificare l'API che viene chiamata.
    Nota:

    È necessario specificare l'API solo se si specifica il modulo.

Attività correlate
Configurazione della protezione contro l'overflow del buffer
Informazioni correlate
Blocco degli exploit da overflow del buffer


Scheda Processi

Definizioni delle opzioni

Scegliere se configurare un solo criterio di scansione per tutti i processi oppure diversi criteri di scansione per i processi predefiniti, a basso rischio e ad alto rischio.

Per ulteriori informazioni, vedere Determinazione del numero di criteri di scansione e Determinazione del livello di rischio da assegnare a un processo.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni per i processi Specificare se configurare uno o più criteri di scansione:
  • Configura un unico criterio di scansione per tutti i processi — Se si seleziona questa opzione, il criterio configurato viene applicato a tutti i processi.
  • Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti — Prima di poter configurare criteri per i processi ad alto o basso rischio è necessario selezionare questa opzione.
Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Opzioni di visualizzazione

Definizioni delle opzioni

Consente di configurare la lingua preferita nonché le opzioni della barra delle applicazioni a cui gli utenti possono accedere.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Icona della barra delle applicazioni
  • Mostra l'icona nella barra delle applicazioni con tutte le opzioni di menu — Consente di visualizzare tutte le opzioni nel menu della barra delle applicazioni.
  • Mostra l'icona nella barra delle applicazioni con le opzioni di menu indispensabili — Consente di nascondere tutte le opzioni del menu della barra delle applicazioni ad eccezione di Informazioni su VirusScan Enterprise e Statistiche della scansione all'accesso.
  • Non mostrare l'icona nella barra delle applicazioni — Nasconde l'icona nella barra delle applicazioni per tutti gli utenti.
Opzioni console
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.

  • Consenti al sistema di stabilire connessioni remote ad altri sistemi mediante la console — Consente di collegarsi a computer remoti.

    È necessario disporre dei diritti di amministratore. Inoltre, il servizio Registro di sistema remoto deve essere in esecuzione.

  • Visualizza le attività gestite nella console client — Consente di visualizzare le attività di ePolicy Orchestrator nella console del computer client.
  • Disattiva il piano delle attività predefinite di Aggiornamento automatico — Consente di disattivare la pianificazione delle attività predefinite di aggiornamento.

    Il piano verrà disattivato al momento dell'applicazione del criterio. Il servizio Task Manager deve essere in esecuzione affinché il piano dell'attività possa essere disattivato.

  • Attiva la schermata di avvio — Consente di visualizzare la schermata di avvio di VirusScan Enterprise 8.8 all'avvio della console o di SHSTAT.EXE.
    Nota:

    Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.

Impostazioni della lingua della console Consente di specificare la lingua da utilizzare per il testo della console:
  • È possibile selezionare automaticamente la lingua oppure selezionare una lingua specifica.
    Nota:

    Quando si modifica la lingua preferita nella Console di VirusScan Enterprise 8.8, verrà richiesto di riavviare il computer. Se si fa clic su Sì, la modifica della lingua risulterà effettiva.

    Quando si modifica la lingua preferita nella Console di ePolicy Orchestrator, la modifica della lingua verrà eseguita nella console utente alla prima applicazione del criterio.

    Per i sistemi gestiti da ePolicy Orchestrator, le modifiche apportate dall'utente sul sistema client influiscono sull'interfaccia della console, ma il file di registro tiene traccia delle attività nella lingua specificata durante la configurazione di ePolicy Orchestrator. La modifica della lingua della console risulterà effettiva dopo il riavvio della console.

Attività correlate
Configurazione delle impostazioni di sicurezza dell'interfaccia utente
Informazioni correlate
Protezione all'accesso


Scheda Azioni

Definizioni delle opzioni

Consente di configurare le azioni da intraprendere in caso di rilevamento di una minaccia o di un programma potenzialmente indesiderato.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Al rilevamento di una minaccia: Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di una minaccia. Impostazione predefinita = Pulisci allegati.
  • Pulisci allegati — Lo scanner effettua un tentativo di rimozione della minaccia dall'allegato.
  • Richiedi azione — Il sistema richiede all'utente quale azione intraprendere quando viene rilevata una minaccia. Selezionare questa opzione, quindi specificare le azioni che possono essere intraprese in Azioni consentite nella finestra di dialogo di richiesta.
Per questa opzione non è consentita alcuna azione secondaria.
  • Continua scansione — Quando viene rilevato un allegato con una minaccia, lo scanner continua la scansione.
Per questa opzione non è consentita alcuna azione secondaria.
  • Sposta allegati in una cartella — Gli allegati con minacce potenziali vengono spostati nella cartella indicata.
  • Elimina allegati — Gli allegati contenenti minacce potenziali vengono eliminati al momento del rilevamento. In Microsoft Outlook, viene eliminato anche il messaggio di posta elettronica. In Lotus Notes, viene eliminato soltanto l'allegato.
  • Elimina messaggio (solo scansione Outlook) — Il messaggio contenente minacce potenziali viene eliminato. Se si seleziona quest'opzione come azione primaria, non è consentita alcuna azione secondaria.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Sposta allegati in una cartella.
  • Richiedi azione — Il sistema richiede all'utente quale azione intraprendere quando viene rilevata una minaccia. Selezionare questa opzione, quindi specificare le azioni che possono essere intraprese in Azioni consentite nella finestra di dialogo di richiesta.
  • Continua scansione — Quando viene rilevato un allegato con una minaccia, lo scanner continua la scansione.
  • Sposta allegati in una cartella — Gli allegati con minacce potenziali vengono spostati nella cartella indicata.
  • Elimina allegati — Gli allegati contenenti minacce potenziali vengono eliminati al momento del rilevamento. In Microsoft Outlook, viene eliminato anche il messaggio di posta elettronica. In Lotus Notes, viene eliminato soltanto l'allegato.
  • Elimina messaggio (solo scansione Outlook) — Il messaggio contenente minacce potenziali viene eliminato.
Al rilevamento di un programma indesiderato Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di un programma potenzialmente indesiderato. Impostazione predefinita = Pulisci allegati.
  • Pulisci allegati — Lo scanner effettua un tentativo di rimozione della minaccia dall'allegato.
  • Richiedi azione — Il sistema richiede all'utente quale azione intraprendere quando viene rilevata una minaccia. Selezionare questa opzione, quindi specificare le azioni che possono essere intraprese in Azioni consentite nella finestra di dialogo di richiesta.
Per questa opzione non è consentita alcuna azione secondaria.
  • Continua scansione — Quando viene rilevato un allegato con una minaccia, lo scanner continua la scansione.
Per questa opzione non è consentita alcuna azione secondaria.
  • Sposta allegati in una cartella — Gli allegati con minacce potenziali vengono spostati nella cartella indicata.
  • Elimina allegati — Gli allegati contenenti minacce potenziali vengono eliminati al momento del rilevamento. In Microsoft Outlook, viene eliminato anche il messaggio di posta elettronica. In Lotus Notes, viene eliminato soltanto l'allegato.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Sposta allegati in una cartella.
  • Richiedi azione — Il sistema richiede all'utente quale azione intraprendere quando viene rilevata una minaccia. Selezionare questa opzione, quindi specificare le azioni che possono essere intraprese in Azioni consentite nella finestra di dialogo di richiesta.
Per questa opzione non è consentita alcuna azione secondaria.
  • Continua scansione — Quando viene rilevato un allegato con una minaccia, lo scanner continua la scansione.
Per questa opzione non è consentita alcuna azione secondaria.
  • Sposta allegati in una cartella — Gli allegati con minacce potenziali vengono spostati nella cartella indicata.
  • Elimina allegati — Gli allegati contenenti minacce potenziali vengono eliminati al momento del rilevamento. In Microsoft Outlook, viene eliminato anche il messaggio di posta elettronica. In Lotus Notes, viene eliminato soltanto l'allegato.
Sposta nella cartella Consente di specificare il percorso della cartella di quarantena. La cartella di quarantena deve trovarsi su un disco rigido di un'unità locale, non su un'unità floppy o CD. Il percorso predefinito come cartella di quarantena varia a seconda che si utilizzi Microsoft Outlook o Lotus Notes.
  • Per Microsoft Outlook, la cartella di quarantena si trova nella cassetta di posta di Microsoft Outlook.
  • Per Lotus Notes, la cartella di quarantena si trova nel file system.
Azioni consentite nella finestra di dialogo di richiesta Selezionare le azioni consentite quando è richiesta un'azione.
Nota:

Un'azione Nega accesso predefinita si verifica prima che sia stata eseguita una qualsiasi delle seguenti azioni.

  • Pulisci allegato
  • Elimina allegato
  • Sposta allegato
  • Elimina messaggio (solo Microsoft Outlook)
Quando il sistema richiede all'utente quale azione intraprendere, quest'ultimo riceve il messaggio specificato nella scheda Avvisi.
Attività correlate
Configurazione del criterio quarantena
Riferimenti correlati
Rilevamenti della scansione all'accesso
Rilevamenti della scansione su richiesta
Rilevamenti della scansione della posta elettronica
Informazioni correlate
Rilevamenti e risposte


Scheda Avvisi

Definizioni delle opzioni

Consente di configurare le impostazioni per gli avvisi relativi alle scansioni eseguite alla consegna della posta elettronica.

Opzioni | Definizione
Impostazioni per | Selezionare Workstation o Server nell'elenco a discesa. Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Avviso posta elettronica per l'utente | Invia messaggio di avviso all'utente — Quando viene rilevato un messaggio di posta elettronica contenente una minaccia, il sistema invia una notifica a un altro utente.
Messaggio di richiesta di azione | Specificare il messaggio visualizzato quando è richiesta un'azione. È necessario selezionare l'opzione Richiedi azione nella scheda Azioni. Confermare il messaggio predefinito o digitare un nuovo messaggio. Messaggio predefinito = Scanner della posta elettronica di McAfee VirusScan Enterprise: Avviso
Attività correlate
Configurazione degli avvisi


Scheda Elementi da sottoporre a scansione

Definizioni delle opzioni

Consente di configurare le opzioni di rilevamento relative alle scansioni della posta elettronica eseguite su richiesta.

Opzioni | Definizione
Messaggi da sottoporre a scansione
  • Tutti gli elementi evidenziati — Viene eseguita la scansione delle cartelle e dei messaggi di posta selezionati.
  • Tutti i messaggi nella cartella Posta in arrivo —Esamina tutti i messaggi attualmente presenti nella cartella Posta in arrivo e nelle relative sottocartelle.
    • Esegui scansione solo su messaggi non letti — Esamina tutti i messaggi non letti attualmente presenti nella cartella Posta in arrivo e nelle relative sottocartelle.
Allegati da sottoporre a scansione
  • Tutti i tipi di file — Viene eseguita la scansione di tutti i tipi di file, indipendentemente dall'estensione.
  • Tipi di file predefiniti e aggiuntivi — Viene eseguita la scansione dei file la cui estensione appartiene all'elenco predefinito delle estensioni, nonché degli eventuali tipi aggiuntivi specificati dall'utente. L'elenco predefinito è definito dal file DAT corrente. Selezionare Tipi di file predefiniti e aggiuntivi, quindi immettere nella casella di testo le estensioni di file desiderate separate da spazi.

    Cerca anche le macro in tutti gli allegati — Se è stata selezionata l'opzione Tipi di file predefiniti e aggiuntivi, è inoltre possibile eseguire in tutti i file una ricerca di minacce note basate su macro.

  • Tipi di file specificati — Consente di creare un elenco personalizzato di estensioni specifiche da sottoporre a scansione, nonché di rimuovere eventuali estensioni aggiunte in precedenza.

    Selezionare Tipi di file specificati, quindi immettere nella casella di testo le estensioni di file desiderate separate da spazi.

Artemis (verifica euristica in rete per verificare la presenza di file sospetti)
  • Trova minacce di programma e trojan sconosciuti — Utilizzare Artemis per rilevare file eseguibili con codice simile a malware.
  • Trova minacce di macro sconosciute — Utilizzare Artemis per rilevare virus macro sconosciuti.
  • Trova allegati con più estensioni — Consente di trattare come una minaccia gli allegati con più estensioni.

    Quando si seleziona questa opzione viene visualizzata la finestra di dialogo Avviso scansione posta elettronica. Fare clic su OK per confermare la selezione.

ATTENZIONE:
Se l'opzione Artemis non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.
File compressi
  • Esegui scansione su file all'interno di archivi — Consente di esaminare i file di archivio (compressi) e il relativo contenuto.

    Benché offra una migliore protezione, la scansione di file compressi può aumentare la quantità di tempo necessaria per eseguire una scansione.

  • Decodifica file MIME codificati — Consente di rilevare, decodificare e sottoporre a scansione i file MIME (Multipurpose Internet Mail Extensions) codificati.
Rilevamento di programmi indesiderati Rileva programmi indesiderati — Consente di attivare la scansione alla consegna della posta elettronica per rilevare programmi potenzialmente indesiderati. Lo scanner di posta elettronica utilizza le informazioni configurate nel Criterio per programmi indesiderati allo scopo di rilevare programmi potenzialmente indesiderati.

Per ulteriori informazioni, vedere Restrizione dei programmi potenzialmente indesiderati.

Corpo del messaggio di posta elettronica (solo per Microsoft Outlook) | Sottoponi a scansione il corpo del messaggio di posta elettronica — Consente di sottoporre a scansione il corpo dei messaggi di posta elettronica di Microsoft Outlook.
Attività correlate
Configurazione di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Rapporti

Definizioni delle opzioni

La registrazione consente di monitorare le attività della rete e di tenere traccia delle impostazioni utilizzate per rilevare e rispondere alle minacce potenziali individuate dal programma antivirus.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Registra su file | Consente di attivare la registrazione delle attività.
Percorso file di registro Confermare il percorso predefinito del file di registro o specificare un nuovo percorso.

Il nome predefinito del registro di posta elettronica su richiesta è EmailOnDemandLog.txt.

Il percorso predefinito è: <unità>:\Documents and Settings\All Users\Dati applicazioni\McAfee\DesktopProtection\

Il percorso predefinito può variare in base al sistema operativo in uso.

Dimensione file di registro | Consente di limitare la dimensione del file di registro. Accettare la dimensione predefinita (1 MB) oppure impostare un valore compreso tra 1 MB e 999 MB. Se il file di registro supera la dimensione impostata, il 20% delle voci meno recenti viene eliminato per consentire l'aggiunta di nuovi dati al file.
Formato file di registro Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Informazioni da registrare oltre all'attività di scansione
  • Impostazioni sessione — Consente di memorizzare le proprietà di ogni sessione di scansione nel file di registro.
  • Riepilogo sessione — Consente di registrare un riepilogo delle azioni dello scanner nel file di registro durante ogni sessione di scansione. Le informazioni di riepilogo includono il numero dei file sottoposti a scansione, il numero e il tipo di rilevamenti, il numero di file puliti o eliminati e altre informazioni.
  • Scansione di file crittografati non riuscita — Consente di memorizzare il nome dei file crittografati di cui non è stato possibile eseguire la scansione.
Attività correlate
Configurazione degli avvisi


Scheda Scansione elementi

Definizioni delle opzioni

Consente di configurare le opzioni di rilevamento dello scanner della posta elettronica.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Scansione di posta elettronica Consente di attivare la scansione della posta elettronica alla consegna.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Allegati da sottoporre a scansione
  • Tutti i tipi di file — Viene eseguita la scansione di tutti i tipi di file, indipendentemente dall'estensione.
  • Tipi di file predefiniti e aggiuntivi — Viene eseguita la scansione dei file la cui estensione appartiene all'elenco predefinito delle estensioni, nonché degli eventuali tipi aggiuntivi specificati dall'utente. L'elenco predefinito è definito dal file DAT corrente. Selezionare Tipi di file predefiniti e aggiuntivi, quindi immettere nella casella di testo le estensioni di file desiderate separate da spazi.

    Cerca anche le macro in tutti gli allegati — Se è stata selezionata l'opzione Tipi di file predefiniti e aggiuntivi, è inoltre possibile eseguire in tutti i file una ricerca di minacce note basate su macro.

  • Tipi di file specificati — Consente di creare un elenco personalizzato di estensioni specifiche da sottoporre a scansione, nonché di rimuovere eventuali estensioni aggiunte in precedenza.

    Selezionare Tipi di file specificati, quindi immettere nella casella di testo le estensioni di file desiderate separate da spazi.

Artemis (verifica euristica in rete per verificare la presenza di file sospetti)
  • Trova minacce di programma e trojan sconosciuti — Utilizzare Artemis per rilevare file eseguibili con codice simile a malware.
  • Trova minacce di macro sconosciute — Utilizzare Artemis per rilevare virus macro sconosciuti.
  • Trova allegati con più estensioni — Consente di trattare come una minaccia gli allegati con più estensioni.

    Quando si seleziona questa opzione viene visualizzata la finestra di dialogo Avviso scansione posta elettronica. Fare clic su OK per confermare la selezione.

ATTENZIONE:
Se l'opzione Artemis non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.
File compressi
  • Esegui scansione su file all'interno di archivi — Consente di esaminare i file di archivio (compressi) e il relativo contenuto.

    Benché offra una migliore protezione, la scansione di file compressi può aumentare la quantità di tempo necessaria per eseguire una scansione.

  • Decodifica file MIME codificati — Consente di rilevare, decodificare e sottoporre a scansione i file MIME (Multipurpose Internet Mail Extensions) codificati.
Rilevamento di programmi indesiderati Rileva programmi indesiderati — Consente di attivare la scansione alla consegna della posta elettronica per rilevare programmi potenzialmente indesiderati. Lo scanner di posta elettronica utilizza le informazioni configurate nel Criterio per programmi indesiderati allo scopo di rilevare programmi potenzialmente indesiderati.

Per ulteriori informazioni, vedere Restrizione dei programmi potenzialmente indesiderati.

Corpo del messaggio di posta elettronica (solo per Microsoft Outlook) | Sottoponi a scansione il corpo del messaggio di posta elettronica — Consente di sottoporre a scansione il corpo dei messaggi di posta elettronica di Microsoft Outlook.
Verifica euristica in rete per verificare la presenza di file sospetti
Consente di configurare il livello di sensibilità che si desidera utilizzare per determinare se un elemento rilevato è una minaccia malware. Per tutti i livelli diversi da Disattivato, vengono inviati gli ID digitali degli esempi, o hash, a McAfee Labs per determinare se si tratta di malware. Il vantaggio per l'utente consiste nell'eventuale disponibilità del rilevamento non appena McAfee Labs avrà pubblicato l'aggiornamento, senza attendere il successivo rilascio del file DAT. Un livello di sensibilità più elevato comporta un maggior numero di rilevamenti di malware. Tuttavia, consentendo l'esecuzione di un elevato numero di rilevamenti è possibile ottenere un maggior numero di risultati falsi positivi. Selezionare uno dei livelli di sensibilità seguenti:

  • Disattivato — Nessun ID digitale o nessun dato viene inviato ai laboratori McAfee Labs per determinare se si tratta di malware.

  • Bassissimo — La quantità di rilevamenti e il rischio che si verifichino falsi positivi corrispondono a quelli che si presentano quando si utilizzano i normali file DAT. Anziché attendere il successivo aggiornamento del file DAT, un rilevamento può essere reso disponibile a VirusScan Enterprise quando viene pubblicato da McAfee Labs.

  • Basso — Questo livello è definito come caso intermedio fra Bassissimo e Medio.

  • Medio — Utilizzare questo livello quando il rischio normale di esposizione al malware è maggiore del rischio di un falso positivo. Nella maggior parte dei casi, le verifiche euristiche proprietarie di McAfee Labs, sono in grado di individuare correttamente gli elementi malware. Tuttavia, benché minimo, esiste il rischio che un rilevamento riguardante un file poco diffuso sia in realtà un falso positivo. McAfee Labs verificano che i rilevamenti dovuti a questa impostazione non comportino un falso positivo qualora il file esaminato appartenga ad applicazioni e a sistemi operativi largamente diffusi.

  • Alto — Questo livello è definito come caso intermedio fra Medio e Altissimo.

  • Altissimo — Questo livello è consigliabile soltanto per la posta elettronica e per la scansione di volumi e directory che non supportano l'esecuzione di programmi né l'utilizzo di sistemi operativi. Benché presumibilmente pericolosi, i rilevamenti ottenuti mediante questo livello non sono stati sottoposti a verifiche esaustive per confermare che non si tratti di falsi positivi.

Attività correlate
Scansione e-mail alla consegna e su richiesta


Scheda Generale

Definizioni delle opzioni

Consente di configurare opzioni generali di scansione all'accesso.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Scansione Specificare gli elementi generali da sottoporre a scansione:
  • Esegui scansione dei settori di avvio: consente di eseguire la scansione dei settori di avvio. Impostazione predefinita = Attivato.
  • Floppy durante l'arresto — Consente di eseguire la scansione delle unità floppy durante l'arresto del computer.Impostazione predefinita = Attivato.
  • Processi in abilitazione: il servizio McShield di scansione all'accesso di McAfee esegue la scansione di tutti i processi già in esecuzione. Impostazione predefinita = Disattivato.
    Nota: L'attivazione di questa funzione consente di migliorare la sicurezza, ma influenza le prestazioni del sistema.
Attiva scansione all'accesso Specificare quando attivare la scansione:
  • Attiva scansione all'accesso all'avvio del sistema — Consente di attivare la scansione all'accesso ogni volta che si avvia il computer.
  • Attiva scansione all'accesso al momento dell'applicazione del criterio — Consente di attivare la scansione all'accesso ogni volta che il criterio viene applicato.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Tempo massimo di scansione Consente di specificare il tempo massimo di scansione:
  • Applica un tempo di scansione massimo a tutti i file — Consente di definire un tempo massimo di scansione e di applicarlo a tutti i file.
  • Tempo massimo di scansione — Consente di specificare il tempo massimo di scansione per tutti i file, in secondi. Impostazione predefinita = 45 secondi.
Nota: Se viene superato il limite di tempo, la scansione si interrompe e viene registrato un messaggio. Se l'interruzione immediata della scansione non è possibile, questa viene terminata e riavviata.
Cookie

Esegui scansione su file cookie — Consente di attivare la scansione su file cookie.

Artemis (verifica euristica in rete per verificare la presenza di file sospetti) | Consente di specificare uno dei sei livello di sensibilità, compresi tra il valore Disattivata e Altissimo, per Artemis. Impostazione predefinita = Bassissimo.
Attività correlate
Configurazione delle impostazioni generali
Informazioni correlate
Scansione di elementi all'accesso


Scheda Impostazioni globali scansione

Definizioni delle opzioni

Consente di impostare le opzioni della cache per salvare i dati di scansione durante un riavvio del sistema e permette alla scansione su richiesta di utilizzare i dati della cache relativi ai file puliti per migliorare le prestazioni. Per ulteriori informazioni, consultare Configurazione delle impostazioni di opzione globali.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Cache di scansione Configura opzioni e impostazioni globali
  • Abilita il salvataggio dei dati di scansione tra i riavvii del sistema — Consente di salvare i risultati di scansione relativi ai file puliti anche quando si riavvia il sistema. (Impostazione predefinita = selezionato).
    Nota: Disattivare questa funzione se il sistema viene utilizzato nei casi in cui il disco rigido potrebbe risultare modificato dall'esterno. Ad esempio, se il disco rigido viene rimosso, se il contenuto viene modificato e successivamente sostituito (le macchine virtuali e i sistemi con configurazioni a doppio avvio sono inclusi in questa eccezione).
  • Consenti alle scansioni su richiesta di utilizzare la cache di scansione — Consente allo scanner su richiesta di utilizzare i risultati di scansione dei file puliti per ridurre le scansioni duplicate. (Impostazione predefinita = selezionato).
Attività correlate
Configurazione della cache di sistema globale


Scheda Processi

Definizioni delle opzioni per il passaggio 1

Consente di specificare i processi definiti ad alto rischio. Questa procedura prevede due passaggi.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni per i processi

Aprire i Criteri dei processi predefiniti all'accesso e selezionare:

  • Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti
Nota:

Prima di poter configurare criteri per i processi ad alto o basso rischio è necessario selezionare questa opzione.

Definizioni delle opzioni per il passaggio 2

Opzioni | Definizione
Impostazioni per | Selezionare Workstation o Server nell'elenco a discesa. Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Processi ad alto rischio | Aprire i Criteri dei processi ad alto rischio all'accesso per specificare i processi identificati come ad alto rischio. Aggiungere e rimuovere i processi in base alle proprie necessità.

Per ulteriori informazioni, vedere Determinazione del numero di criteri di scansione e Determinazione del livello di rischio da assegnare a un processo.

Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Processi

Definizioni delle opzioni per il passaggio 1

Consente di specificare i processi definiti a basso rischio. Questa procedura prevede due passaggi.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni per i processi

Aprire i Criteri dei processi predefiniti all'accesso e selezionare:

  • Configura criteri di scansione diversi per i processi ad alto rischio, a basso rischio e predefiniti
Nota:

Prima di poter configurare criteri per i processi ad alto o basso rischio è necessario selezionare questa opzione.

Definizioni delle opzioni per il passaggio 2

Opzioni | Definizione
Impostazioni per | Selezionare Workstation o Server nell'elenco a discesa. Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Processi a basso rischio | Aprire i Criteri dei processi a basso rischio all'accesso per specificare i processi identificati come a basso rischio. Aggiungere e rimuovere i processi in base alle proprie necessità.

Per ulteriori informazioni, vedere Determinazione del numero di criteri di scansione e Determinazione del livello di rischio da assegnare a un processo.

Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Messaggi

Definizioni delle opzioni

Consente di configurare le opzioni dei messaggi per gli utenti locali e per gli utenti privi di privilegi amministrativi.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Messaggi utente Specificare i messaggi ricevuti dagli utenti locali.
  • Mostra la finestra di dialogo al rilevamento di una minaccia e visualizza il testo specificato nel messaggio — Quando si verifica un rilevamento, nel sistema degli utenti locali viene visualizzata la finestra di dialogo Messaggi della scansione all'accesso.

  • Avvisa al verificarsi di rilevamenti di file cookie — Consente di inviare avvisi in caso di rilevamento di cookie. Ciò comprende la generazione di avvisi di ePolicy Orchestrator, l'invio di messaggi alla finestra di dialogo Messaggi della scansione all'accesso, l'inserimento dei rilevamenti nel registro delle attività se è stata attivata la registrazione delle attività nella scheda Rapporti e l'aggiunta dei rilevamenti nelle statistiche di scansione. Se si deseleziona questa opzione, ePolicy Orchestrator non genera avvisi. Tuttavia, se la registrazione delle attività è stata attivata nella scheda Rapporti, i rilevamenti vengono comunque inseriti nel registro delle attività nonché aggiunti nelle statistiche di scansione.

Testo del messaggio

Confermare il messaggio predefinito o digitare un messaggio personalizzato. Impostazione predefinita = VirusScan Enterprise 8.8 Avviso

Azioni disponibili per gli utenti
  • Rimuovi messaggio dall'elenco — Consente agli utenti privi di privilegi amministrativi di eliminare i messaggi dall'elenco.
  • Pulisci file — Consente agli utenti privi di privilegi amministrativi di pulire i file a cui fanno riferimento i messaggi dell'elenco.
  • Elimina file — Consente agli utenti privi di privilegi amministrativi di eliminare i file a cui fanno riferimento i messaggi dell'elenco.
Riferimenti correlati
Rilevamenti della scansione all'accesso


Attività di mirror

Consente di configurare l'attività di mirror.

Console di VirusScan Enterprise 8.8 — Definizioni delle opzioni

Opzioni | Definizione
File di registro | Consente di attivare la registrazione delle attività.
Formato Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Ricevi file di definizione dei rilevamenti più recenti se disponibili

Questa opzione non si applica alle attività di mirror.
Ricevi motori di rilevamento più recenti se disponibili

Questa opzione non si applica alle attività di mirror.
Ricevi altri aggiornamenti disponibili (Service Pack, aggiornamenti, ecc.)

Questa opzione non si applica alle attività di mirror.
Selezionare il file eseguibile da eseguire dopo che il mirror è stato completato

È possibile indicare un file eseguibile da avviare al termine dell'esecuzione dell'attività di mirror. Specificare il percorso dell'eseguibile da avviare oppure fare clic su Sfoglia per individuarlo.

Ad esempio, è possibile avviare un'utilità di messaggistica di rete che segnali all'amministratore l'avvenuto completamento dell'attività di mirror.

Nota: È necessario che l'utente attualmente connesso possa eseguire il programma specificato. Se l'utente attualmente connesso non ha accesso alla cartella contenente i programmi, o se al momento non è connesso alcun utente, il programma non verrà eseguito.
Esegui solo dopo che il mirror è stato eseguito

Consente di eseguire il programma solo al completamento del mirror. Se il mirror non ha esito positivo, il programma specificato non verrà eseguito.
Percorso mirror

Consente di specificare il percorso di destinazione nel sistema locale che si sta utilizzando per il sito di mirror.

Nota: Le variabili di sistema sono supportate.
Pianificazione

Consente di definire la pianificazione di questa attività di aggiornamento.

Nota:

Per ulteriori informazioni, vedere Attività di pianificazione.

Si consiglia di non pianificare l'esecuzione contemporanea di un'attività di AutoUpdate e di un'attività di mirror. Poiché entrambe le attività utilizzano il servizio McAfee Common Framework, la loro esecuzione contemporanea potrebbe causare un conflitto.
Esegui mirror

Consente di eseguire immediatamente l'attività di mirror.

Concetti correlati
Attività di mirror e relativa modalità di funzionamento
Riferimenti correlati
Configurazione dell'attività di mirror


Scheda Impostazioni di Notes Scanner

Definizioni delle opzioni

Consente di configurare le impostazioni di Lotus Notes relative alle scansioni eseguite alla consegna della posta elettronica.

Configurazione della password di Lotus Notes

Quando si accede a un database locale su Windows 2000 Server, Windows 2003 Server o Windows XP, l'utente deve inserire una password. Quando l'utente digita la password, viene avviata la finestra di dialogo di ricerca del testo e la password viene inserita in tale finestra anziché in quella della password. La finestra di dialogo della password non è completamente modale. Selezionando nuovamente la finestra di dialogo l'utente può inserire la password.

McAfee consiglia di evitare richieste di password multiple nel seguente modo:
  1. Da Lotus Notes, fare clic su File | Preferenze | Protezione | Protezione utente | Finestra di dialogo.
  2. Fare clic su Non richiedere password da altri programmi basati su Notes (riduce la protezione).
    ATTENZIONE:
    Questa configurazione potrebbe ridurre la sicurezza del sistema.
Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Impostazioni scansione server
  • Esegui scansione su tutti i database del server — Consente di eseguire la scansione di tutti i database del server allo scopo di rilevare minacce potenziali.
  • Esegui scansione su cassette postali del server — Consente di eseguire la scansione di tutte le cassette postali del server allo scopo di rilevare minacce potenziali.
  • Cartella principale cassetta postale — Consente di specificare il percorso della cartella principale della cassetta postale. Accettare il percorso predefinito o specificare un nuovo percorso. Questa opzione è disponibile solo per la scansione della posta elettronica alla consegna. Impostazione predefinita = !!mail\.
Opzioni avanzate | Applicazioni Notes da escludere — Consente di specificare le applicazioni Lotus Notes da escludere dalla scansione. Impostazione predefinita = MNOTES.
Attività correlate
Scansione e-mail alla consegna e su richiesta


Scheda Azioni

Definizioni delle opzioni

Consente di configurare le azioni da intraprendere in caso di rilevamento di una minaccia o di un programma potenzialmente indesiderato. Se si configurano criteri differenti per i processi predefiniti, a basso rischio e ad alto rischio, sarà necessario configurare le opzioni di questa scheda per ogni tipo di processo.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Al rilevamento di una minaccia: Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di una minaccia. Impostazione predefinita = Pulisci file automaticamente.
  • Pulisci file automaticamente — Lo scanner effettua un tentativo di rimozione della minaccia dal file rilevato.
  • Nega accesso ai file — Lo scanner nega a tutti gli utenti l'accesso ai file in cui sono state rilevate minacce potenziali.
  • Elimina file automaticamente — Lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Elimina file automaticamente.
  • Nega accesso ai file — Lo scanner nega a tutti gli utenti l'accesso ai file in cui sono state rilevate minacce potenziali.
  • Elimina file automaticamente — Lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Al rilevamento di un programma indesiderato Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di un programma potenzialmente indesiderato. Impostazione predefinita = Pulisci file automaticamente.
  • Consenti accesso ai file — Consente agli utenti di accedere ai file e/o ai programmi rilevati.
    Nota:

    Utilizzare questa azione per controllare quali elementi vengono rilevati prima di decidere le azioni da intraprendere. Analizzare il registro delle attività per verificare i programmi rilevati. Per questa opzione non è consentita alcuna azione secondaria.

  • Pulisci file automaticamente — Consente di rimuovere automaticamente la minaccia dai file e dai programmi rilevati.
  • Nega accesso ai file — Lo scanner nega agli utenti l'accesso ai file e ai programmi rilevati.
  • Elimina file automaticamente — Rimuove automaticamente i file e i programmi rilevati.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Elimina file automaticamente.
  • Consenti accesso ai file — Consente agli utenti di accedere ai file e/o ai programmi rilevati.
  • Nega accesso ai file — Lo scanner nega agli utenti l'accesso ai file e ai programmi rilevati.
  • Elimina file automaticamente — Rimuove automaticamente i file e i programmi rilevati.
Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Esclusioni

Definizioni delle opzioni

Consente di specificare gli elementi da escludere dalla scansione. Se si configurano criteri differenti per i processi predefiniti, a basso rischio e ad alto rischio, sarà necessario configurare le opzioni di questa scheda per ogni tipo di processo.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Elementi da escludere Selezionare il tipo di esclusione, quindi specificare i dettagli dell'esclusione:
  • Escludi in base al tipo/percorso file — Digitare il tipo di file nella casella di testo. Se necessario, selezionare Escludi anche le sottocartelle.
    Nota: È necessario aggiungere una barra rovesciata (\) alla fine della stringa per applicare l'esclusione alla cartella. In caso contrario, viene considerata come un'esclusione del file e la casella di controllo Escludi anche le sottocartelle è disattivata per impostazione predefinita.
  • Escludi in base al tipo di file: digitare il tipo di file nella casella di testo.
  • Escludi in base alla data del file— Selezionare il tipo di accesso e quindi specificare il numero minimo di giorni dalla creazione del file.

Per ulteriori informazioni, vedere Aggiunta ed esclusione di elementi da sottoporre a scansione.

Quando escludere Scegliere quando escludere l'elemento selezionato:
  • Lettura
  • Scrittura
Modalità di gestione delle esclusioni client Sovrascrivi esclusioni client — Consente di escludere soltanto gli elementi specificati in questo criterio. Se questa opzione non è selezionata, i computer client utilizzano le esclusioni specificate localmente insieme alle esclusioni specificate in questo criterio.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Rapporti

Definizioni delle opzioni

La registrazione consente di monitorare le attività della rete e di tenere traccia delle impostazioni utilizzate per rilevare e rispondere alle minacce potenziali individuate dal programma antivirus.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Registra su file | Consente di attivare la registrazione delle attività.
Percorso file di registro Confermare il percorso predefinito del file di registro o specificare un nuovo percorso.

Il nome predefinito del registro è OnAccessScanLog.txt.

Il percorso predefinito è: <unità>:\Documents and Settings\All Users\Dati applicazioni\McAfee\DesktopProtection\.

Il percorso predefinito può variare in base al sistema operativo in uso.
Dimensione file di registro | Consente di limitare la dimensione del file di registro. Accettare la dimensione predefinita (1 MB) oppure impostare un valore compreso tra 1 MB e 999 MB. Se il file di registro supera la dimensione impostata, il 20% delle voci meno recenti viene eliminato per consentire l'aggiunta di nuovi dati al file.
Formato file di registro Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Informazioni da registrare oltre all'attività di scansione
  • Impostazioni sessione — Consente di memorizzare le proprietà di ogni sessione di scansione nel file di registro.
  • Riepilogo sessione — Consente di registrare un riepilogo delle azioni dello scanner nel file di registro durante ogni sessione di scansione. Le informazioni di riepilogo includono il numero dei file sottoposti a scansione, il numero e il tipo di rilevamenti, il numero di file puliti o eliminati e altre informazioni.
  • Scansione di file crittografati non riuscita — Consente di memorizzare il nome dei file crittografati di cui non è stato possibile eseguire la scansione.
Attività correlate
Configurazione di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Scansione elementi

Definizioni delle opzioni

Consente di configurare opzioni di rilevamento. Se si configurano criteri differenti per i processi predefiniti, a basso rischio e ad alto rischio, sarà necessario configurare le opzioni di questa scheda per ogni tipo di processo.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Scansione dei file
  • Durante la scrittura sul disco: consente di eseguire la scansione di tutti i file quando vengono salvati o modificati nel computer o in altri dispositivi di memorizzazione dati.
    ATTENZIONE:
    Se l'opzione Durante la scrittura sul disco non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.

    Se si copiano o spostano file da un computer all'altro, è importante verificare che tutti i computer siano configurati con le stesse impostazioni in modo da impedire la copia o la scrittura di una minaccia potenziale.

  • Durante la lettura dal disco— Consente di eseguire la scansione di tutti i file quando vengono letti dal computer o da altri dispositivi di memorizzazione dati.
    ATTENZIONE:
    L'impossibilità di consentire la scansione Durante la lettura dal disco lascia il sistema sprovvisto di protezione da numerosi attacchi malware.
  • Sulle unità di rete — Consente di eseguire la scansione delle risorse sulle unità di rete mappate.

    La scansione delle risorse di rete può incidere sulle prestazioni.

  • Aperti per il backup — Consente di esaminare i file aperti per le operazioni di backup.
Tipi di file da sottoporre a scansione
  • Tutti i file — Consente di eseguire la scansione di tutti i file, indipendentemente dall'estensione.
    ATTENZIONE:
    Se l'opzione Tutti i file non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.
  • Tipi di file predefiniti e aggiuntivi — Viene eseguita la scansione dei file la cui estensione appartiene all'elenco predefinito delle estensioni, nonché degli eventuali tipi aggiuntivi specificati dall'utente. L'elenco predefinito è definito dal file DAT corrente.

    Esegui anche la ricerca delle macro in tutti i file — Se è stata selezionata questa opzione è inoltre possibile eseguire in tutti i file una ricerca di minacce note basate su macro.

  • Solo i tipi di file specificati — Consente di creare un elenco personalizzato di estensioni specifiche da sottoporre a scansione, nonché di rimuovere eventuali estensioni aggiunte in precedenza.

    Selezionare questa opzione, quindi immettere nella casella di testo le estensioni di file separate da spazi.

Artemis (verifica euristica in rete per verificare la presenza di file sospetti)
  • Trova minacce di programma e trojan sconosciuti — Utilizzare Artemis per rilevare file eseguibili con codice simile a malware.
  • Trova minacce di macro sconosciute — Utilizzare Artemis per rilevare virus macro sconosciuti.
ATTENZIONE:
Se l'opzione Artemis non viene attivata, il sistema rimane non protetto da numerosi attacchi malware.
File compressi
  • Esegui scansione su file all'interno di archivi — Consente di esaminare i file di archivio (compressi) e il relativo contenuto.
  • Decodifica file MIME codificati — Consente di rilevare, decodificare e sottoporre a scansione i file MIME (Multipurpose Internet Mail Extensions) codificati.
Nota: Benché offra una migliore protezione, la scansione di file compressi può aumentare la quantità di tempo necessaria per eseguire una scansione.
Rilevamento di programmi indesiderati
  • Rileva programmi indesiderati — Consente di attivare la scansione all'accesso per rilevare programmi potenzialmente indesiderati.

    Lo scanner utilizza le informazioni configurate nel Criterio per programmi indesiderati per rilevare programmi potenzialmente indesiderati.

    Per ulteriori informazioni, vedere Restrizione dei programmi potenzialmente indesiderati.

Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Azioni

Definizioni delle opzioni

Consente di configurare le azioni da intraprendere in caso di rilevamento di una minaccia o di un programma potenzialmente indesiderato.

Opzioni Definizione
Al rilevamento di una minaccia: Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di una minaccia. Impostazione predefinita = Pulisci file.
  • Pulisci file: lo scanner effettua un tentativo di rimozione della minaccia dal file rilevato.
  • Continua scansione: continua la scansione quando viene rilevato un file contenente una minaccia.
  • Elimina file automaticamente — Lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Elimina file.
  • Continua scansione: continua la scansione quando viene rilevato un file contenente una minaccia.
  • Elimina file: lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Al rilevamento di un programma indesiderato Eseguire innanzitutto questa azione — Consente di selezionare la prima azione che lo scanner deve intraprendere al rilevamento di una minaccia. Impostazione predefinita = Pulisci file.
  • Pulisci file: lo scanner effettua un tentativo di rimozione della minaccia dal file rilevato.
  • Continua scansione: continua la scansione quando viene rilevato un file contenente una minaccia.
  • Elimina file: lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Se la prima azione non riesce, eseguire questa azione — Consente di selezionare l'azione successiva che lo scanner deve intraprendere se la prima azione non riesce. Impostazione predefinita = Elimina file.
  • Continua scansione: continua la scansione quando viene rilevato un file contenente una minaccia.
  • Elimina file: lo scanner elimina i file contenenti minacce potenziali al momento del rilevamento.
Riferimenti correlati
Opzioni della scheda Impostazioni dei processi
Informazioni correlate
Scansione di elementi all'accesso


Scheda Esclusioni

Definizioni delle opzioni

Consente di specificare gli elementi da escludere dalla scansione.

Opzioni Definizione
Elementi da escludere Selezionare il tipo di esclusione nell'elenco a discesa e quindi specificare i dettagli dell'esclusione:
  • Escludi in base al tipo/percorso file — Digitare il tipo di file nella casella di testo. Se necessario, selezionare Escludi anche le sottocartelle.
    Nota: È necessario aggiungere una barrae rovesciata (\) alla fine della stringa per applicare l'esclusione alla cartella. In caso contrario, viene considerata come un'esclusione del file e la casella di controllo Escludi anche le sottocartelle è disattivata per impostazione predefinita.
  • Escludi in base al tipo di file: digitare il tipo di file nella casella di testo.
  • Escludi in base alla data del file: selezionare il tipo di accesso e quindi specificare il numero minimo di giorni dalla creazione del file.

Per ulteriori informazioni, vedere Aggiunta ed esclusione di elementi da sottoporre a scansione.

Quando escludere Scegliere quando escludere l'elemento selezionato:
  • Lettura
  • Scrittura
Modalità di gestione delle esclusioni client Sovrascrivi esclusioni client — Consente di escludere soltanto gli elementi specificati in questo criterio. Se questa opzione non è selezionata, i computer client utilizzano le esclusioni specificate localmente insieme alle esclusioni specificate in questo criterio.
Nota:

Questa opzione è configurabile soltanto tramite ePolicy Orchestrator.

Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Prestazioni

Definizioni delle opzioni

Consente di specificare le opzioni di rinvio e di utilizzo del sistema per migliorare le prestazioni.

Opzioni Definizione
Opzioni di rinvio scansione Selezionare l'opzione di rinvio scansione:
  • Rinvia scansione quando l'alimentazione è a batteria: consente di posticipare la scansione quando il sistema è in uso ed è alimentato mediante batteria.
  • Rinvia scansioni durante le presentazioni: consente di posticipare la scansione mentre il sistema è in modalità di presentazione.
  • L'utente può rinviare scansioni pianificate: consente all'utente di rinviare le scansioni pianificate.

  • Rinvio massimo: consente di specificare per quanto tempo rinviare la scansione. Scegliere un numero di ore compreso fra 1 e 24 oppure selezionare zero per rinviare la scansione per sempre.

Per ulteriori informazioni, vedere Modalità di funzionamento del rinvio scansione.

Utilizzo del sistema Utilizzare l'elenco, da ePolicy Orchestrator, o l'indicatore scorrevole, da Console di VirusScan, per impostare la pianificazione dell'utilizzo della scansione. Ogni attività viene eseguita in maniera indipendente e senza considerare i limiti impostati per le altre attività. Gli incrementi sono i seguenti:
  • Basso
  • Al di sotto del normale — L'impostazione predefinita di ePolicy Orchestrator.
  • Normale — L'impostazione predefinita di VirusScan Enterprise 8.8.
Artemis (verifica euristica in rete per verificare la presenza di file sospetti)
Consente di configurare il livello di sensibilità che si desidera utilizzare per determinare se un elemento rilevato è una minaccia malware. Per tutti i livelli diversi da Disattivato, vengono inviati gli ID digitali degli esempi, o hash, a McAfee Labs per determinare se si tratta di malware. Il vantaggio per l'utente consiste nell'eventuale disponibilità del rilevamento non appena McAfee Labs avrà pubblicato l'aggiornamento, senza attendere il successivo rilascio del file DAT. Un livello di sensibilità più elevato comporta un maggior numero di rilevamenti di malware. Tuttavia, consentendo l'esecuzione di un elevato numero di rilevamenti è possibile ottenere un maggior numero di risultati falsi positivi. Selezionare uno dei livelli di sensibilità seguenti:

  • Disattivato — Nessun ID digitale o nessun dato viene inviato ai laboratori McAfee Labs per determinare se si tratta di malware.

  • Bassissimo — La quantità di rilevamenti e il rischio che si verifichino falsi positivi corrispondono a quelli che si presentano quando si utilizzano i normali file DAT. Anziché attendere il successivo aggiornamento del file DAT, un rilevamento può essere reso disponibile a VirusScan Enterprise quando viene pubblicato da McAfee Labs.

  • Basso — Questo livello è definito come caso intermedio fra Bassissimo e Medio.

  • Medio — Utilizzare questo livello quando il rischio normale di esposizione al malware è maggiore del rischio di un falso positivo. Nella maggior parte dei casi, le verifiche euristiche proprietarie di McAfee Labs, sono in grado di individuare correttamente gli elementi malware. Tuttavia, benché minimo, esiste il rischio che un rilevamento riguardante un file poco diffuso sia in realtà un falso positivo. McAfee Labs verificano che i rilevamenti dovuti a questa impostazione non comportino un falso positivo qualora il file esaminato appartenga ad applicazioni e a sistemi operativi largamente diffusi.

  • Alto — Questo livello è definito come caso intermedio fra Medio e Altissimo.

  • Altissimo — Questo livello è consigliabile soltanto per la posta elettronica e per la scansione di volumi e directory che non supportano l'esecuzione di programmi né l'utilizzo di sistemi operativi. Benché presumibilmente pericolosi, i rilevamenti ottenuti mediante questo livello non sono stati sottoposti a verifiche esaustive per confermare che non si tratti di falsi positivi.

Concetti correlati
Modalità di funzionamento dell'utilizzo del sistema
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Rapporti

Definizioni delle opzioni

La registrazione consente di monitorare le attività della rete e di tenere traccia delle impostazioni utilizzate per rilevare e rispondere alle minacce potenziali individuate dal programma antivirus.

Opzioni | Definizione
Registra su file | Consente di attivare la registrazione delle attività.
Percorso file di registro Confermare il percorso predefinito del file di registro o specificare un nuovo percorso.

Il nome predefinito del registro è OnDemandScanLog.txt.

Il percorso predefinito è: <unità>:\Documents and Settings\All Users\Dati applicazioni\McAfee\DesktopProtection\.

Il percorso predefinito può variare in base al sistema operativo in uso.
Dimensione file di registro | Consente di limitare la dimensione del file di registro. Accettare la dimensione predefinita (1 MB) oppure impostare un valore compreso tra 1 MB e 999 MB. Se il file di registro supera la dimensione impostata, il 20% delle voci meno recenti viene eliminato per consentire l'aggiunta di nuovi dati al file.
Formato file di registro Selezionare il formato del file di registro. Impostazione predefinita = Unicode (UTF8).
  • Unicode (UTF8) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • Unicode (UTF16) — Questo formato è consigliato quando si memorizzano testi con caratteri orientali (in cui ogni carattere è costituito da uno o due byte) o quando si condividono informazioni all'interno di un'azienda multinazionale.
  • ANSI — Questo formato è consigliato quando si memorizzano testi con caratteri occidentali (in cui ogni carattere è costituito da un solo byte).
Informazioni da registrare oltre all'attività di scansione
  • Impostazioni sessione — Consente di memorizzare le proprietà di ogni sessione di scansione nel file di registro.
  • Riepilogo sessione — Consente di registrare un riepilogo delle azioni dello scanner nel file di registro durante ogni sessione di scansione. Le informazioni di riepilogo includono il numero dei file sottoposti a scansione, il numero e il tipo di rilevamenti, il numero di file puliti o eliminati e altre informazioni.
  • Scansione di file crittografati non riuscita — Consente di memorizzare il nome dei file crittografati di cui non è stato possibile eseguire la scansione.
Avvisa al verificarsi di rilevamenti di file cookie

Avvisa al verificarsi di rilevamenti di file cookie — Consente di inviare avvisi in caso di rilevamento di cookie. Ciò comprende la generazione di avvisi di ePolicy Orchestrator, l'invio di notifiche di rilevamento, l'inserimento dei rilevamenti nel registro delle attività se è stata attivata la registrazione delle attività nella scheda Rapporti e l'aggiunta dei rilevamenti nelle statistiche di scansione. Se si deseleziona questa opzione, ePolicy Orchestrator non genera avvisi. Tuttavia, se la registrazione delle attività è stata attivata nella scheda Rapporti, i rilevamenti vengono comunque inseriti nel registro delle attività nonché aggiunti nelle statistiche di scansione.
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Scansione elementi

Definizioni delle opzioni

Consente di configurare opzioni di rilevamento.

Opzioni Definizione
Tipi di file da sottoporre a scansione
  • Tutti i file — Consente di eseguire la scansione di tutti i file, indipendentemente dall'estensione.
  • Tipi di file predefiniti e aggiuntivi — Viene eseguita la scansione dei file la cui estensione appartiene all'elenco predefinito delle estensioni, nonché degli eventuali tipi aggiuntivi specificati dall'utente. L'elenco predefinito è definito dal file DAT corrente.

    Selezionare questa opzione, quindi immettere nella casella di testo le estensioni di file separate da spazi.

    Esegui anche la ricerca delle macro in tutti i file: se è stata selezionata l'opzione Tipi di file predefiniti e aggiuntivi, è inoltre possibile eseguire in tutti i file una ricerca di minacce note basate su macro.

  • Tipi di file specificati — Consente di creare un elenco personalizzato di estensioni specifiche da sottoporre a scansione, nonché di rimuovere eventuali estensioni aggiunte in precedenza.

    Selezionare questa opzione, quindi immettere nella casella di testo le estensioni di file separate da spazi.

Opzioni
  • Rileva programmi indesiderati — Consente di attivare la scansione all'accesso per rilevare programmi potenzialmente indesiderati.

    Lo scanner utilizza le informazioni configurate nel Criterio per programmi indesiderati per rilevare programmi potenzialmente indesiderati.

    Per ulteriori informazioni, vedere Restrizione dei programmi potenzialmente indesiderati.

  • Decodifica file MIME codificati — Consente di rilevare, decodificare e sottoporre a scansione i file MIME (Multipurpose Internet Mail Extensions) codificati.
  • Esegui scansione su file all'interno di archivi — Consente di esaminare i file di archivio (compressi) e il relativo contenuto.
Benché offra una migliore protezione, la scansione di file compressi può aumentare la quantità di tempo necessaria per eseguire una scansione.

  • Esegui scansione sui file passati in archivio — Consente di eseguire la scansione di file della cache memorizzati nell'archivio remoto.

    Per ulteriori informazioni, vedere Modalità di funzionamento della scansione dell'archivio remoto.

Artemis (verifica euristica in rete per verificare la presenza di file sospetti)
  • Trova minacce di programma sconosciute — Consente di attivare la scansione Artemis per rilevare file eseguibili con codice simile a malware.
  • Trova minacce di macro sconosciute — Utilizzare Artemis per rilevare virus macro sconosciuti.
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Attività

Definizioni delle opzioni

Consente di specificare le piattaforme in cui viene eseguita l'attività su richiesta.

Opzioni Definizione
Piattaforme in cui viene eseguita l'attività
  • Run this task on servers (Esegui l'attività nei server): consente di eseguire l'attività di scansione su richiesta nei server.
  • Run this task on workstations (Esegui l'attività nelle workstation): consente di eseguire l'attività di scansione su richiesta nelle workstation.
Account utente da utilizzare durante l'esecuzione dell'attività
  • Nome utente: consente di specificare il nome account dell'utente. Se non si specifica alcun account, l'attività verrà eseguita utilizzando l'account di sistema.
  • Password: immettere la password.
  • Dominio: immettere il dominio.
Nota:

Per pianificare l'attività è necessario disporre dei privilegi di amministratore. Tali privilegi consentono all'utente di accedere in scrittura alla chiave del registro delle attività pianificate. Per informazioni sulla pianificazione di attività client, vedere la documentazione di ePolicy Orchestrator.

Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi su richiesta


Scheda Opzioni password

Definizioni delle opzioni

È possibile impostare la protezione tramite password per l'intero sistema o per gli elementi selezionati. Per ulteriori informazioni, vedere Conseguenze sugli utenti a seguito dell'impostazione di una password.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Password dell'interfaccia utente Specificare la protezione dell'interfaccia utente:
  • Nessuna password: per accedere alle impostazioni di configurazione non è richiesta alcuna password.
  • Protezione tramite password per tutti gli elementi elencati di seguito: consente di specificare un'unica password per tutti gli elementi nell'elenco.
  • Protezione tramite password per gli elementi selezionati: consente di specificare un'unica password per gli elementi selezionati nell'elenco.
  • Protezione tramite password per la conformità ai criteri comuni: consente di proteggere l'interfaccia conformemente ai requisiti richiesti alle agenzie governative che devono utilizzare solo i prodotti di protezione convalidati dai criteri comuni NIAP (National Information Assurance Partnership).

    Ciò consente di impedire l'accesso a tutte le opzioni di configurazione da parte degli utenti senza credenziali amministrative, ad eccezione degli utenti delle workstation che possono: eseguire una scansione immediata su richiesta della propria workstation, includere o escludere i file da una scansione immediata su richiesta, includere o escludere archivi, ad esempio un file ZIP, da una scansione immediata su richiesta e visualizzare i registri delle attività di scansione su richiesta e all'accesso.

Password: immettere la password.

Conferma password: digitare di nuovo la password per confermarla.
Elementi dell'interfaccia utente da proteggere con password Selezionare gli elementi che si desidera proteggere con una password.
  • Seleziona tutto: consente di selezionare tutti gli elementi della sezione.
  • Deseleziona tutto: consente di deselezionare tutti gli elementi della sezione.

Gli amministratori possono bloccare o sbloccare l'interfaccia mediante la Console.

Riferimenti correlati
Configurazione del piano delle attività
Informazioni correlate
Controllo dell'accesso all'interfaccia utente


Scheda Criterio

Definizioni delle opzioni

Consente di configurare il percorso di quarantena e il periodo di tempo in cui gli elementi resteranno in quarantena.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Directory di quarantena | Confermare il percorso predefinito per la directory di quarantena o specificare un nuovo percorso. Impostazione predefinita = <unità_di_sistema>\Quarantine.
Periodo di tempo in cui i dati restano in quarantena
  • Eliminare automaticamente i dati messi in quarantena: i dati messi in quarantena vengono eliminati automaticamente dopo il numero di giorni specificato.
  • Numero di giorni in cui i dati di backup resteranno in quarantena: consente di specificare il numero di giorni in cui gli elementi resteranno in quarantena prima di essere automaticamente eliminati. Scegliere un valore compreso tra 1 e 999 giorni.
Attività correlate
Configurazione del criterio quarantena


Scheda Impostazioni proxy

I server proxy vengono utilizzati come parte della protezione Internet per nascondere i computer degli utenti su Internet e migliorare la velocità di accesso mediante il caching dei siti visitati di frequente.

Se la rete utilizza un server proxy, è possibile specificare le impostazioni del proxy da utilizzare, l'indirizzo del server proxy e determinare se utilizzare o meno l'autenticazione. Le informazioni relative al proxy vengono memorizzate nell'elenco degli archivi di Aggiornamento automatico (sitelist.xml). Le impostazioni del proxy configurate in questa scheda si applicano a tutti gli archivi presenti nell'elenco.

Nota:

Questa funzione non è disponibile nella Console di ePolicy Orchestrator. È possibile accedere a questa funzione dalla Console di VirusScan Enterprise 8.8.

Definizioni delle opzioni

Opzioni Definizione
Non utilizzare il proxy

Consente di non specificare alcun server proxy.

Utilizza le impostazioni del proxy di Internet Explorer

Consente di utilizzare le impostazioni proxy per la versione attualmente installata di Internet Explorer.

Opzione predefinita = Utilizza le impostazioni del proxy di Internet Explorer.

Configura manualmente le impostazioni del proxy

Consente di configurare le impostazioni del proxy in base a esigenze specifiche.

Eccezioni

Questa opzione è disponibile solo se è stata selezionata l'opzione Configura manualmente le impostazioni del proxy.

Consente di specificare le eccezioni del proxy. Fare clic su Eccezioni per aprire la finestra di dialogo Eccezioni del proxy:
  • Specifica eccezioni: selezionare questa opzione per inserire le eccezioni del proxy.
  • Utilizzare i punti e virgola (;) per separare le voci, ad esempio: internal1;internal2.
HTTP

Digitare l'indirizzo del server proxy HTTP.

FTP

Digitare l'indirizzo del server proxy FTP.

Porta

Digitare il numero di porta del server proxy HTTP o FTP.

Utilizza autenticazione per HTTP

Consente di utilizzare le credenziali specificate per l'accesso al proxy HTTP.

Nome utente HTTP

Digitare il nome utente HTTP.

Password HTTP

Digitare la password HTTP.

Concetti correlati
Funzionamento dell'archivio di AutoUpdate
Riferimenti correlati
Configurazione dell'elenco degli archivi


Scheda Scansione elementi

Definizioni delle opzioni

Consente di selezionare le categorie di programmi potenzialmente indesiderati da rilevare e di creare esclusioni per i programmi che non si desidera rilevare.

Opzioni | Definizione
Impostazioni per | Selezionare Workstation o Server nell'elenco a discesa. Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Selezionare le categorie di programmi indesiderati da rilevare | Consente di specificare le categorie di programmi potenzialmente indesiderati da rilevare.
Esclusioni da programmi indesiderati | Specificare le esclusioni in base al nome di rilevamento. Aggiungere e rimuovere gli elementi in base alle proprie necessità.
Attività correlate
Configurazione dei programmi indesiderati
Informazioni correlate
../../pgrestrictingunwantedprogram_chapter.ditamap


Scheda Criterio quarantena

Definizioni delle opzioni

Consente di configurare il percorso di quarantena e il periodo di tempo in cui gli elementi resteranno in quarantena.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Directory di quarantena | Confermare il percorso predefinito per la directory di quarantena o specificare un nuovo percorso. Impostazione predefinita = <unità_di_sistema>\Quarantine.
Periodo di tempo in cui i dati restano in quarantena
  • Eliminare automaticamente i dati messi in quarantena: i dati messi in quarantena vengono eliminati automaticamente dopo il numero di giorni specificato.
  • Numero di giorni in cui i dati di backup resteranno in quarantena: consente di specificare il numero di giorni in cui gli elementi resteranno in quarantena prima di essere automaticamente eliminati. Scegliere un valore compreso tra 1 e 999 giorni.
Attività correlate
Configurazione del criterio quarantena


Aggiunta e modifica di archivi

Consente di aggiungere nuovi archivi o modificare quelli esistenti.

Definizioni delle opzioni

Opzioni Definizione
Descrizione archivio

Consente di specificare il nome dell'archivio.
Recupera file da
Selezionare il percorso dal quale recuperare i file. L'archivio predefinito è HTTP.
  • Archivio HTTP: consente di recuperare i file dal percorso dell'archivio HTTP specificato.
    Nota: Un sito HTTP, analogamente a un sito FTP, consente l’aggiornamento indipendentemente dalla protezione di rete, ma supporta livelli di connessioni simultanee superiori rispetto a FTP.
  • Archivio FTP: consente di recuperare i file dal percorso dell'archivio FTP specificato.
    Nota: Un sito FTP offre flessibilità di aggiornamento senza la necessità di doversi conformare ad autorizzazioni di protezione della rete. FTP si è rivelato meno soggetto ad attacchi di codice non desiderato rispetto a HTTP, pertanto può offrire una maggiore tolleranza.
  • Percorso UNC: consente di recuperare i file dal percorso UNC specificato.
    Nota: Un sito UNC è il sito più rapido e facile da impostare. Per gli aggiornamenti UNC tra domini è necessario disporre delle autorizzazioni di protezione per ciascun dominio e ciò rende la configurazione dell’aggiornamento più complessa.
  • Percorso locale: consente di recuperare i file dal percorso locale specificato.
URL
Questa opzione è disponibile solo se è stata selezionata l'opzione Archivio HTTP o Archivio FTP.
  • HTTP: immettere il percorso del server e della cartella HTTP in cui si trovano i file di aggiornamento.
  • FTP: immettere il percorso del server e della cartella FTP in cui si trovano i file di aggiornamento.
Percorso
Questa opzione è disponibile solo se è stata selezionata l'opzione Percorso UNC o Percorso locale.
  • Percorso UNC: immettere il percorso dell'archivio in cui si trovano i file di aggiornamento utilizzando la notazione UNC (\\nomeserver\percorso\).
  • Percorso locale: immettere il percorso della cartella locale in cui sono stati collocati i file di aggiornamento o fare clic su Sfoglia per individuare la cartella desiderata. Il percorso può essere quello di una cartella su un'unità locale o di rete.
Porta

Questa opzione è disponibile solo se è stata selezionata l'opzione Archivio HTTP o Archivio FTP. Consente di immettere il numero della porta per il server HTTP o FTP specificato.

Utilizza autenticazione

Utilizza accesso anonimo

Utilizza account di connessione
Consente di utilizzare le credenziali specificate per l'accesso all’archivio.
Nota:

L'etichetta di questa opzione varia in base all'opzione selezionata nella sezione Recupera file da.

Le credenziali specificate vengono utilizzate da Aggiornamento automatico per accedere all'archivio e scaricare i file di aggiornamento necessari. Durante la configurazione delle credenziali dell'account per l'archivio, assicurarsi che l'account disponga delle autorizzazioni di lettura per le cartelle contenenti i file di aggiornamento.
  • Le credenziali per il download sono necessarie per gli archivi FTP e UNC, ma facoltative per gli archivi HTTP.
  • Per gli aggiornamenti FTP le connessioni anonime agli archivi sono supportate.
  • Gli aggiornamenti da UNC consentono inoltre di usare l'account di connessione, utilizzando i privilegi dell'utente connesso per accedere all'archivio.
Nome utente

Digitare il nome utente.
Password

Digitare la password.
Conferma

Digitare di nuovo la password per confermarla.
Concetti correlati
Funzionamento dell'archivio di AutoUpdate
Riferimenti correlati
Configurazione dell'elenco degli archivi


Scheda Archivi

Consente di configurare gli archivi da cui ottenere gli aggiornamenti.
Nota:

Questa funzione non è disponibile nella Console di ePolicy Orchestrator. È possibile accedere a questa funzione dalla Console di VirusScan Enterprise 8.8.

Definizioni delle opzioni

Opzioni Definizione
Descrizione archivio

Consente di specificare il nome dell'archivio.

L'elenco è già configurato con un archivio HTTP e FTP.
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

L'archivio HTTP corrisponde al sito di download predefinito.
Stato

Attivato: archivio definito che può essere utilizzato durante il processo di aggiornamento automatico.

Disattivato: archivio definito al quale non si desidera accedere durante il processo di aggiornamento automatico. Potrebbe essere un archivio che si utilizza occasionalmente, ma non sempre.

Nota: Creare tutti gli archivi necessari, quindi attivarli e disattivarli.
Aggiungi

Consente di aggiungere un nuovo archivio all'elenco.
Modifica

Consente di modificare l'archivio selezionato.
Elimina

Consente di eliminare l'archivio selezionato.
Sposta su

Consente di spostare l'archivio selezionato in alto nell'elenco.
Sposta giù

Consente di spostare l'archivio selezionato in basso nell'elenco.
Concetti correlati
Funzionamento dell'archivio di AutoUpdate
Riferimenti correlati
Configurazione dell'elenco degli archivi


Scheda Gestione

Selezionare un elemento dall'elenco, quindi fare clic con il pulsante destro del mouse su di esso per accedere alle opzioni avanzate. È possibile ripetere la scansione, verificare i falsi positivi, ripristinare, eliminare o visualizzare le proprietà.

Attività correlate
Configurazione del criterio quarantena


Scheda Attività

Definizioni delle opzioni

Consente di specificare le informazioni relative all'account utente autorizzato ad accedere al percorso di ripristino. Se non si immette alcun account, l'attività di ripristino verrà eseguita utilizzando l'account di sistema.

Opzioni | Definizione
Utente | Digitare il nome dell'utente autorizzato ad accedere al percorso di ripristino.
Password | Digitare una password per l'utente specificato.
Dominio | Digitare il dominio dell'utente specificato.
Attività correlate
Configurazione del criterio quarantena


Scheda Percorsi

Definizioni delle opzioni

Consente di configurare i tipi di elementi e i percorsi da sottoporre a scansione.

Opzioni Definizione
Percorsi da sottoporre a scansione Consente di selezionare i percorsi da sottoporre a scansione. Impostazione predefinita = Memoria per i rootkit, processi in esecuzione, tutte le unità locali, il registro e i cookie. Fare clic su Aggiungi, Modifica e Rimuovi per modificare le voci Nome elemento.
  • Memoria per i rootkit: consente di eseguire la scansione della memoria del sistema per individuare rootkit installati, processi nascosti e altri segnali che indichino il tentativo di nascondersi da parte di codice dannoso. Questa scansione viene eseguita prima di tutte le altre.
    ATTENZIONE:
    L'impossibilità di consentire la scansione Memoria per i rootkit lascia il sistema sprovvisto di protezione da numerosi attacchi malware.
  • Processi in esecuzione: consente di eseguire la scansione della memoria di tutti i processi in esecuzione. Le azioni diverse da Pulisci vengono trattate come Continua scansione.
    ATTENZIONE:
    Se le scansioni di Processi in escuzione non vengono attivate, il sistema rimane non protetto da numerosi attacchi malware.
  • File registrati: consente di eseguire la scansione di tutti i file registrati. Lo scanner esegue prima una ricerca nel registro in base al nome dei file, quindi esegue la scansione dei file. Eventuali riferimenti a file potenzialmente indesiderati vengono rimossi dal registro.
  • Risorse del computer: consente di eseguire la scansione di tutte le unità collegate fisicamente al computer o delle unità logiche mappate a lettere di unità del computer in uso.
  • Tutte le unità locali: consente di eseguire la scansione di tutte le unità e delle relative sottocartelle appartenenti al computer in uso.
  • Tutte le unità fisse: consente di eseguire la scansione di tutte le unità collegate fisicamente al computer in uso.
  • Tutte le unit�� rimovibili: consente di eseguire la scansione di tutte le unità rimovibili o di altri supporti di archiviazione collegati al computer in uso.
  • Tutte le unità mappate: consente di eseguire la scansione di tutte le unità logiche di rete mappate a un'unità di rete del computer in uso.
  • Cartella principale: consente di eseguire la scansione della cartella principale dell'utente che ha avviato la scansione.
  • Cartella del profilo utente: consente di eseguire la scansione del profilo dell'utente che avvia la scansione, inclusa la cartella Documenti dell'utente.
  • Cartella Windows: consente di eseguire la scansione della cartella Windows.
  • Cartella Programmi: consente di eseguire la scansione della cartella Programmi.
  • Cartella Temp: consente di eseguire la scansione della cartella Temp.
  • Cestino: consente di eseguire la scansione del contenuto del Cestino.
  • Unità o cartella: consente di eseguire la scansione di un'unità o di una cartella specifica.
  • File: consente di eseguire la scansione di un file specifico.
  • Cookie: consente di eseguire la scansione dei cookie contenuti nella cartella dei cookie.
  • Registro: consente di eseguire la scansione delle voci del registro.
Nota: L'utilizzo dell'elenco predefinito delle voci di scansione può generare una scansione che richiede molto tempo. Per un uso regolare, si consiglia di restringere il campo della scansione.
Quando viene visualizzata la finestra di dialogo Stato della scansione su richiesta, i percorsi da sottoporre a scansione vengono visualizzati come stringa separata da virgole successivamente a Scansione in. Quando i processi di scansione vengono completati, vengono rimossi dalla stringa.
Opzioni di scansione Tipo di scansione per l'elemento selezionato.
  • Includi sottocartelle: lo scanner esamina tutte le sottocartelle nei volumi specificati. Deselezionare questa opzione per esaminare solo il livello principale dei volumi.
  • Scansione dei settori di avvio: lo scanner esamina il settore di avvio del disco.
Quando il disco contiene un settore di avvio speciale o anomalo che non può essere sottoposto a scansione, può essere opportuno disabilitare la scansione del settore di avvio.
Riferimenti correlati
Configurazione delle schede di attività di scansione su richiesta
Informazioni correlate
Scansione di elementi all'accesso


Opzioni di pianificazione avanzate

Consente di configurare i parametri di pianificazione.

Definizioni delle opzioni

Opzioni | Definizione
Data di inizio | Specificare la data di inizio dell'attività.
Data di fine | Specificare la data di fine dell'attività.
Ripeti l'attività | Consente di ripetere l'attività con la frequenza specificata. Se si seleziona questa opzione, specificare anche la frequenza con cui ripetere l'attività.
Ogni | Specificare la frequenza con cui ripetere l'attività. Selezionare inoltre se si desidera specificare la frequenza in ore o in minuti.
Ora (locale) | Consente di ripetere l'attività all'ora locale specificata. Se si seleziona questa opzione, selezionare anche l'ora specifica.
Durata | Consente di ripetere l'attività per le ore e i minuti selezionati. Se si seleziona questa opzione, selezionare anche le ore e i minuti.
Ore | Numero di ore. Scegliere un valore compreso tra 0 e 99.
Minuti | Numero di minuti. Scegliere un valore compreso tra 0 e 59.
Concetti correlati
Attività di aggiornamento e relativo funzionamento
Riferimenti correlati
Configurazione dell'attività di AutoUpdate


Scheda Pianificazione

Consente di specificare la frequenza del piano e altre impostazioni relative all'attività.

Definizioni delle opzioni

Opzioni Definizione
Esegui l'attività

Eseguire l'attività Selezionare la frequenza con cui eseguire l'attività tra le seguenti opzioni:

Ogni giorno: consente di eseguire l'attività giornalmente nei giorni specificati.

Le attività giornaliere possono essere eseguite nell'intervallo di giorni specificato oppure ogni giorno da lunedì a domenica. Se si desidera eseguire l'attività solo in determinati giorni della settimana, invece che ogni giorno da lunedì a domenica, si consiglia di utilizzare la frequenza settimanale.

Ogni settimana: consente di eseguire l'attività giornalmente nelle settimane e nei giorni specificati.

Ogni mese: consente di eseguire l'attività giornalmente nei giorni e nei mesi specificati.

Una volta: consente di eseguire l'attività una volta nella data specificata.

All'avvio: consente di eseguire l'attività all'avvio del sistema, di specificare se eseguire l'attività una volta al giorno e di determinare il numero di minuti di cui si desidera ritardare l'attività.

All'accesso dell'utente: consente di eseguire l'attività all'accesso dell'utente, di specificare se eseguire l'attività una volta al giorno e di determinare il numero di minuti di cui si desidera ritardare l'attività.

Quando è inattivo: consente di eseguire l'attività quando il computer è inattivo e di specificare il numero di minuti di inattività del computer, trascorsi i quali verrà avviata l'attività.

Se l'attività viene avviata e l'utente riprende a usare il computer prima che questa sia completata, l'esecuzione dell'attività continua fino al completamento.

Immediatamente: consente di eseguire l'attività immediatamente.

Alla connessione: consente di eseguire l'attività al momento della connessione.

Ora di inizio

Selezionare l'ora di inizio dell'attività pianificata.

Ora UTC

UTC (tempo universale coordinato). Selezionare questa opzione per eseguire l'attività simultaneamente in tutti i fusi orari.

Ora locale

Consente di eseguire l'attività in modo indipendente in ciascun fuso orario locale.

Nota: Impostazione predefinita = Ora locale.
Attiva esecuzione casuale

Consente di eseguire l'attività in un punto casuale all'interno dell'intervallo di tempo impostato dall'utente.

Se si seleziona questa opzione, specificare anche le ore e i minuti per il periodo di tempo massimo.

Nota:

Specificare un intervallo di tempo compreso fra 1 minuto (minimo) e 23 ore (massimo). Ad esempio, impostando la pianificazione dell'attività su 1.00 e l'esecuzione casuale su tre ore, l'attività viene eseguita in qualsiasi orario tra l'una e le quattro.

Questa opzione non è disponibile se l'attività è pianificata per essere eseguita All'avvio, All'accesso dell'utente o Quando è inattivo.

Ore

Numero di ore. Scegliere un valore compreso tra 0 e 23 ore.

Minuti

Numero di minuti.

Nota:
Il numero dei minuti disponibili per la selezione varia in base alle opzioni selezionate. Ad esempio:
  • Attiva esecuzione casuale è possibile scegliere un valore compreso tra 0 e 59 minuti.
  • Ritarda l'attività non eseguita di: è possibile scegliere un valore compreso tra 0 e 99 minuti.
Procedi se non eseguita

Consente di eseguire le attività non eseguite al successivo avvio del computer. Se il computer non era in linea quando l'attività pianificata doveva essere eseguita, è possibile che l'attività non sia stata eseguita.

Nota: Questa funzione assicura la protezione completa degli utenti remoti e della rete nel caso in cui non si trovino in linea quando è programmata l'esecuzione di un'attività.
Ritarda l'attività non eseguita di

Selezionare il numero di minuti di cui si desidera ritardare l'attività non eseguita. Scegliere un valore compreso tra 0 e 99 minuti.

Ogni x giorni

Consente di eseguire l'attività con la cadenza di giorni specificata. Scegliere un valore compreso tra 0 e 9999 giorni.

Nota: Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Ogni giorno.
Ogni x settimane

Consente di eseguire l'attività con la cadenza di settimane specificata. Scegliere un valore compreso tra 0 e 99 settimane.

Se si seleziona questa opzione, specificare anche il numero delle settimane e il giorno o i giorni della settimana.

Nota:

Per il giorno del mese, scegliere tra Domenica, Lunedì, Martedì, Mercoledì, Giovedì, Venerdì e Sabato.

Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Ogni settimana.

Giorno del mese

Consente di eseguire l'attività in un determinato giorno del mese. Scegliere un valore compreso tra 1 e 31 giorni.

Se si seleziona questa opzione, specificare anche il numero del giorno del mese.

Nota: Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Ogni mese.
Giorno della settimana

Consente di eseguire l'attività nel giorno del mese specificato.

Se si seleziona questa opzione, specificare anche l'occorrenza e il giorno del mese.

Nota:

Per l'occorrenza, scegliere tra Primo, Secondo, Terzo, Quarto e Ultimo.

Per il giorno del mese, scegliere tra Domenica, Lunedì, Martedì, Mercoledì, Giovedì, Venerdì e Sabato.

Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Ogni mese.

Seleziona i mesi

Consente di specificare in quali mesi eseguire l'attività.

Nota: Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Ogni mese.
Esegui il

Specificare la data in cui si desidera eseguire l'attività.

Nota: Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Una volta.
Esegui l'attività una volta al giorno

Consente di eseguire l'attività una volta al giorno.

Nota:

Se non si seleziona questa opzione, l'attività viene eseguita ad ogni avvio o ad ogni accesso utente.

Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività All'avvio, All'accesso dell'utente o Esegui alla connessione di accesso remoto.

Ritarda l'attività di

Specificare il numero di minuti di ritardo dell'attività. Scegliere un valore compreso tra 0 e 99.

Nota:

In questo modo gli utenti hanno il tempo necessario per accedere e per eseguire gli script di accesso.

Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività All'avvio o All'accesso dell'utente.

Dopo che il computer è rimasto inattivo per

Specificare il numero di minuti durante i quali il computer deve essere inattivo prima che l'attività sia avviata. Scegliere un valore compreso tra 0 e 999 minuti.

Nota:

Se l'attività viene avviata e l'utente riprende a usare il computer prima che questa sia completata, l'esecuzione dell'attività continua fino al completamento.

Questa opzione è disponibile solo se è stata selezionata l'opzione di pianificazione dell'attività Quando è inattivo.

Avanzate

Consente di configurare le opzioni di pianificazione avanzate.

Nota: Per ulteriori informazioni, vedere Opzioni di pianificazione avanzate.
Concetti correlati
Attività di aggiornamento e relativo funzionamento
Riferimenti correlati
Configurazione dell'attività di AutoUpdate


Scheda Attività

Consente di attivare la pianificazione dell'attività e di specificare le impostazioni dell'account utente.

Definizioni delle opzioni

Opzioni | Definizione
Attiva (l'attività pianificata verrà eseguita nel momento specificato) | Pianifica l'attività per l'esecuzione in un orario specifico. Nota: È necessario selezionare questa opzione per pianificare l'attività.
Termina l'attività dopo | Arresta l'attività dopo il numero di ore e minuti specificato. Nota: Se l'attività viene interrotta prima del completamento, all'avvio successivo la scansione verrà ripresa dal punto in cui è stata interrotta.
Ore | Numero di ore dopo cui l'attività si arresta.
Minuti | Numero di minuti dopo cui l'attività si arresta.
Utente | Digitare l'ID Utente utilizzato per l'esecuzione dell'attività. Nota: L'utilizzo delle credenziali è facoltativo. Se le credenziali non vengono digitate in questo punto, l'attività pianificata verrà eseguita utilizzando l'account del sistema locale. Per ulteriori informazioni, vedere Privilegi di accesso.
Dominio | Digitare il dominio per l'ID Utente specificato.
Password | Digitare la password per l'ID Utente e il dominio specificati.
Concetti correlati
Attività di aggiornamento e relativo funzionamento
Riferimenti correlati
Configurazione dell'attività di AutoUpdate


Scheda ScriptScan

Definizioni delle opzioni

Consente di impedire l'esecuzione degli script indesiderati.

Per ulteriori informazioni, vedere Scansione degli script e relativa modalità di funzionamento.

Opzioni | Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
ScriptScan | Attiva la scansione degli script: consente di eseguire la scansione degli script JavaScript e VBScript prima che vengano eseguiti.
Esclusioni del processo ScriptScan | Processo: consente di specificare le esclusioni ScriptScan in base al nome del processo. Per l'indicazione dei nomi dei processi non è consentito l'uso dei caratteri jolly.
Esclusioni di URL per ScriptScan URL —Specificare le esclusioni ScriptScan in base all'URL. Tenere presente quanto segue:
  • per l'indicazione degli URL, è consentito l'uso dei caratteri jolly. Tuttavia, ad esempio, se l'URL msn.com è escluso, gli URL con quella stringa vengono esclusi dalla scansione. Ad esempio, i seguenti URL vengono esclusi:
    • http://weather.msn.com
    • http://music.msn.com
  • Sui sistemi Windows Server 2008, le esclusioni degi URL Script Scan non funzionano con Windows Internet Explorer, a meno che non si seleziona la casella di controllo Attiva estensioni di browser di terze parti per attivare l'impostazione e riavviare Windows Server 2008. Per informazioni dettagliate, consultare https://kc.mcafee.com/corporate/index?page=content&id=KB69526.
Attività correlate
Configurazione delle impostazioni generali
Informazioni correlate
Scansione di elementi all'accesso


Scheda Rilevamento definito dall'utente

Definizioni delle opzioni

Consente di specificare singoli file o programmi da rilevare come programmi indesiderati.

Opzioni Definizione
Impostazioni per Selezionare Workstation o Server nell'elenco a discesa.
Nota: Questa opzione è disponibile soltanto tramite ePolicy Orchestrator.
Elementi definiti dall'utente
  • Nome file: consente di specificare il nome del file o del programma da rilevare.

  • Descrizione: consente di specificare la descrizione che si desidera visualizzare nella notifica quando il file specificato viene rilevato.

Nota: Lo scanner non rileva programmi indesiderati definiti dall'utente di dimensioni pari a zero byte.
Attività correlate
Configurazione delle impostazioni generali
Informazioni correlate
Scansione di elementi all'accesso