まえがき

このマニュアルを有効に活用するには、本書の対象読者、表記規則、内容、および他のリファレンス マニュアルを検索する方法を理解する必要があります。

目次

  • 対象読者
  • 表記規則
  • 本書の構成
  • 製品マニュアルの検索


対象読者

McAfee のマニュアルは、対象読者に合わせて綿密に調査および記述されています。

このガイドの情報は、主に以下の方を対象としています。
  • 管理者 － 企業のセキュリティ プログラムを実装および施行します。
  • ユーザ － 各自のシステム上の製品オプションを設定したり、各自のシステムを更新したりします。


表記規則

このマニュアルでは、次の表記規則を使用しています。
文書タイトルまたは強調語句 | 文書/章/トピックのタイトル、新しい用語、強調語句を表します。
太字 | 強調されるテキストを表します。
ユーザ入力またはパス | ユーザが入力するコマンドや他のテキスト、フォルダやプログラムのパスを表します。
コード | コード サンプルを表します。
ユーザ インターフェース | オプション、メニュー、ボタン、ダイアログ ボックスなどのユーザ インターフェース要素のテキストを表します。
青いハイパーテキスト | トピックまたは Web サイトへの直接リンクを表します。
注 | オプションにアクセスするための代替方法などの追加情報を表します。
ヒント | 提案事項や推奨事項を表します。
重要/注意 | お使いのコンピュータ システム、インストール済みソフトウェア、ネットワーク、ビジネス、データなどを保護するための有用なアドバイスを表します。
警告 | ハードウェア製品の使用時に身体的な被害を防止するための重要なアドバイスを表します。


本書の構成

このマニュアルは、VirusScan コンソール や ePolicy Orchestrator のユーザ インターフェースを操作しながら参照するためのリファレンスとして提供されています。また、VirusScan Enterprise を使用してお使いのシステムをマルウェアから保護するための方法も順序立てて説明しています。このプロセスを説明するために、このマニュアルは次の 4 つの主要パートと付録に分かれています。
  • パート Ⅰ － 防止:脅威の回避 － お使いのシステムを保護するための最善の方法は、お使いのシステムに対するあらゆるマルウェアからのアクセスを防止することです。このパートでは、以下について説明します。
    • システムのアクセス ポイントとメモリをオーバーフロー エラーや不審なプログラムから保護する方法。
    • 検出定義、これらを使用してシステムを保護する方法、およびこれらの定義を定期的に更新することの重要性。
    • ファイル、フォルダ、およびディスクをスキャン対象から除外する方法。
    • スケジュール設定されたタスクを使用して、システムを定期的にスキャンしたり、VirusScan Enterprise によって使用されるファイルを更新したりする方法。
  • パート II － 検出:脅威の検索 － 他のファイル システムやインターネットから開かれるかコピーされたファイルは、お使いのシステムへのアクセス手段を提供する可能性があります。また、アプリケーション プログラミング インターフェース（API）の呼び出しとスクリプトは、お使いのシステムに脅威をもたらす危険性があります。これらの脅威は、VirusScan Enterprise による以下のスキャン プロセスで検出されます。
    • オンアクセス スキャン － ディスク上のファイルの読み書き時にファイルまたはマルウェアをスキャンするとともに、ブート セクタを保護して、既に実行中のプロセスのメモリをスキャンして、Cookie を検出して、不審なプログラムから保護します。
    • オンデマンド スキャン － 設定されたスケジュールに従って、または VirusScan コンソール から開始されたときに必要に応じて、システム全体をスキャンして脅威を検索します。
    • 配信時およびオンデマンドの電子メール スキャン － Microsoft Outlook および Lotus Notes の電子メールを通じて侵入するマルウェアから保護します。
    • バッファ オーバーフロー保護 － 特定のプロセスによる API 呼び出しを分析して、これらの呼び出しがメモリ バッファ内の隣接するデータを上書きしようとしていないことを確認します。
    • ScriptScan － Windows Script Host を使用するアクセスされたブラウザや他のアプリケーションから脅威を検索します。
  • パート III － 対応:脅威の処理 － VirusScan Enterprise は、脅威が検出されたときに次のいずれかのステップを実行するように設定できます。
    • その脅威へのアクセスを拒否するか、追加のアクションを実行しない。
    • その脅威を削除または駆除する。これらのどちらかのアクションが実行されると、オリジナル ファイルのコピーが隔離フォルダに格納されます。
    注意: 脅威の検出時に、VirusScan Enterprise からユーザに通知するかどうかを設定できます。
  • パート IV － 保護状況の監視、分析、および微調整 － 保護を開始したら、ePolicy Orchestrator のクエリとレポートを使用してお使いのシステムを監視する必要があります。そうすることで、システムの保護を強化するか緩和するために、セキュリティ設定を変更するという判断を下すことができます。また、VirusScan コンソール のログと SNMP（Simple Network Management Protocol）トラップを使用して、お使いのシステムを監視することもできます。
  • 付録 － VirusScan Enterprise の使用時に知っておくべきいくつかの追加機能について説明します。たとえば、VirusScan Enterprise のコマンドライン オプションや、VirusScan Enterprise を通じてリモート システムに接続する機能などです。


製品マニュアルの検索

McAfee は、製品のインストールから使用やトラブルシューティングにいたるまで、製品導入の各段階で必要な情報を提供しています。製品のリリース後は、その製品の情報は、McAfee のオンライン知識ベースに掲載されます。
  1. McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスしてください。
  2. ［Self Service］の下に表示されるメニューから、必要な種類の情報にアクセスします。
    アクセス対象 手順
    ユーザ マニュアル

    1. ［Product Documentation］をクリックします。

    2. ［Product］を選択してから、［Version］を選択します。

    3. 製品マニュアルを選択します。

    知識ベース
    • お使いの製品に関する質問に対する回答を探すには、［Search the KnowledgeBase］をクリックします。
    • 製品別およびバージョン別に一覧表示された記事を参照するには、［Browse the KnowledgeBase］をクリックします。


はじめに

McAfee® VirusScan® Enterprise 8.8 ソフトウェアのコンポーネントについて、およびこのソフトウェアの設定順序について理解することは、お使いのシステムを脅威から保護するのに役立ちます。

目次

  • VirusScan Enterprise について
  • コンポーネントおよび各コンポーネント間の動作
  • セキュリティ対策の作成の重要性
  • VirusScan コンソールとそのアクセス方法
  • 最初に行う作業


VirusScan Enterprise について

VirusScan Enterprise ソフトウェアがインストールされると同時に、お使いのシステムは脅威から保護されます。保護を強化するためには、このソフトウェアの役割、このリリースの新機能、およびその主要なコンポーネントを理解する必要があります。

VirusScan Enterprise の内容と役割

VirusScan Enterprise は、拡張性の高い保護機能、高速なパフォーマンス、およびモバイル向けのデザインを通じてユーザの環境を以下から保護します。

  • ウィルス、ワーム、およびトロイの木馬
  • アクセス ポイント違反とバッファ オーバーフロー攻撃
  • 怪しいコードとプログラム

脅威を検出すると、使用中の環境を保護するよう設定されたアクションを実行します。

このソフトウェアは、スタンドアロン製品として設定することもできますが、McAfee® ePolicy Orchestrator® ソフトウェア バージョン 4.0 以降を使用して、VirusScan Enterprise のポリシーを管理および施行して、クエリとダッシュボードを使用して動作と検出状況を追跡することもできます。

注意: 本書では、ePolicy Orchestrator 4.0、4.5、および 4.6 の使用について説明します。これらのバージョンの ePolicy Orchestrator の使用については、そのバージョンの製品マニュアルを参照してください。

新機能

本リリースには、以下の新機能が含まれています。
  • パフォーマンスが向上しました。
  • ePolicy Orchestrator 4.5 および 4.6 を使用して VirusScan Enterprise システムを管理できます。
  • レジストリを手動で編集する代わりに、新しい ScriptScan URL 除外機能を使用することで、除外の設定を行うことができます。
  • AntiSpyware Enterprise Module は、VirusScan Enterprise 8.8 ソフトウェアに完全に統合されています。
  • Outlook 2010 の電子メール スキャンをサポートしています。
  • Lotus Notes 8.0x ～ 8.5.1 の電子メール スキャンをサポートしています。


コンポーネントおよび各コンポーネント間の動作

VirusScan Enterprise の管理者とユーザは、このソフトウェアのコンポーネントと接続について理解する必要があります。次の図では、基本的な環境でのこれらのコンポーネントを示しています。

図 1. VirusScan Enterprise のコンポーネント

クライアント システム

ここに VirusScan Enterprise とオプションの McAfee Agent をインストールして設定します。
  • DAT ファイル － 検出定義ファイルは、マルウェア シグネチャとも呼ばれ、スキャン エンジンと連携して脅威を識別して、これらの脅威に対してアクションを実行します。
  • スキャン エンジン － クライアント コンピュータ上のファイル、フォルダ、およびディスクをスキャンして、これらを DAT ファイル内の情報と照らし合わせて、既知のウイルスが潜んでいないか確認します。
    注意: DAT ファイルとスキャン エンジンは、McAfee 本部へのインターネット接続を使用して、または指定されたサーバへのオプションの企業イントラネット接続を使用して、必要に応じて更新されます。
  • Artemis（不審なファイルのヒューリスティック ネットワーク チェック） － VirusScan Enterprise によって保護されているクライアント システム上で実行されている不審なプログラムや DLL を検索します。リアルタイム マルウェア防御機能は不審なプログラムを検出すると、McAfee ラボによってホストされる中央のデータベース サーバに不審なファイルのフィンガープリントを含む DNS 要求を送信します。
  • McAfee Agent（オプション） － McAfee 管理対象製品と McAfee ePolicy Orchestrator サーバとの間のセキュア通信を提供します。McAfee Agent は、イベントやプロパティの報告、ログ記録、更新、タスクのスケジュール設定、通信、ポリシーの保管などのローカル サービスも提供します。

McAfee 本部

McAfee 本部は、McAfee ラボと McAfee テクニカル サポートの拠点であり、次の VirusScan Enterprise サービスを提供します。
  • DAT アップデート － これらの DAT アップデート ファイルは、McAfee の中央データベース サーバに保管されており、AutoUpdate を使用し、VirusScan Enterprise クライアントやオプションの DAT リポジトリにコピーされ、既知の脅威に対処するための情報や、リアルタイムで発見されたばかりの既知のウイルスの新しいリストを提供します。
  • スキャン エンジン アップデート － スキャン エンジン アップデートは、中央データベース サーバに保管されており、VirusScan Enterprise のスキャン エンジンを最新状態に保つために必要に応じてダウンロードされます。
  • McAfee ラボ － この脅威ライブラリは、ウイルス、トロイの木馬、デマ、および怪しいプログラム（PUP）の脅威に関する詳細情報を提供します。たとえば、これらの発生源、システムへの感染手口、これらへの対処方法などです。Artemis 機能は不審なファイルのフィンガープリントを McAfee ラボに送信し、このラボではそのファイルが分析されて、実行すべきアクションが決定されます。

サーバ

オプションのサーバは、次のコンポーネントを使用して多数のクライアント システムをリモートで管理および更新します。
  • ePolicy Orchestrator － VirusScan Enterprise のポリシーを一元的に管理および施行し、クエリとダッシュボードを使用して動作と検出状況を追跡します。
    注意: 本書では、ePolicy Orchestrator 4.0、4.5、および 4.6 の使用について説明します。ePolicy Orchestrator については、お使いのバージョンの製品マニュアルを参照してください。
  • DAT リポジトリ － DAT アップデートを McAfee のダウンロード サイトから取得します。このリポジトリから、DAT ファイルを組織全体にわたって複製して、他のすべてのコンピュータからアクセスできるようにします。これにより、更新されたファイルを共有サイトにコピーするプロセスが自動化されるため、ネットワーク全体にわたって転送されるデータ量が最少化されます。


セキュリティ対策の作成の重要性

VirusScan Enterprise を使用して、お使いのクライアント システムをウイルス、ワーム、およびトロイの木馬ファイルから保護するには、入念に計画された対策が必要になります。この対策は、脅威の防止と検出に関する設定、脅威への対応、および継続的な分析と調整からなります。

防止 － 脅威の回避

すべてのデータ ソースを確実に保護するためのセキュリティ ニーズを定義し、使用中の環境にアクセスできるようになる前に侵入を阻止するための効果的な方法を開発します。次の機能を設定して侵入を防止します。
  • ユーザ インターフェース セキュリティ － 表示とパスワードの保護を設定して、VirusScan Enterprise ユーザ インターフェースへのアクセスを制御します。
  • アクセス保護 － アクセス保護ルールを使用して、コンピュータがファイル、レジストリ、およびポートに関して好ましくない動作をしないように保護します。
  • バッファ オーバーフロー保護 － バッファにデータを書き込むときに、不正なプログラムや脅威がバッファの境界を超えることや隣接するメモリを上書きすることを防止します。これらの攻撃目的のバッファ オーバーフローを発生させることで、お使いのコンピュータ上で任意のコードを実行可能になります。
  • 不審なプログラムの保護 - スパイウェアやアドウェアなど、不審なプログラムをコンピュータから削除します。

検出 － 脅威の検索

侵入が発生したときにその侵入を検出するための効果的な方法を開発します。次の機能を設定して脅威を検出します。
  • アップデート タスク － DAT とスキャン エンジンの自動アップデートを McAfee のダウンロード Web サイトから取得します。
  • オンアクセス スキャナ － ファイルをディスクから読み取るときやディスクに書き込むときに、あらゆるソースに潜む脅威を検出します。Cookies フォルダ内をスキャンして、不審な Cookie を探すこともできます。
  • オンデマンド スキャン タスク － 即時スキャンとスケジュールしたスキャンのタスクで潜在的脅威を検出します。これまでに駆除されなかったスパイウェア関連のレジストリ エントリや不審な Cookie を探すためにスキャンすることもできます。
  • 配信時およびオンデマンドの電子メール スキャナ － 配信時スキャンで電子メール メッセージ、添付ファイル、およびパブリック フォルダをチェックし、Microsoft Outlook 電子メール クライアント上の潜在的な脅威を検出します。Lotus Notes 電子メール クライアントの潜在的な脅威は、メッセージにアクセスするときに検出します。
  • Quarantine Manager のポリシー － 隔離の場所および隔離アイテムの保管期間を指定します。必要に応じて隔離したアイテムを復元します。

対応 － 脅威の処理

製品のログ ファイル、自動アクション、および他の通知機能を使用して、検出の処理に最適な方法を決定します。
  • アクション － 検出時にアクションを実行するように各機能を設定します。

  • ログ ファイル － 製品のログ ファイルを監視して検出したアイテムの履歴を表示します。

  • クエリおよびダッシュボード － ePolicy Orchestrator のクエリおよびダッシュボードを使用して、スキャン動作および検出状況を監視します。

調整 － 保護状況の監視、分析、および微調整

VirusScan Enterprise を初期設定した後は、設定を監視および分析することをお勧めします。これにより、システムとネットワークのパフォーマンスを高めることができるとともに、必要に応じてウイルス保護レベルを強化できます。たとえば、次の VirusScan Enterprise のツールと機能は、監視プロセス、分析プロセス、および微調整プロセスの過程で変更できます。
  • ログ ファイル（VirusScan コンソール） － 検出されたアイテムの履歴を表示できます。この情報を分析することで、保護を強化する必要があるのかどうかや、設定を変更してシステム パフォーマンスを高める必要があるのかどうかを判断できることがあります。
  • クエリおよびダッシュボード（ePolicy Orchestrator コンソール） － スキャン動作と検出状況を監視できます。この情報を分析することで、保護を強化する必要があるのかどうかや、設定を変更してシステム パフォーマンスを高める必要があるのかどうかを判断できることがあります。
  • スケジュール設定されたタスク － タスク（AutoUpdate と同様に）とスキャン時刻を変更して、これらのタスクをオフピーク時に実行することでパフォーマンスを高めることができます。
  • DAT リポジトリ － これらのソース ファイルを移動してアップデートを必要とするクライアントに近づけることで、企業のインターネットやイントラネット上のネットワーク トラフィックを低減できます。
  • スキャン ポリシーの変更 － ログ ファイルやクエリの分析結果に応じて、パフォーマンスを高めたりウイルス保護を強化したりできます。たとえば、除外の設定、どのような場合に危険度高または危険度低のプロファイル スキャンを使用するのかの設定、およびどのような場合に書き込み時のスキャンを無効にするのかの設定は、すべてパフォーマンスを高めることができます。
    警告:
    ［ディスクからの読み取り時］スキャンを有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。


VirusScan コンソールとそのアクセス方法

VirusScan コンソールは、スタンドアロン バージョンの当プログラムの動作に対するインターフェースです。VirusScan コンソールを使用して、当製品を設定、監視、および更新できます。
注意: ここに記載された情報は、スタンドアロン バージョンの当製品にのみ適用され、管理対象 ePolicy Orchestrator バージョンには適用されません。


VirusScan コンソールとその動作

VirusScan Enterprise の役割とコンポーネントについて理解したら、その機能にアクセスする方法を理解する必要があります。VirusScan Enterprise 8.8 コンソールを開くには、次のいずれかの方法を使用します。
  • ［スタート］メニューをクリックし、［プログラム ］、［McAfee］、［VirusScan コンソール］の順に選択します。
  • システム トレイで VirusScan Enterprise シールド アイコンを右クリックし、［VirusScan コンソール］ を選択します。

メニュー バー

以下のメニュー項目を使用して、タスクを作成したり、プロパティを設定したり、詳細情報にアクセスしたりします。
  • タスク － スキャンの実行や DAT ファイルのアップデートなど、タスクの作成と設定を行います。
  • 編集 － 選択したタスクのコピー、貼り付け、名前の変更を行います。
  • 表示 － ツールバーやステータス バーを表示したり、表示内容を更新したりします。
  • ツール － ユーザのためのインターフェース オプションの設定、ユーザ インターフェース セキュリティのロック/ロック解除、アラートの設定、イベント ビューアへのアクセス、リモート コンソールへの接続 (管理者権限がある場合)、リポジトリ リストのインポート/編集、DAT ファイルのロールバックを行います。
  • ヘルプ － オンライン ヘルプ トピック、McAfee ラボ Web サイトの脅威ライブラリ、サンプル送信の Web サイト、テクニカル サポートの Web サイトにアクセスします。インストールした製品の修復を行うこともできます。また、［バージョン情報］ ダイアログ ボックスには、著作権情報、インストールされている製品のバージョン、ライセンス タイプ、定義ファイル、スキャン エンジン、外部ドライバ、パッチの情報が表示されます。
注意: メニューの各アイテムには、関連付けられたショートカット キーがあります。一部のオペレーティング システムでは、これらのショートカット キーを使用するには、F10 キーまたは Alt キーを使用してメニューにアクセスする必要があります。

ツールバー

アイコンをクリックして、以下のよく使用されるコマンドを実行できます。
  • 選択したタスクのプロパティを表示します。
  • 選択したタスクを開始します。
  • 選択したタスクを停止します。
  • 選択したタスクをコピーします。
  • 選択したタスクを貼り付けます。
  • 選択したタスクを削除します。
  • アラートのプロパティを設定します。
  • イベント ビューアを起動します。
  • McAfee ラボの Web サイトにある情報ライブラリにアクセスします。
  • 管理者権限がある場合、リモート コンピュータに接続します。
  • 新しいオンデマンド スキャンを作成します。

タスク リスト

デフォルトのタスクと、新規作成したタスクが表示されます。各タスクのステータスと前回の結果も表示されます。

ステータス バー

現在の動作のステータスが表示されます。


右クリック機能の使用

右クリック機能を使用すると、新しいタスクの作成、タスク統計およびログの表示、タスク プロパティ ページの表示、特定ファイルまたはフォルダのスキャン、またはタスクの即時アップデートなど、使用頻度の高いアクションにすばやくアクセスすることができます。

機能の説明

場所 | 説明 | 例
コンソール VirusScan コンソールを右クリックすると、右クリック機能が表示されます。タスクをタスク リストで選択しているかどうか、およびどのタスクを選択するかにより、機能は異なります。
  • コンソールでタスクを右クリックしてプロパティを表示します。どのタスクを選択するかにより、タスクの開始、停止、有効無効の切り替え、および統計や動作ログの表示ができます。タスクの名前の変更やタスクの削除ができる場合もあります。
  • 新しいスキャンまたはアップデート タスクを作成するには、コンソールの空白領域を右クリックします。
Windows エクスプローラ 選択したファイルまたはフォルダを右クリックすると、［脅威のスキャン］を直ちに実行できます。次のスキャン アクションを選択できます。
  • 駆除 — 検出されたアイテムを報告し、駆除します。
  • 続行 — 検出内容を報告し、スキャンを続行します。

脅威にさらされている疑いがあるファイルやフォルダに対して即時スキャンを実行します。

スキャンを開始すると、すべてのスキャン設定が有効な状態で、オンデマンド スキャナが直接呼び出されます。アクション オプションを選択します。それ以外のスキャン設定はカスタマイズできません。

システム トレイ | VirusScan Enterprise アイコンの右クリックの詳細については、「システム トレイ アイコンとその動作」を参照してください。


システム トレイ アイコンとその動作

VirusScan Enterprise をインストールすると、次のいずれかのアイコンが Windows システム トレイに表示されます（この機能をインストール プロセス時に設定した場合）。

シールド アイコン内の「M」

McAfee Agent バージョン 4.5 以降を使用している ePolicy Orchestrator 管理対象システムで表示されます。このアイコンでは以下が表示されます。
  • ステータス － このアイコンは、アクセス保護のトリガ アラートを示すためや、McTray バージョン 2.x 以降（McAfee Agent 4.5 以降を使用）を使用している ePolicy Orchestrator 管理対象クライアント上でオンアクセス スキャンが無効化されているかどうかを示すために変化することはありません。ステータスの変化はツール ヒントとして表示されます。
  • ツール ヒント － アイコンのツール ヒントには以下が含まれます。
    • McAfee ステータス:OK － 正常です。オプションは以下のように表示されます。
      • セキュリティ ステータスの表示 － チェック マークが表示されます。
      • クイック設定、オンアクセス ウイルス スキャン － オン － チェック マークが表示されます。
    • McAfee ステータス:問題が検出されました － オンアクセス スキャンが無効。オプションは以下のように表示されます。
      • セキュリティ ステータスの表示 － 感嘆符が表示されます。
        注意: ［セキュリティ ステータスの表示］をクリックすると、［McAfee セキュリティ ステータス］ダイアログ ボックスが開いて、［ステータス］列に［問題 － オンアクセス スキャンが無効］と表示されます。
      • クイック設定、オンアクセス ウイルス スキャン － オフ － チェック マークは表示されません。
    • McAfee ステータス:問題が検出されました － アクセス保護イベントがトリガされました。オプションは以下のように表示されます。
      • セキュリティ ステータスの表示 － 感嘆符が表示されます。
        注意: ［セキュリティ ステータスの表示］をクリックすると、［McAfee セキュリティ ステータス］ダイアログ ボックスが開いて、［ステータス］列に［問題 － アクセス保護のログを参照してください］と表示されます。
      • クイック設定、オンアクセス ウイルス スキャン － オン － チェック マークが表示されます。
  • メニュー オプション － 右クリック メニュー オプションには以下が含まれます。
    • セキュリティの更新 － DAT ファイルと他の変更内容を更新します。
    • クイック設定 － 以下が表示されます。
      • オンアクセス スキャンのプロパティ － オンアクセス スキャナのプロパティを表示します。
      • オンアクセス スキャンのオンまたはオフ － オンアクセス スキャナのオンとオフを切り替えます。
      • オンアクセス スキャンのプロパティ － オンアクセス スキャナのプロパティを表示します。
      • オンアクセス スキャン メッセージ － オンアクセス スキャンの統計やメッセージを表示します。
      • オンアクセス保護ログ ファイルを開く － ログ ファイルを開きます。

    • 管理機能、VirusScan Enterprise － VirusScan コンソール を開きます。
    • コンピュータのスキャン、脅威 － 即時スキャンを開始します。
    • セキュリティ ステータスの表示 － ［McAfee セキュリティ ステータス］ダイアログ ボックスを開きます。
    • McAfee Agent ステータス モニタ － ［McAfee セキュリティ ステータス モニタ］ダイアログ ボックスを開きます。
    • バージョン情報 － ［バージョン情報］ダイアログ ボックスを開きます。

ボックス内の「M」

McTray 1.0 を使用しているスタンドアロン システム上で表示されるとともに、McTray 1.0 を使用する McAfee Agent バージョン 4.0 を使用している ePolicy Orchestrator 管理対象システム上で表示されます。このアイコンでは以下が表示されます。
  • ステータス － 以下が表示されます。
    • ボックス内の「M」 － 正常なステータスです。
    • ボックス内の「M」と感嘆符 － アクセス保護違反イベントがトリガされたか、オンアクセス スキャンが無効化されています。右クリック メニュー オプションは以下のように表示されます。
      • シールド内の「V」と斜線付きの丸印 － オンアクセス スキャンが無効化されていることを示します。
      • 赤い枠で囲まれたシールド内の「V」 － オンアクセス スキャンが有効化されていることを示しますが、アクセス保護ログ ファイルを参照してください。

  • ツール ヒント － 「McAfee」と表示されます。
  • メニュー オプション － 右クリック メニュー オプションには以下が含まれます。
    • VirusScan コンソール － VirusScan コンソール を開きます。
    • オンアクセス スキャナを無効または有効にする － オンアクセス スキャナのオンとオフを切り替えます。
    • オンアクセス スキャンのプロパティ － オンアクセス スキャナのプロパティを表示します。
    • オンアクセス スキャン統計 － オンアクセス スキャンの統計を表示します。
    • オンアクセス スキャン メッセージ － オンアクセス スキャンの統計やメッセージを表示します。
    • オンデマンド スキャン － 1 度だけ実行する設定可能なオンデマンド スキャンを作成します。
    • 今すぐアップデート － 即時アップデート タスクを実行します。
    • VirusScan Enterprise のバージョン情報 － ［バージョン情報］ダイアログ ボックスを開きます。

シールド アイコン内の「V」

McTray 1.0 がインストールされていないスタンドアロン システム上で表示されます。このアイコンでは以下が表示されます。
  • ステータス － 以下が表示されます。
    • シールド内の「V」 － 正常です。
    • シールド内の「V」と斜線付きの丸印 － オンアクセス スキャンが無効化されていることを示します。
    • 赤い枠で囲まれたシールド内の「V」 － オンアクセス スキャンが有効化されていることを示しますが、アクセス保護ログ ファイルを参照してください。
  • ツール ヒント － ツール ヒントには以下が含まれます。
    • シールド内の「V」 － McAfee OAS が有効化されています。正常です。
    • シールド内の「V」と斜線付きの丸印 － McAfee OAS が無効化されています。
    • 赤い枠で囲まれたシールド内の「V」 － McAfee OAS が有効化されています。アクセス保護ログを参照してください。

  • メニュー オプション － 右クリック メニュー オプションには以下が含まれます。
    • セキュリティの更新 － DAT ファイルと他の変更内容を更新します。
    • クイック設定 － 以下が表示されます。
      • オンアクセス スキャンのプロパティ － オンアクセス スキャナのプロパティを表示します。
      • オンアクセス スキャンのオンまたはオフ － オンアクセス スキャナのオンとオフを切り替えます。
      • オンアクセス スキャン メッセージ － オンアクセス スキャンの統計やメッセージを表示します。
      • オンアクセス保護ログ ファイルを開く － ログ ファイルを開きます。

    • 管理機能、VirusScan Enterprise － VirusScan コンソール を開きます。
    • コンピュータのスキャン、脅威 － 即時スキャンを開始します。
    • セキュリティ ステータスの表示 － ［McAfee セキュリティ ステータス］ダイアログ ボックスを開きます。
    • McAfee Agent ステータス モニタ － ［McAfee セキュリティ ステータス モニタ］ダイアログ ボックスを開きます。
    • バージョン情報 － ［バージョン情報］ダイアログ ボックスを開きます。


最初に行う作業

インストールされた VirusScan Enterprise ソフトウェアは、この製品に付属している DAT ファイルを使用して、ユーザの環境の全般的なセキュリティを確保します。McAfee では、最新の DAT ファイルを入手し、各自の要件を満たすように設定をカスタマイズしてから、クライアント システムにこの製品を配備することをお勧めします。

製品のインストールが完了したら、直ちに次の作業を行ってください。

  1. ユーザ インターフェース セキュリティの設定。表示とパスワードのオプションを設定して、特定のコンポーネントまたは VirusScan Enterprise ユーザ インターフェース全体にユーザがアクセスできないようにします。詳細については、「ユーザ インターフェースへのアクセスの制御」を参照してください。
  2. DAT ファイルの更新。［今すぐアップデート］タスクを実行して、最新の DAT ファイルが確実に使用されるようにします。詳細については、「検出定義のアップデート」を参照してください。
  3. 侵入の防止。以下の機能を設定して、潜在的な脅威がシステムにアクセスすることを防ぎます。
    • アクセス保護。コンピュータに望ましくない変更が加えられないようアクセス保護ルールを設定し、McAfee プロセスを終了させないためのオプションを有効にします。詳細については、「システムのアクセス ポイントの保護」を参照してください。
    • バッファ オーバーフロー保護。バッファ オーバフロー検出を有効にし、除外対象を指定します。詳細については、「バッファ オーバーフロー攻撃のブロック」を参照してください。
    • 不審なプログラム ポリシー。不審なプログラムを検出するためにオンアクセス スキャナ、オンデマンド スキャナ、および電子メール スキャナで使用するポリシーを設定します。事前に定義されているリストから、検出する不審なプログラムのカテゴリを選択してから、検出または除外する追加のプログラムを指定します。詳細については、「不審なプログラムの制限」を参照してください。
  4. 侵入の検知。システムに対する潜在的な脅威を検出し、検出時にユーザに通知してアクションを実行するように以下の機能を設定します。
    • AutoUpdate。最新の DAT ファイル、スキャン エンジン、および製品アップグレードを取得するためのアップデート タスクを設定します。詳細については、「検出定義のアップデート」を参照してください。
    • オンアクセス スキャナ。ユーザの環境内で潜在的な脅威へのアクセスが発生したときにその脅威を検出し、その脅威に対してアクションを実行するようにスキャナを設定します。不審なプログラムのスキャンを有効にして、Cookies フォルダ内で Cookie を検出するためにスキャンします。詳細については、「アイテムのオンアクセス スキャン」を参照してください。
    • オンデマンド スキャン。環境内で潜在的な脅威を検出し、アクションを実行するようにスキャン タスクを設定します。不審なプログラムのスキャンを有効にして、これまでに駆除されなかった怪しいスパイウェア関連のレジストリ エントリと Cookies フォルダ内の Cookie を検出するためにスキャンします。詳細については、「アイテムのオンデマンド スキャン」を参照してください。
    • 電子メール スキャナ。Microsoft Outlook および Lotus Notes 電子メール クライアントの配信時スキャン／オンデマンド スキャンを設定します。不審なプログラムのスキャンを有効にします。詳細については、「配信時とオンデマンドの電子メール スキャン」を参照してください。
  5. アラート送信と脅威の隔離。脅威が検出されたときのユーザへの通知と、検疫アイテムの管理について設定します。
    • アラートおよび通知。検出の通知およびアラートをいつどのような方法で受信するかを設定します。詳細については、「アラートおよび通知の設定」を参照してください。
    • Quarantine Manager のポリシー。隔離フォルダの場所、および隔離されたアイテムが自動的に削除されるまでの隔離日数を設定します。詳細については、「隔離アイテム」を参照してください。
関連概念
隔離アイテム
関連タスク
配信時とオンデマンドの電子メール スキャン
関連情報
ユーザ インターフェースへのアクセスの制御
検出定義のアップデート
システムのアクセス ポイントの保護
バッファ オーバーフロー攻撃のブロック
不審なプログラムの制限
アイテムのオンアクセス スキャン
アイテムのオンデマンド スキャン
アラートおよび通知の設定


パート Ⅰ － 防止:脅威の回避

防止は、保護戦略の最初のステップであり、お使いのシステムが脅威からアクセスされないようにすることです。

目次

  • アクセス保護
  • システムのアクセス ポイントの保護
  • バッファ オーバーフロー攻撃のブロック
  • 不審なプログラムの制限
  • 検出定義のアップデート
  • スキャン アイテムの除外
  • スケジュール設定されたタスクの使用


アクセス保護

脅威からクライアント システムへのアクセスを防止することは、マルウェアに対する防御の最前線です。VirusScan Enterprise のアクセス保護機能は、要求されているアクションを一連の設定済みルールと対比します。各ルールは、発生したアクセス違反をブロックしてレポートするように設定することも、これらのどちらかの動作のみを行うように設定することもできます。

アクセス保護機能は、指定したポート、ファイル、共有、レジストリ キー、およびレジストリ値へのアクセスを制限することで、コンピュータに対する望ましくない変更を阻止します。また、ユーザによって McAfee プロセスが終了されないように保護します。この保護機能は、ウイルスの発生前と発生中のどちらでも、非常に重要です。

この機能では、事前定義済みのルールとユーザ定義のルールを使用して、アクセスを許可するアイテムおよび許可しないアイテムを指定します。各ルールは、発生したアクセス違反をブロックしてレポートするように設定することも、これらのどちらかの動作のみを行うように設定することもできます。事前定義済みのルールとカテゴリは、McAfee アップデート サイトから更新できます。

注意: ポート、ファイル、共有アイテム、およびレジストリのキーと値へのアクセス試行を検知するには、アクセス違反を検知するオンアクセス スキャナを有効にする必要があります。

脅威によるアクセス方法

脅威がシステムにアクセスする代表的な方法は次のとおりです。
  • マクロ － ワード プロセッシング文書やスプレッドシート アプリケーションに組み込まれています。
  • 実行可能ファイル － 安全なように見えるプログラムにも、正規のプログラムに加えてウイルスが含まれている可能性があります。一般的なファイル拡張子の例としては、.EXE、.COM、.VBS、.BAT、.HLP、.DLL などが挙げられます。
  • 電子メール － 添付ファイル付きの電子メール メッセージに組み込まれたジョーク、ゲーム、およびイメージ。
  • スクリプト － Web ページや電子メールと関連付けられた ActiveX や JavaScript などのスクリプトは、実行が許可されている場合は、ウイルスを含むことができます。
  • インターネット リレー チャット（IRC）メッセージ － これらのメッセージとともに送信されるファイルには、メッセージの一部としてマルウェアを簡単に組み込むことができます。たとえば、自動開始プロセスはワームやトロイの木馬を含んでいる可能性があります。
  • ブラウザやアプリケーションのヘルプ ファイル － これらのヘルプ ファイルをダウンロードすると、これらのファイルに埋め込まれたウイルスや実行可能ファイルによってシステムが攻撃される危険性があります。
  • これらすべての組み合わせ － 巧妙なマルウェアの作成者は、これらすべての手段を組み合わせて、マルウェアを別のマルウェアに埋め込んで、コンピュータにアクセスしようとします。

目次

関連概念
アクセス脅威の阻止方法
関連情報
ユーザ インターフェースへのアクセスの制御


アクセス脅威の阻止方法

アクセス保護機能の設定を有効化または変更することで、スパイウェア対策保護、ウイルス対策保護、共通保護、仮想マシン保護を設定して、独自の保護ルールを定義できます。以下では、VirusScan Enterprise がアクセス保護を実現するために使用する基本的なプロセスを示しています。

脅威の発生時に実行されるステップ

  1. ユーザまたはプロセスが何らかのアクションを実行しようとします。
  2. そのアクションは、定義済みルールに従ってアクセス保護によって検査されます。
  3. ルールに違反している場合は、ユーザまたはプロセスによって要求されたアクションは、設定されたルール内の情報を使用して管理されます。たとえば、そのアクションによって何も発生しないか、そのアクションがブロックされるか、またはそのアクションがブロックされた上でレポートが送信されます。
  4. アクセス保護のログ ファイルが更新されて、ePolicy Orchestrator のグローバル管理者に対してイベントが生成されます。

アクセス脅威の例

  1. ユーザが MyProgram.exe というプログラムをインターネットからダウンロードします。
    注意: この例では、MyProgram.exe はマルウェアではありません。
  2. ユーザはこのプログラムを起動して、正常に起動されたように見えます。
  3. 次に MyProgram.exe は AnnoyMe.exe という子プロセスを起動して、このプロセスはオペレーティング システムに変更を加えて、このプロセスがオペレーティング システムの起動時に常にロードされるようにします。
  4. アクセス保護はこの要求を処理して、ブロックおよびレポートするように設定された既存のルールと照らし合わせます。
  5. AnnoyMe.exe は、オペレーティング システムに変更を加えようとしたときにアクセスを拒否され、アクセス保護はこの変更試行の詳細をログに記録して、 ePolicy Orchestrator のグローバル管理者に対してアラートを生成します。

ログ レポートおよび生成されたアラート

次にアクセス保護のログ エントリの例を示します。

2/10/2010 11:00AM アクセス保護によってブロック TestDomain\TestUser C:\Users\TestUser\Desktop\AnnoyMe.exe \REGISTRY\MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion\Run\ プログラムの自動実行登録を防止する

次の表では、上記のアクセス保護ログ エントリ内のデータについて説明しています。
ログ エントリ | 説明
2/10/2010 | 日付
11:00AM | 時刻
アクセス保護ルールによってブロック | 実行されたアクション
TestDomain\TestUser | 資格情報
C:\Users\TestUser\Desktop\AnnoyMe.exe | ルールに違反したプロセスの名前
\REGISTRY\MACHINE\SOFTWARE\Microsoft... | プロセスがアクセスしようとした場所
プログラムの自動実行登録を防止する | トリガされたアクセス保護ルール

同様の情報を ePolicy Orchestrator のクエリを使用して取得できます。詳細については、「クエリおよびダッシュボードへのアクセス」を参照してください。

関連情報
クエリおよびダッシュボードへのアクセス


ユーザ インターフェースへのアクセスの制御

クライアント コンピュータのインターフェースのセキュリティを設定することは、環境を保護するために重要な点です。

管理者は、以下のことを実行できます。
  • ユーザによる VirusScan Enterprise インターフェースへのアクセスを制御します。
  • パスワードを設定して、選択した機能にユーザがアクセスしたり変更を加えたりすることを防止します。
  • 必要に応じてユーザ インターフェースをロックまたはロック解除します。

目次

関連概念
パスワードの設定がユーザに与える影響
関連タスク
ユーザ インターフェース セキュリティの設定


パスワードの設定がユーザに与える影響

悪意のあるユーザをブロックするためのユーザ インターフェース パスワードを設定します。

クライアント コンピュータのユーザ インターフェースをパスワードで保護すると、次のユーザが影響を受けます。

  • 管理者以外のユーザ － 管理者権限のないユーザ。管理者以外のユーザは、 すべての VirusScan Enterprise アプリケーションを読み取り専用モードで実行します。設定パラメータの表示、保存したスキャンの実行、および任意のときすぐにスキャンやアップデートを実行することはできます。設定パラメータの変更、保存したスキャンの作成、削除または変更、あるいはタスクのアップデートはできません。
  • 管理者 － 管理者権限のあるユーザ。保護されたタブおよびコントロールを読み取り/書き込みモードで使用するために、管理者はパスワードを入力する必要があります。保護されたアイテムに対してパスワードを指定しない場合、そのアイテムは読み取り専用モードで表示されます。


ユーザ インターフェース セキュリティの設定

全般オプション ポリシー ユーザ インターフェース プロパティを使用して、ユーザが使用できる表示オプションとパスワード オプションを設定します。
警告:
これらのプロパティに変更を加える前に、セキュリティへの影響を慎重に検討してください。これらのオプションを使用すると、ユーザが各自のセキュリティ設定に変更を加えることを制限または許可できる一方で、システムがさまざまなマルウェアの攻撃に対して無防備になる可能性があります。

以下のユーザ インターフェース コンソールを使用して全般オプション ポリシー ユーザ インターフェース プロパティを設定します。


ePolicy Orchestrator 4.5 または 4.6

全般オプション ポリシー ユーザ インターフェース プロパティを設定します。

タスク

オプションの定義については、各タブで［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［表示オプション］タブで、ユーザがリモート システムに接続できる場合にユーザに表示される VirusScan Enterprise システム トレイ アイコンを指定して、ユーザの言語オプションを設定します。
  5. ［パスワード オプション］タブで、ユーザが正しいパスワードを使用して変更できる VirusScan Enterprise のタスクとユーザ インターフェース オプションを指定します。


ePolicy Orchestrator 4.0

全般オプション ポリシー ユーザ インターフェース プロパティを設定します。

タスク

オプションの定義については、各タブで［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［表示オプション］タブで、ユーザがリモート システムに接続できる場合にユーザに表示される VirusScan Enterprise システム トレイ アイコンを指定して、ユーザの言語オプションを設定します。
  5. ［パスワード オプション］タブで、ユーザが正しいパスワードを使用して変更できる VirusScan Enterprise のタスクとユーザ インターフェース オプションを指定します。


VirusScan コンソール

全般オプション ユーザ インターフェース プロパティを設定します。

タスク

オプションの定義については、各タブで［ヘルプ］をクリックしてください。

  1. ［ツール］、［全般オプション］の順にクリックして、［全般オプションの設定］ダイアログ ボックスを開きます。
  2. ［表示オプション］タブで、ユーザがリモート システムに接続できる場合にユーザに表示される VirusScan Enterprise システム トレイ アイコンを指定して、ユーザの言語オプションを設定します。
  3. ［パスワード オプション］タブで、ユーザが正しいパスワードを使用して変更できる VirusScan Enterprise のタスクとユーザ インターフェース オプションを指定します。


システムのアクセス ポイントの保護

アクセス保護機能は、指定したポート、ファイル、共有、レジストリ キー、およびレジストリ値へのアクセスを制限することで、コンピュータに対する望ましくない変更を阻止します。また、ユーザによって McAfee プロセスが終了されないように保護します。この保護機能は、ウイルスの発生前と発生中のどちらでも、非常に重要です。

この機能では、定義済みのルールとカテゴリおよびユーザ定義ルールを使用して、アクセスを許可するアイテムおよび許可しないアイテムを指定します。各ルールは、アクセス ポイント違反の発生時にその違反をブロックしたりレポートしたりするように設定できます。定義済みのルールとカテゴリは、McAfee アップデート サイトから内容を更新する必要があります。

目次

関連概念
アクセス ポイント違反と VirusScan Enterprise の対応
関連タスク
アクセス保護の設定
関連参照
アクセス保護ルールを定義する方法
ユーザ定義ルールの種類


アクセス保護ルールを定義する方法

ルールのタイプと、保護のレベルは次のとおりです。

ルール タイプの説明

ルール タイプ 説明
ウイルス対策

これらの設定済みルールは、マルウェアの脅威による一般的な動作からコンピュータを保護します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

次に、これらのルールの例を 2 つ示します。

  • 重要なプロセスの無効化または変更、実行可能ファイルのリモート作成または変更、実行可能ファイルのハイジャック、Windows プロセスのなりすまし、および大量メール送信ワームによるメール送信を防止します。
  • パスワードと E-mail アドレスが盗難されないように電話帳ファイルを保護します。

これらの保護レベルはウイルス対策ルールに適用されます。

  • 標準の保護
  • 最大の保護
  • アウトブレーク コントロール
共通

これらの設定済みルールは、使用頻度の高いファイルや設定の変更を防止します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

次に、これらのルールの例を 3 つ示します。

  • McAfee のファイルと設定の変更を防止します。
  • Mozilla と Firefox のファイルと設定、Internet Explorer の設定、およびネットワーク設定を保護します。
  • ブラウザ ヘルパー オブジェクトのインストール、および Temp フォルダからのプログラムの自動実行を防止します。

これらの保護レベルは共通ルールに適用されます。

  • 標準の保護
  • 最大の保護
仮想マシン保護

設定済みのルールにより VMWare プロセスの終了と VMWare ファイルの変更を防止します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

ルールの例は次のとおりです。
  • VMWare プロセスの終了を防止する。
  • VMWare ワークステーション、サーバ、または仮想マシンのファイルの変更を防止する。
ユーザ定義

これらのカスタム ルールは、ウイルス対策および共通ルールによって提供される保護を補完します。

スパイウェア対策

ルールの例は次のとおりです。
  • Internet Explorer のお気に入りと設定の操作を防止する。
  • Temp フォルダからのプログラム実行とスクリプト実行を防止する。

保護レベルの説明

保護レベル | 説明
標準 | いくつかの重要な設定やファイルが変更されないよう保護する、ウイルス対策および共通のルール。ただし通常は、正当なソフトウェアのインストールと実行は許可します。
最大 | 最も重要な設定とファイルが変更されないよう保護する、ウイルス対策および共通のルール。このレベルに設定すると保護は標準よりも強化されますが、正当なソフトウェアのインストールができなくなる可能性もあります。ソフトウェアをインストールできない場合、まずアクセス保護機能を無効にしてからインストールを行い、インストール後に再びこの機能を有効にすることをお勧めします。
アウトブレーク コントロール | DAT ファイルがリリースされるまで、破壊的なコードによるコンピュータへのアクセスをブロックするウイルス対策ルール。これらのルールは、アウトブレーク時に共有へのアクセスをブロックするよう事前に設定されています。


アクセス ポイント違反と VirusScan Enterprise の対応

アクセス違反が発生するのは、お使いのコンピュータの制限されたコンポーネントが制限されたユーザやプロセスによって開始、停止、またはアクセスされようとしたときです。

アクセス ポイント違反が発生した場合、次の処理が行われます。

  • 違反を検出したルールに［レポート］オプションを選択していた場合、情報がログ ファイルに記録されます。
  • [アラートのプロパティ] を設定すると、イベントはローカルのイベント ログおよび SNMP に記録されます。
  • イベントが Alert Manager および ePolicy Orchestrator に報告されます（これらの製品がそのように設定されている場合）。
  • ルールに対する［ブロック］アクションと［レポート］アクションによって、ルールで違反が検出されたときの処理が決定されます。
  • スタンドアロン クライアント システムでは、システム トレイ アイコンの周囲に赤い枠が表示され、リセットしなければ 30 分間表示されます。
    注意: アイコンをリセットするには、システム トレイ アイコンから [アクセス保護ログ ファイル] を開きます。その他の方法でログ ファイルを開くと、アイコンは通常の状態にリセットされません。


ユーザ定義ルールの種類

新しいユーザ定義のアクセス保護ルールを設定する際は、ポートのブロック ルール、ファイルとフォルダのブロック ルール、およびレジストリのブロック ルールを作成できます。

次の表では、これらのルールについて説明しています。

ルールの説明

ルール | 説明
ポートのブロック ルール | 特定のポートまたはある範囲のポートで着信または発信のネットワーク トラフィックをブロックします。 注意: ポートをブロックすると、TCP (Transmission Control Protocol) アクセスと UDP (User Datagram Protocol) アクセスがブロックされます。 注意: ポートをブロックすると、そのポートまたはその範囲のポートを使用しているすべてのプロトコルはブロックされます。たとえば、TCP（Transmission Control Protocol）アクセスと UDP（User Datagram Protocol）アクセスがブロックされます。
ファイルおよびフォルダのブロック ルール | ファイルとフォルダへの書き込みアクセス、ファイルの実行、およびファイルの新規作成と削除がブロックされます。 注意: ファイルまたはフォルダへのアクセス制限は、管理者により解除されるまで継続します。これは侵入防止に役立ち、アウトブレーク時に侵入が拡散するのを阻止します。
レジストリのブロック ルール | 書き込み、作成、または削除のアクションをブロックすることにより、レジストリのキーや値を保護します。


アクセス保護の設定

［アクセス保護ポリシー］を使用して、お使いのシステムのアクセス ポイントを保護し、McAfee のプロセスが終了されることを防止します。
警告:
アクセス保護を有効にせず、McAfee のサービスが停止することを防止しない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
次の 2 種類のアクセス保護ルールを設定できます。
  • 事前定義済みルール － 以下を可能にします。
    • いずれかのユーザ インターフェース コンソールでアクセス保護ルール カテゴリを開く。
    • ルール違反が発生した場合に実行するブロックとレポートのアクションを選択する。
  • ユーザ定義ルール － 以下を可能にします。
    • いずれかのユーザ インターフェース コンソールでユーザ定義ルール カテゴリを作成する。
    • ルールによって施行されるブロックの種類として、ポートのブロック、ファイルとフォルダのブロック、およびレジストリのブロックの中から選択する。
    • ルールの詳細を設定する。
    • ルールを保存して、後で必要に応じて変更する。

タスク

関連タスク
事前定義済みルールの設定
ユーザ定義ルールの設定
ユーザ定義ルールの削除
関連参照
ポートのブロック ルール オプション
ファイルとフォルダのブロック ルール オプション
レジストリのブロック ルール オプション
特定のプロセスを組み入れるか除外するオプション


事前定義済みルールの設定

事前定義済みルールを使用して、お使いのコンピュータを望ましくない変更から保護します。これらのルールは有効化と編集はできますが、削除はできません。

事前定義済みのアクセス保護ルールは次のとおりです。
  • スパイウェア対策標準保護
  • スパイウェア対策最大保護
  • ウイルス対策標準保護
  • ウイルス対策最大保護
  • ウイルス対策アウトブレーク コントロール
  • 一般標準プロテクト
  • 一般最大プロテクト
  • 仮想マシン保護

これらの事前定義済みアクセス保護ルールの詳細については、「アクセス保護ルールを定義する方法」を参照してください。

次のいずれかのユーザ インターフェース コンソールを使用して、事前定義済みのアクセス保護ルールを設定します。


ePolicy Orchestrator 4.5 または 4.6

アクセス保護ポリシーで、事前定義済みアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［アクセス保護ポリシー］ページで、［アクセス保護］タブをクリックしてアクセス保護ルールを表示します。
  5. 左側のペインでいずれかの事前定義済みルール カテゴリを選択してから、右側のペインで特定のルールを選択します。
  6. ［ブロック］オプションと［レポート］オプションのいずれかまたは両方を設定します。
  7. [編集] をクリックして、ルールの詳細を設定します。


ePolicy Orchestrator 4.0

アクセス保護ポリシーで、事前定義済みアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［アクセス保護ポリシー］ページで、［アクセス保護］タブをクリックしてアクセス保護ルールを表示します。
  5. 左側のペインでいずれかの事前定義済みルール カテゴリを選択してから、右側のペインで特定のルールを選択します。
  6. ［ブロック］オプションと［レポート］オプションのいずれかまたは両方を設定します。
  7. [編集] をクリックして、ルールの詳細を設定します。


VirusScan コンソール

アクセス保護のプロパティから、事前定義済みアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［アクセス保護］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. ［アクセス保護ポリシー］ダイアログ ボックスで、［アクセス保護］タブをクリックしてアクセス保護ルールを表示します。
  3. 左側のペインでいずれかの事前定義済みルール カテゴリを選択してから、右側のペインで特定のルールを選択します。
  4. ［ブロック］オプションと［レポート］オプションのいずれかまたは両方を設定します。
  5. [編集] をクリックして、ルールの詳細を設定します。


ユーザ定義ルールの設定

ユーザ定義ルールを作成および編集することで、事前定義済みルールによって実現される保護を補完します。

事前定義済みアクセス保護ルールの詳細については、「アクセス保護ルールを定義する方法」を参照してください。

次のいずれかのユーザ インターフェース コンソールを使用して、ユーザ定義のアクセス保護ルールを作成および編集します。


ePolicy Orchestrator 4.5 または 4.6

アクセス保護ポリシーで、ユーザ定義のアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 左側のペインで［ユーザ定義ルール］カテゴリを選択してから、［新規］をクリックして［新しいルール タイプの選択］ダイアログ ボックスを開きます。
  5. ルール タイプを選択して、［OK］をクリックします。の詳細については、「ユーザ定義ルールの種類」を参照してください。 表示されるアクセス ルール ダイアログ ボックスは、選択したルール タイプに応じて異なります。
  6. 次のアクセス ルール情報を設定します。
    • ネットワーク ポートのアクセス保護ルール － 「ポートのブロック ルール オプション」でオプションの表を参照してください。
    • ファイル/フォルダのアクセス保護ルール － 「ファイルとフォルダのブロック ルール オプション」でオプションの表を参照してください。
    • レジストリのアクセス保護ルール － 「レジストリのブロック ルール オプション」でオプションの表を参照してください。
    注意: 組み入れるか除外するプロセスを設定するには、 「特定のプロセスを組み入れるか除外するオプション」を参照してください。
  7. [OK] をクリックします。 新しいユーザ定義ルールが右側のペインの［ブロック/ルール/レポート］に表示されます。新しいルールを変更するには、そのルールを選択して［編集］をクリックします。


ePolicy Orchestrator 4.0

アクセス保護ポリシーで、ユーザ定義のアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 左側のペインで［ユーザ定義ルール］カテゴリを選択してから、［新規］をクリックして［新しいルール タイプの選択］ダイアログ ボックスを開きます。
  5. ルール タイプを選択して、［OK］をクリックします。の詳細については、「ユーザ定義ルールの種類」を参照してください。 表示されるアクセス ルール ダイアログ ボックスは、選択したルール タイプに応じて異なります。
  6. 次のアクセス ルール情報を設定します。
    • ネットワーク ポートのアクセス保護ルール － 「ポートのブロック ルール オプション」でオプションの表を参照してください。
    • ファイル/フォルダのアクセス保護ルール － 「ファイルとフォルダのブロック ルール オプション」でオプションの表を参照してください。
    • レジストリのアクセス保護ルール － 「レジストリのブロック ルール オプション」でオプションの表を参照してください。
    注意: 組み入れるか除外するプロセスを設定するには、 「特定のプロセスを組み入れるか除外するオプション」を参照してください。
  7. [OK] をクリックします。 新しいユーザ定義ルールが右側のペインの［ブロック/ルール/レポート］に表示されます。新しいルールを変更するには、そのルールを選択して［編集］をクリックします。


VirusScan コンソール

アクセス保護のプロパティから、ユーザ定義のアクセス保護ルールを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［タスク］リストで、［アクセス保護］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. 左側のペインで［ユーザ定義ルール］カテゴリを選択してから、［新規］をクリックして［新しいタイプのルールの選択］ダイアログ ボックスを開きます。
  3. ルール タイプを選択して、［OK］をクリックします。の詳細については、「ユーザ定義ルールの種類」を参照してください。 表示されるアクセス ルール ダイアログ ボックスは、選択したルール タイプに応じて異なります。
  4. 次のアクセス ルール情報を設定します。
    • ネットワーク ポートのアクセス保護ルール － 「ポートのブロック ルール オプション」でオプションの表を参照してください。
    • ファイル/フォルダのアクセス保護ルール － 「ファイルとフォルダのブロック ルール オプション」でオプションの表を参照してください。
    • レジストリのアクセス保護ルール － 「レジストリのブロック ルール オプション」でオプションの表を参照してください。
    注意: 組み入れるか除外するプロセスを設定するには、 「特定のプロセスを組み入れるか除外するオプション」を参照してください。
  5. [OK] をクリックします。 新しいユーザ定義ルールが右側のペインの［ルール］列に表示されます。新しいルールを変更するには、そのルールを選択して［編集］をクリックします。


ポートのブロック ルール オプション

ポート ブロック ルールは、指定された受信ポートや送信ポートがユーザによってアクセスされることを防止するとともに、そのコンピュータが他のコンピュータによってアクセスされることを防止します。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を入力します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
開始ポート | 最初のポート番号を指定します。ポートは個別にまたはある範囲の最初のポート番号で指定することもできます。 注意: McAfee Agent または Host Intrusion Prevention Agent によって使用されるポートへのアクセスをブロックした場合でも、そのエージェントのプロセスは信頼されているため、そのプロセスはブロックされたポートを使用して通信できます。これらのエージェントのプロセスに関連のないトラフィックはブロックされます。
終了ポート | ポート範囲の最後のポート番号を指定します。
受信 | ネットワークを介した指定されたポートへのアクセスを拒否します。
送信 | ローカル プロセスからネットワーク上の指定されたポートへのアクセスを拒否します。


ファイルとフォルダのブロック ルール オプション

ファイルとフォルダのブロック ルールは、指定されたファイルやフォルダが許可されていないユーザによって変更、オープン、または削除されることを防止します。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を入力します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
ブロックするファイルまたはフォルダの名前 | 指定されたファイルまたはフォルダへのアクセスをブロックします。
ファイルの参照 | 目的のファイルに移動します。
フォルダの参照 | 目的のフォルダに移動します。
ファイルに対する読み取りアクセス | 指定ファイルへの読み取りアクセスをブロックします。
ファイルに対する書き込みアクセス | 指定ファイルへの書き込みアクセスをブロックします。
実行中のファイル | 指定フォルダ内でのファイルの実行をブロックします。
新規ファイルの作成 | 指定フォルダ内でのファイルの新規作成をブロックします。
ファイルの削除 | 指定フォルダ内からのファイルの削除をブロックします。


レジストリのブロック ルール オプション

レジストリのブロック ルールは、指定されたレジストリのキーと値がユーザや許可されていないプログラムによって変更、オープン、または削除されることを防止します。

注意: レジストリ ブロック ルールを作成する際は、最も一致度の高いハイブ レジストリ サブツリー略記を使用してください。たとえば、HKLM\System\CurrentControlSet\Services\MyService をブロックするには、HKLM ではなく HKCCS ハイブを使用します。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を指定します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
保護するレジストリのキーまたは値 このレジストリのキーまたは値を保護します。
  • ルート キーまたは値をドロップダウン リストから選択します。
  • キーまたは値をテキスト ボックスに入力します。
ルート キーまたは値をドロップダウン リストから選択するのは、オプションです。キーまたは値を指定するには、次のいずれかの方法を使用します。
  • ルート キーまたは値をドロップダウン リストから選択し、キーまたは値への残りのパスをテキスト ボックスに入力します。
  • キーまたは値へのフル パスをテキスト ボックスに入力します。
ルール タイプ ルールの種類を選択します。
  • キー - 指定したキーを保護します。
  • 値 - 指定した値を保護します。
キーまたは値への書き込み | 指定したキーまたは値への書き込みをブロックします。
キーまたは値の作成 | 指定したキーまたは値の作成をブロックします。
キーまたは値の削除 | 指定したキーまたは値の削除をブロックします。


特定のプロセスを組み入れるか除外するオプション

オプションの定義

名前などのルール情報と、組み入れるか除外するプロセスを変更するには、［アクセス保護］を使用して、［編集］をクリックします。

オプション | 説明
ルール名 | このルールの名前を入力します。たとえば、「レジストリ エディタおよびタスク マネージャが無効にされることを防止します」などです。
組み入れるプロセス | ここに登録したプロセスへのアクセスを制限します。正確なプロセス名を指定します。または、ワイルドカードを使用して *.EXE など幅広い範囲のプロセスを指定し、SETUP.EXE など信頼できるプロセスを除外対象として指定します。たとえば、* を指定するとすべてのプロセスが組み入れられます。
除外するプロセス | ここに登録したプロセスへのアクセスを許可します。正確なプロセス名を指定します。たとえば、次の除外項目を指定します。avtask.exe、cfgwiz,exe、fssm32.exe、giantantispywar*、kavsvc.exe、mmc.exe、navw32.exe、nmain.exe、rtvscan.exe。


ユーザ定義ルールの削除

作成したが使用していないルールを削除します。

次のいずれかのユーザ インターフェース コンソールを使用してユーザ定義ルールを削除します。


ePolicy Orchestrator 4.5 または 4.6

アクセス保護ポリシーから、作成したが現在は使用していないルールを削除します。

タスク

オプションの定義については、このインターフェースにある［?］または［ヘルプ］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 左側のペインで [ユーザ定義ルール] カテゴリをクリックしてから、右側のペインで削除するルールをクリックします。
  5. [削除] をクリックします。
    注意: ルールを削除せずに無効にするには、[ブロック] アクションと [レポート] アクションの選択を解除します。必要に応じて、ルールを再び有効にできます。


ePolicy Orchestrator 4.0

アクセス保護ポリシーから、作成したが現在は使用していないルールを削除します。

タスク

オプションの定義については、このインターフェースにある［?］または［ヘルプ］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 左側のペインで [ユーザ定義ルール] カテゴリをクリックしてから、右側のペインで削除するルールをクリックします。
  5. [削除] をクリックします。
    注意: ルールを削除せずに無効にするには、[ブロック] アクションと [レポート] アクションの選択を解除します。必要に応じて、ルールを再び有効にできます。


VirusScan コンソール

アクセス保護のプロパティから、作成したが現在は使用していないルールを削除します。

次のいずれかのユーザ インターフェース コンソールを使用してユーザ定義ルールを削除します。

タスク

オプションの定義については、このインターフェースにある［?］または［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［アクセス保護］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. 左側のペインで [ユーザ定義ルール] カテゴリをクリックしてから、右側のペインで削除するルールをクリックします。
  3. [削除] をクリックします。
    注意: ルールを削除せずに無効にするには、[ブロック] アクションと [レポート] アクションの選択を解除します。必要に応じて、ルールを再び有効にできます。


バッファ オーバーフロー攻撃のブロック

バッファ オーバフロー保護では、攻撃でオーバフローしたバッファにより、任意のコードが実行されることを防止します。バッファ オーバーフロー保護では、ユーザモードの API 呼び出しを監視し、バッファ オーバフローの結果として発生したこれらの呼び出しを検知します。

脅威が検知されると、情報が動作ログに記録され、［オンアクセス スキャン メッセージ］ダイアログ ボックスに表示されます（これらのオプションでこれらの処理を行うように設定していた場合）。

VirusScan Enterprise では、バッファ オーバフロー保護とアクセス保護の DAT ファイルを使用して、Internet Explorer、Microsoft Outlook、Outlook Express、Microsoft Word、MSN Messenger など、約 30 種類のアプリケーションを保護できます。

目次

関連概念
バッファ オーバーフロー攻撃のしくみ
関連タスク
バッファ オーバーフロー保護の設定


バッファ オーバーフロー攻撃のしくみ

攻撃者は、バッファ オーバーフローの弱点を突き、入力プロセス用に予約された固定サイズのメモリ バッファをあふれさせることで、実行可能コードを実行します。このコードによって、攻撃者はターゲット コンピュータを乗っ取ったり、そのデータに不正にアクセスできます。

バッファ オーバーフロー攻撃には次の 2 種類があります。
  • ヒープベースの攻撃 － この攻撃は、プログラム用に予約されたメモリ領域をあふれさせますが、実行するのが難しいためあまり行われません。
  • スタックベースの攻撃 － この攻撃はスタック メモリ オブジェクトを使用してユーザの入力値を保管するものであり、最も一般的な攻撃です。
次のプロセスは、スタックベースのバッファ オーバーフロー攻撃を説明したものです。
  1. 標準のスタック メモリ プロセス － 固定サイズのスタック メモリ オブジェクトは通常は空であり、ユーザからの入力を待っています。プログラムがユーザからユーザ名などの入力を受け取ると、そのデータはスタックの一番上に保管されて、そのデータに戻りアドレスが割り当てられます。このスタックが処理されると、ユーザの入力値はプログラムによって指定された戻りアドレスに送信されます。
  2. スタックのオーバーフロー － プログラムへの書き込み時には、特定量のメモリ領域がデータ用に予約されます。書き込まれたデータが、メモリ スタック内でそのデータ用に予約された領域より大きい場合は、スタックのオーバーフローが発生します。このことが問題となるのは、攻撃目的の入力を伴う場合のみです。
  3. オーバーフローの悪用 － プログラムがユーザによるユーザ名の入力を待っている場合に、攻撃者がスタック サイズを超える実行可能なコマンドを入力した場合は、そのコマンドは予約済み領域の外部で保存されます。
  4. 不正なコードの実行 － このコマンドは、スタック バッファ領域のサイズより大きいという理由だけで、自動的には実行されません。しかし、その不正なコマンドを指す戻りアドレスが攻撃者によって提供された場合は、このコマンドは実行される可能性があります。プログラムは、最初はバッファ オーバーフローが原因でクラッシュしかけますが、攻撃者によって提供された戻りアドレスを使用して回復しようとします。この戻りアドレスが有効なアドレスの場合は、不正なコマンドは実行されます。
  5. 権限の悪用 － プログラムは通常、カーネル モードで実行されるか、サービス アカウントから継承された権限を使用して実行されるため、この時点で不正なコードは、セキュリティが侵害されたアプリケーションと同じ権限を使用して実行されています。この結果として、攻撃者によってオペレーティング システムが完全に乗っ取られる可能性があります。


バッファ オーバーフロー保護の設定

お使いのコンピュータ上でアプリケーションが任意のコードを実行することを防止するには、バッファ オーバーフロー保護ポリシーを設定する必要があります。

次のユーザ インターフェース コンソールを使用してバッファ オーバーフロー保護ポリシーを設定します。


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用してバッファ オーバーフロー保護ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［バッファ オーバーフロー保護ポリシー］ページで、［バッファ オーバーフロー保護］タブをクリックして、以下を設定します。
    1. ［バッファ オーバーフローの設定］および使用されている保護モードを有効にします。攻撃をブロックするか単にメッセージを送信してイベントをログに記録するように保護モードを設定します。
    2. バッファ オーバーフロー攻撃が発生したときに送信される［クライアント システムの警告］を有効にします。
    3. 特定のアプリケーション プログラミング インターフェース（API）値、および除外するオプションのプロセスとモジュール名について、［保護対象から除外するバッファ オーバーフロー］を設定します。
  5. ［レポート］タブをクリックして、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、および形式を指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際に非常に役立つとともに、これらの脅威に対して実行するアクションを決定するのに役立ちます。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用してバッファ オーバーフロー保護ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［バッファ オーバーフロー保護ポリシー］ページで、［バッファ オーバーフロー保護］タブをクリックして、以下を設定します。
    1. ［バッファ オーバーフローの設定］および使用されている保護モードを有効にします。攻撃をブロックするか単にメッセージを送信してイベントをログに記録するように保護モードを設定します。
    2. バッファ オーバーフロー攻撃が発生したときに送信される［クライアント システムの警告］を有効にします。
    3. 特定のアプリケーション プログラミング インターフェース（API）値、および除外するオプションのプロセスとモジュール名について、［保護対象から除外するバッファ オーバーフロー］を設定します。
  5. ［レポート］タブをクリックして、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、および形式を指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際に非常に役立つとともに、これらの脅威に対して実行するアクションを決定するのに役立ちます。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してバッファ オーバーフロー保護ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［タスク］リストで、［バッファ オーバーフロー保護］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. ［バッファ オーバーフロー保護のプロパティ］ページで、［バッファ オーバーフロー保護］タブをクリックして、以下を設定します。
    1. ［バッファ オーバーフローの設定］および使用されている保護モードを有効にします。攻撃をブロックするか単にメッセージを送信してイベントをログに記録するように保護モードを設定します。
    2. バッファ オーバーフロー攻撃が発生したときに送信される［クライアント システムの警告］を有効にします。
    3. 特定のアプリケーション プログラミング インターフェース（API）値、および除外するオプションのプロセスとモジュール名について、［保護対象から除外するバッファ オーバーフロー］を設定します。
  3. ［レポート］タブをクリックして、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、および形式を指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際に非常に役立つとともに、これらの脅威に対して実行するアクションを決定するのに役立ちます。


不審なプログラムの制限

VirusScan Enterprise では、有害かまたはセキュリティ リスクをもたらす不審なプログラムからコンピュータを保護します。不審なプログラムの共通ポリシーを 1 つ設定できますが、ポリシーを別個に有効または無効にして、各 VirusScan Enterprise スキャナのアクションを指定できます。

怪しいプログラム（PUP）は、インストール先コンピュータのセキュリティの状態またはプライバシ ポリシーを変えてしまう可能性がある、合法的な企業が作成したソフトウェア プログラムとして定義されています。この種のソフトウェアとしては、スパイウェア、アドウェア、ダイヤラなどが挙げられます。これらの組み込み型 PUP は、ユーザが実際に必要とするプログラムとともにダウンロードされる可能性があります。セキュリティ意識の高いユーザならこの種のプログラムについて認識していて、自分で削除することもあります。


不審なプログラムの設定

お使いのコンピュータを怪しいプログラムから保護するには、各自の環境で検出する不審なプログラムのカテゴリを設定する必要があります。

設定の手順は、2 つのプロセスに分類されます。

  1. ［不審なプログラム ポリシー］を設定して、検出および除外する怪しいプログラムを定義します。
    • 現在の DAT ファイルから得られるあらかじめ定義したリストから、プログラムの全カテゴリ、またはカテゴリ内の特定プログラムを選択します。
    • 除外するプログラムを指定します。
    • 検出するユーザ定義のプログラムのリストを作成します。

  2. オンアクセス スキャナ、電子メール スキャナ、およびオンデマンド スキャナで不審なプログラムの検出を有効にしてから、不審なプログラムが検出されたときに実行するアクションを設定します。

注意: オンデマンド スキャンはポリシーではなくタスクであるため、オンデマンド スキャナで不審なプログラムの検出を有効にする方法は、他のスキャナとは異なります。詳細については、「オンデマンド スキャン タスクの設定」を参照してください。

タスク

関連タスク
不審なプログラム ポリシーへのアクセス
オンアクセス スキャナと電子メール スキャナでの不審なプログラムの検出の有効化


不審なプログラム ポリシーへのアクセス

検出する不審なプログラムのカテゴリを選択することで、不審なプログラム ポリシーを設定します。たとえば、スパイウェアやアドウェアなどです。検出対象から除外するプログラムを指定することもできます。

次のユーザ インターフェース コンソールを使用して不審なプログラム ポリシーにアクセスします。


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用して不審なプログラム ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［不審なプログラム ポリシー］ページで、［スキャン アイテム］タブをクリックして以下を設定します。
    1. 検出する不審なプログラムのカテゴリを選択 － たとえば、スパイウェアやアドウェアなどです。これらのカテゴリは、最新の DAT ファイルで定義されています。
    2. 除外対象 － ファイル名ではなく、除外する正確な検出名を指定する必要があります。
  5. ［ユーザ定義の検知対象］タブをクリックして、不審なプログラムとして扱う個別のファイルやプログラムを指定します。各アイテムをファイル名で指定し、各アイテムの説明を入力します。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用して不審なプログラム ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［不審なプログラム ポリシー］ページで、［スキャン アイテム］タブをクリックして以下を設定します。
    1. 検出する不審なプログラムのカテゴリを選択 － たとえば、スパイウェアやアドウェアなどです。これらのカテゴリは、最新の DAT ファイルで定義されています。
    2. 除外対象 － ファイル名ではなく、除外する正確な検出名を指定する必要があります。
  5. ［ユーザ定義の検知対象］タブをクリックして、不審なプログラムとして扱う個別のファイルやプログラムを指定します。各アイテムをファイル名で指定し、各アイテムの説明を入力します。


VirusScan コンソール

このユーザ インターフェース コンソールを使用して不審なプログラムのプロパティを設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［不審なプログラム ポリシー］を右クリックして、［プロパティ］をクリックして［不審なプログラム ポリシー］ダイアログ ボックスを開きます。
  2. ［不審なプログラム ポリシー］ページで、［スキャン アイテム］タブをクリックして以下を設定します。
    1. 検出する不審なプログラムのカテゴリを選択 － たとえば、スパイウェアやアドウェアなどです。これらのカテゴリは、最新の DAT ファイルで定義されています。
    2. 除外対象 － ファイル名ではなく、除外する正確な検出名を指定する必要があります。
  3. ［ユーザ定義の検知対象］タブをクリックして、不審なプログラムとして扱う個別のファイルやプログラムを指定します。各アイテムをファイル名で指定し、各アイテムの説明を入力します。


オンアクセス スキャナと電子メール スキャナでの不審なプログラムの検出の有効化

オンアクセス スキャナと電子メール スキャナで不審なプログラムを検出するには、［スキャン アイテム］タブからこの機能を有効にする必要があります。

次のユーザ インターフェース コンソールを使用して、オンアクセス スキャナと電子メール スキャナで不審なプログラムを検出できるようにします。
注意: オンデマンド スキャナで不審なプログラムを検出できるようにするには、「オンデマンド スキャン タスクの設定」を参照してください。


ePolicy Orchestrator 4.5 または 4.6

ePolicy Orchestrator 4.5 または 4.6 コンソールを使用して、オンアクセス スキャナと電子メール スキャナで不審なプログラムを検出できるようにします。

不審なプログラムの検出を有効にする方法は、オンアクセス スキャナと電子メール スキャナでは基本的に同じです。唯一の相違点は、手順 2 でポリシー カタログから選択するポリシーです。不審なプログラムの検出を有効にするためには、それぞれ次のポリシーを選択します。
  • オンアクセス スキャン － ［オンアクセス スキャン ポリシー］を選択します。
  • 電子メール スキャン － ［配信時電子メール ポリシー］を選択します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャン ポリシー］ページまたは［配信時電子メール ポリシー］ページで、［スキャン アイテム］タブをクリックして、［不審なプログラムを検出］を選択します。


ePolicy Orchestrator 4.0

ePolicy Orchestrator 4.0 コンソールを使用して、オンアクセス スキャナと電子メール スキャナで不審なプログラムを検出できるようにします。

不審なプログラムの検出を有効にする方法は、オンアクセス スキャナと電子メール スキャナでは基本的に同じです。唯一の相違点は、手順 2 でポリシー カタログから選択するポリシーです。不審なプログラムの検出を有効にするためには、それぞれ次のポリシーを選択します。
  • オンアクセス スキャン － ［オンアクセス スキャン ポリシー］を選択します。
  • 電子メール スキャン － ［配信時電子メール ポリシー］を選択します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャン ポリシー］ページまたは［配信時電子メール ポリシー］ページで、［スキャン アイテム］タブをクリックして、［不審なプログラムを検出］を選択します。


VirusScan コンソール

VirusScan コンソールを使用して、オンアクセス スキャナと電子メール スキャナで不審なプログラムを検出できるようにします。

不審なプログラムの検出を有効にする方法は、オンアクセス スキャナと電子メール スキャナでは基本的に同じです。唯一の相違点は、手順 2 で VirusScan コンソールから選択するタスクです。不審なプログラムの検出を有効にするためには、それぞれ次のポリシーを選択します。
  • オンアクセス スキャン － ［オンアクセス スキャン ポリシー］を選択します。
  • 電子メール スキャン － ［配信時の電子メール スキャナ］を選択します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、次のいずれかを右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
    • オンアクセス スキャン ポリシー － オンアクセス スキャンの場合。
    • 配信時の電子メール スキャナ － 電子メール スキャンの場合。
  2. ［オンアクセス スキャン ポリシー］ページまたは［配信時電子メール ポリシー］ページで、［スキャン アイテム］タブをクリックして、［不審なプログラムを検出］を選択します。


検出定義のアップデート

VirusScan Enterprise ソフトウェアは、スキャン エンジンとウイルス定義 (DAT) ファイルの情報に基づいて、脅威を見分けてアクションを実行します。新しい脅威は定期的に出現します。この問題に対処するため、McAfee は、継続的な脅威の調査の結果を取り込んだ、新しい DAT ファイルを毎日リリースしています。アップデート タスクは、最新の DAT ファイルを外部の McAfee アップデート サイトから取得してインストールします。
注意: ePolicy Orchestrator の管理対象環境では、最新の DAT ファイル、EXTRA.DAT ファイル、スキャン エンジン、サービス パック、およびパッチを取得することもできます。

目次

関連概念
DAT ファイルとその機能
アップデート方法の重要性
アップデート タスクとその機能
ミラー タスクとその機能
AutoUpdate リポジトリのしくみ
DAT ファイルのロールバックのしくみ


DAT ファイルとその機能

スキャン エンジンがファイルをスキャンして脅威を検索するときは、スキャン対象ファイルを検出定義（DAT）ファイルに格納された既知の脅威情報と対比します。既知の脅威情報はシグネチャと呼ばれ、McAfee ラボが発見して DAT ファイルに追加した情報です。

DAT ファイルには、シグネチャに加えて、検出されたウイルスによってもたらされたダメージを駆除して解消するための方法も含まれています。このため、VirusScan Enterprise によって使用される最新バージョンの DAT ファイルをダウンロードすることが重要です。
警告:
特定のウイルスのシグネチャがインストール済みのどの DAT ファイルにも含まれていない場合は、そのウイルスはスキャン エンジンによって検出されません。最新の DAT ファイルをフルに活用するには、スキャン エンジンも最新バージョンである必要があります。

VirusScan Enterprise は、DAT ファイルに加えて Artemis と呼ばれるヒューリスティックも使用して、不審なファイルを検索します。詳細については、「Artemis の動作」を参照してください。

各種の DAT ファイルは次のパスに格納されています。

\Program Files\Common Files\McAfee\Engine


アップデート方法の重要性

アップデート方法は非常に重要です。お使いのシステムに最新の DAT ファイルとスキャン エンジンがインストールされていないと、そのシステムを最新のウイルスから完全に保護することはできません。新種のウイルスの数、拡散速度、および感染率はこれまでになく上昇しています。さらに、ますます増えつつあるアドウェアやスパイウェアに対しては、より一貫性と可用性の高い検出機能と削除機能が必要です。

McAfee ラボは、ほぼ毎日の午後 6:00（GMT）という定時に DAT ファイル アップデートをリリースします。当然ながら、アウトブレークは予期せぬ時間にも発生するため、緊急リリースが必要です。潜在的なアウトブレークを事前に回避するために、日次 DAT が定時より早い時刻にリリースされたときは、その日の定時に 2 つ目の DAT がリリースされることはありませんが、新たな DAT を必要とする別の緊急事態が発生した場合は除きます。


アップデート方法を決定する方法

VirusScan Enterprise によって使用される DAT ファイルとスキャン エンジンは、さまざまな方法でアップデートできます。AutoUpdate タスク、手動アップデート、ログイン スクリプトを使用することも、管理ツールでアップデートをスケジュール設定することもできます。

アップデート タスクを使用すると、次のことが可能になります。

  • ネットワーク全体にわたる DAT ファイルの配備をスケジュール設定する － 複数のアップデート タスクを相互に時間的にずらして実行したり、管理者やネットワーク ユーザによる作業を最小限に抑えて、DAT ファイル アップデートをネットワークのさまざまな箇所に都合のよい時間帯に段階的に配備するためのスケジュールを設定したりできます。
  • 配備の管理負担を分散する － ネットワーク帯域幅の使用効率を高めるために、ワイド エリア ネットワークの各領域や他のネットワーク区域で、別々のサーバやドメイン コントローラを使用して、アップデート トラフィックを基本的に内部に留めます。これにより、ネットワークのセキュリティが侵害される危険性を低減することもできます。
  • 新しい DAT ファイルやアップグレードされたエンジン ファイルをダウンロードするための待ち時間を短縮する － DAT ファイルの定期的な公開日や、新しい製品バージョンがリリースされるときには、McAfee コンピュータで発生するトラフィックは大幅に増大します。ダウンロードが殺到する時を避けることで、中断される時間を最小限に抑えて新しいソフトウェアを配備できます。


効率的なアップデート方法の要件

効果的なアップデートを行うには、組織のクライアントまたはサーバの少なくとも 1 つで McAfee ダウンロード サイトからアップデートを入手する必要があります。入手したアップデート ファイルを組織全体で複製して、他のすべてのコンピュータでアクセスできるようにします。アップデート ファイルを共有サイトにコピーするプロセスを自動化して、ネットワーク全体で転送するデータ量をできる限り少なくすることが理想的です。

効果的なアップデートのために考慮する主な点は、クライアント数およびサイト数です。また、各リモート サイトのシステム数およびリモート サイトからインターネットへのアクセス方法なども考慮する場合があります。中央リポジトリを使用してアップデートを取得して、環境の保護機能を最新レベルに保つためにアップデート タスクをスケジュール設定するという基本概念は、どのような規模の組織にも当てはまります。ソフトウェアとアップデートの配備については、該当する ePolicy Orchestrator 製品ガイドを参照してください。


アップデート タスクとその機能

最新の DAT ファイル、スキャン エンジン、サービス パック、およびパッチを取得するには、アップデート タスクを使用します。

VirusScan Enterprise に含まれているデフォルトのアップデート タスクは、毎日午後 5:00 に実行され、1 時間のランダム化が指定されています。必要に応じて追加のアップデート タスクを作成できます。

アップデート タスクの動作

アップデート タスクを実行すると次の動作が発生します。

  • リポジトリ リストにある、最初に有効になったリポジトリ (アップデート サイト) に接続が行われます。このリポジトリが使用できない場合、次のサイトと接触し、接続が行われるまでまたはリストの末尾に到達するまで継続します。
  • 暗号化された CATALOG.Z ファイルをリポジトリからダウンロードします。ファイルには、アップデートに必要な基本データが収録されています。このデータは、使用できるファイルやアップデートを決定するために使用されます。
  • ファイルにあるソフトウェア バージョンが、コンピュータのバージョンに対して確認されます。新しいソフトウェアのアップデートが使用できる場合、ダウンロードされます。

アップデート タスクの中断

アップデート タスクが実行中に中断されると、次の処理が行われます。

  • HTTP、UNC、またはローカル サイトからアップデートするタスクの場合には、次回アップデート タスクを開始する際に続きの部分から再開します。
  • 単一ファイルのダウンロード中に中断された場合、FTP サイトからのアップデート タスクは再開しません。ただし、複数のファイルをダウンロードするタスクが中断された場合、中断された時点でダウンロード中だったファイルの前から、タスクが再開します。

EXTRA.DAT を使用したアップデート

EXTRA.DAT ファイルは、緊急時の一時的な手段として使用できます。EXTRA.DAT は、各アップデートのリポジトリからダウンロードされます。これにより、EXTRA.DAT を編集し、パッケージとして再度チェック インした場合に、すべての VirusScan Enterprise クライアントでアップデートされた同一の EXTRA.DAT パッケージをダウンロードして使用することができます。たとえば、同じ怪しいプログラムの検出機能を改良したり、他の新種の怪しいプログラムに対する検出機能を追加したりすることができます。VirusScan Enterprise で使用できるのは、単一の EXTRA.DAT ファイルのみです。

ヒント: EXTRA.DAT ファイルが不要になったら、マスタ リポジトリから削除して複製タスクを実行してください。これにより、すべての分散リポジトリ サイトからファイルが削除されるため、アップデート時に VirusScan Enterprise クライアントが EXTRA.DAT ファイルをダウンロードするのを防ぎます。デフォルトでは、毎日の DAT ファイルに新しい検出定義が追加されると、EXTRA.DAT にある新しい不審なプログラムを検出しても無視されます。


AutoUpdate タスクの設定

すべての McAfee 製品の DAT ファイルとスキャン エンジンを自動的にアップデートするには、AutoUpdate のプロパティとスケジュールを設定する必要があります。

タスク

オプションの定義については、タブの［?］または［ヘルプ］をクリックしてください。

  1. AutoUpdate のプロパティにアクセスするには、以下を使用します。

    • ePolicy Orchestrator 4.5 または 4.6 — ［メニュー］、［システム］、［システム ツリー］の順にクリックして、［クライアント タスク］を選択します。
      注意: 新しいスケジュール設定されたクライアント タスクの作成の詳細については、『McAfee ePolicy Orchestrator 4.5 製品ガイド』を参照してください。
    • ePolicy Orchestrator 4.0 — ［システム］、［システム ツリー］、［クライアント タスク］の順にクリックして既存のアップデート タスクを選択するか、［新しいタスク］をクリックして新しいタスクを作成します。
      注意: 新しいスケジュール設定されたクライアント タスクの作成の詳細については、『McAfee ePolicy Orchestrator 4.0 製品ガイド』を参照してください。
    • VirusScan コンソール — 既存のアップデート タスクを選択するか（右クリックして［プロパティ］を選択します）、新しいタスクを作成します（［タスク］、［新規アップデート タスク］の順に選択して、リストで新しいタスクを選択します）。
      ヒント: 新しいクライアント タスクを作成した場合は、そのタスクの名前をわかりやすい名前に変更することをお勧めします。
  2. ログ ファイルの場所または形式を指定します。
  3. 新しい DAT、新しいエンジン、サービス パックなどの他の提供されているアップデート、および製品アップグレードを取得するかどうかを設定します。
  4. アップデート タスクの完了後に実行する実行可能ファイルと、アップデートが成功した場合にのみ実行可能ファイルを実行するかどうかを指定します。
  5. ［スケジュール］をクリックして、このタスクを実行するタイミングと方法を設定します。詳細については、「スケジュール設定されたタスクの使用」を参照してください。
  6. ［今すぐアップデート］をクリックして、このタスクを直ちに実行します。


ミラー タスクとその機能

ミラー タスクを実行すると、リポジトリ リストに定義されたダウンロード リポジトリの中で最初にアクセス可能なサイトから、ネットワーク上のミラー サイトへアップデート ファイルが複製されます。通常、このタスクを使用するのは、McAfee ダウンロード サイトのコンテンツをローカル サーバにミラーリングする場合です。

アップデート ファイルが格納されている McAfee サイトを複製すると、ネットワーク上のコンピュータはこのミラー サイトからファイルをダウンロードできます。この方法は、ネットワーク上のコンピュータでインターネットにアクセスしなくてもアップデートできるため、実用的です。また、McAfee のインターネット サイトよりも近いサーバと通信することによりアクセス時間とダウンロード時間を短縮できるため、効率的です。

VirusScan Enterprise ソフトウェアのアップデートは、ディレクトリ構造に依存します。サイトをミラーリングする場合は、ディレクトリ構造全体を複製することが重要です。
注意: このディレクトリ構造は、旧バージョンの VirusScan Enterprise と NetShield もサポートしていますが、そのための条件として、このディレクトリ構造全体が、VirusScan Enterprise 8.8 がアップデート用にするのと同じ場所に複製される必要があります。


ミラー タスクの設定

DAT ファイルとスキャン エンジンを、他のコンピュータで使用するために指定された場所に保管するには、ミラー タスクのプロパティを使用してその場所とスケジュールを設定します。

タスク

オプションの定義については、タブの［?］または［ヘルプ］をクリックしてください。

  1. ミラー タスクのプロパティにアクセスするには、以下を使用します。

    • ePolicy Orchestrator 4.5 または 4.6 — ［メニュー］、［システム］、［システム ツリー］の順にクリックして、［クライアント タスク］を選択します。
      注意: 新しいスケジュール設定されたクライアント タスクの作成の詳細については、『McAfee ePolicy Orchestrator 4.5 製品ガイド』を参照してください。
    • ePolicy Orchestrator 4.0 — ［システム］、［システム ツリー］、［クライアント タスク］の順にクリックして既存のアップデート タスクを選択するか、［新しいタスク］をクリックして新しいタスクを作成します。
      注意: 新しいスケジュール設定されたクライアント タスクの作成の詳細については、『McAfee ePolicy Orchestrator 4.0 製品ガイド』を参照してください。
    • VirusScan コンソール － 次のいずれかの操作を実行します。
      • 既存のミラー タスクを選択して、右クリックして［プロパティ］を選択します。［ミラー タスク］ダイアログ ボックスが表示されます。
      • 新しいミラー タスクを作成するには、［タスク］、［新規ミラー タスク］の順に選択します。これにより、［タスク］リストに［新規アップデート タスク］が表示されます。新しいタスクをクリックして、［ミラー タスク］ダイアログ ボックスを開きます。
        注意: そのタスクを右クリックして［名前の変更］を選択して、タスク名をよりわかりやすい名前に変更します。
  2. VirusScan コンソール — 既存のアップデート タスクを選択するか（右クリックして［プロパティ］を選択します）、新しいタスクを作成します（［タスク］、［新規ミラー タスク］の順に選択して、リストで新しいタスクを選択します）。
    ヒント: 新しいクライアント タスクを作成した場合は、そのタスクの名前をわかりやすい名前に変更することをお勧めします。
  3. ログ ファイルの場所または形式を指定します。
  4. 新しい検出定義、新しいエンジンと DAT、サービス パックなどの使用可能なアップデート、および製品アップグレードを取得するかどうかを設定します。
  5. アップデート タスクの完了後に実行する実行可能ファイルと、アップデートが成功した場合にのみ実行可能ファイルを実行するかどうかを指定します。
  6. ［Mirror 場所］をクリックして、ミラー サーバの宛先を設定します。
  7. ［スケジュール］をクリックして、このタスクを実行するタイミングと方法を設定します。詳細については、「スケジュール設定されたタスクの使用」を参照してください。
  8. ［今すぐ Mirror］をクリックして、このタスクを直ちに実行します。
  9. タブでオプションを設定します。オプションの定義については、タブの［?］または［ヘルプ］をクリックしてください。

タブの定義

タブ 定義
ミラー
  • ログ ファイルの場所または形式を指定します。
  • ミラー タスクの完了後に実行する実行可能ファイルと、ミラーが成功した場合にのみ実行可能ファイルを実行するかどうかを指定します。


AutoUpdate リポジトリのしくみ

AutoUpdate リポジトリ リスト (SITELIST.XML) は、AutoUpdate タスクを実行するために必要な設定情報を指定します。

AutoUpdate リポジトリ リストには以下が含まれます。
  • リポジトリの情報および場所
  • リポジトリの優先順位
  • プロキシ設定（必要な場合）
  • 各リポジトリへのアクセスに必要な暗号化された資格情報

AutoUpdate タスクの実行時には、リポジトリ リスト内の最初に有効になったリポジトリ（アップデート サイト）に接続されます。このリポジトリが使用できない場合、次のリポジトリと接触し、接続が行われるまでまたはリストの末尾に到達するまで継続します。

ネットワークでプロキシ サーバを使用している場合、使用するプロキシ設定、プロキシ サーバのアドレス、および認証を使用するかどうかを指定できます。プロキシ情報は、AutoUpdate リポジトリ リストに保存されています。ここで構成するプロキシ設定は、リポジトリ リストにあるすべてのリポジトリに適用されます。

AutoUpdate リポジトリ リストの場所はオペレーティング システムによって異なります。
  • Microsoft Windows XP、Microsoft Vista、Microsoft 2000 Server、Microsoft 2003 Server、および Microsoft 2008 Server の場合 － C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework
  • Microsoft Windows 7 の場合 － C:\ProgramData\McAfee\Common Framework


リポジトリ リストの設定

リポジトリ リストには、アップデートの取得元となるリポジトリが含まれています。必要な数だけリポジトリを作成し、設定します。何度も使用されるサイトもあれば、まれにしか使用されないサイトもあります。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. VirusScan コンソールから、［ツール］、［AutoUpdate のリポジトリ リストを編集］の順に選択して、AutoUpdate リポジトリ リストのプロパティにアクセスします。
    注意: ePolicy Orchestrator コンソールを使用してリポジトリ機能を設定するには、［ポリシー カタログ］を選択してから ［McAfee Agent］ディスプレイに移動して、［リポジトリ］タブをクリックします。
  2. 各タブでオプションを設定します。

タブの定義

タブ | 定義
リポジトリ
  • アップデートの取得元となるリポジトリを指定します。
  • 各リポジトリにアクセスする順序を設定します。
プロキシ設定 | アップデート時に使用するプロキシ設定を指定します。


DAT ファイルのロールバックのしくみ

現在の DAT ファイルが破損しているか、または互換性がない場合、DAT ファイルを前回バックアップしたバージョンにロールバックできます。

DAT ファイルをアップデートすると、以前のバージョンは次の場所に保存されます。<ドライブ名>:\Program Files\Common Files\McAfee\Engine\OldDats

DAT ファイルをロールバックすると、現在の DAT ファイルが OldDats フォルダのバージョンで置き換えられ、以下のレジストリ項目にフラグが設定されます。HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS

ロールバックが行われた後で以前のバージョンに戻ることはできません。次回にアップデートを実行するとき、レジストリにある DAT バージョンとアップデート リポジトリにある DAT ファイルが比較されます。新しい DAT ファイルが、レジストリ内にあるものと同じである場合、アップデートは実行されません。


DAT ファイルのロールバック

お使いの DAT ファイル バージョンを直前のバージョンに戻すには、［DAT のロールバック］ツールを使用します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. VirusScan コンソールから、［ツール］、［DAT のロールバック］の順に選択します。
  2. ［はい］をクリックして DAT のロールバックを開始します。
    注意: この機能は ePolicy Orchestrator コンソールからは使用できません。
  3. タブでオプションを設定します。


スキャン アイテムの除外

VirusScan Enterprise の各スキャナでは、スキャン対象となるファイルの種類のリストを細かく調整できます。たとえば、個別のファイル、フォルダ、およびディスクをスキャン対象から除外できます。これらの除外設定が必要となる理由は、データベースまたはサーバによって使用されているファイルをスキャナがスキャンしようとして、そのファイルをロックする可能性があるからです。この結果として、そのデータベースまたはサーバでは障害やエラーが発生する可能性があります。

目次

関連参照
除外対象の指定
ワイルドカードを使用したスキャン アイテムの指定方法


除外対象の指定

スキャン操作から除外するファイル、フォルダ、およびドライブを指定してください。以前に指定した除外対象を削除することもできます。

オプションの定義

オプション 定義
除外対象 除外の種類を選択します。
  • ファイル名/場所を指定して除外 － ファイル名と場所を指定して、サブフォルダを除外するかどうかを指定します。
    注意: フォルダに適用する文字列の末尾に円記号（\）を追加する必要があります。そうしないと、それはファイルの除外と見なされ、［サブフォルダも除外］チェックボックスはデフォルトで無効になります。
  • ファイルの種類を指定して除外 － ファイルの種類を指定します。
  • ファイルの保存期間を指定して除外 － アクセス タイプの指定、およびファイルが作成されてからの経過日数の指定を行います。
除外時期 選択したアイテムを除外するタイミングを選択します。
  • 読み取り時
  • 書き込み時
クライアントの除外対象の処理方法 クライアントの除外対象を上書き － このポリシーで指定されたアイテムのみを除外します。このオプションが選択されていない場合、クライアント コンピュータではローカルで指定した除外対象およびこのポリシーで指定した除外対象を使用します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。


ワイルドカードを使用したスキャン アイテムの指定方法

ワイルドカードを使用して、除外するファイルの種類を拡張子によって指定できます。

ワイルドカードを使用する場合は、次の制限事項が適用されます。

  • 有効なワイルドカードは、1 文字を除外する疑問符 (?) と複数文字を除外するアスタリスク (*) です。
  • ワイルドカードは、パスの円記号 (\) の前で使用できます。たとえば、次のように適用されます。C:\ABC\*\XYZ は C:\ABC\DEF\XYZ と一致します。
  • 疑問符 (?) を含めて指定した場合は、それと同じ文字数のファイル名またはフォルダ名が除外対象として扱われます。たとえば、次のように適用されます。W?? と指定した場合、WWW は除外されますが、WW や WWWW は除外されません。
  • 構文上、2 重のアスタリスク (**) を含めることもできます。これはゼロ個以上の任意の文字 (円記号を含む)を意味します。これにより、複数の深さで除外対象を指定できます。たとえば、次のように適用されます。C:\ABC\**\XYZ と指定した場合、C:\ABC\DEF\XYZ や C:\ABC\DEF\DEF\XYZ などが除外対象となります。


スケジュール設定されたタスクの使用

オンデマンド スキャン タスク、AutoUpdate タスク、またはミラー タスクを設定する過程で、これらのタスクを実行するタイミング、頻度、および時間の長さを指定する必要があります。この設定プロセスの過程でユーザ権限も設定する必要があります。

目次

関連参照
タスク スケジュールの設定
関連情報
タスクのスケジュール設定


タスクのスケジュール設定

希望に応じて、オンデマンド タスク、AutoUpdate タスク、およびミラー タスクをスケジュール設定して、これらのタスクを特定の日時または間隔で実行できます。タスクのスケジュール設定方法は、使用するユーザ インターフェース コンソールによって異なります。

これらのタスクをスケジュール設定するには、次のようにします。
  • ePolicy Orchestrator コンソール — ［スケジュール］タブを使用して［スケジュール］ページを表示します。
  • VirusScan コンソール — ［スケジュール］ボタンを使用して［スケジュール］ダイアログ ボックスを表示します。
関連タスク
オンデマンド スキャン タスクの設定
関連参照
AutoUpdate タスクの設定
ミラー タスクの設定
関連情報
ePolicy Orchestrator のサーバ タスクの設定


タスク スケジュールの設定

タスクを指定した時刻または間隔で実行するには、［スケジュールの設定］ダイアログ ボックスを使用します。

作業の前に

このタスクをスケジュールするには、管理者権限が必要です。管理者権限があると、スケジュール タスクのレジストリ キーへの書き込みアクセスが可能です。

タスクのスケジュールを設定するには、そのタスクのプロパティ ダイアログ ボックスで［スケジュール］をクリックします。

警告:
McAfee では、オンデマンド スキャンを最小限の間隔でスケジュール設定することをお勧めします。
McAfee が推奨する最小間隔は次のとおりです。
  • 毎日 － 重大なマルウェアのアウトブレークが発生した場合のみに指定します。
  • 毎週 － 推奨される間隔です。
  • 毎月 － 許容可能な間隔です。
  • 3 か月ごと － かろうじて許容される間隔です。

タブの定義

タブ 定義
タスク
  • 指定された回数実行するにはスケジュール タスクを有効にします。
  • 指定された時間と分の間実行するとタスクを終了します。
  • ユーザ名、ドメイン、パスワードなどのユーザ アカウント設定を指定します。
スケジュール

スケジュールの頻度と関連する設定を指定します。


パート II － 検出:脅威の検索

脅威の検索は、保護戦略の 2 番目のステップであり、お使いのシステムにアクセスしようとしているマルウェアを検出することです。

目次

  • アイテムのオンアクセス スキャン
  • アイテムのオンデマンド スキャン
  • 配信時とオンデマンドの電子メール スキャン


アイテムのオンアクセス スキャン

オンアクセス スキャナを使用すると、コンピュータ上のファイルがアクセスされた時点で直ちにファイルを調べて、さまざまな脅威を常にリアルタイムで検出することができます。アクセス保護機能およびバッファ オーバフロー保護機能でもオンアクセス スキャナを使用して、アクセス保護違反およびバッファ オーバフロー攻撃手段を検出します。

目次

関連概念
オンアクセス スキャンとその動作
スキャンの比較:ディスクへの書き込みとディスクからの読み取り
スキャンの比較:すべてのファイルのスキャンとデフォルトの拡張子と追加した拡張子のスキャン
ScriptScan とその動作
スキャン ポリシーの数の決定
Artemis の動作
関連情報
全般設定とプロセス設定の設定方法


オンアクセス スキャンとその動作

オンアクセス スキャナはシステムの最も深いレベル（ファイル システムのフィルタ ドライバ）と連携し、ファイルが最初にシステムに入っていくる段階で、それらのファイルをスキャンします。オンアクセス スキャナはシステム（システム サービス）の一部として機能として、脅威の検出時にインターフェースを介して通知を配信します。

ファイルのオープン、クローズ、または名前変更が行われようとすると、スキャナはその操作を中断して、次のアクションを実行します。

  1. スキャナは、次の条件に基づいてそのファイルをスキャンすべきかどうかを判断します。
    • ファイルの拡張子が設定と一致している。
    • ファイルがキャッシュされていない。
    • ファイルが除外対象として設定されていない。
    • ファイルが以前にスキャンされていない。
  2. ファイルがこれらのスキャン条件に該当する場合は、そのファイル内の情報を現在読み込まれている DAT ファイル内のマルウェア シグネチャと対比することで、そのファイルがスキャンされます。
    • ファイルに感染が認められなければ、結果をキャッシュし、読み取り、書き込みまたは名前の変更操作を許可します。
    • ファイルで脅威が検出された場合、操作は拒否され、設定されているアクションが実行されます。たとえば、次のように適用されます。
      • ファイルを駆除する必要がある場合は、その駆除プロセスは現在読み込まれている DAT ファイルによって決定されます。
      • これらの結果は動作ログに記録されます（スキャナがそうするように設定されていた場合）。
      • ［オンアクセス スキャン メッセージ］アラートが表示されて、ファイル名と実行されたアクションが示されます（スキャナがそうするように設定されていた場合）。
  3. ファイルがスキャン要件を満たさない場合は、スキャンされません。そのファイルはキャッシュされて、操作が許可されます。
    注意: たとえば、オンアクセス スキャンの設定が変更されたとき、EXTRA.DAT ファイルが追加されたとき、キャッシュがいっぱいになったときなどは、その都度スキャン ファイル キャッシュがフラッシュされて、すべてのファイルが再スキャンされます。


スキャンの比較:ディスクへの書き込みとディスクからの読み取り

オンアクセス スキャナがスキャンを実行する方法は、ユーザがディスクに書き込んでいるのか、ディスクから読み取っているのかによって異なります。

ディスクへのファイルの書き込み時には、オンアクセス スキャナは次のアイテムをスキャンします。

  • ローカル ハード ドライブに書き込まれようとしている受信ファイル。
  • ローカル ハード ドライブ上またはマップされているネットワーク ドライブ上で作成中のファイル (これには、新しいファイル、変更されたファイル、1 つのドライブから別のドライブにコピーまたは移動されているファイルが含まれます)。
    注意: マッピングされたネットワーク ドライブをスキャンするには、［ネットワーク ドライブ上］オプションを有効にする必要があります。「ネットワーク上ドライブの有効化」を参照してください。

    これらのスキャンには、VirusScan Enterprise がインストールされているのと同じクライアントからのみアクセスできます。マッピングされたネットワーク ドライブに対する他のシステムからのアクセスは検出されません。

ディスクからのファイルの読み取り時には、オンアクセス スキャナは次のアイテムをスキャンします。

  • ローカル ハード ドライブまたはマッピングされたネットワーク ドライブから読み取られようとしている送信ファイル。
    注意: マッピングされたネットワーク ドライブをスキャンするには、上記で説明した［ネットワーク ドライブ上］オプションを選択して、リモート ネットワーク ファイルをスキャン対象に含めます。
  • ローカル ハード ドライブ上でプロセスを実行しようとしているすべてのファイル。
  • ローカル ハード ドライブで開かれたすべてのファイル。
  • ファイルのプロパティが変更された場合は、ローカル ハード ドライブで名前を変更中のすべてのファイル。


スキャンの比較:すべてのファイルのスキャンとデフォルトの拡張子と追加した拡張子のスキャン

オンアクセス スキャナは、すべてのファイルをスキャンするように設定されているのか、デフォルトの拡張子と追加した拡張子をスキャンするように設定されているのかに応じて、スキャン方法が異なります。

［すべてのファイル］オプションが選択されている場合は、スキャナはすべてのファイルの種類をスキャンしてすべての潜在的な脅威を検索します。

［デフォルトの拡張子と追加した拡張子］オプションが選択されている場合は、スキャナはユーザによって選択されたファイルの種類に基づいて、リストに含まれた特定のファイルをスキャンします。
  • デフォルトの拡張子:オンアクセス スキャナは、指定された種類のファイルのみをスキャンして、その種類のファイルを攻撃する脅威を検索します。

  • 拡張子の追加:オンアクセス スキャナは指定された拡張子を持つファイルをスキャンして、すべての潜在的な脅威を検索します。

  • 指定した拡張子:オンアクセス スキャナはユーザ定義リストに含まれた拡張子を持つファイルをスキャンして、すべての潜在的な脅威を検索します。


ScriptScan とその動作

スクリプト スキャナは、正規の Windows Scripting Host コンポーネントに対するプロキシ コンポーネントとして機能します。スクリプトを停止して、スクリプトの実行前にスキャンします。

たとえば、スクリプト スキャナは以下を確認します。

  • 問題のないスクリプトは、正規の Windows Scripting Host コンポーネントに渡されます。
  • スクリプト内に潜在的な脅威が検出された場合、そのスクリプトは実行されません。
信頼できるプロセス、およびスクリプトを利用する Web サイトはスキャン対象から除外できます。
注意: Windows Server 2008 システムでは、通常は［ScriptScan URL 除外］設定は Windows Internet Explorer に対して機能しませんが、［サード パーティ製のブラウザ拡張を有効にする］チェック ボックスをオンにしてこの設定を有効にしてから、Windows Server 2008 を再起動した場合は除きます。 詳細については、https://kc.mcafee.com/corporate/index?page=content&id=KB69526 を参照してください。


Artemis の動作

Artemis 機能はヒューリスティックを使用して不審なファイルを検索します。これにより、特定のマルウェアに対する最新のリアルタイム検出機能を備えた Window ベースの McAfee ウィルス対策製品が提供されます。

Artemis は、あらゆる種類のマルウェアから保護するのではなく、不審なサンプルからのみ保護します。特定の脅威から保護することの利点は、サンプルがマルウェアであると McAfee ラボによって判定されるとほぼ同時に McAfee セキュリティによってユーザを保護できることです。

VirusScan Enterprise によって保護されているクライアント システム上で実行されている不審なプログラムや DLL を検索するために Artemis が使用する、管理者によって設定される感度レベルを設定できます。Artemis は不審なプログラムを検出すると、その不審なファイルのフィンガープリントを含む DNS 要求を McAfee ラボによってホストされる中央データベース サーバに送信します。

注意: このリリースでは、Artemis 機能はデフォルトで有効になっており、感度レベルは「非常に低」に設定されています。


スキャン ポリシーの数の決定

次のプロセスに従って、複数のオンアクセス スキャン ポリシーを設定する必要があるかどうかを判断してください。


全般設定とプロセス設定の設定方法

オンアクセス スキャナの一般ポリシーとプロセス ポリシーは、別個に設定します。
  • 全般設定 － すべてのプロセスに適用するオプションが含まれます。
  • プロセス設定 － すべてのプロセスに適用する 1 つのスキャン ポリシーを設定することも、デフォルト プロセス、危険度低プロセス、および危険度高プロセスに適用する個別のポリシーを設定することもできます。


全般設定

全般設定は、あらゆるプロセスのスキャンに適用され、パラメータ類を格納しています。たとえば、最大スキャン時間、スクリプトのスキャン、望ましくない脅威のリモート コンピュータからのブロック、脅威検出時のメッセージの送信、検出のレポートなどです。

次のユーザ インターフェース コンソールを使用してオンアクセス全般設定を設定します。

関連情報
アイテムのオンアクセス スキャン


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用してすべてのプロセスのスキャンに適用される全般設定を設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャンの全般ポリシー］ページで、［全般］タブをクリックして、すべてのオンアクセス スキャンに適用される全般ポリシーを設定します。たとえば、スキャンするオンアクセス アイテム、スキャンするタイミング、最大スキャン時間、Cookie をスキャンするのかどうかなどを設定します。

    オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定できます。これにより、システムのセキュリティが強化されますが、システムの起動時間が長くなる可能性があります。

    有効時にプロセスをスキャンする機能を設定するには、［スキャン］グループで、［有効なプロセス］をクリックして、オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定します。
    注意: この機能を有効にすると、システムの起動時間が長くなる可能性があります。
  5. ［ScriptScan］タブで、ScriptScan を有効にして、必要に応じてスキャン対象から除外するプロセスや URL を設定します。
  6. ［ブロック］タブで、潜在的な脅威や不審なプログラムが含まれているファイルを書き込むリモート コンピュータからの接続のブロックを設定します。
    注意: デフォルトでは、リモート システムが、VirusScan Enterprise がインストールされたシステムにマルウェアを書き込もうとすると、 VirusScan Enterprise はそのリモート システムへの接続をブロックします。

    マルウェアを書き込んだシステムに送信されるメッセージを設定することもできます。

    注意: このメッセージを送信するには、Windows Messenger サービスが必要です。
  7. ［メッセージ］タブで、脅威が検出されたときにローカル ユーザに通知するためのメッセージを設定して、ユーザがその脅威に対して実行できるアクションを指定します。
  8. ［レポート］タブで、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、形式を指定するとともに、この脅威を診断するのに役立つ追加のスキャン ログを指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際、およびこれらの脅威に対して実行するアクションを決定するのに非常に役立ちます。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用してすべてのプロセスのスキャンに適用される全般設定を設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャンの全般ポリシー］ページで、［全般］タブをクリックして、すべてのオンアクセス スキャンに適用される全般ポリシーを設定します。たとえば、スキャンするオンアクセス アイテム、スキャンするタイミング、最大スキャン時間、Cookie をスキャンするのかどうかなどを設定します。

    オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定できます。これにより、システムのセキュリティが強化されますが、システムの起動時間が長くなる可能性があります。

    有効時にプロセスをスキャンする機能を設定するには、［スキャン］グループで、［有効なプロセス］をクリックして、オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定します。
    注意: この機能を有効にすると、システムの起動時間が長くなる可能性があります。
  5. ［ScriptScan］タブで、ScriptScan を有効にして、必要に応じてスキャン対象から除外するプロセスや URL を設定します。
  6. ［ブロック］タブで、潜在的な脅威や不審なプログラムが含まれているファイルを書き込むリモート コンピュータからの接続のブロックを設定します。
    注意: デフォルトでは、リモート システムが、VirusScan Enterprise がインストールされたシステムにマルウェアを書き込もうとすると、 VirusScan Enterprise はそのリモート システムへの接続をブロックします。

    マルウェアを書き込んだシステムに送信されるメッセージを設定することもできます。

    注意: このメッセージを送信するには、Windows Messenger サービスが必要です。
  7. ［メッセージ］タブで、脅威が検出されたときにローカル ユーザに通知するためのメッセージを設定して、ユーザがその脅威に対して実行できるアクションを指定します。
  8. ［レポート］タブで、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、形式を指定するとともに、この脅威を診断するのに役立つ追加のスキャン ログを指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際、およびこれらの脅威に対して実行するアクションを決定するのに非常に役立ちます。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してすべてのプロセスのスキャンに適用される全般設定を設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［オンアクセス スキャナ］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. ［オンアクセス スキャンの全般ポリシー］ページで、［全般］タブをクリックして、すべてのオンアクセス スキャンに適用される全般ポリシーを設定します。たとえば、スキャンするオンアクセス アイテム、スキャンするタイミング、最大スキャン時間、Cookie をスキャンするのかどうかなどを設定します。

    オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定できます。これにより、システムのセキュリティが強化されますが、システムの起動時間が長くなる可能性があります。

    有効時にプロセスをスキャンする機能を設定するには、［スキャン］グループで、［有効なプロセス］をクリックして、オンアクセス スキャンが有効になっているときは常に、お使いのシステムで現在実行されているすべてのプロセスをスキャンするように設定します。
    注意: この機能を有効にすると、システムの起動時間が長くなる可能性があります。
  3. ［ScriptScan］タブで、ScriptScan を有効にして、必要に応じてスキャン対象から除外するスクリプトを設定します。
  4. ［ブロック］タブで、潜在的な脅威や不審なプログラムが含まれているファイルを書き込むリモート コンピュータからの接続のブロックを設定します。
    注意: デフォルトでは、リモート システムが、VirusScan Enterprise がインストールされたシステムにマルウェアを書き込もうとすると、 VirusScan Enterprise はそのリモート システムへの接続をブロックします。

    マルウェアを書き込んだシステムに送信されるメッセージを設定することもできます。

    注意: このメッセージを送信するには、Windows Messenger サービスが必要です。
  5. ［メッセージ］タブで、脅威が検出されたときにローカル ユーザに通知するためのメッセージを設定して、ユーザがその脅威に対して実行できるアクションを指定します。
  6. ［レポート］タブで、スキャン動作ログ ファイルを有効にして、これらの保管場所、サイズ、形式を指定するとともに、この脅威を診断するのに役立つ追加のスキャン ログを指定します。
    注意: これらのログ ファイルは、セキュリティ上の脅威を診断する際、およびこれらの脅威に対して実行するアクションを決定するのに非常に役立ちます。


プロセスの設定

オンアクセス スキャン プロセスは、各プロセスに割り当てる危険度に基づいて設定できます。すべてのプロセスに適用するデフォルト スキャン ポリシーを 1 つ設定することも、各プロセスに割り当てられた危険度に基づいて複数のポリシーを設定することもできます。パラメータとしては、プロセスへのリスクの割り当て、スキャン アイテムの定義、Artemis スキャンの実行、圧縮ファイルのスキャン、検出対象へのアクションの実行、怪しいプログラムに対するスキャンなどがあります。

次のユーザ インターフェース コンソールを使用してオンアクセス プロセス設定を設定します。


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用してオンアクセス スキャンのデフォルト プロセス ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［プロセス］タブで、［危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定］をクリックして、オンアクセスのデフォルト プロセス、危険度低プロセス、または危険度高プロセスを表示します。
  5. ［オンアクセス スキャンのデフォルト プロセス ポリシー］ページ、［オンアクセス スキャンの危険度低プロセス ポリシー］ページ、または［オンアクセス スキャンの危険度高プロセス ポリシー］ページで、各タブでオプションを設定します。「プロセス設定のタブのオプション」を参照してください。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用してオンアクセス スキャンのデフォルト プロセス ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［プロセス］タブで、［危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定］をクリックして、オンアクセスのデフォルト プロセス、危険度低プロセス、または危険度高プロセスを表示します。
  5. ［オンアクセス スキャンのデフォルト プロセス ポリシー］ページ、［オンアクセス スキャンの危険度低プロセス ポリシー］ページ、または［オンアクセス スキャンの危険度高プロセス ポリシー］ページで、各タブでオプションを設定します。「プロセス設定のタブのオプション」を参照してください。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してオンアクセス スキャンのプロパティを設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［オンアクセス スキャナ］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. 左側のペインで、［すべてのプロセス］をクリックします。
  3. ［プロセス］タブで、［危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定］をクリックして、オンアクセスのデフォルト プロセス、危険度低プロセス、または危険度高プロセスを表示します。
  4. ［オンアクセス スキャンのデフォルト プロセス ポリシー］ページ、［オンアクセス スキャンの危険度低プロセス ポリシー］ページ、または［オンアクセス スキャンの危険度高プロセス ポリシー］ページで、各タブでオプションを設定します。「プロセス設定のタブのオプション」を参照してください。


プロセス設定のタブのオプション

次の表では、オンアクセス スキャナのタブのオプションを説明しています。

タブ | 定義
プロセス
  • オンアクセス スキャンのデフォルト プロセス － すべてのプロセスに適用する 1 つのスキャン ポリシーを設定するのか、デフォルトのプロセス、危険度低プロセス、および危険度高プロセスに適用する個別のスキャン ポリシーを設定するかを選択します。
    注意: スキャン ポリシーを 1 つ設定することを選択した場合、このポリシーはすべてのプロセスに適用されます。危険度低プロセスや危険度高プロセスに適用する個別のスキャン ポリシーを設定することを選択した場合、このポリシーは、危険度低としても危険度高としても定義されていないプロセスにのみ適用されます。
  • オンアクセス スキャンの危険度低プロセス - 危険度低と定義するプロセスを指定します。
  • オンアクセス スキャンの危険度高プロセス - 危険度高と定義するプロセスを指定します。
注意: 危険度低プロセスや危険度高プロセスに対して個別のポリシーを設定するには、［オンアクセス スキャンのデフォルト プロセス］タブで［危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに異なるスキャン ポリシーを設定］オプションを選択する必要があります。
スキャン アイテム
  • ファイルの読み取り時、書き込み時、ネットワーク ドライブ上のファイルまたはバックアップのために開いたファイル、あるいはその両方のファイルをスキャンするかを設定します。
    警告:
    ［ディスクへの書き込み時］および［ディスクからの読み取り時］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • スキャンするファイルとファイルの種類を設定します。
    警告:
    ［すべてのファイル］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • 不審なプログラム、トロイの木馬、またはマクロ ウィルスと共通点のある潜在的脅威をスキャンします。
  • アーカイブ内部をスキャンし、MIME 形式のファイルをデコードします。
  • 不審なプログラムのオンアクセス スキャンを有効にします。
除外 | スキャンから除外するディスク、ファイル、フォルダを指定します。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 脅威の検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
不審なプログラムが検出された場合
  • 不審なプログラムが検出されたときに最初に実行するアクションです。
  • 不審なプログラムの検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。


ネットワーク上ドライブの有効化

マッピングされたネットワーク ドライブをスキャンするには、［ネットワーク ドライブ上］オプションを有効にする必要があります。

次のいずれかのユーザ インターフェース コンソールを使用して、［オンアクセス スキャンのデフォルト プロセス ポリシー］ページでネットワーク上ドライブのオンアクセス スキャンを設定します。


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用して［オンアクセス スキャンのデフォルト プロセス ポリシー］ページでネットワーク上ドライブを有効にします。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャンのデフォルト プロセス ポリシー］ページで、［スキャン アイテム］タブをクリックして、［ファイルのスキャン］の横の［ネットワーク ドライブ上］をクリックします。
  5. [保存] をクリックします。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールをネットワーク上ドライブを有効にします。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［オンアクセス スキャンのデフォルト プロセス ポリシー］ページで、［スキャン アイテム］タブをクリックして、［ファイルのスキャン］の横の［ネットワーク ドライブ上］をクリックします。
  5. [保存] をクリックします。


VirusScan コンソール

このユーザ インターフェース コンソールをネットワーク上ドライブを有効にします。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［オンアクセス スキャナ］を右クリックして、［プロパティ］をクリックして［オンアクセス スキャンのプロパティ］ダイアログ ボックスを開きます。
  2. ［スキャン アイテム］タブをクリックして、［ファイルのスキャン］の横の［ネットワーク ドライブ上］をクリックします。
  3. [保存] をクリックします。


アイテムのオンデマンド スキャン

オンデマンド スキャナは、任意の時点でまたは定期的に、お使いのコンピュータを全体にわたってスキャンして脅威が潜んでいないか確認します。オンデマンド スキャンは、オンアクセス スキャナによる継続的な保護を補完するために利用できるとともに、業務に支障のない時間帯に定期的なスキャンを実行するために利用できます。

目次

関連概念
オンデマンド スキャンとその動作
オンデマンド スキャンの方法とその定義方法
リモート ストレージのスキャンの機能のしくみ
スキャンの遅延のしくみ
システム使用率の機能
関連タスク
オンデマンド スキャン タスクの設定
グローバル システム キャッシュの設定


オンデマンド スキャンとその動作

オンデマンド スキャナは、お使いのシステムのファイル、フォルダ、メモリ、レジストリなどをスキャンして、システムに感染している可能性のあるマルウェアを検索します。オンデマンド スキャンを実行するタイミングと方法を設定できます。システムを手動でスキャンすることも、スケジュール設定した時刻にスキャンすることも、システムの起動時にスキャンすることもできます。

ファイルのオープン、クローズ、または名前変更が行われようとすると、スキャナはその操作を中断して、次のアクションを実行します。

  1. スキャナは、そのファイル、フォルダ、またはディスクをスキャンすべきかどうかを次の条件に基づいて判断します。
    • ファイルの拡張子が設定と一致している。
    • ファイルがキャッシュされていない。
    • ファイルが除外対象として設定されていない。
    • ファイルが以前にスキャンされていない。
      注意: Artemis を設定している場合は、オンデマンド スキャナはヒューリスティックを使用して不審なファイルを検索します。詳細については、「Artemis の動作」を参照してください。
  2. ファイル、フォルダ、またはディスクがこれらのスキャン条件に該当する場合は、そのファイル内の情報を現在読み込まれている DAT ファイル内のウイルス シグネチャと対比することで、そのファイル、フォルダ、またはディスクがスキャンされます。
    • スキャンしたアイテムで脅威が検出されなかった場合は、その結果がキャッシュされて、次のアイテムがチェックされます。
    • スキャンしたアイテムで脅威が検出された場合は、設定されたアクションが実行されます。次に例を示します。
      • そのアイテムを駆除する必要がある場合は、そのためのプロセスは現在読み込まれている DAT ファイルによって決定されます。
      • 結果が動作ログに記録されます（スキャナがそうするように設定されていた場合）。
      • ［オンデマンド スキャンの状況］ダイアログ ボックスで、メモリ、ファイル、フォルダ、またはディスクの名前と、実行されたアクションに関する情報が表示されます。
  3. メモリ、ファイル、フォルダ、またはディスクがスキャン要件を満たしていない場合は、それらはスキャンされずに、スキャナはすべてのデータがスキャンされるまでスキャンを継続します。
関連概念
Artemis の動作


オンデマンド スキャンの方法とその定義方法

オンデマンド スキャナは、メモリ内プロセス スキャンとインクリメンタル（再開可能）スキャンを使用します。

メモリ内プロセス スキャン

この方法では、オンデマンド スキャン タスクを実行する前に、アクティブ プロセスをすべて調べます。検出された怪しいプロセスは強調表示されて、停止されます。つまり、オンデマンド スキャナの 1 回のパスで、1 つの怪しいプログラムの全インスタンスを削除できます。

インクリメンタル (再開可能) スキャン

この方法では、オンデマンド スキャンを実行する時間を制限して、複数のセッションにわけてシステム全体をスキャンできます。インクリメンタル スキャンは、スケジュール設定されたスキャンに制限時間を追加することで設定できます。この制限時間が経過するとスキャンは停止します。このタスクが次回に開始されるときは、前回のスキャンが停止したファイルとフォルダ構造内の箇所から再開されます。


リモート ストレージのスキャンの機能のしくみ

リモート ストレージ データは、2 つの定義済みストレージ レベルを持つ階層構造になっています。

これらの 2 つのストレージ レベルは次のとおりです。
  • 上位レベルのローカル ストレージ － Windows 2000 Server 上でリモート ストレージを実行しているコンピュータの NTFS ディスク ボリュームが含まれます。
  • 下位レベルのリモート ストレージ － サーバ コンピュータに接続されているスタンドアロン テープ ドライブ、または自動テープ ライブラリに配置されています。

リモート ストレージでは、ローカル ボリュームの適切なファイルがテープ ライブラリに自動的にコピーされ、ローカル ボリューム上の利用可能な空き領域が監視されます。ファイルのデータは、必要なときにすばやくアクセスできるようローカル ボリュームにキャッシュされます。リモート ストレージは、必要に応じてリモート ストレージのデータをローカル ストレージに移動します。リモート ストレージによって管理されているボリューム上のファイルは、通常どおりに開くだけでアクセスできます。そのファイルのデータがローカル ボリュームのキャッシュから削除されている場合は、リモート ストレージによってテープ ライブラリのデータが呼び出されます。

関連タスク
オンデマンド スキャン タスクの設定


スキャンの遅延のしくみ

パフォーマンスを高めるために、バッテリの残量が少ない場合や全画面プレゼンテーション時にオンデマンド スキャン タスクを遅らせることができます。ユーザがスケジュール設定されたスキャンを 1 時間単位で遅らせることを許可することもできます。1 時間だけ遅らせることも、24 時間遅らせることも、オンデマンド スキャンを無期限に延期することもできます。

個別のユーザ遅延の継続時間は 1 時間です。たとえば、[遅延時間] オプションを 2 に設定すると、ユーザはスキャン タスクを 2 回分または 2 時間遅らせることができます。指定した最大時間が過ぎると、スキャンが続行されます。管理者がこのオプションを 0 に設定して無期限の遅延を許可した場合、ユーザはスキャンを無期限に遅延させ続けることができます。


システム使用率の機能

オンデマンド スキャナは、スキャン プロセスと脅威の優先順位について Windows の［優先度の設定］設定を使用できます。これにより、オペレーティング システムで、オンデマンド スキャナがスキャン プロセス中の任意の時点で受け取る CPU 時間の長さを設定できます。［オンデマンド スキャンのプロパティ］の［システム使用率］設定は、Windows の［優先度の設定］設定と対応しています。

スキャンのシステム使用率を「低」に設定すると、他の実行中アプリケーションのパフォーマンスが向上します。「低」設定は、エンド ユーザが作業中のシステムに対して便利です。その一方で、システム使用率を「標準」に設定すると、スキャン速度が向上します。「標準」設定は、サイズの大きいボリュームを備えた、エンド ユーザの作業量が非常に少ないシステムに対して便利です。

次の表では、VirusScan Enterprise と ePolicy Orchestrator のデフォルト プロセス設定を示しています。

VirusScan Enterprise のプロセス設定 | Windows の［優先度の設定］設定
低 | 低
標準以下 — ePolicy Orchestrator のデフォルト | 標準以下
標準 — VirusScan Enterprise 8.8 のデフォルト | 標準
関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


オンデマンド スキャン タスクの設定

オンデマンド タスクの設定方法は、使用しているユーザ インターフェース コンソールによって異なります。以下のタスクでは、それぞれのユーザ インターフェース コンソールを使用した設定方法を説明しています。

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール
関連参照
オンデマンド スキャン タスクのタブの設定


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用してオンデマンド スキャン タスクを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［システム］、［システム ツリー］の順にクリックして、［クライアント タスク］を選択します。
  2. 表示される［クライアント タスク］ページで次の操作を実行します。
    • 既存のオンデマンド スキャン タスクを編集するには、そのタスクの［アクション］列で［設定を編集］をクリックして、［説明］ページを開きます。
    • 新しいオンデマンド スキャン タスクを作成するには、［アクション］、［新しいタスク］の順にクリックして、［説明］ページを開きます。
  3. ［説明］ページで次の操作を実行します。
    • 既存のオンデマンド スキャン タスクを編集する場合は、説明を確認して［次へ］をクリックします。
    • 新しいオンデマンド スキャン タスクを作成する場合は、以下を設定して［次へ］をクリックします。
      • ［名前］と［注記］を入力します。
      • リストから［オンデマンド スキャン］（VirusScan Enterprise 8.8）を選択して［タイプ］を設定します。
      • オンデマンド スキャン タスクを受信するコンピュータを特定する［タグ］を設定します。
  4. 表示される［クライアント タスク ビルダ］設定ページで、各タブを設定します。詳細については、「オンデマンド スキャン タスクのタブの設定」を参照してください。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用してオンデマンド スキャン タスクを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［システム ツリー］、［クライアント タスク］の順にクリックします。
  2. 表示される［クライアント タスク］ページで次の操作を実行します。
    • 既存のオンデマンド スキャン タスクを編集するには、そのタスクの［アクション］列で［編集］をクリックして、［説明］ページを開きます。
    • 新しいオンデマンド スキャン タスクを作成するには、［アクション］、［新しいタスク］の順にクリックして、［説明］ページを開きます。
  3. 次のいずれかを実行します。
    • 既存のオンデマンド スキャン タスクを編集する場合は、説明を確認して［次へ］をクリックします。
    • 新しいオンデマンド スキャン タスクを作成する場合は、以下を設定して［次へ］をクリックします。
      • ［名前］と［注記］を入力します。
      • リストから［オンデマンド スキャン］（VirusScan Enterprise 8.8）を選択して［タイプ］を設定します。
      • オンデマンド スキャン タスクを受信するコンピュータを特定する［タグ］を設定します。
  4. 表示される［クライアント タスク ビルダ］設定ページで、各タブを設定します。詳細については、「オンデマンド スキャン タスクのタブの設定」を参照してください。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してオンデマンド スキャン タスクを設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. 既存のタスクまたは新しいタスクの［オンデマンド スキャンのプロパティ］ページを開きます。
    • 既存のオンデマンド スキャン タスクを選択して右クリックして、［プロパティ］を選択します。
    • 新しいタスクを作成して、［タスク］、［新規オンデマンド スキャン タスク］の順に選択して、新しいタスクを右クリックして［プロパティ］を選択します。
  2. ［オンデマンド スキャンのプロパティ］ダイアログ ボックスで各タブを設定します。詳細については、「オンデマンド スキャン タスクのタブの設定」を参照してください。
関連参照
オンデマンド スキャン タスクのタブの設定


オンデマンド スキャン タスクのタブの設定

VirusScan Enterprise には、デフォルトのオンデマンド スキャン タスクが含まれています。デフォルト タスクを使用することも、新しいタスクを作成することもできます。

各タブのオプションを設定します。オプションの定義については、各タブで［?］または［ヘルプ］をクリックします。

タブの定義

タブ | 定義
スキャンする場所
  • スキャン対象の場所とアイテムを指定します。
  • 実行中のプロセスも対象にします。
  • スキャン時にサブフォルダも対象にします。
  • スキャン時にブート セクタも対象にします。
  • スキャン時にレジストリのキーと値も対象にします。
  • スキャン時に Cookie ファイルも対象にします。
警告:
［メモリでのルートキットのスキャン］と［実行中のプロセス］のスキャンを有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
注意: ［オンデマンド スキャンの状況］ダイアログ ボックスが開くと、スキャンする場所が［スキャン対象］の後ろにコンマで区切られた文字列として表示されます。それぞれのスキャン プロセスが完了するたびに、完了した場所はこの文字列から削除されます。
スキャン アイテム
  • スキャンするファイルとファイルの種類を設定します。
  • 不審なプログラムのオンデマンド スキャンを有効にします。
  • アーカイブ内部をスキャンし、MIME 形式のファイルをデコードします。
  • ストレージに移動したファイルをスキャンします。
  • 不審なプログラム、トロイの木馬、またはマクロ ウィルスと共通点のある潜在的脅威をスキャンします。
除外 | スキャン対象から除外するディスク、ファイル、およびフォルダを、名前または場所、ファイルの種類、またはファイル作成後の経過日数によって指定します。
パフォーマンス
  • スキャンを遅らせるタイミングと期間を設定します。
  • システム使用率 (%) を指定します。
  • Artemis の感度レベルを設定します。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 脅威の検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
不審なプログラムが検出された場合
  • 不審なプログラムが検出されたときに最初に実行するアクションです。
  • 不審なプログラムの検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。

プロンプト ダイアログ ボックスで許可されているアクションについて、アクションを選択します。

レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。
  • スキャン活動以外にログに記録する処理を指定します。
  • 以下のうち、スキャン動作に加えてログに記録する対象を指定します。
    • セッション設定の有効化
    • セッション サマリの有効化
    • 暗号化ファイルのスキャンの失敗の有効化
  • Cookie 検出時のアラートの有効化
タスク オンデマンド スキャン タスクを実行する場所を指定します。
注意: このタブは ePolicy Orchestrator でのみ使用できます。


グローバル システム キャッシュの設定

VirusScan Enterprise のスキャン キャッシュには、ウイルスなどに感染していないスキャン済みファイルのリストが保存されます。この非感染ファイルのスキャン キャッシュ情報をシステムの再起動時に保存することで、システムのパフォーマンスを高めることができます。これにより、オンデマンド スキャナは、この非感染ファイル キャッシュ情報を使用してファイルの重複スキャンを低減できます。

次のユーザ インターフェース コンソールを使用して、［全般オプション ポリシー］タブと［スキャンの全般設定］タブでスキャン キャッシュ機能を設定します。

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用して全般オプション ポリシーからスキャン キャッシュ機能を設定します。

タスク

オプションの定義については、インターフェースの［?］または［ヘルプ］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 全般オプション ポリシーから、［スキャンの全般設定］タブをクリックして、VirusScan Enterprise のスキャン キャッシュ オプション設定を設定します。
  5. 次のスキャン キャッシュ全般設定を設定します。
    • 再起動中のスキャン データの保存を有効化 － システムの再起動時に非感染スキャン結果を保存します。
    • オンデマンド スキャンにおけるスキャン キャッシュの利用を許可 － オンデマンド スキャナは既存の非感染スキャン結果を使用することで、重複スキャンを低減できます。
  6. [保存] をクリックします。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用して全般オプション ポリシーからスキャン キャッシュ機能を設定します。

タスク

オプションの定義については、インターフェースの［?］または［ヘルプ］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. 全般オプション ポリシーから、［スキャンの全般設定］タブをクリックして、VirusScan Enterprise のスキャン キャッシュ オプション設定を設定します。
  5. 次のスキャン キャッシュ全般設定を設定します。
    • 再起動中のスキャン データの保存を有効化 － システムの再起動時に非感染スキャン結果を保存します。
    • オンデマンド スキャンにおけるスキャン キャッシュの利用を許可 － オンデマンド スキャナは既存の非感染スキャン結果を使用することで、重複スキャンを低減できます。
  6. [保存] をクリックします。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してスキャン キャッシュ機能を設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［ツール］、［全般オプション］、［スキャンの全般設定］タブの順にクリックして、［スキャンの全般設定］ダイアログ ボックスを開きます。
  2. 次のスキャン キャッシュ全般設定を設定します。
    • 再起動中のスキャン データの保存を有効化 － システムの再起動時に非感染スキャン結果を保存します。
    • オンデマンド スキャンにおけるスキャン キャッシュの利用を許可 － オンデマンド スキャナは既存の非感染スキャン結果を使用することで、重複スキャンを低減できます。
  3. [OK] をクリックします。


配信時とオンデマンドの電子メール スキャン

電子メール スキャナは、電子メール メッセージと添付ファイルを自動的にスキャンします。

電子メールは以下を使用してスキャンされます。
  • Microsoft Outlook － 電子メールは配信時にスキャンされるか、Microsoft Outlook からオンデマンド電子メール スキャンを直接実行することもできます。
    注意: ヒューリスティック機能と Artemis 機能を設定している場合は、電子メールの配信時スキャナとオンデマンド スキャナはヒューリスティックを使用して不審なファイルを探します。詳細については、「Artemis の動作」を参照してください。
  • Lotus Notes — 以下を設定できます。
    • アクセス時に、電子メールがスキャンされます。
    • 起動時に、Lotus Notes からオンデマンド電子メール スキャンが直接実行されます。
    • 除外する Notes データベース

次のユーザ インターフェース コンソールを使用して配信時電子メール スキャンのポリシーを設定します。

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール
関連参照
配信時電子メール スキャン ポリシーのタブの定義


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用して配信時電子メール スキャンのポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［配信時の電子メール スキャナ ポリシー］設定ページの各タブでオプションを設定します。「配信時電子メール スキャン ポリシーのタブの定義」を参照してください。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用して配信時電子メール スキャンのポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［配信時の電子メール スキャナ ポリシー］設定ページの各タブでオプションを設定します。「配信時電子メール スキャン ポリシーのタブの定義」を参照してください。


VirusScan コンソール

このユーザ インターフェース コンソールを使用して配信時電子メール スキャンのポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［タスク］リストで、［配信時の電子メール スキャンのプロパティ］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. ［配信時の電子メール スキャンのプロパティ］ダイアログ ボックスの各タブでオプションを設定します。「配信時電子メール スキャン ポリシーのタブの定義」を参照してください。


配信時電子メール スキャン ポリシーのタブの定義

タブ 定義
スキャン アイテム
  • スキャン対象の添付ファイルとメッセージを指定します。
  • ヒューリスティックを使用して、マルウェアと類似した潜在的な脅威や不明なマクロ ウイルスを対象にしてスキャンして、複数の拡張子を持つ添付ファイルを探します。
  • アーカイブ内の圧縮ファイルをスキャンして、MIME 形式のファイルをデコードします。
  • 電子メール スキャナを有効にして、不審なプログラムをスキャンします。
  • 電子メール本文をスキャンします。
  • Artemis の感度レベルを設定します。
    注意: このオプションは、[配信時電子メール スキャン] でのみ使用できます。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
不審なプログラムが検出された場合
  • 不審なプログラムが検出されたときに最初に実行するアクションです。
  • 最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。

プロンプト ダイアログ ボックスで許可されているアクションについて、アクションを選択します。

アラート
  • 脅威が埋め込まれた電子メールが検出されたら、もう 1 人のユーザに通知します。
  • ユーザがアクションの実行を求められたときに表示されるメッセージを指定します。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。
  • スキャン活動以外にログに記録する処理を指定します。
Notes スキャナの設定
注意: このタブは、[配信時電子メール スキャン] でのみ使用できます。

Lotus Notes に固有の設定を指定します。

  • すべてのサーバ データベースをスキャンします。
  • 指定したメールボックスのルート フォルダにあるサーバ メールボックスをスキャンします。
  • 無視する Notes アプリケーションです。


パート III － 対応:脅威の処理

脅威への対応は、保護戦略の 3 番目のステップであり、お使いのシステムにアクセスしようとするマルウェアを検出して駆除することです。

目次

  • 検出および対応
  • アラートおよび通知の設定
  • クエリおよびダッシュボードへのアクセス
  • 緊急 DAT の設定


検出および対応

脅威が発生して検出されたときに実行される処理は、VirusScan Enterprise がどのように対応するように設定されているのか、およびどの機能によってその脅威が検出されたのかによって決まります。これらの違いを理解することは、効果的な戦略を策定して実践するのに役立ちます。

目次

関連概念
検出時のスキャナ アクション
隔離アイテム
関連参照
システムのアクセス ポイント違反
バッファ オーバーフロー検出
不審なプログラムの検出
オンアクセス スキャン検出
オンデマンド スキャン検出
電子メール スキャンによる検出


検出時のスキャナ アクション

脅威が検出されたときの対応は、VirusScan Enterprise の設定内容によって異なります。

VirusScan Enterprise が自動的に駆除するように設定されている場合は（推奨のデフォルト設定）、DAT ファイルに記載された駆除指示に基づいてアクションが実行されます。たとえば、スキャナによるファイルの駆除ができない場合や、ファイルが修復できないほど損傷している場合は、DAT ファイルの定義内容に応じて、スキャナはそのファイルを削除するか、2 番目のアクションを実行することがあります。

脅威が含まれている可能性のあるファイルへのアクセスがスキャナによって拒否される場合は、そのファイルの保存時にファイル名に .mcm 拡張子が追加されます。


システムのアクセス ポイント違反

システムのアクセス ポイント違反が発生したとき、実行されるアクションはルールの設定によって異なります。

ルールの設定とそれに対して実行されるアクションは次のとおりです。

  • レポート － 情報がログ ファイルに記録されます。

  • ブロック － アクセスが拒否されます。

ログ ファイルで、侵害されたシステムのアクセス ポイント、および侵害を検出したルールを確認した後、アクセス保護ルールを設定し、ユーザが正当なアイテムにアクセスでき、保護されたアイテムにはアクセスできないようにします。

対応として実行するアクションを決定するには、以下のシナリオを使用します。

検出の種類 シナリオ
望ましくないプロセス
  • ルールによってログ ファイルに違反がレポートされたが、違反がブロックされなかった場合、ルールについて［ブロック］オプションを選択します。
  • ルールによって違反がブロックされたが、違反がログ ファイルにレポートされなかった場合、ルールについて［レポート］オプションを選択します。
  • ルールによって違反がブロックされ、ログ ファイルにレポートされている場合は、アクションは不要です。
  • 検出されなかった不審なプロセスを見つけた場合は、ルールを編集してそのプロセスをブロック対象として含めます。
正当なプロセス
  • ルールによってログ ファイルに違反がレポートされたが、違反がブロックされなかった場合、ルールについて［レポート］オプションを選択します。
  • ルールによって違反がブロックされてログ ファイルにレポートされている場合、ルールを編集して正当なプロセスをブロック対象から除外します。


バッファ オーバーフロー検出

バッファ オーバーフローが検出されると、スキャナはその検出対象をブロックして、［オンアクセス スキャン メッセージ］ダイアログ ボックスにメッセージが記録されます。このダイアログ ボックスを参照してから、追加のアクションを実行するかどうかを判断できます。

実行できるアクションは次のとおりです。
  • メッセージの削除 － リストのアイテムを選択し、［削除］をクリックします。
  • 除外対象の作成 － 検出されたプロセスが正規のプロセス（誤検知）である場合は、［オンアクセス スキャン メッセージ］ダイアログ ボックスの情報を使用して除外対象を作成します。[名前] コラムにある情報を確認し、呼び出しをかけている書き込み可能メモリを所有しているプロセス名を決定します。プロセス名を利用して除外対象を作成します。
  • 分析のための McAfee ラボへのサンプル送信 － スキャナによって検出されるべきでないものが検出される場合や、検出されるべきものが検出されない場合は、サンプルを McAfee ラボに送信できます。


不審なプログラムの検出

オンアクセス スキャナ、オンデマンド スキャナ、電子メール スキャナは、設定した [不審なプログラム ポリシー] に基づいて不審なプログラムを検出します。不審なプログラムが検出されると、そのスキャナに対して [アクション] タブで設定したアクションが適用されます。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャン アイテムの微調整 － スキャンの効率性を高めます。
  • 検出対象からの除外 － 正当なプログラムが検出された場合は、そのプログラムを検出対象から除外するように設定できます。
  • ユーザ定義の検出リストへの追加 － 不審なプログラムが検出されなかった場合は、そのプログラムをユーザ定義の検出リストに追加できます。
  • 分析のための McAfee ラボへのサンプル送信 － スキャナによって検出されるべきでないものが検出される場合や、検出されるべきものが検出されない場合は、サンプルを McAfee ラボに送信できます。


オンアクセス スキャン検出

オンアクセス スキャナは、マルウェアを検出すると、［オンデマンド スキャンのプロパティ］の［アクション］タブの設定内容に従ってアクションを実行します。また、［オンアクセス スキャン メッセージ］ダイアログ ボックスにメッセージが記録されます。

動作ログと［オンアクセス スキャン メッセージ］ダイアログ ボックスの情報を確認し、以下の追加アクションを実行するかどうかを決定します。

  • スキャン アイテムの微調整 － スキャンの効率性を高めるには、VirusScan Enterprise によって脅威と識別される可能性のある正当なファイルを除外対象に設定して、隔離領域に保存された可能性のある既知の脅威を削除します。
  • ［オンアクセス スキャン メッセージ］ダイアログ ボックスでのアイテムの右クリック － 以下のアクションを実行します。
    • ファイルを駆除 - 選択したメッセージに示されているファイルの駆除を試みます。
    • ファイルを削除 - 選択したメッセージに示されているファイルを削除します。削除されたファイル名はログ ファイルに記録されるので、隔離マネージャから復元することができます。
    • すべて選択 (Ctrl+A) - リスト内のすべてのメッセージを選択します。
    • リストからメッセージを削除 (Ctrl+D) - 選択したメッセージをリストから削除します。メッセージは、リストから削除されてもログ ファイルには記録されています。
    • すべてのメッセージを削除 - すべてのメッセージをリストから削除します。メッセージは、リストから削除されてもログ ファイルには記録されています。
    • オンアクセス スキャナ ログ ファイルを開く - オンアクセス スキャナの動作ログ ファイルを開きます。このオプションは [ファイル] メニューからのみ使用できます。
    • アクセス保護ログ ファイルを開く - アクセス保護に関する動作ログ ファイルを開きます。このオプションは [ファイル] メニューからのみ使用できます。
    • 選択したメッセージに対して実行できないアクションがある場合は、そのアクションに対応するアイコン、ボタン、およびメニュー項目が無効化されます。たとえば、メッセージに示されているファイルがすでに削除されている場合には [駆除] アクションは使用できません。また、管理者がファイルの削除を禁止した場合には、[削除] アクションは使用不能となります。
    • ファイルを駆除 - DAT ファイルにクリーナがない場合や破損して修復できない場合、ファイルは駆除できません。ファイルの駆除が失敗した場合は、ファイル名に .mcm という拡張子が追加され、そのファイルへのアクセスが拒否されます。また、それについてのエントリがログ ファイルに記録されます。この場合、ファイルを削除し、安全なバックアップ コピーから復元することを推奨します。
  • 分析のための McAfee Labs へのサンプル送信 － スキャナによって検出されるべきでないものが検出される場合や、検出されるべきものが検出されない場合は、サンプルを McAfee ラボに送信できます。


オンデマンド スキャン検出

オンデマンド スキャナは、脅威を検出すると、［オンデマンド スキャンのプロパティ］の［アクション］タブの設定内容に従ってアクションを実行します。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャン アイテムの微調整 － スキャンの効率性を高めます。
  • アクションを指定 － ［オンデマンド スキャンの状況］ダイアログ ボックスからアクションを選択することで、スキャナがユーザにアクションの指定を求めるように設定しています。
  • 分析のための McAfee ラボへのサンプル送信 － スキャナによって検出されるべきでないものが検出される場合や、検出されるべきものが検出されない場合は、サンプルを McAfee ラボに送信できます。


電子メール スキャンによる検出

電子メール スキャンによって脅威が検出されたときにスキャナによって実行されるアクションは、［配信時の電子メール スキャンのプロパティ］または［オンデマンド電子メール スキャン プロパティ］の［アクション］タブの設定内容に応じて異なります。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャン アイテムの微調整 － スキャンの効率性を高めます。
  • 分析のための McAfee ラボへのサンプル送信 － スキャナによって検出されるべきでないものが検出される場合や、検出されるべきものが検出されない場合は、サンプルを McAfee ラボに送信できます。


隔離アイテム

脅威として検出されたアイテムは、駆除または削除されます。さらに、そのアイテムのコピーが実行不能な形式に変換されて、隔離フォルダに保存されます。このようにすることで、その脅威を駆除可能にする情報が含まれている可能性のある最新バージョンの DAT のダウンロード後に、これらの隔離アイテムに対してプロセスを実行できます。

これらの追加のプロセスは次のとおりです。

  • 復元

  • 再スキャン

  • 削除

  • 誤検知の確認

  • 検出プロパティの表示

注意: 隔離アイテムには、複数の種類のスキャン済みオブジェクトが含まれている可能性があります。これらのオブジェクトは、ファイル、Cookie、レジストリ、および VirusScan Enterprise がマルウェアを検出するためにスキャンするあらゆるアイテムです。


隔離ポリシーの設定

Quarantine Manager のポリシーにアクセスして、必要に応じて隔離ポリシーを設定するか、デフォルト設定をそのまま使用します。

次のユーザ インターフェース コンソールを使用して Quarantine Manager のポリシーを設定します。

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用して Quarantine Manager のポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［隔離］ページで、デフォルトの検疫ディレクトリをそのまま使用するか、異なるディレクトリを選択します。
  5. 隔離アイテムの保存日数を設定するには、［指定日数後に隔離データを自動削除］をクリックして、［バックアップ データを検疫ディレクトリに保管しておく日数］を入力します。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用して Quarantine Manager のポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. ［隔離］ページで、デフォルトの検疫ディレクトリをそのまま使用するか、異なるディレクトリを選択します。
  5. 隔離アイテムの保存日数を設定するには、［指定日数後に隔離データを自動削除］をクリックして、［バックアップ データを検疫ディレクトリに保管しておく日数］を入力します。


VirusScan コンソール

このユーザ インターフェース コンソールを使用して Quarantine Manager のポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［タスク］リストで、［Quarantine Manager のポリシー］を右クリックして、［プロパティ］をクリックして［Quarantine Manager のポリシー］ダイアログ ボックスを開きます。
  2. デフォルトの隔離ディレクトリをそのまま使用するか、異なるディレクトリを選択します。
  3. 隔離アイテムの保存日数を設定するには、［指定日数後に隔離データを自動削除］をクリックして、［バックアップ データを検疫ディレクトリに保管しておく日数］を入力します。


隔離アイテムの管理

VirusScan コンソール を使用して、隔離アイテムを処理してさらに詳しくチェックして、手動で削除または復元します。
注意: ePolicy Orchestrator コンソールから、［隔離からの復元］クライアント タスクを使用して隔離アイテムを復元します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. VirusScan コンソール の［タスク］リストで、［Quarantine Manager のポリシー］をクリックして［Quarantine Manager のポリシー］ダイアログ ボックスを開きます。
  2. ［マネージャ］タブをクリックして、アイテムを右クリックして次の詳細オプションにアクセスします。

    • 復元

    • 再スキャン

    • 削除

    • 誤検知の確認

    • 検出プロパティの表示

  3. ダイアログ ボックスが開いて、実行しようとしているアクションがもたらす影響が説明されます。


アラートおよび通知の設定

潜在的な脅威が検出されたときに通知を受け取るのは、環境を保護するために重要な点です。ePolicy Orchestrator コンソールまたは VirusScan コンソールを使用して、脅威が検出されたときに通知を受ける方法を設定できます。どちらのコンソールでも、アラート オプションを設定したり、重大度に基づいてアラートをフィルタリングしてアラート トラフィックを制限したり、ローカル アラート オプションを設定したりできます。

関連タスク
アラートの設定
関連参照
オンアクセス スキャン検出


アラートの設定

各種のスキャナが脅威を検出したときに表示されるアラートと通知のプロパティを設定します。

同じプロセスを使用して、以下のポリシーのアラートを設定します。
  • アラート ポリシー
  • バッファ オーバーフロー保護ポリシー
  • 配信時電子メール スキャン ポリシー

次のユーザ インターフェース コンソールを使用して、これら 3 つのポリシーすべてのアラート通知ポリシーを設定します。

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール
関連参照
アラート ポリシーのタブの設定


ePolicy Orchestrator 4.5 または 4.6

このユーザ インターフェース コンソールを使用してアラート ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［メニュー］、［ポリシー］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［アクション］、［新規ポリシー］の順にクリックして、［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［カテゴリ］リストから、既存のポリシーを選択します。
    3. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    4. 新しいポリシーの名前を入力します。
    5. 必要に応じて注釈を入力します。
    6. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
    7. 新しいポリシーの［アクション］列で、［設定を編集］をクリックしてポリシー設定ページを開きます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. アラート ポリシーのタブを設定します。「アラート ポリシーのタブの設定」を参照してください。


ePolicy Orchestrator 4.0

このユーザ インターフェース コンソールを使用してアラート ポリシーを設定します。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ［システム］、［ポリシー カタログ］の順にクリックして、［製品］リストから［VirusScan Enterprise 8.8.0］を選択します。［カテゴリ］リストに、VirusScan Enterprise 8.8.0 のポリシー カテゴリが表示されます。
  2. 既存のポリシーを編集するか、新しいポリシーを作成します。 既存のポリシーの編集
    1. ［カテゴリ］リストから、ポリシー カテゴリを選択します。
    2. ［アクション］列で、［編集］をクリックしてポリシー設定ページを開きます。
    新しいポリシーを作成
    1. ［新規ポリシー］をクリックして［新規ポリシー］ダイアログ ボックスを開きます。
    2. ［この既存ポリシーに基づいて新規ポリシーを作成する］リストから、いずれかの設定を選択します。
    3. 新しいポリシーの名前を入力します。
    4. [OK] をクリックします。新しいポリシーが既存ポリシーのリストに表示されます。
  3. ［設定］リストから、［ワークステーション］または［サーバ］を選択します。
  4. アラート ポリシーのタブを設定します。「アラート ポリシーのタブの設定」を参照してください。


VirusScan コンソール

このユーザ インターフェース コンソールを使用してアラートのプロパティを設定します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. 次のいずれかのプロパティを開いてアラートを設定します。
    • アラート — ［ツール］、［アラート］の順にクリックして、［アラートのプロパティ］ダイアログ ボックスを開きます。
    • バッファ オーバーフロー保護 － ［バッファ オーバーフロー保護］タスクを選択して、［プロパティ］を右クリックして、［バッファ オーバーフロー保護のプロパティ］ダイアログ ボックスを開きます。
    • 配信時の電子メール スキャナ － ［配信時の電子メール スキャナ］タスクを選択して、［プロパティ］を右クリックして、配信時の電子メール スキャナのプロパティ ダイアログ ボックスを開きます。［アラート］タブをクリックします。
  2. アラート ポリシーのタブを設定します。「アラート ポリシーのタブの設定」を参照してください。


アラート ポリシーのタブの設定

タスク 設定
アラート ポリシー

  1. ［アクション］列で、［設定を編集］を選択して［アラート ポリシー］ページを開きます。

  2. ［アラートを生成するコンポーネント］と［Alert Manager のオプション］を設定します。

バッファ オーバーフロー保護ポリシー

  1. ［アクション］列で、［設定を編集］を選択して［バッファ オーバーフロー保護］ページを開きます。

  2. ［クライアント システムの警告］の横で、［バッファ オーバーフローの検出時にメッセージを表示する］をクリックします。

配信時電子メール スキャン ポリシー

  1. ［アクション］列で、［設定を編集］を選択して［バッファ配信時電子メール スキャン ポリシー］ページを開きます。

  2. ［アラート］をクリックして、［ユーザの電子メール アラート］と［アクションを指定メッセージ］を設定します。


クエリおよびダッシュボードへのアクセス

クエリおよびダッシュボードを使用すると、スキャン動作を監視することができ、検出内容に対して実行するアクションを決定するのに役立ちます。クエリおよびダッシュボードは事前定義済みのものだけでなく、必要に応じて新たに作成したものも使用できます。クエリおよびダッシュボードの詳細については、ePolicy Orchestrator 製品マニュアルを参照してください。

クエリ

お使いの ePolicy Orchestrator バージョンに応じて、以下を使用してクエリにアクセスしてください。

ePolicy Orchestrator 4.5 および 4.6
  1. ［メニュー］、［レポート］、［クエリ］の順にクリックして、［クエリ］ページを開きます。
  2. ［クエリ］ペインで、［高速検索］に「VSE:」と入力して、［適用］をクリックします。VirusScan Enterprise のクエリのみがリストに表示されます。
ePolicy Orchestrator 4.0
  1. ［レポート］、［クエリ］の順にクリックして、［クエリ］ページを開きます。
  2. 右側のペインの［クエリ］リストで、スクロール ダウンして「VSE:」で始まるクエリを探します。

事前に定義されたクエリは次のとおりです。

VSE:過去 30 日間の対応状況

VSE:週単位での脅威が検出されたコンピュータ

VSE:現在の DAT の採用

VSE:過去 24 時間での DAT の採用状況

VSE:DAT の導入

VSE:検出対応サマリ

VSE:タグごとの検出数

VSE:過去 24 時間に検出したスパイウェア

VSE:過去 7 日間に検出したスパイウェア

VSE:過去 24 時間に検出した脅威のサマリ

VSE:過去 7 日間に検出した脅威のサマリ

VSE:重大度ごとの脅威の数

VSE:週単位での検出した脅威の名前

VSE:過去 24 時間に検出した脅威

VSE:過去 7 日間に検出した脅威

VSE:過去 2 四半期に検出した脅威

VSE:週単位での検出した脅威

VSE:上位 10 違反のあったアクセス保護ルール

VSE:上位 10 検出されたバッファ オーバーフロー

VSE:上位 10 検出数が最も多いコンピュータ

VSE:上位 10 検出した脅威

VSE:上位 10 脅威源

VSE:上位10 脅威カテゴリごとの脅威

VSE:上位 10 検出数が最も多いユーザ

VSE:過去 24 時間に検出した不審なプログラム

VSE:過去 7 日間に検出した不審なプログラム

VSE:バージョン 8.5 の対応

VSE:バージョン 8.7 の対応

VSE:バージョン 8.8 の対応

ダッシュボード

ePolicy Orchestrator コンソールでダッシュボードにアクセスするには、［ダッシュボード］に移動します。

事前に定義されたダッシュボードは次のとおりです。
  • VSE:バージョン 8.8 の対応
  • VSE:トレンド データ
  • VSE:最新の検出


緊急 DAT の設定

緊急 DAT を手動でダウンロードすることで、通常の VirusScan DAT アップデートがリリースされるまで、お使いのシステムを主要なウイルスから保護できます。
注意: これらの EXTRA.DAT ファイルは、クライアント システムの AutoUpdate の一部として、または ePolicy Orchestrator のスケジュール設定されたプル プロセスの一部として自動的にダウンロードする必要があります。「検出定義のアップデート」を参照してください。
緊急 DAT の設定は、次の 2 つのステップからなるプロセスです。
  1. 緊急 DAT ファイルをダウンロードします。このプロセスは、クライアント システムと ePolicy Orchestrator リポジトリの両方について同じです。
  2. 緊急 DAT ファイルをインストールします。このプロセスは、クライアント システムの場合と ePolicy Orchestrator 4.0 4.5 および 4.6 サーバの場合とで異なります。

ここでは、これらの各プロセスについて説明します。

目次

関連概念
緊急 DAT について
関連タスク
SuperDAT ファイルのダウンロード
ePolicy Orchestrator リポジトリへの SuperDAT ファイルのインストール
クライアント システムへの EXTRA.DAT ファイルのインストール
関連情報
検出定義のアップデート


緊急 DAT について

緊急 DAT は、EXTRA.DAT という名前のファイルであり、VirusScan Enterprise が新種のウイルスを検出するために使用する情報を含んでいます。新たなマルウェアが発見されて、追加の検出が必要な場合は、通常の VirusScan Enterprise DAT アップデートがリリースされるまで、SuperDAT（SDAT）実行ファイル内にパッケージ化された EXTRA.DAT ファイルが McAfee ラボによって提供されます。
注意: McAfee は、現在は Security Updates ダウンロード サイトに個別の EXTRA.DAT ファイルを公開していません。特定の脅威に対応する EXTRA.DAT ファイルを取得するには、McAfee Avert Labs Extra.dat Request Page（https://www.webimmune.net/extra/getextra.aspx）にアクセスしてください。

SuperDAT パッケージ

SuperDAT の実行ファイルは、自己インストール型パッケージです。このファイルには、新しいウイルス スキャン エンジンや他のプログラム コンポーネントが含まれている場合もあります。このファイルの名前は sdatXXXX.exe という形式であり、XXXX は 4 桁の DAT バージョン番号です（例: sdat4321.exe）。

SuperDAT の実行ファイルから EXTRA.DAT ファイルを抽出して、ハード ディスク上のエンジン フォルダに追加すると、VirusScan Enterprise は、通常の DAT ファイルに加えてこの EXTRA.DAT ファイルを使用して、新たなウイルスを検出します。これにより、マルウェアを検出/削除するための情報が含まれた正式な DAT アップデートがリリースされるまで、VirusScan Enterprise によってご使用のコンピュータが新たなマルウェア コードから保護されます。正式な DAT アップデートがリリースされてインストールされると、この EXTRA.DAT ファイルは不要になります。

注意: EXTRA.DAT ファイルは、5 日間だけファイル システム上に保持されてから、自動的に削除されます。正式な日次アップデートを自動的にダウンロードおよびインストールすることで、VirusScan Enterprise の DAT ファイルを最新状態に保つことをお勧めします。


SuperDAT ファイルのダウンロード

SuperDAT（SDAT）ファイルをダウンロードするには、McAfee Security Updates ページに接続する必要があります。

作業の前に

  • McAfee Security Updates ページにアクセスするための有効な承認番号が必要です。http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  • McAfee ソフトウェアを更新するための管理者権限が必要です。

タスク

  1. 次の URL にある McAfee Security Updates ページにアクセスします。http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  2. ［SuperDATs］タブをクリックして、sdatXXXX.exe ファイルをダブルクリックします（XXXX は最新の DAT アップデートの番号です）。
    注意: readme.txt ファイルをダブルクリックして追加情報を参照します。
  3. この実行ファイルをデフォルト名のまま一時的な場所に保存します。


ePolicy Orchestrator リポジトリへの SuperDAT ファイルのインストール

SuperDAT ファイルをダウンロードしたら、このファイルを ePolicy Orchestrator サーバにインストールする必要があります。

作業の前に

McAfee ソフトウェアを更新するための管理者権限が必要です。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. SuperDAT ファイルを ePolicy Orchestrator サーバにインストールするには、次のいずれかの手順を実行します。
    サーバ 手順
    ePolicy Orchestrator 4.5 および 4.6
    1. ePolicy Orchestrator 4.5 および 4.6 コンソールで、［メニュー］、［ソフトウェア］、［マスター リポジトリ］の順にクリックして、［マスター リポジトリのパッケージ］ページを開きます。
    2. ［アクション］、［パッケージのチェックイン］の順にクリックします。
    ePolicy Orchestrator 4.0
    1. ［ソフトウェア］、［マスター リポジトリ］の順にクリックして、［マスター リポジトリのパッケージ］ページを開きます。
    2. ［パッケージのチェックイン］をクリックして、［パッケージのチェックイン］ページを開きます。
  2. ［Super DAT (EXE)］を選択して、ファイルの保存場所に移動して、［次へ］をクリックします。
  3. 選択内容を確認してから、［保存］をクリックします。［マスター リポジトリのパッケージ］ページの［名前］リストに、新しい DAT パッケージが表示されます。


クライアント システムへの EXTRA.DAT ファイルのインストール

McAfee ラボから EXTRA.DAT ファイルをダウンロードしたら、このファイルをスタンドアロン クライアント システムにインストールできます。EXTRA.DAT ファイルのダウンロード情報については、「緊急 DAT について」を参照してください。

作業の前に

McAfee Security ソフトウェアを更新するための管理者権限が必要です。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ダウンロードが完了したら、保存した実行ファイルを探して実行し、ウィザードの指示に従ってください。 EXTRA.DAT ファイルを実行すると、次のステップが実行されます。
    • McAfee のメモリ常駐ソフトウェアをアンロードするか、現在の DAT ファイルを使用しているサービスを停止します。
    • 新しい DAT ファイルを適切なプログラム ディレクトリにコピーします。
    • 新しい DAT ファイルを使用してスキャンを継続するために必要なソフトウェア コンポーネントを再始動します。
  2. インストーラによる DAT ファイルの更新が完了したら、ダウンロードしたファイルを削除することも、後続の更新のために保持することもできます。


パート IV － 保護状況の監視、分析、および微調整

保護戦略を初期設定したら、保護状況を監視、分析、および微調整する必要があります。動作ログ ファイルと ePolicy Orchestrator のクエリをチェックすることで、VirusScan Enterprise システムのパフォーマンスと保護能力を向上させることができます。

目次

  • 環境内の動作の監視
  • 保護状況の分析


環境内の動作の監視

保護戦略における重要な 1 ステップは、お使いのシステムで発生するマルウェア イベントを監視することです。このためには、使用するツールとそれらの使用方法を理解する必要があります。


動作監視用のツール

VirusScan Enterprise は、保護対象システム上で発生する脅威イベントを監視するためのさまざまな方法を提供します。使用するツールは、ePolicy Orchestrator コンソールを使用しているのか、VirusScan コンソール を使用しているのかによって異なります。


クエリとダッシュボードの使用

ePolicy Orchestrator のクエリとダッシュボードを使用して、McAfee 管理対象システム上の動作を監視して、検出時に実行するアクションを決定します。

クエリとダッシュボードの詳細については、以下を参照してください。
  • 使用可能な事前定義済みクエリの全リストについては、「クエリおよびダッシュボードへのアクセス」を参照してください。
  • クエリとダッシュボードの変更と作成については、ePolicy Orchestrator の製品マニュアルを参照してください。
関連情報
クエリおよびダッシュボードへのアクセス


動作ログの使用

VirusScan コンソール の動作ログには、VirusScan Enterprise の保護対象システムで発生したイベントの記録が保管されます。次の表では、これらのログ ファイルについて説明しています。

すべての動作ログ ファイルは、お使いのオペレーティング システムに応じて、次のいずれかの場所にデフォルトで保管されます。
  • Microsoft Windows XP、Microsoft Vista、Microsoft 2000 Server、Microsoft 2003 Server、および Microsoft 2008 Server の場合 － C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7 の場合 － C:\ProgramData\McAfee\DesktopProtection
表 1. ログ ファイル
ファイル名 | アクセス方法 | 表示内容
AccessProtectionLog.txt | ［タスク］列で、［アクセス保護］、［レポート］タブの順にクリックして、［ログの表示］をクリックします。 | 日付、時刻、イベント、ユーザ、ファイル名
BufferOverflowProtectionLog.txt | ［タスク］列で、［バッファ オーバーフロー保護］、［レポート］タブの順にクリックして、［ログの表示］をクリックします。 | 日付、時刻、オーバーフローを発生させた実行ファイル、スタック オーバーフローなのかヒープ オーバーフローなのか
MirrorLog.txt
  • Microsoft Windows XP、Microsoft Vista、Microsoft 2000 Server、Microsoft 2003 Server、および Microsoft 2008 Server の場合 － C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7 の場合 － C:\ProgramData\McAfee\DesktopProtection
日付、時刻、ミラー ファイルのパス、追加情報
OnAccessScanLog.txt | ［タスク］列で、［オンアクセス スキャナ］、［全般設定］、［レポート］タブの順にクリックして、［ログの表示］をクリックします。 | 日付、時刻、検出されたマルウェア、実行されたアクション、検出された内容
OnDemandScanLog.txt | メニューから、［タスク］、［ログの表示］の順にクリックします。 | 日付、スキャンが実行された時刻、実行されたアクション、対象ファイル、検出された内容
UpdateLog.txt
  • Microsoft Windows XP、Microsoft Vista、Microsoft 2000 Server、Microsoft 2003 Server、および Microsoft 2008 Server の場合 － C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7 の場合 － C:\ProgramData\McAfee\DesktopProtection
日付、更新時刻、更新を開始したユーザ、更新に関する情報


サンプル クエリの実行

単純なクエリを実行して、お使いの管理対象システム上で 1 週間に検出された脅威の数を確認します。このクエリは単なる例です。実行または設定するクエリは、ePolicy Orchestrator データベースから取得しようとしている情報によって異なります。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. 次のいずれかの方法で単純な ePolicy Orchestrator クエリを実行します。
    • ePolicy Orchestrator 4.5 または 4.6 － ［メニュー］、［レポート］、［クエリ］の順にクリックして、［VSE: 週単位での検出した脅威］クエリまでスクロール ダウンして、［実行］をクリックします。
    • ePolicy Orchestrator 4.0 － ［レポート］、［クエリ］の順にクリックして、［VSE: 週単位での検出した脅威］クエリまでスクロール ダウンして、［実行］をクリックします。
  2. 脅威が検出された場合は、このクエリの出力では以下が表示されます。
    • 脅威の数とこれらが発生した週を示す棒グラフ
    • 同様の情報と脅威の総数を示す表
    注意: 棒グラフや表内の情報をクリックすると、 ePolicy Orchestrator データベースのデータが表示されます。
  3. ［閉じる］をクリックしてクエリ リストに戻ります。
他にもさまざまなデフォルト クエリを実行できるとともに、独自のクエリを作成することもできます。詳細については、ePolicy Orchestrator 製品マニュアルを参照してください。


保護状況の分析

VirusScan Enterprise によって保護されたシステムの保護状況を分析することは、継続的に実行すべきプロセスであり、システムの保護強化とパフォーマンス向上に役立ちます。

目次

関連概念
分析の重要性
関連タスク
保護状況の分析例


分析の重要性

保護状況を分析することで、直面している脅威の種類、発生源、検知頻度、およびターゲット システムを特定できます。たとえば、あるシステムが継続的に攻撃されている場合は、おそらく、そのシステムをネットワーク内のより安全な領域に移動して、そのシステムを保護するためにセキュリティを強化する必要があります。

この分析は次の場合にも役立ちます。
  • IT 部門およびマネージャ向けのレポートを作成する。
  • スクリプトとクエリを作成するための情報を取得する。
  • ネットワーク アクセス時刻と VirusScan Enterprise アップデートのネットワーク使用状況を監視する。


保護状況の分析例

これらの分析例のステップは、ほとんどの VirusScan Enterprise 保護シナリオを分析するためのフレームワークとして使用できます。

これらの例では、マルウェアによる突発的な攻撃が発生して、以下を特定する過程を記述しています。
  • 攻撃が発生した場所と時刻
  • 攻撃で使用されたマルウェアの種類
  • 攻撃がシステムに与えた影響

タスク

関連タスク
ePolicy Orchestrator 4.5 または 4.6
ePolicy Orchestrator 4.0
VirusScan コンソール


ePolicy Orchestrator 4.5 または 4.6

この分析例は、ePolicy Orchestrator 4.5 または 4.6 を使用したほとんどの VirusScan Enterprise の保護シナリオを分析するためのフレームワークとして使用されます。

作業の前に

この分析例を実行するには、VirusScan Enterprise によって保護されたシステムに直接またはリモートでアクセスできる必要があります。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. 攻撃が発生した場所と時刻を特定します。
    1. ［メニュー］、［レポート］、［クエリ］の順にクリックして、［クエリ］ペインを開きます。
    2. ［高速検索］に「マルウェア」と入力して、［適用］をクリックします。［クエリ］リストに、［マルウェアの検出履歴］クエリが表示されます。
    3. 該当するクエリを選択して［アクション］、［実行］の順にクリックします。クエリによって最近の攻撃の数が返されます。
  2. 攻撃で使用されたマルウェアの種類を確認するには、［メニュー］、［レポート］、［脅威イベント ログ］の順にクリックして、［脅威イベント ログ］を表示します。
  3. ログ イベントをダブルクリックして、ペイン内に詳細ページを表示します。ログ イベントから、次のことを特定できます。
    • 表示される［脅威ソース IP アドレス］とターゲットは、どのアクションを実行すべきか特定するのに役立ちます。
    • ［脅威名］と［脅威タイプ］では、攻撃で使用されたマルウェアが示されます。
    • ［脅威イベントの説明］では、攻撃がシステムに与えた影響と、脅威に対して実行されたアクションが示されます。


ePolicy Orchestrator 4.0

この分析例は、ePolicy Orchestrator 4.0 を使用したほとんどの VirusScan Enterprise の保護シナリオを分析するためのフレームワークとして使用されます。

作業の前に

この分析例を実行するには、VirusScan Enterprise によって保護されたシステムに直接またはリモートでアクセスできる必要があります。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. 攻撃が発生した場所と時刻を特定します。
    1. ［レポート］、［クエリ］の順にクリックして、［クエリ］リストを開きます。
    2. ［公開クエリ］リストで、［ePO：マルウェアの検出履歴］を選択して、［その他のアクション］、［実行］の順にクリックします。［クエリ］リストに、［マルウェアの検出履歴］クエリが表示されます。
  2. マルウェアの検出をトリガしたイベントを表示するには、［レポート］、［イベント ログ］の順にクリックして、クエリによって返される最近の攻撃の数を表示します。
  3. ログ イベントをダブルクリックして、ペイン内に詳細ページを表示します。ログ イベントから、次のことを特定できます。
    • 表示される［脅威ソース IP アドレス］とターゲットは、どのアクションを実行すべきか特定するのに役立ちます。
    • ［脅威名］と［脅威タイプ］では、攻撃で使用されたマルウェアが示されます。
    • ［脅威イベントの説明］では、攻撃がシステムに与えた影響と、脅威に対して実行されたアクションが示されます。


VirusScan コンソール

この分析例は、VirusScan コンソール を使用したほとんどの VirusScan Enterprise の保護シナリオを分析するためのフレームワークとして使用されます。

作業の前に

この分析例を実行するには、VirusScan Enterprise によって保護されたシステムに直接またはリモートでアクセスできる必要があります。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. ［タスク］リストで、［オンアクセス スキャナ］を右クリックして、リストから［統計］を選択します。［オンアクセス スキャン統計］ダイアログ ボックスが表示されます。
  2. ［スキャンの統計］グループで、表示される検出ファイル数をメモします。この数が 0 でない場合は、［プロパティ］クリックして［オンアクセス スキャンのプロパティ］ダイアログ ボックスを開きます。
  3. ［レポート］タブをクリックして、［ログの表示］をクリックします。メモ帳のウィンドウが開いて、OnAccessScanLog.txt ファイルが表示されます。
  4. この出力から次のことを確認できます。
    • 攻撃で使用されたマルウェアの種類以下に例を示します。
      C:\...\eicar.com	EICAR テスト ファイル
    • 攻撃がシステムに与えた影響以下に例を示します。
      （検出対象が駆除不能であるため、駆除に失敗）
    • 脅威に対して実行されたアクション以下に例を示します。
      削除しました
  5. 上記のステップの情報に基づいて、ソースまたはターゲット システムのウイルス保護設定を変更する必要があるのか、または他のアクションを実行する必要があるのかを判断します。


付録

これまでに紹介した以外の設定機能やトラブルシューティング機能を使用して、VirusScan Enterprise による保護を強化できます。これらの機能では、ePolicy Orchestrator コンソール、コマンドライン、インターネットなどの使い慣れたツールが使用されます。

目次

  • ePolicy Orchestrator のサーバ タスクの設定
  • VirusScan Enterprise でのコマンド ラインの使用
  • リモート システムへの接続
  • 分析用の脅威サンプルの送信
  • McAfee ラボの脅威ライブラリへのアクセス
  • トラブルシューティング


ePolicy Orchestrator のサーバ タスクの設定

ePolicy Orchestrator で設定されるサーバ タスクを使用すると、お使いのサーバと VirusScan Enterprise ソフトウェアを管理するための自動タスクをスケジュール設定して実行できます。

VirusScan Enterprise のサーバ タスクは、以下を自動的に生成するように設定できます。
  • ポリシーをエクスポート － ポリシー レポートを実行して、ポリシー情報をファイルに保存します。
  • クエリを実行 － 事前設定済みのクエリを実行して（設定されている場合）、その出力を ePolicy Orchestrator ダッシュボードに表示します。
  • クエリのエクスポート － 事前設定済みのクエリを実行して、レポートを指定された電子メール アドレスに送信するか、指定された場所にエクスポートします。
    注意: ［クエリのエクスポート］機能は、ePolicy Orchestrator 4.5 および 4.6 を使用している場合にのみ使用できます。
ePolicy Orchestrator サーバには、次の VirusScan Enterprise サーバ タスクがあらかじめインストールされています。
  • VSE: 過去 30 日間の対応状況 － クエリを 1 日に 1 回実行して、McAfee ウイルス対策ソフトウェアの対応状況を記録します。
  • VSE: 過去 24 時間での DAT の採用状況 － クエリを 1 時間に 1 回実行して、McAfee ウイルス対策ソフトウェアの DAT バージョン状況を記録します。
注意: カスタム サーバ タスクの設定の詳細については、該当する ePolicy Orchestrator 製品ガイドを参照してください。


サンプル サーバ タスクの設定

ePolicy Orchestrator の既存の［VSE: 過去 30 日間の対応状況］サーバ タスクを有効化および設定するには、次のタスクを実行します。

作業の前に

ePolicy Orchestrator の設定を更新するための管理者権限が必要です。

タスク

オプションの定義については、インターフェースの［?］をクリックしてください。

  1. ePolicy Orchestrator から既存の［サーバ タスク］ページを開きます。
    • ePolicy Orchestrator 4.5 または 4.6 － ［メニュー］、［自動処理］、［サーバ タスク］の順にクリックします。
    • ePolicy Orchestrator 4.0 － ［自動処理］、［サーバ タスク］の順にクリックします。
  2. ［名前］列で［VSE: 過去 30 日間の対応状況］タスクを探して、［アクション］列で［編集］をクリックします。［サーバ タスク ビルダ］ページが表示されます。
  3. ［スケジュール ステータス］の横にある［有効］をクリックし、［次へ］をクリックします。[アクション] ページが表示されます。 ［1. アクション］の横で、［クエリを実行］がデフォルトで選択されています。
  4. ［クエリ］の横で、［VSE: バージョン 8.8.0 順守状況］がデフォルトで選択されています。必要に応じて［言語］設定を変更します。 ［サブアクション］グループで、次の項目がデフォルトで選択されていることを確認します。
    • ［サブアクション］リスト内の［順守状況イベントを生成］
    • テキストボックスに「1」が入力された［ターゲット システムの一定値］
  5. VirusScan Enterprise のバージョン 8.7 および 8.5 のコンプライアンス アクションをこのサーバ タスクに追加します。
    1. ［1. アクション］行で、プラス記号（+）をクリックして追加のアクション行を開きます。
    2. 新しい［2. アクション］行で以下を設定します。
      • ［2. アクション］の横で、［クエリを実行］をリストから選択します。
      • ［クエリ］の横で、［VSE: バージョン 8.7 順守状況］をリストから選択します。
      • 必要に応じて［言語］設定を変更します。
      • ［サブアクション］グループで、［順守状況イベントを生成］と、テキストボックスに「1」が入力された［ターゲット システムの一定値］が選択されていることを確認します。
    3. ［2. アクション］行で、プラス記号（+）をクリックして追加のアクション行を開きます。
    4. 新しい［3. アクション］行で以下を設定します。
      • ［3. アクション］の横で、［クエリを実行］をリストから選択します。
      • ［クエリ］の横で、［VSE: バージョン 8.5 順守状況］をリストから選択します。
      • 必要に応じて［言語］設定を変更します。
      • ［サブアクション］グループで、［順守状況イベントを生成］と、テキストボックスに「1」が入力された［ターゲット システムの一定値］が選択されていることを確認します。
  6. [次へ] をクリックして、[スケジュール] ページを表示します。
  7. ［スケジュール タイプ］リストから、このサーバ タスクの実行頻度を選択します。
    • ［開始日］を設定するか、現在の日付をデフォルトとして使用します。
    • ［終了日］を設定するか、［終了日を指定しない］をデフォルトとして使用します。
    • ［スケジュール］を設定するか、デフォルトをそのまま使用するか、クエリを実行するための別の開始時刻を設定します。
  8. ［次へ］をクリックして［サマリ］ページを開きます。設定されている情報が正しいことを確認します。
  9. ［保存］をクリックして、［サーバ タスク］ページを再び表示します。
  10. ［VSE: 過去 30 日間の対応状況］サーバ タスクについて、［ステータス］が有効化されていること、および［次回の実行］の日付と時刻の設定が正しいことを確認します。


VirusScan Enterprise でのコマンド ラインの使用

コマンド プロンプトを使用して、VirusScan Enterprise のいくつかの基本的なプロセスを実行できます。コマンド ラインから、VirusScan Enterprise をインストール、設定、および更新できます。コマンド ラインのインストール オプションの詳細については、『VirusScan Enterprise インストール ガイド』を参照してください。

コマンド ラインを使用したスキャン例

すべてのファイルをスキャンして、スキャン結果に基づいてログ ファイルを更新して、完了時にオンデマンド スキャンのダイアログ ボックスを自動的に閉じるには、次のコマンドを入力します。

scan32 /all /log /autoexit

コマンド ラインを使用した更新例

McAfee Update のダイアログ ボックスを表示することなく、DAT ファイル、スキャン エンジン、および製品を更新するには、次のコマンドを入力します。

mcupdate /update /quiet


オンデマンド スキャンのコマンドライン オプション

VirusScan Enterprise は、SCAN32.EXE というオンデマンド スキャナを使用して脅威を検出します。同じコマンドの SCAN32 をコマンド ラインから実行するか、バッチ ファイルの一部として実行することで、スキャンを実行できます。

SCAN32 構文では、プロパティと値を分割してはいけないこと以外、要素に特定の順序を必要としません。この構文は次の要素で構成されます。
  • ファイル名 — 実行可能ファイルの名前 : SCAN32.EXE
  • オプション — オプションの前にはスラッシュ (/) が付き、大文字小文字の区別はありません。
このコマンドの書式は次のとおりです。

SCAN32 PROPERTY=VALUE [,VALUE] [/option]

次に scan32.exe コマンドの実行例を示します。

scan32.exe PRIORITY /normal

この例の内容は次のとおりです。
  • 「PRIORITY」はコマンド値です。
  • 「/normal」は値オプションです。

オンデマンド スキャンの値とオプション

コマンドライン値 定義とオプション

ALL

対象フォルダ内のすべてのファイルをスキャンします。

ALLOLE

デフォルト ファイルとすべての Microsoft Office ドキュメントをスキャンします。

ALWAYSEXIT

スキャンでエラーが発生または失敗しても、オンデマンド スキャンを強制終了します。

APPLYNVP

不審なプログラム ポリシーで定義された、怪しいプログラムをスキャンします。

ARCHIVE

.ZIP、.CAP、.LZH、.UUE ファイルなどのアーカイブ ファイルをスキャンします。

AUTOEXIT

非対話型スキャン終了時にオンデマンド スキャナを終了します。

CLEAN

怪しいプログラムを発見した場合、検出した対象ファイルを駆除します。

CLEANA

不審なプログラムを発見した場合、検出したファイルを駆除します。

CONTINUE

怪しいプログラムを検出した後にスキャンを続行します。

CONTINUE2

怪しいプログラムを検出し、最初のアクションに失敗した後にスキャンを続行します。

CONTINUEA

不審なプログラムを検出した後にスキャンを続行します。

CONTINUEA2

不審なプログラムを検出し、最初のアクションに失敗した後にスキャンを続行します。

DEFEXT

パラメータとして指定するファイル拡張子を、スキャンに含まれる選択したファイルの種類のリストに追加します。

DELETE

怪しいプログラムを発見した場合、検出したファイルを削除します。

DELETE2

怪しいプログラムを発見し、最初のアクションに失敗した場合に、検出したファイルを削除します。

DELETEA

不審なプログラムが検出された場合にファイルを削除します。

DELETEA2

怪しいプログラムを検出し、最初のアクションに失敗した場合に、ファイルを削除します。

EDIT

スキャン プロパティのダイアログ ボックスを表示します。

EXT

スキャンに含まれる選択したファイルの種類のリストにある拡張子を、この引数の後にパラメータとして追加するファイル拡張子と置き換えます。

LOG

以前に指定したログ ファイルに検出レポートのログを記録します。

LOGFORMAT <値>

ログ ファイルに指定した形式を使用します。有効な値は、ANSI、UTF8、または UTF16 です。

LOGSETTINGS

スキャンの構成設定をログに記録します。

LOGSUMMARY

スキャン結果のサマリをログに記録します。

LOGUSER

スキャンを実行するユーザについての識別情報をログに記録します。

MHEUR

マクロ ウイルスの Artemis 検出を有効にします。

MIME

mime (多目的インターネット メール拡張仕様) でエンコードされたファイルで怪しいプログラムを検出します。

NOESTIMATE

ファイルのスキャンを開始する前にスキャン サイズを計算しません。進行状況を示す棒グラフは表示されません。

PHEUR

マクロ ウイルス以外の Artemis 検出を有効にします。

PRIORITY

他の CPU 処理と相対してスキャンの優先順位を設定します。次のいずれかのオプションを指定する必要があります。
  • LOW
  • BELOWNORMAL — ePolicy Orchestrator のデフォルトです。
  • NORMAL — VirusScan コンソール のデフォルトです。
注意: 代わりに 1 ～ 100 までの数値パラメータを指定することもできます。この場合、10 は LOW に相当し、50 は BELOWNORMAL に相当し、100 は NORMAL に相当します。

PROMPT

怪しいプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。

PROMPT2

怪しいプログラムを検出し、最初のアクションに失敗した場合に、ユーザにアクションを促すメッセージを表示します。

PROMPTA

不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。

PROMPTA2

不審なプログラムを検出し、最初のアクションに失敗した場合に、ユーザにアクションを促すメッセージを表示します。

RPTSIZE

アラート ログのサイズを MB 単位で設定します。

START

スキャンを実行します。プロパティ ダイアログ ボックスは表示しません。

TASK

VirusScan コンソールで指定されたオンデマンド スキャン タスクを開始します。次の場所にあるレジストリに記録された指定タスク ID を指定する追加パラメータが必要です。hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks

UINONE

ユーザ インターフェース ダイアログを表示せずにスキャナを起動します。


アップデート タスクのコマンドライン オプション

VirusScan Enterprise では、MCUPDATE.EXE を使用してタスクのアップデートを実行します。同じコマンドの MCUPDATE をコマンド ラインから実行するか、バッチ ファイルの一部として実行することで、アップデート タスクを実行できます。

MCUPDATE 構文では、プロパティと値を分割してはいけないこと以外、要素に特定の順序を必要としません。構文は次の要素で構成されます。
  • ファイル名 — 実行可能ファイルの名前 : MCUPDATE.EXE
  • オプション — オプションの前にはスラッシュ (/) が付き、大文字小文字の区別はありません。
このコマンドの書式は次のとおりです。
MCUPDATE [/<type> [/TASK <guid>]] [/option].
注意: 上記の書式で、<type> には ROLLBACKDATS または UPDATE を指定できます。

/TASK 句はオプションです。ただしこの句を指定する場合は、アップデート タスク ID（guid）も指定する必要があります。選択するタスク ID は、アップデート タスクまたは DAT のロールバック タスクの ID である必要があります。スキャン ID は選択しないでください。タスク ID を指定しない場合は、デフォルトのアップデート タスクが使用されます。タスク ID は次の場所にあります。hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

/option 句は必須ではありません。サイレント アップデート タスクを実行するには、/QUIET を使用します。
注意: /QUIET オプションを DAT のロールバック タスクで使用することはできません。次の例では、サイレント アップデート タスクを実行します。MCUPDATE /UPDATE /QUIET

アップデート タスクのオプション

コマンドライン オプション | 定義
ROLLBACKDATS | 現在の DAT ファイルを、最後にバックアップしたバージョンにロールバックします。
UPDATE | DAT ファイル、スキャン エンジン、製品、または extra.dat のアップデートを実行します。
/TASK | VirusScan コンソールで指定された AutoUpdate または DAT のロールバック タスクを開始します。次の場所にあるレジストリに記録されたタスク ID を指定する追加のパラメータが必要です。 hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | タスクをサイレントに実行します。


リモート システムへの接続

VirusScan Enterprise がインストールされたリモート システムに接続して、スキャン タスクやアップデート タスクの変更やスケジュール設定、またはリモート システム上のオンアクセス スキャナの有効化/無効化などの操作を実行できます。
注意: 管理者権限のないユーザがリモート システムへの接続を試行すると、「必要な権限がありません。アクセスが拒否されました。」というメッセージが表示されます。

[VirusScan リモート コンソール] を起動すると、接続しているシステムの名前がコンソールのタイトル バーに表示されます。ネットワーク上のシステムに接続していない場合には、タイトル バーにローカル システム名は表示されません。リモート コンソールからタスクのプロパティ ダイアログ ボックスを開くと、プロパティ ダイアログ ボックスのタイトル バーにシステム名が表示されます。

複数のリモート コンソールを開くことができます。［リモート コンピュータに接続］ダイアログ ボックスを閉じると、リモート システムとの接続も切断されます。


VirusScan Enterprise がインストールされているリモート システムへのアクセス

VirusScan Enterprise がインストールされたリモート システムに管理目的のために接続するには、VirusScan コンソール で［リモート コンソールを開く］オプションを使用します。

タスク

オプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

  1. VirusScan Enterprise 8.8 コンソールの［ツール］メニューから、［リモート コンソールを開く］を選択します。
  2. ［コンピュータに接続］の下で、管理するシステムの名前を入力し、リストからシステムを選択するか、 ［参照］をクリックしてネットワーク上のシステムを探して選択します。
    注意: リモート タスク用にファイルまたはフォルダのパス名を設定するときに環境変数を使用する場合は、リモート システム上にその環境変数が存在することを確認してください。VirusScan Enterprise 8.8 コンソールでは、リモート システム上の環境変数を確認することはできません。
  3. [OK] をクリックして対象のシステムへの接続を試行します。 リモート システムに接続すると、次のことが起こります。
    • タイトル バーにはそのシステムの名前が表示されます。
    • コンソールはリモート システムのレジストリを読み込み、リモート システムのタスクを表示します。
    • リモート システム用のタスクを追加、削除、再設定することができます。


分析用の脅威サンプルの送信

現在の DAT ファイルを使用して、スキャナが潜在的な脅威を検出できなかった場合や脅威でないものを誤検出した場合は、そのサンプルを WebImmune を通じて McAfee ラボに送信できます。McAfee ラボはそのサンプルを分析して、それを次回の DAT ファイルに含めるか、または次回の DAT ファイルから除外するかを検討します。

McAfee ラボにサンプルを送信するには、WebImmune Web サイト経由、電子メール、または郵送という 3 つの方法があります。

WebImmune

  1. VirusScan コンソールから、［ヘルプ］、［サンプルの送信］の順に選択してこの Web サイトにアクセスします。Web サイトは次の場所にあります。https://www.webimmune.net/default.asp
  2. フリー アカウントにログオンするか、またはフリー アカウントを作成します。
  3. 分析を依頼するファイルを McAfee ラボの自動システムに直接アップロードします。さらに調査が必要な場合、アイテムは McAfee Labs の分析担当者にエスカレーションされます。

電子メール

分析を依頼する電子メールを McAfee ラボの自動システムに直接送信してください。さらに調査が必要な場合、アイテムは McAfee ラボの分析担当者にエスカレーションされます。

グローバル電子メール アドレスは virus_research@avertlabs.com です。
注意: WebImmune の Web サイトから、その他のリージョナル アドレスを取得することもできます。

郵便

WebImmune の Web サイトから送付先情報を取得してください。
注意: この方法は、サンプル解析の所要時間が最も長くなるため、あまりお勧めできません。


McAfee ラボの脅威ライブラリへのアクセス

VirusScan Enterprise 8.8 コンソールから McAfee ラボの脅威ライブラリにアクセスするには、［ヘルプ］メニューから［McAfee Labs 脅威ライブラリ］を選択します。お使いのインターネット ブラウザが開いて、http://vil.nai.com/vil/default.aspx に接続されます。


トラブルシューティング

McAfee のテクニカル サポートに連絡する前に、このセクションの情報をお読み下さい。このセクションでは、VirusScan Enterprise の設定をトラブルシューティングするためのプロセスとツール、およびよく寄せられる質問を紹介しています。


製品インストール内容の修復

場合によっては、デフォルト設定を復元したりプログラム ファイルを再インストールしたりするために、VirusScan Enterprise のインストール内容を修復することが必要になります。この操作は、VirusScan コンソール またはコマンドラインから実行できます。

VirusScan コンソール の使用

［修復インストール］ユーティリティを使用するには、VirusScan Enterprise 8.8 コンソールから［ヘルプ］、［修復インストール］の順に選択します。
注意: この機能は ePolicy Orchestrator コンソールからは使用できません。
オプション | 定義
すべての設定をデフォルトに戻す | VirusScan Enterprise のデフォルトのインストール設定を復元します。 警告: インストール後に変更した設定は無効になります。
アプリケーション ファイルをすべて再インストールする | VirusScan Enterprise のアプリケーション ファイルを再インストールします。 警告: HotFix、パッチ、およびサービス パックは上書きされることがあります。

コマンド ラインでの SETUPVSE.exe の使用

コマンド ラインから SETUPVSE.exe コマンドを使用して VirusScan Enterprise を修復または再インストールするには、次のコマンドを使用します。
注意: REINSTALLMODE のコマンド ライン パラメータ オプションについては、http://msdn.microsoft.com/en-us/library/aa371182(VS.85).aspx で「REINSTALLMODE Property」を参照してください。
説明 | コマンド
プログラム ファイルのみをインストール | SETUPVSE.exe REINSTALLMODE=sec /q
レジストリ ファイルのみをインストール | SETUPVSE.exe REINSTALLMODE=secum /q
プログラム ファイルとレジストリ ファイルの両方をインストール | SETUPVSE.exe REINSTALLMODE=amus /q

コマンド ラインでの msiexec.exe の使用

コマンド ラインから msiexec.exe コマンドを使用して VirusScan Enterprise を修復または再インストールするには、次のコマンドを使用します。
注意: msiexec.exe のコマンド ライン オプションについては、http://support.microsoft.com/kb/314881 で「The Command-Line Options for the Microsoft Windows Installer Tool Msiexec.exe」を参照してください。
説明 | コマンド
プログラム ファイルのみをインストール | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=sa /q REBOOT=R
レジストリ ファイルのみをインストール | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=mu /q REBOOT=R
プログラム ファイルとレジストリ ファイルの両方をインストール | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=samu /q REBOOT=R


オンアクセス動作ログ ファイルの表示

VirusScan コンソール のオンアクセス動作ログ ファイルには、更新履歴、脅威の活動履歴、および VirusScan Enterprise の対処内容の履歴が記録されています。これらの情報は、自動更新動作とポリシーの設定をトラブルシューティングする際に役立ちます。

オンアクセス動作ログ ファイルにアクセスするには、次のいずれかの手順を実行してください。
注意: オンアクセス動作ログ ファイルの作成を有効にしている必要があります。オンアクセス動作ログ ファイルを有効にするには、「全般設定」を参照してください。

タスク

オプションの定義については、各タブで［ヘルプ］をクリックしてください。
  1. ［タスク］リストで、［オンアクセス スキャナ］を右クリックして、［プロパティ］をクリックしてダイアログ ボックスを開きます。
  2. ［オンアクセス スキャンのプロパティ］ダイアログ ボックスで、［レポート］タブをクリックして、［ログの表示］をクリックします。メモ帳のウィンドウが開いて、OnAccessScanLog.txt ファイルが表示されます。次にこのログ ファイルの出力例を示します。

  3. 次の表では、上記の OnAccessScanLog.txt ファイル例のデータを説明しています。
    ログ エントリの例 | 説明
    4/27/2010 | 日付
    1:35:47 PM | 時刻
    Cleaned/Deleted/No Action Taken | 実行されたアクション
    更新されたファイル = バージョン、または (Clean failed because... | アクションの説明
    SRVR\user | 資格情報
    C:\WINDOWS\system32\NOTEPAD.EXE C:\temp\eicar.com | 脅威ファイルのパスと名前
    EICAR test file (Test) | ファイルの説明

同様の情報を ePolicy Orchestrator のクエリを使用して取得できます。詳細については、「クエリおよびダッシュボードへのアクセス」を参照してください。

関連タスク
全般設定
関連情報
クエリおよびダッシュボードへのアクセス


トラブルシューティング時の MER ツールの使用

最小エスカレーション要件（MER）ツールは、McAfee VirusScan Enterprise および他の McAfee 製品のデータをコンピュータから収集します。このデータを使用して、McAfee テクニカル サポートはユーザ側で発生している問題を分析して解決できます。

WebMER ツールは、次のいずれかのファイル形式でダウンロードできます。
  • EXE
  • ZIP
  • ProtectedZip
WebMER ツールによって次のような情報が収集されます。
  • レジストリの詳細情報
  • ファイル バージョンの詳細情報
  • ファイル
  • イベント ログ
  • プロセスの詳細情報
WebMER ツールを使用するには、以下を実行する必要があります。
  • https://kc.mcafee.com/corporate/index?page=content&id=TU30146 にアクセスして『Obtaining Minimum Escalation Requirements using McAfee WebMER』チュートリアルを参照してください。
  • http://mer.mcafee.com からこのツールをダウンロードしてインストールしてください。
    注意: ePolicy Orchestrator によって配備可能なバージョンも提供されています。このバージョンでは、ePolicy Orchestrator コンソールを使用して MER をクライアント コンピュータ上で実行して、McAfee 製品の問題を診断する際にログと情報を収集します。ePolicy Orchestrator 4.x（v2.0）用の McAfee MER は http://mer.mcafee.com/enduser/downloadepomer.aspx からダウンロードしてください。
  • このツールを実行して、その出力を McAfee テクニカル サポートに送信してください。


トラブルシューティング時の VirusScan Enterprise の無効化

システムで発生した問題が、VirusScan Enterprise で実行中のプロセスに関連している可能性がある場合は、そのシステム問題が解消されるまで、VirusScan Enterprise の機能を意図的に無効にできます。または少なくとも、その問題の原因として VirusScan Enterprise を排除できます。
警告:
トラブルシューティング後に、マルウェアに対する保護機能を完全な状態に戻すために VirusScan Enterprise を再設定または復元する必要があります。
VirusScan Enterprise の機能を意図的に無効化するには、次の 8 つのステップからなるプロセスを実行します。
  1. バッファ オーバーフロー保護の無効化
  2. アクセス保護の無効化
  3. ScriptScan の無効化
  4. オンアクセス スキャンの無効化
  5. オンアクセス スキャンの無効化後に再起動
  6. MFEVTP の読み込み防止後に再起動
  7. mfehidk.sys ファイルの名前変更後に再起動
  8. 製品の削除後に再起動

以下のセクションでは、これらの 8 つのステップのそれぞれを説明しています。VirusScan コンソール のオプションの定義については、インターフェースの［ヘルプ］をクリックしてください。

バッファ オーバーフロー保護の無効化

バッファ オーバーフロー保護を無効にするには、次の手順を実行してください。
  1. VirusScan コンソール の［タスク］リストで、［バッファ オーバーフロー保護］を右クリックして、［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログ ボックスで、［バッファ オーバーフロー保護の有効にする］を選択解除して、［OK］をクリックします。
  3. システムで発生している問題はバッファ オーバーフロー保護を無効にすることで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらくこの機能と関係ありませんでした。

アクセス保護の無効化

アクセス保護を無効にするには、次の手順を実行してください。
  1. VirusScan コンソール の［タスク］リストで、［アクセス保護］をダブルクリックして、［アクセス保護のプロパティ］ダイアログ ボックスを開きます。
  2. ［アクセス保護］タブをクリックして、［アクセス保護の有効化］を選択解除して、［OK］をクリックします。
  3. システムで発生している問題はアクセス保護を無効にすることで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらく VirusScan Enterprise と関係ありませんでした。

ScriptScan の無効化

ScriptScan を無効にするには、次の手順を実行してください。
  1. VirusScan コンソール の［タスク］リストで、［オンアクセス スキャナ］を右クリックして、［オンアクセス スキャンのプロパティ］ダイアログ ボックスを開きます。
  2. ［ScriptScan］タブをクリックして、［スクリプトのスキャンを有効にする］を選択解除して、［OK］をクリックします。
  3. システムで発生している問題は ScriptScan を無効にすることで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらく VirusScan Enterprise と関係ありませんでした。

オンアクセス スキャンの無効化

オンアクセス スキャンを無効にするには、次の手順を実行してください。
  1. アクセス保護を無効にします。VirusScan コンソール の［タスク］リストで、［アクセス保護］を右クリックして、［無効］を選択します。
  2. 次の手順に従って、［サービス］アプレットで McShield のスタートアップの種類を［無効］に変更します。
    • ［スタート］、［コントロール パネル］、［管理ツール］、［サービス］の順にクリックして、［サービス］アプレットを開きます。
    • ［サービス (ローカル)］で、スクロール ダウンして［McAfee McShield］を表示して、この項目を右クリックして［McAfee McShield のプロパティ］ダイアログ ボックスを開きます。
    • ［全般］タブをクリックして、［スタートアップの種類］リストで［無効］をクリックして、［OK］をクリックします。
  3. VirusScan コンソール の［タスク］リストで、［オンアクセス スキャナ］を右クリックして、表示されるリストから［無効］をクリックします。［オンアクセス スキャナ］アイコンが変化して、斜線付きの丸印が追加されて、その機能が無効になったことが示されます。
  4. システムで発生している問題はオンアクセス スキャンを無効にすることで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらくこの機能と関係ありませんでした。

オンアクセス スキャンの無効化後に再起動

オンアクセス スキャンを無効にしてからシステムを再起動するには、次の手順を実行してください。
注意: 次の手順では、前のセクションでオンアクセス スキャンを無効にした後に再び有効にしていないことを前提としています。

  1. システムを完全にシャットダウンしてから再起動します。
  2. システムで発生している問題は、オンアクセス スキャンの無効化後にシステムを再起動することで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらくこの機能と関係ありませんでした。

MFEVTP の読み込み防止後に再起動

McAfee の McAfee Validation Trust Protection Service （MFEVTP）の読み込みを防止してから、システムを再起動するには、次の手順を実行してください。
警告:
このセクションにはレジストリの表示または変更に関する情報が記載されています。
  • 次の情報はシステム管理者を対象にしています。レジストリの変更は元に戻すことができず、間違った値に変更するとシステムが正常に動作しなくなる可能性があります。
  • 作業を開始する前に、McAfee では、レジストリをバックアップして、復元プロセスを理解しておくことを強くお勧めします。詳細については、http://support.microsoft.com/kb/256986 を参照してください。
  • 正規のレジストリ インポート ファイルであることが確認されていない .REG ファイルを実行しないでください。

  1. コマンド ラインから、「regedit」と入力してレジストリ エディタを開きます。
  2. 次のレジストリ項目に移動します。[HKEY_LOCAL_MACHINE\System\ControlSet001\Services\mfevtp]
  3. 右側のペインで、［Start］を右クリックして［修正］をクリックし、［DWORD 値の編集］ダイアログ ボックスを開きます。
  4. ［値のデータ］に「4」と入力して、［OK］をクリックします。
  5. システムで発生している問題は、MFEVTP の読み込み防止後にシステムを再起動することで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらくこの機能と関係ありませんでした。

mfehidk.sys ファイルの名前変更後に再起動

mfehidk.sys ファイルの名前を変更してからシステムを再起動するには、次の手順を実行してください。
  1. お使いのオペレーティング システムに応じて、次のいずれかのフォルダにある mfehidk.sys ファイルにアクセスします。
    • 32 ビット版オペレーティング システムの場合 － %windir%\System32\drivers
    • 64 ビット版オペレーティング システムの場合 － %windir%\System64\drivers
  2. ファイル名を mfehidk.sys から、たとえば mfehidk.sys.saved に変更します。
  3. システムを再起動することで、VirusScan Enterprise を停止して、mfehidk.sys ファイルを読み込むことなく VirusScan Enterprise を再始動します。
  4. システムで発生している問題は、mfehidk.sys ファイルの名前変更後にシステムを再起動することで解決されましたか。
    • はい － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。
    • いいえ － システムで発生している問題はおそらく VirusScan Enterprise と関係ありませんでした。

製品の削除後に再起動

VirusScan Enterprise を完全に削除してから、システムを再起動するには、次の手順を実行してください。
  1. VirusScan Enterprise のプログラム ファイルを削除します。詳細については、『McAfee VirusScan Enterprise 8.8 インストール ガイド』を参照してください。
  2. システムを再起動することで、オペレーティング システムを停止して、VirusScan Enterprise がインストールされていない状態でオペレーティング システムを再起動します。
  3. システムで発生している問題は、VirusScan Enterprise のプログラム ファイルを完全に削除した後にシステムを再起動することで解決されましたか。
    • はい － システムで発生している問題はおそらく VirusScan Enterprise と関係がありました。
    • いいえ － McAfee テクニカル サポート ServicePortal（http://mysupport.mcafee.com）にアクセスして解決策を検索するか、McAfee テクニカル サポートに連絡してください。


推奨のサポート ツールとトラブルシューティング ツール

VirusScan Enterprise のグローバル管理者は、システムのセキュリティとパフォーマンスをトラブルシューティングおよび評価するのに役立つツールをインストールして設定することをお勧めします。McAfee テクニカル サポートに連絡したときは、設定のトラブルシューティング時にこれらのツールのいくつかを実行することを求められることがあります。これらのツールは、以下の表に示すインターネット サイトからダウンロードできます。

McAfee のツール

次の表では、McAfee のサイトからダウンロードできるサポート ツールとトラブルシューティング ツールを示しています。

ツール | ダウンロード サイト
MER ツール | WebMER
ProcessCounts | McAfee サポートにより提供
SuperDAT Manager | McAfee サポートにより提供
McAfee Profiler | McAfee サポートにより提供

McAfee 以外のツール

次の表では、サポート ツールとトラブルシューティング ツール、およびそれらの実行ファイルとダウンロード サイトを示しています。

ツール | 実行ファイル | ダウンロード サイト
Driver Verifier | Verifier | Microsoft.com
Performance Monitor | PerfMon | Microsoft.com
Pool Monitor | PoolMon | Microsoft.com
Process Monitor | ProcMon | Microsoft.com
Process Explorer | ProcExp | Microsoft.com
Process Dump | ProcDump | Microsoft.com
Windows Object Viewer | WinObj | Microsoft.com
TCP Viewer | TCPView | Microsoft.com
Debug Output Viewer | DebugView | Microsoft.com
Windows Debugger | WinDbg | Microsoft.com
Kernel Rate Viewer | KrView | Microsoft.com
Windows Performance Analysis Tools | Xperf | Microsoft.com
VM Converter | 不特定 | Vmware.com
WireShark | wireshark | Wireshark.org


よく寄せられる質問

このセクションには、よくある質問の形式でトラブルシューティング情報が記載されています。

インストール

  • 質問: サイレント インストール方式でソフトウェアをインストールしましたが、Windows システム トレイに VirusScan Enterprise のアイコンがありません。

    回答: システムを再起動するまでシステム トレイにアイコン シールドは表示されません。ただし、アイコンが表示されていなくても VirusScan Enterprise は実行されており、システムは保護されています。これは、次のレジストリ キーを調べて確認します。HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • 質問: ネットワーク上で独自の設定を構成できるユーザと、構成できないユーザがいるのはなぜですか。

    回答: 管理者が、タスクをパスワードで保護するようにユーザ インターフェースを設定している可能性があります。その場合、ユーザは設定を変更できません。さらに、使用する Windows オペレーティング システムが異なっていると、ユーザの権限も異なります。ユーザの権限については、使用している Microsoft Windows のドキュメントを参照してください。

ブロックされたアプリケーション

  • 質問: VirusScan Enterprise をインストールしたら、アプリケーションの 1 つが動作しなくなりました。

    回答: そのアプリケーションはアクセス保護ルールによってブロックされている可能性があります。
    1. アクセス保護ログ ファイルを調べて、そのアプリケーションがルールによってブロックされたかどうかを確認してください。
    2. アプリケーションがログに記載されていることがわかったら、そのアプリケーションを除外アイテムとしてルールに入力するか、ルールを無効にすることができます。詳細については、「システムのアクセス ポイントの保護」を参照してください。

Cookie の検出

  • 質問: オンデマンド スキャンの動作ログで Cookie の検出を確認すると、検出のファイル名がすべて 00000000.ie となっていました。他のアプリケーションでは Cookie の検出ごとに個別のファイル名や数字が増えるファイル名が割り当てられるのに、VirusScan Enterprise では、オンデマンド スキャンによる Cookie の検出すべてに同じファイル名が割り当てられるのはなぜですか。

    回答: VirusScan Enterprise では、オンデマンド スキャンで Cookie の検出が行われてアクションが実行される方法のために、それぞれの Cookie の検出に同じファイル名が割り当てられます。この動作が適用されるのは、オンデマンド スキャンで検出された Cookie だけです。1 つの Cookie ファイルには、多数の Cookie が含まれている可能性があります。スキャン エンジンは Cookie ファイルをアーカイブとして扱い、ファイルの先頭からのオフセットとして、(ゼロから始まる) 1 つの値を割り当てます。スキャナでは、スキャン エンジンを使用して Cookie の検出が行われ、スキャンを続行する前に、検出された Cookie ごとにアクションが実行されるため、それぞれの検出に対して値がゼロから付け直されます。この結果、すべての検出にファイル名として 00000000.ie が割り当てられます。他の製品は、すべての Cookie を検出し、それぞれに個別のファイル名または数字が増えるファイル名を割り当ててから、各検出に対してアクションを実行します。

全般

  • 質問: 現在使用しているスタンドアロンの VirusScan Enterprise システムでは、システム トレイ内のシステム アイコンが無効化されているようです。

    回答: VirusScan Enterprise アイコンの上に赤い円と線がある場合は、オンアクセス スキャナが無効になっていることを意味します。一般的な原因と解決策を次に示します。これらのどの方法でも問題が解決されない場合は、テクニカル サポートに問い合わせてください。
    1. オンアクセス スキャナが有効になっていることを確認します。システム トレイの VirusScan Enterprise アイコンを右クリックします。オンアクセス スキャナが無効になっている場合は、[OA スキャンの有効化] をクリックします。
    2. McShield サービスが実行されていることを確認します。
      • コントロール パネルの [サービス] から手動でサービスを開始します。
      • [スタート] メニューから [ファイル名を指定して実行] を選択し、「Net Start McShield」と入力します。
      • コントロール パネルの [サービス] で、サービスが自動的に開始されるように設定します。

  • 質問: CATALOG.Z をダウンロードできないというエラーが表示されます。

    回答: このエラーにはさまざまな原因が考えられます。問題の原因を特定するのに役立つヒントをいくつか示します。
    • アップデートのために既定の McAfee ダウンロード サイトを使用している場合は、Web ブラウザから CATALOG.Z ファイルをダウンロードできるかどうか確認します。次の Web サイトからファイルをダウンロードできるかどうか試してみてください。http://update.nai.com/Products/CommonUpdater/catalog.z
    • ファイルをダウンロードできない場合でも、ファイルが見られる (言い換えれば、ファイルのダウンロードがブラウザによって許可されない) 場合は、プロキシに関する問題があります。ネットワーク管理者に相談してください。
    • ファイルをダウンロードできる場合は、VirusScan Enterprise でもダウンロードできるはずです。インストールされている VirusScan Enterprise のトラブルシューティングについて、テクニカル サポートに問い合わせてください。

  • 質問: HTTP ダウンロード サイトの場所はどこですか。

    回答:
    • McAfee ダウンロード サイトの場所は次のとおりです。http://www.mcafee.com/us/downloads/
    • 最新のアップデートが含まれる CATALOG.Z ファイルは、次の Web サイトからダウンロードできます。http://update.nai.com/Products/CommonUpdater/catalog.z

  • 質問: FTP ダウンロード サイトの場所はどこですか。

    回答:
    • FTP ダウンロード サイトの場所は次のとおりです。ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x
    • 最新のアップデートが含まれる CATALOG.Z ファイルは、次のサイトからダウンロードできます。ftp://ftp.mcafee.com/CommonUpdater/catalog.z

  • 質問: [アクションを指定] を選択していて、不審なプログラムが実際に検出された場合は、どのアクション ([駆除] または [削除]) を選択すべきですか。

    回答: 一般的には、検出されたファイルをどうするか自信がない場合は、[ウイルスを駆除] を選択することをお勧めします。オンアクセス スキャナまたはオンデマンド スキャナは、アイテムが駆除または削除される前に、それらのアイテムを自動的に検疫ディレクトリにバックアップします。


［アクセス保護］タブ

オプションの定義

アクセス保護ルールを設定して、McAfee のプロセスが終了されることを防止します。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
アクセス保護設定
  • [アクセス保護の有効化] - アクセス保護機能を有効にします。
  • [McAfee サービスの停止を防止] - デバッグ特権のないユーザによる McAfee プロセスの終了を防止します。

    このオプションを選択しても、プログラムのデバッグ特権があるユーザは McAfee プロセスを終了できます。

    Windows XP および Windows Server 2003 の場合、管理者にはデフォルトでプログラムのデバッグ特権が与えられています。ユーザが McAfee プロセスを終了できないようにするには、ユーザのアクセス許可からこれらの特権を削除します。

警告:
アクセス保護を有効にせず、McAfee のサービスが停止することを防止しない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
アクセス保護のルール

[カテゴリ] - カテゴリをクリックし、そのカテゴリのルールを表示します。ルールは、次のカテゴリに整理されます。

  • ウイルス対策標準保護
  • ウイルス対策最大保護
  • ウイルス対策アウトブレーク コントロール
  • 共通標準保護
    警告:
    以下のルールについて、共通標準保護を設定せず、［ブロック］と［レポート］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
    • McAfee のファイルと設定の変更を防止します。
    • McAfee Common Management Agent のファイルと設定の変更を防止します。
    • McAfee スキャン エンジンのファイルと設定の変更を防止します。
    • McAfee プロセスの出力を防止します。
  • 共通最大保護
  • 仮想マシン保護
  • ユーザ定義ルール
  • スパイウェア対策標準保護
  • スパイウェア対策最大保護

詳細については、「アクセス保護ルールを定義する方法」を参照してください。

ブロック/レポート/ルール - 次のルールを設定します。

  • ブロック - [ルールの詳細] で指定されたプロセスをブロックします。[ブロック] チェック ボックスをオンにしてルールを有効にするか、オフにしてルールを無効にします。

    注意:

    ログ記録を行わずにアクセスの試みをブロックするには、[ブロック] オプションを選択し、[レポート] オプションは選択しないでください。

  • レポート ‐アクセス保護の侵害が試みられた場合のレポートを有効にします。侵害の試行が検出された場合、情報は動作ログに記録されます。
    注意:

    アクセスの試みをブロックせずに、警告の受信だけを行うには、[レポート] オプションを選択し、[ブロック] オプションは選択しないでください。これは、ルールの影響が完全に判明していない場合に便利です。ログやレポートを短時間監視し、アクセスをブロックするかどうかを判断します。

  • ルール - アクセス保護のルールを使用して、望ましくない変更からコンピュータを保護します。ルールはカテゴリ別に整理されます。まずカテゴリを選択し、次にルールを選択します。詳細については、「事前定義済みルールの設定」と「ユーザ定義ルールの設定」を参照してください。

    新規 - 新規のユーザ定義ルールを作成します。詳細については、「ユーザ定義ルールの設定」を参照してください。

    編集 - 既存のルールを変更します。

    削除 - 既存のユーザ定義ルールを削除します。
    注意:

    ユーザ定義ルールのみ削除できます。他のルールは編集または無効化できますが、削除はできません。ルールを無効にするには、[ブロック] オプションと [レポート] オプションの選択を解除します。

関連タスク
ユーザ インターフェース セキュリティの設定
関連情報
アクセス保護


[追加のアラート オプション] タブ

オプションの定義

フィルタとローカル アラートのオプションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
重大度フィルタ 以下のフィルタ オプションから選択します。
  • アラートをフィルタしない - すべてのアラートを送信します。
  • 情報アラートは送信しない - 重要度 1 未満のアラートは送信しません。
  • 情報および警告アラートは送信しない - 重要度 2 未満の情報アラートと警告アラートは送信しません。
  • 情報、警告、および低度のアラートを抑制 - 重要度 3 未満の情報アラート、警告アラート、危険度低アラートは送信しません。
  • 緊急事態アラート以外は送信しない - 重要度 4 未満のアラートは送信しません。
  • どのアラートも送信しない - すべてのアラートを送信しません。
ローカル アラート
  • ローカル アプリケーションのイベント ログに記録する - 情報をローカル アプリケーションのイベント ログに記録します。
  • SNMP サービスを使用して SNMP トラップを送信する - SNMP を使用している場合、SNMP トラップ アラートを送信できます。
注意:

ローカル アラート オプションに Alert Manager は必要ありません。
関連タスク
アラートの設定
関連情報
アラートおよび通知の設定


[アラート] タブ

オプションの定義

アラートを生成するコンポーネントを選択し、Alert Manager を設定します (インストールされている場合)。

詳細については、『Alert Manager 4.7.1 製品ガイド』を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
アラートを生成するコンポーネント
  • オンアクセス スキャン - オンアクセス スキャナが脅威を検出したら、アラートを生成します。
  • オンデマンド スキャンとスケジュール スキャン - オンデマンド スキャン タスクが脅威を検出したら、アラートを生成します。
  • 電子メール スキャン - 電子メールスキャナが脅威を検出したら、アラートを生成します。
  • AutoUpdate - アップデート タスクが脅威を検出したら、アラートを生成します。
  • アクセス保護 - アクセス保護が脅威を検出したら、アラートを生成します。
Alert Manager のオプション
  • アラート通知を無効にする - 侵入が検出されたときにアラートを生成しません。
  • 集中管理アラートを有効にする - 侵入が検出されたときに集中管理アラートを使用してユーザに通知します。
  • アラート マネージャのアラート通知を有効にする - 侵入が検出されたときに Alert Manager を使用してユーザに通知します。このオプションを選択し、アラートを受信する Alert Manager サーバの場所へのパスを入力します。
    • [Active Directory の検索を無効にする] - Active Directory の検索は使用しません。
関連タスク
アラートの設定
関連情報
アラートおよび通知の設定


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、AccessProtectionLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合にお勧めします。
関連概念
アクセス ポイント違反と VirusScan Enterprise の対応
関連タスク
VirusScan コンソール
関連参照
オンアクセス動作ログ ファイルの表示


AutoUpdate タスク

AutoUpdate タスクの設定

オプションの定義

オプション | 定義
ログ ファイル | 動作ログを有効にします。
形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
入手可能な、新しい DAT ファイルを取得

新バージョンが入手可能な場合には、最新バージョンの DAT ファイルを取得します。

入手可能な、新しい検出エンジンを取得する

新バージョンが入手可能な場合には、最新バージョンのエンジン ファイルと DAT ファイルを取得します。

他の入手可能なアップデート (サービス パック、アップグレードなど) を取得する

サービス パックや製品アップグレードなどの最新バージョンを取得します。

アップデートの完了後に実行する実行可能ファイルを入力

AutoUpdate タスクの実行が終了した後に起動する実行可能ファイルを指定します。実行する実行可能ファイルのパスを指定するか、または [参照] をクリックして探します。

たとえば、AutoUpdate タスクが正しく完了したことを管理者に通知するネットワーク メッセージ ユーティリティを開始できます。

注意: 指定するアプリケーションは、現在ログオンしているユーザにより実行可能である必要があります。現在ログオンしているユーザが、アプリケーション ファイルがあるフォルダにアクセスできない場合、または現在ログオンしているユーザがいない場合、アプリケーションは実行されません。
アップデートが成功した場合のみ実行

正常なアップデート後にのみ実行可能ファイルを実行します。正常にアップデートされない場合、指定したアプリケーションは実行されません。

スケジュール

このアップデート タスクのスケジュールを定めます。

注意:

詳細については、「タスクのスケジュール設定」を参照してください。

AutoUpdate タスクとミラー タスクを同時に実行するようなスケジュールは立てないでください。どちらのタスクも McAfee Common Framework サービスを使用するため、同時に実行すると矛盾が生じる可能性があります。

今すぐアップデート

AutoUpdate タスクを直ちに実行します。

関連概念
アップデート タスクとその機能
関連参照
AutoUpdate タスクの設定


[ブロック] タブ

オプションの定義

共有フォルダに潜在的脅威または不審なプログラムプログラムが存在するリモート コンピュータからの接続をブロックできます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
メッセージを送信 | 脅威が検出されたら、ネットワーク ユーザに指定したメッセージを送信する - 脅威が検出されたら、リモート コンピュータのネットワーク ユーザに通知します。
メッセージ テキスト

カスタム メッセージをテキスト ボックスに入力してください。このメッセージを受信するには、リモート コンピュータ上で Windows Messenger サービスが実行されていなければなりません。
接続をブロック
  • 共有フォルダで脅威にさらされたファイルが検出されたときに接続をブロックする - 共有フォルダにある脅威にさらされたファイルの読み取りまたは書き込みを試みるリモート コンピュータ上のすべてのネットワーク ユーザの接続をブロックします。
  • 接続のブロックを解除するまでの時間 - 指定した分数が経過したら、接続のブロックを解除します。時間を分単位で入力します (1 から 9999)。デフォルトは 10 分です。
  • 共有フォルダで不審なプログラムが検出されたときに接続をブロックする - コンピュータに不審なプログラムを書き込もうとするリモート コンピュータのユーザへの接続をブロックします。[オンアクセス スキャン統計] ダイアログ ボックスに、ブロックされたコンピュータの一覧が表示されます。
関連参照
ポートのブロック ルール オプション
ファイルとフォルダのブロック ルール オプション
レジストリのブロック ルール オプション
関連情報
アクセス保護


[レポート] タブ

オプションの定義

特定のプロセスのヒープやスタックのオーバーランからローカル システムで実行されるコードの検出を追跡するための記録を有効にします。

オプション | 定義
Cookie に関する警告 | Cookie が検出されたときにユーザに通知します。 デフォルトでは選択されています。
ログ ファイルに記録 | 動作ログを有効にして、ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、BufferOverflowProtectionLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。

ログ ファイルのサイズ | ログ ファイルのサイズを制限します。 デフォルトのサイズ（1 MB）をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
関連情報
アラートおよび通知の設定
バッファ オーバーフロー攻撃のブロック


[バッファ オーバーフロー保護] タブ

オプションの定義

バッファ オーバーフロー攻撃手段により、何らかのコードが勝手に実行されることを防止します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
バッファ オーバフローの設定 バッファ オーバーフロー保護を有効にする — バッファ オーバーフロー保護機能を有効にし、保護レベルを選択します。

  • 警告モード - バッファ オーバフローが検出されたら警告を送信します。警告以外のアクションは実行されません。

    このモードは、バッファ オーバーフローの影響が完全に判明していない場合に便利です。機能を短期間 [警告モード] で使用し、その期間中にログ ファイルを参照して、[保護モード] に変更するかどうかを決定します。

  • 保護モード - バッファ オーバフローを検出したらブロックし、その脅威の拡大を防ぎます。

    これにより、該当するアプリケーションも終了します。

警告:
［バッファ オーバーフロー保護］と［保護モード］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
クライアント システムの警告 | バッファ オーバーフローの検出時にメッセージを表示する - 検出時に [オンアクセス スキャン メッセージ] ダイアログ ボックスを表示します。
保護対象から除外するバッファ オーバーフロー 除外情報を指定します。
注意:

除外する名前は大文字と小文字を区別します。

  • プロセス - 呼び出しを行っている書き込み可能メモリを所有しているプロセス名を指定します。

    プロセス名またはパスを入力します。

    OUTLOOK.EXE のようにプロセス名のみを入力した場合、プロセスが実行された場所に関係なく、このプロセスは除外されます。C:\Program files\OUTLOOK.EXE のようにパスを含むプロセス名を入力した場合、指定したパスから実行されたプロセスのみが除外されます。ワイルドカードは使用できません。

  • モジュール (オプション) - 該当する場合は、書き込み可能メモリを所有するモジュールの名前を入力します。この情報は必須ではありません。
  • API - 呼び出す API を指定します。
    注意:

    API は、モジュールが指定されている場合のみ必須です。

関連タスク
バッファ オーバーフロー保護の設定
関連情報
バッファ オーバーフロー攻撃のブロック


[プロセス] タブ

オプションの定義

すべてのプロセスに共通に適用するスキャン ポリシーを 1 つ設定するのか、それとも既定のプロセス、危険度低プロセス、および危険度高プロセスに適用する複数のスキャン ポリシーを設定するかを決定します。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定 スキャン ポリシーを設定するかどうかを指定します。
  • すべてのプロセスに適用するスキャン ポリシーを 1 つ設定 - このオプションを選択した場合、設定したポリシーはすべてのプロセスに適用されます。
  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに異なるスキャン ポリシーを設定 - 危険度低プロセスや危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。
関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[表示オプション] タブ

オプションの定義

ユーザがどのシステム トレイ オプションを使用できるかと、優先言語を設定します。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
システム トレイ アイコン
  • [すべてのメニュー オプションとともにシステム トレイのアイコンを表示します] - ユーザがシステム トレイ メニューのすべてのオプションを表示できるようにします。
  • [最小限のメニュー オプションと共にシステム トレイのアイコンを表示する] - システム トレイ メニューの [VirusScan Enterprise のバージョン情報] と [オンアクセス スキャンの統計] 以外のすべてのオプションを非表示します。
  • [システム トレイのアイコンを表示しない] - すべてのユーザに対して、システム トレイのアイコンを非表示にします。
コンソール オプション
注意: このオプションは ePolicy Orchestrator でのみ使用できます。

  • [他のシステムとのリモート コンソール接続を許可] - リモート コンピュータに接続します。

    管理者権限が必要です。また、Remote Registry Service が実行されている必要があります。

  • [クライアント コンソールに管理対象タスクを表示] - ePolicy Orchestrator タスクをクライアント コンピュータのコンソール内に表示します。
  • [デフォルトの AutoUpdate タスク スケジュールを無効にする] - デフォルトのアップデート タスクのスケジュールを無効にします。

    このスケジュールは、ポリシーの施行時に無効になります。タスクのスケジュールを無効にするには、タスク マネージャのサービスを実行しておく必要があります。

  • [スプラッシュ画面を有効にする] - コンソールまたは SHSTAT.EXE の起動時に、VirusScan Enterprise 8.8 のスプラッシュ画面を表示します。
    注意:

    このオプションは ePolicy Orchestrator でのみ使用できます。

コンソール言語の設定 コンソール テキストに使用する言語を指定します。
  • 言語は自動的に選択されますが、特定の言語を手動で選択することもできます。
    注意:

    VirusScan Enterprise 8.8 コンソールで優先言語を変更すると、システムを再起動するように求められます。[はい] をクリックすると、言語の変更が適用されます。

    ePolicy Orchestrator コンソールで優先言語を変更すると、最初のポリシー施行後に言語の変更がユーザのコンソールに適用されます。

    ePolicy Orchestrator 管理対象システムの場合、ユーザがクライアント システムから行った変更はコンソールのインターフェースに影響しますが、ログ ファイルには ePolicy Orchestrator の設定で指定した言語で動作が記録されます。コンソールの言語変更は、コンソールの再起動後に適用されます。

関連タスク
ユーザ インターフェース セキュリティの設定
関連情報
アクセス保護


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト = 添付ファイルの駆除。
  • 添付ファイルの駆除 - スキャナにより、添付ファイルから脅威を削除するアクションが試行されます。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
  • メールの削除 (Outlook スキャン専用) — 潜在的な脅威を含むメールが削除されます。このオプションを最初のアクションとして選択した場合、2 番目のアクションは指定できません。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト = 添付ファイルのフォルダへの移動。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
  • メールの削除 (Outlook スキャン専用) — 潜在的な脅威を含むメールが削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 不審なプログラムの検出時にスキャナに実行させる最初のアクションを選択します。デフォルト = 添付ファイルの駆除。
  • 添付ファイルの駆除 - スキャナにより、添付ファイルから脅威を削除するアクションが試行されます。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト = 添付ファイルのフォルダへの移動。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
移動先フォルダ 隔離フォルダの場所を指定します。隔離フォルダは、ハード ドライブに配置する必要があります。これはローカル ドライブにしてください。フロッピー ドライブや CD ドライブには配置しないでください。隔離フォルダのデフォルトの場所は、Microsoft Outlook と Lotus Notes とでは異なります。
  • Microsoft Outlook では、隔離フォルダは Microsoft Outlook のメールボックスにあります。
  • Lotus Notes では、隔離フォルダはファイル システムにあります。
[処理設定] ダイアログ ボックスでアクションを選択 アクションの指定を求めるダイアログ ボックスでユーザが指定できるアクションを選択します。
注意:

デフォルトでは、以下のアクションが実行される前に [アクセスの拒否] アクションが発生します。

  • 添付ファイルの駆除
  • 添付ファイルを削除
  • 添付ファイルを移動
  • メールの削除 (Microsoft Outlook 専用)
ユーザがアクションの実行を求められると、[アラート] タブで指定したメッセージが表示されます。
関連タスク
隔離ポリシーの設定
関連参照
オンアクセス スキャン検出
オンデマンド スキャン検出
電子メール スキャンによる検出
関連情報
検出および対応


[アラート] タブ

オプションの定義

配信時電子メール スキャナでのアラートの設定を行えます。

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザの電子メール アラート | [ユーザへのアラート メールの送信] - 脅威が埋め込まれた電子メールが検出されたら、もう 1 人のユーザに通知します。
アクションを指定メッセージ | ユーザがアクションの実行を求められたときに表示されるメッセージを指定します。[アクション] タブで [アクションを指定] オプションを選択する必要があります。デフォルトのメッセージをそのまま使用するか、新しいメッセージを入力します。デフォルトのメッセージ = McAfee VirusScan Enterprise 電子メール スキャナ : アラート!
関連タスク
アラートの設定


［スキャン アイテム］ タブ

オプションの定義

オンデマンド電子メール スキャナの検出オプションを設定します。

オプション | 定義
スキャン対象メッセージ
  • 強調表示したすべてのアイテム — 選択した電子メール メッセージとフォルダをスキャンします。
  • [受信] フォルダ内のすべてのメッセージ — 現在 [受信] フォルダおよびそのサブフォルダ内にあるすべてのメッセージをスキャンします。
    • 読み込まれなかったメッセージのみをスキャンする — [受信] フォルダとそのサブフォルダにある未読メッセージをすべてスキャンします。
スキャンする添付ファイル
  • すべての添付ファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。[デフォルトと追加のファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    添付ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    [指定したファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

Artemis（不審なファイルのヒューリスティック ネットワーク チェック）
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 － Artemis スキャン機能を使用して、マルウェアと類似したコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 － Artemis スキャン機能を使用して、未知のマクロ ウイルスを検出します。
  • 複数の拡張子を持つ添付ファイルを検索 - 複数の拡張子を持つ添付ファイルを脅威として扱います。

    このオプションをクリックすると、［電子メール スキャンの警告］ ダイアログ ボックスが表示されます。[OK] をクリックして、指定を確認します。

警告:
［Artemis］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。

    圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
不審なプログラムの検出 不審なプログラムを検出 - 配信時電子メール スキャナを有効にして、不審なプログラムを検出します。電子メール スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

詳細については、「不審なプログラムの制限」を参照してください。

電子メール メッセージ本文 (Microsoft Outlook 専用) | 電子メール メッセージ本文をスキャン - Microsoft Outlook の電子メール メッセージをスキャンします。
関連タスク
オンデマンド スキャン タスクの設定
関連情報
アイテムのオンデマンド スキャン


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

オンデマンド電子メール ログ ファイルのデフォルト名は EmailOnDemandLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。

ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。
関連タスク
アラートの設定


［スキャン アイテム］ タブ

オプションの定義

電子メール スキャナでの検出オプションの設定を行えます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
電子メールのスキャン 配信時電子メールのスキャンを有効にします。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャンする添付ファイル
  • すべての添付ファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。[デフォルトと追加のファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    添付ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    [指定したファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

Artemis（不審なファイルのヒューリスティック ネットワーク チェック）
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 － Artemis スキャン機能を使用して、マルウェアと類似したコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 － Artemis スキャン機能を使用して、未知のマクロ ウイルスを検出します。
  • 複数の拡張子を持つ添付ファイルを検索 - 複数の拡張子を持つ添付ファイルを脅威として扱います。

    このオプションをクリックすると、［電子メール スキャンの警告］ ダイアログ ボックスが表示されます。[OK] をクリックして、指定を確認します。

警告:
［Artemis］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。

    圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
不審なプログラムの検出 不審なプログラムを検出 - 配信時電子メール スキャナを有効にして、不審なプログラムを検出します。電子メール スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

詳細については、「不審なプログラムの制限」を参照してください。

電子メール メッセージ本文 (Microsoft Outlook 専用) | 電子メール メッセージ本文をスキャン - Microsoft Outlook の電子メール メッセージをスキャンします。
不審なファイルのヒューリスティック ネットワーク チェック
検出したサンプルがマルウェアかどうかを決定するときに使用する感度レベルを設定します。[無効] 以外のすべてのレベルでは、マルウェアであるかどうかを判別するためにサンプルのフィンガープリント（ハッシュ）が McAfee ラボに送信されます。ユーザにとっての利点は、McAfee ラボがアップデートを公開すると同時に検出内容を利用でき、次の DAT リリースまで待つ必要がないことです。選択する感度レベルが高いほど、マルウェアの検出数は多くなります。ただし、検出数が増えると、誤検知の数も増える可能性があります。以下の感度レベルから選択してください。

  • 無効 － マルウェアかどうかを判別するために、フィンガープリントもデータも McAfee ラボに送信されません。

  • 非常に低 - 誤検知の検出とリスクは、通常の DAT の場合と同じです。McAfee ラボが次の DAT アップデートを待つ代わりに検出内容を公開すると、その検出内容を VirusScan Enterprise で使用できます。

  • 低 - このレベルは、[非常に低] と [中] の間と定義されています。

  • 中 - このレベルを使用するのは、マルウェアに感染する通常のリスクが、誤検知のリスクよりも大きい場合です。McAfee ラボ独自のヒューリスティック チェックによって、マルウェアの可能性が高いものが検出されます。ただし、一般的ではないファイルについて検出する場合、誤検知という結果になる危険性もあります。McAfee ラボでは、この設定を使用した検出内容によって、一般に普及しているアプリケーションやオペレーティング システム ファイルについて、誤検知が発生しないようにチェックしています。

  • 高 - このレベルは、[中] と [非常に高] の間と定義されています。

  • 非常に高 - このレベルを使用するのは、電子メールと、プログラムやオペレーティング システムの実行をサポートしていないボリュームとディレクトリのみにすることをお勧めします。このレベルで検出されるものはマルウェアと推定されますが、誤検知ではないと確定できるほど完全にはテストされていません。

関連タスク
配信時とオンデマンドの電子メール スキャン


[全般] タブ

オプションの定義

全般的なオンアクセス スキャン オプションを設定できます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャン 以下の一般的なスキャン アイテムを指定します。
  • ブート セクタ - ブート セクタをスキャンします。デフォルトでは有効になっています。
  • フロッピー (シャットダウン時) - コンピュータのシャットダウン時にフロッピー ドライブをスキャンします。 デフォルトでは有効になっています。
  • 有効なプロセス - McAfee オンアクセス McShield サービスは、既に実行されているすべてのプロセスをスキャンします。デフォルトでは無効になっています。
    注意: この機能を有効にすると、セキュリティが強化されますが、起動時間が長くなります。
オンアクセス スキャンを有効にする スキャンを有効にするタイミングを指定します。
  • システム起動時にオンアクセス スキャンを有効にする - コンピュータを起動するたびにオンアクセス スキャナを有効にします。
  • ポリシーを施行するときにオンアクセス スキャンを有効にする - ポリシーを施行するたびにオンアクセス スキャナを有効にします。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
最大スキャン タイム 最大スキャン時間を指定します。
  • すべてのファイルに対して最大スキャン タイムを強制する - すべてのファイルに対する最大スキャン タイムを定義し、強制的に適用します。
  • 最大スキャン タイム - すべてのファイルに対する最大スキャン タイムを秒単位で指定します。デフォルト値 = 45 秒。
注意: スキャンの経過時間が制限時間を上回ると、スキャンは完全に停止してログにメッセージが記録されます。スキャンの完全な停止が不可能な場合は、スキャンは終了して、次回のスキャン時に再開されます。
Cookie

Cookie ファイルをスキャン - Cookie ファイルのスキャンを有効にします。

Artemis（不審なファイルのヒューリスティック ネットワーク チェック） | Artemis の感度レベルを、「無効」から「非常に高」までの 6 段階のいずれかに指定します。デフォルト = 非常に低。
関連タスク
全般設定
関連情報
アイテムのオンアクセス スキャン


［スキャンの全般設定］タブ

オプションの定義

スキャン キャッシュのオプションを設定することで、システムの再起動時にスキャン データを保存して、オンデマンド スキャンでその非感染キャッシュ データを使用してパフォーマンスを向上できるようにします。詳細については、「Configuring global option settings」を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャン キャッシュ 全般的なオプションと設定を指定します。
  • 再起動中のスキャン データの保存を有効化 － このオプションを使用すると、システムの再起動時にも非感染スキャン結果を保存できます。デフォルトでは選択されています。
    注意: ハード ドライブのデータが別の場所で変更される可能性のある環境でシステムを使用している場合は、このオプションを無効にしてください。たとえば、ハード ドライブを取り外して、そのデータを更新した後で、元どおりに取り付けるような環境の場合です（デュアル ブート構成を使用した仮想マシンや仮想システムはこのケースに該当します）。
  • オンデマンド スキャンにおけるスキャン キャッシュの利用を許可 － このオプションを使用すると、オンデマンド スキャナは既存の非感染スキャン結果を使用することで、重複スキャンを低減できます。デフォルトでは選択されています。
関連タスク
グローバル システム キャッシュの設定


[プロセス] タブ

オプションの定義 : 手順 1

危険度高プロセスに定義するプロセスを指定します。これは、2 段階のプロセスで行います。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定

[オンアクセス スキャンのデフォルト プロセス ポリシー] を開き、以下のように選択します。

  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定
注意:

危険度低プロセスまたは危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。

オプションの定義 : 手順 2

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注意: このオプションは ePolicy Orchestrator でのみ使用できます。
危険度高プロセス | [オンアクセス スキャンの危険度高プロセス ポリシー] を開き、危険度高プロセスと見なすプロセスを指定します。必要に応じて、プロセスの追加と削除を行います。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。

関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[プロセス] タブ

オプションの定義 : 手順 1

危険度低プロセスに定義するプロセスを指定します。これは、2 段階のプロセスで行います。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定

[オンアクセス スキャンのデフォルト プロセス ポリシー] を開き、以下のように選択します。

  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定
注意:

危険度低プロセスまたは危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。

オプションの定義 : 手順 2

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注意: このオプションは ePolicy Orchestrator でのみ使用できます。
危険度低プロセス | [オンアクセス スキャンの危険度低プロセス ポリシー] を開き、危険度低プロセスと見なすプロセスを指定します。必要に応じて、プロセスの追加と削除を行います。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。

関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[メッセージ] タブ

オプションの定義

ローカル ユーザおよび管理者権限を持たないユーザに対するメッセージ オプションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ メッセージ ローカル ユーザが受信するメッセージを指定します。
  • 脅威が検出されたときにメッセージのダイアログ ボックスを表示し、メッセージに指定されたテキストを表示します - 検出が発生すると、［オンアクセス スキャン メッセージ］ ダイアログ ボックスがローカル ユーザに表示されます。

  • Cookie の検出が発生したときにアラートを生成します - Cookie が検出されると、アラートが送信されます。たとえば、ePolicy Orchestrator アラートの生成、[オンアクセス スキャン メッセージ] ダイアログ ボックスへのメッセージの送信、[レポート] タブで動作ログを有効にした場合は検出結果の動作ログへの記録、検出結果のスキャン統計への組み込みなどです。このオプションをオフにすると、ePolicy Orchestrator からのアラートは生成されませんが、[レポート] タブで動作ログを有効にした場合は、動作ログに記録されます。また、スキャン統計に組み込まれます。

メッセージ テキスト

デフォルトのメッセージをそのまま使用するか、カスタム メッセージを入力します。デフォルト値 = VirusScan Enterprise 8.8 のアラートです。

ユーザが使用できるアクション
  • リストからメッセージを削除 - 管理者権限のないユーザに対し、リストからメッセージを削除する操作を許可します。
  • ファイルを駆除 - 管理者権限のないユーザに対し、リストのメッセージに示されるファイルの駆除操作を許可します。
  • ファイルを削除 - 管理者権限のないユーザに対し、リストのメッセージに示されるファイルの削除操作を許可します。
関連参照
オンアクセス スキャン検出


ミラー タスク

ミラー タスクの設定

VirusScan Enterprise 8.8 コンソール — オプションの定義

オプション | 定義
ログ ファイル | 動作ログを有効にします。
形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
入手可能な、新しい DAT ファイルを取得

このオプションは、ミラー タスクには適用されません。
入手可能な、新しい検出エンジンを取得する

このオプションは、ミラー タスクには適用されません。
他の入手可能なアップデート (サービス パック、アップグレードなど) を取得する

このオプションは、ミラー タスクには適用されません。
ミラーリングの完了後に実行する実行可能ファイルを入力

ミラー タスクの実行が終了した後に起動する実行可能ファイルを指定します。実行する実行可能ファイルのパスを指定するか、または [参照] をクリックして探します。

たとえば、ミラー タスクが正しく完了したことを管理者に通知するネットワーク メッセージ ユーティリティを開始できます。

注意: 指定するアプリケーションは、現在ログオンしているユーザにより実行可能である必要があります。現在ログオンしているユーザが、アプリケーション ファイルがあるフォルダにアクセスできない場合、または現在ログオンしているユーザがいない場合、アプリケーションは実行されません。
ミラーが成功した場合のみ実行

正常なミラーリング後にのみ実行可能ファイルを実行します。正常にミラーリングされない場合、指定したアプリケーションは実行されません。
Mirror 場所

ミラー サイトに使用しているローカル システム上のミラーリング先のパスを指定します。

注意: システム変数がサポートされています。
スケジュール

このアップデート タスクのスケジュールを設定します。

注意:

詳細については、「タスクのスケジュール設定」を参照してください。

AutoUpdate タスクとミラー タスクを同時に実行するようにスケジュール設定しないことをお勧めします。どちらのタスクも McAfee Common Framework サービスを使用するため、同時に実行すると矛盾が生じる可能性があります。
今すぐ Mirror

ミラー タスクを直ちに実行します。

関連概念
ミラー タスクとその機能
関連参照
ミラー タスクの設定


[Notes スキャナの設定] タブ

オプションの定義

配信時電子メール スキャナでの Lotus Notes の設定を行えます。

Lotus Notes のパスワード設定

Windows 2000 Server、Windows 2003 Server、または Windows XP 上のローカル データベースにアクセスする際は、パスワードの入力が要求されます。パスワードを入力すると、テキスト検索のダイアログ ボックスが開いて、入力したパスワードがパスワード ダイアログ ボックスではなくテキスト検索ダイアログ ボックスに挿入されます。パスワードを入力するダイアログ ボックスは完全にモーダルなダイアログ ボックスではありません。このダイアログ ボックスを再度選択すると、パスワードを入力することができます。

McAfee では、次のようにして複数のパスワード プロンプトが表示されることを防止することをお勧めします。
  1. Lotus Notes で、［File］、［Preferences］、［Security］、［User Security］、［Dialog］の順にクリックします。
  2. ［Don’t prompt for a password from other Notes-based programs (reduces security)］をクリックします。
    警告:
    この設定によって、お使いのシステムのセキュリティが低下する可能性があります。
オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
サーバ スキャンの設定
  • すべてのサーバ データベースのスキャン - 潜在的な脅威がないかすべてのサーバ データベースをスキャンします。
  • サーバのメールボックスのスキャン - 潜在的な脅威がないかすべてのサーバのメールボックスをスキャンします。
  • メールボックスのルート フォルダ - ルート フォルダの場所を指定します。メールボックスのルート フォルダ用にデフォルトの場所を使用するか、新しい場所を指定します。このオプションは、配信時電子メール スキャンでのみ使用できます。デフォルト値 = !!mail\。
詳細オプション | 除外する Notes アプリケーション - スキャンから除外する Lotus Notes アプリケーションを指定します。デフォルト値 = MNOTES。
関連タスク
配信時とオンデマンドの電子メール スキャン


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルの自動的駆除。
  • ファイルの自動的駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • ファイル アクセスの拒否 - スキャナによって検出された潜在的な脅威を含むすべてのファイルについて、全ユーザからのアクセスを拒否します。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルの自動削除。
  • ファイル アクセスの拒否 - スキャナによって検出された潜在的な脅威を含むすべてのファイルについて、全ユーザからのアクセスを拒否します。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 不審なプログラムの検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルの自動的駆除。
  • ファイル アクセスの許可 － 検出されたファイルやプログラムへのアクセスをユーザに許可します。
    注意:

    このアクションを使用すると、実行するアクションを判断する前に検出物を監視できます。動作ログを調べて、どのプログラムが検出されているのかを確認します。このオプションについては、2 番目のアクションは指定できません。

  • ファイルの自動的駆除 － 検出されたファイルやプログラムから脅威を自動的に削除します。
  • ファイル アクセスの拒否 － ユーザによる検出されたファイルやプログラムへのアクセスを拒否します。
  • ファイルの自動削除 － 検出されたファイルやプログラムを自動的に削除します。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルの自動削除。
  • ファイル アクセスの許可 － 検出されたファイルやプログラムへのアクセスをユーザに許可します。
  • ファイル アクセスの拒否 － ユーザによる検出されたファイルやプログラムへのアクセスを拒否します。
  • ファイルの自動削除 － 検出されたファイルやプログラムを自動的に削除します。
関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[除外] タブ

オプションの定義

スキャンから除外するアイテムを指定します。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
除外アイテムの内容 除外の種類を選択してから、除外について以下の詳細を指定します。
  • ファイル名/場所を指定して除外 － 除外するファイルの名前と場所をテキスト ボックスに入力します。必要に応じて、［サブフォルダも除外］を選択します。
    注意: フォルダに適用する文字列の末尾に円記号（\）を追加する必要があります。そうしないと、それはファイルの除外と見なされ、［サブフォルダも除外］チェックボックスはデフォルトで無効になります。
  • ファイルの種類を指定して除外 - 除外するファイルの種類をテキスト ボックスに入力します。
  • ファイルの保存期間を指定して除外 - アクセス タイプを選択し、ファイルが作成されてからの経過日数を指定します。

詳細については、「スキャン アイテムの追加と除外」を参照してください。

除外時期 選択したアイテムを除外するタイミングを選択します。
  • 読み取り時
  • 書き込み時
クライアントの除外対象の処理方法 クライアントの除外対象を上書き - このポリシーで指定されたアイテムのみを除外します。このオプションが選択されていない場合、クライアント コンピュータではローカルで指定した除外対象およびこのポリシーで指定した除外対象を使用します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、OnAccessScanLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ> : \Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。
関連タスク
オンデマンド スキャン タスクの設定
関連情報
アイテムのオンデマンド スキャン


［スキャン アイテム］ タブ

オプションの定義

検出オプションを設定できます。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ファイルのスキャン
  • ディスクへの書き込み時 - すべてのファイルについて、コンピュータまたは他の記憶領域で書き込みや修正がされた場合に、スキャンを実行します。
    警告:
    ［ディスクへの書き込み時］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。

    複数のコンピュータ間でファイルをコピーまたは移動する場合は、潜在的な脅威が含まれるファイルをコンピュータからコピーしたりコンピュータに書き込むことができないように、すべてのコンピュータを同じ設定にすることが重要です。

  • ディスクからの読み取り時 - コンピュータ上またはその他のデータ記憶装置上のファイルからの読み取り時に、その対象ファイルがすべてスキャンされます。
    警告:
    ［ディスクからの読み取り時］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • ネットワーク ドライブ上 - マップされているネットワーク ドライブ上のリソースをスキャンします。

    ネットワーク上のリソースをスキャンすると、パフォーマンスが低下する場合があります。

  • バックアップ用に開いたファイル - バックアップ処理用に開いたファイルをスキャンします。
スキャンするファイルの種類
  • すべてのファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
    警告:
    ［すべてのファイル］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。

    ファイルにマクロが潜んでいないかもすべてスキャンする - このオプションを選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

Artemis（不審なファイルのヒューリスティック ネットワーク チェック）
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 － Artemis スキャン機能を使用して、マルウェアと類似したコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 － Artemis スキャン機能を使用して、未知のマクロ ウイルスを検出します。
警告:
［Artemis］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。
  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
注意: 圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。
不審なプログラムの検出
  • 不審なプログラムを検出 - オンアクセス スキャナを有効にして、不審なプログラムを検出します。

    スキャナは、 ［不審なプログラム ポリシー］で設定された情報を使用して怪しいプログラムを検出します。

    詳細については、「不審なプログラムの制限」を参照してください。

関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。

オプション 定義
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルを駆除。
  • ファイルを駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルを削除。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルを駆除。
  • ファイルを駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルを削除。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。
関連参照
プロセス設定のタブのオプション
関連情報
アイテムのオンアクセス スキャン


[除外] タブ

オプションの定義

スキャンから除外するアイテムを指定します。

オプション 定義
除外アイテムの内容 ドロップダウン リストから除外の種類を選択し、除外についての詳細を以下のように指定します。
  • ファイル名/場所を指定して除外 － 除外するファイルの名前と場所をテキスト ボックスに入力します。必要に応じて、［サブフォルダも除外］を選択します。
    注意: フォルダに適用する文字列の末尾に円記号（\）を追加する必要があります。そうしないと、それはファイルの除外と見なされ、［サブフォルダも除外］チェックボックスはデフォルトで無効になります。
  • ファイルの種類を指定して除外 - 除外するファイルの種類をテキスト ボックスに入力します。
  • ファイルの保存期間を指定して除外 - アクセス タイプを選択し、ファイルが作成されてからの経過日数を指定します。

詳細については、「スキャン アイテムの追加と除外」を参照してください。

除外時期 選択したアイテムを除外するタイミングを選択します。
  • 読み取り時
  • 書き込み時
クライアントの除外対象の処理方法 クライアントの除外対象を上書き - このポリシーで指定されたアイテムのみを除外します。このオプションが選択されていない場合、クライアント コンピュータではローカルで指定した除外対象およびこのポリシーで指定した除外対象を使用します。
注意:

このオプションは、ePolicy Orchestrator によってのみ設定します。

関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


[パフォーマンス] タブ

オプションの定義

パフォーマンスを改善するには、スキャンの遅延とシステム使用率のオプションを指定します。

オプション 定義
スキャンの遅延オプション スキャンの遅延オプションを選択します。
  • 電源に電池を使用しているときにスキャンを遅らせる - システムが使用中であり、電源に電池を使用しているときに、スキャンを遅らせます。
  • プレゼンテーション中にスキャンを遅らせる - システムがプレゼンテーション モードのときに、スキャンを遅らせます。
  • ユーザにスケジュール スキャンの遅延を許可 - ユーザがスケジュール スキャンを遅らせることができるようにします。

  • 遅延時間 - スキャンを遅らせる時間の長さを指定します。1～24 時間を選択します。また、スキャンを永続的に遅らせるには 0 を選択します。

詳細については、「スキャンの遅延の機能」を参照してください。

システムの使用率 ePolicy Orchestrator でリストを使用するか、VirusScan コンソール でスライダを使用して、スキャンに適用するシステム使用率のスケジュールを設定します。個々のスキャン タスクは、他のタスクのシステム使用率の制限レベルに関係なく独立して実行されます。次の段階を選択できます。
  • 低
  • 標準以下 — ePolicy Orchestrator のデフォルト
  • 標準 — VirusScan Enterprise 8.8 のデフォルト
Artemis（不審なファイルのヒューリスティック ネットワーク チェック）
検出したサンプルがマルウェアかどうかを決定するときに使用する感度レベルを設定します。[無効] 以外のすべてのレベルでは、マルウェアであるかどうかを判別するためにサンプルのフィンガープリント（ハッシュ）が McAfee ラボに送信されます。ユーザにとっての利点は、McAfee ラボがアップデートを公開すると同時に検出内容を利用でき、次の DAT リリースまで待つ必要がないことです。選択する感度レベルが高いほど、マルウェアの検出数は多くなります。ただし、検出数が増えると、誤検知の数も増える可能性があります。以下の感度レベルから選択してください。

  • 無効 － マルウェアかどうかを判別するために、フィンガープリントもデータも McAfee ラボに送信されません。

  • 非常に低 - 誤検知の検出とリスクは、通常の DAT の場合と同じです。McAfee ラボが次の DAT アップデートを待つ代わりに検出内容を公開すると、その検出内容を VirusScan Enterprise で使用できます。

  • 低 - このレベルは、[非常に低] と [中] の間と定義されています。

  • 中 - このレベルを使用するのは、マルウェアに感染する通常のリスクが、誤検知のリスクよりも大きい場合です。McAfee ラボ独自のヒューリスティック チェックによって、マルウェアの可能性が高いものが検出されます。ただし、一般的ではないファイルについて検出する場合、誤検知という結果になる危険性もあります。McAfee ラボでは、この設定を使用した検出内容によって、一般に普及しているアプリケーションやオペレーティング システム ファイルについて、誤検知が発生しないようにチェックしています。

  • 高 - このレベルは、[中] と [非常に高] の間と定義されています。

  • 非常に高 - このレベルを使用するのは、電子メールと、プログラムやオペレーティング システムの実行をサポートしていないボリュームとディレクトリのみにすることをお勧めします。このレベルで検出されるものはマルウェアと推定されますが、誤検知ではないと確定できるほど完全にはテストされていません。

関連概念
システム使用率の機能
関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、OnDemandScanLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ> : \Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。
Cookie の検出が発生したときにアラートを生成します

Cookie の検出が発生したときにアラートを生成します - Cookie が検出されると、アラートが送信されます。たとえば、ePolicy Orchestrator アラートの生成、検出の通知、[レポート] タブで動作ログを有効にした場合は検出結果の動作ログへの記録、検出結果のスキャン統計への組み込みなどです。このオプションをオフにすると、ePolicy Orchestrator からのアラートは生成されませんが、[レポート] タブで動作ログを有効にした場合は、動作ログに記録されます。また、スキャン統計に組み込まれます。
関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


［スキャン アイテム］ タブ

オプションの定義

検出オプションを設定できます。

オプション 定義
スキャンするファイルの種類
  • すべてのファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

オプション
  • 不審なプログラムを検出 - オンアクセス スキャナを有効にして、不審なプログラムを検出します。

    スキャナは、 ［不審なプログラム ポリシー］で設定された情報を使用して怪しいプログラムを検出します。

    詳細については、「不審なプログラムの制限」を参照してください。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。
圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • ストレージに移動したファイルをスキャン - リモート ストレージに保存されているキャッシュされたファイルをスキャンします。

    詳細については、「リモート ストレージのスキャンの機能のしくみ」を参照してください。

Artemis（不審なファイルのヒューリスティック ネットワーク チェック）
  • 未知のプログラム脅威を検索 － Artemis スキャン機能を使用して、マルウェアと類似したコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 － Artemis スキャン機能を使用して、未知のマクロ ウイルスを検出します。
関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


[タスク] タブ

オプションの定義

このオンデマンド タスクが実行されるプラットフォームを指定できます。

オプション 定義
このタスクが実行されるプラットフォーム
  • このタスクをサーバで実行 - このオンデマンド スキャン タスクをサーバで実行します。
  • このタスクをワークステーションで実行 - このオンデマンド スキャン タスクをワークステーションで実行します。
タスクの実行時に使用するユーザ アカウント
  • ユーザ名 - ユーザのアカウント名を指定します。アカウント情報が入力されていない場合、タスクはシステム アカウントで実行されます。
  • パスワード - パスワードを入力します。
  • ドメイン - ドメインを入力します。
注意:

このタスクをスケジュールするには、管理者権限が必要です。管理者権限があると、スケジュール タスクのレジストリ キーへの書き込みアクセスが可能です。クライアント タスクのスケジュールについては、ePolicy Orchestrator のマニュアルを参照してください。

関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンデマンド スキャン


[パスワード オプション] タブ

オプションの定義

システム全体、またはアイテムを選択して、パスワード セキュリティを設定できます。詳細については、「パスワードの設定がユーザに与える影響」を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ インターフェース パスワード 以下のユーザ インターフェース セキュリティを指定します。
  • パスワードなし - パスワードを入力しなくても構成設定にアクセスできるようにします。
  • リスト内のすべてのアイテムをパスワードで保護 - リストの全アイテムに 1 つのパスワードを指定します。
  • 選択されたアイテムをパスワードで保護 - リストで選択したアイテムに 1 つのパスワードを指定します。
  • 共通の条件一致設定のパスワード保護 - NIAP (National Information Assurance Partnership) のコモン クライテリアで検証済みのセキュリティ製品以外使用できない政府系機関の要件を満たせるように、インターフェースをセキュリティ保護します。

    これにより、管理資格情報を持たないユーザからすべての設定をセキュリティ保護します。ただし、ワークステーションのユーザは、自分のワークステーションで即時オンデマンド スキャンを実行できます。ファイルを即時オンデマンド スキャンに組み入れたり、除外できます。.ZIP ファイルなどのアーカイブを即時オンデマンド スキャンに組み入れたり、除外できます。オンデマンド スキャンおよびオンアクセス スキャンの動作ログを表示できます。

パスワード - パスワードを入力します。

パスワードの確認 - パスワードを再度入力して確認します。
ユーザ インターフェース アイテムのパスワード保護 パスワードで保護するアイテムを選択します。
  • すべて選択 - セクション内のアイテムをすべて選択します。
  • すべて選択解除 - セクション内のアイテムの選択をすべて解除します。

管理者は、[ コンソール] によりインターフェースをロックまたはロック解除できます。

関連参照
タスク スケジュールの設定
関連情報
ユーザ インターフェースへのアクセスの制御


[ポリシー] タブ

オプションの定義

隔離の場所および隔離アイテムの保管期間を設定します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
検疫ディレクトリ | 検疫ディレクトリ用にデフォルトの場所を使用するか、新しい場所を指定します。デフォルトの場所 = <システムドライブ>\Quarantine。
隔離データの保有期間
  • 隔離データの自動削除 - 隔離アイテムを指定日数後に削除します。
  • バックアップ データを検疫ディレクトリに保管しておく日数 - 隔離アイテムが自動的に削除されるまで保管しておく日数を指定します。1 ～ 999 日から選択します。
関連タスク
隔離ポリシーの設定


[プロキシ設定] タブ

プロキシ サーバは、インターネット ユーザのコンピュータをインターネットから隠し、頻繁にアクセスするサイトをキャッシュしてアクセス速度を向上するためのインターネット セキュリティの一部として使用されます。

ネットワークでプロキシ サーバを使用している場合、使用するプロキシ設定、プロキシ サーバのアドレス、および認証を使用するかどうかを指定できます。プロキシ情報は、AutoUpdate リポジトリ リスト (sitelist.xml) に保存されています。ここで構成するプロキシ設定は、リポジトリ リストにあるすべてのリポジトリに適用されます。

注意:

この機能は、ePolicy Orchestrator コンソールでは使用できません。この機能には、VirusScan Enterprise 8.8 コンソールからアクセスします。

オプションの定義

オプション 定義
プロキシを使用しない

プロキシ サーバを指定しません。

Internet Explorer のプロキシ設定を使用

現在インストールしているバージョンの Internet Explorer にプロキシ設定を使用します。

デフォルト値 = Internet Explorer のプロキシ設定を使用。

プロキシ設定を手動で構成する

具体的な必要に合うようにプロキシ設定を構成します。

例外

これを使用できるのは、[プロキシ設定を手動で構成する] を選択していた場合のみです。

プロキシの例外を指定します。[例外] をクリックして、[プロキシの例外] ダイアログ ボックスを開きます。
  • 例外の指定 - プロキシの例外を設定するには、このオプションを選択します。
  • 複数のエントリを区切るにはセミコロン (;) を使用します。例 : internal1;internal2
HTTP

HTTP プロキシ サーバのアドレスを入力します。

FTP

FTP プロキシ サーバのアドレスを入力します。

ポート

HTTP プロキシ サーバまたは FTP プロキシ サーバのポート番号を入力します。

HTTP で認証を使用

HTTP プロキシのアクセスに指定された資格情報を使用します。

HTTP ユーザ名

HTTP ユーザ名を入力します。

HTTP パスワード

HTTP パスワードを入力します。

関連概念
AutoUpdate リポジトリのしくみ
関連参照
リポジトリ リストの設定


［スキャン アイテム］ タブ

オプションの定義

検出対象とする不審なプログラムのカテゴリを選択し、検出しないプログラムについては除外対象を作成できます。

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注意: このオプションは ePolicy Orchestrator でのみ使用できます。
検出する不審なプログラムのカテゴリを選択します。 | 検出する不審なプログラムのカテゴリを指定します。
不審なプログラムから除外 | 除外対象を検出名で指定します。必要に応じて、アイテムの追加と削除を行います。
関連タスク
不審なプログラムの設定
関連情報
../../pgrestrictingunwantedprogram_chapter.ditamap


[検疫ポリシー] タブ

オプションの定義

隔離の場所および隔離アイテムの保管期間を設定します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
検疫ディレクトリ | 検疫ディレクトリ用にデフォルトの場所を使用するか、新しい場所を指定します。デフォルトの場所 = <システムドライブ>\Quarantine。
隔離データの保有期間
  • 隔離データの自動削除 - 隔離アイテムを指定日数後に削除します。
  • バックアップ データを検疫ディレクトリに保管しておく日数 - 隔離アイテムが自動的に削除されるまで保管しておく日数を指定します。1 ～ 999 日から選択します。
関連タスク
隔離ポリシーの設定


リポジトリの追加と編集

新しいリポジトリを追加するか、既存のレポジトリを編集します。

オプションの定義

オプション 定義
リポジトリの説明

リポジトリの名前を指定します。
ファイルの取得先
ファイルの取得先を選択します。デフォルト = HTTP リポジトリ。
  • HTTP リポジトリ - 指定した HTTP リポジトリの場所からファイルを取得します。
    注意: HTTP サイトでは、FTP と同様に、ネットワークのセキュリティとは独立したアップデートが得られますが、FTP よりも高レベルな同時接続がサポートされます。
  • FTP リポジトリ - 指定した FTP リポジトリの場所からファイルを取得します。
    注意: FTP サイトには、ネットワーク セキュリティのアクセス許可を順守せずにアップデートできる柔軟性があります。FTP は、HTTP よりも怪しいコード攻撃にさらされることが少ないため、脅威に対する抵抗力が増す場合があります。
  • UNC パス - 指定した UNC パスの場所からファイルを取得します。
    注意: UNC サイトは、最も迅速にまた簡単にセットアップできます。ドメイン間で UNC アップデートを行うには、各ドメインでセキュリティのアクセス許可が必要で、アップデートの設定が複雑になります。
  • ローカル パス - 指定したローカル パスからファイルを取得します。
URL
これを使用できるのは、[HTTP リポジトリ] または [FTP リポジトリ] を選択していた場合のみです。
  • HTTP — アップデート ファイルがある HTTP サーバおよびフォルダの場所を入力します。
  • FTP — アップデート ファイルがある FTP サーバおよびフォルダの場所を入力します。
パス
これを使用できるのは、[UNC パス] または [ローカル パス] を選択していた場合のみです。
  • UNC パス — UNC 表記 (\\servername\path\) を使用して、アップデート ファイルがあるリポジトリのパスを入力します。
  • ローカル パス — アップデート ファイルを配置したローカル フォルダのパスを入力するか、または [参照] をクリックして、フォルダに移動します。パスは、ローカル ドライブまたはネットワーク ドライブのフォルダへのパスが使用できます。
ポート

これを使用できるのは、[HTTP リポジトリ] または [FTP リポジトリ] を選択していた場合のみです。指定した HTTP サーバまたは FTP サーバのポート番号を入力します。

ユーザ認証

匿名ログインを使用

ログオン アカウントの使用
リポジトリへのアクセスに指定された資格情報を使用します。
注意:

このオプションの名称は、[ファイルの取得先] で選択したオプションに応じて異なります。

指定した資格情報は、AutoUpdate がリポジトリへのアクセスに使用して、必要なアップデート ファイルをダウンロードします。リポジトリのアカウント資格情報を設定する場合、アップデート ファイルを含むフォルダに対して読み取り許可があることを確認します。
  • FTP および UNC リポジトリでは、ダウンロードの資格情報が必要ですが、HTTP リポジトリでは任意です。
  • FTP アップデートでは、匿名でのリポジトリへの接続をサポートします。
  • UNC アップデートでは、ログオン アカウントを使用し、ログオンしているユーザの権限を利用してリポジトリにアクセスすることもできます。
ユーザ名

ユーザ名を入力します。
パスワード

パスワードを入力します。
確認

パスワードを再度入力して確認します。
関連概念
AutoUpdate リポジトリのしくみ
関連参照
リポジトリ リストの設定


[リポジトリ] タブ

アップデートの取得元となるリポジトリを設定します。
注意:

この機能は、ePolicy Orchestrator コンソールでは使用できません。この機能には、VirusScan Enterprise 8.8 コンソールからアクセスします。

オプションの定義

オプション 定義
リポジトリの説明

リポジトリの名前を指定します。

HTTP と FTP のリポジトリに関しては、リストは事前に設定されています。
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

デフォルトのダウンロード サイトは、HTTP リポジトリです。
状態

有効 - AutoUpdate プロセスで使用可能な定義済みリポジトリです。

無効 - AutoUpdate プロセスで使用しない定義済みリポジトリです。これは、常時ではなく時々使用するリポジトリである場合があります。

注意: リポジトリ サイトは必要に応じていくつでも作成し、有効/無効を切り換えます。
追加

新しいリポジトリをリストに追加します。
編集

選択したリポジトリを編集します。
削除

選択したリポジトリを削除します。
上へ

選択したリポジトリをリスト内で上に移動させます。
下へ

選択したリポジトリをリスト内で下に移動させます。
関連概念
AutoUpdate リポジトリのしくみ
関連参照
リポジトリ リストの設定


[マネージャ] タブ

リストのアイテムを選択し、右クリックすると、詳細オプションにアクセスできます。再スキャン、誤検知がないかどうかの確認、復元、削除、プロパティの表示を行うことができます。

関連タスク
隔離ポリシーの設定


[タスク] タブ

オプションの定義

復元する場所へのアクセス権があるユーザのアカウント情報を指定します。アカウントがこのタブに入力されていない場合、復元タスクはシステム アカウントで実行されます。

オプション | 定義
ユーザ | 復元する場所へのアクセス権があるユーザの名前を入力します。
パスワード | 指定したユーザのパスワードを入力します。
ドメイン | 指定したユーザのドメインを入力します。
関連タスク
隔離ポリシーの設定


［スキャンする場所］ タブ

オプションの定義

スキャンするアイテムの種類と場所を設定できます。

オプション 定義
スキャンする場所 スキャン対象の場所を指定します。デフォルト値 = [メモリでのルートキットのスキャン]、[実行中のプロセス]、[すべてのローカル ドライブ]、［レジストリ］、および［Cookie］。[追加]、[編集]、および [削除] をクリックして、[アイテム名] を変更します。
  • メモリでのルートキットのスキャン -システム メモリに、インストールされたルートキット、隠れたプロセス、および不正なコードが自己の隠蔽を謀るような他の動作がないかどうかをスキャンします。このスキャンは、他のすべてのスキャンに先立って実行されます。
    警告:
    ［メモリでのルートキットのスキャン］を有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • 実行中のプロセス -実行中のすべてのプロセスのメモリをスキャンします。[駆除] 以外のアクションは、[スキャンを続行] として処理されます。
    警告:
    ［実行中のプロセス］スキャンを有効にしない場合は、お使いのシステムはマルウェアによるさまざまな攻撃に対して無防備になります。
  • 登録済みファイル - 登録されているすべてのファイルをスキャンします。まず、スキャナによってレジストリでファイル名が検索された後、それらのファイルがスキャンされます。スキャナによって、潜在的に望ましくないファイルに対する参照はレジストリから削除されます。
  • マイ コンピュータ -コンピュータに物理的に取り付けられているか、またはコンピュータにドライブ文字として論理的に割り当てられたすべてのドライブをスキャンします。
  • すべてのローカル ドライブ -コンピュータ上のすべてのドライブおよびそのサブフォルダをスキャンします。
  • すべてのハード ディスク -コンピュータに物理的に接続しているすべてのドライブをスキャンします。
  • すべてのリムーバブル ドライブ -コンピュータに接続されているすべてのリムーバブル ドライブまたはその他の記憶装置をスキャンします。
  • マップされているすべてのネットワーク ドライブ - コンピュータ上のネットワーク ドライブに、論理的にマップされたネットワーク ドライブをスキャンします。
  • ホーム フォルダ - スキャンを開始するユーザのホーム フォルダをスキャンします。
  • ユーザ プロファイル フォルダ - ユーザのマイ ドキュメント フォルダを含めスキャンを開始したユーザのプロファイルをスキャンします。
  • Windows フォルダ -Windows フォルダの中身をスキャンします。
  • Program Files フォルダ -Program Files フォルダの中身をスキャンします。
  • Temp フォルダ -Temp フォルダの中身をスキャンします。
  • ごみ箱 -ごみ箱に含まれるコンテンツをスキャンします。
  • ドライブまたはフォルダ -指定したドライブまたはフォルダをスキャンします。
  • ファイル -指定したファイルをスキャンします。
  • Cookie - Cookies フォルダ内の Cookie をスキャンします。
  • レジストリ - レジストリ エントリをスキャンします。
注意: スキャン アイテムのデフォルトのリストをそのまま使用すると、スキャンする場所が多すぎて非常に時間がかかる場合があります。定期的なスキャン タスクについては、アイテムの範囲を絞れるかどうか検討することをお勧めします。
［オンデマンド スキャンの状況］ダイアログ ボックスが開くと、スキャンする場所が［スキャン対象］の後ろにコンマで区切られた文字列として表示されます。それぞれのスキャン プロセスが完了するたびに、完了した場所はこの文字列から削除されます。
スキャン オプション 選択したアイテムのスキャンの種類。
  • サブフォルダも対象 - 指定したボリューム内のすべてのサブフォルダがスキャンされます。このチェック ボックスをオフにすると、ボリュームのルート レベルのみがスキャンされます。
  • ブート セクタをスキャン - ディスクのブート セクタをスキャンします。
ただし、ディスクに固有のブート セクタが存在し、スキャン対象にできないような場合には、ブート セクタのスキャンは無効にすることをお勧めします。
関連参照
オンデマンド スキャン タスクのタブの設定
関連情報
アイテムのオンアクセス スキャン


スケジュールの詳細設定

スケジュール パラメータを設定します。

オプションの定義

オプション | 定義
開始日 | このタスクを開始する日を指定します。
終了日 | このタスクを終了する日を指定します。
繰り返しタスク | 指定した頻度でタスクを繰り返します。 このオプションを指定する場合、このタスクを繰り返す頻度も指定します。
間隔 | このタスクを繰り返す頻度を指定します。 その頻度が時間単位か分単位かも選択します。
時間 (現地) | 指定された現地時刻にこのタスクを繰り返します。 このオプションを選択する場合、特定の時間も選択します。
期間 | 指定された時間と分の期間このタスクを繰り返します。 このオプションを選択する場合、時間と分も選択します。
時 | 時間単位の時間。0 ～ 99 から選択します。
分 | 分単位の時間。0 ～ 59 から選択します。
関連概念
アップデート タスクとその機能
関連参照
AutoUpdate タスクの設定


[スケジュール] タブ

このタスクのスケジュールの頻度とその他の設定を指定します。

オプションの定義

オプション 定義
ランタイム

以下のオプションから、このタスクの実行頻度を選択します。

日指定 - 指定した日（複数可）にタスクを実行します。

毎日のタスクは、何日おきかに実行することも、月曜から日曜まで毎日実行することもできます。月曜から日曜の毎日以外に、特定の曜日のみにタスクを実行する場合は、毎週のタスクを使用することをお勧めします。

週指定 - 指定した週の特定の曜日にタスクを実行します（週、曜日ともに複数指定可）。

月指定 - 指定した月の特定の日にタスクを実行します（月、日ともに複数指定可）。

1 回のみ - 指定日にタスクを 1 回実行します。

起動時 - システムの起動時にタスクを実行し、タスクを 1 日に 1 回実行するかどうかおよびタスクを遅らせる時間を分単位で指定します。

ログオン時 - ログオン時にタスクを実行し、タスクを 1 日に 1 回実行するかどうかおよびタスクを遅らせる時間を分単位で指定します。

アイドル時 - コンピュータのアイドル時にタスクを実行し、タスクを開始するまでのアイドル時間を分単位で指定します。

タスクが開始され、完了する前にユーザがコンピュータの利用を再開した場合、タスクは完了するまで実行を続けます。

直ちに - 直ちにタスクを実行する。

ダイアルアップ時 - ダイアルアップ時にタスクを実行する。

開始時刻

スケジュールしたタスクの開始時刻を選択します。

UTC 時刻

協定世界時 (UTC)。すべての時間帯で同時にタスクを実行するには、このオプションを選択します。

現地時刻

それぞれの現地時間帯で個別にタスクを実行します。

注意: デフォルト値 = 現地時間
ランダム化を有効にする

設定期間内で、タスクをランダムに実行します。

このオプションを選択する場合は、最大経過時間の時間数と分数も指定します。

注意:

1 分 (最小) ～ 23 時間 (最大) の間で、経過時間の間隔を指定します。たとえば、タスク スケジュールを 1:00 に、ランダム化を 3 時間に設定すると、タスクは 1:00 ～ 4:00 の任意の時刻に実行されます。

このオプションは、起動時、ログオン時、またはアイドル時にスケジュールされたタスクでは利用できません。

時

時間単位の時間。0 ～ 23 時間から選択します。

分

分単位の時間。

注意:
選択対象の分単位の時間は、どのオプションを選択したかによります。たとえば、次のように適用されます。
  • ランダム化を有効にする - 0 ～ 59 分から選択します。
  • 実行し損ねたタスクを遅らせる時間 - 0 ～ 99 分から選択します。
実行し損ねたら実行する

実行されなかったタスクを、コンピュータを再起動したときに実行します。タスクを実行するスケジュールの時刻にコンピュータがオフラインであれば、実行されなかった可能性があります。

注意: この機能では、タスクを実行するスケジュールの時刻にオフラインになっているリモート ユーザおよびネットワークを完全に保護します。
実行し損ねたタスクを遅らせる期間

実行されなかったタスクを遅らせる期間を分単位で選択します。0 ～ 99 分から選択します。

日間隔

指定したとおり何日かおきに、このタスクを実行します。0 ～ 9999 日から選択します。

注意: このオブションは、タスクのスケジュールが [毎日] のときのみ利用できます。
週間隔

指定したとおり何週間かおきに、このタスクを実行します。0 ～ 99 週から選択します。

このオプションを選択する場合、何週間おきか、および曜日も指定します。

注意:

月の特定の日の場合、[日曜日]、[月曜日]、[火曜日]、[水曜日]、[木曜日]、[金曜日]、[土曜日] から選択します。

このオブションは、タスクのスケジュールが [週指定] のときのみ利用できます。

月の特定の日

月の特定の日にこのタスクを実行します。1 ～ 31 日から選択します。

このオプションを選択する場合、月の日数も指定します。

注意: このオブションは、タスクのスケジュールが [月指定] のときのみ利用できます。
月の特定の曜日

月の特定の曜日にこのタスクを実行します。

このオプションを選択する場合、オカレンスと日にちも指定します。

注意:

オカレンスの場合、[第 1]、[第 2]、[第 3]、[第 4]、[最終] から選択します。

月の特定の日の場合、[日曜日]、[月曜日]、[火曜日]、[水曜日]、[木曜日]、[金曜日]、[土曜日] から選択します。

このオプションは、タスクのスケジュールが [月指定] のときのみ利用できます。

月の選択

タスクを実行する月を指定します。

注意: このオプションは、タスクのスケジュールが [月指定] のときのみ利用できます。
実行日

タスクを実行する日を指定します。

注意: このオブションは、タスクのスケジュールが [1 回のみ] のときのみ利用できます。
このタスクを 1 日 1 回実行する

1 日に 1 回このタスクを実行する。

注意:

このオプションを選択しない場合、起動時またはログオン時に毎回タスクが実行されます。

このオプションは、[起動時]、[ログオン時]、または [ダイアルアップ接続時に実行] にスケジュールされたタスクでのみ利用できます。

タスクを遅らせる期間

タスクを遅らせる期間を分単位で指定します。0 ～ 99 から選択します。

注意:

これにより、ユーザがログオンする時間またはログオン スクリプトを実行する時間が確保されます。

このオプションは、[起動時] または [ログオン時] にスケジュールされたタスクでのみ利用できます。

コンピュータが次の間アイドリング状態の場合

タスクを開始する前のコンピュータのアイドル時間を分単位で指定します。0 ～ 999 分から選択します。

注意:

タスクが開始され、完了する前にユーザがコンピュータの利用を再開した場合、タスクは完了するまで実行を続けます。

このオブションは、タスクのスケジュールが [アイドル時] の場合のみ利用できます。

詳細設定

詳細オプションを設定します。

注意: 詳細については、「詳細スケジュール オプション」を参照してください。
関連概念
アップデート タスクとその機能
関連参照
AutoUpdate タスクの設定


[タスク] タブ

このタスクのスケジュールを有効にしユーザ アカウント設定を指定します。

オプションの定義

オプション | 定義
有効 (スケジュールしたタスクが、指定時に実行されます) | 指定時に実行するタスクをスケジュールします。 注意: タスクをスケジュールするには、このオプションを選択します。
次の時間実行が続くタスクを停止 | 指定した時間数と分数が経過した後にタスクを停止します。 注意: タスクが完了する前に中断されると、次回開始時には中断したところからスキャンを再開します。
時 | タスクが停止するまでの時間単位の時間
分 | タスクが停止するまでの分単位の時間
ユーザ | このタスクを実行するユーザ ID を入力します。 注意: 資格情報の使用はオプションです。ここで資格情報を入力しない場合、スケジュールしたタスクはローカル システム アカウントで実行されます。 詳細については、「ログオン権限」を参照してください。
ドメイン | 指定したユーザ ID のドメインを入力します。
パスワード | 指定したユーザ ID とドメインのパスワードを入力します。
関連概念
アップデート タスクとその機能
関連参照
AutoUpdate タスクの設定


[ScriptScan] タブ

オプションの定義

望ましくないスクリプトの実行を防ぎます。

詳細については、「ScriptScan とそのしくみ」を参照してください。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ScriptScan | スクリプトのスキャンを有効にする - JavaScript および VBScript のスクリプトを実行前にスキャンします。
ScriptScan プロセス除外 | プロセス - ScriptScan の除外対象をプロセス名で指定します。プロセス名の指定にはワイルドカードは使用できません。
ScriptScan URL 除外 URL － ［ScriptScan URL 除外］設定を URL によって指定します。注意事項
  • URL の指定にはワイルドカードを使用できません。ただし、たとえば「msn.com」という URL を除外するように指定した場合は、この文字列が含まれたすべての URL がスキャン対象から除外されます。たとえば、次の URL が除外されます。
    • http://weather.msn.com
    • http://music.msn.com
  • Windows Server 2008 では、通常は［ScriptScan URL 除外］設定は Windows Internet Explorer に対して機能しませんが、［サード パーティ製のブラウザ拡張を有効にする］チェック ボックスをオンにしてこの設定を有効にしてから、Windows Server 2008 を再起動した場合は除きます。 詳細については、https://kc.mcafee.com/corporate/index?page=content&id=KB69526 を参照してください。
関連タスク
全般設定
関連情報
アイテムのオンアクセス スキャン


[ユーザ定義の検知対象] タブ

オプションの定義

不審なプログラムとして処理する個別のファイルまたはプログラムを指定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注意: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ定義のアイテム
  • ファイル名 － 検出するファイルまたはプログラムの名前を指定します。

  • 説明 - 指定したファイルが検出されたときに通知に表示する説明を指定します。

注意: サイズがゼロ バイトであるユーザ定義の不審なプログラムはスキャナによって検出されません。
関連タスク
全般設定
関連情報
アイテムのオンアクセス スキャン