서문

이 문서를 효과적으로 사용하려면 이 문서의 작성 대상, 사용된 규칙, 내용 및 다른 참조 문서를 찾는 방법을 이해해야 합니다.

목차

  • 대상 독자
  • 표기 형식
  • 안내서 구성 방법
  • 제품 설명서 찾기


대상 독자

McAfee 설명서는 독자를 대상으로 신중하게 조사하여 작성되었습니다.

본 안내서의 정보는 주로 다음 사용자를 위한 것입니다.
  • 관리자 - 회사의 보안 프로그램을 구현하고 실행하는 사람입니다.
  • 사용자 — 시스템에서 제품 옵션 구성 및 시스템 업데이트를 담당하는 사람입니다.


표기 형식

본 안내서에서는 다음 표기 규칙을 사용합니다.
책 제목 또는 강조 | 책, 장 또는 항목의 제목, 새 용어 소개, 강조
굵은체 | 강조되는 텍스트
사용자 입력 또는 경로 | 사용자가 입력하는 명령 및 기타 텍스트와 폴더 또는 프로그램의 경로
코드 | 코드 샘플
사용자 인터페이스 | 옵션, 메뉴, 단추 및 대화상자를 비롯한 사용자 인터페이스의 단어에 사용됩니다.
파란색 하이퍼텍스트 | 항목 또는 웹 사이트를 연결하는 활성 링크
참고 | 추가 정보(예: 옵션에 액세스하는 대체 방법)
팁 | 제안 및 권장 사항
중요/주의 | 컴퓨터 시스템, 소프트웨어 설치, 네트워크, 비즈니스 또는 데이터를 보호하기 위한 중요한 조언 사항
경고 | 하드웨어 제품을 사용할 때 신체적 상해를 입지 않도록 보호하기 위한 중요한 정보


안내서 구성 방법

이 문서는 VirusScan 콘솔 및 ePolicy Orchestrator 사용자 인터페이스와 함께 참조로 사용됩니다. 또한 VirusScan Enterprise를 사용하여 악성 프로그램으로부터 시스템을 보호하는 방법도 설명합니다. 해당 프로세스를 설명하기 위해 이 문서는 4가지 주요 부분과 부록으로 구분되어 있습니다.
  • 1부 — 방지: 위협 방지 —시스템을 보호하는 가장 좋은 방법은 악성 프로그램이 시스템에 액세스하지 못하도록 방지하는 것입니다. 문서의 이 부분에서는 다음 사항에 대해 설명합니다.
    • 시스템, 액세스 포인트, 메모리를 오버플로 오류와 원하지 않는 프로그램으로부터 보호
    • 탐지 정의와 시스템을 보호하는 데 사용되는 방법 및 이러한 정의의 정기적인 업데이트 중요성
    • 검색에서 파일, 폴더 및 디스크 제외
    • 예약된 작업을 사용하여 시스템을 정기적으로 검색하고 VirusScan Enterprise에서 사용하는 파일 업데이트
  • 2부 — 탐지: 위협 검색 — 다른 파일 시스템이나 인터넷에서 열었거나 복사한 파일은 시스템에 대한 액세스를 제공할 수 있습니다. 또한 API(응용프로그램 인터페이스) 호출과 스크립트는 시스템에 위협을 줄 수 있습니다. 이러한 위협은 다음 VirusScan Enterprise 검색 프로세스 동안 발견됩니다.
    • 온액세스 검색 — 파일을 읽거나 디스크에 기록할 때 파일에서 악성 프로그램을 검색하고 부트 섹터를 보호하고 이미 실행 중인 프로세스의 메모리를 검색하고 쿠키를 탐지하며 원하지 않는 프로그램으로부터 보호합니다.
    • 주문형 검색 — VirusScan 콘솔에서 시작했을 때 예약 기반으로 또는 필요에 따라 위협에 대해 전체 시스템을 검색합니다.
    • 전자 메일 배달 시 검색 및 주문형 검색 — Microsoft Outlook 및 Lotus Notes에서 전자 메일을 통해 도착하는 악성 프로그램으로부터 보호합니다.
    • 버퍼 오버플로 보호 — 특정 프로세스에서 수행한 API 호출을 분석하여 메모리 버퍼의 인접한 데이터를 덮어쓰지 않는지 확인합니다.
    • ScriptScan — Windows 스크립트 호스트를 사용하여 액세스하는 브라우저 또는 기타 응용 프로그램으로부터 위협을 찾습니다.
  • 3부 — 응답: 위협 처리 —VirusScan Enterprise는 위협이 발견된 경우 다음 단계를 수행하도록 구성할 수 있습니다.
    • 위협에 대한 액세스를 거부하거나 추가 작업을 수행하지 않습니다.
    • 위협을 삭제하거나 치료합니다. 이러한 조치를 취하면 원본 파일의 사본이 검역 폴더에 저장됩니다.
    참고: 탐색의 경우 VirusScan Enterprise가 사용자에게 알릴지 여부를 구성할 수 있습니다.
  • 4부 — 보호 모니터, 분석 및 미세 조정 — 보호가 작동하여 실행되면 ePolicy Orchestrator 쿼리와 보고서를 사용하여 시스템을 모니터해야 하며 그런 다음 시스템 보호 수준을 높이거나 낮추기 위해 보안 설정을 변경할 수 있습니다. 또한 VirusScan 콘솔 로그와 SNMP(Simple Network Management Protocol) 트랩을 사용하여 시스템을 모니터할 수도 있습니다.
  • 부록 —VirusScan Enterprise 사용 시 알고 있어야 하는 몇 가지 추가 기능을 설명합니다. 예를 들어, VirusScan Enterprise 명령줄 옵션, VirusScan Enterprise를 통해 원격 시스템에 연결 등이 있습니다.


제품 설명서 찾기

McAfee는 설치에서부터 일반 사용 및 문제 해결에 이르기까지 각 제품 구현 단계에서 필요한 정보를 제공합니다. 제품이 릴리스된 후 해당 제품에 대한 정보는 McAfee 온라인 기술 자료에 입력됩니다.
  1. McAfee 기술 지원 ServicePortal(http://mysupport.mcafee.com)로 이동합니다.
  2. Self Service에서 필요한 정보 유형에 액세스합니다.
    액세스 대상... 수행 단계
    사용자 설명서

    1. 제품 설명서를 클릭합니다.

    2. 제품을 선택한 다음 버전을 선택합니다.

    3. 제품 설명서를 선택합니다.

    기술 자료
    • 제품 관련 질문에 대한 답변을 보려면 기술 자료 검색을 클릭하십시오.
    • 제품 및 버전별로 나열되는 기사를 보려면 Browse the KnowledgeBase를 클릭하십시오.


시작하기

McAfee® 구성 요소의 이해 VirusScan® Enterprise 8.8 소프트웨어 및 소프트웨어를 구성하는 데 사용해야 하는 순서를 통해 위협으로부터 시스템을 보호할 수 있습니다.

목차

  • VirusScan Enterprise 소개
  • 구성 요소 및 상호 작용 방법
  • 보안 전략 생성의 중요성
  • VirusScan 콘솔 및 액세스 방법
  • 처음 해야 할 일


VirusScan Enterprise 소개

VirusScan Enterprise 소프트웨어가 설치되는 즉시 위협으로부터 시스템이 보호됩니다. 소프트웨어가 수행하는 작업, 이번 릴리스의 새로운 기능 및 주요 구성 요소에 대해 이해하고 있으면 보호 수준을 높일 수 있습니다.

정의 및 기능

VirusScan Enterprise는 간편하게 확장 가능한 보호 기능, 빠른 성능 및 이동 설계를 제공함으로써 다음과 같은 위협으로부터 사용자 환경을 보호합니다.

  • 바이러스, 웜 및 트로이 목마
  • 액세스 포인트 위반 및 취약한 버퍼 오버플로우
  • 잠재적으로 원하지 않는 코드 및 프로그램

VirusScan Enterprise에서 위협을 탐지하면 환경 보호를 위해 사용자가 구성한 액션을 수행합니다.

소프트웨어를 독립 실행형 제품으로 구성하거나 McAfee® ePolicy Orchestrator® 소프트웨어 버전 4.0 이상을 사용하여 VirusScan Enterprise 정책을 관리하고 시행한 다음, 쿼리와 대시보드를 사용하여 작업과 탐지를 추적할 수 있습니다.

참고: 이 문서는 ePolicy Orchestrator 4.0, 4.5 및 4.6 사용에 대해 설명합니다. ePolicy Orchestrator의 이러한 버전 사용에 대한 자세한 내용은 해당 버전의 제품 설명서를 참조하십시오.

새로운 기능

이번 릴리스에는 다음과 같은 새로운 기능이 포함되어 있습니다.
  • 향상된 성능.
  • ePolicy Orchestrator 4.5 및 4.6를 사용하여 VirusScan Enterprise 시스템을 관리할 수 있습니다.
  • 새로운 ScriptScan URL 제외 기능을 사용하면 레지스트리를 수동으로 편집하는 대신 제외를 구성할 수 있습니다.
  • AntiSpyware Enterprise Module는 VirusScan Enterprise 8.8 소프트웨어에 완벽하게 통합되었습니다.
  • Outlook 2010 전자 메일 검색을 지원합니다.
  • Lotus Notes 8.0x ~ 8.5.1 전자 메일 검색을 지원합니다.


구성 요소 및 상호 작용 방법

VirusScan Enterprise의 관리자와 사용자는 구성 요소와 연결에 익숙해져야 합니다. 다음 그림은 기본적인 환경에 대한 구성 요소를 보여줍니다.

그림 1. VirusScan Enterprise 구성 요소

클라이언트 시스템

여기에서 VirusScan Enterprise 및 선택적 McAfee Agent가 설치되고 구성됩니다.
  • DAT 파일 — 악성 프로그램 서명이라고도 하는 탐지 정의 파일은 검색 엔진과 함께 위협을 식별하고 조치를 취합니다.
  • 검색 엔진 — 클라이언트 컴퓨터에서 파일, 폴더 및 디스크를 검색하고 이를 알려진 바이러스가 있는지 DAT 파일의 정보와 비교하는 데 사용됩니다.
    참고: DAT 파일과 검색 엔진은 McAfee 본사의 인터넷 연결을 사용하거나 지정된 서버에 기업 인트라넷을 통해 선택적 연결을 사용하여 필요에 따라 업데이트됩니다.
  • Artemis(의심스러운 파일에 대해 경험적 접근 방식의 네트워크 검사) — VirusScan Enterprise에 의해 보호되는 클라이언트 시스템에서 실행되는 의심스러운 프로그램과 DLL을 찾습니다. 실시간 악성 프로그램 방어가 의심스러운 프로그램을 탐지하면 의심스러운 파일의 지문이 들어 있는 DNS 요청을 McAfee Labs에서 호스팅하는 중앙 데이터베이스 서버로 전송합니다.
  • McAfee Agent(선택 사항) — McAfee 관리 제품과 McAfee ePolicy Orchestrator 서버 사이에 안전한 통신을 제공합니다. 에이전트는 업데이트, 로깅, 이벤트와 속성 보고, 작업 예약, 통신 및 정책 저장 같은 로컬 서비스도 제공합니다.

McAfee 본사

McAfee 본사와 McAfee Labs 홈 및 McAfee 기술 지원은 다음 VirusScan Enterprise 서비스를 제공합니다.
  • DAT 업데이트 — McAfee 중앙 데이터베이스 서버에 저장되어 있고 자동 업데이트를 사용하는 이러한 DAT 업데이트 파일은 VirusScan Enterprise 클라이언트나 옵션 DAT 리포지토리로 복사되어 실시간으로 발견될 때 알려진 위협과 알려진 바이러스의 새로운 목록에 대처하기 위한 정보를 제공합니다.
  • 검색 엔진 업데이트 — 중앙 데이터베이스 서버에 저장되어 있는 검색 엔진 업데이트는 필요할 때 다운로드하여 VirusScan Enterprise 검색 엔진을 최신 상태로 유지할 수 있습니다.
  • McAfee Labs — 이 위협 라이브러리에는 출처, 시스템 감염 방식 및 이를 처리하는 방법 등 바이러스, 트로이 목마, 속임수 및 잠재적으로 원하지 않는 프로그램(PUP) 위협에 대한 자세한 정보가 들어 있습니다. Artemis 기능은 의심스러운 파일의 지문을 McAfee Lab로 보내고, 여기에서 파일을 분석하여 어떤 조치를 취할지 결정합니다.

Server(서버)

옵션 서버는 다음 구성 요소를 사용하여 많은 클라이언트 시스템을 원격으로 관리하고 업데이트합니다.
  • ePolicy Orchestrator — 중앙에서 VirusScan Enterprise 정책을 관리하고 시행한 다음 쿼리와 대시보드를 사용하여 활동과 탐지를 추적합니다.
    참고: 이 문서는 ePolicy Orchestrator 4.0, 4.5 및 4.6 사용에 대해 설명합니다. ePolicy Orchestrator에 대한 자세한 내용은 사용 중인 버전의 제품 설명서를 참조하십시오.
  • DAT 리포지토리 — McAfee 다운로드 사이트에서 DAT 업데이트를 검색합니다. 해당 클라이언트 또는 서버에서 다른 모든 컴퓨터에 대한 액세스 권한을 제공하므로 조직 전체로 DAT 파일을 복제할 수 있습니다. 이렇게 하면 업데이트된 파일을 공유 사이트로 복사하는 프로세스를 자동화함으로써 네트워크를 통해 전송되는 데이터의 양을 최소화합니다.


보안 전략 생성의 중요성

VirusScan Enterprise를 사용하여 바이러스, 웜 및 트로이 목마 파일로부터 클라이언트 시스템을 보호하려면 위협 방지와 탐지 정의, 위협에 대한 대처 및 지속적인 분석과 조정 등 제대로 계획된 전략이 필요합니다.

방지 — 위협 방지

모든 데이터 소스를 보호할 수 있도록 보안 요구 사항을 정의한 다음 사용자 환경을 침입으로부터 보호할 수 있는 효과적인 전략을 개발합니다. 침입을 방지하려면 다음 기능을 구성합니다.
  • 사용자 인터페이스 보안 — 표시 및 암호 보호를 설정하여 VirusScan Enterprise 사용자 인터페이스에 대한 액세스를 제어합니다.
  • 액세스 보호 — 액세스 보호 규칙을 사용하여 파일, 레지스트리 및 포트에 관한 원하지 않는 동작으로부터 컴퓨터를 보호합니다.
  • 버퍼 오버플로우 방지 — 비정상적인 프로그램이나 위협이 버퍼의 경계를 벗어나지 않고 버퍼에 데이터를 쓰는 동안 인접 메모리를 덮어쓰지 않도록 보호합니다. 이러한 악용된 버퍼 오버플로우는 컴퓨터에서 임의의 코드를 실행할 수 있습니다.
  • 원하지 않는 프로그램 방지 — 스파이웨어, 애드웨어와 같은 잠재적으로 원하지 않는 프로그램이 컴퓨터에 액세스하지 못하도록 차단합니다.

탐지 — 위협 찾기

침입이 발생할 때 이를 탐지하는 효과적인 전략을 개발합니다. 위협을 탐지하도록 다음 기능을 구성합니다.
  • 업데이트 작업 — McAfee 다운로드 웹 사이트에서 DAT 및 검색 엔진의 자동 업데이트를 가져옵니다.
  • 온액세스 스캐너 — 파일을 디스크에서 읽거나 디스크에 쓸 때 모든 소스의 잠재적 위협을 탐지합니다. 쿠키 폴더에서 잠재적으로 원하지 않는 쿠키를 검색할 수도 있습니다.
  • 주문형 검색 작업 — 즉시 검색 및 예약 검색 작업을 사용하여 잠재적인 위협을 탐지합니다. 잠재적으로 원하지 않는 쿠키와 이전에 치료되지 않은 스파이웨어 관련 레지스트리 항목을 검색할 수도 있습니다.
  • 배달 시 및 주문형 전자 메일 스캐너 — 메시지, 첨부 파일 및 공용 폴더에 대한 배달 시 검색을 사용하여 Microsoft Outlook 전자 메일 클라이언트에 대한 잠재적인 위협을 탐지합니다. 메시지에 액세스할 때 Lotus Notes 전자 메일 클라이언트에 대한 잠재적 위협을 탐지합니다.
  • Quarantine Manager 정책 — 검역 위치와, 검역된 항목을 보관하는 시간을 지정합니다. 필요에 따라 검역된 항목을 복원합니다.

대응 — 위협 처리

제품 로그 파일, 자동 작업 및 기타 알림 기능을 사용하여 탐지를 처리하는 가장 좋은 방법을 결정합니다.
  • 액션 — 탐지에 대해 액션을 수행할 기능을 구성합니다.

  • 로그 파일 — 제품 로그 파일을 모니터하여 탐지된 항목 내역을 봅니다.

  • 쿼리 및 대시보드 — ePolicy Orchestrator 쿼리와 대시보드를 사용하여 검색 작업 및 탐지를 모니터합니다.

조정 — 보호 모니터, 분석 및 미세 조정

처음 VirusScan Enterprise를 구성한 경우 항상 구성을 모니터하고 분석하는 것이 좋습니다. 그러면 시스템과 네트워크 성능이 개선되는 것은 물론 필요한 경우 바이러스 보호 수준을 향상시킬 수도 있습니다. 예를 들어, 다음 VirusScan Enterprise 도구와 기능은 모니터, 분석 및 미세 조정 프로세스의 일부로 수정할 수 있습니다.
  • 로그 파일(VirusScan 콘솔) — 탐지된 항목 내역을 봅니다. 이 정보를 분석하면 시스템 성능을 개선하기 위해 보호를 향상시키거나 구성을 변경할 필요가 있는지 알 수 있습니다.
  • 쿼리 및 대시보드(ePolicy Orchestrator 콘솔) — 검색 작업과 탐지를 모니터합니다. 이 정보를 분석하면 시스템 성능을 개선하기 위해 보호를 향상시키거나 구성을 변경할 필요가 있는지 알 수 있습니다.
  • 예약 작업 — 작업(예: 자동 업데이트)과 검색 시간을 수정하여 사용량이 적은 시간에 이 작업을 실행하여 성능을 개선합니다.
  • DAT 리포지토리 — 이러한 소스 파일을 업데이트가 필요한 클라이언트 가까이 이동하여 기업 인터넷 또는 인트라넷을 통과하는 네트워크 트래픽을 줄입니다.
  • 검색 정책 수정 — 로그 파일이나 쿼리 분석에 따라 성능이나 바이러스 보호를 향상시킵니다. 예를 들어, 제외, 높거나 낮은 위험 프로파일 검색을 사용하는 시기 및 쓸 때 검색을 비활성화하는 시기를 구성하면 성능을 개선할 수 있습니다.
    주의:
    디스크에서 읽을 때 검색을 활성화하지 않으면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.


VirusScan 콘솔 및 액세스 방법

VirusScan 콘솔은 프로그램 작업의 독립 실행형 버전을 위한 인터페이스입니다. 이 인터페이스를 사용하여 제품을 구성하고 모니터링하고 업데이트합니다.
참고: 이 정보는 관리되는 ePolicy Orchestrator 버전이 아닌 제품의 독립 실행형 버전에만 적용됩니다.


VirusScan 콘솔 및 작동 방식

VirusScan Enterprise의 기능과 해당 구성 요소를 이해한 후에는 이 기능에 액세스하는 방법을 숙지해야 합니다. 다음 방법 중 하나를 사용하여 VirusScan Enterprise 8.8 콘솔을 엽니다.
  • 시작 메뉴에서 프로그램 | McAfee | VirusScan 콘솔을 선택합니다.
  • 시스템 트레이에서 VirusScan Enterprise 방패 아이콘을 마우스 오른쪽 단추로 클릭한 다음 VirusScan 콘솔을 선택합니다.

메뉴 모음

메뉴 항목을 사용하여 작업을 만들고 속성을 구성하며 추가 정보에 액세스합니다.
  • 작업 — 위협에 대한 검색 또는 DAT 파일 업데이트 같은 작업을 만들고 구성합니다.
  • 편집 - 선택한 작업을 복사, 붙여넣기, 삭제하거나 해당 작업의 이름을 변경합니다.
  • 보기 — 도구 모음 및 상태 표시줄을 표시하고 화면을 새로 고칩니다.
  • 도구 - 사용자의 인터페이스 옵션 구성, 사용자 인터페이스 보안의 잠금 또는 잠금 해제, 알림 구성, 이벤트 뷰어 액세스, 관리자 권한이 있는 경우 원격 콘솔 열기, 리포지토리 목록 가져오기 또는 편집, DAT 파일 롤백 같은 작업을 수행합니다.
  • 도움말 — 온라인 도움말 항목, McAfee Labs 웹 사이트의 위협 라이브러리, 샘플 제출 웹 사이트 및 기술 지원 웹 사이트에 액세스합니다. 또한 제품 설치를 복원하고 저작권 정보에 대한 정보 대화 상자는 물론 설치되어 있는 제품 버전, 사용권, 정의 파일, 검색 엔진, 추가 드라이버 및 패치를 확인할 수도 있습니다.
참고: 메뉴의 각 항목에는 연결된 바로 가기 키가 있습니다. 일부 운영 체제에서는 F10 또는 ALT를 사용하여 메뉴에 액세스하지 않는 한 이러한 바로 가기 키를 사용하지 못할 수 있습니다.

도구모음

아이콘을 사용하여 일반적으로 사용되는 다음 명령에 액세스합니다.
  • 선택한 작업의 등록 정보를 표시합니다.
  • 선택한 작업을 시작합니다.
  • 선택한 작업을 중지합니다.
  • 선택한 작업을 복사합니다.
  • 선택한 작업을 붙여 넣습니다.
  • 선택한 작업을 삭제합니다.
  • 경고 속성을 구성합니다.
  • 이벤트 뷰어를 실행합니다.
  • McAfee Labs 웹 사이트의 정보 라이브러리에 액세스합니다.
  • 관리자 권한이 있으면 원격 컴퓨터에 연결합니다.
  • 새 주문형 검색을 만듭니다.

작업 목록

기본 작업과 각 작업의 상태 및 마지막 결과를 비롯하여 새로 만든 작업도 표시합니다.

상태 표시줄

현재 작업의 상태를 표시합니다.


마우스 오른쪽 단추 클릭 기능 사용

오른쪽 클릭 기능을 사용하여 새 작업 만들기, 작업 통계 및 로그 보기, 작업 등록 정보 페이지 열기, 특정 파일 또는 폴더 검색, 즉시 업데이트 작업 수행 등의 자주 사용하는 액션에 빨리 액세스할 수 있습니다.

기능 설명

위치 | 설명 | 예제
콘솔 VirusScan 콘솔을 마우스 오른쪽 단추로 클릭하여 마우스 오른쪽 단추 클릭 기능을 표시합니다. 이 기능은 작업 목록에서 작업을 선택했는지 여부와 선택한 작업에 따라 달라집니다.
  • 콘솔에서 작업을 마우스 오른쪽 단추로 클릭하여 해당 등록 정보에 액세스합니다. 선택한 작업에 따라 해당 작업을 시작, 중지, 사용 또는 사용하지 않고 통계 및 작업 로그를 볼 수도 있습니다. 일부 경우에는 작업의 이름을 바꾸거나 작업을 삭제할 수 있습니다.
  • 콘솔의 빈 영역을 마우스 오른쪽 단추로 클릭하여 새 검색 또는 업데이트 작업을 만듭니다.
Windows 탐색기 선택한 파일이나 폴더를 마우스 오른쪽 단추로 클릭하여 즉시 위협 검색을 수행합니다. 검색할 작업을 선택할 수 있습니다.
  • 치료 — 탐지된 항목을 보고 및 치료합니다.
  • 계속 — 탐지를 보고하고 계속 검색합니다.

위험하다고 의심되는 파일이나 폴더에 대해 즉시 검색을 수행합니다.

검색을 시작하면 모든 검색 설정을 사용하는 주문형 스캐너가 바로 시작됩니다. 액션 옵션을 선택합니다. 다른 검색 설정은 사용자 지정할 수 없습니다.

시스템 트레이 | VirusScan Enterprise 아이콘 마우스 오른쪽 단추 클릭 설명은 시스템 트레이 아이콘 및 작동 방식을 참조하십시오.


시스템 트레이 아이콘 및 작동 방식

일단 VirusScan Enterprise가 설치되면 설치 과정에서 이 기능을 구성한 경우 다음 아이콘 중 하나가 Windows 시스템 트레이에 나타납니다.

방패 아이콘에 "M"

McAfee Agent 버전 4.5 이상을 사용하는 ePolicy Orchestrator 관리 시스템에 나타납니다. 다음과 같이 표시됩니다.
  • 상태 — 이 아이콘은 액세스 보호 트리거 경보를 나타내기 위해 또는 McTray 버전 2.x 이상(McAfee Agent 4.5 이상)을 사용하여 ePolicy Orchestrator 관리 클라이언트에서 온액세스 검색이 비활성화된 경우 변경되지 않습니다. 상태 변경은 도구 설명으로 표시됩니다.
  • 도구 설명 — 아이콘 도구 설명은 다음과 같습니다.
    • McAfee 상태: 이상 없음 — 정상. 옵션은 다음과 같습니다.
      • 보안 상태 보기 — 확인 표시가 나타납니다.
      • 빠른 설정 | 온액세스 바이러스 검색 - 켜짐 — 확인 표시가 나타납니다.
    • McAfee 상태: 문제가 탐지됨 — 온액세스 검색이 비활성화되었습니다. 옵션은 다음과 같습니다.
      • 보안 상태 보기 — 느낌표가 나타납니다.
        참고: 보안 상태 보기를 클릭하여 상태 열이 "온액세스 검색 비활성화됨"인 문제가 있는 McAfee 보안 상태 대화 상자를 표시합니다.
      • 빠른 설정 | 온액세스 바이러스 검색 - 꺼짐 — 확인 표시가 나타나지 않습니다.
    • McAfee 상태: 문제가 탐지됨 — 액세스 보호 이벤트가 트리거됩니다. 옵션은 다음과 같습니다.
      • 보안 상태 보기 — 느낌표가 나타납니다.
        참고: 보안 상태 보기를 클릭하여 상태 열이 "액세스 보호 로그를 참조하십시오"인 문제가 있는 McAfee 보안 상태 대화 상자를 표시합니다.
      • 빠른 설정 | 온액세스 바이러스 검색 - 켜짐 — 확인 표시가 나타납니다.
  • 메뉴 옵션 — 마우스 오른쪽 단추 클릭 메뉴 옵션은 다음과 같습니다.
    • 보안 업데이트 — DAT 파일과 기타 변경 사항을 업데이트합니다.
    • 빠른 설정 — 다음을 표시합니다.
      • 온액세스 검색 등록 정보 — 온액세스 스캐너 등록 정보를 엽니다.
      • 온액세스 검색 켜기 또는 끄기 — 온액세스 스캐너를 토글합니다.
      • 온액세스 검색 등록 정보 — 온액세스 스캐너 등록 정보를 엽니다.
      • 온액세스 검색 메시지 — 온액세스 검색 통계 또는 메시지를 엽니다.
      • 온액세스 보호 로그 파일 열기 — 로그 파일을 엽니다.

    • 기능 관리 | VirusScan Enterprise — VirusScan 콘솔을 엽니다.
    • 컴퓨터 검색 | 위협 — 즉시 검색을 시작합니다.
    • 보안 상태 보기 — McAfee 보안 상태 대화 상자를 표시합니다.
    • McAfee Agent 상태 모니터 — McAfee 보안 상태 모니터 대화 상자를 표시합니다.
    • 정보 — 정보 대화 상자를 엽니다.

상자에 "M"

McTray 1.0을 사용하는 독립 실행형 시스템과 McTray 1.0을 통해 McAfee Agent 버전 4.0을 사용하는 ePolicy Orchestrator 관리 시스템에 나타납니다. 다음과 같이 표시됩니다.
  • 상태 — 다음을 표시합니다.
    • 상자에 "M" — 정상 상태.
    • 느낌표가 있는 상자에 "M" — 액세스 보호 위반 이벤트가 트리거되거나 온액세스 검색이 비활성화되었습니다. 마우스 오른쪽 단추 클릭 메뉴 옵션은 다음과 같습니다.
      • 원과 선이 있는 방패에 "V" — 온액세스 검색이 비활성화되었음을 나타냅니다.
      • 빨간색 외곽선이 있는 방패에 "V" — 온액세스 검색이 활성화되었음을 나타내지만 액세스 보호 로그 파일을 참조하십시오.

  • 도구 설명 — "McAfee"를 표시합니다.
  • 메뉴 옵션 — 마우스 오른쪽 단추 클릭 메뉴 옵션은 다음과 같습니다.
    • VirusScan 콘솔 — VirusScan 콘솔을 엽니다.
    • 온액세스 스캐너 비활성화 또는 활성화 — 온액세스 스캐너를 토글합니다.
    • 온액세스 검색 등록 정보 — 온액세스 스캐너 등록 정보를 엽니다.
    • 온액세스 검색 통계 — 온액세스 검색 통계를 엽니다.
    • 온액세스 검색 메시지 — 온액세스 검색 통계 또는 메시지를 엽니다.
    • 주문형 검색 — 일회성 구성 가능한 주문형 검색을 만듭니다.
    • 지금 업데이트 — 즉시 업데이트 작업을 수행합니다.
    • VirusScan Enterprise 정보 — 정보 대화 상자를 엽니다.

방패 아이콘에 "V"

McTray 1.0이 없는 독립 실행형 시스템에 나타납니다. 다음과 같이 표시됩니다.
  • 상태 — 다음을 표시합니다.
    • 방패에 "V" — 정상.
    • 원과 선이 있는 방패에 "V" — 온액세스 검색이 비활성화되었음을 나타냅니다.
    • 빨간색 외곽선이 있는 방패에 "V" — 온액세스 검색이 활성화되었음을 나타내지만 액세스 보호 로그 파일을 참조하십시오.
  • 도구 설명 — 도구 설명은 다음과 같습니다.
    • 방패에 "V" — McAfee OAS: 활성화됨, 정상.
    • 원과 선이 있는 방패에 "V" — McAfee OAS: 사용 안 함
    • 빨간색 외곽선이 있는 방패에 "V" — McAfee OAS: 활성화됨, 액세스 보호 로그 참조.

  • 메뉴 옵션 — 마우스 오른쪽 단추 클릭 메뉴 옵션은 다음과 같습니다.
    • 보안 업데이트 — DAT 파일과 기타 변경 사항을 업데이트합니다.
    • 빠른 설정 — 다음을 표시합니다.
      • 온액세스 검색 등록 정보 — 온액세스 스캐너 등록 정보를 엽니다.
      • 온액세스 검색 켜기 또는 끄기 — 온액세스 스캐너를 토글합니다.
      • 온액세스 검색 메시지 — 온액세스 검색 통계 또는 메시지를 엽니다.
      • 온액세스 보호 로그 파일 열기 — 로그 파일을 엽니다.

    • 기능 관리 | VirusScan Enterprise — VirusScan 콘솔을 엽니다.
    • 컴퓨터 검색 | 위협 — 즉시 검색을 시작합니다.
    • 보안 상태 보기 — McAfee 보안 상태 대화 상자를 표시합니다.
    • McAfee Agent 상태 모니터 — McAfee 보안 상태 모니터 대화 상자를 표시합니다.
    • 정보 — 정보 대화 상자를 엽니다.


처음 해야 할 일

소프트웨어가 설치되면 해당 제품과 함께 제공되는 DAT 파일을 사용합니다. 이 파일은 환경에 대한 일반 보안을 제공합니다. McAfee는 제품을 클라이언트 시스템에 배포하기 전에 최신 DAT 파일을 가져와서, 사용자 요구 사항을 충족하기 위해 구성을 사용자 지정하도록 권장합니다.

제품을 설치한 후 즉시 다음 조치를 취하십시오.

  1. 사용자 인터페이스 보안 설정. 표시 및 암호 옵션을 구성하여 특정 구성 요소나 VirusScan Enterprise 전체 사용자 인터페이스에 액세스할 수 없도록 합니다. 자세한 내용은 사용자 인터페이스에 대한 액세스 제어를 참조하십시오.
  2. DAT 파일 업데이트. 지금 업데이트 작업을 수행하여 현재 DAT 파일을 최신 상태로 유지합니다. 자세한 내용은 탐지 정의 업데이트를 참조하십시오.
  3. 침입 방지. 다음 기능을 구성하여 잠재적인 위협이 시스템에 액세스하지 못하도록 합니다.
    • 액세스 보호. 액세스 보호 규칙을 구성하여 컴퓨터에 원하지 않는 변경이 발생하지 않도록 하고, McAfee 프로세스가 종료되지 않도록 방지합니다. 자세한 내용은 시스템 액세스 포인트 보호를 참조하십시오.
    • 버퍼 오버플로우 방지. 버퍼 오버플로우 탐지를 활성화하고 제외 항목을 지정합니다. 자세한 내용은 버퍼 오버플로우 악용 차단을 참조하십시오.
    • 원하지 않는 프로그램 정책. 잠재적으로 원하지 않는 프로그램을 탐지하도록 온액세스, 주문형 및 전자 메일 스캐너에서 사용할 정책을 구성합니다. 탐지할 원하지 않는 프로그램 범주를 미리 정의된 목록에서 선택한 다음 탐지하거나 제외할 프로그램을 추가로 정의합니다. 자세한 내용은 잠재적으로 원하지 않은 프로그램 제한을 참조하십시오.
  4. 침입 탐지. 시스템에 대한 잠재적인 위협을 탐지하고, 탐지 발생 시 알린 다음 액션을 취하도록 다음 기능을 구성합니다.
    • 자동 업데이트. 최신 DAT 파일, 검색 엔진 및 제품 업그레이드를 가져오도록 업데이트 작업을 구성합니다. 자세한 내용은 탐지 정의 업데이트를 참조하십시오.
    • 온액세스 스캐너. 사용자 환경에 잠재적인 위협이 액세스할 경우 위협을 탐지하고 액션을 취하도록 스캐너를 구성합니다. 원하지 않는 프로그램 검색을 활성화하고 쿠키 폴더에서 쿠키를 검색합니다. 자세한 내용은 온액세스 항목 검색을 참조하십시오.
    • 주문형 스캐너. 환경에서 잠재적인 위협을 탐지하고 액션을 취하도록 검색 작업을 구성합니다. 원하지 않는 프로그램 검색을 활성화하고 쿠키 폴더의 쿠키와 이전에 치료하지 않은 잠재적으로 원하지 않는 스파이웨어 관련 레지스트리 항목을 검색합니다. 자세한 내용은 주문형 항목 검색을 참조하십시오.
    • 전자 메일 스캐너. Microsoft Outlook 및 Lotus Notes 전자 메일 클라이언트에 대한 배달 시 검색 및 주문형 검색을 구성합니다. 원하지 않는 프로그램 검색을 활성화합니다. 자세한 내용은 배달 시 및 주문형 전자 메일 검색을 참조하십시오.
  5. 경보 및 검역 위협을 보냅니다. 탐지가 발생하면 알려주고 검역 항목을 관리하도록 이 기능을 구성합니다.
    • 알림 및 통보. 사용자가 탐지 통보 및 알림을 받는 방법과 시기를 구성합니다. 자세한 내용은 경보 및 알림 구성을 참조하십시오.
    • 검역 관리자 정책. 검역 폴더 위치 및 검역 항목을 자동으로 삭제하기 전에 보관하는 일수를 구성합니다. 자세한 내용은 검역 항목을 참조하십시오.
관련 개념
검역 항목
관련 작업
배달 시 및 주문형 전자 메일 검색
관련 정보
사용자 인터페이스에 대한 액세스 제어
탐지 정의 업데이트
시스템 액세스 포인트 보호
버퍼 오버플로우 악용 차단
잠재적으로 원하지 않는 프로그램 제한
온액세스 항목 검색
주문형 항목 검색
알림 및 통보 구성


1부 - 방지: 위협 방지

방지는 위협이 사용자 시스템에 대한 액세스 권한을 얻지 못하도록 방지하는 보호 전략의 첫 단계입니다.

목차

  • 액세스 보호
  • 시스템 액세스 포인트 보호
  • 버퍼 오버플로우 악용 차단
  • 잠재적으로 원하지 않는 프로그램 제한
  • 탐지 정의 업데이트
  • 검색 항목 제외
  • 예약된 작업 사용


액세스 보호

클라이언트 시스템에 대한 위협 액세스 방지는 악성 프로그램에 대한 1차 방어선입니다. VirusScan Enterprise의 액세스 보호 기능은 요청한 액션을 구성된 규칙 목록과 비교합니다. 액세스 위반이 발생할 경우 이를 차단하거나 보고하고 또는 차단한 다음 보고하도록 각 규칙을 구성할 수 있습니다.

액세스 보호는 지정된 포트, 파일, 공유, 레지스트리 키와 레지스트리 값에 대한 액세스를 제한함으로써 컴퓨터에 원하지 않는 변경이 발생하지 않도록 합니다. 또한 사용자 임의로 중지하지 못하도록 함으로써 McAfee 프로세스를 보호합니다. 액세스 방지는 아웃브레이크 발생 전과 아웃브레이크 동안에 중요합니다.

이 기능은 미리 정의된 규칙과 사용자 정의 규칙을 사용하여 액세스가 가능한 항목과 불가능한 항목을 지정합니다. 액세스 위반이 발생할 경우 이를 차단하거나 보고하고 또는 차단한 다음 보고하도록 각 규칙을 구성할 수 있습니다. 미리 정의된 규칙과 범주는 McAfee 업데이트 사이트에서 업데이트할 수 있습니다.

참고: 포트, 파일, 공유 및 레지스트리 키와 레지스트리 값에 대한 액세스 시도를 탐지하려면 액세스 위반을 탐지하는 온액세스 스캐너가 활성화되어야 합니다.

위협이 액세스 권한을 얻는 방식

위협이 시스템에 대한 액세스 권한을 얻는 가장 일반적인 방법은 다음과 같습니다.
  • 매크로 — 워드 프로세싱 문서 및 스프레드시트 응용 프로그램에 포함
  • 실행 파일 — 정상적으로 보이는 프로그램에, 예상된 프로그램과 함께 바이러스가 있을 수 있습니다. 예를 들어, 몇 가지 일반적인 파일 확장명은 .EXE, .COM, .VBS, .BAT, .HLP 및 .DLL입니다.
  • 전자 메일 — 첨부 파일이 있는 전자 메일 메시지의 일부에 조크, 게임 및 이미지 포함
  • 스크립트 — 웹 페이지 및 전자 메일과 연결되어 있는 스크립트(예: ActiveX 및 JavaScript)는 실행이 허용된 경우 바이러스를 포함할 수 있습니다.
  • IRC(Internet Relay Chat) 메시지 — 이러한 메시지와 함께 전송된 파일은 메시지의 일부로 악성 프로그램을 포함하기 쉽습니다. 예를 들어, 자동 시작 프로세스는 웜과 트로이 목마 위협을 포함할 수 있습니다.
  • 브라우저 및 응용 프로그램 도움말 파일 — 이러한 도움말 파일을 다운로드하면 포함된 바이러스와 실행 파일에 시스템이 노출됩니다.
  • 모든 방법 조합 — 정교한 악성 프로그램 작성자는 위의 모든 방법을 조합하고 컴퓨터에 액세스를 시도하기 위해 다른 방법 내에 악성 프로그램 일부를 포함시키기도 합니다.

목차

관련 개념
액세스 위협을 중지하는 방법
관련 정보
사용자 인터페이스에 대한 액세스 제어


액세스 위협을 중지하는 방법

액세스 보호 기능의 구성을 활성화하거나 변경하여 안티스파이웨어 보호, 안티바이러스 보호, 일반적인 보호, 가상 시스템 보호를 구성하고 자체적인 보호 규칙을 정의할 수 있습니다. 다음은 VirusScan Enterprise가 액세스 보호를 제공하기 위해 사용하는 기본 프로세스입니다.

위협이 발생할 때 취하는 단계

  1. 사용자 또는 프로세스가 액션을 취합니다.
  2. 이 액션은 정의된 규칙에 따라 액세스 보호에 의해 검사됩니다.
  3. 규칙이 위반되면 사용자 또는 프로세스가 요청한 액션이, 구성된 규칙의 정보를 사용하여 관리됩니다. 예를 들어, 이 액션으로 인해 아무것도 발생하지 않거나, 차단되거나 또는 차단되고 보고서가 전송됩니다.
  4. 액세스 보호 로그 파일이 업데이트되고 ePolicy Orchestrator 글로벌 관리자를 위한 이벤트가 생성됩니다.

액세스 위협의 예제

  1. 사용자가 인터넷에서 MyProgram.exe 프로그램을 다운로드합니다.
    참고: 이 예제에서 MyProgram.exe는 악성 프로그램이 아닙니다.
  2. 사용자가 프로그램을 시작하고 제대로 시작되는 것처럼 보입니다.
  3. MyProgram.exe는 AnnoyMe.exe라는 하위 프로세스를 시작하고 시작할 때 항상 로드될 수 있도록 운영 체제를 수정하려고 시도합니다.
  4. 액세스 보호는 요청을 처리한 다음 차단하고 보고하도록 구성된 기존 규칙과 일치하는지 확인합니다.
  5. AnnoyMe.exe가 운영 체제를 수정하려고 시도하면 액세스가 거부되고, 액세스 보호는 이 시도에 대한 세부 정보를 기록하며 ePolicy Orchestrator 글로벌 관리자에게 이를 경고합니다.

로그 보고서 및 경고 생성

다음은 액세스 보호 로그 항목 예제입니다.

2/10/2010 11:00AM Blocked by Access Protection rule TestDomain\TestUser C:\Users\TestUser\Desktop\AnnoyMe.exe \REGISTRY\MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion\Run\ Prevent programs registering to autorun

다음 표는 이전 액세스 보호 로그 항목의 데이터를 설명합니다.
로그 항목 | 설명
2/10/2010 | 날짜
11:00AM | 시간
액세스 보호 규칙에 의해 차단되었습니다. | 취한 액션
TestDomain\TestUser | 자격 증명
C:\Users\TestUser\Desktop\AnnoyMe.exe | 규칙을 위반한 프로세스 이름
\REGISTRY\MACHINE\SOFTWARE\Microsoft... | 프로세스가 액세스를 시도한 위치
자동 실행 프로그램으로 등록 방지 | 트리거된 액세스 보호 규칙

비슷한 정보를 ePolicy Orchestrator 쿼리를 통해 사용할 수 있습니다. 자세한 내용은 쿼리 및 대시보드 액세스를 참조하십시오.

관련 정보
쿼리 및 대시보드 액세스


사용자 인터페이스에 대한 액세스 제어

클라이언트 컴퓨터의 인터페이스에 대한 보안을 설정하는 것은 사용자 환경을 보호하는 데 있어 중요한 부분입니다.

관리자는 다음을 수행할 수 있습니다.
  • 사용자가 VirusScan Enterprise 인터페이스에 대해 갖는 액세스 권한을 제어합니다.
  • 사용자가 선택한 기능에 액세스하거나 이를 변경하지 못하도록 하려면 암호를 설정합니다.
  • 필요하면 사용자 인터페이스를 잠그고 잠금을 해제합니다.

목차

관련 개념
암호 설정이 사용자에게 주는 영향
관련 작업
사용자 인터페이스 보안 설정 구성


암호 설정이 사용자에게 주는 영향

악의적인 의도를 가진 사용자를 저지하기 위한 사용자 인터페이스 암호를 설정합니다.

클라이언트 컴퓨터에서 사용자 인터페이스를 암호로 보호할 경우 다음 사용자에게 영향을 미칩니다.

  • 비관리자 — 관리자 권한이 없는 사용자. 비관리자는 읽기 전용 모드로 모든 VirusScan Enterprise 응용 프로그램을 실행합니다. 일부 구성 매개 변수를 보고, 저장된 검색을 실행하고, 즉시 검색 및 업데이트를 실행할 수 있습니다. 그러나 구성 매개 변수를 변경하거나 저장된 검색 및 업데이트 작업을 작성, 삭제 또는 수정할 수는 없습니다.
  • 관리자 — 관리자 권한이 있는 사용자. 관리자가 보호된 탭 및 컨트롤에 읽기/쓰기 모드로 액세스하려면 암호를 입력해야 합니다. 보호된 항목에 대해 암호를 입력하지 않으면 읽기 전용 모드로 표시됩니다.


사용자 인터페이스 보안 설정 구성

일반 옵션 정책 사용자 인터페이스 속성을 사용하여 사용자가 사용할 수 있는 디스플레이 및 암호 옵션을 구성합니다.
주의:
이러한 속성을 변경하기 전에 보안에 미치는 영향을 신중하게 검토하십시오. 이러한 옵션을 사용하면 사용자가 보안 구성을 변경하는 것을 제한하거나 허용할 수 있으며 다양한 악성 프로그램 공격으로부터 시스템이 보호되지 않을 수 있습니다.

이러한 인터페이스 콘솔을 사용하여 일반 옵션 정책 사용자 인터페이스 속성을 구성합니다.


ePolicy Orchestrator 4.5 또는 4.6

일반 옵션 정책 사용자 인터페이스 속성을 구성합니다.

작업

옵션 정의를 보려면 각 탭에서 ?를 클릭합니다.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 표시 옵션 탭에서 사용자에게 표시되는 VirusScan Enterprise 시스템 트레이 아이콘과, 원격 시스템에 연결할 수 있는 경우 사용자의 언어 옵션 설정을 구성합니다.
  5. 암호 옵션 탭에서 올바른 암호를 사용하여 사용자가 변경할 수 있는 VirusScan Enterprise 작업과 사용자 인터페이스 옵션을 구성합니다.


ePolicy Orchestrator 4.0

일반 옵션 정책 사용자 인터페이스 속성을 구성합니다.

작업

옵션 정의를 보려면 각 탭에서 ?를 클릭합니다.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 표시 옵션 탭에서 사용자에게 표시되는 VirusScan Enterprise 시스템 트레이 아이콘과, 원격 시스템에 연결할 수 있는 경우 사용자의 언어 옵션 설정을 구성합니다.
  5. 암호 옵션 탭에서 올바른 암호를 사용하여 사용자가 변경할 수 있는 VirusScan Enterprise 작업과 사용자 인터페이스 옵션을 구성합니다.


VirusScan 콘솔

일반 옵션 사용자 인터페이스 속성을 구성합니다.

작업

옵션 정의를 보려면 각 탭에서 도움말을 클릭합니다.

  1. 도구 | 일반 옵션을 클릭하여 일반 옵션 구성 대화 상자를 엽니다.
  2. 표시 옵션 탭에서 사용자에게 표시되는 VirusScan Enterprise 시스템 트레이 아이콘과, 원격 시스템에 연결할 수 있는 경우 사용자의 언어 옵션 설정을 구성합니다.
  3. 암호 옵션 탭에서 올바른 암호를 사용하여 사용자가 변경할 수 있는 VirusScan Enterprise 작업과 사용자 인터페이스 옵션을 구성합니다.


시스템 액세스 포인트 보호

액세스 보호는 지정된 포트, 파일, 공유, 레지스트리 키와 레지스트리 값에 대한 액세스를 제한함으로써 컴퓨터에 원하지 않는 변경이 발생하지 않도록 합니다. 또한 사용자 임의로 중지하지 못하도록 함으로써 McAfee 프로세스를 보호합니다. 액세스 방지는 아웃브레이크 발생 전과 아웃브레이크 동안에 중요합니다.

이 기능은 미리 정의된 규칙과 범주 및 사용자 정의 규칙을 사용하여 액세스가 가능한 항목과 불가능한 항목을 지정합니다. 액세스 포인트 위반이 발생할 경우 이를 차단 및 보고하도록 각 규칙을 구성할 수 있습니다. 미리 정의된 규칙과 범주는 McAfee 업데이트 사이트를 통해 콘텐츠가 업데이트될 수 있습니다.

목차

관련 개념
액세스 포인트 위반 및 VirusScan Enterprise 대응 방법
관련 작업
액세스 방지 설정 구성
관련 참조
액세스 방지 규칙 정의 방법
사용자 정의 규칙 유형


액세스 방지 규칙 정의 방법

규칙을 세 가지 유형으로 나누고 다음과 같은 보호 수준을 제공합니다.

규칙 유형 설명

규칙 유형 설명
안티바이러스

미리 구성된 이 규칙은 일반적인 악성 프로그램 위협 동작으로부터 사용자 컴퓨터를 보호합니다. 구성을 활성화, 비활성화 및 변경할 수 있지만 이 규칙을 삭제할 수는 없습니다.

다음은 규칙에 대한 두 가지 예입니다.

  • 중요 프로세스의 비활성화 또는 변경, 실행 파일의 원격 작성 또는 수정, 실행 파일 가로채기, Windows 프로세스 스푸핑 및 발송 메일에서 대량 메일링 웜 등을 방지
  • 암호 및 전자 메일 주소 도둑으로부터 전화 번호부 보호

다음은 안티바이러스 규칙에 적용되는 보호 수준입니다.

  • 표준 보호
  • 최대 보호
  • 아웃브레이크 제어
공통

미리 구성된 이 규칙은 일반적으로 사용되는 파일 및 설정이 수정되는 것을 방지합니다. 구성을 활성화, 비활성화 및 변경할 수 있지만 이 규칙을 삭제할 수는 없습니다.

다음은 규칙에 대한 세 가지 예입니다.

  • McAfee 파일 및 설정 수정 방지
  • Mozilla와 Firefox 파일 및 설정, Internet Explorer 설정, 네트워크 설정 보호
  • Temp 폴더에서 브라우저 도우미 개체 및 자동으로 실행되는 프로그램의 설치 방지

다음은 일반 규칙에 적용되는 보호 수준입니다.

  • 표준 보호
  • 최대 보호
VM 보호

미리 구성된 이러한 규칙은 VMWare 프로세스 종료와 VMWare 파일의 수정을 방지합니다. 구성을 활성화, 비활성화 및 변경할 수 있지만 이 규칙을 삭제할 수는 없습니다.

규칙 예제는 다음과 같습니다.
  • VMWare 프로세스의 종료 방지
  • VMWare 워크스테이션, 서버 또는 가상 컴퓨터 파일의 수정 방지
사용자 정의

이 사용자 지정 규칙은 안티바이러스 및 일반 규칙에서 제공하는 보호 기능을 보완합니다.

안티스파이웨어

규칙 예제는 다음과 같습니다.
  • Internet Explorer 즐겨찾기 및 설정 보호
  • 프로그램이 임시 폴더에서 스크립트 실행 방지

보호 수준 설명

보호 수준 | 설명
표준 | 일부 중요한 설정과 파일을 수정할 수 없도록 보호하지만 일반적으로 위협 요소가 없는 소프트웨어의 설치 및 실행은 가능한 안티바이러스 및 일반 규칙입니다.
최대 | 대부분의 중요한 설정과 파일을 수정할 수 없도록 보호하는 안티바이러스 및 일반 규칙입니다. 최대 보호 수준은 표준 보다 강력한 보호 기능을 제공하지만 합법적인 소프트웨어의 설치도 차단할 수 있습니다. 소프트웨어를 설치할 수 없는 경우 우선 액세스 방지 기능을 비활성화하고, 설치 후에 다시 활성화하는 것이 좋습니다.
아웃브레이크 제어 | DAT 파일이 릴리스될 때까지 파괴적인 코드가 컴퓨터에 액세스하지 못하게 차단하는 안티바이러스 규칙입니다. 이 규칙은 아웃브레이크 동안 공유 자료에 대한 액세스를 차단하도록 미리 구성됩니다.


액세스 포인트 위반 및 VirusScan Enterprise 대응 방법

액세스 위반은 제한된 사용자 또는 프로세스가 컴퓨터의 제한된 구성 요소를 시작, 중지하거나 또는 이러한 구성 요소에 액세스할 때 발생합니다.

액세스 포인트 위반이 발생하면 다음 작업이 수행됩니다.

  • 위반 탐지 규칙에 대해 보고서 옵션을 선택한 경우 로그 파일에 정보를 기록합니다.
  • 이벤트를 기록하도록 알림 등록 정보를 구성한 경우 로컬 이벤트 로그 및 SNMP에 이벤트가 기록됩니다.
  • 이벤트를 보고하도록 Alert Manager 및 ePolicy Orchestrator를 구성한 경우 이 제품에 이벤트가 보고됩니다.
  • 규칙에 대한 차단 및 보고서 액션에 따라 규칙이 위반을 탐지할 경우 처리 방법이 결정됩니다.
  • 독립 실행형 클라이언트 시스템에서 빨간 프레임이 시스템 트레이 아이콘 주위에 표시되며 재설정하지 않으면 30분 동안 표시됩니다.
    참고: 아이콘을 재설정하려면 시스템 트레이 아이콘에서 액세스 보호 로그 파일을 엽니다. 다른 방법으로 로그 파일을 열면 아이콘이 보통 상태로 재설정되지 않습니다.


사용자 정의 규칙 유형

새로운 액세스 보호 사용자 정의 규칙 구성 시 포트 차단, 파일과 폴더 차단 및 레지스트리 차단 규칙을 생성할 수 있습니다.

다음 표에서는 이러한 규칙을 설명합니다.

규칙 설명

규칙 | 설명
포트 차단 규칙 | 특정 포트 또는 포트 범위에서 수신되거나 송신되는 네트워크 트래픽을 차단합니다. 참고: 포트를 차단하면 TCP(전송 제어 프로토콜) 및 UDP(사용자 데이터그램 프로토콜) 액세스가 차단됩니다. 참고: 포트를 차단하면 해당 포트 또는 포트 범위를 사용하는 모든 프로토콜이 차단됩니다. 예를 들어, TCP(전송 제어 프로토콜) 및 UDP(사용자 데이터그램 프로토콜) 액세스가 차단됩니다.
파일/폴더 차단 규칙 | 파일과 폴더에 대한 쓰기 액세스, 파일 실행, 새 파일 만들기 및 파일 삭제를 차단합니다. 참고: 일단 파일, 공유 또는 폴더에 대한 액세스를 제한하면 관리자가 제거할 때까지 그 제한은 그대로 유지됩니다. 이 기능은 아웃브레이크 동안 침입을 방지할 뿐 아니라 침입의 확산을 중지시키는 데에도 유용합니다.
레지스트리 차단 규칙 | 읽기, 쓰기, 만들기 또는 삭제 등의 액션을 차단함으로써 레지스트리 키 또는 값을 보호합니다.


액세스 방지 설정 구성

액세스 보호 정책을 사용하여 시스템의 액세스 포인트를 보호하고 McAfee 프로세스 종료를 방지합니다.
주의:
McAfee 서비스가 중지되지 않도록 액세스 보호를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
구성할 수 있는 액세스 보호 규칙은 두 가지 유형이 있습니다.
  • 미리 정의된 규칙 — 다음을 수행할 수 있습니다.
    • 사용자 인터페이스 콘솔 중 하나에서 액세스 보호 규칙 범주를 엽니다.
    • 차단을 선택하고 규칙을 위반하는 경우 취할 액션을 보고합니다.
  • 사용자 정의 규칙 — 다음을 수행할 수 있습니다.
    • 사용자 인터페이스 콘솔 중 하나를 사용하여 사용자 정의 규칙 범주를 생성합니다.
    • 규칙이 시행하는 차단 유형, 즉 포트 차단, 파일 및 폴더 차단 또는 레지스트리 차단을 선택합니다.
    • 규칙 세부 정보를 구성합니다.
    • 규칙을 저장하고 필요한 경우 나중에 수정합니다.

작업

관련 작업
미리 정의된 규칙 구성
사용자 정의 규칙 구성
사용자 정의 규칙 제거
관련 참조
포트 차단 규칙 옵션
파일 및 폴더 차단 규칙 옵션
레지스트리 차단 규칙 옵션
특정 프로세스 옵션 포함 또는 제외


미리 정의된 규칙 구성

미리 정의된 규칙을 사용하여 컴퓨터에서 원하지 않는 변경 사항이 발생하지 않도록 차단합니다. 이 규칙은 설정 및 편집은 가능하지만 삭제할 수는 없습니다.

미리 정의된 액세스 보호 규칙은 다음과 같습니다.
  • 안티스파이웨어 표준 보호
  • 안티스파이웨어 최대 보호
  • 안티바이러스 표준 보호
  • 안티바이러스 최대 보호
  • 안티바이러스 아웃브레이크 제어
  • 일반 표준 보호
  • 일반 최대 보호
  • VM 보호

이러한 미리 정의된 액세스 보호 규칙에 대한 자세한 내용은 액세스 보호 규칙 정의 방법을 참조하십시오.

다음 사용자 인터페이스 콘솔 중 하나를 사용하여 미리 정의된 액세스 보호 규칙을 구성합니다.


ePolicy Orchestrator 4.5 또는 4.6

액세스 보호 정책에서 미리 정의된 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 액세스 보호 정책 페이지에서 액세스 보호 탭을 클릭하여 액세스 보호 규칙을 표시합니다.
  5. 왼쪽 창에서 미리 정의된 규칙 범주 중 하나를 선택한 다음 오른쪽 창에서 특정 규칙을 선택합니다.
  6. 차단 또는 보고서 옵션을 구성하거나 차단 및 보고서를 모두 구성합니다.
  7. 편집을 클릭하여 규칙 상세 정보를 구성합니다.


ePolicy Orchestrator 4.0

액세스 보호 정책에서 미리 정의된 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 액세스 보호 정책 페이지에서 액세스 보호 탭을 클릭하여 액세스 보호 규칙을 표시합니다.
  5. 왼쪽 창에서 미리 정의된 규칙 범주 중 하나를 선택한 다음 오른쪽 창에서 특정 규칙을 선택합니다.
  6. 차단 또는 보고서 옵션을 구성하거나 차단 및 보고서를 모두 구성합니다.
  7. 편집을 클릭하여 규칙 상세 정보를 구성합니다.


VirusScan 콘솔

액세스 보호 속성에서 미리 정의된 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 액세스 보호를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 액세스 보호 정책 대화 상자에서 액세스 보호 탭을 클릭하여 액세스 보호 규칙을 표시합니다.
  3. 왼쪽 창에서 미리 정의된 규칙 범주 중 하나를 선택한 다음 오른쪽 창에서 특정 규칙을 선택합니다.
  4. 차단 또는 보고서 옵션을 구성하거나 차단 및 보고서를 모두 구성합니다.
  5. 편집을 클릭하여 규칙 상세 정보를 구성합니다.


사용자 정의 규칙 구성

사용자 정의 규칙을 생성 및 편집하여 미리 정의된 규칙에서 제공하는 보호 기능을 보완합니다.

미리 정의된 액세스 보호 규칙에 대한 자세한 내용은 액세스 보호 규칙 정의 방법을 참조하십시오.

다음 사용자 인터페이스 콘솔 중 하나를 사용하여 사용자 정의 규칙 액세스 보호 규칙을 생성하고 편집합니다.


ePolicy Orchestrator 4.5 또는 4.6

액세스 보호 정책에서 사용자 정의 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 새로 만들기를 클릭하여 새 유형의 규칙 선택 대화 상자를 엽니다.
  5. 규칙 유형을 선택하고 확인을 클릭합니다. 자세한 내용은 사용자 정의 규칙 유형을 참조하십시오. 나타나는 액세스 규칙 대화 상자는 선택한 규칙 유형에 따라 다릅니다.
  6. 액세스 규칙 세부 정보를 구성합니다.
    • 네트워크 포트 액세스 보호 규칙 — 포트 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 파일/폴더 액세스 보호 규칙 — 파일 및 폴더 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 레지스트리 액세스 보호 규칙 — 레지스트리 차단 규칙 옵션의 옵션 표를 참조하십시오.
    참고: 포함 및 제외할 프로세스를 구성하려면 특정 프로세스 옵션 포함 또는 제외를 참조하십시오.
  7. 확인을 클릭합니다. 새로운 사용자 정의 규칙이 차단/보고서/규칙에서 오른쪽 창에 나타납니다. 새 규칙을 수정하려면 규칙을 선택하고 편집을 클릭합니다.


ePolicy Orchestrator 4.0

액세스 보호 정책에서 사용자 정의 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 새로 만들기를 클릭하여 새 유형의 규칙 선택 대화 상자를 엽니다.
  5. 규칙 유형을 선택하고 확인을 클릭합니다. 자세한 내용은 사용자 정의 규칙 유형을 참조하십시오. 나타나는 액세스 규칙 대화 상자는 선택한 규칙 유형에 따라 다릅니다.
  6. 액세스 규칙 세부 정보를 구성합니다.
    • 네트워크 포트 액세스 보호 규칙 — 포트 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 파일/폴더 액세스 보호 규칙 — 파일 및 폴더 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 레지스트리 액세스 보호 규칙 — 레지스트리 차단 규칙 옵션의 옵션 표를 참조하십시오.
    참고: 포함 및 제외할 프로세스를 구성하려면 특정 프로세스 옵션 포함 또는 제외를 참조하십시오.
  7. 확인을 클릭합니다. 새로운 사용자 정의 규칙이 차단/보고서/규칙에서 오른쪽 창에 나타납니다. 새 규칙을 수정하려면 규칙을 선택하고 편집을 클릭합니다.


VirusScan 콘솔

액세스 보호 속성에서 사용자 정의 액세스 보호 규칙을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 작업 목록에서 액세스 보호를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 새로 만들기를 클릭하여 새 유형의 규칙 선택 대화 상자를 엽니다.
  3. 규칙 유형을 선택하고 확인을 클릭합니다. 자세한 내용은 사용자 정의 규칙 유형을 참조하십시오. 나타나는 액세스 규칙 대화 상자는 선택한 규칙 유형에 따라 다릅니다.
  4. 액세스 규칙 세부 정보를 구성합니다.
    • 네트워크 포트 액세스 보호 규칙 — 포트 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 파일/폴더 액세스 보호 규칙 — 파일 및 폴더 차단 규칙 옵션의 옵션 표를 참조하십시오.
    • 레지스트리 액세스 보호 규칙 — 레지스트리 차단 규칙 옵션의 옵션 표를 참조하십시오.
    참고: 포함 및 제외할 프로세스를 구성하려면 특정 프로세스 옵션 포함 또는 제외를 참조하십시오.
  5. 확인을 클릭합니다. 새로운 사용자 정의 규칙은 오른쪽 창에서 규칙 열에 나타납니다. 새 규칙을 수정하려면 규칙을 선택하고 편집을 클릭합니다.


포트 차단 규칙 옵션

포트 차단 규칙은 사용자가 지정된 인바운드 및 아웃바운드 포트에 액세스하지 못하게 하고 다른 컴퓨터가 해당 컴퓨터에 액세스하는 것을 방지합니다.

옵션 정의

옵션 | 정의
규칙 이름 | 이 규칙의 이름을 입력합니다.
포함할 프로세스 | 지정된 프로세스에 대한 액세스를 제한합니다.
제외할 프로세스 | 지정된 프로세스에 대한 액세스를 허용합니다.
시작 포트 | 첫 번째 포트 번호를 지정합니다. 단일 포트이거나 포트 범위의 시작 번호일 수 있습니다. 참고: McAfee 에이전트, Entercept 에이전트 또는 Host Intrusion Prevention 에이전트가 사용하는 포트에 대한 액세스를 차단하는 경우 에이전트의 프로세스는 신뢰를 받으며 차단된 포트와 통신할 수 있습니다. 이러한 에이전트 프로세스와 관련되지 않는 다른 모든 트래픽은 차단됩니다.
끝 포트 | 포트 범위에서 마지막 포트 번호를 지정합니다.
수신 | 네트워크상의 시스템이 지정된 포트에 액세스하지 못하도록 방지합니다.
송신 | 로컬 프로세스가 네트워크상의 지정된 포트에 액세스하지 못하도록 방지합니다.


파일 및 폴더 차단 규칙 옵션

파일 및 폴더 차단 규칙은 인증되지 않은 사용자가 지정된 파일 또는 폴더를 변경하거나 열거나 또는 삭제하지 못하도록 차단합니다.

옵션 정의

옵션 | 정의
규칙 이름 | 이 규칙의 이름을 입력합니다.
포함할 프로세스 | 지정된 프로세스에 대한 액세스를 제한합니다.
제외할 프로세스 | 지정된 프로세스에 대한 액세스를 허용합니다.
차단할 파일 또는 폴더 이름 | 지정된 파일 또는 폴더에 대한 액세스를 차단합니다.
파일 찾아보기 | 파일 위치를 찾습니다.
폴더 찾아보기 | 폴더 위치를 찾습니다.
파일에 대한 읽기 액세스 | 지정된 파일에 대한 읽기 액세스를 차단합니다.
파일에 대한 쓰기 액세스 | 지정된 파일에 대한 쓰기 액세스를 차단합니다.
실행할 파일 | 지정된 폴더에서 실행할 파일을 차단합니다.
만들 새 파일 | 지정된 폴더에서 만들 새 파일을 차단합니다.
삭제할 파일 | 파일이 지정된 폴더에서 삭제되지 않도록 차단합니다.


레지스트리 차단 규칙 옵션

레지스트리 차단 규칙은 사용자와 승인되지 않은 프로그램이 지정된 레지스트리 키와 값을 변경하거나 열거나 삭제하지 못하도록 합니다.

참고: 레지스트리 차단 규칙을 생성할 때 가장 적합한 하이브 레지스트리 하위 트리 약어를 사용하십시오. 예를 들어, HKLM\System\CurrentControlSet\Services\MyService를 차단하려면 HKLM 대신 HKCCS 하이브를 선택합니다.

옵션 정의

옵션 | 정의
규칙 이름 | 이 규칙의 이름을 지정합니다.
포함할 프로세스 | 지정된 프로세스에 대한 액세스를 제한합니다.
제외할 프로세스 | 지정된 프로세스에 대한 액세스를 허용합니다.
보호할 레지스트리 키 또는 값 레지스트리 키 또는 값 보호:
  • 드롭다운 목록에서 루트 키 또는 값을 선택합니다.
  • 입력란에 키 또는 값을 입력합니다.
드롭다운 목록에서 루트 키 또는 값의 선택은 선택 사항입니다. 다음 방법들 중 하나를 사용하여 키 또는 값을 지정합니다.
  • 드롭다운 목록에서 루트 키 또는 값을 선택한 후에 키 또는 값에 대한 나머지 경로를 입력란에 입력합니다.
  • 키 또는 값에 대한 전체 경로를 입력란에 입력합니다.
규칙 유형 규칙 유형 선택:
  • 키 - 이 규칙은 지정된 키를 보호합니다.
  • 값 - 이 규칙은 지정된 값을 보호합니다.
키 또는 값에 쓰기 | 지정된 키 또는 값에서 쓰기를 차단합니다.
키 또는 값 만들기 | 지정된 키 또는 값에서 만들기를 차단합니다.
키 또는 값 삭제 | 지정된 키 또는 값에서 삭제를 차단합니다.


특정 프로세스 옵션 포함 또는 제외

옵션 정의

이름, 포함하거나 제외할 프로세스 같은 규칙 세부 정보를 변경하려면 액세스 보호를 사용하고 편집을 클릭합니다.

옵션 | 설명
규칙 이름 | 이 규칙의 이름입니다. 예를 들어 레지스트리 편집기 및 작업 관리자 비활성화 방지가 있습니다.
포함할 프로세스 | 이 프로세스에 대한 액세스를 제한합니다. 정확한 프로세스 이름을 사용하거나 와일드카드를 사용하여 *.EXE 같이 광범위한 프로세스를 지정한 다음 SETUP.EXE 같은 올바른 특정 프로세스에 대해 제외를 추가합니다. 예를 들어 모든 프로세스를 포함하려면 *를 지정합니다.
제외할 프로세스 | 프로세스에 대한 액세스를 허용합니다. 정확한 프로세스 이름을 사용합니다. 예를 들어 다음과 같은 예외를 지정합니다. avtask.exe, cfgwiz,exe, fssm32.exe, giantantispywar*, kavsvc.exe, mmc.exe, navw32.exe, nmain.exe, rtvscan.exe.


사용자 정의 규칙 제거

만들었지만 더 이상 사용하지 않는 규칙을 제거합니다.

다음 사용자 인터페이스 콘솔 중 하나를 사용하여 사용자 정의 규칙을 제거합니다.


ePolicy Orchestrator 4.5 또는 4.6

액세스 보호 정책에서, 생성했지만 더 이상 사용하지 않는 규칙을 제거합니다.

작업

옵션 정의를 보려면 인터페이스에서 ? 또는 도움말을 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 오른쪽 창에서 제거하려는 규칙을 선택합니다.
  5. 삭제를 클릭합니다.
    참고: 차단 및 보고서 액션을 모두 선택 취소함으로써 규칙을 삭제하지 않고 비활성화할 수 있습니다. 필요하면 규칙을 다시 활성화할 수 있습니다.


ePolicy Orchestrator 4.0

액세스 보호 정책에서, 생성했지만 더 이상 사용하지 않는 규칙을 제거합니다.

작업

옵션 정의를 보려면 인터페이스에서 ? 또는 도움말을 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 오른쪽 창에서 제거하려는 규칙을 선택합니다.
  5. 삭제를 클릭합니다.
    참고: 차단 및 보고서 액션을 모두 선택 취소함으로써 규칙을 삭제하지 않고 비활성화할 수 있습니다. 필요하면 규칙을 다시 활성화할 수 있습니다.


VirusScan 콘솔

액세스 보호 속성에서, 생성했지만 더 이상 사용하지 않는 규칙을 제거합니다.

다음 사용자 인터페이스 콘솔 중 하나를 사용하여 사용자 정의 규칙을 제거합니다.

작업

옵션 정의를 보려면 인터페이스에서 ? 또는 도움말을 클릭하십시오.

  1. 작업 목록에서 액세스 보호를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 왼쪽 창에서 사용자 정의 규칙 범주를 선택한 다음 오른쪽 창에서 제거하려는 규칙을 선택합니다.
  3. 삭제를 클릭합니다.
    참고: 차단 및 보고서 액션을 모두 선택 취소함으로써 규칙을 삭제하지 않고 비활성화할 수 있습니다. 필요하면 규칙을 다시 활성화할 수 있습니다.


버퍼 오버플로우 악용 차단

버퍼 오버플로우 방지는 악용된 버퍼 오버플로우가 컴퓨터에서 임의의 코드를 실행하지 못하도록 합니다. 이 기능은 사용자 모드의 API 호출을 감시하며 버퍼 오버플로우의 결과로 호출될 때 이를 인식합니다.

해당 옵션을 구성한 경우, 탐지가 발생하면 해당 정보는 작업 로그에 기록되고 온액세스 검색 메시지 대화 상자에도 표시됩니다.

VirusScan Enterprise에서는 버퍼 오버플로우 및 액세스 보호 DAT 파일을 사용하여 Internet Explorer, Microsoft Outlook, Outlook Express, Microsoft Word 및 MSN Messenger 등 약 30개 정도의 응용 프로그램을 보호합니다.

목차

관련 개념
버퍼 오버플로우 악용이 발생하는 방식
관련 작업
버퍼 오버플로우 방지 구성


버퍼 오버플로우 악용이 발생하는 방식

공격자는 버퍼 오버플로우 악용을 사용하여 입력 프로세스를 위해 예약된 고정 크기 메모리 버퍼를 오버플로우하여 실행 파일 코드를 실행합니다. 이 코드를 사용하면 공격자가 대상 컴퓨터를 제어하거나 데이터를 손상시킬 수 있습니다.

두 가지 유형의 버퍼 오버플로우 악용이 있습니다.
  • 힙 기반 공격 — 프로그램에 예약된 메모리를 쇄도하게 하지만 수행하기 어려우며 드뭅니다.
  • 스택 기반 공격 — 스택 메모리 개체를 사용하여 사용자 입력을 저장하며 가장 흔합니다.
다음 프로세스는 스택 기반 버퍼 오버플로우 공격을 설명합니다.
  1. 정상 스택 메모리 프로세스 — 고정 크기 스택 메모리 개체는 주로 비어 있으며 사용자 입력을 기다립니다. 프로그램이 사용자로부터 이름 같은 입력을 받으면 데이터는 스택 상단에 저장되며 반환 메모리 주소가 할당됩니다. 스택이 처리되면 사용자 입력은 프로그램에서 지정한 반환 주소로 전송됩니다.
  2. 스택 오버플로우 — 프로그램이 작성되면 특정 크기의 메모리 공간이 데이터용으로 예약됩니다. 작성된 데이터가 메모리 스택 내에 예약된 공간보다 크면 스택이 오버플로우됩니다. 이는 악의적인 입력과 결합될 때만 발생하는 문제입니다.
  3. 오버플로우 악용 — 프로그램이 사용자의 이름 입력을 기다리고 있지만 공격자가 스택 크기를 초과하는 실행 명령을 입력하는 경우 해당 명령은 예약된 공간 외부에 저장됩니다.
  4. 악의적인 코드 실행 — 이 명령은 스택 버퍼 공간을 초과하기 때문에 자동으로 실행되지 않습니다. 그러나 공격자가 악의적인 명령을 가리키는 반환 주소를 제공하게 되면 실행될 수 있습니다. 처음에는 버퍼 오버플로우로 인해 프로그램이 충돌하지만 프로그램이 공격자가 제공하는 반환 주소를 사용하여 복구를 시도합니다. 반환 주소가 유효한 주소인 경우 악의적인 명령이 실행됩니다.
  5. 권한 악용 — 프로그램은 주로 커널 모드 또는 서비스 계정에서 상속한 권한을 사용하여 실행되기 때문에 악의적인 코드는 이제 손상된 응용 프로그램과 같은 권한을 사용하여 실행됩니다. 이는 공격자가 운영 체제를 완벽하게 제어할 수 있음을 의미합니다.


버퍼 오버플로우 방지 구성

응용 프로그램이 사용자 컴퓨터에서 임의의 코드를 실행하는 것을 방지하려면 버퍼 오버플로우 방지 정책을 구성해야 합니다.

다음 사용자 인터페이스 콘솔을 사용하여 버퍼 오버플로우 방지 정책을 구성합니다.


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 버퍼 오버플로우 방지 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 버퍼 오버플로우 방지 정책 페이지에서 버퍼 오버플로우 방지 탭을 클릭하고 다음을 구성합니다.
    1. 버퍼 오버플로우 설정과 사용된 방지 모드를 활성화합니다. 악용을 차단하거나 메시지를 전송하도록 방지 모드를 구성하고 이벤트를 기록합니다.
    2. 버퍼 오버플로우 악용이 발생할 때 전송되는 클라이언트 시스템 경고를 활성화합니다.
    3. 특정 API(application programming interface) 값에 대한 버퍼 오버플로우 제외와 제외할 선택적 프로세스 및 모듈 이름을 구성합니다.
  5. 보고서 탭을 클릭하고 검색 활동 로그 파일, 저장 위치, 크기 및 형식을 활성화합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 버퍼 오버플로우 방지 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 버퍼 오버플로우 방지 정책 페이지에서 버퍼 오버플로우 방지 탭을 클릭하고 다음을 구성합니다.
    1. 버퍼 오버플로우 설정과 사용된 방지 모드를 활성화합니다. 악용을 차단하거나 메시지를 전송하도록 방지 모드를 구성하고 이벤트를 기록합니다.
    2. 버퍼 오버플로우 악용이 발생할 때 전송되는 클라이언트 시스템 경고를 활성화합니다.
    3. 특정 API(application programming interface) 값에 대한 버퍼 오버플로우 제외와 제외할 선택적 프로세스 및 모듈 이름을 구성합니다.
  5. 보고서 탭을 클릭하고 검색 활동 로그 파일, 저장 위치, 크기 및 형식을 활성화합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 버퍼 오버플로우 방지 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 작업 목록에서 버퍼 오버플로우 방지를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 버퍼 오버플로우 방지 속성 페이지에서 버퍼 오버플로우 방지 탭을 클릭하고 다음을 구성합니다.
    1. 버퍼 오버플로우 설정과 사용된 방지 모드를 활성화합니다. 악용을 차단하거나 메시지를 전송하도록 방지 모드를 구성하고 이벤트를 기록합니다.
    2. 버퍼 오버플로우 악용이 발생할 때 전송되는 클라이언트 시스템 경고를 활성화합니다.
    3. 특정 API(application programming interface) 값에 대한 버퍼 오버플로우 제외와 제외할 선택적 프로세스 및 모듈 이름을 구성합니다.
  3. 보고서 탭을 클릭하고 검색 활동 로그 파일, 저장 위치, 크기 및 형식을 활성화합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


잠재적으로 원하지 않는 프로그램 제한

VirusScan Enterprise는 방해가 되거나 보안에 위협이 될 수 있는 잠재적으로 원하지 않는 프로그램으로부터 컴퓨터를 보호합니다. 한 개의 원하지 않는 프로그램 정책이 공통적으로 구성되어 있지만 각 VirusScan Enterprise 스캐너에 대해 개별적으로 정책을 활성화 또는 비활성화하고 액션을 지정할 수 있습니다.

PUP(잠재적으로 원하지 않는 프로그램)는 프로그램이 설치되어 있는 컴퓨터의 보안 상태나 개인 정보 보호 정책을 변경할 수 있는 합법적인 회사가 만든 프로그램입니다. 이 소프트웨어에는 스파이웨어, 애드웨어 및 다이얼러가 포함될 수 있지만 반드시 그런 것은 아닙니다. 이렇게 포함된 PUP는 실제로 원하는 프로그램과 함께 다운로드할 수 있습니다. 보안에 관심이 있는 사용자라면 이러한 프로그램을 알아보고 경우에 따라 제거하기도 합니다.


원하지 않는 프로그램 구성

잠재적으로 원하지 않는 프로그램으로부터 컴퓨터를 보호하려면 사용자 환경에서 원하지 않는 프로그램에서 검색할 범주를 구성해야 합니다.

두 단계의 프로세스로 구성됩니다.

  1. 검색 및 제외할 잠재적으로 원하지 않는 프로그램을 정의하도록 원하지 않는 프로그램 정책을 구성합니다.
    • 현재 DAT 파일이 제공하는 미리 정의된 목록에서 전체 프로그램 범주 또는 범주 내 특정 프로그램을 선택합니다.
    • 제외 항목을 지정합니다.
    • 탐지할 사용자 정의 프로그램 목록을 만듭니다.

  2. 온액세스, 전자 메일 및 주문형 스캐너에서 원하지 않는 프로그램 탐지를 활성화한 다음 원하지 않는 프로그램이 탐지될 때 취할 액션을 구성합니다.

참고: 주문형 검색은 정책이 아닌 작업이므로 원하지 않는 프로그램 탐지는 주문형 스캐너를 다르게 활성화합니다. 자세한 내용은 주문형 검색 작업 구성을 참조하십시오.

작업

관련 작업
원하지 않는 프로그램 정책에 액세스
온액세스 및 전자 메일 스캐너에서 원하지 않는 프로그램 탐지 활성화


원하지 않는 프로그램 정책에 액세스

원하지 않는 프로그램에서 검색할 범주를 선택하여 원하지 않는 프로그램 정책을 구성합니다. 스파이웨어 및 애드웨어를 예로 들 수 있습니다. 또한 프로그램에 대해 검색하지 않도록 예외를 지정할 수도 있습니다.

다음 사용자 인터페이스 콘솔을 사용하여 원하지 않는 프로그램 정책에 액세스합니다.


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 원하지 않는 프로그램 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 원하지 않는 프로그램 정책 페이지에서 검색 항목 탭을 클릭하여 다음을 구성합니다.
    1. 원하지 않는 프로그램에서 검색할 범주 — 예를 들어, 스파이웨어 및 애드웨어. 이러한 범주는 현재 DAT 파일에 의해 정의됩니다.
    2. 제외 — 파일 이름이 아니라 제외하려는 정확한 탐지 이름을 지정해야 합니다.
  5. 사용자 정의 탐지 탭을 클릭하여 원하지 않는 프로그램으로 취급할 개별 파일 또는 프로그램을 지정합니다. 파일 이름별로 각 항목을 지정하고 각 항목의 설명을 제공합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 원하지 않는 프로그램 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 원하지 않는 프로그램 정책 페이지에서 검색 항목 탭을 클릭하여 다음을 구성합니다.
    1. 원하지 않는 프로그램에서 검색할 범주 — 예를 들어, 스파이웨어 및 애드웨어. 이러한 범주는 현재 DAT 파일에 의해 정의됩니다.
    2. 제외 — 파일 이름이 아니라 제외하려는 정확한 탐지 이름을 지정해야 합니다.
  5. 사용자 정의 탐지 탭을 클릭하여 원하지 않는 프로그램으로 취급할 개별 파일 또는 프로그램을 지정합니다. 파일 이름별로 각 항목을 지정하고 각 항목의 설명을 제공합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 원하지 않는 프로그램 속성을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 원하지 않는 프로그램 정책을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 원하지 않는 프로그램 정책 대화 상자를 엽니다.
  2. 원하지 않는 프로그램 정책 페이지에서 검색 항목 탭을 클릭하여 다음을 구성합니다.
    1. 원하지 않는 프로그램에서 검색할 범주 — 예를 들어, 스파이웨어 및 애드웨어. 이러한 범주는 현재 DAT 파일에 의해 정의됩니다.
    2. 제외 — 파일 이름이 아니라 제외하려는 정확한 탐지 이름을 지정해야 합니다.
  3. 사용자 정의 탐지 탭을 클릭하여 원하지 않는 프로그램으로 취급할 개별 파일 또는 프로그램을 지정합니다. 파일 이름별로 각 항목을 지정하고 각 항목의 설명을 제공합니다.


온액세스 및 전자 메일 스캐너에서 원하지 않는 프로그램 탐지 활성화

온액세스 및 전자 메일 스캐너에서 원하지 않는 프로그램을 탐지하게 하려면 항목 검색 탭에서 해당 기능을 활성화해야 합니다.

다음 사용자 인터페이스 콘솔을 사용하여 원하지 않는 프로그램을 탐지하도록 온액세스 및 전자 메일 스캐너를 활성화합니다.
참고: 주문형 스캐너를 할성화하여 원하지 않는 프로그램을 탐지하려면 주문형 검색 작업 구성을 참조하십시오.


ePolicy Orchestrator 4.5 또는 4.6

ePolicy Orchestrator 4.5 또는 4.6 콘솔을 사용하여 원하지 않는 프로그램을 탐지하도록 온액세스 및 전자 메일 스캐너를 활성화합니다.

온액세스 및 전자 메일 스캐너에 대해 원하지 않는 프로그램 탐지를 활성화하는 데 사용되는 프로세스는 기본적으로 동일합니다. 유일한 차이는 2단계를 위해 정책 카탈로그에서 어떤 정책을 선택하는 가입니다. 원하지 않는 프로그램 탐지를 활성화하려면:
  • 온액세스 검색 — 온액세스 검색 정책을 선택합니다.
  • 전자 메일 검색 — 배달 시 전자 메일 정책을 선택합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 검색 정책 또는 배달 시 전자 메일 정책 페이지에서 검색 항목 탭을 클릭하고 원하지 않는 프로그램 탐지를 선택합니다.


ePolicy Orchestrator 4.0

ePolicy Orchestrator 4.0 콘솔을 사용하여 원하지 않는 프로그램을 탐지하도록 온액세스 및 전자 메일 스캐너를 활성화합니다.

온액세스 및 전자 메일 스캐너에 대해 원하지 않는 프로그램 탐지를 활성화하는 데 사용되는 프로세스는 기본적으로 동일합니다. 유일한 차이는 2단계를 위해 정책 카탈로그에서 어떤 정책을 선택하는 가입니다. 원하지 않는 프로그램 탐지를 활성화하려면:
  • 온액세스 검색 — 온액세스 검색 정책을 선택합니다.
  • 전자 메일 검색 — 배달 시 전자 메일 정책을 선택합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 검색 정책 또는 배달 시 전자 메일 정책 페이지에서 검색 항목 탭을 클릭하고 원하지 않는 프로그램 탐지를 선택합니다.


VirusScan 콘솔

VirusScan 콘솔을 사용하여 원하지 않는 프로그램을 탐지하도록 온액세스 및 전자 메일 스캐너를 활성화합니다.

온액세스 및 전자 메일 스캐너에 대해 원하지 않는 프로그램 탐지를 활성화하는 데 사용되는 프로세스는 기본적으로 동일합니다. 유일한 차이는 2단계를 위해 VirusScan 콘솔에서 어떤 작업을 선택하는 가입니다. 원하지 않는 프로그램 탐지를 활성화하려면:
  • 온액세스 검색 — 온액세스 검색 정책을 선택합니다.
  • 전자 메일 검색 — 배달 시 전자 메일 스캐너를 선택합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 다음 중 하나를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
    • 온액세스 검색 정책 — 온액세스 검색의 경우
    • 배달 시 전자 메일 스캐너 — 전자 메일 검색의 경우
  2. 온액세스 검색 정책 또는 배달 시 전자 메일 정책 페이지에서 검색 항목 탭을 클릭하고 원하지 않는 프로그램 탐지를 선택합니다.


탐지 정의 업데이트

VirusScan Enterprise 소프트웨어는 검색 엔진 및 탐지 정의(DAT) 파일의 정보를 기반으로 하여 위협을 식별하고 위협에 대한 액션을 수행합니다. 새로운 위협은 정기적으로 나타납니다. 이 문제를 해결하기 위해 McAfee는 지속적인 위협 연구 결과가 통합되어 있는 새 DAT 파일을 매일 릴리스합니다. 업데이트 작업은 외부 McAfee 업데이트 사이트에서 최신 DAT 파일을 검색하여 설치합니다.
참고: ePolicy Orchestrator 관리 환경은 최신 DAT 파일, EXTRA.DAT 파일, 검색 엔진, 서비스 팩 및 패치를 검색할 수도 있습니다.

목차

관련 개념
DAT 파일 및 작동 방식
업데이트 전략의 중요성
업데이트 작업 및 수행 방법
미러 작업 및 작동 방식
자동 업데이트 리포지토리 작동 방식
롤백 DAT 파일 작동 방식


DAT 파일 및 작동 방식

검색 엔진이 위협을 찾는 파일을 검색할 때 검색한 파일의 내용을 탐지 정의(DAT) 파일에 저장된 알려진 위협 정보와 비교합니다. 서명이라고 하는 알려진 위협 정보는 McAfee Labs가 발견하여 DAT 파일에 추가한 정보입니다.

DAT 파일에는 서명 이외에도 탐지된 바이러스로 인한 손상을 치료하고 이에 대응하는 방법도 포함되어 있습니다. 이것이 바로 VirusScan Enterprise에서 사용하는 최신 버전의 DAT 파일을 다운로드해야 하는 이유입니다.
주의:
특정 바이러스의 서명이 설치한 DAT 파일에 포함되어 있지 않은 경우 해당 바이러스는 검색 엔진에 의해 탐지되지 않습니다. 또한 최신 DAT 파일을 충분히 활용할 수 있으려면 검색 엔진이 최신 버전이어야 합니다.

VirusScan Enterprise는 또한 Artemis라는 경험적 접근을 사용하여 DAT 파일과 함께 의심되는 파일을 검사합니다. 자세한 내용은 Artemis 작동 방식을 참조하십시오.

다양한 DAT 파일이 다음 경로에 저장되어 있습니다.

\Program Files\Common Files\McAfee\Engine


업데이트 전략의 중요성

업데이트 전략의 중요성은 아무리 강조해도 지나치지 않습니다. 최신 DAT 파일과 검색 엔진이 시스템에 설치되어 있지 않으면 최신 바이러스로부터 완벽하게 보호되지 않습니다. 새로운 악성 프로그램 수, 전파 속도 및 확산이 전례 없이 증가하고 있습니다. 뿐만 아니라 애드웨어와 스파이웨어의 양적 증가로 인해 일관성 및 가용성이 향상된 탐지 및 제거가 필요합니다.

McAfee Labs는 거의 매일 오후 6:00(GMT)에 DAT 파일 업데이트를 릴리스합니다. 아웃브레이크는 항상 곤란한 시기에 발생하기 때문에 비상 릴리스가 필요합니다. 잠재적 아웃브레이크를 사전에 예방하기 위해 일일 DAT가 일찍 릴리스되는 경우, 다른 비상 상황으로 인해 필요한 경우가 아니면 해당 날짜의 정상적인 예정 시간에 두 번째 DAT가 릴리스되지 않습니다.


업데이트 전략 결정 방법

여러 가지 방법을 사용하여 VirusScan Enterprise에서 사용하는 DAT 파일과 검색 엔진을 업데이트할 수 있습니다. 자동 업데이트 작업, 수동 업데이트, 로그인 스크립트를 사용하거나 관리 도구로 업데이트를 예약할 수 있습니다.

업데이트 작업을 통해 다음과 같은 기능을 수행할 수 있습니다.

  • 네트워크 차원의 DAT 파일 롤아웃 예약 — 업데이트 작업에 시차를 두거나, 관리자나 네트워크 사용자 작업을 최소화하면서 편리한 시간에 단계적으로 수행할 DAT 파일 업데이트에 대한 예약을 네트워크의 여러 부분에 설정할 수 있습니다.
  • 롤아웃 관리 작업 분배 — 네트워크 대역폭 효율성을 높이려면 WAN(광역 네트워크)의 다른 지역 간 또는 다른 네트워크 단위에 다른 서버 또는 도메인 컨트롤러를 사용하여 기본적으로 업데이트 트래픽을 내부에서 관리하십시오. 네트워크 보안 위반의 가능성을 줄일 수도 있습니다.
  • 새 DAT나 업그레이드된 엔진 파일을 다운로드하는 데 필요한 대기 시간 단축 — McAfee 컴퓨터의 트래픽은 정기 DAT 파일 게시 날짜에는 물론 새 제품 버전이 출시될 때마다 엄청나게 늘어납니다. 네트워크 대역폭의 사용량이 많은 시간을 피하면 연결이 끊어지는 현상을 최소화하면서 새 소프트웨어를 배포할 수 있습니다.


효율적인 업데이트 전략 요구 사항

효율적인 업데이트 전략을 세우려면 일반적으로 조직 내 하나 이상의 클라이언트 또는 서버에서 McAfee 다운로드 사이트로부터 업데이트를 검색해야 합니다. 해당 클라이언트 또는 서버에서 다른 모든 컴퓨터에 대한 액세스 권한을 제공하므로 조직 전체로 파일을 복제할 수 있습니다. 가장 좋은 방법은 업데이트된 파일을 공유 사이트로 복사하는 프로세스를 자동화함으로써 네트워크를 통해 전송되는 데이터의 양을 최소화하는 것입니다.

효과적인 업데이트를 위해 고려해야 할 중요한 요소는 클라이언트 수 및 사이트 수입니다. 이와 함께 각 원격 사이트의 시스템 수와 원격 사이트의 인터넷 액세스 방법 등도 고려할 수 있습니다. 업데이트 검색에 중앙 리포지토리를 사용하고 업데이트 작업을 예약하여 사용자 환경을 최신 상태로 유지하는 등의 기본 개념은 규모에 관계없이 모든 조직에 적용됩니다. 소프트웨어 배포와 업데이트 정보는 해당 ePolicy Orchestrator 제품 안내서를 참조하십시오.


업데이트 작업 및 수행 방법

업데이트 작업을 사용하여 최신 DAT 파일, 검색 엔진 및 서비스 팩과 패치를 검색합니다.

VirusScan Enterprise에는 한 시간 임의 추출을 사용하여 매일 오후 5시에 실행되는 기본 업데이트 작업이 포함되어 있습니다. 필요에 따라 추가 업데이트 작업을 만들 수 있습니다.

업데이트 작업 활동

업데이트 작업을 실행하면 다음과 같은 작업이 수행됩니다.

  • 리포지토리 목록의 첫 번째 사용 가능한 리포지토리(업데이트 사이트)에 연결됩니다. 이 리포지토리를 사용할 수 없으면 연결되거나 목록의 끝에 도달할 때까지 계속 다음 사이트에 연결됩니다.
  • 암호화된 CATALOG.Z 파일이 리포지토리에서 다운로드됩니다. 이 파일에는 업데이트에 필요한 기초 데이터가 포함되어 있습니다. 이 데이터는 사용 가능한 파일과 업데이트를 결정하는 데 사용됩니다.
  • 파일의 소프트웨어 버전을 컴퓨터의 소프트웨어 버전과 비교하여 확인합니다. 새 소프트웨어 업데이트를 사용할 수 있으면 해당 업데이트가 다운로드됩니다.

업데이트 작업 중지

업데이트 중에 어떤 이유로든 업데이트 작업이 중지된 경우

  • HTTP, UNC 또는 로컬 사이트에서 업데이트 중인 작업은 다음에 업데이트 작업이 시작되면 이전에 종료된 위치에서 다시 시작됩니다.
  • FTP 사이트에서 업데이트 중인 작업은 단일 파일 다운로드 중에 중지된 경우에는 다시 시작되지 않습니다. 그러나 여러 파일을 다운로드하는 중 작업이 중지된 경우, 중지된 시점에 다운로드 중이던 파일의 이전 파일부터 작업이 다시 시작됩니다.

EXTRA.DAT를 사용하여 업데이트

EXTRA.DAT 파일은 비상 시 임시 수단으로 사용할 수 있습니다. EXTRA.DAT는 업데이트할 때마다 리포지토리에서 다운로드됩니다. 이렇게 하면 패키지로 EXTRA.DAT를 수정하고 재확인할 경우 모든 VirusScan Enterprise 클라이언트가 동일하게 업데이트된 EXTRA.DAT 패키지를 다운로드하여 사용할 수 있습니다. 예를 들어 잠재적으로 원하지 않는 동일한 프로그램에 대한 향상된 탐지기 또는 잠재적으로 원하지 않는 새 프로그램에 대한 추가 탐지로서 EXTRA.DAT를 사용할 수 있습니다. VirusScan Enterprise에서는 단 하나의 EXTRA.DAT 파일만 사용하도록 지원합니다.

팁: EXTRA.DAT 파일 사용을 완료하면 해당 파일을 마스터 리포지토리에서 제거하고 복제 작업을 실행하여 배포된 모든 리포지토리 사이트에서 제거해야 합니다. 이렇게 하면 VirusScan Enterprise 클라이언트는 업데이트 중 EXTRA.DAT 파일을 다운로드하지 못합니다. 기본적으로 새 탐지 정의가 일일 DAT 파일에 추가되면 EXTRA.DAT에서 잠재적으로 원하지 않는 새 프로그램의 탐지가 무시됩니다.


자동 업데이트 작업 구성

모든 McAfee 제품에 대해 DAT 파일과 검색 엔진을 자동으로 업데이트하려면 자동 업데이트 속성과 일정을 구성해야 합니다.

작업

옵션 정의를 보려면 탭에서 ? 또는 도움말을 클릭합니다.

  1. 자동 업데이트 속성에 액세스하려면 다음을 사용합니다.

    • ePolicy Orchestrator 4.5 또는 4.6 — 메뉴 | 시스템 | 시스템 트리를 클릭하고 클라이언트 작업을 선택합니다.
      참고: 예약된 클라이언트 작업을 새로 만드는 방법에 대한 자세한 내용은 McAfee ePolicy Orchestrator 4.5 제품 안내서를 참조하십시오.
    • ePolicy Orchestrator 4.0 — 시스템 | 시스템 트리 | 클라이언트 작업을 클릭하고 기존 업데이트 작업을 선택하거나 새 작업을 만들고 새 작업을 클릭합니다.
      참고: 예약된 클라이언트 작업을 새로 만드는 방법에 대한 자세한 내용은 McAfee ePolicy Orchestrator 4.0 제품 안내서를 참조하십시오.
    • VirusScan 콘솔 — 기존 업데이트 작업을 선택하거나(마우스 오른쪽 단추를 클릭한 후 속성 선택) 새 작업을 만듭니다(작업 | 새 업데이트 작업을 선택하고 목록에서 새 작업 선택).
      팁: 새 클라이언트 작업을 만들 때 작업 이름을 설명적인 이름으로 변경하는 것이 좋습니다.
  2. 로그 파일 위치와 형식을 지정합니다.
  3. 최신 DAT, 최신 엔진 및 서비스 팩과 제품 업그레이드 같은 기타 유용한 업데이트를 가져올지 여부를 구성합니다.
  4. 업데이트 작업이 완료된 후 실행할 실행 파일 및 업데이트 성공 후에만 실행할지 여부를 지정합니다.
  5. 예약을 클릭하여 작업을 실행할 시기와 빈도를 구성합니다. 자세한 내용은 예약된 작업 사용을 참조하십시오.
  6. 지금 업데이트를 클릭하면 작업이 즉시 실행됩니다.


미러 작업 및 작동 방식

미러 작업은 리포지토리 목록에 정의된 첫 번째 액세스 가능 리포지토리에서 사용자의 네트워크 상에 있는 미러 사이트로 업데이트 파일을 복제합니다. 이 작업은 McAfee 다운로드 사이트의 내용을 로컬 서버로 미러링하기 위해 가장 많이 사용됩니다.

업데이트 파일이 포함된 McAfee 사이트를 복제한 후 네트워크상의 컴퓨터에서 미러 사이트의 파일을 다운로드할 수 있습니다. 이렇게 하면 인터넷 액세스가 가능한지 여부와 상관없이 네트워크상의 모든 컴퓨터를 업데이트할 수 있으므로 실용적일 뿐만 아니라, 사용자의 시스템이 McAfee 인터넷 사이트보다 가까이 있는 서버와 통신함으로써 액세스 및 다운로드 시간을 줄일 수 있으므로 효율적입니다.

VirusScan Enterprise 소프트웨어는 자체 업데이트에 디렉토리 구조를 사용합니다. 사이트 미러링 시 반드시 전체 디렉토리 구조를 복제해야 합니다.
참고: 업데이트에 사용되는 VirusScan Enterprise 8.8과 동일한 위치에 전체 디렉토리 구조가 복제되면 이 디렉토리 구조는 이전 버전의 VirusScan Enterprise 및 NetShield도 지원합니다.


미러 작업 구성

다른 컴퓨터에서 사용하도록 지정된 위치에 DAT 파일과 검색 엔진을 저장하려면 미러 작업 속성을 사용하여 위치와 일정을 구성합니다.

작업

옵션 정의를 보려면 탭에서 ? 또는 도움말을 클릭합니다.

  1. 미러 작업 속성에 액세스하려면 다음을 사용합니다.

    • ePolicy Orchestrator 4.5 또는 4.6 — 메뉴 | 시스템 | 시스템 트리를 클릭하고 클라이언트 작업을 선택합니다.
      참고: 예약된 클라이언트 작업을 새로 만드는 방법에 대한 자세한 내용은 McAfee ePolicy Orchestrator 4.5 제품 안내서를 참조하십시오.
    • ePolicy Orchestrator 4.0 — 시스템 | 시스템 트리 | 클라이언트 작업을 클릭하고 기존 업데이트 작업을 선택하거나 새 작업을 만들고 새 작업을 클릭합니다.
      참고: 예약된 클라이언트 작업을 새로 만드는 방법에 대한 자세한 내용은 McAfee ePolicy Orchestrator 4.0 제품 안내서를 참조하십시오.
    • VirusScan 콘솔에서 다음 중 하나를 실행합니다.
      • 기존 미러 작업을 선택하여 마우스 오른쪽 단추를 클릭하고 속성을 선택합니다. 미러 작업 대화 상자가 나타납니다.
      • 새 미러 작업을 만들려는 경우 작업 | 새 미러 작업을 선택하면 작업 목록에 새 업데이트 작업이 나타납니다. 새 작업을 클릭하여 미러 작업 대화 상자를 엽니다.
        참고: 작업을 마우스 오른쪽 단추로 클릭하고 이름 변경을 선택하여 작업 이름을 보다 설명적인 이름으로 변경합니다.
  2. VirusScan 콘솔 — 기존 업데이트 작업을 선택하거나(마우스 오른쪽 단추를 클릭한 후 속성 선택) 새 작업을 만듭니다(작업 | 새 미러 작업을 선택하고 목록에서 새 작업 선택).
    팁: 새 클라이언트 작업을 만들 때 작업 이름을 설명적인 이름으로 변경하는 것이 좋습니다.
  3. 로그 파일 위치와 형식을 지정합니다.
  4. 최신 탐지 정의, 최신 엔진, DAT 및 서비스 팩과 제품 업그레이드 같은 기타 유용한 업데이트를 가져올지 여부를 구성합니다.
  5. 업데이트 작업이 완료된 후 실행할 실행 파일 및 업데이트 성공 후에만 실행할지 여부를 지정합니다.
  6. 미러 위치를 클릭하여 미러 서버 대상을 구성합니다.
  7. 예약을 클릭하여 작업을 실행할 시기와 빈도를 구성합니다. 자세한 내용은 예약된 작업 사용을 참조하십시오.
  8. 지금 미러링을 클릭하여 작업을 즉시 실행합니다.
  9. 탭에서 옵션을 구성합니다. 옵션 정의를 보려면 탭에서 ? 또는 도움말을 클릭합니다.

탭 정의

탭 정의
미러
  • 로그 파일 위치와 형식을 지정합니다.
  • 미러 작업이 완료된 후 실행할 실행 파일 및 미러 성공 후에만 실행할지 여부를 지정합니다.


자동 업데이트 리포지토리 작동 방식

자동 업데이트 리포지토리 목록(SITELIST.XML)은 자동 업데이트 작업을 수행하는 데 필요한 구성 정보를 지정합니다.

자동 업데이트 리포지토리 목록은 다음과 같이 구성되어 있습니다.
  • 리포지토리 정보와 위치
  • 리포지토리 순서 기본 설정
  • 프록시 설정(필요한 경우)
  • 각 리포지토리에 액세스하는 데 필요한 암호화된 자격 증명

자동 업데이트 작업을 수행하면 리포지토리 목록의 첫 번째 사용 가능한 리포지토리(업데이트 사이트)에 연결됩니다. 이 리포지토리를 사용할 수 없으면 연결될 때까지 다음 리포지토리에 접속하거나 목록의 끝에 있는 리포지토리까지 연결을 시도합니다.

네트워크에서 프록시 서버를 사용하는 경우에는 사용할 프록시 설정, 프록시 서버의 주소 및 인증 사용 여부를 지정할 수 있습니다. 프록시 정보는 자동 업데이트 리포지토리 목록에 저장됩니다. 구성하는 프록시 설정은 리포지토리 목록의 모든 리포지토리에 적용됩니다.

자동 업데이트 리포지토리 목록의 위치는 사용자의 운영 체제에 따라 다릅니다.
  • Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server 및 Microsoft 2008 Server의 경우 — C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework
  • Microsoft Windows 7의 경우 — C:\ProgramData\McAfee\Common Framework


리포지토리 목록 구성

리포지토리 목록에는 업데이트를 검색하는 리포지토리가 포함되어 있습니다. 필요한 만큼의 리포지토리를 만들고 구성할 수 있습니다. 항상 사용하는 사이트도 있고 가끔 사용하는 사이트도 있습니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. VirusScan 콘솔에서 도구 | 자동 업데이트 리포지토리 목록 편집을 선택하여 자동 업데이트 리포지토리 목록 속성에 액세스합니다.
    참고: ePolicy Orchestrator 콘솔을 사용하여 리포지토리 기능을 구성하려면 정책 카탈로그 | McAfee Agent 디스플레이로 이동하고 리포지토리 탭을 클릭합니다.
  2. 탭에서 옵션을 구성합니다.

탭 정의

탭 | 정의
리포지토리
  • 업데이트를 가져오는 리포지토리를 지정합니다.
  • 리포지토리에 액세스하는 순서를 구성합니다.
프록시 설정 | 업데이트 시 사용할 프록시 설정을 지정합니다.


롤백 DAT 파일 작동 방식

현재 DAT 파일이 손상되었거나 호환되지 않는 경우 DAT 파일을 최신 백업 버전으로 롤백할 수 있습니다.

DAT 파일을 업데이트할 때 이전 버전의 저장 위치는 다음과 같습니다. <drive>:\Program Files\Common Files\McAfee\Engine\OldDats.

DAT 파일을 롤백할 때 현재 DAT 파일은 OldDats 폴더의 버전으로 바뀌고 플래그는 다음 위치에 있는 레지스트리에 설정됩니다. HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS.

롤백이 수행되고 나면 이전 버전으로 다시 되돌릴 수 없습니다. 다음 업데이트 수행 시 레지스트리에 있는 DAT 버전을 업데이트 리포지토리에 있는 DAT 파일과 비교합니다. 새 DAT 파일이 레지스트리의 파일과 동일하면 업데이트가 수행되지 않습니다.


DAT 파일 롤백

DAT 파일 버전을 이전 버전으로 되돌리려면 DAT 롤백 도구를 사용합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. VirusScan 콘솔에서 도구 | DAT 롤백을 선택합니다.
  2. 예를 클릭하여 DAT 롤백을 진행합니다.
    참고: 이 기능은 ePolicy Orchestrator 콘솔에서는 사용할 수 없습니다.
  3. 탭에서 옵션을 구성합니다.


검색 항목 제외

각각의 VirusScan Enterprise 스캐너를 사용하면 검색한 파일 형식의 목록을 미세 조정할 수 있습니다. 예를 들어, 개별 파일, 폴더 및 디스크를 검색에서 제외할 수 있습니다. 해당 파일이 데이터베이스 또는 서버에서 사용 중이면 스캐너가 파일을 검색하고 잠글 수 있기 때문에 이러한 제외가 필요할 수 있습니다. 이는 데이터베이스 또는 서버가 실패하거나 오류가 생성되는 원인이 될 수 있습니다.

목차

관련 참조
제외 항목 지정
대표 문자를 사용하여 검색 항목 지정하는 방법


제외 항목 지정

검색 작업에서 제외할 파일, 폴더 및 드라이브를 지정합니다. 이전에 지정한 제외 항목을 제거할 수도 있습니다.

옵션 정의

옵션 정의
제외 대상 제외 유형을 선택합니다.
  • 파일 이름/위치별 제외 — 파일 이름, 위치 및 하위 폴더를 제외할지 여부를 지정합니다.
    참고: 폴더에 적용하려면 문자열 끝에 백슬래시(\)를 추가해야 합니다. 그렇지 않으면 파일 제외로 간주되며 하위 폴더 제외 확인란이 기본적으로 비활성화됩니다.
  • 파일 유형별 제외 — 파일 형식을 지정합니다.
  • 파일 연령별 제외 — 액세스 유형과 최소 연령을 지정합니다.
제외 시기 선택한 항목을 제외할 시기를 선택합니다.
  • 읽을 때
  • 쓸 때
클라이언트 제외를 처리하는 방법 클라이언트 제외 항목 덮어쓰기 — 이 정책에 지정된 항목만 제외합니다. 이 옵션을 선택하지 않으면 클라이언트 컴퓨터는 로컬로 지정된 제외 항목과 정책에서 지정된 제외 항목을 사용합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.


대표 문자를 사용하여 검색 항목 지정하는 방법

와일드카드를 사용하여 확장명으로 파일 형식을 제외할 수 있습니다.

와일드카드를 사용할 때는 다음과 같은 제한 사항이 적용됩니다.

  • 유효한 대표 문자는 단일 문자 제외에 사용하는 물음표(?)와 다중 문자 제외에 사용하는 별표(*)입니다.
  • 대표 문자는 경로에서 백슬래시(\) 앞에 나타날 수 있습니다. 예: C:\ABC\*\XYZ는 C:\ABC\DEF\XYZ와 같습니다.
  • 물음표(?)를 사용한 제외는 물음표의 수가 파일 또는 폴더 이름의 길이와 일치되는 경우에 적용됩니다. 예: W?? 제외는 WWW는 제외하지만 WW 또는 WWWW는 제외하지 않습니다.
  • 구문이 확장되어 이중 별표(**)를 포함할 경우에는 백슬래시를 포함하여 영(0)개 이상의 문자를 의미합니다. 이렇게 하면 여러 경로 수준의 제외를 사용할 수 있습니다. 예: C:\ABC\**\XYZ matches C:\ABC\DEF\XYZ and C:\ABC\DEF\DEF\XYZ 등.


예약된 작업 사용

자동 업데이트, 미러 작업 또는 주문형 검색 구성의 일부로 이러한 작업을 실행할 시기, 빈도 및 기간을 지정해야 합니다. 또한 구성 프로세스의 일부로 사용자 권한을 구성해야 합니다.

목차

관련 참조
작업 예약 구성
관련 정보
작업 예약


작업 예약

특정 날짜/시간에 또는 일정한 간격으로 주문형, 자동 업데이트 및 미러 작업을 실행하도록 예약할 수 있습니다. 작업을 예약하는 방식은 사용 중인 사용자 인터페이스 콘솔에 따라 다릅니다.

이러한 작업을 예약하려면:
  • ePolicy Orchestrator 콘솔 — 예약 탭을 사용하여 예약 페이지를 표시합니다.
  • VirusScan 콘솔 — 예약 단추를 사용하여 예약 대화 상자를 표시합니다.
관련 작업
주문형 검색 작업 구성
관련 참조
자동 업데이트 작업 구성
미러 작업 구성
관련 정보
ePolicy Orchestrator 서버 작업 구성


작업 예약 구성

지정된 시간 또는 간격으로 실행할 작업을 구성하려면 예약 설정 대화 상자를 사용합니다.

시작하기 전에

작업을 예약하려면 관리자 권한이 있어야 합니다. 관리자 권한은 사용자에게 예약된 작업의 레지스트리 키에 대한 쓰기 액세스 권한을 제공합니다.

작업을 예약하려면 작업의 속성 대화 상자에서 예약을 클릭합니다.

주의:
McAfee에서는 최소 간격으로 주문형 검색을 예약할 것을 권장합니다.
권장 McAfee 최소 간격:
  • 매일 — 주요 악성 프로그램이 발생한 경우에만 수행합니다.
  • 매주 — 권장 설정입니다.
  • 매월 — 허용 가능한 설정입니다.
  • 분기별 — 최소 설정입니다.

탭 정의

탭 정의
작업
  • 지정된 시간에 실행하도록 예약 작업 사용
  • 지정된 시간 및 분 동안 실행되면 작업 중지
  • 사용자 이름, 도메인 및 암호와 같은 사용자 계정 설정 지정
예약

예약 빈도 및 관련 설정 지정


2부 - 탐지: 위협 찾기

위협 찾기는 사용자 시스템에 대한 액세스 권한을 얻으려고 시도하는 악성 프로그램을 탐지하는 보호 전략의 두 번째 단계입니다.

목차

  • 온액세스 항목 검색
  • 주문형 항목 검색
  • 배달 시 및 주문형 전자 메일 검색


온액세스 항목 검색

온액세스 스캐너는 컴퓨터에서 액세스된 파일을 검사하여 실시간으로 계속해서 위협을 탐지합니다. 액세스 방지와 버퍼 오버플로우 방지 기능도 모두 온액세스 스캐너를 사용하여 액세스 위반과 버퍼 오버플로우 악용을 각각 탐지합니다.

목차

관련 개념
온액세스 검색 및 수행 방법
검색 비교: 디스크에 기록과 디스크에서 읽기
검색 비교: 모든 파일 검색 및 기본 + 추가 파일 형식 검색
스크립트 검색 및 수행 방법
검색 정책 수 결정
Artemis 작동 방식
관련 정보
일반 설정 및 프로세스 설정 구성 방법


온액세스 검색 및 수행 방법

온액세스 스캐너는 최하위 수준에서 시스템에 연결(파일 시스템 필터 드라이버)합니다. 이 수준에서는 처음 시스템에 입력하는 지점에서 파일을 검색합니다. 온액세스 스캐너는 시스템의 일부로서 작동하며(시스템 서비스), 탐지가 발생하면 인터페이스를 통해 통보를 전달합니다.

파일을 열고 닫거나 파일의 이름을 바꾸려고 할 때 스캐너는 이 작업을 가로채고 다음 액션을 취합니다.

  1. 스캐너는 다음 기준에 따라 해당 파일을 검색해야 하는지 여부를 결정합니다.
    • 파일 확장명이 구성과 일치합니다.
    • 파일이 캐시되지 않았습니다.
    • 파일이 제외되지 않았습니다.
    • 파일이 이전에 검색되지 않았습니다.
  2. 파일이 검색 기준을 충족하는 경우 파일에 있는 정보를 현재 로드된 DAT 파일에 있는 알려진 악성 프로그램 서명과 비교하여 검색합니다.
    • 파일이 감염되지 않았으면 결과가 캐시되며 읽기, 쓰기 또는 이름 바꾸기 작업이 허가됩니다.
    • 파일에 위협이 있으면 작업이 거부되며 구성한 액션이 수행됩니다. 예:
      • 치료가 필요한 경우 해당 치료 프로세스는 현재 로드된 DAT 파일에 의해 결정됩니다.
      • 스캐너가 결과를 기록하도록 구성되어 있으면 결과가 작업 로그에 기록됩니다.
      • 스캐너가 그렇게 구성된 경우 파일 이름과 취한 액션을 설명하는 온액세스 검색 메시지 경보가 표시됩니다.
  3. 검색 요구 사항이 만족되지 않으면 파일을 검색하지 않습니다. 파일이 캐시되며 작업이 허가됩니다.
    참고: 검색 파일 캐시가 플러시되었으며 온액세스 검색 구성이 변경되거나, EXTRA.DAT 파일이 추가되거나 캐시가 꽉 찾을 경우에는 모든 파일이 다시 검색됩니다.


검색 비교: 디스크에 기록과 디스크에서 읽기

온액세스 스캐너는 사용자가 디스크에 기록하는지 또는 디스크에서 읽는지 여부에 따라 다르게 검색을 수행합니다.

파일을 디스크에 기록할 때, 온액세스 스캐너는 다음 항목을 검색합니다.

  • 로컬 하드 드라이브에 기록되고 있는 수신 파일
  • 로컬 하드 드라이브 또는 매핑된 네트워크 드라이브에서 작성 중인 파일(새 파일, 수정된 파일 또는 한 드라이브에서 다른 드라이브로 복사되거나 이동 중인 파일)
    참고: 매핑된 네트워크 드라이브를 검색하려면 네트워크 드라이브 옵션을 활성화해야 합니다. 네트워크 드라이브 활성화를 참조하십시오.

    이러한 검색은 VirusScan Enterprise가 설치된 동일한 클라이언트에서만 액세스할 수 있습니다. 다른 시스템에 의해 매핑된 네트워크 드라이브에 대한 액세스는 탐지하지 않습니다.

파일을 디스크에서 읽을 때, 온액세스 스캐너는 다음 항목을 검색합니다.

  • 로컬 하드 드라이브 또는 매핑된 네트워크 드라이브로부터 읽는 중인 송신 파일
    참고: 매핑된 네트워크 드라이브를 검색하려면 이전 글머리 기호에서 설명하는 네트워크 드라이브 옵션을 선택하여 원격 네트워크 파일을 포함합니다.
  • 로컬 하드 드라이브에서 프로세스를 실행하려고 시도 중인 파일
  • 로컬 하드 드라이브에서 연 파일
  • 로컬 하드 드라이브에서 이름을 바꾼 파일(파일 등록 정보가 변경된 경우)


검색 비교: 모든 파일 검색 및 기본 + 추가 파일 형식 검색

온액세스 스캐너는 모든 파일을 검색하거나 기본 파일과 추가 파일 형식을 검색하도록 구성되었는지 여부에 따라 다르게 파일을 검색합니다.

모든 파일을 검색할 때 스캐너는 가능한 모든 위협에 대해 모든 파일을 검사합니다.

기본 + 추가 파일 형식을 검색하면 스캐너는 사용자가 선택하는 파일 형식을 기준으로 특정 파일 목록을 검사합니다.
  • 기본 파일 형식: 온액세스 스캐너는 해당 파일 형식을 공격하는 위협에 대해서만 지정된 파일 형식을 검사합니다.

  • 추가 파일 형식: 온액세스 스캐너는 가능한 모든 위협에 대해 확장자가 일치하는 파일을 검사합니다.

  • 기본 파일 형식: 온액세스 스캐너는 가능한 모든 위협에 대해 사용자 정의 파일 확장자 목록을 검사합니다.


스크립트 검색 및 수행 방법

스크립트 스캐너는 실제 Windows 스크립팅 호스트 구성 요소에 대한 프록시 구성 요소로 작동하고 스크립트를 가로챈 후에 실행 이전에 스크립트를 검색합니다.

예를 들어, 스크립트 스캐너는 다음을 확인합니다.

  • 스크립트가 감염되지 않은 경우 실제 스크립팅 호스트 구성 요소로 전달됩니다.
  • 스크립트에 잠재적 위협이 있는 경우 해당 스크립트는 실행되지 않습니다.
신뢰할 수 있는 프로세스 및 스크립트를 이용하는 웹 사이트도 검사에서 제외할 수 있습니다.
참고: Windows Server 2008 시스템에서 스크립트 검색 URL 제외는 타사의 브라우저 확장 기능 사용 확인란을 클릭하여 설정을 활성화하고 Windows Server 2008을 다시 시작하지 않는 한 Windows Internet Explorer에서 작동하지 않습니다. 자세한 내용은 https://kc.mcafee.com/corporate/index?page=content&id=KB69526을 참조하십시오.


Artemis 작동 방식

Artemis 기능은 경험적 접근을 사용하여 의심스러운 파일을 검사합니다. Window 기반 McAfee 안티바이러스 제품 사용자에게 특정 악성 프로그램에 대한 실시간 최신 탐지 기능을 제공합니다.

Artemis는 악성 프로그램의 전체 클래스에 대해 보호를 제공하는 것이 아니라 의심스러운 샘플에 대해서만 보호를 제공합니다. 특정 위협에 대한 보호의 이점은 McAfee Labs가 샘플이 악의적인지 확인하는 것과 거의 동시에 McAfee 보안으로 사용자를 보호할 수 있는 기능입니다.

VirusScan Enterprise에 의해 보호되는 클라이언트 시스템에서 실행되는 의심스러운 프로그램과 DLL을 찾기 위해 Artemis가 사용하는 관리자 구성 민감도 수준을 구성할 수 있습니다. Artemis가 의심스러운 프로그램을 탐지하면 의심스러운 파일의 지문이 들어 있는 DNS 요청을 McAfee Labs에서 호스팅하는 중앙 데이터베이스 서버로 전송합니다.

참고: 이 릴리스에서는 Artemis 기능이 기본적으로 매우 낮게 설정된 민감도 수준으로 활성화됩니다.


검색 정책 수 결정

다음 프로세스를 수행하여 둘 이상의 온액세스 검색 정책을 구성할지 여부를 결정합니다.


일반 설정 및 프로세스 설정 구성 방법

온액세스 스캐너의 일반 정책과 프로세스 정책은 별도로 구성됩니다.
  • 일반 설정 — 모든 프로세스에 적용되는 옵션을 포함합니다.
  • 프로세스 설정 — 모든 프로세스에 대해 하나의 검색 정책을 구성하거나 기본, 저위험 및 고위험으로 정의하는 프로세스에 대해 각각 다른 정책을 구성할 수 있습니다.


일반 설정 구성

일반 설정은 모든 프로세스의 검색에 적용되며 최대 검색 시간, 스크립트 검색, 원격 컴퓨터에서 원하지 않는 위협 차단, 위협이 탐지되면 메시지 보내기 및 탐지 보고 등과 같은 매개 변수를 포함합니다.

다음 사용자 인터페이스 콘솔을 사용하여 온액세스 일반 설정을 구성합니다.

관련 정보
온액세스 항목 검색


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 모든 프로세스 검색에 적용되는 일반 설정을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 일반 정책 페이지에서 일반 탭을 클릭하여 모든 온액세스 검색에 적용되는 일반 정책을 구성합니다. 예를 들어, 검색할 온액세스 항목, 검색 시기, 최대 검색 시간 및 쿠키 검색 여부가 있습니다.

    온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스의 검색을 구성할 수 있습니다. 그러면 시스템 보안이 개선되지만 시스템 부팅 시간 성능에 영향을 미칠 수 있습니다.

    검색 그룹에서 활성화 기능에 대한 검색 프로세스를 구성하려면 활성화 시 프로세스 검색을 클릭하여 온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스를 검색합니다.
    참고: 이 기능을 활성화하면 시스템을 부팅하는 데 걸리는 시간에 영향을 미칠 수 있습니다.
  5. ScriptScan 탭에서 ScriptScan을 활성화하고 검색에서 제외할 프로세스 또는 URL을 구성합니다.
  6. 차단 탭에서 공유 폴더에 원하지 않는 프로그램이나 잠재적 위협이 있는 파일을 쓰는 원격 컴퓨터와의 연결 차단을 구성합니다.
    참고: 기본적으로 원격 시스템이 VirusScan Enterprise를 사용하여 시스템에 악성 프로그램을 쓰면 VirusScan Enterprise는 해당 원격 시스템에 대한 연결을 차단합니다.

    또한 악성 프로그램을 작성한 시스템으로 전송되는 메시지를 구성할 수도 있습니다.

    참고: 이 메시지를 전송하려면 Windows Messenger 서비스가 필요합니다.
  7. 메시지 탭에서 구성된 메시지와 함께 탐지가 발생할 때 로컬 사용자에게 알리는 메시지를 구성하고 위협에 대해 사용자가 취할 수 있는 액션을 지정합니다.
  8. 보고서 탭에서 검색 작업 로그 파일을 활성화하고 이 위협 진단에 도움을 주는 저장 위치, 크기, 형식 및 추가 검색 로깅을 정의합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 모든 프로세스 검색에 적용되는 일반 설정을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 일반 정책 페이지에서 일반 탭을 클릭하여 모든 온액세스 검색에 적용되는 일반 정책을 구성합니다. 예를 들어, 검색할 온액세스 항목, 검색 시기, 최대 검색 시간 및 쿠키 검색 여부가 있습니다.

    온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스의 검색을 구성할 수 있습니다. 그러면 시스템 보안이 개선되지만 시스템 부팅 시간 성능에 영향을 미칠 수 있습니다.

    검색 그룹에서 활성화 기능에 대한 검색 프로세스를 구성하려면 활성화 시 프로세스 검색을 클릭하여 온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스를 검색합니다.
    참고: 이 기능을 활성화하면 시스템을 부팅하는 데 걸리는 시간에 영향을 미칠 수 있습니다.
  5. ScriptScan 탭에서 ScriptScan을 활성화하고 검색에서 제외할 프로세스 또는 URL을 구성합니다.
  6. 차단 탭에서 공유 폴더에 원하지 않는 프로그램이나 잠재적 위협이 있는 파일을 쓰는 원격 컴퓨터와의 연결 차단을 구성합니다.
    참고: 기본적으로 원격 시스템이 VirusScan Enterprise를 사용하여 시스템에 악성 프로그램을 쓰면 VirusScan Enterprise는 해당 원격 시스템에 대한 연결을 차단합니다.

    또한 악성 프로그램을 작성한 시스템으로 전송되는 메시지를 구성할 수도 있습니다.

    참고: 이 메시지를 전송하려면 Windows Messenger 서비스가 필요합니다.
  7. 메시지 탭에서 구성된 메시지와 함께 탐지가 발생할 때 로컬 사용자에게 알리는 메시지를 구성하고 위협에 대해 사용자가 취할 수 있는 액션을 지정합니다.
  8. 보고서 탭에서 검색 작업 로그 파일을 활성화하고 이 위협 진단에 도움을 주는 저장 위치, 크기, 형식 및 추가 검색 로깅을 정의합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 모든 프로세스 검색에 적용되는 일반 설정을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 온액세스 일반 정책 페이지에서 일반 탭을 클릭하여 모든 온액세스 검색에 적용되는 일반 정책을 구성합니다. 예를 들어, 검색할 온액세스 항목, 검색 시기, 최대 검색 시간 및 쿠키 검색 여부가 있습니다.

    온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스의 검색을 구성할 수 있습니다. 그러면 시스템 보안이 개선되지만 시스템 부팅 시간 성능에 영향을 미칠 수 있습니다.

    검색 그룹에서 활성화 기능에 대한 검색 프로세스를 구성하려면 활성화 시 프로세스 검색을 클릭하여 온액세스 검색이 활성화될 때마다 시스템에서 현재 실행 중인 모든 프로세스를 검색합니다.
    참고: 이 기능을 활성화하면 시스템을 부팅하는 데 걸리는 시간에 영향을 미칠 수 있습니다.
  3. ScriptScan 탭에서 ScriptScan을 활성화하고 검색에서 제외할 스크립트를 구성합니다.
  4. 차단 탭에서 공유 폴더에 원하지 않는 프로그램이나 잠재적 위협이 있는 파일을 쓰는 원격 컴퓨터와의 연결 차단을 구성합니다.
    참고: 기본적으로 원격 시스템이 VirusScan Enterprise를 사용하여 시스템에 악성 프로그램을 쓰면 VirusScan Enterprise는 해당 원격 시스템에 대한 연결을 차단합니다.

    또한 악성 프로그램을 작성한 시스템으로 전송되는 메시지를 구성할 수도 있습니다.

    참고: 이 메시지를 전송하려면 Windows Messenger 서비스가 필요합니다.
  5. 메시지 탭에서 구성된 메시지와 함께 탐지가 발생할 때 로컬 사용자에게 알리는 메시지를 구성하고 위협에 대해 사용자가 취할 수 있는 액션을 지정합니다.
  6. 보고서 탭에서 검색 작업 로그 파일을 활성화하고 이 위협 진단에 도움을 주는 저장 위치, 크기, 형식 및 추가 검색 로깅을 정의합니다.
    참고: 이러한 로그 파일은 보안 위협을 진단하고 이러한 위협에 대해 취할 액션을 결정할 때 매우 유용합니다.


프로세스 설정 구성

온액세스 검색 프로세스는 각 프로세스에 할당하는 위험에 따라 구성됩니다. 모든 프로세스에 대해 하나의 기본 검색 정책을 구성하거나 각 프로세스에 할당된 위험에 따라 각각 다른 정책을 구성할 수도 있습니다. 매개 변수에는 프로세스에 위험 할당, 검색할 항목 정의, Artemis 검색 수행, 압축된 파일 검색, 탐지 시 액션 수행 및 잠재적으로 원하지 않는 프로그램에 대한 검색 등이 포함됩니다.

다음 사용자 인터페이스 콘솔을 사용하여 온액세스 프로세스 설정을 구성합니다.


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 온액세스 기본 프로세스 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 프로세스 탭에서 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다.를 클릭하여 온액세스 기본 프로세스, 저위험 프로세스 또는 고위험 프로세스를 표시합니다.
  5. 온액세스 기본, 저위험 또는 고위험 프로세스 정책 페이지의 각 탭에서 옵션을 구성합니다. 프로세스 설정 탭 옵션을 참조하십시오.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 온액세스 기본 프로세스 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 프로세스 탭에서 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다.를 클릭하여 온액세스 기본 프로세스, 저위험 프로세스 또는 고위험 프로세스를 표시합니다.
  5. 온액세스 기본, 저위험 또는 고위험 프로세스 정책 페이지의 각 탭에서 옵션을 구성합니다. 프로세스 설정 탭 옵션을 참조하십시오.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 온액세스 검색 등록 정보를 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 왼쪽 창에서 모든 프로세스를 클릭합니다.
  3. 프로세스 탭에서 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다.를 클릭하여 온액세스 기본 프로세스, 저위험 프로세스 또는 고위험 프로세스를 표시합니다.
  4. 온액세스 기본, 저위험 또는 고위험 프로세스 정책 페이지의 각 탭에서 옵션을 구성합니다. 프로세스 설정 탭 옵션을 참조하십시오.


프로세스 설정 탭 옵션

다음 테이블은 온액세스 스캐너 탭 옵션을 설명합니다.

탭 | 정의
프로세스
  • 온액세스 기본 프로세스 — 모든 프로세스에 대해 하나의 검색 정책을 구성할지 기본 프로세스, 저위험 프로세스 및 고위험 프로세스에 대해 각각 다른 검색 정책을 구성할지 선택합니다.
    참고: 하나의 검색 정책을 구성할 경우 해당 정책은 모든 프로세스에 적용됩니다. 저위험 프로세스 및 고위험 프로세스에 대해 각각 다른 검색 정책을 구성할 경우 해당 정책은 저위험 또는 고위험으로 정의되지 않은 프로세스에만 적용됩니다.
  • 온액세스 저위험 프로세스 — 저위험으로 정의한 프로세스를 지정합니다.
  • 온액세스 고위험 프로세스 — 고위험으로 정의한 프로세스를 지정합니다.
참고: 저위험 및 고위험 프로세스에 개별 정책을 구성하려면 먼저 온액세스 기본 프로세스 탭의 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다. 옵션을 선택해야 합니다.
검색 항목
  • 읽을 때, 기록할 때, 네트워크 드라이브에서 또는 백업을 위해 열 때 파일을 검색할지 여부 구성
    주의:
    디스크에 기록할 때 및 디스크에서 읽을 때를 활성화하지 않으면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • 검색할 파일과 파일 형식을 구성합니다.
    주의:
    모든 파일을 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • 원하지 않는 프로그램, 트로이 목마 및 매크로 바이러스와 비슷한 잠재적 위협 검색
  • 압축 파일 내부 검색 및 MIME로 암호화된 파일 복호화
  • 원하지 않는 프로그램에 대한 온액세스 검색 사용
제외 항목 | 검색에서 제외되는 디스크, 파일 및 폴더 구성
액션
위협 탐지 시
  • 위협이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 위협 탐지 시 수행할 보조 액션
원하지 않는 프로그램 탐지 시
  • 원하지 않는 프로그램이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 원하지 않는 프로그램 탐지 시 수행할 보조 액션


네트워크 드라이브 활성화

매핑된 네트워크 드라이브를 검색하려면 네트워크 드라이브 옵션을 활성화해야 합니다.

다음 사용자 인터페이스 콘솔 중 하나를 사용하여 온액세스 기본 프로세스 정책에서 네트워크 드라이브의 온액세스 검색을 구성합니다.


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 온액세스 기본 프로세스 정책에서 네트워크 드라이브를 활성화합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 기본 프로세스 정책 페이지에서 검색 항목 탭을 클릭하고 파일 검색 옆의 네트워크 드라이브를 클릭합니다.
  5. 저장을 클릭합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 네트워크 드라이브를 활성화합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 온액세스 기본 프로세스 정책 페이지에서 검색 항목 탭을 클릭하고 파일 검색 옆의 네트워크 드라이브를 클릭합니다.
  5. 저장을 클릭합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 네트워크 드라이브를 활성화합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 온액세스 스캐너 등록 정보 대화 상자를 엽니다.
  2. 검색 항목 탭을 클릭하고 검색 파일 옆의 네트워크 드라이브를 클릭합니다.
  3. 저장을 클릭합니다.


주문형 항목 검색

주문형 스캐너는 편리한 시간에 또는 정기적으로 컴퓨터의 모든 부분에서 잠재적인 위협이 있는지 검사합니다. 주문형 검색을 사용하여 온액세스 스캐너의 지속적인 보호 기능을 보완하거나 사용자의 작업을 방해하지 않을 때 정기 검색을 수행하도록 예약할 수 있습니다.

목차

관련 개념
주문형 검색 및 작동 방식
주문형 검색 방법 및 정의 방법
원격 저장 영역 검색 방법
검색 연기 작동 방식
시스템 사용률 작동 방식
관련 작업
주문형 검색 작업 구성
글로벌 시스템 캐시 구성


주문형 검색 및 작동 방식

주문형 스캐너는 시스템의 파일, 폴더, 메모리, 레지스터 및 시스템을 감염시킬 수 있는 악성 프로그램을 검색합니다. 사용자는 주문형 검색이 발생하는 시기와 방법을 결정합니다. 시스템을 수동으로, 예약된 시간에 또는 시스템을 부팅할 때 검색할 수 있습니다.

파일을 열고 닫거나 파일의 이름을 변경하려고 하면 스캐너가 이 작업을 가로채고 다음 액션을 취합니다.

  1. 스캐너는 다음 기준에 따라 파일, 폴더 또는 디스크를 검색해야 하는지 여부를 결정합니다.
    • 파일 확장명이 구성과 일치합니다.
    • 파일이 캐시되지 않았습니다.
    • 파일이 제외되지 않았습니다.
    • 파일이 이전에 검색되지 않았습니다.
      참고: Artemis를 구성하는 경우 주문형 스캐너는 경험적 접근을 사용하여 의심되는 파일을 검사합니다. 자세한 내용은 Artemis 작동 방식을 참조하십시오.
  2. 파일, 폴더 또는 디스크가 검색 기준을 충족하는 경우 파일에 있는 정보를 현재 로드된 DAT 파일에 있는 알려진 바이러스 서명과 비교하여 검색합니다.
    • 감염되지 않았으면 결과가 캐시되며 다음 항목이 검사됩니다.
    • 위협이 포함된 경우 구성된 액션을 취합니다. 예:
      • 치료가 필요한 경우 해당 프로세스는 현재 로드된 DAT 파일에 의해 결정됩니다.
      • 스캐너가 결과를 기록하도록 구성되어 있으면 결과가 작업 로그에 기록됩니다.
      • 주문형 검색 진행 대화 상자에서 메모리, 파일, 폴더 또는 디스크 이름 및 취한 액션을 설명하는 정보가 표시됩니다.
  3. 메모리, 파일, 폴더 또는 디스크가 검색 요구 사항을 충족하지 않을 경우 모든 데이터를 검색할 때까지 검색을 계속합니다.
관련 개념
Artemis 작동 방식


주문형 검색 방법 및 정의 방법

주문형 스캐너는 내부 메모리 프로세스 검색 및 증분이나 다시 시작 가능한 검색을 사용합니다.

메모리 내 프로세스 검색

이 방법은 주문형 검색 작업을 실행하기 전에 모든 활성 프로세스를 검사합니다. 탐지된 잠재적으로 원하지 않는 프로세스가 강조 표시되며 해당 프로세스는 중지됩니다. 따라서 잠재적으로 원하지 않는 프로그램의 모든 인스턴스를 제거하려면 주문형 스캐너로 한 번만 통과시키면 됩니다.

증분형 또는 다시 시작할 수 있는 검색

이 방법을 사용하면 주문형 검색 작업이 발생하는 시기를 제한하고 여러 세션에서 전체 시스템을 검색할 수 있습니다. 증분 검색은 예약된 검색에 시간 제한을 추가하여 설정할 수 있습니다. 검색은 시간 제한에 도달하면 중지됩니다. 다음에 이 작업을 시작하면 이전 검색이 중지된 파일과 폴더 구조의 해당 지점에서 계속됩니다.


원격 저장 영역 검색 방법

원격 저장소 데이터는 2개의 정의된 저장 영역 수준으로 구성된 계층 구조입니다.

2개의 저장 영역 수준:
  • 상위 수준인 로컬 저장 영역 — Windows 2000 Server에서 원격 저장 영역을 실행 중인 컴퓨터의 NTFS 디스크 볼륨이 포함됩니다.
  • 하위 수준인 원격 저장 영역 — 서버 컴퓨터에 연결된 로보틱 테이프 라이브러리 또는 독립 실행형 테이프 드라이브에 있습니다.

원격 저장 영역은 로컬 볼륨에 있는 유효한 파일을 테이프 라이브러리에 자동으로 복사한 다음 로컬 볼륨에서 사용 가능한 공간을 모니터합니다. 파일 데이터는 로컬로 캐시되어 필요한 경우 파일 데이터에 빠르게 액세스할 수 있습니다. 필요한 경우 원격 저장 영역은 로컬 저장 영역의 데이터를 원격 영역으로 이동합니다. 원격 저장 영역에서 관리하는 볼륨의 파일에 액세스해야 할 경우 평소대로 파일을 엽니다. 파일의 데이터가 더 이상 로컬 볼륨에 캐시되지 않는 경우 원격 영역에서는 테이프 라이브러리의 데이터를 재호출합니다.

관련 작업
주문형 검색 작업 구성


검색 연기 작동 방식

성능을 개선을 위해 배터리 전원이 부족하거나 전체 화면 프레젠테이션 수행 시 주문형 검색 작업을 연기할 수 있습니다. 또한 사용자는 한 시간 단위로 예약된 검색을 연기할 수 있습니다. 증분은 한 시간, 24시간 지속될 수 있으며, 또는 주문형 검색을 계속 연기할 수 있습니다.

각 사용자 지연은 한 시간 지속될 수 있습니다. 예를 들어, 최대 연기 옵션이 2로 설정된 경우 사용자는 검색 작업을 2회 또는 2시간 연기할 수 있습니다. 지정된 최대 시간이 경과하면 검색이 계속됩니다. 관리자가 옵션을 0으로 설정하여 무제한 연기를 허용하는 경우 사용자는 검색을 계속해서 연기할 수 있습니다.


시스템 사용률 작동 방식

주문형 스캐너는 검색 프로세스와 위협 우선 순위에 대해 Windows 우선 순위 설정을 사용합니다. 따라서 운영 체제는 검색 프로세스의 모든 지점에서 주문형 스캐너가 수신하는 CPU 시간을 설정할 수 있습니다. 주문형 검색 등록 정보의 시스템 사용률 설정은 Windows 우선 순위 설정 제어에 매핑됩니다.

스캔을 위한 시스템 사용률을 낮게 설정하면 실행 중인 다른 응용 프로그램에 대한 개선된 성능을 제공합니다. 낮은 설정은 진행 중인 최종 사용자 작업이 있는 시스템에 사용됩니다. 반대로 시스템 사용률을 보통으로 설정하면 검색이 더 빨리 완료됩니다. 보통 설정은 많은 볼륨과 매우 적은 최종 사용자 작업이 있는 시스템에 유용합니다.

다음 표는 VirusScan Enterprise 및 ePolicy Orchestrator 기본 프로세스 설정을 보여줍니다.

VirusScan Enterprise 프로세스 설정 | Windows 우선 순위 설정
낮음 | 낮음
보통 이하 — ePolicy Orchestrator 기본값 | 보통 이하
보통 — VirusScan Enterprise 8.8 기본값 | 보통
관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


주문형 검색 작업 구성

사용 중인 사용자 인터페이스 콘솔에 따라 주문형 작업을 구성합니다. 이러한 작업은 각 사용자 인터페이스 콘솔의 프로세스를 설명합니다.

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔
관련 참조
주문형 검색 작업 탭 구성


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 주문형 검색 작업을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 시스템 | 시스템 트리를 클릭하고 클라이언트 작업을 선택합니다.
  2. 나타나는 클라이언트 작업 페이지에서:
    • 기존 주문형 검색 작업을 편집하려면 작업의 액션 열에서 설정 편집을 클릭하여 설명 페이지를 엽니다.
    • 새 주문형 검색 작업을 생성하려면 작업 | 새 작업을 클릭하여 설명 페이지를 엽니다.
  3. 설명 페이지:
    • 기존 주문형 검색 작업을 편집할 때 설명을 확인하고 다음을 클릭합니다.
    • 새 주문형 검색 작업을 생성할 때 다음을 구성하고 다음을 클릭합니다.
      • 이름 및 참고.
      • 유형 - 목록에서 주문형 검색(VirusScan Enterprise 8.8)을 선택하면 됩니다.
      • 태그 - 주문형 검색 작업을 수신하는 컴퓨터를 결정합니다.
  4. 나타나는 클라이언트 작업 작성기 구성 페이지에서 각 탭을 구성합니다. 자세한 내용은 주문형 검색 작업 탭 구성을 참조하십시오.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 주문형 검색 작업을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 시스템 트리 | 클라이언트 작업을 클릭합니다.
  2. 나타나는 클라이언트 작업 페이지에서:
    • 기존 주문형 검색 작업을 편집하려면 작업의 액션 열에서 편집을 클릭하여 설명 페이지를 엽니다.
    • 새 주문형 검색 작업을 생성하려면 작업 | 새 작업을 클릭하여 설명 페이지를 엽니다.
  3. 다음 중 하나를 수행합니다.
    • 기존 주문형 검색 작업을 편집할 때 설명을 확인하고 다음을 클릭합니다.
    • 새 주문형 검색 작업을 생성할 때 다음을 구성하고 다음을 클릭합니다.
      • 이름 및 참고.
      • 유형 - 목록에서 주문형 검색(VirusScan Enterprise 8.8)을 선택하면 됩니다.
      • 태그 - 주문형 검색 작업을 수신하는 컴퓨터를 결정합니다.
  4. 나타나는 클라이언트 작업 작성기 구성 페이지에서 각 탭을 구성합니다. 자세한 내용은 주문형 검색 작업 탭 구성을 참조하십시오.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 주문형 검색 작업을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 기존 작업 또는 새 작업을 위한 주문형 검색 등록 정보 페이지를 엽니다.
    • 기존 주문형 검색 작업을 선택하고 마우스 오른쪽 단추를 클릭한 후 속성을 선택합니다.
    • 새 작업을 만들고 작업 | 새 주문형 검색 작업을 선택하고 새 작업을 마우스 오른쪽 단추로 클릭한 후 속성을 클릭합니다.
  2. 주문형 검색 등록 정보 대화 상자에서 각 탭을 구성합니다. 자세한 내용은 주문형 검색 작업 탭 구성을 참조하십시오.
관련 참조
주문형 검색 작업 탭 구성


주문형 검색 작업 탭 구성

VirusScan Enterprise에는 기본 주문형 검색 작업이 포함되어 있습니다. 기본 작업을 사용하고 새 작업을 생성할 수 있습니다.

각 탭에서 옵션을 구성합니다. 옵션 정의를 보려면 각 탭에서 ? 또는 도움말을 클릭합니다.

탭 정의

탭 | 정의
검색 위치
  • 검색할 위치와 항목 지정
  • 실행 중인 프로세스 포함
  • 검색할 때 하위 폴더 포함
  • 검색할 때 부팅 섹터 포함
  • 검색할 때 레지스트리 키와 값 포함
  • 검색할 때 쿠키 파일 포함
주의:
루트킷에서 사용하는 메모리 및 실행 중인 프로세스를 검색하지 않으면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
참고: 주문형 검색 진행 대화 상자가 나타나면 검색할 위치가 검색 위치 다음에 쉼표로 구분된 문자열로 나타납니다. 모든 검색 프로세스가 완료되면 문자열에서 제거됩니다.
검색 항목
  • 검색할 파일과 파일 형식을 구성합니다.
  • 원하지 않는 프로그램에 대한 주문형 검색 사용
  • 압축 파일 내부 검색 및 MIME로 암호화된 파일 복호화
  • 저장 영역으로 마이그레이션된 파일 검색
  • 원하지 않는 프로그램, 트로이 목마 및 매크로 바이러스와 비슷한 잠재적 위협 검색
제외 항목 | 이름/위치별, 파일 형식별 또는 파일 연령별로 검색에서 제외하도록 디스크, 파일 및 폴더를 구성합니다.
Performance(성능)
  • 검색을 연기할 시간과 기간 구성
  • 시스템 사용률 백분율 지정
  • Artemis의 민감도 수준 구성
액션
위협 탐지 시
  • 위협이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 위협 탐지 시 수행할 보조 액션
원하지 않는 프로그램 탐지 시
  • 원하지 않는 프로그램이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 원하지 않는 프로그램 탐지 시 수행할 보조 액션

프롬프트 대화 상자에서 허용된 액션에 대해 작업 선택

보고서
  • 작업 로그 기록을 활성화합니다.
  • 로그 파일 이름 및 위치를 지정합니다.
  • 로그 파일 크기 제한을 지정합니다.
  • 로그 파일 형식을 선택합니다.
  • 검색 작업 외에 기록할 내용을 지정합니다.
  • 다음 중 검색 작업 외에 기록할 내용을 지정합니다.
    • 세션 설정 사용
    • 세션 요약 사용
    • 암호화된 파일 검색 실패 사용
  • 쿠키가 탐지되면 경고 사용
작업 주문형 검색 작업을 실행할 위치를 지정합니다.
참고: 이 탭은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.


글로벌 시스템 캐시 구성

VirusScan Enterprise 캐시 검색은 검색되고 치료된 파일의 목록을 저장합니다. 시스템을 재부팅하는 동안 이 치료 파일 검색 캐시 정보를 저장하여 시스템 성능을 개선할 수 있습니다. 따라서 주문형 스캐너가 이 치료 파일 캐시 정보를 사용하여 중복된 파일 검색을 줄일 수 있습니다.

다음 사용자 인터페이스 콘솔을 통해 일반 옵션 정책과 전역 검색 설정 탭을 사용하여 검색 캐시 기능을 구성합니다.

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 통해 일반 옵션 정책에서 검색 캐시 기능을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ? 또는 도움말을 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 일반 옵션 정책에서 글로벌 검색 설정 탭을 클릭하여 VirusScan Enterprise 검색 캐시 옵션 설정을 구성합니다.
  5. 검색 캐시에 대해 다음 글로벌 설정을 구성합니다.
    • 재부팅할 때 검색 데이터 저장 활성화 클릭 — 시스템을 재부팅할 때 치료 검색 결과를 저장합니다.
    • 주문형 검색에서 캐시 검색 사용 허용 클릭 — 주문형 스캐너가 기존 치료 검색 결과를 사용하여 중복된 검색을 줄일 수 있습니다.
  6. 저장을 클릭합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 통해 일반 옵션 정책에서 검색 캐시 기능을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ? 또는 도움말을 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 일반 옵션 정책에서 글로벌 검색 설정 탭을 클릭하여 VirusScan Enterprise 검색 캐시 옵션 설정을 구성합니다.
  5. 검색 캐시에 대해 다음 글로벌 설정을 구성합니다.
    • 재부팅할 때 검색 데이터 저장 활성화 클릭 — 시스템을 재부팅할 때 치료 검색 결과를 저장합니다.
    • 주문형 검색에서 캐시 검색 사용 허용 클릭 — 주문형 스캐너가 기존 치료 검색 결과를 사용하여 중복된 검색을 줄일 수 있습니다.
  6. 저장을 클릭합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 검색 캐시 기능을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 도구 | 일반 옵션 및 글로벌 검색 설정 탭을 클릭하여 글로벌 검색 설정 대화 상자를 표시합니다.
  2. 검색 캐시에 대해 다음 글로벌 설정을 구성합니다.
    • 재부팅할 때 검색 데이터 저장 활성화 클릭 — 시스템을 재부팅할 때 치료 검색 결과를 저장합니다.
    • 주문형 검색에서 캐시 검색 사용 허용 클릭 — 주문형 스캐너가 기존 치료 검색 결과를 사용하여 중복된 검색을 줄일 수 있습니다.
  3. 확인을 클릭합니다.


배달 시 및 주문형 전자 메일 검색

전자 메일 스캐너는 전자 메일 메시지와 첨부 파일을 자동으로 검사합니다.

전자 메일은 다음을 통해 검색됩니다.
  • Microsoft Outlook — 전자 메일이 배달 시 검색됩니다. 그렇지 않으면 Microsoft Outlook에서 직접 주문형 전자 메일 검색을 호출할 수 있습니다.
    참고: 경험적 접근 및 Artemis 기능을 구성하는 경우 전자 메일 배달 시 및 주문형 스캐너는 경험적 접근을 사용하여 의심스러운 파일을 검사합니다. 자세한 내용은 Artemis 작동 방식을 참조하십시오.
  • Lotus Notes — 다음과 같이 구성할 수 있습니다.
    • 액세스할 때 전자 메일을 검색합니다.
    • 호출되면 Lotus Notes에서 직접 주문형 전자 메일을 검색합니다.
    • Notes 데이터베이스에서 제외할 내용.

다음 사용자 인터페이스 콘솔을 사용하여 배달 시 전자 메일 검색 정책을 구성합니다.

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔
관련 참조
배달 시 전자 메일 검색 정책 탭 정의


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 배달 시 전자 메일 검색 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 배달 시 전자 메일 검색 정책 구성 페이지에서 각 탭의 옵션을 구성합니다. 배달 시 전자 메일 검색 정책 탭 정의를 참조하십시오.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 배달 시 전자 메일 검색 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 배달 시 전자 메일 검색 정책 구성 페이지에서 각 탭의 옵션을 구성합니다. 배달 시 전자 메일 검색 정책 탭 정의를 참조하십시오.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 배달 시 전자 메일 검색 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 작업 목록에서 배달 시 전자 메일 검색 등록 정보를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 배달 시 전자 메일 검색 등록 정보 대화 상자에서 각 탭의 옵션을 구성합니다. 배달 시 전자 메일 검색 정책 탭 정의를 참조하십시오.


배달 시 전자 메일 검색 정책 탭 정의

탭 정의
검색 항목
  • 검색할 첨부 파일과 메시지 지정
  • 악성 프로그램, 알려지지 않은 매크로 바이러스와 비슷한 잠재적 위협에 대해 경험적 접근을 사용하여 검색하고 여러 확장자가 있는 첨부 파일 찾기
  • 압축 파일 내부 보관 파일을 검색하고 MIME 인코딩 파일 디코딩
  • 원하지 않는 프로그램을 검색하도록 전자 메일 스캐너 사용
  • 전자 메일 메시지 본문 검색
  • Artemis의 민감도 수준 구성
    참고: 이 옵션은 배달 시 전자 메일 검색에만 사용할 수 있습니다.
액션
위협 탐지 시
  • 위협이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 수행할 보조 액션
원하지 않는 프로그램 탐지 시
  • 원하지 않는 프로그램이 탐지되면 수행할 기본 액션
  • 첫 번째 액션이 실패하면 수행할 보조 액션

프롬프트 대화 상자에서 허용된 액션에 대해 작업 선택

알림
  • 위협이 있는 전자 메일 메시지가 탐지되면 다른 사용자에게 알림
  • 액션을 묻는 메시지가 표시되면 사용자에게 표시할 메시지를 지정합니다.
보고서
  • 작업 로그 기록을 활성화합니다.
  • 로그 파일 이름 및 위치를 지정합니다.
  • 로그 파일 크기 제한을 지정합니다.
  • 로그 파일 형식을 선택합니다.
  • 검색 작업 외에 기록할 내용을 지정합니다.
Notes 스캐너 설정
참고: 이 탭은 배달 시 전자 메일 검색에만 사용할 수 있습니다.

Lotus Notes 전용 설정을 구성합니다.

  • 모든 서버 데이터베이스를 검색
  • 지정된 사서함 루트 폴더에서 서버 사서함 검색
  • 무시할 Notes 응용 프로그램


3부 - 응답: 위협 처리

위협에 대한 응답은 사용자 시스템에 대한 액세스 권한을 얻으려고 시도하는 악성 프로그램을 탐지하고 치료하는 보호 전략의 세 번째 단계입니다.

목차

  • 탐지 및 응답
  • 알림 및 통보 구성
  • 쿼리 및 대시보드 액세스
  • 긴급 DAT 구성


탐지 및 응답

위협이 발생하고 탐지되면 VirusScan Enterprise가 응답하도록 구성되는 방식과 위협을 탐지하는 기능에 따라 처리 방법이 결정됩니다. 이러한 차이를 이해하면 효과적인 전략을 개발하고 구현할 수 있습니다.

목차

관련 개념
탐지가 발생한 경우 처리 방식
검역 항목
관련 참조
시스템 액세스 포인트 위반
버퍼 오버플로우 탐지
원하지 않는 프로그램 탐지
온액세스 검색 탐지
주문형 검색 탐지
전자 메일 검색 탐지


탐지가 발생한 경우 처리 방식

탐지가 발생하면 대응은 VirusScan Enterprise가 구성된 방식에 따라 달라집니다

VirusScan Enterprise가 자동으로 치료되도록 구성된 경우(제안된 기본 설정) 결과 액션은 DAT 파일의 치료 지침에 따라 달라집니다. 예를 들어 스캐너에서 파일을 치료할 수 없거나 복구할 수 없을 정도로 파일이 손상된 경우에는 DAT 파일의 정의에 따라 스캐너에서 파일을 삭제하거나 보조 액션을 수행할 수 있습니다.

스캐너가 잠재적 위협이 있는 파일에 대한 액세스를 거부하는 경우 스캐너는 파일을 저장할 때 파일 이름에 .mcm 확장명도 추가합니다.


시스템 액세스 포인트 위반

시스템 액세스 포인트가 위반된 경우 수행되는 액션은 규칙이 구성된 방법에 따라 달라집니다.

규칙이 다음과 같이 구성된 경우:

  • 보고 — 정보가 로그 파일에 기록됩니다.

  • 차단 — 액세스가 거부됩니다.

로그 파일을 검토하여 위반된 시스템 액세스 포인트와 위반을 탐지한 규칙을 식별한 다음 사용자가 올바른 항목에는 액세스할 수 있지만 보호된 항목에는 액세스할 수 없도록 액세스 보호 규칙을 구성합니다.

다음 시나리오를 사용하여 대응으로 취할 액션을 결정합니다.

탐지 유형 시나리오
원하지 않는 프로세스
  • 규칙이 로그 파일에서 위반을 보고했지만 위반을 차단하지 않은 경우 규칙에 대해 차단 옵션을 선택합니다.
  • 규칙이 위반을 차단했지만 로그 파일에서 위반을 보고하지 않은 경우 규칙에 대해 보고서 옵션을 선택합니다.
  • 규칙이 위반을 차단하고 로그 파일에 보고한 경우 액션이 필요하지 않습니다.
  • 원하지 않는 프로세스가 탐지되지 않으면 이 프로세스를 차단으로 포함하도록 규칙을 편집합니다.
올바른 프로세스
  • 규칙이 로그 파일에서 위반을 보고했지만 위반을 차단하지 않은 경우 규칙에 대해 보고서 옵션을 선택 취소합니다.
  • 규칙이 위반을 차단했고 로그 파일에 보고한 경우 합법적인 프로세스가 차단에서 제외되도록 규칙을 편집합니다.


버퍼 오버플로우 탐지

버퍼 오버플로 탐지가 발생하면 스캐너는 탐지를 차단하고 온액세스 검색 메시지 대화 상자에 메시지가 기록됩니다. 대화 상자를 본 다음 추가 액션을 취할지 여부를 결정할 수 있습니다.

취할 수 있는 액션은 다음과 같습니다.
  • 메시지 제거 — 목록에서 항목을 선택하고 제거를 클릭합니다.
  • 제외 항목 생성 — 탐지된 프로세스가 올바르게 사용하는 프로세스이거나 잘못된 긍정인 경우 온액세스 검색 메시지 대화 상자의 정보를 사용하여 제외를 생성합니다. 이름 열의 정보를 검토하여 호출을 수행하는 쓰기가 가능한 메모리를 소유한 프로세스의 이름을 확인합니다. 프로세스 이름을 사용하여 제외를 만듭니다.
  • 분석을 위해 McAfee Labs에 샘플 제출 - 스캐너에서 탐지하지 않아야 할 항목을 탐지하거나 탐지해야 할 항목을 탐지하지 않는 경우에는 McAfee Labs에 샘플을 보낼 수 있습니다.


원하지 않는 프로그램 탐지

온액세스, 주문형 및 전자 메일 스캐너는 구성한 원하지 않는 프로그램 정책에 따라 원하지 않는 프로그램을 탐지합니다. 탐지가 발생하면 잠재적으로 원하지 않는 프로그램을 탐지한 스캐너는 해당 스캐너에 대해 액션 탭에서 구성한 액션을 적용합니다.

작업 로그의 정보를 검토하여 다음 추가 액션 중 하나를 수행할지 여부를 결정합니다.

  • 검색 항목을 미세 조정 — 보다 효율적인 검색을 수행합니다.
  • 검색에서 제외 — 합법적인 프로그램이 탐지된 경우 제외하도록 구성할 수 있습니다.
  • 사용자 지정 탐지 목록에 추가 — 원하지 않는 프로그램이 탐지된 경우 해당 프로그램을 사용자 정의 탐지 목록에 추가할 수 있습니다.
  • 분석을 위해 McAfee Labs에 샘플 제출 - 스캐너에서 탐지하지 않아야 할 항목을 탐지하거나 탐지해야 할 항목을 탐지하지 않는 경우에는 McAfee Labs에 샘플을 보낼 수 있습니다.


온액세스 검색 탐지

온액세스 스캐너가 악성 프로그램을 탐지하면 액션 탭에서 온액세스 검색 등록 정보를 구성하는 방법에 따라 액션이 취해집니다. 또한 메시지는 온액세스 검색 메시지 대화 상자에 기록됩니다.

작업 로그 및 온액세스 검색 메시지 대화 상자의 정보를 검토하여 다음 추가 액션 중 하나를 수행할지 여부를 결정합니다.

  • 검색 항목을 미세 조정 — 보다 효율적으로 검색하려면 VirusScan Enterprise가 위협을 고려할 수 있는 합법적인 파일을 제외하고 검역에 저장될 수 있는 알려진 위협을 삭제합니다.
  • 온액세스 검색 메시지 대화 상자에서 항목을 마우스 오른쪽 단추로 클릭 — 다음 액션 수행:
    • 파일 치료 - 선택한 메시지에서 참조한 파일을 치료합니다.
    • 파일 삭제 - 선택한 메시지에서 참조한 파일을 삭제합니다. 검역 관리자로부터 복원할 수 있도록 파일 이름이 로그에 기록됩니다.
    • 모두 선택(Ctrl+A) - 목록의 모든 메시지를 선택합니다.
    • 목록에서 메시지 제거(Ctrl+D) - 목록에서 선택한 메시지를 제거합니다. 목록에서 제거된 메시지가 로그 파일에 계속 표시됩니다.
    • 모든 메시지 제거 - 목록에서 모든 메시지를 제거합니다. 목록에서 제거된 메시지가 로그 파일에 계속 표시됩니다.
    • 온액세스 스캐너 로그 파일 열기 - 온액세스 스캐너 작업 로그 파일을 엽니다. 이 옵션은 파일 메뉴에서만 사용할 수 있습니다.
    • 액세스 방지 로그 파일 열기 - 액세스 방지 작업 로그 파일을 엽니다. 이 옵션은 파일 메뉴에서만 사용할 수 있습니다.
    • 현재 메시지에 대해 액션을 사용할 수 없는 경우 해당 아이콘, 단추 및 메뉴 항목을 사용할 수 없습니다. 예를 들어 파일이 이미 삭제되었다면 치료를 사용할 수 없고 관리자가 액션을 수행할 수 없도록 한 경우 삭제를 사용할 수 없습니다.
    • 파일 치료 - DAT 파일에 대한 치료 프로그램이 없거나 복구할 수 없을 정도로 파일이 손상된 경우 파일을 치료할 수 없습니다. 파일을 치료할 수 없으면 스캐너는 파일 이름에 .mcm 확장명을 추가하고 파일에 대한 액세스를 거부합니다. 항목이 로그 파일에 기록됩니다. 이러한 경우 파일을 삭제하고 감염되지 않은 백업 복사본을 사용하여 해당 파일을 복원하는 것이 좋습니다.
  • 분석을 위해 McAfee Labs에 샘플 제출 - 스캐너에서 탐지하지 않아야 할 항목을 탐지하거나 탐지해야 할 항목을 탐지하지 않는 경우에는 McAfee Labs에 샘플을 보낼 수 있습니다.


주문형 검색 탐지

주문형 탐지가 발생하면 스캐너는 액션 탭의 주문형 검색 등록 정보를 구성한 방법에 따라 액션을 수행합니다.

작업 로그의 정보를 검토하여 다음 추가 액션 중 하나를 수행할지 여부를 결정합니다.

  • 검색 항목을 지세 조정 — 검색 항목을 미세 조정하여 보다 효율적인 검색을 수행합니다.
  • 액션에 대한 프롬프트 — 주문형 검색 프로세스 대화 상자에서 액션을 선택하여 스캐너를 액션에 대한 프롬프트로 구성합니다.
  • 분석을 위해 McAfee Labs에 샘플 제출 - 스캐너에서 탐지하지 않아야 할 항목을 탐지하거나 탐지해야 할 항목을 탐지하지 않는 경우에는 McAfee Labs에 샘플을 보낼 수 있습니다.


전자 메일 검색 탐지

전자 메일 탐지가 발생하면 스캐너는 배달 시 전자 메일 검색 등록 정보 또는 주문형 전자 메일 검색 등록 정보, 액션 탭 구성 방법에 따라 액션을 취합니다.

작업 로그의 정보를 검토하여 다음 추가 액션 중 하나를 수행할지 여부를 결정합니다.

  • 검색 항목을 미세 조정 — 보다 효율적인 검색을 수행합니다.
  • 분석을 위해 McAfee Labs에 샘플 제출 - 스캐너에서 탐지하지 않아야 할 항목을 탐지하거나 탐지해야 할 항목을 탐지하지 않는 경우에는 McAfee Labs에 샘플을 보낼 수 있습니다.


검역 항목

위협으로 탐지되는 항목은 치료되거나 삭제됩니다. 또한 항목의 사본은 실행할 수 없는 형식으로 변환되고 검역 폴더에 저장됩니다. 따라서 위협을 치료할 수 있는 정보가 포함되어 있을 수 있는 DAT의 최신 버전을 다운로드한 후에 검역된 항목에서 프로세스를 수행할 수 있습니다.

이러한 추가 프로세스는 다음과 같습니다.

  • 복원.

  • 다시 검색.

  • 삭제.

  • 잘못된 긍정 검사.

  • 탐지 등록 정보 보기.

참고: 검역된 항목에는 여러 유형의 검색된 개체가 포함될 수 있습니다 이러한 개체에는 악성 프로그램의 파일, 쿠키, 레지스트리 또는 VirusScan Enterprise 검색이 있습니다.


검역 정책 구성

검역 관리자 정책에 액세스하고 필요한 경우 검역 정책을 구성하거나 기본 설정을 사용합니다.

다음 사용자 인터페이스 콘솔을 사용하여 검역 관리자 정책을 구성합니다.

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 검역 관리자 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 검역 페이지에서 기본 검역 디렉토리를 사용하거나 다른 디렉토리를 선택합니다.
  5. 검역 항목을 저장한 일수를 구성하려면 지정된 기간(일수)이 경과하면 검역된 데이터 자동 삭제를 클릭하고 검역 디렉토리에 백업 데이터를 유지할 기간(일수)을 입력합니다.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 검역 관리자 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 검역 페이지에서 기본 검역 디렉토리를 사용하거나 다른 디렉토리를 선택합니다.
  5. 검역 항목을 저장한 일수를 구성하려면 지정된 기간(일수)이 경과하면 검역된 데이터 자동 삭제를 클릭하고 검역 디렉토리에 백업 데이터를 유지할 기간(일수)을 입력합니다.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 검역 관리자 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 작업 목록에서 검역 관리자 정책을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 검역 관리자 정책 대화 상자를 엽니다.
  2. 기본 검역 디렉토리를 사용하거나 다른 디렉토리를 선택합니다.
  3. 검역 항목을 저장한 일수를 구성하려면 지정된 기간(일수)이 경과하면 검역된 데이터 자동 삭제를 클릭하고 검역 디렉토리에 백업 데이터를 유지할 기간(일수)을 입력합니다.


검역 항목 관리

이러한 항목을 추가로 검사하도록 검역 항목을 처리하고 VirusScan 콘솔을 사용하여 해당 항목을 수동으로 삭제하거나 복원합니다.
참고: ePolicy Orchestrator 콘솔에서 검역에서 복원 클라이언트 작업을 사용하여 검역 항목을 복원합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. VirusScan 콘솔 작업 목록에서 검역 관리자 정책을 클릭하여 검역 관리자 정책 대화 상자를 엽니다.
  2. 관리자 탭을 클릭하고 항목을 마우스 오른쪽 단추로 클릭하여 다음과 같은 고급 옵션에 액세스합니다.

    • 복원.

    • 다시 검색.

    • 삭제.

    • 잘못된 긍정 검사.

    • 탐지 등록 정보 보기.

  3. 대화 상자가 나타나고 시도 영향을 설명합니다.


알림 및 통보 구성

잠재적 위협이 탐지될 때 통보를 받는 일은 사용자 환경을 보호하는 데 있어서 중요한 부분입니다. ePolicy Orchestrator 콘솔 또는 VirusScan 콘솔을 사용하여 탐지가 발생하는 시기를 통보하는 방법을 구성할 수 있습니다. 두 콘솔을 사용하여 경고 옵션을 구성하고 경고 트래픽을 제한하기 위해 심각도별로 경고를 필터링하고 로컬 경고 옵션을 구성할 수 있습니다.

관련 작업
알림 구성
관련 참조
온액세스 검색 탐지


알림 구성

다양한 스캐너가 위협을 탐지할 때 나타나는 경보 및 알림 속성을 구성합니다.

동일한 프로세스를 사용하여 다음 정책에 대한 경보를 구성합니다.
  • 경고 정책
  • 버퍼 오버플로 보호 정책
  • 배달 시 전자 메일 검색 정책

다음 사용자 인터페이스 콘솔을 사용하여 세 가지 정책 모두에 대한 경보 알림 정책을 구성합니다.

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔
관련 참조
경보 정책 탭 구성


ePolicy Orchestrator 4.5 또는 4.6

이 사용자 인터페이스 콘솔을 사용하여 경보 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 메뉴 | 정책 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 작업 | 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 범주 목록에서 기존 정책을 선택합니다.
    3. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    4. 새 정책 이름을 입력합니다.
    5. 필요한 경우 메모를 입력합니다.
    6. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
    7. 새 정책의 액션 열에서 편집 설정을 클릭하여 정책 구성 페이지를 엽니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 경보 정책 탭을 구성합니다. 경보 정책 탭 구성을 참조하십시오.


ePolicy Orchestrator 4.0

이 사용자 인터페이스 콘솔을 사용하여 경보 정책을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 시스템 | 정책 카탈로그를 클릭한 다음 제품 목록에서 VirusScan Enterprise 8.8.0을 선택합니다. 범주 목록은 VirusScan Enterprise 8.8.0에 대한 정책 범주를 표시합니다.
  2. 기존 정책을 편집하거나 새 정책을 작성합니다. 기존 정책 편집
    1. 범주 목록에서 정책 범주를 선택합니다.
    2. 작업 열에서 편집을 클릭하여 정책 구성 페이지를 엽니다.
    새 정책 작성
    1. 새 정책을 클릭하여 새 정책 대화 상자를 엽니다.
    2. 이 기존 정책을 기반으로 정책 작성 목록에서 설정 중 하나를 선택합니다.
    3. 새 정책 이름을 입력합니다.
    4. 확인을 클릭합니다. 기존 정책 목록에 새 정책이 나타납니다.
  3. 설정 목록에서 워크스테이션 또는 서버를 선택합니다.
  4. 경보 정책 탭을 구성합니다. 경보 정책 탭 구성을 참조하십시오.


VirusScan 콘솔

이 사용자 인터페이스 콘솔을 사용하여 경보 속성을 구성합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 다음 속성 중 하나를 열어 경보를 구성합니다.
    • 경보 — 도구 | 경보를 사용하여 경보 속성 대화 상자를 엽니다.
    • 버퍼 오버플로우 방지 — 버퍼 오버플로우 방지 작업을 선택하고 속성을 마우스 오른쪽 단추로 클릭하여 버퍼 오버플로우 방지 속성 대화 상자를 엽니다.
    • 배달 시 전자 메일 스캐너 — 배달 시 전자 메일 스캐너 작업을 선택하고 속성을 마우스 오른쪽 단추로 클릭하여 배달 시 전자 메일 스캐너 속성 대화 상자를 엽니다. 경보 탭을 클릭합니다.
  2. 경보 정책 탭을 구성합니다. 경보 정책 탭 구성을 참조하십시오.


경보 정책 탭 구성

작업 Configuration(구성)
경보 정책

  1. 작업 열에서 설정 편집을 선택하여 경보 정책 페이지를 엽니다.

  2. 경고를 생성하는 구성 요소 및 Alert Manager 옵션을 구성합니다.

버퍼 오버플로 보호 정책

  1. 작업 열에서 설정 편집을 선택하여 버퍼 오버플로우 방지 페이지를 엽니다.

  2. 클라이언트 시스템 경고 옆에서 버퍼 오버플로우가 탐지되면 메시지 대화 상자 표시를 클릭합니다.

배달 시 전자 메일 검색 정책

  1. 작업 열에서 설정 편집을 선택하여 버퍼 배달 시 전자 메일 검색 속성 페이지를 엽니다.

  2. 경고를 클릭하고 사용자용 경고를 전자 메일로 보내기 및 액션 프롬프트 메시지를 구성합니다.


쿼리 및 대시보드 액세스

쿼리와 대시보드를 사용하면 작업을 모니터할 수 있으며 탐지 시 취할 액션을 결정하는 데 도움이 됩니다. 미리 정의된 쿼리와 대시보드를 사용하여 필요에 맞게 추가 대시보드와 쿼리를 생성할 수 있습니다. 쿼리 및 대시보드에 대한 자세한 내용은 ePolicy Orchestrator 제품 설명서를 참조하십시오.

쿼리

ePolicy Orchestrator 버전에 따라 다음을 사용하여 쿼리를 탐색합니다.

ePolicy Orchestrator 4.5 및 4.6
  1. 메뉴 | 보고 | 쿼리를 클릭하면 쿼리 페이지가 나타납니다.
  2. 쿼리 창에서 빠른 찾기에 VSE:를 입력하고 적용을 클릭합니다. VirusScan Enterprise 쿼리만 목록에 나타납니다.
ePolicy Orchestrator 4.0
  1. 보고 | 쿼리를 클릭하면 쿼리 페이지가 나타납니다.
  2. 쿼리 목록의 오른쪽 창에서 아래로 스크롤하여 "VSE:"로 시작하는 쿼리를 찾습니다.

다음과 같은 미리 정의된 쿼리를 사용할 수 있습니다.

VSE: 최근 30일간 준수

VSE: 검색된 위협을 갖는 주별 컴퓨터

VSE: 최신 DAT 채택

VSE: 최근 24시간 동안 DAT 채택

VSE: DAT 배포

VSE: 탐지 응답 요약

VSE: 태그별 검색 수

VSE: 지난 24시간 동안 탐지된 스파이웨어

VSE: 지난 7일 동안 탐지된 스파이웨어

VSE: 지난 24시간 동안 탐지된 위협 요약

VSE: 지난 7일 동안 탐지된 위협 요약

VSE: 심각도별 위협 개수

VSE: 주별 탐지된 위협 이름

VSE: 지난 24시간 동안 탐지된 위협

VSE: 지난 7일 동안 탐지된 위협

VSE: 지난 2분기 동안 탐지된 위협

VSE: 주별 탐지된 위협

VSE: 위반된 상위 10개 액세스 보호 규칙

VSE: 검색된 상위 10개 버퍼 오버플로

VSE: 탐지 수가 가장 많은 상위 10개의 컴퓨터

VSE: 탐지된 상위 10개 위협

VSE: 상위 10개 위협 출처

VSE: 위협 범주별 상위 10개 위협

VSE: 탐지 수가 가장 많은 상위 10개의 컴퓨터

VSE: 지난 24시간 동안 탐지된 원하지 않는 프로그램

VSE: 지난 7일 동안 탐지된 원하지 않는 프로그램

VSE: 버전 8.5 호환성

VSE: 버전 8.7 호환성

VSE: 버전 8.8 호환성

대시보드

ePolicy Orchestrator 콘솔의 대시보드에 액세스하려면 대시보드로 이동합니다.

다음과 같은 미리 정의된 대시보드를 사용할 수 있습니다.
  • VSE: 버전 8.8 호환성
  • VSE: 트렌딩 데이터
  • VSE: 현재 탐지


긴급 DAT 구성

긴급 DAT는 정상적인 VirusScan DAT 업데이트가 릴리스될 때까지 주요 바이러스로부터 시스템을 보호하기 위해 수동으로 다운로드할 수 있습니다.
참고: 이러한 EXTRA.DAT 파일은 클라이언트 시스템 자동 업데이트 또는 ePolicy Orchestrator 예약된 끌어오기 프로세스의 일부로 자동으로 다운로드해야 합니다. 탐지 정의 업데이트 절을 참조하십시오.
긴급 DAT 구성은 두 단계 프로세스입니다.
  1. 긴급 DAT 파일을 다운로드합니다. 이 프로세스는 클라이언트 시스템과 ePolicy Orchestrator 리포지토리에 대해 동일합니다.
  2. 긴급 DAT 파일을 설치합니다. 이 프로세스는 클라이언트 시스템 및 ePolicy Orchestrator 4.0, 4.5 및 4.6 서버에 대해 다릅니다.

이 절에서 이러한 각각의 프로세스를 설명합니다.

목차

관련 개념
긴급 DAT 정보
관련 작업
SuperDAT 파일 다운로드
ePolicy Orchestrator 리포지토리에 SuperDAT 파일 설치
클라이언트 시스템에 EXTRA.DAT 파일 설치
관련 정보
탐지 정의 업데이트


긴급 DAT 정보

EXTRA.DAT 파일이라고 하는 긴급 DAT에는 VirusScan Enterprise에서 새로운 바이러스를 탐지하는 데 사용하는 정보가 포함되어 있습니다. 새로운 악성 프로그램이 검색되고 추가 탐지가 필요한 경우 정상적인 VirusScan Enterprise DAT 업데이트가 릴리스될 때까지 SuperDAT(SDAT) 실행 파일에 패키징된 EXTRA.DAT 파일을 McAfee Labs가 사용할 수 있습니다.
참고: McAfee에서는 더 이상 보안 업데이트 다운로드 사이트에 개별 EXTRA.DAT 파일을 게시하지 않습니다. 특정 위협에 대한 EXTRA.DAT 파일을 가져오려면 https://www.webimmune.net/extra/getextra.aspx의 McAfee Avert Labs Extra.dat 요청 페이지로 이동하십시오.

SuperDAT 패키지

SuperDAT 실행 파일은 자동 설치 패키지입니다. 또한 새로운 바이러스 검색 엔진과 기타 프로그램 구성 요소를 포함할 수도 있습니다. 파일은 sdatXXXX.exe 형식의 이름을 사용합니다. 여기서 XXXX는 sdat4321.exe 같은 4자리 DAT 버전 번호입니다.

EXTRA.DAT 파일이 SuperDAT 실행 파일에서 추출되고 하드 드라이브에 있는 엔진 폴더에 추가되면 정상적인 DAT 파일 외에 새로운 바이러스를 탐지하기 위해 VirusScan Enterprise에서 사용합니다. 이를 통해 VirusScan Enterprise에서 악성 프로그램 탐지와 제거 정보를 포함하고 있는 공식적인 DAT 업데이트가 릴리스될 때까지 새로운 악성 프로그램 코드로부터 컴퓨터를 보호할 수 있습니다. 공식적인 DAT 업데이트가 릴리스되고 설치되면 EXTRA.DAT 파일이 더 이상 필요하지 않습니다.

참고: EXTRA.DAT 파일은 5일 동안 파일 시스템에 유지되었다가 자동으로 삭제됩니다. 공식적인 일일 업데이트를 자동으로 다운로드하고 설치함으로써 VirusScan Enterprise DAT 파일 업데이트를 유지해야 합니다.


SuperDAT 파일 다운로드

SuperDAT(SDAT) 파일을 다운로드하려면 McAfee 보안 업데이트 페이지에 연결해야 합니다.

시작하기 전에

  • McAfee 보안 업데이트 페이지에 액세스하려면 유효한 허가 번호가 있어야 합니다. http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  • McAfee 소프트웨어를 업데이트하려면 관리자 권한이 있어야 합니다.

작업

  1. 다음 URL에 있는 McAfee 보안 업데이트 페이지로 이동합니다. http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  2. SuperDATs 탭을 클릭하고 sdatXXXX.exe 파일을 두 번 클릭합니다. 여기서 XXXX는 최신 DAT 업데이트 번호입니다.
    참고: 자세한 내용을 보려면 readme.txt 파일을 두 번 클릭합니다.
  3. 기본 이름을 사용하여 실행 파일을 임시 위치에 저장합니다.


ePolicy Orchestrator 리포지토리에 SuperDAT 파일 설치

SuperDAT 파일을 다운로드한 후에 ePolicy Orchestrator 서버에 설치해야 합니다.

시작하기 전에

McAfee 소프트웨어를 업데이트하려면 관리자 권한이 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. SuperDAT 파일을 ePolicy Orchestrator 서버에 설치하려면 다음 중 하나를 사용하십시오.
    Server(서버) 단계...
    ePolicy Orchestrator 4.5 및 4.6
    1. 메뉴 | 소프트웨어 | 마스터 리포지토리를 클릭하여 ePolicy Orchestrator 4.5 및 4.6 콘솔에서 마스터 리포지토리의 패키지 페이지를 엽니다.
    2. 액션 | 패키지 체크인을 클릭합니다.
    ePolicy Orchestrator 4.0
    1. 소프트웨어 | 마스터 리포지토리를 클릭하여 마스터 리포지토리의 패키지 페이지를 엽니다.
    2. 패키지 체크인을 클릭하여 패키지 체크인 페이지를 엽니다.
  2. Super DAT(EXE)를 선택하고 파일을 저장하려는 위치를 탐색한 후 다음을 클릭합니다.
  3. 선택 내용을 확인한 다음 저장을 클릭합니다. 마스터 리포지토리의 패키지 페이지가 이름 목록에 새로운 DAT 패키지를 표시합니다.


클라이언트 시스템에 EXTRA.DAT 파일 설치

McAfee Labs에서 파일을 다운로드한 후에 독립 실행형 클라이언트 시스템에 EXTRA.DAT 파일을 설치할 수 있습니다. EXTRA.DAT 파일 다운로드 정보는 긴급 DAT 정보를 참조하십시오.

시작하기 전에

McAfee 보안 소프트웨어를 업데이트하려면 관리자 권한이 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 다운로드가 완료되면 방금 저장한 파일을 찾고 실행 파일을 실행하고 마법사의 지침을 따릅니다. 실행 파일 EXTRA.DAT 파일은 다음 단계를 수행합니다.
    • McAfee 메모리 상주 소프트웨어를 언로드하거나 최신 DAT 파일을 사용하는 서비스를 중지합니다.
    • 새로운 DAT 파일을 적절한 프로그램 디렉토리에 복사합니다.
    • 새로운 DAT 파일로 검색을 계속하는 데 필요한 소프트웨어 구성 요소를 다시 시작합니다.
  2. 설치 프로그램이 DAT 파일의 업데이트를 완료하면 다운로드한 파일을 삭제하거나 추가 업데이트에 사용할 사본을 유지합니다.


4부 - 보호 모니터, 분석 및 미세 조정

보호 전략을 처음 구성한 후에는 보호를 모니터하고 분석하고 미세 조정해야 합니다. 작업 로그 파일과 ePolicy Orchestrator 쿼리를 검사함으로써 VirusScan Enterprise 시스템의 성능과 보호를 개선할 수 있습니다.

목차

  • 사용자 환경에서 작업 모니터
  • 보호 분석


사용자 환경에서 작업 모니터

보호 전략의 중요한 단계는 사용자 시스템에서 발생하는 악성 프로그램 이벤트를 모니터하는 것입니다. 이를 위해 사용하는 도구와, 도구 사용 방법을 이해해야 합니다.


작업 모니터 도구

VirusScan Enterprise는 보호되는 시스템에서 발생하는 위협 이벤트를 모니터하는 다양한 방법을 제공합니다. 사용하는 도구는 ePolicy Orchestrator 콘솔 또는 VirusScan 콘솔 사용 여부에 따라 다릅니다.


쿼리 및 대시보드 사용

ePolicy Orchestrator 쿼리와 대시보드를 사용하면 McAfee 관리 시스템의 작업을 모니터할 수 있고 탐지 시 수행할 액션을 결정할 수 있습니다.

쿼리 및 대시보드에 대한 자세한 내용은 다음을 참조하십시오.
  • 미리 정의된 쿼리의 전체 목록은 쿼리 및 대시보드 액세스를 참조하십시오.
  • 쿼리 및 대시보드 수정 및 생성에 대한 자세한 내용은 ePolicy Orchestrator 제품 설명서를 참조하십시오.
관련 정보
쿼리 및 대시보드 액세스


작업 로그 사용

VirusScan 콘솔 작업 로그는 VirusScan Enterprise 보호 시스템에서 발생하는 이벤트의 기록을 저장합니다. 다음 표에서는 로그 파일에 대해 설명합니다.

모든 작업 로그 파일은 기본적으로 운영 체제에 따라 다음 위치 중 하나에 저장됩니다.
  • Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server 및 Microsoft 2008 Server의 경우 — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7의 경우 — C:\ProgramData\McAfee\DesktopProtection
표 1. 로그 파일
파일 이름 | 액세스 방법 | 표시 항목
AccessProtectionLog.txt | 작업 열에서 액세스 보호 | 보고서 탭을 클릭하고 로그 보기를 클릭합니다. | 날짜, 시간, 이벤트, 사용자 및 파일 이름.
BufferOverflowProtectionLog.txt | 작업 열에서 버퍼 오버플로 방지 | 보고서 탭을 클릭하고 로그 보기를 클릭합니다. | 날짜, 시간, 오버플로를 일으킨 실행 파일 및 스택 또는 힙 오버플로우였는지 여부.
MirrorLog.txt
  • Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server 및 Microsoft 2008 Server의 경우 — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7의 경우 — C:\ProgramData\McAfee\DesktopProtection
날짜, 시간, 미러 파일 경로 및 추가 정보.
OnAccessScanLog.txt | 작업 열에서 온액세스 스캐너 | 일반 설정 | 보고서 탭을 클릭하고 로그 보기를 클릭합니다. | 날짜, 시간, 탐지된 악성 프로그램, 취한 조치 및 발견한 내용.
OnDemandScanLog.txt | 메뉴에서 작업 | 로그 보기를 클릭합니다. | 날짜, 검색이 발생한 시간, 수행한 모든 조치, 대상 파일 및 발견한 내용.
UpdateLog.txt
  • Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server 및 Microsoft 2008 Server의 경우 — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Microsoft Windows 7의 경우 — C:\ProgramData\McAfee\DesktopProtection
날짜, 업데이트가 발생한 시간, 업데이트를 시작한 사람 및 업데이트에 대한 정보.


예제 쿼리 실행

간단한 쿼리를 실행하여 관리되는 시스템에서 주당 얼마나 많은 위협이 탐지되었는지 확인합니다. 이 쿼리는 단지 예제입니다. 실행하거나 구성하는 쿼리는 ePolicy Orchestrator 데이터베이스에서 검색하려는 정보에 따라 다릅니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 다음 중 하나를 사용하여 간단한 ePolicy Orchestrator 쿼리를 실행합니다.
    • ePolicy Orchestrator 4.5 또는 4.6 — 메뉴 | 보고 | 쿼리를 클릭하고 VSE: Threats Detected per Weeks 쿼리로 스크롤한 후 실행을 클릭합니다.
    • ePolicy Orchestrator 4.0 — 보고 | 쿼리를 클릭하고 VSE: Threats Detected per Weeks 쿼리로 스크롤한 후 실행을 클릭합니다.
  2. 위협이 탐지딘 경우 쿼리 출력은 다음을 표시합니다.
    • 위협 수와 발생한 주를 보여주는 막대 그래프
    • 비슷한 정보 및 총 위협 수를 보여주는 표
    참고: 막대 그래프나 표 정보를 클릭하여 ePolicy Orchestrator 데이터베이스 데이터를 열 수 있습니다.
  3. 닫기를 클릭하여 쿼리 목록으로 돌아갑니다.
실행할 수 있는 많은 기본 쿼리가 있으며 자체 쿼리를 만들 수도 있습니다. 자세한 내용은 ePolicy Orchestrator 설명서를 참조하십시오.


보호 분석

VirusScan Enterprise 보호 시스템의 보호 분석은 지속적인 프로세스여야 하며 시스템의 보호와 성능을 개선합니다.

목차

관련 개념
분석의 중요성
관련 작업
보호 분석 예제


분석의 중요성

보호를 분석하면 직면한 위협의 종류, 발생 위치, 위협 발생 빈도 및 대상으로 하는 시스템을 확인할 수 있습니다. 예를 들어, 한 시스템이 계속 공격을 받는 경우 해당 시스템을 네트워크의 보다 안전한 장소로 이동하고 보안을 강화시켜야 할 수 있습니다.

이 분석은 다음과 같은 경우에도 유용합니다.
  • IT 및 관리자를 위한 보고서 생성
  • 스크립트와 쿼리를 생성하는 데 사용되는 정보 캡처
  • 네트워크 액세스 시간 및 VirusScan Enterprise 업데이트 네트워크 사용 모니터


보호 분석 예제

대부분의 VirusScan Enterprise 보호 시나리오를 분석하기 위한 프레임워크로 이러한 분석 예제의 단계를 사용할 수 있습니다.

이러한 예제는 악성 프로그램 공격의 폭주를 확인하고 다음을 결정하는 방법을 설명합니다.
  • 공격이 발생한 위치 및 시기
  • 공격에 사용된 악성 프로그램
  • 공격이 시스템에 미치는 영향

작업

관련 작업
ePolicy Orchestrator 4.5 또는 4.6
ePolicy Orchestrator 4.0
VirusScan 콘솔


ePolicy Orchestrator 4.5 또는 4.6

이 예제 분석은 ePolicy Orchestrator 4.5 또는 4.6을 사용한 대부분의 VirusScan Enterprise 보호 시나리오를 분석하는 프레임워크로 사용됩니다.

시작하기 전에

이 예제 분석을 수행하려면 VirusScan Enterprise 보호 시스템에 직접 또는 원격으로 액세스할 수 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 공격이 발생한 위치와 시기를 확인합니다.
    1. 메뉴 | 보고 | 쿼리를 클릭하여 쿼리 창을 엽니다.
    2. 빠른 찾기 검색에 Malware를 입력하고 적용을 클릭합니다. 악성 프로그램 탐지 내역 쿼리가 쿼리 목록에 나타납니다.
    3. 쿼리를 선택하고 액션 | 실행을 클릭합니다. 이 쿼리는 최근 공격 수를 반환합니다.
  2. 공격에 사용된 악성 프로그램을 확인하려면 메뉴 | 보고 | 위협 이벤트 로그를 클릭하여 위협 이벤트 로그를 표시합니다.
  3. 로그 이벤트를 두 번 클릭하여 창에 세부 정보 페이지를 표시합니다. 로그 이벤트에서 다음 사항을 확인할 수 있습니다.
    • 위협 소스 IP 주소 및 대상이 표시되어 취할 액션을 결정하는 데 도움을 줍니다.
    • 위협 이름 및 위협 유형은 공격에 사용된 악성 프로그램을 설명합니다.
    • 위협 이벤트 설명은 시스템을 공격한 방식과 위협에 대해 취한 액션을 설명합니다.


ePolicy Orchestrator 4.0

이 예제 분석은 ePolicy Orchestrator 4.0을 사용한 대부분의 VirusScan Enterprise 보호 시나리오를 분석하는 프레임워크로 사용됩니다.

시작하기 전에

이 예제 분석을 수행하려면 VirusScan Enterprise 보호 시스템에 직접 또는 원격으로 액세스할 수 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. 공격이 발생한 위치와 시기를 확인합니다.
    1. 보고 | 쿼리를 클릭하여 쿼리 목록을 엽니다.
    2. 공개 쿼리 목록에서 ePO: 악성 프로그램 탐지 내역을 클릭하고 추가 액션 | 실행을 클릭합니다. 악성 프로그램 탐지 내역 쿼리가 쿼리 목록에 나타납니다.
  2. 악성 프로그램 탐지를 트리거한 이벤트를 보려면 보고 | 이벤트 로그를 클릭합니다. 그러면 이 쿼리가 최근 공격 숫자를 반환합니다.
  3. 로그 이벤트를 두 번 클릭하여 창에 세부 정보 페이지를 표시합니다. 로그 이벤트에서 다음 사항을 확인할 수 있습니다.
    • 위협 소스 IP 주소 및 대상이 표시되어 취할 액션을 결정하는 데 도움을 줍니다.
    • 위협 이름 및 위협 유형은 공격에 사용된 악성 프로그램을 설명합니다.
    • 위협 이벤트 설명은 시스템을 공격한 방식과 위협에 대해 취한 액션을 설명합니다.


VirusScan 콘솔

이 예제 분석은 VirusScan 콘솔을 사용한 대부분의 VirusScan Enterprise 보호 시나리오를 분석하는 프레임워크로 사용됩니다.

시작하기 전에

이 예제 분석을 수행하려면 VirusScan Enterprise 보호 시스템에 직접 또는 원격으로 액세스할 수 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭하고 목록에서 통계를 선택합니다. 온액세스 검색 통계 대화 상자가 나타납니다.
  2. 검색 통계 그룹에서 나타나는 탐지된 파일 수를 기록합니다. 0 이외의 숫자가 있는 경우 속성을 클릭하여 온액세스 검색 속성 대화 상자를 엽니다.
  3. 보고서 탭을 클릭하고 로그 보기를 클릭합니다. OnAccessScanLog.txt 파일이 메모장 창에 나타납니다.
  4. 이 출력에서 다음 사항을 확인할 수 있습니다.
    • 공격에 사용된 악성 프로그램 예:
      C:\...\eicar.com	EICAR 테스트 파일
    • 공격이 시스템에 미치는 영향 예:
      (탐지를 치료할 수 없어 치료 실패)
    • 위협에 대해 취한 액션 예:
      삭제됨
  5. 이전 단계의 정보를 사용하여 소스 또는 대상 시스템이 수정된 바이러스 방지 설정을 필요로 하는지 또는 다른 액션을 취할 것인지 결정합니다.


부록

VirusScan Enterprise에서 제공하는 보호를 개선하는 데 사용할 수 있는 추가 구성 및 문제 해결 기능이 있습니다. 이러한 기능은 ePolicy Orchestrator 콘솔, 명령줄 및 인터넷 같은 익숙한 도구를 사용합니다.

목차

  • ePolicy Orchestrator 서버 작업 구성
  • VirusScan Enterprise에서 명령줄 사용
  • 원격 시스템에 연결
  • 분석을 위해 위협 샘플 제출
  • McAfee Labs 위협 라이브러리 액세스
  • 문제 해결


ePolicy Orchestrator 서버 작업 구성

ePolicy Orchestrator에서 구성한 서버 작업을 사용하면 자동 작업을 예약하고 실행하여 서버와 VirusScan Enterprise 소프트웨어를 관리할 수 있습니다.

다음을 자동으로 생성하도록 VirusScan Enterprise 서버 작업을 구성할 수 있습니다.
  • 정책 내보내기 — 정책 보고서를 실행하고 파일에 정책 정보를 저장합니다.
  • 쿼리 실행 — 미리 구성된 쿼리를 실행하고 구성된 경우 ePolicy Orchestrator 대시보드에 출력을 표시합니다.
  • 쿼리 내보내기 — 미리 구성된 쿼리를 실행하고 구성된 주소로 보고서를 전자 메일을 보내거나 구성된 위치로 보고서를 내보냅니다.
    참고: 쿼리 내보내기 기능은 ePolicy Orchestrator 4.5 및 4.6를 사용할 경우에만 사용할 수 있습니다.
ePolicy Orchestrator 서버에는 다음 VirusScan Enterprise 서버 작업이 이미 설치되어 있습니다.
  • VSE: 최근 30 일간 준수— McAfee 안티바이러스 소프트웨어 준수 상태를 저장하는 쿼리를 하루에 한 번 실행합니다.
  • VSE: 최근 24시간 동안 DAT 적용 — McAfee 안티바이러스 소프트웨어 DAT 버전 상태를 저장하는 쿼리를 매시간 실행합니다.
참고: 사용자 지정 서버 작업을 구성하려면 자세한 내용은 해당 ePolicy Orchestrator 제품 안내서를 참조하십시오.


예제 서버 작업 구성

기존 ePolicy Orchestrator VSE를 활성화하고 구성하려면: 최근 30일간 서버 작업 준수

시작하기 전에

ePolicy Orchestrator 구성을 업데이트하려면 관리자 권한이 있어야 합니다.

작업

옵션 정의를 보려면 인터페이스에서 ?를 클릭하십시오.

  1. ePolicy Orchestrator에서 기존 서버 작업 페이지를 엽니다.
    • ePolicy Orchestrator 4.5 또는 4.6 — 메뉴 | 자동화 | 서버 작업을 클릭합니다.
    • ePolicy Orchestrator 4.0 — 자동화 | 서버 작업을 클릭합니다.
  2. 이름 열에서 VSE: 최근 30일간 준수 작업을 찾아 액션 열에서 편집을 클릭합니다. [서버 작업 작성기] 페이지가 나타납니다.
  3. 예약 상태 옆에서 사용을 클릭한 후 다음을 클릭합니다. 그러면 액션 페이지가 나타납니다. 1. 액션 옆에서 기본적으로 쿼리 실행이 선택됩니다.
  4. 쿼리 옆에서 VSE: 버전 8.8.0 준수가 기본적으로 선택되어 있습니다. 필요한 경우 언어 설정을 변경합니다. 하위 액션 그룹에서 다음 항목이 기본적으로 선택되어 있는지 확인합니다.
    • 하위 액션 목록의 호환성 이벤트 생성.
    • 대상 시스템의 특정 수가 텍스트 상자에서 1로 선택됩니다.
  5. VirusScan Enterprise, 버전 8.7 및 8.5 준수 액션을 서버 작업에 추가합니다.
    1. 1. 액션 행에서 더하기(+)를 클릭하여 추가 액션 행을 엽니다.
    2. 새로운 2. 액션 행에서 다음을 구성합니다.
      • 2. 액션 다음의 목록에서 쿼리 실행을 선택합니다.
      • 쿼리 옆의 목록에서 VSE: 버전 8.7 준수를 선택합니다.
      • 필요한 경우 언어 설정을 변경합니다.
      • 하위 액션 그룹에서 호환성 이벤트 생성 및 대상 시스템의 특정 수가 텍스트 상자에서 1로 선택되었는지 확인합니다.
    3. 2. 액션 행에서 더하기(+)를 클릭하여 추가 액션 행을 엽니다.
    4. 새로운 3. 액션 행에서 다음을 구성합니다.
      • 3. 액션 다음의 목록에서 쿼리 실행을 선택합니다.
      • 쿼리 옆의 목록에서 VSE: 버전 8.5 준수를 선택합니다.
      • 필요한 경우 언어 설정을 변경합니다.
      • 하위 액션 그룹에서 호환성 이벤트 생성 및 대상 시스템의 특정 수가 텍스트 상자에서 1로 선택되었는지 확인합니다.
  6. 다음을 클릭하여 예약 페이지를 엽니다.
  7. 예약 유형 목록에서 서버 작업을 실행할 빈도를 선택합니다.
    • 시작 날짜를 설정하거나 현재 날짜를 기본값으로 사용합니다.
    • 종료 날짜를 설정하거나 종료 날짜 없음을 기본값으로 사용합니다.
    • 예약을 설정하거나 기본값을 사용하거나 쿼리를 실행할 다른 시작 시간을 설정합니다.
  8. 다음을 클릭하여 요약 페이지를 엽니다. 구성된 정보가 올바른지 확인합니다.
  9. 저장을 클릭하면 서버 작업 페이지가 다시 나타납니다.
  10. VSE: 최근 30일간 준수 서버 작업 상태가 활성화되어 있고 다음 실행 날짜와 시간 설정이 올바른지 확인합니다.


VirusScan Enterprise에서 명령줄 사용

명령 프롬프트를 사용하여 몇몇 기본 VirusScan Enterprise 프로세스를 실행할 수 있습니다. 명령줄에서 VirusScan Enterprise를 설치, 구성 및 업데이트할 수 있습니다. 명령줄 설치 옵션은 VirusScan Enterprise 설치 안내서에서 설명합니다.

명령줄 검색 예제

모든 파일을 검색하고, 검색 결과로 로그 파일을 업데이트하고, 완료되면 주문형 검색 대화 상자를 자동으로 닫으려면 다음 명령을 입력합니다.

scan32 /all /log /autoexit

명령줄 업데이트 예제

DAT 파일, 검색 엔진 및 제품을 자동으로 업데이트하거나 업데이트하는 동안 McAfee 업데이트 대화 상자를 표시하지 않으려면 다음 명령을 입력합니다.

mcupdate /update /quiet


주문형 검색 명령줄 옵션

VirusScan Enterprise에서는 주문형 스캐너 SCAN32.EXE를 사용하여 위협을 탐지합니다. 명령줄에서 또는 배치 파일의 일부로 동일한 실행 파일 명령 SCAN32을 사용하여 검색을 실행할 수 있습니다.

SCAN32 구문에는 속성과 해당 값을 분리할 수 없다는 점 외에 해당 요소의 특정 순서는 필요하지 않습니다. 이 구문은 다음과 같이 구성됩니다.
  • 파일 이름 - 실행 파일의 이름입니다. SCAN32.EXE.
  • 옵션 - 옵션은 슬래시(/) 문자로 시작하며 대/소문자를 구분하지 않습니다.
명령 형식:

SCAN32 PROPERTY=VALUE [,VALUE] [/option].

다음은 scan32.exe 명령 예제입니다.

scan32.exe PRIORITY /normal

이 예에서 다음 작업이 수행됩니다.
  • "PRIORITY"는 명령 값입니다.
  • "/normal"은 값 옵션입니다.

주문형 검색 값 및 옵션

명령줄 옵션 옵션이 있는 정의

모두

대상 폴더의 모든 파일을 검색합니다.

ALLOLE

기본 파일과 모든 Microsoft Office 문서를 검색합니다.

ALWAYSEXIT

검색이 오류/실패로 끝난 경우에도 주문형 검색을 강제 종료합니다.

APPLYNVP

원하지 않는 프로그램 정책에 정의된 잠재적으로 원하지 않는 프로그램을 검색합니다.

ARCHIVE

.ZIP, .CAP, .LZH 및 .UUE 파일 같은 압축 파일을 검색합니다.

AUTOEXIT

비대화형 검색 완료 시 주문형 스캐너를 종료합니다.

CLEAN

잠재적으로 원하지 않는 프로그램 발견 시 검색된 대상 파일을 치료합니다.

CLEANA

원하지 않는 프로그램 탐지 시 탐지된 파일을 치료합니다.

CONTINUE

잠재적으로 원하지 않는 프로그램을 탐지한 이후 검색을 계속합니다.

CONTINUE2

잠재적으로 원하지 않는 프로그램을 탐지하고 기본 액션이 실패한 이후 검색을 계속합니다.

CONTINUEA

원하지 않는 프로그램을 탐지한 이후 검색을 계속합니다.

CONTINUEA2

원하지 않는 프로그램을 탐지하고 기본 액션이 실패한 이후 검색을 계속합니다.

DEFEXT

매개 변수로서 지정하는 파일 확장명을 검색에 포함된 선택한 파일 형식의 목록에 추가합니다.

DELETE

잠재적으로 원하지 않는 프로그램 탐지 시 탐지된 파일을 삭제합니다.

DELETE2

잠재적으로 원하지 않는 프로그램이 탐지되고 기본 액션이 실패했을 때 탐지된 파일을 삭제합니다.

DELETEA

원하지 않는 프로그램 탐지 시 파일을 삭제합니다.

DELETEA2

잠재적으로 원하지 않는 프로그램이 탐지되고 기본 액션이 실패했을 때 파일을 삭제합니다.

EDIT

검색 등록 정보 대화 상자를 표시합니다.

EXT

검색에 포함된 선택한 파일 형식의 목록에서의 확장명을 이 인수 다음의 매개 변수로서 추가한 파일 확장명으로 바꿉니다.

LOG

미리 지정한 로그 파일에 탐지 보고서를 기록합니다.

LOGFORMAT <value>

로그 파일에 대해 지정된 형식을 사용합니다. 유효한 값은 ANSI, UTF8 또는 UTF16입니다.

LOGSETTINGS

검색의 구성 설정을 기록합니다.

LOGSUMMARY

검색 결과의 요약을 기록합니다.

LOGUSER

검색을 실행하는 사용자에 대한 식별 정보를 기록합니다.

MHEUR

매크로 위협의 Artemis 탐지를 사용합니다.

MIME

mime(Multipurpose Internet Mail Extensions) 인코딩된 파일에서 잠재적으로 원하지 않는 프로그램을 탐지합니다.

NOESTIMATE

파일 검색을 시작하기 전에 검색 크기를 계산하지 않습니다. 진행률 표시줄이 표시되지 않습니다.

PHEUR

비매크로 위협의 Artemis 탐지를 사용합니다.

PRIORITY

다른 CPU 프로세스와의 상대적인 검색 우선 순위를 설정합니다. 다음 옵션 중 하나가 필요합니다.
  • LOW(낮음)
  • BELOWNORMAL — ePolicy Orchestrator 기본값.
  • NORMAL — VirusScan 콘솔 기본값.
참고: 1~100의 숫자 매개 변수를 입력할 수 있습니다. 여기서 10은 LOW, 50은 BELOWNORMAL, 100은 NORMAL입니다.

PROMPT

잠재적으로 원하지 않는 프로그램 탐지 시 사용자의 액션을 요구합니다.

PROMPT2

잠재적으로 원하지 않는 프로그램이 탐지되고 기본 액션이 실패했을 때 사용자의 액션을 요구합니다.

PROMPTA

원하지 않는 프로그램 탐지 시 사용자의 액션을 요구합니다.

PROMPTA2

원하지 않는 프로그램이 탐지되고 기본 액션이 실패했을 때 사용자의 액션을 요구합니다.

RPTSIZE

알림 로그의 크기를 MB 단위로 설정합니다.

START

검색을 실행합니다. 등록 정보 대화 상자를 표시하지 않습니다.

TASK

VirusScan 콘솔에 지정된 주문형 스캐너 작업을 시작합니다. 다음 위치의 레지스트리에 기록된 대로 지정된 작업 ID를 지정하는 추가적인 매개변수가 필요합니다. hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.

UINONE

사용자 인터페이스 대화 상자를 표시하지 않고 스캐너를 시작합니다.


업데이트 작업 명령줄 옵션

VirusScan Enterprise는 MCUPDATE.EXE를 사용하여 업데이트 작업을 수행합니다. 명령줄에서 또는 배치 파일의 일부로 동일한 실행 파일 명령 MCUPDATE를 사용하여 업데이트 작업을 실행할 수 있습니다,

MCUPDATE 구문에는 속성과 해당 값을 분리할 수 없다는 점 외에 해당 요소의 특정한 순서는 필요하지 않습니다. 이 구문은 다음으로 구성됩니다.
  • 파일 이름 - 실행 파일의 이름입니다. MCUPDATE.EXE.
  • 옵션 - 옵션은 슬래시(/) 문자로 시작하며 대/소문자를 구분하지 않습니다.
명령 형식:
MCUPDATE [/<type> [/TASK <guid>]] [/option].
참고: 이전 형식에서 <type>은 ROLLBACKDATS 또는 UPDATE가 될 수 있습니다.

/TASK 절은 선택 사항입니다. 그러나 사용할 경우 업데이트 작업 ID(guid)도 지정해야 합니다. 선택한 작업 ID는 업데이트 또는 롤백 DAT 작업용이어야 합니다. 검색 ID를 선택하지 마십시오. 작업 ID를 지정하지 않으면 기본 업데이트 작업이 사용됩니다. 작업 ID는 다음 위치에 있습니다. hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

/option 절은 필수가 아닙니다. 자동 업데이트 작업을 수행하려면 /QUIET를 사용합니다.
참고: /QUIET 옵션은 롤백 DAT 작업에서 사용할 수 없습니다. 이 예에서는 자동 업데이트 작업을 수행합니다. MCUPDATE /UPDATE /QUIET.

업데이트 작업 옵션

명령줄 옵션 | 정의
ROLLBACKDATS | 현재 DAT 파일을 마지막으로 백업한 버전으로 롤백합니다.
UPDATE | DAT 파일, 검색 엔진, 제품 또는 extra.dat를 업데이트합니다.
/TASK | VirusScan 콘솔에 지정되어 있는 자동 업데이트 또는 롤백 DAT 작업을 시작합니다. 다음의 레지스트리 키에 기록된 대로 작업 ID를 지정하려면 추가 매개 변수가 필요합니다. hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | 작업을 자동 모드로 수행합니다.


원격 시스템에 연결

VirusScan Enterprise가 설치된 원격 시스템에 연결하여 검색 또는 업데이트 작업을 수정 또는 예약하거나, 원격 시스템에서 온액세스 스캐너를 활성화하거나 비활성화하는 등의 작업을 수행할 수 있습니다.
참고: 원격 시스템에 연결할 수 있는 관리자 권한이 없을 경우 불충분한 사용자 권한, 액세스 거부됨 등의 오류 메시지가 표시됩니다.

VirusScan 원격 콘솔을 시작하면, 연결되어 있는 시스템의 이름이 콘솔 제목 표시줄에 나타납니다. 네트워크상의 다른 시스템에 연결되어 있지 않으면 제목 표시줄에 로컬 시스템 이름이 표시되지 않습니다. 원격 콘솔에서 작업의 속성 대화 상자를 열면 시스템 이름이 속성 대화 상자 제목 표시줄에 표시됩니다.

원격 콘솔은 여러 개를 열 수 있습니다. 원격 컴퓨터에 연결 대화 상자를 닫으면 원격 시스템에 대한 연결도 닫힙니다.


VirusScan Enterprise가 설치된 원격 시스템에 액세스

VirusScan Enterprise가 설치된, 원하는 원격 시스템에 연결하여 관리하려면 VirusScan 콘솔에서 원격 콘솔 열기를 사용합니다.

작업

옵션 정의를 보려면 인터페이스에서 도움말을 클릭합니다.

  1. VirusScan Enterprise 8.8 콘솔의 도구 메뉴에서 원격 콘솔 열기를 선택합니다.
  2. 컴퓨터에 연결에서, 관리하려는 시스템 이름을 입력하고 목록에서 시스템을 선택하거나 찾아보기를 클릭하여 네트워크에서 시스템을 찾습니다.
    참고: 원격 작업을 위한 파일이나 폴더의 경로 이름을 구성하는 동안 환경 변수가 사용되는 경우 환경 변수가 원격 시스템에 있는지 확인하십시오. VirusScan Enterprise 8.8 콘솔은 원격 시스템에서 환경 변수를 확인할 수 없습니다.
  3. 확인을 클릭하여 대상 시스템에 연결을 시도합니다. 원격 시스템에 연결할 때:
    • 제목 표시줄이 해당 시스템 이름을 표시하도록 변경됩니다.
    • 콘솔은 원격 시스템의 레지스트리를 읽고 원격 시스템의 작업을 표시합니다.
    • 원격 시스템의 작업을 추가, 삭제하거나 다시 구성할 수 있습니다.


분석을 위해 위협 샘플 제출

탐지되지 않은 잠재적 위협이 발견되거나 최신 DAT 파일을 사용하여 스캐너가 위협으로 탐지해서는 안 된다고 생각하는 것을 탐지하는 경우 위협의 샘플을 WebImmune을 통해 McAfee Labs에 제출할 수 있습니다. McAfee Labs는 샘플을 분석하고 다음 DAT 파일에 포함할 것인지 또는 제외할 것인지 고려합니다.

웹 사이트 WebImmune 액세스, 전자 메일 또는 일반 우편의 3가지 방식으로 McAfee Labs에 샘플을 제출할 수 있습니다.

WebImmune

  1. VirusScan 콘솔에서 도움말 | 샘플 제출을 선택하여 웹 사이트에 액세스합니다. 웹 사이트 위치는 다음과 같습니다. https://www.webimmune.net/default.asp.
  2. 무료 계정에 로그온하거나 새 계정을 만듭니다.
  3. 검토를 위해 McAfee Labs 자동 시스템에 파일을 직접 업로드합니다. 추가 연구가 필요한 항목인 경우 McAfee Labs 분석가가 담당합니다.

전자 메일

검토를 위해 McAfee Labs의 자동 시스템에 전자 메일을 직접 보냅니다. 추가 연구가 필요한 항목인 경우 McAfee Labs 분석가가 담당합니다.

글로벌 전자 메일 주소는 virus_research@avertlabs.com입니다.
참고: WebImmune 웹 사이트에서 추가로 지역 주소를 가져옵니다.

우편

WebImmune 웹 사이트에서 주소를 가져옵니다.
참고: 이 방법은 권장하지 않는 방법이며 샘플을 검토하는 데 가장 오랜 시간이 걸립니다.


McAfee Labs 위협 라이브러리 액세스

VirusScan Enterprise 8.8 콘솔에서 McAfee Labs 위협 라이브러리에 액세스하려면 도움말 메뉴에서 McAfee Labs 위협 라이브러리를 선택합니다. 인터넷 브라우저가 http://vil.nai.com/vil/default.aspx에 연결된 상태로 열립니다.


문제 해결

McAfee 기술 지원에 전화하기 전에 이 섹션의 정보를 읽어주십시오. 여기에는 VirusScan Enterprise 구성 문제를 해결하는 데 사용할 수 있는 프로세스와 도구 및 자주 묻는 질문이 포함되어 있습니다.


제품 설치 복구

VirusScan Enterprise의 설치를 복구하여 기본 설정을 복원하거나 프로그램 파일을 다시 설치하거나 두 단계를 모두 수행해야 하는 경우가 있을 수 있습니다. 이 작업은 VirusScan 콘솔 또는 명령줄에서 수행할 수 있습니다.

VirusScan 콘솔 사용

설치 복구 유틸리티를 사용하여 VirusScan Enterprise 8.8 콘솔에서 도움말 | 설치 복구를 선택합니다.
참고: 이 기능은 ePolicy Orchestrator 콘솔에서는 사용할 수 없습니다.
옵션 | 정의
모든 설정을 설치 기본값으로 복원 | VirusScan Enterprise 기본 설치 설정을 복원합니다. 주의: 사용자 지정된 설정은 손실될 수 있습니다.
모든 프로그램 파일 재설치 | VirusScan Enterprise 프로그램 파일을 다시 설치합니다. 주의: 핫픽스, 패치 및 서비스 팩을 덮어쓸 수 있습니다.

명령줄에서 SETUPVSE.exe 사용

SETUPVSE.exe 명령을 사용하여 명령줄에서 VirusScan Enterprise를 복구하거나 다시 설치하려면 다음 명령을 사용합니다.
참고: REINSTALLMODE 명령줄 매개 변수 옵션의 경우 http://msdn.microsoft.com/en-us/library/aa371182(VS.85).aspx에서 REINSTALLMODE 속성을 참조하십시오.
설명 | 명령
프로그램 파일만 설치 | SETUPVSE.exe REINSTALLMODE=sec /q
레지스트리 파일만 설치 | SETUPVSE.exe REINSTALLMODE=secum /q
프로그램 파일 및 레지스트리 파일 모두 설치 | SETUPVSE.exe REINSTALLMODE=amus /q

명령줄에서 msiexec.exe 사용

msiexec.exe 명령을 사용하여 명령줄에서 VirusScan Enterprise를 복구하거나 다시 설치하려면 다음 명령을 사용합니다.
참고: msiexec.exe 명령줄 옵션의 경우 http://support.microsoft.com/kb/314881에서 Microsoft Windows Installer Tool Msiexec.exe의 명령줄 옵션을 참조하십시오.
설명 | 명령
프로그램 파일만 설치 | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=sa /q REBOOT=R
레지스트리 파일만 설치 | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=mu /q REBOOT=R
프로그램 파일 및 레지스트리 파일 모두 설치 | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=samu /q REBOOT=R


온액세스 작업 로그 파일 보기

VirusScan 콘솔 온액세스 작업 로그 파일은 업데이트 내역, 위협 활동 및 VirusScan Enterprise의 대응 방법을 보여줍니다. 이 정보는 자동 업데이트 작업과 정책 구성 문제를 해결하는 데 유용할 수 있습니다.

다음 프로세스 중 하나를 사용하여 온액세스 작업 로그 파일에 액세스하십시오.
참고: 온액세스 작업 로그 파일 생성을 활성화해야 합니다. 온액세스 작업 로그 파일을 활성화하려면 일반 설정 구성을 참조하십시오.

작업

옵션 정의를 보려면 각 탭에서 도움말을 클릭합니다.
  1. 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭하여 대화 상자를 엽니다.
  2. 온액세스 스캐너 속성 대화 상자에서 보고서 탭을 클릭하고 로그 보기를 클릭합니다. OnAccessScanLog.txt 파일이 메모장 창에 나타납니다. 다음은 로그 파일 출력의 예입니다.

  3. 다음 표는 이전 OnAccessScanLog.txt 예의 데이터를 설명합니다.
    로그 항목 예 | 설명
    4/27/2010 | 날짜
    13:35:47AM | 시간
    치료됨/삭제됨/취한 액션 없음 | 취한 액션
    업데이트된 파일 = 버전 또는 (치료 실패 이유 | 액션 설명
    SRVR\user | 자격 증명
    C:\WINDOWS\system32\NOTEPAD.EXE C:\temp\eicar.com | 위협 파일의 경로와 이름
    EICAR 테스트 파일(테스트) | 파일에 대한 설명

비슷한 정보를 ePolicy Orchestrator 쿼리를 통해 사용할 수 있습니다. 자세한 내용은 쿼리 및 대시보드 액세스를 참조하십시오.

관련 작업
일반 설정 구성
관련 정보
쿼리 및 대시보드 액세스


문제 해결 중 MER 도구 사용

Minimum Escalation Requirements Tool은 McAfee VirusScan Enterprise 및 기타 McAfee 제품, 컴퓨터 데이터를 수집합니다. 이 데이터를 사용하여 McAfee 기술 지원은 문제를 분석하고 해결할 수 있습니다.

WebMER 도구는 다음 파일 형식을 사용하여 다운로드할 수 있습니다.
  • EXE
  • ZIP
  • ProtectedZip
WebMER 도구에서 수집하는 정보는 다음과 같습니다.
  • 레지스트리 세부 정보
  • 파일 버전 세부 정보
  • Files
  • 이벤트 로그
  • 프로세스 세부 정보
WebMER 도구를 사용하려면 다음을 수행해야 합니다.
  • https://kc.mcafee.com/corporate/index?page=content&id=TU30146에서 McAfee WebMER를 사용하여 Minimum Escalation Requirement Tools 가져오기 자습서를 봅니다..
  • http://mer.mcafee.com에서 도구를 다운로드하고 설치합니다..
    참고: ePolicy Orchestrator 배포 가능한 버전도 사용할 수 있습니다. 이 버전의 경우 McAfee 제품 문제 진단 시 로그와 정보를 수집하기 위해 ePolicy Orchestrator 콘솔을 사용하여 클라이언트 컴퓨터에서 MER을 실행합니다. http://mer.mcafee.com/enduser/downloadepomer.aspx에서 McAfee MER for ePolicy Orchestrator 4.x (v2.0)를 다운로드합니다..
  • 도구를 실행하고 출력을 다시 McAfee 기술 지원에 보냅니다.


문제 해결 중 VirusScan Enterprise 비활성화

프로세스 VirusScan Enterprise 실행과 관련이 있는 시스템 문제가 발생하는 경우 시스템 문제가 제거될 때까지 VirusScan Enterprise 기능을 체계적으로 비활성화할 수 있습니다. 또는 최소한 문제의 원인으로 VirusScan Enterprise를 제거할 수 있습니다.
주의:
문제를 해결한 후 완벽한 멀웨어 보호를 위해서는 VirusScan Enterprise를 구성하거나 복원해야 합니다.
VirusScan Enterprise 기능을 체계적으로 비활성화하는 단계는 다음 8단계 프로세스로 구분됩니다.
  1. 버퍼 오버플로우 보호 비활성화
  2. 액세스 보호 비활성화
  3. ScriptScan 비활성화
  4. 온액세스 검색 비활성화
  5. 온액세스 검색을 비활성화한 다음 다시 부팅
  6. MFEVTP가 로드되지 않도록 한 다음 다시 부팅
  7. mfehidk.sys의 이름을 변경한 다음 다시 부팅
  8. 제품을 제거한 다음 다시 부팅

여덟 단계 각각에 대해서는 다음 절에서 설명합니다. VirusScan 콘솔의 옵션 정의를 보려면 인터페이스에서 도움말을 클릭하십시오.

버퍼 오버플로우 보호 비활성화

버퍼 오버플로우 보호를 비활성화하려면 다음 단계를 따르십시오.
  1. VirusScan 콘솔 작업 목록에서 버퍼 오버플로우 방지를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.
  2. 속성 대화 상자에서 버퍼 오버플로우 방지 사용을 선택 취소하고 확인을 클릭합니다.
  3. 버퍼 오버폴로 방지를 비활성화하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 이 기능과 관련이 없을 수도 있습니다.

액세스 보호 비활성화

액세스 보호를 비활성화하려면 다음 단계를 따르십시오.
  1. VirusScan 콘솔 작업 목록에서 액세스 보호를 두 번 클릭하여 액세스 보호 등록 정보 대화 상자를 엽니다.
  2. 액세스 보호 탭을 클릭하고 액세스 보호 사용을 선택 취소한 다음 확인을 클릭합니다.
  3. 액세스 보호를 비활성화하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 VirusScan Enterprise과 관련이 없을 수도 있습니다.

ScriptScan 비활성화

ScriptScan을 비활성화하려면 다음 단계를 따르십시오.
  1. VirusScan 콘솔 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭하여 온액세스 검색 등록 정보 대화 상자를 엽니다.
  2. ScriptScan 탭을 클릭하고 스크립트 검색 활성화를 선택 취소하고 확인을 클릭합니다.
  3. ScriptScan을 비활성화하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 VirusScan Enterprise과 관련이 없을 수도 있습니다.

온 액세스 검사 비활성화

온액세스 검색을 비활성화하려면 다음 단계를 따르십시오.
  1. 액세스 보호 비활성화. 작업 목록의 VirusScan 콘솔에서 액세스 보호를 마우스 오른쪽 단추로 클릭하고 비활성화를 선택합니다.
  2. 다음을 사용하여 McShield 서비스 애플릿 시작 유형을 사용 안 함으로 변경합니다.
    • 시작 | 제어판 | 관리 도구 | 서비스를 클릭하여 서비스 애플릿을 엽니다.
    • 서비스(로컬)에서 McAfee McShield로 스크롤하고 이름을 마우스 오른쪽 단추로 클릭하여 McAfee McShield 속성 대화 상자를 엽니다.
    • 일반 탭을 클릭하고 시작 유형 목록에서 사용 안 함을 클릭하고 확인을 클릭합니다.
  3. VirusScan 콘솔 작업 목록에서 온액세스 스캐너를 마우스 오른쪽 단추로 클릭하고 나타나는 목록에서 사용 안 함을 클릭합니다. 기능이 비활성화되었음을 나타내는 슬래시가 있는 원을 포함하도록 온액세스 스캐너 아이콘이 변경되어야 합니다.
  4. 온액세스 검색을 비활성화하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 이 기능과 관련이 없을 수도 있습니다.

온액세스 검색을 비활성화한 다음 다시 부팅

온액세스 검색을 비활성화한 다음 다시 부팅하려면 다음 단계를 따르십시오.
참고: 다음 프로세스에서는 이전 섹션을 비활성화한 후에 온액세스 검색을 다시 활성화하지 않았다고 가정합니다.

  1. 완전 종료를 수행하고 시스템을 다시 부팅합니다.
  2. 온액세스 검색을 비활성화한 다음 다시 부팅하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 이 기능과 관련이 없을 수도 있습니다.

MFEVTP가 로드되지 않도록 한 다음 다시 부팅

McAfee MFEVTP(Validation Trust Protection 서비스)가 로드되지 않도록 하고 시스템을 다시 부팅하려면 다음 단계를 따르십시오.
주의:
이 절에는 레지스트리 열기나 수정에 대한 정보가 포함되어 있습니다.
  • 다음 정보는 시스템 관리자를 위한 것입니다. 레지스트리 수정은 되돌릴 수 없으며 올바르지 않게 수행한 경우 시스템 오류가 발생할 수 있습니다.
  • 계속하기 전에 McAfee는 레지스트리를 백업하고 복원 프로세스를 이해하는 것이 좋습니다. 자세한 내용은 다음을 참조하십시오. http://support.microsoft.com/kb/256986 .
  • 실제 레지스트리 가져오기 파일임이 확인되지 않은 .REG 파일은 실행하지 마십시오.

  1. 명령줄에서 regedit를 입력하여 레지스트리 편집기 사용자 인터페이스를 표시합니다.
  2. 다음 레지스트리로 이동합니다. [HKEY_LOCAL_MACHINE\System\ControlSet001\Services\mfevtp]
  3. 오른쪽 창에서 시작을 마우스 오른쪽 단추로 클릭하고 수정을 클릭하여 DWORD 값 편집 대화 상자를 표시합니다.
  4. 값 데이터에 4를 입력하고 확인을 클릭합니다.
  5. MFEVTP가 로드되지 않도록 한 다음 다시 부팅하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 이 기능과 관련이 없을 수도 있습니다.

mfehidk.sys 파일의 이름을 변경한 다음 다시 부팅

mfehidk.sys 파일의 이름을 변경하고 시스템을 다시 부팅하려면 다음 단계를 따르십시오.
  1. 운영 체제에 따라 다음 폴더에서 mfehidk.sys 파일로 이동합니다.
    • 32비트 운영 체제의 경우 — %windir%\System32\drivers
    • 64비트 운영 체제의 경우 — %windir%\System64\drivers
  2. 예를 들어 파일 이름을 mfehidk.sys에서 mfehidk.sys.saved로 변경합니다.
  3. mfehidk.sys 파일을 로드하지 않은 상태에서 시스템을 다시 부팅하여 VirusScan Enterprise를 중지했다가 다시 시작합니다.
  4. mfehidk.sys 파일 이름을 변경한 다음 다시 부팅하여 원래 시스템 문제 해결:
    • 예 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.
    • 아니오 — 원래 시스템 문제가 VirusScan Enterprise과 관련이 없을 수도 있습니다.

제품을 제거한 다음 다시 부팅

VirusScan Enterprise를 완전히 제거하고 다시 부팅하려면 다음 단계를 따르십시오.
  1. VirusScan Enterprise 프로그램 파일을 제거합니다. 자세한 내용은 McAfee VirusScan Enterprise 8.8, 설치 안내서를 참조하십시오.
  2. VirusScan Enterprise가 설치되지 않은 상태에서 시스템을 다시 부팅하여 운영 체제를 중지하고 다시 시작합니다.
  3. VirusScan Enterprise 프로그램 파일을 완전히 제거하고 다시 부팅하여 원래 시스템 문제 해결:
    • 예 — 원래 시스템 문제가 VirusScan Enterprise과 관련이 있을 수 있습니다.
    • 아니오 — http://mysupport.mcafee.com의 McAfee 기술 지원 서비스 포털로 이동하여 솔루션을 검색하거나 McAfee 기술 지원에 문의합니다.


제안된 지원 및 문제 해결 도구

VirusScan Enterprise 글로벌 관리자로서 시스템 보안과 성능 문제를 해결하고 평가하기 위해 설치하고 구성해야 하는 도구가 있습니다. McAfee 기술 지원에 문의 시, 구성 문제를 해결하는 동안 이러한 몇 가지 도구를 실행하도록 요청받을 수 있습니다. 이러한 도구는 다음 표에 나열된 인터넷 사이트에서 다운로드할 수 있습니다.

McAfee 도구

다음 표에는 McAfee에서 다운로드할 수 있는 지원 및 문제 해결 도구가 나열되어 있습니다.

도구 | 다운로드 사이트
MER Tool | WebMER
ProcessCounts | McAfee 지원에서 제공
SuperDAT Manager | McAfee 지원에서 제공
McAfee Profiler | McAfee 지원에서 제공

비McAfee 도구

다음 표에는 지원 및 문제 해결 도구, 실행 파일 및 다운로드 사이트가 나열되어 있습니다.

도구 | Executable | 다운로드 사이트
드라이버 확인 프로그램 | Verifier | Microsoft.com
성능 모니터 | PerfMon | Microsoft.com
Pool Monitor | PoolMon | Microsoft.com
Process Monitor | ProcMon | Microsoft.com
Process Explorer | ProcExp | Microsoft.com
프로세스 덤프 | ProcDump | Microsoft.com
Windows Object Viewer | WinObj | Microsoft.com
TCP Viewer | TCPView: | Mircosoft.com
Debug Output Viewer | DebugView | Microsoft.com
Windows 디버거 | WinDbg | Microsoft.com
Kernel Rate Viewer | KrView | Microsoft.com
Windows Performance Analysis Tools | Xperf | Microsoft.com
VM Converter | Varies | Vmware.com
WireShark | wireshark | Wireshark.org


질문과 대답

이 절에는 질문과 대답 형식의 문제 해결 정보가 포함되어 있습니다.

설치

  • 질문: 자동 설치 방법을 사용하여 소프트웨어를 설치했지만 Windows 시스템 트레이에 VirusScan Enterprise 아이콘이 없습니다.

    답변: 시스템을 다시 시작해야 시스템 트레이에 방패 아이콘이 나타납니다. 그러나 아이콘이 없어도 VirusScan Enterprise는 실행 중이며 시스템이 보호됩니다. 다음 레지스트리 키를 통해 이를 확인하십시오. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • 질문: 네트워크의 일부 사용자는 자체 설정을 구성할 수 있지만 다른 일부 사용자는 그럴 수 없는 이유는 무엇입니까?

    답변: 작업이 암호로 보호되도록 관리자가 사용자 인터페이스를 구성했을 수 있습니다. 그런 경우 사용자는 설정을 변경할 수 없습니다. 뿐만 아니라 Windows 운영 체제마다 사용자 권한이 다릅니다. 사용자 권한에 대한 자세한 내용은 Microsoft Windows 설명서를 참조하십시오.

차단된 프로그램

  • 질문: VirusScan Enterprise를 설치한 후 작동하지 않는 프로그램이 있습니다.

    답변: 액세스 보호 규칙에 의해 프로그램이 차단되었을 수 있습니다.
    1. 액세스 방지 로그 파일을 검토하여 프로그램이 규칙에 의해 차단되었는지 여부를 판별합니다.
    2. 로그에 해당 프로그램이 나열되어 있으면 해당 프로그램을 규칙에 대한 제외 항목으로 입력하거나 규칙을 사용하지 않는 방법이 있습니다. 자세한 내용은 시스템 액세스 포인트 보호를 참조하십시오.

쿠키 탐지

  • 질문: 주문형 검색 작업 로그에서 쿠키 탐지를 검토해 보니 모든 탐지에 대해 파일 이름 탐지가 항상 00000000.ie였습니다. 다른 프로그램은 각 쿠키 탐지에 개별 또는 증분 파일 이름을 할당하는데 VirusScan Enterprise에서는 모든 주문형 검색 쿠키 탐지에 동일한 파일 이름을 할당하는 이유는 무엇입니까?

    답변: 주문형 스캐너가 쿠키를 탐지하고 액션을 수행하는 방식으로 인해 VirusScan Enterprise에서는 각 쿠키 탐지에 동일한 파일 이름을 할당합니다. 이 작동은 주문형 검색에 의해 탐지된 쿠키에만 적용됩니다. 쿠키 파일에 여러 쿠키가 들어 있을 수 있습니다. 검색 엔진은 쿠키 파일을 아카이브로 취급하며 파일 시작부터 값을 오프셋으로 할당합니다(0으로 시작). 주문형 스캐너는 검색을 진행하기 전에 검색 엔진을 사용하여 쿠키를 탐지하고 탐지된 각 쿠키에 대한 액션을 수행하기 때문에 각 탐지마다 값은 0부터 시작됩니다. 그 결과 모든 탐지에 00000000.ie 파일 이름이 할당됩니다. 다른 제품은 모든 쿠키를 탐지하고 각각에 개별 또는 증분 파일 이름을 할당한 다음 각 탐지에 대해 액션을 수행합니다.

일반

  • 질문: 내 독립형 VirusScan Enterprise 시스템에서 시스템 트레이에 있는 시스템 아이콘이 사용 안 함으로 표시됩니다.

    답변: VirusScan Enterprise 아이콘 위에 빨간색 원과 선이 있으면 온액세스 스캐너를 사용할 수 없습니다. 가장 일반적인 원인과 해결책은 다음과 같습니다. 그래도 문제가 해결되지 않으면 기술 지원에 문의하십시오.
    1. 온액세스 스캐너를 사용할 수 있는지 확인하십시오. 시스템 트레이에서 VirusScan Enterprise 아이콘을 마우스 오른쪽 단추로 클릭합니다. 온액세스 스캐너를 사용할 수 없으면 온액세스 검색 사용을 클릭합니다.
    2. McShield 서비스가 실행 중인지 확인하십시오.
      • 서비스 제어판에서 수동으로 서비스를 시작합니다.
      • 시작 | 실행을 선택하고 Net Start McShield를 입력합니다.
      • 서비스 제어판에서 자동으로 시작하도록 서비스를 설정합니다.

  • 질문: 오류가 발생하여 CATALOG.Z를 다운로드할 수 없습니다.

    답변: 이 오류에는 여러 가지 원인이 있을 수 있습니다. 다음은 문제의 원인을 파악하는 데 도움이 되는 몇 가지 제안 사항입니다.
    • 업데이트를 위해 McAfee 기본 다운로드 사이트를 사용하는 경우, 웹 브라우저에서 CATALOG.Z 파일을 다운로드할 수 있는지 판별합니다. 다음 웹 사이트에서 파일을 다운로드합니다. http://update.nai.com/Products/CommonUpdater/catalog.z.
    • 파일을 볼 수는 있지만 다운로드할 수 없으면(즉, 브라우저에서 다운로드를 허용하지 않음) 프록시 문제이므로 네트워크 관리자에게 문의해야 합니다.
    • 파일을 다운로드할 수 있으면 VirusScan Enterprise에서도 다운로드할 수 있어야 합니다. VirusScan Enterprise 설치 문제를 해결하는 데 도움이 필요하면 기술 지원부에 문의하십시오.

  • 질문: HTTP 다운로드 사이트의 위치는 어디입니까?

    답변:
    • McAfee 다운로드 사이트 위치: http://www.mcafee.com/us/downloads/.
    • 최신 업데이트가 포함된 CATALOG.Z 파일은 다음 웹 사이트에서 다운로드할 수 있습니다. http://update.nai.com/Products/CommonUpdater/catalog.z.

  • 질문: FTP 다운로드 사이트의 위치는 어디입니까?

    답변:
    • FTP 다운로드 사이트 위치: ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x.
    • 최신 업데이트가 포함된 CATALOG.Z 파일은 다음 사이트에서 다운로드할 수 있습니다. ftp://ftp.mcafee.com/CommonUpdater/catalog.z.

  • 질문: 액션에 대한 사용자 프롬프트를 선택한 상태에서 잠재적으로 원하지 않는 프로그램이 탐지되는 경우 치료 또는 삭제 중 어떤 액션을 선택해야 합니까?

    답변: 탐지된 파일을 어떻게 처리해야 할지 확실하지 않으면 치료를 선택하는 것이 좋습니다. 온액세스 스캐너 및 주문형 스캐너에서는 치료 또는 삭제 전에 항목을 검역 디렉토리에 자동으로 백업합니다.


액세스 방지 탭

옵션 정의

액세스 방지 규칙을 구성하고 McAfee 프로세스가 중지하지 않도록 합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
액세스 방지 설정
  • 액세스 방지 사용 — 액세스 방지 기능을 사용합니다.
  • McAfee 서비스가 중지되지 않도록 함 — 사용자가 디버그 권한 없이 McAfee 프로세스를 종료하는 것을 방지합니다.

    이 옵션을 선택해도 디버그 프로그램 권한이 있는 사용자는 McAfee 프로세스를 중지할 수 있습니다.

    기본적으로 관리자는 Windows XP 및 Windows 2003 운영 체제에 대한 디버그 프로그램 권한을 가지고 있습니다. 관리자가 McAfee 프로세스를 중지할 수 없도록 이 권한을 사용자 권한에서 제거합니다.

주의:
McAfee 서비스가 중지되지 않도록 액세스 보호를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
액세스 방지 규칙

범주 — 범주를 선택하여 해당 범주에 대한 규칙을 표시합니다. 규칙은 다음의 범주로 구성됩니다.

  • 안티바이러스 표준 보호
  • 안티바이러스 최대 보호
  • 안티바이러스 아웃브레이크 제어
  • 일반 표준 보호
    주의:
    공통 표준 보호를 구성하고 다음 규칙에 대해 차단 및 보고서를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
    • McAfee 파일 및 설정 수정 방지
    • McAfee Common Management Agent 파일 및 설정 수정 방지
    • McAfee Scan Engine 파일 및 설정 수정 방지
    • McAfee 프로세스 종료 방지
  • 일반 최대 보호
  • VM 보호
  • 사용자 정의 규칙
  • 안티스파이웨어 표준 보호
  • 안티스파이웨어 최대 보호

자세한 내용은 액세스 방지 규칙 정의 방법을 참조하십시오.

차단/보고서/규칙 — 다음과 같이 규칙을 구성합니다.

  • 차단 — 규칙 상세 정보에 지정된 프로세스를 차단합니다. 차단을 선택하여 규칙을 사용하거나 선택 취소하여 사용하지 않을 수 있습니다.

    참고:

    로그를 기록하지 않고 액세스 시도를 차단하려면 차단을 선택하고 보고서는 선택하지 마십시오.

  • 보고서 — 액세스 방지를 위반하는 시도를 보고합니다. 탐지 발생 시 작업 로그에 정보가 기록됩니다.
    참고:

    액세스 시도를 차단하지 않고 경고를 받으려면 보고서는 선택하고 차단은 선택하지 마십시오. 이 방법은 규칙의 전체적인 영향을 알 수 없는 경우에 유용합니다. 잠시 동안 로그 및 보고서를 모니터한 후 액세스 차단 여부를 결정하십시오.

  • 규칙 — 규칙을 사용하여 컴퓨터에서 원하지 않는 변경 사항이 발생하는 것을 방지합니다. 규칙은 범주별로 구성됩니다. 범주를 먼저 선택한 다음 규칙을 선택합니다. 자세한 내용은 미리 정의된 규칙 구성 및 사용자 정의 규칙 구성을 참조하십시오.

    새로 만들기 — 새 사용자 정의 규칙을 만듭니다. 자세한 내용은 사용자 정의 규칙 구성을 참조하십시오.

    편집 — 기존 규칙을 변경합니다.

    삭제 — 기존의 사용자 정의 규칙을 제거합니다.
    참고:

    사용자 정의 규칙만 삭제할 수 있습니다. 다른 규칙은 편집하거나 사용하지 않을 수 있지만 삭제할 수는 없습니다. 규칙을 사용하지 않으려면 차단 및 보고서 옵션을 모두 선택 취소하십시오.

관련 작업
사용자 인터페이스 보안 설정 구성
관련 정보
액세스 보호


추가 알림 옵션 탭

옵션 정의

필터 및 로컬 알림 옵션을 구성합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
심각도 필터 다음 필터 옵션 중에서 선택합니다.
  • 알림을 필터링하지 않음 — 모든 알림을 보냅니다.
  • 정보성 알림 표시 안 함 — 심각도가 1 미만인 정보성 알림은 보내지 않습니다.
  • 정보성 및 경고성 알림 표시 안 함 — 심각도가 2 미만인 정보성 및 경고성 알림은 보내지 않습니다.
  • 정보성, 경고성 및 낮은 수준의 알림 표시 안 함 — 심각도가 3 미만인 정보성, 경고성 및 낮은 심각도의 알림을 보내지 않습니다.
  • 심각한 알림 이외의 모든 알림 표시 안 함 — 심각도가 4 이상인 심각한 알림 이외의 모든 알림을 보내지 않습니다.
  • 모든 알림 표시 안 함 — 어떠한 알림도 보내지 않습니다.
로컬 알림
  • 로컬 응용 프로그램 이벤트 로그에 로그 기록 — 정보를 로컬 응용 프로그램 이벤트 로그에 기록합니다.
  • SNMP 서비스를 사용하여 SNMP 트랩 전송 — SNMP를 사용하면 SNMP 트랩 알림을 보낼 수 있습니다.
참고:

로컬 경고 옵션은 Alert Manager가 필요하지 않습니다.
관련 작업
알림 구성
관련 정보
알림 및 통보 구성


알림 탭

옵션 정의

Alert Manager가 설치되어 있으면 알림을 생성할 구성 요소를 선택하고 Alert Manager를 구성합니다.

자세한 내용은 Alert Manager 4.7.1 제품 안내서를 참조하십시오.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
경고를 생성하는 구성요소
  • 온액세스 검색 — 온액세스 스캐너에서 위협을 탐지하면 알림을 생성합니다.
  • 주문형 검색과 예약된 검색 — 주문형 검색 작업에서 위협을 탐지하면 알림을 생성합니다.
  • 전자 메일 검색 — 전자 메일 스캐너에서 위협을 탐지하면 알림을 생성합니다.
  • 자동 업데이트 — 업데이트 작업에서 위협을 탐지하면 알림을 생성합니다.
  • 액세스 방지 — 액세스 방지에서 위협을 탐지하면 알림을 생성합니다.
Alert Manager 옵션
  • 알림 사용 안 함 — 탐지 발생 시 알림을 생성하지 않습니다.
  • 중앙 집중식 알림 사용 — 탐지가 발생하면 사용자에게 알리도록 중앙 집중식 알림을 사용합니다.
  • Alert Manager 알림 사용 — 탐지가 발생하면 사용자에게 알리도록 Alert Manager 알림을 사용합니다. 이 옵션을 선택하고 알림을 받는 Alert Manager 서버 위치의 경로를 입력합니다.
    • Active Directory 조회 사용 안 함 — Active Directory 조회를 사용하지 않습니다.
관련 작업
알림 구성
관련 정보
알림 및 통보 구성


보고서 탭

옵션 정의

로그 기록을 사용하면 네트워크에서 작업을 추적할 뿐만 아니라 스캐너에서 찾은 잠재적인 위협을 탐지하고 이에 대응하는 데 사용된 설정을 기록할 수 있습니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
파일에 로그 기록 | 작업 로그 기록을 활성화합니다.
로그 파일 위치 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.

기본 로그 이름은 AccessProtectionLog.txt입니다.

기본 위치는 다음과 같습니다. <드라이브>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

기본 위치는 사용 중인 운영 체제에 따라 달라질 수 있습니다.
로그 파일 크기 | 로그 파일의 크기를 제한합니다. 기본 크기(1MB)를 그대로 사용하거나 1MB~999MB 범위에서 크기를 설정합니다. 로그 파일에 기록된 데이터가 설정된 파일 크기를 초과하면 항목 중에서 가장 오래된 20%가 삭제되고 새로운 데이터가 파일에 추가됩니다.
로그 파일 형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 모든 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 사용하는 것이 좋습니다.
관련 개념
액세스 포인트 위반 및 VirusScan Enterprise 대응 방법
관련 작업
VirusScan 콘솔
관련 참조
온액세스 작업 로그 파일 보기


AutoUpdate 작업

자동 업데이트 작업 구성

옵션 정의

옵션 | 정의
로그 파일 | 작업 로그 기록을 활성화합니다.
형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
사용 가능한 경우 새 탐지 정의 파일 가져오기

새 버전을 사용할 수 있으면 DAT 파일의 최신 버전을 가져옵니다.

사용 가능한 경우 새 검출 엔진 가져오기

새 버전을 사용할 수 있으면 최신 버전의 엔진 및 DAT 파일을 가져옵니다.

사용 가능한 기타 업데이트(예: 서비스 팩, 업그레이드 등) 가져오기

서비스 팩 및 제품 업그레이드와 같은 기타 업데이트의 최신 버전을 가져옵니다.

업데이트가 완료된 후에 실행할 실행 파일 입력

자동 업데이트 작업의 실행이 완료된 후에 시작할 실행 파일을 지정합니다. 실행할 실행 파일의 경로를 지정하거나 찾아보기를 클릭하여 실행 파일을 찾습니다.

예를 들어, 관리자에게 자동 업데이트 작업이 완료되었음을 알리는 네트워크 메시지 유틸리티를 시작할 수 있습니다.

참고: 지정한 프로그램 파일은 현재 로그온된 사용자가 실행할 수 있어야 합니다. 현재 로그온된 사용자에게 해당 프로그램 파일이 포함된 폴더에 대한 액세스 권한이 없거나 현재 로그온된 사용자가 없으면 프로그램이 실행되지 않습니다.
성공적으로 업데이트한 뒤에만 실행

업데이트가 성공한 후에만 실행 프로그램을 실행합니다. 업데이트가 성공하지 못한 경우에는 지정한 프로그램이 실행되지 않습니다.

예약

이 업데이트 작업에 대한 예약을 정의합니다.

참고:

자세한 내용은 작업 예약을 참조하십시오.

자동 업데이트 작업과 미러 작업이 동시에 실행되도록 예약하는 것은 좋지 않습니다. 두 작업에서 모두 McAfee 공통 프레임워크 서비스를 사용하기 때문에 두 작업을 동시에 실행하면 충돌이 일어날 수 있습니다.

지금 업데이트

자동 업데이트 작업을 즉시 수행합니다.

관련 개념
업데이트 작업 및 수행 방법
관련 참조
자동 업데이트 작업 구성


차단 탭

옵션 정의

공유 폴더에 원하지 않는 프로그램이나 잠재적 위협이 있는 파일이 있는 원격 컴퓨터와의 연결을 차단합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
메시지 보내기 | 위협이 탐지될 경우 네트워크 사용자에게 메시지를 보냄 — 위협이 탐지되면 원격 컴퓨터의 네트워크 사용자에게 알립니다.
메시지 텍스트

텍스트 상자에 사용자 지정 메시지를 입력합니다. 이 메시지를 받으려면 원격 컴퓨터에서 Windows Messenger 서비스를 실행해야 합니다.
연결 차단
  • 공유 폴더에서 위협이 있는 파일이 탐지될 경우 연결을 차단 — 공유 폴더의 위협이 있는 파일을 읽거나 쓰려고 하는 원격 컴퓨터의 모든 네트워크 사용자에 대한 연결을 차단합니다.
  • 다음 시간 경과 후 연결 차단 해제 — 지정된 시간(분) 이후에 연결 차단을 해제합니다. 1과 9999 사이의 숫자를 입력합니다. 기본값 = 10분.
  • 공유 폴더에서 악성 프로그램이 검색될 경우 연결을 차단합니다. — 컴퓨터에서 원하지 않는 프로그램을 실행하려는 원격 컴퓨터의 모든 사용자에 대한 연결을 차단합니다. 온액세스 검색 통계 대화 상자에 차단된 컴퓨터의 목록이 표시됩니다.
관련 참조
포트 차단 규칙 옵션
파일 및 폴더 차단 규칙 옵션
레지스트리 차단 규칙 옵션
관련 정보
액세스 보호


보고서 탭

옵션 정의

특정 프로세스에 대해 힙 또는 스택 오버런으로부터 로컬 시스템에서 코드 실행 탐지를 추적하는 로깅을 활성화합니다.

옵션 | 정의
쿠키에 대한 경고 | 쿠키 검색이 발생할 경우 사용자에게 통보합니다. 기본값 = 선택됨.
파일에 로그 기록 | 작업 로그 기록을 활성화하고 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.
로그 파일 위치 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.

기본 로그 이름은 BufferOverflowProtectionLo.txt입니다.

기본 위치는 다음과 같습니다. <드라이브>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

기본 위치는 사용 중인 운영 체제에 따라 달라질 수 있습니다.

로그 파일 크기 | 로그 파일의 크기를 제한합니다. 기본 크기(1MB)를 그대로 사용하거나 1MB~999MB 범위에서 크기를 설정합니다. 로그 파일에 기록된 데이터가 설정된 파일 크기를 초과하면 항목 중에서 가장 오래된 20%가 삭제되고 새로운 데이터가 파일에 추가됩니다.
로그 파일 형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
관련 정보
알림 및 통보 구성
버퍼 오버플로우 악용 차단


버퍼 오버플로우 방지 탭

옵션 정의

버퍼 오버플로우가 컴퓨터에서 임의의 코드를 실행하지 못하도록 합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
버퍼 오버플로우 설정 버퍼 오버플로우 방지 사용 — 버퍼 오버플로우 방지 기능을 사용하여 방지 수준을 선택합니다.

  • 경고 모드 — 버퍼 오버플로우가 탐지되면 경고를 보냅니다. 다른 액션은 수행되지 않습니다.

    이 모드는 버퍼 오버플로우의 전체적인 영향을 알 수 없는 경우에 유용합니다. 잠시 경고 모드의 기능을 사용하고 그 시간에 로그 파일을 검토하면 방지 모드로 변경할지 여부를 결정하는 데 도움이 됩니다.

  • 방지 모드 — 버퍼 오버플로우가 탐지되고 탐지된 스레드가 종료되면 버퍼 오버플로우가 차단됩니다.

    이로 인해 응용 프로그램이 종료될 수도 있습니다.

주의:
버퍼 오버플로우 방지 및 보호 모드를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
클라이언트 시스템 경고 | 버퍼 오버플로우가 탐지되면 메시지 대화 상자 표시 — 탐지가 발생하면 온액세스 검색 메시지 대화 상자를 표시합니다.
버퍼 오버플로우 제외 항목 제외 정보 지정:
참고:

제외 이름은 대/소문자를 구분합니다.

  • 프로세스 — 호출을 실행하는 쓰기 가능한 메모리가 있는 프로세스 이름을 지정합니다.

    프로세스 이름만 입력하거나 해당 경로를 포함하여 입력할 수 있습니다.

    OUTLOOK.EXE와 같이 프로세스 이름만 입력할 경우, 해당 프로세스는 위치에 상관없이 실행될 때마다 제외됩니다. C:\Program files\OUTLOOK.EXE 같이 경로를 포함한 프로세스 이름을 입력할 경우, 해당 프로세스는 지정된 경로에서 실행될 때만 제외됩니다. 대표 문자를 사용할 수 없습니다.

  • 모듈(옵션) — 해당하는 경우 쓰기 가능한 메모리가 있는 모듈의 이름을 입력합니다. 이 정보는 필요하지 않습니다.
  • API — 호출할 API를 지정합니다.
    참고:

    모듈이 지정되어 있는 경우 API는 필수입니다.

관련 작업
버퍼 오버플로우 방지 구성
관련 정보
버퍼 오버플로우 악용 차단


프로세스 탭

옵션 정의

모든 프로세스에 대해 하나의 검색 정책 구성 여부 또는 기본, 저위험 및 고위험 프로세스에 대해 각각 다른 검색 정책 구성 여부를 선택합니다.

자세한 내용은 검색 정책 개수 결정 및 프로세스에 할당할 위험 결정을 참조하십시오.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
프로세스 설정 1개 또는 여러 개의 검색 정책을 구성할지 지정합니다.
  • 모든 프로세스에 적용되는 하나의 검색 정책을 구성합니다.— 이 옵션을 선택하면 사용자가 구성한 하나의 정책이 모든 프로세스에 적용됩니다.
  • 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다. — 저위험 또는 고위험 프로세스에 대해 정책을 구성하려면 이 옵션을 선택해야 합니다.
관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


표시 옵션 탭

옵션 정의

사용자가 액세스할 수 있는 시스템 트레이 옵션과 기본 설정 언어를 구성합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
시스템 트레이 아이콘
  • 모든 메뉴 옵션이 있는 시스템 트레이 아이콘 표시 — 사용자가 시스템 트레이 메뉴의 모든 옵션을 볼 수 있도록 합니다.
  • 최소 메뉴 옵션이 있는 시스템 트레이 아이콘 표시 — 시스템 트레이 메뉴에서 VirusScan Enterprise 정보와 온액세스 검색 통계를 제외한 모든 옵션을 숨깁니다.
  • 시스템 트레이 아이콘 표시 안 함 — 모든 사용자에게 시스템 트레이 아이콘을 숨깁니다.
콘솔 옵션
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.

  • 이 시스템이 다른 시스템으로 원격 콘솔 연결을 만들도록 허용 — 원격 컴퓨터에 연결합니다.

    관리자 권한이 있어야 하며 원격 레지스트리 서비스를 실행하고 있어야 합니다.

  • 클라이언트 콘솔에 관리된 작업 표시— 클라이언트 컴퓨터의 콘솔에 ePolicy Orchestrator 작업을 표시합니다.
  • 기본 자동 업데이트 작업 예약 사용 안 함 — 기본 업데이트 작업 예약을 사용하지 않습니다.

    정책이 적용되면 예약을 사용할 수 없습니다. 작업 예약을 사용하지 않으려면 작업 관리자 서비스를 실행해야 합니다.

  • 시작 화면 사용 — 콘솔 또는 SHSTAT.EXE를 시작하면 VirusScan Enterprise 8.8 시작 화면이 표시됩니다.
    참고:

    이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.

콘솔 언어 설정 콘솔 텍스트에 대해 사용할 언어를 지정합니다.
  • 언어가 자동으로 선택되거나 특정 언어를 직접 선택할 수 있습니다.
    참고:

    VirusScan Enterprise 8.8 콘솔에서 기본 언어를 변경하면 시스템을 다시 시작할 것인지 묻는 메시지가 나타납니다. 예를 클릭하면 언어 변경이 적용됩니다.

    ePolicy Orchestrator 콘솔에서 기본 언어를 변경하면 첫 번째 정책 시행 시 사용자 콘솔에 언어 변경 내용이 적용됩니다.

    ePolicy Orchestrator 관리 시스템의 경우 클라이언트 시스템으로부터 사용자가 변경한 내용은 콘솔 인터페이스에 영향을 미치지만 로그 파일은 ePolicy Orchestrator 구성에 지정된 언어로 활동을 기록합니다. 콘솔 언어 변경은 콘솔을 다시 시작한 후에 적용됩니다.

관련 작업
사용자 인터페이스 보안 설정 구성
관련 정보
액세스 보호


액션 탭

옵션 정의

위협이나 잠재적으로 원하지 않는 프로그램이 탐지되면 수행할 액션을 구성합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
위협 발견 시: 처음 수행할 액션 — 위협이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 첨부 파일 치료
  • 첨부 파일 치료 - 스캐너가 첨부 파일에서 위협을 제거합니다.
  • 액션에 대한 프롬프트 - 위협이 탐지되면 사용자에게 액션에 대해 알립니다. 이 옵션을 선택한 다음 프롬프트 대화 상자에서 허용된 액션에서 수행 가능한 액션을 지정합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 검색 계속 - 위협이 있는 첨부 파일이 탐지되면 검색을 계속합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 첨부 파일을 폴더로 이동 - 스캐너에서 잠재적 위협이 있는 첨부 파일을 지정된 폴더로 이동합니다.
  • 첨부 파일 삭제 - 잠재적 위협이 있는 첨부 파일을 탐지하는 즉시 스캐너에서 해당 파일을 삭제합니다. Microsoft Outlook의 경우 전자 메일이 삭제됩니다. Lotus Notes의 경우에는 첨부 파일이 삭제됩니다.
  • 메일 삭제(Outlook 검색 전용) - 스캐너가 잠재적 위협이 있는 메일을 삭제합니다. 이 옵션을 기본 액션으로 선택하면 보조 액션을 사용할 수 없습니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 첨부 파일을 폴더로 이동
  • 액션에 대한 프롬프트 - 위협이 탐지되면 사용자에게 액션에 대해 알립니다. 이 옵션을 선택한 다음 프롬프트 대화 상자에서 허용된 액션에서 수행 가능한 액션을 지정합니다.
  • 검색 계속 - 위협이 있는 첨부 파일이 탐지되면 검색을 계속합니다.
  • 첨부 파일을 폴더로 이동 - 스캐너에서 잠재적 위협이 있는 첨부 파일을 지정된 폴더로 이동합니다.
  • 첨부 파일 삭제 - 잠재적 위협이 있는 첨부 파일을 탐지하는 즉시 스캐너에서 해당 파일을 삭제합니다. Microsoft Outlook의 경우 전자 메일이 삭제됩니다. Lotus Notes의 경우에는 첨부 파일이 삭제됩니다.
  • 메일 삭제(Outlook 검색 전용) - 스캐너가 잠재적 위협이 있는 메일을 삭제합니다.
원하지 않는 프로그램 발견 시: 처음 수행할 액션 — 잠재적으로 원하지 않는 프로그램이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 첨부 파일 치료
  • 첨부 파일 치료 - 스캐너가 첨부 파일에서 위협을 제거합니다.
  • 액션에 대한 프롬프트 - 위협이 탐지되면 사용자에게 액션에 대해 알립니다. 이 옵션을 선택한 다음 프롬프트 대화 상자에서 허용된 액션에서 수행 가능한 액션을 지정합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 검색 계속 - 위협이 있는 첨부 파일이 탐지되면 검색을 계속합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 첨부 파일을 폴더로 이동 - 스캐너에서 잠재적 위협이 있는 첨부 파일을 지정된 폴더로 이동합니다.
  • 첨부 파일 삭제 - 잠재적 위협이 있는 첨부 파일을 탐지하는 즉시 스캐너에서 해당 파일을 삭제합니다. Microsoft Outlook의 경우 전자 메일이 삭제됩니다. Lotus Notes의 경우에는 첨부 파일이 삭제됩니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 첨부 파일을 폴더로 이동
  • 액션에 대한 프롬프트 - 위협이 탐지되면 사용자에게 액션에 대해 알립니다. 이 옵션을 선택한 다음 프롬프트 대화 상자에서 허용된 액션에서 수행 가능한 액션을 지정합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 검색 계속 - 위협이 있는 첨부 파일이 탐지되면 검색을 계속합니다.
이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.
  • 첨부 파일을 폴더로 이동 - 스캐너에서 잠재적 위협이 있는 첨부 파일을 지정된 폴더로 이동합니다.
  • 첨부 파일 삭제 - 잠재적 위협이 있는 첨부 파일을 탐지하는 즉시 스캐너에서 해당 파일을 삭제합니다. Microsoft Outlook의 경우 전자 메일이 삭제됩니다. Lotus Notes의 경우에는 첨부 파일이 삭제됩니다.
이동 대상 폴더 검역 폴더의 위치를 지정합니다. 검역 폴더는 하드 드라이브에 있어야 하며 이 위치는 로컬 드라이브여야 합니다. 검역 폴더는 Microsoft Outlook을 사용하는지 Lotus Notes를 사용하는지에 따라 다르기 때문에 플로피 드라이브나 CD 드라이브의 기본 위치에 있을 수 없습니다.
  • Microsoft Outlook의 경우 검역 폴더는 Microsoft Outlook 우편함에 있습니다.
  • Lotus Notes의 경우 검역 폴더는 파일 시스템에 있습니다.
프롬프트 대화 상자에서 허용된 액션 사용자가 액션을 입력할 때 허용되는 액션을 선택합니다.
참고:

기본 액세스 거부 액션은 다음 액션을 취하기 전에 발생합니다.

  • 첨부 파일 치료
  • 첨부 파일 삭제
  • 첨부 파일 이동
  • 메일 삭제(Microsoft Outlook에만 해당)
액션을 묻는 메시지가 표시되면 사용자는 알림 탭에서 지정한 메시지를 받습니다.
관련 작업
검역 정책 구성
관련 참조
온액세스 검색 탐지
주문형 검색 탐지
전자 메일 검색 탐지
관련 정보
탐지 및 응답


알림 탭

옵션 정의

배달 시 전자 메일 스캐너에 대한 알림 설정을 구성합니다.

옵션 | 정의
설정: | 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다. 참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
사용자용 경고를 전자 메일로 보내기 | 사용자에게 알림 메일 보내기 — 위협이 있는 전자 메일 메시지가 탐지되면 다른 사용자에게 알립니다.
액션 프롬프트 메시지 | 액션을 묻는 메시지가 표시되면 사용자에게 표시할 메시지를 지정합니다. 액션에 대한 프롬프트 옵션은 액션 탭에서 선택해야 합니다. 기본 메시지를 사용하거나 새 메시지를 입력합니다. 기본 메시지 = McAfee VirusScan Enterprise 전자 메일 스캐너: 알림!
관련 작업
알림 구성


검색 항목 탭

옵션 정의

주문형 전자 메일 스캐너에 대한 탐지 옵션을 구성합니다.

옵션 | 정의
검색할 메시지
  • 선택한 모든 항목 — 선택한 전자 메일 메시지와 폴더를 검색합니다.
  • 받은 편지함 폴더의 모든 메시지 — 현재 받은 편지함 폴더와 하위 폴더에서 모든 메시지를 검색합니다.
    • 읽지 않은 메시지만 검색 — 현재 받은 편지함 폴더와 하위 폴더에 있는 모든 읽지 않은 메시지를 검색합니다.
검색할 첨부 파일
  • 모든 파일 형식 — 확장명에 관계없이 모든 형식의 파일을 검색합니다.
  • Default + additional file types(기본 + 추가 파일 형식) — 기본 확장명 목록과 지정한 추가 파일 형식을 검색합니다. 기본 목록은 현재 DAT 파일에서 정의합니다. 기본 + 추가 파일 형식을 선택한 다음 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

    모든 첨부 파일의 매크로에 대해 검색 — 기본 + 추가 파일 형식을 선택한 경우 모든 파일의 알려진 매크로 위협도 검색할 수 있습니다.

  • Specified file types(지정된 파일 형식) — 검색할 사용자 지정 확장명의 목록을 만듭니다. 이전에 추가한 확장명을 제거할 수도 있습니다.

    지정된 파일 형식을 선택한 다음 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행)
  • 알 수 없는 프로그램 위협 및 트로이 목마 찾기 — Artemis 검색을 사용하여 악성 프로그램과 비슷한 코드가 있는 실행 파일을 탐지합니다.
  • 알 수 없는 매크로 위협 찾기 — Artemis 검색을 사용하여 알려지지 않은 매크로 바이러스를 탐지합니다.
  • 다중 확장명으로 된 첨부 파일 찾기 — 다중 확장명으로 된 첨부 파일을 위협으로 처리합니다.

    이 옵션을 선택하면 전자 메일 검색 경고 대화 상자가 표시됩니다. 확인을 클릭하여 선택 사항을 확인합니다.

주의:
Artemis를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
Compressed files(압축된 파일)
  • 압축 파일 내부 검색 — 압축 파일과 해당 파일의 내용을 검사합니다.

    보다 효율적으로 보호해 주지만, 압축 파일을 검색하면 검색 수행에 필요한 시간이 늘어날 수 있습니다.

  • MIME로 암호화된 파일 복호화 — MIME(Multipurpose Internet Mail Extensions) 암호화 파일을 탐지, 복호화 및 검색합니다.
원하지 않는 프로그램 탐지 원하지 않는 프로그램 탐지 — 잠재적으로 원하지 않는 프로그램을 탐지하도록 배달 시 전자 메일 스캐너를 사용합니다. 전자 메일 스캐너는 원하지 않는 프로그램 정책에서 구성한 정보를 사용하여 잠재적으로 원하지 않는 프로그램을 탐지합니다.

자세한 내용은 잠재적으로 원하지 않은 프로그램 제한을 참조하십시오.

전자 메일 메시지 본문(Microsoft Outlook에만 해당) | 전자 메일 메시지 본문 검색 — Microsoft Outlook 전자 메일 메시지의 본문을 검색합니다.
관련 작업
주문형 검색 작업 구성
관련 정보
주문형 항목 검색


보고서 탭

옵션 정의

로그 기록을 사용하면 네트워크에서 작업을 추적할 뿐만 아니라 스캐너에서 찾은 잠재적인 위협을 탐지하고 이에 대응하는 데 사용된 설정을 기록할 수 있습니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
파일에 로그 기록 | 작업 로그 기록을 활성화합니다.
로그 파일 위치 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.

주문형 전자 메일 로그에 대한 기본 로그 이름은 EmailOnDemandLog.txt입니다.

기본 위치는 다음과 같습니다. <드라이브>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

기본 위치는 사용 중인 운영 체제에 따라 달라질 수 있습니다.

로그 파일 크기 | 로그 파일의 크기를 제한합니다. 기본 크기(1MB)를 그대로 사용하거나 1MB~999MB 범위에서 크기를 설정합니다. 로그 파일에 기록된 데이터가 설정된 파일 크기를 초과하면 항목 중에서 가장 오래된 20%가 삭제되고 새로운 데이터가 파일에 추가됩니다.
로그 파일 형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
검색 작업 외에 추가 기록할 내용
  • 세션 설정 — 각 검색 세션에 대한 속성을 로그 파일에 기록합니다.
  • 세션 요약 — 각 검색 세션 중 스캐너의 액션에 대한 요약을 로그 파일에 기록합니다. 요약 정보에는 검색된 파일의 수, 탐지의 유형 및 수, 치료되거나 삭제된 파일의 수 및 기타 정보가 들어있습니다.
  • 암호화된 파일 검색 실패 — 스캐너에서 검색하지 못한 암호화된 파일의 이름을 기록합니다.
관련 작업
알림 구성


검색 항목 탭

옵션 정의

전자 메일 스캐너에 대한 탐지 옵션을 구성합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
전자 메일 검색 배달 시 전자 메일 검색을 사용합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
검색할 첨부 파일
  • 모든 파일 형식 — 확장명에 관계없이 모든 형식의 파일을 검색합니다.
  • Default + additional file types(기본 + 추가 파일 형식) — 기본 확장명 목록과 지정한 추가 파일 형식을 검색합니다. 기본 목록은 현재 DAT 파일에서 정의합니다. 기본 + 추가 파일 형식을 선택한 다음 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

    모든 첨부 파일의 매크로에 대해 검색 — 기본 + 추가 파일 형식을 선택한 경우 모든 파일의 알려진 매크로 위협도 검색할 수 있습니다.

  • Specified file types(지정된 파일 형식) — 검색할 사용자 지정 확장명의 목록을 만듭니다. 이전에 추가한 확장명을 제거할 수도 있습니다.

    지정된 파일 형식을 선택한 다음 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행)
  • 알 수 없는 프로그램 위협 및 트로이 목마 찾기 — Artemis 검색을 사용하여 악성 프로그램과 비슷한 코드가 있는 실행 파일을 탐지합니다.
  • 알 수 없는 매크로 위협 찾기 — Artemis 검색을 사용하여 알려지지 않은 매크로 바이러스를 탐지합니다.
  • 다중 확장명으로 된 첨부 파일 찾기 — 다중 확장명으로 된 첨부 파일을 위협으로 처리합니다.

    이 옵션을 선택하면 전자 메일 검색 경고 대화 상자가 표시됩니다. 확인을 클릭하여 선택 사항을 확인합니다.

주의:
Artemis를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
Compressed files(압축된 파일)
  • 압축 파일 내부 검색 — 압축 파일과 해당 파일의 내용을 검사합니다.

    보다 효율적으로 보호해 주지만, 압축 파일을 검색하면 검색 수행에 필요한 시간이 늘어날 수 있습니다.

  • MIME로 암호화된 파일 복호화 — MIME(Multipurpose Internet Mail Extensions) 암호화 파일을 탐지, 복호화 및 검색합니다.
원하지 않는 프로그램 탐지 원하지 않는 프로그램 탐지 — 잠재적으로 원하지 않는 프로그램을 탐지하도록 배달 시 전자 메일 스캐너를 사용합니다. 전자 메일 스캐너는 원하지 않는 프로그램 정책에서 구성한 정보를 사용하여 잠재적으로 원하지 않는 프로그램을 탐지합니다.

자세한 내용은 잠재적으로 원하지 않은 프로그램 제한을 참조하십시오.

전자 메일 메시지 본문(Microsoft Outlook에만 해당) | 전자 메일 메시지 본문 검색 — Microsoft Outlook 전자 메일 메시지의 본문을 검색합니다.
의심스러운 파일에 대해 경험적 접근 방식의 네트워크 검사
탐지된 샘플이 악성 프로그램인지 확인할 때 사용할 민감도 수준을 구성합니다. 비활성화됨 이외의 모든 수준에 대해 샘플 지문 또는 해시는 악성 프로그램인지 결정하기 위해 McAfee Labs에 제출됩니다. 탐지가 McAfee Labs가 업데이트를 게시하는 즉시 사용할 수 있으며 다음 DAT 릴리스를 기다릴 필요가 없다는 이점이 있습니다. 선택하는 민감도 수준이 높을수록 탐지되는 악성 프로그램 수가 많아집니다. 그러나 탐지가 많아질수록 잘못된 긍정의 결과 수도 많아질 수 있습니다. 다음 민감도 수준에서 선택하십시오.

  • 비활성화됨 — 악성 프로그램인지 확인하기 위해 지문 또는 데이터가 McAfee Labs에 제출되지 않습니다.

  • 매우 낮음 —잘못된 긍정의 탐지와 위험은 일반 DAT와 마찬가지입니다. 다음 DAT 업데이트를 기다리는 대신 McAfee Labs가 업데이트를 게시하면 VirusScan Enterprise에 탐지를 사용할 수 있습니다.

  • 낮음 — 이 수준은 매우 낮음과 중간 사이로 정의됩니다.

  • 중간 — 악성 프로그램의 정상적인 노출 위험이 잘못된 긍정의 위험보다 클 때 이 수준을 사용합니다. McAfee Labs 자체의 경험적 접근 검사에서는 악성 프로그램으로 탐지할 가능성이 높습니다. 그러나 파일에서의 일반적이지 않은 탐지는 잘못된 긍정을 초래할 수 있는 몇 가지 위험이 있습니다. McAfee Labs는 이 설정의 탐지가 널리 사용되는 응용 프로그램과 운영 체제 파일에서 잘못된 긍정을 생성하지 않는지 검사합니다.

  • 높음 — 이 수준은 중간과 매우 높음 사이로 정의됩니다.

  • 매우 높음 —실행 프로그램이나 운영 체제를 지원하지 않는 볼륨과 디렉토리를 검색하거나 전자 메일에 대해서만 이 수준을 사용하는 것이 좋습니다. 이 수준에서 발견된 탐지는 악성인 것으로 가정하지만 잘못된 긍정이 아닌지 확인하기 위해 완벽하게 테스트되지 않았습니다.

관련 작업
배달 시 및 주문형 전자 메일 검색


일반 탭

옵션 정의

일반 온 액세스 검사 옵션을 구성합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
검색 일반 검색 항목을 지정합니다.
  • 부트 섹터 — 부트 섹터를 검색합니다. 기본값 = 활성화됨.
  • 플로피(종료하는 동안) — 컴퓨터를 종료할 때 플로피 드라이브를 검색합니다.기본값 = 활성화됨.
  • 활성화된 프로세스 — McAfee 온액세스 McShield 서비스는 이미 실행 중인 모든 프로세스를 검색합니다. 기본값 = 비활성화됨.
    참고: 이 기능을 활성화하면 보안은 개선되지만 부팅 시간 성능에 영향을 미칩니다.
온액세스 검색 사용 검색을 사용할 시기를 지정합니다.
  • 시스템 시동 시 온 액세스 검색 사용 — 컴퓨터를 시작할 때마다 온액세스 스캐너를 사용합니다.
  • 정책 적용 시 온액세스 검색 사용 — 정책을 적용할 때마다 온액세스 스캐너를 사용합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
최대 검색 시간 최대 검색 시간을 지정합니다.
  • 모든 파일에 대해 최대 검색 시간 적용 — 모든 파일에 대해 최대 검색 시간을 정의하고 적용합니다.
  • 최대 검색 시간 — 모든 파일에 대해 최대 검색 시간(초)을 지정합니다. 기본값 = 45초
참고: 검색 제한 시간이 지나면 검색이 완전히 중지되며 메시지를 기록합니다. 검색을 완전히 중지할 수 없으면, 종료 후에 다음 검색에서 다시 시작됩니다.
쿠키

쿠키 파일 검색 — 쿠키 파일 검색을 활성화합니다.

Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행) | Artemis에 대해 사용 안 함에서 매우 높음 사이에 있는 6개 민감도 수준 중 하나를 지정합니다. 기본값 = 매우 낮음.
관련 작업
일반 설정 구성
관련 정보
온액세스 항목 검색


글로벌 검색 설정 탭

옵션 정의

시스템 재부팅 동안 검색 데이터를 저장할 캐시 검색 옵션을 설정하고 주문형 검색에서 치료 캐시 데이터를 사용하여 성능을 개선합니다. 자세한 내용은 글로벌 옵션 설정 구성을 참조하십시오.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
캐시 검색 글로벌 옵션 및 설정을 구성합니다.
  • 재부팅할 때 검색 데이터 저장 활성화 — 시스템을 재부팅할 때 치료 검색 결과를 저장할 수 있습니다. (기본값 = 선택됨)
    참고: 시스템이 외부적으로 변경할 수 있는 하드 드라이브를 사용하는 경우 이 기능을 비활성화합니다. 예를 들어, 하드 드라이브를 제거하는 경우 해당 내용이 업데이트되고 나중에 교체됩니다(이중 부팅이 구성된 VM과 시스템이 이 예외에 포함됨).
  • 주문형 검색에서 캐시 검색 사용 허용 — 주문형 스캐너가 기존 치료 검색 결과를 사용하여 중복된 검색을 줄일 수 있습니다. (기본값 = 선택됨)
관련 작업
글로벌 시스템 캐시 구성


프로세스 탭

1단계 옵션 정의

고위험으로 정의한 프로세스를 지정합니다. 두 단계로 된 프로세스입니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
프로세스 설정

온액세스 기본 프로세스 정책을 열고 다음을 선택합니다.

  • 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다.
참고:

저위험 또는 고위험 프로세스에 대해 정책을 구성하려면 이 옵션을 선택해야 합니다.

2단계 옵션 정의

옵션 | 정의
설정: | 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다. 참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
고위험 프로세스 | 온액세스 고위험 프로세스 정책을 열고 고위험으로 확인한 프로세스를 지정합니다. 필요에 따라 프로세스를 추가하고 제거합니다.

자세한 내용은 검색 정책 개수 결정 및 프로세스에 할당할 위험 결정을 참조하십시오.

관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


프로세스 탭

1단계 옵션 정의

저위험으로 정의된 프로세스를 지정합니다. 두 단계로 된 프로세스입니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
프로세스 설정

온액세스 기본 프로세스 정책을 열고 다음을 선택합니다.

  • 고위험, 저위험 및 기본 프로세스에 대해 서로 다른 검색 정책을 구성합니다.
참고:

저위험 또는 고위험 프로세스에 대해 정책을 구성하려면 이 옵션을 선택해야 합니다.

2단계 옵션 정의

옵션 | 정의
설정: | 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다. 참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
저위험 프로세스 | 온액세스 저위험 프로세스 정책을 열고 저위험으로 확인한 프로세스를 지정합니다. 필요에 따라 프로세스를 추가하고 제거합니다.

자세한 내용은 검색 정책 개수 결정 및 프로세스에 할당할 위험 결정을 참조하십시오.

관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


메시지 탭

옵션 정의

로컬 사용자와 관리 권한이 없는 사용자에 대한 메시지 옵션을 구성합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
사용자 메시지 로컬 사용자가 받는 메시지를 지정합니다.
  • 위협이 탐지될 경우 메시지 대화 상자가 나타나고 메시지에 지정한 텍스트를 표시합니다. — 탐지가 발생하면 온액세스 검색 메시지 대화 상자를 로컬 사용자에게 표시합니다.

  • 쿠키 탐지 발생 시 알림 — 쿠키가 탐지되면 경보를 보냅니다. 여기에는 ePolicy Orchestrator 경보를 생성하고, 메시지를 온액세스 검색 메시지 대화 상자로 보내고, 보고서 탭에 로깅되는 작업을 활성화한 경우 작업 로그에 탐지를 기록하고 검색 통계에서 검색 수를 계산하는 것이 포함됩니다. 이 옵션을 선택 취소하는 경우 ePolicy Orchestrator는 경보를 생성하지 않지만 탐지는 보고서 탭에 로깅되는 작업을 활성화한 경우 작업 로그에 기록되고 검색 통계에서 계산됩니다.

메시지 텍스트

기본 메시지를 사용하거나 사용자 정의 메시지를 입력합니다. 기본값 = VirusScan Enterprise 8.8 알림!

사용자가 수행할 수 있는 액션
  • 목록에서 메시지 제거 — 관리자 권한이 없는 사용자라도 목록에서 메시지를 삭제할 수 있습니다.
  • 파일 치료 — 관리자 권한이 없는 사용자가 목록의 메시지에서 참조하는 파일을 치료할 수 있습니다.
  • 파일 삭제 — 관리자 권한이 없는 사용자가 목록의 메시지에서 참조하는 파일을 삭제할 수 있습니다.
관련 참조
온액세스 검색 탐지


미러 작업

미러 작업 구성

VirusScan Enterprise 8.8 콘솔 — 옵션 정의

옵션 | 정의
로그 파일 | 작업 로그 기록을 활성화합니다.
형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
사용 가능한 경우 새 탐지 정의 파일 가져오기

이 옵션은 미러 작업에 적용되지 않습니다.
사용 가능한 경우 새 검출 엔진 가져오기

이 옵션은 미러 작업에 적용되지 않습니다.
사용 가능한 기타 업데이트(예: 서비스 팩, 업그레이드 등) 가져오기

이 옵션은 미러 작업에 적용되지 않습니다.
미러가 완료된 후에 실행할 실행 파일 입력

미러 작업이 완료된 후에 시작할 실행 파일을 지정합니다. 실행할 실행 파일의 경로를 지정하거나 찾아보기를 클릭하여 실행 파일을 찾습니다.

예를 들어 관리자에게 미러 작업이 완료되었음을 알리는 네트워크 메시지 유틸리티를 시작할 수 있습니다.

참고: 지정한 프로그램 파일은 현재 로그온된 사용자가 실행할 수 있어야 합니다. 현재 로그온된 사용자에게 해당 프로그램 파일이 포함된 폴더에 대한 액세스 권한이 없거나 현재 로그온된 사용자가 없으면 프로그램이 실행되지 않습니다.
성공적으로 미러링한 뒤에만 실행

성공적으로 미러링한 후에만 실행 프로그램을 실행합니다. 미러링이 성공하지 못한 경우 지정한 프로그램이 실행되지 않습니다.
미러 위치

미러 사이트에 대해 사용 중인 로컬 시스템의 대상 경로를 지정합니다.

참고: 시스템 변수가 지원됩니다.
예약

이 업데이트 작업에 대한 예약을 정의합니다.

참고:

자세한 내용은 작업 예약을 참조하십시오.

자동 업데이트 작업과 미러 작업이 동시에 실행되도록 예약하는 것은 좋지 않습니다. 두 작업에서 모두 McAfee 공통 프레임워크 서비스를 사용하기 때문에 두 작업을 동시에 실행하면 충돌이 일어날 수 있습니다.
지금 미러링

미러 작업을 즉시 수행합니다.

관련 개념
미러 작업 및 작동 방식
관련 참조
미러 작업 구성


Notes 스캐너 설정 탭

옵션 정의

배달 시 전자 메일 스캐너에 대한 Lotus Notes 설정을 구성합니다.

Lotus Notes 암호 구성

Windows 2000 Server, Windows 2003 Server 또는 Windows XP에 있는 로컬 데이터베이스에 액세스하면 암호를 묻는 메시지가 나타납니다. 암호를 입력하면 텍스트 검색 대화 상자가 시작되고 암호 대화 상자에 삽입하는 대신 텍스트 검색 대화 상자에 암호가 삽입됩니다. 암호 대화 상자는 완전히 모달이 아닙니다. 다시 대화 상자를 선택하면 암호를 입력할 수 있습니다.

McAfee에서는 다음과 같이 암호를 여러 번 묻는 것을 방지할 것을 권장합니다.
  1. Lotus Notes에서 파일 | 기본 설정 | 보안 | 사용자 보안 | 대화 상자를 클릭합니다.
  2. 다른 Notes 기반 프로그램에서 암호에 대한 대화 상자를 표시하지 않음(보안 감소)을 클릭합니다.
    주의:
    이 구성은 시스템 보안을 잠재적으로 줄입니다.
옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
서버 검색 설정
  • 서버의 모든 데이터베이스를 검색 — 모든 서버 데이터베이스에서 잠재적 위협을 검색합니다.
  • 서버 사서함 검색 — 모든 서버 사서함에서 잠재적 위협을 검색합니다.
  • 사서함 루트 폴더 — 루트 폴더의 위치를 지정합니다. 사서함 루트 폴더의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다. 이 옵션은 배달 시 전자 메일 검색에만 사용할 수 있습니다. 기본값 = !!mail\
고급 옵션 | 제외할 Notes 응용 프로그램 — 검색에서 제외할 Lotus Notes 응용 프로그램을 지정합니다. 기본값 = MNOTES
관련 작업
배달 시 및 주문형 전자 메일 검색


액션 탭

옵션 정의

위협이나 잠재적으로 원하지 않는 프로그램이 탐지되면 수행할 액션을 구성합니다. 기본, 저위험 및 고위험 프로세스에 대해 서로 다른 검색 정책을 구성하는 경우에는 각 프로세스 유형에 대해 이 탭의 옵션을 구성해야 합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
위협 발견 시: 처음 수행할 액션 — 위협이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 자동으로 파일 치료
  • 자동으로 파일 치료 - 스캐너가 탐지된 파일에서 위협을 제거합니다.
  • 파일에 대한 액세스 거부 - 스캐너에서 찾은 잠재적 위협이 있는 파일에 대한 모든 사용자 액세스를 거부합니다.
  • 자동으로 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 자동으로 파일 삭제
  • 파일에 대한 액세스 거부 - 스캐너에서 찾은 잠재적 위협이 있는 파일에 대한 모든 사용자 액세스를 거부합니다.
  • 자동으로 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
원하지 않는 프로그램 발견 시: 처음 수행할 액션 — 잠재적으로 원하지 않는 프로그램이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 자동으로 파일 치료
  • 파일에 대한 액세스 허용 - 탐지된 파일 및 프로그램에 대한 액세스를 사용자에게 제공합니다.
    참고:

    수행할 액션을 결정하기 전에 탐지되는 내용을 감시하는 데 유용합니다. 작업 로그를 검토하여 탐지되는 프로그램을 파악합니다. 이 옵션에 대해 사용할 수 있는 보조 액션이 없습니다.

  • 자동으로 파일 치료 - 탐지된 파일 및 프로그램에서 자동으로 위협을 제거합니다.
  • 파일에 대한 액세스 거부 - 탐지된 파일 및 프로그램에 사용자가 액세스하지 못하도록 합니다.
  • 자동으로 파일 삭제 - 탐지된 파일 및 프로그램을 자동으로 제거합니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 자동으로 파일 삭제
  • 파일에 대한 액세스 허용 - 탐지된 파일 및 프로그램에 대한 액세스를 사용자에게 제공합니다.
  • 파일에 대한 액세스 거부 - 탐지된 파일 및 프로그램에 사용자가 액세스하지 못하도록 합니다.
  • 자동으로 파일 삭제 - 탐지된 파일 및 프로그램을 자동으로 제거합니다.
관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


제외 항목 탭

옵션 정의

검색에서 제외할 항목을 지정합니다. 기본, 저위험 및 고위험 프로세스에 대해 서로 다른 검색 정책을 구성하는 경우에는 각 프로세스 유형에 대해 이 탭의 옵션을 구성해야 합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
제외 대상 제외 형식을 선택한 다음 제외 항목에 대한 세부 정보를 지정합니다.
  • 파일 이름/위치별 제외 — 입력란에 파일 이름과 위치를 입력합니다. 필요한 경우 하위 폴더 제외를 선택합니다.
    참고: 폴더에 적용하려면 문자열 끝에 백슬래시(\)를 추가해야 합니다. 그렇지 않으면 파일 제외로 간주되며 하위 폴더 제외 확인란이 기본적으로 비활성화됩니다.
  • 파일 유형별 제외 — 입력란에 파일 형식을 입력합니다.
  • 파일 연령별 제외 — 액세스 유형을 선택하고 최소 일령을 지정합니다.

자세한 내용은 검색 항목 추가 및 제외를 참조하십시오.

제외 시기 선택한 항목을 제외할 시기를 선택합니다.
  • 읽을 때
  • 쓸 때
클라이언트 제외를 처리하는 방법 클라이언트 제외 항목 덮어쓰기 — 이 정책에 지정된 항목만 제외합니다. 이 옵션을 선택하지 않으면 클라이언트 컴퓨터는 로컬로 지정된 제외 항목과 정책에서 지정된 제외 항목을 사용합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


보고서 탭

옵션 정의

로그 기록을 사용하면 네트워크에서 작업을 추적할 뿐만 아니라 스캐너에서 찾은 잠재적인 위협을 탐지하고 이에 대응하는 데 사용된 설정을 기록할 수 있습니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
파일에 로그 기록 | 작업 로그 기록을 활성화합니다.
로그 파일 위치 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.

기본 로그 이름은 onaccessscanlog.txt입니다.

기본 위치는 다음과 같습니다. <드라이브>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\.

기본 위치는 사용 중인 운영 체제에 따라 달라질 수 있습니다.
로그 파일 크기 | 로그 파일의 크기를 제한합니다. 기본 크기(1MB)를 그대로 사용하거나 1MB~999MB 범위에서 크기를 설정합니다. 로그 파일에 기록된 데이터가 설정된 파일 크기를 초과하면 항목 중에서 가장 오래된 20%가 삭제되고 새로운 데이터가 파일에 추가됩니다.
로그 파일 형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
검색 작업 외에 추가 기록할 내용
  • 세션 설정 — 각 검색 세션에 대한 속성을 로그 파일에 기록합니다.
  • 세션 요약 — 각 검색 세션 중 스캐너의 액션에 대한 요약을 로그 파일에 기록합니다. 요약 정보에는 검색된 파일의 수, 탐지의 유형 및 수, 치료되거나 삭제된 파일의 수 및 기타 정보가 들어있습니다.
  • 암호화된 파일 검색 실패 — 스캐너에서 검색하지 못한 암호화된 파일의 이름을 기록합니다.
관련 작업
주문형 검색 작업 구성
관련 정보
주문형 항목 검색


검색 항목 탭

옵션 정의

탐지 옵션을 구성합니다. 기본, 저위험 및 고위험 프로세스에 대해 서로 다른 검색 정책을 구성하는 경우에는 각 프로세스 유형에 대해 이 탭의 옵션을 구성해야 합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
파일 검색
  • 디스크에 기록할 때 — 컴퓨터 또는 다른 데이터 저장 장치에 기록되거나 수정되는 모든 파일을 검색합니다.
    주의:
    디스크에 기록할 때를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.

    컴퓨터 간에 파일을 복사하거나 이동하는 경우에는 잠재적 위협이 있는 파일이 컴퓨터에서 복사되거나 컴퓨터에 기록되지 않도록 모든 컴퓨터를 동일하게 구성해야 합니다.

  • 디스크에서 읽을 때 — 컴퓨터나 다른 데이터 저장 장치에서 읽는 모든 파일을 검색합니다.
    주의:
    디스크에서 읽을 때를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • 네크워크 드라이브에 — 매핑된 네트워크 드라이브에서 리소스를 검색합니다.

    네트워크 리소스를 검색하면 성능에 영향을 미칠 수 있습니다.

  • 백업을 위해 열려 있음 — 백업 작업을 위해 열려 있는 파일을 검사합니다.
검색할 파일 형식
  • All files(모든 파일) — 확장명에 관계없이 모든 파일을 검색합니다.
    주의:
    모든 파일을 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • Default + additional file types(기본 + 추가 파일 형식) — 기본 확장명 목록과 지정한 추가 파일 형식을 검색합니다. 기본 목록은 현재 DAT 파일에서 정의합니다.

    모든 파일의 매크로에 대해 검색 — 이 옵션을 선택한 경우 모든 파일의 알려진 매크로 위협도 검색할 수 있습니다.

  • 지정된 파일 형식만 — 검색할 사용자 지정 확장명의 목록을 만듭니다. 이전에 추가한 확장명을 제거할 수도 있습니다.

    이 옵션을 선택한 후 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행)
  • 알 수 없는 프로그램 위협 및 트로이 목마 찾기 — Artemis 검색을 사용하여 악성 프로그램과 비슷한 코드가 있는 실행 파일을 탐지합니다.
  • 알 수 없는 매크로 위협 찾기 — Artemis 검색을 사용하여 알려지지 않은 매크로 바이러스를 탐지합니다.
주의:
Artemis를 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
Compressed files(압축된 파일)
  • 압축 파일 내부 검색 — 압축 파일과 해당 파일의 내용을 검사합니다.
  • MIME로 암호화된 파일 복호화 — MIME(Multipurpose Internet Mail Extensions) 암호화 파일을 탐지, 복호화 및 검색합니다.
참고: 보다 효율적으로 보호해 주지만, 압축 파일을 검색하면 검색 수행에 필요한 시간이 늘어날 수 있습니다.
원하지 않는 프로그램 탐지
  • 원하지 않는 프로그램 탐지 — 잠재적으로 원하지 않는 프로그램을 탐지하도록 온액세스 스캐너를 사용합니다.

    스캐너는 원하지 않는 프로그램 정책에서 구성한 정보를 사용하여 잠재적으로 원하지 않는 프로그램을 탐지합니다.

    자세한 내용은 잠재적으로 원하지 않은 프로그램 제한을 참조하십시오.

관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


액션 탭

옵션 정의

위협이나 잠재적으로 원하지 않는 프로그램이 탐지되면 수행할 액션을 구성합니다.

옵션 정의
위협 발견 시: 처음 수행할 액션 — 위협이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 파일 치료
  • 파일 치료 — 스캐너가 탐지된 파일에서 위협을 제거합니다.
  • 검색 계속 — 위협이 있는 파일이 탐지되면 검색을 계속합니다.
  • 자동으로 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 파일 삭제
  • 검색 계속 — 위협이 있는 파일이 탐지되면 검색을 계속합니다.
  • 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
원하지 않는 프로그램 발견 시: 처음 수행할 액션 — 위협이 탐지되면 스캐너에서 수행할 첫 번째 액션을 선택합니다. 기본값 = 파일 치료
  • 파일 치료 — 스캐너가 탐지된 파일에서 위협을 제거합니다.
  • 검색 계속 — 위협이 있는 파일이 탐지되면 검색을 계속합니다.
  • 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
첫 번째 액션이 실패하면 그 다음 수행할 액션 — 첫 번째 액션이 실패하면 스캐너에서 수행할 다음 액션을 선택합니다. 기본값 = 파일 삭제
  • 검색 계속 — 위협이 있는 파일이 탐지되면 검색을 계속합니다.
  • 파일 삭제 — 잠재적 위협이 있는 파일이 탐지되는 즉시 스캐너가 해당 파일을 삭제합니다.
관련 참조
프로세스 설정 탭 옵션
관련 정보
온액세스 항목 검색


제외 항목 탭

옵션 정의

검색에서 제외할 항목을 지정합니다.

옵션 정의
제외 대상 드롭다운 목록에서 제외 형식을 선택한 다음 해당 제외 항목에 대한 상세 정보를 지정합니다.
  • 파일 이름/위치별 제외 — 입력란에 파일 이름과 위치를 입력합니다. 필요한 경우 하위 폴더 제외를 선택합니다.
    참고: 폴더에 적용하려면 문자열 끝에 백슬래시(\)를 추가해야 합니다. 그렇지 않으면 파일 제외로 간주되며 하위 폴더 제외 확인란이 기본적으로 비활성화됩니다.
  • 파일 유형별 제외 — 입력란에 파일 형식을 입력합니다.
  • 파일 연령별 제외 — 액세스 유형과 최소 일령을 선택합니다.

자세한 내용은 검색 항목 추가 및 제외를 참조하십시오.

제외 시기 선택한 항목을 제외할 시기를 선택합니다.
  • 읽을 때
  • 쓸 때
클라이언트 제외를 처리하는 방법 클라이언트 제외 항목 덮어쓰기 — 이 정책에 지정된 항목만 제외합니다. 이 옵션을 선택하지 않으면 클라이언트 컴퓨터는 로컬로 지정된 제외 항목과 정책에서 지정된 제외 항목을 사용합니다.
참고:

이 옵션은 ePolicy Orchestrator를 통해서만 구성됩니다.

관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


성능 탭

옵션 정의

검색 연기와 시스템 사용률 옵션을 지정하여 성능을 개선합니다.

옵션 정의
검색 연기 옵션 검색 연기 옵션을 선택합니다.
  • 배터리 전원 사용 시 검색을 연기합니다.— 시스템이 배터리 전원을 사용 중일 때 검색을 연기합니다.
  • 프레젠테이션 수행 시 검색을 연기합니다.— 시스템이 프레젠테이션 모드에 있는 동안 검색을 연기합니다.
  • 사용자가 예약된 검색을 연기할 수 있습니다. — 사용자가 예약된 검색을 연기할 수 있습니다.

  • 최대 연기 기간 — 검색을 연기할 기간을 지정합니다. 1시간~24시간 사이에서 선택하거나 검색을 영구 연기하려면 0을 선택합니다.

자세한 내용은 검색 연기 작동 방식을 참조하십시오.

시스템 사용률 ePolicy Orchestrator에서 목록을 사용하거나 VirusScan 콘솔의 슬라이더를 사용하여 검색을 위한 사용률 예약을 설정합니다. 각 작업은 다른 작업에 대한 사용률 제한과 상관없이 독립적으로 실행됩니다. 증분은 다음과 같습니다.
  • 낮음
  • 보통 이하 — ePolicy Orchestrator 기본값.
  • 보통 — VirusScan Enterprise 8.8 기본값.
Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행)
탐지된 샘플이 악성 프로그램인지 확인할 때 사용할 민감도 수준을 구성합니다. 비활성화됨 이외의 모든 수준에 대해 샘플 지문 또는 해시는 악성 프로그램인지 결정하기 위해 McAfee Labs에 제출됩니다. 탐지가 McAfee Labs가 업데이트를 게시하는 즉시 사용할 수 있으며 다음 DAT 릴리스를 기다릴 필요가 없다는 이점이 있습니다. 선택하는 민감도 수준이 높을수록 탐지되는 악성 프로그램 수가 많아집니다. 그러나 탐지가 많아질수록 잘못된 긍정의 결과 수도 많아질 수 있습니다. 다음 민감도 수준에서 선택하십시오.

  • 비활성화됨 — 악성 프로그램인지 확인하기 위해 지문 또는 데이터가 McAfee Labs에 제출되지 않습니다.

  • 매우 낮음 —잘못된 긍정의 탐지와 위험은 일반 DAT와 마찬가지입니다. 다음 DAT 업데이트를 기다리는 대신 McAfee Labs가 업데이트를 게시하면 VirusScan Enterprise에 탐지를 사용할 수 있습니다.

  • 낮음 — 이 수준은 매우 낮음과 중간 사이로 정의됩니다.

  • 중간 — 악성 프로그램의 정상적인 노출 위험이 잘못된 긍정의 위험보다 클 때 이 수준을 사용합니다. McAfee Labs 자체의 경험적 접근 검사에서는 악성 프로그램으로 탐지할 가능성이 높습니다. 그러나 파일에서의 일반적이지 않은 탐지는 잘못된 긍정을 초래할 수 있는 몇 가지 위험이 있습니다. McAfee Labs는 이 설정의 탐지가 널리 사용되는 응용 프로그램과 운영 체제 파일에서 잘못된 긍정을 생성하지 않는지 검사합니다.

  • 높음 — 이 수준은 중간과 매우 높음 사이로 정의됩니다.

  • 매우 높음 —실행 프로그램이나 운영 체제를 지원하지 않는 볼륨과 디렉토리를 검색하거나 전자 메일에 대해서만 이 수준을 사용하는 것이 좋습니다. 이 수준에서 발견된 탐지는 악성인 것으로 가정하지만 잘못된 긍정이 아닌지 확인하기 위해 완벽하게 테스트되지 않았습니다.

관련 개념
시스템 사용률 작동 방식
관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


보고서 탭

옵션 정의

로그 기록을 사용하면 네트워크에서 작업을 추적할 뿐만 아니라 스캐너에서 찾은 잠재적인 위협을 탐지하고 이에 대응하는 데 사용된 설정을 기록할 수 있습니다.

옵션 | 정의
파일에 로그 기록 | 작업 로그 기록을 활성화합니다.
로그 파일 위치 로그 파일의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다.

기본 로그 이름은 OnDemandScanLog.txt입니다.

기본 위치는 다음과 같습니다. <드라이브>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\.

기본 위치는 사용 중인 운영 체제에 따라 달라질 수 있습니다.
로그 파일 크기 | 로그 파일의 크기를 제한합니다. 기본 크기(1MB)를 그대로 사용하거나 1MB~999MB 범위에서 크기를 설정합니다. 로그 파일에 기록된 데이터가 설정된 파일 크기를 초과하면 항목 중에서 가장 오래된 20%가 삭제되고 새로운 데이터가 파일에 추가됩니다.
로그 파일 형식 로그 파일 형식을 선택합니다. 기본값 = Unicode(UTF8)
  • Unicode (UTF8) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • Unicode (UTF16) — 각 문자가 1바이트 또는 2바이트인 아시아어 텍스트를 저장하거나 다국적 조직 내에서 정보를 공유하는 경우에 사용하는 것이 좋습니다.
  • ANSI — 각 문자가 1바이트인 구미어 텍스트를 저장하는 경우에 ANSI 형식을 사용하는 것이 좋습니다.
검색 작업 외에 추가 기록할 내용
  • 세션 설정 — 각 검색 세션에 대한 속성을 로그 파일에 기록합니다.
  • 세션 요약 — 각 검색 세션 중 스캐너의 액션에 대한 요약을 로그 파일에 기록합니다. 요약 정보에는 검색된 파일의 수, 탐지의 유형 및 수, 치료되거나 삭제된 파일의 수 및 기타 정보가 들어있습니다.
  • 암호화된 파일 검색 실패 — 스캐너에서 검색하지 못한 암호화된 파일의 이름을 기록합니다.
쿠키 검출 발생 시 경고

쿠키 탐지 발생 시 알림 — 쿠키가 탐지되면 경보를 보냅니다. 여기에는 ePolicy Orchestrator 경보와 탐지 알림을 생성하고 보고서 탭에 로깅되는 작업을 활성화한 경우 작업 로그에 탐지를 기록하고 검색 통계에서 검색 수를 계산하는 것이 포함됩니다. 이 옵션을 선택 취소하는 경우 ePolicy Orchestrator는 경보를 생성하지 않지만 탐지는 보고서 탭에 로깅되는 작업을 활성화한 경우 작업 로그에 기록되고 검색 통계에서 계산됩니다.
관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


검색 항목 탭

옵션 정의

탐지 옵션을 구성합니다.

옵션 정의
검색할 파일 형식
  • All files(모든 파일) — 확장명에 관계없이 모든 파일을 검색합니다.
  • Default + additional file types(기본 + 추가 파일 형식) — 기본 확장명 목록과 지정한 추가 파일 형식을 검색합니다. 기본 목록은 현재 DAT 파일에서 정의합니다.

    이 옵션을 선택한 후 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

    모든 파일의 매크로에 대해 검색 — 기본 + 추가 파일 형식을 선택한 경우 모든 파일의 알려진 매크로 위협도 검색할 수 있습니다.

  • Specified file types(지정된 파일 형식) — 검색할 사용자 지정 확장명의 목록을 만듭니다. 이전에 추가한 확장명을 제거할 수도 있습니다.

    이 옵션을 선택한 후 입력란에 파일 확장명을 공백으로 구분하여 입력합니다.

옵션
  • 원하지 않는 프로그램 탐지 — 잠재적으로 원하지 않는 프로그램을 탐지하도록 온액세스 스캐너를 사용합니다.

    스캐너는 원하지 않는 프로그램 정책에서 구성한 정보를 사용하여 잠재적으로 원하지 않는 프로그램을 탐지합니다.

    자세한 내용은 잠재적으로 원하지 않은 프로그램 제한을 참조하십시오.

  • MIME로 암호화된 파일 복호화 — MIME(Multipurpose Internet Mail Extensions) 암호화 파일을 탐지, 복호화 및 검색합니다.
  • 압축 파일 내부 검색 — 압축 파일과 해당 파일의 내용을 검사합니다.
보다 효율적으로 보호해 주지만, 압축 파일을 검색하면 검색 수행에 필요한 시간이 늘어날 수 있습니다.

  • 저장 영역으로 이동된 파일 검색 — 원격 저장 영역에 저장되어 있는 캐시된 파일을 검색합니다.

    자세한 내용은 원격 저장 영역 검색 방법을 참조하십시오.

Artemis(의심스러운 파일에 대해 경험적 네트워크 검사 수행)
  • 알려지지 않은 프로그램 위협 찾기 — Artemis 검색을 사용하여 악성 프로그램과 비슷한 코드가 있는 실행 파일을 탐지합니다.
  • 알 수 없는 매크로 위협 찾기 — Artemis 검색을 사용하여 알려지지 않은 매크로 바이러스를 탐지합니다.
관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


작업 탭

옵션 정의

이 주문형 작업을 실행할 플랫폼을 지정합니다.

옵션 정의
이 작업이 실행될 플랫폼
  • 이 작업을 서버에서 실행 — 이 주문형 검색 작업을 서버에서 실행합니다.
  • 이 작업을 워크스테이션에서 실행 — 이 주문형 검색 작업을 워크스테이션에서 실행합니다.
작업 실행 시 사용할 사용자 계정
  • 사용자 이름 — 사용자 계정 이름을 지정합니다. 계정을 입력하지 않으면 작업은 시스템 계정 아래에서 실행합니다.
  • 암호 — 암호를 입력합니다.
  • 도메인 — 도메인을 입력합니다.
참고:

작업을 예약하려면 관리자 권한이 있어야 합니다. 관리자 권한은 사용자에게 예약된 작업의 레지스트리 키에 대한 쓰기 액세스 권한을 제공합니다. 클라이언트 작업 예약에 대한 자세한 내용은 ePolicy Orchestrator 설명서를 참조하십시오.

관련 참조
주문형 검색 작업 탭 구성
관련 정보
주문형 항목 검색


암호 옵션 탭

옵션 정의

전체 시스템 또는 선택된 항목에 대한 암호 보안을 설정합니다. 자세한 내용은 암호 설정이 사용자에게 주는 영향을 참조하십시오.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
사용자 인터페이스 암호 사용자 인터페이스 보안을 지정합니다.
  • 암호 없음 — 암호가 없어도 구성 설정에 액세스할 수 있습니다.
  • 나열된 모든 항목에 대한 암호 보호 — 목록에서 모든 항목에 대해 하나의 암호를 지정합니다.
  • 선택한 항목에 대한 암호 보호 — 목록에서 선택한 항목에 대해 하나의 암호를 지정합니다.
  • 일반 기준에 따라 암호 보호 — NIAP(National Information Assurance Partnership) 공통 기준에 따라 검증된 보안 제품만을 사용해야 하는 정부 기관에서 필요한 인터페이스를 보호합니다.

    워크스테이션 사용자가 워크스테이션의 즉시 주문형 검색을 수행할 수 있는 것을 제외하고 관리 인증서가 없는 사용자로부터 모든 구성 옵션을 보호합니다. 즉시 주문형 검색에 파일을 포함시키거나 제외합니다. 즉시 주문형 검색에 .ZIP 파일과 같은 압축 파일을 포함시키거나 제외합니다. 주문형 검색 및 온액세스 검색 작업 로그를 봅니다.

암호 — 암호를 입력합니다.

암호 확인 — 암호를 다시 입력하고 암호를 확인합니다.
암호로 보호할 사용자 인터페이스 항목 암호 보호를 설정할 항목을 선택합니다.
  • 모두 선택 — 섹션의 모든 항목을 선택합니다.
  • 모두 선택 취소 — 섹션의 모든 항목을 선택 취소합니다.

관리자는 콘솔을 통해 인터페이스를 잠그거나 잠금을 해제할 수 있습니다.

관련 참조
작업 예약 구성
관련 정보
사용자 인터페이스에 대한 액세스 제어


정책 탭

옵션 정의

검역 위치와 검역된 항목을 보관하는 시간을 구성합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
검역 디렉토리 | 검역 디렉토리의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다. 기본 위치 = <시스템_드라이브>\Quarantine.
검역된 데이터 보존
  • 검역된 데이터 자동 삭제 — 지정된 기간(일수)이 경과하면 검역된 항목을 삭제합니다.
  • 검역 디렉토리에 백업 데이터를 유지할 기간(일 수) — 검역 항목을 자동으로 삭제하기 전에 보관하는 일 수를 지정합니다. 1~999일 사이에서 선택합니다.
관련 작업
검역 정책 구성


프록시 설정 탭

프록시 서버는 인터넷에서 인터넷 사용자의 컴퓨터를 숨기는 인터넷 보안의 일부로서 사용되며, 자주 액세스하는 사이트를 캐시함으로써 액세스 속도를 높여줍니다.

네트워크에서 프록시 서버를 사용하는 경우에는 사용할 프록시 설정, 프록시 서버의 주소 및 인증 사용 여부를 지정할 수 있습니다. 프록시 정보는 자동 업데이트 리포지토리 목록(sitelist.xml)에 저장됩니다. 여기서 구성하는 프록시 설정은 이 리포지토리 목록의 모든 리포지토리에 적용됩니다.

참고:

이 기능은 ePolicy Orchestrator 콘솔에서는 사용할 수 없습니다. VirusScan Enterprise 8.8 콘솔에서 이 기능에 액세스합니다.

옵션 정의

옵션 정의
프록시 사용하지 않음

프록시 서버를 지정하지 않습니다.

Internet Explorer 프록시 설정 사용

현재 설치된 버전의 Internet Explorer 프록시 설정을 사용합니다.

기본값 = Internet Explorer 프록시 설정 사용

프록시 설정을 수동으로 구성

사용자의 특정 요구에 맞게 프록시 설정을 구성합니다.

예외

수동으로 프록시 설정 구성을 선택한 경우에만 사용할 수 있습니다.

프록시 예외를 지정합니다. 예외를 클릭하면 프록시 예외 대화 상자가 열립니다.
  • 예외 지정 - 이 옵션을 선택하여 프록시 예외를 입력할 수 있습니다.
  • 세미콜론(;)을 사용하여 항목 구분 - 예: internal1;internal2
HTTP

HTTP 프록시 서버의 주소를 입력합니다.

FTP

FTP 프록시 서버의 주소를 입력합니다.

포트

HTTP 또는 FTP 프록시 서버의 포트 번호를 입력합니다.

HTTP용 인증 사용

HTTP 프록시에 액세스하기 위해 지정된 자격 증명을 사용합니다.

HTTP 사용자 이름

HTTP 사용자 이름을 입력합니다.

HTTP 암호

HTTP 암호를 입력합니다.

관련 개념
자동 업데이트 리포지토리 작동 방식
관련 참조
리포지토리 목록 구성


검색 항목 탭

옵션 정의

잠재적으로 원하지 않는 프로그램 범주 중 탐지할 범주를 선택하고 탐지하지 않을 프로그램은 제외 항목으로 만듭니다.

옵션 | 정의
설정: | 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다. 참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
원하지 않는 프로그램에서 검색할 범주 선택 | 잠재적으로 원하지 않는 프로그램 범주 중 탐지할 범주를 지정합니다.
원하지 않는 프로그램 제외 | 탐지 이름별로 제외 항목을 지정합니다. 필요에 따라 항목을 추가하고 제거합니다.
관련 작업
원하지 않는 프로그램 구성
관련 정보
../../pgrestrictingunwantedprogram_chapter.ditamap


검역 정책 탭

옵션 정의

검역 위치와 검역된 항목을 보관하는 시간을 구성합니다.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
검역 디렉토리 | 검역 디렉토리의 기본 위치를 그대로 사용하거나 새 위치를 지정합니다. 기본 위치 = <시스템_드라이브>\Quarantine.
검역된 데이터 보존
  • 검역된 데이터 자동 삭제 — 지정된 기간(일수)이 경과하면 검역된 항목을 삭제합니다.
  • 검역 디렉토리에 백업 데이터를 유지할 기간(일 수) — 검역 항목을 자동으로 삭제하기 전에 보관하는 일 수를 지정합니다. 1~999일 사이에서 선택합니다.
관련 작업
검역 정책 구성


리포지토리 추가 및 편집

새 리포지토리를 추가하거나 기존 리포지토리를 편집합니다.

옵션 정의

옵션 정의
리포지토리 설명

리포지토리 이름을 지정합니다.
파일 검색 위치
파일을 검색할 위치를 선택합니다. 기본값 = HTTP 리포지토리
  • HTTP 리포지토리 - 지정한 HTTP 리포지토리 위치에서 파일을 검색합니다.
    참고: FTP와 마찬가지로 HTTP 사이트에서 네트워크 보안과 상관없이 업데이트할 수 있지만 FTP보다 높은 수준의 동시 연결을 지원합니다.
  • FTP 리포지토리 - 지정한 FTP 리포지토리 위치에서 파일을 검색합니다.
    참고: FTP 사이트에서는 네트워크 보안 권한과 상관없이 유연하게 업데이트를 수행할 수 있습니다. FTP는 일반적으로 HTTP보다 원하지 않는 코드 공격에 노출될 가능성이 적으므로 보다 유연하게 업데이트를 수행할 수 있습니다.
  • UNC 경로 - 지정한 UNC 경로 위치에서 파일을 검색합니다.
    참고: UNC 사이트는 가장 빠르고 쉽게 설치할 수 있습니다. 교차 도메인 UNC 업데이트에는 업데이트 구성을 더 자세히 설정할 수 있도록 각 도메인에 대한 보안 권한이 필요합니다.
  • 로컬 경로 - 지정한 로컬 경로 위치에서 파일을 검색합니다.
URL
HTTP 리포지토리나 FTP 리포지토리를 선택한 경우에만 사용할 수 있습니다.
  • HTTP — 업데이트 파일이 있는 HTTP 서버와 폴더의 위치를 입력합니다.
  • FTP — 업데이트 파일이 있는 FTP 서버와 폴더의 위치를 입력합니다.
경로
UNC 경로나 로컬 경로를 선택한 경우에만 사용할 수 있습니다.
  • UNC 경로 — UNC 표기법(\\servername\path\)을 사용하여 업데이트 파일이 있는 리포지토리의 경로를 입력합니다.
  • 로컬 경로 — 업데이트 파일이 있는 로컬 폴더의 경로를 입력하거나 찾아보기를 클릭하여 폴더를 찾습니다. 경로는 로컬 드라이브 또는 네트워크 드라이브의 폴더 경로가 될 수 있습니다.
포트

HTTP 리포지토리나 FTP 리포지토리를 선택한 경우에만 사용할 수 있습니다. 지정한 HTTP 또는 FTP 서버의 포트 번호를 입력합니다.

인증 사용

익명 로그인 사용

로그온 계정 사용
리포지토리에 액세스하기 위한 지정된 자격 증명을 사용합니다.
참고:

이 옵션의 제목은 파일 검색 위치 섹션에서 선택한 옵션에 따라 다릅니다.

필요한 업데이트 파일을 다운로드할 수 있도록 리포지토리에 액세스하기 위해 자동 업데이트에서 지정한 자격 증명을 사용합니다. 리포지토리의 계정 자격 증명을 구성하는 경우에는 계정에 업데이트 파일이 포함된 폴더에 대한 읽기 권한이 있는지 확인합니다.
  • FTP 및 UNC 리포지토리의 경우에는 다운로드 자격 증명이 필요하지만 HTTP 리포지토리의 경우에는 옵션입니다.
  • FTP 업데이트는 익명 리포지토리 연결을 지원합니다.
  • UNC 업데이트의 경우 로그온된 계정을 사용할 수도 있으므로 로그온된 사용자의 권한으로 리포지토리에 액세스할 수 있습니다.
사용자 이름

사용자 이름을 입력합니다.
암호

암호를 입력합니다.
확인

암호를 다시 입력하고 암호를 확인합니다.
관련 개념
자동 업데이트 리포지토리 작동 방식
관련 참조
리포지토리 목록 구성


리포지토리 탭

업데이트를 가져오는 리포지토리를 구성합니다.
참고:

이 기능은 ePolicy Orchestrator 콘솔에서는 사용할 수 없습니다. VirusScan Enterprise 8.8 콘솔에서 이 기능에 액세스합니다.

옵션 정의

옵션 정의
리포지토리 설명

리포지토리 이름을 지정합니다.

이 목록은 HTTP 및 FTP 리포지토리와 함께 미리 구성됩니다.
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

HTTP 리포지토리는 기본 다운로드 사이트입니다.
상태

사용 - 자동 업데이트 프로세스 중 사용할 수 있는 정의된 리포지토리

사용 안 함 - 자동 업데이트 프로세스 중에 액세스하지 않을 정의된 리포지토리 항상 사용하는 리포지토리가 아니라 간혹 사용하는 리포지토리입니다.

참고: 필요한 만큼 리포지토리를 만든 후 사용하거나 사용하지 않습니다.
추가

목록에 새 리포지토리를 추가합니다.
편집

선택한 리포지토리를 편집합니다.
삭제

선택한 리포지토리를 삭제합니다.
위로 이동

선택한 리포지토리를 목록에서 위로 이동합니다.
아래로 이동

선택한 리포지토리를 목록에서 아래로 이동합니다.
관련 개념
자동 업데이트 리포지토리 작동 방식
관련 참조
리포지토리 목록 구성


관리자 탭

목록에서 항목을 선택한 다음 마우스 오른쪽 단추를 클릭하여 고급 옵션에 액세스합니다. 다시 검색하고 잘못된 긍정이 있는지 검사하고 속성을 복원, 삭제 또는 볼 수 있습니다.

관련 작업
검역 정책 구성


작업 탭

옵션 정의

복원 위치에 대한 액세스 권한을 가진 사용자의 계정 정보를 지정합니다. 계정을 입력하지 않으면 복원 작업은 시스템 계정으로 실행됩니다.

옵션 | 정의
사용자 | 복원 위치에 대한 액세스 권한을 가진 사용자 이름을 입력합니다.
암호 | 지정된 사용자에 대한 암호를 입력합니다.
도메인 | 지정된 사용자에 대한 도메인을 입력합니다.
관련 작업
검역 정책 구성


검색 위치 탭

옵션 정의

검색할 항목 유형 및 위치를 구성합니다.

옵션 정의
검색할 위치 검색할 위치를 선택합니다. 기본값 = 루트킷에서 사용하는 메모리, 실행 중인 프로세스, 모든 로컬 드라이브, 레지스트리 및 쿠키. 추가, 편집 및 제거를 클릭하여 항목 이름을 변경합니다.
  • 루트킷에서 사용하는 메모리. 설치된 루트킷, 숨겨진 프로세스 및 악성 코드가 자신을 숨기려고 함을 암시하는 기타 동작에 대해 시스템 메모리를 검색합니다. 이 검색은 다른 모든 검색보다 먼저 수행됩니다.
    주의:
    루트킷에서 사용하는 메모리 검색을 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • 실행 중인 프로세스. 실행 중인 모든 프로세스의 메모리를 검색합니다. 치료 이외의 액션은 검색 계속으로 처리됩니다.
    주의:
    실행 중인 프로세스 검색을 활성화하지 못하면 많은 악성 프로그램 공격으로부터 시스템이 보호되지 않습니다.
  • 등록된 파일. 등록된 모든 파일을 검색합니다. 스캐너는 먼저 레지스트리에서 파일 이름을 검색한 다음 파일을 검색합니다. 스캐너는 레지스트리에서 잠재적으로 원하지 않는 파일에 대한 참조를 제거합니다.
  • 내 컴퓨터. 컴퓨터에 물리적으로 연결된 모든 드라이브 또는 드라이브 문자에 논리적으로 매핑된 모든 드라이브를 검색합니다.
  • 모든 로컬 드라이브. 컴퓨터의 모든 드라이브와 하위 폴더를 검색합니다.
  • 모든 고정 드라이브. 컴퓨터에 물리적으로 연결된 모든 드라이브를 검색합니다.
  • 모든 이동식 드라이브. 컴퓨터에 연결된 모든 이동식 드라이브나 기타 저장 장치를 검색합니다.
  • 매핑된 모든 드라이브. 컴퓨터의 네트워크 드라이브에 논리적으로 매핑된 네트워크 드라이브를 검색합니다.
  • 홈 폴더. 검색을 시작한 사용자의 홈 폴더를 검색합니다.
  • 사용자 프로파일 폴더. 사용자의 내 문서 폴더를 포함하여 검색을 시작하는 사용자의 프로파일을 검색합니다.
  • Windows 폴더. Windows 폴더의 내용을 검색합니다.
  • Program Files 폴더. Program Files 폴더의 내용을 검색합니다.
  • Temp 폴더. Temp 폴더의 내용을 검색합니다.
  • 휴지통. 휴지통의 내용을 검색합니다.
  • 드라이브 또는 폴더. 지정된 드라이브나 폴더를 검색합니다.
  • 파일. 지정된 파일을 검색합니다.
  • 쿠키. 쿠키 폴더에서 쿠키를 검색합니다.
  • 레지스트리. 레지스트리 항목을 검색합니다.
참고: 검색 항목의 기본 목록을 사용하면 결과적으로 시간이 많이 걸리지만 철저한 검색이 수행될 수 있습니다. 정기적으로 사용할 수 있도록 이러한 검색의 범위를 좁힐 것인지 생각해 보십시오.
주문형 검색 진행 대화 상자가 나타나면 검색할 위치가 검색 위치 다음에 쉼표로 구분된 문자열로 나타납니다. 모든 검색 프로세스가 완료되면 문자열에서 제거됩니다.
검색 옵션 선택한 항목에 대한 검색 유형입니다.
  • 하위 폴더 포함 — 스캐너는 지정된 볼륨의 모든 하위 폴더를 검사합니다. 이 옵션의 선택을 취소하면 볼륨의 루트 레벨만 검색합니다.
  • 부트 섹터 검색 — 스캐너는 디스크 부트 섹터를 검사합니다.
검색할 수 없는 고유하거나 비정상적인 부트 섹터가 디스크에 있으면 부트 섹터 검색을 사용하지 않는 것이 좋습니다.
관련 참조
주문형 검색 작업 탭 구성
관련 정보
온액세스 항목 검색


고급 예약 옵션

예약 매개 변수를 구성합니다.

옵션 정의

옵션 | 정의
시작 날짜 | 이 작업을 시작하는 날짜를 지정합니다.
종료 날짜 | 이 작업이 종료되는 날짜를 지정합니다.
작업 반복 | 지정된 빈도에 따라 작업을 반복합니다. 이 옵션을 선택하는 경우에는 이 작업을 반복하는 빈도도 지정합니다.
매 | 이 작업을 반복하는 빈도를 지정합니다. 빈도가 시간 또는 분 단위인지도 선택합니다.
시간(로컬) | 지정한 로컬 시간에 이 작업을 반복합니다. 이 옵션을 선택하는 경우에는 특정 시간도 선택합니다.
기간 | 지정된 시간 및 분 동안 이 작업을 반복합니다. 이 옵션을 선택하는 경우에는 시간 및 분도 선택합니다.
시간 | 시간(시)을 설정합니다. 0~99 사이에서 선택합니다.
분 | 시간(분)을 설정합니다. 0~59 사이에서 선택합니다.
관련 개념
업데이트 작업 및 수행 방법
관련 참조
자동 업데이트 작업 구성


예약 탭

이 작업에 대해 예약 빈도와 기타 설정을 지정합니다.

옵션 정의

옵션 정의
런타임

작업을 실행하고 다음 옵션에서 이 작업에 대한 빈도를 선택합니다.

매일 - 지정된 요일에 작업을 실행합니다.

매일 작업은 여러 날 동안 매일 또는 월요일부터 일요일까지 매일 실행될 수 있습니다. 월요일부터 일요일까지 매일이 아니라 특정 요일에만 작업을 실행하려면 작업 빈도를 매주로 설정하는 것이 좋습니다.

매주 - 지정된 주와 요일에 작업을 실행합니다.

매월 - 지정된 날짜와 월에 작업을 실행합니다.

한 번 - 지정된 날짜에 작업을 한 번만 실행합니다.

시작할 때 - 시스템을 시작할 때 작업을 실행하고 작업을 하루에 한 번씩 실행할 것인지 여부와 작업 지연 시간(분)을 지정합니다.

로그온 시 - 로그온할 때 작업을 실행하고 작업을 하루에 한 번씩 실행할 것인지와 작업 지연 시간(분)을 지정합니다.

유휴 모드 시 - 컴퓨터가 유휴 상태일 때 작업을 실행하고 작업을 시작하기 전에 컴퓨터의 유휴 상태 시간(분)을 지정합니다.

작업이 시작되면,작업이 완료되기 전에 사용자가 컴퓨터를 다시 사용하는 경우에도 작업은 완료될 때까지 계속 수행됩니다.

즉시 - 작업을 즉시 실행합니다.

전화 접속 시 - 전화 접속 시 작업을 실행합니다.

시작 시간

예약된 작업의 시작 시간을 선택합니다.

UTC 시간

UTC(Coordinated Universal Time)입니다. 모든 표준 시간대에서 동시에 작업을 실행하려면 이 옵션을 선택합니다.

로컬 시간

각 현지 표준 시간대에서 개별적으로 작업을 실행합니다.

참고: 기본값 = 로컬 시간
임의 추출 활성화

설정한 시간 간격 내의 임의의 시점에 작업을 실행합니다.

이 옵션을 선택하는 경우에는 최대 시간 경과에 대한 시간 및 분도 지정합니다.

참고:

최소 1분에서 최대 23시간 사이의 시간 경과 간격을 지정합니다. 예를 들어, 작업 예약을 1:00로 설정하고 임의 추출을 3시간으로 설정하면 1:00와 4:00 사이의 임의의 시간에 작업이 실행됩니다.

시작할 때, 로그온 시 또는유휴 모드 시로 작업을 예약하는 경우에는 이 옵션을 사용할 수 없습니다.

시간

시간(시)을 설정합니다. 0~23시간 사이에서 선택합니다.

분

시간(분)을 설정합니다.

참고:
선택할 수 있는 시간(분)은 선택한 옵션에 따라 다릅니다. 예:
  • 임의 추출 사용 - 0 ~ 59분 사이에서 선택합니다.
  • 누락된 작업 지연 시간 - 0~99분 사이에서 선택합니다.
누락된 작업 실행

컴퓨터가 다시 시작되면 누락된 작업이 실행됩니다. 작업 실행이 예약되어 있는데 컴퓨터가 오프라인 상태인 경우 작업 실행이 누락될 수 있습니다.

참고: 이 기능은 작업 실행이 예약되어 있는데 오프라인 상태가 될 경우 원격 사용자 및 네트워크를 완벽하게 보호합니다.
누락된 작업 지연 시간

누락된 작업을 지연시킬 시간(분)을 선택합니다. 0~99분 사이에서 선택합니다.

매

지정한 기간 동안 매일 이 작업을 실행합니다. 0~9999일 사이에서 선택합니다.

참고: 매일로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.
매주

지정한 기간 동안 매주 이 작업을 실행합니다. 0~99주 사이에서 선택합니다.

이 옵션을 선택하는 경우에는 주 수와 요일도 지정합니다.

참고:

해당 월의 요일은 일요일, 월요일, 화요일, 수요일, 목요일, 금요일 및 토요일 중에서 선택합니다.

매주로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.

날짜

해당 월의 특정 날짜에 이 작업을 실행합니다. 1~31일 사이에서 선택합니다.

이 옵션을 선택하는 경우에는 해당 월의 날짜 수도 지정합니다.

참고: 매월로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.
평일

지정한 월의 특정 요일에 이 작업을 실행합니다.

이 옵션을 선택하는 경우에는 해당 월의 주 수 및 날짜도 선택합니다.

참고:

주 수는 첫 번째, 두 번째, 세 번째 및 마지막 중에서 선택합니다.

해당 월의 요일은 일요일, 월요일, 화요일, 수요일, 목요일, 금요일 및 토요일 중에서 선택합니다.

매월로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.

월 선택

이 작업을 실행할 월을 지정합니다.

참고: 매월로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.
실행 날짜

이 작업을 실행하고자 하는 날짜를 지정합니다.

참고: 한 번으로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.
이 작업은 하루에 한 번만 실행됩니다.

이 작업을 하루에 한 번씩 실행합니다.

참고:

이 옵션을 선택하지 않으면 시작 또는 로그온할 때마다 작업이 실행됩니다.

시작할 때, 로그온 시 또는전화 접속 시로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.

작업 지연 시간

이 작업이 지연되는 시간(분)을 지정합니다. 0~99 사이에서 선택합니다.

참고:

사용자가 로그온하여 로그온 스크립트가 실행되기까지 허용되는 시간입니다.

시작할 때 또는 로그온 시로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.

컴퓨터가 유휴 상태인 시간

작업을 시작하기 전에 컴퓨터가 유휴 모드 시간(분)을 지정합니다. 0~999분 사이에서 선택합니다.

참고:

작업이 시작되면,작업이 완료되기 전에 사용자가 컴퓨터를 다시 사용하는 경우에도 작업은 완료될 때까지 계속 수행됩니다.

유휴 모드 시로 작업을 예약한 경우에만 이 옵션을 사용할 수 있습니다.

Advanced(고급)

고급 옵션을 구성합니다.

참고: 자세한 내용은 고급 예약 옵션을 참조하십시오.
관련 개념
업데이트 작업 및 수행 방법
관련 참조
자동 업데이트 작업 구성


작업 탭

이 작업에 대한 예약을 사용하고 사용자 계정 설정을 지정합니다.

옵션 정의

옵션 | 정의
(지정된 시간에 예약된 작업 실행)사용 | 지정된 시간에 작업이 실행되도록 예약합니다. 참고: 이 옵션을 선택해야 작업을 예약할 수 있습니다.
[실행하는 경우 작업 중지] | 지정한 기간(시간 및 분)이 지나면 작업이 중지됩니다. 참고: 완료되기 전에 작업이 중단되면 다음 시작 시 중단되었던 지점부터 검색이 다시 시작됩니다.
시간 | 경과하면 작업이 중지되는 시간(시)입니다.
분 | 경과하면 작업이 중지되는 시간(분)입니다.
사용자 | 이 작업이 실행되는 사용자 ID를 입력합니다. 참고: 자격 증명 사용은 옵션입니다. 자격 증명을 입력하지 않으면 예약된 작업이 로컬 시스템 계정으로 실행됩니다. 자세한 내용은 로그온 권한을 참조하십시오.
도메인 | 지정한 사용자 ID에 대한 도메인을 입력합니다.
암호 | 지정한 사용자 ID와 도메인에 대한 암호를 입력합니다.
관련 개념
업데이트 작업 및 수행 방법
관련 참조
자동 업데이트 작업 구성


ScriptScan 탭

옵션 정의

원하지 않는 스크립트가 실행되지 못하도록 합니다.

자세한 내용은 스크립트 검색 및 수행 방법을 참조하십시오.

옵션 | 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
ScriptScan | 스크립트 검색 활성화 — JavaScript 및 VBScript 스크립트를 검색한 다음 실행합니다.
ScriptScan 프로세스 제외 | 프로세스 — 프로세스 이름별로 ScriptScan 제외 항목을 지정합니다. 프로세스 이름을 지정할 때는 대표 문자를 사용할 수 없습니다.
ScriptScan URL 제외 URL —ScriptScan URL 제외를 URL별로 지정합니다. 참고 다음을 참조하십시오.
  • URL을 지정할 때 와일드카드를 사용할 수 없습니다. 그러나, 예를 들어 URL msn.com이 제외되는 경우 해당 문자열이 있는 URL은 검색에서 제외됩니다. 예를 들어 다음 URL은 제외됩니다.
    • http://weather.msn.com
    • http://music.msn.com
  • Windows Server 2008에서 스크립트 검색 URL 제외는 타사의 브라우저 확장 기능 사용 확인란을 클릭하여 설정을 활성화하고 Windows Server 2008을 다시 시작하지 않는 한 Windows Internet Explorer에서 작동하지 않습니다. 자세한 내용은 https://kc.mcafee.com/corporate/index?page=content&id=KB69526를 참조하십시오.
관련 작업
일반 설정 구성
관련 정보
온액세스 항목 검색


사용자 정의 탐지 탭

옵션 정의

원하지 않는 프로그램으로 처리할 개별 파일이나 프로그램을 지정합니다.

옵션 정의
설정: 드롭다운 목록에서 워크스테이션 또는 서버를 선택합니다.
참고: 이 옵션은 ePolicy Orchestrator를 통해서만 사용할 수 있습니다.
사용자 정의 항목
  • 파일 이름 — 탐지할 파일 또는 프로그램의 이름을 지정합니다.

  • 설명 — 지정된 파일이 탐지되었을 때 통보에 표시할 설명을 지정합니다.

참고: 스캐너는 0바이트 크기인 사용자 정의된 원하지 않는 프로그램은 탐지하지 않습니다.
관련 작업
일반 설정 구성
관련 정보
온액세스 항목 검색