Предисловие

Для эффективного использования данного документа требуется понять, для кого именно предназначен этот документ, ознакомиться с условными обозначениями, с содержанием документа, а также с источниками другой справочной документации.

Содержание

  • Аудитория
  • Условные обозначения
  • Организация данного руководства
  • Поиск документации по продукту


Аудитория

Документация McAfee была тщательно проработана и составлена в соответствии с требованиями целевой аудитории.

Информация, содержащаяся в данном руководстве, в основном рассчитана на следующих лиц.
  • Администраторы: специалисты, которые устанавливают и вводят в действие программу, обеспечивающую информационную безопасность компании.
  • Пользователи: сотрудники компании, которые настраивают или обновляют программу на своих компьютерах.


Условные обозначения

В этом руководстве используются следующие условные обозначения.
Название книги или выделение | Название книги, главы или темы; введение нового термина; выделение.
Жирный шрифт | На данном тексте акцентируется внимание.
Пользовательский ввод или путь | Команды и другой текст, который вводится пользователем; путь к папке или программе.
Код | Пример кода.
Интерфейс пользователя | Слова, входящие в интерфейс пользователя, в том числе параметры, меню, кнопки и диалоговые окна.
Гипертекст синего цвета | Действующая ссылка на тему или веб-сайт.
Примечание | Дополнительная информация, например альтернативный способ получения доступа к параметру.
Совет | Предложения и рекомендации.
Внимание! | Ценный совет по защите компьютера, безопасной установке программного обеспечения, защите сети, бизнеса или данных.
Предупреждение | Важный совет по предотвращению телесных повреждений при работе с аппаратным обеспечением.


Организация данного руководства

Данный документ следует использовать как справочное пособие при работе с интерфейсами пользователя Консоль VirusScan и ePolicy Orchestrator. В нем также указана последовательность действий по обеспечению защиты системы от вредоносных программ с помощью VirusScan Enterprise. Описание этого процесса в документе представлено в четырех отдельных частях и приложении.
  • Часть I. Предотвращение угроз Лучшим способом защиты системы является предотвращение к ней доступа любых вредоносных программ. Ниже приведены темы, которым посвящена данная часть документа.
    • Защита точек доступа системы, защита памяти от ошибок переполнения и защита от нежелательных программ.
    • Определения обнаружений и их использование для защиты системы; значимость регулярных обновлений данных определений.
    • Исключение из сканирования файлов, папок и содержимого дисков.
    • Использование запланированной задачи для периодического сканирования системы и обновление файлов, используемых в VirusScan Enterprise.
  • Часть II. Обнаружение угроз Файлы, открываемые или копируемые из других файловых систем или Интернета, могут обеспечить доступ к системе. Угроза для системы также исходит от вызовов и сценариев API (Application Programming Interface). Обнаружение этих угроз возможно в ходе перечисленных ниже процессов сканирования VirusScan Enterprise.
    • Проверка при доступе: сканирование файла на наличие вредоносных программ во время его чтения или записи на диск. При такой проверке также обеспечивается защита загрузочных секторов, сканируется память запущенных процессов, происходит обнаружение файлов cookie и обеспечивается защита от нежелательных программ.
    • Проверка по требованию: сканирование всей систем на наличие угроз, запланированное или выполняемое при необходимости при запуске с Консоль VirusScan.
    • Проверка электронной почты при доставке и по требованию: защита от вредоносных программ, проникающих через электронную почту в Microsoft Outlook и Lotus Notes.
    • Защита от переполнения буфера: анализ вызовов API, инициированных определенными процессами, который позволяет определить, не будут ли перезаписаны соседние данные в буфере памяти.
    • ScriptScan: поиск угроз, исходящих от обозревателей или других приложений, к которым осуществляется доступ и в которых используется Windows Script Host.
  • Часть III. Ответ на угрозы VirusScan Enterprise можно настроить на выполнение любого из представленных действий в том случае, если обнаружена какая-либо угроза.
    • Запрет доступа к угрозе или отказ от выполнения любых последующих действий.
    • Удаление или очистка угрозы. При любом из этих действий в карантиновой папке сохраняется копия исходного файла.
    ПРИМЕЧАНИЕ: При любом способе обнаружения можно настроить VirusScan Enterprise, указав, требуется ли уведомлять пользователя.
  • Часть IV. Мониторинг, анализ и точная настройка защиты После настройки и запуска механизма защиты требуется контролировать работу системы, используя запросы и отчеты ePolicy Orchestrator. Если в ходе контроля потребуется повысить или понизить степень защиты системы, можно внести соответствующие изменения в настройки параметров защиты. Для мониторинга систем можно также использовать журналы Консоль VirusScan и ловушки протокола SNMP (Simple Network Management Protocol).
  • Приложение В приложении дается описание ряда дополнительных функций, о которых требуется знать при использовании VirusScan Enterprise. Например, параметры командной строки VirusScan Enterprise, подключение к удаленным системам через VirusScan Enterprise и другие.


Поиск документации по продукту

McAfee предоставляет всю необходимую информацию на каждом этапе внедрения продукта: от установки до использования и устранения неполадок. После выпуска продукта сведения о нем вводятся в интерактивную базу знаний McAfee.
  1. Перейдите на портал McAfee Technical Support ServicePortal по адресу: http://mysupport.mcafee.com.
  2. В разделе Self Service (Самообслуживание) найдите необходимую информацию.
    Для доступа... Действия
    Документация пользователя

    1. Щелкните Product Documentation (Документация по продукту).

    2. Выберите Product (Продукт), а затем выберите Version (Версия).

    3. Выберите документ по продукту.

    База знаний
    • Щелкните Search the KnowledgeBase (Поиск в базе знаний), чтобы найти ответы на вопросы по продукту.
    • Щелкните Browse the KnowledgeBase (Просмотр базы знаний) для просмотра списка статей по продукту и версии.


Начало работы

Понимание компонентов программного обеспечения McAfee® VirusScan® Enterprise 8.8 и порядок настройки этого программного обеспечения помогают защитить систему от угроз.

Содержание

  • Знакомство с VirusScan Enterprise
  • Компоненты и принцип их взаимодействия
  • Значение создания стратегии защиты
  • Консоль VirusScan и доступ к ней
  • С чего начать


Знакомство с VirusScan Enterprise

Сразу после установки программное обеспечение VirusScan Enterprise выполняет защиту системы от угроз. Можно усилить степень защиты, если известно, какие действия выполняет программное обеспечение, какие новшества появились в этом выпуске и каковы его основные компоненты.

Назначение и функции

VirusScan Enterprise обеспечивает легко масштабируемую защиту, высокую скорость работы и мобильность, позволяющие эффективно защищать среду от следующих угроз:

  • вирусов, червей, «троянских коней»;
  • проникновений через точки доступа и переполнения буфера в результате атаки;
  • потенциально нежелательных кодов и программ.

Программное обеспечение обнаруживает угрозы, а затем выполняет действия, настроенные для защиты среды.

Можно настроить программное обеспечение как автономный продукт или использовать McAfee® ePolicy Orchestrator® версии 4.0 или более поздней версии для управления и применения политик VirusScan Enterprise, а затем использовать запросы и панели мониторинга для отслеживания активности и обнаружений.

ПРИМЕЧАНИЕ: В этом документе описано использование ePolicy Orchestrator 4.0, 4.5 и 4.6. Сведения об использовании этих версий ePolicy Orchestrator см. в документации по соответствующей версии.

Новшества

Эта версия отличается следующими новшествами.
  • Повышенная производительность.
  • Возможность для ePolicy Orchestrator 4.5 и 4.6 управлять системами VirusScan Enterprise.
  • Новая функция исключения URL-адресов ScriptScan позволяет настраивать исключения, а не изменять реестр вручную.
  • Приложение AntiSpyware Enterprise Module полностью интегрировано в программное обеспечение VirusScan Enterprise 8.8.
  • Поддержка сканирования электронной почты Outlook 2010.
  • Поддержка сканирования электронной почты Lotus Notes 8.0x — 8.5.1.


Компоненты и принцип их взаимодействия

Если вы являетесь администратором и пользователем VirusScan Enterprise, вам необходимо знать компоненты и соединения этой программы. На приведенном рисунке представлены компоненты этой программы, применяемые в базовой среде.

Рисунок 1. Компоненты VirusScan Enterprise

Клиентская система

Система, в которой выполняется установка и настройка VirusScan Enterprise и дополнительного McAfee Agent.
  • Файлы DAT: файлы определения обнаружений, называемые также сигнатурами вредоносных программ. Совместно с механизмом сканирования они отвечают за обнаружение угроз и выполнение соответствующих действий по их устранению.
  • Механизм сканирования: используется для сканирования файлов, папок и дисков клиентского компьютера и для сравнения их с информацией файлов DAT об известных вирусах.
    ПРИМЕЧАНИЕ: Обновление файлов DAT и механизма сканирования выполняется по мере необходимости через Интернет-соединение со штаб-квартирой McAfee или с помощью дополнительных соединений через корпоративный интранет-портал с назначенным сервером.
  • Artemis (эвристическая проверка наличия подозрительных файлов в сети: поиск подозрительных программ и библиотек DLL, запущенных в клиентских системах, защищенных VirusScan Enterprise. При обнаружении подозрительной программы система защиты от вредоносных программ, действующая в режиме реального времени, отправляет DNS-запрос, содержащий контрольную сумму подозрительного файла, на центральный сервер базы данных McAfee Labs.
  • McAfee Agent (дополнительно): обеспечивает безопасную связь между продуктами, управляемыми McAfee, и сервером McAfee ePolicy Orchestrator. Данный агент также предоставляет такие локальные службы, как обновление, журналирование, создание отчетов о событиях и свойствах, планирование задач, связь и хранение политик.

Штаб-квартира McAfee

Штаб-квартира McAfee, в которую входит McAfee Labs и Служба технической поддержки McAfee, предоставляет следующие услуги VirusScan Enterprise:
  • Обновления DAT: эти обновления хранятся в центральной базе данных сервера McAfee и с помощью AutoUpdate эти файлы обновлений DAT можно копировать на клиенты VirusScan Enterprise или в дополнительные хранилища DAT. Тем самым можно получить информацию о способах борьбы с известными угрозами, а также списки известных вирусов (по мере их обнаружения в режиме реального времени).
  • Обновления механизма сканирования: эти обновления хранятся в центральной базе данных сервера и загружаются по мере необходимости с целью использования самых последних версий механизма сканирования VirusScan Enterprise.
  • McAfee Labs: данная библиотека угроз содержит подробные сведения о таких угрозах, как вирусы, «троянские кони», hoax-программы и потенциально нежелательные программы (источник возникновения, влияние на систему и способы борьбы). С помощью функции Artemis контрольная сумма подозрительного файла направляется в McAfee Labs, где выполняется анализ файла и определяются дальнейшие действия.

Сервер

Для удаленного управления и обновления многих клиентских систем в дополнительном сервере используются следующие компоненты.
  • ePolicy Orchestrator: обеспечивает централизованное управление и соблюдение политик VirusScan Enterprise, а затем с помощью запросов и панелей мониторинга отслеживает активность и обнаружения.
    ПРИМЕЧАНИЕ: В этом документе описано использование ePolicy Orchestrator 4.0, 4.5 и 4.6. Для получения сведений о ePolicy Orchestrator см. документацию по используемой версии продукта.
  • Хранилище DAT: получение обновлений DAT с сайта загрузки McAfee. С него файлы DAT реплицируются на все компьютеры организации. При этом сводится к минимуму объем данных, передаваемых по сети, путем автоматизации процесса копирования обновленных файлов на общие сайты.


Значение создания стратегии защиты

Для защиты клиентских систем от вирусов, червей и троянских программ с помощью VirusScan Enterprise требуется хорошо спланированная стратегия: определение способов обнаружения и предотвращения угроз, ответов на угрозы, текущий анализ и настройка.

Предотвращение угроз

Определите, что необходимо для обеспечения защиты ваших источников данных, затем разработайте эффективную стратегию предотвращения вторжений в вашу среду. Настройте следующие функции для предотвращения вторжений.
  • Защита интерфейса пользователя: настройка защиты при отображении и защиты паролем для контроля доступа к интерфейсу пользователя VirusScan Enterprise.
  • Защита доступа: применение правил защиты доступа для обеспечения защиты компьютера от нежелательных действий с файлами, реестрами и портами.
  • Защита от переполнения буфера: предотвращение выхода за границы буфера и замены данных в смежных ячейках памяти нестандартными программами или угрозами при записи данных в буфер. При переполнении буфера в результате атаки на вашем компьютере возможно выполнение произвольного кода.
  • Защита от нежелательных программ: устранение потенциально нежелательных программ, например шпионских программ и программ для показа рекламы, с вашего компьютера.

Обнаружение угроз

Разработайте эффективную стратегию для обнаружения вторжений. Настройте следующие функции для обнаружения угроз.
  • Задача обновления: получение автоматических обновлений файлов DAT и механизма сканирования с веб-сайта загрузки McAfee.
  • Сканер при доступе: обнаружение возможных угроз из любого источника при чтении файлов с диска или записи на диск. Можно также выполнить сканирование потенциально нежелательных файлов cookie в соответствующей папке.
  • Задачи проверки по требованию: обнаружение потенциальных угроз путем выполнения задач немедленной или запланированной проверки. Можно также выполнить сканирование потенциально нежелательных файлов и записей в реестре для шпионского программного обеспечения, которые не были удалены ранее.
  • Сканер электронной почты при доставке и по требованию: обнаружение возможных угроз в клиентах электронной почты Microsoft Outlook путем проверки сообщений, вложений и общих папок при доставке. Обнаружение потенциальных угроз в клиентах электронной почты Lotus Notes при доступе к сообщениям.
  • Политика Quarantine Manager: определение карантинной папки, а также продолжительности времени хранения в ней файлов. Восстановление элементов из карантина, когда это необходимо.

Ответ на угрозы

Используйте файлы журналов продукта, автоматические действия и другие функции уведомления для определения наилучшего способа обработки обнаружений.
  • Действия: настройка функций для выполнения действий в отношении обнаружений.

  • Файлы журнала: отслеживание содержимого файлов журналов продукта и просмотр истории обнаруженных элементов.

  • Запросы и панели мониторинга: использование запросов и панелей мониторинга ePolicy Orchestrator для отслеживания активности сканирования и обнаружений.

Настройка: отслеживание, анализ и точная настройка защиты.

После первоначальной настройки VirusScan Enterprise полезно провести контроль работы и анализ конфигурации. Это может повысить производительность системы и сети, а также усилить защиту от вирусов, если это необходимо. Например, в процессе отслеживания, анализа и точной настройки можно изменить следующие инструменты и функции VirusScan Enterprise.
  • Файлы журналов (Консоль VirusScan): просмотр истории обнаруженных элементов. Анализ этих сведений позволяет определить, необходимо ли усилить защиту или изменить конфигурацию для повышения производительности системы.
  • Запросы и панели мониторинга (консоль ePolicy Orchestrator): отслеживание активности сканирования и обнаружений. Анализ этих сведений позволяет определить, необходимо ли усилить защиту или изменить конфигурацию для повышения производительности системы.
  • Запланированные задачи: изменение задач (например, AutoUpdate) и времени сканирования для повышения производительности путем их запуска в периоды низкой нагрузки.
  • Хранилища DAT: снижение сетевого трафика через Интернет или внутреннюю сеть предприятия путем перемещения исходных файлов ближе к клиентским системам, для которых требуются обновления.
  • Изменение политик сканирования: повышение производительности или усиление защиты от вирусов в соответствии с анализом файлов журналов или запросов. Например, настройка исключений, условий для сканирования профилей, подвергающихся высокому и низкому риску, а также условий отключения сканирования при записи, может повысить производительность.
    ОСТОРОЖНО:
    Если не включить параметр сканирования При чтении с диска, система может остаться без защиты от многочисленных вредоносных атак.


Консоль VirusScan и доступ к ней

Консоль VirusScan — это интерфейс для автономной версии действий программы. Она используется для настройки, мониторинга и обновления продукта.
ПРИМЕЧАНИЕ: Данная информация применима только к автономной версии продукта. Она не распространяется на версию под управлением ePolicy Orchestrator.


Консоль VirusScan и принципы ее работы

Разобравшись в принципах работы программы VirusScan Enterprise и ее компонентов, можно перейти к вопросу о доступе к функциям программы. Консоль VirusScan Enterprise 8.8 можно открыть одним из следующих способов.
  • В меню Пуск выберите Программы | McAfee | Консоль VirusScan.
  • Щелкните правой кнопкой мыши значок щита VirusScan Enterprise на панели задач и выберите Консоль VirusScan.

Строка меню

Элементы меню служат для создания задач, настройки свойств и доступа к дополнительным сведениям.
  • Задача: создание и настройка задач, таких как сканирование на наличие угроз или обновление файлов DAT.
  • Изменить: копирование, вставка, удаление или переименование выбранной задачи.
  • Просмотр: отображение панели инструментов и строки состояния, а также обновление экрана.
  • Сервис: настройка параметров интерфейса для пользователей, блокировка и разблокировка защиты интерфейса пользователя, настройка предупреждений, доступ к средству просмотра событий, открытие удаленной консоли при наличии прав администратора, импорт и изменение списка хранилищ, а также откат файлов DAT.
  • Справка: доступ к разделам справки в Интернете, библиотеке угроз Threat Library на веб-сайте McAfee Labs, доступ к веб-сайту отправки образцов и веб-сайту технической поддержки. Кроме того, можно восстановить установку продукта и просмотреть в диалоговом окне О программе сведения об авторских правах, а также установленных версиях продукта, лицензии, файлов определений обнаружений, механизма сканирования, файла extra.dat и исправлений.
ПРИМЕЧАНИЕ: Каждому элементу меню соответствует определенное сочетание клавиш. В некоторых операционных системах данные сочетания клавиш могут быть недоступны, за исключением случаев, когда для доступа к меню используются клавиши F10 или ALT.

Панель инструментов

Для доступа к часто используемым командам, приведенным ниже, используются специальные значки.
  • Отображение свойств выбранной задачи.
  • Запуск выбранной задачи.
  • Остановка выбранной задачи.
  • Копирование выбранной задачи.
  • Вставка выбранной задачи.
  • Удаление выбранной задачи.
  • Настройка свойств предупреждений.
  • Запуск средства просмотра событий.
  • Доступ к библиотеке сведений на веб-сайте McAfee Labs.
  • Подключение к удаленному компьютеру при наличии прав администратора.
  • Создание задачи проверки по требованию.

Список задач

Отображаются задачи по умолчанию и созданные пользователем задачи, а также состояние и последний результат каждой из задач.

Строка состояния

Отображается состояние текущей операции.


Использование функций, вызываемых правой кнопкой мыши

Функции, вызываемые правой кнопкой мыши, используются для быстрого доступа к часто используемым действиям, таким как создание задач, просмотр статистики журналов задач, открытие страниц свойств задач, сканирование определенного файла или папки или немедленное выполнение задачи обновления.

Описания функций

Местоположение | Описание | Примеры
Консоль Щелкните правой кнопкой мыши Консоль VirusScan, чтобы отобразить функции, вызываемые правой кнопкой мыши. В зависимости от того, выбрана ли задача в списке задач и какая задача выбрана, набор доступных функций может быть разным.
  • В консоли щелкните задачу правой кнопкой мыши, чтобы открыть ее свойства. В зависимости от выбранной задачи могут быть доступны такие возможности, как запуск, остановка, включение или выключение задачи, а также просмотр статистики и журнала активности. В некоторых случаях может быть доступно переименование или удаление задачи.
  • Щелкните правой кнопкой мыши пустую область консоли, чтобы создать новую задачу сканирования или обновления.
Проводник Windows Щелкните правой кнопкой мыши выбранный файл или папку, чтобы немедленно выполнить Сканирование на предмет наличия угроз. Можно выбрать действие для сканирования.
  • Очистить: составление отчета об обнаружении элемента и очистка этого элемента.
  • Продолжить: составление отчета об обнаружении элемента и продолжение сканирования.

Выполнить немедленное сканирование файла или папки, которые, по вашему мнению, могут быть опасными.

При запуске сканирования сканер, запускаемый по требованию, вызывается напрямую со всеми настройками сканирования. Выберите необходимое действие. Другие настройки сканирования изменять нельзя.

Панель задач | В разделе Значки на панели задач и принцип их работы приведены описания значков элементов VirusScan Enterprise, вызываемых правой кнопкой мыши.


Значки на панели задач и принцип их работы

После установки VirusScan Enterprise на панели задач Windows отобразится один из следующих значков, если в процессе установки была задана соответствующая возможность.

Буква «M» на значке щита

Отображается в системах под управлением ePolicy Orchestrator, в которых установлена программа McAfee Agent версии 4.5 или более поздней версии. Значок обеспечивает следующую информацию.
  • Состояние: значок не меняется при отображении предупреждений о защите доступа а также если функция проверки при доступе отключена на клиентах под управлением ePolicy Orchestrator, в которых используется McTray версии 2.x или более поздней (McAfee Agent 4.5 или более поздней версии). Изменения состояний отображаются во всплывающих подсказках.
  • Всплывающие подсказки: ниже перечислены возможные всплывающие подсказки.
    • Состояние McAfee: OK — норма. Другие варианты:
      • Просмотреть состояние защиты: отображается флажок.
      • Быстрая настройка | Проверка на наличие вирусов при доступе — Вкл: отображается флажок.
    • Состояние McAfee: Обнаружена проблема — проверка при доступе отключена. Параметры:
      • Просмотреть состояние защиты: отображается восклицательный знак.
        ПРИМЕЧАНИЕ: Щелкните Просмотреть состояние защиты, чтобы отобразить диалоговое окно состояния защиты McAfee с описанием проблемы в столбце состояния — «Проверка при доступе отключена».
      • Быстрая настройка | Проверка на наличие вирусов при доступе — Выкл: флажок не отображается.
    • Состояние McAfee: Обнаружена проблема — инициировано событие защиты доступа. Параметры:
      • Просмотреть состояние защиты: отображается восклицательный знак.
        ПРИМЕЧАНИЕ: Щелкните Просмотреть состояние защиты, чтобы отобразить диалоговое окно состояния защиты McAfee с описанием проблемы в столбце состояния — «См. журнал защиты доступа».
      • Быстрая настройка | Проверка на наличие вирусов при доступе — Вкл: отображается флажок.
  • Параметры меню — ниже перечислены параметры меню, вызываемые правой кнопкой мыши.
    • Обновить параметры безопасности: обновление файлов DAT и другие изменения.
    • Быстрая настройка: вызов ниже перечисленных пунктов меню.
      • Свойства проверки при доступе: открытие окна свойств сканера при доступе.
      • Включение или выключение проверки при доступе: включение/выключение сканера при доступе.
      • Свойства проверки при доступе: открытие окна свойств сканера при доступе.
      • Сообщения проверки при доступе: открытие статистики или сообщений проверки при доступе.
      • Открыть файл журнала защиты при доступе: открытие файла журнала.

    • Управление компонентами | VirusScan Enterprise: открытие Консоль VirusScan.
    • Сканировать компьютер на предмет | Угрозы: запуск немедленного сканирования.
    • Просмотреть состояние защиты: отображение диалогового окна состояния защиты McAfee.
    • Монитор состояния McAfee Agent: отображение диалогового окна монитора состояния защиты McAfee.
    • О программе: открытие диалогового окна «О программе».

Буква «M» в рамке

Отображается в автономных системах с установленным приложением McTray 1.0, а также в системах с ePolicy Orchestrator и McAfee Agent версии 4.0, использующих McTray 1.0. Значок обеспечивает следующую информацию.
  • Состояние: ниже показаны варианты отображения значка.
    • Буква «M» в рамке [image] — нормальное состояние.
    • Буква «M» в рамке с восклицательным знаком [image] — инициировано событие нарушения защиты доступа или проверка при доступе отключена. Ниже перечислены параметры меню, вызываемые правой кнопкой мыши.
      • Буква «V» на щите с перечеркнутым кружком [image] указывает на то, что проверка при доступе отключена.
      • Буква «V» на щите в красной рамке [image] указывает на то, что проверка при доступе включена, но необходимо обратиться к файлу журнала защиты при доступе.

  • Всплывающая подсказка: отображение McAfee.
  • Параметры меню — ниже перечислены параметры меню, вызываемые правой кнопкой мыши.
    • Консоль VirusScan: открытие консоли Консоль VirusScan.
    • Отключить или включить сканер при доступе: включение/выключение сканера при доступе.
    • Свойства проверки при доступе: открытие окна свойств сканера при доступе.
    • Статистика проверки при доступе: открытие статистики проверки при доступе.
    • Сообщения проверки при доступе: открытие статистики или сообщений проверки при доступе.
    • Проверка по требованию: создание однократно настраиваемой проверки по требованию.
    • Обновить сейчас: немедленное выполнение задачи обновления.
    • О программе VirusScan Enterprise: открытие информационного диалогового окна.

Буква «V» на значке щита

Отображается в автономных системах, в которых не установлено приложение McTray 1.0. Значок обеспечивает следующую информацию.
  • Состояние: ниже показаны варианты отображения значка.
    • Буква «V» на значке щита [image] — норма.
    • Буква «V» на щите с перечеркнутым кружком [image] указывает на то, что проверка при доступе отключена.
    • Буква «V» на щите в красной рамке [image] указывает на то, что проверка при доступе включена, но необходимо обратиться к файлу журнала защиты при доступе.
  • Всплывающие подсказки: ниже перечислены возможные всплывающие подсказки.
    • Буква «V» на значке щита [image] — сканирование McAfee при доступе: включено, норма.
    • Буква «V» на щите с перечеркнутым кружком [image] — проверка McAfee при доступе: отключена.
    • Буква «V» на щите в красной рамке [image] — проверка McAfee при доступе: включена, см. журнал защиты доступа.

  • Параметры меню — ниже перечислены параметры меню, вызываемые правой кнопкой мыши.
    • Обновить параметры безопасности: обновление файлов DAT и другие изменения.
    • Быстрая настройка: вызов ниже перечисленных пунктов меню.
      • Свойства проверки при доступе: открытие окна свойств сканера при доступе.
      • Включение или выключение проверки при доступе: включение/выключение сканера при доступе.
      • Сообщения проверки при доступе: открытие статистики или сообщений проверки при доступе.
      • Открыть файл журнала защиты при доступе: открытие файла журнала.

    • Управление компонентами | VirusScan Enterprise: открытие Консоль VirusScan.
    • Сканировать компьютер на предмет | Угрозы: запуск немедленного сканирования.
    • Просмотреть состояние защиты: отображение диалогового окна состояния защиты McAfee.
    • Монитор состояния McAfee Agent: отображение диалогового окна монитора состояния защиты McAfee.
    • О программе: открытие диалогового окна «О программе».


С чего начать

После установки программного обеспечения в нем используются файлы DAT, входящие в пакет продукта. Эти файлы обеспечивают общую безопасность среды. McAfee рекомендует получить последние версии файлов DAT и настроить конфигурацию в соответствии с конкретными требованиями.

Сразу после установки продукта необходимо выполнить следующие действия.

  1. Настройка защиты интерфейса пользователя. Настройте параметры отображения и пароля, чтобы предотвратить доступ пользователей к определенным компонентам или всему интерфейсу пользователя VirusScan Enterprise. Дополнительные сведения см. в разделе Управление доступом к интерфейсу пользователя.
  2. Обновление файлов DAT. Выполните задачу Обновить сейчас, обеспечивающую наличие последней версии файлов DAT. Дополнительные сведения см. в разделе Обновление определений обнаружений.
  3. Предотвращение вторжений. Настройте следующие функции, чтобы предотвратить доступ потенциальных угроз к вашим системам.
    • Защита доступа. Настройте правила защиты доступа, чтобы предотвратить нежелательные изменения в компьютере, и включите параметр, запрещающий прерывание процессов McAfee. Для получения дополнительных сведений см. Защита точек доступа к системе.
    • Защита от переполнения буфера. Включите обнаружение переполнения буфера и задайте исключения. Дополнительные сведения см. в разделе Блокировка атак с переполнением буфера.
    • Политика нежелательных программ. Настройте политику, на основе которой сканеры, запускаемые при доступе, по требованию, а также сканеры электронной почты будут выполнять обнаружение потенциально нежелательных программ. В предварительно определенном списке выберите категории нежелательных программ для обнаружения, затем задайте дополнительные программы, которые следует обнаруживать или исключать. Дополнительные сведения см. в разделе Запрещение потенциально нежелательных программ.
  4. Обнаружение вторжений. Настройте следующие функции для обнаружения потенциальных угроз в системах, получения уведомлений и принятия необходимых мер при обнаружениях.
    • AutoUpdate. Настройте задачи обновления, чтобы получать последние обновления файлов DAT, механизма сканирования и продукта. Дополнительные сведения см. в разделе Обновление определений обнаружений.
    • Сканер при доступе. Настройте сканер для обнаружения потенциальных угроз в рабочей среде и выполнения соответствующих действий. Включите сканирование нежелательных программ и сканирование файлов cookie в соответствующей папке. Дополнительные сведения см. в разделе Сканирование объектов при доступе.
    • Сканер по требованию. Настройте задачи сканирования для обнаружения потенциальных угроз в рабочей среде и выполнения соответствующих действий. Включите сканирование нежелательных программ и сканирование файлов cookie в соответствующей папке, а также сканирование потенциально нежелательных записей в реестре для шпионского программного обеспечения, которые не были удалены ранее. Дополнительные сведения см. в разделе Сканирование объектов по требованию.
    • Сканеры электронной почты. Настройте проверку клиентов электронной почты Microsoft Outlook и Lotus Notes при доставке и по требованию. Включите сканирование нежелательных программ. Дополнительные сведения см. в разделе Сканирование электронной почты при доставке и по требованию.
  5. Отправка предупреждений и угроз, помещенных в карантин. Настройте следующие функции, чтобы получать предупреждения об обнаружениях и управлять элементами в карантине.
    • Предупреждения и уведомления. Настройте способы и случаи получения уведомлений и предупреждений об обнаружении. Дополнительные сведения см. в разделе Настройка предупреждений и уведомлений.
    • Политика Quarantine Manager. Настройте местоположение карантиновой папки и число дней, по истечении которого помещенные в карантин элементы будут автоматически удаляться. Дополнительные сведения см. в разделе Элементы, помещенные в карантин.
Связанные понятия
Элементы, помещенные в карантин
Связанные задачи
Сканирование электронной почты при доставке и по требованию
Связанная информация
Контроль доступа к интерфейсу пользователя
Обновление определений обнаружений
Защита точек доступа к системе
Блокировка атак с переполнением буфера
Запрещение потенциально нежелательных программ
Сканирование объектов при доступе
Сканирование объектов по требованию
Настройка предупреждений и уведомлений


Часть I. Предотвращение угроз

Предотвращение является первым этапом в стратегии защиты, в ходе которого угрозы не допускаются в систему.

Содержание

  • Защита доступа
  • Защита точек доступа к системе
  • Блокировка атак с переполнением буфера
  • Запрещение потенциально нежелательных программ
  • Обновление определений обнаружений
  • Исключение элементов сканирования
  • Использование запланированных задач


Защита доступа

Предотвращение проникновения угроз в клиентскую систему является передним краем защиты от вредоносного программного обеспечения. Запрашиваемые действия сопоставляются функцией «Защита доступа» приложения VirusScan Enterprise со списком настроенных правил. Каждое правило можно настроить таким образом, что вторжения будут только блокироваться или блокироваться с последующим созданием отчета.

Защита доступа предотвращает нежелательные изменения на компьютере путем ограничения доступа к указанным портам, файлам, общим ресурсам, разделам и значениям реестра. Она также предотвращает остановку процессов McAfee пользователями. Эта защита имеет важное значение до и во время эпидемий.

Для этой функции используются предварительно настроенные правила и правила, определенные пользователем, которые позволяют указать, к каким элементам разрешен или запрещен доступ. Каждое правило можно настроить таким образом, что вторжения будут только блокироваться или блокироваться с последующим созданием отчета. Предварительно определенные правила и категории можно обновить с сайтов обновлений McAfee.

ПРИМЕЧАНИЕ: Для доступа к портам, файлам, общим ресурсам, разделам и значениям реестра должен быть включен сканер при доступе, который обнаруживает нарушение прав доступа.

Способы проникновения угроз

Самые распространенные способы проникновения угроз в систему включают следующие.
  • Макрос: как часть документов, созданных в текстовых редакторах, а также электронных таблиц.
  • Исполняемые файлы: кажущиеся безвредными программы вместе с ожидаемым содержимым могут содержать и вирусы. Например, наиболее часто файлы таких программ имеют расширение .EXE, .COM, .VBS, .BAT, .HLP и .DLL.
  • Электронная почта: анекдоты, игры и изображения, вложенные в сообщения электронной почты.
  • Сценарии: разрешенные для выполнения сценарии веб-страниц и электронной почты, такие как ActiveX и JavaScript, могут содержать вирусы.
  • Сообщения системы IRC (Internet Relay Chat): файлы, отправленные с этими сообщениями, могут включать вредоносное содержимое. Например, процессы автоматического запуска могут содержать червей и «троянских коней».
  • Файлы справки обозревателя и приложений: при загрузке этих файлов справки в систему могут проникать встроенные вирусы и исполняемые файлы.
  • Сочетание выше перечисленных способов: изощренные разработчики вредоносных программ одновременно используют все эти способы проникновения и даже встраивают одну вредоносную программу в другую для доступа к вашему компьютеру.

Содержание

Связанные понятия
Способы предотвращения угроз доступа
Связанная информация
Контроль доступа к интерфейсу пользователя


Способы предотвращения угроз доступа

Включив или изменив конфигурацию функции «Защита доступа», можно настроить защиту от шпионских программ, антивирусную защиту, общую защиту, защиту виртуальных машин, а также определить собственные правила защиты. Далее описан основной процесс, используемый VirusScan Enterprise для обеспечения защиты доступа.

Действия, предпринимаемые в случае возникновения угрозы

  1. Пользователем или процессом запускается действие.
  2. С помощью функции «Защита доступа» выполняется проверка этого действия в соответствии с определенными правилами.
  3. В случае нарушения правила управление действием, запрашиваемым пользователем или процессом, выполняется с использованием информации настроенных правил. Например, в результате действия ничего не происходит, оно просто блокируется или блокируется с последующей отправкой отчета.
  4. Обновляется файл журнала «Защита доступа», и создается событие для глобального администратора ePolicy Orchestrator.

Пример угрозы доступа

  1. Пользователь загружает из Интернета программу MyProgram.exe.
    ПРИМЕЧАНИЕ: В данном примере MyProgram.exe не является вредоносной программой.
  2. Пользователь запускает программу, процедура запуска выполняется в обычном режиме.
  3. Затем программой MyProgram.exe запускается дочерний процесс под именем AnnoyMe.exe, который выполняет попытку внести в операционную систему изменения, чтобы ее загрузка всегда выполнялась при запуске.
  4. Функция «Защита доступа» обрабатывает запрос и сопоставляет его с существующим правилом, настроенным для блокировки и отправки отчета.
  5. При попытке внести изменения в операционную систему программе AnnoyMe.exe запрещается доступ, функцией «Защита доступа» регистрируются сведения о попытке и создается предупреждение для глобального администратора ePolicy Orchestrator.

Отчет по журналу и предупреждения

Далее приведен пример записи в журнале «Защита доступа».

2/10/2010 11:00AM Blocked by Access Protection rule TestDomain\TestUser C:\Users\TestUser\Desktop\AnnoyMe.exe \REGISTRY\MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion\Run\ Prevent programs registering to autorun

В следующей таблице описаны данные приведенной записи журнала «Защита доступа».
Запись журнала | Описание
2/10/2010 | Дата
11:00AM | Время
Blocked by Access Protection rule (Заблокировано правилом функции «Защита доступа») | Выполненное действие
TestDomain\TestUser | Учетные данные
C:\Users\TestUser\Desktop\AnnoyMe.exe | Имя процесса, противоречащее правилу
\REGISTRY\MACHINE\SOFTWARE\Microsoft... | Папка, к которой пытался обратиться процесс
Prevent programs registering to autorun (Предотвращение автозапуска регистрации программ) | Инициированное правило функции «Защита доступа»

Аналогичные сведения можно получить с помощью запросов ePolicy Orchestrator. Подробные сведения см. в разделе Доступ к запросам и панелям мониторинга.

Связанная информация
Доступ к запросам и панелям мониторинга


Контроль доступа к интерфейсу пользователя

Настройка защиты интерфейса на клиентских компьютерах является важной частью защиты среды.

Права и возможности администратора:
  • обеспечение контроля доступа пользователей к интерфейсу VirusScan Enterprise;
  • настройка пароля для предотвращения доступа пользователей к определенным функциям или их изменения;
  • при необходимости: блокировка и разблокировка интерфейса пользователя.

Содержание

Связанные понятия
Последствия настройки пароля для пользователей
Связанные задачи
Настройка параметров защиты интерфейса пользователя


Последствия настройки пароля для пользователей

Настройте пароль интерфейса пользователя для ограничения доступа злонамеренных пользователей.

Защита интерфейса пользователя на клиентских компьютерах с помощью пароля касается следующих пользователей.

  • Не администраторы — пользователи без административных прав. Не администраторы запускают все приложения VirusScan Enterprise в режиме только для чтения. Они могут просматривать некоторые параметры конфигурации, запускать сохраненные задачи сканирования, немедленное сканирование и обновления. Они не могут изменять какие-либо параметры конфигурации, создавать, удалять или изменять сохраненные задачи сканирования или задачи обновления.
  • Администраторы — пользователи с административными правами. Для доступа к защищенным вкладкам и элементам управления в режиме чтения-записи администраторам необходимо ввести пароль. Если не ввести пароль для защищенного объекта, просмотр разрешается только в режиме только для чтения.


Настройка параметров защиты интерфейса пользователя

Используйте свойства интерфейса пользователя политик с общими параметрами для настройки параметров отображения и пароля, доступных пользователям.
ОСТОРОЖНО:
Прежде чем изменять эти свойства, внимательно изучите последствия этих изменений для системы защиты. Эти параметры позволяют ограничить или разрешить доступ пользователей к конфигурации системы защиты для внесения изменений. В случае их неадекватного использования система может остаться без защиты от многочисленных вредоносных атак.

Настройте свойства интерфейса пользователя в политиках с общими параметрами с помощью консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Настройте свойства интерфейса пользователя в политиках с общими параметрами.

Задача

Чтобы просмотреть определения параметров, щелкните ? на каждой вкладке.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На вкладке Параметры отображения настройте, какие значки панели задач VirusScan Enterprise будут отображаться для пользователей в случае их подключения к удаленным системам, а также язык пользователей.
  5. На вкладке Параметры пароля настройте, какие задачи VirusScan Enterprise и параметры интерфейса могут изменять пользователи с помощью соответствующего пароля.


ePolicy Orchestrator 4.0

Настройте свойства интерфейса пользователя в политиках с общими параметрами.

Задача

Чтобы просмотреть определения параметров, щелкните ? на каждой вкладке.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На вкладке Параметры отображения настройте, какие значки панели задач VirusScan Enterprise будут отображаться для пользователей в случае их подключения к удаленным системам, а также язык пользователей.
  5. На вкладке Параметры пароля настройте, какие задачи VirusScan Enterprise и параметры интерфейса могут изменять пользователи с помощью соответствующего пароля.


Консоль VirusScan

Настройте свойства интерфейса пользователя в общих параметрах.

Задача

Чтобы просмотреть определения параметров, щелкните Справка на каждой вкладке.

  1. Щелкните Сервис | Общие параметры, чтобы открыть диалоговое окно конфигурации общих параметров.
  2. На вкладке Параметры отображения настройте, какие значки панели задач VirusScan Enterprise будут отображаться для пользователей в случае их подключения к удаленным системам, а также язык пользователей.
  3. На вкладке Параметры пароля настройте, какие задачи VirusScan Enterprise и параметры интерфейса могут изменять пользователи с помощью соответствующего пароля.


Защита точек доступа к системе

Защита доступа предотвращает нежелательные изменения на компьютере путем ограничения доступа к указанным портам, файлам, общим ресурсам, разделам и значениям реестра. Она также предотвращает остановку процессов McAfee пользователями. Эта защита имеет важное значение до и во время эпидемий.

Для этой функции используются предварительно настроенные правила и категории и правила, определенные пользователем, которые позволяют указать, к каким элементам разрешен или запрещен доступ. Каждое правило можно настроить таким образом, что вторжения будут блокироваться с последующим созданием отчета. Содержимое предварительно определенных правил и категорий постоянно обновляется через сайты обновлений McAfee.

Содержание

Связанные понятия
Нарушения доступа и способы реагирования VirusScan Enterprise
Связанные задачи
Настройка параметров защиты доступа
Связанные ссылки
Процесс определения правил защиты доступа
Типы правил, определяемых пользователем


Процесс определения правил защиты доступа

Правила делятся на представленные типы и обеспечивают уровни защиты, перечисленные ниже.

Описание типов правил

Тип правила Описание
Защита от вирусов

Эти предварительно настроенные правила защищают компьютер от наиболее распространенных угроз вредоносных программ. Можно включать, отключать и изменять конфигурацию этих правил, однако их нельзя удалять.

Два примера таких правил:

  • Предотвращение выключения или изменения критически важных процессов, удаленного создания или модификации исполняемых файлов, захвата исполняемых файлов, подделки процессов Windows и массовой рассылки червей вместе с почтой.
  • Защита файлов телефонной книги от программ кражи паролей и взлома электронной почты.

Эти уровни защиты применимы к правилам защиты от вирусов:

  • Стандартная защита
  • Максимальная защита
  • Защита от эпидемии
Общие

Эти предварительно настроенные правила предотвращают модификацию часто используемых файлов и настроек. Можно включать, отключать и изменять конфигурацию этих правил, однако их нельзя удалять.

Три примера таких правил:

  • Предотвращение модификации файлов и настроек McAfee.
  • Защита файлов и настроек Mozilla и Firefox, настроек Internet Explorer и сетевых настроек.
  • Предотвращение установки объектов модуля поддержки обозревателя и автоматического запуска программ из временной папки.

Эти уровни защиты применимы к общим правилам:

  • Стандартная защита
  • Максимальная защита
Защита виртуальных машин

Эти предварительно настроенные правила предотвращают прерывание процессов VMWare и модификацию файлов VMWare. Можно включать, отключать и изменять конфигурацию этих правил, однако их нельзя удалять.

Примеры правил:
  • Предотвращение прерывания процессов VMWare.
  • Предотвращение модификации файлов рабочей станции, сервера или виртуальных машин VMWare.
Определяемые пользователем

Эти пользовательские правила усиливают защиту, обеспечиваемую правилами защиты от вирусов и общими правилами.

Защита от шпионских программ

Примеры правил:
  • Защита избранного и настроек Internet Explorer.
  • Предотвращение запуска программ и выполнения сценариев из временной папки.

Описание уровней защиты

Уровень защиты | Описание
Стандартная | Правила антивируса и общие правила, которые защищают некоторые важные настройки и файлы от изменений, однако обычно разрешают установку и выполнение допустимого программного обеспечения.
Максимальная | Правила антивируса и общие правила, которые защищают наиболее важные настройки и файлы от изменений. Данный уровень обеспечивает большую защиту, чем стандартный, но может препятствовать установке допустимого программного обеспечения. Если невозможно установить программное обеспечение, рекомендуется сначала отключить функцию Защита доступа, а затем снова включить после установки.
Защита от эпидемии | Правила защиты от вирусов, блокирующие доступ разрушающего кода к компьютеру до тех пор, пока не будет выпущен файл DAT. Эти правила предварительно настроены на блокировку доступа к общим ресурсам во время эпидемии.


Нарушения доступа и способы реагирования VirusScan Enterprise

Нарушение прав доступа происходит в том случае, когда пользователь с ограниченным доступом пытается запустить, остановить или получить доступ к ограниченным компонентам.

Ниже перечислены процессы, которые имеют место при нарушении в точке доступа

  • Если для правила, с помощью которого обнаружено нарушение, выбран параметр Отчет, то соответствующая информация будет записываться в файл журнала.
  • Если в диалоговом окне Свойства предупреждений задать соответствующие настройки, событие будет записываться в журнал локальных событий и в SNMP.
  • Событие будет записываться в Alert Manager и ePolicy Orchestrator, если эти продукты будут настроены соответствующим образом.
  • С помощью действий блокировки и построения отчета, заданных для правила, определяются шаги, которые последуют за обнаружением нарушения с помощью этого правила.
  • В автономной клиентской системе значок на панели задач обведен красной рамкой и будет отображаться в течение 30 минут, пока не будет сброшен.
    ПРИМЕЧАНИЕ: Чтобы сбросить этот значок, с помощью значка на панели задач откройте файл журнала «Защита доступа». Если файл журнала открыть каким-либо другим способом, значок не будет сброшен до обычного состояния.


Типы правил, определяемых пользователем

Во время настройки нового правила защиты доступа, определяемого пользователем, разрешается создавать правила блокировки портов, блокировки файлов и папок, а также блокировки реестров.

Описание этих правил приводится в следующей таблице.

Описание правил

Правило | Описание
Правило блокировки портов Блокировка входящего или исходящего сетевого трафика в определенных портах или рядах портов.
ПРИМЕЧАНИЕ: При блокировке порта блокируются доступы к протоколам TCP (Transmission Control Protocol) и UDP (User Datagram Protocol).
ПРИМЕЧАНИЕ: При блокировке порта происходит блокировка любого протокола, для которого используется этот порт или ряд портов. Например, блокируются доступы к протоколам TCP (Transmission Control Protocol) и UDP (User Datagram Protocol).
Правило блокировки файлов/папок Блокировка доступа на запись к файлам и папкам, блокировка исполнения файлов, а также блокировка создания новых файлов и удаления файлов.
ПРИМЕЧАНИЕ: После ограничения доступа к файлу или папке это ограничение остается в силе до тех пор, пока не будет удалено администратором. Благодаря этому предотвращаются вторжения, которые уже не могут распространяться во время эпидемии.
Правило блокировки реестра | Защита разделов или значений реестра путем блокировки следующих действий: запись, создание или удаление.


Настройка параметров защиты доступа

Используйте политики защиты доступа для защиты точек доступа системы и предотвращения прерывания процессов McAfee.
ОСТОРОЖНО:
Если не включить защиту доступа, предотвращающую остановку служб McAfee, система может остаться без защиты от многочисленных вредоносных атак.
Существует два типа правил защиты доступа, которые можно настраивать.
  • Предварительно определенные правила и предоставляемые возможности
    • Открытие категории правил защиты доступа на одной из консолей интерфейса пользователя.
    • Выбор действия блокировки и построения отчета, которое будет предпринято в случае нарушения правила.
  • Правила, определяемые пользователем, и предоставляемые возможности
    • Создание категории правил, определяемых пользователем, с помощью одной из консолей интерфейса пользователя.
    • Выбор типа блокировки, определяемого правилом: блокировка портов, блокировка файлов и папок или блокировка реестров.
    • Настройка сведений о правиле.
    • Сохранение правила и изменение его в будущем, если потребуется.

Задачи

Связанные задачи
Настройка предварительно определенных правил
Настройка правил, определяемых пользователем
Удаление правил, определяемых пользователем
Связанные ссылки
Параметры правил блокировки портов
Параметры правил блокировки файлов и папок
Параметры правил блокировки реестров
Включение или исключение определенных параметров процесса


Настройка предварительно определенных правил

Предварительно настроенные правила используются для защиты компьютера от нежелательных изменений. Эти правила можно включать и редактировать, однако их нельзя удалять.

Ниже перечислены предварительно определенные правила защиты доступа:
  • Стандартная защита от шпионских программ
  • Максимальная защита от шпионских программ
  • Стандартная защита от вирусов
  • Максимальная защита от вирусов
  • Защита от вирусной эпидемии
  • Общая стандартная защита
  • Общая максимальная защита
  • Защита виртуальных машин

Для получения подробной информации об этих предварительно определенных правилах защиты доступа см. раздел Процесс определения правил защиты доступа.

Настройка предварительно определенных правил защиты доступа выполняется на одной из данных консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Выбрав политики защиты доступа, настройте предварительно определенные правила защиты доступа.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. Чтобы отобразить правила защиты доступа, на странице «Политика защиты доступа» щелкните вкладку Защита доступа.
  5. В левой панели выберите одну из категорий предварительно определенных правил, затем в правой панели выберите конкретное правило.
  6. Настройте параметр Блокировать или Отчет или оба параметра: Блокировать и Отчет.
  7. Щелкните Изменить, чтобы настроить Сведения о правиле.


ePolicy Orchestrator 4.0

Выбрав политики защиты доступа, настройте предварительно определенные правила защиты доступа.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. Чтобы отобразить правила защиты доступа, на странице «Политика защиты доступа» щелкните вкладку Защита доступа.
  5. В левой панели выберите одну из категорий предварительно определенных правил, затем в правой панели выберите конкретное правило.
  6. Настройте параметр Блокировать или Отчет или оба параметра: Блокировать и Отчет.
  7. Щелкните Изменить, чтобы настроить Сведения о правиле.


Консоль VirusScan

Выбрав свойства защиты доступа, настройте предварительно определенные правила защиты доступа.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Защита доступа, затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. Чтобы отобразить правила защиты доступа, в диалоговом окне «Политика защиты доступа» щелкните вкладку Защита доступа.
  3. В левой панели выберите одну из категорий предварительно определенных правил, затем в правой панели выберите конкретное правило.
  4. Настройте параметр Блокировать или Отчет или оба параметра: Блокировать и Отчет.
  5. Щелкните Изменить, чтобы настроить Сведения о правиле.


Настройка правил, определяемых пользователем

Создание и редактирование правил, определяемых пользователем, позволяет усилить защиту, которую обеспечивают предварительно определенные правила.

Для получения подробной информации об этих предварительно определенных правилах защиты доступа см. раздел Процесс определения правил защиты доступа.

Создание и редактирование правил защиты доступа, определяемых пользователем, выполняется на одной из данных консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Выбрав политики защиты доступа, настройте правила защиты доступа, определяемые пользователем.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В левой панели выберите категорию Правила, определяемые пользователем, затем щелкните Создать, чтобы открыть диалоговое окно Выбрать новый тип правила.
  5. Выберите тип правила и щелкните OK. Для получения подробной информации см. раздел Типы правил, определяемых пользователем. Вид диалогового окна правила доступа зависит от того, какой тип правила выбран.
  6. Настройте следующие сведения о правиле доступа.
    • Правило защиты доступа к сетевому порту: см. таблицу параметров в разделе Параметры правил блокировки портов.
    • Правило защиты доступа к файлам/папкам: см. таблицу параметров в разделе Параметры правил блокировки файлов и папок.
    • Правило защиты доступа к реестрам: см. таблицу параметров в разделе Параметры правил блокировки реестров.
    ПРИМЕЧАНИЕ: Сведения об указании процессов для включения и исключения см. в разделе Включение или исключение определенных параметров процесса.
  7. Щелкните OK. Новое правило, определяемое пользователем, отобразится в правой панели, ниже раздела «Блокировать/отчет/правила». Чтобы изменить новое правило, выберите его и щелкните Изменить.


ePolicy Orchestrator 4.0

Выбрав политики защиты доступа, настройте правила защиты доступа, определяемые пользователем.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В левой панели выберите категорию Правила, определяемые пользователем, затем щелкните Создать, чтобы открыть диалоговое окно Выбрать новый тип правила.
  5. Выберите тип правила и щелкните OK. Для получения подробной информации см. раздел Типы правил, определяемых пользователем. Вид диалогового окна правила доступа зависит от того, какой тип правила выбран.
  6. Настройте следующие сведения о правиле доступа.
    • Правило защиты доступа к сетевому порту: см. таблицу параметров в разделе Параметры правил блокировки портов.
    • Правило защиты доступа к файлам/папкам: см. таблицу параметров в разделе Параметры правил блокировки файлов и папок.
    • Правило защиты доступа к реестрам: см. таблицу параметров в разделе Параметры правил блокировки реестров.
    ПРИМЕЧАНИЕ: Сведения об указании процессов для включения и исключения см. в разделе Включение или исключение определенных параметров процесса.
  7. Щелкните OK. Новое правило, определяемое пользователем, отобразится в правой панели, ниже раздела «Блокировать/отчет/правила». Чтобы изменить новое правило, выберите его и щелкните Изменить.


Консоль VirusScan

Выбрав свойства защиты доступа, настройте правила защиты доступа, определяемые пользователем.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. В списке Задача щелкните правой кнопкой мыши Защита доступа, затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. В левой панели выберите категорию Правила, определяемые пользователем, затем щелкните Создать, чтобы открыть диалоговое окно Выбрать новый тип правила.
  3. Выберите тип правила и щелкните OK. Для получения подробной информации см. раздел Типы правил, определяемых пользователем. Вид диалогового окна правила доступа зависит от того, какой тип правила выбран.
  4. Настройте следующие сведения о правиле доступа.
    • Правило защиты доступа к сетевому порту: см. таблицу параметров в разделе Параметры правил блокировки портов.
    • Правило защиты доступа к файлам/папкам: см. таблицу параметров в разделе Параметры правил блокировки файлов и папок.
    • Правило защиты доступа к реестрам: см. таблицу параметров в разделе Параметры правил блокировки реестров.
    ПРИМЕЧАНИЕ: Сведения об указании процессов для включения и исключения см. в разделе Включение или исключение определенных параметров процесса.
  5. Щелкните OK. Новое правило, определяемое пользователем, отобразится в правой панели, в столбце «Правила». Чтобы изменить новое правило, выберите его и щелкните Изменить.


Параметры правил блокировки портов

Правила блокировки портов предотвращают доступ пользователей к портам входящего и исходящего трафика, а также доступ других компьютеров к данному компьютеру.

Определения параметров

Параметр | Определение
Имя правила | Выполняется ввод имени правила.
Процессы для включения | Ограничение доступа к указанным процессам.
Процессы для исключения | Разрешение доступа к указанным процессам.
Начальный порт | Указывается номер первого порта. Это может быть номер одного порта или начальный номер ряда портов. ПРИМЕЧАНИЕ: Если заблокировать доступ к порту, используемому агентом McAfee или агентом Host Intrusion Prevention, процессы агента приобретают статус доверенных и получают разрешение на связь с заблокированным портом. Остальной трафик, не связанный с процессами этих агентов, будет заблокирован.
Конечный порт | Указывается номер последнего порта в ряде портов.
Входящий трафик | Предотвращение доступа систем, включенных в сеть, к указанным портам.
Исходящий трафик | Предотвращение доступа локальных процессов к указанным портам в сети.


Параметры правил блокировки файлов и папок

Правила блокировки файлов и папок не позволяют неавторизованным пользователям изменять, открывать или удалять определенные файлы или папки.

Определения параметров

Параметр | Определение
Имя правила | Выполняется ввод имени правила.
Процессы для включения | Ограничение доступа к указанным процессам.
Процессы для исключения | Разрешение доступа к указанным процессам.
Имя файла или папки, предназначенной для блокировки | Блокировка доступа к указанному файлу или папке.
Поиск файла | Переход к определенному файлу.
Поиск папки | Переход к определенной папке.
Доступ на чтение к файлам | Блокировка доступа на чтение к указанным файлам.
Доступ на запись к файлам | Блокировка доступа на запись к указанным файлам.
Выполнение файлов | Блокировка выполнения файлов в указанной папке.
Создание новых файлов | Блокировка создания новых файлов в указанной папке.
Удаление файлов | Блокировка удаления файлов из указанной папки.


Параметры правил блокировки реестров

Правила блокировки реестров не позволяют пользователям и неавторизованным программам изменять, открывать или удалять определенные разделы и значения реестров.

ПРИМЕЧАНИЕ: При создании правила блокировки реестра рекомендуется использовать наиболее подходящую аббревиатуру ветви куста реестра. Например, чтобы заблокировать реестр HKLM\System\CurrentControlSet\Services\MyService, выберите куст HKCCS, а не HKLM.

Определения параметров

Параметр | Определение
Имя правила | Указывается имя для данного правила.
Процессы для включения | Ограничение доступа к указанным процессам.
Процессы для исключения | Разрешение доступа к указанным процессам.
Раздел или значение реестра, предназначенное для защиты Защита данного раздела или значения реестра:
  • В раскрывающемся списке выберите корневой раздел или значение.
  • Введите раздел или значение в текстовом поле.
Выбирать корневой раздел или значение в раскрывающемся списке необязательно. Для указания раздела или значения используйте любой из представленных способов:
  • Выберите корневой раздел или значение в раскрывающемся списке, затем в текстовом поле введите остальной путь к разделу или значению.
  • В текстовом поле введите полный путь к разделу или значению.
Тип правила Выберите тип правила:
  • Раздел: данное правило защищает указанный раздел.
  • Значение: данное правило защищает указанное значение.
Запись в раздел или значение | Блокировка записи в указанный раздел или значение.
Создание раздела или значения | Блокировка создания указанного раздела или значения.
Удаление раздела или значения | Блокировка удаления указанного раздела или значения.


Включение или исключение определенных параметров процесса

Определения параметров

Чтобы изменить сведения о правиле, такие как имя, а также указать процессы, которые требуется включить или исключить, выберите Защита доступа и щелкните Изменить.

Параметр | Описание
Имя правила | Имя данного правила. Например, Предотвращение отключения редактора реестра и Task Manager.
Процессы для включения | Ограничение доступа к данным процессам. Используйте точное имя процесса или, чтобы задать широкий диапазон процессов, используйте подстановочный знак, например *.EXE. Затем для конкретных допустимых процессов, например SETUP.EXE, добавьте исключения. Например, задайте *, чтобы включить все процессы.
Процессы для исключения | Разрешение доступа к данным процессам. Используйте точное имя процесса. Например, задайте следующие исключения: avtask.exe, cfgwiz,exe, fssm32.exe, giantantispywar*, kavsvc.exe, mmc.exe, navw32.exe, nmain.exe, rtvscan.exe.


Удаление правил, определяемых пользователем

Созданные пользователем, но не используемые правила, следует удалять.

Удаление правил, определяемых пользователем, выполняется на одной из данных консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Выбрав политики защиты доступа, удалите созданные правила, которые больше не используются.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка в интерфейсе.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В левой панели выберите категорию Правила, определяемые пользователем, затем в правой панели выберите правило, которое требуется удалить.
  5. Щелкните Удалить.
    ПРИМЕЧАНИЕ: Чтобы отключить правило, не удаляя его, отмените выбор действий Блокировать и Отчет. При необходимости правило можно снова включить.


ePolicy Orchestrator 4.0

Выбрав политики защиты доступа, удалите созданные правила, которые больше не используются.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка в интерфейсе.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В левой панели выберите категорию Правила, определяемые пользователем, затем в правой панели выберите правило, которое требуется удалить.
  5. Щелкните Удалить.
    ПРИМЕЧАНИЕ: Чтобы отключить правило, не удаляя его, отмените выбор действий Блокировать и Отчет. При необходимости правило можно снова включить.


Консоль VirusScan

Выбрав свойства защиты доступа, удалите созданные правила, которые больше не используются.

Удаление правил, определяемых пользователем, выполняется на одной из данных консолей интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка в интерфейсе.

  1. В списке Задача щелкните правой кнопкой мыши Защита доступа, затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. В левой панели выберите категорию Правила, определяемые пользователем, затем в правой панели выберите правило, которое требуется удалить.
  3. Щелкните Удалить.
    ПРИМЕЧАНИЕ: Чтобы отключить правило, не удаляя его, отмените выбор действий Блокировать и Отчет. При необходимости правило можно снова включить.


Блокировка атак с переполнением буфера

Защита от переполнения буфера предотвращает выполнение произвольного кода на вашем компьютере при переполнении буфера в результате атаки. Она отслеживает вызовы API в режиме пользователя, совершаемые в результате переполнения буфера.

В случае обнаружения сведения записываются в журнал активности и отображаются в диалоговом окне Сообщения сканера при доступе, если настроены соответствующие параметры.

В приложении VirusScan Enterprise используется файл DAT защиты от переполнения буфера и защиты доступа для 30 приложений, например Internet Explorer, Microsoft Outlook, Outlook Express, Microsoft Word и MSN Messenger.

Содержание

Связанные понятия
Атаки с переполнением буфера
Связанные задачи
Настройка защиты от переполнения буфера


Атаки с переполнением буфера

Взломщики выполняют атаки с переполнением буфера для запуска исполняемых кодов путем переполнения буферов с фиксированным объемом памяти, зарезервированных для процесса ввода. Эти коды позволяют взломщику проникнуть в систему целевого компьютера или повредить хранящиеся на нем данные.

Существуют два типа атак с переполнением буфера.
  • Атаки на динамическую память: заполняется память, зарезервированная для программы. Это сложные для выполнения атаки, которые совершаются редко.
  • Атаки на стек: объекты стековой памяти используются для хранения введенных пользователем данных. Это наиболее распространенный тип атак.
В приведенном далее процессе описаны атаки на стек с переполнением буфера.
  1. Использование стековой памяти в обычном режиме: объект стековой памяти с фиксированным размером обычно пуст и находится в состоянии ожидания ввода данных пользователем. Когда пользователь вводит в программу данные, например свое имя, данные сохраняются в верхней части стека и им назначается обратный адрес блока памяти. При обработке стека введенные пользователем данные отправляются на обратный адрес, указанный программой.
  2. Переполнение стека: при написании программы для данных резервируется определенный объем памяти. При записи данных, объем которых превышает зарезервированное в стеке пространство, происходит переполнение стека. Это вызывает проблему, только если введенные данные являются вредоносными.
  3. Использование переполнения: когда программа ожидает ввода имени пользователя, а взломщик вводит исполняемую команду, которая превышает размер стека, команда сохраняется за пределами зарезервированного пространства.
  4. Запуск вредоносного кода: автоматический запуск команды не происходит только при превышении размера буфера стека. Он возможен, если взломщиком предоставлен обратный адрес, указывающий на вредоносную программу. Сначала в результате переполнения буфера происходит сбой программы, однако программа пытается выполнить восстановление, используя предоставленный взломщиком обратный адрес. Если обратный адрес является допустимым, вредоносная команда выполняется.
  5. Использование разрешений: поскольку программы обычно выполняются в режиме ядра или с разрешениями, унаследованными от учетной записи службы, вредоносный код выполняется с теми же разрешениями, что и приложение, в отношении которого совершена атака. Это означает, что взломщик может получить полный контроль над операционной системой.


Настройка защиты от переполнения буфера

Чтобы предотвратить выполнение приложениями произвольного кода на вашем компьютере, необходимо настроить политики защиты от переполнения буфера.

Настройте политики защиты от переполнения буфера с помощью следующих консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Настройте политики защиты от переполнения буфера с помощью этих консолей интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице «Политики защиты от переполнения буфера» щелкните вкладку Защита от переполнения буфера и настройте следующие параметры.
    1. Включите параметр Настройки переполнения буфера и используемый режим защиты. В режиме защиты настройте блокировку атаки или просто отправку сообщения и запись события в журнал.
    2. Активируйте Предупреждения клиентской системы, отправляемые в случае атаки с переполнением буфера.
    3. Настройте Исключения при переполнении буфера для определенных значений интерфейса API, а также дополнительные процессы и имена модулей для исключения.
  5. Щелкните вкладку Отчеты, включите файлы журналов активности сканирования, настройте их местоположение, размер и формат.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


ePolicy Orchestrator 4.0

Настройте политики защиты от переполнения буфера с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице «Политики защиты от переполнения буфера» щелкните вкладку Защита от переполнения буфера и настройте следующие параметры.
    1. Включите параметр Настройки переполнения буфера и используемый режим защиты. В режиме защиты настройте блокировку атаки или просто отправку сообщения и запись события в журнал.
    2. Активируйте Предупреждения клиентской системы, отправляемые в случае атаки с переполнением буфера.
    3. Настройте Исключения при переполнении буфера для определенных значений интерфейса API, а также дополнительные процессы и имена модулей для исключения.
  5. Щелкните вкладку Отчеты, включите файлы журналов активности сканирования, настройте их местоположение, размер и формат.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


Консоль VirusScan

Настройте политики защиты от переполнения буфера с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. В списке Задача щелкните правой кнопкой мыши Защита от переполнения буфера, затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. На странице «Политики защиты от переполнения буфера» щелкните вкладку Защита от переполнения буфера и настройте следующие параметры.
    1. Включите параметр Настройки переполнения буфера и используемый режим защиты. В режиме защиты настройте блокировку атаки или просто отправку сообщения и запись события в журнал.
    2. Активируйте Предупреждения клиентской системы, отправляемые в случае атаки с переполнением буфера.
    3. Настройте Исключения при переполнении буфера для определенных значений интерфейса API, а также дополнительные процессы и имена модулей для исключения.
  3. Щелкните вкладку Отчеты, включите файлы журналов активности сканирования, настройте их местоположение, размер и формат.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


Запрещение потенциально нежелательных программ

VirusScan Enterprise защищает компьютер от потенциально нежелательных программ, которые навязываются пользователю или представляют угрозу безопасности. В системе уже настроена одна из наиболее распространенных политик нежелательных программ, однако эту политику можно включать или выключать, а также задавать действия для каждого сканера VirusScan Enterprise в индивидуальном порядке.

Потенциально нежелательные программы определяются как программное обеспечение, записанное правомочными компаниями, которые могут изменять состояние безопасности или политику конфиденциальности компьютера, на котором это программное обеспечение установлено. Данное программное обеспечение может включать шпионские программы, программы для показа рекламы и набиратели номера, а может и не включать. Такие внедренные потенциально нежелательные программы могут быть загружены вместе с действительно необходимой программой. Пользователи, которые заботятся о безопасности своих систем, распознают такие программы и в некоторых случаях удаляют их.


Настройка нежелательных программ

Чтобы защитить компьютер от потенциально нежелательных программ, необходимо настроить категории нежелательных программ, которые необходимо обнаруживать в компьютерной среде.

Такая настройка является двухэтапным процессом.

  1. Настройка политики нежелательных программ, определяющая, какие потенциально нежелательные программы требуется обнаруживать и исключать.
    • В предварительно определенном списке, который имеется в текущем файле DAT, выберите целые категории программ или определенные программы в рамках одной категории.
    • Укажите исключения.
    • Создайте список программ, определяемых пользователем, которые требуется обнаруживать.

  2. Включите обнаружение нежелательных программ для сканеров при доступе, сканеров электронной почты и сканеров по требованию, затем задайте действия, которые необходимо выполнять в случае обнаружения нежелательной программы.

ПРИМЕЧАНИЕ: Для сканера по требованию функция обнаружения нежелательных программ включается по-другому, поскольку проверка по требованию является не политикой, а задачей. Для получения подробных сведений см. Настройка задач проверки по требованию.

Задачи

Связанные задачи
Доступ к политикам нежелательных программ
Включение обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты


Доступ к политикам нежелательных программ

Настройку политик нежелательных программ можно выполнить путем выбора категорий нежелательных программ, которые требуется обнаруживать. Например, шпионские программы и программы для показа рекламы. Для программ, которые не следует обнаруживать, можно задать исключения.

Доступ к политикам нежелательных программ выполняется на одной из следующих консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Настройте политики нежелательных программ с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политика нежелательных программ выберите вкладку Элементы сканирования, чтобы настроить следующие параметры:
    1. Категории нежелательных программ, которые требуется обнаруживать: например, шпионские программы и программы для показа рекламы. Эти категории определяются текущим файлом DAT.
    2. Исключения: необходимо указать точное имя обнаружения, которое требуется исключить, а не имя файла.
  5. Выберите вкладку Обнаружения, определяемые пользователем и укажите отдельные файлы или программы, которые следует рассматривать как нежелательные программы. Укажите каждый элемент по имени файла и представьте его описание.


ePolicy Orchestrator 4.0

Настройте политики нежелательных программ с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политика нежелательных программ выберите вкладку Элементы сканирования, чтобы настроить следующие параметры:
    1. Категории нежелательных программ, которые требуется обнаруживать: например, шпионские программы и программы для показа рекламы. Эти категории определяются текущим файлом DAT.
    2. Исключения: необходимо указать точное имя обнаружения, которое требуется исключить, а не имя файла.
  5. Выберите вкладку Обнаружения, определяемые пользователем и укажите отдельные файлы или программы, которые следует рассматривать как нежелательные программы. Укажите каждый элемент по имени файла и представьте его описание.


Консоль VirusScan

Настройте свойства нежелательных программ с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Политика нежелательных программ, затем щелкните Свойства, чтобы открыть диалоговое окно «Политика нежелательных программ».
  2. На странице Политика нежелательных программ выберите вкладку Элементы сканирования, чтобы настроить следующие параметры:
    1. Категории нежелательных программ, которые требуется обнаруживать: например, шпионские программы и программы для показа рекламы. Эти категории определяются текущим файлом DAT.
    2. Исключения: необходимо указать точное имя обнаружения, которое требуется исключить, а не имя файла.
  3. Выберите вкладку Обнаружения, определяемые пользователем и укажите отдельные файлы или программы, которые следует рассматривать как нежелательные программы. Укажите каждый элемент по имени файла и представьте его описание.


Включение обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты

Чтобы настроить сканеры при доступе и сканеры электронной почты на обнаружение нежелательных программ, соответствующую функцию следует включить на вкладке «Элементы сканирования».

Включение функции обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты выполняется на одной из следующих консолей интерфейса пользователя.
ПРИМЕЧАНИЕ: Для получения информации о включении функции обнаружения нежелательных программ для сканера по требованию см. раздел Настройка задач проверки по требованию.


ePolicy Orchestrator 4.5 или 4.6

Включение функции обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты выполняется с помощью консоли ePolicy Orchestrator 4.5 или 4.6.

Процесс, используемый для включения обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты, фактически такой же. Единственное различие заключается в том, какая политика будет выбрана в каталоге политик для шага 2. Чтобы включить обнаружение нежелательных программ для:
  • проверки при доступе, выберите Политики проверки при доступе;
  • для сканирования электронной почты, выберите Политики сканирования электронной почты при доставке.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политики сканирования при доступе или Политики сканирования электронной почты при доставке выберите вкладку Элементы сканирования, а затем выберите параметр Обнаружение нежелательных программ.


ePolicy Orchestrator 4.0

Включение функции обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты выполняется с помощью консоли ePolicy Orchestrator 4.0.

Процесс, используемый для включения обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты, фактически такой же. Единственное различие заключается в том, какая политика будет выбрана в каталоге политик для шага 2. Чтобы включить обнаружение нежелательных программ для:
  • проверки при доступе, выберите Политики проверки при доступе;
  • для сканирования электронной почты, выберите Политики сканирования электронной почты при доставке.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политики сканирования при доступе или Политики сканирования электронной почты при доставке выберите вкладку Элементы сканирования, а затем выберите параметр Обнаружение нежелательных программ.


Консоль VirusScan

Включение функции обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты выполняется с помощью Консоль VirusScan.

Процесс, используемый для включения обнаружения нежелательных программ для сканеров при доступе и сканеров электронной почты, фактически такой же. Единственное различие заключается в том, какая задача будет выбрана в Консоль VirusScan для шага 2. Чтобы включить обнаружение нежелательных программ для:
  • проверки при доступе, выберите Политики проверки при доступе;
  • для сканирования электронной почты, выберите Сканер электронной почты при доставке.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши один из элементов, а затем щелкните кнопку Свойства, чтобы открыть соответствующее диалоговое окно:
    • Политики проверки при доступе: для проверки при доступе.
    • Сканер электронной почты при доставке: для сканирования электронной почты.
  2. На странице Политики сканирования при доступе или Политики сканирования электронной почты при доставке выберите вкладку Элементы сканирования, а затем выберите параметр Обнаружение нежелательных программ.


Обновление определений обнаружений

Для определения угроз и принятия по отношению к ним необходимых действий программное обеспечение VirusScan Enterprise использует механизм сканирования и информацию в файлах определения обнаружений (DAT). Новые угрозы появляются постоянно. В ответ на это McAfee ежедневно выпускает новые файлы DAT, содержащие результаты постоянного исследования угроз. Задача обновления позволяет получать самые последние файлы DAT с внешнего сайта обновлений McAfee и устанавливать их на локальный сервер.
ПРИМЕЧАНИЕ: В среде с платформой управления ePolicy Orchestrator возможно также получение текущих файлов DAT, файла EXTRA.DAT, механизма сканирования, пакетов обновлений и исправлений.

Содержание

Связанные понятия
Файлы DAT и принцип их работы
Значимость стратегии обновления
Задачи обновления и принципы их работы
Задачи отражения и принцип их работы
Принцип работы хранилища AutoUpdate
Принципы отката файлов DAT


Файлы DAT и принцип их работы

Когда механизм сканирования файлов на предмет угроз запущен, сканируемые файлы сравниваются с имеющимися сведениями об угрозах, которые хранятся в файлах определения обнаружений (DAT). Имеющиеся сведения об угрозах, так называемые сигнатуры, — это информация, найденная McAfee Labs и добавленная в файлы DAT.

Кроме сигнатур файлы DAT также содержат информацию о том, как нейтрализовать последствия обнаруженного вируса. Поэтому так важно загружать именно последнюю версию файла DAT, используемую VirusScan Enterprise.
ОСТОРОЖНО:
Если сигнатура определенного вируса отсутствует в одном из установленных файлов DAT, данный вирус не будет обнаружен при запуске механизма сканирования. Кроме того, для использования последних файлов DAT механизм сканирования также должен быть последней версии.

Кроме файлов DAT в VirusScan Enterprise также используются эвристические методы, Artemis, для проверки наличия подозрительных файлов. Для получения дополнительной информации см. раздел Принцип работы Artemis.

Различные файлы DAT хранятся по следующему пути:

\Program Files\Common Files\McAfee\Engine


Значимость стратегии обновления

Значимость стратегии обновления нельзя преувеличить. Если в системе не установлены последние файлы DAT и механизм сканирования, полная защита от самых последних вирусов не гарантируется. Последнее время наблюдается беспрецедентный рост числа, уровня и масштабов распространения вредоносных программ. Кроме того, растет число программ для показа рекламы и шпионских программ, что создает необходимость в надежных механизмах их обнаружения и удаления.

McAfee Labs выпускает обновления файлов DAT практически ежедневно приблизительно в 18:00 (по Гринвичу). Естественно, вспышки вирусных эпидемий возможны в любое время, что требует экстренных выпусков. В случае более раннего выпуска файла DAT для предупреждения потенциальной вспышки второй файл не выпускается в этот же день в запланированное время, если только того не требует другая экстренная ситуация.


Определение стратегии обновления

Существует несколько методов обновления файлов DAT и механизма сканирования, используемых VirusScan Enterprise. К ним относятся задачи AutoUpdate, обновления, выполняемые вручную, сценарии входа в систему и планирование обновлений с помощью средств управления.

Задача обновления позволяет выполнять следующие действия.

  • Планирование развертывания файлов DAT во всей сети: пользователь может дифференцировать задачи обновления или задать для них такое расписание, при котором обновления файлов DAT в разных частях сети будут проводиться циклично в удобное время с минимальным участием со стороны администраторов или пользователей сети.
  • Разделение функций администрирования развертывания: для повышения эффективности использования пропускной способности сети используются различные серверы или контроллеры домена в различных сегментах глобальных сетей или других подразделениях сети, чтобы трафик обновлений оставался внутренним. Это также позволит снизить риск нарушений сетевой безопасности.
  • Сокращение времени ожидания загрузки новых файлов DAT или обновленных файлов механизма сканирования: трафик на компьютерах с McAfee существенно возрастает в дни публикации файлов DAT и доступности новых версий продукта. Отсутствие необходимости борьбы за полосу пропускания позволяет развертывать новое программное обеспечение с минимальными перерывами в работе.


Требования к эффективной стратегии обновления

Обычно для эффективного обновления требуется, чтобы как минимум один клиент или сервер в организации получал обновления с сайта загрузки McAfee. С него файлы можно реплицировать на все компьютеры организации. В идеале, следует свести к минимуму объем передаваемых по сети данных, автоматизировав процесс копирования обновленных файлов на общие сайты.

Основные факторы, которые необходимо принимать во внимание при выборе эффективной стратегии обновления — это число клиентов и число объектов. Кроме того, можно также учесть число систем на каждом удаленном объекте и способ их доступа в Интернет. Основные принципы использования центрального хранилища для получения обновлений и планирования задач обновления, позволяющих поддерживать среду в обновленном состоянии, применимы к организации любого размера. Сведения о развертывании приложений и обновлений см. в соответствующем руководстве по эксплуатации ePolicy Orchestrator.


Задачи обновления и принципы их работы

Используйте задачу обновления для получения текущих файлов DAT, механизма сканирования, пакетов обновлений и исправлений.

VirusScan Enterprise включает задачу обновления по умолчанию, которая запускается ежедневно в 17:00 с часовым периодом случайного выбора. Пользователь может создавать дополнительные задачи обновления по мере необходимости.

Действия при запуске задачи обновления

При запуске задачи обновления выполняются следующие действия.

  • Устанавливается подключение к первому включенному хранилищу (сайту обновлений) в списке. Если данное хранилище недоступно, выполняется обращение к следующему сайту — и так до тех пор, пока не будет установлено соединение или достигнут конец списка хранилищ.
  • Зашифрованный файл CATALOG.Z загружается из хранилища. Файл содержит фундаментальные данные, необходимые для обновления. На основе этих данных определяются доступные файлы и обновления.
  • Версии программного обеспечения в файле сравниваются с версиями, установленными на компьютере. Если доступны обновления программного обеспечения, они загружаются.

Прерывание задачи обновления

Если задача обновления прерывается по любой причине в ходе обновления, выполняются следующие действия.

  • Обновление, выполняемое с HTTP, UNC или локального сайта, возобновляется с места прерывания при следующем запуске задачи обновления.
  • Обновление, выполняемое с сайта FTP, не возобновляется, если загружался только один файл. Однако если задача прервалась в ходе загрузки нескольких файлов, она возобновляется с файла, предшествующего тому, который загружался в момент прерывания.

Обновление с помощью файла EXTRA.DAT

Файл EXTRA.DAT может использоваться в качестве временной меры в случае крайней необходимости. Файл EXTRA.DAT загружается из хранилища при каждом обновлении. Это дает гарантию того, что в случае изменения и повторной регистрации файла EXTRA.DAT в качестве пакета, все клиенты VirusScan Enterprise загрузят и будут использовать один и тот же обновленный пакет EXTRA.DAT. Например, файл EXTRA.DAT можно использовать в качестве более точного средства обнаружения одной и той же потенциально нежелательной программы или дополнительного средства обнаружения новых потенциально нежелательных программ. VirusScan Enterprise

Совет: После завершения работы с файлом EXTRA.DAT его необходимо удалить из главного хранилища и запустить задачу репликации, чтобы файл был удален со всех распределенных сайтов хранилищ. Это предотвратит загрузку файла EXTRA.DAT клиентами VirusScan Enterprise во время обновления. По умолчанию, обнаружение новых потенциально нежелательных программ в EXTRA.DAT не выполняется после добавления нового определения обнаружения в ежедневные файлы DAT.


Настройка задачи AutoUpdate

Для автоматического обновления файлов DAT и механизмов сканирования для всех продуктов McAfee необходимо задать свойства и расписание AutoUpdate.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка на вкладке.

  1. Для получения доступа к свойствам задачи AutoUpdate выполните следующие действия.

    • ePolicy Orchestrator 4.5 или 4.6: щелкните Меню | Системы | Дерево систем и выберите Задачи клиента.
      ПРИМЕЧАНИЕ: Для получения дополнительных сведений о создании новой запланированной задачи клиента см. Руководство по эксплуатации McAfee ePolicy Orchestrator 4.5.
    • ePolicy Orchestrator 4.0: щелкните Системы | Дерево систем | Задача клиента и выберите существующую задачу обновления. Или щелкните Создать задачу для создания новой задачи.
      ПРИМЕЧАНИЕ: Для получения дополнительных сведений о создании новой запланированной задачи клиента см. Руководство по эксплуатации McAfee ePolicy Orchestrator 4.0.
    • Консоль VirusScan: выберите существующую задачу обновления (щелкните правой кнопкой мыши и выберите Свойства), или создайте новую задачу (щелкните Задача | Создать задачу обновления и выберите новую задачу в списке).
      Совет: При создании новой задачи клиента рекомендуется переименовать ее, изменив имя на более описательное.
  2. Укажите местоположение и формат файла журнала.
  3. Укажите, следует ли получить обновленные файлы DAT, обновленный механизм сканирования и другие доступные обновления, например пакеты обновлений и обновления продукта.
  4. Укажите, какой исполняемый файл следует запустить после выполнения задачи обновления, а также, следует ли запускать его только в случае успешного обновления.
  5. Щелкните Планирование для настройки времени и периодичности запуска задачи. Дополнительные сведения см. в разделе Использование запланированных задач.
  6. Щелкните Обновить сейчас. Задача запустится немедленно.


Задачи отражения и принцип их работы

Задача отражения служит для репликации файлов обновлений из первого доступного хранилища, указанного в соответствующем списке, на сайт отражения в сети пользователя. Основным назначением данной задачи является отражение содержимого сайта загрузки McAfee на локальный сервер.

После репликации сайта McAfee, содержащего файлы обновления, компьютеры в сети могут загружать файлы с сайта отражения. Такой подход является одновременно практичным, так как позволяет обновлять любой компьютер в сети независимо от наличия доступа к сети Интернет, и эффективным, поскольку системы обмениваются данными с сервером, который находится ближе, чем сайт McAfee, что сокращает время доступа и загрузки.

Обновление программного обеспечения VirusScan Enterprise выполняется с учетом структуры каталогов. При отражении сайта очень важно выполнять репликацию всей структуры каталогов.
ПРИМЕЧАНИЕ: Данная структура каталогов также поддерживает предыдущие версии VirusScan Enterprise и NetShield при условии, что вся структура каталогов реплицируется в те же местоположения, которые использовались VirusScan Enterprise 8.8 для обновления.


Настройка задачи отражения

Чтобы сохранить файлы DAT и механизмы сканирования в назначенном местоположении для использования другими компьютерами, необходимо настроить местоположение и расписание с помощью свойств задач отражения.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка на вкладке.

  1. Для доступа к свойствам задач отражения используйте:

    • ePolicy Orchestrator 4.5 или 4.6: щелкните Меню | Системы | Дерево систем и выберите Задачи клиента.
      ПРИМЕЧАНИЕ: Для получения дополнительных сведений о создании новой запланированной задачи клиента см. Руководство по эксплуатации McAfee ePolicy Orchestrator 4.5.
    • ePolicy Orchestrator 4.0: щелкните Системы | Дерево систем | Задача клиента и выберите существующую задачу обновления. Или щелкните Создать задачу для создания новой задачи.
      ПРИМЕЧАНИЕ: Для получения дополнительных сведений о создании новой запланированной задачи клиента см. Руководство по эксплуатации McAfee ePolicy Orchestrator 4.0.
    • В Консоль VirusScan выполните одно из следующих действий.
      • Выберите существующую задачу отражения, щелкните правой кнопкой мыши и выберите Свойства. Появится диалоговое окно «Задача отражения».
      • Для создания новой задачи отражения выберите Задача | Создать задачу отражения. В результате в списке задач появится новая задача обновления. Щелкните новую задачу, чтобы открыть диалоговое окно «Задача отражения».
        ПРИМЕЧАНИЕ: Измените имя задачи на более описательное, щелкнув задачу правой кнопкой мыши и выбрав Переименовать.
  2. Консоль VirusScan: выберите существующую задачу обновления (щелкните правой кнопкой мыши и выберите Свойства), или создайте новую задачу (щелкните Задача | Создать задачу отражения и выберите новую задачу в списке).
    Совет: При создании новой задачи клиента рекомендуется переименовать ее, изменив имя на более описательное.
  3. Укажите местоположение и формат файла журнала.
  4. Укажите, следует ли получить обновленные определения обнаружений, обновленный механизм сканирования и файлы DAT, а также другие доступные обновления, такие как пакеты обновлений и обновления продуктов.
  5. Укажите, какой исполняемый файл следует запустить после выполнения задачи обновления, а также, следует ли запускать его только в случае успешного обновления.
  6. Щелкните Отразить местоположение для настройки назначения сервера отражения.
  7. Щелкните Планирование для настройки времени и периодичности запуска задачи. Дополнительные сведения см. в разделе Использование запланированных задач.
  8. Щелкните Отразить для немедленного запуска задачи.
  9. Настройте параметры на вкладке. Чтобы просмотреть определения параметров, щелкните ? или Справка на вкладке.

Определения вкладок

Вкладка Определения
Отражение
  • Укажите местоположение и формат файла журнала.
  • Укажите, какой исполняемый файл следует отразить после выполнения задачи обновления, а также, следует ли отражать его только в случае успешного обновления.


Принцип работы хранилища AutoUpdate

В списке хранилищ AutoUpdate (SITELIST.XML) содержится информация о конфигурации, необходимая для выполнения задачи AutoUpdate.

Список хранилищ AutoUpdate содержит следующую информацию:
  • сведения о хранилище и его местоположение;
  • предпочтительный порядок использования хранилищ;
  • настройки прокси-подключения (при необходимости);
  • зашифрованные учетные данные, необходимые для доступа к каждому хранилищу.

При выполнении задачи AutoUpdate устанавливается подключение к первому включенному хранилищу (сайту обновлений) в списке хранилищ. Если данное хранилище недоступно, выполняется обращение к следующему хранилищу и так до тех пор, пока не будет установлено соединение или достигнут конец списка хранилищ.

Если в сети используется прокси-сервер, можно указать используемые настройки прокси-подключения: адрес прокси-сервера и необходимость применения проверки подлинности. Сведения о прокси-подключении хранятся в списке хранилищ AutoUpdate. Заданные настройки прокси-подключения применяются ко всем хранилищам в списке.

Местоположение списка хранилищ AutoUpdate зависит от операционной системы.
  • Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server и Microsoft 2008 Server: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework
  • Microsoft Windows 7: C:\ProgramData\McAfee\Common Framework


Настройка списка хранилищ

Список хранилищ содержит хранилища, в которые извлекаются обновления. Пользователь может создать любое число хранилищ. Отдельные сайты могут использоваться постоянно, другие — лишь иногда.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В Консоль VirusScan выберите Сервис | Изменить список хранилищ AutoUpdate, чтобы открыть свойства Список хранилищ AutoUpdate.
    ПРИМЕЧАНИЕ: Для конфигурации функции хранилищ с помощью консоли ePolicy Orchestrator выберите Каталог политик | McAfee Agent и перейдите на вкладку Хранилища.
  2. Настройте параметры на вкладках.

Определения вкладок

Вкладка | Определения
Хранилища
  • Укажите хранилища, в которые необходимо получить обновления.
  • Настройте порядок доступа к хранилищам.
Параметры прокси-подключения | Укажите, какие настройки прокси-подключения необходимо использовать при обновлении.


Принципы отката файлов DAT

Если обнаружится, что текущие файлы DAT повреждены или несовместимы, можно выполнить их откат до последней архивной версии.

При обновлении файлов DAT старая версия сохраняется в следующей папке: <диск>:\Program Files\Common Files\McAfee\Engine\OldDats.

При откате файлов DAT текущие файлы заменяются версиями, сохраненными в папке OldDats, а в реестре устанавливается флажок: HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATS.

После выполнения отката вернуть предыдущую версию файла будет невозможно. При следующем обновлении версия файлов DAT в реестре сравнивается с файлами DAT в хранилище обновлений. Если новые файлы DAT совпадут с файлами в реестре, обновление выполняться не будет.


Откат файлов DAT

Для отката файлов DAT к предыдущей версии используется инструмент «Откат файлов DAT».

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В Консоль VirusScan выберите Сервис | Откат файлов DAT.
  2. Щелкните Да, чтобы продолжить откат файлов DAT.
    ПРИМЕЧАНИЕ: Эта функция недоступна в консоли ePolicy Orchestrator.
  3. Настройте параметры на вкладке.


Исключение элементов сканирования

Каждый сканер VirusScan Enterprise позволяет выполнять точную настройку списка сканируемых типов файлов. Например, можно исключить из сканирования отдельные файлы, папки и диски. Эти исключения необходимы, поскольку сканеры могут проверить и заблокировать файл, когда он используется базой данных или сервером. Это может привести к сбою базы данных или сервера либо возникновению ошибок.

Содержание

Связанные ссылки
Задание исключений
Использование подстановочных знаков при указании элементов для сканирования


Задание исключений

Укажите файлы, папки и диски, которые требуется исключить из операций сканирования. Можно также удалить исключения, заданные ранее.

Определения параметров

Параметр Определение
Объекты для исключения Выберите тип исключения.
  • Исключить по имени файла/местоположению: укажите имя файла, местоположение, а также следует ли исключить подпапки.
    ПРИМЕЧАНИЕ: Можно добавить косую черту (\) в конце строки, чтобы применить к папке. В противном случае она будет рассматриваться как исключение файла, и флажок Исключать подпапки будет отключен по умолчанию.
  • Исключить по типу файла: укажите типы файлов.
  • Исключить по сроку хранения: укажите тип доступа и минимальный срок хранения в днях.
Когда исключать Укажите, когда следует исключать выбранный элемент:
  • При чтении
  • При записи
Обработка исключений клиента Перезаписать исключения клиента: исключение только тех элементов, которые указаны в данной политике. Если параметр не выбран, на клиентском компьютере будут использоваться исключения, указанные локально и заданные в данной политике.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.


Использование подстановочных знаков при указании элементов для сканирования

Подстановочные знаки можно использовать для исключения типов файлов по расширению.

При использовании подстановочных знаков действуют следующие ограничения.

  • Допустимыми подстановочными знаками являются вопросительный знак (?) для исключения отдельных символов и звездочка (*) для исключения нескольких символов.
  • Подстановочные знаки можно указывать в пути перед косой чертой (\). Пример. C:\ABC\*\XYZ соответствует C:\ABC\DEF\XYZ.
  • Исключение, которое содержит символы знака вопроса (?), применяется, когда число символов совпадает с длиной имени файла или папки. Пример. Исключение «W??» позволяет исключить имя WWW, но не исключает WW или WWWW.
  • В синтаксисе дополнительно используются две звездочки (**), которые означают ноль или любые другие символы, в том числе косую черту. Это позволяет определять исключения различной глубины. Пример. C:\ABC\**\XYZ соответствует C:\ABC\DEF\XYZ и C:\ABC\DEF\DEF\XYZ, и т.д.


Использование запланированных задач

Процесс настройки проверки по требованию, задач AutoUpdate или задач отражения предполагает указание времени, периодичности и продолжительности выполнения соответствующих задач. В рамках данной процедуры необходимо также настроить разрешения пользователя.

Содержание

Связанные ссылки
Настройка расписания выполнения задач
Связанная информация
Планирование задач


Планирование задач

Пользователь может задать выполнение задач по требованию, задач AutoUpdate и задач отражения в определенное время или через определенные интервалы. Способ планирования задач зависит от используемой консоли интерфейса пользователя.

Планирование задач
  • Консоль ePolicy Orchestrator: используйте вкладку Планирование для отображения страницы планирования.
  • Консоль VirusScan: нажмите кнопку Планирование для отображения диалогового окна планирования.
Связанные задачи
Настройка задач проверки по требованию
Связанные ссылки
Настройка задачи AutoUpdate
Настройка задачи отражения
Связанная информация
Настройка задач сервера ePolicy Orchestrator


Настройка расписания выполнения задач

Для настойки запуска задачи в указанное время или через определенный интервал времени используйте диалоговое окно «Параметры планирования».

Перед началом работы

Для планирования задачи необходимы права администратора. Права администратора дают пользователю доступ к разделу реестра запланированной задачи с возможностью записи.

Чтобы запланировать задачу, щелкните Планирование в диалоговом окне свойств задачи.

ОСТОРОЖНО:
McAfee рекомендует планировать проверку по требованию с минимальными интервалами.
Минимальные интервалы проверки, рекомендуемые McAfee:
  • Ежедневно: только в случае серьезной вирусной эпидемии.
  • Еженедельно: рекомендуется.
  • Ежемесячно: допустимо.
  • Ежеквартально: абсолютный минимум.

Определения вкладок

Вкладка Определения
Задача
  • Запуск запланированной задачи в указанное время.
  • Остановка задачи, если она выполняется в течение указанного количества часов и минут.
  • Указание параметров учетной записи пользователя: имени пользователя, домена и пароля.
Планирование

Задание частоты выполнения задачи по расписанию и соответствующих настроек.


Часть II. Обнаружение угроз

Обнаружение угроз является вторым этапом в стратегии защиты, в ходе которого обнаруживаются вредоносные программы, пытающиеся проникнуть в систему.

Содержание

  • Сканирование объектов при доступе
  • Сканирование объектов по требованию
  • Сканирование электронной почты при доставке и по требованию


Сканирование объектов при доступе

Сканер при доступе проверяет файлы компьютера при обращении к ним. Благодаря этому обеспечивается непрерывное обнаружение угроз в режиме реального времени. Сканер при доступе также используется при работе функций «Защита доступа» и «Защита от переполнения буфера», которые отвечают за обнаружение нарушений прав доступа и переполнения буфера, соответственно.

Содержание

Связанные понятия
Проверка при доступе и принцип ее работы
Сравнение сканирования: запись на диск и чтение с диска
Сравнение сканирования: параметр «Сканирование всех файлов» и параметр «По умолчанию + дополнительные типы файлов»
Принцип сканирования сценариев
Определение числа политик сканирования
Принцип работы Artemis
Связанная информация
Настройка общих параметров и настроек процессов


Проверка при доступе и принцип ее работы

Сканер, запускаемый при доступе, внедряется в систему на самом низком уровне (драйвер фильтра файловой системы) и сканирует файлы на входе в систему. Сканер при доступе выступает как часть системы (системная служба) и при обнаружениях выдает о них уведомления через интерфейс.

При попытке открытия, закрытия или переименования файла сканер перехватывает операцию и выполняет следующие действия.

  1. Сканер определяет необходимость сканирования файла на основе следующих критериев:
    • расширение файла соответствует конфигурации;
    • кэширование файла не выполнено;
    • файл не был исключен;
    • файл не сканировался ранее.
  2. Если файл отвечает критериям сканирования, он сканируются путем сравнения содержащейся в нем информации с известными сигнатурами вредоносных программ в загруженных файлах DAT.
    • Если угрозы не обнаруживаются, результат кэшируется и выдается разрешение на чтение, запись или переименование файла.
    • При обнаружении угрозы в файле операция запрещается и выполняется заданное действие. Пример.
      • Необходимость очистки файла определяется загруженными файлами DAT.
      • Результаты записываются в журнал активности, если в сканере включено журналирование.
      • Если для сканера задана соответствующая настройка, отображается предупреждение Сообщения проверки при доступе с именем файла и описанием выполненного действия.
  3. Если файл не отвечает критериям сканирования, он не сканируется. Он кэшируется и операция разрешается.
    ПРИМЕЧАНИЕ: Кэш сканирования очищается и все содержащиеся в нем файлы повторно сканируются при изменении конфигурации проверки при доступе, добавлении файла EXTRA.DAT, а также при заполнении кэша.


Сравнение сканирования: запись на диск и чтение с диска

Сканер, запускаемый при доступе, работает по-разному в зависимости от того, выполняет ли пользователь запись на диск или чтение с диска.

При записи файлов на диск проверяются перечисленные ниже элементы.

  • Входящие файлы, записываемые на локальный жесткий диск.
  • Файлы, создаваемые на локальном жестком диске или сопоставленном сетевом диске (к ним относятся новые файлы, измененные файлы или файлы, копируемые или перемещаемые с одного диска на другой).
    ПРИМЕЧАНИЕ: Для сканирования сопоставленных сетевых дисков включите параметр Сетевые диски. См. раздел Включение сетевых дисков.

    Такое сканирование возможно только для клиента, на котором установлено программное обеспечение VirusScan Enterprise. Доступ к сопоставленному сетевому диску с других систем не отслеживается.

При чтении файлов с диска сканер, запускаемый при доступе, проверяет нижеперечисленные элементы.

  • Исходящие файлы, читаемые с локального жесткого диска или сопоставленных сетевых дисков.
    ПРИМЕЧАНИЕ: Для сканирования сопоставленных сетевых дисков выберите параметр Сетевые диски (о котором речь шла выше), чтобы включить удаленные сетевые файлы.
  • Любой файл, выполняемый на локальном жестком диске.
  • Любой файл, открытый на локальном жестком диске.
  • Любой файл, переименовываемый на локальном жестком диске при изменении свойств файла.


Сравнение сканирования: параметр «Сканирование всех файлов» и параметр «По умолчанию + дополнительные типы файлов»

Сканер, запускаемый при доступе, работает по-разному в зависимости от того, задано ли в нем сканирование всех файлов или типов файлов по умолчанию и дополнительных типов.

При выборе параметра Все файлы сканер проверяет каждый тип файлов на наличие всех возможных угроз.

При выборе параметра По умолчанию + дополнительные типы файлов сканер проверяет файлы по списку выбранных пользователем типов файлов.
  • Типы файлов по умолчанию: сканер проверяет указанный тип файлов только на наличие угроз, характерных для этого типа.

  • Дополнительные типы файлов: сканер проверяет файлы с одинаковыми расширениями на все возможные угрозы.

  • Указанные типы файлов: сканер проверяет определенные пользователем типы файлов на все возможные угрозы.


Принцип сканирования сценариев

Сканер сценариев является посредником реального компонента сервера сценариев Windows. Он перехватывает сценарии и перед их выполнением сканирует их.

Сканер сценариев проверяет следующее.

  • Если сценарий не содержит угроз, сканер передает его реальному компоненту сервера сценариев.
  • Если сценарий содержит потенциальную угрозу, он не выполняется.
Доверенные процессы, а также веб-сайты, использующие сценарии, можно исключить из проверки.
ПРИМЕЧАНИЕ: В системах Windows Server 2008 исключения URL-адресов из диапазона сканирования сценариев не работают в Windows Internet Explorer, если не установлен флажок Разрешение сторонних расширений обозревателя для настройки и перезагрузки Windows Server 2008. Для получения дополнительных сведений см. https://kc.mcafee.com/corporate/index?page=content&id=KB69526.


Принцип работы Artemis

Система Artemis предполагает использование эвристических методов проверки наличия подозрительных файлов. Благодаря ей клиенты, использующие антивирусные продукты McAfee на основе Windows, получают сведения о самых последних обнаружениях в реальном времени для определенных вредоносных программ.

Система Artemis обеспечивает защиту не от всех классов вредоносных программ, а только от подозрительных образцов. Преимущество защиты от определенных типов угроз заключается в возможности защитить пользователей, использующих систему безопасности McAfee, практически сразу, как только лаборатория McAfee подтвердит вредоносность образца.

Пользователь может настроить заданные администратором уровни чувствительности, которые в системе Artemis используются при обнаружении подозрительных программ и библиотек DLL, запущенных на клиентских системах, которые защищены с помощью VirusScan Enterprise. При обнаружении подозрительной программы система Artemis отправляет DNS-запрос, содержащий контрольную сумму подозрительного файла, на центральный сервер базы данных McAfee Labs.

ПРИМЕЧАНИЕ: В этом выпуске система Artemis включена по умолчанию с установленным низким уровнем чувствительности.


Определение числа политик сканирования

Выполните следующую процедуру, чтобы определить, следует ли настраивать больше одной политики проверки при доступе.


Настройка общих параметров и настроек процессов

Общие политики и политики процессов для сканера, включаемого при доступе, настраиваются отдельно друг от друга.
  • Общие параметры: включены параметры, применяемые ко всем процессам.
  • Настройки процессов: позволяют настроить одну политику сканирования для всех процессов или настроить разные политики для процессов, определяемых как процессы по умолчанию, малоопасные процессы и процессы с высоким риском.


Настройка общих параметров

Общие настройки применяются к сканированию всех процессов и содержат такие параметры, как максимальное время сканирования, сканирование сценариев, блокировка нежелательных угроз с удаленного компьютера, отправка сообщений при обнаружении угроз и сообщение об обнаружениях.

Общие настройки сканирования при доступе выполняются на одной из следующих консолей интерфейса пользователя.

Связанная информация
Сканирование объектов при доступе


ePolicy Orchestrator 4.5 или 4.6

Выполните общие настройки, применяемые к сканированию всех процессов, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Общие политики при доступе выберите вкладку Общие, чтобы настроить общую политику, которая применяется ко всем процессам проверки при доступе. Например, какие объекты требуется сканировать при доступе, когда выполнять сканирование, максимальное время сканирования и требуется ли сканировать файлы cookie.

    Можно задать сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе. Эта функциональная особенность усиливает безопасность системы, однако может негативно повлиять на время загрузки системы.

    Чтобы настроить функцию сканирования процессов при включении, в группе сканирования щелкните Процессы при включении, чтобы выполнить сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе.
    ПРИМЕЧАНИЕ: При включении этой функции время, необходимое для загрузки системы, может увеличиться.
  5. На вкладке ScriptScan включите ScriptScan и настройте процессы или URL-адреса, которые требуется исключить из сканирования.
  6. На вкладке Блокировка задайте блокировку соединений с удаленных компьютеров, на которых записываются файлы с потенциальными угрозами или нежелательные программы.
    ПРИМЕЧАНИЕ: По умолчанию, когда удаленная система записывает какую-либо вредоносную программу в систему с VirusScan Enterprise, VirusScan Enterprise блокирует соединение с этой удаленной системой.

    Можно также настроить сообщение, которое будет отправляться системе с записанной вредоносной программой.

    ПРИМЕЧАНИЕ: Для отправки такого сообщения должна быть запущена служба Windows Messenger.
  7. На вкладке Сообщения настройте сообщения для уведомления локальных пользователей в случае обнаружений, а также укажите, какие действия может предпринять пользователь, чтобы устранить угрозу.
  8. На вкладке Отчеты включите файлы журналов сканирования активности, определите их местоположение, размер и формат, а также включите дополнительные журналы сканирования, которые помогут при диагностике данной угрозы.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


ePolicy Orchestrator 4.0

Выполните общие настройки, применяемые к сканированию всех процессов, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Общие политики при доступе выберите вкладку Общие, чтобы настроить общую политику, которая применяется ко всем процессам проверки при доступе. Например, какие объекты требуется сканировать при доступе, когда выполнять сканирование, максимальное время сканирования и требуется ли сканировать файлы cookie.

    Можно задать сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе. Эта функциональная особенность усиливает безопасность системы, однако может негативно повлиять на время загрузки системы.

    Чтобы настроить функцию сканирования процессов при включении, в группе сканирования щелкните Процессы при включении, чтобы выполнить сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе.
    ПРИМЕЧАНИЕ: При включении этой функции время, необходимое для загрузки системы, может увеличиться.
  5. На вкладке ScriptScan включите ScriptScan и настройте процессы или URL-адреса, которые требуется исключить из сканирования.
  6. На вкладке Блокировка задайте блокировку соединений с удаленных компьютеров, на которых записываются файлы с потенциальными угрозами или нежелательные программы.
    ПРИМЕЧАНИЕ: По умолчанию, когда удаленная система записывает какую-либо вредоносную программу в систему с VirusScan Enterprise, VirusScan Enterprise блокирует соединение с этой удаленной системой.

    Можно также настроить сообщение, которое будет отправляться системе с записанной вредоносной программой.

    ПРИМЕЧАНИЕ: Для отправки такого сообщения должна быть запущена служба Windows Messenger.
  7. На вкладке Сообщения настройте сообщения для уведомления локальных пользователей в случае обнаружений, а также укажите, какие действия может предпринять пользователь, чтобы устранить угрозу.
  8. На вкладке Отчеты включите файлы журналов сканирования активности, определите их местоположение, размер и формат, а также включите дополнительные журналы сканирования, которые помогут при диагностике данной угрозы.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


Консоль VirusScan

Выполните общие настройки, применяемые к сканированию всех процессов, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Сканер при доступе, а затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. На странице Общие политики при доступе выберите вкладку Общие, чтобы настроить общую политику, которая применяется ко всем процессам проверки при доступе. Например, какие объекты требуется сканировать при доступе, когда выполнять сканирование, максимальное время сканирования и требуется ли сканировать файлы cookie.

    Можно задать сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе. Эта функциональная особенность усиливает безопасность системы, однако может негативно повлиять на время загрузки системы.

    Чтобы настроить функцию сканирования процессов при включении, в группе сканирования щелкните Процессы при включении, чтобы выполнить сканирование всех процессов, в настоящий момент запущенных в системе, независимо от того, включена ли проверка при доступе.
    ПРИМЕЧАНИЕ: При включении этой функции время, необходимое для загрузки системы, может увеличиться.
  3. На вкладке ScriptScan включите ScriptScan и настройте сценарии, которые требуется исключить из сканирования.
  4. На вкладке Блокировка задайте блокировку соединений с удаленных компьютеров, на которых записываются файлы с потенциальными угрозами или нежелательные программы.
    ПРИМЕЧАНИЕ: По умолчанию, когда удаленная система записывает какую-либо вредоносную программу в систему с VirusScan Enterprise, VirusScan Enterprise блокирует соединение с этой удаленной системой.

    Можно также настроить сообщение, которое будет отправляться системе с записанной вредоносной программой.

    ПРИМЕЧАНИЕ: Для отправки такого сообщения должна быть запущена служба Windows Messenger.
  5. На вкладке Сообщения настройте сообщения для уведомления локальных пользователей в случае обнаружений, а также укажите, какие действия может предпринять пользователь, чтобы устранить угрозу.
  6. На вкладке Отчеты включите файлы журналов сканирования активности, определите их местоположение, размер и формат, а также включите дополнительные журналы сканирования, которые помогут при диагностике данной угрозы.
    ПРИМЕЧАНИЕ: Эти файлы журналов очень полезны при диагностике угроз безопасности и помогают определить, какие действия следует предпринять в отношении этих угроз.


Настройка параметров процессов

Настройка процессов сканирования, инициируемых при доступе, выполняется на основе риска, назначенного каждому процессу. Можно настроить одну политику сканирования по умолчанию для всех процессов или настроить различные политики на основе риска, назначенного каждому процессу. К настраиваемым параметрам относятся: назначение риска процессам, определение элементов для сканирования, сканирование вирусов Artemis, сканирование сжатых файлов, выполнение действий с обнаружениями и сканирование на предмет наличия потенциально нежелательных программ.

Настройки процессов сканирования при доступе выполняется на одной из следующих консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Настройте политики процессов по умолчанию, активируемых при доступе, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На вкладке «Процессы» выберите Настроить разные политики сканирования для процессов с высокой и низкой степенью риска и процессов по умолчанию, чтобы отобразился список процессов, инициируемых при доступе, а именно: процессов по умолчанию, малоопасных процессов или процессов с высоким риском.
  5. На странице процессов по умолчанию, малоопасных процессов или процессов с высоким риском, инициируемых при доступе, настройте параметры каждой вкладки. См. таблицу Вкладки с настройками процессов.


ePolicy Orchestrator 4.0

Настройте политики процессов по умолчанию, активируемых при доступе, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На вкладке «Процессы» выберите Настроить разные политики сканирования для процессов с высокой и низкой степенью риска и процессов по умолчанию, чтобы отобразился список процессов, инициируемых при доступе, а именно: процессов по умолчанию, малоопасных процессов или процессов с высоким риском.
  5. На странице процессов по умолчанию, малоопасных процессов или процессов с высоким риском, инициируемых при доступе, настройте параметры каждой вкладки. См. таблицу Вкладки с настройками процессов.


Консоль VirusScan

Настройте свойства сканирования при доступе, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Сканер при доступе, а затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. В левой панели щелкните Все процессы.
  3. На вкладке «Процессы» выберите Настроить разные политики сканирования для процессов с высокой и низкой степенью риска и процессов по умолчанию, чтобы отобразился список процессов, инициируемых при доступе, а именно: процессов по умолчанию, малоопасных процессов или процессов с высоким риском.
  4. На странице процессов по умолчанию, малоопасных процессов или процессов с высоким риском, инициируемых при доступе, настройте параметры каждой вкладки. См. таблицу Вкладки с настройками процессов.


Вкладки с настройками процессов

В таблице ниже приведены описания вкладок сканера, запускаемого при доступе.

Вкладка | Определения
Процессы
  • Процессы по умолчанию, активируемые при доступе: выберите, чтобы настроить одну политику сканирования для всех процессов или настроить разные политики сканирования для процессов по умолчанию, малоопасных процессов и процессов с высоким риском.
    ПРИМЕЧАНИЕ: В случае настройки одной политики сканирования эта политика будет применяться для всех процессов. В случае настройки разных политик сканирования для процессов с высокой и низкой степенью риска эта политика будет применяться только к тем процессам, которые не определены как малоопасные или с высоким риском.
  • Малоопасные процессы, активируемые при доступе: укажите процессы, определенные как малоопасные.
  • Процессы с высоким риском, активируемые при доступе: укажите процессы, определенные как процессы с высоким риском.
ПРИМЕЧАНИЕ: Прежде чем настраивать отдельные политики для малоопасных процессов и процессов с высоким риском, необходимо выбрать параметр Настроить отдельные политики сканирования для малоопасных процессов, процессов с высоким риском и процессов по умолчанию на вкладке Процессы по умолчанию, активируемые при доступе.
Элементы сканирования
  • Указывается, требуется ли сканировать файлы при чтении, при записи, на сетевых дисках и сканирование файлов, открытых для резервного копирования.
    ОСТОРОЖНО:
    Если не включить параметры При записи на диск и При чтении с диска, система может остаться без защиты от многочисленных вредоносных атак.
  • Указание сканируемых файлов и типов файлов.
    ОСТОРОЖНО:
    Если не включить параметр Все файлы, система может остаться без защиты от многочисленных вредоносных атак.
  • Сканирование на предмет наличия потенциальных угроз, похожих на нежелательные программы, «троянских коней» и макровирусы.
  • Сканирование внутри архивов и декодирование файлов в кодировке MIME.
  • Включение сканирования потенциально нежелательных программ при доступе.
Исключения | Выбор дисков, файлов и папок, исключаемых из сканирования.
Действия
Для обнаружений угроз
  • Действие, которое при обнаружении угрозы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при обнаружении угрозы, если первое не дало результата.
Для обнаружения нежелательных программ
  • Действие, которое при обнаружении нежелательной программы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при обнаружении нежелательной программы, если первое не дало результата.


Включение сетевых дисков

Для сканирования сопоставленных сетевых дисков включите параметр Сетевые диски.

Настройка проверки сетевых дисков при доступе, осуществляемая на странице «Политики процессов по умолчанию, активируемых при доступе», выполняется на одной из перечисленных ниже консолей интерфейса пользователя.


ePolicy Orchestrator 4.5 или 4.6

Включите сетевые диски на странице политик процессов по умолчанию, активируемых при доступе, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политики процессов по умолчанию, активируемых при доступе выберите вкладку Элементы сканирования и параметр Сетевые диски рядом с параметром «Сканировать файлы».
  5. Щелкните Сохранить.


ePolicy Orchestrator 4.0

Включите сетевые диски, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Политики процессов по умолчанию, активируемых при доступе выберите вкладку Элементы сканирования и параметр Сетевые диски рядом с параметром «Сканировать файлы».
  5. Щелкните Сохранить.


Консоль VirusScan

Включите сетевые диски, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Сканер при доступе, а затем щелкните Свойства, чтобы открыть диалоговое окно Свойства сканера при доступе.
  2. Выберите вкладку Элементы сканирования и параметр Сетевые диски рядом с параметром «Сканировать файлы».
  3. Щелкните Сохранить.


Сканирование объектов по требованию

Сканер по требованию позволяет проверить все области компьютера на предмет потенциальных угроз в удобное для пользователя время или через регулярные интервалы времени. Проверка по требованию является дополнением к непрерывной защите, которую обеспечивает сканер при доступе, а также позволяет запланировать регулярные процессы проверки в удобное время так, чтобы они не мешали работе.

Содержание

Связанные понятия
Проверка по требованию и принцип ее работы
Методы проверки по требованию и их определение
Принцип сканирования удаленного хранилища
Принцип работы отложенного сканирования
Принципы использования ресурсов системы
Связанные задачи
Настройка задач проверки по требованию
Настройка глобального системного кэша


Проверка по требованию и принцип ее работы

С помощью сканера по требованию осуществляется осмотр всех системных файлов, папок, памяти, реестра и других элементов на предмет вредоносных программ, которые могут нанести вред системе. Время и способ проверки по требованию определяется пользователем. Сканирование системы можно запускать вручную, в запланированное время или, например, при загрузке системы.

При попытке открытия, закрытия или переименования файла сканер перехватывает операцию и выполняет следующие действия.

  1. Сканер определяет необходимость сканирования файла, папки или диска на основе следующих критериев:
    • расширение файла соответствует конфигурации;
    • кэширование файла не выполнено;
    • файл не был исключен;
    • файл не сканировался ранее.
      ПРИМЕЧАНИЕ: Сканер по требованию использует эвристические методы проверки наличия подозрительных файлов, если настроена система Artemis. Для получения дополнительных сведений см. раздел Принцип работы Artemis.
  2. Если файл, папка или диск отвечают критериям сканирования, они сканируются путем сравнения содержащейся в них информации с известными сигнатурами вирусов в загруженных файлах DAT.
    • Если угрозы не обнаруживаются, результат кэшируется и выполняется проверка следующего элемента.
    • При обнаружении угрозы выполняется настроенное действие. Пример.
      • Необходимость очистки определяется загруженными файлами DAT.
      • Результаты записываются в журнал активности, если в сканере включено журналирование.
      • В диалоговом окне Ход выполнения проверки по требованию отображаются сведения об имени раздела памяти, файла, папки или диска и выполненном действии.
  3. Если раздел памяти, файл, папка или диск не отвечают критериям сканирования, они не сканируются. Сканер продолжает работать до тех пор, пока все данные не будут отсканированы.
Связанные понятия
Принцип работы Artemis


Методы проверки по требованию и их определение

При проверке по требованию используются следующие два метода: сканирование процессов в памяти и добавочное или возобновляемое сканирование.

Сканирование процессов в памяти

При использовании этого метода перед запуском задачи проверки по требованию выполняется проверка всех активных процессов. Обнаруженный нежелательный процесс выделяется и останавливается. Это означает, что одна проверка с помощью сканера, запускаемого по требованию, позволяет удалить все вхождения потенциально нежелательной программы.

добавочное или возобновляемое сканирование

При использовании этого метода можно задать временной интервал проверки по требованию. Проверка всей системы будет выполняться в несколько сеансов. Добавочное сканирование можно настроить, задав временной предел для запланированного сканирования. Сканирование будет останавливаться по достижении заданного временного предела. При следующем запуске данной задачи сканирование начнется с того места в структуре файлов и папок, на котором остановилось предыдущее сканирование.


Принцип сканирования удаленного хранилища

Данные удаленного хранилища имеют иерархическую структуру с двумя заданными уровнями.

Два уровня хранилища
  • Верхний уровень, локальное хранилище: включает тома диска NTFS на компьютере, где выполняется удаленное хранение на платформе Windows 2000 Server.
  • Нижний уровень, удаленное хранилище: находится в автоматизированной ленточной библиотеке или в автономном ленточном томе, подключенном к серверному компьютеру.

Удаленное хранилище автоматически копирует доступные файлы в локальных томах в ленточную библиотеку, а затем выполняет мониторинг пространства, доступного в локальных томах. Данные файлов кэшируются локально, поэтому доступ к ним осуществляется достаточно быстро. При необходимости данные из локального хранилища перемещаются в удаленное. Для доступа к файлу в томе, управляемом удаленным хранилищем, откройте файл обычным образом. Если данные для файла в локальном томе больше не кэшируются, удаленное хранилище вызывает данные из ленточной библиотеки.

Связанные задачи
Настройка задач проверки по требованию


Принцип работы отложенного сканирования

Чтобы улучшить производительность, можно отложить задачи проверки по требованию, когда заряд батареи на исходе или на время показа презентаций. Кроме того, пользователь может откладывать запланированное сканирование с шагом в один час. Запланированная проверка по требованию может быть отложена на период от 1 часа до 24 часов или на неопределенный период времени.

Каждый период пользовательской задержки составляет 1 час. Например, если для параметра Максимальная задержка задано значение 2, пользователь может отложить задачу сканирования два раза или на два часа. По истечении указанного максимального количества часов сканирование будет возобновлено. Если администратор разрешит бессрочную задержку, установив для параметра значение нуль, пользователь сможет и далее откладывать сканирование на неопределенный срок.


Принципы использования ресурсов системы

При проверке по требованию используется настройка приоритета Windows для процесса сканирования и приоритет потоков. Это позволяет операционной системе задавать системный предел для потока проверки по требованию в любой момент процесса сканирования. Параметр использования ресурсов системы в окне «Свойства проверки по требованию» соответствует настройке приоритета Windows.

Установка низкого значения системного предела для потока сканирования повышает производительность других работающих приложений. Низкое значение следует устанавливать при высокой активности конечного пользователя. И наоборот, при установке для системного предела значения «норма» сканирование выполняется быстрее. Значение «норма» следует устанавливать в системах с большим объемом данных и низкой активностью конечных пользователей.

В следующей таблице показаны настройки процесса по умолчанию для VirusScan Enterprise и ePolicy Orchestrator.

Настройки процесса VirusScan Enterprise | Настройка приоритета Windows
Низкий | Низкий
Ниже нормы: параметр по умолчанию ePolicy Orchestrator | Ниже нормы
Норма: параметр по умолчанию VirusScan Enterprise 8.8 | Норма
Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Настройка задач проверки по требованию

Настройка задач по требованию зависит от используемой консоли интерфейса пользователя. В задачах ниже описывается данных процесс для каждой консоли интерфейса пользователя.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan
Связанные ссылки
Настройка вкладок задач проверки по требованию


ePolicy Orchestrator 4.5 или 4.6

Настройте задачи проверки по требованию, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Система | Дерево систем и выберите Задача клиента.
  2. На открывшейся странице «Задача клиента» выполните следующие действия.
    • Для изменения существующей задачи проверки по требованию щелкните Изменить параметры в столбце Действия задачи, чтобы открыть страницу «Описание».
    • Чтобы создать новую задачу проверки по требованию, щелкните Действия | Создать задачу. В результате откроется страница «Описание».
  3. На странице «Описания» выполните следующие действия.
    • При изменении существующей задачи проверки по требованию проверьте описания и щелкните Далее.
    • При создании новой задачи проверки по требованию выполните следующие настройки и щелкните Далее.
      • Имя и Примечания.
      • Тип: выберите Проверка по требованию (VirusScan Enterprise 8.8) в списке.
      • Теги, которые определяют компьютеры, получающие задачу проверки по требованию.
  4. На открывшейся странице построителя задач клиента настройте каждую из вкладок. Подробные сведения см. в разделе Настройка вкладок задач проверки по требованию.


ePolicy Orchestrator 4.0

Настройте задачи проверки по требованию, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Дерево систем | Задача клиента.
  2. На открывшейся странице «Задача клиента» выполните следующие действия.
    • Для изменения существующей задачи проверки по требованию щелкните Изменить в столбце Действия задачи, чтобы открыть страницу «Описание».
    • Чтобы создать новую задачу проверки по требованию, щелкните Действия | Создать задачу. В результате откроется страница «Описание».
  3. Выполните одно из следующих действий.
    • При изменении существующей задачи проверки по требованию проверьте описания и щелкните Далее.
    • При создании новой задачи проверки по требованию выполните следующие настройки и щелкните Далее.
      • Имя и Примечания.
      • Тип: выберите Проверка по требованию (VirusScan Enterprise 8.8) в списке.
      • Теги, которые определяют компьютеры, получающие задачу проверки по требованию.
  4. На открывшейся странице построителя задач клиента настройте каждую из вкладок. Подробные сведения см. в разделе Настройка вкладок задач проверки по требованию.


Консоль VirusScan

Настройте задачи проверки по требованию, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. Откройте страницу «Свойства проверки по требованию» для существующей или новой задачи.
    • Выберите существующую задачу проверки по требованию, щелкните ее правой кнопкой мыши и выберите Свойства.
    • Создайте новую задачу, выберите Задача | Создать задачу проверки по требованию, щелкните правой кнопкой мыши новую задачу и выберите Свойства.
  2. Настройте каждую вкладку в диалоговом окне «Свойства проверки по требованию». Подробные сведения см. в разделе Настройка вкладок задач проверки по требованию.
Связанные ссылки
Настройка вкладок задач проверки по требованию


Настройка вкладок задач проверки по требованию

VirusScan Enterprise включает задачу проверки по требованию по умолчанию. Можно использовать задачу по умолчанию или создать новую.

Настройте параметры на каждой вкладке. Чтобы просмотреть определения параметров, щелкните ? или Справка на каждой вкладке.

Определения вкладок

Вкладка | Определения
Области сканирования
  • Указание папок и элементов для сканирования.
  • Включение запущенных процессов.
  • Включение подпапок в диапазон сканирования.
  • Включение загрузочных секторов в диапазон сканирования.
  • Включение разделов и значений реестра в диапазон сканирования.
  • Включение файлов cookie в диапазон сканирования.
ОСТОРОЖНО:
Если не выполнить сканирование памяти на наличие руткитов и запущенных процессов, система останется без защиты от многочисленных вредоносных атак.
ПРИМЕЧАНИЕ: В диалоговом окне Ход выполнения проверки по требованию области сканирования отображаются в виде разделенных запятыми элементов строки, следующих за словами Сканирование в. По завершении процесса сканирования они удаляются из строки.
Элементы сканирования
  • Указание сканируемых файлов и типов файлов.
  • Включение проверки потенциально нежелательных программ по требованию.
  • Сканирование внутри архивов и декодирование файлов в кодировке MIME.
  • Сканирование файлов, перемещенных в хранилище.
  • Сканирование на предмет наличия потенциальных угроз, похожих на нежелательные программы, «троянских коней» и макровирусы.
Исключения | Выбор дисков, файлов и папок, исключаемых из сканирования, по имени или местоположению, по типу или сроку хранения файла.
Производительность
  • Настройка времени отсрочки сканирования и продолжительности задержки.
  • Указание процента использования ресурсов системы.
  • Настройка уровня чувствительности для системы Artemis.
Действия
Для обнаружений угроз
  • Действие, которое при обнаружении угрозы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при обнаружении угрозы, если первое не дало результата.
Для обнаружения нежелательных программ
  • Действие, которое при обнаружении нежелательной программы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при обнаружении нежелательной программы, если первое не дало результата.

Чтобы просмотреть разрешенные действия в диалоговом окне запроса, выберите действие.

Отчеты
  • Включение журналирования активности.
  • Задание имени и расположения файла журнала.
  • Задание предельного размера файла журнала.
  • Выбор формата файла журнала.
  • Указание дополнительных сведений, которые необходимо записывать помимо событий сканирования.
  • Выбор сведений, которые необходимо записывать в журнал помимо событий сканирования:
    • настройки сеанса;
    • сводка сеанса;
    • сбой при сканировании зашифрованных файлов.
  • Включение оповещений при обнаружении файлов cookie.
Задача Указание случаев запуска задачи проверки по требованию.
ПРИМЕЧАНИЕ: Эта вкладка доступна только в ePolicy Orchestrator.


Настройка глобального системного кэша

В кэше сканирования VirusScan Enterprise сохраняется список просканированных файлов, которые не заражены. Для повышения производительности системы можно сохранять данную информацию кэша сканирования при перезагрузке системы. Сканер, запускаемый по требованию, использует информацию о незараженных файлах в кэше сканирования, что устраняет необходимость в повторном их сканировании.

Функции кэша сканирования можно настроить, используя вкладки «Политики с общими параметрами» и «Глобальные настройки сканирования» в следующих консолях интерфейса пользователя.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan


ePolicy Orchestrator 4.5 или 4.6

Настройте функцию кэша сканирования в окне «Политики с общими параметрами», используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка в интерфейсе.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В окне «Политики с общими параметрами» щелкните вкладку Глобальные настройки сканирования для настройки параметров кэша сканирования VirusScan Enterprise.
  5. Настройте следующие глобальные параметры для кэша сканирования.
    • Щелкните Включить сохранение данных сканирования при перезагрузке, чтобы результаты сканирования незараженных файлов сохранялись при перезагрузке системы.
    • Щелкните Разрешить использование кэша при проверке по требованию, чтобы сканер, запускаемый по требованию, использовал существующие результаты сканирования незараженных файлов, не выполняя их повторное сканирование.
  6. Щелкните Сохранить.


ePolicy Orchestrator 4.0

Настройте функцию кэша сканирования в окне «Политики с общими параметрами», используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? или Справка в интерфейсе.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. В окне «Политики с общими параметрами» щелкните вкладку Глобальные настройки сканирования для настройки параметров кэша сканирования VirusScan Enterprise.
  5. Настройте следующие глобальные параметры для кэша сканирования.
    • Щелкните Включить сохранение данных сканирования при перезагрузке, чтобы результаты сканирования незараженных файлов сохранялись при перезагрузке системы.
    • Щелкните Разрешить использование кэша при проверке по требованию, чтобы сканер, запускаемый по требованию, использовал существующие результаты сканирования незараженных файлов, не выполняя их повторное сканирование.
  6. Щелкните Сохранить.


Консоль VirusScan

Настройте функцию кэша сканирования, используя данную консоль интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. Щелкните Сервис | Общие параметры и перейдите на вкладку Глобальные настройки сканирования, чтобы отобразить диалоговое окно Глобальные настройки сканирования.
  2. Настройте следующие глобальные параметры для кэша сканирования.
    • Щелкните Включить сохранение данных сканирования при перезагрузке, чтобы результаты сканирования незараженных файлов сохранялись при перезагрузке системы.
    • Щелкните Разрешить использование кэша при проверке по требованию, чтобы сканер, запускаемый по требованию, использовал существующие результаты сканирования незараженных файлов, не выполняя их повторное сканирование.
  3. Щелкните OK.


Сканирование электронной почты при доставке и по требованию

Сканер электронной почты автоматически проверяет сообщения и вложения электронной почты.

Методы сканирования сообщения электронной почты:
  • Microsoft Outlook: сканирование электронной почты при доставке или инициация сканирования электронной почты по требованию непосредственно из Microsoft Outlook.
    ПРИМЕЧАНИЕ: При настройке функций эвристики и Artemis во время проверки подозрительных файлов сканер электронной почты при доставке и по требованию будет использовать эвристические методы. Для получения дополнительных сведений см. раздел Принцип работы Artemis.
  • Lotus Notes: ниже перечислены доступные настройки.
    • Сканирование электронной почты при ее открытии.
    • При активации сканирование электронной почты по требованию выполняется непосредственно из Lotus Notes.
    • Указание баз данных Notes, которые требуется исключить.

Настройка политик сканирования электронной почты при доставке выполняется на одной из следующих консолей интерфейса пользователя.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan
Связанные ссылки
Определения вкладок, относящихся к политикам сканирования электронной почты при доставке


ePolicy Orchestrator 4.5 или 4.6

Настройте политики сканирования электронной почты при доставке с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице настройки политик сканера электронной почты при доставке настройте параметры каждой вкладки. См. таблицу Определения вкладок, относящихся к политикам сканирования электронной почты при доставке.


ePolicy Orchestrator 4.0

Настройте политики сканирования электронной почты при доставке с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице настройки политик сканера электронной почты при доставке настройте параметры каждой вкладки. См. таблицу Определения вкладок, относящихся к политикам сканирования электронной почты при доставке.


Консоль VirusScan

Настройте политики сканирования электронной почты при доставке с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. В списке Задача щелкните правой кнопкой мыши Свойства сканирования электронной почты при доставке, а затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. В диалоговом окне «Свойства сканирования электронной почты при доставке» настройте параметры каждой вкладки. См. таблицу Определения вкладок, относящихся к политикам сканирования электронной почты при доставке.


Определения вкладок, относящихся к политикам сканирования электронной почты при доставке

Вкладка Определения
Элементы сканирования
  • Указание вложений и сообщений для сканирования.
  • Сканирование эвристическими методами, в ходе которого обнаруживаются потенциальные угрозы, похожие на вредоносные программы и неизвестные макровирусы, а также выполняется поиск вложений с несколькими расширениями.
  • Сканирование сжатых файлов внутри архивов и декодирование файлов в кодировке MIME.
  • Включение сканера электронной почты для проверки на наличие нежелательных программ.
  • Сканирование текстов сообщений электронной почты.
  • Настройка уровня чувствительности для системы Artemis.
    ПРИМЕЧАНИЕ: Этот параметр доступен только при выборе функции Сканирование электронной почты при доставке.
Действия
Для обнаружений угроз
  • Действие, которое при обнаружении угрозы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при сбое первого действия.
Для обнаружения нежелательных программ
  • Действие, которое при обнаружении нежелательной программы следует выполнить в первую очередь.
  • Дополнительное действие, которое необходимо выполнить при сбое первого действия.

Чтобы просмотреть разрешенные действия в диалоговом окне запроса, выберите действие.

Предупреждения
  • Уведомление других пользователей в случае обнаружения сообщения электронной почты, представляющего угрозу.
  • Указание сообщения, которое должно отображаться при запросе о действии.
Отчеты
  • Включение журналирования активности.
  • Задание имени и расположения файла журнала.
  • Задание предельного размера файла журнала.
  • Выбор формата файла журнала.
  • Указание дополнительных сведений, которые необходимо записывать помимо событий сканирования.
Настройки сканера Notes
ПРИМЕЧАНИЕ: Эта вкладка доступна только при выборе функции Сканирование электронной почты при доставке.

Задание определенных настроек Lotus Notes.

  • Сканировать все базы данных сервера.
  • Сканировать почтовые ящики сервера в определенной корневой папке почтового ящика.
  • Приложения Notes, которые требуется пропускать.


Часть III. Ответ на угрозы

Ответ на угрозы является третьим этапом в стратегии защиты, в ходе которого обнаруживаются и удаляются вредоносные программы, пытающиеся проникнуть в систему.

Содержание

  • Обнаружения и ответы
  • Настройка предупреждений и уведомлений
  • Доступ к запросам и панелям мониторинга
  • Настройка экстренных файлов DAT


Обнаружения и ответы

Дальнейшие действия после обнаружения угрозы определяются особенностями настройки реагирования VirusScan Enterprise на обнаружение, а также выбором функции, с помощью которой должна обнаруживаться угроза. Понимание этих различий поможет разработать и внедрить эффективную стратегию действий.

Содержание

Связанные понятия
Процессы, происходящие при обнаружении
Элементы, помещенные в карантин
Связанные ссылки
Нарушения защиты точки доступа к системе
Обнаружения переполнения буфера
Обнаружения нежелательных программ
Обнаружения по результатам проверки при доступе
Обнаружения по результатам проверки по требованию
Обнаружения по результатам сканирования электронной почты


Процессы, происходящие при обнаружении

Действие, предпринимаемое в ответ на обнаружение, зависит от того, как настроена программа VirusScan Enterprise.

Если программа VirusScan Enterprise настроена на выполнение автоматической очистки (предлагаемая настройка по умолчанию), то предпринимаемое действие зависит от инструкций по очистке, поступающих от файла DAT. Например, если сканеру не удается очистить файл или файл поврежден так, что восстановить его невозможно, сканер может удалить файл или выполнить дополнительное действие. Это зависит от определения в файле DAT.

Запрещая доступ к файлам с потенциальными угрозами, при сохранении этих файлов сканер также добавляет к имени расширение .mcm.


Нарушения защиты точки доступа к системе

При нарушении защиты точки доступа к системе выполняемое действие зависит от способа настройки правила.

Способы настройки правила:

  • Отчет: в файл журнала записывается соответствующая информация.

  • Блокировать: доступ запрещен.

Просмотрите файл журнала, чтобы определить, в каких точках было зафиксировано нарушение прав доступа и какие правила обнаружили нарушения. Затем настройте правила защиты доступа так, чтобы пользователи могли получать доступ к разрешенным элементам и не имели доступа к защищенным.

С помощью следующих сценариев можно выбрать необходимое ответное действие.

Тип обнаруженной угрозы Сценарии
Нежелательные процессы
  • Если правило сообщило о нарушении в файле журнала, но не заблокировало его, выберите для правила параметр Блокировать.
  • Если правило заблокировало нарушение, но не сообщило о нем в файле журнала, выберите для правила параметр Отчет.
  • Если правило заблокировало нарушение и сообщило о нем в файле журнала, никакие действия не требуются.
  • Если определен нежелательный процесс, который не был обнаружен, измените правило, включив в него этот процесс как заблокированный.
Безопасные процессы
  • Если правило сообщило о нарушении в файле журнала, но не заблокировало его, отключите для правила параметр Отчет.
  • Если правило заблокировало нарушение и сообщило о нем в файле журнала, измените правило, исключив безопасный процесс из блокировки.


Обнаружения переполнения буфера

При обнаружении переполнения буфера сканер блокирует обнаружение, а в диалоговом окне Сообщения сканера при доступе записывается соответствующее сообщение. Просмотрите диалоговое окно и определите, следует ли выполнять какие-либо дополнительные действия.

Ниже представлены возможные действия.
  • Удаление сообщения: выберите элемент в списке и щелкните Удалить.
  • Создание исключения: если обнаруженный процесс является безопасным или зафиксирован ложно положительный результат обнаружения, создайте исключение на основе сведений диалогового окна Сообщения сканера при доступе. Просмотрите сведения в столбце имя, чтобы определить имя процесса, к которому относится доступная для записи память, выполняющая вызов. При создании исключения используйте имя процесса.
  • Отправка образца на анализ в McAfee Labs: если сканер обнаруживает то, что, по вашему мнению, он не должен обнаруживать, либо не обнаруживает то, что должен, можно отправить образец в лаборатории McAfee.


Обнаружения нежелательных программ

Сканеры, запускаемые при доступе, сканеры по требованию и сканеры электронной почты обнаруживают нежелательные программы на основании настроенной политики нежелательных программ. При обнаружении сканер, выявивший потенциально нежелательную программу, выполняет действие в соответствии с параметрами, настроенными для данного сканера на вкладке Действия.

Просмотрите сведения в файле журнала и решите, следует ли выполнять какие-либо из перечисленных ниже дополнительных действий.

  • Настройка элементов сканирования: повышение эффективности сканирования.
  • Исключение из обнаружения: при обнаружении безопасной программы ее можно настроить как исключение.
  • Добавление в список обнаружений, определяемых пользователем: если нежелательная программа не была обнаружена, ее можно добавить в список обнаружений, определяемых пользователем.
  • Отправка образца на анализ в McAfee Labs: если сканер обнаруживает то, что, по вашему мнению, он не должен обнаруживать, либо не обнаруживает то, что должен, вы можете отправить образец в McAfee Labs.


Обнаружения по результатам проверки при доступе

Когда при попытке доступа сканер обнаруживает какую-либо вредоносную программу, он выполняет действие в соответствии с настройками на вкладке «Действия» диалогового окна «Свойства сканера при доступе». Кроме того, в диалоговом окне «Сообщения сканера при доступе» записывается соответствующее сообщение.

Просмотрите сведения в журнале активности и диалоговом окне Сообщения сканера при доступе и решите, следует ли выполнять какие-либо из следующих дополнительных действий.

  • Настройка элементов сканирования: чтобы сделать сканирование более эффективным, исключите безопасные файлы, которые в VirusScan Enterprise могут быть приняты за угрозы, и удалите известные угрозы, которые могут быть сохранены в карантине.
  • Щелкните правой кнопкой мыши элемент в диалоговом окне «Сообщения сканера при доступе», чтобы выполнить перечисленные ниже действия.
    • Очистить файл: выполняется попытка очистить файл, на который ссылается выбранное сообщение.
    • Удалить файл: удаление файла, на который ссылается выбранное сообщение. Имя файла записывается в журнал, поэтому его можно восстановить через Quarantine Manager.
    • Удалить все (ctrl+a): выбор всех сообщений в списке.
    • Удалить сообщение из списка (ctrl+d): удаление выбранного сообщения из списка. Удаленные из списка сообщения по-прежнему отображаются в файле журнала.
    • Удалить все сообщения: удаление всех сообщений из списка. Удаленные из списка сообщения по-прежнему отображаются в файле журнала.
    • Открыть файл журнала сканера, запускаемого при доступе: открытие файла журнала сканера, запускаемого при доступе. Этот параметр доступен только в меню «Файл».
    • Открыть файл журнала защиты доступа: открытие файла журнала защиты доступа. Этот параметр доступен только в меню «Файл».
    • Если для текущего сообщения то или иное действие недоступно, соответствующий значок, кнопка и элементы меню отключаются. Например, действие Очистить недоступно, если файл уже удален, а действие Удалить недоступно, если было отключено администратором.
    • Очистить файл: файл невозможно очистить, если в файле DAT отсутствует средство очистки или файл был поврежден настолько, что восстановить его не удается. Если файл не удается очистить, сканер добавляет к его имени расширение .mcm и запрещает к нему доступ. В файле журнала появляется соответствующая запись. В этом случае рекомендуется удалить файл и восстановить его из чистой резервной копии.
  • Отправка образца на анализ в McAfee Labs: если сканер обнаруживает то, что, по вашему мнению, он не должен обнаруживать, либо не обнаруживает то, что должен, вы можете отправить образец в McAfee Labs.


Обнаружения по результатам проверки по требованию

При обнаружении угроз в результате проверки по требованию сканер выполняет действие в соответствии с настройками диалогового окна Свойства проверки по требованию на вкладке Действия.

Просмотрите сведения в файле журнала и решите, следует ли выполнять какие-либо из перечисленных ниже дополнительных действий.

  • Настройка элементов сканирования, чтобы сделать сканирование более эффективным.
  • Запрос на действие: настройка сканера на запрос на действие путем выбора действия в диалоговом окне «Ход выполнения проверки по требованию».
  • Отправка образца на анализ в McAfee Labs: если сканер обнаруживает то, что, по вашему мнению, он не должен обнаруживать, либо не обнаруживает то, что должен, вы можете отправить образец в McAfee Labs.


Обнаружения по результатам сканирования электронной почты

При обнаружении сканирования электронной почты сканер выполняет действие в соответствии с параметром Свойства сканирования электронной почты при доставке или Свойства сканирования электронной почты по требованию, заданным на вкладке Действия.

Просмотрите сведения в файле журнала и решите, следует ли выполнять какие-либо из перечисленных ниже дополнительных действий.

  • Настройка элементов сканирования: повышение эффективности сканирования.
  • Отправка образца на анализ в McAfee Labs: если сканер обнаруживает то, что, по вашему мнению, он не должен обнаруживать, либо не обнаруживает то, что должен, вы можете отправить образец в McAfee Labs.


Элементы, помещенные в карантин

Элементы, обнаруженные как угрозы, очищаются или удаляются. Кроме того, копия такого элемента преобразуется в неисполняемый формат и сохраняется в карантиновой папке. Благодаря этому после загрузки более поздней версии DAT, в которой может содержаться информация, позволяющая очистить угрозу, в отношении элементов, помещенных в карантин, можно выполнять необходимые процессы.

Эти дополнительные процессы перечислены ниже.

  • Восстановление.

  • Повторное сканирование.

  • Удаление.

  • Проверка на ложный положительный результат.

  • Просмотр свойств обнаружения.

ПРИМЕЧАНИЕ: Элементы, помещенные в карантин, могут включать множество типов сканируемых объектов. К этим объектам относятся файлы, файлы cookie, реестры и другие объекты, которые программа VirusScan Enterprise проверяет на наличие вредоносных программ.


Настройка политики карантина

Откройте политики Quarantine Manager и при необходимости настройте политику карантина или примите параметры по умолчанию.

Настройка политик Quarantine Manager выполняется на одной из следующих консолей интерфейса пользователя.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan


ePolicy Orchestrator 4.5 или 4.6

Настройте политики Quarantine Manager с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Карантин примите каталог карантина по умолчанию или выберите другой каталог.
  5. Чтобы настроить дни, в течение которых должны храниться помещенные в карантин элементы, щелкните Автоматически удалять данные, помещенные в карантин, по истечении указанного числа дней и введите значение в поле Число дней, в течение которого резервные копии данных будут храниться в каталоге карантина.


ePolicy Orchestrator 4.0

Настройте политики Quarantine Manager с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. На странице Карантин примите каталог карантина по умолчанию или выберите другой каталог.
  5. Чтобы настроить дни, в течение которых должны храниться помещенные в карантин элементы, щелкните Автоматически удалять данные, помещенные в карантин, по истечении указанного числа дней и введите значение в поле Число дней, в течение которого резервные копии данных будут храниться в каталоге карантина.


Консоль VirusScan

Настройте политики Quarantine Manager с помощью данной консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. В списке Задача щелкните правой кнопкой мыши Политика Quarantine Manager, затем щелкните Свойства, чтобы открыть диалоговое окно «Политика Quarantine Manager».
  2. Примите каталог карантина по умолчанию или выберите другой каталог.
  3. Чтобы настроить дни, в течение которых должны храниться помещенные в карантин элементы, щелкните Автоматически удалять данные, помещенные в карантин, по истечении указанного числа дней и введите значение в поле Число дней, в течение которого резервные копии данных будут храниться в каталоге карантина.


Управление элементами, помещенными в карантин

Следует обработать помещенные в карантин элементы, чтобы позднее можно было их проверить и вручную удалить или восстановить с помощью.Консоль VirusScan
ПРИМЕЧАНИЕ: В консоли ePolicy Orchestrator выберите задачу клиента Восстановить из карантина, чтобы с ее помощью восстановить элементы, помещенные в карантин.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. В списке задач Консоль VirusScan щелкните Политика Quarantine Manager, чтобы открыть диалоговое окно «Политика Quarantine Manager».
  2. Выберите вкладку Диспетчер и щелкните правой кнопкой мыши элемент, чтобы стали доступны перечисленные дополнительные параметры.

    • Восстановление.

    • Повторное сканирование.

    • Удаление.

    • Проверка на ложный положительный результат.

    • Просмотр свойств обнаружения.

  3. Появится диалоговое окно, в котором будут описаны последствия выполняемой попытки.


Настройка предупреждений и уведомлений

Получение уведомлений при обнаружении потенциальной угрозы очень важно для обеспечения защиты вашей среды. Для настройки способа уведомления при обнаружении можно использовать консоль ePolicy Orchestrator или Консоль VirusScan. На обеих консолях можно настроить параметры предупреждений, фильтрацию предупреждений по уровню опасности, ограничивающую трафик, и параметры локальных предупреждений.

Связанные задачи
Настройка предупреждений
Связанные ссылки
Обнаружения по результатам проверки при доступе


Настройка предупреждений

Настройте свойства предупреждений и уведомлений, которые отображаются при обнаружении угрозы различными сканерами.

Используйте тот же самый процесс для следующих политик:
  • политики предупреждений;
  • политики защиты от переполнения буфера;
  • политики сканирования электронной почты при доставке.

Настройте политики предупреждений для всех трех политик с помощью следующих консолей интерфейса пользователя.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan
Связанные ссылки
Настройка вкладки «Политика предупреждений»


ePolicy Orchestrator 4.5 или 4.6

Настройте политики предупреждений с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Меню | Политика | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить параметры, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Действия | Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Категория выберите существующую политику.
    3. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    4. Введите новое имя политики.
    5. Введите необходимые примечания.
    6. Щелкните OK. Новая политика отобразится в списке существующих политик.
    7. В столбце Действия новой политики щелкните Изменить параметры, чтобы открыть страницу настройки политики.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. Настройте вкладки политик предупреждений. См. раздел Настройка вкладки «Политика предупреждений».


ePolicy Orchestrator 4.0

Настройте политики предупреждений с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Щелкните Системы | Каталог политик, затем в списке продуктов выберите VirusScan Enterprise 8.8.0. В списке категорий отобразятся категории политик для VirusScan Enterprise 8.8.0.
  2. Отредактируйте существующую политику или создайте новую. Редактирование существующей политики
    1. В списке Категория выберите категорию политики.
    2. В столбце Действия щелкните Изменить, чтобы открыть страницу настройки политики.
    Создание новой политики
    1. Щелкните Создать политику, чтобы открыть диалоговое окно создания новой политики.
    2. В списке Создать политику на основе этой существующей политики выберите один из параметров.
    3. Введите новое имя политики.
    4. Щелкните OK. Новая политика отобразится в списке существующих политик.
  3. В списке Настройки выберите Рабочая станция или Сервер.
  4. Настройте вкладки политик предупреждений. См. раздел Настройка вкладки «Политика предупреждений».


Консоль VirusScan

Настройте свойства предупреждений с помощью этой консоли интерфейса пользователя.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. Откройте одно из следующих свойств для настройки предупреждений:
    • Предупреждения: щелкните Сервис | Предупреждения, чтобы открыть диалоговое окно «Свойства предупреждений».
    • Защита от переполнения буфера: выберите задачу Защита от переполнения буфера, щелкните правой кнопкой мыши пункт Свойства, чтобы открыть диалоговое окно свойств защиты от переполнения буфера.
    • Сканер электронной почты при доставке: выберите задачу Сканер электронной почты при доставке, щелкните правой кнопкой мыши пункт Свойства, чтобы открыть диалоговое окно свойств сканера электронной почты при доставке. Щелкните вкладку Предупреждения.
  2. Настройте вкладки политик предупреждений. См. раздел Настройка вкладки «Политика предупреждений».


Настройка вкладки «Политика предупреждений»

Задача Настройка
Политики предупреждений

  1. В столбце Действия выберите Изменить параметры, чтобы открыть страницу «Политики предупреждений».

  2. Настройте Компоненты, создающие предупреждения и Параметры Alert Manager.

Политики защиты от переполнения буфера

  1. В столбце Действия выберите Изменить параметры, чтобы открыть страницу «Защита от переполнения буфера».

  2. Рядом с параметром Предупреждение клиентской системы щелкните Выводить диалоговое окно сообщений при обнаружении переполнения буфера.

Политики сканирования электронной почты при доставке

  1. В столбце Действия выберите Изменить параметры, чтобы открыть страницу «Политики сканирования электронной почты при доставке».

  2. Щелкните Предупреждения и настройте параметры Предупреждение об электронной почте для пользователя и Запрос сообщения о действии.


Доступ к запросам и панелям мониторинга

Используйте запросы и панели мониторинга для отслеживания активности и определения действий, необходимых при обнаружениях. Можно использовать предварительно определенные запросы и панели мониторинга и создавать дополнительные в соответствии с потребностями. Для получения сведений о запросах и панелях мониторинга см. документацию по продукту ePolicy Orchestrator.

Запросы

Способ перехода к запросам зависит от версии ePolicy Orchestrator:

ePolicy Orchestrator 4.5 и 4.6
  1. Щелкните Меню | Отчетность | Запросы, откроется страница «Запросы».
  2. На панели «Запросы» введите VSE: в строке Быстрый поиск и щелкните Применить. В списке отображаются только запросы VirusScan Enterprise.
ePolicy Orchestrator 4.0
  1. Щелкните Отчетность | Запросы, откроется страница «Запросы».
  2. В списке «Запросы» на правой панели прокрутите вниз, чтобы найти запросы, начинающиеся с «VSE:».

Доступны следующие предварительно определенные запросы:

VSE: совместимость в течение последних 30 дней

VSE: компьютеры, на которых угрозы обнаружены в течение недели

VSE: подтверждение текущей версии DAT

VSE: подтверждение версии DAT в течение последних 24 часов

VSE: развертывание DAT

VSE: сводка реагирования на обнаруженные угрозы

VSE: количество обнаружений по тегу

VSE: шпионское программное обеспечение за последние 24 часа

VSE: шпионское программное обеспечение за последние 7 дней

VSE: сводка угроз, обнаруженных за последние 24 часа

VSE: сводка угроз, обнаруженных за последние семь дней.

VSE: количество угроз по степени опасности

VSE: имена угроз, обнаруженных за неделю

VSE: угрозы, обнаруженные за последние 24 часа

VSE: угрозы, обнаруженные за последние 7 дней

VSE: угрозы, обнаруженные за последние 2 квартала

VSE: угрозы, обнаруженные в течение недели

VSE: 10 основных нарушенных правил защиты доступа

VSE: 10 основных обнаруженных угроз, связанных с переполнением буфера

VSE: Первые 10 компьютеров с наибольшим количеством обнаружений

VSE: 10 основных обнаруженных угроз

VSE: 10 основных источников угроз

VSE: 10 основных угроз по категориям угроз

VSE: первые 10 пользователей с наибольшим количеством обнаружений

VSE: нежелательные программы, обнаруженные за последние 24 часа

VSE: нежелательные программы, обнаруженные за последние 7 дней

VSE: cовместимость с версией 8.5

VSE: cовместимость с версией 8.7

VSE: совместимость с версией 8.8

Панели мониторинга

Чтобы обеспечить доступ к панелям мониторинга в консоли ePolicy Orchestrator, перейдите в меню Панели мониторинга.

Доступны следующие предварительно определенные панели мониторинга:
  • VSE: совместимость с версией 8.8
  • VSE: анализ тенденций
  • VSE: текущие обнаружения


Настройка экстренных файлов DAT

Экстренные файлы DAT можно загрузить вручную; они обеспечат защиту системы от основных вирусов до тех пор, пока не будет выпущено стандартное обновление VirusScan DAT.
ПРИМЕЧАНИЕ: Эти файлы EXTRA.DAT следует автоматически загрузить в ходе обновления клиентской системы с помощью функции AutoUpdates или запланированного процесса опроса ePolicy Orchestrator. См. раздел Обновление определений обнаружений.
Настройка экстренных файлов DAT является двухэтапным процессом.
  1. Загрузите экстренный файл DAT. Эта процедура аналогичная для обеих клиентских систем и хранилищ ePolicy Orchestrator.
  2. Установите экстренный файл DAT. Эта процедура отличается для различных клиентских систем и серверов ePolicy Orchestrator 4.0, 4.5 и 4.6.

Каждый из этих процессов описан в данном разделе.

Содержание

Связанные понятия
Об экстренных файлах DAT
Связанные задачи
Загрузка файла SuperDAT
Установка файлов SuperDAT в хранилище ePolicy Orchestrator
Установка файла EXTRA.DAT на клиентской системе
Связанная информация
Обновление определений обнаружений


Об экстренных файлах DAT

Экстренные файлы DAT (EXTRA.DAT) содержат сведения, используемые VirusScan Enterprise для обнаружения новых вирусов. При обнаружении нового вредоносного программного обеспечения и необходимости дополнительной проверки можно воспользоваться файлом EXTRA.DAT, входящим в пакет исполняемого файла SuperDAT (SDAT), который предоставляется McAfee Labs до выпуска стандартного обновления VirusScan Enterprise DAT.
ПРИМЕЧАНИЕ: McAfee больше не размещает отдельные файлы EXTRA.DAT на сайте загрузки обновлений защиты. Чтобы получить файл EXTRA.DAT для определенной угрозы, перейдите на страницу запроса файла Extra.dat лаборатории McAfee Avert Labs по адресу: https://www.webimmune.net/extra/getextra.aspx.

Пакеты SuperDAT

Исполняемый файл SuperDAT является самоустанавливающимся пакетом. Он также должен включать новый механизм сканирования вирусов и другие программные компоненты. Для имени файла используется следующий формат: sdatXXXX.exe, где XXXX — это номер версии DAT из четырех цифр, например sdat4321.exe.

После извлечения файла EXTRA.DAT из исполняемого файла SuperDAT и добавления в папку Engine на жестком диске он используется VirusScan Enterprise в дополнение к обычным файлам DAT для обнаружения нового вируса. Это позволяет VirusScan Enterprise обеспечить защиту компьютера от новых вредоносных кодов до выпуска официального обновления DAT с информацией об обнаружении вредоносных кодов и их удалении. После выпуска и установки обновления DAT файл EXTRA.DAT больше не требуется.

ПРИМЕЧАНИЕ: Файлы EXTRA.DAT сохраняются в файловой системе в течение 5 дней, затем они автоматически удаляются. Необходимо обновлять файлы VirusScan Enterprise DAT путем автоматической загрузки и установки официальных ежедневных обновлений.


Загрузка файла SuperDAT

Чтобы загрузить файл SuperDAT (SDAT), необходимо зайти на страницу обновлений защиты McAfee.

Перед началом работы

  • Для доступа к странице обновлений защиты McAfee требуется действующий номер разрешения: http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  • Для обновления программного обеспечения McAfee необходимо обладать правами администратора.

Задача

  1. Перейдите на страницу обновлений защиты McAfee по следующему URL-адресу: http://www.mcafee.com/apps/downloads/security_updates/dat.asp
  2. Щелкните вкладку SuperDATs и дважды щелкните файл sdatXXXX.exe, где XXXX — это номер самого последнего обновления DAT.
    ПРИМЕЧАНИЕ: Дважды щелкните файл readme.txt для получения дополнительной информации.
  3. Сохраните исполняемый файл во временную папку, используя его имя по умолчанию.


Установка файлов SuperDAT в хранилище ePolicy Orchestrator

После загрузки файла SuperDAT необходимо установить его на сервере ePolicy Orchestrator.

Перед началом работы

Для обновления программного обеспечения McAfee необходимо обладать правами администратора.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Чтобы установить файл SuperDAT на сервере ePolicy Orchestrator, выполните одно из следующих действий.
    Сервер Действия...
    ePolicy Orchestrator 4.5 и 4.6
    1. Щелкните Меню | Программное обеспечение | Главное хранилище, чтобы открыть страницу главного хранилища со списком пакетов в консоли ePolicy Orchestrator 4.5 и 4.6.
    2. Щелкните Действия | Проверить пакет на входе.
    ePolicy Orchestrator 4.0
    1. Щелкните Программное обеспечение | Главное хранилище, чтобы открыть страницу главного хранилища со списком пакетов.
    2. Щелкните Проверить пакет на входе, чтобы открыть страницу проверки пакетов.
  2. Выберите Super DAT (EXE), перейдите в папку для сохранения файла, а затем щелкните Далее.
  3. Подтвердите выбор, затем щелкните Сохранить. На странице главного хранилища со списком пакетов отобразится новый пакет DAT в списке «Имя».


Установка файла EXTRA.DAT на клиентской системе

Можно установить файл EXTRA.DAT на автономной клиентской системе после загрузки файла со страницы McAfee Labs. Сведения о загрузке файла EXTRA.DAT см. в разделе Об экстренных файлах DAT.

Перед началом работы

Для обновления программного обеспечения защиты McAfee необходимо обладать правами администратора.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. По завершении загрузки найдите сохраненный файл, запустите исполняемый файл и следуйте инструкциям мастера. Исполняемым файлом EXTRA.DAT будут выполняются следующие действия:
    • выгрузка программного обеспечения McAfee из памяти или остановка работы служб, использующих файлы DAT;
    • копирование новых файлов DAT в соответствующие папки программы;
    • перезапуск компонентов программного обеспечения, необходимых для продолжения сканирования с использованием новых файлов DAT.
  2. После завершения обновления файлов DAT можно удалить загруженный файл или сохранить копию для дальнейших обновлений.


Часть IV. Мониторинг, анализ и точная настройка защиты

Завершив первоначальную настройку стратегии защиты, необходимо выполнить мониторинг, анализ и точную настройку системы защиты. Проверяя файлы журнала активности и запросы ePolicy Orchestrator, можно повысить производительность и защиту систем VirusScan Enterprise.

Содержание

  • Отслеживание активности в имеющейся среде
  • Анализ защиты


Отслеживание активности в имеющейся среде

Важным этапом стратегии защиты является отслеживание событий регистрации вредоносных программ в системе. Для успешного отслеживания необходимо понять, какие для этого используются инструменты и принцип их использования.


Инструменты для отслеживания активности

VirusScan Enterprise предоставляет множество способов отслеживания событий угроз, имеющих место в защищенных системах. Набор используемых инструментов зависит от того, какая консоль используется: консоль ePolicy Orchestrator или Консоль VirusScan.


Использование запросов и панелей мониторинга

Запросы и панели мониторинга ePolicy Orchestrator используются для отслеживания активности в системах, управляемых McAfee, и определения действий, которые следует выполнять при обнаружениях.

Для получения дополнительных сведений о запросах и панелях мониторинга см. следующую документацию:
  • Полный список предварительно определенных доступных запросов см. в разделе Доступ к запросам и панелям мониторинга.
  • Сведения об изменении и создании запросов и панелей мониторинга см. в документации по продукту ePolicy Orchestrator.
Связанная информация
Доступ к запросам и панелям мониторинга


Использование журналов активности

В журналах активности Консоль VirusScan хранятся записи о событиях, имеющих место в системе, защищенной с помощью VirusScan Enterprise. В таблице ниже приведено описание файлов журнала.

По умолчанию все файлы журнала активности хранятся в одном из следующих местоположений, выбор которых зависит от операционной системы:
  • Для Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server и Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Для Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Таблица 1. Файлы журнала
Имя файла | Способ доступа | Отображение
AccessProtectionLog.txt | В столбце Задача щелкните вкладку Защита доступа | Отчеты, затем щелкните Просмотреть журнал. | Дата, время, событие, пользователь и имя файла.
BufferOverflowProtectionLog.txt | В столбце «Задача» щелкните вкладку Защита от переполнения буфера | Отчеты, затем щелкните Просмотреть журнал. | Дата, время, исполняемый файл, ставший причиной переполнения, и тип переполнения: «переполнение стека» или «переполнение динамической памяти».
MirrorLog.txt
  • Для Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server и Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Для Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Дата, время, путь к файлам отражения и любая другая дополнительная информация.
OnAccessScanLog.txt | В столбце Задача щелкните вкладку Сканер при доступе | Общие настройки | Отчеты, затем щелкните Просмотреть журнал. | Дата, время, обнаруженная вредоносная программа, предпринятое действие и найденный компонент.
OnDemandScanLog.txt | В меню щелкните Задача | Просмотреть журнал. | Дата, время выполнения сканирования, выполненные действия, файл, в отношении которого выполнялись действия, и найденный компонент.
UpdateLog.txt
  • Для Microsoft Windows XP, Microsoft Vista, Microsoft 2000 Server, Microsoft 2003 Server и Microsoft 2008 Server — C:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection
  • Для Microsoft Windows 7 — C:\ProgramData\McAfee\DesktopProtection
Дата, время выполнения обновления, пользователь, инициировавший обновление, и любая другая информация об обновлении.


Запуск образца запроса

Запустите образец запроса, чтобы определить, сколько угроз в защищенных системах было обнаружено в течение недели. Данный запрос служит только примером. Выбор запроса для запуска или настройки зависит от информации, которую требуется получить в базе данных ePolicy Orchestrator.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Для запуска простого запроса ePolicy Orchestrator используйте один из представленных компонентов.
    • ePolicy Orchestrator 4.5 или 4.6: щелкните Меню | Отчетность | Запросы, прокрутите вниз до запроса VSE: угрозы, обнаруженные в течение недели и щелкните Выполнить.
    • ePolicy Orchestrator 4.0: щелкните Отчетность | Запросы, прокрутите вниз до запроса VSE: угрозы, обнаруженные в течение недели и щелкните Выполнить.
  2. В случае обнаружения каких-либо угроз могут отобразиться следующие компоненты:
    • гистограмма с указанием угроз и недель, в течение которых они появились;
    • таблица с аналогичной информацией и сведениями обо всех угрозах.
    ПРИМЕЧАНИЕ: Можно щелкнуть гистограмму или сведения в таблице, чтобы открыть данные базы данных ePolicy Orchestrator.
  3. Щелкните Закрыть, чтобы вернуться к списку запросов.
Существует еще множество запросов по умолчанию, доступных для запуска. Кроме того, можно создать и собственные запросы. Дополнительные сведения см. в документации ePolicy Orchestrator.


Анализ защиты

Анализ защиты в системе, где установлено приложение VirusScan Enterprise, следует проводить постоянно. Это повышает степень защиты и производительность системы.

Содержание

Связанные понятия
Необходимость анализа
Связанные задачи
Примеры анализа уровней защиты


Необходимость анализа

Анализ уровня защиты позволяет определить, с какими типами угроз сталкивается пользователь, из каких источников они поступают, как часто они обнаруживаются и на какие системы нацелены. Например, если на одну систему постоянно совершаются атаки, возможно, эту систему следует перенести в более безопасную часть сети и повысить уровень ее защиты.

Такой анализ также полезен при:
  • создании отчетов для ИТ-специалистов и менеджеров;
  • сборе данных для создания сценариев и запросов;
  • отслеживании времени доступа к сети и нагрузки на сеть при обновлении VirusScan Enterprise.


Примеры анализа уровней защиты

Действия, приведенные в этих примерах анализа, можно использовать в качестве схемы анализа большинства сценариев защиты VirusScan Enterprise.

В этих примерах показан процесс обнаружения атак, совершаемых вредоносным программным обеспечением, и определения:
  • места и времени атаки;
  • вредоносного программного обеспечения, используемого для атаки;
  • влияния атаки на систему.

Задачи

Связанные задачи
ePolicy Orchestrator 4.5 или 4.6
ePolicy Orchestrator 4.0
Консоль VirusScan


ePolicy Orchestrator 4.5 или 4.6

Данный пример анализа можно использовать как схему проведения анализа большинства сценариев защиты VirusScan Enterprise с помощью ePolicy Orchestrator 4.5 или 4.6.

Перед началом работы

Для выполнения анализа из этого примера необходимо иметь прямой или удаленный доступ к системе, защищенной приложением VirusScan Enterprise.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Определите место и время совершения атаки.
    1. Щелкните Меню | Отчетность | Запросы, чтобы открыть страницу «Запросы».
    2. Введите Вредоносное программное обеспечение в строке Быстрый поиск и щелкните Применить. Запрос «История обнаруженных угроз» отобразится в списке «Запросы».
    3. Выберите запрос и щелкните Действия | Выполнить. По запросу будет отображен список недавно совершенных атак.
  2. Чтобы определить, какое вредоносное программное обеспечение совершило атаку, щелкните Меню | Отчетность | Журнал событий угроз, чтобы отобразить этот журнал.
  3. Дважды щелкните событие журнала, чтобы отобразить страницу сведений на панели. На основе данных события из журнала можно определить следующее.
    • IP-адрес источника угрозы и цель указываются, чтобы помочь при определении необходимых действий.
    • Имя угрозы и Тип угрозы указывают, какое вредоносное программное обеспечение использовалось для совершения атаки.
    • Описания событий угроз показывают, как атака повлияла на систему, и какие действия в отношении угрозы были предприняты.


ePolicy Orchestrator 4.0

Данный пример анализа можно использовать как схему проведения анализа большинства сценариев защиты VirusScan Enterprise с помощью ePolicy Orchestrator 4.0.

Перед началом работы

Для выполнения анализа из этого примера необходимо иметь прямой или удаленный доступ к системе, защищенной приложением VirusScan Enterprise.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Определите место и время совершения атаки.
    1. Щелкните Отчетность | Запросы, чтобы открыть страницу «Запросы».
    2. В списке «Общие запросы» выберите ePO: история обнаруженных угроз и щелкните Дополнительные действия | Выполнить. Запрос «История обнаруженных угроз» отобразится в списке «Запросы».
  2. Чтобы просмотреть событие, которое запустило обнаружение вредоносного программного обеспечения, щелкните Отчетность | Журнал событий, и по запросу будет отображен список недавно совершенных атак.
  3. Дважды щелкните событие журнала, чтобы отобразить страницу сведений на панели. На основе данных события из журнала можно определить следующее.
    • IP-адрес источника угрозы и цель указываются, чтобы помочь при определении необходимых действий.
    • Имя угрозы и Тип угрозы указывают, какое вредоносное программное обеспечение использовалось для совершения атаки.
    • Описания событий угроз показывают, как атака повлияла на систему, и какие действия в отношении угрозы были предприняты.


Консоль VirusScan

Данный пример анализа можно использовать как схему проведения анализа большинства сценариев защиты VirusScan Enterprise с помощью Консоль VirusScan.

Перед началом работы

Для выполнения анализа из этого примера необходимо иметь прямой или удаленный доступ к системе, защищенной приложением VirusScan Enterprise.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В списке Задача щелкните правой кнопкой мыши Сканер при доступе и выберите в списке Статистика. Откроется диалоговое окно «Статистика проверки при доступе».
  2. В группе «Статистика сканирования» обратите внимание на количество обнаруженных файлов. Если оно не равно нулю, щелкните Свойства, чтобы открыть диалоговое окно «Свойства проверки при доступе».
  3. Щелкните вкладку Отчеты и выберите Просмотреть журнал. В окне Блокнота откроется файл OnAccessScanLog.txt.
  4. С помощью этого файла можно определить следующее.
    • Вредоносное программное обеспечение, использовавшееся для атаки. Например,
      C:\...\eicar.com	Тестовый файл EICAR
    • Влияние атаки на систему. Например,
      (Не удалось выполнить очистку, поскольку обнаруженная угроза не может быть удалена)
    • Действия, предпринятые в ответ на угрозу. Например,
      Удаленные
  5. Используйте сведения, приведенные в предыдущем шаге, чтобы определить, необходимо ли изменить настройки антивирусной защиты на исходной и целевой системах или предпринять какое-либо иное действие.


Приложение

Для повышения защиты, обеспечиваемой VirusScan Enterprise, существуют дополнительные функции конфигурации и устранения неполадок. Этими функциями используются известные инструменты, например, консоль ePolicy Orchestrator, командная строка и Интернет.

Содержание

  • Настройка задач сервера ePolicy Orchestrator
  • Использование командной строки с приложением VirusScan Enterprise
  • Подключение к удаленным системам
  • Отправка образцов угроз на анализ
  • Открытие библиотеки угроз McAfee
  • Устранение проблем


Настройка задач сервера ePolicy Orchestrator

С помощью задач сервера, настроенных в ePolicy Orchestrator, можно автоматически планировать и запускать задачи, связанные с управлением сервером и программным обеспечением VirusScan Enterprise.

Можно настроить задачи сервера VirusScan Enterprise таким образом, чтобы автоматически генерировались следующие компоненты.
  • Экспортировать политики: запуск отчета политики и сохранение сведений политики в файле.
  • Запустить запрос: запуск предварительно настроенного запроса и, если выполнена соответствующая настройка, отображение результатов на панели мониторинга ePolicy Orchestrator.
  • Экспортировать запросы: запуск предварительно настроенного запроса и отправка отчета по электронной почте по настроенному адресу или экспорт отчета в настроенное местоположение.
    ПРИМЕЧАНИЕ: Функция «Экспортировать запросы» доступна только при использовании ePolicy Orchestrator 4.5 и 4.6.
Для сервера ePolicy Orchestrator уже установлены следующие задачи сервера VirusScan Enterprise:
  • VSE: совместимость в течение последних 30 дней — запуск запроса один раз в день. При этом сохраняется состояние совместимости с антивирусным программным обеспечением McAfee.
  • VSE: подтверждение версии DAT в течение последних 24 часов — запуск запроса каждый час. При этом сохраняется состояние версии DAT антивирусного программного обеспечения McAfee.
ПРИМЕЧАНИЕ: Для получения подробных инструкций по настройке пользовательских задач сервера см. соответствующее руководство по эксплуатации ePolicy Orchestrator.


Настройка задачи сервера, приведенной в пример

Включение и настройка существующей задачи сервера ePolicy Orchestrator VSE: совместимость в течение последних 30 дней.

Перед началом работы

Для обновления конфигурации ePolicy Orchestrator необходимо обладать правами администратора.

Задача

Чтобы просмотреть определения параметров, щелкните ? в интерфейсе клиента.

  1. Откройте страницу существующей задачи сервера в ePolicy Orchestrator.
    • ePolicy Orchestrator 4.5 или 4.6: щелкните Меню | Автоматизация | Задачи сервера.
    • ePolicy Orchestrator 4.0: щелкните Автоматизация | Задачи сервера.
  2. В столбце «Имя» найдите задачу VSE: совместимость в течение последних 30 дней и в столбце «Действия» щелкните Изменить. Появится страница построителя задач сервера.
  3. Рядом с пунктом «Состояние планирования» щелкните Включено, затем щелкните Далее. Откроется страница «Действия». Рядом с пунктом «1. Действия» по умолчанию выбран параметр Запустить запрос.
  4. Радом с пунктом «Запрос» по умолчанию выбран запрос VSE: совместимость с версией 8.8.0. При необходимости измените настройку «Язык». Убедитесь, что в группе «Дополнительные действия» по умолчанию выбраны следующие элементы:
    • Генерировать событие совместимости: в списке «Дополнительные действия».
    • Определенное число целевых систем: выбран в текстовом поле со значением 1.
  5. В задачу сервера добавьте действия совместимости с VirusScan Enterprise версии 8.7 и 8.5.
    1. В строке «1. Действия» щелкните знак плюса (+), чтобы открыть строку для дополнительных действий.
    2. В новой строке «2. Действия» настройте следующие элементы:
      • Рядом с пунктом «2. Действия» выберите в списке параметр Запустить запрос.
      • Радом с пунктом «Запрос» выберите в списке запрос VSE: совместимость с версией 8.7.
      • При необходимости измените настройку «Язык».
      • Убедитесь в том, что в группе «Дополнительные действия» параметры Генерировать событие совместимости и Определенное число целевых систем выбраны в текстовом поле со значением 1.
    3. В строке «2. Действия» щелкните знак плюса (+), чтобы открыть строку для дополнительных действий.
    4. В новой строке «3. Действия» настройте следующие элементы:
      • Рядом с пунктом «3. Действия» выберите в списке параметр Запустить запрос.
      • Радом с пунктом «Запрос» выберите в списке запрос VSE: совместимость с версией 8.5.
      • При необходимости измените настройку «Язык».
      • Убедитесь в том, что в группе «Дополнительные действия» параметры Генерировать событие совместимости и Определенное число целевых систем выбраны в текстовом поле со значением 1.
  6. Щелкните Далее. Откроется страница «Планирование».
  7. Выбрав значение в списке Тип планирования, укажите, как часто требуется запускать задачу сервера.
    • Задайте значение параметра Дата начала или в качестве значения по умолчанию примите текущую дату.
    • Задайте значение параметра Дата окончания или в качестве значения по умолчанию примите значение Без даты окончания.
    • Задайте параметр Планирование, примите значение по умолчанию или укажите другое время запуска запроса.
  8. Щелкните Далее. Откроется страница «Сводка». Убедитесь в том, что настроенная информация верна.
  9. Щелкните Сохранить. Снова отобразится страница с задачей сервера.
  10. Убедитесь в том, что для задачи сервера «VSE: совместимость в течение последних 30 дней» включен параметр Состояние, а настройки даты и времени для параметра Следующий запуск верны.


Использование командной строки с приложением VirusScan Enterprise

Командную строку можно использовать для запуска некоторых основных процессов VirusScan Enterprise. С помощью командной строки можно установить, настроить и обновить VirusScan Enterprise. Параметры установки для командной строки описаны в руководстве по установке VirusScan Enterprise.

Пример сканирования с помощью командной строки

Чтобы выполнить сканирование всех файлов, обновите файлы журнала, используя результаты сканирования. По завершении окно проверки по требованию автоматически закроется; далее введите следующую команду:

scan32 /all /log /autoexit

Пример обновления с помощью командной строки

Чтобы обновить файлы DAT, механизм сканирования и продукт в фоновом режиме или скрыть диалоговое окно обновления McAfee в процессе обновления, введите следующую команду:

mcupdate /update /quiet


Параметры командной строки проверки по требованию

В VirusScan Enterprise для обнаружения угроз используется сканер по требованию SCAN32.EXE. Для запуска сканирования можно использовать одну исполняемую команду SCAN32 из командной строки или как часть пакетного файла.

В синтаксисе SCAN32 не требуется определенный порядок элементов. Особенность состоит только в том, что свойство и его значение нельзя разделять. Синтаксис включает следующие элементы.
  • Имя файла — имя исполняемого файла: SCAN32.EXE.
  • Параметры — параметру предшествует косая черта (/), регистр не учитывается.
Команда представляется в следующем формате.

SCAN32 СВОЙСТВО=ЗНАЧЕНИЕ [,ЗНАЧЕНИЕ] [/параметр].

Ниже приведен пример команды scan32.exe:

scan32.exe ПРИОРИТЕТ /норма

В данном примере:
  • «ПРИОРИТЕТ» — это значение команды;
  • «/норма» — значение параметра.

Значения и параметры проверки по требованию

Значение командной строки Описание и параметры

ALL

Сканирование всех файлов в целевой папке.

ALLOLE

Сканирование файлов по умолчанию и всех документов Microsoft Office.

ALWAYSEXIT

Принудительное завершение проверки по требованию, даже если она завершена с ошибкой/сбоем.

APPLYNVP

Сканирование потенциально нежелательных программ, определенных в политике нежелательных программ.

ARCHIVE

Сканирование архивных файлов, например .ZIP, .CAP. LZH и файлов .UUE.

AUTOEXIT

Завершение проверки по требованию по окончании не интерактивного сканирования.

CLEAN

Очистка найденного целевого файла при обнаружении потенциально нежелательной программы.

CLEANA

Очистка найденного файла при обнаружении нежелательной программы.

CONTINUE

Продолжение сканирования после обнаружения потенциально нежелательной программы.

CONTINUE2

Продолжение сканирования после обнаружения потенциально нежелательной программы и при ошибке основного действия.

CONTINUEA

Продолжение сканирования после обнаружения нежелательной программы.

CONTINUEA2

Продолжение сканирования после обнаружения нежелательной программы и при ошибке основного действия.

DEFEXT

Добавление расширений файлов, указанных в качестве параметров в списке выбранных типов файлов, включенных в процедуру сканирования.

DELETE

Удаление найденного целевого файла при обнаружении потенциально нежелательной программы.

DELETE2

Удаление найденного файла при обнаружении потенциально нежелательной программы и при ошибке основного действия.

DELETEA

Удаление файла при обнаружении нежелательной программы.

DELETEA2

Удаление файла при обнаружении потенциально нежелательной программы и при ошибке основного действия.

EDIT

Отображение диалогового окна свойств сканирования.

EXT

Замена расширений в списке выбранных типов файлов, включенных в процедуру сканирования, расширениями файлов, добавленных в виде параметров за данным аргументом.

LOG

Регистрация отчетов об обнаружении в указанном ранее файле журнала.

LOGFORMAT <значение>

Использование указанного формата для файла журнала. Допустимые значения: ANSI, UTF8 или UTF16.

LOGSETTINGS

Регистрация настроек конфигурации сканирования.

LOGSUMMARY

Регистрация сводки результатов сканирования.

LOGUSER

Регистрация идентифицирующей информации о пользователе, выполняющем сканирование.

MHEUR

Включение системы обнаружения макроугроз Artemis.

MIME

Обнаружение потенциально нежелательных программ в файлах в кодировке MIME (Multipurpose Internet Mail Extensions — многоцелевые почтовые расширения Интернет).

NOESTIMATE

Объем сканирования не оценивается перед началом сканирования файлов. Шкала хода выполнения не отображается.

PHEUR

Включение системы Artemis для обнаружения угроз, не относящихся к макроугрозам.

PRIORITY

Задание приоритета сканирования относительно других процессов центрального процессора. Требуется установка одного из перечисленных ниже параметров.
  • НИЗКИЙ
  • НИЖЕ НОРМЫ — параметр по умолчанию ePolicy Orchestrator.
  • НОРМА — параметр по умолчанию Консоль VirusScan.
ПРИМЕЧАНИЕ: Пользователь может ввести числовой параметр от 1 до 100, где 10 соответствует параметру «НИЗКИЙ», 50 — параметру «НИЖЕ НОРМЫ», а 100 — параметру «НОРМА».

PROMPT

Запрос действия от пользователя при обнаружении потенциально нежелательной программы.

PROMPT2

Запрос действия от пользователя при обнаружении потенциально нежелательной программы и при ошибке основного действия.

PROMPTA

Запрос действия от пользователя при обнаружении нежелательной программы.

PROMPTA2

Запрос действия от пользователя при обнаружении нежелательной программы и при ошибке основного действия.

RPTSIZE

Установка размера журнала регистрации тревог, в мегабайтах.

START

Запуск сканирования. Диалоговое окно свойств не отображается.

TASK

Запуск задачи устройства проверки по требованию, указанной в консоли VirusScan. Требуется дополнительный параметр, содержащий идентификатор задачи, записанный в реестре по следующему пути: hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks.

UINONE

Запуск сканера без отображения диалогового окна интерфейса пользователя.


Параметры командной строки задачи обновления

В VirusScan Enterprise для выполнения задач обновления используется процесс MCUPDATE.EXE. Для запуска задач обновления можно использовать одну исполняемую команду MCUPDATE из командной строки или как часть пакетного файла.

В синтаксисе MCUPDATE не требуется определенный порядок элементов. Особенность состоит только в том, что свойство и его значение нельзя разделять. Синтаксис включает следующие элементы.
  • Имя файла — имя исполняемого файла: MCUPDATE.EXE.
  • Параметры — параметру предшествует косая черта (/), регистр не учитывается.
Команда представляется в следующем формате.
MCUPDATE [/<тип> [/ЗАДАЧА <guid>]] [/параметр].
ПРИМЕЧАНИЕ: В предыдущем формате в качестве <типа> может быть указано ROLLBACKDATS или UPDATE.

Пункт /ЗАДАЧА необязательный. Однако если он используется, необходимо также указать идентификатор задачи обновления (guid). Выбираемый идентификатор задачи должен быть для задачи обновления или отката файлов DAT. Не выбирайте идентификатор сканирования. Если не указать идентификатор задачи, будет использована задача обновления по умолчанию. Идентификаторы задач расположены по следующему пути: hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

Пункт /параметр является необязательным. Для выполнения задачи обновления в фоновом режиме используйте параметр /QUIET.
ПРИМЕЧАНИЕ: Параметр /QUIET не поддерживается для задачи отката файлов DAT. Пример задачи обновления, выполняемой в фоновом режиме: MCUPDATE /UPDATE /QUIET.

Параметры задачи обновления

Параметр командной строки | Определение
ROLLBACKDATS | Откат текущего файла DAT до последней архивной версии.
UPDATE | Выполнение обновления файла DAT, механизма сканирования, продукта или файла extra.dat.
/TASK | Запуск задачи AutoUpdate или задачи отката файлов DAT, указанной в консоли VirusScan. Требуется дополнительный параметр для указания идентификатора задачи, записанного в реестре по следующему пути: hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | Выполнение задачи в фоновом режиме.


Подключение к удаленным системам

Пользователь может подключаться к удаленным системам с установленным приложением VirusScan Enterprise для выполнения таких операций, как изменение, планирование сканирования, задач обновления, а также включения и выключения сканера при доступе в удаленной системе.
ПРИМЕЧАНИЕ: Если у пользователя нет административных прав для подключения к удаленной системе, отобразится сообщение Недостаточно прав. В доступе отказано.

При запуске Удаленной консоли VirusScan имя системы, с которой устанавливается соединение, отображается в строке заголовка консоли. Если не установлено соединение ни с одной из систем в сети, в строке заголовка не будет отображаться имя локальной системы. При открытии в удаленной консоли диалогового окна свойств любой задачи имя системы отображается в строке заголовка диалогового окна свойств.

Пользователь может открыть несколько удаленных консолей. При закрытии диалогового окна Подключиться к удаленному компьютеру окно подключения к удаленной системе также закрывается.


Доступ к удаленным системам с установленным приложением VirusScan Enterprise

Для подключения к удаленным системам с установленным приложением VirusScan Enterprise для администрирования используйте команду «Открыть удаленную консоль» в Консоль VirusScan.

Задача

Чтобы просмотреть определения параметров, щелкните Справка в окне интерфейса.

  1. В меню Сервис в консоли VirusScan Enterprise 8.8 выберите Открыть удаленную консоль.
  2. В области Установить соединение с компьютером введите имя системы для администрирования и выберите систему из списка или щелкните Обзор, чтобы найти систему в сети.
    ПРИМЕЧАНИЕ: При использовании переменных среды в настройке имени пути файла или папки для удаленной задачи убедитесь в наличии переменной среды в удаленной системе. Консоль VirusScan Enterprise 8.8 не выполняет проверку переменных среды в удаленной системе.
  3. Щелкните OK, чтобы выполнить попытку установки соединения с удаленной системой. При подключении к удаленной системе:
    • в строке заголовка отображается имя соответствующей системы;
    • консоль считывает реестр удаленной системы и отображает ее задачи;
    • пользователь может добавлять, удалять или изменять конфигурацию удаленной системы.


Отправка образцов угроз на анализ

При нахождении потенциальной угрозы, для которой отсутствует определение, а также в случае, если сканер примет за угрозу то, что, по вашему мнению, не является угрозой, с помощью текущего файла DAT можно отправить образец угрозы в McAfee через веб-сайт WebImmune. В McAfee Labs будет выполнен анализ образца на предмет необходимости его включения или исключения из следующего файла DAT.

Образец можно отправить в McAfee Labs тремя способами: через веб-сайт WebImmune, по электронной или обычной почте.

WebImmune

  1. В Консоль VirusScan выберите Справка | Отправить образец, чтобы открыть веб-сайт. Веб-сайт расположен по следующему адресу: https://www.webimmune.net/default.asp.
  2. Войдите в систему под своей учетной записью или создайте учетную запись, если у вас ее нет.
  3. Загрузите файлы напрямую в автоматические системы McAfee Labs для анализа. Элементы передаются аналитикам McAfee Labs при необходимости дополнительного анализа.

Электронная почта

Отправляйте электронные сообщения напрямую в автоматические системы McAfee Labs для анализа. Элементы передаются аналитикам McAfee Labs при необходимости дополнительного анализа.

Глобальный адрес электронной почты: virus_research@avertlabs.com.
ПРИМЕЧАНИЕ: Региональные адреса можно узнать на веб-сайте WebImmune.

Обычная почта

Адрес можно найти на веб-сайте WebImmune.
ПРИМЕЧАНИЕ: Это наименее эффективный способ, при котором обработка образца займет больше всего времени.


Открытие библиотеки угроз McAfee

Для открытия библиотеки угроз McAfee из консоли VirusScan Enterprise 8.8 выберите пункт Библиотека угроз McAfee Labs в меню Справка. В веб-обозревателе откроется следующая страница: http://vil.nai.com/vil/default.aspx.


Устранение проблем

Прежде чем обращаться в службу технической поддержки McAfee, ознакомьтесь с информацией в данном разделе. Он содержит сведения о процедурах и средствах поиска и устранения неполадок VirusScan Enterprise, а также часто задаваемые вопросы.


Восстановление установки продукта

Иногда может потребоваться восстановить установку VirusScan Enterprise для возврата настроек по умолчанию и/или переустановки программных файлов. Это можно сделать с помощью Консоль VirusScan или командной строки.

Использование Консоль VirusScan

Откройте служебную программу Восстановление установки в консоли VirusScan Enterprise 8.8 и выберите Справка | Восстановление установки.
ПРИМЕЧАНИЕ: В консоли ePolicy Orchestrator данная функция недоступна.
Параметр | Определение
Восстановить все настройки установки до настроек по умолчанию | Восстановление настроек установки VirusScan Enterprise по умолчанию. ОСТОРОЖНО: Пользовательские настройки могут быть утрачены.
Переустановить все файлы программы | Переустановка файлов программы VirusScan Enterprise. ОСТОРОЖНО: Исправления и пакеты обновлений могут быть заменены.

Использование исполняемого файла SETUPVSE.exe в командной строке

Для восстановления или переустановки VirusScan Enterprise из командной строки с помощью SETUPVSE.exe используйте следующие команды.
ПРИМЕЧАНИЕ: Параметры командной строки REINSTALLMODE см. в разделе Свойство REINSTALLMODE по адресу: http://msdn.microsoft.com/en-us/library/aa371182(VS.85).aspx.
Описание | Команда
Установить только файлы программы | SETUPVSE.exe REINSTALLMODE=sec /q
Установить только файлы реестра | SETUPVSE.exe REINSTALLMODE=secum /q
Установить файлы программы и реестра | SETUPVSE.exe REINSTALLMODE=amus /q

Использование исполняемого файла msiexec.exe в командной строке

Для восстановления или переустановки VirusScan Enterprise из командной строки с помощью msiexec.exe используйте следующие команды.
ПРИМЕЧАНИЕ: Параметры командной строки msiexec.exe см. в разделе Свойства командной строки для установщика Microsoft Windows Msiexec.exe по адресу: http://support.microsoft.com/kb/314881.
Описание | Команда
Установить только файлы программы | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=sa /q REBOOT=R
Установить только файлы реестра | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=mu /q REBOOT=R
Установить файлы программы и реестра | msiexec.exe /I VSE880.msi REINSTALL=ALL REINSTALLMODE=samu /q REBOOT=R


Просмотр файла журнала активности при доступе

Файл журнала активности при доступе Консоль VirusScan содержит историю обновлений, угроз и ответов VirusScan Enterprise. Эти сведения могут быть полезны при устранении неполадок при автоматическом обновлении и настройке политик.

Используйте один из описанных ниже процессов для доступа к файлам журнала активности при доступе.
ПРИМЕЧАНИЕ: Необходимо включить функцию создания файла журнала активности при доступе. Сведения о включении файла журнала активности при доступе см. в разделе Настройка общих параметров.

Задача

Чтобы просмотреть определения параметров, щелкните Справка на каждой вкладке.
  1. В списке Задача щелкните правой кнопкой мыши Сканер при доступе, а затем щелкните Свойства, чтобы открыть диалоговое окно.
  2. В диалоговом окне «Свойства сканера при доступе» щелкните вкладку Отчеты, а затем щелкните Просмотреть журнал. В окне Блокнота откроется файл OnAccessScanLog.txt. Далее приведен пример данных файла журнала.

  3. В следующей таблице описаны данные приведенного ранее примера с файлом OnAccessScanLog.txt.
    Пример записи журнала | Описание
    4/27/2010 | Дата
    1:35:47 PM | Время
    Cleaned/Deleted/No Action Taken | Выполненное действие
    File updated = version или (Clean failed because... | Описание действия
    SRVR\user | Учетные данные
    C:\WINDOWS\system32\NOTEPAD.EXE C:\temp\eicar.com | Путь и имя файла угрозы
    EICAR test file (Test) | Описание файла

Аналогичные сведения можно получить с помощью запросов ePolicy Orchestrator. Подробные сведения см. в разделе Доступ к запросам и панелям мониторинга.

Связанные задачи
Настройка общих параметров
Связанная информация
Доступ к запросам и панелям мониторинга


Использование инструмента MERTool в процессе устранения неполадок

Инструмент MERTool (Minimum Escalation Requirements) обеспечивает сбор данных McAfee VirusScan Enterprise и других продуктов McAfee с вашего компьютера. Эти данные позволяют Службе технической поддержки McAfee анализировать и подбирать решение для возникающих проблем.

Инструмент WebMER можно загрузить в одном из следующих форматов файлов:
  • EXE;
  • ZIP;
  • защищенный Zip.
Данные, собираемые инструментом WebMER:
  • данные реестра;
  • данные о версиях файлов;
  • файлы;
  • журналы событий;
  • данные о процессе.
Чтобы использовать инструмент WebMER, необходимо:
  • Просмотреть учебное пособие Obtaining Minimum Escalation Requirements using McAfee WebMER (Получение минимальных требований к эскалации с помощью McAfee WebMER) по адресу: https://kc.mcafee.com/corporate/index?page=content&id=TU30146.
  • Загрузить и установить инструмент с сайта: http://mer.mcafee.com.
    ПРИМЕЧАНИЕ: Также доступна версия ePolicy Orchestrator для развертывания. В этой версии консоль ePolicy Orchestrator используется для запуска инструмента MERTool на клиентских компьютерах с целью сбора журналов и данных при диагностике проблем продукта McAfee. Загрузите инструмент McAfee MERTool для ePolicy Orchestrator 4.x (v2.0) с сайта: http://mer.mcafee.com/enduser/downloadepomer.aspx.
  • Запустите инструмент и отправьте данные в Службу технической поддержки McAfee.


Отключение VirusScan Enterprise в процессе устранения неполадок

В случае возникновения проблемы в системе, которая может быть связана с запуском тех или иных процессов VirusScan Enterprise, можно методично отключать функции VirusScan Enterprise до тех пор, пока не будет устранена проблема. Можно также удалить VirusScan Enterprise как причину проблемы.
ОСТОРОЖНО:
После устранения неполадок необходимо снова выполнить конфигурацию или восстановить VirusScan Enterprise для обеспечения полной защиты от вредоносного программного обеспечения.
Методичное отключение функций VirusScan Enterprise осуществляется в следующие восемь этапов.
  1. Отключение защиты от переполнения буфера
  2. Отключение защиты доступа
  3. Отключение ScriptScan
  4. Отключение проверки при доступе
  5. Отключение проверки при доступе с последующей перезагрузкой
  6. Предотвращение загрузки службы проверки защиты доверенной области McAfee с последующей перезагрузкой компьютера
  7. Переименование файла mfehidk.sys с последующей перезагрузкой
  8. Удаление продукта с последующей перезагрузкой

Каждый из этих восьми этапов описан в следующих разделах. Чтобы просмотреть определения тех или иных параметров в Консоль VirusScan, щелкните значок Справка в окне интерфейса.

Отключение защиты от переполнения буфера

Выполните следующие действия, чтобы отключить защиту от переполнения буфера.
  1. В списке «Задача» консоли Консоль VirusScan щелкните правой кнопкой мыши элемент Защита от переполнения буфера и выберите Свойства.
  2. В диалоговом окне «Свойства» снимите флажок Включить защиту от переполнения буфера и щелкните OK.
  3. Устранена ли исходная проблема системы путем отключения защиты от переполнения буфера:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с этой функцией.

Отключение защиты доступа

Выполните следующие действия, чтобы отключить защиту доступа.
  1. В списке «Задача» Консоль VirusScan дважды щелкните Защита доступа, чтобы открыть диалоговое окно «Свойства защиты доступа».
  2. Щелкните вкладку Защита доступа, снимите флажок Включить защиту доступа и щелкните OK.
  3. Устранена ли исходная проблема системы путем отключения защиты доступа:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с VirusScan Enterprise.

Отключение ScriptScan

Выполните следующие действия, чтобы отключить ScriptScan.
  1. В списке «Задача» консоли Консоль VirusScan щелкните правой кнопкой мыши Сканер при доступе, чтобы открыть диалоговое окно «Свойства сканера при доступе».
  2. Щелкните вкладку ScriptScan, снимите флажок Отключить сканирование сценариев и щелкните OK.
  3. Устранена ли исходная проблема системы путем отключения ScriptScan:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с VirusScan Enterprise.

Отключение проверки при доступе

Выполните следующие действия, чтобы отключить проверку при доступе.
  1. Отключите защиту доступа. В списке «Задача» консоли Консоль VirusScan щелкните правой кнопкой мыши Защита доступа и выберите Отключить.
  2. Измените тип запуска приложения McShield Services, установив флажок Отключено. Для этого выполните следующее.
    • Щелкните Пуск | Панель управления | Администрирование | Службы, чтобы открыть приложение «Службы».
    • В окне «Службы (локальные)» прокрутите список к пункту McAfee McShield и щелкните правой кнопкой имя, чтобы открыть диалоговое окно «Свойства McAfee McShield».
    • Щелкните вкладку Общие, в списке «Тип запуска» выберите Отключено и щелкните OK.
  3. В списке «Задача» консоли Консоль VirusScan щелкните правой кнопкой мыши Сканер при доступе и выберите в открывшемся списке пункт Отключить. Значок «Сканер при доступе» должен измениться на круг с косой чертой, который указывает, что функция отключена.
  4. Устранена ли исходная проблема системы путем отключения проверки при доступе:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с этой функцией.

Отключение проверки при доступе с последующей перезагрузкой

Выполните следующие действия, чтобы отключить проверку при доступе с последующей перезагрузкой.
ПРИМЕЧАНИЕ: В следующей процедуре предполагается, что проверка при доступе не включена после отключения в ходе выполнения действий предыдущего раздела.

  1. Выполните процедуру полного выключения и перезагрузите систему.
  2. Устранена ли исходная проблема системы путем отключения проверки при доступе с последующей перезагрузкой:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с этой функцией.

Предотвращение загрузки службы проверки защиты доверенной области McAfee с последующей перезагрузкой компьютера

Выполните следующие действия, чтобы предотвратить загрузку службы проверки защиты доверенной области McAfee и перезагрузку системы.
ОСТОРОЖНО:
В этом разделе содержатся сведения об открытии или изменении реестра.
  • Следующие сведения предназначены для системных администраторов. Изменения реестра являются необратимыми и при неправильном выполнении могут привести к сбою в работе системы.
  • Перед внесением изменений McAfee настоятельно рекомендует выполнить резервное копирование реестра и разобраться в процедуре восстановления. Дополнительные сведения см. по адресу: http://support.microsoft.com/kb/256986 .
  • Не запускайте файл .REG, если он не утвержден как подлинный файл импорта реестра.

  1. В командной строке введите regedit, чтобы открыть окно редактора реестра.
  2. Перейдите к следующему разделу реестра: [HKEY_LOCAL_MACHINE\System\ControlSet001\Services\mfevtp]
  3. На правой панели щелкните правой кнопкой мыши Пуск и выберите пункт Изменить, чтобы открыть диалоговое окно «Изменение параметра DWORD».
  4. Введите 4 в поле «Значение» и щелкните OK.
  5. Устранена ли исходная проблема системы путем предотвращения загрузки службы проверки защиты доверенной области McAfee с последующей перезагрузкой:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с этой функцией.

Переименование файла mfehidk.sys с последующей перезагрузкой

Выполните следующие действия, чтобы переименовать файл и выполнить перезагрузку системы.
  1. Перейдите к файлу mfehidk.sys в следующей папке (зависит от операционной системы).
    • Для 32-разрядных операционных систем: %windir%\System32\drivers
    • Для 64-разрядных операционных систем: %windir%\System64\drivers
  2. Измените имя файла mfehidk.sys, например, на mfehidk.sys.saved.
  3. Перезагрузите систему, чтобы остановить и перезапустить приложение VirusScan Enterprise без загрузки файла mfehidk.sys.
  4. Устранена ли исходная проблема системы путем переименования файла mfehidk.sys с последующей перезагрузкой:
    • Да — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.
    • Нет — возможно, исходная проблема в системе не связана с VirusScan Enterprise.

Удаление продукта с последующей перезагрузкой

Выполните следующие действия, чтобы полностью удалить VirusScan Enterprise и выполнить перезагрузку системы.
  1. Удалите файлы программы VirusScan Enterprise. Подробные инструкции см. в руководстве по установке McAfee VirusScan Enterprise 8.8.
  2. Перезагрузите систему, чтобы остановить и перезапустить операционную систему без установки VirusScan Enterprise.
  3. Устранена ли исходная проблема системы путем удаления файлов программы VirusScan Enterprise и перезагрузки системы:
    • Да — возможно, исходная проблема в системе связана с VirusScan Enterprise.
    • Нет — перейдите на портал McAfee Technical Support ServicePortal по адресу http://mysupport.mcafee.com и выполните поиск решения или обратитесь в Службу технической поддержки McAfee.


Предлагаемые инструменты поддержки и устранения неполадок

Глобальному администратору VirusScan Enterprise необходимо установить и настроить инструменты для устранения неполадок и оценки безопасности и производительности системы. При обращении в Службу технической поддержки McAfee, возможно, вас попросят запустить эти инструменты в процессе устранения неполадок в вашей конфигурации. Эти инструменты можно загрузить с интернет-сайтов, перечисленных в данных таблицах.

Инструменты McAfee

Инструменты поддержки и устранения неполадок, которые можно загрузить с сайта McAfee, перечислены в данной таблице.

Инструмент | Сайт загрузки
Инструмент MERTool | WebMER
ProcessCounts | Предоставляется Службой поддержки McAfee
SuperDAT Manager | Предоставляется Службой поддержки McAfee
McAfee Profiler | Предоставляется Службой поддержки McAfee

Инструменты других разработчиков

Инструменты поддержки и устранения неполадок, исполняемые файлы и сайт загрузки перечислены в приведенной ниже таблице.

Инструмент | Исполняемый файл | Сайт загрузки
Driver Verifier | Verifier | Microsoft.com
Performance Monitor | PerfMon | Microsoft.com
Pool Monitor | PoolMon | Microsoft.com
Process Monitor | ProcMon | Microsoft.com
Process Explorer | ProcExp | Microsoft.com
Process Dump | ProcDump | Microsoft.com
Windows Object Viewer | WinObj | Microsoft.com
TCP Viewer | TCPView | Mircosoft.com
Debug Output Viewer | DebugView | Microsoft.com
Отладчик Windows | WinDbg | Microsoft.com
Kernel Rate Viewer | KrView | Microsoft.com
Инструменты анализа производительности Windows | Xperf | Microsoft.com
VM Converter | Различные | Vmware.com
WireShark | wireshark | Wireshark.org


Часто задаваемые вопросы

В данном разделе представлены сведения о поиске и устранении неисправностей в форме часто задаваемых вопросов.

Установка

  • Вопрос. Я только что установил программное обеспечение, используя метод фоновой установки, однако на панели задач Windows не отображается значок VirusScan Enterprise.

    Ответ. Значок в виде щита отобразится на панели задач только после перезагрузки системы. Однако даже при отсутствии значка программное обеспечение VirusScan Enterprise работает и система защищена. Чтобы проверить это, найдите следующий раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • Вопрос. Почему одни пользователи в моей сети могут настраивать свои собственные параметры, а другие — не могут?

    Ответ. Вероятно, администратор указал в настройках интерфейса пользователя защиту задач паролем. В этом случае пользователи не могут изменить настройки. Кроме того, в различных операционных системах Windows существуют различные права пользователей. Для получения дополнительных сведений о правах пользователей см. документацию по Microsoft Windows.

Заблокированные программы

  • Вопрос. После установки VirusScan Enterprise одна из моих программ перестала работать.

    Ответ. Вероятно, программа заблокирована правилом защиты доступа.
    1. Чтобы узнать, не заблокирована ли программа правилом, просмотрите файл журнала защиты доступа.
    2. Если программа приведена в списке журнала, можно добавить ее в виде исключения для данного правила или отключить само правило. Для получения дополнительных сведений см. Защита точек доступа к системе.

Обнаружения файлов cookie

  • Вопрос. Если просмотреть обнаружения файлов cookie в журнале операций проверки по требованию, можно заметить, что у каждого обнаружения имя файла всегда одно и то же — 00000000.ie. Почему в VirusScan Enterprise каждому обнаружению файла cookie, выявленного в ходе проверки по требованию, назначается одно и то же имя, тогда как другие программы назначают им разные или последовательные имена?

    Ответ. VirusScan Enterprise назначает каждому обнаружению файла cookie одно и то же имя, поскольку так сканер, запускаемый по требованию, обнаруживает и выполняет действия по отношению к файлам cookie. Таким образом обрабатываются только файлы cookie, обнаруженные сканером по требованию. Файл cookie может содержать несколько элементов cookie. Механизм сканирования рассматривает файл cookie как архив и задает для него значение в виде отступа от начала файла (начинающегося с нуля). Поскольку сначала с помощью механизма сканирования сканер обнаруживает и выполняет действие по отношению к каждому файлу cookie и лишь потом приступает к сканированию, значение начинается с нуля для каждого обнаружения. В результате каждому обнаружению назначается имя файла 00000000.ie. Другие программы обнаруживают все файлы cookie, назначают каждому из них особое или последовательно возрастающее имя файла, а потом выполняют действия по каждому обнаружению.

Общие

  • Вопрос. В автономной системе VirusScan Enterprise значок системы на панели задач кажется отключенным.

    Ответ. Если значок VirusScan Enterprise заключен в красный перечеркнутый кружок, значит сканер, запускаемый при доступе, отключен. Ниже приведены наиболее распространенные причины и решения этой проблемы. Если они не помогут, обратитесь в службу технической поддержки.
    1. Убедитесь, что сканер, запускаемый при доступе, включен. На панели задач щелкните правой кнопкой мыши значок VirusScan Enterprise. Если сканер, запускаемый при доступе, отключен, щелкните Включить сканирование при доступе.
    2. Убедитесь, что служба McShield выполняется.
      • Запустите службу вручную на панели управления службами.
      • Выберите Пуск | Выполнить, а затем введите Net Start McShield.
      • Настройте автоматический запуск службы на панели управления службами.

  • Вопрос. Отображается сообщение об ошибке «Невозможно загрузить CATALOG.Z».

    Ответ. Эта ошибка может быть вызвана многими причинами. Ниже приведены рекомендации, которые помогут определить источник проблемы.
    • Если для обновлений по умолчанию используется сайт загрузки McAfee, проверьте возможность загрузки файла CATALOG.Z из веб-обозревателя. Попробуйте загрузить файл с веб-сайта: http://update.nai.com/Products/CommonUpdater/catalog.z.
    • Если файл загрузить не удается, но он отображается (иными словами, причина невозможности загрузки файла в обозревателе), значит проблема с прокси-подключением, о которой следует сообщить сетевому администратору.
    • Если файл удалось загрузить, значит он должен загружаться и программой VirusScan Enterprise. Обратитесь в службу технической поддержки за помощью в устранении проблем с программой VirusScan Enterprise.

  • Вопрос. По какому адресу находится сайт загрузки HTTP?

    Ответ.
    • Адрес сайта загрузки McAfee: http://www.mcafee.com/us/downloads/.
    • Файл CATALOG.Z, содержащий последние обновления, можно загрузить с веб-сайта: http://update.nai.com/Products/CommonUpdater/catalog.z.

  • Вопрос. По какому адресу находится сайт загрузки FTP?

    Ответ.
    • Адрес сайта загрузки FTP: ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x.
    • Файл CATALOG.Z, содержащий последние обновления, можно загрузить с веб-сайта: ftp://ftp.mcafee.com/CommonUpdater/catalog.z.

  • Вопрос. Если потенциально нежелательная программа будет обнаружена, какое действие следует выбрать при заданном параметре вывести запрос о действии (Очистить или Удалить)?

    Ответ. Если точно неизвестно, что лучше сделать с обнаруженным файлом, выберите Очистить. Сканеры, запускаемые при доступе и по требованию, автоматически создают резервные копии элементов в карантинном каталоге перед их очисткой или удалением.


Вкладка «Защита доступа»

Определения параметров

Настройте правила защиты доступа, чтобы предотвратить остановку процессов McAfee.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки защиты доступа
  • Включить защиту доступа: включение функции защиты доступа.
  • Запретить остановку служб McAfee: предотвращение прерывания процессов McAfee пользователями, не имеющими прав на отладку.

    Пользователи с правами на отладку программ по-прежнему смогут останавливать процессы McAfee даже при выборе этого параметра.

    В операционных системах Windows XP и Windows 2003 администраторы по умолчанию имеют права на отладку программ. Удалите эти права из разрешений пользователя, чтобы они не могли останавливать процессы McAfee.

ОСТОРОЖНО:
Если не включить защиту доступа и запрет остановки служб McAfee, система может остаться без защиты от многочисленных вредоносных атак.
Правила защиты доступа

Категории: выбор категории, для которой требуется отобразить правила. Существуют следующие категории правил.

  • Стандартная защита от вирусов
  • Максимальная защита от вирусов
  • Защита от вирусной эпидемии
  • Общая стандартная защита
    ОСТОРОЖНО:
    Если не настроить общую стандартную защиту и не включить параметры Блокировать и Отчет для следующих правил, система может остаться без защиты от многочисленных вредоносных атак.
    • Предотвращение модификации файлов и настроек McAfee.
    • Предотвращение модификации файлов и настроек McAfee Common Management Agent.
    • Предотвращение модификации файлов и настроек механизма сканирования McAfee.
    • Предотвращение прерывания процессов McAfee.
  • Общая максимальная защита
  • Защита виртуальных машин
  • Правила, определяемые пользователем
  • Стандартная защита от шпионских программ
  • Максимальная защита от шпионских программ

Дополнительные сведения см. в разделе Процесс определения правил защиты доступа.

Блокировать/отчет/правила. Настройте следующие правила.

  • Блокировать: блокировка процесса, указанного в поле Сведения о правиле. Установите флажок Блокировать, чтобы включить правило, или снимите, чтобы отключить его.

    ПРИМЕЧАНИЕ:

    Для блокировки попыток доступа без журналирования установите флажок Блокировать. При этом флажок Отчет должен быть снят.

  • Отчет: составление отчетов о попытках нарушения защиты доступа. В случае обнаружения соответствующие сведения записываются в журнал активности.
    ПРИМЕЧАНИЕ:

    Чтобы получать предупреждение без блокировки попыток доступа, установите флажок Отчет, но не устанавливайте флажок Блокировать. Это удобно, если результат действия правила полностью неизвестен. Рекомендуется некоторое время просматривать журналы и отчеты, чтобы определить, стоит ли блокировать доступ.

  • Правила: использование правил с целью защиты компьютера от нежелательных изменений. Правила сгруппированы по категориям. Сначала выберите категорию, затем — правило. Дополнительные сведения см. в разделах Настройка предварительно определенных правил и Настройка правил, определяемых пользователем.

    Создать: создание нового правила, определяемого пользователем. Дополнительные сведения см. в разделе Настройка правил, определяемых пользователем.

    Изменить: изменение существующего правила.

    Удалить: удаление существующего правила, определяемого пользователем.
    ПРИМЕЧАНИЕ:

    Можно удалять только правила, определяемые пользователем. Все остальные правила можно изменять или отключать, но не удалять. Чтобы отключить правило, снимите флажки Блокировать и Отчет.

Связанные задачи
Настройка параметров защиты интерфейса пользователя
Связанная информация
Защита доступа


Вкладка «Дополнительные параметры предупреждений»

Определения параметров

Настройте параметры фильтрации и параметры локальных предупреждений.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Фильтр «Опасность» Выберите один из следующих параметров фильтрации.
  • Не фильтровать предупреждения: отправка всех предупреждений.
  • Отключить информационные предупреждения: запрет на отправку информационных предупреждений с уровнем опасности менее 1.
  • Отключить информационные и оповещающие предупреждения: запрет на отправку информационных и оповещающих предупреждений с уровнем опасности менее 2.
  • Отключить информационные, оповещающие предупреждения и предупреждения с низким уровнем опасности: запрет на отправку информационных, оповещающих предупреждений и предупреждений с уровнем опасности менее 3.
  • Отключить все предупреждения, кроме предупреждений с высоким уровнем опасности: отправка только предупреждений с уровнем опасности более 4.
  • Отключить все предупреждения: запрет на отправку предупреждений.
Локальные предупреждения
  • Записывать в локальный журнал событий приложений: запись сведений в локальный журнал событий приложений.
  • Отправлять ловушку SNMP с помощью службы SNMP: пользователи службы SNMP могут отправлять предупреждения ловушки SNMP.
ПРИМЕЧАНИЕ:

Для параметров локальных предупреждений Alert Manager не требуется.
Связанные задачи
Настройка предупреждений
Связанная информация
Настройка предупреждений и уведомлений


Вкладка «Предупреждения»

Определения параметров

Выберите компоненты, необходимые для создания предупреждений, и настройте компонент Alert Manager, если он установлен.

Дополнительные сведения см. в руководстве по эксплуатации Alert Manager 4.7.1.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Компоненты, создающие предупреждения
  • Проверка при доступе: создание предупреждений при обнаружении угроз сканером, запускаемым при доступе.
  • Проверка по требованию и запланированная проверка: создание предупреждений при обнаружении угроз в ходе выполнения задач проверки по требованию.
  • Сканирование электронной почты: создание предупреждений при обнаружении угроз сканером электронной почты.
  • AutoUpdate: создание предупреждений при обнаружении угроз в ходе выполнения задач обновления.
  • Защита доступа: создание предупреждений при обнаружении угроз с помощью функции «Защита доступа».
Параметры Alert Manager
  • Отключить предупреждения: запрет на создание предупреждений при обнаружениях.
  • Включить централизованное оповещение: использование централизованного оповещения для уведомления пользователя при обнаружениях.
  • Включить предупреждения Alert Manager: использование предупреждений Alert Manager для уведомления пользователя об обнаружениях. Выберите этот параметр и укажите путь к папке на сервере Alert Manager, на который поступают предупреждения.
    • Отключить поиск в Active Directory: запрет на использование поиска в Active Directory.
Связанные задачи
Настройка предупреждений
Связанная информация
Настройка предупреждений и уведомлений


Вкладка «Отчеты»

Определения параметров

Включите журналирование для отслеживания событий в сети и регистрации настроек, которые использовались сканером для обнаружения потенциальной угрозы и реагирования на нее.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Записывать в файл | Включение журналирования активности.
Местоположение файла журнала Примите местоположение файла журнала по умолчанию или укажите новое местоположение.

Имя журнала по умолчанию: AccessProtectionLog.txt.

Местоположение по умолчанию: <Диск>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

В различных операционных системах местоположение по умолчанию может быть разным.
Размер файла журнала | Ограничение размера файла журнала. Примите размер по умолчанию (1 МБ) или укажите размер в пределах от 1 до 999 МБ. Если объем данных в файле журнала превысит заданный размер, 20 процентов наиболее старых записей будет удалено, и в файл будут добавлены новые данные.
Формат файла журнала Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Связанные понятия
Нарушения доступа и способы реагирования VirusScan Enterprise
Связанные задачи
Консоль VirusScan
Связанные ссылки
Просмотр файла журнала активности при доступе


Задача AutoUpdate

Настройка задачи AutoUpdate

Определения параметров

Параметр | Определение
Файл журнала | Включение журналирования активности.
Формат Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Получить новые файлы определения обнаружений (если доступны)

Получение последней версии файлов DAT (если доступна).

Получить новый механизм обнаружения (если доступен)

Получение последней версии механизма и/или файлов DAT (если доступна).

Получить другие доступные обновления (пакеты обновления, обновления версий и др.)

Получение последней версии других обновлений, например пакетов обновлений и обновлений продуктов.

Ввести имя исполняемого файла, который необходимо запустить после выполнения обновления

Указание имени исполняемого файла, запускаемого после завершения задачи AutoUpdate. Укажите путь к исполняемому файлу, который требуется запустить, или щелкните «Обзор», чтобы найти его.

Например, можно запустить служебную программу сетевых сообщений, уведомляющую администратора об успешном выполнении задачи AutoUpdate.

ПРИМЕЧАНИЕ: Выбранный файл программы должен быть доступен для выполнения текущему пользователю, вошедшему в систему. Если у текущего пользователя нет доступа к папке, содержащей файлы программы, либо вошедшие в систему пользователи отсутствуют, программа не запустится.
Выполнять только после успешного обновления

Запуск исполняемой программы только после успешного обновления. Если обновление выполнено с ошибками, исполняемая программа не запустится.

Планирование

Планирование выполнения данной задачи обновления.

ПРИМЕЧАНИЕ:

Дополнительные сведения см. в разделе «Планирование задач».

Не рекомендуется планировать одновременное выполнение задач AutoUpdate и задач отражения. При выполнении обеих задач используется служба McAfee Common Framework, и их одновременный запуск может привести к конфликту.

Обновить сейчас

Немедленное выполнение задачи AutoUpdate.

Связанные понятия
Задачи обновления и принципы их работы
Связанные ссылки
Настройка задачи AutoUpdate


Вкладка «Блокировка»

Определения параметров

Можно блокировать соединения с удаленных компьютеров, в общих папках которых содержатся файлы с потенциальными угрозами или нежелательные программы.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Отправка сообщения | Отправить указанное сообщение пользователю сети при обнаружении угрозы: уведомление пользователя сети на удаленном компьютере при обнаружении угрозы.
Текст сообщения

Введите требуемое сообщение в текстовое поле. Для получения этого сообщения на удаленном компьютере должна быть запущена служба Windows Messenger.
Блокировать соединение
  • Блокировать соединение при обнаружении в общей папке опасного файла: блокировка соединения с любым пользователем сети на удаленном компьютере, который пытается прочитать опасный файл в общей папке или выполнить запись в него.
  • Разблокировать соединения через: разблокировка соединения по истечении указанного числа минут. Введите число от 1 до 9999. По умолчанию = 10 минут.
  • Блокировать соединение при обнаружении в общей папке потенциально нежелательной программы: блокировка соединения с любым пользователем сети на удаленном компьютере, который пытается выполнить запись потенциально нежелательной программы на компьютер. В диалоговом окне Статистика проверки при доступе отображается список заблокированных компьютеров.
Связанные ссылки
Параметры правил блокировки портов
Параметры правил блокировки файлов и папок
Параметры правил блокировки реестров
Связанная информация
Защита доступа


Вкладка «Отчеты»

Определения параметров

Включите журналирование, чтобы отслеживать в локальной системе обнаружения выполнения кода из переполнений динамической памяти или стека для определенных процессов.

Параметр | Определение
Предупреждать о файлах сookie | Уведомление пользователя при обнаружении файла Cookie. По умолчанию = Выбрано.
Записывать в файл | Включите функцию журналирования активности и примите местоположение файла журнала по умолчанию или укажите новое местоположение.
Местоположение файла журнала Примите местоположение файла журнала по умолчанию или укажите новое местоположение.

Имя журнала по умолчанию: BufferOverflowProtectionLog.txt.

Местоположение по умолчанию: <Диск>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

В различных операционных системах местоположение по умолчанию может быть разным.

Размер файла журнала | Ограничение размера файла журнала. Примите размер по умолчанию (1МБ) или укажите размер в пределах от 1 до 999 МБ. Если объем данных в файле журнала превысит заданный размер, 20 процентов наиболее старых записей будет удалено, и в файл будут добавлены новые данные.
Формат файла журнала Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Связанная информация
Настройка предупреждений и уведомлений
Блокировка атак с переполнением буфера


Вкладка «Защита от переполнения буфера»

Определения параметров

Предотвратите выполнение на компьютере произвольного кода в результате атак с переполнением буфера.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки переполнения буфера Включить защиту от переполнения буфера: включение функции защиты от переполнения буфера, затем выбор уровня защиты.

  • Режим предупреждения: отправка предупреждения при обнаружении переполнения буфера. Никакие другие действия не предпринимаются.

    Это удобно, если результат переполнения буфера полностью неизвестен. Рекомендуется некоторое время использовать эту функцию в Режиме предупреждения, просматривая файл журнала, чтобы определить, следует ли включать Режим защиты.

  • Режим защиты: блокировка переполнений буфера при их обнаружении и прекращение действия обнаруженной угрозы.

    Это также может привести к завершению работы приложения.

ОСТОРОЖНО:
Если не включить защиту от переполнения буфера и режим защиты, система может остаться без защиты от многочисленных вредоносных атак.
Предупреждение клиентской системы | Выводить диалоговое окно сообщений при обнаружении переполнения буфера: отображение диалогового окна Сообщения сканера при доступе в случае обнаружения.
Исключения при переполнении буфера Указание сведений об исключениях.
ПРИМЕЧАНИЕ:

Имена исключений вводятся с учетом регистра.

  • Процесс: указание имени процесса, к которому относится доступная для записи память, выполняющая вызов.

    Введите имя процесса или укажите путь к нему.

    Если ввести только имя процесса, например OUTLOOK.EXE, данный процесс исключается при каждом его запуске независимо от местоположения. Если ввести имя процесса и путь к нему, например C:\Program files\OUTLOOK.EXE, этот процесс исключается только при выполнении из указанной папки. Подстановочные знаки не допускаются.

  • Модуль (дополнительно): ввод имени модуля, к которому относится доступная для записи память. Эта информация не является обязательной.
  • API: указание вызываемого API.
    ПРИМЕЧАНИЕ:

    Имя API требуется только при указании модуля.

Связанные задачи
Настройка защиты от переполнения буфера
Связанная информация
Блокировка атак с переполнением буфера


Вкладка «Процессы»

Определения параметров

Выберите настройку одной политики сканирования для всех процессов или разные политики сканирования для процессов по умолчанию, малоопасных процессов и процессов с высоким риском.

Дополнительные сведения см. в разделах Определение числа политик сканирования и Определение риска, назначаемого процессу.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки процессов Укажите, следует ли настраивать одну или несколько политик сканирования.
  • Настроить одну политику сканирования для всех процессов: при выборе этого параметра настраиваемая политика будет применяться для всех процессов.
  • Настроить отдельные политики сканирования для процессов с высоким риском, малоопасных процессов и процессов по умолчанию: перед настройкой разных политик для процессов с разной степенью риска следует выбрать этот параметр.
Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Параметры отображения»

Определения параметров

Настройте параметры панели задач, доступные для пользователей, и предпочтительный язык.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Значок на панели задач
  • Отображать значок панели задач со всеми параметрами меню: отображение всех параметров меню на панели задач.
  • Отображать значок панели задач с минимальным числом параметров меню: скрытие всех параметров меню панели задач, кроме О программе VirusScan Enterprise и Статистика проверки при доступе.
  • Не отображать значок панели задач: скрытие значка панели задач от всех пользователей.
Параметры консоли
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.

  • Разрешить системе устанавливать подключения удаленной консоли к другим системам: подключение к удаленным компьютерам.

    Для этого необходимо наличие прав администратора и запуск службы удаленного реестра.

  • Отображать управляемые задачи в клиентской консоли: отображение задач ePolicy Orchestrator в консоли на клиентском компьютере.
  • Отключить расписание задачи AutoUpdate по умолчанию: отключение расписания для задачи обновления по умолчанию.

    При применении этой политики расписание отключается. Для отключения расписания задачи необходимо запуск службы Task Manager.

  • Включить экран-заставку: отображение экрана-заставки VirusScan Enterprise 8.8 при запуске консоли или SHSTAT.EXE.
    ПРИМЕЧАНИЕ:

    Этот параметр доступен только в ePolicy Orchestrator.

Языковые настройки консоли Указание языка, используемого для текста консоли.
  • Язык может быть выбран автоматически или пользователем.
    ПРИМЕЧАНИЕ:

    После изменения языка в консоли VirusScan Enterprise 8.8 отображается запрос на перезапуск системы. При нажатии кнопки Да изменение языка вступает в силу.

    При изменении языка консоли ePolicy Orchestrator это изменение применяется к пользовательской консоли при первом применении политики.

    Для управляемых систем ePolicy Orchestrator изменения, выполненные пользователем из клиентской системы, применяются к интерфейсу консоли, но события записываются в файл журнала на языке, указанном в конфигурации ePolicy Orchestrator. Изменение языка консоли вступает в силу после ее перезапуска.

Связанные задачи
Настройка параметров защиты интерфейса пользователя
Связанная информация
Защита доступа


Вкладка «Действия»

Определения параметров

Настройте действия, которые требуется выполнять при обнаружении угрозы или потенциально нежелательной программы.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
При обнаружении угрозы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить вложения.
  • Очистить вложения: сканер попытается удалить угрозу из вложения.
  • Запрос на действие: вывод запроса на действие в случае обнаружения угрозы. Выберите этот параметр, а затем в группе Разрешенные действия в диалоговом окне «Запрос» укажите доступные для пользователей действия.
Для данного параметра дополнительные действия недоступны.
  • Продолжить сканирование: продолжение сканирования при обнаружении вложения с угрозой.
Для данного параметра дополнительные действия недоступны.
  • Переместить вложения в папку: сканер перемещает вложения с потенциальными угрозами в назначенную папку.
  • Удалить вложения: при обнаружении вложений с потенциальными угрозами сканер удаляет их. В программе Microsoft Outlook удаляется все сообщение электронной почты. В программе Lotus Notes удаляется только вложение.
  • Удалить почту (только для сканера Outlook): сканер удаляет почту с потенциальными угрозами. При выборе этого параметра в качестве основного действия дополнительные действия недоступны.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Переместить вложения в папку.
  • Запрос на действие: вывод запроса на действие в случае обнаружения угрозы. Выберите этот параметр, а затем в группе Разрешенные действия в диалоговом окне «Запрос» укажите доступные для пользователей действия.
  • Продолжить сканирование: продолжение сканирования при обнаружении вложения с угрозой.
  • Переместить вложения в папку: сканер перемещает вложения с потенциальными угрозами в назначенную папку.
  • Удалить вложения: при обнаружении вложений с потенциальными угрозами сканер удаляет их. В программе Microsoft Outlook удаляется все сообщение электронной почты. В программе Lotus Notes удаляется только вложение.
  • Удалить почту (только для сканера Outlook): сканер удаляет почту с потенциальными угрозами.
При обнаружении нежелательной программы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить вложения.
  • Очистить вложения: сканер попытается удалить угрозу из вложения.
  • Запрос на действие: вывод запроса на действие в случае обнаружения угрозы. Выберите этот параметр, а затем в группе Разрешенные действия в диалоговом окне «Запрос» укажите доступные для пользователей действия.
Для данного параметра дополнительные действия недоступны.
  • Продолжить сканирование: продолжение сканирования при обнаружении вложения с угрозой.
Для данного параметра дополнительные действия недоступны.
  • Переместить вложения в папку: сканер перемещает вложения с потенциальными угрозами в назначенную папку.
  • Удалить вложения: при обнаружении вложений с потенциальными угрозами сканер удаляет их. В программе Microsoft Outlook удаляется все сообщение электронной почты. В программе Lotus Notes удаляется только вложение.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Переместить вложения в папку.
  • Запрос на действие: вывод запроса на действие в случае обнаружения угрозы. Выберите этот параметр, а затем в группе Разрешенные действия в диалоговом окне «Запрос» укажите доступные для пользователей действия.
Для данного параметра дополнительные действия недоступны.
  • Продолжить сканирование: продолжение сканирования при обнаружении вложения с угрозой.
Для данного параметра дополнительные действия недоступны.
  • Переместить вложения в папку: сканер перемещает вложения с потенциальными угрозами в назначенную папку.
  • Удалить вложения: при обнаружении вложений с потенциальными угрозами сканер удаляет их. В программе Microsoft Outlook удаляется все сообщение электронной почты. В программе Lotus Notes удаляется только вложение.
Перемещение в папку Укажите местоположение карантиновой папки. Карантиновая папка должна находиться на жестком диске, и этот диск должен быть локальным. Папка не должна находиться на гибком диске или компакт диске, поскольку карантиновые папки для программ Microsoft Outlook и Lotus Notes отличаются.
  • Карантиновая папка Microsoft Outlook находится в почтовом ящике Microsoft Outlook.
  • Карантиновая папка Lotus Notes находится в файловой системе.
Разрешенные действия в диалоговом окне «Запрос» Выберите действия, доступные пользователю при запросе на выполнение действия.
ПРИМЕЧАНИЕ:

Для всех остальных действий выполняется действие Запретить доступ.

  • Очистить вложение
  • Удалить вложение
  • Переместить вложение
  • Удалить почту (только для Microsoft Outlook)
При выводе запроса на выполнение действия пользователь получает сообщение, указанное на вкладке Предупреждения.
Связанные задачи
Настройка политики карантина
Связанные ссылки
Обнаружения по результатам проверки при доступе
Обнаружения по результатам проверки по требованию
Обнаружения по результатам сканирования электронной почты
Связанная информация
Обнаружения и ответы


Вкладка «Предупреждения»

Определения параметров

Настройте параметры предупреждений для сканера электронной почты при доставке.

Параметр | Определение
Настройки | В раскрывающемся списке выберите Рабочая станция или Сервер. ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Предупреждение об электронной почте для пользователя | Отправить предупреждение об электронной почте пользователю: уведомление другого пользователя при обнаружении опасного сообщения электронной почты.
Запрос сообщения о действии | Указание сообщения, которое должно отображаться при запросе о действии. Необходимо выбрать параметр Запрос на действие на вкладке Действия. Примите сообщение по умолчанию или введите новое сообщение. Сообщение по умолчанию = Сканер электронной почты McAfee VirusScan Enterprise: предупреждение!
Связанные задачи
Настройка предупреждений


Вкладка «Элементы сканирования»

Определения параметров

Настройте параметры обнаружения для сканера электронной почты по требованию.

Параметр | Определение
Сообщения для сканирования
  • Все выделенные элементы: сканирование выбранных сообщений и папок электронной почты.
  • Все сообщения в папке «Входящие»: сканирование всех сообщений в папке «Входящие» и ее подпапках.
    • Сканировать только непрочитанные сообщения: сканирование всех непрочитанных сообщений в папке «Входящие» и ее подпапках.
Вложения для сканирования
  • Все типы файлов: сканирование всех типов файлов независимо от расширения.
  • По умолчанию + дополнительные типы файлов: сканирование файлов с расширениями, заданными по умолчанию, а также всех дополнительно указанных файлов. Список по умолчанию определяется текущим файлом DAT. Выберите параметр По умолчанию + дополнительные типы файлов, затем введите расширения в текстовое поле через пробел.

    Также сканировать все файлы на наличие макросов: в случае выбора параметра По умолчанию + дополнительные типы файлов можно также настроить поиск опасных макросов во всех файлах.

  • Указанные типы файлов: создание пользовательского списка расширений сканируемых файлов. Добавленные ранее расширения можно впоследствии удалять.

    Выберите параметр Указанные типы файлов, затем введите расширения файлов в текстовое поле через пробел.

Artemis (эвристическая проверка наличия подозрительных файлов в сети)
  • Найти неизвестные опасные программы и «троянские кони»: обнаружение исполняемых файлов, содержащих код, напоминающий вредоносную программу, с помощью сканирования вирусов Artemis.
  • Найти неизвестные опасные макросы: обнаружение макровирусов с помощью сканирования вирусов Artemis.
  • Поиск вложений с несколькими расширениями: распознавание вложений с несколькими расширениями как угроз.

    При выборе этого параметра отображается диалоговое окно Предупреждение о сканировании электронной почты. Щелкните OK, чтобы подтвердить выбор.

ОСТОРОЖНО:
Если не включить параметр Artemis, система может остаться без защиты от многочисленных вредоносных атак.
Сжатые файлы
  • Сканировать внутри архивов: проверка архивных (сжатых) файлов и их содержимого.

    Способствуя усилению защиты, проверка сжатых файлов в то же время может увеличить продолжительность сканирования.

  • Декодировать файлы в кодировке MIME: обнаружение, декодирование и сканирование файлов в кодировке MIME (Multipurpose Internet Mail Extensions).
Обнаружение нежелательных программ Обнаружение нежелательных программ: включение сканера электронной почты при доставке для обнаружения потенциально нежелательных программ. Для обнаружения потенциально нежелательных программ сканер электронной почты использует сведения, заданные в политике нежелательных программ.

Дополнительные сведения см. в разделе Запрещение потенциально нежелательных программ.

Текст сообщения электронной почты (только для Microsoft Outlook) | Сканировать текст сообщения электронной почты: сканирование текста сообщений электронной почты Microsoft Outlook.
Связанные задачи
Настройка задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Отчеты»

Определения параметров

Включите журналирование для отслеживания событий в сети и регистрации настроек, которые использовались сканером для обнаружения потенциальной угрозы и реагирования на нее.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Записывать в файл | Включение журналирования активности.
Местоположение файла журнала Примите местоположение файла журнала по умолчанию или укажите новое местоположение.

Имя журнала по умолчанию для сканирования электронной почты при доставке: EmailOnDemandLog.txt.

Местоположение по умолчанию: <Диск>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

В различных операционных системах местоположение по умолчанию может быть разным.

Размер файла журнала | Ограничение размера файла журнала. Примите размер по умолчанию (1 МБ) или укажите размер в пределах от 1 до 999 МБ. Если объем данных в файле журнала превысит заданный размер, 20 процентов наиболее старых записей будет удалено, и в файл будут добавлены новые данные.
Формат файла журнала Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Что заносить в журнал (кроме событий сканирования)
  • Настройки сеанса: в файл журнала записываются свойства каждого сеанса сканирования.
  • Сводка сеанса: в файл журнала записывается сводка действий сканера в ходе каждого сеанса сканирования. Информация в сводке включает количество просканированных файлов, количество обнаружений, их типы, количество очищенных и удаленных файлов, а также другие сведения.
  • Сбой при сканировании зашифрованных файлов: в журнал записываются имена зашифрованных файлов, при сканировании которых возникли сбои.
Связанные задачи
Настройка предупреждений


Вкладка «Элементы сканирования»

Определения параметров

Настройте параметры обнаружения для сканера электронной почты.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Сканирование электронной почты Включение сканирования электронной почты при доставке.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Вложения для сканирования
  • Все типы файлов: сканирование всех типов файлов независимо от расширения.
  • По умолчанию + дополнительные типы файлов: сканирование файлов с расширениями, заданными по умолчанию, а также всех дополнительно указанных файлов. Список по умолчанию определяется текущим файлом DAT. Выберите параметр По умолчанию + дополнительные типы файлов, затем введите расширения в текстовое поле через пробел.

    Также сканировать все файлы на наличие макросов: в случае выбора параметра По умолчанию + дополнительные типы файлов можно также настроить поиск опасных макросов во всех файлах.

  • Указанные типы файлов: создание пользовательского списка расширений сканируемых файлов. Добавленные ранее расширения можно впоследствии удалять.

    Выберите параметр Указанные типы файлов, затем введите расширения файлов в текстовое поле через пробел.

Artemis (эвристическая проверка наличия подозрительных файлов в сети)
  • Найти неизвестные опасные программы и «троянские кони»: обнаружение исполняемых файлов, содержащих код, напоминающий вредоносную программу, с помощью сканирования вирусов Artemis.
  • Найти неизвестные опасные макросы: обнаружение макровирусов с помощью сканирования вирусов Artemis.
  • Поиск вложений с несколькими расширениями: распознавание вложений с несколькими расширениями как угроз.

    При выборе этого параметра отображается диалоговое окно Предупреждение о сканировании электронной почты. Щелкните OK, чтобы подтвердить выбор.

ОСТОРОЖНО:
Если не включить параметр Artemis, система может остаться без защиты от многочисленных вредоносных атак.
Сжатые файлы
  • Сканировать внутри архивов: проверка архивных (сжатых) файлов и их содержимого.

    Способствуя усилению защиты, проверка сжатых файлов в то же время может увеличить продолжительность сканирования.

  • Декодировать файлы в кодировке MIME: обнаружение, декодирование и сканирование файлов в кодировке MIME (Multipurpose Internet Mail Extensions).
Обнаружение нежелательных программ Обнаружение нежелательных программ: включение сканера электронной почты при доставке для обнаружения потенциально нежелательных программ. Для обнаружения потенциально нежелательных программ сканер электронной почты использует сведения, заданные в политике нежелательных программ.

Дополнительные сведения см. в разделе Запрещение потенциально нежелательных программ.

Текст сообщения электронной почты (только для Microsoft Outlook) | Сканировать текст сообщения электронной почты: сканирование текста сообщений электронной почты Microsoft Outlook.
Эвристическая проверка наличия подозрительных файлов в сети
Настройте уровень чувствительности, который требуется использовать при определении, является ли обнаруженный образец вредоносной программой. На всех уровнях чувствительности, кроме Отключено, контрольные суммы образцов, или хэши, отправляются в лабораторию McAfee Labs, чтобы определить, являются ли они вредоносной программой. Преимущество заключается в том, что обнаружение может стать доступным после публикации обновления в McAfee Labs, поэтому ждать нового выпуска файла DAT не придется. Чем выше выбранный уровень чувствительности, тем выше число обнаружений вредоносных программ. Однако большее число обнаружений может привести к большему числу ложно положительных результатов. Выберите один из следующих уровней чувствительности.

  • Отключено: контрольные суммы и данные не отправляются в McAfee Labs, чтобы определить, являются ли они вредоносной программой.

  • Очень низкий: число обнаружений и риск ложно положительных результатов те же, что при использовании обычных файлов DAT. Обнаружение становится доступным для VirusScan Enterprise после его публикации в McAfee Labs, поэтому ждать следующего обновления файла DAT не требуется.

  • Низкий: этот уровень находится между уровнями Очень низкий и Средний.

  • Средний: данный уровень применяется в случаях, когда обычный риск появления вредоносной программы выше риска ложно положительного результата. Эвристические проверки, выполняемые по технологии McAfee Labs, выявляют обнаружения, которые, скорее всего, являются вредоносными программами. Однако существует некоторый риск, что обнаружение в необычном файле может привести к ложно положительному результату. McAfee Labs проверяет, не приводят ли обнаружения, выявленные при данном уровне чувствительности, к ложно положительным результатам на популярных приложениях и файлах операционной системы.

  • Высокий: этот уровень находится между уровнями Средний и Очень высокий.

  • Очень высокий: данный уровень рекомендуется использовать только для электронной почты и сканирования томов и каталогов, не поддерживающих ни исполнение программ, ни операционные системы. Обнаружения при данном уровне считаются вредоносными, но их полное тестирование на ложно положительный результат не проводится.

Связанные задачи
Сканирование электронной почты при доставке и по требованию


Вкладка «Общие»

Определения параметров

Настройте общие параметры проверки при доступе.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Сканировать Указание общих элементов для сканирования.
  • Загрузочные секторы: сканирование загрузочных секторов. По умолчанию = Включено.
  • Сканировать гибкий диск при выключении: сканирование гибких дисков при выключении компьютера.По умолчанию = Включено.
  • Процессы при включении: служба McAfee On-access McShield сканирует все запущенные процессы. По умолчанию = Отключено.
    ПРИМЕЧАНИЕ: Включение этой службы повышает безопасность, но негативно влияет на время загрузки системы.
Включить проверку при доступе Укажите, когда необходимо выполнять сканирование.
  • Включить проверку при доступе при запуске системы: включение сканера при доступе при каждом включении компьютера.
  • Включить проверку при доступе при применении политики: включение сканера при доступе при каждом применении политики.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Максимальное время сканирования Укажите максимальное время сканирования.
  • Включить максимальное время сканирования для всех файлов: определение максимального времени сканирования и применение его для всех файлов.
  • Максимальное время сканирования: указание максимального времени сканирования всех файлов в секундах. По умолчанию = 45 секунд.
ПРИМЕЧАНИЕ: По истечении указанного времени сканирование останавливается, и выполняется запись сообщения в файл журнала. Если остановить сканирование не удается, оно прерывается принудительно и запускается при следующей инициации сканирования.
Файлы cookie

Сканировать файлы cookie: включение сканирования файлов cookie.

Artemis (эвристическая проверка наличия подозрительных файлов в сети) | Укажите один из шести уровней чувствительности для Artemis в пределах от уровня «Отключено» до «Очень высокий». По умолчанию = очень низкий.
Связанные задачи
Настройка общих параметров
Связанная информация
Сканирование объектов при доступе


Вкладка «Глобальные настройки сканирования»

Определения параметров

Настройте параметры кэша сканирования таким образом, чтобы данные сканирования сохранялись во время перезагрузки системы. Незараженные данные будут использоваться сканером, запускаемым по требованию, что позволит повысить производительность. Дополнительные сведения см. в разделе Настройка глобальных параметров.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Кэш сканирования Задайте глобальные параметры и настройки.
  • Включить сохранение данных сканирования при перезагрузке: сохранение результатов сканирования незараженных файлов даже при перезагрузке системы. (По умолчанию = выбрано.)
    ПРИМЕЧАНИЕ: Отключите эту функцию при использовании системы, в которой жесткие диски можно изменить извне. Например, если жесткий диск можно извлечь, обновить его содержимое и впоследствии заменить (это исключение распространяется на виртуальные машины и конфигурации с двумя операционными системами).
  • Разрешить использование кэша при проверке по требованию: разрешение использования существующих результатов сканирования незараженных файлов при проверке по требованию во избежание их повторного сканирования. (По умолчанию = выбрано.)
Связанные задачи
Настройка глобального системного кэша


Вкладка «Процессы»

Определения параметров для этапа 1

Укажите процессы, определенные как процессы с высоким риском. Этот процесс включает два этапа.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки процессов

Откройте страницу Политики процессов по умолчанию, активируемых при доступе и выберите параметр

  • Настроить отдельные политики сканирования для процессов с высоким риском, малоопасных процессов и процессов по умолчанию
ПРИМЕЧАНИЕ:

Перед настройкой политик для малоопасных процессов и процессов с высоким риском необходимо сначала выбрать этот параметр.

Определения параметров для этапа 2

Параметр | Определение
Настройки | В раскрывающемся списке выберите Рабочая станция или Сервер. ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Процессы с высоким риском | Откройте страницу Политики процессов с высоким риском, активируемых при доступе, чтобы указать процессы, определенные как процессы с высоким риском. Процессы можно добавлять и удалять по мере необходимости.

Дополнительные сведения см. в разделах Определение числа политик сканирования и Определение риска, назначаемого процессу.

Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Процессы»

Определения параметров для этапа 1

Укажите процессы, определенные как малоопасные процессы. Этот процесс включает два этапа.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки процессов

Откройте страницу Политики процессов по умолчанию, активируемых при доступе и выберите параметр

  • Настроить отдельные политики сканирования для процессов с высоким риском, малоопасных процессов и процессов по умолчанию
ПРИМЕЧАНИЕ:

Перед настройкой политик для малоопасных процессов и процессов с высоким риском необходимо сначала выбрать этот параметр.

Определения параметров для этапа 2

Параметр | Определение
Настройки | В раскрывающемся списке выберите Рабочая станция или Сервер. ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Малоопасные процессы | Откройте страницу Политики малоопасных процессов, активируемых при доступе чтобы указать процессы, определенные как малоопасные. Процессы можно добавлять и удалять по мере необходимости.

Дополнительные сведения см. в разделах Определение числа политик сканирования и Определение риска, назначаемого процессу.

Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Сообщения»

Определения параметров

Настройте параметры сообщений для локальных пользователей и пользователей без прав администратора.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Сообщения пользователей Укажите сообщения, получаемые локальными пользователями.
  • Выводить диалоговое окно сообщений при обнаружении угрозы, отображая в сообщении указанный текст: в случае обнаружения угрозы для локальных пользователей выводится диалоговое окно Сообщения сканера при доступе.

  • Уведомление при обнаружении файла cookie: отправка уведомлений при обнаружении файлов cookie. Сюда относится создание предупреждений ePolicy Orchestrator, отправка сообщений в диалоговое окно «Сообщения сканера при доступе», запись обнаружений в файл журнала активности, если она включена на вкладке Отчеты, и подсчет обнаружений в статистике сканирования. Если отключить этот параметр, ePolicy Orchestrator не будет создавать предупреждения, но обнаружения будут по-прежнему записываться в журнал активности, если эта запись включена на вкладке Отчеты, и учитываться в статистике сканирования.

Текст сообщения

Примите сообщение по умолчанию или введите требуемое сообщение. По умолчанию = Предупреждение VirusScan Enterprise 8.8!

Действия, доступные для пользователей
  • Удалить сообщения из списка: разрешить пользователям без прав администратора удалять сообщения из списка.
  • Очистить файлы: разрешить пользователям без прав администратора очищать файлы, указанные в сообщениях из списка.
  • Удалить файлы: разрешить пользователям без прав администратора удалять файлы, указанные в сообщениях из списка.
Связанные ссылки
Обнаружения по результатам проверки при доступе


Задача отражения

Настройка задачи отражения

Консоль VirusScan Enterprise 8.8 — определения параметров

Параметр | Определение
Файл журнала | Включение журналирования активности.
Формат Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Получить новые файлы определения обнаружений (если доступны)

Этот параметр не применяется к задачам отражения.
Получить новый механизм обнаружения (если доступен)

Этот параметр не применяется к задачам отражения.
Получить другие доступные обновления (пакеты обновления, обновления версий и др.)

Этот параметр не применяется к задачам отражения.
Ввести имя исполняемого файла, который необходимо запустить после выполнения отражения

Укажите имя исполняемого файла, запускаемого после завершения задачи отражения. Укажите путь к исполняемому файлу, который требуется запустить, или щелкните «Обзор», чтобы найти его.

Например, можно запустить служебную программу сетевых сообщений, уведомляющую администратора об успешном выполнении задачи отражения.

ПРИМЕЧАНИЕ: Выбранный файл программы должен быть доступен для выполнения текущему пользователю, вошедшему в систему. Если у текущего пользователя нет доступа к папке, содержащей файлы программы, либо вошедшие в систему пользователи отсутствуют, программа не запустится.
Выполнять только после успешного отражения

Запуск исполняемой программы только после успешного отражения. Если отражение выполнено с ошибками, исполняемая программа не запустится.
Отразить местоположение

Укажите путь к папке назначения на локальной системе, используемой для сайта отражения.

ПРИМЕЧАНИЕ: Поддерживаются системные переменные.
Планирование

Планирование выполнения данной задачи обновления.

ПРИМЕЧАНИЕ:

Дополнительные сведения см. в разделе «Планирование задач».

Не рекомендуется планировать одновременное выполнение задач AutoUpdate и задач отражения. При выполнении обеих задач используется служба McAfee Common Framework, и их одновременный запуск может привести к конфликту.
Отразить

Немедленное выполнение задачи отражения.

Связанные понятия
Задачи отражения и принцип их работы
Связанные ссылки
Настройка задачи отражения


Вкладка «Настройки сканера Notes»

Определения параметров

Выполните настройки Lotus Notes для сканера электронной почты при доставке.

Настройка пароля Lotus Notes

При доступе к локальной базе данных в Windows 2000 Server, Windows 2003 Server или Windows XP появляется запрос на ввод пароля. При вводе пароля отображается диалоговое окно поиска текста, в которое и вставляется данный пароль (а не в диалоговое окно пароля). Диалоговое окно пароля не модальное. При повторном выборе этого диалогового окна в нем можно ввести пароль.

McAfee рекомендует предотвратить повторное отображение запросов на ввод пароля.
  1. В Lotus Notes щелкните Файл | Настройки | Безопасность | Безопасность пользователя | Диалоговое окно.
  2. Выберите Не запрашивать пароль для других программ на основе Notes (снижение безопасности).
    ОСТОРОЖНО:
    Такая конфигурация потенциально снижает уровень безопасности системы.
Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Настройки сканирования сервера
  • Сканировать все базы данных сервера: сканирование всех баз данных сервера на предмет наличия потенциальных угроз.
  • Сканировать почтовые ящики сервера: сканирование всех почтовых ящиков сервера на предмет наличия потенциальных угроз.
  • Корневая папка почтового ящика: указание местоположения корневой папки. Примите местоположение корневой папки почтового ящика по умолчанию или задайте новое местоположение. Этот параметр доступен только для сканирования электронной почты при доставке. По умолчанию = !!mail\.
Дополнительные параметры | Исключаемые приложения Notes: указание приложений Lotus Notes, исключаемых из сканирования. По умолчанию = MNOTES.
Связанные задачи
Сканирование электронной почты при доставке и по требованию


Вкладка «Действия»

Определения параметров

Настройте действия, которые требуется выполнять при обнаружении угрозы или потенциально нежелательной программы. Если для процессов по умолчанию, малоопасных процессов и процессов с высоким риском настраиваются разные политики сканирования, то на этой вкладке требуется настраивать параметры отдельно для каждого типа процесса.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
При обнаружении угрозы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить файлы автоматически.
  • Очистить файлы автоматически: сканер пытается удалить угрозу из обнаруженного файла.
  • Запретить доступ к файлам: запрет доступа к файлам с потенциальными угрозами, обнаруженными сканером, который распространяется на всех пользователей.
  • Удалить файлы автоматически: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Удалить файлы автоматически.
  • Запретить доступ к файлам: запрет доступа к файлам с потенциальными угрозами, обнаруженными сканером, который распространяется на всех пользователей.
  • Удалить файлы автоматически: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
При обнаружении нежелательной программы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить файлы автоматически.
  • Разрешить доступ к файлам: предоставление пользователям доступа к обнаруженным файлам и программам.
    ПРИМЕЧАНИЕ:

    Это действие позволяет просмотреть, какие объекты обнаружены, а уже затем определить, какие действия следует выполнить. Обнаруженные программы можно просмотреть в журнале активности. Для данного параметра дополнительные действия недоступны.

  • Очистить файлы автоматически: автоматическое удаление угроз из обнаруженных файлов и программ.
  • Запретить доступ к файлам: предотвращение доступа к обнаруженным файлам и программам.
  • Удалить файлы автоматически: автоматическое удаление обнаруженных файлов и программ.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Удалить файлы автоматически.
  • Разрешить доступ к файлам: предоставление пользователям доступа к обнаруженным файлам и программам.
  • Запретить доступ к файлам: предотвращение доступа к обнаруженным файлам и программам.
  • Удалить файлы автоматически: автоматическое удаление обнаруженных файлов и программ.
Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Исключения»

Определения параметров

Укажите объекты, которые требуется исключить из сканирования. Если для процессов по умолчанию, малоопасных процессов и процессов с высоким риском настраиваются разные политики сканирования, то на этой вкладке требуется настраивать параметры отдельно для каждого типа процесса.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Объекты для исключения Выберите тип исключения, затем укажите дополнительные сведения об исключении.
  • Исключить по имени файла/местоположению: введите имя и местоположение файла в текстовом поле. При необходимости выберите параметр Исключать подпапки.
    ПРИМЕЧАНИЕ: Можно добавить косую черту (\) в конце строки, чтобы применить к папке. В противном случае она будет рассматриваться как исключение файла, и флажок Исключать подпапки будет отключен по умолчанию.
  • Исключить по типу файла: введите тип файла в текстовом поле.
  • Исключить по сроку хранения: выберите тип доступа, затем укажите минимальный срок хранения в днях.

Для получения дополнительной информации см. раздел Добавление и исключение элементов сканирования.

Когда исключать Укажите, когда следует исключать выбранный элемент:
  • При чтении
  • При записи
Обработка исключений клиента Перезаписать исключения клиента: исключение только тех элементов, которые указаны в данной политике. Если параметр не выбран, на клиентском компьютере будут использоваться исключения, указанные локально и заданные в данной политике.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Отчеты»

Определения параметров

Включите журналирование для отслеживания событий в сети и регистрации настроек, которые использовались сканером для обнаружения потенциальной угрозы и реагирования на нее.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Записывать в файл | Включение журналирования активности.
Местоположение файла журнала Примите местоположение файла журнала по умолчанию или укажите новое местоположение.

Имя журнала по умолчанию: OnAccessScanLog.txt.

Местоположение по умолчанию: <Диск>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\.

В различных операционных системах местоположение по умолчанию может быть разным.
Размер файла журнала | Ограничение размера файла журнала. Примите размер по умолчанию (1 МБ) или укажите размер в пределах от 1 до 999 МБ. Если объем данных в файле журнала превысит заданный размер, 20 процентов наиболее старых записей будет удалено, и в файл будут добавлены новые данные.
Формат файла журнала Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Что заносить в журнал (кроме событий сканирования)
  • Настройки сеанса: в файл журнала записываются свойства каждого сеанса сканирования.
  • Сводка сеанса: в файл журнала записывается сводка действий сканера в ходе каждого сеанса сканирования. Информация в сводке включает количество просканированных файлов, количество обнаружений, их типы, количество очищенных и удаленных файлов, а также другие сведения.
  • Сбой при сканировании зашифрованных файлов: в журнал записываются имена зашифрованных файлов, при сканировании которых возникли сбои.
Связанные задачи
Настройка задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Элементы сканирования»

Определения параметров

Настройте параметры обнаружения. Если для процессов по умолчанию, малоопасных процессов и процессов с высоким риском настраиваются разные политики сканирования, то на этой вкладке требуется настраивать параметры отдельно для каждого типа процесса.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Сканировать файлы
  • При записи на диск: сканирование всех файлов во время их записи или модификации в системе компьютера или другого устройства хранения данных.
    ОСТОРОЖНО:
    Если не включить параметр При записи на диск, система может остаться без защиты от многочисленных вредоносных атак.

    Если выполняется копирование или перемещение файлов с одного компьютера на другой, все компьютеры должны быть настроены одинаково, чтобы невозможно было скопировать или записать файл с потенциальной угрозой.

  • При чтении с диска: сканирование всех файлов во время их чтения с компьютера или другого устройства хранения данных.
    ОСТОРОЖНО:
    Если не включить параметр При чтении с диска, система может остаться без защиты от многочисленных вредоносных атак.
  • Сетевые диски: сканирование ресурсов на сопоставленных сетевых дисках.

    Сканирование сетевых ресурсов может повлиять на производительность.

  • Открыты для резервного копирования: просмотр файлов, открытых для операций резервного копирования.
Типы файлов, подлежащих сканированию
  • Все файлы: сканируются все файлы независимо от расширения.
    ОСТОРОЖНО:
    Если не включить параметр Все файлы, система может остаться без защиты от многочисленных вредоносных атак.
  • По умолчанию + дополнительные типы файлов: сканирование файлов с расширениями, заданными по умолчанию, а также всех дополнительно указанных файлов. Список по умолчанию определяется текущим файлом DAT.

    Также сканировать все файлы на наличие макросов: в случае выбора данного параметра можно также настроить поиск опасных макросов во всех файлах.

  • Только указанные типы файлов: создание списка расширений для сканирования, заданных пользователем. Добавленные ранее расширения можно впоследствии удалять.

    Выберите этот параметр, а затем введите расширения файлов в текстовое поле через пробел.

Artemis (эвристическая проверка наличия подозрительных файлов в сети)
  • Найти неизвестные опасные программы и «троянские кони»: обнаружение исполняемых файлов, содержащих код, напоминающий вредоносную программу, с помощью сканирования вирусов Artemis.
  • Найти неизвестные опасные макросы: обнаружение макровирусов с помощью сканирования вирусов Artemis.
ОСТОРОЖНО:
Если не включить параметр Artemis, система может остаться без защиты от многочисленных вредоносных атак.
Сжатые файлы
  • Сканировать внутри архивов: проверка архивных (сжатых) файлов и их содержимого.
  • Декодировать файлы в кодировке MIME: обнаружение, декодирование и сканирование файлов в кодировке MIME (Multipurpose Internet Mail Extensions).
ПРИМЕЧАНИЕ: Способствуя усилению защиты, проверка сжатых файлов в то же время может увеличить продолжительность сканирования.
Обнаружение нежелательных программ
  • Обнаружение нежелательных программ: включение сканера при доступе для обнаружения потенциально нежелательных программ.

    Сканер использует сведения, настроенные в политике нежелательных программ для обнаружения потенциально нежелательных программ.

    Дополнительные сведения см. в разделе Запрещение потенциально нежелательных программ.

Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Действия»

Определения параметров

Настройте действия, которые требуется выполнять при обнаружении угрозы или потенциально нежелательной программы.

Параметр Определение
При обнаружении угрозы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить файлы.
  • Очистить файлы: сканер пытается удалить угрозу из обнаруженного файла.
  • Продолжить сканирование: при обнаружении опасного файла сканирование продолжается.
  • Удалить файлы автоматически: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Удалить файлы.
  • Продолжить сканирование: при обнаружении опасного файла сканирование продолжается.
  • Удалить файлы: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
При обнаружении нежелательной программы Выполнить это действие первым: выбор действия, которое при обнаружении угрозы следует выполнить в первую очередь. По умолчанию = Очистить файлы.
  • Очистить файлы: сканер пытается удалить угрозу из обнаруженного файла.
  • Продолжить сканирование: при обнаружении опасного файла сканирование продолжается.
  • Удалить файлы: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
Если первое действие выполнить не удастся, выполнить это действие: выбор действия, которое должен будет выполнить сканер при неудачной попытке выполнения первого действия. По умолчанию = Удалить файлы.
  • Продолжить сканирование: при обнаружении опасного файла сканирование продолжается.
  • Удалить файлы: при обнаружении файлов, содержащих потенциальные угрозы, сканер удаляет их.
Связанные ссылки
Вкладки с настройками процессов
Связанная информация
Сканирование объектов при доступе


Вкладка «Исключения»

Определения параметров

Укажите объекты, которые требуется исключить из сканирования.

Параметр Определение
Объекты для исключения В раскрывающемся списке выберите тип исключения, затем укажите дополнительные сведения об исключении.
  • Исключить по имени файла/местоположению: введите имя и местоположение файла в текстовом поле. При необходимости выберите параметр Исключать подпапки.
    ПРИМЕЧАНИЕ: Можно добавить косую черту (\) в конце строки, чтобы применить к папке. В противном случае она будет рассматриваться как исключение файла, и флажок Исключать подпапки будет отключен по умолчанию.
  • Исключить по типу файла: введите тип файла в текстовом поле.
  • Исключить по сроку хранения: выберите тип доступа, затем укажите минимальный срок хранения в днях.

Для получения дополнительной информации см. раздел Добавление и исключение элементов сканирования.

Когда исключать Укажите, когда следует исключать выбранный элемент:
  • При чтении
  • При записи
Обработка исключений клиента Перезаписать исключения клиента: исключение только тех элементов, которые указаны в данной политике. Если параметр не выбран, на клиентском компьютере будут использоваться исключения, указанные локально и заданные в данной политике.
ПРИМЕЧАНИЕ:

Данный параметр можно настроить только в ePolicy Orchestrator.

Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Производительность»

Определения параметров

Укажите параметры отложенного сканирования и использования системы для улучшения производительности.

Параметр Определение
Параметры отложенного сканирования Выберите параметр отложенного сканирования.
  • Отложить сканирование при работе от батареи: если система работает от батареи, сканирование откладывается.
  • Отложить сканирование во время презентаций: если система работает в режиме презентаций, сканирование откладывается.
  • Разрешить пользователю отложить сканирование, выполняемое по расписанию: пользователь может откладывать запланированное сканирование.

  • Максимальная задержка: указание длительности периода задержки. Укажите период от одного до 24 часов или выберите нулевое значение, чтобы отложить сканирование навсегда.

Для получения дополнительных сведений см. раздел Принцип работы отложенного сканирования.

Использование ресурсов системы Чтобы задать расписание сканирования, используйте список (с ePolicy Orchestrator) или ползунок (с Консоль VirusScan). Каждая задача выполняется независимо, и на нее не влияют ограничения для других задач. Доступны следующие приращения:
  • Низкий
  • Ниже нормы: параметр ePolicy Orchestrator по умолчанию.
  • Норма: параметр VirusScan Enterprise 8.8 по умолчанию.
Artemis (эвристическая проверка наличия подозрительных файлов в сети)
Настройте уровень чувствительности, который требуется использовать при определении, является ли обнаруженный образец вредоносной программой. На всех уровнях чувствительности, кроме Отключено, контрольные суммы образцов, или хэши, отправляются в лабораторию McAfee Labs, чтобы определить, являются ли они вредоносной программой. Преимущество заключается в том, что обнаружение может стать доступным после публикации обновления в McAfee Labs, поэтому ждать нового выпуска файла DAT не придется. Чем выше выбранный уровень чувствительности, тем выше число обнаружений вредоносных программ. Однако большее число обнаружений может привести к большему числу ложно положительных результатов. Выберите один из следующих уровней чувствительности.

  • Отключено: контрольные суммы и данные не отправляются в McAfee Labs, чтобы определить, являются ли они вредоносной программой.

  • Очень низкий: число обнаружений и риск ложно положительных результатов те же, что при использовании обычных файлов DAT. Обнаружение становится доступным для VirusScan Enterprise после его публикации в McAfee Labs, поэтому ждать следующего обновления файла DAT не требуется.

  • Низкий: этот уровень находится между уровнями Очень низкий и Средний.

  • Средний: данный уровень применяется в случаях, когда обычный риск появления вредоносной программы выше риска ложно положительного результата. Эвристические проверки, выполняемые по технологии McAfee Labs, выявляют обнаружения, которые, скорее всего, являются вредоносными программами. Однако существует некоторый риск, что обнаружение в необычном файле может привести к ложно положительному результату. McAfee Labs проверяет, не приводят ли обнаружения, выявленные при данном уровне чувствительности, к ложно положительным результатам на популярных приложениях и файлах операционной системы.

  • Высокий: этот уровень находится между уровнями Средний и Очень высокий.

  • Очень высокий: данный уровень рекомендуется использовать только для электронной почты и сканирования томов и каталогов, не поддерживающих ни исполнение программ, ни операционные системы. Обнаружения при данном уровне считаются вредоносными, но их полное тестирование на ложно положительный результат не проводится.

Связанные понятия
Принципы использования ресурсов системы
Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Отчеты»

Определения параметров

Включите журналирование для отслеживания событий в сети и регистрации настроек, которые использовались сканером для обнаружения потенциальной угрозы и реагирования на нее.

Параметр | Определение
Записывать в файл | Включение журналирования активности.
Местоположение файла журнала Примите местоположение файла журнала по умолчанию или укажите новое местоположение.

Имя журнала по умолчанию: OnDemandScanLog.txt.

Местоположение по умолчанию: <Диск>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\ .

В различных операционных системах местоположение по умолчанию может быть разным.
Размер файла журнала | Ограничение размера файла журнала. Примите размер по умолчанию (1 МБ) или укажите размер в пределах от 1 до 999 МБ. Если объем данных в файле журнала превысит заданный размер, 20 процентов наиболее старых записей будет удалено, и в файл будут добавлены новые данные.
Формат файла журнала Выбор формата файла журнала. По умолчанию = Unicode (UTF8).
  • Unicode (UTF8): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • Unicode (UTF16): рекомендуется при сохранении текста на восточных языках (размер одного символа равен одному-двум байтам) или при работе в многонациональной организации.
  • ANSI: рекомендуется при сохранении текста на европейских языках (размер одного символа равен одному байту).
Что заносить в журнал (кроме событий сканирования)
  • Настройки сеанса: в файл журнала записываются свойства каждого сеанса сканирования.
  • Сводка сеанса: в файл журнала записывается сводка действий сканера в ходе каждого сеанса сканирования. Информация в сводке включает количество просканированных файлов, количество обнаружений, их типы, количество очищенных и удаленных файлов, а также другие сведения.
  • Сбой при сканировании зашифрованных файлов: в журнал записываются имена зашифрованных файлов, при сканировании которых возникли сбои.
Уведомление при обнаружении файла cookie

Уведомление при обнаружении файла cookie: отправка уведомлений при обнаружении файлов cookie. Сюда относится создание предупреждений ePolicy Orchestrator, уведомления об обнаружениях, запись обнаружений в файл журнала активности, если она включена на вкладке Отчеты, и подсчет обнаружений в статистике сканирования. Если отключить этот параметр, ePolicy Orchestrator не будет создавать предупреждения, но обнаружения будут по-прежнему записываться в журнал активности, если журналирование активности будет включено на вкладке Отчеты и учитываться в статистике сканирования.
Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Элементы сканирования»

Определения параметров

Настройте параметры обнаружения.

Параметр Определение
Типы файлов, подлежащих сканированию
  • Все файлы: сканируются все файлы независимо от расширения.
  • По умолчанию + дополнительные типы файлов: сканирование файлов с расширениями, заданными по умолчанию, а также всех дополнительно указанных файлов. Список по умолчанию определяется текущим файлом DAT.

    Выберите этот параметр, а затем введите расширения файлов в текстовое поле через пробел.

    Также сканировать все файлы на наличие макросов: если был выбран параметр По умолчанию + дополнительные типы файлов, можно также настроить поиск во всех файлах опасных макросов.

  • Указанные типы файлов: создание пользовательского списка расширений сканируемых файлов. Добавленные ранее расширения можно впоследствии удалять.

    Выберите этот параметр, а затем введите расширения файлов в текстовое поле через пробел.

Параметры
  • Обнаружение нежелательных программ: включение сканера при доступе для обнаружения потенциально нежелательных программ.

    Сканер использует сведения, настроенные в политике нежелательных программ для обнаружения потенциально нежелательных программ.

    Дополнительные сведения см. в разделе Запрещение потенциально нежелательных программ.

  • Декодировать файлы в кодировке MIME: обнаружение, декодирование и сканирование файлов в кодировке MIME (Multipurpose Internet Mail Extensions).
  • Сканировать внутри архивов: проверка архивных (сжатых) файлов и их содержимого.
Способствуя усилению защиты, проверка сжатых файлов в то же время может увеличить продолжительность сканирования.

  • Сканирование файлов, перемещенных в хранилище: сканирование кэшированных файлов, хранящихся в удаленном хранилище.

    Для получения дополнительных сведений см. раздел Принцип сканирования удаленного хранилища.

Artemis (эвристическая проверка наличия подозрительных файлов в сети)
  • Найти неизвестные опасные программы: обнаружение исполняемых файлов, содержащих код, напоминающий вредоносную программу, с помощью сканирования вирусов Artemis.
  • Найти неизвестные опасные макросы: обнаружение макровирусов с помощью сканирования вирусов Artemis.
Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Задача»

Определения параметров

Укажите платформы, на которых выполняется данная задача по требованию.

Параметр Определение
Платформы, на которых будет выполняться эта задача
  • Выполнять задачу на серверах: выполнение задачи проверки по требованию на серверах.
  • Выполнять задачу на рабочих станциях: выполнение задачи проверки по требованию на рабочих станциях.
Учетная запись пользователя для запуска задачи
  • Имя пользователя: укажите имя учетной записи пользователя. Если информация об учетной записи не введена, задача запускается с учетной записью системы.
  • Пароль: введите пароль.
  • Домен: введите домен.
ПРИМЕЧАНИЕ:

Для планирования этой задачи требуются права администратора. Права администратора предоставляют пользователю доступ на запись к разделу реестра для запланированных задач. Сведения о планировании клиентских задач см. в документации по продукту ePolicy Orchestrator.

Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов по требованию


Вкладка «Параметры пароля»

Определения параметров

Установите защиту паролем для всей системы или выбранных элементов. Для получения дополнительных сведений см. раздел Последствия настройки пароля для пользователей.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Пароль интерфейса пользователя Настройте защиту интерфейса пользователя.
  • Без пароля: для доступа к настройкам конфигурации пароль не требуется.
  • Защита паролем для всех перечисленных элементов: задание одного пароля для всех элементов списка.
  • Защита паролем для выбранных элементов: задание одного пароля для выбранных элементов списка.
  • Защита паролем для соответствия сертификации Common Criteria: защита интерфейса в соответствии с требованиями правительственных учреждений, связанных с использованием только продуктов обеспечения безопасности, отвечающих критериям сертификации National Information Assurance Partnership (NIAP) Common Criteria.

    Это позволяет защитить от пользователей, не имеющих прав администратора, все параметры конфигурации, за исключением возможности пользователей рабочей станции выполнять немедленную проверку своей рабочей станции по требованию. Можно включить или исключить файлы из немедленной проверки по требованию. Можно включить или исключить архивы, например файлы .ZIP, из немедленной проверки по требованию. Можно просмотреть журналы активности проверки по требованию и проверки при доступе.

Пароль: введите пароль.

Подтвердить пароль: повторный ввод пароля для его подтверждения.
Элементы интерфейса пользователя для защиты паролем Выберите элементы, для которых необходимо установить защиту паролем.
  • Выбрать все: выбор всех элементов в разделе.
  • Отменить выбор: отмена выбора всех элементов в разделе.

Администраторы могут блокировать и разблокировать интерфейс с помощью консоли.

Связанные ссылки
Настройка расписания выполнения задач
Связанная информация
Контроль доступа к интерфейсу пользователя


Вкладка «Политика»

Определения параметров

Настройте карантиновую папку, а также продолжительность хранения элементов в ней.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Каталог карантина | Примите местоположение каталога карантина по умолчанию или задайте новое местоположение. По умолчанию = <СИСТЕМНЫЙ_ДИСК>\Quarantine.
Срок хранения данных в карантине
  • Автоматически удалять данные, помещенные в карантин: удаление данных, помещенных в карантин, по истечении указанного числа дней.
  • Число дней, в течение которого резервные данные будут храниться в каталоге карантина: указание числа дней, по истечении которого помещенные в карантин элементы будут автоматически удаляться. Доступные значения: от 1 до 999 дней.
Связанные задачи
Настройка политики карантина


Вкладка «Настройки прокси-сервера»

Прокси-серверы являются одним из средств обеспечения безопасности в Интернете, которое позволяет скрыть подключенные к Интернету компьютеры пользователей и улучшить скорость доступа благодаря кэшированию часто посещаемых сайтов.

Если в сети используется прокси-сервер, можно указать используемые настройки прокси-подключения: адрес прокси-сервера и необходимость применения проверки подлинности. Сведения о прокси-сервере хранятся в списке хранилищ AutoUpdate (sitelist.xml). Заданные здесь настройки прокси-сервера применяются ко всем хранилищам из данного списка хранилищ.

ПРИМЕЧАНИЕ:

В консоли ePolicy Orchestrator данная функция недоступна. Эта функция недоступна в консоли VirusScan Enterprise 8.8.

Определения параметров

Параметр Определение
Не использовать прокси-подключение

Прокси-сервер не указывается.

Использовать настройки прокси-сервера Internet Explorer

Использование настроек прокси-сервера для текущей установленной версии Internet Explorer.

По умолчанию = Использовать настройки прокси-сервера Internet Explorer.

Задать настройки прокси-сервера вручную

Задание настроек прокси в соответствии с конкретными требованиями.

Исключения

Параметр доступен только при выборе параметра «Задать настройки прокси-сервера вручную».

Укажите исключения прокси-сервера. Щелкните «Исключения», чтобы открыть диалоговое окно «Исключения прокси-сервера».
  • Указать исключения: выберите этот параметр, чтобы ввести исключения прокси-сервера.
  • Использовать для разделения элементов точку с запятой (;): например, internal1;internal2
HTTP

Введите адрес прокси-сервера HTTP.

FTP

Введите адрес прокси-сервера FTP.

Порт

Введите номер порта прокси-сервера HTTP или FTP.

Использовать проверку подлинности для HTTP

Использование для доступа к прокси-серверу HTTP указанных учетных данных.

Имя пользователя HTTP

Введите имя пользователя HTTP.

Пароль HTTP

Введите пароль HTTP.

Связанные понятия
Принцип работы хранилища AutoUpdate
Связанные ссылки
Настройка списка хранилищ


Вкладка «Элементы сканирования»

Определения параметров

Выберите категории потенциально нежелательных программ, подлежащих обнаружению, и создайте исключения для программ, которые не требуется обнаруживать.

Параметр | Определение
Настройки | В раскрывающемся списке выберите Рабочая станция или Сервер. ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Выбрать категории нежелательных программ для обнаружения | Указание категорий потенциально нежелательных программ, которые требуется обнаруживать.
Исключения нежелательных программ | Указание исключений по имени обнаружения. При необходимости элементы можно добавлять и удалять.
Связанные задачи
Настройка нежелательных программ
Связанная информация
../../pgrestrictingunwantedprogram_chapter.ditamap


Вкладка «Политика карантина»

Определения параметров

Настройте карантиновую папку, а также продолжительность хранения элементов в ней.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Каталог карантина | Примите местоположение каталога карантина по умолчанию или задайте новое местоположение. По умолчанию = <СИСТЕМНЫЙ_ДИСК>\Quarantine.
Срок хранения данных в карантине
  • Автоматически удалять данные, помещенные в карантин: удаление данных, помещенных в карантин, по истечении указанного числа дней.
  • Число дней, в течение которого резервные данные будут храниться в каталоге карантина: указание числа дней, по истечении которого помещенные в карантин элементы будут автоматически удаляться. Доступные значения: от 1 до 999 дней.
Связанные задачи
Настройка политики карантина


Добавление и изменение хранилищ

Добавьте новые или измените существующие хранилища.

Определения параметров

Параметр Определение
Описание хранилища

Указывается имя хранилища.
Для получения файлов использовать
Выбор местоположения, из которого необходимо получить файлы. По умолчанию = хранилище HTTP.
  • Хранилище HTTP: получение файлов из хранилища HTTP, назначенного пользователем.
    ПРИМЕЧАНИЕ: Сайт HTTP, как и FTP, обеспечивает обновление независимо от сетевой безопасности, но поддерживает больше одновременных соединений, чем FTP.
  • Хранилище FTP: получение файлов из хранилища FTP, назначенного пользователем.
    ПРИМЕЧАНИЕ: Сайт FTP обеспечивает гибкость обновления, не требуя соответствия разрешениям сетевой безопасности. FTP меньше подвержен присоединению нежелательного кода, чем HTTP, поэтому может допускать большую гибкость.
  • Путь UNC: получение файлов из назначенного расположения пути UNC.
    ПРИМЕЧАНИЕ: Сайт UNC настраивается быстрее и проще остальных сайтов. Для междоменных обновлений пути UNC требуются разрешения для каждого домена и, соответственно, большее участие конфигурации обновления.
  • Локальный путь: получение файлов из назначенного расположения локального пути.
URL-адрес
Доступен только при выборе параметра Хранилище HTTP или Хранилище FTP.
  • HTTP: введите местоположение для HTTP-сервера и папки с файлами обновлений.
  • FTP: введите местоположение для FTP-сервера и папки с файлами обновлений.
Путь
Доступен только при выборе параметра Путь UNC или Локальный путь.
  • Путь UNC: используя UNC-нотацию (\\имя_сервера\путь\), введите путь хранилища с файлами обновлений.
  • Локальный путь: введите путь локальной папки с файлами обновлений или щелкните кнопку Обзор, чтобы перейти к этой папке. Это может быть путь к папке на локальном или сетевом диске.
Порт

Доступен только при выборе параметра Хранилище HTTP или Хранилище FTP. Введите номер порта для указанного сервера HTTP или FTP.

Использовать проверку подлинности

Использовать анонимное подключение

Использовать текущую учетную запись
Использование указанных учетных данных для доступа к хранилищу.
ПРИМЕЧАНИЕ:

Название этого параметра зависит от того, какой параметр выбран в разделе Для получения файлов использовать.

С помощью указанных учетных данных AutoUpdate получает доступ к хранилищу и возможность загрузить нужные файлы обновлений. При настройке данных учетной записи в хранилище убедитесь, что у нее есть разрешения на чтение папок с файлами обновлений.
  • Учетные данные загрузки являются обязательными для хранилищ FTP и UNC и необязательными для хранилищ HTTP.
  • Обновления FTP поддерживают анонимные соединения с хранилищами.
  • С обновлениями UNC можно также использовать учетную запись пользователя, вошедшего в систему, получая доступ к хранилищу с помощью его разрешений.
Имя пользователя

Введите имя пользователя.
Пароль

Введите пароль.
Подтвердить

Повторный ввод пароля для его подтверждения.
Связанные понятия
Принцип работы хранилища AutoUpdate
Связанные ссылки
Настройка списка хранилищ


Вкладка «Хранилища»

Настройте хранилища, используемые для получения обновлений.
ПРИМЕЧАНИЕ:

В консоли ePolicy Orchestrator данная функция недоступна. Эта функция недоступна в консоли VirusScan Enterprise 8.8.

Определения параметров

Параметр Определение
Описание хранилища

Указывается имя хранилища.

В списке предварительно заданы хранилища HTTP и FTP.
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

Хранилище HTTP по умолчанию является сайтом загрузки.
Состояние

Включено: определенное хранилище, которое можно использовать в процессе AutoUpdate.

Отключено: определенное хранилище, к которому не требуется обращаться в процессе AutoUpdate. Это может быть хранилище, используемое время от времени, а не постоянно.

ПРИМЕЧАНИЕ: Создайте необходимое число сайтов хранилищ, которые можно включать и отключать.
Добавить

Добавление нового хранилища в список.
Изменить

Изменение выбранного хранилища.
Удалить

Удаление выбранного хранилища.
Вверх

Перемещение выбранного хранилища в списке вверх.
Вниз

Перемещение выбранного хранилища в списке вниз.
Связанные понятия
Принцип работы хранилища AutoUpdate
Связанные ссылки
Настройка списка хранилищ


Вкладка «Диспетчер»

Выберите элемент в списке, затем щелкните его правой кнопкой мыши, чтобы открыть окно дополнительных параметров. Доступны следующие действия: повтор сканирования, проверка на ложно положительный результат, восстановление, удаление или просмотр свойств.

Связанные задачи
Настройка политики карантина


Вкладка «Задача»

Определения параметров

Укажите данные учетной записи пользователя, имеющего доступ к папке восстановления. Если информация не введена, задача восстановления будет выполняться под системной учетной записью.

Параметр | Определение
Пользователь | Ввод имени пользователя, имеющего доступ к папке восстановления.
Пароль | Ввод пароля указанного пользователя.
Домен | Ввод домена указанного пользователя.
Связанные задачи
Настройка политики карантина


Вкладка «Области сканирования»

Определения параметров

Укажите типы элементов и области сканирования.

Параметр Определение
Области сканирования Выбор областей сканирования. По умолчанию = память на наличие руткитов, запущенные процессы, все локальные диски, реестр и файлы cookie. Щелкните Добавить, Изменить и Удалить, чтобы изменить Название элемента.
  • Память на наличие руткитов. Сканирование системной памяти на предмет установленных руткитов, скрытых процессов и других явлений, которые могут указывать на попытку скрытия своей деятельности вредоносным кодом. Это сканирование выполняется перед всеми остальными типами сканирования.
    ОСТОРОЖНО:
    Если не включить сканирование памяти на наличие руткитов, система останется без защиты от многочисленных вредоносных атак.
  • Запущенные процессы. Сканирование памяти всех выполняемых процессов. Все действия, кроме Очистить, обрабатываются как Продолжить сканирование.
    ОСТОРОЖНО:
    Если не включить сканирование запущенных процессов, система останется без защиты от многочисленных вредоносных атак.
  • Зарегистрированные файлы. Сканирование всех зарегистрированных файлов. Сканер сначала ищет в реестре имена файлов, затем сканирует их. Ссылки на потенциально нежелательные файлы из реестра удаляются.
  • Мой компьютер. Сканирование всех дисков, физически подключенных к компьютеру или логически сопоставленных с буквой диска на компьютере.
  • Все локальные диски. Сканирование всех локальных дисков и их подпапок на компьютере.
  • Все встроенные диски. Сканирование всех дисков, физически подключенных к компьютеру.
  • Все съемные диски. Сканирование всех съемных дисков и других подключенных к компьютеру устройств хранения данных.
  • Все сопоставленные диски. Сканирование всех сетевых дисков, сопоставленных с сетевыми дисками на компьютере.
  • Домашняя папка. Сканирование домашней папки пользователя, запустившего сканирование.
  • Папка профиля пользователя. Сканирование профиля пользователя, запустившего сканирование, в том числе папки Мои документы.
  • Папка Windows. Сканирование содержимого папки Windows.
  • Папка Program Files. Сканирование содержимого папки Program Files.
  • Папка Temp. Сканирование содержимого папки Temp.
  • Корзина. Сканирование содержимого корзины.
  • Диск или папка. Сканирование указанного диска или папки.
  • Файл. Сканирование указанного файла.
  • Файлы cookie. Сканирование файлов cookie в соответствующей папке.
  • Реестр. Сканирование записей реестра.
ПРИМЕЧАНИЕ: При использовании списка элементов сканирования по умолчанию сканирование может быть слишком детальным и занять много времени. Поэтому пользователь может ограничить диапазон регулярного сканирования.
В диалоговом окне Ход выполнения проверки по требованию области сканирования отображаются в виде разделенных запятыми элементов строки, следующих за словами Сканирование в. По завершении процесса сканирования они удаляются из строки.
Параметры сканирования Тип сканирования для выбранного элемента.
  • Включить подпапки: проверка всех подпапок в указанных томах. Для сканирования только корневого уровня томов отключите этот параметр.
  • Сканировать загрузочные секторы: проверка загрузочного сектора диска.
Если на диске уникальный или нетипичный загрузочный сектор, который не подлежит сканированию, рекомендуется отключить соответствующий параметр.
Связанные ссылки
Настройка вкладок задач проверки по требованию
Связанная информация
Сканирование объектов при доступе


Дополнительные параметры планирования

Настройте параметры планирования.

Определения параметров

Параметр | Определение
Дата начала | Указание даты начала задачи.
Дата окончания | Указание даты окончания задачи.
Повторять задачу | Повторение задачи с указанной частотой. При выборе этого параметра задается также частота повторения задачи.
Каждые | Указание частоты повторения задачи. Указывается также формат задания частоты: в часах или минутах.
Время (местное) | Повторение задачи в указанное местное время. При выборе этого параметра также указывается определенное время.
Продолжительность | Повторение задачи в течение указанного числа часов и минут. При выборе этого параметра указываются также часы и минуты.
Часы | Количество часов. Доступные значения — от 0 до 99.
Минуты | Количество минут. Доступные значения — от 0 до 59.
Связанные понятия
Задачи обновления и принципы их работы
Связанные ссылки
Настройка задачи AutoUpdate


Вкладка «Планирование»

Укажите частоту планирования и другие настройки для данной задачи.

Определения параметров

Параметр Определение
Время выполнения

Запустите задачу. Выберите один из перечисленных ниже параметров частоты для задачи.

По дням: выполнение задачи в указанные дни.

Задачи по дням могут выполняться регулярно через определенное число дней или ежедневно с понедельника по воскресенье. Если задачу необходимо выполнять только в указанные дни недели (то есть, не ежедневно с понедельника по воскресенье), рекомендуется использовать параметр частоты «По неделям».

По неделям: выполнение задачи в указанные недели и дни.

По месяцам: выполнение задачи в указанные дни и месяцы.

Однократно: выполнение задачи однократно в указанную дату.

При запуске: выполнение задачи при запуске системы; указание необходимости выполнения задачи раз в день и ввод времени задержки задачи в минутах.

При входе в систему: выполнение задачи при входе в систему; указание необходимости выполнения задачи раз в день и ввод времени задержки задачи в минутах.

Во время бездействия: выполнение задачи во время бездействия компьютера; указание количества минут простоя компьютера перед запуском задачи.

Если после запуска задачи пользователь возобновит работу на компьютере до момента окончания задачи, она будет выполняться до завершения.

Немедленно: немедленный запуск задачи.

При дозвоне: запуск задачи при дозвоне.

Время начала

Выбор времени начала для запланированной задачи.

Время UTC

UTC (Coordinated Universal Time — универсальное глобальное время). Этот параметр используется для запуска задачи одновременно во всех часовых поясах.

Местное время

Независимый запуск задачи в каждом часовом поясе.

ПРИМЕЧАНИЕ: По умолчанию = Местное время
Включить случайный выбор

Запуск задачи в произвольный момент времени в течение указанного временного интервала.

При выборе этого параметра также указывается продолжительность максимального промежутка времени в часах и минутах.

ПРИМЕЧАНИЕ:

Временной интервал указывается в диапазоне от 1 минуты (минимум) до 23 часов (максимум). Например, если настроить выполнение задачи в 1:00 и задать интервал случайного выбора, равный трем часам, то задача будет запускаться в любое время между 1:00 и 4:00.

Этот параметр недоступен при выборе параметров планирования задачи «При запуске», «При входе в систему» или «Во время бездействия».

Часы

Количество часов. Доступные значения — от 0 до 23 часов.

Минуты

Количество минут.

ПРИМЕЧАНИЕ:
Доступное значение количества минут зависит от выбранных параметров. Пример.
  • Включить случайный выбор: выбор от 0 до 59 минут.
  • Отложить пропущенную задачу на: выбор от 0 до 99 минут.
Выполнить, если пропущена

Выполнение пропущенных задач при следующем запуске компьютера. Если компьютер был в автономном режиме в то время, на которое было запланировано выполнение задачи, она могла быть пропущена.

ПРИМЕЧАНИЕ: Выбор этого параметра гарантирует, что удаленные пользователи и сеть будут полностью защищены, если в момент запланированного выполнения задачи они окажутся вне сети.
Отложить пропущенную задачу на

Выберите число минут, на которое требуется отложить пропущенную задачу. Доступные значения — от 0 до 99 минут.

Каждые N дней

Запуск задачи через указанный интервал в днях. Доступные значения — от 0 до 9999 дней.

ПРИМЕЧАНИЕ: Этот параметр доступен только при выборе планирования задачи «По дням».
Каждые N недель

Выполнение задачи через указанный интервал в неделях. Доступные значения — от 0 до 99 дней.

При выборе данного параметра также указывается число недель и дни недели.

ПРИМЕЧАНИЕ:

В качестве дня недели можно выбрать понедельник, вторник, среду, четверг, пятницу, субботу или воскресенье.

Этот параметр доступен только при выборе планирования задачи «По неделям».

День месяца

Запуск задачи в указанный день месяца. Доступные значения — от 1 до 31 дня.

При выборе данного параметра также указывается число дней в месяце.

ПРИМЕЧАНИЕ: Этот параметр доступен только при выборе планирования задачи «По месяцам».
День недели месяца

Запуск задачи в указанный день месяца.

При выборе данного параметра также указывается вхождение и день месяца.

ПРИМЕЧАНИЕ:

Можно указать одно из следующих вхождений: первый, второй, третий, четвертый или последний.

В качестве дня недели можно выбрать понедельник, вторник, среду, четверг, пятницу, субботу или воскресенье.

Этот параметр доступен только при выборе планирования задачи «По месяцам».

Выбрать месяцы

Указание месяцев выполнения данной задачи.

ПРИМЕЧАНИЕ: Этот параметр доступен только при выборе планирования задачи «По месяцам».
Запускать

Указание даты выполнения задачи.

ПРИМЕЧАНИЕ: Этот параметр доступен только при выборе планирования задачи «Однократно».
Запускать задачу только один раз в день

Запуск задачи один раз в день.

ПРИМЕЧАНИЕ:

Если этот параметр не выбран, задача будет выполняться при каждом запуске или входе в систему.

Этот параметр доступен только при выборе планирования задачи «При запуске», «При входе в систему» или «При дозвоне».

Отложить задачу на

Указывается число минут, на которое следует отложить задачу. Доступные значения — от 0 до 99.

ПРИМЕЧАНИЕ:

При выборе этого параметра у пользователя будет время для входа в систему и выполнения сценариев.

Этот параметр доступен только при выборе планирования задачи «При запуске» или «При входе в систему».

При простое компьютера в течение

Выбор числа минут, в течение которых компьютер должен бездействовать до начала задачи. Доступные значения — от 0 до 999 минут.

ПРИМЕЧАНИЕ:

Если после запуска задачи пользователь возобновит работу на компьютере до момента окончания задачи, она будет выполняться до завершения.

Этот параметр доступен только при выборе планирования задачи «Во время бездействия».

Дополнительные настройки

Настройка дополнительных параметров.

ПРИМЕЧАНИЕ: Дополнительные сведения см. в разделе «Дополнительные параметры планирования».
Связанные понятия
Задачи обновления и принципы их работы
Связанные ссылки
Настройка задачи AutoUpdate


Вкладка «Задача»

Включите планирование данной задачи и укажите параметры учетной записи пользователя.

Определения параметров

Параметр | Определение
Включить (запланированная задача запускается в указанное время) | Планирование запуска задачи в определенное время. ПРИМЕЧАНИЕ: Данный параметр необходимо выбрать для планирования задачи.
Остановить задачу, если она выполняется в течение | Остановка задачи по истечении количества часов и минут, указанного пользователем. ПРИМЕЧАНИЕ: Если прервать задачу до ее завершения, в следующий раз сканирование возобновится с того места, где оно было остановлено.
Часы | Число часов, через которое задача должна остановиться.
Минуты | Число минут, через которое задача должна остановиться.
Пользователь | Выбор идентификатора пользователя, под учетной записью которого выполняется эта задача. ПРИМЕЧАНИЕ: Использование учетных данных необязательно. Если учетные данные не введены, запланированная задача будет выполняться под учетной записью «Локальная система». Дополнительные сведения см. в разделе «Права при входе в систему».
Домен | Ввод домена для указанного идентификатора пользователя.
Пароль | Ввод пароля для указанного идентификатора и домена пользователя.
Связанные понятия
Задачи обновления и принципы их работы
Связанные ссылки
Настройка задачи AutoUpdate


Вкладка ScriptScan

Определения параметров

Запретите выполнение нежелательных сценариев.

Для получения дополнительных сведений см. Принцип сканирования сценариев.

Параметр | Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
ScriptScan | Включить сканирование сценариев: сканирование сценариев JavaScript и VBScript перед их выполнением.
Исключения для процесса ScriptScan | Процесс: указание исключений ScriptScan по имени процесса. Подстановочные знаки для имен процессов не используются.
Исключения для URL-адресов ScriptScan URL-адрес: указание исключений для URL-адресов ScriptScan по URL-адресу. Примечание.
  • При указании URL-адресов подстановочные знаки не используются. Однако при исключении URL-адреса msn.com, например, все URL-адреса с данной строкой будут исключены из диапазона сканирования. Например, будут исключены следующие URL-адреса:
    • http://weather.msn.com
    • http://music.msn.com
  • В системах Windows Server 2008 исключения URL-адресов из диапазона сканирования сценариев не работают в Windows Internet Explorer, если не установлен флажок Разрешение сторонних расширений обозревателя для настройки и перезагрузки Windows Server 2008. Для получения дополнительных сведений см. https://kc.mcafee.com/corporate/index?page=content&id=KB69526.
Связанные задачи
Настройка общих параметров
Связанная информация
Сканирование объектов при доступе


Вкладка «Обнаружение, определяемое пользователем»

Определения параметров

Укажите отдельные файлы или программы, которые следует рассматривать как нежелательные.

Параметр Определение
Настройки В раскрывающемся списке выберите Рабочая станция или Сервер.
ПРИМЕЧАНИЕ: Этот параметр доступен только в ePolicy Orchestrator.
Пользовательские элементы
  • Имя файла: указание имени файла или программы, которую необходимо обнаружить.

  • Описание: указание описания, которое должно отображаться в уведомлении при обнаружении указанного файла.

ПРИМЕЧАНИЕ: Сканер не обнаруживает определенные пользователем нежелательные программы размером в ноль байт.
Связанные задачи
Настройка общих параметров
Связанная информация
Сканирование объектов при доступе